Version Control

<< Click to Display Table of Contents >>

Navigation:  Reference > Workspace, Toolbars and Dialogs > The File Menu >

Version Control

This entry in the File menu is only shown in the Professional and Server versions of Help+Manual and if access to an actively supported version control system (VCS). Help+Manual currently supports the open-source Subversion (SVN, recommended), Microsoft Team Foundation Server and the obsolete Microsoft Visual SourceSafe system.

For full details please see Using Version Control Systems.

Subversion (SVN) and Team Foundation Server (TFS) Options

Load an SVN/TFS project and open locally

Connect to the VCS server to download a local working copy of a Help+Manual project to your computer. You then work on your local copy and synchronize your work with the central copy with the Synchronize SVN/TFS tool in the Project tab.

Bind current project to SVN/TFS

Connect to the VCS server to upload the current project you have open in Help+Manual to the server.

Your local copy of the project then becomes your working copy.

Other users can then download their working copies of the project to their computers with the Load an SVN/TFS project option.

Visual SourceSafe (VSS) Options

Load VSS project and open it locally

Downloads a copy of a Help+Manual project stored in a VSS database to your local computer and links the two.

When you open your local copy it will be automatically updated with any changes made on the VSS version by other users. When you work on topics they will be automatically checked out of the VSS database and locked for other users until you save and move on to another topic.

Bind current project to VSS

Uploads a copy of the current project to your VSS database and links the database version to your local version. The current project thus becomes the local working copy for the new VSS project. Topics you work on will be checked out of the VSS database and locked for other users automatically. They are checked back in when you save and move on to another topic.

If additional users want to work on the project they must use Load VSS project to local system to download a local copy to their own computers.

See also:

Using Version Control Systems