Program Options - General

<< Click to Display Table of Contents >>

Navigation:  Reference > Program Options >

Program Options - General

These options control how Help+Manual starts up, automatic backups, automatic update checking and some other general features.

DLG_Customize_General

User interface language:

Currently either German or English are available. Automatic sets the language to your Windows language (if it is German or English), otherwise you can set the language manually.

Automatically check for updates:

Checks for the availability of a more recent version of Help+Manual. New versions are published regularly, both to provide new and improved functions and to correct issues reported by users.

Note that this only works if you are connected to the Internet. Also, if you are behind a firewall you may need to configure your firewall settings give the Help+Manual program helpman.exe permission to access the Internet.

What does checking "now and then" mean in this option? Here's what the programmer has to say about it:

It means that it checks for updates not every time you start it, but more frequently than once a month. It will check more often in the beginning and less often if it gets frustrated because it hasn't successfully detected an update for a while. That could be once a week or so. But it never checks for updates on Sundays and occasionally does on weekdays, except if the day is a holiday in Austria. It only checks for updates when it is idle and there are no other urgent tasks to process and it stops checking when it finds that you are on lunch break (it figures you will not read the message while you are away).

Note: The above is not entirely serious...

Visual effects are performance-optimized:        

Turn this on if the user interface display in the Project Explorer seems to be too slow on your system.

Show mouseover hints for buttons and objects in text:

Recommended! When this is activated little tooltip popups are displayed when you position the mouse cursor over toolbar buttons and objects in the editor. These popups contain a lot of useful information for your project. They are like an extra status bar for links, graphics etc.

Automatically back up project file every xx minutes:

Autobackup/autosave automatic backup feature. Also recommended, particularly if you are one of those authors who concentrate so much on their project that they forget to save their work regularly! This function creates a backup copy of your project file in the project directory at the specified intervals.

The backup files are saved in single-file compressed mode with the extension .hmxz~~ to make them readable Help+Manual projects just delete the ~~ characters from the file extension.

Open last help projects on start:

Automatically loads the last project(s) you had open when you start Help+Manual. If you activate this Help+Manual will also return to the last topic you were editing and re-open any topics that were open in tabs when you closed the program.

Empty Clipboard when Help+Manual closes:

Automatically clears the Windows Clipboard when you exit the program.

When filtering table of contents do not hide nodes, display them with:

Setting for the TOC filter option in Project > Manage Topics > Explore > Filter. This allows you to filter the TOC display in the Project Explorer to hide or highlight topics on the basis of their "Include in Builds" settings.

When you activate this option topics filtered out by build are displayed in a different color instead of being hidden.

Default image editor:

By default Help+Manual starts the integrated Impict graphics editing program when you click on graphic in the Help+Manual editor and then select the Image Editor tool in the Project tab. This setting allows you to change this to a different graphics editing program.

See also:

Options & Keyboard Shortcuts

The View Tab

Devices with Hi-Res Displays