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1 Welcome to Help+Manual

Turbocharge your technical writing and have fun doing it!

Help+Manual 9 is a single-source documentation authoring suite for individual technical

writers and teams. It is now the most mature and comprehensive solution of its kind avail-

able. The focus is twofold: 

· Make documentation development as efficient and enjoyable as possible for the author

(you and your team)

· Enable you to produce the best possible documentation in all relevant formats, custom-

ized to your specific needs

About this documentation

This help is designed both as a course in using Help+Manual and as an ongoing reference

while you are working with the program. You can skim it for easy reference, work through

it systematically for in-depth knowledge and refer to it for additional information

whenever you need.

Getting started – new users

· Study the Introduction  and Quick Start Tutorials  sections to familiarize yourself

with the basics of the program.

· Check out all the links in the Help tab – plenty of help is available!

· Visit the  User Forum to get help from us and other experienced Help+Manual users.

35 69

http://helpman.it-authoring.com/


What's new in Version 9?

Help+Manual 9 is the best release ever. It adds improvements and powerful new
features that will change the way you work on your documentation.
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2 What's new in Version 9?

This new version of Help+Manual includes a wide range of major improvements and new fea-

tures. Some that users have been asking for, some that will surprise you. The user interface is

more modern and attractive and works even better than before on modern, high-resolution

Windows displays. The eWriter format has new standalone viewers for both Windows and

MacOS, allowing you to create modern local software documentation for both Windows and

Apple Mac applications. Table and figure counters can now be referenced directly with links

that include their captions and numbers. 

Help+Manual upgraders should read this chapter!

If you're upgrading from an earlier version of Help+Manual you should definitely take the

time to read this chapter. It will give you direct access to all the new features and changes

that are going to make working with HM even more efficient than it was already. 

If you're new to Help+Manual 

If you're a completely new user, get started with the Quick Start Tutorials  chapter. That

will teach you the basic principles of working with the program and introduce you to the

most important tools. After that you can start referring to the Basic Working Proced-

ures  chapter to help you with your daily work. 

2.1 User Interface

Basic version supports HMXP for Help+Manual Translation Assistant

The Basic version of Help+Manual can now save uncompressed HMXP projects and activ-

ate Tidy XML for more efficient translation. This makes it compatible with our

Help+Manual Translation Assistant program. 

New Project dialog

It is now possible to create a new style repository  directly with the New Project dialog.

In the past, you had to first create a regular project and then save it as a style repository. 

69
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File Preview in Open Dialogs and mouseover hints

Most Open dialogs now show a full preview of the file being selected. This is particularly

useful for things like the new PDF Snippets  function, because it shows you the pages of

the file so that you can choose which ones you want to insert.

In addition to this, you now also get a preview of the target topic in mouseover hints for

topic links, and entries in the table of contents. This preview is displayed after a brief delay

so that it does not interfere with normal operation.

Author Comments

When you save comments  the timestamp now includes the time as well as the date..

Syntax Highlighter

The performance of the Syntax Highlighter  has been improved.

2.2 PDF and Printed Manuals

PDF Peer Review Plugin

The PDF Peer Review Plugin  now includes a context menu that allows you to update

the comments in your project with comments and annotations added to the PDF by your

colleagues.

272
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Extended chapter numbering options

In Print Manual Designer you now have much more control over how your chapter num-

bering is formatted, with a range of new options in a separate Chapter Numbering tab in

the Page Options dialog of the Topics Section.
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Extended support for transparent PNGs

Transparent PNGs can now also be used in Print Manual Designer for both PDF and prin-

ted manuals. (They were already supported for PDF in topic pages, but not in Manual

Designer).

Alternative positions for Table of Figures

The Table of Figures section in Print Manual Designer can now be exported either before

or after the Table of Contents.

2.3 Embedded PDF Files

In a major new feature, Help+Manual 9 now supports embedding of PDF files, including nat-

ive embedding in PDF output, both in your project and in your PDF templates. In the past,

this was only possible by editing the PDF with external tools after it was generated by

Help+Manual. 

See PDF Snippets  for instructions. This feature is also supported in the Print Manual

Designer  tool for editing PDF templates.

PDFs are embedded natively

When Help+Manual exports a PDF, the embedded PDF pages are inserted natively. This

means that they include all their fonts, their page layout and their portrait or landscape

page orientation.

272

805



27

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

What's new in Version 9?

Insert PDFs in your PDF templates

Print Manual Designer now allows you to insert external PDFs in any location in the tem-

plate. You can insert individual pages or the entire PDF. The page numbering of the out-

put PDF is adjusted automatically, and the function supports PDFs with both portrait and

landscape pages, or a combination. 

Insert PDFs in your project

You can insert both individual pages from PDF files and entire PDFs as snippets with the

new  PDF Snippets  function. In PDF output the pages are inserted as native PDFs, here

too with automatic adjustment of page numbers. In other output formats the PDF pages

are converted into images.

Supported PDF types

You can insert any PDF file, not just one created by Help+Manual. 

2.4 Link Tool

Figure links for images and tables

The link tool now includes a dedicated Figure Link  option for linking to figures, tables

and link captions that have been added to the list of figures. The figure is selected in the

same way as an anchor in a topic.

272
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Link to images, tables and captions with topic links

The topic link tool  can now link to images , tables  and caption objects  for fig-

ure and table counters with regular topic links, in the same way that you link to anchors.

The only requirement is that the target object must have an ID assigned to it. Then the ID

will show up in list of anchors displayed in the drop-down beside the Target: field in the

link tool.

2.5 Version Control

See Using Version Control Systems  for full details on the new VCS support in Help+Manual

9.

Integrated Git and SVN support plus an editable scripted interface for any

VCS

In the past, Help+Manual used the programming interface of version control systems

(VCS) to interface with them. This involved a huge amount of development work, which

was repeated every time the systems introduced software changes. Among other things,

this caused significant problems for Subversion (SVN) users. In addition to having to use

older versions of SVN, they also had to install additional SVN tools from another third

party provider.

The new scripted interface is user-configurable

This situation was untenable and has now been corrected. Help+Manual now uses the ed-

itable scripted interface supported by all modern version control systems. Ready-to-use

scripts for Git and Subversion are already included. In addition to this, there is a script

template called by Help+Manual that you can use to interface with any other system that

supports command line access. The scripts for Git and SVN are also fully-editable, allowing

you to configure them for your own needs.

Resulting changes

No more TOC icons

This update has resulted in a couple of unavoidable changes. First and foremost, you will

no longer have the overlay icons in the Help+Manual TOC showing the current VCS status

of each topic. This is no longer possible, because it depends on the programming inter-

face. However, the benefit is that you now have the ability to configure VCS access and

410 481 520 944
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provide integrated access to any modern VCS, not just the nominally supported Git and

SVN.

No default support for Team Foundation Server

In addition to this, we have removed standard support for Microsoft Team Foundation

Server (TFS). Microsoft TFS has always been the most problematic VCS, and it is available

in several not mutually compatible versions, so Help+Manual was only able to support a

subset of the system anyway. TFS is also on the way to becoming obsolete, and even Mi-

crosoft is switching to Git for its own version control needs. We have thus decided to no

longer support it by default. Instead, TFS users who must stay with TFS need to configure

the custom script template for their version of TFS. This can be achieved using Microsoft's

tf.exe program for the command line calls. However, if possible, we strongly recom-

mend switching to Git, which is significantly superior to TFS.

2.6 Image Styles

Many users have asked for the ability to apply borders to images globally, or to define the

same size for an entire class of images. This is now possible with the new image style intro-

duced in Help+Manual 9. 

You can now define styles for images  in the same way as for paragraphs and tables. And

just as with paragraphs and tables, changing the image style definition changes the format-

ting for all images tagged with the style. 

Image styles: Borders

You can define the border style (solid, dashed etc.), width and color. Plus the radius, which

creates rounded corners, and an offset, for a border offset from the image.

492
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Image styles: Scaling

Define the dimensions of the image, either absolutely or relative to the page width. This

ensures that all images with this style will have the same width. If you choose relative per-

centage, they will also be responsive, adjusting in relation to the width of the current win-

dow. This is essential for responsive web design for both desktop and mobile devices, and

it also ensures that your images won't break PDF and Word layouts.

2.7 Markdown Import

Markdown import for new and existing projects

Help+Manual now supports importing Markdown files, both for creating new projects and

into existing projects. See Creating an empty new project , New project with imported

data  and Importing data into existing projects  for details.

There are no special settings for Markdown import as it is by definition a very simple

format. The Markdown flavor (Daring Fireball or Common Mark) is selected automatically

on the basis of the content of the file. A set of standard styles are used to represent the

few Markdown formatting options.

2.8 Project Configuration

Configuration > Common Properties > Project Search Path

Invalid search path entries are now identified automatically and highlighted in red.

Configuration > Common Properties > Text Variables

You will now be warned that you are creating a conflicting duplicate if you try to create a

variable with the same name as one of Help+Manual's own predefined global variables,

for example TITLE or COPYRIGHT. 

2.9 DeepL Machine Translation

API Glossaries

The new API Glossaries in the DeepL machine translation tool  radically improves the

ability to define your own translations for specific words and phrases. The earlier word list

option was local on your computer and couldn't integrate with DeepL's translation on its

124
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servers. This meant that your translations weren't included in DeepL's advanced context

analysis, often resulting in less meaningful translations.

In contrast, API Glossaries are fully integrated with DeepL, so that the words you define for

your translations are included in the contextual analysis, with significantly better results.

Automatic selection of the correct Base API URL

You now no longer have to select the Base API URL for your DeepL subscription. This is

now done automatically on the basis of your free or paid DeepL Auth-Key.

Turkish language support added

The DeepL plugin now also supports Turkish in both directions, in addition to all the other

languages.

Bulk DeepL translation for entire topics and projects with Help+Manual

Translation Assistant 

The new Help+Manual Translation Assistant is a new product, but definitely worth men-

tioning here. It gives you a WYSIWYG three-pane comparison view of original, update and

translation that makes it much easier for translators to work on Help+Manual projects. It is

fully integrated with DeepL, allowing you to perform bulk translations of entire projects in

minutes. This can radically reduce your costs by doing all the hard work of the raw transla-

tion. The human translator then just needs to do basic proofreading and correction. 

Once you have done the translation, HMTA can then generate a zip package of all the files

that you want the translator or proofreader to work on. They then return the edited pack-

age to you, which HMTA imports seamlessly into your existing project.
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2.10 Publishing

Global variables support for output

You can now use user-defined and HM global variables in the output file name fields for

publishing, both in the main Publish screen and in the Publishing Task Manager for batch

output. The only restriction is that it must be a global variable defined for the entire pro-

ject, not a per-topic variable definition.
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Automatic selection of output file on "Explore output folder"

When you click on the "Open and explore output folder" option in the Publish screen after

publishing, Help+Manual now automatically selects the output file as well as opening the

correct folder. This can be useful for WebHelp, and in folders containing multiple files of

the same type.



Introduction

A brief overview of Help+Manual, what you need to know and what you can do with it.
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3 Introduction

3.1 About Help+Manual

Help+Manual is a professional help authoring and documentation tool that is as easy to use

as a normal word processor. Originally, help authoring tools were developed to make it easier

to produce interactive help files for Windows applications in the standard Microsoft help

formats. 

Help+Manual can do this and much more. In addition to publishing your projects as standard

Windows help files you can also produce websites for access on the Internet, Adobe PDF files,

printed manuals and a number of other formats . 

This is why we refer to Help+Manual as a help authoring and documentation tool – you can

use it for creating and managing documentation of all kinds: Software documentation, pro-

duction documentation, corporate information systems accessed on the Internet or your in-

tranet and much more.

Help+Manual is XML-based has full support for flexible single sourcing, team authoring and

conditional output. 

· Single sourcing: 

Publish multiple formats from the same project at any time.

· XML-based: 

Help+Manual project files are pure XML for maximum flexibility. The Basic version saves

in a compressed format with all project files packed into a single file. The Professional

and Floating license versions can also save as a directory of plain-text XML files. 

· Team authoring: 

Multiple authors can work on the same project (requires the Professional or Floating li-

cense version).

· Conditional output: 

Generate different versions from the same project.

· Reuse content:

Create libraries of reusable topics and texts and insert them in your projects in Link or

Copy mode. In Link mode the texts update everywhere where they are used when the

original files are changed. In the Professional and Floating license versions you can also

reuse topics from other projects directly. 

3.2 Why Help+Manual?

Create hyperlinks by dragging and dropping. Add graphics and multimedia elements in

seconds. Make screenshots of your application with the integrated screenshot tool and en-

hance them quickly with the screenshot editing program. Compile your project to any suppor-

1504
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ted output format with a couple of clicks. Work in collaboration with a team of authors all

editing the same project at the same time. Produce help and documentation faster and more

efficiently and have fun in the process!

Save time

Help+Manual helps you to create better documentation quicker. Despite its power

the user interface and workflow are amazingly intuitive The time required for produ-

cing the help for a medium-sized software project can be measured in days or weeks

instead of months.

Save money

Online help is a key feature of your software and is just as important for success as

an application that does not crash. Professional, attractive and well-organized docu-

mentation can significantly decrease your support costs. At the same time it will also

increase user satisfaction, generating a positive snowball effect.

Concentrate on your work

Explain your software to your users, not the help authoring tool to yourself.

Help+Manual's intuitive user interface is transparent and straightforward. All the

technical details are handled in the background by the program. What you see is

what you get and what you get is what you need.

Work in a team

With Help+Manual you and your co-authors can all work on the same project at the

same time. Just put your project on server where all team members can access it and

get to work. Help+Manual makes sure that no two team members can try to change

the same topic at the same time.

All standard help formats are supported

No matter whether you need to create  modern HTML Help CHM files , multi-

browser friendly WebHelp  and even Visual Studio Help  for internal Visual Stu-

dio .NET programming documentation (both the old HXS and the new MSHC

formats), Help+Manual is the right tool for the job. It generates all standard help

formats and it creates them all from the same single source. 

In addition to this Help+Manual also generates Adobe PDF , printed manuals ,

Apple iBooks® eBooks  using the universal ePUB format for the Apple iPad and

1506
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other devices, Windows EXE eBooks for CDs and older Windows machines and Word

DOCX  – also all from the same single source file, that you only need to edit once!

Reuse content

Create libraries of reusable topics and texts and insert them in your projects in Link

or Copy mode. In Link mode the texts update everywhere where they are used when

the original files are changed. In the Professional and Floating license versions you

can also reuse topics from other projects directly. 

Localize your documentation

Help+Manual projects can be edited and translated directly by translators working

with professional tools like SDL Trados. In addition to this, tools are included to help

translators using Help+Manual itself as their translation editor.

Supply a user manual

You can output printed manuals on paper or as a PDF file that your users can view

on screen or print themselves. Here too, Help+Manual delivers where other help au-

thoring tools just make promises – it creates ready-to-ship user manuals directly

from your help project, including powerful facilities for controlling all the elements

that need to be different in printed and electronic output. 

Forget about maintaining different versions for your online help and printed manu-

als!

Writing help can be fun

Don't believe it? Give it a try with Help+Manual...

3.3 License Management

Help+Manual licenses are still perpetual – you can use them without a time limit once you

have purchased them – but we have now added maintenance options for upgrades and true,

server-based floating licenses that can be used in any geographical location. This topic ex-

plains the few things you need to know to get the best out of this system.

License management with proxy servers

If you are behind a proxy server Help+Manual may initially experience problems contact-

ing our license server to register your licenses or check floating licenses in and out. If this

1525
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is the case you can enter the credentials for your proxy server with Edit Proxy Settings in

the View  tab. This opens a separate utility program that requires administrator permis-

sions. 

Maintenance: What it is and how to renew it

The maintenance concept is simple: All updates and upgrades, both major and minor, are

free provided your maintenance is still valid. You can check it with About Help+Manual in

the Help tab. 

Renewing your maintenance

Just click on the Extend Maintenance tool in the Help tab to purchase maintenance ex-

tension and to enter your purchased maintenance key once you receive it. If you are con-

nected to the Internet your maintenance will then be extended right away. If you are not

there is an offline option you can use. Just follow the instructions shown.

Changing licenses

If you ever need to change your license key for any reason, use the Change Serial Num-

ber tool in the Help tab.

Floating licenses: Activation and offline use

Floating server licenses can be used anywhere, not just on your local network. 

Floating license manager utility for administrators

Please note that a floating license manager utility is available for administrators. This use-

ful tool allows you to add licenses to your pool, see who is currently using a license and

release licenses for use by other users. See below for full details.

How floating licenses work

Each user installs Help+Manual on their own computer and your administrator issues you

with a floating license key that you enter using the normal registration process. If this

doesn't start automatically just use the tool in the Help tab.

A floating license is normally only active while you are using it. It is released automatically

as soon as you close the program, allowing other users to use the same key. When you

are using floating licenses in this way an Internet connection is required. However, you can

also "pin" your license to your computer for offline work, for example on a plane.

1398
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How to activate and use floating licenses

Using floating licenses normally:

1. The administrator first registers all the floating license keys on one computer. This first

step is important, because it combines all your licenses in your license pool, establish-

ing the number of available license slots. An Internet connection is required for this. 

2. You then give each user a license key, which can be any key from the pool. You can

give all users the same key, if you like, and this is actually a good idea. 

3. Each user registers Help+Manual on their computer by entering the license key. This

only needs to be done once and requires an Internet connection.

4. When a user starts Help+Manual a license slot is checked out for them and released as

soon as you close the program. This makes it possible for other users to access your

company's contingent of floating licenses. An Internet connection is required when us-

ing floating licenses like this.
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Using floating licenses offline:

If a user needs to work offline, for example on a long flight, they must "pin" their license

before you go offline. To do this start Help+Manual while you have an Internet connec-

tion and select the Pin License tool in the Help tab. The tool will then be highlighted until

you unpin the license. The license will then remain active until unpinned. The adminis-

trator can release a pinned floating license with the administration tool, which is available

on request, but only after eight days have elapsed since the license was pinned.

Using your computer as a build server

Many users like to use Help+Manual's command line publishing options  to manage ex-

tensive lists of publishing tasks as batch operations. This can be done with any Profes-

sional or Floating license but you must activate the license for this purpose. 

Command line batch activation

Before using your machine as a build server you need to activate your license for batch

use with the following command line call:

<path>HELPMAN.EXE /LIC:XXXXXXXXXXXXX

Where XXXXXXXXXXXXX is your license key. The server must have an Internet connection

when you do this. Upon successful activation, the digital license key for build server use is

saved in the Help+Manual program directory on the headless server. You only need to do

this once. After this you can run normal batch operations on the licensed computer from

anywhere in your local network.

Build server operation does not use a license slot!

Note that this build server functionality provides you access in addition to your current li-

cense. If you do this with a floating license it does not occupy a floating license slot. Even

if all your floating licenses are currently in use by users, you can still use your build server

in addition to those users. 

Floating license manager for administrators

This administration tool allows you to add floating licenses to your pool, see who is cur-

rently using your licenses and release licenses to make them available to other users un-

der certain circumstances. 
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How to get the floating license manager

The download link for this utility is included in the instructions you receive when you pur-

chase floating licenses. You can also get it from EC Software support by mailing

support@ec-software.com.

Connecting the manager to your license pool

Before using the utility you must activate at least one of your floating licenses in

Help+Manual, which you then use to activate the manager. After that you can add the

other licenses to your pool with the manager (although you can also do this in

Help+Manual). 

1. Install Help+Manual on your own computer and activate at least one of your keys on

that computer to create your license pool. 

2. Unpack the license manager from the ZIP file. There is no installation, just double-click

on it to run it. 

3. Enter an activated floating license key (from Step1) at the first screen to connect it to

your pool:

The license manager screen

The license manager shows you a list of all the license keys in your pool, who is currently

using them and the date and time they started their current session. In the case of licenses

pinned for offline use the date and time shows when the license was pinned.

mailto:support@ec-software.com
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Refresh

Hit this option to contact our license server and refresh the status display of all your li-

censes

Add a New License to Pool

This allows you to add new licenses to the pool. (This can also be done by activating the li-

cense on the same computer and copy of Help+Manual that you used to activate your

first license.)

Unbook Selected license

This option allows you to release licenses that are in use, subject to the following restric-

tions:

· A normally used floating license can only be released by the administrator after two

hours have passed since the user started Help+Manual.

· A floating license that has been pinned for offline use can only be released by the ad-

ministrator after eight days have passed since the license was pinned. However, you can

see who is using it so you can contact them to tell them to unpin it before that... 

Set a Pin Code for Your Pool (used to revoke access to licenses)

This adds an additional PIN code that your authorized users must enter the first time they

start Help+Manual after you set the PIN. You don't need this for normal operation. It is

provided for when you want to revoke access to licenses for specific users. For example,

you might make a license available to a temporary translator for a limited time. If you

want to prevent that user from continuing to use the license after the job is finished you

just enter a PIN and give the PIN code to all authorized users. All users will then be asked

to enter the PIN once the next time they start the program. Once they have entered it they

won't need to enter it again. Once you have entered a PIN you will also have a function

for changing the PIN.

PIN codes: These can be as simple or as complex as you like. Spaces and special characters

are permitted.

Make a note of the PIN you enter!

You will not be able to change or remove your PIN without the original PIN code, so

please do store it in a safe place!
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3.4 The User Interface

The main Help+Manual window

The Help+Manual window has four main components: The File Menu, the Ribbon Toolbar, the

Project Explorer and the Editor Window. 

The Help+Manual user interface

The File Menu

The File menu switches to a special interface for file-related operations like creating new

projects, publishing your projects and importing data. It includes functions like creating

new projects, publishing your projects to different formats, printing user manuals and sav-

ing your projects in different formats for different purposes.

The Quick Search Tool

This tool in the lower left of the program window provides instant access to any

Help+Manual function, tool or project. Just type the first couple of letters of the name of

what you want in the tool and then select it from the list displayed.

You can select the tool with CTRL+SPACE. If this key combination is already assigned on

your computer you can change it in View > Program Options > Shortcuts.
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The Ribbon Toolbar

Help+Manual's functions are accessed primarily through the Ribbon Toolbar (or Ribbon

for short). It is divided into tabs that group functions according to tasks. 

The Project Explorer

The Project Explorer provides access to all the components of your project, including the

table of contents, your topic files, other project files and all the settings and templates as-

sociated with your project. 

The Editor

The editor is where you do all your editing work. You will spend most of your time here

editing topics, working as you do in a normal word processor. However, this is also where

your project options and settings are displayed when you select the Configuration sec-

tions of your project in the Project Explorer.

3.4.1 Devices with Hi-Res Displays

More and more users are enjoying the benefits of modern mobile devices with ultra high-res-

olution displays like the Microsoft Surface Pro and Lenovo Yoga Pro series. Often, however,

the text and controls in application programs can look much too small on these displays.

Help+Manual has full support for these devices and will generally adjust itself automatically to

give you a good experience. In addition to this, you can manually adjust the size of the user

interface and the zoom level in the editor.

User interface size adjustment

Adjust this with the Text Size control in the View tab in the Ribbon toolbar. This will also

adjust the size of all the icons and other user interface elements.

Zoom in the editor window

You also have full zoom in the editor window. This zooms all the elements displayed cor-

rectly. You can change it in two places:

· With the Editor Zoom setting in the View tab of the Ribbon toolbar

· With the Zoom control in the status bar on the right below the main editor window

48
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3.4.2 Workspaces and Preferences

Workspaces: Save your project setups for different tasks

In Windows you can save "virtual desktops" with different configurations of programs for

different tasks. Workspaces in Help+Manual are similar. They allow you to save the "set"

of projects you are currently working on to a file so that you can then reload it in one easy

process, instead of manually re-opening all the projects. 

In addition to the open projects workspace also stores and reopens all open tabs and re-

members the last topic you were working on in each project. 

How to save and load workspaces

Save a workspace

1. With all the projects you are working on open, select Save As... in the File menu and then

the Workspaces tab. 

2. Click on Save Workspace As... and choose a location and a name for the file.

Load a workspace

1. Select Open in the File menu and then select the Workspaces tab. 

2. If the workspace you want is not listed use the Browse option to locate and load it.
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Rearranging projects in workspaces

You change the order of projects in an open workspace by dragging them with the mouse in

the Project Explorer:

Workspaces in the Quick Access Toolbar

You can optionally enable Save and Load Workspace icons in the Quick Access Toolbar at the

left hand end of the Help+Manual title bar. Use the menu tool to the right of the QAT to en-

able these tools and others.
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Save/Load Preferences

The innocent-looking Save/Load Preferences option in the View tab hides a very useful

feature. This tool saves all user preferences, license key, keyboard shortcuts, recent pro-

jects, recent workspaces, Quick Access Toolbar settings, pinned projects, syntax high-

lighter configuration and everything else that you can configure to plain text file. You can

use this to load your desktop settings on your laptop computer, for example, or for

restoring all your settings when you are upgrading to a new computer. 

3.4.3 The File Menu

The File menu switches to a special interface called "backstage view" for managing file-related

operations. These include creating new projects and selecting recent projects, importing data

from external sources, publishing your projects to any of the supported output formats and

saving projects under different names and in different locations. 

Many of these operations are quite complex and the special backstage view provides more

space than conventional dialogs. This makes it easier to provide intuitive access to all the vari-

ous functions and options needed.
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Recent Projects

Recent Projects

Click/select: Open the selected project in the current instance of

Help+Manual.

Pin icons (on right) "Pinning" a project entry moves it to the top of the list for

easy access.

RIGHT-CLICK MENU: Open in new instance:

Open the project in a new copy of Help+Manual.

Add to / Remove from pinned projects:

Moves the entry to the top of the list for easy access or re-

moves the entry from the pinned list (same as pin icon).

Remove from list:

Prune the list by removing the current entry completely.

Move Up/Down:

Arrange the list to suit your preferences

Quickly access recent

documents:

Shows the select number of recent documents from the top

of the list in the File Menu. 

1. Use the pin icons to move the projects you want to man-

age to the top of the list. 

2. Activate quick access to enter these projects in the File

Menu.

Workspaces

Lists the workspaces  you have created so that you can select them.

3.4.4 The Project Explorer

The Project Explorer is the main pane on the left of the Help+Manual window. It provides dir-

ect access to all the components of your projects, including both topics and settings. This is

where you select topics for editing, create new topics, change the structure of your project

and configure all your project's settings.
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Help+Manual Project Explorer

· Editing: Just select an item in the Project Explorer to view it for editing in the Editor. 

· Multiple projects: You can load multiple projects into the Explorer and work on them all at

the same time, for example to copy and paste between projects and to work on the com-

ponents of modular help systems.

The Welcome Section

The Welcome section of the Project Explorer displays general information, recently-

opened projects, tips for finding information in the help, live information on the latest

program updates and other details. There are links to sample projects that will help you to

learn how to use the program better, a link to the Help+Manual user forum and Facebook

page, an update checker and an option for creating new projects.
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The Welcome Screen

Tip – removing recently-opened projects from the Welcome section:

The recently-opened projects listed in the Welcome section are the same as the ones lis-

ted in the Recent Projects section  in the File Menu. Removing recently-opened projects

from there also removes them from the Welcome section.

The Table of Contents

The Table of Contents or "TOC" is used to organize the topics in your project in a hierarch-

ical structure. Every topic that has a TOC entry here will also have a corresponding entry in

the TOC of your published output. 
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You can create new topics by adding new entries

to the TOC, which automatically creates a match-

ing topic file for the TOC entry in the Project Files

> Topic Files section (see below).

You can change the structure of your project by

moving entries around in the TOC. This is quick

and very easy. You just drag TOC entries with the

mouse or manipulate them with the tools in Pro-

ject > Manage Topics.

Each topic file has its own individual settings,

which are accessed in the  tab in the editor.

The Project Files Section

Project Files:

The Project Files section is used for managing and

viewing the files in your project. It is divided into two

groups, Topic Files and Baggage Files. The Topic

Files section contains all your topic files, both those

that are included in the TOC and those that are not

(known as "invisible files" in Help+Manual 4 and

earlier).

Topic Settings in Topic Options:

Each topic file has its own individual settings, which

are accessed in the Topic Options tab to the left of

the editor window.
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Topic Files

This section lists all the topic files in your project, including topic files that do not have

entries in the TOC – for example topics containing the text for popup windows, for display

in external windows or for use as embedded topics.

Topics without TOC entries

To create a topic without a TOC entry you create it in the Topic Files section. Just click in

the Topic Files section where you want to insert the topic and create a new topic . You

can always change the position of the topic later. 

Baggage Files

You do not need to concern yourself with this section when you are just getting started

with Help+Manual. It is used for storing additional files you want to associate with your

project, such as additional graphics and script files that you want to reference in the code

of your HTML templates.

All the files included in the Baggage Files section are automatically exported to the relev-

ant output formats when you publish your project. See Using Baggage Files  for more

information.

91
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The Configuration Section 

Project configuration settings

This section contains all your project's configuration

settings . This includes your project title, copy-

right notice, your language settings for help in in-

ternational languages, special settings and editable

layout templates for your output formats, "skins"

for changing the appearance and formatting of

your entire project, user-defined variables and so

on.

Program configuration settings are in

the File Menu!

Note that the Configuration section in the Project

Explorer only contains settings for your individual

projects (each project has its own configuration set-

tings). The general configuration settings for

Help+Manual are accessed in the File Menu!

3.4.5 Toolbars

The Ribbon Toolbar is context-sensitive, automatically displaying the functions relevant to

what you are doing at the moment. Functions that cannot be used in the current context are

grayed out.

The Ribbon Toolbar

The File Menu and Quick Access Toolbar

This "Quick Access Toolbar" above the Ribbon provides direct access to the most fre-

quently used functions.

1400
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The File Menu

Selecting the File menu  switches to a special display interface for managing file-related

functions, including creating new projects, importing data, publishing your projects to dif-

ferent formats and so on.

The Quick Access Toolbar

This configurable mini toolbar above the Ribbon provides direct access to your most fre-

quently-used functions. Click on the button at the right end of the Quick Access Toolbar

to configure it.

The Ribbon Toolbar

The Ribbon Toolbar or "Ribbon" for short is organized in tabs, each of which contains

groups of tools. The Ribbon is user-configurable . 

Most of the tools are available directly in the "groups" within each tab – for example

above you can see the Clipboard, Editing, Styles and Font groups. Some groups and tools

also provide access to dialogs with additional options. 

Dialog icons and menu icons

Some groups in the Ribbon have little icons

in the bottom right corner. Clicking on

these icons displays a full dialog of options

for that function group. 
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Other controls in the ribbon have menu

icons that display a normal menu of op-

tions when you click on them. These menu

options open dialogs – for example for

editing styles 

3.4.6 The Editor

This is the large area on the right below the Ribbon. When you select items in the Project Ex-

plorer you edit their contents in the Editor. This will usually be the content of your topics but

the editor pane also displays project settings in the Configuration section of the Project Ex-

plorer.

Help+Manual Topic Editor

Editor Tabs

This is the main editor where you will spend most of your time. It shows an approximately

WYSIWYG (what you see is what you get) view of your topic pages. You can edit multiple

topics at the same time in multiple tabs.
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To load a topic into the page editor just select it in the Project Explorer, either in the

Table of Contents or in the Topic Files section. Then you can start editing as you would in

a normal text editor.

To load a topic into a new tab right-click on the topic in the Project Explorer and select

Open topic in a New Tab.

To move a tab to a new position just drag the tab left or right. You cannot move the

leftmost tab, which is the main browsing tab.

To undock a tab to an external window drag it away from the editor or double-click on

its tab. To redock an undocked tab double-click on its header bar.

You can select topics both in the Table of Contents section and the Topic Files section of

the Project Explorer. The Topic Files section lists all the topic files in your project, the Table

of Contents section only shows those topic files that have entries in the Table of Contents

(TOC).

The Topic Options tab

This tab displays the editable settings of the current topic. Among other things you can

enter index keywords for the topic here. These keywords will then be included in the index

when you publish your project. See this topic  for details on the settings here.186
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Tip: You can display Topic Options next to the editor window by selecting Show Topic Op-

tions side by side in the settings menu (gear button in the top left corner).

Apart from adding index keywords it is better not to change any of the settings displayed

here until you become more familiar with working with Help+Manual.

The XML Source tab

This tab is for experts and is only displayed in the Professional and Floating license ver-

sions of Help+Manual. It displays the XML source code of your topics and allows you to

edit it.
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If you don' t understand what you see here don't worry about it. You don't need to know

anything about XML to use Help+Manual efficiently.

Warning: Anything you enter here is automatically checked against the Help+Manual

XML schema file. Anything not compatible with the schema is silently deleted when you

return to the normal editor pane. 

For details about XML in Help+Manual see XML and XML editing .

3.4.7 The Quick Search Tool

This tool in the lower left of the program window provides instant access to any Help+Manual

function, tool or project. Just type the first couple of letters of the name of what you want in

the tool and then select it from the list displayed.

You can select the tool with CTRL+SPACE. If this key combination is already assigned on your

computer you can change it in View > Program Options > Shortcuts.
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Help+Manual Quick Search Tool

3.4.8 Options & Keyboard Shortcuts

Help+Manual is extensively customizable. Most customization options are available in the

View section in the ribbon and the Program Options settings that can be accessed both in

View and in the File menu. 

Almost all program functions can be controlled with keyboard shortcuts, which you can con-

figure in the Program Options . In addition to this you can also undock the Project Explorer

by double-clicking on it and add items to the Quick Access Toolbar by selecting the Custom-

ize button at its right-hand end.

Customizing the user interface

· Select the View tab in the Ribbon to access the options for changing Help+Manual's

appearance and behavior.

1264
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· Select the drop-down gallery on the right of the Quick Access Toolbar to customize the

Quick Access Toolbar .

Program customization options

· Select Program Options in the File menu or View > Program Options in the Ribbon to

access the  program configuration  dialog.
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· You can configure the appearance of the program, the layout and contents of the Rib-

bon Toolbar, the behavior of the editor, automatic update checking and many other

things. 
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Keyboard shortcuts and accelerators

Keyboard shortcuts:

You can assign keyboard shortcuts to most functions in Help+Manual, many functions are

already configured with keyboard shortcuts. 

· Select  Program Options in the File menu or View > Program Options in the Ribbon or

to view and edit keyboard shortcuts.



63

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Introduction

· You can also assign keyboard shortcuts to styles. Select Write > Styles > Edit Styles in

the Ribbon to access the styles editing dialog.

Accelerator keys:

The Ribbon interface has an additional accelerator keys interface which can also be used

by authors with vision handicaps.

1. Press the ALT key once briefly (you may have to press it twice if you have just clicked

on a control in the Ribbon). Small icons showing accelerator letters and codes will be

displayed on the Ribbon controls. 

Accelerator key display

2. Type the accelerator letters on the keyboard to perform the corresponding actions. If

multiple letters are displayed type them one after another. These are not key combin-

ations!

Additional accelerator keys will be displayed to access any menus in the individual Ribbon

groups. 

Undocking the Project Explorer

Undocking the Project Explorer

· Double-click on the Project Explorer title bar or drag it out of the program window to

display it as a separate window. 
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Undocking the Project Explorer

· To re-dock the Project Explorer double-click on its title bar again.

Undocking, docking and pinning Explorer panes

· Click in the title bar and drag the new Explorer pane out to the left to display it in a sep-

arate window. 

· Drag it onto one of the light blue location icons When you are dragging an Explorer pane light
blue "location icons" will appear on each side of the HM window. Drag the mouse cursor onto one of

these icons to dock the pane on that side of the window. on each side of the window. 

· Double-clicking on an Explorer pane title bar also docks and undocks. 

· You can also "pin" individual Explorer panes to the left margin by clicking on the pin

tool in the pane's title bar (see below).

Pinning the Project Explorer to the margin

· Click on the "pin" tool in the Explorer title bar to "pin" the Explorer to the left margin of

the window. The Explorer will then be hidden while you are editing and will only be dis-

played when you mouseover the Explorer title in the left margin.
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· To "unpin" just mouseover the Explorer title to display it and then click on the pin tool

in the title bar again.

See also:
Using the Project Explorer

3.5 Getting help

There are a number of different sources of help in Help+Manual. In addition to this help file

you can also access tutorials, the online user forum and EC Software support.

To get started, your main source of information should be this help file. We have designed it

to provide all the information you will need for using and learning Help+Manual.

Before contacting support, please make sure that you really can't find the information you

need here or on the  user forum. Thanks! 

Displaying the help

· The quickest way to display the help is to press F1. If context-sensitive help is available it

will be displayed automatically.

· Most dialogs have a Help button that displays relevant information.

· Select the Help tab in the Ribbon for additional help options.

Using the user forum

· The online Help+Manual user forum is a great resource that contains a huge amount of

material. Register today (it's completely free) and get support from the EC Software

team and thousands of other experienced Help+Manual users.

· The forum is located at  https://helpman.it-authoring.com/

· The forum portal page also has a list of links to other useful sites and user groups

where you can find more information about help authoring.
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Contacting EC Software support

· Direct email support is available from the EC Software team at

support@helpandmanual.com. You can send a mail to this address automatically by

clicking on the Customer Support tool in the Help tab of the Ribbon. 

Tutorials

· Check the Help tab in the Ribbon for links to a number of useful tutorials.

· You can also find a collection of tutorial projects in the Examples folder in the My Docu-

ments\My HelpAndManual Projects directory.

· A selection of tutorials for programmers showing you how to integrate your help with

your application is available here on the EC Software website:

 https://www.helpandmanual.com/support_tutorials.html

Getting a printed user manual

You can download a formatted PDF version of the entire documentation designed for

printing from our download page at:

 https://www.helpandmanual.com/downloads.html

3.6 How to buy Help+Manual

You can buy Help+Manual directly online worldwide with all major credit cards. As soon as

your transaction is completed you will be able to download and install the program and start

working right away.

Direct order link and Help+Manual homepage:

Order link:

 https://www.helpandmanual.com/order.html

List of authorized resellers worldwide:

 https://www.helpandmanual.com/partner_resellers.html

mailto:support@helpandmanual.com.
https://www.helpandmanual.com/support_tutorials.html
https://www.helpandmanual.com/downloads.html
https://www.helpandmanual.com/order.html
https://www.helpandmanual.com/partner_resellers.html
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Help+Manual homepage:

 https://www.helpandmanual.com

https://www.helpandmanual.com


Quick Start Tutorials

Quick start! Learn Help+Manual step by step, tutorials are intentionally kept brief.

Picture courtesy of pixabay or picjumbo

http://pixabay.com/
http://picjumbo.com/
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4 Quick Start Tutorials

4.1 Create Your First Project!

You can create a new Help+Manual project from scratch or import documentation from an-

other source and convert it into a new Help+Manual project. In both cases an interactive on-

screen wizard will guide you through the process.

Creating an empty new project

1. Select the File menu, then select New Project. 

2. Select the option Create an empty new project and then enter the name of your pro-

ject, the save location and other data in the form displayed.

3. If you have Help+Manual Professional you can choose between two save formats (you

can switch formats at any time with Save As... in the File menu):

· Uncompressed XML:

Saves your project as a collection of XML files. Must be saved in an empty folder.

This format is required for multi-user editing. The main project file has the extension

.hmxp. This is the preferred format for normal work when it is available. 

· Compressed single-file format:

Saves the same project files in a single compressed file with the extension .hmxz.

This is the only format supported by the Help+Manual Basic.

4. Click on Create to create your new project.

Creating a new project from imported data

1. Select the File menu and click on New Project. 

2. Select the data type you want to import in the Import existing documentation to a new

project section.

3. Follow the instructions displayed in the interactive wizard, select your save format (see

above) and then select Import to complete the operation.
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You can also import some formats directly by clicking on the File menu and selecting

Open. Then select the format type and open the file – additional instructions may be dis-

played.

See Importing data  for information on the different import formats.

4.2 Get to Know the Project Explorer

The Project Explorer is the control center for your Help+Manual projects. It displays the struc-

ture of your project with the Table of Contents (TOC), all your topic files (including those not

in the TOC), additional files associated with your project (Baggage Files) and all the configura-

tion settings saved with your project (Configuration).  

You can open multiple projects at the same time. Each project has its own full entry in the

Project Explorer. Working in the Project Explorer you can copy and paste single and multiple

topics and chapters both within your project and between different projects.

In addition to this, you can also open Help+Manual more than once and have multiple pro-

jects open in the different instances of the program. If you are working in the uncompressed

HMXP format you can also have the same project open multiple times in different instances of

the program.

4.2.1 Project Explorer Sections

When you load a project its contents and settings are accessible in three main sections in the

Project Explorer on the left: Table of Contents, Project Files and Configuration. 

The Table of Contents or "TOC" is a hierarchical tree of entries that define the structure of

your project, organizing your topics into chapters and sub-chapters. Most TOC entries have

direct links to topic files in the Project Files section. (You can also create additional TOCs

with different structures for the same project.) 

The Project Files section provides access to the actual files that make up your project. 

The Configuration section stores all the settings associated with your project.

Key Information
Topic entries in the TOC are actually links pointing to

matching topic files in the Topic Files section. The ac-

tual topics are only stored in the Topic Files section.

90
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The Table of Contents section

This is the "structure" of your topic. It consists of

TOC "entries", most  which are linked to topic

files in the Project Files section. Other TOC

entries include empty TOC nodes/("chapters

without text") without any content of their own,

and entries that link to web pages or to other

Help+Manual projects that you want to merge

into the current project.

The TOC section does not actually contain any

topic files. It is really just a structured list of titles

with links to the actual topic files, which are

stored in the Project Files/Topic Files section of

the Project Explorer.

You can create new topic files  by adding entries to the TOC. Doing this creates a TOC

entry and a topic file, and links the entry to the topic file. You can also create topic files

directly in the Topic Files section. Then the files do not have TOC entries. 

You can change the structure of your TOC by moving the entries around in the TOC tree,

either with the mouse or with the blue arrow tools in Project > Manage Topics. Doing this

just moves around the entries in the TOC – the topic files and other items to which the

TOC entries link remain unchanged.

172
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The Project Files section

This section lists all the topic files in your pro-

ject and "Baggage Files", which are additional

files associated with your project. 

The Topic Files subsection lists all your topic

files, including those that do not have entries

in the TOC. For example, these include popup

topics and topics that are only displayed when

the user clicks on a hyperlink.

The Baggage Files subsection is the place

where you store files that you want to export

together with your project when you publish it.

These can include graphics you want to use in

your own HTML templates , JavaScript files

containing functions you want to use in your

HTML-based publishing formats and so on. If

you are just getting started with Help+Manual

you don't need to worry about the Baggage

Files section at the moment.

1021
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The Configuration section

Project configuration settings

This section contains all your project's configuration

settings . This includes your project title, copy-

right notice, your language settings for help in in-

ternational languages, special settings and editable

layout templates for your output formats, "skins"

for changing the appearance and formatting of

your entire project, user-defined variables and so

on.

Program configuration settings are in

the File Menu!

Note that the Configuration section in the Project

Explorer only contains settings for your individual

projects (each project has its own configuration set-

tings). The general configuration settings for

Help+Manual are accessed in the File Menu!

4.2.2 Navigating in the Project Explorer

If you are familiar with Windows Explorer and a word processor like MS Word then you

already have the basic skills you need to find your way around the Project Explorer. It func-

tions like a combination of Windows Explorer and Word. 

1400
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Help+Manual Project Explorer

The Project Explorer displays the contents of your projects in the same way as files in the Win-

dows Explorer file manager. Selecting topic files in the Table of Contents (TOC) or Topic Files

sections displays their contents in the Editor, which works like a word procesor. 

The Project Explorer display is exactly the same for projects using both the compressed

.hmxz format and the uncompressed .hmxp format. The only difference between the two

formats is the way they are saved – both contain exactly the same files and folders. The com-

pressed format just has its folders and files inside a single file, which works like a ZIP archive.

Loading projects in the Project Explorer

Opening projects:

· To load an existing project select the File menu, click on Open. and select a project to

load (or create a new project ).69
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Loading multiple projects:

· You can load multiple projects in the Project Explorer.

· To load multiple projects at the same time, use Ctrl+Click and Shift+Click in the Open

dialog.

· Select entries in the Table of Contents section to display and edit topics.

Expanding and collapsing projects and sections
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· The  and  buttons expand and collapse projects and the main sections of each pro-

ject.

· Inside the main sections the +/- nodes expand and collapse the subsections, just as

they do in the Windows Explorer.

Editing in the Project Explorer

· To edit a topic or topic file just click on an item in the Table of Contents or Project Files

sections of the Explorer. Topic contents are displayed in the editor and can be edited

directly. Work as you would in a word processor.

· To edit your project properties just select items in the Configuration section – the dia-

logs with the settings are displayed in the editor pane.
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Dragging, copying and pasting in the Project Explorer

You can move, copy and paste topics in the Explorer. Drag with the mouse, right-click to

display editing options or use the Clipboard functions in the Project tab.

· Drag a topic between other topics to insert it before or after the other topics.

· Drag a topic onto another topic to make it a child (subtopic) of the other topic.

· Use Ctrl+C to copy, Ctrl+X to cut and Ctrl+V to paste topics in the Project Explorer.

4.2.3 Managing Topic Files

When you are working in the Project Files section, the Project Explorer functions as a file man-

ager for your topic files and the folders where they are stored. If you are working in uncom-

pressed XML format (Professional and Floating license versions only, .hmxp project file) the

files and folders are stored directly on your hard drive. In the compressed single-file .hmxz

format the files and folders are stored inside the compressed .hmxz file, which is actually a

normal ZIP archive. 

How to "filter" the TOC display by build/include options

You can use include options to "filter" the display of your topics in the TOC and Topic Files

section of the Project Explorer. This makes it possible for you to see only the topics that

will be included in a specific build, so that you can preview the results of specific build op-

tions without publishing your project.
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1. Apply build options to one or more topics. If you don't do this filtering will not have

any effect! See Conditions and Customized Output  for details. 

2. Select Explore > Filter in Project > Manage Topics and set the filter options you want

to apply. The filter settings are also available from the right-click menu in the Project

Explorer (Explore > Filter).

This works both in the TOC and in Topic Files. This only filters entire topics, it does not

filter conditional text tagged within your topics.

Important Notes:

· The current build settings of topics are shown in the Project Explorer, next to the topic

caption in the TOC. Topics and chapters set to All Builds (the default) will always be in-

cluded, of course – you cannot hide them.

· Filtered topics will be either shown in a different color or hidden completely. This de-

pends on your settings for When filtering the table of contents... in View > Program Op-

tions > General. See Program Options - General  for details on these settings.

How to view topic files and folders in the Explorer

Folders:

Select Topic Files in the Project Files section of the Project Explorer. This will initially dis-

play a list of the folders in which your topic files are stored. How many folders are dis-

played will depend on whether you have created sub-folders:

969
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Files:

Select the Topics folder or any other folder in the Topic Files section:

Tip: You can check whether a topic file has a TOC entry with the In TOC column above

the file list on the right. By default this is the last column on the right so it may not

be visible immediately. You can rearrange the columns by dragging them left and

right with the mouse.

Checking whether topic files are in the TOC

You can check whether topic files have TOC entries with the In TOC column above the file

list on the right. You can also sort and group files by this option (see below). In addition to

this you can also locate files that do not have TOC entries with the Report Tool  in the

Project tab.

How to sort and group files in the Project Explorer

You can sort and group files by several different criteria (name, modification status, modi-

fication date, build option, topic status). You can combine sorting and grouping: When the

1212
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files are grouped the sorting options are applied within each group.

Sorting the files:

Just left-click in the column header you want to sort by. Alternatively you can also right-

click in the column header and select the sort option in the context menu.

Grouping the files:

Right-click in the column header and select the group option in the context menu, or se-

lect Ungroup to return to an ungrouped list.

Creating folders for organizing topic files

You can create additional folders in the Topic Files section to organize your files to make

them easier to manage. For example, it is a good idea to keep topic files without TOC

entries in separate folders.

All folders must be sub-topics of the main Topics folder 

All folders you create must be sub-folders of the main Topics folder. You cannot create

additional top-level folders on the same level as the Topics folder.

Folders must contain at least one topic to appear in the file system

When you create a folder in Help+Manual in an uncompressed HMXP project it is only re-

gistered in the project file. It will not be created aS a physical sub-folder in your project
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folder until you add at least one topic to it. (You won't see the folder in Windows Explorer

until it contains one or more topics.)

1. Select the folder in which you want to create your new folder – either the main Topics

folder or a sub-folder that you have already created. 

2. Right-click and select Add New Folder in the context menu, or select  Add File > Add

New Folder in Project > Manage Topics.

3.  Enter the name for the new folder and select OK.

Moving, deleting and renaming topic files

Cutting and pasting is not possible with topic files in the Topic Files section because you

are actually dealing with physical files. (See Moving, cutting and pasting topics  for in-

structions on working with topic entries in the TOC.) However you can move files between

folders and delete files in the Topic Files section.

Moving topic files and folders:

To move a topic file from one folder to another just drag it to the new folder with the

mouse. You can also move folders in the same way. 

Deleting topic files:

Just select the topic file in the Explorer and press DEL or right-click and select Delete File. 

Renaming topic files:

You cannot rename topic files directly. To rename the topic file you need to edit the Topic

ID.

1. Select the topic file in the Explorer. 

2. Select the Topic Options tab on the left of the main editor window, edit the Topic ID

and save your project to update the Topic Files display. 

All references to the topic in the project will be updated automatically. However, since the

ID changes any references to the topic from other help projects or elsewhere will no

longer work. This includes links to specific topics in WebHelp from other websites, be-

cause the topic ID is also the name of the HTML topic file in WebHelp. 

You should thus be cautious about renaming topics, particularly topics that get a lot of

traffic on your website.

See also:
Moving cutting and pasting topics

357
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Using the Project Explorer

4.2.4 Tips & Tricks in the Project Explorer

You can have multiple projects open for editing at the same time in the Project Explorer. The

Explorer has a number of features that make these functions more useful. In addition to this

you can also open the main Help+Manual program multiple times and have projects open in

completely separate copies of the program. 

If you are working in the uncompressed HMXP format you can also have the same project

open in different copies of the program (Pro and Floating license versions of Help+Manual

only).

Opening topics in new tabs

You can edit multiple topics at the same time in "tabs" in the editor, which are like tabs in

a modern web browser. 

· To open a topic in a tab, right-click on the topic title in the Table of Contents pane and

select Open topic in a new tab.

70
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Changing the Explorer position

If you don't like the Project Explorer position on the left of the editor pane you can

change it. Just click in the title bar of the Explorer and drag it onto one of the four light

blue position icons displayed on the edges of the program window while you are drag-

ging. 

You can position the Project Explorer to the left, right, above or below the Editor Pane.

You can also undock the Project Explorer to an external window (see below).

Undocking the Project Explorer

You can "undock" the entire Project Explorer to display it in a separate window. For ex-

ample, if you have a dual monitor system you may want to display the Explorer in a separ-

ate monitor. 



84

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Quick Start Tutorials

Undocking the Explorer:

· Double-click on the Explorer title bar. You can then drag the new window and resize it

as you like.

OR

· Click in the Explorer title bar and drag it out of the Help+Manual window.

Redocking the Explorer:

· Double-click on the title bar of the undocked Explorer window. 

Tabbing the Explorer:

You can also display the Explorer in a tab by dragging it into the topic tabs area. 

Pinning the Project Explorer to the margin (auto-hide function)

Clicking on the "pin" tool in the Project Explorer title bar "pins" the Explorer into the left

margin of the Help+Manual window. The Explorer then collapses into the left margin,
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showing only its title in a vertical tab. This can give you more room for editing on smaller

monitors.

 

· To display the pinned Explorer just move the mouse pointer over the vertical tab in the

left margin.

· To unpin the Explorer, first display it, then click on the pin tool in its title bar. 

4.2.5 Converting old projects

Help+Manual automatically converts the project files from older versions with obsolete

formats (H+M 3 and H+M 4) when you open them. Alternatively, you can also use the stan-

dalone converter program to convert old projects manually.

Help+Manual 4 projects are generally converted 1:1 and do not require any post-processing

after conversion. Older Help+Manual 3 projects did not have the styles and other features in-

troduced in the modern versions of the program and may require some reformatting after im-

porting. 

Backward compatibility with Help+Manual 5 and 6:

The Help+Manual 5 and 6 project formats are almost identical with the current format and

require no conversion. 

You can edit projects saved with Help+Manual 9 in versions 5 and 6 but this is not recom-
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mended. Any new features will be stripped out by the older versions when you do this. If

you are working on projects in a team all team members should also be using exactly the

same version.

Converting old projects automatically

Help+Manual 5 and Help+Manual 6 projects

Just open the project normally. No conversion is required. However, newer features of the

current version of Help+Manual are not supported by earlier versions. If you use these

features and then edit and save with the older version, the features may be deleted by the

older version.

Help+Manual 3 and 4 projects

1. Select the File menu and click on Open, then select the format of the project you want

to open in the Files of Type: field (or the drop-down menu next to the File Name: field

in newer versions of Windows). 

2. Select the file you want to convert and click on Open to display the following dialog:

3. Select Convert and open to convert the old project.The new project file will be saved

in the same directory as the old project you are converting. 

This method automatically converts the old project into a single compressed file with the

extension .hmxz containing all the project components except the graphics files. If you

are using the Basic version of Help+Manual this is the only project format you can use.

Using the external converter:

If you use the external converter you can also convert old projects to the uncompressed

XML format (HMXP, Professional and Floating license versions only) and select additional

conversion options for Help+Manual 3 projects.  
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Follow the instructions above and select Start external converter. For full details see The

Project Converter .

Invisible topics from obsolete Help+Manual project formats (HM3 and
HM4)

If your old HMX or HM3 project contains "invisible topics" (topics without TOC entries)

they will be moved to a sub-folder called Topics\Invisible in the Topic Files section in the

Project Explorer. 

1234
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Automatic Converter:

When you use the automatic converter a chapter

called (Former Invisible Topics) will also be created

at the bottom of the converted project's Table of

Contents (TOC) section. 

These TOC entries are linked to the topic files of

the former invisible topics but they will still not be

included in your published output because their in-

clude options are automatically set to "None". 

You can delete the (Former Invisible

Topics) chapter by selecting it and

pressing DELETE. Before confirming,

deselect the option Also delete re-

ferred topic files to keep the actual

topic files. 

External Converter:

When you use the external converter program you can decide what you want to do with

your old invisible topics:



89

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Quick Start Tutorials

Add invisible topics to TOC creates the (Former Invisible Topics) chapter described

above. We recommend deselecting this option.

Keep organization structure creates sub-folders in the Topic Files section to match your

folder structure in your old project. You can create a maximum of 10 levels but the con-

verter will not create more levels than the original project contained.

Important: Images from old projects are not copied or moved

When you convert old projects the images they use are left in their original locations. The

images are accessed by  adding links to the old locations to the Project Search Path in the

converted project. If you want to store the images with your new project you must manu-

ally copy them to a new folder in your new project folder and then update the Project

Search Path of your new project so that it only references the new folder(s) location.

See Managing your graphics  for more details on these subjects. 

See also:
Choosing your save mode

The Project Converter

4.2.6 Opening recent projects

To open a project you have edited recently just select it in the Recent Projects list in the File

menu.

Recent Projects

Click/select: Open the selected project in the current instance of

Help+Manual.

514
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Pin icons (on right) "Pinning" a project entry moves it to the top of the list for

easy access.

RIGHT-CLICK MENU: Open in new instance:

Open the project in a new copy of Help+Manual.

Add to / Remove from pinned projects:

Moves the entry to the top of the list for easy access or re-

moves the entry from the pinned list (same as pin icon).

Remove from list:

Prune the list by removing the current entry completely.

Move Up/Down:

Arrange the list to suit your preferences

Quickly access recent

documents:

Shows the select number of recent documents from the top

of the list in the File Menu. 

1. Use the pin icons to move the projects you want to man-

age to the top of the list. 

2. Activate quick access to enter these projects in the File

Menu.

Workspaces

Lists the workspaces  you have created so that you can select them.

4.2.7 Importing data

You can import existing documentation into your Help+Manual projects from a wide variety

of different formats. When you import data you can either create a new project or import the

data into an existing project. The procedure in both cases is almost identical. 

When you import data an interactive wizard guides you through each step of the process.

However, each data format needs to be handled a little differently. You will find important in-

formation on each format further below. 

Importing data to new projects

45
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1. Select the File menu. 

2. Select New Project.

3. Select the documentation format under the Import existing documentation to a new

project heading, then follow the instructions displayed.

See Settings for importing data  for details on the import settings. 

Importing data into existing projects

1. Click anywhere in the Table of Contents section in the Project Explorer. The data will

be inserted at the end of the current Table of Contents. You can move imported

chapters and topics after importing if necessary. 

2. Select the File menu and click on Import.

3. Select the documentation format, then follow the instructions displayed in the inter-

active wizard.

See Settings for importing data  for details on individual settings that you need to con-

sider for each import format.

See also:
Settings for importing data

4.2.8 Adding topics

The New Project option creates some topics for you automatically to get you started. In your

normal daily work you will create topics yourself. Creating a topic in Help+Manual is very

much like creating a new document in a word processor – but the document is also part of a

larger project. Each topic in a project is actually an independent document, but you can man-

age all these topics as though they were a single document. 

You will normally create new topics in the Table of Contents (TOC), which automatically cre-

ates both the topic file and an entry for the topic in the TOC, where you can move it

around  as you like. And you can also add text  and other content  to it, of course.

You can also create new topics in the Project Files/Topic Files section of the Project Explorer,

but when you do this the topics will not have TOC entries – they will be "invisible". Topics cre-

ated in Topic Files can only be displayed with hyperlinks, they are used for popup topics and

for information you don't want to include in the TOC directly.

157
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How to create a new topic

You can create topics in the project's Table of Contents (TOC) and the Topic Files sections

in the Project Explorer. You will normally create topics in the TOC so that they are included

in the table of contents of your published project.

1. In the Project Explorer click in the position in the TOC where you want to insert a new

topic. 

2. Select Add Topic in the Project tab of the Ribbon. 

3. Choose where you want to insert your topic relative to the selected topic:

Insert Child inserts the new topic as a sub-topic of the selected topic, turning the par-

ent topic into a chapter (if it is not already a chapter).

4. This displays the Insert New Topic or Chapter dialog:
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Select the New Topic/Chapter option. Enter a heading (title) for the new topic. The

Topic ID is created automatically from the heading. You can edit this if you like. Leave

the HTML Template, Topic Class, Create in: and Topic Template: settings as they are.

See Add Topic/File  for detailed information on the settings in this dialog if you are

interested.

5. After entering your settings click on OK to create the new topic and insert it in the

TOC.

6. Once you have created a topic you can edit it  and move it around  in the TOC.

See also:

1298
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Creating and Editing Topics

Add Topic/File  (dialog reference)

4.2.9 Editing topics

Entering and editing text in your topics in Help+Manual is very similar to working in a word

processor. To edit a topic select the topic in the Table of Contents or Project Files section of

the Project Explorer, then click inside the editing window to start editing.

The Write tab in the Ribbon provides direct access to all the tools you need while you are edit-

ing. The only group inside this section that may be unfamiliar to word processor users is the

Insert group, which contains special tools and objects used in help authoring projects. 

Editing overview

· You can type and enter text and copy and paste from other programs just as you would

in a normal word processor.

· Double-click to select a word, triple-click to select an entire paragraph.

· Use the tools in the Font and Paragraph groups in the Write tab to format text. Select

text to apply new formatting, select a formatting option (Bold, Italic etc.) and type to

change formatting from the current cursor position. 

· The Font and Paragraph groups have additional dialog modes that you can display by

clicking on the little icons in their bottom right corners.

· Hover the mouse pointer over the tools in the Write tab of the Ribbon for descriptions.

· You can save a lot of time and work by using styles. See the Using styles  tutorial. 

Spell checking

Live spell checking:

1. Select Project > Spelling > Configure Spell Checker and select the dictionary for the

language you want to use in the Main Dictionaries section at the bottom of the dialog.

Select Download dictionaries to get additional dictionaries. 

172

1298

96



95

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Quick Start Tutorials

2. Activate the Check spelling as you type option. Misspelled words will then be under-

lined in red as you type.

Manual spell checking:

· Select the top half of the Spelling tool in the Project tab to check the current topic or

text entry field or window. If text is selected only the selected text will be checked.

· Select the bottom half of the tool for the spell-check menu.

Spell checking is supported almost everywhere in Help+Manual where you can enter text.

Just right-click to display the context menu or click on the upper half of the Spelling tool

in the Project tab to access. 

Copying and pasting

· You can copy and paste text just as you would in a normal word processor. This works

within topics, between topics and between projects. 

· You can open multiple projects and copy and paste between them, or you can open

Help+Manual a second time and copy and paste between the two windows.

· You can copy and paste formatted text from and to other programs, including Office

programs like MS Word and MS Excel.

Copying images from Word:

When you copy text with images from MS Word a dialog will be displayed prompting you

to convert the embedded image data to an external graphics file. Always do this, or right-

click on the image afterward and convert the image into an external file. Otherwise the im-

age will be embedded in your topic file and will take up too much space. 
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If you have many embedded images you may experience slow editing performance in the

single-file HMXZ format. Even if you don't, embedded images unnecessarily bloat your

topic files and should be avoided if possible. 

Editor zoom and preview mode for screen/print styles and font sizes

You can zoom the entire contents of the editor quickly with the Zoom control in the status

bar below the editor window. This control is also available in the View tab in the ribbon

toolbar.

You can also switch the editor display between the styles defined for electronic help

formats (HTML Help, WebHelp, Visual Studio Help and eWriter Help) print-style help

formats (PDF, printed manuals, Word DOCX and ePUB and Kindle Mobi eBooks). 

This will only have an effect if you have defined different settings for screen and print out-

put in your style definitions. See Multiple style sets  for more information on using dif-

ferent style sets for different output formats.

Display buttons in the status bar:

See also:
Use Styles  (Quick Start Tutorial)

Creating and Editing Topics

Text Formatting and Styles

4.2.10 Using styles

You can format all your text manually if you like but it's much more efficient to use styles.

Styles are formatting definitions that you can apply to text and paragraphs with a single click.

302
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The style definition is then linked to the formatted text and if you change the definition

everything formatted with the style is updated immediately. This works in the same way as

styles in a word processor like MS Word.

How to apply a style

To apply a style to a paragraph just click anywhere in the paragraph and select the style in

the Style Selector in the Write tab:

If you included a keyboard shortcut in the style definition  you can use the keyboard

shortcut instead of the Style Selector. 

If you select text before applying a style the style's font attributes will only be applied to

the selected text. 

Note: If the paragraph consists of formatted imported text you must select the entire

paragraph before applying a style. Formatted text has priority over styles and must be se-

lected to be changed.

How to modify a style

1. Click in a paragraph in your project formatted with a style you want to change, then

select Styles > Edit Styles in the Write tab. 

2. This displays the Edit Styles dialog. The style at the current cursor position is selected

automatically. 

288
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3. Click on the Font Settings and Paragraph Settings buttons and adjust the font and

paragraph settings. If you want you can also apply Borders and Background settings.

4.  Click on OK to close the dialog. The results are immediately visible in the editor and

will be applied to all the text in your entire project formatted with the edited style.

The same settings will also be applied to text formatted with styles based on the edited

style, for all attributes that have not been explicitly changed in the other styles. 

How to change the font and paragraph settings for your entire pro-
ject 

There are a number of predefined standard styles. The most important one is Normal,

which is the default style for all normal body text paragraphs in your project. Most other

styles are based on Normal. This means that changing the settings of Normal will auto-

matically change all text in your entire project formatted with Normal or with any style

based on Normal. 

Changing the definition of Normal changes the body text style for your entire project in a

couple of seconds. 

The same settings will also be applied to text formatted with styles based on Normal, for

all attributes that have not been explicitly changed in the other styles. 
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How to define a new style

In addition to changing the Normal style you will also want to define your own styles so

that you can apply complex formatting quickly and change it whenever you want.

1. Select Styles > Edit Styles in the Write tab to display the Edit Styles dialog: 

2. Select Add Style to define a new style, then edit its default name in the Style Name:

field. You can change style names whenever you like!

3. Select Font Settings and Paragraph Settings to edit the settings for the style. You can

also add a style for the next paragraph; then pressing ENTER in a paragraph with the

current style will automatically format the new paragraph with the "next" style.

4. If you want you can also assign a shortcut key so that you can apply the style quickly.

5. Then click on OK to close the dialog. 

Using table styles

You can define table styles in the Edit Styles dialog (see above) in the same way as you

define styles for paragraphs and text. 
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Applying a style to a table:

Click inside the table, select Properties in the Table tab and then select the style in the

Table Style: field.

Creating a table with a style:

Create a table with Table > Insert Table in the Write or Table tab and select the style in

the Table Style: field when entering the table configuration settings. Any additional set-

tings you enter in the Insert Table dialog will override the style settings for that table. 

See also:
Text Formatting and Styles

Dynamic Styles  (Reference)

4.2.11 Organizing the TOC

One of the main differences between Help+Manual and a word processor is that in a word

processor you work in a single document. In a Help+Manual project, each topic is an inde-

pendent file that is like a word processor document. However, Help+Manual manages all

these files as though they were a single document. For example, you can perform search and

replace operations globally in all your topic files.

You can move topics around in the Table of Contents (TOC) section of the Project Explorer

with the keyboard and the mouse and you can also change the "level" of topics in the TOC

tree hierarchy. 

273
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Table of Contents (TOC) Overview

Moving topics around in the TOC

· Use the arrow tools in Project > Manage Topics to move selected topics around in the

TOC:

· Drag a topic onto another topic to make it the child (sub-topic) of the target topic:
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· Drag a topic between two topics to insert it between them:

 

Using cut and paste in the TOC

You can also use normal cut and paste methods to move topics around in the TOC and to

copy and move topics between projects. There are two ways to do this:

· Open the second project in the current instance of Help+Manual. The second project

will be displayed as an additional item in the Project Explorer and you can then cut and

paste between the two projects in the Project Explorer.
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· Open Help+Manual a second time, open the second project there and then cut and

paste between the projects.

There are three different ways to cut and paste in the TOC:

· Right-click in the TOC to display Cut, Copy and Paste options.

· Use the tools in the Clipboard group in the Ribbon.

· Use Ctrl+X and Ctrl+C to cut or copy and Ctrl+V to paste.

Managing files in the Topic Files section

All the topic files in your TOC are also available in the Project Files > Topic Files section of

the Project Explorer. 

These are not second copies of your topic files, they are the same files! The TOC entries

are really just links pointing to your topic files. The TOC shows the Table of Contents struc-

ture with links to the topic files, the Topic Files section only shows you the files.

In addition to your TOC topics, the Topic Files section can also contain topic files not in-

cluded in the TOC, for example topic files for popups and topics that are only accessible

by clicking on hyperlinks.

Folder display and file display in Topic Files:

The folders in the Project Files section are just like folders in Windows Explorer. You can

delete topic files and you can shift them from one folder to another if you have created

multiple folders. However, there is no "table of contents" structure here because you are

really just looking at disk folders containing lists of files. 
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See also:
Managing Topics in the TOC

4.2.12 Inserting graphics

In addition to text you will also want to add graphics to illustrate your topics. This tutorial

shows you how to add ordinary graphic images to your topics from files and by cut and

paste. 

You can also use Help+Manual's built-in screen capture utility  to capture images of objects

on your computer screen and insert them in your topics. In addition to graphics you can also

insert video files  and OLE objects  from other programs.

See Graphics formats and file size  for details on choosing graphics formats.

Key Information
Graphics files are the only project components that are

not stored as an integral part of your project. However,

you can put your folder(s) containing your graphics

files in your project folder. This is also recommended.

Inserting a graphic from a file

1. Click in the position where you want to insert a graphic, then select Image in Write >

Insert: 

342
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2. This displays the Open Image dialog. Select the image you want to insert, then click on

Open to insert the image in your document.

Click on the preview thumbnail at the lower left for a full-size preview.

Picture ID: An optional ID for use in HTML output (ignore this for now!)

Tooltip: Displays a tooltip when the user mouseovers the image in HTML formats.

Caption: A caption displayed below the image 

Padding: Space around the image (in pixels), you can enter individual values for each

side with  

Alignment: Position of the image in relation to the text on the page

Zoom% / Autosize: Resize  the image or display in full size.503
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Zoom is proportional to document width: Make image responsive. The zoom per-

centage is then relative to the container width (document page or table cell).

3. If the image is not in your project folder you will be asked whether you want to copy it

or add the path to the image location to your project.

Where to store your images

Help+Manual allows you to use images in any location. However, it is better to store your

images in a one or more graphics folders together with your project. Otherwise it is easy

to lose track of your images. 

You can easily move all your images  to different locations later if you need to.

Inserting images with cut and paste

1. Copy the image in your graphics program, then switch to Help+Manual and select

Write > Clipboard > Paste or press Ctrl+V. You can then either embed the image

(not recommended!) or choose the Convert Embedded Image option (recommen-

ded!). Choosing Convert will display the Save Image dialog with the following options: 

· File name: Give the file a descriptive name!

· Save as type: You can save the image as a BMP, GIF, JPEG, PNG or Impict IPP im-

age. Use BMP for most purposes, Help+Manual converts and compresses BMPs

automatically when you publish your project. 

2. Then just click on Save to save the graphics file. It will be inserted in the topic at the

current cursor position. 

After inserting you can double-click on the image to display and edit the image properties

and settings.

Pasting transparent PNGs and GIFs

If a copied PNG or GIF file loses its transparency when you paste it try using the Paste

HTML option in the Help+Manual Paste tool instead. This will work with some graphics

programs:

514
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See Inserting graphics and screenshots  for more detailed instructions and an explana-

tion.

Pasting graphics from MS Word

If you paste graphics from MS Word together with text a dialog will be displayed asking

you to convert the image data to an external file. This is recommended, because embed-

ding images in your topics uses up a huge amount of memory and computer resources

(many times the uncompressed size of the image itself). 

Always select the option for converting embedded images to external files after pasting

them from Word or other programs. If you forget to do this you can always access the

conversion option by right-clicking on the embedded image after inserting it.

See also:
Using Graphics

Graphics, Videos and OLE Objects

4.2.13 Inserting tables

Tables can be used both to arrange tabular data and as a formatting tool, in the same way as

in HTML pages. However, in preparation for responsive web design we strongly recommend

that you avoid using tables for layout whenever possible, because they break responsive

design.

Help+Manual has full support for complex and nested tables. This tutorial just shows you the

basics of inserting tables – for full details see the Working with Tables  chapter.  

481
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How to insert a quick table

1. Click in the topic at the position where you want to insert the table. 

2. Select Insert > Table in the Write tab or New > Table in the Table tab.

3. Move the mouse in the grid to highlight the number of columns and rows you want to

have, then click to insert the table,

How to insert a table with settings

1. Click in the topic at the position where you want to insert the table. 

2. Select Insert > Table in the Write tab or New > Table in the Table tab, then select In-

sert Table to display the Insert Table dialog.
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3. Select the number of rows and columns and choose the color and cell border settings.

For the moment leave all the other settings as they are – you can always change them

later.

4. Click on OK to insert the table. 

 For full details of the settings see Table Properties  in the Reference section.

Manipulating tables

· Drag column borders with the mouse to change column widths. This can be tricky

and works differently from static word processor tables! See Managing Column

Widths  for more detailed instructions.

1391
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· To change the width of the entire table, right-click in the table, select Table > Prop-

erties and define the table width settings.

· Click in the table and select the Table tab to display the table tools – most of these

are self-explanatory. 

· Use the Lock Column tool in the Table tab to make column widths fixed or dynamic.

· Click in the table and select Table > Table > Properties to edit the table properties.

· Click and drag to select cells, columns and rows, then select Table Properties and ap-

ply settings in the Selected Cells tab (if you don't select anything the settings apply

to the current cell only).

Using table styles

You can define table styles in the Edit Styles  dialog in the same way as you define

styles for paragraphs and text. 

Applying a style to a table:

Click inside the table, select Properties in the Table tab and then select the style in the

Table Style: field.

Creating a table with a style:

Create a table with Table > Insert Table in the Write or Table tab and select the style in

the Table Style: field when entering the table configuration settings. Any additional set-

tings you enter in the Insert Table dialog will override the style settings for that table. 

See also:
Working with Tables

How table sizing works

4.2.14 Creating hyperlinks

The Web without hyperlinks would be unthinkable and the same applies to interactive help

and documentation. Hyperlinks between topics are what makes your help genuinely useful.

You can create links to topics and specific places in topics. In addition to this you can create

links to pages on the Web and external files, and you can also create special links that execute

scripts.

This tutorial shows you the basics of creating hyperlinks to topics and specific positions in top-

ics. For full details on working with hyperlinks see Links, Anchors, Macros, Scripts and

HTML .
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Create a hyperlink with drag and drop

This is the fastest and easiest way to create a hyperlink and it is the method that you will

probably use most frequently when working on a project.

1. Select the text you want to turn into a hyperlink in the editor. 

2. Drag the selected text to the Table of Contents (TOC) in the Project Explorer and drop

it on the topic you want to link to.

3. That's it, your hyperlink is finished. You can then edit the hyperlink by double-clicking

on it if you wish. 

Create a hyperlink manually

1. Select the text you want to use as the link. (This is optional with this method – you can

also create a link without selecting anything first.) 

2. Select Insert > Link in the Write tab or press Ctrl+L to display the Edit Hyperlink dia-

log. For the moment leave the default setting of Topic Link unchanged.
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3. Select the Topic ID of the topic you want to link to from the list below the Target:

field. 

4. Choose a style for the link from the options on the left. 

5. Click on OK to create the link. 

Create a hyperlink to an anchor

Sometimes you will want to link to a specific location in the middle of a topic instead of

just displaying the top of the topic. This is achieved with anchors , which are named

"link targets" that you can insert anywhere in a topic.

1. In the topic you want to link to, click in the position for the link target and select the

 Insert Anchor tool in Write > Insert Object. 

2. Type a name for the anchor in the Anchor ID: field and click on OK to insert the an-

chor. Don't worry about the other settings in the dialog at the moment.

3. Manually create a hyperlink (see above) to the topic containing the anchor.

4. In the Insert Hyperlink dialog select the name of the anchor you want to link to from

the drop-down list next to the Target: field. 

415
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You can also activate an anchor for an existing link by double-clicking on the link and se-

lecting the anchor from the list.

See also:
Links, Anchors, Macros, Scripts and HTML

Topic IDs, Context Numbers and Keywords

4.2.15 Publishing your project

Once you have completed a couple of topics you will want to publish your output to see what

your finished product is going to look like. You can output any of the formats  supported

by Help+Manual at any time – you don't have to decide in advance what format you are

building your project for. The only thing you may need to do before you begin is install the

necessary Microsoft help compilers for HTML Help and Visual Studio Help (VS Help is only rel-

evant for .NET program code documentation).  

How to publish your project

1. Save your project, then click on the File menu and select Publish. This displays the

Publish interface: 
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Help+Manual Publish Dialog

2. Select the format you want to publish to from the Publish Format drop-down list.

3. Check the output file name and location in the Output File: field and change them if

you want.

4. Make sure that the Display file when publishing is complete checkbox is selected, leave

all other settings as they are.

5. Click on the Publish Now button. In a few moments you will be able to admire your

finished product.

Notes on individual output formats:

MS HTML Help/CHM:

If you haven't done it already, you need to install the free Microsoft HTML Help Workshop

package so that you have the compiler that Help+Manual needs to turn your project into

a CHM help file. See "Installing the Microsoft help compilers" further below on this page

for details.

WebHelp

When you publish WebHelp  always use an empty folder because this format generates

a large number of output files. The program will suggest creating a folder called \HTML

inside your project directory, which is a good choice for quick testing.

1415
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ePUB and Kindle Mobi eBooks

Before publishing ePUB or Kindle  eBooks please check the eBook sections in Configur-

ing Your Output  and Publishing Formats . You need to install a program from

Amazon to generate Kindle Mobi eBooks. You will also need to install the free Calibre

eBook viewer reader software so that you can preview your eBooks locally on your Win-

dows computer. 

eWriter Help

This is a special format unique to Help+Manual. See the eWriter chapter  for informa-

tion before using it.

Adobe PDF

The layout of your PDF output is controlled by separate template files. See Adobe PDF

for details.

Installing the Microsoft help compilers

HTML Help compiler:

Unless you have already done so you need to download and install the free Microsoft

compiler for HTML Help CHM files  if you are planning on using this format. You can

find the correct version of this compiler on the EC Software website, here:

 https://www.helpandmanual.com/downloads_mscomp.html

Visual Studio Help compiler for .NET programmers (MS Help 2 &

MS Help 3):

You only need to publish to the Visual Studio Help formats if you are a Visual Studio .NET

programmer. These help formats are only used for documenting programming compon-

ents added to Visual Studio .NET. The compiler for VS MS Help 2 (HXS) is also only avail-

able to programmers working with Microsoft Visual Studio .NET 2008. VS MS Help 3

(MSHC) does not require a compiler.

For details on using this format see the chapter on Visual Studio Help  in the More Ad-

vanced Procedures section.

Setting the compiler paths:

After installing the compilers go to View > Program Options > Compilers and make sure

that Help+Manual knows where to find them. The HTML Help compiler executable is

called hhc.exe.
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See also:
Customize - Compilers

Testing Your Project

Configuring Your Output

Visual Studio Help

4.3 Tutorial Projects and Templates

In addition to the Quick Start Tutorials included in this help file, Help+Manual also comes with

a number of other useful tutorials and templates. All the tutorials are stored in Help+Manual

HMXZ project files that you can publish and edit yourself, so that you can experiment with the

procedures described directly. 

This chapter provides brief descriptions of the subjects covered in these tutorials and informa-

tion on where you can find them.

· An introduction to using featured images and descriptions  for title pages.

· An introduction to inserting videos and interactive online media  in your projects.

· A tutorial project explaining and demonstrating the use of multiple TOCs .

· A tutorial on how to use conditional output  

· A tutorial on how to work with modular help systems , including instructions for using

A-Links to link between modules 

· The entire source code of Help+Manual's own help

· Tutorials showing you how to create your own non-scrolling headers, navigation but-

tons with mouseover effects, print links and buttons, CSS styles for hyperlinks, CSS

styles for the TOC in WebHelp, background images in the TOC and topics and more

(HTML5 & CSS )

See also:
Quick Start Tutorials

4.3.1 Template files

In addition to the other resources listed in this chapter the \Templates folder in the

Help+Manual program directory also contains a number of other useful templates and con-

figuration files:

Location of the files:

The files are stored in the \Templates folder in the Help+Manual program directory.

Help+Manual skin files (*.hmskin) \Templates\HTML skins
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These are special template files that store the

formatting, layout and design of an entire pro-

ject for HTML-based output formats. When you

publish a project you can then select a skin file

in the Publish  dialog to apply the design of

a different project to your output.

Some sample skins are provided in \Tem-

plates\skins but if you have the Profes-

sional or Floating license version of

Help+Manual you can save any project as a

skin with Save As in the File menu. You can

then edit the skin file by opening it with

Help+Manual, just like a normal project. 

If you purchase the  Help+Manual Premium

Pack the skins from this package are also in-

stalled in this directory.

Print manual templates (*.mnl): \Templates\pdf

These standard template files can be used as a

basis for creating and editing your own print

manual templates for PDF files and printed

manuals . 

Please copy these templates to your project

folder before editing them! (In Windows Vista

you will probably not be able to save your own

versions of the templates otherwise.)

Word DOCX templates (*.docx): \templates\Word

A selection of template files for Word DOCX

output  for different formats and require-

ments. 

Standalone viewer for eWriter Help: \Templates\ebooks

This is the standalone version of the viewer that

can also be embedded in eWriter Help  help

files. 

Full-text search language files for

WebHelp in multiple languages

\Templates\WebHelp

1310
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https://www.helpandmanual.com/products_hm_pluspack.html
https://www.helpandmanual.com/products_hm_pluspack.html
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(*.zlang): These files allow you to set the interface texts

for the full-text search function in WebHelp to

a number of different languages. The language

files can be selected for your project in Config-

uration > Publishing Options> WebHelp >

Full-text Search.

XML schema and stylesheet files

(*.xsd and *.xsl):

\Templates\xml

These are the source files for the XML Schema

definition and XSL stylesheets, if generated. 

Do not make any changes to these files!

See also:
Templates in Help+Manual

Transforming your output with skins

PDF and Printed Manuals

Configuring your output for WebHelp

Configuring your output for eBooks

4.3.2 Featured images for title pages

Tutorial location and name:

Location: My Documents\My HelpAndManual Projects\Examples\Feature

Images 

(on some Windows systems My Documents is called Documents)

Quick access: Welcome section at the top of the Project Explorer

Name: Feature Images.hmxz

Subjects covered:

This tutorial shows you how to create attractive chapter title pages with images and de-

scriptions for both PDF and HTML-based output. This uses the featured image and de-

scription that you can associate with each topic in the Topic Options tab to the left of the

main editor window in Help+Manual.

This subject is also covered in detail in the separate help of the Manual Designer  pro-

gram for PDF. See this topic  for basic reference information for using featured images

in HTML templates.

See also:

1007

638

785

655

696

803

1059
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Featured Images for Title Pages

4.3.3 Video & Interactive Media

Tutorial location and name:

Location: My Documents\My HelpAndManual Projects\Examples\Interact-

ive Media

(on some Windows systems My Documents is called Documents)

Quick access: Welcome section at the top of the Project Explorer

Name: InteractiveMedia.hmxz

About the tutorial:

This tutorial shows you how to add video, online video and online interactive HTML media

to your projects. It includes a number of examples of media already inserted and full in-

structions.

See also:
Videos and Online Media

4.3.4 Multiple TOCs

Tutorial location and name:

Location: My Documents\My HelpAndManual Projects\Examples\Multiple

TOCs 

(on some Windows systems My Documents is called Documents)

Quick access: Welcome section at the top of the Project Explorer

Name: Multiple-TOCs.hmxz

Subjects covered:

This tutorial shows you how to use Help+Manual's Multiple TOC feature to create com-

pletely different versions of your project with a different TOC structure and content.

See also:
Multiple TOCs

792

548

970
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4.3.5 Conditional output tutorial

Tutorial location and name:

Location: My Documents\My HelpAndManual Projects\Examples\Condi-

tional Output 

(on some Windows systems My Documents is called Documents)

Quick access: Welcome section at the top of the Project Explorer

Name: CondOutput.hmxz

Subjects covered:

This tutorial project walks you through using the conditional output capabilities of 

Help+Manual. 

You will learn how to use build conditions to control the content included in your output.

When you have finished working through this tutorial you will be able to:

· Include and exclude topics, groups of topics and modules from your output on the
basis of output formats or your own defined build conditions.

· Include and exclude topic content (text, images etc.) on the basis of output
formats or user-defined build conditions. 

· Define your own build conditions to create multiple versions of the same project
for different purposes.

· Exclude all the topics of a chapter while including the chapter topic (this is a trick
that is not normally possible directly).

See also:
Conditions and Customized Output

4.3.6 Modular help systems tutorial

Tutorial location and name:

Location: My Documents\My HelpAndManual Projects\Examples\Modular

Help Systems 

(on some Windows systems My Documents is called Documents)

Quick access: Welcome section at the top of the Project Explorer

Names: Master.hmxz, Module_A.hmxz, Module_B.hmxz

969
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Subjects covered:

This tutorial project is an example of a simple modular help system. It guides you through

all the steps of creating and using modular help systems for a variety of different output

formats. When you have completed the tutorial you will be able to:

· Create and manage modular projects for all types of output formats.

· Add project files to your TOC as modules.

· Create genuine modular help systems for the HTML Help format. This allows you
to create different versions of your help without re-publishing, just by adding or
removing help files from your distribution.

· Create dynamic conditional hyperlinks between modules using A-Links. 

See also:
Working with Modular Help Systems

4.3.7 Non-scrolling header template

Template location and name:

Location: My Documents\My HelpAndManual Projects\Examples\HTML5

Tricks

(on some Windows systems My Documents is called Documents)

Quick access: Welcome section at the top of the Project Explorer

Name: dhtml.hmxz

About the template:

This HTML template is included in the DHTML tutorial project. It works both in HTML Help

and WebHelp. In addition to this it includes full printing support with a Print button and

generation of a printer-friendly version.

See also:
Using HTML templates

4.3.8 Help+Manual help source code

Location of the help project source code:

Location: My Documents\My HelpAndManual Pro-

jects\Examples\HelpAndManual7

(on some Windows systems My Documents is called Documents)

Quick access: Welcome section at the top of the Project Explorer

1088

1026
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Name: helpman.hmxp

About the source code:

This is the complete source code of  Help+Manual's own help as an example of a relat-

ively complex project. You are welcome to reverse-engineer the help and use its compon-

ents in any way you like but please don't use the actual text from the help in your own

projects.

4.3.9 HTML5 & CSS tutorial

Tutorial location and name:

Location: My Documents\My HelpAndManual Projects\Examples\HTML5

Tricks

(on some Windows systems My Documents is called Documents)

Quick access: Welcome section at the top of the Project Explorer

Name: HTML5-and-CSS.hmxz

Subjects covered:

This tutorial shows you how to edit the HTML templates in your project or skin to create

some more advanced formatting and effects. All the code required is included in the tu-

torial project, which you can also use as a template for your own projects. Once you have

worked through all the lessons you will be able to:

· Create non-scrolling headers A non-scrolling header stays visible while the user scrolls the
text of your topic. Help & Manual's own help uses these headers. for your HTML Help and
WebHelp output. 

· Add graphical navigation buttons to your topic headers, with and without
mouseover effects When the user positions the mouse over the button it changes and becomes
highlighted..

· Add a Print link or button to your topic headers.

· Use CSS styles to change the appearance and behavior of all the hyperlinks in
your project.

· Add customized icons to the TOC (table of contents) of your WebHelp projects.

· Add a background to the TOC in WebHelp.

· Add background images to topics and headers.

See also:
Using HTML templates 1026
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5 Basic Working Procedures

More information

Once you have learned the basics in this section see More Advanced Procedures  to

learn what else you can do with Help+Manual. 

The "How-To" topics are intentionally kept as brief as possible. The focus is on how to do

what you need to do. More detailed background information on many subjects is

provided in the Reference  section and in other areas. 

See also:
Introduction

The User Interface

Quick Start Tutorials

5.1 Creating Projects

Creating a new project with Help+Manual is generally as easy as creating a new word pro-

cessing file – you just click on the File menu, select New Project and follow the instructions. 

In addition to creating an empty new project you can also create a project with data imported

from other sources, including Word RTF files, compiled HTML Help CHM files, Microsoft Sand-

castle program code documentation projects and HTML pages. See Importing Data  for

more details.

See also:
Importing Data

Help Formats

5.1.1 Creating an empty new project

When you create a new project Help+Manual automatically generates a table of contents

(TOC) with a small set of topics that you can use as a starting-point.

How to create an empty new project

1. Select the File menu and click on New Project to display the New Project settings

page:  

848

1261

35

43

69

148

148

1504
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Select Create an empty new help project, or choose one of the options that includes a

set of styles that you can use right away. Don't select New Repository  here – that is

a special kind of project for sharing styles and other assets across multiple projects.

2. Select the project save format and specify the project save location, the project file

name, the project title and the language settings:

Save format:

We recommend using the uncompressed HMXP format for ongoing work, which re-

quires saving in an empty folder. See HMXZ or HMXP?  for details on the save

formats. 

Title, language and character set:

Enter a title for your help project and select your help project language and character

set. See International languages setup  for details on settings for other languages.

Then click on Next.

3. At the bottom of the New Project page you can see a small set of standard topics that

you can now edit and add to. You can edit, delete and add topics if you want to. Don't

worry about getting everything right now – you can change everything later very eas-

ily.

4. Click on Create on the right to create and open your new project. All the topics whose

titles you entered in the previous step will automatically be created.

Backups and project recovery!

Your work is the most valuable thing on your computer. When setting up a project, always

make sure that you will have backups of your work in the case of an emergency. Ideally,

your backups should be on a different computer, or at the very least on an external drive.

Then if something catastrophic happens to your machine, you will be able to recover your

work from the backup.

1076
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Note that if you are ever unable to save your current work, for example when you lose a

network connection, Help+Manual will automatically enable you to save a special rescue

copy containing only those topics that have been edited since the last save. 

In addition to this, your unsaved edits are also saved to an ongoing background backup. If

you experience a Windows or other system crash so that Help+Manual itself is no longer

available, you will be prompted to restore your unsaved changes from the backup the

next time you open the project.

Check out Backups and Emergencies  to learn about this and other backup options so

that you are prepared to recover your valuable project work if something ever goes badly

wrong on your computer. 

See also:
Importing Data

5.1.2 HMXZ or HMXP?

Help+Manual Help stores your projects as a collection of plain text XML files, the code of

which looks a little like HTML. You don't need to know anything at all about XML to use the

program. 

If you are using the Professional or Floating license version of Help+Manual you can save

your project in single-file compressed mode (HMXZ) or uncompressed XML mode (HMXP).

Single-file mode saves all your project files in a single compressed file with the extension

.hmxz. Uncompressed mode saves your project as a collection of files and folders with a pro-

ject file with the extension .hmxp. Uncompressed XML projects must always be saved in an

empty folder.

Key Information
The uncompressed XML format (.hmxp) is only suppor-

ted in the Professional and Floating license versions of

Help+Manual. The Basic version can only save in the

compressed single-file format (.hmxz).

Which format should I use?

If you can choose between the two formats we recommend using the uncompressed

HMXP format for your ongoing work. It has a number of benefits and is also better pro-

tected against damage that can be caused to any computer files by Windows crashes or

network errors during saving. 

The compressed HMXZ format is compact and convenient and an excellent choice for

archiving and small, quick projects.

The uncompressed format has the following benefits:

608

148
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· It consists of a folder of plain-text XML files, with a separate file for every topic and for

the other project components. Since the files are plain text, data can be recovered from

the undamaged portions of files, even individual files become damaged. And it is al-

most impossible to damage the entire project.

· It handles very large projects better, because you only need to load the topics that are

currently being edited into memory instead of the entire project.

· It supports multi-user editing , storage in version control systems  and the use of

the Project Synchronization  tool for updating translations. 

How to choose and change save mode

You can only choose and change your save mode with Help+Manual Professional. The

Basic version saves in compressed mode only.

· When creating a new project the default save mode is Single-File Compressed (HMXZ).

You can save in uncompressed XML (HMXP) by deselecting the option Project file

format is XML in a compressed ZIP archive in the Output file screen of the New Project

wizard.

· To switch to the other save format (compressed or uncompressed) click on the File

menu and select Save as...

· Always save to an empty folder when saving in Uncompressed XML mode.

Help+Manual will not allow you to save to a folder with any content but you can add

files and folders to your HMXP project folder later.

About single-file compressed mode

Help+Manual Basic only supports compressed mode. 

· One compressed .hmxz file containing all project files.

· Contains exactly the same files and folders as uncompressed XML mode. The content of

both formats is identical.

· Compact and easily portable.

· Does not support multi-user editing, saving in version control repositories, processing

with external tools or editing with external editors. 

About uncompressed XML mode

A Help+Manual Professional or Floating license is required for this mode.

1171 848

1245
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· Your project and all its topics, formatting and settings are stored in a collection of plain-

text XML files. The main project file has the extension .hmxp.

· Must be saved in an empty folder, but you can add sub-folders (for example for graph-

ics) and other files later if you want.

· Required for multi-user editing, saving in version control systems and editing with ex-

ternal editors.

· Not quite as portable as .hmxz, but data security is better because damage to a single

file cannot compromise your entire project.

5.1.3 Setting the default topic

The "default" or "home" topic is the topic that is displayed automatically when the user opens

your help without a specific topic being called when you are using the CHM or WebHelp

formats. If you don't configure this the help will open at the first topic. 

How to set the default topic

There are two ways to set the default topic: You can choose it directly in the TOC, or you

can specify it by its topic ID in the project configuration options.

Setting the default topic in the TOC

To do this just right-click on the topic in the table of contents and select Set as Default

Topic in the context menu:
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Once you have set it, the default topic is indicated by a green arrow icon (the green check

marks you see in the example are for version control status):

Setting the default topic in the configuration options:

If you are only using one TOC in your project you can also set the default topic the project

configuration options. 

In the Project Explorer on the left, navigate down to Configuration > Common Properties

> Language Settings. You can then set the default topic by selecting its ID. (If you need to

locate the ID select the topic in the TOC first and look in the Topic Options tab on the left

of the editor window.)
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Note that this setting will generally only apply for the main TOC if you have defined mul-

tiple TOCs in your project. See the section on default topics in multiple TOCs further be-

low for details on this.

Defining the default topic with a variable

If you use the default topic setting in Language Settings you can also use a user-defined

variable instead of selecting the topic ID directly. (This variable must insert a valid topic ID,

of course.) This makes it possible for you to change the default topic at publish time by

changing the definition  of the variable. 

Important: Variables can only be used for the main TOC

Since this setting is only used for the main TOC, you can also only change the default

topic with variables for the main TOC. 

Setting the default topic with multiple TOCs

If you are using multiple TOCs  in your project you can set a separate default topic for

each TOC. Then you will automatically get the correct default topic for that TOC when you

use it.

Important: The default for secondary TOCs must be set in the TOC

Default topics for secondary TOCs must be set directly in the TOC. The setting in Config-

uration > Common Properties > Language Options is only for the main TOC. 

Each TOC you define can have its own default topic:

960
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Multiple default topics: how the correct one is chosen

Help+Manual allows you to combine multiple projects in modular help systems and each

project can have multiple TOCs, each with their own default topic. This means you can

have multiple default topics defined, but your output can only ever have one default topic.

The right one to use is chosen as follows:

In modular projects only the Master defines the default topic

In modular projects only the default topic defined in the Master project is used. Any de-

fault topics set in child modules are always ignored, because child projects can be ex-

cluded.

Logic for choosing the default topic

1. If the current TOC has default topic defined it will be used.  

2. If the current TOC has no default defined, the default topic defined in the main TOC is

used.

3. If the main TOC has no default topic defined, the default topic defined in the Config-

uration > Common Properties > Language Settings. If nothing is defined there, the

first topic is used. 

4. If the Language Settings option is used, resolve any variables used there and use that

topic if the result is a valid topic ID that exists. If the topic does not exist or is not in-

cluded use the first topic in the current TOC.



132

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

5.1.4 Publishing formats

If you are familiar with other help authoring tools you may expect that you need to decide

what publishing format you are going to use when you create your project. This is not neces-

sary in Help+Manual. You can always publish your project to any of the supported formats at

any time. To change your publishing format you just need to select Publish  and choose a

different output format.

Available publishing formats

You can generate a total of eight different output formats (ten including printed manu-

als), each of which has its advantages and disadvantages for specific purposes. You can

generate multiple formats from the same project, for example HTML Help for your online

help and PDF for your printable manual.

Supported publishing formats in Help+Manual:

· HTML Help (.chm)

· WebHelp (HTML, for display in normal web browsers)

· Adobe PDF (.pdf)

· Word DOCX (.docx)

· ePUB eBooks (.epub) for Apple iOS devices and all other ePUB readers

· Amazon Mobi for Kindle eBooks (.mob)

· Windows eWriter Help (proprietary .ewriter file with a standalone eViewer or

.exe with integrated viewer)

· Visual Studio 2002-2008 Help (.hxs, for Visual Studio .NET 2002-2008 components

only)

· Visual Studio 2010 Help (.mshc, for Visual Studio 2010 .NET components only)

For details on these help formats and their individual features and uses see Help

Formats  in the Reference section.

See also:
Help Formats

5.1.5 Converting old projects

Help+Manual automatically converts the project files from older versions with obsolete

formats (H+M 3 and H+M 4) when you open them. Alternatively, you can also use the stan-

dalone converter program to convert old projects manually.

Help+Manual 4 projects are generally converted 1:1 and do not require any post-processing

after conversion. Older Help+Manual 3 projects did not have the styles and other features in-

troduced in the modern versions of the program and may require some reformatting after im-

613
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porting. 

Backward compatibility with Help+Manual 5 and 6:

The Help+Manual 5 and 6 project formats are almost identical with the current format and

require no conversion. 

You can edit projects saved with Help+Manual 9 in versions 5 and 6 but this is not recom-

mended. Any new features will be stripped out by the older versions when you do this. If

you are working on projects in a team all team members should also be using exactly the

same version.

Converting old projects automatically

Help+Manual 5 and Help+Manual 6 projects

Just open the project normally. No conversion is required. However, newer features of the

current version of Help+Manual are not supported by earlier versions. If you use these

features and then edit and save with the older version, the features may be deleted by the

older version.

Help+Manual 3 and 4 projects

1. Select the File menu and click on Open, then select the format of the project you want

to open in the Files of Type: field (or the drop-down menu next to the File Name: field

in newer versions of Windows). 

2. Select the file you want to convert and click on Open to display the following dialog:

3. Select Convert and open to convert the old project.The new project file will be saved

in the same directory as the old project you are converting. 

This method automatically converts the old project into a single compressed file with the
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extension .hmxz containing all the project components except the graphics files. If you

are using the Basic version of Help+Manual this is the only project format you can use.

Using the external converter:

If you use the external converter you can also convert old projects to the uncompressed

XML format (HMXP, Professional and Floating license versions only) and select additional

conversion options for Help+Manual 3 projects.  

Follow the instructions above and select Start external converter. For full details see The

Project Converter .

Invisible topics from obsolete Help+Manual project formats (HM3 and
HM4)

If your old HMX or HM3 project contains "invisible topics" (topics without TOC entries)

they will be moved to a sub-folder called Topics\Invisible in the Topic Files section in the

Project Explorer. 

1234
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Automatic Converter:

When you use the automatic converter a chapter

called (Former Invisible Topics) will also be created

at the bottom of the converted project's Table of

Contents (TOC) section. 

These TOC entries are linked to the topic files of

the former invisible topics but they will still not be

included in your published output because their in-

clude options are automatically set to "None". 

You can delete the (Former Invisible

Topics) chapter by selecting it and

pressing DELETE. Before confirming,

deselect the option Also delete re-

ferred topic files to keep the actual

topic files. 

External Converter:

When you use the external converter program you can decide what you want to do with

your old invisible topics:
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Add invisible topics to TOC creates the (Former Invisible Topics) chapter described

above. We recommend deselecting this option.

Keep organization structure creates sub-folders in the Topic Files section to match your

folder structure in your old project. You can create a maximum of 10 levels but the con-

verter will not create more levels than the original project contained.

Important: Images from old projects are not copied or moved

When you convert old projects the images they use are left in their original locations. The

images are accessed by  adding links to the old locations to the Project Search Path in the

converted project. If you want to store the images with your new project you must manu-

ally copy them to a new folder in your new project folder and then update the Project

Search Path of your new project so that it only references the new folder(s) location.

See Managing your graphics  for more details on these subjects. 

Post-processing for Help+Manual 3 projects

There are three areas where you may need to make adjustments after converting and im-

porting old HM3 projects:

Settings for styles:

The settings for your styles may need to be edited a little because styles in Help+Manual

3 projects did not have the same close association with text and paragraphs that they

have in Help+Manual 4 and 5. All the formatting of your text will be converted correctly

but you may find that some paragraphs are associated with the Normal style instead of a

newly-defined style matching the old formatting.

514
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Imported and converted tables:

Some of the static tables from H+M3 projects may also need a little post-editing. Tables

in Help+Manual 3 were fixed-width only and they were often split into multiple tables to

handle page break problems in PDF and printed manuals. The Project Converter has op-

tions  for dealing with both of these issues but because of the differences between the

two table formats you may need to make some manual corrections to your tables after

importing.

Custom code in HTML templates:

The HTML templates  used in Help+Manual 4 and later have changed considerably, so

it is not possible to transfer custom code from your .hm3 projects when they are impor-

ted – the risk of damaging the resulting code would be too great. 

If you have entered custom code in your templates you will need to re-enter it in the tem-

plates of your  converted Help+Manual project. 

See also:
The Project Converter

Text Formatting and Styles

Dynamic Styles

Working with Tables

5.1.6 Command line project converter

The project converter also has a command line version that you can use manually and in

batch files to convert old Help+Manual 3 and Help+Manual 4 projects. (Help+Manual 5 and 6

projects do not need conversion.)The program file is called HMXConv.exe and is stored in the

Help+Manual program directory. 

The syntax of the project converter command line module is displayed automatically if you

open a command line window at the Help+Manual program directory and enter

HMXConv.exe (the version with a graphical user interface is HMC.exe). 

1234
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1234
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Project converter (hmxconv.exe) command line syntax:

HMXConv.exe Inputfile Outputfile [switches] 

· Always enclose all paths and filenames containing spaces in quotes. 
· Wildcard characters are not supported.
· Switches can be included in any order after the output file argument. 
· Relative paths are relative to the current directory – this is either the

current directory  of the command prompt or the directory you set with
the CD command in your batch file.  

HMXConv.exe The converter application, include a path to the program if
necessary. It is stored in the Help+Manual program
directory.

Inputfile The file to be converted. Include the extension (.hmx or

.hm3) and the path if necessary. Wildcards are not

supported.

Outputfile The name of the converted project. You must include the
extension, as follows:

If you don't use the /decompress switch use the extension

.hmxz, a compressed .hmxz file will be generated. 

If you do use /decompress use the extension .hmxp and

include a path to an empty folder. 

/noinvisibles Prevents creation of a Former Invisible Topics folder in the
TOC. Your invisible topics will still be imported to the Topic
Files section in the new project.

By default the converter creates a folder called Former
Invisible Topics in the TOC to show you the  invisible topics
that have been imported from your old project. This folder's
build options are automatically set to "none" so that it is not
included in your published output. It is a convenience only
and is not really needed. 

/maxfolder-

depth=x

Sets the number of levels of invisible topics folders in the
new Topic Files section. The default value is 1, the maximum
value is 10. Set to a higher number if your old project
contains multiple levels of invisible topics that you want to
preserve. 

/log=filename Saves any console messages to the specified log file. Include
a path if you want to specify where the file is to be saved. 

/fullreport Generates a detailed conversion report. This will also be
diverted from the console to the log file if you include
the /log switch.
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Project converter (hmxconv.exe) command line syntax:

HMXConv.exe Inputfile Outputfile [switches] 

· Always enclose all paths and filenames containing spaces in quotes. 
· Wildcard characters are not supported.
· Switches can be included in any order after the output file argument. 
· Relative paths are relative to the current directory – this is either the

current directory  of the command prompt or the directory you set with
the CD command in your batch file.  

Options for Help+Manual 3 (.hm3) files 

/autosizetables Converts fixed-width tables to autosize mode. 

/autosizelastcol Makes the last column of tables dynamic so that the table
width can adjust automatically.

/jointables=toler-

ance

Merges tables that are less than tolerance pixels apart

from each other.

/convertstyles Attempts to convert Help+Manual 3 style names to dynamic
styles in the new project's stylesheet. Text that is not
associated with a clearly-defined style name will not be
converted.

5.2 Configuring Your Project

Once you have created a new project the first thing you want to do is to check through the

settings for the project in the Configuration section of the Project Explorer. There are a large

number of options that you will probably use once you are more experienced but the basic

settings are quick and intuitive. This chapter guides you through the most important ones

that you need to remember. 

5.2.1 Project Configuration

After creating your project it's a good idea go through the Configuration  section of your

project in the Project Explorer and check all your basic settings, which are initially set to de-

fault values. You can change these settings at any time, but some are easy to forget, like the

help title, window titles and copyright information and so it's a good idea to get into the habit

of doing a check whenever you start a new project.

This topic lists the basic settings in Configuration that you should always check when you cre-

ate a new project. The other sections are also important but these generally contain things

1400
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that you will edit while working on or publishing your project. For full details see the Project

Configuration  chapter. 

Backups and project recovery!

Your work is the most valuable thing on your computer. When setting up a project, always

make sure that you will have backups of your work in the case of an emergency. Ideally,

your backups should be on a different computer, or at the very least on an external drive.

Then if something catastrophic happens to your machine, you will be able to recover your

work from the backup.

Note that if you are ever unable to save your current work, for example when you lose a

network connection, Help+Manual will automatically enable you to save a special rescue

copy containing only those topics that have been edited since the last save. 

In addition to this, your unsaved edits are also saved to an ongoing background backup. If

you experience a Windows or other system crash so that Help+Manual itself is no longer

available, you will be prompted to restore your unsaved changes from the backup the

next time you open the project.

Check out Backups and Emergencies  to learn about this and other backup options so

that you are prepared to recover your valuable project work if something ever goes badly

wrong on your computer. 

Setting your help title, copyright notice and version

The first thing you want to do is to enter the title of your project, the name of the author,

your copyright notice and so on. 

· Select Title & Copyright in Configuration > Common Properties in the Project Explorer.

· Enter your details. You can insert the version numbers and other information you store

here in your project topics with variables – see here  for a list.

See Title & Copyright  in the Project Configuration chapter for details on the settings.

Setting the default topic

The default topic in your help is the topic that is automatically displayed when the help is

opened in HTML Help, WebHelp, Visual Studio Help (MS Help 2.0 and MS Help 3.0) and

eWriter Help for Windows and MacOS (this feature is not supported in Apple

iBooks®/ePUB eBooks). If you don't set a topic the help will open at the first topic con-

taining text in your TOC.

1400
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1. Select Title & Copyright  in Configuration > Common Properties. 

2. Select the topic ID of the default topic in the Default Topic: field.

Tip: You can also use a user-defined text variable  instead of entering the topic ID here

directly.

Setting your language settings

One of the most important things to check is your language settings. Help+Manual sup-

ports almost all international languages but you need to make sure that your project is

configured correctly to handle the language you are using, even if it is English or a com-

mon Western European language. 

See International languages setup  for full details!

Setting the title of your help windows

You probably want the Help Title you enter in Title & Copyright section of Project Config-

uration to be displayed in the title bar of your published help in HTML Help. This is nor-

mally done with the <%TITLE%> variable but you can also enter a different text manually

if you like. 

Important: This setting is only for HTML Help (CHM) output files. All other output formats

where the title is relevant take the title directly from the Title & Copyright section.

1. Select Help Windows in Configuration > Publishing Options > Microsoft HTML Help. 

2. Click on the name of the help window whose title you want to change. If you have not

defined any additional help windows only the standard Main help window type will be

displayed. See Using secondary windows  for more information.

3. In the General tab, check that the <%TITLE%> variable is entered in the Title bar text:

field. If it is not just type it in manually. Alternatively you can type in a title manually

but this will not be updated automatically if you change your project title.

See Help Windows  and Help Windows Settings  in the Reference section background

information.

Checking your output format settings

All the output formats you can generate with Help+Manual can be customized with a

large number of options in your Project Configuration. You will only need to check and ad-

just the settings for the formats you are actually going to use, of course.

1402
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See Configuring Your Output  and Project Configuration  chapter for details on all

the individual settings in these sections.

See also:
Project Configuration

Configuring your Output

Using help windows

Templates and Secondary Windows

5.2.2 Background colors and help viewers

If you are planning to publish your project to HTML Help (CHM) you will also want to config-

ure the appearance and features of the Microsoft help viewer used to display this format.

These settings are stored in what is known as a "help window definition".

You can also define background colors for your topic pages and topic headers. These colors

are defined in the HTML page templates for HTML-based publishing formats. You cannot

define topic and header background colors for PDF, Word DOCX or printed manuals. 

The settings in Help window definitions are only relevant for the Microsoft HTML Help format.

For details see Help Windows  and Help Windows Settings  in the Reference section and

Choosing a help window  in the Creating Topic Files section.

Background colors of topics and headers

Background colors can only be set for the topics and headers in electronic HTML-based

help formats, with the exception of Apple ©iBooks/ePUB, for which the background color

is always white. The background colors are ignored in PDF, DOCX and printed manuals.

Background colors for HTML Help, WebHelp, eWriter Help and

Visual Studio Help

In all these formats the background colors for the topic and header are set in the HTML

Page Template settings. 

If you are using a skin to publish your output you must edit these settings in the .hm-

skin file. When you use a skin, the templates in the skin replace those in your project.

You will need to make a copy of the skin in your project folder to edit the skin.

· In the Project Explorer, go to Configuration > HTML Page Templates > Default and set

the colors for the header and topic.

You can apply different background colors to different topics by creating additional HTML

page template definitions  and choosing different templates for individual topics in the

Topic Options tab accessible on the left the main editor window. 
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How to edit the Microsoft HTML Help CHM file viewer features

You can adjust the features of the Microsoft help viewer for HTML Help CHM files by edit-

ing the settings of the Main help window in Configuration > Microsoft HTML Help >

Help Windows. 

1. In the Project Explorer go to Configuration > Microsoft HTML Help > Help Windows

and select the Main help window in the drop-down list at the top of the dialog win-

dow. 

2. Set the size and position of the help window in the General Options tab. In HTML Help

this setting will only be used the first time the user opens the help. After this Windows

will apply the last size and position used by the user. 

3. The title bar text is displayed in the title bar of the help viewer. The standard setting <

%TITLE%> displays the title of your help project from your Title and Copyright set-

tings.

4. Select the HTML Help Options tab and define the help viewer settings. 

HTML Help CHM Viewer window size and position

Note that if you want to control the size and position of the help viewer window in HTML

Help you must change two settings:

1. Set the window size and position in the Color and Position section. 

2. Deselect the option Save user-defined positions after first use in the HTML Help Op-

tions section. 

If you don't do this your window settings will be ignored and Windows will save and use

the last window size and position set manually by the user. Note that most users prefer

the help window to remember their own settings. They dislike it when a program sets its

own window size and position for the help!

See also:
Using help windows

Help Windows

Help Windows Settings

Templates and Secondary Windows

5.2.3 International languages setup

Help+Manual is fully Unicode-enabled and can edit and publish help files in virtually all inter-

national languages. There are just some restrictions on right-to left languages, which are only

supported in HTML Help CHM files and WebHelp (for example languages like Hebrew, Arabic

and Farsi). 
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Working in Unicode languages requires both configuration settings for the language you are

using in your project and special Windows settings for the Microsoft help compilers, which are

not Unicode programs.

Even if you are working in English or any other Western European language it is still important

to check that the language settings of your project are correct before starting work. 

For more information see International Languages and Unicode   and Language Settings

in the Reference section.

Where to find the language settings

· Go to Configuration > Common Properties > Language Settings in the Project Ex-

plorer to view and edit the language settings for your project.

· See Language Settings  in the Project Configuration section of the help for details.

English and Western European languages

Windows version and configuration:

Projects in English and Western European languages can be published and viewed on all

versions of Windows without restrictions. The language of the help file does not have to

match the language of the Windows version on which the file is being viewed.

Configuration > Common Properties > Language Settings:

Language of the

help file:

The default setting is English (United States). This should not be

changed for English and Western European languages unless you

experience problems with sorting in the Keyword Index. 

Because of a bug in the Microsoft HTML Help viewer it is best to

set English (United States) for all Western European languages if

possible – otherwise "HTML Help" will be displayed in the title bar

of the help if the language setting does not match the language

of the user's Windows version.

Font character set: The default setting is ANSI_CHARSET. This should not be changed

for English and Western European languages. 

Default font: This option only defines the font used in the TOC and dialog

boxes in HTML Help CHM files.

1627 1403
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Note that HTML Help is designed to work with the default font

and font size settings so please test thoroughly if you use differ-

ent fonts or sizes. 

The default is MS Sans Serif,8,0. The value 8 defines the font

size and should generally not be changed. The last value defines

the character set and 0 tells Help+Manual to set the character set

automatically.

Eastern European languages, Greek, Russian, Turkish etc.

Windows version and configuration:

Publishing projects:

You can publish projects written in these languages to WebHelp, MS Word DOCX, PDF,

eBooks and Visual Studio Help (MS Help 2.0/3.0) with any version of Windows XP or later

with support installed for the language you are using.

Publishing projects to CHM:

To publish projects in these languages to HTML Help / CHM you must also set the "sys-

tem locale" of your Windows configuration to match the language of your project. See

Publishing instructions by format  and CHM in Non-Latin Languages  for more details

on this and a method for publishing to multiple CHM languages without having to restart

Windows.

Changing the system locale for CHM publishing

Note that the system locale and the user locale are different! Simply setting the display

and/or data entry language does not change the system locale!

1. Log in to a user account with administrator permissions. 

2. In current Windows versions (7 and 10) go to Settings > Time & Language > Region >

Additional date, time & regional settings. Then select Region in the new dialog that

opens and you will find the locale setting in the Administrative tab. Alternatively, you

can open the Control Panel directly and select the Region option.

3. Click on OK to apply the setting and then restart Windows.

Viewing published help:

Help+Manual's output files can be viewed on most versions of Windows on which proper

support for the specific languages is installed. Some features of HTML Help (full-text

search, Keyword Index sorting) will only work properly if the language of the Windows

623 629
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version matches the language of the help file. This applies particularly for Asian languages.

For example, all functions of a Chinese HTML Help file will only work correctly on a

Chinese version of Windows.

See About H+M's Unicode support  for more details on this.

Configuration > Common Properties > Language Settings:

Language of the

help file:

This setting must be set to the language in which your help is

written. This is important both for proper sorting in the Keyword

Index and proper identification of the language by the system.

Font character set: This setting must be set to the correct character set to display the

language used in your help file.

Default font: This is not the default font of your help project! This option only

defines the font used in the TOC and dialog boxes by HTML Help

CHM files. 

Note that HTML Help/CHM is designed to work with the default

font and font size settings so please test thoroughly if you use

different fonts or sizes. You may need to change the font to dis-

play all characters correctly in your language. 

The default is MS Sans Serif,8,0. The value 8 defines the

font size and should generally not be changed unless you are us-

ing a language with a special character set, like Asian languages,

Greek, Russian etc. The last value defines the character set and 0

tells Help+Manual to set the character set automatically.

Asian languages, all languages requiring Unicode

This group includes all languages that require Unicode, which means languages with more

than 255 characters requiring two bytes to store each character. For example, this includes

most Asian languages like Chinese, Japanese and Thai.

Windows version and configuration:

Editing projects:

Help+Manual projects written in Unicode-based languages can be edited on Windows XP

or later provided that support is installed for the language you are using.

Publishing projects:

1629
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· You can publish Unicode projects to WebHelp, MS Word DOCX, eBooks and Visual Stu-

dio Help (MS Help 2.0/3.0) with any version of Windows XP or later with support in-

stalled for the language you are using.

· To publish Unicode projects to HTML Help (CHM) you must also set the "system locale"

of your Windows configuration to match the language of your project.

Changing the system locale for CHM publishing

Note that the system locale and the user locale are different! Simply setting the display

and/or data entry language does not change the system locale!

1. Log in to a user account with administrator privileges. 

2. Open the Regional and Languages section in the Windows Control Panel.

· Windows XP: Select your language as the default language for non-Unicode pro-

grams in the Advanced tab (this tab is only displayed if you have administrator rights).

· Windows Vista and later: Select the Change System Locale button in the Adminis-

trative tab (this tab is only displayed if you have administrator rights.

3. Click on OK to apply the setting and then restart Windows.

Viewing published help:

Help+Manual's output files can be viewed on most versions of Windows on which proper

support for the specific languages is installed. Some features of HTML Help (full-text

search, Keyword Index sorting) will only work properly if the language of the Windows

version matches the language of the help file. This applies particularly for Asian languages.

For example, all functions of a Chinese HTML Help file will only work correctly on a

Chinese version of Windows.

See About H+M's Unicode support  for more details on this.

Configuration > Common Properties > Language Settings:

Language of the

help file:

This setting must be set to the language in which your help is writ-

ten. This is important both for proper sorting in the Keyword In-

dex and proper identification of the language by the system. 

Font character set: This setting must be set to the correct character set to display the

language used in your help file. This too is particularly important

for proper handling of Unicode-based languages. You must have

the proper character set for your language installed for

Help+Manual to be able to process and publish the language cor-

rectly.

1629
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Default font: This is not the default font of your help project! This option only

defines the font used in the TOC and dialog boxes in HTML Help

CHM files. 

The default is MS Sans Serif,8,0, which is the font and size

that HTML Help is designed for. In Asian languages and other

Unicode-based languages you may need to choose an appropri-

ate font for your language instead of MS Sans Serif. 

The value 8 defines the font size and should generally not be

changed. The value 0 defines the character set. You do not need

to change the character set value – Help+Manual does this for

you automatically when you publish your project.

Test-publishing Asian languages on non-Asian Windows

Normally, you cannot publish help projects written Asian languages on non-Asian versions

of Windows because the necessary language settings don't match. However, if you just

want to do a quick test publish and don't have a Windows version in the matching Asian

language there is a configuration setting that will allow you to do this.

· Go to View > Program Options > Compilers and activate the option Tolerant handling

of Asian languages. 

Some features may not work correctly in the resulting help file in HTML Help if the lan-

guages of your Windows version and the help file don't match (Search, Keyword Index)

but you will be able to complete the compilation and view the CHM file, which is sufficient

for testing.

To produce a finished CHM for distribution you must publish it on a copy of Windows

with a matching system locale. 

See also:
International Languages and Unicode  (Reference)

Language Settings  (Project Configuration)

5.3 Importing Data

There are a number of different ways to import data from other formats into Help+Manual.

You can "convert" the data you are importing into a new project, merge it into an existing pro-

ject or import individual documents into individual Help+Manual topics. You can also copy

and paste data directly into your topics from Office programs and other applications. 
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In addition to this you can also import data from other Help+Manual projects in a number of

different ways: You can copy and paste data and topics, "embed" topics from other projects in

your current project or import topics and projects.

5.3.1 New project with imported data

If you have existing documentation in other formats you can import it to Help+Manual and

create a new project in one easy process. Interactive instructions guide you through each step

of the process of importing the data. 

Check your settings for importing from other formats

Before importing from any of these formats please check the Settings for importing

data :

· MS CHM files and HTML files (check structure for optimum import)

· AuthorIT projects (you need to publish your book to XML first)

· MS Word files (save as RTF in Word first)

· MS WinHelp (use the .HPJ project if possible)

· Adobe RoboHelp for HTML (check structure and formatting)

· Adobe FrameMaker (save to RTF first )

· MS Sandcastle (see Importing Sandcastle projects  and Source Code Documenta-

tion )

Importing data to new projects

1. Select the File menu and click on New Project. 

2. Select the format you want to import from in the Import existing documentation to a

new project section in the lower part of the page
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3. Select the source files, then enter the name, save location, format and other settings

for the new project in the same way as for an empty new project .

4. If there are additional options click on Continue with Options and set the options.

Then click on Import to finish.

See Settings for importing data  for details on the optimum settings for each data

format.

General settings for all formats

See Settings for importing data  for full details. The following settings are the same for

all formats:

· Output file:

Name and location of the new project.

· Project file format:

Save in a single-file compressed format (.hmxz) or uncompressed XML (with .hmxp

project file, Professional and Floating license versions only). See HMXZ or HMXP?  to

help you decide which format to use.

· Project title:

The title of your project. This can be changed later.

· Project language and character set:

You can also change these settings later. See International languages setup  for de-

tails. 

See also:
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Settings for importing data

5.3.2 Importing Sandcastle projects

Sandcastle is a free Microsoft tool that automatically generates documentation from program

source assemblies and XML comment files for Microsoft Visual Studio .NET development pro-

jects. The latest version of Sandcastle 2.7.2 from Microsoft is included with Help+Manual,

making it possible to generate source code documentation from your .NET projects directly. 

See the Source Code Documentation with Sandcastle  chapter for full instructions on using

Sandcastle for documenting your .NET source code.

Help+Manual cannot be used with Sandcastle Help File Builder

Please note that you cannot use the independent Sandcastle Help File Builder system or

its configuration. Help+Manual actually performs similar tasks to Help File Builder, so it re-

places its role in interaction with Sandcastle.

Installing Sandcastle with Help+Manual

Help+Manual's installation includes the latest version of Microsoft Sandcastle. You can

use your own Sandcastle installation if you wish, provided it is version 2.4 or later.

However, if you wish to do this you must not select the Sandcastle option when installing

the program. Help+Manual will always use its own version automatically, and it will then

ignore any other installed version. (Help+Manual's version will not interfere with your own

installation, if it exists.)

We strongly recommend using the bundled version of Sandcastle included with

Help+Manual. It is the latest official Microsoft version and Help+Manual is optimized for

it. 

For more information about Sandcastle see Microsoft's Sandcastle page:
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 http://msdn.microsoft.com/en-us/vstudio/bb608422.aspx 

Preparing your .NET project and comments for import to
Help+Manual with Sandcastlel

1. Document your source code using triple slash comments and Sandcastle XML tags. 

2. Activate the XML documentation file option for your project in Visual Studio in the

Project Properties > Build section. Alternatively you can also compile manually with

the documentation switch /doc:comments.xml.

3. Build your .NET project or assemblies to the release version, or the version where the

XML documentation file you have configured is exported.

See Configuring Your .NET Project  for detailed instructions explaining how to set up

your .NET project and write your comments there.

Importing a Sandcastle project to a new project

1. Select New Project in the File menu. 

2. Select Sandcastle documentation file in the Import existing documentation section in

the lower half of the page. 

3. Enter the name and path for your new Help+Manual project and configure the other

settings as you would for an empty new project .

4. Click on Continue with Options and select your assemblies, comment files and any de-

pendent assemblies. The comments file is the XML documentation file  you config-

ure in your .NET project. You can choose multiple files in each category. You can also

set a topic status to be set for your imported topics.
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5. Click on Import. Help+Manual will then run Sandcastle in the background, generate

the project and import it to a Help+Manual project. Depending on the size of your

programming project this may take a while. The time this takes depends on Sandcastle

and the speed of your computer, not on Help+Manual. 
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6. When the process is finished your Sandcastle project will appear in Help+Manual for

editing. You can then edit and publish it just like any normal Help+Manual project:
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Updating existing HM projects from your source code

You can also update your source code documentation to the Help+Manual project you

created from an earlier version.

Open the Help+Manual project and select Import in the File menu instead of New Project.

All the other steps are the same as described above. New topics chapters will be added to

the end of the existing TOC. Updates to existing topics and chapters will be handled de-

pending on the conflict management settings you configure for "changed topics". If you

opt to overwrite the existing topics the earlier versions will be replaced.

5.3.3 Importing data into existing projects

In addition to creating new projects with imported data you can also import documentation

from other formats into existing Help+Manual projects. 

See Settings for importing data  for details on configuring your import settings correctly for

importing different types of data.

Productivity Tip
Also see the powerful Snippets  function with which

you can reuse topics and topic content saved in ex-

ternal files.

Importing external data into existing projects

1. Select the Table of Contents section in the Project Explorer and click on any topic. The

imported data will be inserted at the end of the TOC. You can move the imported top-

ics later. 

2. Select Import in the File menu.

3. Select the format you want to import, then follow the instructions displayed.
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See Settings for importing data  for details on settings for individual formats.

Importing external data into individual topics

You can also import external data directly into individual topics. Note that you should al-

ways create a new topic to do this because importing the data overwrites the current

topic. The exception to this is when you use Drag & Drop to insert the contents of an RTF

file into the current topic (see further below in this topic.)

1. Create a new empty topic or select a topic that you want to overwrite. 

2. Select File > Load Topic from File in Project > Manage Topics and select the file you

want to load. You can import HTML, RTF, RVF, TXT files and Help+Manual XML topic

files. 

If you have the Professional or Floating license version of Help+Manual you can load top-

ics from other projects directly provided the projects are saved in uncompressed XML

format. Then you just select them in the /Topics folder of the other project.

For full details on this function see Exporting and importing topics  in the Creating and

Editing Topics section. 

Copying and pasting topics between projects

You can also cut, copy and paste topics directly between projects in the Project Explorer.

Just open both projects in the Explorer and then use the Clipboard functions in the Rib-

bon to cut, copy and paste entire topics and chapters between the Table of Contents sec-

tions of the projects. See Moving, cutting and pasting topics  for full details.

Inserting RTF file content with Drag & Drop

If you drag an RTF file into the Help+Manual editor window the contents of the file will be

inserted directly at the drop position as formatted text. 

This currently only works with RTF files and image files, which are inserted directly as im-

ages. All other file types are inserted as file links when you drop them.

See also:
Re-using content with snippets

Moving, cutting and pasting topics
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5.3.4 Settings for importing data

Generally the interactive screens displayed when you select Import in the File menu provide

most of the information you need. However, the additional tips below will help you to choose

the settings that will produce the best results with the individual import formats.

HTML files and compiled HTML Help files (.chm)

The importer needs to know how to deal with the different parts of HTML topic pages.

You can improve the import performance with the import options settings.

Converting imported HTML formatting to styles

Provided style classes were used in the original HTML you can globally strip out inline

formatting imported from HTML and convert it to style references with the powerful Tool-

box utility included in the Premium Pack style pack. 

Tip: You can view the HTML source code of topic pages in CHM files by right-clicking in

the topic in the Windows CHM viewer and selecting Display Source. This can be use-

ful for identifying the tags and blocks of code you need to filter with these options. 

Topic header:

Getting the header information from the <title> tag will usually work. If your topics

have a separate header block you may need to specify a different tag. If in doubt display

the CHM file, right-click on one of its pages and examine the source code with View

Source.

Topic body:

Specify a <table> or <div> tag with a specific ID only if you know that is used to

identify your body content. Otherwise use the default setting.

Ignore internal folders:

Help+Manual does not use internal folders in CHM files, all files are stored on the same

level. If the CHM file contains internal folders the folder names will normally be prefixed to

the topic IDs of the imported topics to prevent name conflicts. You can turn this option off

https://www.helpandmanual.com/products_hm_pluspack.html
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if you are sure that there are no name conflicts caused by files with the same names

stored in different folders.

Single-column tables:

Some topic pages are enclosed in single-cell/single-column tables, which can cause un-

desirable results when you import them. You can solve this problem with the option for

converting such tables to single paragraphs.

Import tags and labeled elements as anchors:

If you you know the HTML files you are importing contain tags and labeled elements with

name= attributes that you want to use as anchors you can make sure that they are con-

verted to anchors (jump targets) with this setting.

Import invisible block elements (and make them visible):

Normally block elements hidden with the display=none attribute are considered to be

not part of a page. This setting enables you to import these elements and switches them

to visible. (Invisible block elements are not directly supported in Help+Manual). 

Ignore HTML styles and use default styles (except margins, bold, italic, underline):

Use this option if you want to import your CHM or HTML files with a "clean slate" for

styles and formatting. It will strip out all styles (both CSS and inline styles) and only keep

margins, bold, italics and underline. This can be particularly useful for source material that

has accumulated a lot of manual formatting over time.

Overwrite existing topics:

This is only displayed when you are importing into an existing Help+Manual project. If you

select it, it will overwrite any existing topics in your project with imported topics that have

the same IDs. Use with caution!

Popup topics file:

In CHM help popup topics are stored in a special plain-text file inside the CHM. Normally

this has a standard name (CSHelp.txt) but if you know that the file you are importing

uses a different name you can select or enter it here.

Integrating imported inline formatting from HTML and CHM

Help+Manual automatically imports and integrates the styles from Word RTF files, but

formatted text from HTML must be imported as "manual formatting". This is necessary be-

cause HTML formatting cannot be automatically converted cleanly into "text" and "para-

graph" styles. Normally, if you want to use styles on imported formatted text you must

first create Help+Manual styles on the basis of the imported formatting and then apply

the styles to your text.
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Converting imported HTML formatting to styles globally with

Premium Pack Toolbox

Provided style classes were used in the original HTML you can globally strip out inline

formatting imported from HTML and convert it to style references with the powerful Tool-

box utility included in the Premium Pack add-on for Help+Manual. If you have or are con-

sidering buying the Premium Pack, see Integrating imported formatting globally  for

details on this. 

Otherwise see the Replacing Formatting and Styles  chapter for instructions.

Markdown files

There are no special settings for importing Markdown files, as the Markdown format is by

definition extremely simple. The Markdown flavor (Daring Fireball or Common Mark) is se-

lected automatically on the basis of the content of the file.

A set of standard styles is used to represent the basic Markdown formats.

Winhelp files (compiled .hlp and .hpj project files)

There are no special settings for importing Winhelp files. 

You will get much better results if you import Winhelp project source files (.hpj project

file and other accompanying files). Compiled .hlp files do not contain all the information

needed for recreating Winhelp projects.

FrameMaker Projects

Help+Manual does not import Adobe FrameMaker projects directly. However, you can

achieve very good results by using FrameMaker's Save as RTF function. This provides all

the benefits of importing Word files, including integrating your styles in the Help+Manual

project stylesheet. In addition to this, FrameMaker also does a great job of exporting its

compound graphics to vector-based EMF files, which Help+Manual can handle very well.

So to import a project from FrameMaker, just save it as RTF in FrameMaker, then follow

the instructions for importing Word RTF files below.

1165

1143
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Word RTF files

There are no special settings in the import wizard for importing RTF files. However, you do

need to plan the content of your RTF files in order to get the best results. 

Save your Word files in the RTF format with Word before import-

ing

If you have RTF files that were not created with Word, always re-save them to RTF with

Word before importing them to Help+Manual.

Automatic topic generation

The importer splits the contents of RTF files into topics automatically if possible, using one

of two methods:

Standard Word Heading1 - Heading 9 styles:

If your RTF file uses the standard Word Heading 1 ... Heading 9 styles each heading

with one of these styles will start a new topic. Subtopics will be created automatically

on the basis of the heading levels.

Hard page breaks:

If your file does not use Heading 1 .. Heading 9 styles new topics are created at hard

page breaks. No subtopics are created with this method.

Limiting the depth of chapter creation

You can limit the depth of chapter creation when importing Word documents with excess-

ively complex chapter structures. You do this by specifying the maximum levels that

should be converted to chapters and sub-topics in your Help+Manual project. For ex-

ample, if you specify you only want the first 3 levels as chapters, all sub-topics below level

3 will be included in body of the corresponding topic.

These lower-level topics will not be included in the TOC and their headings will be

rendered as normal text sub-headings in the body of the topic, along with their text. 
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Styles in RTF files

Styles used in RTF files are imported to your Help+Manual project. They remain attached

to the text they were applied to in the RTF document and they are also added to your pro-

ject styles list. If the RTF you are importing to an existing project contains styles that con-

flict with existing styles in the project a dialog will be displayed asking you whether you

want to keep the old styles, the new styles or add a second version of the style with a dif-

ferent name. 

You can start using your styles immediately after importing and you can also edit them in

Write > Edit Styles.

Map styles to imported styles:

This option merges styles from the imported document with styles with the same

name in your Help+Manual project. 

Hyperlinks in RTF files

Most hyperlinks in RTF files will be converted correctly but in some cases it may not be

possible to resolve their targets with 100% certainty. In these cases the links will be shown

highlighted in red in the Help+Manual editor so that you can check them and make the

necessary correctly.

Graphics in RTF files

Graphics embedded in RTF files do not have names, they only have sequential numbers,

starting with 1 in every RTF file. Help+Manual automatically generates sequential names

for the graphics files combined with the first 8 letters of the RTF name, or of the project
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name if it is a WinHelp HPJ project. This ensures that you don't get duplicate file names

for different graphics when you import RTF files to different projects.

AuthorIT XML Projects

About AuthorIT importing:

Help+Manual does a very thorough conversion and import of your AuthorIT project. All

the following items are imported:

· All topics and snippets

· All "Books" (converted into H+M  TOCs)

· Index keywords automatically created by AIT

· Text and paragraph styles (AIT Help styles)

· Hyperlinks to topics and web pages

· Tables

· Variables (3 predefined variables and all user-defined variables)

· Topic status (converted to H+M topic status)

· Build tags (AIT Help, Web and Print tags converted to H+M build tags)

· Graphics with original file names

· Embedded pictures

· "See Also" link lists in topics

First publish your AuthorIT project to XML with the Publish To option:

To import an AuthorIT project you first need to publish it to XML using the Publish To op-

tion. This step is essential. You won't be able to import an Author IT source project dir-

ectly.
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Options you must set in AuthorIT:

These two options must be set as follows in your AuthorIT configuration when you publish

to XML for importing to Help+Manual:

· Export embedded pictures as files:YES

· Export linked pictures as files:YES

The following option can be activated, but is not required:

· Include preview of file objects:optional

AuthorIT import options in Help+Manual:

You can then import the XML project created by AuthorIT to Help+Manual. You will be

shown these options:
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· Create topic IDs from titles
Recommended! Activate this to make "human-readable" IDs based on the topic titles in

your AuthorIT project. Turning this off generates "human-unfriendly" IDs based on the

AuthorIT numeric topic IDs. This makes selecting the correct topics for link targets etc.

much more difficult if you are a human and not a machine.

· Import snippets as separate topics
By default, your AuthorIT snippets are imported as topic files with the build option

"none" so that they are only used as source for snippets and not automatically exported

as hidden topics when you publish to formats that support this (CHM, WebHelp,

eWriter, VS Help). Activating this option sets their build option to "all builds" instead, so

that they have the same status as any other topic without a TOC entry. 

· Add a list of related topics
If you activate this option your "Related Topics" lists for each topic are imported along

with each topic. Turn it off to exclude these lists.

RoboHelp projects

You can import RoboHelp X5, X6, 7, 8 and 9 projects. 
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Here too, the importer needs to know how to deal with the different parts of the HTML

topic pages. You can improve the import performance with the import options settings.

Topic header:

Getting the header information from the <title> tag will usually work. If your topics

have a separate header block you may need to specify a different tag. If in doubt check

the HTML source code of the files in your RoboHelp project.

Single-column tables:

Some topic pages are enclosed in single-cell/single-column tables, which can cause un-

desirable results when you import them. You can solve these problems with the option for

converting such tables to single paragraphs.

Graphics files:

The graphics files from the RoboHelp project are not imported to the new project direct-

ory. Instead, Help+Manual adds the current location(s) of the graphics files to the image

folders list in the Configuration > Common Properties section of your project. You can

move the image files after importing if you want – just change the folder entries in the

Image Folders list accordingly after doing so and Help+Manual will then be able to find

them. 

Integrating imported formatting in your H+M stylesheet

With the exception of RTF files (see above), text imported from external sources is all

tagged as "manually formatted" with inline formatting, not with styles. You can integrate

this formatting into your Help+Manual stylesheet with the Create Style from Selection

and Replace Styles functions.

Provided style classes were used in the original HTML you can globally strip out inline

formatting imported from HTML and convert it to style references with the powerful Tool-

box utility included in the Premium Pack style pack. 

For instructions see Replacing Formatting and Styles .

5.3.5 Importing & copying topics and XML files

You can import topics and XML topic files to the current topic from the current project, from

other Help+Manual projects and from libraries of Help+Manual XML files. You can either

overwrite the entire current topic with the external file using Load Topic from File or you can

insert the external file in the current topic with the Snippets tool. 

You can also copy and paste topics and chapters from other projects in the same way as

within your current project. 

1143
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Productivity Tip
Use Snippets to build up a collection of pre-formatted

text blocks and topics that you and your team use fre-

quently! Just copy the XML topic files you want to use

to a folder for storage. 

Importing topics and XML files as snippets

The   Snippets tool inserts topics and H+M XML files into your current topic at the

cursor position. These topics can be inserted in Copy mode or Link mode. In Link mode

the snippet content updates automatically when the source topic or XML file is edited.

The topics can be in your current project, another Help+Manual project (HMXP format,

Professional and Floating license versions only) or a directory of H+M XML files.

1. Click in your topic where you want to insert the snippet. 

2. Select the  Snippet tool in Write > Insert Object.

3. Choose From Topic to insert a topic from the current project or From File to insert an

external H+M XML file or an XML topic file from another project. 

· Copy & Paste inserts a copy of the file that you can then edit.

· Linked creates a live link to the file – changes in the source file or topic are updated

automatically. 

· Deselecting Snippet creates a new paragraph allows you to insert a snippet as inline

text in an existing paragraph.

· You can also insert XML files from your current project instead of using the From

Topic mode (HMXP format, Professional and Floating license versions only).

4. Select the topic or file you want to insert and click on OK to insert it.

"Use project search path to locate snippet"

This option adds the location of the snippet file to the project search path  – if you

deselect it the path to the snippet is stored with the snippet.

Rather than using snippets from many locations it is better to store all your snippet files in

a common location. This will make them easier to manage, particularly if you ever need to

move your project or have it translated.

1405
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Managing and organizing snippets

You can insert snippets from any location. However, if you use linked snippets from many

locations the links will be dead if you move your project or send it to someone by email.

You can solve this problem by storing your snippet files together with your project in a

special directory. Alternatively, you can store and edit your snippets in their own uncom-

pressed Help+Manual project, or in a special Help+Manual project known as a style repos-

itory:

See this topic  for more information on working with and managing snippets.

Snippets managed in a snippet folder:

1. Create a folder for your snippets in a location where you can easily transport it to-

gether with your project folder. 

2. Add the path to the snippets folder to your Project Search Path in your project's Con-

figuration > Common Properties settings.

3. When you insert a snippet select the Project Search Path option to tell Help+Manual

to look for the snippet files in the folders listed in the Project Search Path.

When you do this you can always move your snippets folders to any location you like. To

get Help+Manual to find the snippets you just need to add the new location to your Pro-

ject Search Path.

Snippets managed in a project:

Create an uncompressed Help+Manual project using the HMXP format (Pro and Floating

license versions only). Then save your snippets directly in the /Topics folder of that project.

You can then edit the snippet files in that project in the Project Files > Topic Files section

in the Project Explorer.

Snippets managed in a style repository:

See Working with Style Repositories  for instructions on this option.

Exporting text and topics as snippet files

You can export selected text or the current topic to an external XML file, for example for

use as a snippet in a snippet directory. 

265
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Export the entire topic:

1. Select the topic you want to export in the Project Explorer (TOC or Topic Files). 

2. Select File > Save Topic to File in Project > Manage Topics and choose the save loca-

tion.

Export selected text:

Select text in the editor – the text can include anything that a topic can contain, i.e. also

images, tables, etc.

Select File > Save Snippet in Project > Manage Topics and choose a save location and a

filename.

Formatting and snippets

Formatting with styles:

If the text in snippets is formatted with styles the styles must be defined in the present

project. If the styles are not defined the snippets text will be displayed unformatted. If you

use standard style names in all your projects your snippets will be reformatted automatic-

ally to match the styles of the current project. 

Snippets in style repositories come with their own styles:

Style repositories are used as a source for styles for multiple projects. If you use snippets

from a style repository the styles used in the repository are automatically imported to

your project, so you don't have to worry about the styles issue. See Working with Style

Repositories  for details on working with repositories.

Manual formatting:

If the text in your snippets files is manually formatted it will be displayed normally in the

current project. It is generally better to use manual formatting if you want the formatting

of the snippets to look identical wherever they are used.

Loading entire topics from external files

You can load entire topics from external files. Unlike snippets, loading a topic from a file

replaces the entire current topic with the external file. You can load topics from  RTF,

1076
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HTML, TXT and Help+Manual XML topic files. 

1. Select the topic you want to overwrite in the Project Explorer (TOC or Topic Files), or

create a new empty topic. 

2. Select File > Load Topic from File in Project > Manage Topics and select the file you

want to load. This will overwrite the current topic with the contents of the selected file!

See Content templates for topics  for information on using Help+Manual XML topic

files as content templates for topics.

Merging external HTML files into topics

In HTML-based output formats you can also use the Insert HTML Code tool to merge the

contents of external HTML files into your topics when you publish your project. These files

can be local or accessed via an http URL. This enables you to maintain external files for in-

formation that may change and insert the latest version automatically every time you pub-

lish.

See Merging HTML files into topics  for full details and instructions.

Copying topics and chapters between projects

1. Open both projects in the Project Explorer. Alternatively you can open Help+Manual a

second time and open one project in on instance of the program and the other project

in the other. This can make it easier to switch between projects. 

2. Select the source and target positions in both projects so that you can see them

clearly.

3. Use the Copy, Cut and Paste tools in the Ribbon Toolbar to copy and paste topics or

chapters. These Clipboard tools are available in both the Write and Project tabs.

If the pasted topics have the same IDs as topics in the target project H+M will change

them automatically. It's advisable to open the Topic Options tab on the left of the main

editor window and check the IDs of all pasted topics after importing them.

See also:
Re-using content with snippets

Exporting and importing topics

Moving, cutting and pasting topics

5.3.6 Merging HTML files into topics

In addition to importing HTML and text files you can also use a command that enables you to

merge external HTML files into existing topics at publish time with the HTML Code Object

tool. The files can be local or read from a location on the Internet with a URL. This can be very
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useful if you have material that changes frequently. You can maintain it in an external HTML

file and automatically merge the latest version into your project when you publish.

Key Information
This only works in HTML-based output formats.

Merged HTML files are not included in PDF, printed

manuals and MS Word DOCX output.

Inserting an external HTML file in an existing topic

Merging HTML files injects the entire external HTML file, including its <head> section and

everything it contains. If you use it to insert an HTML file in the middle of an existing topic,

it will also paste in all the information that is normally in the head section of the HTML

page. This may work because most browsers are quite forgiving, but it can also cause

problems.

Because of this, it is advisable to remove everything in the external file outside the open-

ing and closing <body> and </body> tags, and those tags as well, when merging into

topic pages. Basically, such files should only contain normal HTML code, without the addi-

tional sections needed for independent pages.

Step 1: Preparing a full page for insertion inside a topic:

1. Open the external HTML file in an editor. 

2. Locate the opening <body> tag and delete it and everything that comes before it.

3. Locate the closing </body> tag and delete it and everything that comes after it.

4. Save the file with the .htm or .html extension.

Step 2: Insert the file with the Code Object tool

See Inserting HTML code objects  for instructions.

Replacing a topic with an external file

In some special cases you may want to replace a topic entirely with an external HTML file.

It's important to understand that when you to a this you are responsible for the entire lay-

out. You must provide not only the page content but also everything that would normally

be in the HTML page template. So you need to provide the <head> section and all the

settings there, including CSS file references JavaScript file references meta tags and so on. 

469



171

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

This method is incompatible with most skins and templates!

This is a method that should only be used in very special cases where you completely un-

derstand the HTML code you are using and the results it will produce. It will be incompat-

ible with most skins in templates included with Help+Manual and all Premium Pack skins

without exception. In the huge majority of cases the insertion method described above is

the only method you should use. 

Procedure 

It's important to understand that the #MERGE command inserts the entire HTML file it ref-

erences. Since HTML files are normally complete, with all the header and layout informa-

tion they need, you don't want the page components that are normally used for

Help+Manual topic pages. You need to create a special HTML topic page template that

does not contain this information; otherwise you will have two pages in one, nested inside

each other.

The solution here is to create an empty HTML topic page template that only contains the

variable for inserting the content from your topic page. 

Step 1: Create a special HTML page template for merged HTML files

1. In your project, go to Project Explorer: Configuration > HTML Page Templates, click

on Add to create a new page template and give the template a descriptive Name like

External. 

2. Select the new template, and in the Source Code tab select all the code and delete

everything.

3. Type in the variable <%TOPIC_TEXT%> in the Source Code tab, so that this is the only

content. It should look like this:
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4. IF YOU ARE USING A SKIN: 

If you are using a skin to publish you must repeat the above steps in the skin file as

well. Open the .hmskin skin file in Help+Manual (select .hmskin as the file type to

open in the Open dialog) and add your additional HTML page template there as well,

with exactly the same contents and the same name. 

Step 2: Create the topic with the #MERGE command to insert the file

1. Create an empty topic in the position where you want to insert the file. 

2. Select the Topic Options tab on the left of the main editor window, and in the HTML

Page Template: field select the External template you created in step 1 above.

3. Use the Code Object tool  to insert the external file. 

See also:
Inserting HTML code objects

5.4 Creating Topic Files

Topics are the main components of your project. Each topic is a separate file, which is like a

word processor document. These files are stored inside the main project file if you use the

single-file .hmxz format and in your project folder if you use the uncompressed .hmxp

format. (Help+Manual Basic uses the compressed format only.)

Topic files are managed in the Project Explorer

You manage your topic files and your Table of Contents in the Project Explorer. Before

starting with this chapter, please study the chapter Using the Project Explorer  – it con-
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tains important information that you need to be familiar with before you start working

with topic files.

5.4.1 About topics and the TOC

The text and other content in your projects is organized in "topics". Each topic is stored in a

separate file in the Project Files section in the Project Explorer.

Key Information
Creating a new topic in the TOC creates a TOC entry

and an associated topic file in the Project Files section.

Creating a topic in the Project Files section creates a

topic file without a TOC entry.

About topics, TOC entries and topic files

A topic is like a word processing file; it is a document dealing with one subject and it is

generally represented by one entry in your Table of Contents (TOC). 

Each topic is stored in a separate file stored inside your project. The entries in the TOC are

actually separate from your topic files. The TOC entry is really just a link pointing to a topic

file. 

Creating topics in the TOC:

When you create a topic in the TOC you automatically create a TOC entry and a topic file

in the Topic Files section of the Project Explorer. When you click on the TOC entry the

topic file is displayed for editing automatically.

Creating topics in the Topic Files section:

If you create a topic in the Topic Files section of your project it will not have a TOC entry.

Topics without TOC entries are used for popup topics, topics displayed only by hyperlinks

and topics used as snippets  (reusable content that you insert in other topics). They are

not exported to PDF, ePUB or DOCX output files.

How topics are managed in your projects:

Although your topics are all separate files Help+Manual manages your project as though

it was one big file for some functions. For example, you can perform global search and re-

place operations on all the topics in your project and your formatting styles also apply to

all your topics.

165
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The Table of Contents (TOC)

The Table of Contents (TOC) in the Project Explorer is a representation of the structure of

the TOC in your finished documentation. The TOC is used to organize your project into

chapters and sub-chapters. In the Project Explorer it works like an outliner, allowing you to

move topics and chapters around and change your structure quickly and easily. 

Topics included in the TOC are listed both in the Table of Contents section and in the Pro-

ject Files section of the Project Explorer. The Project Files section shows all the files in your

project, the TOC only shows those files that will actually appear in the table of contents of

your documentation. It's important to understand that the topics in the Topic Files section

are not duplicates – you are viewing the same topic files in both sections.

See Managing Topic Files and the TOC  for information on working with topic files in

the Project Explorer.

See also:
Managing Topic Files and the TOC

5.4.2 Creating new topics in the TOC

You create a new topics in two places: In your project's Table of Contents (TOC) or the Project

Files section. Creating a new topic in the TOC creates a TOC entry and a topic file and links the

TOC entry to the topic file. Creating a new topic in Project Files creates a topic file without a

TOC entry.

The instructions below explain how to create topics with TOC entries. See Creating new topics

in Topic Files  for instructions on creating topics without TOC entries.

Key Information
If you save in compressed single-file mode (.hmxz) all

your  topic files are stored inside your compressed

project file and can only be viewed in the Project Ex-

plorer. The Basic version of Help+Manual can only

save in compressed mode.

How to create a single new topic in the TOC

Normally, you will want your topic files to have entries in your Table of Contents (TOC).

Topic files that you create in the TOC section of the Project Explorer automatically have

TOC entries. 

1. Click in the TOC in the Project Explorer at the position where you want to add your

new topic. 

342

342

179



175

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

2. Select Project > Add Topic and choose an Add Topic option OR 

Right-click to display the context menu and then select an Add Topic option

3. This displays the Insert New Topic  dialog, select Topic/Chapter to create a normal

topic with content.:

4. Type your title in the Topic Heading: field (this is the title that appears in the TOC). The

Topic ID is generated automatically and is initially based on the caption you enter. You

can edit the automatically-generated topic ID if you like – see Topic IDs and context

numbers  for more details.

See the Insert New Topic  for details of the settings displayed by More . Note that

you cannot select Popup as the Topic Class when you are adding topics to the TOC.

Popups should not have TOC entries so you must create popup topics in the Topic

Files  section.

5. Click on OK to create the topic.

Initially the header of the topic above the editing area will be identical to the caption. If

you edit the caption in the TOC the header will change with the caption. However, if you

edit the header this will turn off the "link" between the caption and the header. Any

changes made to the caption after this will no longer be reflected in the header.

1298
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Creating a topic by Drag & Drop

You can also create a new topic by dragging & dropping text to the Table of Contents

(TOC), in the same way that you create hyperlinks:

1. Select the text in a topic that you want to use for the topic caption. 

2. Drag the text into the TOC between two topics, in the position where you want the

new topic to be inserted.

A blue line is displayed between the TOC entries in the position where the new topic

will be inserted.

3. Let go of the mouse button. A new topic will be created with the selected text as the

caption.

TOC Link: Link to web address or an existing topic

This option can create two types of links:

Link to a topic in this project:

Creates an additional link to an existing topic in the current project. See Multiple TOC

entries for one topic  for more details on this subject.

Link to a web address:

Instead of displaying a topic this displays a web page with the URL you enter here. You

must include the http:// prefix if the address, otherwise it won't work.

After creating the TOC entry you can specify the target of the link on the right:

371
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TOC link targets in different output formats:

WebHelp: Web links in the TOC are no longer recommended for WebHelp. In

the future, they will not work in responsive, single-page layouts be-

cause there is no topic frame where a web page can be loaded.

They will just open in a new window instead.

· Topic frame displays in the topic frame, if there is one. Otherwise

it will open in a new browser page or tab.

· Top frame replaces the WebHelp entirely with the linked web

page.

· New window opens the link in a new browser window or tab.

HTML Help/CHM: Web links in the TOC always open in the topic frame in CHM files.

The target window setting is ignored.

eWriter Help: Web links in the TOC are not recommended in eWriter Help. They

can be opened in the topic frame but the embedded browser will

often not provide good results with external websites. It is much

better to put web links in the body of your topics and configure

them to open in an external browser window in the eWriter set-

tings . 

PDF and Word

DOCX:

Web links in the TOC are not supported and are ignored in these

formats. The TOC entries are not included in the TOC.

Kindle/Mobi ePUB

eBooks

Web links in the TOC are not supported and are ignored in these

formats. The TOC entries are not included in the TOC.

Visual Studio Help: Web links and external links in the TOC are not permitted in these

formats. The TOC entries are not included in the TOC.

Creating multiple topics

1. Proceed as described above for creating a new topic. 

2. In the Insert New Topic  dialog select the Multiple Topics option. 

3. Enter captions in the Item Captions editing box. Use the indent tools on the right to

indent captions, which makes them sub-topics of the topic above them. The  button

un-indents captions. You can also use the TAB key to indent entries to turn them into

sub-topics.

1477
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4. Click on OK to create the topics.

Note that when you use this method the topic IDs are all generated automatically from

the topic captions. You can edit the IDs  afterwards if you want.

Using templates for new topics

You can use content templates for topics to automatically insert a basic layout, including

any content (text, graphics, tables etc.) when you create a new topic. If you have already

created one or more topic content templates in your project directory you can select them

when you create the topic. 

· Select the template you want to use in the Topic Template: field.

· Templates will only be defined if you have created them by saving topics in your project

directory as XML template files, using the naming syntax topicname.template.xml,

with the File > Save Topic to File in Project > Manage Topics.

See Content templates for topics  for full details on creating and using topic content

templates.

See also:
Insert New Topic  (Reference)

Topic IDs and context numbers

Content templates for topics
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5.4.3 Creating new topics in Topic Files

When you create a new topic in your project's Project Files section you just create a topic file,

without an entry in the Table of Contents (TOC). Topics like these are used in electronic help

formats for information that is only displayed when the user clicks on a link – for example

popup topics and topics displayed in external windows. 

Topics without TOC entries are also used for content that you want to insert in multiple loca-

tions in your project with Help+Manual's snippets  function. 

The instructions below explain how to create topics without TOC entries. See Creating new

topics in the TOC  for instructions on creating topics with TOC entries.

Key Information
If you save in single-file compressed mode (.hmxz) all

your  topic files are stored inside your compressed

project file and can only be viewed in the Project Ex-

plorer. The Basic version of Help+Manual can only

save in compressed mode.

How to create topic files without TOC entries

By default, topics with TOC entries are created in the Topics folder in the Topic Files sec-

tion. It is advisable to create additional folders for topic files without TOC entries to keep

them separate. Follow the instructions below to create folders for your topic files. 

1. Select Topic Files in the Project Files section of the Project Explorer, then select the

folder where you want to create your new topic file. 

2. Select Add File > Add New File in Project > Manage Topics.

3. This displays the Insert New Topic  dialog in file mode:
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4. You can create multiple topic files with this dialog. Type one or more names for the

topic files you want to create, one name per line.  See Insert New Topic  for details

on the options available here (template, class etc). 

5. Click on OK to create the new topic file(s).

The file names and topic IDs for the new files will be generated automatically from the

names you enter. Spaces in your names will be converted to underscore characters.

How to create new folders for topic files

All your topic files are stored in the Topic Files section of your project, including the topic

files with TOC entries that you create in the TOC (which is really a list of links to the files).

By default, files with TOC entries are stored in a folder called Topics. It is advisable to cre-

ate additional folders for your files without TOC entries to keep them separate from the

TOC topic files. 

1. Select Topic Files in the Project Files section of the Project Explorer. 

2. Select Add File > Add New Folder in Project > Manage Topics.

3. Enter a name for the new folder and click on OK. 

You can also access the Add File/Folder options by right-clicking in the Topic Files section.

1298
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Using include options for topics without TOC entries

You can use conditional output include options for topic files in the same way that you

can for TOC entries to include or exclude the topic files from your output when you pub-

lish. For more details on using include options see Conditions and Customized Output .

· Select the file you want to apply include options to in the Explorer and select Change >

Include in Builds in Project > Manage Topics, then select the options you want to apply.

· Alternatively you can also right-click on the file to edit its include options. 

Excluding the source files of snippets:

You should always exclude the source files for snippets  (both linked and pasted) from

your output using include options. Since the snippets are just copied from the source files

you don't want to include the source files themselves in your published output – if you did

the user would be able to find them with search, which is not what you want.

How to add a TOC entry to a topic file

Sometimes you may decide that you would like to add a TOC entry to a topic file that

does not yet have one. Or you want to add an additional TOC entry for a topic that

already has one. You can do this with the TOC Link option in the New Topic dialog.

Method 1: Dragging topic files into the TOC

Dragging a topic file into the TOC from the Topic Files section will also create a new TOC

entry for that topic file. It doesn't move anything. It just creates a new TOC entry. You can

also do this with multiple files. Use SHIFT+Click and CTRL+Click to select multiple files,

then drag them into the TOC.

Method 2: Creating a new TOC entry as a copy of an existing entry

You can also create a new TOC entry for a topic that already has a TOC entry by holding

down the SHIFT+CTRL keys and dragging the original TOC entry with the mouse to the

position where you want to insert the copy. Instead of moving the original entry this will

then create a new TOC entry pointing to the same topic. This only works for topics that

already have TOC entries, of course. 

Method 3: Use the TOC Link tool

The TOC Link tool in the Insert New Topic dialog creates a new TOC entry for a topic file.

969
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Note that topics can have more than on entry in the TOC, because TOC entries are really

just links pointing to topic files. They are not part of the topic.

Tip – locating the topic ID:

You can find the ID of any topic by selecting Topic Options to the left of the editor win-

dow and checking the Topic ID: field there.

1. Click in the TOC where you want to insert the new entry and select the Add Topic tool

in Project > Manage Topics. 

2. Select TOC Link on the left and click on Link to Topic in this Project.

3. Select the  topic ID of the topic you want to link to in the Target Topic: list. You can

optionally also select an anchor to scroll to in the Topic Anchor: field if the target topic

contains anchors.

4. Click on OK to insert the link. 

See Multiple TOC entries for one topic  for more details on this subject.

How to delete a TOC entry without deleting the topic file

You can delete a topic's TOC entry without deleting the topic file. This turns a TOC topic

into a topic without a TOC entry.

1. Select the topic in the TOC (you can also use Ctrl+Click and Shift+Click to select mul-

tiple topics). 

371
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2. Press DEL or right-click and select Delete Topic.

3. In the dialog displayed deselect the Also delete referred topic files option and click on

Delete Topics.

Auto-generating topic files

If your programmer can generate a "map" file containing a list of the topic IDs and context

numbers you can automatically generate any missing topics with the Context Tool in the

Project tab. See Auto-generating topic files  for details.

See also:
Insert New Topic  (Reference)

Creating popup topics

Organizing invisible topics

Using Context-Sensitive Help

5.4.4 Creating topics from other sources

In addition to creating new topics into which you enter new content you can also create TOC

entries that display content from other sources when the user clicks on the TOC entry.

 You can create TOC entries that link to web pages or to topics in other help files that are

available when the user views the help. 

You can also insert entire Help+Manual projects in your TOC. When you publish your project

the external projects are merged with the main project. 

Productivity Tip
You can also use Snippets  to insert topics and XML

files from other sources into existing topics. Snippets

can be inserted as editable copies or linked to the

source files so that they update automatically when

the sources are edited.

Linking a TOC entry to a topic in an external help file

This option does not create a topic file. Instead, it creates a TOC entry that links to a topic

in an external HTML Help .chm file. This only works in HTML Help output! Such topics will

be empty in other output formats and should be excluded from those formats with condi-

tional output  options.

1. Select an Add Topic option to create a new topic. 

2. In the Insert New Topic  dialog select the Jump to External Help option.
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3. Use the  Browse button in the Help File: field to navigate to the Help+Manual pro-

ject from which you are generating the help file you want to reference. This must be a

.hmxz or .hmxp project file. 

4. Then use the  Browse button in the Topic ID: field to select the ID of the topic you

want to link to.

5. Then click on OK to create the new topic. 

Important notes:

· The name of the Help+Manual project and the name of the referenced CHM help file

must match exactly! Help+Manual can only reference the CHM on the basis of the

name, so if the project and CHM file name do not match the CHM cannot be found.

· The CHM help file containing the topic you link to must be present in the same directory

as the help file containing the link, otherwise the topic will not be displayed. You can

only link between between two CHM files!

Linking a TOC entry to a web page

This method only works in HTML-based output formats. You cannot include web pages in

your help in PDF files, for example. 

1. Select an Add Topic option to create a new topic. 

2. In the Insert New Topic  dialog, select the TOC Link option, then select Link to Web

Address.

1298
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3. Enter the URL of the web page in the Web Address: field. You must enter a fully-quali-

fied URL including the http:// protocol identifier. For example,

http://www.ec.software.com/ will work but www.helpandmanual.com will not

work.

4. Click on OK to create the new topic. The web page will only be displayed in your pub-

lished output and only when you have an active connection to the Internet. 

Inserting an entire Help+Manual project

In addition to topics you can also insert entire Help+Manual projects in the TOC, thus

merging the two projects. 

1. Select an Add Topic option to create a new topic. 

2. Select Include Help Project in the Insert New Topic  dialog and select the project you

want to insert.

1298
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Merge content on publishing: If you select this mode the external project's contents

will be displayed in the TOC of the current project and can be edited directly. Merged

projects are still stored externally and their topics are identified by small green icon in

the TOC. 

Merge content at runtime: This is for HTML Help only and just inserts a placeholder

in the TOC. The projects must be edited and published separately and are only

merged when the user views them if the help files are all present in the same folder. 

Publishing merged projects:

In most output formats the projects will be merged into one large help system when you

publish your output. In HTML Help you can also create separate help files that are dis-

played in a single Table of Contents when the user opens the main help file. This makes it

possible to create different versions of your help just by including or excluding help files in

your distribution package.

See Working with Modular Help Systems  for full details.

See also:
Working with Modular Help Systems

5.4.5 Topic Options

The Topic Options tab is accessible on the left of the main editor window and contains a num-

1088
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ber of key settings for the topic currently displayed. It enables you to view and edit a number

of settings that are assigned automatically when you create topics, and some additional op-

tional settings.

<TITLE> tag: This is the text inserted in the <TITLE> tag in topic pages in HTML-

based output. By default this is the text displayed as the table of

contents entry displayed in the Project Explorer on the left. If you

edit the TOC entry this text changes automatically, unless you edit

this field in Topic Options manually.

If the topic header text in the box above the editor is different from

the TOC entry, the TOC entry is shown here and not the topic

header text. (Again, only if you didn't edit the title tag text manu-

ally.)

Topic ID: The address of the topic. This is used for referencing topics for links

etc. and it is also used for generating the file names of HTML files

generated for topics in HTML-based output formats.

You can change the topic ID by editing this entry. When you do

this, all the references to the topic within your project are updated

automatically. 

External references to the topic from other projects and other web

pages linking to your WebHelp cannot be updated from within
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Help+Manual. They will become invalid if you change the topic ID

and must then be updated. 

Anchor: Target of the TOC entry for the topic. Normally this is the top of the

topic, but if there are anchors defined in the topic you can select

one here. Then the TOC entry will scroll down to the anchor when it

is selected.

This option is normally only used for topics with multiple TOC

entries . Then each entry can link to the appropriate part of the

topic. Don't let this possibility tempt you to make excessively long

topics – that is generally a bad idea. Normally, it is much better to

have a separate document for each topic.

Topic class: There are two possible classes: Default and Popup. Most topics will

be default topics. The popup class can only be selected for topics

that don't have TOC entries, because popup topics are not allowed

to have TOC entries. See Creating popup topics  for details. 

Help context: Optional numeric context IDs for use in Microsoft HTML Help/CHM

files. You only need these if your programmers are using context

IDs for references from your application to the CHM help file. See

the chapters on context sensitive help  and the Help Context

Tool  for more details.

HTML Page Tem-

plate:

This selects the HTML layout template to be used for this topic in

HTML-based output formats. Normally this will be the standard De-

fault template. You can only select additional templates here if you

have defined them yourself . 

Topic Status: This just provides another way to select and set the status for the

current topic  displayed in the table of contents in the Project Ex-

plorer on  the left. This is design-time only – the status is not expor-

ted to your output. 

Keywords: The index keywords associated with the topic. You can enter them

directly here or centrally with the Index tool  (Professional and

Floating license versions only).

A-Keywords: These are special "associative" keywords that are only supported in

the Microsoft HTML Help/CHM help format. See this topic  for

more details on this.
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Description: An optional description of the topic. This has two uses:

1. Source for the description meta tag  for search engine

optimization in WebHelp. 

2. Future use for alternative table of contents layouts with de-
scriptions and images as well as titles.

Featured image: This allows you to associate an image with the topic that can then
be used in topic templates and PDF title pages for chapters. 

In HTML templates you can use the TOPIC_PICTURE  variable
to insert the images in your templates. 

See the help of the Print Manual Designer program for details on
how to use the featured images to create title pages for chapters in
PDF output.

Topic variables: This table can be used to change the definition of user-defined or

global variables for the current topic only. See this topic for de-

tails .

5.4.6 Editing the topic caption and header

The topic caption is the title of the topic displayed in the TOC, both in Help+Manual and in

your output. For example, captions are displayed as the TOC titles in the Contents pane of the

HTML Help viewer and the Contents page of a PDF file. 

When you create a new topic the caption text is duplicated in the topic header, which is the

title displayed in the editing box above the topic itself. The header is also displayed in your

output, for example above the topics in the HTML Help viewer.

How to edit the caption (title) of a topic in the TOC

1. Click on the topic in the TOC. 

2. Press F2 or click on the  Edit Caption button in Project >  Manage Topics.

3. Edit the caption and then press Enter to finish
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Editing the topic header separately

When you create a new topic its caption is automatically duplicated in the topic header. If

you only edit the caption the header is also updated automatically so that the caption and

the header remain identical. However, if you want you can also make the topic header dif-

ferent – for example so that you have a short caption for the TOC and a longer, more de-

scriptive header.

· Click in the header box above the Page Editor end edit the header text. When you do

this the header and the caption are no longer linked and can then both be edited sep-

arately.

· To "re-link" the caption and the header again just make the text in both identical again.

Then the header will automatically be updated when you edit the caption in the TOC. 

How to turn off the header

To turn off the header for a topic click open the options menu with the button in the top

left corner of the editor and disable the Topic has a separate header item in the menu. 

This turns off the header in the editor for that topic and will create a topic without a

header in your published output.

Warning: Turning off the header deletes any additional content you have added to the

header box. If you turn the header on again the box will only contain the standard topic
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title, taken from the topic's TOC entry. The content will not be lost while you are still edit-

ing the current topic (you can restore it by reactivating the checkbox) but once you leave

the current topic it will be deleted permanently.

See also:
Topic headers

5.4.7 Topic headers

By default, new topics always have a "header", displayed in a separate editing box above the

main topic editor. You can turn the header off with the options menu in the top left corner of

the editor window if you want. This turns off the header for the current topic. 

Initially, this header contains the title of the topic, formatted with the standard Heading1 style

and with the background color set in the HTML topic page template. You can also add other

content, including graphics, hyperlinks etc. 

Header formatting, background colors and additional content are only supported in electronic

help formats (HTML Help, WebHelp, eBooks and Visual Studio Help). ePUB eBooks have lim-

ited or no support for additional content. In print-style formats (PDF, DOCX, printed manuals)

only the plain text from the header is exported when you publish and the formatting is

defined separately

How to format the header text and background

Formatting the header text:

By default the header text has the standard Heading1 style. The easiest way to format your

header text is to edit this style in Write > Styles > Edit Styles. Then all new headers will

automatically have the selected formatting. You can format headers manually by selecting

the text and using the formatting tools in the Write tab if you want, but then you must do

this separately for every single topic.

191
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Setting the header background color:

In most electronic output formats the header background color is defined by the HTML

topic page template. 

Important: Edit in the skin file if you are using a skin!

If you are using a skin to publish this is defined in the topic page template in the skin

file, not the template in your project. Make a copy of the .hmskin skin file in your pro-

ject folder to edit it. Then open it in Help+Manual by selecting .hmskin as the file type

to edit in the Open dialog. The template is in the same location as in a normal project

file.

In the Project Explorer go to Configuration > HTML Page Templates and select the De-

fault template. Then you can set the background colors for the header and the topic body.

The background colors you set in the template are automatically displayed in the editor. 

See Background colors and help viewers  for more details on this.

How to turn off the header

To turn off the header for a topic deactivate the Topic has a separate header option in the

options menu at the top left corner of the editor window. This will create a topic without a

header in your published output.

Warning: Turning off the header deletes any additional content you have added to the

header box. If you turn the header on again the box will only contain the standard topic

title, taken from the topic's TOC entry. The content will not be lost while you are still edit-

ing the current topic (you can restore it by reactivating the option) but once you leave the

current topic it will be deleted permanently.

142
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Additional content in the header

You can insert any content in the topic header box that you would normally insert in the

main body of the topic, including graphics, hyperlinks and so on. This content will be pub-

lished with the header in electronic formats (HTML Help, WebHelp, eBooks and Visual Stu-

dio Help) but not in print-style formats (PDF, DOCX, printed manuals). 

Note that content added to the header will only be displayed in the current topic. If you

want to include the same content in every topic (for example a logo) you need to edit the

HTML topic page template and add the content to the header section of the template. See

Using HTML Templates  for more details. 

If you want to include additional with your headers in PDF and printed manuals you need

to add it to the header definitions in the print manual template – see PDF & Printed

Manuals  for details.

Topic headers in PDF, DOCX and printed manuals

The topic header and its formatting and background color are not exported or used in

PDF and printed manuals. In these formats, only the plain text topic title is exported, the

formatting is applied with the print manual template for PDF and printed manuals (which

use the same PDF templates).

In PDF you can use either the TOC topic title or the text from the topic header (if it is dif-

ferent). This is done by selecting either the <%HEADINGx%> variables in the template for

the TOC topic title or the <%HEADINGLONGx%> variables for the text from the header box

in your template in Manual Designer.

See PDF & Printed Manuals  for details on accessing and editing print manual tem-

plates for PDF.

In Word DOCX the heading style from the header are used in the body text of the DOCX 

document, but the styles of the entries in the TOC at the beginning of the document use

the Heading 1 ... Heading 9 styles defined in your DOCX template. 

See MS Word DOCX  for details on configuring your DOCX output for publishing.

See also:
Background colors and help viewers

Using HTML Templates

PDF & Printed Manuals
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5.4.8 Using help windows for CHM files

The Microsoft HTML Help (CHM) format uses sets of definitions called "help windows" to con-

figure the appearance, size and behavior of the Windows viewer used to display CHM help

files. Help window definitions can also be used to display individual topics in external win-

dows. 

Changing the definition of the default help window, which is called Main, adjusts the help

viewer features. You can also define additional "secondary" help window types, which can

have different features. These help windows are used for opening specific topics in external

windows when you link to them. You do this by specifying a different help window type when

you define the hyperlink.

Key Information
Help window settings are only relevant for HTML Help

output, where they control the appearance and beha-

vior of the Microsoft CHM viewer.

How to change the features of the help viewers

The definition of the default Main help window type controls the size, appearance and

controls of the help viewers  for HTML Help.

You can change these settings with the Main help window definition in Configuration >

Microsoft HTML Help > Help Windows. The common settings define the position and

size of the help viewer, the HTML Help Options tab defines the features and behavior of

the help viewer. 

See Background colors and help viewers  for more details and Help Windows Set-

tings  in the Reference section for information on the individual settings. .

How to create, delete and edit help window types

1. Select Configuration > Microsoft HTML Help > Help Windows  > {WindowName} 

2. Add creates a new secondary help window type, Remove  deletes the current window

type (you cannot delete Main). For more information see Help Windows  and Help

Windows Settings  in the Reference section.

3. Edit the attributes to change the properties.
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How to display topics in external windows in HTML Help

In HTML Help you can use additional help window definitions to display topics in external

windows when they are opened with hyperlinks. Topics can only be displayed in external

windows in HTML Help CHM files and the help window settings have no effect in other

help formats. 

Important Restrictions

Important: Help window types can only be used in hyperlinks. 

You cannot directly associate a help window type with an individual topic and you cannot

set a topic in the TOC to open in an external window when you click on its TOC entry.

You cannot link open topics from other CHM files in external windows.

Due to restrictions in the Microsoft HTML Help CHM viewer, you can only display topics

from the current CHM file in an external window. It does not work when linking to topics

in another CHM file. 

Procedure:

1. In the Project Explorer go to Configuration > Microsoft HTML Help > Help Windows

and create at least one secondary help window type definition with Add. 

Adjust the settings of the window definition as you want the external window to ap-

pear – in addition to the size and position you may want to switch off navigation con-

trols etc. in the help window definition's HTML Help Options tab.  

2. In the HTML Help Options tab activate the option Links to secondary help windows

open a new help window.

3. When you create a hyperlink to a topic specify the secondary help window type with

the Window: setting in the link definition. 

When the user clicks on the hyperlink the target topic it will now be displayed in an ex-

ternal window in HTML Help, with all the settings defined for the window type in step 1. 

Topic and header background colors

The help window definition no longer sets background colors (it only did this in the now

obsolete WinHelp format). In current electronic output formats the background colors are

controlled by the HTML page template  (you cannot set page and header background

colors for PDF, DOCX or printed manuals).
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See Background colors and help viewers  for more information on how to set back-

ground colors. 

See also:
Help Windows

Help Windows Settings

Using secondary windows

HTML templates

5.4.9 Reusing content with snippets

The Snippet tool in Write > Insert Object enables you to insert the contents of another topic,

a Help+Manual XML file or PDF pages  at the cursor position. 

You can insert topics and files from the current project, from other Help+Manual projects

(there are some restrictions in the Basic version of H+M) and directly from Help+Manual XML

files. This means that you can build up a library of reusable content that you can access very

easily.

You can insert topic and XML snippets in two different modes: Copy and Link. Copy mode is

like normal Copy & Paste. It pastes the contents of the topic or file at the cursor position and

you can then edit it. Link mode creates a live link to the snippet file. To edit the snippet you

must then edit the original topic or file, but then it updates automatically in all the places

where you have inserted it, even if you are using it in multiple projects.

Productivity Tip
If you send your project for translation remember to

include any linked external snippet files you have ref-

erenced, otherwise the translator won't see them! 

Snippet storage locations

Rather than using snippets from many locations it is better to store all your snippet files in

a common location, for example in a folder inside your project folder. Then add this folder

to your project search path. This will make them easier to manage, particularly if you ever

need to move your project or have it translated. Alternatively, you can also store them in a

Style Repository or their own project. See further below for details on this. 

Inserting topics and XML files as snippets

You can insert topics and XML files into your current topic at the cursor position. These

topics can be inserted in Copy mode or Link mode. In Link mode the snippet content up-

dates automatically when the source topic or XML file is edited.
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The topics can be in your current project, another Help+Manual project or a directory of

H+M XML files.

Procedure

1. Click in your topic where you want to insert the snippet. 

2. Select the  Insert Snippet tool in Write > Insert Object.

3. Choose From Topic to insert a topic from the current project or From File to insert an

external H+M XML file or a topic from another project. 

4. Select the topic or file you want to insert and click on OK to insert it.

Options:

· Copy & Paste inserts a copy of the file contents that you can then edit.

· Linked creates a live link to the file – changes in the source file or topic are updated

automatically. 

· Snippet begins a new paragraph inserts the snippet as a new paragraph. Turn this off to

insert the snippet text inline inside an existing paragraph. If the snippet contains para-

graphs they will also be inserted, of course!

· Use project search path to locate snippet adds the location of the snippet file to the pro-

ject search path . If you deselect it the absolute path to the snippet is stored with the

snippet.

1405
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Inserting snippets from a style repository

A style repository is a special kind of Help+Manual project that is used to share styles and

snippets between multiple projects. Before using a style repository you need to create it

from a Help+Manual project and link it to your current project. See Working with Style

Repositories  for instructions.

To insert snippets from a style repository just select the From Repository option in the In-

sert Snippet dialog and then select the topic ID of the snippet you want to insert. All the

other options are the same as inserting snippets from topic files in the current project.

The advantage of a style repository is that its styles are also merged with those of your

project, so that the styles used for the snippets in the style repository project are also

available for use in the project where you are inserting the snippet.

Exporting selected text and topics as snippet files

You can export selected text or the current topic to an external XML file, for example for

use as a snippet in a snippet directory. 

Export the entire topic:

1. Select the topic you want to export in the Project Explorer (TOC or Topic Files). 

2. Select File > Save Topic to File in Project > Manage Topics and choose the save loca-

tion.

Export selected text:

1. Select text in the editor – the text can include anything that a topic can contain, i.e.

also images, tables, etc. 

2. Select File > Save Snippet in Project > Manage Topics and choose a save location and

a filename.

If you save in the uncompressed XML format you can also copy the XML files directly from

your project directory to other locations in Windows Explorer (Professional and Floating li-

cense versions only).

Managing and organizing snippets

You can insert snippets from any location. However, if you use snippets from many loca-

tions your linked snippets will not be displayed if you move your project or send it to
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someone by email. You can solve this problem by storing your snippet files together with

your project in a special directory.

1. Create a folder for your snippets in a location where you can easily transport it to-

gether with your project folder. 

2. Add the path to the snippets folder to your Project Search Path in your project's Con-

figuration > Common Properties settings.

3. When you insert a snippet select the Use project search path to locate snippet option to

tell Help+Manual to look for the snippet files in the folders listed in the Project Search

Path.

When you do this you can always move your snippets folders to any location you like. To

get Help+Manual to find the snippets you just need to add the new location to your pro-

ject search path .

Managing snippets in a 'snippet project'

By far the easiest way to manage snippets is in a 'snippet project', which is just a normal

Help+Manual project saved in uncompressed XML  (.hmxp) mode. You then insert your

snippets by selecting the XML topic files from the /Topics sub-folder of this snippet pro-

ject. Help+Manual topic files can be used as snippets without restrictions. 

Add your styles to the snippet project!

After creating your snippet project it's a good idea to add the paragraph and text styles

used in your snippets to the snippet project. You should do this before adding any snip-

pets to the snippet project – if you add them later the styles may not be used properly. 

1. Select Styles > Edit Styles in the Write tab. 

2. Select Copy Styles From... and then select your main Help+Manual project (i.e. the pro-

ject in which you are going to use the snippets). This will replace all the styles in the

snippet project with those from your main project. 

Adding new snippets to a snippet project

· Just create a new topic or topic file in the snippet project, just as you would in any other

Help+Manual project.

Adding existing snippets to a snippet project

· Move the XML snippet files to the /Topics folder of your snippets project in Windows

Explorer. 
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Saving snippets to a snippet project from another project

· Create the snippet as you would normally and save it in the /Topics folder of your

snippets project.

When you do this you can always move your snippets folders to any location you like. To

get Help+Manual to find the snippets you just need to add the new location to your pro-

ject search path .

Managing snippets in a style repository

You can also manage snippets in special Help+Manual projects called "style repositories".

When a style repository is linked to your project all the snippets it contains are automatic-

ally displayed for selection in the Insert Snippet dialog.

· In addition to direct access to the snippets, the advantage of a style repository over a

normal snippet project is that its styles are merged into the styles of your current pro-

ject. The snippets using the styles defined in the repository are thus automatically

formatted correctly because their styles are directly available.

· The disadvantage of a style repository is that you can only link one repository with any

project. However, you can also use both a linked style repository and additional manu-

ally-created snippet projects (see above). 

See Working with Style Repositories  for full details on how to create style repositories

and register and link them to your projects.

Excluding the snippets source files from your published output

When you use topic files from your current project as snippets you will generally want to

exclude the source files from your published output. If you don't do this these files will be

published and the user will able to find them with Search in formats like HTML Help and

WebHelp. 

1. Select the entry of the topic file in the Project Files section of the Project Explorer. 

2. In Project > Manage Topics select Change > Include in Builds and deselect all build

options. This will ensure that these topics will never be included when you publish

your project.

This is not necessary for snippets inserted from other projects or external XML files, of

course! 
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Editing the contents of snippet files

There are three ways to edit the content of external snippet files in Help+Manual. Which

you use depends on whether the snippet contains a small or large amount of text.

However, by far the easiest way to manage and edit snippets is to organize them in a

'snippet project' of their own, for which Help+Manual Professional is required (see further

above on this page for more details). In addition to this, you can also manage snippets in

a style repository project .

Create a snippet project (Professional and Floating license ver-

sions only):

See the instructions further above on this page for more details on this.

· Create a new Help+Manual project and save it in an empty folder in uncompressed

XML  (HMXP) mode. Note that this save option is only available in the Professional

and Floating license versions of Help+Manual. 

· Create new snippet files by creating new topics in the snippet project, or create the

snippets in another project and save them to the /Topics folder of the snippets project.

· Add existing snippet files to the 'snippet project' by moving their XML files to

the /Topics sub-folder in the snippet project folder. The topics will then appear in the

Topic Files section of the snippet project. You can create TOC entries for them for easier

organization by dragging the topic files into the snippet project TOC from the Topic

Files section. 

Create a style repository project (Professional and Floating license

versions only):

In addition to "normal" snippet projects you can also manage snippets in a "style reposit-

ory", which is a special kind of Help+Manual project for managing reusable topics and

styles. See Working with Style Repositories  for full details on this.

Editing small snippets stored as individual files:

1. Press ENTER a couple of times to create some space in the current topic. 

2. Insert the snippet file you want to edit in Copy & Paste mode (see above) and make

the necessary changes.

3. Select the edited text and export it as a snippet, overwriting the original snippet file

(see above).

1076

126

1076



202

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

Editing larger snippets stored as individual files:

1. Create an empty dummy topic in the TOC. 

2. Select File > Load Topic from File in Project > Manage Topics and load the snippet

file. 

3. Edit the content and then select File > Save Topic to File and overwrite the original

snippet file. 

Hyperlinks to anchors in linked snippets

If a linked snippet contains an anchor (jump target) you can link to it from other topics.

However, since the snippet file is not really inserted in the current topic you cannot select

the anchor from the drop-down list next to the Target: field in the Insert Hyperlink  dia-

log. You need to enter the anchor name manually.

1. Make a note of the name of the anchor you want to link to. 

2. Create a normal hyperlink to the topic containing the linked snippet.

3. Double-click on the hyperlink to edit it and type in the name of the anchor in the

drop-down list box next to the Target: field.

4. Publish your project and test the link to make sure that it works.

You won't have this problem with snippets inserted in Copy mode because the text con-

taining the anchor is inserted in the topic directly.

Checking where a snippet topic is used

You can use the Find Referrers function to check where a topic file is being used as a

linked snippet. You can also use the same function to find the location of the linked snip-

pet topic files inserted in the current topic. 

This only works for topic files used as snippets in the current project. It won't work across

multiple projects or for XML files that are not part of projects.

1. In the Project Explorer select the topic file – either a file containing a linked snippet or

a file that you think is being used as a linked snippet. 

2. Select Find > Find Referrers in Project > Manage Topics (or just right-click and select

Find Referrers).

3. The sources of linked snippets in the topic are shown as incoming links. Topics in

which the topic is used as a linked snippet are shown as outgoing links.

1352
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Keywords in snippets

If snippet files are H+M topic files containing index keywords the keywords are imported

when you use Link mode. A-keywords are not supported in snippets, however.

Keywords are not imported with snippets in Copy & Paste mode. Small snippets saved

from selected text do not include keywords – that is only possible when you save an entire

topic as a snippet.

See also:
Multiple TOC entries for one topic

Snippets and multiple TOC references

Topic include options  

Anchors - jump targets

5.4.10 Using HTML page templates

In HTML-based output formats the layout of topic pages in your output is defined in an HTML

file called an HTML page template. 

This template exists in your project but the project version is normally not used because you

will almost always publish to these formats using a skin. Then the template used in the skin is

used, and this will have been configured appropriately by the skin designer. 

If you are designing a skin yourself you can find the template in the same location as de-

scribed below, but in the .hmskin skin file instead of in your project. If you are editing one of

the standard skins included with Help+Manual you always need to make a copy of it in your

project folder to be able to edit it. You can then open it in Help+Manual by selecting .hmskin

as the file type to open in the Open dialog. All the components in skins are in the same loca-

tions as in normal Help+Manual projects.

Kindle and ePUB use a special template generated by Help+Manual that is only stored in the

project. It is available in Configuration > Publishing Options > eBooks > ePUB + Kindle:

Page Template.

Topic and header background colors

In all HTML-based output formats except ePUB and Kindle eBooks the background colors

of the topic and topic header are defined in the HTML page template if you are not using

a skin to publish your output. 

If you are publishing with a skin, the templates in the skin are used and the templates in

the project are ignored.
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If you are publishing with a skin:

If you are publishing your project with a skin you do not normally need to edit anything.

The topic header and body background colors will have been set appropriately by the skin

designer. If you design your skin yourself you can edit the background colors in the HTML

Page Template in the .hmskin skin file the same place as in a project (see below). 

If you are not using a skin:

If you are using the templates stored in your project the topic and header background

colors are defined in your page template and are also automatically displayed in the

Help+Manual editor. 

· In the Project Explorer go to Configuration > HTML Page Templates > Default and set

the background colors for the topic and topic header.

· If you edit the HTML code of the template manually you can also set the header and

background colors manually. The topic background color is set in the <body> tag, the

header background color is the background of the main table in the section defined by

the <IF_TOPIC_HEADER> condition. 

Navigation link texts or buttons

By default every topic in HTML-based output formats has Top, Previous and Next naviga-

tion links. These links can be deactivated and edited in the HTML page template and re-

placed with icons. 

If you are publishing with a skin:

If you are publishing your project with a skin you do not normally need to edit anything.

The navigation links will have been set appropriately by the skin designer. If you design

your skin yourself you can edit the navigation links in the HTML Page Template in the

.hmskin skin file the same place as in a project (see below). 

If you are not using a skin:

If you are using the templates stored in your project the navigation links are defined in

your page template. 

· In the Project Explorer go to Configuration > HTML Page Templates > Default and

edit the settings for the Top, Previous and Next Links in the Simple Template Layout

tab.
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· If you edit the HTML code of the template directly you are completely free to make any

additions you like. For example you could create icon buttons with mouseover effects

and so on.

If you use icons for your navigation links it is a good idea to add the icon files to your

Baggage Files in the Project Files section of the Project Explorer. This will ensure that the

icons are exported correctly when you publish your output. 

Disabled Simple Template Layout tab:

The Simple Layout tab will be disabled as soon as you edit source code to prevent acci-

dental deletion of your custom code. It can only be re-enabled by clicking on the Reset

Template button. This will delete the edited code and replace it with the standard tem-

plate.

Adding headers and footers to your pages

If you are publishing with a skin:

If you are publishing your project with a skin you do not normally need to edit anything.

Any headers and footers will have been set appropriately by the skin designer. If you

design your skin yourself you can edit the navigation links in the HTML Page Template in

the .hmskin skin file the same place as in a project (see below). 

If you are not using a skin:

You can also add "headers" and "footers" to your HTML page templates to display stand-

ard text, icons, logos or links above or below the main body of your text on every topic

page.

Simple template layout tab:

1. In the Project Explorer go to Configuration > HTML Page Templates > Default and

select the Simple Template Layout tab. 

2. Insert text for your header or footer in the Text Above Topic or Text Below Topic

boxes. You can also use HTML code, CSS formatting and JavaScript.

HTML source code tab:

If you have experience with editing HTML you can also edit the HTML code directly. 

1. In the Project Explorer go to Configuration > HTML Page Templates > Default and

select the HTML  Source Code tab. 
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2. The topic content from your project is inserted in the template with the <%

TOPIC_TEXT%> variable. Everything directly above this variable is a "header",

everything below it is a "footer".

See Using HTML Templates  for more details.

Defining and using different HTML templates for individual topics

By default every topic you create is associated with the Default template. You can also cre-

ate additional HTML page templates with different settings and apply them to individual

topics – for example to use different topic and header background colors or different nav-

igation buttons etc. in some topics.

If you are using a skin:

If you are using a skin you must define additional HTML page templates twice: Once in

your project and once in the .hmskin skin file. The contents of the copy in your project

are irrelevant – it only needs to have the correct name, so that you can select it. The

second copy in the skin file has the actual content that is used, and it must have exactly

the same name as the additional template in your project. 

Creating new HTML templates:

1. Open the project (if you are not using a skin) or the .hmskin skin file (if you are using

a skin) in Help+Manual. In the Project Explorer go to Configuration > HTML Page

Templates > Default and click on the Add button. 

2. Enter a name for the template and click OK. 

3. Edit the code of the template as you wish.

Applying HTML templates to individual topics:

1. In the Project Explorer select the topic you want to change. 

2. Select the Topic Options tab to the left of the main editor window, then select the

template in the HTML Page Template: field. 

See also:
Help window settings

Using HTML templates
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5.4.11 Creating popup topics

Popups are mini topics used to display a small amount of information in a small "popup” win-

dow, which is normally displayed when the user clicks on a link. Popups are used both in the

help text itself and in applications, where they are referred to as "field-level popups". 

Natively, field-level popups are a special Microsoft technology that is only supported in HTML

Help CHM files. However, the responsive skins in the Premium Pack 3 add-on for

Help+Manual also add field-level popups for WebHelp.

Topics used as popups should be created in the Project Files section so that they do not have

TOC entries. For more details on field-level popups see Using Context-Sensitive Help  and

Context-Sensitive Help and Popups .

Key Information
You must create popup topics in the Topic Files sec-

tion, not in the TOC section! You cannot assign the

Popup topic class in the TOC.

How to create a popup topic

1. Open the Project Files section In the Project Explorer and click on Topic Files, or a sub-

folder if you have created one and want to use it (see Creating new topics in Topic

Files  for more details).

2. Click on Add File in the Project tab to create a new topic.  

3. Select Popup In the Topic Class: field. Note that you cannot select this class when cre-

ating topics in the TOC. You can only do this for topics accessed from within the Topic

Files section!

4. You must enter a context number if you want to use your popup topics as field-level

popups  displayed in your application in CHM files without the main help. This is re-

quired by the Microsoft HTML Help API for field-level popups and if your popup topics

do not have help context numbers they will not be exported to the internal popup text

file in the CHM it. 

(See the Premium Pack help chapter for details on using field-level popups in WebHelp

with Premium Pack 3 skins. )

The HTML Template and topic header settings are irrelevant for these topics because

popups do not use HTML templates or headers. When you create hyperlinks to popup

topics  in your help they will automatically be displayed as popups. 
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See Using Context-Sensitive Help  for information on calling popups directly from your

application. See this topic  for instructions on creating field-level CHM popups dis-

played in your application.

Configuring your output formats to use popups

How popup topics are handled depends on your output formats. If you want popups in

HTML Help CHM files and WebHelp you must activate JavaScript popups, otherwise links

to popup topics will be displayed as normal topics. 

HTML Help's native plain-text popups are very limited and they are not supported within

the main help. You can only use them in field-level popups  that are displayed in your

application without the main help file. Normal JavaScript popups can be used as field-

level popups in WebHelp if you are using the Premium Pack 3 responsive skins. 

HTML Help and WebHelp:

In the Project Explorer select Configuration > Publishing Options > HTML Help/We-

bHelp > HTML Export Options. The settings are at the bottom of the page. The settings

are shared for both formats

· Export popup topics as JavaScript popups

This enables JavaScript popups  for both HTML Help CHM files and WebHelp. If you

want to use popups within your help in these formats you must enable this option.

Popup links in the project's topic files will be displayed as JavaScript popups in both

formats when this option is activated. If it is turned off, popup links will display the tar-

get topics as normal topics. You can still use plain-text field-level popups  in your ap-

plication in HTML Help CHM files because the plain-text popup file is always included in

the CHM, even when JavaScript popups are activated. 

· Customize popup appearance

Select this to configure the formatting, colors and behavior of your JavaScript popup

topics.

JavaScript popups are generated by Help+Manual. They support formatting, links and
graphics but they cannot be used as field-level popups. They can only be displayed within
your help file by other links in your help file.

Native CHM plain text popups are only available in HTML Help CHM files and can only
be used as field-level popups  that are displayed directly in your application without the
main help. They only support plain text without any formatting, graphics or links. They
cannot be 
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Popups in eBooks:

Windows eWriter Help files have exactly the same popup support as WebHelp. Popups

are not supported in ePUB or Kindle Mobi eBooks.

Controlling the width of popup topics

Controlling popup width in HTML Help field-level popups:

· In HTML Help's plain text popup topics the only way you can control popup width is by
entering a hard line break (ENTER) at the end of each line. This popup format is only
used in field-level popups .

Controlling popup width JavaScript popups:

· In JavaScript popups  you can control popup width precisely by entering the entire
text of the popup in a single-cell table with a fixed width.

· You must set the width of the single-cell table you use for this to an absolute value in

pixels. Select Size Table Manually and enter the value in pixels. Don't use percentage

values for this!

You can speed up the process by defining a topic content template for your popup topics

or using snippets. See Content templates for topics  and Re-using content with snip-

pets  for details.

Linking to popup topics to display them

Any link within a project to a topic defined with the Popup class will automatically be dis-

played as a popup in any of the output formats where popups are supported (HTML Help,

Windows eWriter Help and WebHelp with JavaScript popups activated). Just create a nor-

mal link  to the topic. Popups are not supported in ePUB or Kindle eBooks.

Popups in secondary TOCs

When you use popup topics in secondary TOCs the popup topic files your links refer to

will not be included automatically as they are when you use the primary TOC. The All

Builds include option assigned to all topics by default only works automatically in the

primary TOC. 

When you are using multiple TOCs in your project and publishing a secondary TOC, any
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popup topics you link to must be included explicitly. You can do this in two different ways:

Option 1: Dead links handling options

Go to View > Program Options > Compilers and set the dead links handling option to Si-

lently include linked topic. This is the simplest solution but it will also automatically include

any excluded topic files that you may have referenced with regular topic links. So you

should always check your compiler report for topics like these that you may have not

wanted to include. You can then handle the links with conditional text  to exclude them

automatically. 

Option 2: Set the build options of your popup topic files

Alternatively you can set the build options of your popup topic files to the output formats

that support popups, which are WebHelp, CHM, eWriter, and Visual Studio Help (if you are

using that). The eWriter format will be included automatically if you set WebHelp, so gen-

erally you will only need to set CHM and WebHelp. 

1. Right-click on the popup topic file in Project Files > Topic Files and select Include in

Builds in the context menu. 

2. Set the include options to WebHelp, CHM and (if necessary) also VSHelp. 

3. Repeat for all your poup topic files.

984
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Where popups are supported

Output Format Supported Popup Types Where Supported

HTML Help (.CHM): Plain-text popups integrated
in the main help file.
Context numbers are
required for these popup
topics!

Formatted JavaScript
popups  stored in the
main help file.

Plain-text popups are only
supported as field-level
popups in applications. If
you want popups in the help
text you must activate
JavaScript popups.

Formatted JavaScript
popups can only be used in
the help text. They are not
supported for context-
sensitive help.

Browser-based HTML 
(.HTM):

Fully-formatted JavaScript
popups  integrated in the
individual HTML files.

JavaScript popups can only
be used in help topics. You
cannot link to them from
your application.

eWriter Help: Same popup options as
WebHelp

Same as WebHelp

ePUB and Kindle Mobi
eBooks:

Popups are not supported.
Popup links are
automatically converted to
plain text.

N/A

Adobe PDF and
printed user manuals:

Popups are not supported.
Popup links are
automatically converted to
plain text.

N/A

Word DOCX: Popups are not supported.
Popup links are
automatically converted to
plain text.

N/A

See also:
Using JavaScript popups

Using Context-Sensitive Help

Context-Sensitive Help & Popups  (Reference)

5.4.12 Using JavaScript popups

Productivity Tip
You can get more powerful JavaScript popups with the

Help+Manual Premium Pack, which also supports

field-level popups for WebHelp. See here for details. 

212

212

212

892

1586

https://www.helpandmanual.com/products_hm_pluspack.html
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JavaScript popups are used to display topics as popups in WebHelp and in HTML Help CHM

files. They are the only way to display popups in the help in these two formats. If you don't

activate JavaScript popups links to popup topics will display as normal topics in both these

formats. HTML Help has native plain-text popups, but they are only used for field-level

popups  displayed as context help within applications. 

If you are using the V3 Responsive skins in the Premium Pack 3 add-on, you can also use

JavaScript popups as field-level popups in WebHelp. 

Advantages: JavaScript popups create fully-formatted popups that can
contain formatted text (bold, italic, different fonts etc.) and
graphics. In HTML Help JavaScript popups are stored inside the
main CHM help file so that you only need to distribute one file.

Limitations: JavaScript popups cannot be used for field-level popups
called from and displayed in applications. They can only be
displayed within the help file. 

Note that activating JavaScript popups is a global setting for all the popup topics defined in
your project.

Using JavaScript popups in HTML Help, WebHelp and eWriter Help

Popups displayed in the help itself in HTML Help CHM files and WebHelp are only pos-

sible with JavaScript popups. These popups can also be used in eWriter Help, which can

be used as an alternative to CHM files for application help, and for help on Apple MacOS.

This popup technology will work both in the CHM viewer and in all current browsers and

should not cause problems with popup blockers. In addition to being blocker-transparent

the popups are also activated by the user, which is explicitly permitted by most blockers.

1. In the Project Explorer select Configuration > Publishing Options > HTML Help/We-

bHelp > HTML Export Options. WebHelp and HTML Help have separate settings. The

JS popup options for WebHelp are also used by eWriter Help.

2. Activate JavaScript popups at the bottom of the page, then click on Customize

JavaScript Popups to configure your popups. See below for details. 

3. Create your popup topic files  in the Topic Files section, selecting Popup as the

Topic Class. You can use all Help+Manual's formatting options, including tables, hyper-

links, formatted text, fonts, graphics, videos and animations. Just don't go overboard –

if your popups are too large and contain too many features they will not be very use-

ful!

4. Create normal topic links to your popup topics in your topics. The target topics will

automatically be displayed as JavaScript popups when the user clicks on the links in

the published help files.

1592
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207
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Configuring JavaScript popup options

JavaScript popups are configurable, with separate settings for WebHelp and HTML Help.

The WebHelp settings are also used for eWriter Help. 

These settings are ignored for WebHelp project popups and WebHelp field-level popups

in the Premium Pack V3 Responsive skins, which use their own integrated design for the

popup windows. 

1. Activate JavaScript popups in Configuration > Publishing Options > HTML Help/We-

bHelp > HTML Export Options. Note that the settings for HTML Help and WebHelp

are separate.

2. Click on Customize JavaScript Popups to display the configuration dialog:

Click/mouseover: Displays the popup on user click or mouseover (i.e. as soon as the

user moves the mouse pointer over the link). Be careful with using

the mouseover option as many users find this intrusive and it may

also trigger popup blockers in some browsers.

Border width: Enter 0 for no border, any value above 0 (in pixels) to draw a border

around the popup box.

Border padding: The distance between the popup content and the border or edge

of the popup (if there is no border) in pixels.

Background: The background color of the popup box.

Border color: The color of the border, if there is one.
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Rounded borders

and drop shadow:

These effects are only supported by modern browsers: Internet Ex-

plorer 9, Firefox 3.6, Opera 10.6, Google Chrome 10 or later.

See also:
Creating popup topics

Field-level popups for context help

5.4.13 Using field-level popups

Key Information
Field-level popups must have help context  num-

bers. Field-level popups are only exported if you as-

sign help context numbers to them! 

A field-level popup is a popup displayed directly from within your application. They are nor-

mally only available for Microsoft HTML Help CHM files.

Field-level popups for WebHelp

In their native form field-level popups are only supported by the Microsoft HTML Help

(CHM) format. This is the version described in this topic. However, the responsive skins

available in the Premium Pack 3 add-on for Help+Manual also add field-level popups for

WebHelp. Their use is explained in the additional help chapter titled Help+Manual

Premium Pack added to the main Help+Manual help when you install the Premium Pack.

(If you don't  have the Premium Pack installed this chapter will just display some intro-

ductory material.)

Introduction

In your Help+Manual project, the same popup topics are used for both purposes. When

you publish your project the content of the topics are automatically exported to a special

text file in the CHM for field-level popups, and to the JavaScript popups file for JavaScript

popups. 

The plain-text CHM popups are not available within the main CHM file, however. They are

only for field-level popups. You can only use JavaScript popups for popups displayed

within the CHM file.

· Normal popup topics are displayed within the help when the user clicks on a link in a

topic, for example to display a definition or an explanation. JavaScript popups must be

activated for this to be possible in HTML Help CHM files and WebHelp.

· Field-level popup topics are called directly by the application and displayed in little

windows of their own. This is done without displaying the rest of the help at all. Only

207
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the little popup is displayed, and it is closed again as soon as the user clicks on it.

About creating field-level popups:

Field-level popups are only supported in HTML Help CHM files. They are a proprietary Mi-

crosoft technology and they are not supported in any other output format.

To create field-level popups the help author needs to perform the following steps:

1. Create popup topics  so that you have popups to display. 

2. Assign help context numbers  to all your popup topics. This is essential because

field-level CHM popups must be called by their context numbers. If you don't assign

numbers the topics won't be exported to the plain-text field-level popups file!

3. Inform your programmer of the help context numbers and topic IDs and the name of

the internal plain text popups file so that they can make the calls. You can use the con-

text tool  to export a list of IDs and context numbers. 

The internal popups file is normally called CSHelp.txt but you can change its name in

the Extended .HHP Settings .

See Implementing context help  for more general information.

If you are writing field-level popups for an application you may have to produce a lot of

popups. You can save yourself a lot of work by generating your field-level popups auto-

matically .

Using both field-level popups and JavaScript popups

Only the CHM format's native plain-text popups can be used as field-level popups. If you

also want to display popups inside your CHM help file you must activate JavaScript

popups , otherwise links to popup topics will be displayed as normal topics. 

The native plain-text popups used in CHM cannot be used for displaying topics inside the

main CHM file, only for field-level popups. (This plain-text file is always exported, even if

JavaScript popups are turned off.) 

If JavaScript popups are activated, popup links in your project topics will display as JS

popups in the HTML Help viewer. However, since the plain-text popups file is also stored

in the CHM, calls to this file from your application will also work. 

See also:
Creating popup topics

Using Context-Sensitive Help

IDs, Context Numbers and Keywords
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5.5 Editing Topic Files

Entering, editing and formatting text in topic files in Help+Manual is very similar to working in

a modern word processor like MS Word. If you know how to use a word processor you

already have most of the skills you need to edit topics in Help+Manual. 

See also:
Text Formatting and Styles

Numbered and Bulleted Lists

Links and Anchors

5.5.1 Recently changed topics

When you are working on a project you will often want to access topics you have edited re-

cently again to continue working on them. Also, when you have updated your documentation

you will often want to provide your users with a linked list of topics that have been updated

or changed so that they can access them quickly. 

Links to recently-edited topics

Help+Manual automatically maintains a linked list of all the topics you have edited recently.

To access it, just select the project name at the top of the Project Explorer pane on the left

side of the Help+Manual window (see screenshot above).

273

313

409
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· If you don't see the linked list click on Refresh Details at the top of the screen to dis-

play it. Activate the Automatically start calculating... checkbox at the bottom of the

screen to display the list automatically.

· To edit recent topics just click on the links in the list.

· To get a linked list of recent topics you can use in your project click on the Copy Topic

List to Clipboard link. You can then paste this list into any Help+Manual topic.

5.5.2 Topic Options

The Topic Options tab is accessible on the left of the main editor window and contains a num-

ber of key settings for the topic currently displayed. It enables you to view and edit a number

of settings that are assigned automatically when you create topics, and some additional op-

tional settings.

<TITLE> tag: This is the text inserted in the <TITLE> tag in topic pages in HTML-

based output. By default this is the text displayed as the table of

contents entry displayed in the Project Explorer on the left. If you

edit the TOC entry this text changes automatically, unless you edit

this field in Topic Options manually.

If the topic header text in the box above the editor is different from

the TOC entry, the TOC entry is shown here and not the topic

header text. (Again, only if you didn't edit the title tag text manu-
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ally.)

Topic ID: The address of the topic. This is used for referencing topics for links

etc. and it is also used for generating the file names of HTML files

generated for topics in HTML-based output formats.

You can change the topic ID by editing this entry. When you do

this, all the references to the topic within your project are updated

automatically. 

External references to the topic from other projects and other web

pages linking to your WebHelp cannot be updated from within

Help+Manual. They will become invalid if you change the topic ID

and must then be updated. 

Anchor: Target of the TOC entry for the topic. Normally this is the top of the

topic, but if there are anchors defined in the topic you can select

one here. Then the TOC entry will scroll down to the anchor when it

is selected.

This option is normally only used for topics with multiple TOC

entries . Then each entry can link to the appropriate part of the

topic. Don't let this possibility tempt you to make excessively long

topics – that is generally a bad idea. Normally, it is much better to

have a separate document for each topic.

Topic class: There are two possible classes: Default and Popup. Most topics will

be default topics. The popup class can only be selected for topics

that don't have TOC entries, because popup topics are not allowed

to have TOC entries. See Creating popup topics  for details. 

Help context: Optional numeric context IDs for use in Microsoft HTML Help/CHM

files. You only need these if your programmers are using context

IDs for references from your application to the CHM help file. See

the chapters on context sensitive help  and the Help Context

Tool  for more details.

HTML Page Tem-

plate:

This selects the HTML layout template to be used for this topic in

HTML-based output formats. Normally this will be the standard De-

fault template. You can only select additional templates here if you

have defined them yourself . 

Topic Status: This just provides another way to select and set the status for the

current topic  displayed in the table of contents in the Project Ex-
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plorer on  the left. This is design-time only – the status is not expor-

ted to your output. 

Keywords: The index keywords associated with the topic. You can enter them

directly here or centrally with the Index tool  (Professional and

Floating license versions only).

A-Keywords: These are special "associative" keywords that are only supported in

the Microsoft HTML Help/CHM help format. See this topic  for

more details on this.

Description: An optional description of the topic. This has two uses:

1. Source for the description meta tag  for search engine

optimization in WebHelp. 

2. Future use for alternative table of contents layouts with de-
scriptions and images as well as titles.

Featured image: This allows you to associate an image with the topic that can then
be used in topic templates and PDF title pages for chapters. 

In HTML templates you can use the TOPIC_PICTURE  variable
to insert the images in your templates. 

See the help of the Print Manual Designer program for details on
how to use the featured images to create title pages for chapters in
PDF output.

Topic variables: This table can be used to change the definition of user-defined or

global variables for the current topic only. See this topic for de-

tails .

5.5.3 Topic History - Previous Versions

Help+Manual can archive every previous version of every topic whenever you save your help

project. It can be an alternative to version control systems  for individual help authors. It al-

lows you to compare multiple versions of a topic and refer to or revert to a previous version if

you find that you or another author has made changes that you want to undo.

Activating topic history

Topic history needs to be activated in each project where you want to use it. You can ac-

tivate this option in Configuration  > Common Properties > Miscellaneous . 
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IMPORTANT: You cannot use topic history if you are using version

control

Note that you cannot activate topic history in projects linked to version control systems.

This is also not necessary, because then the entire history of your project is stored in the

version control system.

Viewing topic history

To view and compare previous versions of the current topic select Show History in the

topic menu in the top left corner of the topic editor window:

Comparing and reverting

When you display the history you see the previous versions on the right. You can select

which version you want to view with the menu above the history display on the left. You

can revert the current topic to the displayed history version with the option on the right.
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Deleting topic history

You can delete the history of the current project in Configuration > Common Properties

> Miscellaneous. For example, if old versions contained sensitive information you may

want to delete the history before sending a copy of the project to someone.



223

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

5.5.4 Word and Character Count

Word count for a single topic:

Select the topic, then select the Word Count tool in Write > Font.

Word count for the entire project:

Select the Report tool  in the Project tab and choose the Full Report option. This will in-

clude a word and character count at the end of the report, and individual word counts for

each topic.

You can include/exclude topics in/from the entire report and the word count by selecting

or deselecting Include Options  and the other filtering options in the report dialog

(topic classes, topic status, modification date range).

5.5.5 Writing and formatting text

For more detailed information on formatting text see Text Formatting and Styles .

The editor tabs and the header box

The editor:

The Help+Manual editor has two or three tabs, depending on the version of Help+Manual

you are using:

1212
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· The Page Editor tab is where you edit the content of your topic files. This is basically

just like a normal word processor. You can enter text, copy and paste, apply styles, in-

sert images etc. You can also use special help authoring features that a word processor

does not have. 

· The Topic Options  tab provides access to settings that are saved separately for each

individual topic, including index keywords assigned to topics. 

· The XML tab (Professional and Floating license versions only) allows you to view and

edit the XML source code of your topic. If you don't understand what you see here just

ignore it!

The topic header area:

The area above the main editor window contains the topic header. This  corresponds to

the header of topics in help files and supplies the titles of topics for PDF and other printed

formats. By default, the header box contains the same text as the topic caption in the

Table of Contents but you can add additional text if you like. You can also insert graphics,

hyperlinks etc., but such additional content is not used in all output formats.

Multiple topic tabs:

You can edit multiple topics in multiple tabs. Right-click on a topic in the TOC on the left

and select Open Topic in a New Tab to open an additional tab. This makes it easy to refer

to or edit additional topics and not lose your place in the main topic you are working on. 
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Editing and formatting tools

The editing and formatting tools are grouped in the Write tab of the Ribbon. Many of

these tools can also be selected with keyboard shortcuts. Select Program Options in the

View tab of the Ribbon to view and change all available keyboard shortcuts.

Applying formatting and copying, cutting and pasting work in the same way as in any

modern word processor. 

· To format existing text manually you must first select it and then apply the formatting,

using a formatting tool or a style. 

· If you select a formatting tool without selecting text (font, bold, underline, color, back-

ground color etc.)  it will apply from the cursor position onwards if you continue typing. 

· To delete the word to the left of the editing cursor press Ctrl+Backspace.

· Use the Format Painter  tool in the Clipboard group (Write and Project tabs) to copy

formatting. The Format Painter works in the same way as similar tools in word pro-

cessors. Click once to select and use once, double-click for multiple use, click again or

Escape key to turn off.

· See Text Formatting and Styles  for detailed information on formatting text and using

styles. 

· See Special characters, lines and breaks  for inserting typographic quotes and other

special characters.

Editor zoom and preview mode for screen/print styles and font sizes

You can zoom the entire contents of the editor quickly with the Zoom control in the status

bar below the editor window. This control is also available in the View tab in the ribbon

toolbar.
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You can also switch the editor display between the styles defined for electronic help

formats (HTML Help, WebHelp, Visual Studio Help and eWriter Help) print-style help

formats (PDF, printed manuals, Word DOCX and ePUB and Kindle Mobi eBooks). 

This will only have an effect if you have defined different settings for screen and print out-

put in your style definitions. See Multiple style sets  for more information on using dif-

ferent style sets for different output formats.

Display buttons in the status bar:

How to protect text against editing

Sometimes you want to make sure that text will not be changed or translated, particularly

when you are working on a project in a team. 

· Select the text you want to protect, then click on the  Protect Text tool in Write >

Font. 

The text will be displayed with shading in the editor to show that it is protected. In the

XML file it will also be tagged with a translate="false" attribute to inform the translator

that you do not want it to be translated.

Navigating in the editor

Zoom editor: Use the Zoom control in the status bar below the editor or in

the View tab of the ribbon toolbar.

302



227

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

Go to hyperlink: Hold down Ctrl and click on the link (double-clicking on

links opens the link editing dialog).

Word left/right: Ctrl+Cursor Left/Right 

Next/previous topic: Ctrl+Cursor Up/Down 

Other nav. controls: PgUp, PgDown, Ctrl+Home, Ctrl+End

Edit history: The   buttons in the Quick Access Toolbar navigate

through the sequence of topics you have edited in the cur-

rent session. 

Double-click, triple click: A double-click selects a word, a triple-click selects the entire

paragraph.

Keyboard shortcuts: Select Program Options in the View tab for a full list of all

available keyboard shortcuts. You can change the shortcuts

and assign your own shortcuts to most of Help+Manual's

functions.

Display paragraph marks: Click on the  tool in Write > Paragraph or select Program

Options in the View tab and activate Display paragraph and

text marks in the Editor tab.

Preview Windows

large/small fonts settings:

Click on the 96/120 DPI button in the status bar at the bot-

tom of the program window to  emulate Windows' small and

large font modes in the editor. This is useful for making sure

that your layouts will work correctly with both settings. 

Show Screen/Print styles

in the editor:

Click on the Screen/Print button in the status bar at the bot-

tom of the program window to switch between the style

definitions for screen output (electronic help files) and print

style output (PDF, printed manuals, Word DOCX). This will

only show any changes if you have actually defined different

styles for screen and print output.

See Multiple style sets  for more details on this subject.

The XML Source editor

This tab is only available in the Professional and Floating license versions of Help+Manual

 and it is designed for advanced users only. 

Please don't edit anything in this tab unless you have plenty of experience in XML editing

and understand all the code. XML syntax is very strict and unlike HTML not even a single

mistake in the code is permitted! If you enter incorrect code Help+Manual will perform a

302
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syntax check and delete it automatically (and silently!) when you return to the main editor

window.

You can find a detailed reference to the Help+Manual XML syntax in the Help-

man_XML_ref.chm file in the Help+Manual program directory.

See also
Formatting text manually

Text Formatting and Styles

Editing XML source code

5.5.6 The paragraph end mark

If you're used to working with a word processor like MS Word you will find that editing in

Help+Manual is different from a word processor in some ways. It's just as powerful, but the

way it stores text formatting is different, and you need to understand this.

The paragraph end mark does not store any formatting!

Word processors like MS Word store paragraph styles and formatting in the paragraph

end mark. In word processors like this you can format a paragraph by selecting the end

mark and applying formatting. Also, if you delete the paragraph end mark in these word

processors the formatting of the entire paragraph will be deleted. This does not happen in

Help+Manual.

You cannot select or format the paragraph end mark!

Help+Manual's paragraph end marks don't store anything, they are just carriage returns

marking the end of the paragraph. Instead, the formatting is associated with the entire

paragraph. Since the paragraph end mark contains neither formatting nor any other in-

formation you cannot select it or format it. 

Formatting is associated with the text

In Help+Manual formatting is associated directly with the text and the entire paragraph.

When you apply formatting to text it is associated with every letter of the text. When you

apply a style  to a paragraph in it is associated both with the entire paragraph and with

every letter of the text it contains. 

When you copy text all its formatting goes with it!

You will see this, for example, if you copy a passage of text from one paragraph to an-

other. If you then put your cursor in the copied text and look in the style selector  in the

toolbar you will find that it still has the attributes of the source paragraph. (You can pre-
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vent this behavior by using the   Paste as Text  tool in  Write > Clipboard or

Ctrl+Shift+V.)

Paragraph formatting attributes are only copied if you copy an entire paragraph, including

all the text in the paragraph down to the beginning of the next paragraph.

It's a slightly different way of working

Once you get used to it you'll find that it's quite intuitive and also has its advantages. For

example, unlike Word you can't accidentally delete the formatting of an entire paragraph

by pressing DEL or BACKSPACE. If you ever accidentally join two  paragraphs you just

need to press ENTER to separate them again.  You may need to adjust the paragraph

formatting or reapply a style  to adjust the paragraph formatting, but that's it. 

When paragraphs are joined the program automatically uses the paragraph attributes of

the upper paragraph in the text, because a paragraph can't have two sets of paragraph

settings.

5.5.7 Topic Headers

By default, new topics always have a "header", displayed in a separate editing box above the

main topic editor. You can turn the header off with the options menu in the top left corner of

the editor window if you want. This turns off the header for the current topic. 

Initially, this header contains the title of the topic, formatted with the standard Heading1 style

and with the background color set in the HTML topic page template. You can also add other

content, including graphics, hyperlinks etc. 

Header formatting, background colors and additional content are only supported in electronic

help formats (HTML Help, WebHelp, eBooks and Visual Studio Help). ePUB eBooks have lim-

ited or no support for additional content. In print-style formats (PDF, DOCX, printed manuals)

only the plain text from the header is exported when you publish and the formatting is

defined separately

1324
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How to format the header text and background

Formatting the header text:

By default the header text has the standard Heading1 style. The easiest way to format your

header text is to edit this style in Write > Styles > Edit Styles. Then all new headers will

automatically have the selected formatting. You can format headers manually by selecting

the text and using the formatting tools in the Write tab if you want, but then you must do

this separately for every single topic.

Setting the header background color:

In most electronic output formats the header background color is defined by the HTML

topic page template. 

Important: Edit in the skin file if you are using a skin!

If you are using a skin to publish this is defined in the topic page template in the skin

file, not the template in your project. Make a copy of the .hmskin skin file in your pro-

ject folder to edit it. Then open it in Help+Manual by selecting .hmskin as the file type

to edit in the Open dialog. The template is in the same location as in a normal project

file.

In the Project Explorer go to Configuration > HTML Page Templates and select the De-

fault template. Then you can set the background colors for the header and the topic body.

The background colors you set in the template are automatically displayed in the editor. 

See Background colors and help viewers  for more details on this.

How to turn off the header

To turn off the header for a topic deactivate the Topic has a separate header option in the

options menu at the top left corner of the editor window. This will create a topic without a

header in your published output.

142
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Warning: Turning off the header deletes any additional content you have added to the

header box. If you turn the header on again the box will only contain the standard topic

title, taken from the topic's TOC entry. The content will not be lost while you are still edit-

ing the current topic (you can restore it by reactivating the option) but once you leave the

current topic it will be deleted permanently.

Additional content in the header

You can insert any content in the topic header box that you would normally insert in the

main body of the topic, including graphics, hyperlinks and so on. This content will be pub-

lished with the header in electronic formats (HTML Help, WebHelp, eBooks and Visual Stu-

dio Help) but not in print-style formats (PDF, DOCX, printed manuals). 

Note that content added to the header will only be displayed in the current topic. If you

want to include the same content in every topic (for example a logo) you need to edit the

HTML topic page template and add the content to the header section of the template. See

Using HTML Templates  for more details. 

If you want to include additional with your headers in PDF and printed manuals you need

to add it to the header definitions in the print manual template – see PDF & Printed

Manuals  for details.

Topic headers in PDF, DOCX and printed manuals

The topic header and its formatting and background color are not exported or used in

PDF and printed manuals. In these formats, only the plain text topic title is exported, the

formatting is applied with the print manual template for PDF and printed manuals (which

use the same PDF templates).

In PDF you can use either the TOC topic title or the text from the topic header (if it is dif-

ferent). This is done by selecting either the <%HEADINGx%> variables in the template for

the TOC topic title or the <%HEADINGLONGx%> variables for the text from the header box

1026
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in your template in Manual Designer.

See PDF & Printed Manuals  for details on accessing and editing print manual tem-

plates for PDF.

In Word DOCX the heading style from the header are used in the body text of the DOCX 

document, but the styles of the entries in the TOC at the beginning of the document use

the Heading 1 ... Heading 9 styles defined in your DOCX template. 

See MS Word DOCX  for details on configuring your DOCX output for publishing.

See also:
Background colors and help viewers

Using HTML Templates

PDF & Printed Manuals

5.5.8 Selecting text and content

This topic outlines the different ways you can select text and content in the Help+Manual ed-

itor. You can use both the mouse and key combinations. 

Selecting with the mouse

Select a block of

text:

Click and drag. Or click in the editor, hold down Shift and then

click at the end of the text you want to select. 

Select a single

word:

Click and drag or double-click on the word.

Select a single

line:

Click to the left of the line in the margin of the editor.

Select a para-

graph:

Triple-click in the paragraph or click and drag from the beginning

of the paragraph to the end. 

Selecting graph-

ics:

Click once on the graphic.

Hyperlinks: Click once to select and edit link text, double-click to edit link prop-

erties.

Ctrl+Click navigates to the link target topic.

Selecting a table: Position the mouse pointer just to the left of the table and left-click.

For more details see Selecting and formatting cells and tables .
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Selecting with key combinations

Select by word: Hold down Shift+Ctrl and press right or left cursor arrow.

Select by screen: Hold down Shift and press PgUp or PgDown.

Select everything: Press Ctrl+A or select Edit > Select All.

Keyboard short-

cuts:

Click on View > Program Options and then select the Shortcuts tab

to view and edit all the keyboard shortcuts available in the pro-

gram. 

See also:
Selecting and formatting table cells and tables

5.5.9 Copying, cutting and pasting

Copying, cutting and pasting text and other content in Help+Manual is exactly the same as in

a modern word processor. Just select what you want to copy and then use the standard

cut/copy and paste commands. 

See Moving, cutting and pasting topics  for details on working with entire topics.

How to cut, copy and paste text and content

First select the text or content you want to copy. You then have two options:

Dragging:

· To move the selected text just drag without pressing any keys.

· To copy the selected text hold down Ctrl and drag.

You can use Drag & Drop within topics but not from one topic to another within the same

project. This is because dragging selected text onto a topic entry in the TOC creates a

link  to that entry! To use Drag & Drop between two separate projects you must open

the second project in a second instance of Help+Manual.

Using the Copy, Cut and Paste commands:

The Copy, Cut and Paste commands work just as they do in any normal word processor.

They are available in several places: 

· Keyboard shortcuts: Ctrl+C (copy), Ctrl+X (cut), Ctrl+V (paste)
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· Write and Project tabs in the Ribbon (Clipboard group)

· Context menu: (right-click)

Copy as plain text

Select the Paste Text tool in Write > Clipboard or press Shift+Ctrl+V to copy the contents

of the clipboard as text only, without any formatting or styles. 

This is useful when you are copying text between paragraphs with different styles or from

another application like MS Word.

Paste HTML

The Paste HTML tool in Write > Clipboard converts HTML code in the clipboard to

formatted Help+Manual text as you paste. 

Copying from MS Word and other Office applications

Copying from and to MS Word:

You can copy and paste fully-formatted text both from and back to MS Word. Virtually all

formatting is supported, including tables (but not text boxes). 

Copying tables from and to MS Excel:

You can also copy tables directly from and to MS Excel. In some cases you may find that

you get better results if you copy via MS Word: First copy the table from Excel to Word,

and then from Word to Help+Manual. Similarly, to copy a table from Help+Manual to Ex-

cel, copy it to Word first and then to Excel. 

Copy as plain text

Select the Paste as Text tool in Write > Clipboard or press Shift+Ctrl+V to copy the con-

tents of the clipboard as text only, without any formatting or styles. .

Copying between projects

You can copy, cut and paste text between projects in exactly the same way as within a

project. Just open the second project and copy and paste between the two projects. See

Using the Project Explorer  for help with working in the Project Explorer.70
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You can't use Drag & Drop to copy text from topics between different projects if the pro-

jects are both open in the same instance of Help+Manual. However, if you open

Help+Manual a second time you can use Drag & Drop between two projects.

Copying project settings between projects:

You can copy Project Configuration  settings from from one project to another. You can

copy individual groups of settings or entire settings sections. Note that this will overwrite

your current project settings with the new settings!

1. Open the project you want to copy settings to. 

2. In the Project Explorer select the Configuration section and click inside the section

containing the settings you want to copy from another project – for example Title &

Copyright in Common Properties:

3. Click on Copy Properties From... at the bottom of the dialog and select the .hmxz or

.hmxp project file containing the settings you want to copy.

Warning: This will overwrite your current project settings with the settings that you copy!

4. In the dialog that appears choose This Page Only to copy only the settings of the se-

lected page or Copy Section to copy all the settings in the current section.

See also:
Moving, cutting and pasting topics

Project Configuration

5.5.10 Searching and replacing

The functions for finding and replacing text in Help+Manual are very similar to the compar-

able functions in word processors, with some additional options for the special requirements

of help projects. 

In addition to this the program also has powerful functions for locating individual topics by

their topic IDs and their context numbers, and for locating "referrers", i.e. topics containing

links to the current topic or topics.  

Productivity Tip
The Search function is also available in the XML Source

editor tab (Professional and Floating license versions

only) and all HTML editor windows for HTML tem-

plates and other editing windows. Just right-click in

these editor windows to access.
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How to find and replace text

1. Select Write > Editing > Find & Replace… or press Ctrl+F. 

2. Enter your search text and choose your options. These are self-explanatory and are

very similar to all search and replace functions in all modern word processors.

Find where:

Topic Keywords searches for index keywords you have associated with your topics.

Image File Names changes the filenames of graphics file references in your projects so

that they refer to files with different names. See below for details. 

Captions searches in TOC captions (the Topic Title field in the Topic options tab below the

main editor window). Note that replacing  this text does not change the name of the topic

in the TOC or the header in the header box above the editor. Instead, it "uncouples" the

topic title attribute from the other two texts, giving it a different value. 

Table of Contents searches in the TOC in the Project Explorer (search only, no replace).

Conditional Texts searches and replaces the tag names in conditional text build tags. See

Conditional text include options  for details on how these tags work and how they are

used.

How to find and replace variables and conditional tags

Variables:

Note: This only works for variables that have been typed in manually. You can't use the

search function to locate variables inserted with the Variable tool in Write > Insert Object.

1. Select Find & Replace in the Edit menu and set the scope of your search (current topic,

all topics etc). 

2. To search for a variable or replace text with a variable enter:

<% + VARIABLENAME + %>

For example if your variable is called DEMOBUILD you would type:

<%DEMOBUILD%>

When you insert or replace variables with Find and Replace the variables are not high-

lighted in the topic text. This is exactly the same as typing in variables manually  – the

variables are still fully functional, they are just not highlighted in the text. (The highlight is

994
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just an editing convenience to make the variables easier to see.)

Conditional tags:

1. Select Find & Replace in the Edit menu and set the scope of your search (current topic,

all topics etc). 

2. Select Conditional Texts as the type of search to perform.

3. Enter the conditional tags you want to search for, including the commas if you are

searching for tags with multiple conditions.

Examples:

Find what: CHM,HTML

Find what: USER1

Find what: PDF,NEWBUILD,HTML

How to find and replace images

Images are referenced with their file names only so you can "replace" them with other im-

ages by replacing their file names in your topics. Help+Manual finds the image files by

searching through all the folders in your Project Search Path  so if the file name you use

is in one of those folders Help+Manual will be able to find it.

1. Select Write > Editing > Find & Replace… or press Ctrl+F. 

2. Select Image File Names in the Find Where section.

3. Enter the exact name of the image file as the search and replacement texts, including

the file extension, for example: main_screen.bmp.

4. Choose your other options. These are self-explanatory and are very similar to all

search and replace functions in all modern word processors.

Tip: Changing image type

You can change the type of image used by searching and replacing the file name exten-

sion. For example, if you have replaced all your PNG files with BMP files of the same name,

you would just need to replace all instances of .png in image file names with the .bmp

extension.

How to find topics by ID or context number

1. Select Project > Manage Topics > Find >  Find Topic 

2. Select Topic ID or Help Context Number.

514
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Find topics that link to the current topic

You can find links to the current topic with the Find Referrers function, which also shows

which topics the current topics links to. 

Links to and from the current topic:

· Select Topics > Manage Topics > Find > Find Referrers 

OR

· Right-click on a topic in the TOC and select Find Referrers in the context menu.

Selecting Find Referrers for a chapter in the TOC will display the referrers for all the topics

in the chapter. You can also use this function for multiple topics. Just select two or more

topics in the TOC before selecting the function. Note that this function will only find links

to the current topic or topics in the current project! You cannot use this function to locate

links to the topic in other projects or help files. 

Finding links in all topics:

· Select Project > Tools > Report Tool and select either Long Report or Full Report mode.

The report will include lists of all outgoing and ingoing links in all topics in your project. 

See also:
Find & Replace  (Reference)

Find Referrers  (Reference)

The Project Reports Tool

5.5.11 Spell checking

In addition to manual spell checking for individual topics, selected text and your entire project

you can also use live spell checking (misspelled words are highlighted as you type). You can

create your own user dictionaries with lists of special terms for your own projects, auto-cor-

rect entries and terms that you want to identify as incorrect even though they are in the main

dictionary. User dictionaries can be global for all projects or local for just one project and can

be stored anywhere you like.

See The Spell Checker  for full details on configuring the spell checker.

Productivity Tip
Spell checking is supported almost everywhere in

Help+Manual where you can enter text. Just right-click

to display the context menu or click on the upper half

of the Spelling tool in the Project tab to access. 
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Selecting the language, user and hyphenation dictionaries

Select the language:

Go to Project > Tools > Spelling > Configure Spell Checker > Dictionaries and select the

correct dictionary for the language you want to check in the Main Dictionaries section:

You can spell check documents that contain multiple languages by selecting more than

one main dictionary. Click on Download dictionaries... to download free dictionaries for ad-

ditional languages. These dictionaries must be stored in the Dictionaries folder in your

Help+Manual program directory.
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Select the user dictionaries:

All user dictionaries listed in the Custom Dictionaries section will also be used for spell

checks. You can store these dictionaries anywhere you want, also on network drives, and

multiple users can access the same dictionary at the same time.

Select When adding words, use this dictionary: to choose the user dictionary you want to

use to store new words.

Hyphenation dictionary is a separate selection:

Note that you need to select the dictionary to be used for automatic hyphenation in PDF

and DOCX separately. Note also that there are no configuration options for hyphenation

beyond the custom word list with which you can specify how specific words are to be hy-

phenated, and words that are not to be hyphenated. Beyond that all aspects of hyphena-

tion are controlled by the Open Office hyphenation dictionaries used by Help+Manual. 

Styles excluded from spell checking are also excluded from hyphen-

ation

No hyphenation is performed on text formatted with styles that are excluded from spell

checking. You can thus disable hyphenation for any text by formatting it with one of the

styles you have excluded from spell checking. 

See The Spell Checker  for full details on configuring the spell checker.

How to use live spell checking

Go to Tools > Spelling > Configure Spell Checker and activate the Check spelling as you

type option.

Unknown words are highlighted with a wavy red underline. Right-click on a highlighted

word (or click on it and press the context menu key on your keyboard if you have one) to

display alternatives. 

Select Spelling in the context menu to open a full manual spell checker window.

1220
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Live spell check does not flag repeated words

Note that the live spell checker does not mark repeated words as errors. This is only

marked by the manual spell checker. 

Automatic hyphenation is only performed on publishing

Since the source of your topics in the editor is not between fixed margins, hyphenation is

only performed when publishing to a fixed-margin format like PDF and DOCX.

Styles excluded from spell checking are also excluded from hyphen-

ation

No hyphenation is performed on text formatted with styles that are excluded from spell

checking. You can thus disable hyphenation for any text by formatting it with one of the

styles you have excluded from spell checking. 

See The Spell Checker  for full details on how to configure this.1220
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How to use manual spell checking

Selected text, current topic or current text entry field or window:

Select text in the editor and click on the top part of the Spelling tool in Project > Tools.

Current topic, all topics, table of contents:

Click on the top part of the Spelling tool to spell check the current topic.

Click on the bottom part of the Spelling tool and select Current Topic, All Topics or Table

of Contents.

When an unknown word is found the following dialog is displayed:
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Ignore Once Skips this occurrence of the unknown word without correcting it and

continues the spell check. 

Ignore All Skips the unknown word and all future occurrences of the word. Applies

for the current spell check session only.

Add to Diction-

ary

Adds the unknown word to the current custom dictionary (see below).

Change Changes this occurrence of the unknown word and continues with the

spell check. You can type a word manually in the text field at the top or

click on a word in the Suggestions: list.

Change All Changes both this occurrence and all future occurrences of the unknown

word without prompting for confirmation. Applies for the current spell

check session only.

Auto-Correct Adds the unknown word and its replacement to the Auto-Correct list in

the current custom user dictionary. When this unknown word is en-

countered in future manual spell checks it will be corrected automatically

without prompting for confirmation. 

Options Direct access to the spell checker configuration options.
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Selecting and adding custom (user) dictionaries

The main dictionaries are not editable.

However, you can create custom user dic-

tionaries to store your own additional terms.

These dictionaries can also store auto-cor-

rect word pairs and "excluded" words that

you want to always identify as incorrect even

if they are in the main dictionary. 

See Using custom dictionaries  and Creat-

ing and editing custom dictionaries  for

full details on this subject.

· The standard user dictionary is stored in

your My Documents folder (called Docu-

ments in Windows Vista). To use this just

select it in the When adding words, use this

dictionary list at the bottom of the dialog.

· Click on Add/New to create a new user

dictionary or to select an existing diction-

ary. You can store your dictionary any-

where you like. 

· If you only want to use the selected dictionaries for the current project activate Selected

dictionaries are used for this help project only. Otherwise your selections will be stored

for all projects. 

Using Auto-Correct to replace words and abbreviations

The spell checker has an Auto-Correct feature that can be used to automatically replace

words with other words when they are encountered in manual spell checks. 

1. Set up your user dictionary and enter words you want to correct in the Auto-Correct

Pairs (see Creating and editing custom dictionaries  for details). 

2. To add new Auto-Correct Pairs during manual spell checks enter the correct word you

want to use, then click on Auto-Correct to add the pair to the current user dictionary. 
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This word pair will be corrected automatically from now on when you use this dictionary

(also in the current session). 

See also:
The Spell Checker

5.5.12 Special characters, lines and breaks

Like most modern word processors Help+Manual can also insert special characters not avail-

able on the keyboard, horizontal lines and hard page breaks. 

Please note that special characters and hard page breaks need to be used with consideration

for the limitations of your chosen output format: If the fonts required for the characters are

not available on the user's computer the characters will not be displayed. 

Page breaks are also inserted in HTML and will work there in browsers that interpret them

correctly.

Solving the "characters not available" problem

Symbols and special characters are frequently a problem. Even though they may display

fine on your computer, you will have issues if the user does not have the corresponding

fonts installed. Either they will see garbage characters, like a square or question mark, or

worse, the wrong character. This applies in particular if you use dedicated symbol fonts

like Font Awesome or Fontello. 

Convert symbol characters to SVG graphics

In both HTML and print (PDF and Word) output, Help+Manual can solve this problem by

automatically converting symbol characters to scalable SVG graphics. This display with ex-

actly the same quality as font characters and they have great advantages:

1220
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· They always work. Since the SVG is the character it cannot happen that it will be dis-

played incorrectly

· The quality is the same as font characters, at all sizes.

· In HTML web fonts are often blocked by security settings and ad blockers. That can't

happen with SVG characters.

See Converting symbol fonts to SVG for maximum reliability  further below in this topic

for details on how to use this feature.

How to insert typographic (curly) quotes

Help+Manual has an intelligent function for inserting typographic/curly quotation marks

instead of the standard computer vertical quotes. The main function is accessed in the

Symbol tool in Write > Insert Object:

Selecting the quotes style

First click on the arrow at the right end of the Quote(s) entry in the menu and select the

style of quotes you want to use. You only need to do this once for any quote style. After

that Help+Manual will remember it until you change it.

251
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Select text and apply quotes

The easiest way to apply curly quotes is to select the text you want to quote and then se-

lect the c entry in the menu. The quotes will be applied at the beginning and end of the

selected text.

Applying curly quotes singly

Just position the cursor at the beginning of the text and select the Quote(s) entry in the

menu, then position the cursor at the end of the text and select the entry again.

Help+Manual will figure out whether the quote is at the beginning or the end of the

quoted text and insert the correct quote character.

Set a keyboard shortcut for curly quotes

If you use quotes a lot you won't want to select the menu every time. Go to View > Pro-

gram Options > Shortcuts and define a keyboard shortcut to the Insert quotation marks

entry in the Insert group. This works both for quoting selected text and inserting quotes

singly. It will use the currently defined quotes style. 

How to insert special characters

Note that It doesn't make much sense to use characters from a rare font in your WebHelp

or HTML Help output, because most users won't have that font installed on their com-

puters. If you use rare fonts in PDF you can embed the font in your output, but this will

significantly increase the size of your PDF file. (Configuration > Publishing Options >

Adobe PDF > Font Embedding.)

1. Click in the editor in the position where you want to insert the special character. 

2. Select Write > Insert Object >   

3. Common special characters can be selected directly in the menu -- or select More

Symbols... to display more characters and all available fonts.

Keyboard shortcuts for special characters

You can assign keyboard shortcuts to a number of these characters in View > Program

Options > Shortcuts.
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Keep the Symbol tool open for other characters

You can keep the Symbol tool ("More Symbols") open while you are working to provide

quick access to special characters. This is particularly useful if you have defined a custom

list of characters – see further below in this topic for details. 

Exporting special characters as SVG graphics for consistency

You can configure your project to export symbol characters as scalable SVG graphics for

maximum compatibility. See further below for details.

Using dedicated symbol fonts like Font Awesome

In addition to the standard symbol fonts available in Windows, Help+Manual supports the

installation of dedicated symbol fonts like the popular Font Awesome and Fontello sys-

tems. 

Converting the symbols to SVG for maximum compatibility

This section explains how to get and use these fonts. See further below for instructions on

activating the option to convert to SVG for maximum compatibility on all output formats.

The standard Font Awesome font is pre-installed!

The standard set of open-source Font Awesome symbols is preinstalled in Help+Manual 9.

You can get it by selecting the FontAwesome font as described below.

How to get and install additional dedicated symbol fonts

These are standard font files but you choose the character sets you want them to install.

You generate them by visiting the website of the font provider (for example Font Awe-

some or Fontello). You choose the symbols or symbol sets you want to include, then you

generate and download the fonts containing your selected symbols. 

You ONLY need the desktop fonts!

You only need the normal desktop fonts. All the SVG conversion is handled by

Help+Manual, so you don't need any of the web font components. How this works varies

depending on the font system. For example, Font Awesome has a specific download page

for the desktop fonts only. Fontello always downloads a zipped package for web use.

https://fontawesome.com/
http://fontello.com/
https://fontawesome.com/how-to-use/on-the-desktop/setup/getting-started
https://fontawesome.com/how-to-use/on-the-desktop/setup/getting-started
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Whichever method, you only need to take the TTF or OTF desktop font files and install

them in Windows by double-clicking on the .ttf or .otf font files. 

Using the fonts

To insert symbol characters from these fonts just use the regular Write > Insert Object >

 tool, with the More Symbols option. When it opens, select the font at the top from the

drop-down list:

Set up a keyboard shortcut for the Symbol tool!

If you insert symbols frequently it's a good idea to set up a keyboard shortcut for the

Symbols tool. You can do this in View > Program Options > Shortcuts. The tool ("Insert

Symbol Character") is in the Insert group there.

Keep the Symbol tool open for other characters

You can also keep the Symbol open while you are working to provide quick access to spe-

cial characters. This is particularly useful if you have defined a custom list of characters –

see further below in this topic for details. 

Locating the symbol character set

These dedicated symbol fonts have "reduced" character sets. The actual characters

defined in the font only make up a tiny subset of the entire Unicode list. So when you se-

lect the font you will initially see the normal characters and symbols at the top of the list.

You will usually need to scroll all the way down to the end to find the special symbols that

are actually defined in the font. 
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Custom Symbols tab: Your symbols for reuse

The Custom Symbols tab in the Insert Symbol tool allows you to store a list of multiple

symbols from multiple fonts for quick access. In addition to single symbols you can also

store entire symbol sequences here. 

Adding symbols to the custom list:

Select a symbol in the Character Map tab and click on the Add to Custom button at the

bottom. Once it is in the custom list you can change the font, font size and font color in

the Custom Symbols tab.

Creating sequences of symbols:

You can enter sequences of symbols in the Symbol Text field. There are a number of ways

to do this, depending on the font and the symbols you are using. In all cases you can start

by creating a new custom symbol entry with the New button on the right.

Fonts with normal characters:

Just type the symbols into the Symbol Text field via the keyboard. You can use the New

button for this to create a new entry, then just type in the Symbol Text field. 



251

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

Symbols for which you know the decimal ALT codes:

Click in the Symbol Text field, then hold down the ALT key and type in the ALT code on

the numeric keypad of your computer. For example ALT+0222 for the Þ symbol. 

Special symbols you don't have the ALT codes for:

Add the symbols to the custom list via the Character Map tab using the Add to Custom

button, as described further above. Then copy and paste the characters from the Symbol

Text: field of one entry to another to build the sequence you want. 

Converting symbol fonts to SVG for maximum reliability

Symbols and special characters are frequently a problem, because they often display in-

correctly, or are blocked, on your users' computers. This applies in particular if you use

dedicated symbol fonts like Font Awesome or Fontello (see further above). You can solve

this problem by activating Help+Manual's ability to convert these symbol fonts to SVG

graphics on publishing. This looks exactly the same as the symbol font characters and

scales with the same quality, but unlike the font version it always works.

Converting to SVG in HTML-based formats (WebHelp, eWriter, ePub,

Kindle and CHM)

Open your project in Help+Manual. Then in the Project Explorer on the left, navigate

down to Configuration > Publishing Options > WebHelp > HTML Fonts. The settings

here are also used for CHM, eWriter, ePub, Kindle and Visual Studio Help. 

Just hit the Add Symbol Font button and add the fonts you want to convert to SVG on

publishing. That's it. You can also remove fonts, if necesary.

Converting to SVG in CHM / Microsoft HTML Help:

CHM has access to the same setting in Configuration > Publishing Options > Microsoft

HTML Help > HTML Fonts. (These are the same settings, just accessed in a different loca-

tion.)
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Converting to SVG in PDF output

PDF has the same setting for Symbol font SVG conversion, located in Publishing Options

> Adobe PDF > Font Embedding:

Word DOCX output

Word DOCX output does not currently support this feature. Symbol characters are expor-

ted to Word as regular font characters, not SVG, and depend on the fonts being available

on the user's computer for correct display.

How to insert horizontal lines

Horizontal lines are inserted in their own paragraph and they are not formattable. They al-

ways occupy the entire width of the page or table cell in which they are inserted.

1. Click in the editor in the position where you want to insert the horizontal line. 

2. Select Write > Insert Object >  to insert the line. A dialog will be displayed allow-

ing you to choose the line thickness and color.

Selecting Custom Style allows you to define the thickness and color of the line yourself. In

HTML output this styling information will be inserted as inline CSS in the HR line tag. If you

prefer the line to be unstyled choose the Browser Default option. This will just insert a

plain HR tag in HTML. This won't affect non-HTML formats like PDF and DOCX.
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How to insert hard page breaks

Hard page breaks are only used in PDF, printed manuals and Word DOCX. They are ig-

nored in all other formats.

1. Click in the editor in the position where you want to insert the hard page break. 

2. Select Write > Insert Object >  

Print orientation: Switch between Landscape & Portrait in PDF

When you insert a page break you can decide whether you want the orientation to switch

between landscape and portrait mode in PDF and printed manuals. This enables you to

use both landscape and portrait pages within a single document. 

Orientation change in PDF and printed manuals only

Note that changing the page orientation is currently only available for PDF and printed

manual output. If you want to change the page orientation in Word output you must do

this in Word after publishing the Word file from Help+Manual. 

See also:
Insert Special Character  (Reference)

5.5.13 Using comments and bookmarks

Comments and bookmarks enable you to annotate your text and create jump markers so that

you can quickly access topics or chapters that you need to edit frequently. 

Comments and bookmarks are separate. You cannot jump to comments and you cannot add

text to bookmarks, other than the label that is the bookmark name. However, they can be as-

1387
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sociated with one another: You can set a configuration option  that will automatically create

a bookmark for every comment you enter. 

Key Information
Comments and bookmarks are only an editing tool to

make working on your project easier. They are not

normally exported when you publish your project.

However, you can export comments to PDF.

Automatically inserting bookmarks for comments

You can configure Help+Manual to automatically create a topic bookmark for every com-

ment you insert. Open Program Options in the File menu and activate the option Automat-

ically manage topic bookmarks for every comment. Then a bookmark with a pin in the

Table of Contents will be added for every comment you create. These bookmarks can be

viewed and accessed with the Bookmarks tool in the Project tab.

How to insert a comment

You can insert multiple comments in a single topic. If you wish you can also set a config-

uration option  that automatically creates a bookmark for every new topic you enter. 

1. Click in the position in the editor where you want to insert your comment. (You can in-

sert comments both in the topics themselves and in the header.) 

2. Select Write > Insert Object >   in the Ribbon. 

3. Enter your comment text. 

4. Select Show comment as icon only if you want to hide its content inside the topic.

Including comments in PDF files as annotations for review

You can include your comments as annotations in PDF output, with a date range to in-

clude only comments from a specific time span. This can be a useful option when your

project is being reviewed for comments by team members, editors and so on. Then they

can see your annotations directly and add their own to the review PDF as well. 

To include the comments in the PDF select the comments option displayed in the Publish

dialog  when you export your PDF file. 

1267

1267

798
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How to insert and delete bookmarks

Bookmarks always link to the top of a topic and you can only manually enter one book-

mark per topic. Automatic bookmarks generated for comments (see below) all also link to

the top of the topic, even if there are multiple bookmarks for a single topic.

Bookmarked topics are identified with a red "pin" icon in the Table of Contents.

Inserting bookmarks:

1. Select the topic you want to bookmark. 

2. Select Bookmark > Bookmark Current Topic in Project > Project.

3. Enter a descriptive name for the bookmark and click OK.

Deleting bookmarks:

Select Bookmark > Remove Bookmarks in Project > Project, then click on the bookmarks

you want to remove. 

Inserting automatic bookmarks for comments:

This is a configuration option. Go to View > Program Options > Editor and check the op-

tion Automatically manage bookmarks for every comment. A new bookmark will then be

inserted automatically for every comment you create, using the first few words of the

comment as the bookmark identifier. See Program Options  for details. 

How to jump to bookmarks

· Select Project > Project > Bookmark and select the  bookmark want to jump to from

the list. 

Note that when you jump to a comment or bookmark you are always jumping to the topic

containing the bookmark. You cannot jump to the position of a comment within the topic,

even if the bookmark was inserted automatically when you created the comment. 

How to edit comments

· Double-click on the comment in the editor. If only the pin icon is displayed you must

double-click on the lower half of the icon.

OR:

1267
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· Right-click on the comment in the editor and select Edit. Again, note that the clickable

area is in the lower half of the pin icon.

Changing the comment's text style:

The appearance of the text in the comment controlled by the standard Comment style,

which you can edit by selecting Write > Styles > Edit Styles. This is a special style that has

quite limited features compared to most other styles. See Caption and comment styles

for details on this.

Storing text in comments

You can insert the text from comment a into your topic by right-clicking on it in the editor

and selecting Convert to plain text. You can "abuse" this feature to use comments as a

store for text that you may or may not want to include in your topics – for example for

text that is not yet finalized. When you want to insert it just convert the comment to plain

text. 

See also:
Graphic caption and comment styles

5.5.14 Mini-TOC and Link lists

The Link List tool can automatically create a variety of different lists of hyperlinks to topics

and insert them in your topic. These lists are dynamic. This means that they are not created

when you insert them, but every time you publish your project. This means that the list is al-

ways up to date at the time of publishing.

The tool is located in the Insert Object section at the right end of the Write tab:

How to use the Link List tool

Opening the tool displays this dialog:

305

305
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Just select the list type (see further below for a reference) and configure your settings:

Dialog settings:

See further below in this topic for a description of the link list types.

Exclude this topic: The current topic is not included in the link list.

Bullet list: Displays the list as a bulleted list. Otherwise it will just be displayed

as a series of paragraphs.

Inline: Displays links in a single paragraph, separated by commas.

Changed date: Includes the modification date of the referenced topics, in the se-

lected format.

Topic description: Adds the description of the current topic, if available. This is the op-

tional text that you can enter in the Description: box in the Topic

Options tab, to the left of the topic editor.

Note that the description is not included if you choose the Inline

link format. 

Fallback text: If a link list happens to be empty, because no links qualify for the

specified criteria, this text is inserted instead.
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The list is inserted as a placeholder!

Note that the list is not generated when you insert it. You will only see a placeholder in

the topic editor. The actual list is generated when you publish your project so that the top-

ics it contains are always up to date.

List types and list formatting

Available list types:

Siblings of this chapter: Links to all the topics in the current chapter on the same

level as the topic in which you are inserting the list. You

will generally want to exclude the current topic from this

list.

Sub-topics of this chapter: Includes all the sub-TOC-entries of the current topic, if

there are any.

Anchors within this topic: Links to all anchors in the same topic and creates a Mini-

TOC for navigation within the topic. The caption of the

link will be all text from the corresponding anchor to the

end of the anchor paragraph.

Topics modified within last: All the topics that have been modified/edited within the

last X days. You need to specify the number of days.

Topics modified between: All topics modified/edited between two specified dates.

List formatting:

The formatting of the list is generated automatically and based on the formatting of the

placeholder. The easiest way to achieve this is to apply a paragraph style to the place-

holder. Then the list will be formatted with that style. Otherwise just select the placeholder

and then format it with the Font and Paragraph dialogs in the Write tab.
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Examples

(A) Link list with all siblings in this chapter, excluding self, no date:

Recently changed topics

Topic Options

Topic History - Previous Versions

Word and Character Count

Writing and formatting text

The paragraph end mark

Topic Headers

Selecting text and content

Copying, cutting and pasting

Searching and replacing

Spell checking

Special characters, lines and breaks

Using comments and bookmarks

Inserting QR codes

Printing topics

Editing XML source code

(B) Recently changed topics in the entire project, short date:

(C) Topics changed between two specific dates in entire project, bul-

let list, long date:

· Table Counters, Captions and CSS  (Sunday, January 5, 2020)

· Adobe PDF and printed manuals  (Saturday, January 4, 2020)

· Special Characters  (Friday, January 3, 2020)

· Featured images for title pages  (Thursday, December 19, 2019)

· CHM in Asian Languages  (Thursday, December 19, 2019)

· The User Interface  (Thursday, December 12, 2019)

· Microsoft HTML Help  (Thursday, November 28, 2019)

· Managing modules in the TOC  (Thursday, November 28, 2019)

· Step 4: Synchronize the new version  (Thursday, November 28, 2019)

· Link lists and See Also links  (Wednesday, November 27, 2019)

· The Formula Editor  (Thursday, November 7, 2019)
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· Screen Capture  (Thursday, November 7, 2019)

· Microsoft help compilers  (Thursday, November 7, 2019)

· Selecting and formatting cells and tables  (Thursday, October 31, 2019)

· Translation-friendly Tidy XML  (Thursday, October 31, 2019)

(D) Topics changed in entire project between January 1 and October

31, 2019, bullet list, long date:

· Translation-friendly Tidy XML  (Thursday, October 31, 2019)

· Selecting and formatting cells and tables  (Thursday, October 31, 2019)

· Reference  (Tuesday, October 22, 2019)

· Importing data  (Tuesday, May 14, 2019)

· Links to help from your application  (Tuesday, May 14, 2019)

· Creating context-sensitive topics  (Tuesday, May 14, 2019)

· Getting help  (Tuesday, May 14, 2019)

· Editing topics  (Tuesday, May 14, 2019)

· Converting text to tables  (Tuesday, March 19, 2019)

· About tables  (Tuesday, March 19, 2019)

· Editing and formatting links  (Thursday, March 7, 2019)

· Styling imported formatted text  (Wednesday, February 13, 2019)

(E) Link list with all siblings in this chapter, excluding self, as

numbered list:

1. Recently changed topics

2. Topic Options

3. Topic History - Previous Versions

4. Word and Character Count

5. Writing and formatting text

6. The paragraph end mark

7. Topic Headers

8. Selecting text and content

9. Copying, cutting and pasting

10. Searching and replacing

11. Spell checking

12. Special characters, lines and breaks
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13. Using comments and bookmarks

14. Inserting QR codes

15. Printing topics

16. Editing XML source code

(F) Link list with all siblings in this chapter, as bullet list/tree, embed-

ded in another bullet list:

· This is the static first entry of the list

o Here are some recently changed topics:

§ Recently changed topics

§ Topic Options

§ Topic History - Previous Versions

§ Word and Character Count

§ Writing and formatting text

§ The paragraph end mark

§ Topic Headers

§ Selecting text and content

§ Copying, cutting and pasting

§ Searching and replacing

§ Spell checking

§ Special characters, lines and breaks

§ Using comments and bookmarks

§ Mini-TOC and Link lists

§ Inserting QR codes

§ Printing topics

§ Editing XML source code

· The static list continues here

For experts: HTML formatting

Formatting with your own CSS in HTML output

When you publish to HTML-based formats topic links in link lists have an additional CSS

class hmlinklistitem.  This is added to the standard topiclink class, so that topic

links in link lists have the class attribute class="topiclink hmlinklistitem". You

can use this to format topic links in link lists differently from other topic links. 
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5.5.15 Inserting QR codes

The QR Code Tool  in Write > Insert Object inserts a graphical QR code containing text or

hyperlinks. These can be scanned by QR code readers in smartphones with cameras, which

will then display the text, open the link in phone's browser or create an email with the phone's

mail client. This can be very useful in printed material, enabling you to provide live links to

web pages or for feedback or a way of directly copying text to the growing number of users

with smartphones.

For example, the first QR code below links to a web page, the second one sends an email:

                 

How to insert a QR code in a topic

1. Click in the topic and select the QR Code Tool  in Write > Insert Object.

2. Enter the URL or text you want to encode in the editing box. You must enter the

http:// prefix for web links and the mailto: prefix for email addresses, otherwise

they won't work in most QR code readers.

See the QR code tool reference  for details of the settings and controls.

Doing more with QR codes: public APIs

A number of enterprising online companies operates servers with QR code APIs (applica-

tion programming interfaces) for a wide range of functions. You can use them to create

QR codes that will send an SMS, dial a phone number, save contact details to a vCard,

save calendar entries and much more. This works by taking the user to the company's

server and then performing a function.

1381
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If you search online you will find quite a lot of these service providers. Make sure that they

are trustworthy before using them, however: Since you will be routing your users via the

provider's servers, you need to be sure what you are getting them into!

5.5.16 Printing topics

You can print individual topics with the Print Topic tool in Project > Manage Topics. The ad-

vantage of this over Print User Manual function (File menu menu) is that this function only

prints the selected topic or topics. Print User Manual uses a PDF print manual template, which

always includes additional elements like the cover and back page, table of contents, index and

so on, even when you only print one or more selected topics.

See PDF and Printed Manuals  for more details on using these other functions.

How to print the current topic

1. Select the topic you want to print by clicking on it in the TOC. 

2. Select the  Print Topic tool in Project > Manage Topics > File.

3. Select your printer and other settings in the print menu, then select OK to print.

How to print multiple topics

To print multiple topics you need to use the Print User Manual function (File menu menu).

If you frequently want to print multiple topics you can set up a special print manual tem-

plate  for this with all the sections except the Topics section disabled. Then you just se-

lect this template in the Print User Manual dialog before printing.

1. Select the topics you want to print by clicking on them in the TOC, using Ctrl+Click to

select topics out of order and SHIFT+Click to select continuous blocks of topics. 

2. Select the File menu and click on Print User Manual.

3. Select the Selected topics option in the Include Options: box.

4. Select your printer and other settings in the print menu, then select OK to print.

See Printing user manuals  for full details on using the Print User Manual function.

See also:
PDF and Printed Manuals

Printing user manuals
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5.5.17 Editing XML source code

As a normal documentation author you do not need to know anything about Help+Manual's

XML source code to get all the benefits from using Help+Manual. Familiarity with XML is

really only needed for users who want to generate their topic files from their own applications

automatically in XML format and for performing complex search and replace operations dir-

ectly on your project files with an external editor. 

If you are used to editing HTML pages you might feel tempted to try to edit the XML code in

the XML Source tab to tweak your topic formatting. Because of the absolute strictness of XML,

doing this will be more trouble than it is worth in most cases. It is best to use this tab just as a

reference when you need to know how your topic formatting is defined in the XML source.

Key Information
XML editing is for experts only. Although XML looks a

little like HTML it is actually very different and does not

tolerate even the smallest syntax error.

Editing in the XML Source tab

The XML Source tab is a text editor with syntax highlighting. You can copy, cut and paste

and both search and spell-checking are supported (right-click in the XML editor window

for options). 

If you want you can also copy the entire contents of the XML Source to a separate file –

this is effectively the same as exporting the topic to an external XML file with Topics >

Save Topic to File .

You can only edit individual topics in the XML Source tab. To perform global search and

replace operations you must edit the source files of your project directly with an external

editor capable of performing search and replace operations on multiple files. If you select

another topic directly while the XML Source tab is active you will be returned to the Page

Editor tab automatically.

Help+Manual's XML format is open and fully documented. Full documentation is available

in the file Helpman_XML_ref.chm which you can find in the Help+Manual program dir-

ectory.

Editing the XML project files directly

If you use Help+Manual Professional you can save your projects in as uncompressed XML

files with an .hmxp file as the main project file (this file is also an XML file). 

365
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If you observe the syntax rules of the Help+Manual XML Language you can edit these files

directly, either with a normal text editor or with a specialized XML editor. If you have an

editor that supports multiple-file search and replace you can also perform search and re-

place operations on your entire project that are not possible directly in Help+Manual it-

self. For example, you can use an editor that supports regular expressions to perform very

complex manipulations on the text and the source code.

WARNING: Don't try to edit XML files in word processors like MS

Word!

When you save XML files with a word processor they may change the source code and

make it unusable in Help+Manual. Some versions of Word will actually change the source

code Microsoft's own version of XML. You should always use either a normal text editor or

a source code or dedicated XML editor.

Supported XML formats

Help+Manual can only process XML files conforming to the Help+Manual XML Language.

These can be produced by Help+Manual itself or generated by other programs that con-

form to the language schema specifications. Documentation of the Help+Manual XML

Language can be found in the Help+Manual program directory (Help-

man_XML_ref.chm). Currently you cannot export or import any other XML formats.

See also:
XML and XML editing

5.6 Re-using content with snippets

The Snippet tool in Write > Insert Object enables you to insert the contents of another topic,

a Help+Manual XML file or PDF pages  at the cursor position. 

You can insert topics and files from the current project, from other Help+Manual projects

(there are some restrictions in the Basic version of H+M) and directly from Help+Manual XML

files. This means that you can build up a library of reusable content that you can access very

easily.

You can insert topic and XML snippets in two different modes: Copy and Link. Copy mode is

like normal Copy & Paste. It pastes the contents of the topic or file at the cursor position and

you can then edit it. Link mode creates a live link to the snippet file. To edit the snippet you

must then edit the original topic or file, but then it updates automatically in all the places

where you have inserted it, even if you are using it in multiple projects.

1137
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Productivity Tip
If you send your project for translation remember to

include any linked external snippet files you have ref-

erenced, otherwise the translator won't see them! 

Snippet storage locations

Rather than using snippets from many locations it is better to store all your snippet files in

a common location, for example in a folder inside your project folder. Then add this folder

to your project search path. This will make them easier to manage, particularly if you ever

need to move your project or have it translated. Alternatively, you can also store them in a

Style Repository or their own project. See further below for details on this. 

Inserting topics and XML files as snippets

You can insert topics and XML files into your current topic at the cursor position. These

topics can be inserted in Copy mode or Link mode. In Link mode the snippet content up-

dates automatically when the source topic or XML file is edited.

The topics can be in your current project, another Help+Manual project or a directory of

H+M XML files.

Procedure

1. Click in your topic where you want to insert the snippet. 

2. Select the  Insert Snippet tool in Write > Insert Object.

3. Choose From Topic to insert a topic from the current project or From File to insert an

external H+M XML file or a topic from another project. 

4. Select the topic or file you want to insert and click on OK to insert it.
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Options:

· Copy & Paste inserts a copy of the file contents that you can then edit.

· Linked creates a live link to the file – changes in the source file or topic are updated

automatically. 

· Snippet begins a new paragraph inserts the snippet as a new paragraph. Turn this off to

insert the snippet text inline inside an existing paragraph. If the snippet contains para-

graphs they will also be inserted, of course!

· Use project search path to locate snippet adds the location of the snippet file to the pro-

ject search path . If you deselect it the absolute path to the snippet is stored with the

snippet.

Inserting snippets from a style repository

A style repository is a special kind of Help+Manual project that is used to share styles and

snippets between multiple projects. Before using a style repository you need to create it

from a Help+Manual project and link it to your current project. See Working with Style

Repositories  for instructions.

To insert snippets from a style repository just select the From Repository option in the In-

sert Snippet dialog and then select the topic ID of the snippet you want to insert. All the

other options are the same as inserting snippets from topic files in the current project.

The advantage of a style repository is that its styles are also merged with those of your

project, so that the styles used for the snippets in the style repository project are also

available for use in the project where you are inserting the snippet.

Exporting selected text and topics as snippet files

You can export selected text or the current topic to an external XML file, for example for

use as a snippet in a snippet directory. 

1405
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Export the entire topic:

1. Select the topic you want to export in the Project Explorer (TOC or Topic Files). 

2. Select File > Save Topic to File in Project > Manage Topics and choose the save loca-

tion.

Export selected text:

1. Select text in the editor – the text can include anything that a topic can contain, i.e.

also images, tables, etc. 

2. Select File > Save Snippet in Project > Manage Topics and choose a save location and

a filename.

If you save in the uncompressed XML format you can also copy the XML files directly from

your project directory to other locations in Windows Explorer (Professional and Floating li-

cense versions only).

Managing and organizing snippets

You can insert snippets from any location. However, if you use snippets from many loca-

tions your linked snippets will not be displayed if you move your project or send it to

someone by email. You can solve this problem by storing your snippet files together with

your project in a special directory.

1. Create a folder for your snippets in a location where you can easily transport it to-

gether with your project folder. 

2. Add the path to the snippets folder to your Project Search Path in your project's Con-

figuration > Common Properties settings.

3. When you insert a snippet select the Use project search path to locate snippet option to

tell Help+Manual to look for the snippet files in the folders listed in the Project Search

Path.

When you do this you can always move your snippets folders to any location you like. To

get Help+Manual to find the snippets you just need to add the new location to your pro-

ject search path .

Managing snippets in a 'snippet project'

By far the easiest way to manage snippets is in a 'snippet project', which is just a normal

Help+Manual project saved in uncompressed XML  (.hmxp) mode. You then insert your
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snippets by selecting the XML topic files from the /Topics sub-folder of this snippet pro-

ject. Help+Manual topic files can be used as snippets without restrictions. 

Add your styles to the snippet project!

After creating your snippet project it's a good idea to add the paragraph and text styles

used in your snippets to the snippet project. You should do this before adding any snip-

pets to the snippet project – if you add them later the styles may not be used properly. 

1. Select Styles > Edit Styles in the Write tab. 

2. Select Copy Styles From... and then select your main Help+Manual project (i.e. the pro-

ject in which you are going to use the snippets). This will replace all the styles in the

snippet project with those from your main project. 

Adding new snippets to a snippet project

· Just create a new topic or topic file in the snippet project, just as you would in any other

Help+Manual project.

Adding existing snippets to a snippet project

· Move the XML snippet files to the /Topics folder of your snippets project in Windows

Explorer. 

Saving snippets to a snippet project from another project

· Create the snippet as you would normally and save it in the /Topics folder of your

snippets project.

When you do this you can always move your snippets folders to any location you like. To

get Help+Manual to find the snippets you just need to add the new location to your pro-

ject search path .

Managing snippets in a style repository

You can also manage snippets in special Help+Manual projects called "style repositories".

When a style repository is linked to your project all the snippets it contains are automatic-

ally displayed for selection in the Insert Snippet dialog.

· In addition to direct access to the snippets, the advantage of a style repository over a

normal snippet project is that its styles are merged into the styles of your current pro-

ject. The snippets using the styles defined in the repository are thus automatically

formatted correctly because their styles are directly available.
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· The disadvantage of a style repository is that you can only link one repository with any

project. However, you can also use both a linked style repository and additional manu-

ally-created snippet projects (see above). 

See Working with Style Repositories  for full details on how to create style repositories

and register and link them to your projects.

Excluding the snippets source files from your published output

When you use topic files from your current project as snippets you will generally want to

exclude the source files from your published output. If you don't do this these files will be

published and the user will able to find them with Search in formats like HTML Help and

WebHelp. 

1. Select the entry of the topic file in the Project Files section of the Project Explorer. 

2. In Project > Manage Topics select Change > Include in Builds and deselect all build

options. This will ensure that these topics will never be included when you publish

your project.

This is not necessary for snippets inserted from other projects or external XML files, of

course! 

Editing the contents of snippet files

There are three ways to edit the content of external snippet files in Help+Manual. Which

you use depends on whether the snippet contains a small or large amount of text.

However, by far the easiest way to manage and edit snippets is to organize them in a

'snippet project' of their own, for which Help+Manual Professional is required (see further

above on this page for more details). In addition to this, you can also manage snippets in

a style repository project .

Create a snippet project (Professional and Floating license ver-

sions only):

See the instructions further above on this page for more details on this.

· Create a new Help+Manual project and save it in an empty folder in uncompressed

XML  (HMXP) mode. Note that this save option is only available in the Professional

and Floating license versions of Help+Manual. 

· Create new snippet files by creating new topics in the snippet project, or create the

snippets in another project and save them to the /Topics folder of the snippets project.
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· Add existing snippet files to the 'snippet project' by moving their XML files to

the /Topics sub-folder in the snippet project folder. The topics will then appear in the

Topic Files section of the snippet project. You can create TOC entries for them for easier

organization by dragging the topic files into the snippet project TOC from the Topic

Files section. 

Create a style repository project (Professional and Floating license

versions only):

In addition to "normal" snippet projects you can also manage snippets in a "style reposit-

ory", which is a special kind of Help+Manual project for managing reusable topics and

styles. See Working with Style Repositories  for full details on this.

Editing small snippets stored as individual files:

1. Press ENTER a couple of times to create some space in the current topic. 

2. Insert the snippet file you want to edit in Copy & Paste mode (see above) and make

the necessary changes.

3. Select the edited text and export it as a snippet, overwriting the original snippet file

(see above).

Editing larger snippets stored as individual files:

1. Create an empty dummy topic in the TOC. 

2. Select File > Load Topic from File in Project > Manage Topics and load the snippet

file. 

3. Edit the content and then select File > Save Topic to File and overwrite the original

snippet file. 

Hyperlinks to anchors in linked snippets

If a linked snippet contains an anchor (jump target) you can link to it from other topics.

However, since the snippet file is not really inserted in the current topic you cannot select

the anchor from the drop-down list next to the Target: field in the Insert Hyperlink  dia-

log. You need to enter the anchor name manually.

1. Make a note of the name of the anchor you want to link to. 

2. Create a normal hyperlink to the topic containing the linked snippet.

3. Double-click on the hyperlink to edit it and type in the name of the anchor in the

drop-down list box next to the Target: field.

4. Publish your project and test the link to make sure that it works.
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You won't have this problem with snippets inserted in Copy mode because the text con-

taining the anchor is inserted in the topic directly.

Checking where a snippet topic is used

You can use the Find Referrers function to check where a topic file is being used as a

linked snippet. You can also use the same function to find the location of the linked snip-

pet topic files inserted in the current topic. 

This only works for topic files used as snippets in the current project. It won't work across

multiple projects or for XML files that are not part of projects.

1. In the Project Explorer select the topic file – either a file containing a linked snippet or

a file that you think is being used as a linked snippet. 

2. Select Find > Find Referrers in Project > Manage Topics (or just right-click and select

Find Referrers).

3. The sources of linked snippets in the topic are shown as incoming links. Topics in

which the topic is used as a linked snippet are shown as outgoing links.

Keywords in snippets

If snippet files are H+M topic files containing index keywords the keywords are imported

when you use Link mode. A-keywords are not supported in snippets, however.

Keywords are not imported with snippets in Copy & Paste mode. Small snippets saved

from selected text do not include keywords – that is only possible when you save an entire

topic as a snippet.

See also:
Multiple TOC entries for one topic

Snippets and multiple TOC references

Topic include options  

Anchors - jump targets

5.6.1 PDF Snippets

As of Help+Manual 9, you can now insert PDF files as snippets. This function is also available

in Print Manual Designer  tool for editing your PDF templates, where you can insert PDF

pages your PDF template sections. 
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How PDF snippets are inserted

When you publish to PDF, PDF snippets are inserted as native PDF pages. In HTML

formats they are inserted as graphics.

Inserting PDF snippets

The option is available in the From PDF tab in the Insert Snippet dialog:

Procedure

1. Click in the topic editor where you want to insert the snippet and select the Snippet

Tool. 

2. Choose From PDF on the left and navigate to the PDF file with the  browse button. 

3. Choose to insert all the PDF pages or just a page range. Entering a single page number

inserts a single page.

5.7 Text Formatting and Styles

Text formatting in Help+Manual works in the same way as in a modern word processor, sup-

porting both manual formatting and formatting with styles. Styles give you full control over

your formatting. Changing your style definitions reformats all text formatted with your styles.

Once you have got this set up it will save you many hours of unnecessary work. We strongly

recommend that you learn about styles and use them!

If you are not familiar with styles please study the chapter Dynamic Styles  in the Reference

section before getting started. 

Share stylesheets across multiple projects with style repositories

If you manage multiple projects that all need to look the same, check out Help+Manual's

powerful style repositories. They allow you to share stylesheets between multiple projects

1482
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and edit the styles for all of them in the same central location. See the Working with Style

Repositories  chapter for details!

See also:
Dynamic Styles  (Reference)

5.7.1 Formatting text manually

Manual formatting in Help+Manual works exactly as it does in a modern word processor. You

apply formatting to text manually with the tools in the Write tab of the Ribbon, where you

can select formatting options for Font, Paragraph and Borders and Background.

Generally, however, you should use styles for formatting your text. Styles are more efficient,

create uniform-looking documents and enable you to reformat your entire project quickly just

by changing your style definitions. When you are working on a project in a team styles are es-

sential for uniformly-formatted documents

Productivity Tip
You can assign keyboard shortcuts to most manual

formatting tools. Select View > Program Options >

Keyboard Shortcuts to access the settings.

How to apply manual formatting to text in the editor

There are two ways to apply formatting manually: Select a formatting option and start

typing, or select text and then apply a formatting option.

Select a formatting option and start typing:

If you select a formatting option without selecting text first the formatting options you se-

lect will apply to all the text you type from that point onwards (unless you move the

cursor again). If you press Enter to create a new paragraph after applying formatting like

this the new paragraph will also have all the formatting attributes you have just applied.

Select text and then apply a formatting option:

If you select text in the editor and then select formatting options the options will be ap-

plied to the selected text and paragraphs. If you then place the cursor directly after the

formatted text any new text you type in that position will also have the formatting.
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Manual formatting tools

To see what a formatting tool does just position the mouse over it for a second or two

and a description will be displayed.

The Font and Paragraph tools:

The tools in the Font and Paragraph groups of the Write tab all apply formatting manu-

ally in the current position. If text is selected the options are applied to the selected text. If

no text is selected the options apply from the cursor position onwards when you start typ-

ing. 

For more detailed formatting settings you can display the Font , Paragraph  and

Borders and Background  dialogs. To display them just click on the little arrow icons at

the bottom right of the Font and Paragraph groups. 

Quick access to Paragraph tool:

Right-click in the ruler above the main editor window and select Paragraph to open the

paragraph tool. You can also access the program settings for the editor here.

The Borders and Background tool:

This tool is included in the Paragraph group in the Write tab. You can display a full dialog

of options by clicking on the little arrow next to the Border Tool.

1329 1336
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Using the Format Painter tool

Use the Format Painter tool in the Clipboard group (Write and Project tabs) to copy format-

ting. The Format Painter works in the same way as similar tools in Word processors. 

1. Select text or click in the paragraph whose formatting you want to copy, then click

once to use the painter once, or double-click to turn on the painter for multiple use.

The mouse pointer changes to a painter symbol. 

2. Click in the paragraph or select the text that you want to apply the formatting to. 

3. Press ESC or click on the Format Painter tool again to turn it off if necessary. 

Converting text to a table

You can convert selected paragraphs to a table. Columns will be created automatically at

tab characters in the text. Note that you cannot convert text to a table inside another

table.

Context menu: Direct conversion without a dialog

Right-click on the selected text and select Convert text to a Table in the context menu. This

uses the default table format directly. You can configure the table afterwards with the

Properties tool in the Table tab.

Table tool: Configure the table with a dialog

Select the paragraphs you want to convert and then select the Table tool in the Write or

Table tab. Before the table is created the table properties dialog is displayed with which

you can configure all table attributes except the number of columns and rows. Those are

based on the selected paragraphs and the tab characters they contain.

See also:
Formatting text with styles

The Format Menu  (Reference)

Syntax highlighting for program code
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5.7.2 Quick guide to using styles

If you are new to using styles you should take a little time to learn how to use them. Used

properly, dynamic styles give you full control over your project's formatting, enabling you to

change the appearance and layout in seconds at any time.

You should define a style for each paragraph type and text format that you plan to use fre-

quently. You can do this as you work and you can change and reorganize your styles

whenever you like. 

For maximum efficiency only use manual formatting for formats that you are not going to use

again. If you later find you want to use the formatting as a style you can always turn it into a

style later.

Productivity Tip
You can quickly turn manual formatting into a style by clicking in the formatted

text and then selecting Write > Styles > Create Style from Selection.

Share stylesheets across multiple projects with style repositories

If you manage multiple projects that all need to look the same, check out Help+Manual's

powerful style repositories. They allow you to share stylesheets between multiple projects

and edit the styles for all of them in the same central location. See the Working with Style

Repositories  chapter for details!

Applying styles

· To apply a style to a full paragraph just click in the paragraph and select the style in the

style selector. Note that this will only work if the paragraph has not been formatted

manually. If it has, you must select the entire paragraph to reset the manual formatting

with a style. 

· To apply a style to text select the text and then select the style in the style selector.
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· Pre-formatted/manually formatted text: If you have imported formatted text from

other sources you must select it to be able apply styles to it, otherwise the imported

formatting has priority – it is treated as manual formatting. After applying a style you

just need to click in the paragraph and select a different style to change the style.

Changing an existing style

1. Click in a paragraph or in text formatted with the style you want to change (the style

name will be displayed in the style selector in Write > Font). 

2. Select Styles > Edit Style in the Write tab. The style at the cursor is selected for editing

automatically.

3. Select Font Settings, Paragraph Settings and Borders and Background to change the

style attributes.

4. Define different settings for Print View (PDF, DOCX, printed manuals) and Help View

(electronic formats).

5. Define keyboard shortcuts for styles you want to use frequently.

All text formatted with the styles you edit will be changed immediately. 

Note that you can set different attributes for electronic help formats (Help View tab) and

print-style help formats (Print View tab). You can also switch between print and help view

in the Help+Manual editor by clicking on the Screen/Print switch in the status bar below

the editor. See Multiple style sets  for  details.

Defining a new style

1. Select Styles > Edit Style in the Write tab, then select Add Style to define a new style. 

2. Enter a name for the style and then set its paragraph and font attributes.

3. Don't forget to define a keyboard shortcut for styles that you want to use frequently.

This will speed up your work a lot!

302
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Note that you can set different attributes for electronic help formats (Help View tab) and

print-style help formats (Print View tab). You can also switch between print and help view

in the Help+Manual editor by clicking on the Screen/Print switch in the status bar below

the editor. See Multiple style sets  for  details.

Changing the formatting in your entire project

If you use styles you can change the formatting in your entire project just by changing the

definitions of your styles. This is particularly powerful with the Normal style, which is usu-

ally the main style used for all body text paragraphs. In addition to this, you will usually

base all your other styles on Normal, including your heading styles. If you organize your

styles like this you can change the font and formatting in your entire project just by edit-

ing Normal.

· Follow the instructions above to edit the Normal style. 

· If you change the font of Normal the font will change in all text formatted with Normal
and with styles based on Normal, including heading styles. The font will only not
change in those styles in which the font has been changed so that it is not the same as
Normal.

· All the paragraph, background and border attributes of Normal are also "inherited" in
the same way by all the other styles based on Normal.

See also:
Dynamic Styles  (Reference)

5.7.3 Style display in the Toolbar

The style selector in the Ribbon Toolbar functions as an indicator to identify the style of the

current text or paragraph. It displays the paragraph and/or text style at the current cursor pos-

ition or of the currently selected text. For example, in the screenshot below, the cursor is in a

paragraph formatted with a style called Body Text:

Share stylesheets across multiple projects with style repositories

If you manage multiple projects that all need to look the same, check out Help+Manual's

powerful style repositories. They allow you to share stylesheets between multiple projects

and edit the styles for all of them in the same central location. See the Working with Style

Repositories  chapter for details!
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Display for manually-formatted text and text styles

If the cursor or selection is at a position containing manually-applied formatting the style

selector shows the name of the style in bold with a + sign after it, to indicate additional

formatting. For example, here the cursor is in text formatted in bold in a paragraph

formatted with the Normal style:

Here the cursor is positioned in text with

formatting different to the style.

The style name is shown as "Normal+" when the cursor is in manually-formatted text . In

the rest of the text of the paragraph the style selector display will be "Normal", without

the bold highlight and the + sign.

The bold Stylename+ display is also shown when the cursor is in text within a paragraph

formatted with a text style, because this also counts as additional formatting.

Display for no style and imported styles

No style:

If the current paragraph has no style the style selector display will be empty:

  The style selector is empty when 

  the current text has no style.

The style display is also empty when you paste text from Word or another word processor

that uses styles. The formatting of the text is imported but the styles with which the text is

tagged are not.
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Imported styles:

If you paste text containing styles that are not defined in your current project the un-

known style will be displayed in red in the style selector.

· See Turning formatting into styles  for instructions on how to turn imported styles like
these into styles you can use in your project.

See also:
Dynamic Styles  (Reference)

Formatting text with styles

Defining styles

5.7.4 Defining styles

Help+Manual's dynamic styles are defined and edited by selecting Styles > Edit Styles in the

Write tab.  The style at the cursor position is automatically selected for editing.

If you have not used dynamic styles in a word processor before please study the chapter on

Dynamic Styles  in the Reference section before proceeding. This will make using styles

much easier for you.

Help and Print style settings: You can define two different sets of attributes for every style:

One for electronic help formats (HTML Help, WebHelp, Visual Studio Help and eBooks) and

one for print-style output (PDF, printed manuals and Word DOCX). See Multiple style sets

for more details on this.

Share stylesheets across multiple projects with style repositories

If you manage multiple projects that all need to look the same, check out Help+Manual's

powerful style repositories. They allow you to share stylesheets between multiple projects

and edit the styles for all of them in the same central location. See the Working with Style

Repositories  chapter for details!

Topic header styles are NOT used in PDF and DOCX!

It is important to understand that the formatting of the text in the topic header box above

the topic editor is handled differently in PDF and DOCX output. The formatting of the

main text in the editor is exported to PDF and DOCX and used there. The formatting of
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the topic header is not exported – only the plain text is exported and the formatting is

defined in the PDF or DOCX template.

This is necessary because in PDF and DOCX you can define different formatting for the

headings on different levels. This formatting can only be defined in the template, since

you don't have multi-level formatting definitions in your project.

You can't influence header formatting in PDF and DOCX from your

project

What this means is that you can't influence the formatting of topic headers or TOC entries

in PDF and DOCX from your project. All the header formatting in these two document

types is defined in the PDF and DOCX templates, not in your project.

Paragraph styles and text styles

By default, style definitions are "paragraph styles" and always include both text and para-

graph attributes (borders and backgrounds are included in the paragraph attributes). 

You can also define text-only styles for formatting text within paragraphs. See Defining a

new text style below for details. 

Defining a new paragraph style

1. Select Styles > Edit Styles in the Write tab to display the Edit Styles dialog. 
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2. Select Add Style and enter a name for your new style.

3. In the Based on Style: field select the style you want to base the new style on. The style

will inherit all the attributes of this style. Base paragraph styles on paragraph styles,

text styles on text styles. Alternatively, select (None) to create a style without a parent. 

4. Set the attributes of the style with the Font Settings, Paragraph Settings and Borders

and Backgrounds buttons. 

5. If you want to create a hotkey combination for selecting the style click in the Shortcut:

field and press the key combination you want to use. You will be warned if the key

combination is already in use.

6. Click on OK to save the new style. It is then available immediately in all the style lists. 

Defining a new text style

A text style is a style that only contains font attributes. See Formatting text with styles

for details on how to use text styles. 

292
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Note that you cannot create a text style based on a paragraph style. This also means that

you cannot create text styles based on the Normal style because Normal always has para-

graph attributes.

1. Select Styles > Edit Styles in the Write tab. 

2. Select Add Style and enter a name for your new style.

It's a good idea to use a prefix in the name of your text styles to identify them clearly.

For example, you could use T_, so that your text styles would have names like T_Em-

phasized, or T_ProductNames.

3. In the Based on Style: field select another text style if you want to base the new style

on another style. The style will inherit all the attributes of this style. Alternatively, select

(None) to create a new text style without a parent.. 

4. Click on Reset Style to make absolutely sure that all the non-text attributes of the style
are canceled. 

5. Click on Font Settings and set the attributes of the style. 

Don't select the Paragraph or Borders buttons – if you do the style will become a para-

graph style.

If you want to create a hotkey shortcut for selecting the style click in the Shortcut: field

and press the key combination you want to use. You will be warned if the key combin-

ation is already in use.

6. Click on OK to save the new style. It is then available immediately in all the style lists

(see Formatting text with styles  for details). 

Different style definitions for screen and print style documentation

Help and Print style settings: 

292
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You can define two different sets of attributes for every style: One for electronic help

formats (HTML Help, WebHelp, Visual Studio Help and eBooks) and one for print-style

output (PDF, printed manuals and Word DOCX). 

By default, only the Screen View tab in the Edit Styles dialog is activated. If you also activ-

ate the Print Manual View tab you can define different settings there and they will be used

for PDF, DOCX, printed manuals and eBooks. 

You can switch the editor display between the two style sets with the Screen/Print toggle

switch in the status bar below the editor window, next to the Zoom control.

See Multiple style sets  for more details on this.

Sharing stylesheets between multiple projects

You can share stylesheets between multiple projects and edit them centrally in special

projects known as style repositories. You then only need to edit the styles on one place for

all the projects linked to the repository.

See Working with Style Repositories  for detailed instructions.

Importing styles from another project

This function replaces all the styles of the current project with styles imported from an-

other project. Only use it if you really want to use the styles defined in another project in-

stead of the current project's styles.

1. Select Styles > Edit Styles in the Write tab. 
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2. Click on Copy Styles From... in the Edit Styles dialog and select the project containing

the styles you want to copy.

See Copying styles from other projects  for full details on this function.

See also:
Formatting text with styles

Editing styles

Dynamic Styles  (Reference)

5.7.5 HTML fonts and headings

Defining font families for HTML output formats

The fonts you define may not always be present on the user's system or may be restricted

by some browsers. To avoid just getting the browser's default font you can define font

"families" for the fonts you use. This is a list of alternative fonts that the browser will use

instead of your chosen font if it is not available. 

306

292

288

1482



287

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

The font families settings

The settings for this are in Configuration > Publishing Options > WebHelp > HTML

Fonts. The same settings are available in the section for Microsoft HTML Help. The fonts

you define are global and are used in all HTML output formats (WebHelp, CHM, eWriter,

Kindle, ePub and Visual Studio Help). 

How to define font families

Help+Manual already has families defined for most common fonts. You can edit the exist-

ing families by clicking in the entry. To add a new family just scroll down to the bottom of

the list and click in the first empty row.

Rules for font families

· The first entry is the name of the font you are defining the family for.

· Insert a comma after each font name that is followed by another font name.

· All font names that contain spaces must be enclosed in single quotes.

· The browser will choose the first alternative font in the list that is available, so define

the family in order of preference.

· Always insert a standard, web-safe font as the last option if you are using fonts that

may not be available.

Generating H1 .. H6 styles for WebHelp

When you are targeting WebHelp you want the main headings in your topics to use the

standard HTML H1 through H6 heading styles so that search engines like Google will
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automatically identify the important subjects in your topics. You can achieve this by using

Help+Manual's Heading1...Heading6 style naming convention.

Styles called Heading1 ... Heading6 are exported as H1 .. H6 in HTML

· Getting this to work is simple. Just use styles called Heading1 through Heading6 for

the headings in your topics that you want to export as H1 through H6 in your HTML

output.

· The Heading1 style is a predefined standard style that is automatically used for the text

in your topic headers by Help+Manual, so the titles of your topics are always automatic-

ally exported as H1 styles in HTML.

· To use H2 through H6 headings just define additional styles called Heading2 through

Heading6 and use them for your sub-headings in your topics. They will then be expor-

ted as H2 through H6.

See also:
Using HTML Templates

5.7.6 Editing styles

Whenever you edit a style all the text in your project formatted with the style is updated auto-

matically and immediately. In addition to this any changes you make to styles will automatic-

ally be inherited by any other styles based on that style. This makes it possible to make

changes to entire families of styles very quickly and easily by editing the parent styles. For ex-

ample, you can normally change the base font in your entire document by changing the font

of the Normal style. 

Styles Locked?
If the styles in the Edit Styles screen are read-only your

project is using a Style Repository and you need to

edit the styles there. See here  for instructions.

Share stylesheets across multiple projects with style repositories

If you manage multiple projects that all need to look the same, check out Help+Manual's

powerful style repositories. They allow you to share stylesheets between multiple projects

and edit the styles for all of them in the same central location. See the Working with Style

Repositories  chapter for details!
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Topic header styles are NOT used in PDF and DOCX!

It is important to understand that the formatting of the text in the topic header box above

the topic editor is handled differently in PDF and DOCX output. The formatting of the

main text in the editor is exported to PDF and DOCX and used there. The formatting of

the topic header is not exported – only the plain text is exported and the formatting is

defined in the PDF or DOCX template.

This is necessary because in PDF and DOCX you can define different formatting for the

headings on different levels. This formatting can only be defined in the template, since

you don't have multi-level formatting definitions in your project.

You can't influence header formatting in PDF and DOCX from your

project

What this means is that you can't influence the formatting of topic headers or TOC entries

in PDF and DOCX from your project. All the header formatting in these two document

types is defined in the PDF and DOCX templates, not in your project.

Defining a new style

1. Select Styles > Edit Styles in the Write tab, then select Add Style to define a new style. 

2. Enter a name for the style and then select Font Settings, Paragraph Settings and

Borders and Background to change the style attributes. See The Write Tab  for de-

tails in the settings in these dialogs.

3. Don't forget to define a keyboard shortcut for styles that you want to use frequently.

This will speed up your work a lot!

1324
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Editing an existing style

1. Click in a paragraph or in text formatted with the style you want to change (the style

name will be displayed in the style selector in Write > Font). 

2. Select Styles > Edit Styles in the Write tab. The style at the cursor is selected for editing

automatically.

3. Select Font Settings, Paragraph Settings and Borders and Background to change the

style attributes. See The Write Tab  for details in the settings in these dialogs.

4. Define different settings for Print View (PDF, DOCX, printed manuals) and Help View

(electronic formats). See Multiple style sets  for more details on these two sets of

settings.

5. Define keyboard shortcuts for styles you want to use frequently.

All text formatted with the styles you edit will be changed immediately. 

Select Reset Style to completely reset all of the style's attributes to the settings of its par-

ent style (the style listed in the Based on Style: field). If the style has no parent it will be

set to the Help+Manual defaults.

1324
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Moving and renaming styles

Change the style's parent:

To change a style's parent select a different parent style in the Based on Style: field. Any

style attributes that were set explicitly in the style will remain unchanged. All other style

attributes will be changed to those of the new parent style. 

Eliminate the style's parent:

To eliminate the style's parent just select (None) in the Based on Style: field. This will pre-

vent the style from inheriting any attributes from any other styles. It will also make the

style the first parent in a new style tree. This can be useful under some circumstances. See

Style organization strategies  for details.

Rename a style:

Just select the style in the Edit Styles dialog and edit the name. You can change the name

of a style whenever you like, it will be updated automatically throughout your project. 

Modifying an existing style on the basis of a selection in the editor

You can also modify a style on the basis of a modified paragraph or text formatted with

the style. This is often the easiest way to edit a style because it is much easier to see your

formatting in the editor.

1. Use the manual formatting tools to format a paragraph or some text formatted with

the style you want to change. 

2. Make sure that the cursor is inside the formatted text, then select Styles > Create Style

from Selection in the Write tab. 

You don't need to select any text, the cursor must only be inside the formatted text

you want to use as a model. If you do select text it should all be formatted in the same

way – don't try to create a style based on text with some words formatted in one way

and some in another!

3. Select the Change existing style option in the dialog displayed. The style at the cursor

should be selected automatically. If it isn't close the dialog and check the position of

the cursor in the editor.

1497
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The Assign paragraph attributes option will be selected automatically for paragraph

styles and deselected for text styles. Only change this if you want to change the style

type. (See Paragraph and text styles  for details on changing the style type.)

4. Click on OK to apply the changes to the selected style. 

See Defining styles  for details on using this function to create a new styles.

See also:
Paragraph and text styles

5.7.7 Formatting text with styles

Formatting text with styles couldn't be simpler: You just select your text and select a style, and

all the attributes of that style are applied to the text in one quick operation. 

Help+Manual comes with a basic set of standard styles already predefined, so you can start

using styles right away, even without defining your own styles. Normally, however, you will

want to modify these styles and add styles of your own to create a customized layout and ap-

pearance for your project.

See Defining styles  for information on defining and editing styles. If you are not yet famil-

iar with styles please study the chapter on Dynamic Styles  in the Reference section.

Share stylesheets across multiple projects with style repositories

If you manage multiple projects that all need to look the same, check out Help+Manual's

powerful style repositories. They allow you to share stylesheets between multiple projects

and edit the styles for all of them in the same central location. See the Working with Style

Repositories  chapter for details!
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Topic header styles are NOT used in PDF and DOCX!

It is important to understand that the formatting of the text in the topic header box above

the topic editor is handled differently in PDF and DOCX output. The formatting of the

main text in the editor is exported to PDF and DOCX and used there. The formatting of

the topic header is not exported – only the plain text is exported and the formatting is

defined in the PDF or DOCX template.

This is necessary because in PDF and DOCX you can define different formatting for the

headings on different levels. This formatting can only be defined in the template, since

you don't have multi-level formatting definitions in your project.

You can't influence header formatting in PDF and DOCX from your

project

What this means is that you can't influence the formatting of topic headers or TOC entries

in PDF and DOCX from your project. All the header formatting in these two document

types is defined in the PDF and DOCX templates, not in your project.

Applying styles

· To apply a style to a full paragraph just click in the paragraph and select the style in the

style selector. You can also select multiple paragraphs and apply styles to all of them.

You must select all the text in all the paragraphs to do this – only font attributes are ap-

plied to partially-selected paragraphs.

· To apply a style to text select the text and then select the style in the style selector.

· If you have imported formatted text from other sources you must select it to be able ap-

ply styles to it, otherwise the imported formatting has priority – it is treated as manual

formatting. After applying a style you just need to click in the paragraph and select a

different style to change the style.
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Paragraph styles and text styles

By default style definitions are paragraph styles and include both text and paragraph at-

tributes (borders and backgrounds are included in the paragraph attributes). 

You can also define text-only styles for formatting text within paragraphs. See Defining

styles  for details, and see below for instructions on how to use text-only styles. 

Applying text-only styles

You can also define text-only styles  that only set font attributes. Applying these styles

is very similar to formatting text manually.

To apply the text style to existing text: 

Select the text and then select the style.

To apply the text style to an entire paragraph: 

Click anywhere in the paragraph and select the style. The text style attributes will be ap-
plied to all the text in the paragraph except manually-formatted text, imported formatted
text and text already formatted with other styles. 

To type new text with a text style: 

First press Enter to create a new paragraph. Then select the style and start typing. 

How text selection interacts with applying styles

Nothing selected (click in paragraph):

When nothing is selected the style is applied to the entire paragraph with all its attributes

(text, paragraph, borders/background). 

If the style is a text-only style the text attributes are applied to the entire paragraph.

Manually-formatted text, imported formatted text and text within paragraphs formatted

with other styles are all "protected" – they will only be reset if they are selected before ap-

plying the style. 

Everything selected (all the text in one or more paragraphs):

When everything is selected the style and all its attributes (text, paragraph, borders/back-

ground) are applied to all selected paragraphs. All formatting is reset to the style attrib-

281
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utes, including manually-formatted text, imported formatted text and text within para-

graphs formatted with other styles.

If any paragraph is only partially selected then only text attributes will be applied to that

paragraph.

Text within a paragraph selected (partial selection):

If you select text within a paragraph then only font attributes of styles will be applied to

that text, even if the style also has paragraph attributes.

The standard styles

There are several standard styles that are used automatically for various purposes. For ex-

ample, when you create a new topic the first paragraph always has the Normal style, the

topic header above the editing area always has the Heading1 style and graphics captions

always have the Image Caption style. 

There are a number of other standard styles. They are all identified and displayed in bold

in the style editing dialog . You can edit these styles but you cannot delete them or

change their names. See The standard styles  for details. 

See also:
Defining styles

5.7.8 Turning formatting into styles

The easiest way to define a new style is to use some manually-formatted text in the editor as

a model. This allows you to see what you are doing much more clearly than when you are set-

ting attributes in the formatting dialogs. 

Defining a new paragraph style from a selection

1. Use manual formatting options to format a paragraph so that it looks exactly as you

want your style to look. 

2. Click in your model paragraph, then select Styles > Create Style from Selection in the

Write tab. 

1347
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3. Select the Create a new style option and enter a name for the new style. 

4. If you want the style to have a parent select a style in the Based on Style: list. The new

style will then inherit all the attributes of the parent style that are not different from

the current paragraph in the editor. If you do not want the style to have a parent scroll

to the top of the list and select (None).

5. Make sure that the Assign paragraph attributes option is checked, then click on OK to

create the new style. 

Defining a new text style from a selection

You can also create new text styles based on text in the editor. The procedure is almost

the same as for a paragraph style.

1. Format some text so that it looks exactly as you want your style to look. 

2. Click in the formatted text, then select Styles > Create Style from Selection in the Write

tab. 

3. Select the Create a New Style and enter a name for the new style. It is a good idea to

enter a prefix to identify it as a text style, for example "T_".

4. If you want the style to have a parent select a text style in the Based on Style: list. If you

use this option the parent style must be another text style. The new style will then in-

herit all the attributes of the parent style that are not different from the current para-

graph in the editor. If you do not want the style to have a parent scroll to the top of

the list and select (None).

5. Deselect the Assign paragraph attributes option, then click on OK to create the new

style. 
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Modifying an existing style on the basis of a selection in the editor

You can also modify a style on the basis of a modified paragraph or text formatted with

the style. This is often the easiest way to edit a style because it is much easier to see your

formatting in the editor.

1. Use the manual formatting tools to format a paragraph or some text formatted with

the style you want to change. 

2. Make sure that the cursor is inside the formatted text, then select Styles > Create Style

from Selection in the Write tab. 

You don't need to select any text, the cursor must only be inside the formatted text

you want to use as a model. If you do select text it should all be formatted in the same

way – don't try to create a style based on text with some words formatted in one way

and some in another!

3. Select the Change existing style option in the dialog displayed. The style at the cursor

should be selected automatically. If it isn't close the dialog and check the position of

the cursor in the editor.

The Assign paragraph attributes option will be selected automatically for paragraph

styles and deselected for text styles. Only change this if you want to change the style

type. (See Paragraph and text styles  for details on changing the style type.)

4. Click on OK to apply the changes to the selected style. 

See Defining styles  for details on using this function to create a new styles.
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Adding imported styles to the current document

If you paste text from another Help+Manual project containing styles that are not defined

in your current project the unknown style will be displayed in red in the style selector. You

can convert this to a "known" style with Create Style from Selection.

  Unknown styles are displayed in red

1. Place the cursor inside the pasted text so that the red style name is shown in the style

selector. 

2. Select Styles > Create Style from Selection in the Write tab. 

3. Select the Create New Style option and type the name of the unknown style exactly as

it appears in the style selector (the red text)

4. If you want to make the style the child of an existing style select the name of the par-

ent style you want to use in the Based On Style: list. The new style will then inherit all

common attributes from the parent style. 

See also:
Defining styles

Editing styles

281
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5.7.9 Using indents

Creating indents in a word processor is a trivial task that you hardly even need to think about.

In HTML-based formats indents are not quite so straightforward. HTML does not support

either tab stops or multiple spaces, so you cannot use them to create indented paragraphs or

to format tabular data. (Tabs and multiple spaces wouldn't work in HTML because the page

width is dynamic.)

You can use indented paragraphs – Help+Manual will convert them to stable HTML structures

when you publish to HTML-based formats. However, you should avoid using tab stops and

spaces on their own to create indented effects, because these will not work in HTML-based

outputs. You should always use the paragraph indenting functions described below.

For some more background information see Tabs, indents and HTML  in the Reference sec-

tion.

Key Information
You cannot use the indent tools on single-level bul-

leted and numbered lists. To change the indent in a list

you must first switch off the list with the list tool. In

outline numbered lists the indent tools change the list

level.

How to indent paragraphs

· Use the  indent tools  in Write > Paragraph to increase and decrease indents.

OR:

· Press Shift+Ctrl and the + or - key to increase and decrease indents.

OR: 

· Drag the Indent tool in the ruler above the editor. The tool has three parts, which can all

be dragged separately: The upper triangle adjusts the first-line indent, the lower triangle

adjusts the main paragraph indent and the square box at the bottom adjusts the first

line and the paragraph indent together.

OR:

1500
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· Select the paragraph dialog icon in Write > Paragraph and set the indent values manu-

ally.

How to create a paragraph with a hanging indent

Hanging indents work in all publishing formats, including HTML-based formats where

they are converted to stable table structures. Hanging indents are formatted in the editor

with a single tab stop between the "hanging" portion and the main paragraph. This is the

only place where you should use a tab stop for HTML-based output. Use only one tab and

don't add any spaces, otherwise you will get errors in HTML output.

· Use the Indent tool in the Toolbar to define the hanging indent:

OR:

· Select Format > Paragraph and set the indent values in the Indentation section.

See Tabs, indents and HTML  in the Reference section for more information on hanging

indents and how they are converted in HTML-based output.

1500
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Negative indents for sidebar effects

You can set negative indents to put part of a paragraph to the left of the normal natural

margin of the page. To do this, enter a negative number like -24 in the Left: or Right: box

for the indents. Alternatively just use the down arrow next to the field to go "down" below

zero.

This is mainly useful for output to PDF, DOCX and eBooks when you want to put some-

thing like an icon to the left or right of the main body of the text. If you apply a negative

indent to the container paragraph of a table, you can put an entire table column to the

left or right of the normal margin for a sidebar effect.

Indenting with leading spaces/blanks

In normal text:

Generally you should never indent text with leading spaces, it is much better to use real

paragraph indents. In HTML multiple spaces are normally always interpreted as a single

space – Help+Manual gets around this by converting multiple spaces to alternating soft

and hard space characters. However, this still may not produce the results you need be-

cause different browsers can interpret the widths of these different space characters in dif-

ferent ways.

In program code:

Program code is often automatically indented with leading spaces. To get this to display

correctly you just need to turn word wrap off in the paragraph settings of your code ex-

amples, either manually or with a style. Then all the spaces will be converted to &nbsp;

hard space entities which will render correctly in all browsers. Paragraphs will not wrap,

but you don't want paragraphs to wrap in program code. See Formatting program source

code  for more details. 

Tip: Hanging indents in HTML-based publishing formats

In HTML hanging indents are turned into tables. This means that the left part of the

hanging indent will wrap inside the table cell if it is too long to fit. If you are only output-

ting to HTML-based publishing formats this means you can make the left part of the in-

dent as long as you like because it will wrap in your output.

310
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The indent in the editor:

This shows the paragraph with the 

overlong text in the editor.

Result in HTML output format:

This shows the output in HTML 

Help or Webhelp.

You can't use this trick if you are also outputting to PDF, printed manuals or Word DOCX.

It only works in HTML-based output!

See also:
Tabs, indents and HTML

5.7.10 Multiple style sets

You can define two different sets of attributes for every style: One for electronic help formats

(HTML Help, WebHelp, Visual Studio Help and eWriter Help) and one for print-style output

(PDF, printed manuals, Word DOCX and ePUB and Kindle Mobi eBooks).

Share stylesheets across multiple projects with style repositories

If you manage multiple projects that all need to look the same, check out Help+Manual's

powerful style repositories. They allow you to share stylesheets between multiple projects

and edit the styles for all of them in the same central location. See the Working with Style

Repositories  chapter for details!

Topic header styles are NOT used in PDF and DOCX!

It is important to understand that the formatting of the text in the topic header box above

the topic editor is handled differently in PDF and DOCX output. The formatting of the

main text in the editor is exported to PDF and DOCX and used there. The formatting of

1500
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the topic header is not exported – only the plain text is exported and the formatting is

defined in the PDF or DOCX template.

This is necessary because in PDF and DOCX you can define different formatting for the

headings on different levels. This formatting can only be defined in the template, since

you don't have multi-level formatting definitions in your project.

You can't influence header formatting in PDF and DOCX from your

project

What this means is that you can't influence the formatting of topic headers or TOC entries

in PDF and DOCX from your project. All the header formatting in these two document

types is defined in the PDF and DOCX templates, not in your project.

How to use different fonts for electronic and print output

1. Select Styles > Edit Styles in the Write tab. 

2. Select Normal, as most other styles are usually based on this style. You will need to

edit any styles not based on Normal separately).

3. Change the font settings in the Print View and Help View tabs. Deselect Same options

as help view in the Print View tab to edit the print style settings.

4. Repeat for any styles not based on Normal – these are styles that are not shown as

"sub-branches" of Normal in the style tree.

Completely different style attributes for electronic and print output

You can also create completely different layouts for electronic and print output, with a

completely different appearance for all your styles in each format. However remember

that you can only redefine the attributes of existing styles for each output format. You

cannot have different styles for each format because the styles are attached to your text

by name. There is only one list of styles, but each style can have two different definitions.

· Proceed as described above and edit all the style attributes you want to change for

each output format – you can define separate font, paragraph, border and background

settings for each view.

Print styles are strongly recommended for Kindle Mobi and ePub

If you define print view style attributes they will be used in Kindle Mobi and ePUB eBooks.

For technical reasons, eBook files work better when they have their own styles and fonts
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defined for them specifically. Among other things, it may be sometimes be necessary to

define special font names for use in your ePUB eBooks (for example for eBooks aimed at

Apple iBooks on iOS devices, which have different standard fonts available). Please see

Managing Fonts in ePUB  for more details.

Editor zoom and preview mode for screen/print styles and font sizes

You can zoom the entire contents of the editor quickly with the Zoom control in the status

bar below the editor window. This control is also available in the View tab in the ribbon

toolbar.

You can also switch the editor display between the styles defined for electronic help

formats (HTML Help, WebHelp, Visual Studio Help and eWriter Help) print-style help

formats (PDF, printed manuals, Word DOCX and ePUB and Kindle Mobi eBooks). 

This will only have an effect if you have defined different settings for screen and print out-

put in your style definitions. See Multiple style sets  for more information on using dif-

ferent style sets for different output formats.

Display buttons in the status bar:

See also:
About inheritance in styles

Defining styles

Editing styles

The Format Menu  (Reference)
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5.7.11 Image caption and comment styles

Image captions and comments/bookmarks are formatted with two standard styles called

Image Caption and Comment. These styles are applied automatically to all image captions and

comments and they are the only styles that these elements can use. 

This means that all image captions and all comments/bookmarks in your project will have the

same style. You can override these styles and change the formatting of individual captions

and comments by applying manual formatting. 

Share stylesheets across multiple projects with style repositories

If you manage multiple projects that all need to look the same, check out Help+Manual's

powerful style repositories. They allow you to share stylesheets between multiple projects

and edit the styles for all of them in the same central location. See the Working with Style

Repositories  chapter for details!

Restrictions

· The Image Caption and Comment styles only have font attributes. If you set paragraph

attributes in the style definition they will be ignored.

· All the text in captions and comments has same font attributes. You cannot format indi-

vidual words differently from the rest of the text.

· Image captions are always centered, comments are always left-aligned. Since the styles

do not have paragraph attributes you cannot change these settings.

Editing the caption and comment styles

Select Styles > Edit Styles in the Write tab, then select the Comment or Image Caption

style in the list and edit its font attributes. (Don't bother editing the paragraph, border or

background attributes because these are ignored for these styles.

· See Editing styles  for more information.

Formatting caption and comment texts manually

You can also change the formatting of individual captions and comments manually:

· Just click on the graphic or comment in the editor to select it, then select the font attrib-
ute you want to apply (bold, underlined, font etc).

1076
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All formatting will be applied to the entire comment or caption text. You cannot apply dif-

ferent formatting to parts of the text. Also remember that you cannot apply paragraph at-

tributes to these texts, they will simply be ignored.

See also:
Editing styles

Inserting graphics and screenshots

Comments and bookmarks

5.7.12 Copying styles from other projects

Once you have created styles in one project you don't need to redefine them when you create

a new project. You can copy styles between projects, both individually and as complete collec-

tions, which are referred to as "stylesheets". 

Note that unlike many word processors, Help+Manual does not store its project stylesheets in

separate files. Instead, they are stored in the main project file along with all the other project

settings. This is why it is necessary to import them from the project file when you want to

copy them, instead of selecting a different stylesheet.

Share stylesheets across multiple projects with style repositories

If you manage multiple projects that all need to look the same, check out Help+Manual's

powerful style repositories. They allow you to share stylesheets between multiple projects

and edit the styles for all of them in the same central location. See the Working with Style

Repositories  chapter for details!

Copying a project stylesheet to an existing project

Note that importing a stylesheet completely replaces the stylesheet of the current project!

This is not a merge process: All the styles in the current project will be deleted, even if

they do not have the same names as the styles in the source file.

1. Make a backup of your current project and store it in a safe place. (In case you
change your mind about deleting the styles in your current project.) 

2. Select Write > Styles > Edit Styles and select Copy Styles From....

3. Select the Help+Manual project you want to copy the stylesheet from and click on OK

to import and overwrite your stylesheet.
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Copying a project stylesheet to a new project

If you are creating a new project the easiest way to copy the stylesheet from an existing

project is to use the existing project as a "template" for the new project. Then all the styles

of the existing project will be included in the new project automatically, along with all of

the project's other settings. 

1. Open the project, click on the File menu and make a copy of it using Save As... 

2. Delete all the topic files that you don't want to use in the new project.

3. Check your project settings in the Configuration section in the Project Explorer and

update anything that needs to be changed for the new project (project title, copyright

dates etc).

This is by far the quickest way to set up a new project if you wish to continue using the

same basic style, appearance and layout.

· See Templates for projects  for details.

Copying individual styles from one project to another

You cannot copy individual styles from other projects directly but it is still possible with

this little trick:

1. Open the project you want to copy the style to. We will call this Project A. 

2. Open the project you want to copy the style from. We will call this Project B.

3. In Project B find a paragraph (for paragraph styles) or a piece of text (for text styles)

formatted with the style you want to copy. Use copy and paste to copy this paragraph

or text to a topic in Project A. If you now click in this text the name of its style will be

displayed in red in the style selector, like this:

4. Click anywhere in the copied text and select Write > Styles > Create Style from Selec-

tion. 

See Turning formatting into styles  for full instructions.

See also:
Templates for projects

Defining styles

Transforming your output with skins
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5.7.13 Table styles

Table styles define the formatting of the table itself – the table width and width mode, bor-

ders and border style, background colors and so on. They do not define the formatting of the

text inside the tables – that must be formatted with styles or the manual formatting tools. 

How to align a table with a paragraph style

You can control the alignment of a table by applying a style to the paragraph containing

the table – for example to center a fixed-width table or to indent the left and right sides of

the table from the margins of the page. Only the paragraph attributes will have an effect,

text attributes will be ignored. 

1. Click on  in Write > Paragraph to display paragraph marks (this makes it easier to

see what you are doing). 

2. Click to the right of the table between the table and its paragraph mark so that you

can see the blinking editing cursor between the right margin of the table and the

paragraph mark.

3. Select the style you want to apply in the drop-down style list in the Toolbar.

How to apply styles to the contents of tables

If you select all or part of a table and apply text or paragraph styles the styles will be ap-

plied to the text in the selected cells inside the table. 

· Select text and paragraphs in the table cells and apply styles just as you would in the

normal editor. You can also apply styles to multiple paragraphs in multiple cells by se-

lecting the cells and then applying the style.

Note that if you want to apply a style to all the paragraphs in a table you must select the

entire table by clicking and dragging inside the table. If you click in the left margin to se-

lect the table you will not be able to apply styles because then the table is selected and

not its contents.

How to apply a table style to a table

1. Click in the table you want to format. 
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2. Select Properties in the Table tab and then select the table style you want to use and

click on OK.

See Working with Tables > Table styles  for full details.

How to define a table style

1. Select Styles > Edit Styles in the Write tab. 

2. Click in the Table Styles section at the top, then select Add Style.

3. Enter a name for the style in the Style Name: field. 

4. If you want to base the style on another style select the parent style in the Based on

Style: field.

5. Click on Modify Layout to define the attributes of the style. The settings are just the

same as the normal table settings , although there are a couple of table settings

that cannot be included in table styles.

CSS classes for table styles

When you publish to HTML-based output formats the name of the table style is also the

class attribute of the table. For example, if the table style is called demotable it will contain

a class attribute like this:

<table class="demotable" ...

You can use this knowledge to change the formatting of tables with your own additional

CSS code in your HTML templates, attaching your rules to the class names.

Giving a table multiple class names

Help+Manual will also allow you to create table styles containing spaces. For example,

suppose you create two otherwise identical table styles called "demotable normal" and

"demotable highlight". The result in the HTML code would be:

<table class="demotable normal" ...
<table class="demotable highlight" ...

This effectively gives the tables two classes, which is allowed in CSS. You can then write in-

dividual CSS rules for the "normal" and "highlight" classes to be applied to different

groups of tables in your output that otherwise have identical formattig. 

See also:
Working with Tables
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5.7.14 Formatting program source code

Examples of program source code are much easier to read if reserved words, comments, iden-

tifiers and so on are highlighted as they are in a modern programming editor. Help+Manual's

Syntax Highlighting function does this for you. It understands the syntax of a total of 53 dif-

ferent code languages, so yours is almost certainly among them. You can also define up to

three different custom formatting sets. 

The highlighter is pre-configured with standard formatting for all these languages, but you

can change the formatting yourself for every element type in every language to suit your own

preferences. (Note that you must do this before applying your formatting. Changing high-

lighting settings does not change the formatting of code that has already been highlighted.) 

How to format program code

1. Paste your program code into your topic and select it. 

2. Select the  Syntax Highlighter tool in Write > Font (click on the arrow to the

right of the icon to display the menu) then select the language parser you want to use

from the list displayed.

If the code language you are using is not displayed select Customize... to add it to the

menu.

Once you have chosen a language parser it is set as the default until you select a different

language. You can then select it directly by clicking on the main C:\ icon of the Syntax

Highlighter tool in the Ribbon.

Editing the syntax highlighting style

The syntax highlighter uses a standard style called Code Example for the font and para-

graph attributes. By default this style is set to Courier New, 8 points, no word wrap and

keep paragraph lines together.

You cannot delete or rename this style but you can edit it. Just position the cursor in a

piece of text formatted with the syntax highlighter and select Styles > Edit Styles in the

Write tab to open the style editing dialog with the Code Example style selected. See Edit-

ing styles  for details.

Indenting with leading spaces/blanks

Program code is often automatically indented with leading spaces. To get this to display

correctly you just need to turn word wrap off in the paragraph settings of your code ex-

288
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amples, either manually or with a style (this is already set correctly in the standard Code

Example style used for syntax highlighting). Then all the spaces will be converted to

&nbsp; hard space entities which will render correctly in all browsers. Paragraphs will not

wrap, but you don't want paragraphs to wrap in program code.

In paragraphs with word wrap turned on Help+Manual converts multiple spaces to altern-

ating soft and hard space characters – otherwise browsers would interpret multiple spaces

as a single space. However, this will often not render quite right because different

browsers interpret the width of these hard/soft space combinations in different ways.

Customizing the syntax highlighter

· Click on the drop-down arrow next to  in Write > Font, then select Customize....

Syntax highlighter settings are not styles!

Note that changing highlighting settings does not change the formatting of code that has

already been highlighted. If you change your settings you must select the code again and

re-apply the highlighting. Unlike styles, the syntax highlighter only applies inline format-

ting to selected text.
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Font color and style:

You can define the font style and color for the supported elements for each highlighter
language. To change the standard syntax highlighting font face click on Edit Style and
edit the Code Example style that is used automatically by the syntax highlighter (see

above ).

Restoring the default settings:

Clicking on Reset Defaults restores all the syntax highlighter's settings for the current lan-
guage to Help+Manual's default values, including the list of reserved words.

Format code samples with soft line breaks:

Uses soft line breaks instead of full paragraph breaks. Use this when you are using back-

ground color and border settings for your code samples, then line breaks will not interrupt

the background and borders between lines.

Exporting and importing syntax highlighter settings

If you are working in a team on the same project you will want everyone to use the same

syntax highlighter settings. You can achieve this with the Load/Save Configuration button

at the bottom of the Customize dialog:

Using Load/Save Configuration

· Click on the Load/Save button to save the current configuration to a file or to load a

saved configuration.

· This saves ALL your syntax highlighting settings. It is not possible to save or load only

individual settings.

· Loading a configuration replaces ALL the current settings with those stored in the file.

310
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User-defined highlighters

The last three code languages in the list are user-defined. You can use these to describe

your own customized highlighting languages, including a list of reserved words that you

can load from an external file. 

Please see Syntax Highlighting  for a reference to the settings you can configure there.

See also:
Editing styles

Syntax Highlighting

5.7.15 Numbered and Bulleted Lists

This chapter describes how to use Help+Manual's tools for creating and managing numbered

and bulleted lists. 

Important: List formatting cannot be included in style definitions.

The formatting definitions for numbered and bulleted lists are currently still separate from the

dynamic styles. You can control text and paragraph formatting of your lists and the list in-

dents  with normal text and paragraph styles. 

The bullet types, numbering types bullets and numbering used on individual levels in multi-

level lists are all controlled by the list definitions stored in the list tools. 

These settings are applied individually to each list with the list tools and they are not dynamic

like styles. This means that changing the definition of a list in the list tool has no effect on lists

that have already been created. To change a list at the moment, you must always re-apply the

list definition. This may change in a future version of Help+Manual.

See also:
Formatting text with styles

5.7.15.1 Bulleted lists

To create simple bulleted lists you basically just need to select the tool in the Write tab and

start typing – or just select the paragraphs you want to turn into a list and then select the

tool.

To change the text and paragraph formatting of the list contents you need to apply a style or

format the paragraph and text manually. See Formatting lists  for details.
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Key Information
If you activate standard UL/OL lists  for HTML out-

put list bullet definitions are ignored. When standard

lists are enabled only the default browser bullets are

used. 

How to make a quick bulleted list

Making a new list:

1. Click in the paragraph where you want to start the list. 

2. Select the Bullets tool in the Write tab. Clicking on the left of the tool will apply the

default bullet template. Clicking on the arrow on the right of the tool displays a quick

gallery of available bullet templates:

3. Select a template to use and start typing. Alternatively you can also select Bullets and

Numbering to display the full Bullets and Numbering dialog. 

4. Select the Bullets tool again to turn the list off. Pressing Enter twice in a list without

typing any text also turns the list off.

Turning existing paragraphs into a list:

1. Select the paragraphs you want to turn into a bulleted list.  

2. Select the Bullets tool in the Write tab. Clicking on the left of the tool will apply the

default bullet template. Clicking on the arrow on the right of the tool displays a quick

gallery of available bullet templates:

341
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3. Select the template you want to apply. Alternatively you can also select Bullets and

Numbering to display the full Bullets and Numbering dialog.

Changing the bulleted list template

1. Click in the list entry (for a single entry) or select the entire list. 

2. Display the quick gallery by clicking on the arrow next to the Bullets tool:

3. Select a different template from the options in the gallery.
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Customizing a bulleted list definition

In bulleted lists you can only change the bullet character with the list definition. All other

formatting is handled by the template of the paragraph used for the list. See Formatting

lists  for details.

1. Click in the list entry (for a single entry) or select the entire list. 

2. Display the quick gallery by clicking on the arrow next to the Bullets tool:

3. Select Bullets and Numbering below the gallery to display the Bullets and Number-

ing  formatting dialog:

4. Select the bullet template you want to change, then click on Customize to edit it. If no

template is selected when you select Customize the last slot will be used automatically.

See Temporary list customization  for details.

Important: Don't use the last list template for customization you want to store. 

The last list template on the bottom right is used for temporary customization of list tem-
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plates that you don't want to save permanently. It will be overwritten by the next tempor-

ary customization. See Temporary list customization  for details.

5. The Customize button displays the customization dialog. Select one of the bullets dis-

played or click on Select Bullet to select a different bullet character.

Inactive settings:

Levels only applies to Outline numbered lists  and is inactive here. 

List indent:

The list indent is set automatically. To change it you must change the indent of the first

paragraph in the list. See Formatting lists  for details.

Inserting normal un-bulleted paragraphs in a bulleted list

Sometimes you want to insert a paragraph without a bullet within a bulleted list and have

the list continue normally after the paragraph.

1. Create all the text entries of the list with bullets, including the paragraph you want to

be un-bulleted. 
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2. Click in the paragraph you want to be un-bulleted and select List Tool in the Toolbar.

This will turn off the bullet for that paragraph. You can also do this for multiple para-

graphs.

See also:
Formatting lists

5.7.15.2 Numbered lists

To create simple numbered lists you basically just need to select the 

tool in the Write Ribbon and start typing – or just select the paragraphs you want to turn into

a list and then select the tool.

To change the text and paragraph formatting of the list contents you need to apply a style or

format the paragraph and text manually. For details see Formatting lists .

The only thing that is a little tricky at first is inserting un-numbered items within list while

maintaining the automatic list numbering. It's easy once you know how – see the instructions

below for details!

How to make a quick numbered list

Making a new list:

1. Click in the paragraph where you want to start the list. 

2. Select the Numbered List tool in the Write tab. Clicking on the left of the tool will ap-

ply the default numbering template. Clicking on the arrow on the right of the tool dis-

plays a quick gallery of available numbering templates:
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3. Select a template to use and start typing. Alternatively you can also select Bullets and

Numbering to display the full Bullets and Numbering dialog. 

4. Select the Numbered List tool again to turn the list off. Pressing Enter twice in a list

without typing any text also turns the list off.

Turning existing paragraphs into a list:

1. Select the paragraphs you want to turn into a numbered list.  

2. Select the Numbered List tool in the Write tab. Clicking on the left of the tool will ap-

ply the default bullet template. Clicking on the arrow on the right of the tool displays a

quick gallery of available numbering templates:



320

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

3. Select the template you want to apply. Alternatively you can also select Bullets and

Numbering to display the full Bullets and Numbering dialog.

Changing the numbered list template

1. Click in the list entry (for a single entry) or select the entire list. 

2. Display the quick gallery by clicking on the arrow next to the Numbered List tool:

3. Select a different template from the options in the gallery.

Restarting list numbering

Often you will want to reset the numbering of your lists, or set your lists to start with a

specific number.

Note 1: You can reset numbering at any point in a list. However, if you reset the number-

ing anywhere below the first list item, you are actually splitting the list into two lists. The

first list ends at the point above the reset numbering, the second list begins with the item

where you reset the numbering.

1. Select the items in the list you want to renumber. This will normally be the entire list,

but you can also select a section of the list. 

If you want to restart numbering in the middle of a list you must select from the point

where you want renumbering to start until the end of the list.If you want to renumber

just part of the list, select the list part and turn numbering off and then on again. This

will create a second list inside the first list, and the numbering of the first list will "jump

over" the second, new list. 
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2. Display the quick gallery (see above) and then select Bullets and Numbering to dis-

play the Bullets and Numbering  formatting dialog and select the Numbered tab:

3. Select Restart Numbering to reset the list numbering to start at 1 or Start at: to select

the number you want to start with.

Restart Numbering splits the current list

Note that Restart Numbering creates a new list that begins at the point where the num-

bering is restarted. If you restart numbering in the middle of a list you are splitting the list

into two lists with their own numbering sequences.

Inserting un-numbered paragraphs in a numbered list

Sometimes you want to insert a paragraph without numbering within a numbered list and

have the numbering continue normally after the paragraph. This method is easier than re-

setting the numbering:

1. Create all the text entries of the list with numbering, including the paragraph you want

to be un-numbered. 

2. Click in the paragraph you want to be un-numbered and select List Tool in the Tool-

bar. This will turn off numbering for that paragraph and the entries beneath the para-

graph will be re-numbered correctly. You can also select multiple paragraphs and turn

numbering off for them.

3. Now you can type text or insert a graphic in the un-numbered paragraph.

You can also restart numbering for lists that contain un-numbered paragraphs. After re-

setting the numbering (see above) the un-numbered paragraphs will be numbered again.

Just select them and click on the numbering tool to switch the numbering off again.

1340
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Customizing numbered lists

1. Click in the list entry (for a single entry) or select the entire list. 

2. Display the quick gallery (see above) and then select Bullets and Numbering to display

the Bullets and Numbering  formatting dialog and select the Numbered tab:

3. Select one of the definitions and click on Customize to modify the definition.

Important: Don't use the last list template for customization you want to store. 

The last list template on the bottom right is used for temporary customization of list tem-

plates that you don't want to save permanently. It will be overwritten by the next tempor-

ary customization. See Temporary list customization  for details.
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4. The Customize button displays this dialog

Inactive settings:

Levels and Start numbering at: only apply to Outline numbered lists  (the Start number-

ing at setting is for sub-levels). 

List indent:

The list indent is set automatically. To change it you must change the indent of the first

paragraph in the list. See Formatting lists  for details.

Number style:

Just select the style from the list, it will be displayed automatically in the preview on the

right.

Number format:

This field allows you to enter characters to be displayed to the left and the right of the

number. <L1> is the variable that enters the number in the list. Don't change or delete this

entry unless you know what effect you want to achieve!

"L" stands for "level" and since there is only one level in a normal numbered list <L1> is

the only variable you can use in single-level lists. You can use other level variables (<L2>,

<L3> and so on) in Outline numbered lists .
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1. Enter the characters you want to display with the list number to the left and right of

the <L1> variable. 

Examples:

(<L1>) will generate: (1), (2), (3) 

[<L1>]  will generate:  [1], [2], [3]

<L1>.   will generate: 1., 2., 3. 

2. Click on OK to save your changed definition. This overwrites the existing definition.

The Reset button in the Gallery resets the predefined lists to the default values.  See For-

matting lists  for information on changing the list indent.

See also:
Formatting lists

5.7.15.3 Outline numbered lists

Key Information
If you activate standard UL/OL lists  for HTML out-

put list bullet definitions are ignored. When standard

HTML lists are enabled only the default browser bullets

are used. 

Outline numbered lists, or multi-level lists, are pretty much the same as normal numbered lists

except that they also support multiple numbering levels and each level can have a different

style. This is much easier to demonstrate than to describe:

Example of an outline numbered list:

1. This is the first level of an outline numbered list. 

a. The is the second level of the list.

b. This is another second-level list entry.

2. This is another first-level entry in an outline numbered list.

a. This is a second-level entry. In this list second-level entries are numbered with a, b, c...

b. This is another second-level entry.

i) And this is a third-level entry. In this list third-level entries are numbered with i, ii,

iii...

ii) This is another third-level entry. You get the general idea...
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How to make an outline numbered list

1. Click in a paragraph or select the paragraphs you want to turn into a list. Then select

the bullets and numbering tool in Write > Paragraph. Display the quick gallery, then

select Bullets and Numbering to display the bullets and numbering  formatting dia-

log. 

2. Select the Outline Numbered tab and choose the outline list template you want to

apply. 

1340
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3. Click on OK to create the list. 

All the items in the list will initially be top-level items. See below for instructions on creat-

ing lower-level items.

Tip – turning single-level lists into outline lists:

Selecting the Numbered List tool in the Toolbar automatically creates a single-level list.

However, using the the Indent Tools in Write > Paragraph. automatically changes the

level of the current item, turning the list into a multi-level list.

Numbered List

tool:

Indent tools:

Changing item levels

1. Click in the list entry you want to make a lower-level item. 

2. Use the Indent Tools in Write > Paragraph to increase or decrease the level of the

current item. (When you are not in a list these tools change the normal paragraph in-

dents.)

List indent:

The list indent is set automatically. To change it you must change the indent of the first

paragraph in the list. See Formatting lists  for details. Note also that in multi-level lists

you only have one indent that applies for all items in the list, no matter what level they are

on.

Restarting list numbering

Note 1 – Resetting in the middle of a list: 

You can reset numbering at any point in a list. However, if you reset the numbering any-

where below the first list item, you are actually splitting the list into two lists. 

Note 2 – Resetting in the gallery only works on top-level items: 

Reset numbering in the gallery only works on the top level of a list. See Customizing out-

line numbered list definitions further below for instructions on resetting the numbering of

lower-level entries. 

334
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1. Select the part of the list you want to renumber. This will normally be the entire list,

but you can also restart at any point in the list. 

2. Select the bullets and numbering tool in Write > Paragraph. Display the quick gallery,

then select Bullets and Numbering to display the bullets and numbering  formatting

dialog.

3. Select the Outline Numbered tab. This is important! If you try to reset numbering of

an outline list in the normal Numbered tab you will get incorrect results! then select

Restart Numbering to reset the list numbering to start at 1 or Start at: to select the

number you want to start with:

1340
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Selecting different list templates

See Formatting lists  for more details on individual list formatting options. It is import-

ant to understand that the list templates just define the list bullets or numbering and the

levels for outline numbered lists. They are not styles and they do not define the paragraph

attributes of the list items, with the exception of the indent.

1. Click in the list entry (for a single entry) or select the entire list. (It does not actually

make much sense to change the appearance for a single list entry...) 

2. Select Write > Bullets and Numbering. to open the Bullets and Numbering dialog and

select the Outline Numbered tab:

3. Select one of the predefined outline numbered lists from the Gallery and click on OK. 

OR select one of the definitions and click on Customize to modify the definition. 

Important: Don't use the last list template for customization you want to store. 

The last list template on the bottom right is used for temporary customization of list

templates that you don't want to save permanently. It will be overwritten by the next

temporary customization. See Customizing lists  for details.
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The Reset  button resets the list definition for the selected style slot. It is only active if the

selected slot definition has been customized.

Customizing outline numbered list definitions

See Formatting lists  for more details on individual list formatting options. It is import-

ant to understand that the list templates just define the list bullets or numbering and the

levels for outline numbered lists. They are not styles and they do not define the paragraph

attributes of the list items, with the exception of the indent.

1. Select a list template in the Outline Numbered tab (see above). You can select any of

the predefined "slots" for customization except the last one at the bottom right. That

one is reserved for temporary customization and will be overwritten the next time

temporary customization is performed. See Temporary list customization  for de-

tails. 
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2. Then click on Customize to modify the definition. You will see this dialog:

3. Edit the list definitions for each level of your list that you want to change by selecting

the level number in the Levels box on the left. The results for each level are displayed

in the Preview box on the right.

Note that there is a separate definition for each level of your outline numbered list!

You must edit all the values for every list level that you want to change.

4. Click on OK to save your new outline numbered list definition to the Gallery. This will

overwrite the current definition.

Use the RESET button to restore a list template slot

To return a list template slot to the default settings, just select it and click on the Reset

button in the Outline Numbered tab. 
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Number style:

You can choose a different numbering style for each level. Select the level from the list on

the left, then select the numbering style. The selected style will be displayed automatically

in the preview on the right.

Number format:

This field allows you to enter characters to be displayed to the left and the right of the

number for each level.

· <L1>, <L2>, <L3> and so on are the variables that enter the numbers in the list for

each level. Don't change or delete these entries! Also note that the number of each vari-

able must correspond to the level number. For example, <L1> is for level 1, <L6> for

level 6, and so on.

· For each level, enter the characters you want to display with the list number to the left

and right of the <Lx> variable.

Examples:

(<L1>) will generate: (1), (2), (3) 

[<L1>]  will generate:  [1], [2], [3]

<L1>.   will generate: 1., 2., 3. 

Start numbering at:

This setting allows you to set the number at which numbering is to begin for the current

level. The setting is stored separately for each level and must be set for each level.

Legal numbering style:

Activates legal numbering style for outline numbered lists, with all the list numbers at the

left margin. Must be set separately for each level of an outline numbered list!

· You cannot have different indent sizes for individual levels in outline numbered lists. Be-

cause of this the legal numbering style is preferable for lists with large numbers of

levels  otherwise you would have a very large indent for the top level and smaller in-

dents for the lower levels, which does not look so harmonious.
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Level reset:

When this is selected the numbering of sub-levels in outline numbered lists always re-

starts with 1 or the equivalent. Otherwise the numbering continues from one sub-level to

the next. Must be selected separately for each level of the outline numbered list!

Changing the number of levels:

By default outline numbered lists have 9 levels. You can increase or decrease this number

with the Count: setting. The maximum number of levels is 20. Even 9 is actually far too

many – lists should never have more than four or five levels at the maximum, otherwise

they tend to be confusing for the reader.

Editing multi-level lists with customized templates

If you customize a list, apply it to the list you are working on and then edit the list

everything will be normal. You can add new levels to the list in the topic editor window

and each new level you add to the list will have the style you defined in the customization

dialog. This is because in the background, the list temporarily already has all the levels you

defined in the dialog. However, this is only valid for your current session. That leads us to

this problem:

Customized list templates don't work when I return to them the next

day!

Whoops! You spent time customizing a list template and stored it in one of the available

slots in the list dialog. Then you closed your project, returned to it the next day and added

some new levels to the list – and they had the wrong formatting! Instead of your defini-

tions in the list template, they seem to have random formatting! What gives???
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The full list template is only stored with the list for the current ses-

sion

Since list templates in Help+Manual aren't (yet) dynamic, there is no link between the

style and the list as there is for paragraph styles. However, when you apply a style to a list,

the list temporarily stores the formatting for all the levels in the background.  If you add

levels to the list, it formats them correctly because it already "knows" how all the levels are

supposed to look.

This background information is lost when you save and move to a different topic or close

the project, however. When you return and add new levels, Help+Manual will then "guess"

what the new levels are supposed to look like, and that is rarely what you defined in the

list template.

How to use a stored customized list template in the next editing session

To do this you need to re-activate the background information for the whole list. You do

this by re-applying your stored list template. 

1. Select or click in the list you want to work on in the editor. 

2. Click on the arrow on the right of the Numbered List tool in the Toolbar and then se-

lect Bullets and Numbering at the bottom of the dialog displayed to open the list gal-

lery. The list template belonging to the list will be selected if Help+Manual recognizes

it.
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3. If it's not selected, just select the slot where you stored your list definition. 

Caution: Temporary List Customization:

If you click on the Customize button when no list template is selected you start a tem-

porary list customization. This will then automatically be stored in the last template (bot-

tom right). You can use this just like the other templates, but it will be overwritten the

next time you start a temporary customization. So it's better not to use this for tem-

plates you want to reuse. See Temporary list customization  for details.

4. If you want to customize the list before applying it click on Customize after selecting

the template. See Customizing outline numbered list definitions above for details.

Otherwise, just click on OK to apply it to your list. It will then have all the information it

needs in the background for all levels for the current editing session. 

After this, the list will have all the information from the list template for the current editing

session. If you add new levels to the list, or have added them prior to reselecting the tem-

plate, they will be formatted as they are defined in the list template.

See also:
Numbered lists

Formatting lists

5.7.15.4 Formatting lists

Key Information
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By default lists have their own hidden indent for the

numbers or bullets, which is not displayed in the editor

ruler. To use your own indent you must apply a style

or format the paragraph manually. 

List definitions only define the bullet or numbering styles to be used and a standard auto-

matic indent between the number or bullet and the list item. They do not allow you to format

indents or to define paragraph formatting, and they are not linked to paragraph styles. It's

also important to know that the list formatting templates really are templates, not dynamic

styles. 

Paragraph formatting and indents can be applied manually or with styles. In addition to this

you can also change the appearance of the bullets and numbers (color, bold, italic etc) by ap-

plying manual formatting in the list items.

HTML output: Text formatting or list formatting mode?

In HTML-based output formats you can choose to have your lists formatted "as text" or as

standard HTML <ol> (numbered) and <ul> (bullets) lists. The setting for this is in the

HTML Export Options sections for WebHelp and eBooks  and for CHM and Visual Stu-

dio Help .

Lists as text are the default

By default, lists will be formatted as text, using a combination of formatting methods to

achieve maximum compatibility across different browsers, browser versions, viewers and

platforms. The advantage of this is the the formatting will be as consistent as possible on

all these platforms. 

Lists as <ol> and <ul> have some restrictions

When you use standard HTML lists Help+Manual generates HTML and CSS styling to

make the lists as accurate as possible, but it will sometimes not be as close to what you

format in the Help+Manual editor as the text formatting option.

· The general left indent of the list is included, but it will not be exact. There is still no

CSS formatting that will indent lists the same in all browsers, and this is worse in older

browsers.

· Hanging indents in lists always revert to the browser's default indent. CSS does not

have a definition for the size of the hanging indent part.

1435
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· Vertical margins should be correct. By default, browsers typically leave a huge gap

between the preceding paragraph and the first list item, because this is the default mar-

gin of the browser. Help+Manual corrects this automatically, as far as possible.

· Simple, single-level numbered lists are supported with all numbering options:

decimal, upper/lower Roman, upper/lower alpha.

· Numbered lists with level reset (change numbering at specific list items) are also sup-

ported

· The list numbering format is always the browser default, which is typically a dot (".")

following the number. Brackets, braces and the other formatting options available with

Help+Manual's list definitions are only supported  with text-based lists.

· Legal numbering in lists is not supported.

· The bullets available in lists are very limited. Even CSS3 has just 3 bullet symbols: disc,

circle and square. If the bullet defined in your Help+Manual topic matches one of the

three, the list-style-type attribute is exported. If the bullet does not match, the

list-style-type is left undefined and the browser will apply its default style (usually

a disc, circle or square).

How to change list indents

The paragraph settings of lists, including the indent for the bullets or numbers, are con-

trolled by the first item in the list. To change the indent or the paragraph formatting of

the entire list you just need to format the first item.

1. Click in the first item in the list. 

2. Adjust the indent of the list with the paragraph tool in the ruler above the editor:

You can also adjust list indents by applying an indented paragraph style to the first item in

the list. Note that in outline numbered lists you can only set one indent for the entire list,

including the lower levels.
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Formatting lists manually and with styles

· You can change the paragraph settings of an entire list by formatting the first item of

the list manually or with a paragraph style.

· If you also want to apply font settings you must apply styles to all the items in the list.

· Even though the first item controls the entire list, it is good practice to apply your para-

graph style to the entire list. Then you won't need to reformat if you ever split the list in

two.

How to make bold and colored numbering and bullets

The formatting of bullets and numbering in lists is controlled by the formatting of the last

character in the first item of the list. 

· To make bold numbering add a space to the end of the first item in the list, select the

space and make it bold. The numbering will also be bold if the entire first item is bold,

of course.

· You can use the same method to change the color of the numbering or the bullets in

the list. Just format a space at the end of the first item with a color – the space is invis-

ible so the color won't show.

See also:
Bulleted lists

Numbered lists

5.7.15.5 Temporary list customization

The last template on the bottom right in the list gallery for each list type is used for temporary

list customization. It works in exactly the same way as the other templates, but it is not stored

permanently like the other templates. It is overwritten every time you perform a new tempor-

ary customization for the current list type. 

This works because the templates are not dynamically linked to the lists formatted with them.

Changing the list template definition does not change existing lists unless you reformat them

with the updated template. 

You can use this fact to create and format more different list types than the available number

of template slots. To reuse a list type that isn't stored in a template you just need to load it

into the temporary list template slot. Then you can apply it to other lists.
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Customizing known lists

You customize existing lists by selecting or clicking in the list. Then you click on the arrow

on the right of the  or  tool in the Toolbar and then select

Bullets and Numbering at the bottom of the dialog displayed to open the list gallery. If

Help+Manual recognizes the list type it will preselect the template. 

This is the normal case. When you customize any list templates except the last one (bot-

tom right) the template is stored in your project and will be available in that project in the

future.

Customizing unknown lists 

If the list is not known no list template is preselected when you open the gallery. You then

have the following choices:

· If you click Customize for the unknown list the settings of the currently loaded list will

be loaded into the editing dialog. When you save, your changes will be automatically

saved in the last, temporary template slot. This is not permanent because it will be over-

written automatically by the next temporary customization.

· If you select any of the other templates before selecting Customize the settings from

the current list will not be loaded. Instead, you will edit the settings for that template
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and apply them to the current list when you close the dialog. The changes in the tem-

plate will be stored permanently.

Reusing the formatting of an unknown list as a template

You can use this behavior to reuse the formatting of an unknown list type as a template.

You just need to load the list formatting into the temporary template slot. Then it will be

available for use until you reuse the slot.

1. Click in the list whose formatting you want to reuse. 

2. Then click on the arrow on the right of the List tool in the Toolbar and select Bullets

and Numbering at the bottom of the dialog displayed to open the list gallery. 

3. DON'T select any list template! Instead, just click on the Customize button.

4. If you want to make any changes, you can. Otherwise, just click directly on OK. You will

see this dialog:

5. The loaded/customized settings will then be saved in the last template slot, where

they can be used just like all the other templates.
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Creating temporary customization yourself

To create a temporary customization yourself, you just need to select the last template

slot (bottom right) and customize that. You can continue to use this template in exactly

the same way as all the others. You just need to remember that it will be overwritten the

next time you perform a temporary customization. This applies for all list types (Bulleted,

Numbered, Outline Numbered).
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5.7.15.6 HTML list output format

By default Help+Manual outputs numbered and bulleted lists with <span> tags formatted as

inline-block in HTML-based output formats (HTML Help, WebHelp, Windows Exe and

ePUB eBooks, Visual Studio Help). This generally produces better results across all browsers

than the standard <ul> and <ol> lists generated when you turn the Export lists as texts op-

tion off in HTML Export Options (see below). 

Even HTML Help/CHM, which uses Internet Explorer for HTML rendering, will frequently pro-

duce unsatisfactory list formatting if you do not use this option. This applies particularly to

more complex lists and the indents used in lists.

Differences between text format and list format lists

Bullets are not specified explicitly in list format (UL)

Since the kind of bullets you can use with <ul> tags is very limited, H+M doesn't even

bother to specify them, and it does not use graphics as bullets. It just writes an un-

numbered list and lets the browser display it. In the default "export lists as text" mode the

bullets are defined specifically and the HTML page will look as close as possible to the list

in the editor. There are some limitations in Webhelp, as there is no corresponding

Unicode symbol for all the possible bullets, but most bullets should work fine.

List formatting is largely under browser control
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Help+Manual sets the list indents and basic bullet or number position in list format lists

(UL and OL) but it does not try to compensate for differences in the ways that individual

browsers manage lists. If you see differences in different browsers this is due to the

browsers rendering of the HTML list code, not anything that Help+Manual is doing. 

How to choose the HTML list output format

If you want you can configure your project to output lists as standard HTML <OL> and

<UL> tags with <LI> list elements. This will produce less attractive formatting and layout

in many cases and the appearance will vary greatly from browser to browser. However, it

may be necessary for some applications.

· Go to Configuration > Publishing Options > WebHelp/HTML Help > HTML Export

Options  and deselect the option Export lists as text.

Note that there are separate HTML Export Options settings in the WebHelp and HTML

Help configuration sections. The settings in the HTML Help section are used for HTML

Help/CHM and the two Microsoft Visual Studio Help formats. The settings in the WebHelp

section are used for WebHelp and eBooks (ePUB, Kindle and eWriter).

See also:
HTML Export Options

5.8 Managing the TOC & Topic Files

The Table of Contents (TOC) and Project Files sections in the Project Explorer are much more

than just a place to display the contents of your project. They are also a powerful editing tool

for manipulating the structure of your project. In the TOC section you can move topics around

to change the structure and organization of your project whenever you want. 

These sections are also where you will normally create new topics . You create topics in the

Table of Contents section to include them in your project's TOC. In addition to this, you can

also create topics that are not included in the TOC by creating new topic files directly in the

Project Files section.

Once you have added topics to the TOC you can manipulate them in many ways. You can

move them around, change their names, status and icons, cut and paste them (also between

projects) and demote or promote them to change their positions and status in the TOC tree

hierarchy.

All these operations can be performed in seconds with the mouse and/or simple keyboard

and menu commands. 
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Managing the TOC & Topic Files

Ø Moving, cutting and pasting topics

Ø Changing the levels of topics

Ø Exporting and importing topics

Ø Topic files without TOC entries

Ø Managing topic files in the Explorer

5.8.1 Multiple TOCs

Help+Manual's conditional output features can create a wide range of variants of your project

for different purposes. However, it is difficult to create versions with TOCs that have very dif-

ferent structures using only conditional output. The multiple TOC feature solves this problem.

It allows you to create completely different TOCs with a different structure and different

entries for different purposes.

The entries in your additional TOCs can point to the same topic files as in your main TOC. Or

they can have their own topic files that only exist in that TOC. When you publish you choose

which TOC you want to use, and only the topics referenced by that TOC are exported – in

some cases along with topic files linked to in those topics, to prevent dead links.

See Publishing projects with multiple TOCs  for details on selecting specific TOCs when you

are publishing your projects. Also see the Multiple TOCs tutorial project that you can access

directly in the Welcome page at the top of the Project Explorer on the left.

How to create an additional TOC

1. Right-click on the Table of Contents entry at the top of the Project Explorer on the left

and select Create new Table of Contents in the context menu. 
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2. This opens the New TOC dialog:

3. Enter a descriptive title for the new TOC and choose whether you want it to be empty

or a copy of the current TOC. If this is your first additional TOC you probably want it to

be empty rather than a full copy of the entire TOC. Later you may want to make copies

of existing additional TOCs that you then edit.
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4. Then create new entries in the new TOC in any of these ways:

o Drag items from another TOC into the new one (onto the empty node if it doesn't

yet have any entries). This does not create new topics. It only creates new refer-

ences to existing topics.

o Copy and paste from another TOC.

o Create new entries with the Add Topic tool in the Project tab. If you use the TOC

Link option it creates new entries for existing topics. If you use the New Topic op-

tion you will create completely new topics.

IMPORTANT: The "main" TOC always includes all topics!

To maintain compatibility with existing projects, the "original" or "main" TOC in your pro-

ject will always include all topics when you publish with it. If you remove TOC entries from

it without explicitly excluding the topic files that no longer have TOC entries (by using

build options ), those files will still all be included in the background in HTML output

when you publish with the main TOC. They can then be found by search and the keyword

index. 

This only applies to CHM, WebHelp, eWriter and Visual Studio Help output. It doesn't ap-

ply to PDF, DOCX and eBooks, because there only topics that have TOC entries can ever

be included.

Only secondary TOCs automatically exclude the topics for which they do not have

TOC entries!

If you want to create an alternative TOC with a reduced or different set of topics, always

do this with a secondary TOC, not with your "main" or "original" TOC (the top one). Again:

The main TOC is always complete. If there are topic files without TOC entries in the project

they will be included in the background when you choose the main TOC unless they have

explicit build options that exclude them.

Use build options to to include hidden topics with secondary TOCs

By the same token, topic files without TOC entries will not be included automatically in the

background with secondary TOCs. Then, a topic file without an entry in the current TOC

will still be excluded even if it is set to "all builds". It will only be included if you explicitly

989



346

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

set a specific build option on it and activate that in the include options for the publishing

operation. 

Popups in secondary TOCs

When you use popup topics in secondary TOCs the popup topic files your links refer to

will not be included automatically as they are when you use the primary TOC. The All

Builds include option assigned to all topics by default only works automatically in the

primary TOC. 

When you are using multiple TOCs in your project and publishing a secondary TOC, any

popup topics you link to must be included explicitly. You can do this in two different ways:

Option 1: Dead links handling options

Go to View > Program Options > Compilers and set the dead links handling option to Si-

lently include linked topic. This is the simplest solution but it will also automatically include

any excluded topic files that you may have referenced with regular topic links. So you

should always check your compiler report for topics like these that you may have not

wanted to include. You can then handle the links with conditional text  to exclude them

automatically. 

Option 2: Set the build options of your popup topic files

Alternatively you can set the build options of your popup topic files to the output formats

that support popups, which are WebHelp, CHM, eWriter, and Visual Studio Help (if you are

using that). The eWriter format will be included automatically if you set WebHelp, so gen-

erally you will only need to set CHM and WebHelp. 

1. Right-click on the popup topic file in Project Files > Topic Files and select Include in

Builds in the context menu. 

2. Set the include options to WebHelp, CHM and (if necessary) also VSHelp. 

3. Repeat for all your poup topic files.

984
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Managing links to excluded topics in additional TOCs

When you create a TOC that is a subset of the main TOC, your topics will often contain

links to topics that are not in the new TOC. You need to take steps to deal with these links

to ensure that they are not dead and so that they do not accidentally provide access to

content you don't want to include in the version with this TOC.

Failsafe: Global options for links to excluded topics 

You can set a global option for how links to excluded topics are handled in View > Pro-

gram Options > Compilers. There are three choices:

· Silently include linked topic

In HTML-based output formats this exports the topic file without a TOC entry so that

the link displays the topic. In PDF and DOCX this has no effect, because only topics that

are in the TOC can be in the document.

· Remove link

This turns the link into plain text. The referenced topic is not exported.

· Allow links to be dead

This leaves the links unchanged in the topics but does not export the linked topic files.

So either nothing happens or an error message (404) is displayed when the user clicks

on the link. This can be good "protection" if you are managing the links with conditional

output, to make sure that the excluded topics are never seen.
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Use conditional output to replace the links with alternative text

This is basically the same approach you would use for handling the same problem in nor-

mal conditional output scenarios where topics are excluded. See this topic  for full in-

structions. 

Create conditional output build options for your additional TOCs and apply them to the

links to the external topics so with the Conditional Text tool. You can use this method to

either remove the references entirely, or replace them with alternative text or alternative

links in the version with the additional TOC. 

For example, suppose you have a TOC for a specific client. You could create a conditional

build option called CLIENT_B and then tag the link with it like this:

This inserts the first link if you are not exporting the CLIENT_B version and the second

link if you are. 

Setting the default topic with multiple TOCs

If you are using multiple TOCs in your project you can set a separate default topic for each

TOC. Then you will automatically get the correct default topic for that TOC when you use

it.

See Setting the default topic  for full details on setting and managing the default topic

for your project.

Important: The default for secondary TOCs must be set in the TOC

Default topics for secondary TOCs must be set directly in the TOC. The setting in Config-

uration > Common Properties > Language Options is only for the main TOC. 

Each TOC you define can have its own default topic. Just right-click on the topic you want

to use as the default in the TOC and select "Set as Default Topic" in the context menu.

984
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More granular control of output with include options on topic files

In addition to the conditional output tagging inside topics described above, it is also pos-

sible to apply include options to the topic files referenced by the links but not to the TOC

entries in the main TOC pointing to them. This is possible because TOC entries and topic

files are separate items and each can have their own build options.

Consider this example:



350

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

This would allow you to include the Overview topic file with your additional TOC by activ-

ating the build option CLIENT_B in your publishing settings, even if it does not have a

TOC entry. 

You can do this if you activate the global option "Allow links to be dead" to handle the

majority of links, but have a few links for which you do want to include the linked topics,

for example. 

What happens to topics like this in Word and PDF output?

When you then publish the normal TOC that includes the Overview entry to PDF or Word

you have a logical discrepancy: The TOC entry says to include it, but the topic file include

option says to exclude it. That is OK, because in those formats only topics with TOC entries

are included and the TOC entry setting then has priority. The topic will thus be included

normally.

Topics without TOC entries in additional TOCs

When you use topics without TOC entries  in combination with additional TOCs you

may need to take additional action to ensure that the topic file is included in your output.

An additional TOC acts like an include option for every topic it includes, and by default all

other topics can be excluded. Because of this, topic files that are only accessed by hyper-

179
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links and not by TOC entries may get excluded if you are not careful.

Method 1: Use the compiler option to force inclusion

This is the simplest solution. It tells Help+Manual to automatically include any topic file

that is referenced with a link in your project. Just go to View > Program Options > Com-

pilers and set the Handling of dead links option to Silently include linked topic. This will in-

clude all topic files referenced with hyperlinks, even if they don't have TOC entries. The in-

cluded topic files will be listed in the compiler report.

Side-effect: This will also include topics that were excluded from the TOC with build op-

tions, if there are links to those topics that you have overlooked. Check the compiler re-

port!

Method 2: Use a user-defined include option

Alternatively, you can define an include option  with a descriptive name like NONTOC or

something like that and apply it to the topic file  in the Topic Files section. Then you just

need to activate that option  in the Publish screen when you publish. Then all topics

tagged with that option will be included in your output. 

Creating TOC entries for "invisible" topics in PDFs

PDF is a special case because only topics with TOC entries can be included in PDF docu-

ments. If your project contains "invisible" topics that are normally only displayed with hy-

perlinks from other topics you must add TOC entries for them to be able to include them

in the PDF version of your output. This is very simple to do with the knowledge you now

have:

1. Create TOC entries for the "invisible" topics: Either drag the topic file into the TOC or

create a "new" topic and select the topic ID of the invisible topic with the  browse

button in the Topic ID: field of the new topic dialog. You might want to organize these

TOC entries as one or more special chapters in your TOC. 

2. Apply build options to the new TOC entries so that they are only included in the PDF

version of your output. See See Including and excluding TOC entries above for instruc-

tions.

How to "filter" the TOC display by build/include options

You can use include options to "filter" the display of your topics in the TOC and Topic Files

section of the Project Explorer. This makes it possible for you to see only the topics that
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will be included in a specific build, so that you can preview the results of specific build op-

tions without publishing your project.

1. Apply build options to one or more topics. If you don't do this filtering will not have

any effect! See Conditions and Customized Output  for details. 

2. Select Explore > Filter in Project > Manage Topics and set the filter options you want

to apply. The filter settings are also available from the right-click menu in the Project

Explorer (Explore > Filter).

This works both in the TOC and in Topic Files. This only filters entire topics, it does not

filter conditional text tagged within your topics.

Important Notes:

· The current build settings of topics are shown in the Project Explorer, next to the topic

caption in the TOC. Topics and chapters set to All Builds (the default) will always be in-

cluded, of course – you cannot hide them.

· Filtered topics will be either shown in a different color or hidden completely. This de-

pends on your settings for When filtering the table of contents... in View > Program Op-

tions > General. See Program Options - General  for details on these settings.

See also:
Preventing dead links  (Conditional Output)

Publishing projects with multiple TOCs  (Publishing)

5.8.2 Topic Options

The Topic Options tab is accessible on the left of the main editor window and contains a num-

ber of key settings for the topic currently displayed. It enables you to view and edit a number

of settings that are assigned automatically when you create topics, and some additional op-

tional settings.
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<TITLE> tag: This is the text inserted in the <TITLE> tag in topic pages in HTML-

based output. By default this is the text displayed as the table of

contents entry displayed in the Project Explorer on the left. If you

edit the TOC entry this text changes automatically, unless you edit

this field in Topic Options manually.

If the topic header text in the box above the editor is different from

the TOC entry, the TOC entry is shown here and not the topic

header text. (Again, only if you didn't edit the title tag text manu-

ally.)

Topic ID: The address of the topic. This is used for referencing topics for links

etc. and it is also used for generating the file names of HTML files

generated for topics in HTML-based output formats.

You can change the topic ID by editing this entry. When you do

this, all the references to the topic within your project are updated

automatically. 

External references to the topic from other projects and other web

pages linking to your WebHelp cannot be updated from within

Help+Manual. They will become invalid if you change the topic ID

and must then be updated. 

Anchor: Target of the TOC entry for the topic. Normally this is the top of the
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topic, but if there are anchors defined in the topic you can select

one here. Then the TOC entry will scroll down to the anchor when it

is selected.

This option is normally only used for topics with multiple TOC

entries . Then each entry can link to the appropriate part of the

topic. Don't let this possibility tempt you to make excessively long

topics – that is generally a bad idea. Normally, it is much better to

have a separate document for each topic.

Topic class: There are two possible classes: Default and Popup. Most topics will

be default topics. The popup class can only be selected for topics

that don't have TOC entries, because popup topics are not allowed

to have TOC entries. See Creating popup topics  for details. 

Help context: Optional numeric context IDs for use in Microsoft HTML Help/CHM

files. You only need these if your programmers are using context

IDs for references from your application to the CHM help file. See

the chapters on context sensitive help  and the Help Context

Tool  for more details.

HTML Page Tem-

plate:

This selects the HTML layout template to be used for this topic in

HTML-based output formats. Normally this will be the standard De-

fault template. You can only select additional templates here if you

have defined them yourself . 

Topic Status: This just provides another way to select and set the status for the

current topic  displayed in the table of contents in the Project Ex-

plorer on  the left. This is design-time only – the status is not expor-

ted to your output. 

Keywords: The index keywords associated with the topic. You can enter them

directly here or centrally with the Index tool  (Professional and

Floating license versions only).

A-Keywords: These are special "associative" keywords that are only supported in

the Microsoft HTML Help/CHM help format. See this topic  for

more details on this.

Description: An optional description of the topic. This has two uses:

1. Source for the description meta tag  for search engine

optimization in WebHelp. 
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2. Future use for alternative table of contents layouts with de-
scriptions and images as well as titles.

Featured image: This allows you to associate an image with the topic that can then
be used in topic templates and PDF title pages for chapters. 

In HTML templates you can use the TOPIC_PICTURE  variable
to insert the images in your templates. 

See the help of the Print Manual Designer program for details on
how to use the featured images to create title pages for chapters in
PDF output.

Topic variables: This table can be used to change the definition of user-defined or

global variables for the current topic only. See this topic for de-

tails .

5.8.3 Topic History - Previous Versions

Help+Manual can archive every previous version of every topic whenever you save your help

project. It can be an alternative to version control systems  for individual help authors. It al-

lows you to compare multiple versions of a topic and refer to or revert to a previous version if

you find that you or another author has made changes that you want to undo.

Activating topic history

Topic history needs to be activated in each project where you want to use it. You can ac-

tivate this option in Configuration  > Common Properties > Miscellaneous . 

IMPORTANT: You cannot use topic history if you are using version

control

Note that you cannot activate topic history in projects linked to version control systems.

This is also not necessary, because then the entire history of your project is stored in the

version control system.

Viewing topic history

To view and compare previous versions of the current topic select Show History in the

topic menu in the top left corner of the topic editor window:
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Comparing and reverting

When you display the history you see the previous versions on the right. You can select

which version you want to view with the menu above the history display on the left. You

can revert the current topic to the displayed history version with the option on the right.
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Deleting topic history

You can delete the history of the current project in Configuration > Common Properties

> Miscellaneous. For example, if old versions contained sensitive information you may

want to delete the history before sending a copy of the project to someone.

5.8.4 Moving, cutting and pasting topics

To change the structure of your project you need to be able to move topics around in the

Table of Contents (TOC). You can do this by dragging topics with the mouse or by cutting and

pasting. You can also copy, cut and paste between different projects in the Project Explorer.

Note that all these operations must be performed in the Table of Contents section of the Pro-

ject Explorer. Different rules apply for managing your topic files directly in the Topic Files sec-

tion – see Managing topic files in the Explorer  for details. 

Key Information
There is no UNDO in the Table of Contents (TOC) – all

changes that you make here are permanent! In addi-

tion to deleting TOC entries this also applies to cut-

ting, pasting and moving TOC entries. Use Explore >

Disable Drag & Drop in the Project tab to prevent acci-

dental changes to the TOC.

Moving and copying topics with Drag & Drop

Drag & Drop can only be used on single topics. To move or copy multiple topics you must

use Cut & Paste. You can perform these operations both within the same project and

between multiple projects open at the same time in the Project Explorer. 

Move: Select and drag with the left mouse button

Copy: Select, hold down Ctrl and drag with the left mouse button

377



358

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

· Select a topic or chapter in the TOC and drag it onto another TOC entry (target topic is

highlighted) to make topic you are dragging the child (sub-topic) of the target topic.

· Select a topic or chapter and drag it between two other topics (a blue line is displayed

between the target topics) to insert the topic you are dragging before/after the target

topic. Position the mouse pointer to the right or left of the topic caption to display the

blue line.

Note: You can create a second TOC reference  to an existing topic by holding down

Shift+Ctrl and dragging a topic in the TOC!

Copying items between multiple TOC

If you have created more than one TOC in your project with the Multiple TOCs  option

you can copy items between the TOC with the methods described here.

However, there is an important difference: When you copy items between multiple TOC a

new topic is never created. The copied item in the second TOC is always a new reference

to the existing topic in the other TOC, not a completely new topic.

If you want to create new topics in additional TOCs you must really create a new topic.

Moving topics with the Ribbon tools

The Ribbon tools can only be used on single topics. To move multiple topics you must use

Cut & Paste (see below).
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The Up and Down arrows

move topics.

Select the topic you want to move, then select the blue Up or Down arrow in Project >

Manage Topics to move the selected topic up and down one step at a time.

Moving and copying topics with Cut & Paste

You can use Cut & Paste to move and copy multiple topics and chapters at the same time.

To select multiple entries use Shift+Click to select continuous blocks of entries and

Ctrl+Click to select multiple individual entries in different locations.

1. Select a topic or chapter in the TOC or in Topic Files and then use one of the Copy or

Cut options: 

Keyboard shortcuts: Ctrl+C (copy), Ctrl+X (cut)
Ribbon: Clipboard tools
Context menu (right-click in TOC): Copy, Cut

2. Click on the topic after which you wish to insert the topic and use one of the Paste

options:

Keyboard shortcuts: Ctrl+V

Ribbon: Clipboard tools

Context menu (right-click in TOC): Paste

When you copy topics "(COPY)" is added to the topic caption in the TOC and "_2" (or _3

etc.) is added to the Topic ID in the to prevent duplicates. See Multiple TOC entries for

one topic  for an alternative to copying. 

Moving and copying topics between projects

You can also copy and move single and multiple topics and chapters between projects:

1. Open the second project in the Project Explorer. See Using the Project Explorer  for

details. Alternatively, you can also open the second project in a second instance of

Help+Manual (just start Help+Manual a second time and open the project there). 

2. Follow the instructions above to copy or move topics and chapters.

See also:
Promoting and demoting topics

Copying, cutting and pasting  (text and content)

Importing topics and merging projects
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5.8.5 Editing the TOC caption and topic header

The topic caption is the title of the topic displayed in the TOC, both in Help+Manual and in

your output. For example, captions are displayed as the TOC titles in the Contents pane of the

HTML Help viewer and the Contents page of a PDF file. 

When you create a new topic the caption text is duplicated in the topic header, which is the

title displayed in the editing box above the topic itself. The header is also displayed in your

output, for example above the topics in the HTML Help viewer.

How to edit the caption (title) of a topic in the TOC

1. Click on the topic in the TOC. 

2. Press F2 or click on the  Edit Caption button in Project >  Manage Topics.

3. Edit the caption and then press Enter to finish

Editing the topic header separately

When you create a new topic its caption is automatically duplicated in the topic header. If

you only edit the caption the header is also updated automatically so that the caption and

the header remain identical. However, if you want you can also make the topic header dif-

ferent – for example so that you have a short caption for the TOC and a longer, more de-

scriptive header.

· Click in the header box above the Page Editor end edit the header text. When you do

this the header and the caption are no longer linked and can then both be edited sep-

arately.
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· To "re-link" the caption and the header again just make the text in both identical again.

Then the header will automatically be updated when you edit the caption in the TOC. 

How to turn off the header

To turn off the header for a topic click open the options menu with the button in the top

left corner of the editor and disable the Topic has a separate header item in the menu. 

This turns off the header in the editor for that topic and will create a topic without a

header in your published output.

Warning: Turning off the header deletes any additional content you have added to the

header box. If you turn the header on again the box will only contain the standard topic

title, taken from the topic's TOC entry. The content will not be lost while you are still edit-

ing the current topic (you can restore it by reactivating the checkbox) but once you leave

the current topic it will be deleted permanently.

See also:
Topic headers

5.8.6 Deleting TOC entries and topics

Topics and their TOC entries are two different things. The topic content is actually stored in

the topic file, which is stored in the Project Files section of the Explorer. The TOC entry is really

just a hyperlink to the topic file, which is stored in the Table of Contents section of the Ex-

plorer. 

191
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When you click on a TOC entry, the topic file is displayed in the editor for editing, but this is

just for convenience. there are not actually any topic files in the TOC, when you click on a TOC

entry and edit the topic you are actually editing the file stored in the Topic Files section.

How to delete TOC entries

1. Select one or more entries in the Table of Contents section in the Project Explorer. You

can select multiple entries with Ctrl+Click and Shift+Click. 

2. Press the DEL key or right-click and select Delete Topic. The following dialog is dis-

played:

If you deselect the Also delete referred topic files option only the TOC entry/entries will be

deleted. This will result in topics without TOC entries in the Topic Files section. These top-

ics will not be included at all in print-style output formats like PDF and Word DOCX. In

HTML-based formats they will be included and can be displayed with topic links. They will

also be included in the search and if they contain index keywords they can also be found

in the index. If you want to exclude them you need to use conditional build options .

How to delete topic files

Note that topic files can also be deleted together with TOC entries if you delete their

entries in the TOC. See above for details.

1. Select one or more entries in the Topic Files section in the Project Explorer. You can se-

lect multiple entries with Ctrl+Click and Shift+Click. 

2. Press the DEL key or right-click and select Delete File. The following dialog is dis-

played:

969
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If you deselect the Also remove TOC references option only topic files be deleted. This will

result in TOC entries without any links to topic files. This is not normally desirable but you

may sometimes want to do this to reassign an existing TOC entry to a different topic. 

5.8.7 Sorting TOC entries

You can sort entries in the TOC alphabetically with a context menu tool. 

1. Select the chapter in the TOC containing the topics you want to sort. 

2. Right-click on the chapter and select Sort Child Nodes and then Sort Ascending or Sort

Descending to sort the topics in the chapter. 
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5.8.8 Changing the levels of topics

The Table of Contents (TOC) in most projects is organized in chapters with sub-chapters. You

can change the structure by moving topics around  and by changing their levels. Changing

the topic level is referred to as "promoting" or "demoting" a topic – promoting a topic moves

it to a higher level in the TOC, demoting it moves it to a lower level.

Topics with sub-topics are automatically displayed as "chapters", shown with a book icon in

the TOC. 

You can also organize topic files in the Topic Files section in folders and sub-folders, but this

is for convenience only. It does not have any effect on the structure of your project. 

How to promote and demote topics with the Ribbon tools

The topic tools in Project > Manage Topics can be used to move topics up and down in

the TOC (Up and Down arrows) and to promote and demote topics (Left and Right ar-

rows). These tools can only be used on single topics.
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· The Promote button (left arrow) promotes the current topic to the next level by moving

it one step to the left.

· The Demote button (right arrow) demotes the current topic to the next level by moving

it one step to the right.

How to promote and demote topics with the mouse

· Just drag the topic to the new position in the TOC. If you drag onto another topic it will

become the child of the target topic. If you drag between two topics (position mouse to

left of topic icons) it will be inserted between the target topics.

· It is easier to use Cut & Paste  to promote and demote topics over large distances in

large, complex TOCs.

See also:
Moving, cutting and pasting topics

5.8.9 Exporting and importing topics

You can export and import individual topics with the functions in the functions in the File

menu in Project > Manage Topics. You can save topics and select parts of topics to

Help+Manual XML files and you can load topics from XML, HTML, RTF and RVF files. 

These functions can be used to create a library of reusable content in Help+Manual XML topic

files, which can also be used in combination with the Snippets tool  and the topic content

templates  feature. In addition to XML files you can also load topics from HTML, Word RTF

and RVF files.
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How to export a topic as an external XML or RVF file

This method saves the entire topic file along with its title and any keywords associated

with it. Note that you cannot export multiple topics using this method. You can save as a

Help+Manual XML file or as an RVF file that can be imported by Help+Manual and some

RVF-based (RichView Format) word processors and editors.

1. Select the topic you want to export in the Project Explorer. 

2. Select File > Save Topic to File in Project > Manage Topics.

3. Select XML or RVF as the format to be saved. 

4. Select the directory where you want to save your topic file and save.

If you want to use the file as a topic content template  you must save as XML and

name the file as follows, replacing "filename" with the name you want to use (the

.template.xml extension is required): 

filename.template.xml

How to export a topic or selected text as a snippet

Topics and selected text can be exported as reusable snippets, which are also saved in

XML files. Saving an entire topic as a snippet is exactly the same as saving it with Save

Topic to File – it also exports the topic title and all the keywords. Saving selected text as a

snippet only saves the selected text and does not include any keywords or the topic title. 

1. Select the topic you want to export from in the Project Explorer. 

2. Select text in the topic if you only want to export part of the topic. You can select any

kind of content, including graphics, hyperlinks, toggles etc. If you do not select any-

thing the entire topic will be exported.

3. Select File > Save Snippet in Project Manage Topics.

4. Select the directory where you want to save the snippet and save.

See Re-using content with snippets  for more details on working with snippets.

Supported XML formats

Help+Manual can only process XML files conforming to the Help+Manual XML Language.

These can be produced by Help+Manual itself or generated by other programs that con-

form to the language schema specifications. Documentation of the Help+Manual XML

Language can be found in the Help+Manual program directory (Help-
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man_XML_ref.chm). Currently you cannot export or import any other XML formats.

How to import a topic from an external file

This method is for importing individual topics. For instructions on how to import multiple

topics from a single Word RTF file see Settings for Importing Data . 

Note that Importing a topic into an existing topic overwrites the entire contents of the ex-

isting topic! If you just want to insert another topic into the current topic use the Snippet

Tool  instead.

1. Create a new, empty topic in the position in the TOC where you want to import the

topic. Click inside the editor window in the new topic. 

2. Select File > Load Topic from File in Project > Manage Topics and select the topic file

you want to load. You can load XML, HTML, RTF and RVF files.

You can only import XML files created with Help+Manual or files created with other

programs using the Help+Manual XML Language schema. Other XML formats or

schemas are not supported. RTF files created by programs other than MS Word or

Help+Manual may contain incompatible features. If in doubt re-save the file in Word

before importing.

3. Select the topic file you want to load.

How to export topics to the Word DOCX format

To do this you must publish your project using the "selected topics" option. Unlike Save

Topic to File you can also export multiple topics at the same time with this function.

However, remember that DOCX does not support all of Help+Manual's formatting fea-

tures. If you want to re-import your topics later it is better to save as XML.

1. Select the topic or topics you want to export in the Project Explorer. 

2. Select Publish in the Project tab and select MS Word as the output format.

3. Select Selected Topics in the section under the Include Options: heading. 

4. Use the  button in the Output path and file name: field to select the location and file

name for the export.

5. Click on OK to export the topic(s).

See also:
Importing Data

Content templates for topics

Publishing your Project

Importing topics and merging projects
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5.8.10 Topic IDs and context numbers

The topic ID is the unique alphanumeric identifier of a topic. It must be unique because it is

used to reference the topic for hyperlinks and by programmers accessing the topic from ap-

plications. 

The help context number is an additional unique topic identifier. Context numbers are op-

tional for making calls to normal topics and required for making calls to field-level popups

displayed directly in applications. Most programmers now use normal IDs for calls to topics

because they are human-readable, which reduces errors.

You can view and edit topic IDs and help context numbers in the Topic Options tab on the left
of the main editor window. For more background information see IDs, Context Numbers and
Keywords  in the Reference section. 

Key Information
Accented characters, special characters and high-ASCII

characters are not permitted in IDs. For maximum

compatibility with all output formats only use a..z, A..Z,

0..9 and _ in topic IDs. Topic IDs are never seen by the

user.

How to assign and edit topic IDs

Topic IDs are assigned automatically when you create a new topic but you can also edit

them at any time. The topic ID is an alphanumeric string that is the address of the topic in

the project. It is also used to generate the HTML filename of the topic in all HTML-based

output formats.

· When you create a new topic the ID is generated on the basis of the topic caption. You

can accept the program's suggestion or edit it. Use descriptive topic IDs, it will make

your project much easier to manage. IDs can be up to 255 characters long. (Automatic-

ally-generated topic IDs are restricted to 30 characters to prevent accidental creation of

excessively long IDs.)

· To edit a topic's ID just select the Topic Options tab on the left of the main editor win-

dow and edit the ID in the Topic ID: field. 

All links and references within your project are updated automatically when you edit the

ID. However, you must update any references to the ID from your applications or other

help files yourself. You must also update any references in your own manually-written

code in HTML templates etc.
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How to assign and edit context numbers

Help context numbers are only relevant in HTML Help CHM files. They are optional for

making calls to normal topics and required for making calls to field-level popups  dis-

played directly in applications. Most programmers now use normal IDs for calls to topics

because they are human-readable, which reduces errors.

Value range:

Context numbers are stored as an unsigned 4-byte integer, which means you can enter

values between 1 and 4294967295. This is nearly 4.3 billion, so it should provide you with

a reasonable number of context numbers for most normal-sized applications.

Assigning and editing context numbers manually:

· Select the  tab and type a help context number in the Help Context:  field. Edit context

numbers in the same way.

· You can assign multiple context numbers to a single topic. To do this just separate the

context numbers by commas (no spaces required). You can then reference the same

topic with different context numbers.

Assigning context numbers automatically:

· Help+Manual can assign context numbers to new topics automatically. Activate this

function for your project in the Project Explorer in Configuration > Common Properties

> Miscellaneous.

· If you are working on modular projects make sure that you assign number ranges that

will not overlap. Remember, all context numbers must be unique!

Assigning context numbers to entire projects:

· Select the Context Tool in Project > Tools and follow the instructions displayed. See The

Help Context Tool  for details.

Assigning help context numbers to anchors

You can also assign help context numbers to anchors . This enables programmers to

make calls to a specific position within a topic. 

· To apply a context number to a new anchor just select Write > Insert Object >  and

enter a context number in the Help Context field in the Insert Anchor dialog.
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· To apply context numbers to new anchors automatically activate the anchors option in

Configuration > Common Properties > Miscellaneous.

Context numbers in WebHelp

Help context numbers are normally only relevant in HTML Help CHM files. However,

Help+Manual will also export them to WebHelp where you can use them to access topics

and anchors in topics with references in URLs. 

You would not want to use this for new WebHelp, but if you already have context num-

bers you are using for calls to your CHM files your programmers can also reference the

same numbers in WebHelp. See this topic  for details.

Descriptive and hierarchical Topic IDs

It's advisable to give topics descriptive IDs, this will make your projects much easier to

manage. In addition to this, using a "hierarchical" topic ID naming scheme will keep topics

belonging to the same chapters together in lists of topic IDs.

Suppose you have a project called Widget Editor with a chapter called The Editor that

contains the topics About the Editor, Editor Controls and Using the Editor.

Descriptive, hierarchical IDs for these topics could look something like this:

WE_Editor

WE_Editor_About

WE_Editor_Controls

WE_Editor_Using

Topic ID prefixes

Using a unique topic ID prefix for each project prevents ID conflicts in modular projects

. This allows you to use IDs like "introduction" in all your projects without creating duplic-

ates. 

If there is even a small chance that you will ever want to combine multiple projects to a

single large project you should use ID prefixes. It is best to use a 2 or 3 character project

identification prefix separated from the rest of the ID by an underscore, for example:

WE_Editor

WE_Editor_About

WE_Editor_Controls

WE_Editor_Using

900
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You can configure Help+Manual to generate a prefix of your choice automatically for

every new topic you create. Just enter the prefix you want to use in the Project Explorer in

Configuration > Common Properties > Miscellaneous. 

See also:
IDs, Context Numbers and Keywords  (Reference)

5.8.11 Multiple TOC entries for one topic

Normally you only have one item in the Table of contents (TOC) for each topic file. However,
there may be some situations where you want to use exactly the same topic in more than one
place in the TOC. 

You can do this by creating multiple references to an single topic in the TOC. The result is a

single TOC topic that can be accessed from multiple positions in the TOC. There is still only

one topic, but it is displayed in several different positions within the TOC – for example in dif-

ferent chapters.

Sometimes it is better to create a copy or to use an embedded topic. See Snippets and mul-

tiple TOC references  for more background information.

Key Information
Multiple TOC references are not copies of topics. There

is still just one topic file but with two items pointing to

it in the TOC. It is like a single room with two doors.

Creating additional topic references with Add Topic

1. Click in the TOC in the position where you want to enter the new TOC item, then select

any of the options for creating a new topic . 

2. When the Insert Topic  dialog is displayed select TOC Link on the left. Then select

Link to topic in this project.

1600
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3. Enter a title for the new TOC link in Heading in Table of Contents:, then select the ID of

the topic you want to link to from the Target Topic: list. You can also select an anchor

to scroll to if the topic contains anchors. 

4. Click on OK to create the new TOC link.

Creating additional topic references with Drag & Drop

1. Click on the topic you want to make an additional reference to in the TOC to select it. 

2. Hold down Shift+Ctrl and drag to the position where you want to create the

second reference. Dragging onto a topic makes the new reference a child (sub-topic)

of the target topic. Dragging between two topics (position mouse to left of topic

icons) inserts the reference between the target topics. (See Moving, cutting and past-

ing topics .)

Warning for Parallels users on Apple Mac computers:

If you are running Windows in Parallels on an Apple Mac computer this will not work ini-

tially. This is because by default Parallels maps the right mouse button to

357
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Shift+Ctrl+Left Click. You need to re-map this key combination in the Parallels

settings to be able to create additional TOC references with Drag & Drop.

Creating TOC entries for "invisible" topics in PDFs

PDF is a special case because only topics with TOC entries can be included in PDF docu-

ments. If your project contains "invisible" topics that are normally only displayed with hy-

perlinks from other topics you must add TOC entries for them to be able to include them

in the PDF version of your output. This is very simple to do with the knowledge you now

have:

1. Create TOC entries for the "invisible" topics: Either drag the topic file into the TOC or

create a "new" topic and select the topic ID of the invisible topic with the  browse

button in the Topic ID: field of the new topic dialog. You might want to organize these

TOC entries as one or more special chapters in your TOC. 

2. Apply build options to the new TOC entries so that they are only included in the PDF

version of your output. See See Including and excluding TOC entries above for instruc-

tions.

See also:
Using embedded topics

Moving, cutting and pasting topics

5.8.12 Topic icon, status and timestamps

You can change the standard topic icons displayed in the Table of Contents (TOC). You can

also apply a "status color" to topics in the TOC to identify topics that need more work. Every

topic file and every TOC entry has a "timestamp" which records when they were last edited. 

Productivity Tip
You can insert the date on which the topic was
last edited in the topic with a variable. See Global
predefined variables  for details.

How to change the topic icon and status color

1. Select one or more topics in the TOC. Use Ctrl+Click and Shift+Click to select

multiple topics. 

2. Select Change > Change Icon / Topic Status... in Project > Manage Topics or right-

click in the TOC and select Change Icon / Topic Status...
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Icon: Choose the new icon from the list displayed to select it. Select Automatic to re-

set the default icon.

Status color: Select the status color from the list. The status color is only displayed in

the editor, it is not exported when you publish.

HTML Help: 

Only supports the icons displayed in the Change Icon list. These are an old set of icons

dating from Windows 98 that are still hard-wired into the Microsoft HTML Help CHM

viewer

ePUB and Kindle Mobi eBooks:

These formats do not support TOC icons at all. 

WebHelp and Windows eWriter Help: 

These formats allow you to use your own icons. In the Project Explorer go to Configura-

tion > Publishing Options > WebHelp > Navigation to select your own icon graphics.

You can select three graphics: two for the open and closed state of chapters and one for

topics that are not chapters. In addition to this, the individual icons from the Help+Manual

TOC used in these formats are an updated set that are more modern than the Windows

98 icons still used by the Microsoft HTML Help CHM viewer.

Checking topic and TOC entry timestamps

Every topic file and every TOC entry stores the date and time it was last edited. These

timestamps are normally only changed when the topic or TOC entry is actually edited,

they are not changed when the project is saved. 

Topic file timestamp:

Click on the topic entry in the TOC or Project Files list. The topic file timestamp is dis-

played in the status bar below the editor. 

TOC entry timestamp:

Hover the mouse pointer over the topic entry in the TOC or Project Files list for a second

or so. The timestamp is displayed in a popup tooltip along with other information.

(Mouseover hints must be activated in View > Program Options > General.)
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Changing timestamp output for WebHelp:

If you wish, you can change the timestamps for your HTML topic files in WebHelp output

to the time the files were published instead of the last time they were edited. This setting

is in Configuration > Publishing Options > WebHelp > HTML Export Options.

5.8.13 Topic files without TOC entries

Most topics have entries in the Table of Contents (TOC). However, sometimes you also need

topics that are not included in the TOC. For example, topic files without TOC entries are re-

quired for popup topics , and they are recommended for topics that are displayed in ex-

ternal windows in HTML Help. You can also use them for topics that are only displayed when

the user clicks on a link.

To create a topic file without a TOC entry you just create the file in the Topic Files section of

the Project Explorer instead of in the Table of Contents section. 

How to create a topic file without a TOC entry

1. In the Project Explorer open the Project Files > Topic Files section. 

2. Select Add File > Add New File in Project > Manage Topics.

3. Enter the name of the topic you want to create. You can create multiple files by enter-

ing multiple names, one on each line.

4. Click on More Options and select a folder in Create in: to create the topic file in a sub-

folder that you have created in the Topic Files section.

5. Select any other relevant settings for the topic.

Organizing topic files in folders

You can create sub-folders in the Topic Files section to organize your files. It is a good

idea to use separate folders for the various different types of topics files that are not in-

cluded in the TOC to keep them separate from your TOC topic files.

1. Open the Topic Files section in the Project Explorer and select the folder that you want

to add a new sub-folder to. 

2. Select Add File > Add New Folder in Project > Manage Topics and enter a name for

the new folder.

When you create new topics you can then click on More Options and select Create in: to

create the topic file for the new topic in a specific folder.

207
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Using status options and include options topic files

You can apply both topic status and include options to topic files in the Project Files sec-

tion of the Project Explorer. Just right-click on the file in the Explorer and select the op-

tions in the context menu, or select the options in the Change menu in Project > Manage

Topics.

How to add a TOC entry to a topic file

Sometimes you may decide that you would like to add a TOC entry to a topic file that

does not yet have one. Or you want to add an additional TOC entry for a topic that

already has one. You can do this with the TOC Link option in the New Topic dialog.

Method 1: Dragging topic files into the TOC

Dragging a topic file into the TOC from the Topic Files section will also create a new TOC

entry for that topic file. It doesn't move anything. It just creates a new TOC entry. You can

also do this with multiple files. Use SHIFT+Click and CTRL+Click to select multiple files,

then drag them into the TOC.

Method 2: Creating a new TOC entry as a copy of an existing entry

You can also create a new TOC entry for a topic that already has a TOC entry by holding

down the SHIFT+CTRL keys and dragging the original TOC entry with the mouse to the

position where you want to insert the copy. Instead of moving the original entry this will

then create a new TOC entry pointing to the same topic. This only works for topics that

already have TOC entries, of course. 

Method 3: Use the TOC Link tool

The TOC Link tool in the Insert New Topic dialog creates a new TOC entry for a topic file.

Note that topics can have more than on entry in the TOC, because TOC entries are really

just links pointing to topic files. They are not part of the topic.

Tip – locating the topic ID:

You can find the ID of any topic by selecting Topic Options to the left of the editor win-

dow and checking the Topic ID: field there.

1. Click in the TOC where you want to insert the new entry and select the Add Topic tool

in Project > Manage Topics. 

2. Select TOC Link on the left and click on Link to Topic in this Project.
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3. Select the  topic ID of the topic you want to link to in the Target Topic: list. You can

optionally also select an anchor to scroll to in the Topic Anchor: field if the target topic

contains anchors.

4. Click on OK to insert the link. 

See Multiple TOC entries for one topic  for more details on this subject.

See also:
Creating new topics

Promoting and demoting topics

Conditions and Customized Output .

5.8.14 Managing topic files in the Explorer

When you are working in the Project Files section, the Project Explorer functions as a file man-

ager for your topic files and the folders where they are stored. If you are working in uncom-

pressed XML format (Professional and Floating license versions only, .hmxp project file) the

files and folders are stored directly on your hard drive. In the compressed single-file .hmxz

format the files and folders are stored inside the compressed .hmxz file, which is actually a

normal ZIP archive. 

How to "filter" the TOC display by build/include options

You can use include options to "filter" the display of your topics in the TOC and Topic Files
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section of the Project Explorer. This makes it possible for you to see only the topics that

will be included in a specific build, so that you can preview the results of specific build op-

tions without publishing your project.

1. Apply build options to one or more topics. If you don't do this filtering will not have

any effect! See Conditions and Customized Output  for details. 

2. Select Explore > Filter in Project > Manage Topics and set the filter options you want

to apply. The filter settings are also available from the right-click menu in the Project

Explorer (Explore > Filter).

This works both in the TOC and in Topic Files. This only filters entire topics, it does not

filter conditional text tagged within your topics.

Important Notes:

· The current build settings of topics are shown in the Project Explorer, next to the topic

caption in the TOC. Topics and chapters set to All Builds (the default) will always be in-

cluded, of course – you cannot hide them.

· Filtered topics will be either shown in a different color or hidden completely. This de-

pends on your settings for When filtering the table of contents... in View > Program Op-

tions > General. See Program Options - General  for details on these settings.

How to view topic files and folders in the Explorer

Folders:

Select Topic Files in the Project Files section of the Project Explorer. This will initially dis-

play a list of the folders in which your topic files are stored. How many folders are dis-

played will depend on whether you have created sub-folders:

969
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Files:

Select the Topics folder or any other folder in the Topic Files section:

Tip: You can check whether a topic file has a TOC entry with the In TOC column above

the file list on the right. By default this is the last column on the right so it may not

be visible immediately. You can rearrange the columns by dragging them left and

right with the mouse.

Checking whether topic files are in the TOC

You can check whether topic files have TOC entries with the In TOC column above the file

list on the right. You can also sort and group files by this option (see below). In addition to
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this you can also locate files that do not have TOC entries with the Report Tool  in the

Project tab.

How to sort and group files in the Project Explorer

You can sort and group files by several different criteria (name, modification status, modi-

fication date, build option, topic status). You can combine sorting and grouping: When the

files are grouped the sorting options are applied within each group.

Sorting the files:

Just left-click in the column header you want to sort by. Alternatively you can also right-

click in the column header and select the sort option in the context menu.

Grouping the files:

Right-click in the column header and select the group option in the context menu, or se-

lect Ungroup to return to an ungrouped list.

1212
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Creating folders for organizing topic files

You can create additional folders in the Topic Files section to organize your files to make

them easier to manage. For example, it is a good idea to keep topic files without TOC

entries in separate folders.

All folders must be sub-topics of the main Topics folder 

All folders you create must be sub-folders of the main Topics folder. You cannot create

additional top-level folders on the same level as the Topics folder.

Folders must contain at least one topic to appear in the file system

When you create a folder in Help+Manual in an uncompressed HMXP project it is only re-

gistered in the project file. It will not be created aS a physical sub-folder in your project

folder until you add at least one topic to it. (You won't see the folder in Windows Explorer

until it contains one or more topics.)

1. Select the folder in which you want to create your new folder – either the main Topics

folder or a sub-folder that you have already created. 

2. Right-click and select Add New Folder in the context menu, or select  Add File > Add

New Folder in Project > Manage Topics.

3.  Enter the name for the new folder and select OK.
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Moving, deleting and renaming topic files

Cutting and pasting is not possible with topic files in the Topic Files section because you

are actually dealing with physical files. (See Moving, cutting and pasting topics  for in-

structions on working with topic entries in the TOC.) However you can move files between

folders and delete files in the Topic Files section.

Moving topic files and folders:

To move a topic file from one folder to another just drag it to the new folder with the

mouse. You can also move folders in the same way. 

Deleting topic files:

Just select the topic file in the Explorer and press DEL or right-click and select Delete File. 

Renaming topic files:

You cannot rename topic files directly. To rename the topic file you need to edit the Topic

ID.

1. Select the topic file in the Explorer. 

2. Select the Topic Options tab on the left of the main editor window, edit the Topic ID

and save your project to update the Topic Files display. 

All references to the topic in the project will be updated automatically. However, since the

ID changes any references to the topic from other help projects or elsewhere will no

longer work. This includes links to specific topics in WebHelp from other websites, be-

cause the topic ID is also the name of the HTML topic file in WebHelp. 

You should thus be cautious about renaming topics, particularly topics that get a lot of

traffic on your website.

See also:
Moving cutting and pasting topics

Using the Project Explorer

5.9 Toggles: Expanding Text and Images

This feature enables you to create expanding text and images in your projects with just a few

simple clicks. Toggles are powerful and easy to use and they can make your help much more

useful and accessible to the user. They make it possible to scan the content of a topic quickly

and then click to display only the relevant information.

357
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5.9.1 About toggles

There are three different types of toggles:

Expanding section toggles 

These toggles create a header with a hidden block of text that is displayed when the user

clicks on the header. Here is an example of an expanding section toggle:

Support for toggles in Help+Manual's output formats

HTML Help, WebHelp, eWriter Help and Visual Studio Help

Toggles are fully functional in all these formats. In WebHelp JavaScript must be turned on

for the toggles to be operational. If JavaScript is turned off, the toggles are automatically

displayed in their expanded state. For eWriter Help JavaScript must be activated in the

user's Internet options in Windows, which control the configuration of the Internet Ex-

plorer based WebView component in Windows which is used to display HTML files. 

PDF, MS Word DOCX and Printed Manuals

In all these static formats toggles are automatically displayed in their expanded state. This

is the default setting. However, you can also choose to have them displayed in their col-

lapsed state if you want to do this.

eBooks

Kindle Mobi and ePUB eBooks display toggles as static text and in their expanded state.

Image toggles will display the target version of the toggle image in a separate page when

the user clicks on it.

Note: The ePUB format does officially support scripting but since virtually no readers imple-

ment this support it should never be used in ePUB. 

Expanding inline text toggles 

These toggles create a link like this Inline text toggles can be used instead of popups for definitions

and other references. that expands when the user clicks on it to display additional text, that

can be formatted in a different way to highlight it. The text is displayed in the flow of the

paragraph, as though it had been pasted into the paragraph.

Expanding image toggles 

These toggles create a small version of a graphic or other image that expands when the

user clicks on it. Here is an example of an expanding image toggle:
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Expanding Image Toggle

5.9.2 Expanding section toggles

Expanding sections display text and other content – as much as you like – when the user clicks

on the header. There are no restrictions on the content of expanding sections. You can insert

anything that you can use in normal topics, including other expanding sections and snip-

pets .

Productivity Tip
Avoid using additional tables inside your expanding

section toggles if you also plan to publish to PDF or

printed manuals.  If you do, page breaks may not work

correctly inside the rows containing additional tables. 

How to create a new expanding section

Expanding sections are handled by placing all the text and other content you want to in-

clude in the section in a single-cell table. Normally, this table will be created automatically

by the Toggle function but you can also use an existing table if you want (see further be-

low).

1. Click in your topic in the place where you want to insert an expanding section toggle.

If you want to use existing text as the expanding section header, select it in the editor. 

2. Select the Insert Toggle tool  in Write > Insert Object and select the Expanding

Text option at the top and Toggle a Table: in the middle of the dialog (these are the

default settings).

265
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3. Configure the settings in the Insert Toggle dialog  and then click on OK to insert the

toggle. This will create the toggle header with an empty, single-cell table below it. 

4. Enter or copy the text and other content you want to include in your expanding sec-

tion in the table. See further below for details on using existing text for expanding sec-

tions and expanding existing tables.

You can have a maximum of one empty paragraph between the expanding section

header and its table. If you have two or more empty paragraphs the expanding section

will not work!

5. Format the header of your expanding section if you want. You can also use styles on

the header paragraph, but you should switch off the "blue underlined" link style in the

toggle settings when you do this. See below for more details.

You can adjust the left and right indents of the toggle table by formatting the paragraph

containing the table. See below for details. 

1373
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Using an existing table for the expanding section

Normally, the Toggle Tool will automatically create an empty, single-cell table together

with your expanding section header when you create the toggle. However, you can also

toggle an existing table.

To do this just follow the instructions above to create a toggle directly above the table

you want to "toggle". In the Toggle a Table: setting select the option Toggle the table be-

low this link. This option will only be displayed if there is actually a table below the para-

graph where you are creating the toggle!

When you toggle an existing table you may need to adjust the indents of the toggle and

the table. See further below on this page for instructions.

Toggling existing tables with IDs:

Toggle links know which table to toggle by referencing the ID of the table, which is as-

signed automatically when you publish your output. If you have already assigned an ID to

your existing table this ID will be overwritten by the toggle ID. If you want the table to

keep its ID you must enter this ID as the toggle ID in the Insert Toggle  dialog. Then it

will still be overwritten, but with the correct ID. 

Formatting the expanding section headers

By default, the header (caption) of your expanding section either uses the standard hyper-

link format or plain formattable text, depending on whether the Link Style option is selec-

ted in the Insert Toggle  dialog.

Using manual formatting and styles:

If you deselect the Link Style option the header initially has the same style as the para-

graph in which it is located. You can then apply manual formatting or use a style to format

it.

· To use manual formatting select the entire toggle header and use the font formatting

tools in the Write tab. You must format the entire toggle header in exactly the same

way, otherwise you will have breaks in the toggle link.

· To use a style just click in the toggle header and select the style you want to use in the

Style Selector in Write > Font. 

1373
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Using CSS styles in HTML-based output:

Help+Manual exports individual CSS classes for all three toggle types. (The class drop-

down-toggle is assigned to the toggle headers of expanding sections.)

This means that you can define CSS styles in your HTML template to control both the ap-

pearance and behaviour of your toggle links. See Formatting toggle links  topic for de-

tails.

Note that CSS formatting only works on links when the Link Style option is selected in the

Insert Toggle  dialog! Otherwise you must format the toggle link manually or with a

style (see above).

Adjusting the indents for expanding sections

When you create the expanding section table together with its toggle both are automatic-

ally given the same indent. Normally this will be fine and will not need to be changed.

However, you may want to use a different indent and if you are using a toggle with an ex-

isting table you will probably need to make some adjustments.

Adjusting the indent of the toggle header:

The expanding section toggle header is a normal paragraph with a hanging indent for the

toggle icon (if you are  using one). Just click anywhere in the toggle and adjust the indent

settings  as you would for any other paragraph. You can also use a paragraph style

to apply the desired indents to the toggle header.

Adjusting the indent of the toggle table:

The table containing the expanding text for the toggle is a normal table. Like any other

table, it is effectively a single object in a paragraph that cannot contain any other objects.

To adjust the indent of this table you need to adjust the indent settings  of the para-

graph containing the table. This too can be done with manual formatting or with a style.

See Indenting tables  for detailed instructions on how to do this.

Using your own icons in the headers

You can also use your own icons in your toggle headers. Just select Custom Icons in the

Icon: field when you are defining or editing your toggle. Then select your icon files for the

Collapsed: and Expanded: icon states in the fields directly below.
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· You will probably have to adjust the indents of your toggle and its table manually when

you use your own icons (see above).

Suppressing icons or using different icons in PDF, eBooks, DOCX and
printed manuals

When expanding text toggles are expanded in print-style output (PDF, DOCX, eBooks,

printed manuals) the icon may not be suitable or desirable. You can remove the icon in

these outputs by selecting the Remove icon when printing option. Alternatively, you can

choose a different icon for these outputs by selecting the Custom Icons option and choos-

ing an additional icon in the Print: field. 

Replacing the standard icons with your own

When you choose one of the standard icon pairs for an expanding text toggle,

Help+Manual first looks in your project folder to see if the necessary graphics files are

there. If they are not there, it will write copies of the files to your project folder from its in-

ternal database. 

This means that if you store icons of your own in your project folder using these names

they will be used instead of the standard icons. You can also "swap" the open and closed

state icons around by renaming the icon files in your project folder. 

To replace the standard icon pairs with your own icons:

Just give your icons the names of the standard icon pairs (see below) and store them in

your project folder. Help+Manual will not overwrite them and they will be used automat-

ically when you select the corresponding standard icon option (Plus/Minus Symbol,

Folder, Arrow).

Standard Icons Filenames

Plus/Minus Symbol hmtoggle_plus0.gif

hmtoggle_plus1.gif

Folder hmtoggle_folder0.gif

hmtoggle_folder1.gif

Arrow hmtoggle_arrow0.gif

hmtoggle_arrow1.gif

See also:
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Indenting tables
Using indents

Formatting toggles with CSS

Toggle IDs  

Editing and copying toggles

5.9.3 Expanding inline text toggles

When you click on an expanding inline text toggle This is the expanding text of the inline text toggle. It

is formatted with a normal style that has been designed to make the text stand out from the paragraph. its text is

"inserted" in the topic directly after the link, as though it had been pasted into the paragraph.

This is ideal for short explanations and definitions that would otherwise disturb the flow of the

topic. It is also simpler than using a popup topic and cannot trigger popup blockers in

browsers.

How to create an inline text toggle

Making inline text toggles is quick and easy. Basically, you just enter a caption for the link

in your topic, your inline text and an optional tooltip and you're done. You can also

choose a style to format the inline text.

1. Click in your topic in the place where you want to insert your inline text toggle. If you

want to use existing text as the toggle link text select it in the editor first. 

2. Select the  Insert Toggle tool in Write > Insert Object and select the Expanding

Text option at the top and Toggle Inline Text: in the lower part of the dialog.

See Insert Toggle  for details on all the settings in the Insert Toggle dialog.

3. Enter a caption (the link text to be displayed) in the Caption: field if you did not select

text in the editor for the caption. 
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4. Optional: If you wish you can also select an open/closed icon to be displayed together

with the inline text toggle. This works in the same way as the icons used in expanding

section toggles. 

5. Enter your inline text in the text entry box directly below the Toggle Inline Text: option.

You can only enter plain text here. You can enter carriage returns with the Enter key

and they will be converted to line breaks in the output.

6. Choose a style for the inline text in the Format text with style: field. It is best to define a

style that makes the text stand out against the normal text in your topic. 

7. Click on OK to insert the toggle, which will be displayed in your topic in the same way

as other hyperlinks.

Formatting the text of inline text toggles

The inline text of these toggles can only be formatted with styles. You can only apply a

single style to the entire inline text and the style must be selected in the Insert Toggle

dialog. You should define a style that makes the text stand out well against the rest of the

text in the paragraph, otherwise the user may be confused after clicking on the toggle be-

cause the new text won't be immediately visible. 

Toggle icons:

In addition to the standard icons you can also use your own icons in inline text toggle

links. Just select Custom Icons in the Icon: field when you are defining or editing your

toggle. Then select your icon files for the Collapsed: and Expanded: icon states in the fields

directly below. You will probably have to adjust the indents of your toggle and its table

manually when you use your own icons (see above).

Selecting a style in a new toggle:

Select the style in the Format text with style: field. If you need to define a style  first just

save the toggle and then double-click on the toggle link in the editor later to open the

Edit Toggle dialog.

Applying or changing the style in an existing toggle:

Double-click on the toggle link in the editor to open the Edit Toggle dialog, then select

the style in the Format text with style field.

1373
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Formatting inline toggle links

By default, the link of your inline text toggle is displayed either with the standard hyper-

link format or as plain formattable text, depending on whether the Link style option is se-

lected in the Insert Toggle  dialog.

Using manual formatting and styles for the toggle links:

If you deselect the Link style option the link initially has the same style as the paragraph in

which it is located. You can then apply manual formatting to it or use a style to format it.

· To use manual formatting select the entire toggle link and use the font formatting

tools in the Write tab. You must format the entire toggle header in exactly the same

way, otherwise you will have breaks in the toggle link.

· To use a style select the entire toggle link and then select the style you want to use in

the Style Selector in Write > Font. 

Using CSS styles in HTML-based output:

Help+Manual exports individual CSS classes for all three toggle types. This means that

you can define CSS styles in your HTML template to control both the appearance and be-

havior of your toggle links.  (The inline-toggle class is used for expanding inline text

toggles.) See Formatting toggle links  for details.

See also:
Text Formatting and Styles

Formatting toggles with CSS

Toggle IDs

Editing and copying toggles
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5.9.4 Expanding image toggles

Click on the image to collapse it!

Expand-

ing image

toggles

like the

one on

the right

use a

small

"display

version"

of the im-

age that

the user

can click

on to dis-

play the

full ver-

sion. This can make your topic pages much easier to read because the larger versions of the

image are only displayed when needed.

Help+Manual does all the work for you. You just select the full-size image you want to display

and the smaller version is generated automatically. 

Use image styles with image toggles

Note that you can apply image styles  to the image toggle preview to set a border and

a standard width to an entire class of toggles.

How to create an expanding image toggle

To make an expanding image toggle you just select the image you want to use, choose a

zoom factor for the thumbnail display version and enter tooltips and/or captions if you

want to use them.

1. Click in your topic in the place where you want to insert your expanding image toggle.

Don't select any text (it would be deleted when you insert the image toggle). 

2. Select the Insert Toggle tool  in Write > Insert Object and select the Screenshot

Toggle option at the top of the dialog.

492
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Thumbnail: Sets the size of the preview image that the user clicks or taps on to

display the full-size image. 

% of picture size/document width: Makes the size of preview image a percent-

age of the original image size or of the document width. The second option

makes the preview responsive and relative to the width of the current browser

window. If the image is in a table the width will be relative to the table cell con-

taining the toggle image.

Style: You can apply an image style  to the image toggle preview to define a

border and a standard width.

 See Insert Toggle  for details on all the settings in the Insert Toggle dialog.

3. Select the image you want to toggle by clicking on the  browse button in the Pic-

ture file name: field. This file should be stored in your graphics folder or project folder,

just like all the other graphics in your project.

4. Select a zoom factor for the preview version and enter tooltips and captions for the

expanded and collapsed versions. 

5. Click on OK to insert your expanding image toggle.

Using a different image for the preview

You can specify a completely different image for the preview/collapsed state version. For

example, you could use a button image that the user clicks on to display a larger image,

like this:

492
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This is the expanded version.

Just select the Picture: option beneath When collapsed, use different settings... and then se-

lect the image you want to use.

When you use this option you are completely responsible for the size and appearance of

the collapsed state version. Help+Manual will not apply a zoom factor for you.

You can enter separate captions and tool tips for the preview and the expanded image. 

Using SVG images

You can also use vector-based SVG images for image toggles. The procedure is exactly

the same as when you use any other image type.

The only difference is that the smaller version of the image is a PNG with alpha transpar-

ency instead of an SVG. The SVG image will only be displayed for the full size version. 

Converting existing images into toggles

You can convert any image in your project into a toggle image. Just right-click on the im-

age and select Picture > Convert Picture to a Toggle... The procedure is then the same as

for inserting a new image toggle. 

Formatting the toggle image with CSS

The CSS class image-toggle is automatically applied to the <img> tag for your image

toggles. If you know how to use CSS and HTML you can add style definitions for this class
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to your HTML template to control the formatting of your toggle image. See Formatting

toggles with CSS  for details.

Before you do this, however, check out Image Styles , which cover most of the things

you may want to apply to images with CSS, and they also work for PDF and Word. 

See also:
Formatting toggles with CSS

Toggle IDs  

Editing and copying toggles

5.9.5 Toggle IDs

The toggle ID is optional and we recommend that you leave this field blank in the Insert

Toggle  dialog. Then Help+Manual will automatically assign a unique ID to each toggle

when you publish your help. If you don't know what HTML IDs are and how they can be used

you can ignore the ID field and this topic entirely – you don't need to worry about it.

When you need static, manually-entered IDs

You only need to enter your own ID manually if you plan to access the toggle IDs with

your own code after generating your help. The automatically-assigned IDs can change

every time you publish (they are based on the sequential order of the toggles on the

page) and so you must enter a manual ID if you always want to have the same ID to refer

to.

When you use your own IDs you have to make sure that each ID is unique in the current

topic. If you use the same ID more than once in the same topic your toggles will not work

properly. 

Auto-incrementing IDs for cloned and copied toggles

If you make copies of toggles containing manually-entered IDs within the same topic you

must change the IDs in the copies, otherwise you will have ID conflicts. Help+Manual

automatically flags copied and cloned toggles containing ID conflicts by highlighting them

in red, and it will not allow you to manually enter a duplicate ID for a toggle. 

If you want to clone toggles, for example by copying or with snippets , it can be annoy-

ing to have to manually edit the ID for every toggle you enter. You can get around this

problem by creating an automatically-incrementing ID with text variables.

You can't mix text and variables in topic IDs so you need to create two variables to do this.

1. Go to Project Explorer > Configuration > Common Properties > Text Variables and

create two text variables , one for the static part of the ID and one for the incre-
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menting number. The static part can have any name you like, the incrementing num-

ber must have two plus characters at the end of its name, for example TOGGLLENO++. 

2. Let's say the two variables are TOGGLEID and TOGGLENO++. Now enter any text you like

as the text for the TOGGLEID variable, for example mytoggle_, and a 0 (the number

zero) as the text for the TOGGLENO++ variable, like this (this example shows similar vari-

ables for use in tables):

3.  Then instead of an ID, type in both variables in the Optional ID: field in the Edit/Insert

Toggle dialog, like this:

<%TOGGLEID%><%TOGGLENO++%>

Then every time you insert a copy of the toggle in your project a new unique ID will be

generated automatically. The first will be mytoggle_1, the second will be mytoggle_2 and

so on. 

See also:
Editing and copying toggles

Counter variables for numbering

5.9.6 Editing and reusing toggles

Toggle links are normal hyperlinks so editing the links is basically just the same as editing any

other kind of hyperlink. They can also be copied and moved in the same way as normal text.

The toggle content in expanding section toggles is just normal text in a single-cell table and

can be edited normally. Note, however, that you must move the link and table of expanding

text toggles together! They will not work if you separate them.

The text of inline text toggles is stored in the Edit Toggle dialog and can be edited by double-

clicking on the toggle link.

Expanding image toggles can be edited by double-clicking on them.

How to edit toggles

Toggle links and settings:

To edit an expanding section or inline text toggle just double-click on its link in the editor

(it looks just like an ordinary hyperlink), or right-click on it and select Edit in the context

menu. This opens the Edit Toggle  dialog in which you can change all the settings of the

toggle.

396
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Toggle contents:

Expanding inline text toggles contain plain text only and must be edited in the Edit Toggle

dialog, where you can also apply a style to make the text stand out from the rest of the

topic page.

Editing the contents of expanding section toggles is exactly the same as editing normal

text in the editor. You just have to be careful that all the text is inside the table and that

you never insert more than one empty paragraph between the expanding section's table

and its header.

Expanding image toggles:

Just double-click on the toggle in the editor to access its settings.

Reusing formatted toggles with snippets

You will often want to use the same type of formatted toggle repeatedly – for example

like the toggles used for the individual instructions on this page. Instead of reformatting

the entire toggle every time, it is much easier to store a 'blank' toggle as a snippet and

just insert it in the editor every time you want to use it.

1. Create the complete toggle you want to reuse with all components, using some

dummy text in places where text is necessary. The snippet for the toggles used on this

page looks like this, for example: 

2. Select the entire item you want to reuse. 

3. Select File > Save Snippet in the Project > Manage Topics tab and save the snippet in

your project folder with a descriptive name.

4. To use the snippet, click in the place where you want to insert a new item, then select

the Snippet tool in Write > Insert Object. Activate the options "From File" and "Copy

& paste into text". Then select the snippet and click OK.
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See this chapter  in the help for more details on using snippets:

How to copy toggles

There are no restrictions on copying toggles. The copies will be fully functional, both

within the same topic and when you copy them to other topics. 

When you copy expanding section toggles you just need to make sure that you copy both

the toggle header and the toggle table containing the expanding content, because these

are two separate items.

Caution with expanding section toggles to which you have as-

signed IDs

You only have to be a little careful when you copy toggles in which you have entered the

toggle IDs yourself. When the IDs are manually entered they will not be updated automat-

ically. This is OK when you copy a toggle to a different topic but duplicate IDs within the

same topic will cause conflicts. 

When you copy toggles containing manually-entered IDs within the same topic you

should always edit the toggle and update the IDs. (Help+Manual automatically highlights

toggles with duplicate ID conflicts in red.)

See also:
Toggle IDs
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5.9.7 Formatting toggles with CSS

When your help is exported to HTML-based formats the <a> link tags for the text toggles and

the <img> tag for the image toggles are exported with CSS classes, which makes it possible to

change the appearance and behavior of your toggle links by adding CSS style definitions for

these classes to the HTML template for your topic pages.

Following the instructions in this topic requires some experience with writing HTML manually

and using CSS styles. If you feel stumped by this we recommend that you get an experienced

friend or colleague to help you. 

See the Using HTML Templates  and About HTML Templates  chapters more information

on using and editing HTML templates.

The CSS class names for the toggle link types

Help+Manual exports CSS classes to the tags used of all three toggle types. The classes

are applied three different components of the expanding section drop-down toggles. The

expanding inline text toggles and expanding image toggles only have one component

each with a class.

You must use the classes directly as properties of the tags that you want to apply them to,

otherwise they won't work properly. For example, you must use the syntax img.image-

toggle {} for defining styles for your image toggles and a.inline-toggle {} and

a.dropdown-toggle {} for defining styles for your text toggle links.

Toggle Type Class Name Notes

Expanding section

toggles link:

dropdown-toggle This is the class of the <a> tag of the

link that the user clicks on to activate

the toggle:

<a class="dropdown-toggle"
href="javas-
cript:HMToggle('toggle','TOGG
LE0186A1','TOGGLE0186A1_ICON'
)">...

Expanding section

toggles body:

dropdown-toggle-
body

This is the class of a DIV element that

encloses the actual table containing the

toggle. This element also contains the

ID of the toggle.

1026 1611
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Toggle Type Class Name Notes

Expanding section

toggles link:

dropdown-toggle This is the class of the <a> tag of the

link that the user clicks on to activate

the toggle:

<a class="dropdown-toggle"
href="javas-
cript:HMToggle('toggle','TOGG
LE0186A1','TOGGLE0186A1_ICON'
)">...

<div id="TOGGLE0186A1"
class="dropdown-toggle-body"
><table...

Expanding section

toggles icon:

dropdown-toggle-
icon

Class  of the <img> tag for the toggle

icon, if one is used. It also contains the

toggle ID with the suffix _ICON.

<img id="TOGGLE0186A1_ICON"
class="dropdown-toggle-
icon"... 

Expanding inline

text toggles:

inline-toggle Class of the <a> tag that the user clicks

on to activate the toggle:

<a class="inline-toggle"
href="javas-
cript:HMToggle('toggle','TOGGL
E0186A1')">

Expanding image

toggles:

image-toggle Class of the <img> tag containing the

preview image. It is enclosed in an <a>

tag without a class or ID that makes the

image clickable:

<a href="demoimage.png"><img
id="TOGGLE0186A1" class="im-
age-toggle" src="demoimage_-
zoom50.png"/></a>
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Example of style CSS class definitions for toggles

The following example shows you how to format your toggle links and images with a CSS

style definition using the class names listed above. The style definitions are shown inser-

ted in the standard HTML template for topic pages. The toggle styles are shown in blue,

the other style definitions are for the other hyperlink types in the help.

Sample CSS Definitions for Toggles

<%DOCTYPE%>
<html>
<head>
   <title><%TOPIC_TITLE%></title>
   <meta name="generator" content="Help &amp; Manual" />
   <meta name="keywords" content="<%TOPIC_KEYWORDS%>" />
   <meta http-equiv="Content-Type" content="text/html;
charset=<%DOCCHARSET%>" />
   <meta http-equiv="Content-Style-Type" con-
tent="text/css" />
   <link type="text/css" href="<%STYLESHEET%>"
rel="stylesheet" />

<style type="text/css"> 
<!-- These are the normal hyperlink styles -->
  a { color: #0000FF; text-decoration: none }
  a:visited {color: #0000FF }
  a:hover {color: #E4641C; text-decoration: underline }
  a.weblink {color: #0000FF; text-decoration: underline }
  a.weblink:visited {color: #0000FF}
  a.weblink:hover {color: #E4641C }
  a.popuplink {color: #FF0000; text-decoration: none}
  a.popuplink:visited {color: #FF0000}
  a.popuplink:hover {color: #FF0000; text-decoration: un-
derline}
  a.filelink {color: #04BC14; text-decoration: none}
  a.filelink:visited {color: #04BC14}
  a.filelink:hover {color: #04BC14; text-decoration: un-
derline}
<!-- These are the toggle styles -->
  a.dropdown-toggle {color: Navy; text-decoration: none; 
font-weight: bold;  font-family: "Times New  Roman",
Times, serif; }
  a.drop-down-toggle:visited {color: Navy; }
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  a.drop-down-toggle:hover {text-decoration: underline}
  a.inline-toggle {color: Green; text-decoration: none; 
font-weight: bold;  font-family: "Times New Roman", Times,
serif;  }
  a.inline-toggle:visited {color: Green; }
  a.inline-toggle:hover {text-decoration: underline}
  img.image-toggle { border: border-width: 2px; border-
color: red; border-style: solid;}
</style>   

</head>
<body style="margin: 0px 0px 0px 0px; background: <%
TOPIC_TEXT_BGCOLOR%>;">
....

See also:
Using HTML Templates

About HTML Templates  

5.9.8 Expand All / Collapse All

You can create special links with which you can allow the user to expand and collapse all the

toggles in the current topic with a single click. There are a number of very useful things you

can do with this feature. For example, it allows you to write help for both novice and experi-

enced users on the same page. You could then create More Detail / Less Detail links in the

topic header for switching between the two versions. You can also use it to create a Print but-

ton that will pre-expand all the toggles in the current topic before it is printed.

How to create Expand All and Collapse All links

1. Click in the place where you want to insert the links, for example in the header of your

topic. 

2. Select the Link tool in Write > Insert and select the Script Link tab at the left of the

dialog and HTML JavaScript as the script/macro type.

3. Enter the following code in the Script: editing box:

Version for separate links for Expand and Collapse:

Expand All: Collapse All:

javascript:HMToggleEx-
pandAll(true)

javascript:HMToggleEx-
pandAll(false)

Version for a single link that alternates between expand and collapse:

1026
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Expand/Collapse:

javascript:HMToggleExpandAll(!HMTogglesAllExpanded)

Adding Expand All and Collapse All links to all pages

To add Expand All / Collapse All links to all your pages you need to insert the necessary

code manually in the HTML template for your pages. You will need some experience in

editing HTML for this. See The topic page templates  in the Using HTML Templates

chapter for detailed instructions on how to add code to your topic page templates. 

· Locate the position in the template where you want to insert your links and then insert

the following code (you can change the title text to insert your own tooltips, of

course):

Expand All: <a href="javascript:HMToggleExpandAll(true)"
title="Tooltip text">Expand All</a>

Collapse All: <a href="javascript:HMToggleExpandAll(false)"
title="Tooltip text">Collapse All</a>

Expand/Colla
pse:

<a href="javascript:HMToggleExpandAll(!HMTogglesAllEx-
panded)" title="Tooltip text">Expand/Collapse</a>

Locating the correct position in the template:

The <%TOPIC_TEXT%> variable in the HTML template inserts the content of your topic

from the editor into the template. This means that everything inserted directly above this

variable is inserted directly before the beginning of your normal topic content, everything

directly below it is inserted directly after the end of your topic content.

The topic header is in the code between the <IF_TOPIC_HEADER> and

</IF_TOPIC_HEADER> tags. The header components are in a table. You may need to

add cells or rows to achieve the effect and positioning you want.

Conditional Expand All and Collapse All

There is a special conditional tag called <IF_TOGGLES> that you can use in your HTML

templates. This condition only evaluates true if the current topic contains one or more

toggles. This means that you can use them to create Expand All / Collapse All links that

will only be displayed in topics containing toggles. 

1036 1026
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You use this condition just like any other condition in HTML templates. Just enclose the

link code (and any other additional code you are using for the links) in a pair of

<IF_TOGGLES> condition tags, like this:

<IF_TOGGLES><a href="javascript:HMToggleExpandAll(!HMTogglesAllEx-
panded)" title="Expand/collapse hidden text">Expand/Col-
lapse</a></IF_TOGGLES>

Creating a Print button that pre-expands your toggles

You can use the Expand All function to create a Print link for HTML Help and WebHelp

that will pre-expand all the toggles in the current topic before printing it. For instructions

Printing topics containing toggles .

See also:
Using HTML Templates

The topic page templates

About HTML Templates

5.9.9 Toggle troubleshooting

Toggles are generally stable and reliable but since they are based on HTML and JavaScript

there are a few things you need to keep in mind when you are using them. Among other

things, toggles only work in formats that support both HTML and JavaScript. They are conver-

ted to static text in all other formats and they are displayed expanded by default in browsers

without JavaScript support or with JavaScript turned off.

Problems with toggle IDs

When you need to enter IDs manually:

The ID field in all three toggle types is optional and we strongly recommend that you

leave it blank unless you have a very good reason for using your own IDs – for example if

you need to access the IDs with your own program code in the output generated by

Help+Manual. If you need to do this you must enter your own IDs manually because the

automatically-assigned IDs may change every time you publish your output.

If you enter your IDs manually you must make sure that there are no conflicts between

them in the same topic. Duplicate IDs in different topics are OK but duplicate IDs within

the same topic will cause problems and malfunctions.
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Toggles don't work or clicking on one toggle "toggles" a different

toggle:

This can happen if you have duplicate IDs in the same topic when you are entering your

IDs manually. Check all the toggles in the topic for duplicate IDs. Invalid or duplicate IDs

will be displayed highlighted in red in the editor.

Problems with expanding section toggles

Clicking on the header doesn't "toggle" the section:

If you don't have duplicate IDs (see above) you have probably entered more than one

empty paragraph between the toggle header and the toggle table. You can have one

empty paragraph between the two but not more.

Unwanted interaction with other images in the same line as the

header:

The toggle header icon is a normal image. If you insert other images directly next to it the

toggle may also attempt to toggle those images. You can usually solve these problems by

editing the toggle (double-click on the header link) and saving it again with OK.

Problems with formatting in toggle links

The toggle link is broken into several individual links:

This happens when you try to format different parts of the link text differently. You can

format toggle links but you must format the entire text in exactly the same way, otherwise

the link will be broken up.

CSS styles are not applied to the links:

CSS styles  will only work if the Link style option is checked in the Edit Toggle  dialog.

If this option is not checked you must format the links in the editor, either manually or

with styles. 

399 1373
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Image toggles result in larger output files

This is normal because each image toggle must use two images instead of one. In addi-

tion to this you are probably using a larger image for the full-size version than you would

normally use. It is thus advisable to use image toggles sparingly and not to use images

that are larger than absolutely necessary, even in the full-size versions.

Page break problems in PDFs and printed manuals

Help+Manual can create page breaks within table rows and not just at row boundaries.

This means that it is OK to have a large expanding section toggle consisting of just one

big table cell with multiple paragraphs of text and other content.

However, page breaks inside tables may not work correctly if you insert tables inside other

tables. If you want to be sure your pages will break correctly in PDF don't insert additional

tables inside your main toggle tables. 

See also: 
Formatting toggles with CSS

Working with Tables

5.9.10 Updating old expanding sections

If you have imported Help+Manual 3 projects with manually-programmed expanding sections

you will probably want to replace them with toggles because they are much easier to manage.

How to convert your old expanding sections

The new toggles are not compatible with manually-programmed expanding sections so

you need to remove the old expanding sections and replace them with toggles.

Step 1: Remove all the code of the old expanding sections:

1. Check through your HTML template and remove all the code that you added to create

your expanding sections. 

2. In the Project Explorer check Project Files > Baggage Files for any files added for your

expanding sections and delete them. 

3. In the Project Explorer check Configuration > Publishing Options > HTML Help > Ex-

tended .HHP Settings for any references added for your expanding sections and de-

lete them. 

4. For each expanding section in your project delete any manually-inserted plain HTML

code blocks in your topics.
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Step 2: Create the new expanding section toggles:

1. Create a single-cell table for each expanding section and cut and paste the contents of

your expanding section into the table. 

2. Position the cursor in an empty paragraph directly above the table.

3. Select the Insert Toggle tool  in Write > Insert Object, then select the Expanding

Text and Toggle a Table: options.

4. In the drop-down box below the Toggle a Table option select Toggle the table below

this link so that the toggle uses the table containing your old expanding section text.

See also:
Expanding section toggles

5.9.11 Printing topics containing toggles

You need to do a little planning to make it possible for your users to print topics containing

toggles. Of course, this is only necessary in the formats where toggles are "active" – toggle

printing is not a problem in formats like PDF and Word DOCX because the toggles are always

static in these formats, so their entire contents are always printed (provided you have con-

figured the toggles to be displayed expanded in print mode).

In all formats where dynamic toggles are supported (WebHelp, HTML Help, MS Help 2.0) the

toggles are always printed exactly as they are currently displayed. Expanded toggles are prin-

ted expanded, collapsed toggles are printed collapsed. 

Generally, your users will want to print out the entire contents of the topic, including the con-

tents of all toggles. 

Including Expand All and Collapse All links

The simplest method is to provide your user with Expand All / Collapse All links in your

topic header, as explained in the topic Expand All / Collapse All  in this chapter. Then

they can click on Expand All before they print.

The disadvantage of this method is that you have to explain it to your users. If they miss

the explanation it may take them a while to figure out what they need to do, and they

may waste a lot of paper in the process.

Creating an auto-expanding Print link

The best solution is a Print link that automatically expands the toggles in the topic. These

are created in exactly the same way as an Expand All link, you just need to add one

more small snippet of code to send the topic to the printer after expanding the toggles:
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1. Follow the instructions for creating Expand All links  to create a new link in the loca-

tion where you want to have your Print link. 

2. Create the code for the link as follows:

Code for a Script Link: Code for your HTML template:

javascript:HMToggleEx-
pandAll(true); print();

<a href="javascript:HMToggleEx-
pandAll(true); print();">Print
this Topic</a>

See Expand All/Collapse All  for more detailed instructions on creating Print links and

buttons.

Print link with an icon instead of a text link

You can also use an icon instead of a text link for the Print function. If you use the Link

tool in the Write tab you just need to select Picture as the style and then select an appro-

priate printer icon. If you add the link to your HTML template you need to enter the code

manually.

Static icon in the HTML template:

<a href="javascript: HMToggleExpandAll(true); print();">
<img name="printbutton" border="0" alt="Print This Topic" title="Print This Topic"
src="print2.gif"></a>

Icon with a mouseover function in the HTML template: 

<a href="javascript: HMToggleExpandAll(true); print();"
onmouseover="document.images.printbutton.src='print1.gif'"
onmouseout="document.images.printbutton.src='print2.gif'">
<img name="printbutton" border="0" alt="Print this Topic" title="Print this Topic"
src="print2.gif"></a>

Add your icon images to the Baggage Files  section and replace the image names in the

above code with the filename of your own icon. 

Excluding the Print link in unsupported formats

If you also plan to generate Windows Exe or ePUB eBooks from your project you must ex-

clude the Print link there because toggles and JavaScript are not supported in eBooks

(toggles are always displayed as static text, fully expanded).
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· If you use script links enclose the links in conditional text  tags to make sure that

they are only included in the output formats where dynamic toggles are supported

(HTML Help, WebHelp and MS Help 2.0).

· If you use links in your HTML templates enclose the link code in a pair of

<IFNOT_EBOOK> </IFNOT_EBOOK> build conditions  to make sure that they are ex-

cluded from eBooks. This will work for both Windows Exe and ePUB eBooks. 

See also:
Using HTML Templates

The topic page templates

About HTML Templates

5.10 Links, Anchors, Macros, Scripts and HTML

Links, more properly referred to as "hyperlinks", are the main feature that makes electronic

help so much more useful and flexible than printed documentation. Hyperlinks allow you to

refer directly to related information, creating a non-linear "web" of information that is much

better at describing complex programs and processes than linear documentation. 

Another subject covered in this section is Help+Manual's function for editing and inserting

plain or "inline" HTML code in your help files. If you know how to code HTML you can use this

function to add features and formatting with scripts and blocks of code. 

5.10.1 Supported hyperlink types

Help+Manual can create several different types of hyperlinks, which are used for linking to

different items or providing additional functionality:

Topic links: These links create "jumps" to other help topics, which can be in the

current help project or in other help projects or help files.

Topic anchors: Anchors are not really links in their own right – they are "targets" for

other links. They allow you to create a links that go to specific posi-

tions in a topic instead of to the top of the topic.

Internet links: Links to HTML pages on the World Wide Web or email addresses.

Figure links: Creates a live reference link to a figure or table counter object, in-

cluding the current caption and number of the object.

File links: Links to external files on the user's computer.

Script links: These are not really hyperlinks in the real sense of the word. Instead

of taking the user to another page or topic, clicking on them executes
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script code that you insert.

Named destina-

tions in PDF:

In PDF files, "named destinations" are the equivalent of anchors, i.e.

named targets that you can jump to with hyperlinks, like anchors in

HTML files. Help+Manual inserts named destinations for a number of

targets in the PDFs it creates.

Named destinations are a special case and must always be linked to

using file links and a special anchor-like syntax.

See this topic in the help  for details on using and linking to named

destinations in PDF files.

5.10.2 Inserting topic links

The easiest way to create hyperlink to another topic in your current project is with Drag &

Drop – just select text in the editor and drag it onto the topic you want to link to in the Table

of Contents. 

Productivity Tip
You can navigate to the targets of your links within

your project by holding down Ctrl and clicking on the

link.

How to create a topic hyperlink with Drag & Drop

Drag topic text on to the target topic:

This method turns text in your topic into a hyperlink to a selected topic in the TOC.

1. Select the text in your topic that you want to use as the link caption (you can edit this

later). 
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2. Drag the selected text onto the topic in the Table of Contents (TOC) that you want to

link to and release the mouse button.

3. To view and edit the hyperlink settings double-click on the link to display the Hyper-

link  dialog box. 

Note: 

Be careful to drag the text onto the topic. Dragging the text between topics creates a new

topic with a title and ID based on the selected text.

Drag target topic into the topic text:

This method turns a TOC entry into a hyperlink to that entry in your topic.

1. Click on the target topic in the TOC and hold down the mouse button (if you release

the button this won't work). 

2. Drag to the position in the current topic where you want to insert the link, then release

the button. 

3. Double-click on the new hyperlink to open its properties if you want to edit the link

text etc. 

Links to anchors:

To quickly create a link to an anchor  in the current or another topic just create the link

with Drag & Drop and then double-click on the link to select the target anchor in the dia-

log. Select the anchor from the drop-down list next to the Target: field (see below for de-

tails).

Links to images, tables and captions

You can also link to images , tables  and caption objectsk  for figure and table

counters with the same drop-down list next to the Target: field. The only requirement is

that the target must have an ID. 

Links to popup topics:

You do not need to do anything special to create a popup link. Links to popup topics

in your project automatically open the target topics as popups.

How to create a topic hyperlink manually

1. Select text in your document if you want to use it as the link. You can also skip this

step and enter the caption in the hyperlink dialog. 
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2. Open the Insert Hyperlink dialog box. There are two different ways to do this:

· Press Ctrl+L

· Select the Link tool in Write > Insert

3. Right-click on the target ID to quickly copy the title of the target topic to the Caption

(Ctrl+L) or Tooltip (Ctrl+T) fields:

4. Edit the Caption: if necessary and select the link style (standard link, plain text, button

or graphic). 

You can type the <%TARGETTITLE%> variable in the Caption: field to automatically in-

sert the title of the target topic as the caption. See further below for full instructions.

5. Select the ID of the topic you want to link to from the Topic ID: list. 

If the topic contains anchors  or images and tables with IDs you can also select them

as jump targets from the drop-down list next to the Target: field. The link will then

jump directly to the position of the anchor in the topic instead of the top of the topic.

415
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See The Hyperlink dialog  for details of the other settings in the dialog. See Linking to

other projects and help files  for details on creating external links.

Links to popup topics:

You do not need to do anything special to create a popup link. Links to popup topics

in your project automatically open the target topics as popups.

Automatic hyperlink captions with the <%TARGETTITLE%> variable

When you create topic links you can insert any text you like as the link text (caption).

However, you can also insert a special variable that automatically inserts the title of the

target topic when you publish your help. The advantage of this is that the link caption will

update automatically if the title of the target topic changes.

1. Create a hyperlink using any of the methods described on this page. 

2. In the Caption: field of the Edit Hyperlink dialog enter the following variable, typing all

characters of the variable exactly as shown, including the <% and %> characters:

<%TARGETTITLE%>

Tip: Double-click on a hyperlink in the editor to display the Edit Hyperlink dialog. 

Insert page references for links in PDF and printed manuals

In print-style (non-interactive) PDFs and printed manuals links are not active – you can't

click in a paper printout. You can configure Help+Manual to automatically insert the page

numbers of the targets of topic links in a little icon directly after the link in PDFs and prin-

ted manuals. 

To activate this, go to Project Explorer > Configuration > Publishing Options > PDF >

PDF Layout and turn on the option "Insert Page Referrers". If you do this, you should also

turn on the "Underline topic links" option to make the links visible. 

How to create multiple topic links with Copy & Paste

This method works with both single and multiple links. If you copy multiple items in the

TOC and paste them in the editor the result will be a list of links to the selected topics.

1. Select one or more items in the TOC that you want to link to. Use Ctrl+Click and

Shift+Click to select multiple items. 

2. Select Copy in the Clipboard tools in the Ribbon or press Ctrl+C.

3. Click in the editor where you want to insert the links.
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4. Select Paste in the Clipboard tools the Ribbon or press Ctrl+V.

This will insert a list of links to all the items you copied from the TOC.

Opening topics in external windows in CHM

In HTML Help (.chm) you can open topics in external windows by specifying a secondary

help window type in the link definition. Just select the window type you want to link to in

the Window: field in the Insert Hyperlink dialog. 

See Using help windows  for more details. 

Linking to anchors in topics

If the target topic contains anchors  you can link to an anchor to take the user directly

to a point inside the target topic. 

· Double-click on the link in the editor to display hyperlink dialog  and select the an-

chor from the drop-down list next to the Target: field.

The procedure is the same when you are creating a new link. Just select the anchor you

want to link to from the drop-down list.

Anchors in embedded topics:

If you link to a topic containing an embedded topic any anchors in the embedded topic

will not be displayed in the drop-down anchor list. To link to an anchor in an embedded

topic make a note of the anchor ID and type it in the drop-down list box next to the Tar-

get: field manually when you edit the hyperlink.
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Topic link compatibility in publishing formats

HTML Help: Fully functional

Visual Studio

Help:

Fully functional.

WebHelp: Fully functional

Adobe PDF: Functional if activated in Configuration > Publishing Options >

Adobe PDF > PDF Layout .

Windows eWriter,

ePUB and Kindle

eBooks:

Fully functional

MS Word DOCX: Fully functional (links in DOCX are activated with Ctrl+Click in

Word)

5.10.3 Anchors - jump targets

Normally, topic links execute jumps to the top of the target topic. However, often you will also

want to create jumps to some point inside a topic. This is done with "anchors" (sometimes

also referred to as "bookmarks" in books on help). Anchors are named "jump targets" that

you insert at any position within a topic so that you can jump to them with a link.

Key Information
Anchors in Help+Manual do not have captions. They

are identified by an anchor icon in the editor.

How to insert an anchor

1. Click in the text at the point where you want to insert the anchor (i.e. the position you

want to be able to jump to with your links). 

2. If you select text the selected text will be copied and used as the anchor ID.

3. Open the Insert Anchor  dialog box. There are two ways to do this:

· Press Ctrl+H 

   OR

· Select the  anchor tool in Write > Insert 
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Type in a descriptive ID for the anchor in the Anchor ID: field. This will be displayed in

the link dialog when you are creating links so it should be easy to identify. You cannot

use spaces or special characters.

4. If you want to use a help context number  you can type it in manually (this allows

you to make calls to anchors from applications). You can also set Help+Manual to as-

sign help context numbers to anchors automatically in Configuration >  Common

Properties > Miscellaneous .

5. Type in any keywords  you want to associate with the anchor (see below  for de-

tails).

Like topic IDs, anchor IDs can be up to 255 characters long. However, since you need to

view anchor IDs in dialog boxes it is advisable to keep them relatively short. 

How to create a hyperlink to an anchor

1. First create a normal topic link to the topic containing the anchor. 

2. Open the Edit Hyperlink  dialog box. Just double-click on the link to open the dialog

if it is not already open.

3. Select the anchor ID from the drop-down list to the right of the Target: field and click

on OK.
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To quickly create a link to an anchor in the current or another topic just create the link

with Drag & Drop and then double-click on the link to select the target anchor in the dia-

log.

Linking to an anchor in the current topic

Linking to an anchor in the current topic is simple once you get your head around the

concept: Basically, you first need to create a normal topic link to the current topic, in the

same way you would if you were linking to a different topic. Then you edit the link and se-

lect the anchor.

1. Create a normal topic link  to the current topic. 

2. Double-click on the link to open its edit dialog. 

3. Select the anchor you want to link to in the anchor drop-down list directly next to the

Target: field.

Links to images, tables and caption objects

You can also link to images , tables  and caption objects  for figure and table coun-

ters, provided they have IDs. Then they are displayed in the anchors drop-down list next

to the Target: field in the same way as regular anchors.
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Creating a TOC entry linked to an anchor in the current topic

You can also create additional TOC entries  pointing to the current topic that are linked

to an anchor in the topic. Then selecting the TOC entry in the published documentation

will take the user to that anchor in the topic. This can be useful to create a "fake chapter"

consisting of a single topic. The sub-topics then point to the anchors inserted at the head-

ings for those parts of the topic.

1. Create headings in your topic for the sections and insert anchors at the beginning of

each heading or in the paragraph directly above the heading (that leaves an attractive

space at the top when the page scrolls to the anchor). 

2. Make a note of the Topic ID of the topic, which you can find in the Topic Options tab

on the left of the main editor window. 

3. Click in the TOC in the position where you want to enter the new TOC item, then select

any of the options for creating a new topic . 

4. When the Insert Topic  dialog is displayed select TOC Link on the left. Then select

Link to topic in this project.

5. Enter a title for the new TOC link in Heading in Table of Contents:, then select the ID of

the topic you want to link to from the Target Topic: list. 

6. Select the anchor you want the new TOC item to point to in the Topic Anchor list at the

bottom of the dialog. 

7. Click on OK to create the new TOC link.

Linking to anchors in linked snippets

When you create a hyperlink to a topic containing a linked snippet , any anchors stored

in the snippet will not be displayed the drop-down anchor list next to the Target: field.

371

174

1298

265



419

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

(This does not apply for snippets inserted in Copy mode, of course, which become part of

the current topic like normal pasted text.)

1. To link to an anchor in a linked snipped first view the source topic or snippet file and
make a note of the anchor IDs you want to link to. 

2. Then create the link and type the ID of the anchor you want to link to manually in the

drop-down list box next to the Target: field. 

Linking to anchors in Webhelp pages

You can also create URL links from your application or from other web pages to anchors

in WebHelp pages so that users are taken directly to a specific point in a topic when they

use your links. The syntax is exactly the same as the standard HTML syntax for URLs con-

taining anchor references:

index.html?topicname.htm#anchorname

The topic name is simply the Topic ID of the topic, plus the extension .htm. The entire

URL must be written in lower case because Help+Manual automatically converts all file

names to lower case in HTML output for compatibility with Unix and Linux servers.

See Context calls to WebHelp  for some more details on this.

Using keywords in anchors

You can also associate index keywords with anchors. Selecting these keywords in the help

index will then jump to the anchor instead of the top of the topic. See Keywords and In-

dexes  more information on using keywords and Using keywords with anchors  for

more information on using keywords in combination with anchors.

· Type the keywords into the Keywords: field of the Insert Anchor  dialog. You can enter

both main keywords and sub-keywords. Use the TAB key to enter sub-keywords (an in-

dented keyword automatically becomes the sub-keyword of the keyword above it). 

· Typing a space or tab in front of a keyword automatically makes it a sub-keyword of the

entry directly above it. Only one level of sub-keywords is allowed.

It is possible to have the same keywords in both the topic's keyword list and in one or

more anchors in the same topic. However, if you want your index entries to enable jumps

to the anchor without confusing the user it is better to avoid this.
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Editing anchor IDs, "dead" anchor links

You can edit an anchor and its ID by double-clicking on it. However, it is better not to

change anchor IDs after creating them. Unlike topic IDs, links to anchor IDs are not up-

dated if you edit them. This means that editing an anchor ID can create dead links and

links to "dead" anchors are not highlighted. The link to the page will still work, of course,

but the jump to the anchor will not.

How to locate and correct dead anchor links

Dead anchor links are not listed in your project reports . However, you can locate them

by publishing to any HTML-based output format (HTML Help, WebHelp, eBooks, Visual

Studio Help). The compiler report will list all topics containing links to undefined anchors

with links to the topics so that you can edit them and correct the anchor reference.

Tip: If you have the Professional edition of Help+Manual the easiest way to locate an an-

chor is to search for the anchor ID in the XML Source Code tab. You can  then either edit it

directly there or switch back to the editor tab and edit it there.

See also:
Inserting topic links

Using embedded topics

5.10.4 Inserting figure links

Links and references to images, tables and caption objects

The powerful Figure and Table Counter Variables  feature allows you to create automat-

ically numbered images, tables and user-defined caption objects for any other kind of ele-

ment you want to number and reference in your project. The Figure Link option in the Link

Tool is used to create links to these objects with link text that automatically shows the

caption and number of the target object.

How it works

This works in the same way as links to anchors in the topic link tool. Instead of anchors,

the dropdown list next to the Target: field shows the figure, table and caption object IDs

contained in the target topic. In addition to this, the special <\%HMFIGURECAPTION%>

variable in the link text can insert the number and caption of the target object.
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Procedure

1. Click where you want to insert the link and open the hyperlink tool. 

2. Choose Figure Link on the left, then select the ID of the topic containing the figure

from the list.

3. Select the ID of the figure from the list next to the Target: field. You will only see IDs

here if the topic contains figures with IDs.

Tip: The preview on the right scrolls to the item with the selected ID.

4. The <\%HMFIGURECAPTION%> variable inserts the caption and counter number of the

target item in the link text.

Important configuration option

Help+Manual needs to scan the entire project in advance to calculate figure link refer-

ences to elements that come later in the project than the reference. You can configure this

in advance with the Calculate figure tables setting in Configuration > Common Properties

> Miscellaneous options . If you don't turn this on and Help+Manual finds a figure

table reference that needs advance calculation during export, it will stop with an error and

ask you to restart. After this, it will be left on for the project until you turn it off.

Note that leaving this on will roughly double the time it takes to publish a project, so turn

it off unless you really need it.

Cool tip

If you hover over a figure link in the Help+Manual topic editor for a couple of seconds

you will see a preview of the target page scrolled to the target link. 
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5.10.5 Inserting Internet links

This function inserts Internet URLs and email links in your help. Internet links are supported in

all published help formats. The easiest way to create an Internet link is to type the URL in the

editor – Help+Manual will automatically recognize the URL and turn it into an active hyper-

link.

Key Information
When inserting web links always include the http:// or

https:// protocol prefix! Web links without this prefix

will almost always fail.

Creating Internet links automatically

· Type a web URL or an email address in your text. Help+Manual will automatically recog-

nize the URL and turn it into an active link. (This function can be deactivated. See Pro-

gram Options - Editor  for details.)

· Double-click on the link to edit it. 

· If you edit the link caption you must replace the <%LINK_CAPTION%> variable with the

URL that you want to link to, otherwise the link will point to the text you enter in the

caption field, which will not work.

If you don't want the address to be a link just right-click on the link and select Convert

to plain text in the context menu.

You can turn automatic URL recognition off in View > Program Options > Editor.

How to insert an Internet link manually

1. Select text in your document if you want to use it as the link. You can also skip this

step and enter the caption in the hyperlink dialog. 

2. Open the Insert Hyperlink dialog box. There are two ways to do this:

· Press Ctrl+L

· Select the Link tool in Write > Insert

1265
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3. Select the Internet Link tab:

4. Select the Email or Internet address option and enter the web page URL or the email

address. You must include the http:// prefix for URLs, otherwise they won't work.

See The Insert Hyperlink dialog  for full details on the settings in the dialog.

Inserting Internet links by Drag & Drop

You can also create web links in topics by Drag & Drop.

Just drag the URL from your browser's address bar and drop it into the editor. In most

browsers you do this by dragging the icon next to the address in the address bar.

Help+Manual will then insert a web link to the page, using the title of the page as the link

caption. 

Links to PDFs from WebHelp and HTML files

Links to named destinations in PDF from Help+Manual WebHelp

When creating links to named destinations in PDF files from WebHelp you can use exactly

the same procedure and syntax as for links from PDF files. Create a file link and follow the

instructions above. 
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Links to named destinations in PDF from other HTML files

The syntax is also the same for links to named destinations in other HTML files not gener-

ated by Help+Manual. Just create a hyperlink using the same pdf_file.pdf#named-

dest=xxxx and pdf_file.pdf#page=yy syntax for the href target of the link as you

use in Help+Manual, where xxxx is the named destination and yy is the page number.

Internet link compatibility in output formats

HTML Help: Fully functional

Visual Studio

Help:

Fully functional

WebHelp: Fully functional

Adobe PDF: Outgoing Internet links functional if activated in Configuration >

Publishing Options > Adobe PDF > PDF Layout .

eWriter Help for

Windows and

MacOS:

Fully functional

ePUB and Kindle

eBooks:

Supported in the format but remember that hardware readers may

not have Internet access 

MS Word DOCX: Fully functional

5.10.6 Inserting file links

A file link is a link to an executable file (e.g. notepad.exe) or to a data file associated with an

application  (e.g. DOC word processing files or PDF files). Clicking on the link in the help is just

like double-clicking on an executable or DOC or PDF file on your desktop or in Windows Ex-

plorer. It either starts the executable file or opens the DOC, PDF or other file with the associ-

ated application.

File links are not supported in all output formats! See the compatibility list below for details.

1442
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How to insert file links

If you plan to publish to Microsoft HTML Help (CHM), the files you link to must be stored

in the same folder as the CHM help file. The Microsoft HTML Help viewer has a bug that

makes it unable to access files outside the help file folder.

1. Select text in your document if you want to use it as the link. You can also skip this

step and enter the caption in the hyperlink dialog.

2. Open the Insert Hyperlink dialog box. There are two ways to do this:

· Press Ctrl+L

· Select the Link tool in Write > Insert

3. Select the File Link tab:

4. Enter the filename with extension in the File Name: field.

5. Enter any execution parameters associated with the file in the Execution Parameters:

field, for example the file to be opened by the executable file or any necessary para-

meters for a data file.

6. Click on Test to test the link (the file must be present in your project directory for this

to work).

See The Hyperlink dialog  for full details on the settings in the dialog.

Inserting file links with Drag & Drop

If you drag any file that is not a known image format or an RTF file into the Help+Manual

editor it will automatically be inserted as a file link.

(Image files will be inserted as images. RTF files are converted to formatted text and their

content is inserted.)

1352
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File links to page numbers and named destinations in PDF documents

You can create links to both page numbers and "named destinations" in PDF documents.

The procedure is the same for links that will be used in PDF files and in WebHelp output.

 Named destinations are jump targets that work like anchors. These links will work in PDFs

created by Help+Manual and in WebHelp created by Help+Manual, but not in CHM files.

The Microsoft CHM viewer does not support the link format needed to jump to destina-

tions in PDF files. A link to a PDF in a CHM file will simply open the PDF at the first page.

See Named destinations in PDF  for details on the named destinations created in PDFs

by Help+Manual and more background information.

Use normal topic links for targets in the current document

Note that named destinations are only needed for links between two different PDF

files or from other applications or documents. Use normal topic links to jump to tar-

gets within your Help+Manual projects (i.e. from one topic to another). You don't

need to use named destinations for this.

Requirements:

· File Links are required for linking to PDFs:

You must use the File Link option for creating links to targets inside PDF files. The

Internet Link option will not always work correctly, even in WebHelp. 

· Set the PDF to "interactive" to use named destinations:

If the PDF you are linking to is created with Help+Manual it must be generated us-

ing the "interactive PDF" option in your PDF settings . Named destinations are

only generated for interactive PDF documents.

Linking to named destinations in PDF documents:

You need to create a file link with the destination added to it to link to a destination in

a PDF document. Internet links will not work correctly, not even in WebHelp.The syntax

is the same for links that are going to be in PDF files and WebHelp files. The links to

the PDF files will also work in CHM files, but they will only open the PDF document;

they will not jump to the destination in the PDF from a link in a CHM.

Procedure:

1. Follow the instructions for inserting a file link  and enter the name of the PDF

file you want to link to. 

465
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2. Add #nameddest= after the file name, followed by the name of the named des-

tination in all lower case characters. See this topic  for details of the named des-

tinations you can jump to.

Examples:

myfile.pdf#nameddest=toc (jumps to the Table of Contents in the PDF)

myfile.pdf#nameddest=welcome_topic (jumps to the topic with the ID

Welcome_Topic)

myfile.pdf#nameddest=custom1 (jumps to user-defined template section 1)

Special case: anchors:

Links to named destinations including anchors are a special case. They will only work

in links in PDF files, not in links in WebHelp files. If you use a link with an anchor in

WebHelp output the link will only open the PDF file at the first page.

Example:

In a PDF file, the following file link will jump to the anchor testanchor in the topic

with the ID Welcome_Topic. In a WebHelp file it will only open the PDF at the first

page.

myfile.pdf#nameddest=welcome_topic#testanchor 

Linking to a page number in a PDF document:

You need to create a file link with the page number added to it do link to a page num-

ber in a PDF document. Internet links will not work correctly, not even in WebHelp.The

syntax is the same for links that are going to be in PDF files and WebHelp files. The

links to the PDF files will also work in CHM files, but they will only open the PDF docu-

ment; they will not jump to the page number in the PDF from a link in a CHM.

Important: The page number destinations in PDFs created by Help+Manual start

counting at 0, so you must jump to the actual page number minus one. If you are

jumping to pages in PDFs created by other tools you can usually jump to the actual

page numbers.

1. Follow the instructions for inserting a file link  and enter the name of the PDF

file you want to link to. 

2. Add #page= after the file name, followed by the page number:

myfile.pdf#page=123 (jumps to page 124)

myfile.pdf#page=0 (jumps to page 1, same as just opening the PDF file

465
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without a target)

myfile.pdf#page=11 (jumps to page 12)

Embedding linked files in PDF documents

You can automatically embed files referenced with file links into the PDF file when you ex-

port your project to PDF. This makes it possible to distribute additional files with your PDF

document without having to use multiple files. 

When the user clicks on the link the file will be displayed with the application with which it

is associated in Windows. This works for most file types, including other PDF files, docu-

ments and images of all kinds and even executable EXE files.

1. In the Project Explorer go to Configuration > Publishing Options > Adobe PDF >

PDF Layout and activate the option File links - embed linked files with the following ex-

tensions:. 

2. Make sure that the files you want to link to are stored in one of the folders referenced

in your Image Folders  list in your project configuration settings. If you have many

folder references place the files in one of the first few folders in the list.

3. Create your file links using the normal procedure. 

When you publish your project the files referenced with file links will be physically embed-

ded in the PDF file. You no longer need to distribute these files separately as they are now

part of the PDF. This will increase the size of the PDF accordingly, of course.

File link compatibility in output formats

HTML Help: Supported with execution parameters but do not use paths. All ex-

ternal files must be in the same directory as the HTML Help CHM

file. 

Also, note that links to some types of external files in HTML Help

are now restricted in Windows. This is a security feature implemen-

ted by Microsoft so you should test all links on properly-configured

XP systems before distributing.

Even more severe restrictions apply to HTML Help files accessed

across network drives. Here file links will not work at all and HTML

Help itself is also severely restricted. See  the EC Software web-

site for more details. It may be possible to enable the display of

CHM files on network drives but file links will not work in CHM files

on network drives.

1405
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Note that the restrictions on CHM files on network drives have be-

come more strict in Windows 7 and Vista, particularly the 64-bit

versions. In these 64-bit versions of Windows, the activation op-

tions explained on our website will only work with CHM files

opened by 64-bit applications. CHM files will not work when

opened by 32-bit applications.

WebHelp: Exported, but behavior depends entirely on the user's browser – a

file link in WebHelp is an URL to a file, with all that entails. Relative

and absolute paths are supported; relative paths must be relative to

the location of the help when it is accessed by the user. No execu-

tion parameters (for example, "wordpad.exe" on its own is OK but

"wordpad.exe myfile.doc" will not work).

eWriter Help for

Windows and

MacOS:

Fully supported, including parameters. You can even link to local

executable applications to start them. See this topic  for details. 

You can use both absolute and relative paths in file links in eWriter

Help. However, you are responsible for making sure that the targets

of the links actually exist at the time and location where the eWriter

help file is viewed! This means that you have to be certain that the

files you are linking to will be present in the target location. 

This will normally only be the case in a known environment, such as

your own corporate network. In most cases, it is advisable to only

link to files in the same folder as the eWriter Help file.

ePUB and Kindle

eBooks:

File links are not supported.

Visual Studio

Help:

File links are explicitly forbidden in Visual Studio Help.

Adobe PDF: Links to PDFs can include page number references and named des-

tinations (see above). You can link to pages and named destina-

tions in PDFs from PDFs created in Help+Manual, from PDFs cre-

ated with other tools and from HTML pages created in

Help+Manual and other tools. All links to PDF documents created

in Help+Manual should use file links. The Internet Link option will

not work correctly in some cases.

Links from PDFs created with Help+Manual can be simple file links

only, without execution parameters. Links must be activated in Con-

figuration > Publishing Options > Adobe PDF > PDF Layout  to

701
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work in PDFs (this also applies for links to named destinations and

page numbers in other PDFs).

Word DOCX: Supported but not recommended – users are very likely to move

Word DOCX documents around and the links will then be dead. No

execution parameters permitted.

5.10.7 Link lists and See Also links

The Link List tool can automatically create a variety of different lists of hyperlinks to topics

and insert them in your topic. These lists are dynamic. This means that they are not created

when you insert them, but every time you publish your project. This means that the list is al-

ways up to date at the time of publishing.

The tool is located in the Insert Object section at the right end of the Write tab:

How to use the Link List tool

Opening the tool displays this dialog:
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Just select the list type (see further below for a reference) and configure your settings:

Dialog settings:

See further below in this topic for a description of the link list types.

Exclude this topic: The current topic is not included in the link list.

Bullet list: Displays the list as a bulleted list. Otherwise it will just be displayed

as a series of paragraphs.

Inline: Displays links in a single paragraph, separated by commas.

Changed date: Includes the modification date of the referenced topics, in the se-

lected format.

Topic description: Adds the description of the current topic, if available. This is the op-

tional text that you can enter in the Description: box in the Topic

Options tab, to the left of the topic editor.

Note that the description is not included if you choose the Inline

link format. 

Fallback text: If a link list happens to be empty, because no links qualify for the

specified criteria, this text is inserted instead.

The list is inserted as a placeholder!

Note that the list is not generated when you insert it. You will only see a placeholder in

the topic editor. The actual list is generated when you publish your project so that the top-

ics it contains are always up to date.

List types and list formatting

Available list types:

Siblings of this chapter: Links to all the topics in the current chapter on the same

level as the topic in which you are inserting the list. You

will generally want to exclude the current topic from this

list.
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Sub-topics of this chapter: Includes all the sub-TOC-entries of the current topic, if

there are any.

Anchors within this topic: Links to all anchors in the same topic and creates a Mini-

TOC for navigation within the topic. The caption of the

link will be all text from the corresponding anchor to the

end of the anchor paragraph.

Topics modified within last: All the topics that have been modified/edited within the

last X days. You need to specify the number of days.

Topics modified between: All topics modified/edited between two specified dates.

List formatting:

The formatting of the list is generated automatically and based on the formatting of the

placeholder. The easiest way to achieve this is to apply a paragraph style to the place-

holder. Then the list will be formatted with that style. Otherwise just select the placeholder

and then format it with the Font and Paragraph dialogs in the Write tab.

Examples

(A) Link list with all siblings in this chapter, excluding self, no date:

Supported hyperlink types

Inserting topic links

Anchors - jump targets

Inserting figure links

Inserting Internet links

Inserting file links

Contextual Links from Applications

Linking to PDF files

Linking to WebHelp Topics

Linking to eWriter topics

Inserting script links

Editing and formatting links

Linking to other projects and help files

Preventing dead links

Named destinations in PDF

Links and secondary windows

Inserting HTML code objects

409

410

415

420

422

424

435

438

440

444

452

455

457

461

465

469

469
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A-Links and A-Keywords

(B) Recently changed topics in the entire project, short date:

(C) Topics changed between two specific dates in entire project, bul-

let list, long date:

· Table Counters, Captions and CSS  (Sunday, January 5, 2020)

· Adobe PDF and printed manuals  (Saturday, January 4, 2020)

· Special Characters  (Friday, January 3, 2020)

· CHM in Asian Languages  (Thursday, December 19, 2019)

· Featured images for title pages  (Thursday, December 19, 2019)

· The User Interface  (Thursday, December 12, 2019)

· Step 4: Synchronize the new version  (Thursday, November 28, 2019)

· Managing modules in the TOC  (Thursday, November 28, 2019)

· Microsoft HTML Help  (Thursday, November 28, 2019)

· Microsoft help compilers  (Thursday, November 7, 2019)

· The Formula Editor  (Thursday, November 7, 2019)

· Screen Capture  (Thursday, November 7, 2019)

· Selecting and formatting cells and tables  (Thursday, October 31, 2019)

· Translation-friendly Tidy XML  (Thursday, October 31, 2019)

(D) Topics changed in entire project between January 1 and October

31, 2019, bullet list, long date:

· Translation-friendly Tidy XML  (Thursday, October 31, 2019)

· Selecting and formatting cells and tables  (Thursday, October 31, 2019)

· Reference  (Tuesday, October 22, 2019)

· Importing data  (Tuesday, May 14, 2019)

· Links to help from your application  (Tuesday, May 14, 2019)

· Creating context-sensitive topics  (Tuesday, May 14, 2019)

· Getting help  (Tuesday, May 14, 2019)

· Editing topics  (Tuesday, May 14, 2019)

· Converting text to tables  (Tuesday, March 19, 2019)

· About tables  (Tuesday, March 19, 2019)

476

535

677

1387

629

118

43

1251

1103

1451

632

1232

1316

525

1198

1198

525

1261

90

897

895

65

94

531

519
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· Editing and formatting links  (Thursday, March 7, 2019)

· Styling imported formatted text  (Wednesday, February 13, 2019)

(E) Link list with all siblings in this chapter, excluding self, as

numbered list:

1. Supported hyperlink types

2. Inserting topic links

3. Anchors - jump targets

4. Inserting figure links

5. Inserting Internet links

6. Inserting file links

7. Contextual Links from Applications

8. Linking to PDF files

9. Linking to WebHelp Topics

10. Linking to eWriter topics

11. Inserting script links

12. Editing and formatting links

13. Linking to other projects and help files

14. Preventing dead links

15. Named destinations in PDF

16. Links and secondary windows

17. Inserting HTML code objects

18. A-Links and A-Keywords

(F) Link list with all siblings in this chapter, as bullet list/tree, embed-

ded in another bullet list:

· This is the static first entry of the list

o Here are some recently changed topics:

§ Supported hyperlink types

§ Inserting topic links

§ Anchors - jump targets

§ Inserting figure links

§ Inserting Internet links

§ Inserting file links

§ Link lists and See Also links

455

1162

409

410

415

420

422

424

435

438

440

444

452
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465
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§ Contextual Links from Applications

§ Linking to PDF files

§ Linking to WebHelp Topics

§ Linking to eWriter topics

§ Inserting script links

§ Editing and formatting links

§ Linking to other projects and help files

§ Preventing dead links

§ Named destinations in PDF

§ Links and secondary windows

§ Inserting HTML code objects

§ A-Links and A-Keywords

· The static list continues here

For experts: HTML formatting

Formatting with your own CSS in HTML output

When you publish to HTML-based formats topic links in link lists have an additional CSS

class hmlinklistitem.  This is added to the standard topiclink class, so that topic

links in link lists have the class attribute class="topiclink hmlinklistitem". You

can use this to format topic links in link lists differently from other topic links. 

5.10.8 Contextual Links from Applications

Basically "context help" means access to specific help information from within your applica-

tion or web page. You can create context help links and calls to Help+Manual output in a

wide variety of ways.

The options you have for implementing context-sensitive help depend on your output format,

because different formats support different ways of making calls to your help files. This topic

lists the different types of context help possible in the output formats supported by

Help+Manual.

For more details on context-sensitive help, the available context-sensitive help technologies

and implementation information for programmers see the Context-Sensitive Help &

Popups  chapter in the Reference section.

Context help links to eWriter Help: Integrated viewer

For instructions on context links to eWriter help, see both Links & Context Help  and

eWriter for Software Help  in the main eWriter Help chapter.
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Important: Updates to the eWriter context help interface

Please refer to the above chapters even if you are already familiar with eWriter help from

earlier versions. A new calling syntax has been introduced along with the new eViewer 3

and the version for MacOS. the old syntax is still supported, but we still recommend

switching to the new syntax for all new help files.

HTML Help (CHM)

This is the standard Microsoft help format for Windows applications.  It is used for help in-

stalled locally on the user's computer. 

Calls to HTML Help CHM files are made using the Microsoft HTML Help API (application

programming interface), which is documented in the help file delivered with the free Mi-

crosoft HTML Help Workshop compiler and CHM authoring package. For details see Ap-

plication calls to context-sensitive topics .

Making the calls is up to your programmers; each programming language has different

methods for doing this. You can download programming tutorials from our website.

Supported context-sensitive help types

· Calls to specific help topics

Display a specific topic in your help, inside the main help window.

· Calls to anchors in specific help topics

Display a specific topic in your help file in the main help window and scroll down to an

anchor  (jump target) within the topic.

· Field-level popups

Field-level popups  are small popup windows displayed in your application. They are

read from the help file but the main help window is not opened. Useful for document-

ing individual fields and controls in your application (thus the name).

· Training card help

Training card help uses the HTML ActiveX control (CHM) to create special interactive

links between your help topics and your application. In theory you can use training card

help to create interactive tutorials that guide users through steps of doing things in

your program. In practice it is so difficult to implement that most developers try it out

once and then decide that it is not worth their time. You can insert ActiveX objects for

training card help with Help+Manual's Write > Insert Object > Plain HTML Code com-

mand (HTML Help).

897

415

896
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Internal structure of H+M CHM files

One important thing to know about the CHM files generated by Help+Manual when mak-

ing calls to them from your applications is that there are no internal folders. 

Help+Manual uses a "flat file" directory model inside the CHM, with everything on the

root level. This means that all topics and other files inside the CHM can be accessed dir-

ectly, without any path information. Some programming tips assume the use of folders –

for example a folder called "html" for the HTML topic files – and if they also include this

path without alternatives in their call examples this will lead to failures. But that is really

the only element of H+M CHM files that you need to be aware of.

WebHelp

WebHelp is displayed in a normal web browser like Firefox, Safari, Opera or even Internet

Explorer. It is used for help accessed on networks and the Internet. Calls to WebHelp are

made with normal URLs. The basic syntax is:

index.html?topicname.htm#anchorname

where index.html is the main start page, topicname.htm is the topic ID in all lower case +

the extension ".htm" and anchorname is the optional anchor you want to scroll to on the

page. See Linking to WebHelp topics  for details.

Supported context-sensitive help types

· Calls to specific help topics

Display a specific topic in your help, inside the main help window.

· Calls to anchors in specific help topics

Display a specific topic in your help file in the main help window and scroll down to an

anchor  (jump target) within the topic.

· Calls using CHM help context numbers

We have also implemented support for help context numbers in WebHelp so that you

can use the same numbers you use in your CHM help if necessary. See Linking to We-

bHelp topics  for details.

Field-level popups and topics in V3 Premium Pack skins

When you use the V3 Responsive skins in the Premium Pack add-on you can also display

both popups and topics within your own web pages without taking the the user away

from the page. The popups and topics are draggable and resizable. The field-level topics

include a bar at the top with which the user can redisplay the topic within the entire help if

899

415

899
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they want to browse further.

Adobe PDF, ePUB and Kindle/Mobi eBooks, Word DOCX

These print-style formats do not support any real context-sensitive help features. In PDF

files you can link to anchors called "named destinations ", but without proper browse

buttons in the PDF viewer they are not as flexible as hyperlinks HTML-based formats. 

See also:
Context-Sensitive Help & Popups

Linking to and controlling eWriter help

Configuring for publishing - all formats

5.10.9 Linking to PDF files

You can create links to both page numbers and "named destinations" in PDF documents. The

procedure is the same for links that will be used in PDF files and in WebHelp output.

 Named destinations are jump targets that work like anchors. These links will work in PDFs

created by Help+Manual and in WebHelp created by Help+Manual, but not in CHM files. The

Microsoft CHM viewer does not support the link format needed to jump to destinations in

PDF files. A link to a PDF in a CHM file will simply open the PDF at the first page. See Named

destinations in PDF  for details on the named destinations created in PDFs by Help+Manual

and more background information.

Use normal topic links for targets in the current document

Note that named destinations are only needed for links between two different PDF files or

from other applications or documents. Use normal topic links to jump to targets within

your Help+Manual projects (i.e. from one topic to another). You don't need to use named

destinations for this.

Requirements:

· File Links are required for linking to PDFs:

You must use the File Link option for creating links to targets inside PDF files. The Inter-

net Link option will not always work correctly, even in WebHelp. 

· Set the PDF to "interactive" to use named destinations:

If the PDF you are linking to is created with Help+Manual it must be generated using

the "interactive PDF" option in your PDF settings . Named destinations are only gen-

erated for interactive PDF documents.

913

1586
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Linking to named destinations in PDF documents:

You need to create a file link with the destination added to it to link to a destination in a

PDF document. Internet links will not work correctly, not even in WebHelp.The syntax is

the same for links that are going to be in PDF files and WebHelp files. The links to the PDF

files will also work in CHM files, but they will only open the PDF document; they will not

jump to the destination in the PDF from a link in a CHM.

Procedure:

1. Follow the instructions for inserting a file link  and enter the name of the PDF file

you want to link to. 

2. Add #nameddest= after the file name, followed by the name of the named destina-

tion in all lower case characters. See this topic  for details of the named destinations

you can jump to.

Examples:

myfile.pdf#nameddest=toc (jumps to the Table of Contents in the PDF)

myfile.pdf#nameddest=welcome_topic (jumps to the topic with the ID Wel-

come_Topic)

myfile.pdf#nameddest=custom1 (jumps to user-defined template section 1)

Special case: anchors:

Links to named destinations including anchors are a special case. They will only work in

links in PDF files, not in links in WebHelp files. If you use a link with an anchor in WebHelp

output the link will only open the PDF file at the first page.

Example:

In a PDF file, the following file link will jump to the anchor testanchor in the topic with

the ID Welcome_Topic. In a WebHelp file it will only open the PDF at the first page.

myfile.pdf#nameddest=welcome_topic#testanchor 

Linking to a page number in a PDF document:

You need to create a file link with the page number added to it do link to a page number

in a PDF document. Internet links will not work correctly, not even in WebHelp.The syntax

425
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is the same for links that are going to be in PDF files and WebHelp files. The links to the

PDF files will also work in CHM files, but they will only open the PDF document; they will

not jump to the page number in the PDF from a link in a CHM.

Important: The page number destinations in PDFs created by Help+Manual start count-

ing at 0, so you must jump to the actual page number minus one. If you are jumping to

pages in PDFs created by other tools you can usually jump to the actual page numbers.

1. Follow the instructions for inserting a file link  and enter the name of the PDF file

you want to link to. 

2. Add #page= after the file name, followed by the page number:

myfile.pdf#page=123 (jumps to page 124)

myfile.pdf#page=0 (jumps to page 1, same as just opening the PDF file without a

target)

myfile.pdf#page=11 (jumps to page 12)

5.10.10 Linking to WebHelp Topics

You can create context-sensitive calls to WebHelp  (web HTML) from your application or

web pages with normal URLs using the syntax explained below. These calls can be made loc-

ally, across networks or across the Internet.

Field-level popups are not supported in WebHelp, they can only be implemented with HTML

Help (CHM). The JavaScript popups  supported in WebHelp can only be used within your

help, you cannot make calls to them from your application or web pages. 

HM2Go mini server for local WebHelp

If you want your WebHelp to be opened locally without a server (for example WebHelp on

CDs and DVDs), Help+Manual has a special mini server that you can distribute with your

help for better performance. See HM2Go - mini server for local WebHelp  for details. 

How to make calls to Webhelp topics

Calls to WebHelp must be normal URLs, made in the same way as any other URL link that

opens a browser with a specific web location or local HTML file, using exactly the same

syntax: 

Calling syntax:

index.html?topicname.htm#anchorname

425

1510

212

673
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Different syntax in Premium Pack V3, V4 and V5 skins

Please note that the new V3 skins in the Premium Pack add-on use a simpler, easier URL

syntax that only requires you to use topic.html. The index.html?topic.htm syntax

is no longer required for these skins, although it is supported for backward compatibility.

They also use a different syntax for references to anchors. See the Premium Pack docu-

mentation for full details.

Examples of the standard WebHelp URL syntax:

This example uses the standard file names and extensions and accesses an anchor in the

referenced topic:

index.html?introduction.htm#gettingstarted

The following example shows a call to a project that was published with both a non-

standard index file name and a non-standard extension for the topic files (see below).

There is no reference to an anchor in this example.

help.html?new_features.html

Elements of the calls: 

index.html This is the name of the index file of your WebHelp (this is the de-

fault, it can be changed in the Publish  dialog when you publish).

If you use this on its own it will simply display the help system with

the standard home topic.

?topicname.htm This is the name of the topic you want to display. This is created by

combining the topic ID  with the extension .htm..

This is the default topic extension, you can change it in Project

Configuration >  Publishing Options > WebHelp > HTML Export

Options . (These settings are shared with the other HTML-based

output formats and can also be accessed in the HTML Help and

Visual Studio Help sections.)

#anchorname Optional. This is the name of an anchor  in the topic that you

want to jump to. 

Using context IDs to link to WebHelp

Normally, context IDs or context numbers  are only used in Microsoft CHM/HTML Help

1310
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files. However, Help+Manual also exports a scripted map file of all the context IDs in your

project in your WebHelp output and allows you to link to them with a URL switch, in the

same way as you link to normal topic IDs. This makes it easier for programmers who are

using context IDs for making their CHM files to remap their calls to WebHelp.

Calling syntax:

index.html?contextid=xxxxx

Where xxxxxx is the context number/context ID. This works both for normal topic con-

text IDs and context IDs attached to anchors. If you are using standard templates or skins

the anchor must not be inside hidden text (i.e. not inside a toggle that is not open when

the topic is opened). If you are use a  Premium Pack skin the ToggleJump feature im-

plemented there allows you to link to anchors inside toggles as well.

Examples:

http://www.mydocumentation.com/index.html?contextid=60672

That is really all there is to it.

Where this is implemented:

Standard Templates:

The context ID URL switch was added in Help+Manual 6.3. It will work directly if you are

using the standard HTML templates in your project, although you may need to reset the

Layout template before publishing to get it to work, in Configuration > Publishing Op-

tions > WebHelp > Layout. 

Standard Skins:

Similarly, it has also been implemented in the standard HTML skins provided with

Help+Manual. If you are using an earlier edited copy of these skins you will need to get

the new version from the /Templates/HTML Skins to be able to use URL switches with con-

text IDs.

Premium Pack Skins:

The Premium Pack skins for Help+Manual 6 and later all support URL switches with con-

text IDs. You just need to make sure you are using version 1.56 or later if you are using

the version 1 Premium Pack or 2.20 or later if you are using version 2.

Adding support in your own skins:

Please contact support@ec-software.com if you want to add support for context IDs in

URL switches to your own custom skins or templates.

https://www.helpandmanual.com/products_hm_pluspack.html
mailto:support@ec-software.com


443

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

Links to WebHelp topics without the 'index.html' reference

By default, only the topic will be opened if you link to it with the topic name only, i.e. like

this:

topicname.htm

In all the standard skins, a link will then be displayed automatically above the topic header

with which the user can display the full user interface with the TOC. 

Automatic reload will stop Google from indexing your WebHelp!

There is a reload feature that will do this automatically when only the topic file is ad-

dressed without the index.html part of the URL. This is off by default, because Google

interprets the automatic reload as an attempt to increase your click count artificially and

stops indexing your WebHelp. 

Turning on automatic TOC reload for topic.htm links

If you don't care about Google indexing your WebHelp, or if you are using the WebHelp

on a local intranet server where there is no Google indexing, you can turn the automatic

reload feature on:

1. Open the .hmskin file for the skin you are using in Help+Manual. 

2. In the Project Explorer on the left, navigate down to Configuration > Publishing Op-

tions > WebHelp > Navigation.

3. Activate the option "When a topic is opened outside the navigation frame..."

Calling only a topic when automatic reload is on:

When the automatic reload option is active you can still call just the topic without the TOC

if you want. You do this by leaving out the index.html part and adding a simple switch

to your URL.

topicname.htm?toc=0#anchorname (with an anchor)

topicname.htm?toc=0 (without an anchor)

Avoid direct calls to the topic file

Direct calls to the topic.htm file without the index.html? portion of the URL will only

display the topic file by default. There is an reload feature that automatically displays the

full user interface for such links but this is off by default because Google doesn't index
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your site when it is on  (see above). 

However, even when the automatic reload feature is on, you should try to make sure that

all your links to your WebHelp use the full index.html?topic.htm syntax. The reload

feature is convenient, but in addition to creating problems with Google it will also confuse

the browser history, so that the user will get unexpected results when they try to navigate

with the Back and Next buttons. 

It is thus always advisable to use the full call including the index file, using the standard

syntax:

index.html?introduction.htm#gettingstarted

See also:
Creating popup topics

Context-Sensitive Help & Popups

Topic files without TOC entries

5.10.11 Linking to eWriter topics

On Windows, eWriter Help is the modern alternative to the obsolete CHM format for local ap-

plication help. It offers full support for context-sensitive help and file links and combines the

benefits of CHM and WebHelp while eliminating many of the disadvantages of both. On

MacOS eWriter provides an software help format that is not otherwise available in this integ-

rated form.

This topic provides a quick overview of the link options. For full details see the EWriter for

Software Help  chapter.

Viewer installation for eWriter as software documentation

When you are using eWriter as software documentation to replace CHM files you need to

know where the viewer is so that you can make your calls to it reliably. We recommend in-

stalling the standard version of the viewer for this together with your software. See

EWriter for Software Help  for details.

Each book is opened in a separate instance of the eViewer app

Each book you open has one and only one instance. If you make another call to the same

book it will apply to the open instance. You can have multiple books open at the same

time. To address the individual books you include the name of the book in your call along

with the parameters, as shown below.

207
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731
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Choosing the right file extension for your eWriter files

Use the .ewriter file extension for books distributed on their own

You need to use the .ewriter extension for eWriter files that are going to be distributed

on their own. It is registered with the Windows Store, and when a Windows 10 user who

does not have the viewer opens an .ewriter file they will be prompted to install the

viewer from the Windows store. Users on older versions of Windows can download the

Win32 installer from our eWriter page, which will also register the .ewriter extension.

Use your own file extension for eWriter used for software document-

ation

When you are using eWriter for software documentation you want to install the Win32

version of eViewer together with your software and make your calls to it directly. You also

don't want to conflict with any other version of the viewer that your user may have in-

stalled, so in this case you don't want to use the .ewriter extension. Instead, see one of

your own. 

See URL-style command syntax  for full details on this.

EWriter context help links and command line interface

Making calls to eWriter help files from your applications to display topics is very simple.

On Windows, you basically just need to call the viewer app with a shellExecute() or

equivalent function in your programming language, along with the name of the topic file

to be viewed and an optional anchor to scroll to.

File extensions of your topic files

The HTML topic files inside eWriter Help can have either the .htm or .html extension,

based on your settings for the topic file extension in your project in Configuration > Pub-

lishing Options > WebHelp > HTML Export Options. However, only these two extensions

are permitted. If you set a different extension in your project (for example .php or .asp),

the standard .htm extension will be used.

You need to use the correct extension in your context help calls, otherwise the topics will

not be found.

739

https://www.helpandmanual.com/ewriter/
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Context calls syntax

The syntax for context calls to eWriter Help has been changed with the introduction of the

new MacOS eViewer and the updated Windows eViewer. If you have used eWriter for ap-

plication help in the past the calls with the old syntax in your existing projects will still

work. However, we strongly recommend switching to the new integrated URL-style syntax

from now on. 

Please refer to the eWriter for Software Help  chapter for full details and instructions.

Basic New Syntax:

"<viewer app>" "ewriter://<ewriter file>?loadpage=<page in the
help>"

Note that when you are using integrated EXE eWriter Help files, the viewer app is the help

file itself, so it calls itself when using the new syntax.

Basic Old Syntax (not supported for MacOS):

"<viewer app>" "<page in the help>"

URL examples eViewer app:
"<path>eViewer.exe" "ewriter://<path>my_help.ewriter?loadpage=in-
dex.html"
"<path>eViewer.exe" "ewriter://<path>my_help.ewriter?loadpage=in-
dex.html?introduction.htm#anchor2"
"<path>eViewer.exe" "ewriter://<path>my_help.ewriter?loadpage=in-
troduction.html?anchor=anchor2 (Premium Pack)"

URL examples Windows EXE eWriter file:
"<path>MyHelp.exe" "ewriter://<path>MyHelp.exe?loadpage=index.html"
"<path>MyHelp.exe" "ewriter://<path>MyHelp.exe?loadpage=index.html?
introduction.htm#anchor2"
"<path>MyHelp.exe" "ewriter://<path>MyHelp.exe?loadpage=introduc-
tion.html?anchor=anchor2" (Premium Pack)

URL parameters and JavaScript

If your HTML pages include scripts that can evaluate URL parameters (supported in some

Premium Pack skins, for example) you can also include parameters to be parsed by your

script, like this:

"<path>eViewer.exe" "ewriter://<path>my_help.ewriter?loadpage=in-

731
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dex.html?mysetting=xyz&setting2=12"

The HTML location object is fully supported for interpreting URLs you pass to your pages

like this. This means you can extract the query portion of the script with document.loc-

ation.search, the hash portion (anchor) with document.location.hash and so on. 

Linking between eWriter files

If you have multiple eWriter help files installed on your user's computer you may some-

times want to link between them. This will normally only apply when you are using eWriter

for software documentation . 

There are several methods you can use for linking between eWriter files. You must always

use the File Link option for this, not the Internet Link!

Linking between eWriter files when the file association is known

You can use a simple method if you are sure that the .ewriter extension has been asso-

ciated with the eViewer application, or if you are using your own extension that you have

registered as part of your installation on the user's computer. Then you just need to refer-

ence the eWriter file and the topic parameters.

This also works when you have changed the file extension and eViewer name:

Note that this also works if you are using eWriter for software documentation and you

have changed both the file extension and the name of your copy of the eViewer applica-

tion. You just need to link to another eWriter file that has the same extension as the

eWriter file containing the link. 

File name: The name of the eWriter file you want to link to without any path

information. Just the file name. You must use the extension that has

731
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been registered to the eViewer application on the user's computer.

This will be .ewriter if you are sure that has been registered, or

your own custom extension if you are installing eViewer as part of

your software installation and registering the extension yourself. 

Relative path: Only include the path to the file here if the target file is not in the

same folder as the file containing the link. Despite the name, you

can use either a relative or an absolute path.

Important: No quotes around this path, even if it includes spaces!

Execution para-

meters:

The normal WebHelp reference to the topic you want to display in

the target file. The syntax depends on the skin type you are using.

This parameter must be enclosed in double quotes.

Standard Help+Manual skins and older Premium Pack skins:

"index.html?topic.html"

Premium Pack V3 skins:

"topic.html"

Topic file extensions

The topic file extension can be .htm or .html, depending on what

you have set in your project. Other extensions are not allowed for

eWriter topics. 

Anchors and other parameter extensions

Add these in the execution parameters, inside the double quotes,

exactly as you would in WebHelp. 

Using an Internet link instead of a File link (required for MacOS)

You can also use an Internet link to link between eWriter Help files, but then you have to

use the new syntax with the ewriter:// prefix. This is also required if you are using

eWriter Help on MacOS.

ewriter://NewProject.ewriter?loadpage=index.html?topic_name.html
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Linking between files when you are using the integrated viewer in

EXE eWriter books

When you create combined book and viewer files with the EXE extension you always just

enter the EXE file as the file to link to and the topic to open as the parameters. 

File name: The name of the eWriter EXE file you want to link to without any

path information. Just the file name.

Relative path: Only include the path to the file here if the target file is not in the

same folder as the file containing the link. Despite the name, you

can use either a relative or an absolute path.

Important: No quotes around this path, even if it includes spaces!

Execution para-

meters:

The normal WebHelp reference to the topic you want to display in

the target file. The syntax depends on the skin type you are using.

This parameter must be enclosed in double quotes.

Standard Help+Manual skins and older Premium Pack skins:
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"index.html?topic.html"

Premium Pack V3 skins:

"topic.html"

Topic file extensions

The topic file extension can be .htm or .html, depending on what

you have set in your project. Other extensions are not allowed for

eWriter topics. 

Anchors and other parameter extensions

Add these in the execution parameters, inside the double quotes,

exactly as you would in WebHelp. 

Calls to EXE eWriter files with the integrated viewer

You can still create the original EXE eWriter files with an integrated viewer if you wish, al-

though we strongly recommend using the separate viewer. You just need to change the

output file extension to .exe in the Publish screen before publishing. Help+Manual iden-

tifies this automatically and then creates an EXE eWriter Help file with an integrated

viewer.

Not supported on MacOS

Note that EXE eWriter Help is a Windows format and cannot be used on MacOS. On Macs,

you must use the eViewer app and .ewriter data files.

Context calls syntax

The calling syntax is the same as with the external viewer, except you call the EXE eWriter

Help file instead of the viewer, followed by the parameters. You can use both the old and

the new syntax for this.

Old syntax:

<path>my_ebook.exe "index.html?introduction.htm"
<path>my_ebook.exe "index.html?this_page.htm#anchor"
<path>my_ebook.exe "index.html?anotherpage.htm"

New syntax:
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If you use the new syntax, you must also include the name of the EXE eWriter Help file

after the ewriter:// protocol prefix, so that the file is calling itself:

<path>my_ebook.exe "ewriter://my_ebook.exe?loadpage=index.html?
introduction.htm"
<path>my_ebook.exe "ewriter://my_ebook.exe?loadpage=index.html?
this_page.htm#anchor"
<path>my_ebook.exe "ewriter://my_ebook.exe?loadpage=index.html?
anotherpage.htm"

Always include the page parameters in quotes, even if there are no spaces. Otherwise you

will get Windows errors caused by some of the characters that need to be used. 

Links to executable files

If you're used to producing CHM files and WebHelp you don't even think about opening

executable EXE program files from your documentation. But with eWriter Help, you can!

This is possible both from normal links in topics and from TOC entries.

RESTRICTION: Not supported in the Windows Store version of the

viewer!

Windows Store apps are not permitted to invoke executable files from within the program.

Because of this, the functions described below are not available in the Windows Store ver-

sion of the viewer app. However, you can use them if you are installing the standard Win-

dows eViewer app together with your software. See EWriter for Software Help  for de-

tails.

Current directory status when linking to executable files

When executing external files, the eWriter viewer explicitly sets the current directory to

prevent possible failure of file links using a relative path.

File links to executables in topics

Just create a normal file link to the EXE file and add exec: directly before the file name,

like this:

exec:notepad.exe
exec:../demo_program/widget_maker.exe

731
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Links to executables in the TOC

You can also create links to executable files in the TOC of an eWriter Help file. Create a

new topic entry and choose the TOC Link option, and then Link to Web Address. Then

enter the target in the Web Address: field, using same exec:filename.exe format as

above. Here too, you can include a relative path if necessary.

exec:notepad.exe
exec:../demo_program/widget_maker.exe

See also:
eWriter Help  (publishing information)

eWriter Help  (reference)

5.10.12 Inserting script links

This function inserts a piece of script code that is executed when the user clicks on the link in

your help file. Note that scripts are not supported in all output formats – see the  compatibil-

ity list below for details. 

696
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See Scripts and HTML  in the Reference section for some more background information on

scripts and how they are implemented and handled.

How to insert a script link

1. Select text in your document if you want to use it as the link. You don't have to do

this: you can enter a completely new caption in the Insert Hyperlink dialog box if you

want. 

2. Open the Insert Hyperlink dialog box. There are two ways to do this:

· Press Ctrl+L

· Select the Link tool in Write > Insert

3. Select the Script Link tab:

4. Select HTML JavaScript or Winhelp Macro and enter your script or macro in the editing

field. (Only four Winhelp macros are supported, see below for details.)

1539
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See The Hyperlink dialog  for full details on the settings in the dialog.

Script implementation

Help+Manual creates script links by inserting the code you type between <a href=" and

">. For example, if you type:

javascript:alert('Hello World!');

The resulting link created in your output will be:

<a href="javascript:alert('Hello World!');">Link text</a>

This is just a simple example of course, you can place as much code in the script as you

want. If you are familiar with JavaScript and HTML you can use this knowledge to create

quite complex scripts! You just have to remember that everything you write is inserted

between <a href=" and ">. See Scripts, HTML and Macros  in the Reference section for

more details.

Winhelp macro implementation and translation

Help+Manual no longer supports the obsolete Winhelp format. However, four Winhelp

macros are still supported because they are easier to enter than their HTML Help equival-

ents. You can use them as shorthand versions for these functions in HTML Help output.

Help+Manual automatically converts these four macros into the code required in HTML

Help CHM files. 

Macros translated in HTML Help:

The following four standard Winhelp macros are automatically translated to their HTML

equivalents when you publish to HTML Help.

ALink()  KLink()

TCard() Close()

· Note that only keywords are supported as arguments in the ALink and KLink macros

when they are used in HTML Help. All other arguments are ignored.

· See Scripts, HTML and Macros  in the Reference section for full details on how scripts

and macros are implemented and handled.

1352
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Macro/script link compatibility in output formats

HTML Help: JavaScript is broadly supported in CHMs. See the MS HTML Help

Workshop documentation for details. Four standard Winhelp mac-

ros (see above) are translated to their HTML Help equivalents. Do

not use paths.

Visual Studio

Help:

Same as for HTML Help.

WebHelp: Scripts are supported but support depends to a great extent on the

user's browser, so use the same caution as when using scripting in

any HTML pages.

eWriter Help for

Windows and

MacOS:

Scripts are supported and are executed by the embedded Internet

Explorer used to render the pages. When writing scripts remember

that you are operating inside an encapsulated browser that is dif-

ferent from the environment of a web page on the Internet or an

intranet.

Kindle/Mobie and

ePUB eBooks:

Script and macro links are not supported.

Adobe PDF: Script and macro links are not supported.

Word DOCX: Script and macro links are not supported.

 See also:
Scripts, HTML and Macros

Inserting plain HTML code

Using HTML templates

WebHelp  (Project Configuration)

5.10.13 Editing and formatting links

You can edit link captions (the link text) directly just by clicking inside a link text once in the

editor and typing. You also have great freedom to format the appearance of your links. The

link text can be formatted like normal text provided that you use the same formatting for all

the text in the link. 

Productivity Tips

1539
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Hold down Ctrl and click on a link to navigate to the

link target in your project. Double-click on a link to

display its editing dialog.

How to edit link captions

You can edit link captions (the text of the link displayed in the editor) in exactly the same

way you would edit normal text. Just click once inside the link or move the cursor into the

link with the cursor keys and start typing. 

Alternatively, you may find it easier to double-click on the link and edit its caption in the

Hyperlink dialog .

Link captions at the beginning of a paragraph

If a link caption is at the beginning of a paragraph you can't insert any text before it; all

the text you type to the left of the link becomes part of the link. Here is how to solve this

problem:

1. Click to the left of the link and press Enter to create a new paragraph. 

2. Move up to the empty new paragraph, press the space bar (this switches off the link

highlighting) then type some text. 

3. Click to the right of the new text and press Delete to bring the link into the same para-

graph. 

How to format the link caption

· Select the caption and format it in the same way you would format any other text. Al-

ways select the entire caption – applying different formatting to different parts of the

caption will split the link in two.

· Note that underlining and color cannot be changed for normal links because they are

always blue and underlined. 

· For full control over link caption formatting choose the Text style in the Link Proper-

ties  dialog. You can then format the link manually or by applying a text style.

(Double-click on a link in the editor to display this dialog.)

· See the HTML5 & CSS tutorial project in My Documents\My HelpAndManual Pro-

jects\Examples for instructions on how to style your links with CSS in HTML-based out-

put formats. It is also accessible directly in the Welcome screen that you can access at

the top of the Project Explorer on the left.

1352
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Turning links back into text, deleting links, [****] links

· Turn a link back into text right-click on the link and select Convert to plain text in the

context menu.

· To delete a link select the entire link and press Delete. It is best to select the spaces be-

fore and after the link, otherwise you may only delete the link caption and create a

ghost link (a link without a caption).

· If you create a ghost link it will be displayed as [****] in the editor after saving or re-

freshing the topic. To get rid of it just right-click on it and select Convert to plain text in

the context menu.

5.10.14 Linking to other projects and help files

By default the target ID list in the Hyperlink dialog displays the IDs of the current project, but

you can also link to topics in other projects and in other help files. 

Where links to topics in other projects and help files work

If and how links targeting topics in other projects work depend on your output format.

Generally they are only relevant in HTML Help CHM files. When you distribute your help

the link files must be present in the same directory as the help file containing the link. 

CHM files: Links to other CHM files are supported. You can link via the HM

project creating the other CHM file or directly to the other CHM

file. If you link via the project the project name and target CHM

name must be exactly the same, and the CHM files must all be in

the same folder. 

WebHelp: You can link to topics in other WebHelp documentation but not via

HM projects. You must use Internet links and enter the correct URL

for linking to the other WebHelp at runtime. 

PDF files: You can link to other PDF files with some limitations, but not via

the HM project. See this topic  for details.

eWriter Help: You can use the file link and context help capabilities of eWriter

Help to link between help files. See this topic  for details.

Word DOCX: You can open other Word files with file links but you cannot link to

specific topics or locations in another Word file.
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Kindle/Mobi and

ePUB eBooks:

No links between eBooks are supported.

Visual Studio Help: No links between different Visual Studio Help collections are sup-

ported.

How to link to an external project or help file for CHM help systems

This will only work for CHM files and only if the CHM file containing the link and the CHM

file you are linking to are both in the same folder. The target topic will be displayed inside

the current CHM viewer, without the TOC of the target CHM file.

1. Follow the basic instructions for inserting a normal topic link . 

2. In the Hyperlink dialog  click on the  browse button in the Help File: field and

choose the project or help file containing the topic you want to link to.

+

3. If you choose a Help+Manual project (.hmxz or .hmxp)  the topic IDs of the target

project or file will be displayed in the Topic ID list. Choose the topic (and anchor  if

applicable) you want to link to and click on OK.  

If you choose an HTML Help (.chm) file you will see the topic filenames with the .htm

extensions. These are the same  as the IDs in your project, just select in the same way.

You won't see the available anchors in the drop-down list when you select a CHM file

as the target, but if you know the anchor ID you can type it in in the anchor field,

which is fully editable.
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Links between modular projects:

When you are linking between modular projects you may need to think about what will

happen in situations when the project you are linking to is not present when the user

clicks on the link. See Modular Projects  for more information on this and solutions.

Opening a topic in another CHM file in a new viewer instance

Normally, links to topics in another CHM file will open in the current CHM viewer instance.

The user only sees the topic contents, the TOC of the other CHM is not visible. If you want

to provide access to the entire TOC of the other CHM you need to open the other CHM in

a separate viewer. 

To do this, you need to create a file link to the hh.exe CHM viewer and insert the name

of the CHM file and topic you want to display as parameters:

File name: hh.exe

Execution parameters: ms-its:myhelp.chm::/introduction.htm#an-
chorname

myhelp.chm is the file you want to open, introduction.htm is the topic ID in lower case +

".htm" and anchorname is an optional anchor to scroll to. Note the ms-its: prefix, the

::/ between the CHM file name and the topic file name and the # between the topic and

the anchor. These are all essential. 

1547
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Using a help context number instead of the topic ID:

You can also do this with the help context number of a topic or anchor instead of the

topic ID. Then you use the same procedure with these execution parameters (12030 is the

context number):

File name: hh.exe

Execution parameters: -mapid 12030 ms-its:helpfile.chm

Linking to topics in other WebHelp (HTML) projects

The situation is a little different when you want to create links between different We-

bHelp  projects, which are by definition stored in different directories. These are effect-

ively just groups of HTML pages, like any other set of HTML pages on a website. Topic

links will not work here because this is really a website, not a help project – you have to

use Internet links instead. 

1510
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1. Follow the instructions for inserting an Internet link  and choose the Links to an In-

ternet address option. 

2. Enter the URL of the page in the other project in the Address: field. You can enter

either the absolute address or the relative address (the relative address will depend on

the relative positions of the directories on your website, of course):

Absolute address:

http://www.yourdomain.com/subdirectory/index.html?topicname.ht-
m#anchorname

Relative address:

../subdirectory/index.html?topicname.htm#anchorname

Here index.html is the index file of your project (this is the default, you can change it

in the Publish  dialog when you publish), topicname.htm is the name of the topic

(topic ID  plus .htm) and anchorname (optional) is an anchor  in the topic you

want to link to.

Choosing the window to open the link in:

If you want to display the TOC of the target project in the current browser window select

the Top Frame option in the Target window: field. If you don't  do this the topic will over-

write the TOC in a single browser window. Selecting New Window opens the topic in a

new browser window together with its TOC.

Direct links to topic files:

It is possible to link directly to the topic filename, for example with:

../subdirectory/topicname.htm

The entire help with the TOC wills still be displayed automatically when you do this.

However, the Back and Next history buttons in the user's browser will not work properly

so it is better to use the full syntax  including the index.html index file. 

See also:
Working with Modular Help Systems

5.10.15 Preventing dead links

Excluding topics from your output can create dead hyperlinks. If there are links to the ex-

cluded topics in other topics, those links will not have any targets and will produce errors or

do nothing when the user clicks on them. You need to plan your project to prevent this from

happening.

Help+Manual has several functions that can help you to prevent and eliminate dead hyper-
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links caused by excluding topics. If you use them correctly you can easily locate all potential

dead links and automatically replace them with alternative text or links.

How to use Find Referrers to locate potential dead links

Whenever you set an include option to exclude a topic you should always use the Find Re-

ferrers function to check for any links to the excluded topic in other topics. 

1. Select the topic you plan to exclude in the Project Explorer. You can select either a

TOC item or a topic file. 

2. Right-click on the topic name in the Project Explorer and select Find Referrers in the

context menu. Alternatively you can also select Find > Find Referrers in Project > Man-

age Topics.

3. This displays the topic referrer report. Double-click on its title bar to display it in an ex-

ternal window, this makes it easier to use (double-clicking on the title bar again re-

docks it to the Help+Manual window):

Links to the topic in other topics are listed in the Is referred by column. The Links to

column only shows topics that the current topic links to, which you don't need to

worry about here.

4. Click on the links in the Is referred by column to display the topics so that you can use

conditional text to eliminate dead links (see below). When you are finished you can re-

turn to the current topic by clicking on its link in the Topic column.

How to use Conditional Text to replace dead links

When you exclude topics from your published output you do this with include options.

You can prevent dead links to the topic by using the exactly the same include options to
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also exclude the hyperlinks that would be dead. This is then automatic. The hyperlinks will

always be excluded whenever the topic they link to is excluded, because they are both

controlled by the same include options. 

You can also use additional include options to include alternative text or even alternative

links whenever the topic is excluded.

1. Use Find Referrers (see above) to locate all topics containing links to the topic you

want to exclude. 

2. Open the topic containing the link that you want to exclude in the editor and locate

the link. 

You now need to decide what needs to be excluded and replaced. We will assume that

you want to exclude the entire sentence containing the link and replace it with an al-

ternative sentence.

Excluding the link:

3. Select the entire sentence containing the link and select the  Conditional Text Tool

in Write > Insert Object.

4. Now select exactly the same include options that you are using to exclude the topic

the link points to and click on OK. 

In the example above we have selected WebHelp and Adobe PDF. This means that the

link will only be included when you publish to WebHelp or PDF, it will be excluded
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from all other formats. Since the options match those set for the topic the link points

to it will be excluded whenever the topic is excluded and included when it is included.

Including alternative text and/or links:

5. If you want, you can now write an alternative sentence with or without a link to a dif-

ferent topic and use conditional text to include the alternative text whenever the ori-

ginal text is excluded. 

The easiest way to do this is with IFNOT. In the above example we would also select

WebHelp and Adobe PDF, but in combination with IFNOT instead of IF. This will ensure

that the alternative is always included when the original is excluded, and vice versa.

How to set publishing options to manage dead links

These options can be configured in View > Program Options > Compilers. They not a "fi-

nal" solution. They should only be used as a failsafe to handle any dead links you may

have accidentally missed when planning your project. 

Option 1: Silently include linked topic

This option prevents dead links by exporting your excluded topics when you publish if

there are any other topics that contain links to them. When this is done no TOC entry is

exported for the topic, so it can only be displayed by clicking on the links to it. Don't use

this option if the topics you are excluding contain information you don't want a specific

user group to see!

All nominally excluded topics that get included by this option will be listed as "implicitly

exported" in the compiler report when you publish your project.

Option 2: Remove links

This option simply deactivates dead links to topics excluded from your output. The link

caption text is still there but it is normal text, no longer a hyperlink. This is definitely safer

than Option 1, because it always ensures that excluded content remains excluded.

However, depending on the context the plain text in place of the links may be confusing

for your users.

All links turned into plain text in this way are listed in the compiler report.

Option 3: Allow links to be dead

This option does nothing at all. The links are left in your output and they point to invalid
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targets. When the user clicks on them either nothing will happen or an error message will

be displayed.

5.10.16 Named destinations in PDF

When Help+Manual generates PDF documents it automatically exports a number PDF an-

chors known as "named destinations" for targets in the document. These destinations are sim-

ilar to topic anchors  in HTML documents. You can use these destinations as targets in hy-

perlinks to the PDF files.

Key Information
Named destinations are only generated if you gener-

ate an interactive PDF  document.

Items exported as named destinations

Topic IDs

Topic IDs are exported as named destinations in all lower case. Links to named destina-

tions are case-sensitive, so you must also use the lower case format in all your links to

named destinations in PDFs created by Help+Manual. 

For example, if your topic ID is Index_Topic then the named destination in the PDF will

be index_topic. 

Topic anchors

Anchors inserted in your topics are exported together with the topic IDs, also in all lower

case letters, using the syntax topicid#anchorid. The topic ID is always part of the

named destination for an anchor, with a pound character (#) between the two.

Links to anchors in PDF only work in PDF links:

Links to named destinations including anchors are a special case. They will only work in

links in PDF files, not in links in WebHelp files. If you use a link with an anchor in WebHelp

output the link will only open the PDF file at the first page.

Standard PDF template sections

The following named destinations are exported for the standard PDF template sections

defined in your print manual template . These destinations are exported in all  lower

case as shown below, and that is also how you must link to them. (The commas are not

part of the destinations.)

415
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cover, title1, title2, title3, foreword, toc, topics, endnote1,
index, endnote2, backcover

Note that there are no destinations for repeating sections like Top Level Entry and Blank

Pages. 

User-defined template sections

User-defined PDF sections created in Manual Designer with the Insert Page option in the

Pages menu are also exported as named destinations. The destinations generated for

these sections are called custom1, custom2, custom3 and so on – i.e. the word "cus-

tom" in all lower case plus the sequential number of the custom page in the order in

which the pages were created in the template.

Important note:

The named destinations for user-defined sections are fixed and are assigned in the order

in which the user-defined sections are created. The first section you create gets the destin-

ation custom1, the second section gets custom2 and so on. The actual order of the cus-

tom sections in your template is irrelevant.

Linking to named destinations in PDF documents

You can create links to both page numbers and "named destinations" in PDF documents. The

procedure is the same for links that will be used in PDF files and in WebHelp output.

 Named destinations are jump targets that work like anchors. These links will work in PDFs

created by Help+Manual and in WebHelp created by Help+Manual, but not in CHM files. The

Microsoft CHM viewer does not support the link format needed to jump to destinations in

PDF files. A link to a PDF in a CHM file will simply open the PDF at the first page. See Named

destinations in PDF  for details on the named destinations created in PDFs by Help+Manual

and more background information.

Use normal topic links for targets in the current document

Note that named destinations are only needed for links between two different PDF files or

from other applications or documents. Use normal topic links to jump to targets within

your Help+Manual projects (i.e. from one topic to another). You don't need to use named

destinations for this.

Requirements:

· File Links are required for linking to PDFs:

You must use the File Link option for creating links to targets inside PDF files. The Inter-

net Link option will not always work correctly, even in WebHelp. 

465
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· Set the PDF to "interactive" to use named destinations:

If the PDF you are linking to is created with Help+Manual it must be generated using

the "interactive PDF" option in your PDF settings . Named destinations are only gen-

erated for interactive PDF documents.

Linking to named destinations in PDF documents:

You need to create a file link with the destination added to it to link to a destination in a

PDF document. Internet links will not work correctly, not even in WebHelp.The syntax is

the same for links that are going to be in PDF files and WebHelp files. The links to the PDF

files will also work in CHM files, but they will only open the PDF document; they will not

jump to the destination in the PDF from a link in a CHM.

Procedure:

1. Follow the instructions for inserting a file link  and enter the name of the PDF file

you want to link to. 

2. Add #nameddest= after the file name, followed by the name of the named destina-

tion in all lower case characters. See this topic  for details of the named destinations

you can jump to.

Examples:

myfile.pdf#nameddest=toc (jumps to the Table of Contents in the PDF)

myfile.pdf#nameddest=welcome_topic (jumps to the topic with the ID Wel-

come_Topic)

myfile.pdf#nameddest=custom1 (jumps to user-defined template section 1)

Special case: anchors:

Links to named destinations including anchors are a special case. They will only work in

links in PDF files, not in links in WebHelp files. If you use a link with an anchor in WebHelp

output the link will only open the PDF file at the first page.

Example:

In a PDF file, the following file link will jump to the anchor testanchor in the topic with

the ID Welcome_Topic. In a WebHelp file it will only open the PDF at the first page.

myfile.pdf#nameddest=welcome_topic#testanchor 
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Linking to a page number in a PDF document:

You need to create a file link with the page number added to it do link to a page number

in a PDF document. Internet links will not work correctly, not even in WebHelp.The syntax

is the same for links that are going to be in PDF files and WebHelp files. The links to the

PDF files will also work in CHM files, but they will only open the PDF document; they will

not jump to the page number in the PDF from a link in a CHM.

Important: The page number destinations in PDFs created by Help+Manual start count-

ing at 0, so you must jump to the actual page number minus one. If you are jumping to

pages in PDFs created by other tools you can usually jump to the actual page numbers.

1. Follow the instructions for inserting a file link  and enter the name of the PDF file

you want to link to. 

2. Add #page= after the file name, followed by the page number:

myfile.pdf#page=123 (jumps to page 124)

myfile.pdf#page=0 (jumps to page 1, same as just opening the PDF file without a

target)

myfile.pdf#page=11 (jumps to page 12)

Links to PDFs from WebHelp and HTML files

Links to named destinations in PDF from Help+Manual WebHelp

When creating links to named destinations in PDF files from WebHelp you can use exactly

the same procedure and syntax as for links from PDF files. Create a file link and follow the

instructions above. 

Links to named destinations in PDF from other HTML files

The syntax is also the same for links to named destinations in other HTML files not gener-

ated by Help+Manual. Just create a hyperlink using the same pdf_file.pdf#named-

dest=xxxx and pdf_file.pdf#page=yy syntax for the href target of the link as you

use in Help+Manual, where xxxx is the named destination and yy is the page number.

Links to PDF from CHM files

You cannot link to named destinations in PDFs from a page in a CHM file. The Microsoft

CHM viewer will block all attempts to do this. You can only use a normal file link to open

425
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the PDF file at the first page. That is the only option available. This is a limitation of the

CHM format and the Microsoft CHM viewer. Help+Manual cannot do anything to change

this (and the PDF must be in the same folder as the CHM to open at all).

5.10.17 Links and secondary windows

The following information is only relevant for the Microsoft HTML Help CHM format.

Help windows define the features of the Microsoft help viewer for HTML Help and are also

used to display individual topics in external windows. When you define a hyperlink to a topic

you can include a setting that specifies a secondary help window for opening the topic.  This

allows you to create links that open topics that would normally open in the TOC in external

windows.

See Using help windows  for more details. 

Opening the target topic in an external window

Preparation:

1. Define at least one secondary help window  type. 

2. In the window's HTML Help Options  tab select the Links to secondary help windows

open a new help window option. (This allows external windows in HTML Help.)

3. You will probably also want to use the other options in the HTML Help Options tab to

switch off the external windows' control buttons and navigation panel.

Opening target topics in an external window:

Create a hyperlink to a topic, open the Hyperlink dialog  (double-click on the link) and

select the  secondary window type in the Window: field, then click on OK.

See also:
Using help windows

Help Windows  (Project Configuration)

Help windows and external windows

Help Windows  (Reference)

5.10.18 Inserting HTML code objects

The  Insert HTML Code Object tool in Write > Insert Object allows you to add special fea-

tures or formatting to your topic pages with HTML code. For example, you can write dynamic

HTML code with JavaScript to add features not available directly in Help+Manual. 
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This function "injects" HTML code into your topic at the point where you insert it. The code is

entirely your responsibility and is not checked or parsed by Help+Manual in any way, so you

need to be familiar with HTML coding.

Productivity Tip
You can resize the HTML code objects in your topics

to make their contents visible. You can also the code

object editor for editing larger blocks of code.

Where HTML code objects are supported

HTML code objects are supported in all HTML-based output formats. This includes the

eWriter Help format, which supports scripting in the same way as WebHelp. You will only

find restrictions there in some cases because of the fact that eWriter is a local format like

CHM, not a server-based format on the Internet like WebHelp.

The ePUB eBooks standard includes scripting but most ePUB readers do not so it should

be avoided as it will hardly ever work, 

If you want to use this feature in projects that will also be published to formats where it is

not supported you need to use Help+Manual's conditional output  features to create

alternative text for those versions.

Note that the Insert HTML Code Object tool inserts the code directly in the body of your

topic. If you want to insert scripts in the <head> section of your topic page you must do

so in the HTML template, either directly or by reference. See below for more information

on this.

How to insert plain HTML code in a topic

1. Click in the editor at the point where you want to insert the plain HTML code and se-

lect the  HTML Code Object tool in Write > Insert Object. 

2. Then select the Static HTML Code option and enter and edit your code in the HTML

Code: box, which includes syntax highlighting for HTML,

969
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Insert inline code without block tags:

Normally, the HTML code block is inserted in a standard <p> paragraph or <div>

layer tag. You can prevent this by activating the HTML code must not be enclosed in a

block tag option.

3. You can resize the window for easier editing by dragging on the lower right corner. 

The Load from File and Save to File functions allow you to save blocks of code in external

text files for reuse. 

Referencing external files in plain HTML code

If you reference external files in your plain HTML code you are entirely responsible for

making sure that the files are included in your output. Help+Manual does not parse or

check the code and it will not do this for you. There are two ways to make sure that refer-

enced files are included in your project:



472

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

Method 1: Adding the files to the Baggage Files

This is the simplest solution. The Baggage Files function provides a quick and easy way to

integrate external files in your project and make sure that they are available to the com-

piler and included in your output.

· See Using Baggage Files  for details on using this function.

· See Graphics references  for more details on referencing graphics files. Since graph-

ics files are often large it is not always a good idea to add them to the Baggage.

Method 2: Integrating the files in your output manually

This is not really necessary since it is much easier to add any referenced files to your Bag-

gage. The following instructions are just included for the sake of completeness.

· In WebHelp you must manually copy the files to your output directory if you have not

added them to the Baggage Files (see above).

· In HTML Help you need to tell the HTML Help compiler to add the files to the .chm

file. Proceed as follows:

1. Copy the external file(s) to your project folder (the folder containing your .hmxz

or .hmxp project file). 

2. In the Project Explorer open Configuration > Publishing Options > HTML Help >

Extended HHP Settings.

3. In the editing box add the following entries, replacing the dummy filenames in the

examples with your own files (one file per line):

[FILES]
..\donald.js
..\mickey.asp

Don't add a second [FILES] header if one already exists. Enter each external
filename on its own line below the [FILES] header and precede it with the ..\
relative path reference. 

This example assumes the files are stored in your project directory. (This is
necessary because the project is published from a temporary subdirectory in the
project directory, so files in the project directory are one level up.) If your files are
located anywhere else you need to adjust the ..\ relative path reference accordingly.

Inserting external and online HTML files with a code object

In addition to HTML code and JavaScript, you can also use a code object to merge an en-

tire external HTML file into your page. Here too, this will only work in HTML-based output
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formats.  It will be ignored in other formats. The raw HTML is inserted in the page without

conversion and that only works in HTML pages.

How and when the files are inserted

The files are not dynamic content. They are inserted in the HTML of your output pages

when the project is compiled and they then become static content and part of the output.

Format of the files to insert

Note that the #MERGE command will insert the entire HTML file. It is thus better to only

use files that contain plain HTML code, without any <html>, <head> or <body> structural

components. See this topic  for more details. 

Inserting local files

Select the Merge Content of File option and then navigate to the file with the [..] browse

button. The #MERGE command will be generated and inserted automatically. You can also

enter the path and file name manually, if you wish. If you use a relative path it must be rel-

ative to the folder containing your project. (You can also reference online files here if you

enter the http URL manually.)

Activating the option to prevent the HTML code from being inserted in a block tag is re-

commended.

169
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Inserting online files

You can also insert online files with the Merge Web Content option. Note that this will

not work for all files, particularly complex files with many containers or dynamic content.

Here too, the files should ideally contain only plain HTML code, without <html>, <head>

or <body> sections.
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Referencing code in the <head> section

If you reference JavaScript or other script code in your HTML code objects you may want

to insert scripts containing the functions to be executed in the <head> section of your

HTML topic page that you then reference and run from the code objects inserted in the

body of your topics. You can't do this directly in the topic page because this only inserts

the code between the <body> and </body> tags in the final HTML page. 

The code for the sections of your HTML pages above and below the <body> and

</body> tags is provided by your HTML topic page templates, which you can access and

edit in the Project Explorer. You can add script code and references to external script files

to the <head> section of your pages by editing these templates. By default you have one

HTML topic page template called Default, which is used for all topics. However, you can

create as many different templates as you like and assign them to individual topics in the

Topic Options tab on the left of the main editor window.

In addition to this you can use HTML variables that you can redefine in individual topics to

add different script and code to the <head> section of every single topic. To do this you

insert the variables in your template and then redefine their content for individual topics

in the Topic Options tab on the left of the main editor window.
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See Using HTML Templates  for general information on how to access and edit your

HTML topic page templates. See The power of editable variables  for details on how to

use HTML variables to insert individual code in your templates on a per-topic basis. 

See also:
Inserting script and macro links

Using HTML templates

Scripts, HTML and Macros

WebHelp  (Project Configuration)

Using Baggage Files

Graphics References

Extended .HHP Settings

5.10.19 A-Links and A-Keywords

Key Information
Note that A-keywords are a Microsoft help technology

that is only supported in the Microsoft HTML Help

(CHM) format. A-keywords are irrelevant in all other

output formats, including WebHelp. 

A-keywords, also known as "A-link keywords", are only used in Microsoft's HTML Help (CHM)

format. They are quite similar to normal keywords but they not displayed in the index, they

are always "hidden". What use is a keyword that isn't displayed anywhere? There are two ma-

jor uses for A-keywords: To create "See also" lists of related topics and to create links between

help files in modular help systems. 

See About A-Keywords  for background information.

How to make an automated See Also list with A-keywords

This method creates links that display a list of related topics. It only works in HTML Help

CHM files. It will not work an any other output format.

Step 1: Enter the A-keywords

1. Select a topic and select its Topic Options tab (top left of the main editor window). 

2. Enter one or more keywords in the A-Keywords: section, one keyword per line. Note

that sub-keywords are not supported with A-keywords!

3. Repeat for all topics you want to "associate" with one another, adding the same A-

keyword to each topic.
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Step 2: Create the link

The link that displays the list of See also: topics is created using the Winhelp ALink macro.

The syntax of this macro is much simpler than its HTML Help equivalent and so

Help+Manual automatically translates it when you output to HTML Help. 

1. Select Insert > Link in Write > Insert to create a hyperlink. 

2. Select the Script Link tab in the Insert Hyperlink dialog, then select Winhelp macro as

the type of hyperlink.

3. Enter Alink() in the Script: field and type the keywords you want to link to between the

parentheses. If you enter more than one keyword separate them with semicolon (;)

characters, like this:

This example will create a link that displays a list of all topics that contain the A-keywords

"troubleshooting" or "solutions".

Note that when you are working in HTML Help you can only enter keywords as the argu-

ment for the Winhelp macro. You cannot enter the other parameters for the Winhelp A-

Link macro because they are not translated into HTML Help code!

How to link between help modules with A-keywords

Use this method to create links between the help files of modular help systems if there is a

possibility that the help files containing the target topics may not be present when the

help is viewed. This can happen when you use runtime merging and choose not to include

one or more of the help files in your distribution. It can also happen if you are using con-

ditional output to exclude modules from publish-time merged HTML Help and Winhelp

projects.

This technique works both in HTML Help and the obsolete Winhelp forma but not in any

other formats. Please study Working with Modular Help Systems  before trying to use

this method!

Step 1: Prepare the alternative topic in the master project

The alternative topic should be in the master project because this is the only help file that

1088
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is always present in a runtime-merged modular help system.

1. Open the master help project and choose or create the alternative topic that you want

the user to be able to view when the other help file module containing the target topic

is not available. 

2. Select this alternative topic, select the  tab and enter a unique A-keyword in the A-

Keywords: field. The A-Keyword must be unique. It should not be used anywhere else

in your projects! If it is, all the topics where it is used will be displayed when the A-Link

hyperlink is clicked.

Step 2: Prepare the target topic in the child project

1. Open the child project and select the topic you want to link to. 

2. Select the  tab and enter the same unique A-keyword as above in the A-Keywords:

field. 

Step 3: Create the link

1. Open the project module in which you want to create the link. This can be a master

module or another child module. 

2. Select Insert > Link in Write > Insert to create a hyperlink. 

3. Select the Script Link tab in the Insert Hyperlink dialog, then select Winhelp macro as

the type of hyperlink.

4. Enter Alink() in the Script: field and type the keyword between the parentheses. If your

keyword is "about widgets" the dialog would look like this:

If the target help file is not present when the user clicks on the link the alternative topic

will be displayed automatically. If the target topic is present a dialog will be displayed in

which the user can select either the target topic or the alternative topic.

This is just a very simple example to show you how this solution works in principle. In

practice you can also make more complex solutions, using more alternative topics and

more keywords. If you use multiple keywords remember to separate them with semi-

colons, like this:

Alink(about widgets;troubleshooting;widget solutions)
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Note that when you are working in HTML Help you can only enter keywords as the argu-

ment for the Winhelp macro. You cannot enter the other parameters for the Winhelp A-

Link macro because they are not translated into HTML Help code!

See also:
About A-Keywords  (Reference)

Keywords and Indexes

5.11 Using Graphics

Inserting graphics in your topics with Help+Manual couldn't be easier. You just select the In-

sert Image tool in Write > Insert  and choose your graphic file. Graphics can also include cap-

tions that are stored together with the graphic.  

You can capture and insert screenshots with the integrated screen capture utility and add hot-

spots to your images with hyperlinks to topics, files, scripts and macros.

See also:
About Graphics in Help+Manual

5.11.1 Supported graphics formats

You can use a large number of different graphics formats directly in Help+Manual. If the

format of a graphic you use in your project is not supported in your publishing format

Help+Manual converts the file automatically when you publish your project.

Key Information
For most purposes BMP or Impict IPP are the best

formats. Help+Manual automatically converts and

compresses images as required when you publish and

BMP or IPP are the best source formats for this.

Directly supported graphics formats

All the following graphics formats listed below be inserted in your projects directly with

the Insert Image  tool. Native HTML graphics formats (PNG, GIF, JPG) are published un-

changed when you publish to HTML-based output formats. Other formats are converted

to one of these formats on the basis of your HTML Export Options  conversion settings

in your project configuration settings.

· Standard bitmaps (BMP)

· Compuserve Graphics Interchange Format (GIF)

· SVG vector graphics, including compressed SVGs (.svgz)

(See SVG Graphics  and Responsive Images  for more information)

· JPEG Graphics (JPG)
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· Portable Network Graphics (PNG)

· Photoshop images (PSD)

· Paint Shop Pro images (PSP, single-layer only)

· TIFF images (TIF) 

· Kodak PhotoCD images (PCD)

· Windows Metafiles (WMF, EMF) 

These are now obsolete formats. Use modern SVG graphics instead. See further below

for details on display problems with WMF files.

· Impict graphics (IPP, the special format of Help+Manual's Impict graphics editor)

· Segmented Hyper Graphics (SHG, MRB the Winhelp hotspot graphics format, now ob-

solete.)

You can also insert unsupported graphics by opening them in a graphics program that

supports them and copying them to the Windows clipboard. Then just paste the clipboard

contents in the Help+Manual editor and you will be prompted to save in an external file. 

Correcting the display of WMF graphics for high-resolution monitors

The now obsolete WMF and EMF vector graphics formats were created long before mod-

ern, high-resolution monitors existed. We strongly recommend that you no longer use

these obsolete formats. Use modern SVG vector graphics instead. 

If no correction is applied, WMF graphics will scale incorrectly on high-res monitors, ap-

pearing much larger than they should. EMF Help+Manual corrects this with a program op-

tions setting that is on by default. This setting is in 

View > Program Options > Editor: Auto-adjust legacy .WMF images for high-resolution

displays. 

When WMF correction should be on

If you inserted old WMF graphics in old projects the correction prevents them from dis-

playing too large when you switch to a high-resolution monitor. Similarly, it should always

be on when users with both high-resolution monitors and standard monitors work on the

same project, as it prevents different displays on the different monitors.

When you might want to turn WMF correction off

If you have always worked on a high-resolution monitor and inserted your graphics before

correction was available, the introduction of WMF correction will make your images look

too small. Turning correction off will return them to normal. However, this display is actu-

ally incorrect, and it would be better to turn correction on and adjust the scaling of your
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graphics instead. Of course, it would be even better to stop using WMF and switch to SVG

graphics. 

Old SHG graphics containing hotspots

The obsolete.shg format for Winhelp graphics should no longer be used, support for it is

only included for backward compatibility. You no longer need to use SHG graphics to add

hotspots in your images because you can add hotspots  to all graphics formats directly

in the Help+Manual editor.

However, if you have old .shg files with hotspots you can use them in your projects dir-

ectly, provided the hotspots link to valid topic IDs in your project. 

IPP graphics containing hotspots from HM3 projects

Hotspots in .ipp graphics created with Help+Manual 3 cannot be imported to new pro-

jects on their own because they are linked to specific projects. The hotspots will only be

imported if the .ipp images are imported together with the .hm3 project for which they

were created.

5.11.2 Inserting graphics and screenshots

You can insert graphics in your projects from files stored on your hard disk or with cut &

paste. Drag & drop from the desktop or Windows Explorer is not supported. 

Note that although cut & paste may be more convenient you may get slightly better image

quality when you insert graphics directly from files. This applies particularly to pasting from

MS Word, which generally resizes the image very slightly (just a couple of percent) when you

copy it via the Windows clipboard.

Graphics as link targets

You can link directly to graphics in topic links  in the same way as anchors. You just

need to assign an ID to the graphic, then it will be shown as a target in the anchor list in

the link tool.

Productivity Tip
When inserting a graphic in a paragraph with text al-

ways type a space as the first character after the

graphic, this will prevent the image caption style from

being applied to the text you type.
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How to insert one or more graphics from a file

Using Drag & Drop

You can also insert images with Drag & Drop. Just drag the image file into the editor win-

dow and drop it where you want to insert it.

Using the Insert Image tool

Note that you can also insert multiple images at the same time. To do this, just select mul-

tiple images in the Open dialog. All the settings you choose in the dialog then apply for all

the images selected.

· Click in the editor at the position where you want to insert the graphic. 

· Select Insert > Image in the Write tab. displays the Open Image  dialog:

See Editing image attributes below for details of all the attributes and what they do.

Pasting graphics from the Windows clipboard

Probably the quickest way to insert a graphic is pasting directly from the Windows clip-

board. Just copy the graphic in your graphics editor or any other program, then click in

the Help+Manual editor where you want to have the graphic and press CTRL+V or select

Paste in the right-click context menu or the Help+Manual toolbar.

This opens a Save File dialog with an automatically-generated filename. You can then

choose where you want to save the file and change the name. It's advisable to use a de-

1359
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scriptive name instead of the automatic name. For long-term compatibility avoid spaces,

accented characters, non-alphanumeric characters and any special characters in the

names. 

Where to save

If possible, save your graphics in the project's own graphics folder(s), which should be in-

side the project folder. Then you can move the project around with the entire folder

without having to change any settings or manage graphics locations . 

Pasting transparent PNGs and GIFs 

When you paste a graphic stored in a clipboard you will always get a graphic, but when

pasting from some applications you may have problems with PNG and GIF files with trans-

parent areas. For example, this will happen if you paste from the Snagit screenshot pro-

gram. If you experience this, try the Paste from HTML option in the Help+Manual Paste

menu.

These programs only store a non-transparent bitmap in the clipboard, but they also in-

clude a snippet of HTML code that links to the actual transparent image that they store on

the disk. When you use Paste HTML with an image in the clipboard Help+Manual checks

for code like this and gets the actual image it references.

Image name not editable when pasting HTML:

You can't change the name of the pasted image directly when you get it via HTML code.

This is because Help+Manual needs to copy the actual image that has already been saved

to disk. So you need to accept the file name generated by your graphics program when

you paste and change it later if necessary.

514
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Methods for updating existing graphics quickly

When working on your documentation you will frequently want to update a graphic im-

age. There are a couple of methods you can use to achieve this quickly and efficiently:

Paste the new image over the old image in the editor

This is the fastest solution if you are replacing the entire graphic with a new or edited ver-

sion. Note that this only works for single-layer images! If you do this with an Impict IPP

image containing multiple layers (objects) all the layers in the original image will be re-

placed by the pasted image.

1. Select the graphic in your editing program and copy it to the Windows clipboard. 

2. Click on the old version of the graphic in the Help+Manual editor to select it.

3. Press CTRL+V to paste your new version over the old version.

This will automatically replace the old version in the editor and the file on the disk with the

new version. (You will be prompted to confirm you want to do this).

Edit the image in place

Instead of editing the image in a separate location, use your graphics program to edit the

version stored in your project's image folder directly. This is to only way to speed things

up for Impict .IPP images with multiple layers, because you can't paste them in with the

method described above.

After editing, you can refresh the image in the current topic in Help+Manual in the follow-

ing ways:

· Right-click on the image in Help+Manual and select Picture > Reload.

· In the Project tab, Select File > Reload Topic in the Manage Topics section.

· Switch briefly to another topic and back to the topic containing the image.

Editing image attributes, captions etc.

To edit the attributes of an image in the Help+Manual editor just double-click on it with

the mouse. This displays the Insert Image dialog again, where you can add or edit all the

attributes:
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Tip: Align the caption with image styles

You can change the alignment of the image caption (left, center, right) by defining an im-

age style . 

· Image Style applies an image style  that you have defined. This defines a border

and the image dimensions. 

· Alignment can make text wrap around the image with the Left or Right options.

· Padding adds empty space around the image (in pixels). You can set values for indi-

vidual sides with .

· Display Size controls the display size of the image on the page. See Responsive

Images  for more details on how to use these options to optimize your graphics

for responsive layouts. 

o Physical image size displays the image in its native size.

o % of physical image size scales the image to the percent you define. This is

static – the image size does not change with the window size.

o % of page with, maximum is physical size scales the image in relation to the

page width or the width of the table cell, if the image is in a table. However, the

image never expands beyond its native width. This uses 99.90% as the trigger

value, but the result is still 100% of the native width.

o Scaled to full page width scales the image to the size of its container (page or

table cell) without limit. The image will expand beyond its native size if necessary.

Preventing excessive scaling:

Use the % of page with, maximum is physical size setting to prevent "inflated" and

"jaggy" images on larger screens. When you using this setting the image will only

expand up to its native width but will not zoom further to prevent excessive scaling. 

· Tooltip is a text displayed when the mouse pointer is over the image.

· Caption is displayed below the image (formatted with the Image Caption style) and

is included as the ALT attribute in HTML-based image formats. It is required for the

Table of Figures function  in Word DOCX output (images without captions are not

included in the Table of Figures). 

· Add to Table of Figures inserts a figure counter variable. See Figure and table

counters  for full details on using this feature.

· Picture ID adds an ID that can be used as a link target in topic links . It can also

serve as a unique reference in HTML and for hyperlink references to the figure

counter  reference.
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· HTML Class add an optional HTML class name to the image for referencing all im-

ages with this class in your own CSS and JavaScript code (unlike the ID, which can

only be used for a single image in the same topic). You can also add multiple HTML

class names separated by spaces if you need to.

You don't need to worry about entering the pixel dimensions of your graphic as you

would have to do in an HTML editor. Help+Manual does this automatically.

Numbering images and including them in the table of figures

The Add to Table of Figures option in the image dialog automatically inserts a figure

counter variable in the caption and includes the image in the internal list for the genera-

tion of a table of figures for the project. These tables of figures, tables and other items can

be used in both PDF and Word DOCX output. See Figure and table counters  for details

and full instructions.

Responsive images: relative to page or table cell width

If you set the Display Size in the image dialog to % of page width or scaled to full page

width, the zoom value you enter is relative to the container of the image. This is the page

width if the image is inserted directly on the page or the table cell containing the image if

the image is in a table. 

In HTML output formats this makes the images responsive. This means that the images

will automatically scale with the size of the window. 

Use image styles for sizing images

Defining an image style  allows you to set an absolute or relative width (% of page

width) for all images in a class. This ensures that all the images will be displayed with the

same width on the page without you having to apply individual settings to each image.

You just need to select the style for the image.

944
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Preventing excessive scaling

If the width is defined as any percentage less than 100% (i.e. up to 99.90%), the image will

only expand up to its full native width but will not zoom further to prevent excessive scal-

ing. Setting a width of 100% turns this off and allows unlimited scaling. The % of page

width and scaled to full page width options do this for you automatically. The first sets the

width to 99.90%, the second sets it to 100%. 

Putting responsive images side by side

If you set the image widths to add up to less than 100% you can put multiple responsive

images on the same line and they will display side by side. The only exception to this are

images with captions: These must be put in tables if you want to display them side by

side, because otherwise the caption container will create a new paragraph after every im-

age, even if the images fit on the page side by side.

Responsive images in table cells

Note that when responsive images are in table cells their width is relative to the table cell,

not to the page. So you could have three images in a table side by side in three cells, each

with a width of 80%, for example. Each image will then be 80% of the width of the cell

containing it, leaving 10% space on either side.

Responsive images with captions side by side

When images have captions they have an invisible container around the image that en-

closes the caption and keeps it with the image. This container always creates a new para-

graph in HTML output. To put responsive images with captions side by side you must put

them in a table. Otherwise each image will be in a separate paragraph, even if they would

actually fit side by side.

Separate padding values for each side

You can set separate padding values for each side of the image by entering multiple val-

ues in the Padding field. The easiest way to do this is with the popup menu displayed

when you click on  in the Padding: field.

You can set the values manually: For all four sides (1 value), vertical and horizontal sides (2

values) or each side individually (4 values). The values apply in the same way as HTML val-

ues, clockwise from the top – i.e. top right bottom left.

Padding setting Effect
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10 Sets the same padding value for all four sides of the image,.

10 15 Sets padding to 10 pixels for top and bottom and 15 pixels for left

and right

10 25 15 5 Top: 10 pixels, Right: 25 pixels, Bottom: 5 pixels, Left: 15 pixels

HelpXplain slides as static images

If you use the EC Software HelpXplain  application for animated screencasts and in-

fographics you can also insert HelpXplain slides as static images. This makes it possible to

use HelpXplain as an alternative screenshot editor and create edited screenshots with a

more modern look and feel than the older Impict utility. 

How to insert a HelpXplain slide

Note that this method always inserts the first slide in your HelpXplain .xplain file as a

static image. So the .xplain you use should either contain only one slide or the first

slide should be the one you want to use.

· Click in your topic where you want to insert the image. 

· Select the Image tool in the Write tab and select the .xplain file containing the slide

you want to insert. 

That's all there is to it. The first or only slide in the Xplain will be inserted as a static

graphic image and will then behave like any other graphic. The same padding, positioning

and formatting apply as for other graphics.

Conversion of Xplains for HTML

Xplains are converted to HTML-compatible graphics using the same settings as for all

other bitmap files. The settings are in Configuration > Publishing Options > We-

bHelp/Microsoft HTML Help > HTML Export Options. Your static image Xplains will be

converted to PNG, JPG or GIF, depending on your settings there. If you choose the

JPG+GIF option they will be converted to JPG, since Xplains are always full-range color im-

ages.

Inserting graphics from unsupported formats

You can also insert unsupported graphics formats by opening them in a graphics program

that supports them and copying them to the Windows clipboard. Then just paste the clip-

550
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board contents in the Help+Manual editor. You will be prompted to save in an external

file and you can then choose the format you want to save in.

How to insert a graphic with Cut & Paste

· Copy the graphic to the Windows clipboard in the source program. 

·  Click in the editor at the position where you want to insert the graphic and press

Ctrl+V or select Clipboard > Paste in the Write tab.

· You will be prompted to save the graphic in an external file. 

· Give the image a descriptive name and save it in your project's graphics folder

rather than the main project folder. 

· To edit the graphic insertion properties double-click on the graphic to reopen the

Open Image dialog .

How to format the image caption

· The formatting of the caption text is controlled by a standard style  called Image Cap-

tion. You can change this for the entire project by editing the style . 

· You can also change the appearance of the caption text by applying font attributes dir-

ectly. To do this select the graphic in the editor, then select the font attribute you want

to apply (bold, underlined, font etc). 

Note that you can only format the entire caption text. You cannot apply different font at-

tributes to individual parts of the text. For more details see Image caption and comment

styles .

See also:
Graphics, Videos and OLE  (Reference)

5.11.3 Positioning graphics

By default, a graphic inserted in Help+Manual is a handled as a single object in a paragraph,

essentially the same as a character. This means that if it is alone in its paragraph it can be

centered, left-justified and right-justified by adjusting the paragraph formatting settings. In

addition to this you can also make text wrap around it to the left or right with the Alignment:

settings in the Open Image  dialog. 

For more complex control over the position of graphics on your page you need to place the

graphics in tables , in the same way that you would in a HTML page.
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How to align a graphic without wrapping text around it

You can center graphics on the page or place them on the left or right side of the page

with the settings for the paragraph containing the graphic. 

1. Click in the paragraph containing the graphic. There shouldn't be any text in the para-

graph as the result would not look good in the output. 

2. Format the paragraph to position the graphic. For example you can left-justify, center

or right-justify the paragraph or add space before and space after to separate the

graphic from the paragraphs above and below it. (You can also add space around the

graphic with the Spacing: setting in the Open Image dialog .

Formatting options:

Use the Paragraph tools in the Write tab or select the paragraph dialog icon at the bot-

tom right corner of the Paragraph tools group to display the full Paragraph formatting

dialog.

Responsive images: relative to page or table cell width

If you set the Display Size in the image dialog to % of page width or scaled to full page

width, the zoom value you enter is relative to the container of the image. This is the page

width if the image is inserted directly on the page or the table cell containing the image if

the image is in a table. 

In HTML output formats this makes the images responsive. This means that the images

will automatically scale with the size of the window. 

Use image styles for sizing images

Defining an image style  allows you to set an absolute or relative width (% of page

width) for all images in a class. This ensures that all the images will be displayed with the

same width on the page without you having to apply individual settings to each image.

You just need to select the style for the image.

Preventing excessive scaling

If the width is defined as any percentage less than 100% (i.e. up to 99.90%), the image will

only expand up to its full native width but will not zoom further to prevent excessive scal-

ing. Setting a width of 100% turns this off and allows unlimited scaling. The % of page

width and scaled to full page width options do this for you automatically. The first sets the

1359
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width to 99.90%, the second sets it to 100%. 

Putting responsive images side by side

If you set the image widths to add up to less than 100% you can put multiple responsive

images on the same line and they will display side by side. The only exception to this are

images with captions: These must be put in tables if you want to display them side by

side, because otherwise the caption container will create a new paragraph after every im-

age, even if the images fit on the page side by side.

Responsive images in table cells

Note that when responsive images are in table cells their width is relative to the table cell,

not to the page. So you could have three images in a table side by side in three cells, each

with a width of 80%, for example. Each image will then be 80% of the width of the cell

containing it, leaving 10% space on either side.

Responsive images with captions side by side

When images have captions they have an invisible container around the image that en-

closes the caption and keeps it with the image. This container always creates a new para-

graph in HTML output. To put responsive images with captions side by side you must put

them in a table. Otherwise each image will be in a separate paragraph, even if they would

actually fit side by side.

How to wrap text to the left or right of the graphic

1. Double-click on the graphic to re-open the Open Image  dialog. 

2. Select Left of text or Right of text in the Alignment: field.

3. Set the Padding: value to increase the amount of free space around the image. You

can also set separate padding values  for each side of the image. To do this quickly

just click on the  button in the Padding: field. 

The wrapping is displayed in the editor and is supported in all output formats, including

PDF.

See also:
About Graphics in Help+Manual
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Working with Tables Help+Manual

5.11.4 Image Styles

You can now define styles for images in the same way as for paragraphs and tables. And just

as with paragraphs and tables, changing the image style definition changes the formatting for

all images tagged with the style. 

Image styles can also be used for image toggles and video placeholders

Note that image styles can be applied to image toggles  and the placeholders for

videos and online media .

Image style settings

Image styles can include these settings. The width and height settings allow you to create

a class of images that match exactly in your output. 

Responsive or

fixed width:

We recommend always using the responsive width setting (% of

page width). This makes your images adjust to the browser or

viewer window in HTML formats, or to the page width on publish-

ing in PDF and Word files. In both cases this prevents your images

from breaking your layout.

Responsive images in tables:

Note that when an image is in a table the % width is relative to the

table cell, not to the page.

Fixed height: This sets all the images to the same absolute height in pixels. You

cannot combine this with a width setting. You must set either the

width, or the height. 

518 1529
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Borders: Apply a border around all images formatted with the style.

Caption alignment: Align the image caption left, centered or right.

Note on image styles in Word export

Image styles in Word DOCX export can have borders, but they cannot include rounded

corners or an offset between the image and the border. This is a restriction of the style

settings available in Word.

Defining an image style

Notes

· You can't add style settings to the Default image style. This is the standard setting for

images and is without additional style attributes. 

·  Image styles can be based on other image styles or independent. This is the same as

with other style types.

Procedure

1. Open Styles > Edit Styles in the Write tab. 

2. Locate the Image Styles heading and click on Add Style. 

3. Enter a name and choose whether it is to be based on another style or not. Styles

based on other styles inherit any settings you don't change in the parent.

4. Select Modify Layout to define the style settings.
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Width or height:

You can define either the width or the height. The other setting is always automatic. 

Percentage width or fixed width:

Percentage is recommended, because it makes the images responsive, adjusting in rela-

tion to the width of the current window or page. This is essential for responsive web

design for both desktop and mobile devices, and it also ensures that your images won't

break PDF and Word layouts.

Borders:

You can define the border style (solid, dashed etc.), width and color. Plus the radius, which

creates rounded corners, and an offset, for a border offset from the image.

Rounded borders with an offset:

If you use a style with rounded borders and an offset for the border, you will want the

rounded corners of the image to match those of the border as closely as possible. For this

to work, you need to use a fairly high value for the border radius. In the example below,

the 5px radius doesn't match the image, but the 20px radius does.
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Caption alignment:

Centered, left or right. The text style for the caption is defined globally with the Image

Caption style in the Text & Paragraph Styles section. 

Applying styles to images

The style setting is in the Insert/Open Image dialog displayed when you insert an image.

For existing images, just double-click on the image in the topic editor to display it.

Procedure

1. Insert a new image, or double-click on an existing image to display the dialog. 

2. Select the style from the Image Style: dropdown list and click on Open to save. 

Dual Styles for electronic help and print-style help (PDF etc.)

Screen View and Print View tabs:

You can define two sets of settings for each style: Screen View is for electronic help

formats (HTML Help, WebHelp and eWriter Help), Print View is for page-style formats

(PDF, Print User Manual, Word DOCX and ePUB eBooks).
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You can switch between the Screen and Print View style settings in the Help+Manual ed-

itor by clicking on the Screen/Print button in the status bar at the bottom of the main pro-

gram window.

5.11.5 Responsive images

Graphics are often a problem in responsive layouts designed to adapt automatically to differ-

ent device sizes – from desktop monitors to hand-held smartphones. Traditionally, graphics

have fixed dimensions that break responsive layouts on screens that are smaller than the

graphic. 

To solve this problem you need to set the width of your graphics in percent relative to the

page dimensions. Then the graphic can never be wider than the page. Length is not a prob-

lem, because pages can always scroll vertically. However, you never want the page to have to

scroll horizontally on mobile devices with fluid layouts.

Maximizing quality for responsive images

The best way to maximize quality for responsive images is to use images that are larger

than the intended display size and scale them with the responsive percentage settings.

This is particularly important if you are targeting high-resolution devices and monitors,

and it also produces better results for zooming and printing in PDF and DOCX documents.

The images then have plenty of "reserve resolution" that allows them to display at accept-

able sizes on high-resolution displays without being upscaled, which would result in fuzzy

or jaggy images.
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Making images responsive with the Display Size setting

The setting you use for this is Display Size in the Insert Image dialog . There are corres-

ponding settings for making images responsive in the image toggle  and video dia-

logs  as well, where they control the responsive behavior of the clickable/tappable pre-

view images.

Tip: Use image styles for responsive images

You can set the same responsive width for an entire class of images with image styles . 

Use an image style instead of setting the same dimensions for every

image

If you define an image style , you can set the same absolute or relative width for all the

images in a class. This ensures they will all be displayed with the same width on the page,

and you no longer have to set the dimensions for every image. You just select the style. 

The Display Size setting controls the display size of the image on the page and can make

it either static or responsive.

Physical image size: This is the traditional setting. It display the image at 1:1, in its

natural native size. The image is non-responsive and will al-

ways force the layout around it to adapt to it. The only ex-

ceptions are PDF and DOCX, where Help+Manual will adjust

the image width so that it fits on the page or in the table

where it is located without breaking your layout.

% of physical image size: This is also static. It simply resizes the image to display at the

percentage of the original size you enter.  If this is wider than

the device it will still extend beyond the width of the window

horizontally.

% of page with, max-

imum is physical size:

This creates a fully responsive image that will expand to a

maximum of its own native size, but not more. If the page or

481
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table cell is narrower than the native size the image will be

scaled down. 

This automatically sets the width to 99.90%, which is the

value that triggers this behavior.

Scaled to full page

width:

This creates a fully responsive image without a maximum size

restriction. It will continue to expand to the width of the page

or table cell, no matter how wide they are. This is generally

not recommended. It can result in fuzzy, jaggy images at lar-

ger resolutions. 

Responsive SVG images in CHM help and older versions of Internet
Explorer

Most browsers handle responsive SVG vector graphics correctly. There are two exceptions:

Older versions of Microsoft Internet Explorer and the Microsoft HTML Help/CHM help

format. Actually, this is just one exception, because the CHM viewer in Windows uses an

older mode of Internet Explorer to render the HTML pages, and Internet Explorer is the

problem.

Older versions of Internet Explorer and the CHM help viewer only scale responsive SVG

graphics correctly if their internal <svg> tag contains correctly configured width/height

attributes followed by a correctly configured viewBox attribute that also contains the de-

fault width and height of the graphic. If these three attributes are not all present and cor-

rectly configured, the SVG image will remain static and will not scale with the window,

even if you insert it with responsive settings.

See SVG Graphics  for detailed instructions.

Enabling SVG export in CHM

By default, Help+Manual converts SVG images to PNG in CHM export, for maximum com-

patibility. If you want vector SVG images in your CHM you need to turn off PNG conver-

sion in Configuration > Publishing Options > HTML Help > HTML Export Options. 

Responsive images in PDF and DOCX

In PDF and DOCX responsive images don't adjust dynamically on viewing, because the

page width is always static. The user can zoom the pages on the screen, but that simply

500
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adjusting the display of the entire page. The layout does not "reflow" as it does in dy-

namic formats like WebHelp or CHM. 

When you export responsive images to PDF and DOCX, the responsive part happens dur-

ing the actual publishing operation. Help+Manual adjusts the images to the page width

during this process in exactly the same way as the dynamic adjustment that happens

when the user adjusts the window width in a web browser. However, since the resulting

page width is static, the adjustment is also static and final.

It is still a good idea to insert larger images in PDF and DOCX, however. This gives you

better image quality on high-resolution devices and for zooming and printing. In both

formats, Help+Manual exports the full original image with a scaling command for its final

display. If you use a larger image it will have "reserve capacity" that can be used for better

display at different resolutions and printing.

Responsive images: relative to page or table cell width

If you set the Display Size in the image dialog to % of page width or scaled to full page

width, the zoom value you enter is relative to the container of the image. This is the page

width if the image is inserted directly on the page or the table cell containing the image if

the image is in a table. 

In HTML output formats this makes the images responsive. This means that the images

will automatically scale with the size of the window. 

Use image styles for sizing images

Defining an image style  allows you to set an absolute or relative width (% of page

width) for all images in a class. This ensures that all the images will be displayed with the

same width on the page without you having to apply individual settings to each image.

You just need to select the style for the image.

Preventing excessive scaling

If the width is defined as any percentage less than 100% (i.e. up to 99.90%), the image will

only expand up to its full native width but will not zoom further to prevent excessive scal-

ing. Setting a width of 100% turns this off and allows unlimited scaling. The % of page

width and scaled to full page width options do this for you automatically. The first sets the

width to 99.90%, the second sets it to 100%. 

Putting responsive images side by side

If you set the image widths to add up to less than 100% you can put multiple responsive

492
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images on the same line and they will display side by side. The only exception to this are

images with captions: These must be put in tables if you want to display them side by

side, because otherwise the caption container will create a new paragraph after every im-

age, even if the images fit on the page side by side.

Responsive images in table cells

Note that when responsive images are in table cells their width is relative to the table cell,

not to the page. So you could have three images in a table side by side in three cells, each

with a width of 80%, for example. Each image will then be 80% of the width of the cell

containing it, leaving 10% space on either side.

Responsive images with captions side by side

When images have captions they have an invisible container around the image that en-

closes the caption and keeps it with the image. This container always creates a new para-

graph in HTML output. To put responsive images with captions side by side you must put

them in a table. Otherwise each image will be in a separate paragraph, even if they would

actually fit side by side.

5.11.6 SVG Graphics

Vector-based SVG graphics files are very useful for responsive designs and any other formats

where the content may be zoomed because they are compact and can be scaled without any

loss of quality. You can insert them directly in your topics just like any other graphics files.

How they are supported and handled in individual output formats varies slightly, however.

WebHelp: Both uncompressed SVG and compressed SVGz graphics are ex-

ported directly as the original files in WebHelp. In addition to this,

each image has a PNG fallback image that is displayed in older

browsers that do not support SVG.

MS HTML

Help/CHM:
(Also applies for

older versions of In-

ternet Explorer)

The Microsoft CHM viewer uses an older mode of Internet Explorer

to display help pages which is not seamlessly compatible with SVG

files. They can only be rendered correctly if certain conditions are

fulfilled. Because of this, SVGs are converted to PNG by default

when you publish to CHM. If you are sure that your SVG files will

work correctly in CHM you can turn this conversion off.
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Characteristics of the PNG conversion:

When SVGs are converted to PNG the resulting PNG will have the

current display dimensions of the SVG or the original SVG dimen-

sions, whichever are larger.

Enable export of native SVG files to CHM:

By default, Help+Manual converts SVG to PNG for CHM export for

maximum compatibility. If you want vector SVGs to be exported

natively to CHM you need to turn off PNG conversion in Configur-

ation > Publishing Options > Microsoft HTML Help > HTML

Export Options.

Compiler warnings for incompatible SVGs

Help+Manual checks for these attributes when you publish to CHM

with native SVG support switched on. If it encounters files without

the necessary attributes warnings will be displayed in the compiler

report. 

Conditions for correct rendering of SVG graphics

in the CHM viewer

SVG graphics are will be rendered and scaled correctly in the Mi-

crosoft CHM viewer if the following conditions are fulfilled:

1) The skin or template includes the following line in the HTML

Page Template:

<meta http-equiv="X-UA-Compatible" con-
tent="IE=9" />

This line is included by default in all of Help+Manual's standard

CHM skins and in the CHM skins in the Premium Pack add-on. If

this line is missing or if the IE level is set to 8 or lower, the CHM

viewer will not support SVG and the SVG graphics will be converted

to PNG on export.

2) The SVG file you use contains correctly configured width,

height and viewBox attribute

The version of MS Internet Explorer used in the CHM viewer can
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only scale SVG graphics if the <svg> tag in the SVG file contains

correctly configured width and height attributes followed by the

correctly configured viewBox attribute. These attributes should look

like this when you view the SVG file in a code or text editor (see

further below for instructions):

<svg width="212.16249" height="211.27501"
viewBox="0 0 212.16249 211.27501" ...

Configuring the width, height and viewBox at-

tributes in your SVG images

If your graphic program can configure the width, height and

viewBox attributes in the <svg> tag in your images you just need

to enable those options there. Otherwise you need to edit the

.svg file in a text/code editor and add the attributes to the <svg>

tag yourself. (SVG files are actually text files containing vector

graphics code.)

Editing the <svg> tag manually

1. Open the .svg file in a text or code editor (NOT in a word pro-

cessor!). 

2. Locate the <svg ... tag, which begins in the first line of the

file. 

3. Add the viewBox attribute after the width and height attributes,

as follows:

<svg width="212.16249" height="211.27501"
viewBox="0 0 212.16249 211.27501" ...

4. The first two values in the viewBox attribute are two zeroes sep-

arated by a space. This is followed by the width and height val-

ues, which should be exactly the same as the values from the

width and height attributes, as shown in the example.

5. Save the SVG file. After this, it should behave responsively in

CHM and Internet Explorer.

Word DOCX: Only the latest version of Word 2016 in the Office 365 edition sup-

ports SVG graphics. To ensure maximum compatibility with the

very large number of users on other versions, SVG graphics are

converted to PNG files for export to Word DOCX.
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When SVGs are converted to PNG the resulting PNG will have the

current display dimensions of the SVG or the original SVG dimen-

sions, whichever are larger.

Adobe PDF: SVG graphics are exported to PDF if possible (if they are not too

complex). More complex SVGs will be exported to PNG with alpha

transparency, which is supported natively in PDF. 

When SVGs are converted to PNG the resulting PNG will have a 32-

bit color depth and will have the current display dimensions of the

SVG or the original SVG dimensions, whichever are larger.

eWriter Help: Same support as in WebHelp (eWriter is WebHelp in a single file

with an embedded viewer).

ePUB and Kindle

eBooks:

SVG graphics are supported natively in these formats. 

5.11.7 Editing, resizing, PDF, DOCX and hi-res devices

You can edit the properties of a graphic by double-clicking on it. You can also resize your

graphics directly in the editor by selecting it and dragging its corners with the mouse or by

double-clicking and entering a zoom factor. Although this function is primarily designed for

high-resolution printing with PDF files you can use it for all your output formats whenever

you need a quick resize. You may obtain slightly better quality if you resize in Impict  or an-

other graphics program, but this feature can be a great time-saver when you are in a hurry. 

Editing graphics properties and captions

· Just double-click on any graphic to display the Open Image  dialog where you can

edit the caption, alignment, spacing (empty space around the graphic) and hotspots

(clickable links in the graphic). 

· You can adjust the size of graphics precisely with the Zoom % setting in the Open

Image dialog. This does not physically resize the image until you publish and in PDF the

full image resolution is used (see below).

· You can also edit the properties and hotspots by right-clicking on a graphic and select-

ing from the Picture... options in the context menu.

1216
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Resizing graphics in the Help+Manual editor

Note that resizing does not physically change the image file, except in one case in CHM

output (see further below). The full original images are always exported, along with a scal-

ing command for the individual output format. If you want smaller image files you need to

resize the images physically in a graphics program. 

· Quick resize: Just click once on the graphic to select it and resize it by dragging the

resize handles displayed at the edges. It doesn't matter which handle you drag because

the height and width of the graphic are always resized proportionally.

· Precise resizing: Double-click on the graphic to display the Image dialog and enter a

zoom factor in percent. This also allows you to configure responsive image settings .

· Undo resize: To return the graphic to its original size just double-click on it to display

the Open Image dialog and select the Autosize option.

How resized images are processed on publishing

Nothing is actually done to the image when you resize it in the Help+Manual editor. Your

original source image file is not changed at all, and is never changed. Any processing is

only performed on publishing. How resized images are handled on publishing depends on

the output format:

WebHelp, ePUB, Kindle and eWriter: Export images with original di-

mensions

The images are exported with their original native dimensions when you publish to to

these formats. Instead of physically resizing the image, Help+Manual simply adjusts the

display size of the image. Modern browsers and eBook viewers do an excellent job of scal-

ing and this provides much better quality for responsive images on high-resolution

devices.

HTML Help/CHM: Original images or physical resizing

Help+Manual generates fully scalable pages for CHM output if you activate the setting

Make CHM file compatible with high-resolution monitors in Configuration > Publishing

Options > HTML Help > HTML Export Options. Then the original images are exported in

exactly the same way as for WebHelp, along with a scaling setting. If you turn this option

off the images are physically resized to the target dimensions during the publishing pro-

cess.
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PDF and DOCX: Export images with original dimensions

Images exported to these formats are handled in the same way as WebHelp. The image is

exported with its full original dimensions along with a scaling command that controls its

display dimensions on the page, in accordance with your image dimensions settings. Here

too, this gives you better quality for zooming and printing if you insert an image with nat-

ive dimensions larger than those of the display dimensions. 

Using high-resolution graphics for PDF, DOCX and printing

When you print PDF or DOCX files or view them at above 100% graphics can look "blocky"

and "jaggy". You can solve this problem by using larger graphics and resizing them in the

Help+Manual editor. Since the images are exported with their original dimensions they

then have enough "reserve resolution" for better quality display on high-resolution

devices and printers. 

Resizing graphics physically with the Impict graphics editor

For the best possible resize quality when using native image dimensions rather than re-

sponsive images you can also resize your graphics files physically. You can do this with

your own favorite graphics editor, or with Impict, the screenshot enhancement and graph-

ics editor included with Help+Manual, or with any other graphics editor.

However, with the increasing use of high-resolution devices this method is no longer as

useful as it used to be. Generally, it is now almost always better to insert larger responsive

images that will give you better display quality on these modern devices. 

· To edit a graphic in Impict just click on the graphic in the editor to select it and then se-

lect Image Editor in Project > Tools. 

· Once you have opened the image in Impict you can then resize it by right-clicking on it,

selecting Edit Properties and then Quality Resize. 

· After saving the new version in Impict (don't change the filename or location) just select

another topic briefly in Help+Manual and then return to the current topic to reload the

topic with the modified graphic.

See also:
About Graphics in Help+Manual

Conditions and Customized Output

1529
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5.11.8 Using the Impict graphics editor

Help+Manual comes with its own powerful graphics program called Impict for editing and en-

hancing screenshots and other graphics. This editor has a wide range of powerful features for

making professional help graphics and screenshots.

How to open a graphic in Impict

· Click once on the graphic in the Help+Manual editor screen to select it, then select

Tools > Image Editor in the Project tab.

Impict comes with its own comprehensive help and documentation. Please refer to this for

full details on using the program.

Treating IPP images as transparent

By default, IPP images are non-transparent and their background is the solid color that

you define for the image canvas in Impict. However, if you wish you can also change a set-

ting in Help+Manual that converts the IPP image background to transparent. Then the

canvas background color will be transparent and the image will be exported as a PNG im-

age with an alpha transparent background.

Setting for transparent IPPs

Go to View > Program Options > Editor and activate the option Treat Impict images

(*.ipp) as transparent and ignore the background.

Editable objects and texts in Impict images

The great advantage of Impict is that all effects and objects you add to your images are

non-destructive. You can always go back and edit your screenshots later if you need to

make changes – you don't need to rebuild the entire screenshot.

Texts in Impict images can be exported to XML files for translation. See the Impict help for

details.

For all these features you must save working copies of your images in Impict's own IPP

format – you can't save editable objects and texts in standard formats like BMP, GIF or

JPG.
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5.11.9 Using the screen capture function

Help+Manual has an integrated screen capture function that includes most of the functional-

ity you need to make attractive screenshots quickly and efficiently. The function will automat-

ically select windows, controls and menus and you can also select freely-defined rectangular

regions of applications or the desktop and fixed size regions.

In addition to simple screenshots you can also make screenshots with a wide variety of differ-

ent shapes, add shadows and background colors and automatically resize your screenshots

with a choice of high-quality scaling filters.

Using the screen capture tool

· Select the Screen Capture tool in Project > Tools. The tool is pretty self-explanatory but

for full instructions see Screen Capture  in the Tools Included with Help+Manual

chapter.

For even more screenshot power try our free TNT utility, which combines screen capture

and graphics editing:

 TNT Screen Capture Program Page

Making screen captures with Impict

You may want make screen captures for editing, without inserting them in your topic dir-

ectly. To do this use the screen capture feature in Impict , the specialized graphics ed-

itor included with Help+Manual.

Impict's screenshot tool simply captures a plain screenshot without applying any auto-

matic effects. All the effects can be applied inside Impict. The advantage of this is that

Impict's effects and objects are non-destructive – you can always go back and make

changes later if you save a working copy in Impict's own IPP format.

The texts stored in Impict IPP images can also be exported to XML files for translation.

Screen capture seems to fail with some applications - no red bor-
der

On some Windows systems you may experience that the screen capture function doesn't

seem to work. When you start the capture you don't see the red border around the win-

dows or elements you want to capture and no captures are made. This is caused by per-

missions restrictions in your Windows account that are preventing you from capturing ele-

ments from applications with different permissions.

1207
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Solution: Start Help+Manual in Administrator mode

The solution is simple, just start Help+Manual in Administrator mode:

1. Close Help+Manual (or Impict if you started it independently, outside of

Help+Manual). 

2. Right-click on the program item for starting Help+Manual (or Impict if you are starting

it outside of Help+Manual) and select Run as Administrator in the context menu.

You will then have maximum permissions, which will also allow you to perform capture

functions on all other applications.

See also:
Screen Capture

About Graphics in Help+Manual

The Impict Screenshot Editor

5.11.10 Using graphics as hyperlinks

In addition to standard text links you can also use graphics as hyperlinks  in your help pro-

ject, for all the different supported link types. You can use this feature to turn entire illustra-

tions into clickable links, or to use your own graphical buttons as links.

In addition to this you can also add "hotspots" to your graphics, which are clickable regions

that can have all the properties that any other link in a Help+Manual can have. See Graphics

with hotspots, macros and scripts  for details.

How to use a graphic as a link

Note that you cannot turn an existing graphic in your text into a link, you have to edit a

link and select a graphic instead of a caption.

1. Create a new hyperlink or double-click on an existing link to edit it. 

2. Select the Picture option in the Style: section of the Hyperlink dialog . The title of the

entry field at the top changes to Picture:, where you can then specify the graphics file

you want to use.
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3. Click on the  browse button next to the entry field to select your graphic file.

4. Click on OK to close the dialog.

See also:
Inserting Hyperlinks

5.11.11 Graphics with hotspots, macros and scripts

Hotspots are active, clickable areas in graphics. Hotspot data is stored separately from the

graphics, which  makes it possible to add hotspots to all graphics types, not just special hot-

spot graphics. All the link types supported in the editor are also supported in hotspots (topic

links, Internet links, file links and script links). 

Since the link types are identical to those used in normal topics their settings are only de-

scribed briefly here. See Links, Anchors, Macros, Scripts and HTML  for more information on

hyperlinks.

Key Information
Hotspots in graphics are only supported in electronic

output formats (HTML Help, Windows eWriter Help,

Visual Studio Help and PDF with hyperlinks activated).

ePUB eBook readers do not support hotspots.

How to insert and edit a hotspot in a graphic

1. Insert the graphic in your topic. 

2. Open the hotspot editor:

409
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Hotspot editor in the Open Image

dialog

· Double-click on the graphic and then click on the Hotspots... button 

OR 

· Right-click on the graphic and select Picture > Edit Hotspots in the context menu.

3. Click on one of the Insert Hotspot tools (this will insert a new hotspot in the top left

corner of the graphic). These include tools for Topic Links, Internet Links, File Links and

Script Links.

4. Move and resize the hotspot with the mouse and select the hotspot style (Rectangle

or Ellipse). You can also enter the precise size and position of your hotspot as pixel

values.

5. Select and enter the hotspot details. These are exactly the same as for ordinary links in

topics.

Editing hotspots:

To edit a hotspot just double-click on the graphic and open the Hotspots editor again.
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Linking to popup topics

You don't have to do anything special to create a link to a popup topic. A topic defined as

a popup will automatically display as a popup when you link to it, so you just need to cre-

ate a normal topic link and choose a popup topic as the target.

See Creating popup topics  for full instructions on how to create and use popup topics.

All the instructions here apply for links in hotspots, which are essentially exactly the same

as normal links. 

Making the clickable hotspot areas invisible or visible

By default the hotspot area will be made visible in the CHM, WebHelp or eWriter output

so that the user can see where it is, and it will also respond on mouseover to indicate that

it is active. This is a good solution when your images don't contain areas that are clearly

meant to be clicked or tapped.

If you prefer the hotspots to be invisible so that the clickable areas are indicated by your

graphics you can turn this feature off. Then the hotspots will be completely invisible and

will only change the mouse cursor on mouseover. 

For WebHelp and eWriter Help:

In the Project Explorer navigate to Configuration > Publishing Options > WebHelp >

HTML Export Options. Disable the option Highlight hotspots in pictures.

For HTML Help/CHM help files and Visual Studio Help:

In the Project Explorer navigate to Configuration > Publishing Options > Microsoft

HTML Help > HTML Export Options. Disable the option Highlight hotspots in pictures.

How to align hotspots precisely

The Align buttons arrange all the selected hotspots in a row, aligning them to first hotspot

that you select:

1. Use Shift+Click to select all the hotspots you want to align. The hotspots will be lined

up with the first hotspot you select. 

2. Select one of the two Align tools to align the hotspots vertically or horizontally.

207
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The alignment tools are activated when two or more hotspots are selected.

Old IPP and SHG graphics with hotspots

In Help+Manual 3 and earlier, hotspots were stored in Impict IPP graphics files and in files

in the standard Microsoft SHG format. If you convert HM3 projects containing these

graphics to the current Help+Manual format the hotspots will be converted correctly. 

However if you insert old IPP or SHG graphics containing hotspots in a current

Help+Manual project the hotspots will not be available. If you want to use hotspots in

these graphics you must re-enter them using the hotspot editor following the instructions

above.

Hotspot compatibility in publishing formats

HTML Help: Supported (JavaScript and four standard Winhelp macros )

Visual Studio Help: Same as HTML Help but all external file links are explicitly forbidden

in Visual Studio Help.

WebHelp: Supported (JavaScript but no Winhelp macros, JavaScript support

also depends to a great extent on the user's browser, so use with

caution)

eWriter for Win-

dows eBooks:

Same as in WebHelp

ePUB eBooks Hotspots are included in the ePUB specification but most ePUB

readers (both hardware and software) do not support them so they

452
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should be avoided

Kindle eBooks Kindle eBooks do not support images with hotspots

Adobe PDF: Hotspot topic links are supported, no support for script or macro

links

Word DOCX: No support for graphics hotspots.

See also:
Links, Anchors, Macros, Scripts and HTML

IDs, Context Numbers and Keywords

5.11.12 Finding and replacing graphics

The Find & Replace function for text can also locate and replace references to graphics files in

your entire project. This can be very useful if a graphic that you have used over and over

again in your entire project needs to be replaced quickly!

Key Information
This function only replaces the file names in the refer-

ences to the graphics files in your topics. It does NOT

change the actual graphics files or their names!

How to find and replace graphics with Find & Replace

1. Make a note of the exact names of the graphics files you want to find and replace.  

2. Select Find & Replace in Write > Editing.

3. Select the In Image Filenames option in the Find Where section of the dialog.

4. Use the other options in the dialog to define the scope of your search. See Find & Re-

place Text  in the Reference section for details.

This function only searches for entire graphics file names. Wildcard characters are not sup-

ported. This means you must enter the entire name, including the dot and the file exten-

sion.

A quicker way to replace graphics files

There is a quicker way to do this if the name of the graphics file you want to replace is not

important:

409
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· Just overwrite the original graphics file in your project graphics directory with the up-

dated or different graphic, so that the new graphic is in the same location and has the

same name as the old graphic. 

Help+Manual always checks the size of graphics when it loads them so this also works

with graphics that have different dimensions. The two graphics must both have the same

format, however! (You cannot use this method to replace a JPG with a GIF graphic, for ex-

ample.)

See also:
Searching for text, topics and referrers

Find & Replace Text

Find Topic

Find Referrers

5.11.13 Managing your graphics

When you add graphics to a project Help+Manual inserts a reference to the graphic file that

only contains the name of the file. It finds the graphics by looking in the folders listed in the

Project Search Path, which is defined in the Configuration section of your project. The folders

here are searched in order and the first file with a matching name is used. 

This strategy makes it very easy to organize and move your graphics files – you just need to

change the settings in the Project Search Path to let Help+Manual know where to look for the

graphics.

It is generally advisable to store your image folders together with your project folder. 

Key Information
If you use multiple graphics folders it is very important

to avoid duplicate filenames in different image folders!

If you have duplicates Help+Manual will only find the

first version of the graphics file with a matching name. 

Editing the Project Search Path

Help+Manual locates graphics on the disk by searching in the directories listed in the Pro-

ject Search Path. You do not normally need to add image folders to the path manually.

The program does this for you when you insert images from a new folder.

· To edit the Image Folders list manually go to  Configuration > Common Properties >

Program Search Path for your current project in the Project Explorer. 

· See Project Search Path  for more details.
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Moving image files and image folders

You are free to move your image files and image folders whenever you like. Since only the

image file names are stored in your project you just need to change the references in the

Project Search Path to tell Help+Manual where to look for the files.

1. Move and/or rename the image folders and their contents. 

2. Edit the Project Search Path (see above) to remove the old directories and add the

new ones. Help+Manual will now find your images in the new location(s).

Splitting and consolidating image folders:

You can also reorganize your image files in any way you like – for example move all your

image files to a single folder or to multiple folders in any locations. You just need to tell

Help+Manual where to look for the images in the Image Search Path settings.

Moving your projects to different locations

The references in the Project Search Path are actually relative, even though the full paths

of all the folders are shown for your information. This means that moving your project is

very easy. 

· If you save both your project folder and your image folders in the same folder you can

move your project without needing to make any changes to the Project Search Path. 

· If your image folders and your project folders are in different locations you will need to

update your Project Search Path after moving your project folder. 

Managing graphics in modular projects

It's always important to avoid duplicate filenames for your graphics. This applies in partic-

ular for modular projects, because you will often have separate graphics folders for each

project. 

Duplicate names across project modules are OK in HTML Help with runtime merging

because then each module is published individually and the correct graphics will be used.

However, you need to avoid duplicates in all other formats and in modular projects with

publish-time merging  in HTML Help. 

1552
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Use filename prefixes for graphics files in modules

The simplest solution for this problem is to add a unique prefix to the filenames of graph-

ics files used in modules, in the same way that you use prefixes for the topic IDs  in

modules. The prefix should be short – two letters and an underline character are usually

plenty – and should identify the module.

IDs and CSS classes for graphics

The Insert Image dialog has two optional fields for Picture ID: and HTML Class:. An ID you

enter here will be exported as the id="your_id" attribute for the image's <img> tag in

HTML-based output formats, and the HTML class is exported as the class="your_class" at-

tribute. 

Tip: You can enter multiple class names separated by spaces in the HTML Class: field if you

need more than one class for the image.

You will not need these features for normal graphics but they are sometimes useful. For

example, if you are planning to manipulate your graphics with your own CSS or JavaScript

code. 

Creating auto-incrementing IDs for cloned copies of images

In HTML an ID always has to be unique, you should never have more than one object on

the same page with the same ID. This can be a problem if you are cloning copies of a

ready-made image. You can get around this by creating an automatically-incrementing ID

with text variables.

You can't mix text and variables in topic IDs so you need to create two variables to do this.

1. Go to Project Explorer > Configuration > Common Properties > Text Variables and

create two text variables , one for the static part of the ID and one for the incre-

menting number. The static part can have any name you like, the incrementing num-

ber must have two plus characters at the end of its name, for example IMAGENO++. 

2. Let's say the two variables are IMAGEID and IMAGENO++. Now enter any text you like as

the text for the IMAGEID variable, for example myimage_, and a 0 (the number zero) as

the text for the IMAGEENO++ variable, like this (this example shows similar variables for

use in tables):

1107
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3.  Then instead of an ID, type in both variables in the Picture ID: field in the Insert Image

dialog (or double-click on an image that has already been inserted), like this:

<%IMAGEID%><%IMAGENO++%>

Then every time you make a copy of the image in your project a new unique ID will be

generated automatically. The first will be myimage_1, the second will be myimage_2 and

so on. 

See also:
Image Folders

Importing graphics from RTF files

5.11.14 Shortcuts for graphics

You probably have some graphics that you use again and again in your project –  logos, im-

ages of buttons and so on. Help+Manual's "Recent Images" and "Image Shortcuts" functions

make accessing images quick and easy.  Recent Images shows thumbnails of all the images

you have used recently, so that you can click on them to insert them again. Image Shortcuts is

a configurable list of graphics that you can select and insert in your projects with a single

click.

How to access Recent Images and Image Shortcuts

To display the Image Shortcuts list select the menu icon below the Insert Picture tool in

Write > Insert. The Recent Images selection appears automatically as soon as you have

inserted some images in your projects. You must add images to the Image Shortcuts list

yourself by selecting Configure Image Shortcuts.

Recent Images only appears when you have inserted images

1405
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How to use the Image Shortcuts list

Image Shortcuts graphics are not embedded in your project. They are simply links for

quick access to frequently-used graphics. This means that you can also use shortcuts for

larger images.

Adding images to the list:

1. Click on the dialog icon below the Image tool in Write > Insert and select Configure

Image Shortcuts: 

2. Select Add Picture in the dialog displayed to add a new image to the list.

Inserting images:

Click in the editor in the position where you want to insert the image, then click on the

thumbnail image you want  to insert in the Picture Shortcuts menu.

Organizing the list:

Use Add Category to organize your images in categories, which are also displayed in the

menus. Use Move Up and Move Down to arrange your images and categories in the list. 

See also:
Graphics References

5.12 Working with Tables

Tables in Help+Manual are a little different from what you may be used to if you have only

worked with a word processor like MS Word up to now. This is necessary because most of the

1056
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main output formats supported by Help+Manual are more like dynamic HTML pages than the

static print-style pages produced by word processors. 

Word processor tables are "static" – you define them once and they stay the same. In HTML

and similar formats, tables can shrink and grow as the user changes the size of the browser or

viewer window. This means that you need to be able to define both tables and table columns

with dynamic widths that can change interactively, and you also need to plan the layout of

your table content to accommodate this behavior. 

This is also important for "static" formats like Word DOCX and PDF, because when you pub-

lish your project your tables must fit inside the margins of the page. For this to be possible,

the table must be able to adjust to the width of the page when your topic is converted into a

PDF or DOCX file.

5.12.1 About tables

Help+Manual supports fully-formatted complex tables. Your tables can have styles, borders,

background colors, background images, alternating colors in alternating rows and much

more. Tables break automatically at page boundaries in PDF and other print-style output

formats, both between rows and within rows. 

You can also define styles for tables in the same way as for paragraphs. This allows you to

format complex tables in seconds and when you change the style definition all tables format-

ted with the table style will be updated automatically.

Table tools in the Table tab

You can insert tables with the Table tool in Write > Insert but all the main tools for ma-

nipulating tables are in the Table tab of the ribbon. Most of the tools here are self-explan-

atory – just make selections in your table and select the tools.

Table styles

· Table styles are defined and managed together with paragraph and text styles. To cre-

ate and edit table styles select Styles > Edit Styles in the Write tab.

· To apply a style to a table just click in the table and then select Table > Properties and

select the style you want to use.

· You can also select a style when you are defining a new table. 

See Table styles  for more details. 533
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Tables occupy an entire paragraph

A table is inserted as a single paragraph containing a single object (the table). It is not

possible to add any more objects to this paragraph. For example, if you type a character in

the paragraph before or after the table this will automatically insert a new paragraph. This

has two important consequences:

· You can delete an entire table by pressing the Delete or Backspace key once.

· You can indent and center tables by applying paragraph formatting to the paragraph

containing the table.

Copying and pasting in and between tables

You can copy and paste both the contents of individual cells and of multiple cells. To copy

multiple cells select all the cells you want to copy with the mouse and copy to the clip-

board. Then click in position where you want to insert and the same number of cells will

be overwritten from that point.

Warning: Pasting multiple cells overwrites the target cells!

See also:
Table styles

5.12.2 Inserting tables

You can insert new tables with tools in the Write and Table tabs of the Ribbon. The Table tab

provides you with direct access to all the table editing tools. 

Tables as link targets

You can link directly to tables in topic links  in the same way as anchors. You just need

to assign an ID to the table, then it will be shown as a target in the anchor list in the link

tool.

Key Information
If you set a color for the heading row of a table it will

only be displayed if your table has at least one head-

ing row! Check this in Table Properties if your heading

row color is not displaying.

533
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How to create a new table

1. Select the Table tool in Write > Insert. 

2. For a quick table just highlight the number of

rows and columns in the table matrix and click

to insert the table. For more control click on In-

sert Table to display the Insert Table dialog. 

3. Enter the number of rows and columns and

choose your formatting options.

For full details see Table Properties  in the Refer-

ence section.

Choosing the table width options 

Column widths are not set when you create the table. Please see Managing column

widths  and About table and column widths  for details on setting and adjusting the

widths of your tables and their columns.

You can choose the following table width options when you insert a table:

Autosize: Creates a table that calculates its size on the basis of the contents of its

cells. The absolute width of the table in your output will depend on how

you adjust the width of the cells and the content you put in them.

Size table to fit

on page:

Creates a table that is permanently maximized to the width of the cur-

rent paragraph (if the paragraph has indents the table will be narrower

than the page). This is exactly the same as sizing manually and setting a

width of 100%.

Size table

manually:

Creates a table with a fixed width in percent or pixels. Percentage val-

ues are relative to the width of the current paragraph. Setting a value of

100% is exactly the same as Size table to fit on page.

1391
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Setting up tables for printing

Tables can be set to split automatically at page boundaries for PDFs and manual printouts.

Note that this function is not supported by the Print Topic tool in the Topics tab, which is

a very simple print function. 

· Select Table can split to next page in the Table Properties to ensure that page breaks

can be inserted when you output to PDFs and printed manuals. 

· Select the Number of heading rows that you want repeat on each page as the ongoing

header of the table.

If you set a background color for your table header it will only be displayed if you define

at least one heading row!

Converting text to a table

You can convert selected paragraphs to a table. Columns will be created automatically at

tab characters in the text. Note that you cannot convert text to a table inside another

table.

Context menu: Direct conversion without a dialog

Right-click on the selected text and select Convert text to a Table in the context menu. This

uses the default table format directly. You can configure the table afterwards with the

Properties tool in the Table tab.

Table tool: Configure the table with a dialog

Select the paragraphs you want to convert and then select the Table tool in the Write or

Table tab. Before the table is created the table properties dialog is displayed with which

you can configure all table attributes except the number of columns and rows. Those are

based on the selected paragraphs and the tab characters they contain.

See also:
Table Properties  (Reference)

Managing column widths

How table sizing works  (Reference)

5.12.3 Managing column widths

By default, the widths of all columns in tables are "dynamic" – they expand to fit the width of

the content they contain and the defined width of the table. After you create a table you can

adjust the widths of columns by dragging their borders with the mouse and by setting their

widths to absolute or percentage values in the Table Properties dialog.

1391
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You can also "lock" the widths of columns. This can be necessary if you are using tables as a

layout tool and want to have column widths that do not change dynamically when the users

adjusts the size of the help viewer window.

How you define your column widths is crucial for how your tables behave in your published

output, in particular in formats like PDF and DOCX where the tables must fit inside a fixed

page width.

Relationship of column width to table width

The table width is defined when you create the table and can be changed with the Proper-

ties tool in the Table tab. The width can be dynamic or fixed.

In tables with dynamic widths (autosize, percentage widths and 100%/fit to page) you

must always have at least one column with a dynamic width that can resize to allow the

table to resize. If you do not Help+Manual will make all column widths dynamic in your

output and the results may be unexpected.

Setting and changing column widths

To adjust the width of a column you must make its width fixed, otherwise it will expand

automatically to fit its content. You do this by dragging the column dividers with the

mouse or by changing the settings in the Table Properties dialog. 

· Drag column dividers with the mouse

This will lock the width of both affected columns. If you want one of the columns to be

dynamic click on the Lock Column tool (see below) in the Table tab to unlock it again

after resizing.

· Use Table Properties

Click in a column or click and drag to select  two or more columns. Then select the

Selected Cells tab in Table > Properties and enter a width value in percent or pixels.

· Use the Lock Column tool

When working with column widths use the Lock Column  tool in the Table tab while you

are working to lock and unlock the widths of columns. It also shows you whether the

current column is locked or unlocked.

Column widths in complex tables:

If you merge and split cells in a table you will find that some widths cannot be changed

beyond a certain point because the rows and columns no longer extend across the entire

height and width of the table. In some cases you may have to use nested tables or mul-

tiple tables to achieve the widths you need. 

525
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The Lock Column tool

The Lock Column tool in the Table tab sets the width of the selected column or columns

to a fixed value in pixels. In locked columns selecting the tool unlocks the column and

makes it dynamic again. 

You can also access the same function by right-clicking in the column or by setting a fixed

width in pixels for Selected Cells in Table > Properties.

Possible and impossible column widths

The column widths you set will only be used if they are possible, otherwise you will have

problems in your output:

· If all column widths are in percent their total must be exactly 100%, otherwise they will

all be ignored.

· Avoid mixing columns with percentage widths and pixel widths in fixed-width tables.

Browsers, particularly the famously competent Microsoft Internet Explorer, will often in-

terpret these "mixed widths" incorrectly. 

· If the table width is dynamic ("autosize" or "percent") you must always have at least one

dynamic column.

If your column width settings are contradictory or impossible all columns will be made dy-

namic in your output and the results may be unexpected!

Column widths and PDF/DOCX output

PDF and DOCX files have fixed margins and fixed page widths. This means that your tables

and their content must fit inside the margins of your pages in these formats. If they do not

fit with the defined column widths Help+Manual will make all the column widths dynamic

to force the table to fit. The results may be unexpected!

You should always have at least one dynamic column in your tables to allow the table

width to be adjusted to fit on the PDF or DOCX page. Adjustable columns should only

contain wrapping text; fixed-width content like graphics or paragraphs with word wrap

turned off (for example program code examples) will prevent column width adjustment.

See also:
Table Properties  (Reference)

How table sizing works  (Reference)
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5.12.4 Editing, copying and pasting in tables

You can edit text in your table cells just as you would on a normal page. There are just a few

things you need to be aware of:

· Each cell is like a separate document

Text doesn't flow or continue from one cell to another.

· Numbered lists cannot span table cells

Since each cell is a separate document you can only have numbered lists within a cell.

Numbering cannot "continue" from one cell to the next, neither horizontally nor vertic-

ally.

· Cells can have their own height and width settings

These settings are applied with the "selected cells" tab in the table options dialog. If the

width or height of the text in your output looks different or "off" check the width and

height settings of the cell containing it.

Copying and pasting single and multiple cells

You can copy and paste content of both single and multiple cells from one position in a

table to another and from one table to another. 

If you copy multiple cells the contents of the target cells will be replaced with the copied

content. It will overwrite exactly the same number of cells as those copied.

5.12.5 Selecting and formatting cells and tables

In general you can select and format tables and cells just as you would in a normal word pro-

cessor. However, there are a couple of differences. Also, you need to remember that tables in

Help+Manual behave more like dynamic HTML tables than the static tables you may be used

to if you have only worked with word processors up to now.

Key Information
Changing the widths of table columns with the mouse

always locks the width of both affected columns. Al-

ways use the Lock Column tool after changing widths

to make columns dynamic again!

Selecting and resizing tables with the mouse

Select entire

table: 

Position the mouse just to left of table and click, or click and drag

through the entire table.

OR
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Click in a cell and press Ctrl+A. Pressing once selects the current

cell, pressing again selects the entire table.

Select single cell: Just click in the cell. Even though it is not highlighted, it is still selec-

ted for formatting the cell properties (see below). This does not se-

lect any text that the cell contains, however – this must be selected,

formatted and edited just like any other text in the editor.

Select multiple

cells:

Click and drag.

Select row: Position mouse over left border of table (  mouse pointer) and

click. Or click and drag through row. Using the click method takes a

little practice, the  mouse pointer only appears in a very narrow

area.

Select column: Position mouse over top border of table (  mouse pointer) and

click. Or click and drag through column. Using the click method

takes a little practice, the  mouse pointer only appears in a very

narrow area.

You cannot select a column if the cursor is currently in the top cell

of the column. Click in a cell to the left or right of the top cell be-

fore selecting using this method!

Resize table: Open the table properties and adjust the width settings. You can-

not normally adjust the overall table width with the mouse. Its

width will either be defined by the width of its content/columns

(autosize) or it will have a fixed or relative width in pixels or percent.

Resize cell width: Drag the cell borders. Note that this "locks" the width of both af-

fected columns. If you only want to have one of the columns with a

fixed width you must then use the lock/unlock tool in the Table tab

to unlock the column that needs to be fluid. 

Rotating text in tables

In addition to normal horizontal text you can also rotate the text in individual cells by 90°

or 270° to display vertical text oriented to the right or left. 
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How to rotate text

1. Click in the cell where you want to rotate the text. 

2. In the Table tab select Text Direction and then 90° or 270° rotation. 

The Text Direction options can also restore normal horizontal orientation.

Resizing tables and cells with Table Properties

Note that most of the settings you can enter are not absolute. All widths except pixel val-

ues are relative to the output page, which can vary depending on how the user sizes the

viewer window (electronic formats) and the size of the printout page (PDF etc). You can

only set a minimum height for cells; the actual height is controlled by the cell contents.

1. Select the table or the cells you want to resize (see above). 

2. Select Table > Properties or right-click and select Table > Table Properties.

· To resize the entire table use the settings in the Table Layout tab.

· Select the Selected Cells tab to adjust the size settings for individual cells.

For details see Table Properties  in the Reference section.

Formatting entire tables and individual cells

Formatting entire

table:

Right-click in the table and select Table > Properties.

1391
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Formatting single

cells:

Right-click in the cell and select Table > Properties, then click on the

Selected Cells tab.

Formatting mul-

tiple cells:

Select the cells, right-click on the selection and select Table > Prop-

erties, then click on the Selected Cells tab.

See also:
Table Properties  (Reference)

How table sizing works  (Reference)

5.12.6 Adding, deleting and moving rows and columns

You can add and delete rows and columns in tables both with the Ribbon tools and by chan-

ging the number of rows and columns in the table definition in Table Properties. 

 

Key Information
In complex tables with split and merged cells deleting

rows and columns may have unexpected results if the

row or column you are deleting overlaps merged or

split cells.

Adding rows and columns with the Ribbon tools

1. Click in the table at the point where you want to insert new rows or columns. 

2. Use the Rows and Columns tools in the Table tab, or right-click and select the same

options from the context menu.

Deleting rows, columns and tables with the Ribbon tools

1. Select the rows or columns you want to delete or click in a cell to delete only the row

or column containing that cell. 

2. Select Table > Rows and Columns > Delete or right-click and select Table > Delete

and then select what you want to delete (Rows, Columns or Table).

You can also delete an entire table by placing the cursor directly before or after the table

and pressing Delete or Backspace.

Moving table rows

1. Click in the row you want to move or select a block of rows. 

2. Select Move Up or Move Down in the the Table tab. 

1391
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Adding and deleting rows and columns with Table Properties

1. Select Table > Properties or right-click and select Table > Properties in the context

menu. 

2. Adjust the Rows and Columns settings to increase or delete. 

Increasing and decreasing the number of rows and columns in the Table Properties dialog

adds or deletes rows or columns in the last positions (right and bottom) of the table.

See also:
Table Properties  (Reference)

How table sizing works  (Reference)

5.12.7 Splitting, merging and unmerging

You can create complex tables by splitting and merging cells both vertically and horizontally.

In addition to this you can also nest tables  inside one another to create even more com-

plex structures. (To nest a table just insert a new table in the cell of an existing table.)

Splitting tables

1. Click in the table to select it. 

2. Click in the row where you want the table to split.

3. In the Table tab select Split - Split Table. You can change the row number where the
table is to split manually if you like.

Note: You can only split tables, you cannot join them. 

How to merge cells

1. Select the cells you want to merge (you must select at least two cells). 

2. Use the Merge Cells tool in the Table tab or right-click and select Table > Merge Cells

in the context menu.

You may need to adjust the width of the table or individual columns after merging. Re-

member to check your column lock settings with the Lock Column tool  in the Table tab

after adjusting widths. 

How to split cells

1. Select the cells you want to split. If you just want to split a single cell click inside the

cell, it is then selected automatically even though it is not highlighted. 
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2. Use the Split tool in the Table tab or right-click and select Table > Split Cells in the

context menu and choose Vertically or Horizontally to choose the direction of the

split.

3. Enter the number of columns or rows you want to split into (the default is 2).

How to unmerge cells

This function restores the original number of rows and/or columns in the selected cells,

basing the number on the original definition of the entire table.

1. Select the cells you want to unmerge. If you just want to unmerge a single cell just

click inside the cell, it is then selected automatically even though it is not highlighted. 

2. Use the Unmerge tool in the Table tab or right-click and select Table > Unmerge in

the context menu and then choose Rows, Columns or Rows and Columns.

See also:
Nested tables

Managing column widths

Table Properties  (Reference)

How table sizing works  (Reference)

5.12.8 Sorting tables

You can sort the content of tables on any column. Basically you just need to click in the table

column you want to sort on and then select Sort in the Table tab.

Key Information
Table header rows are never sorted. If you want to

change the position of the header rows you need to

use the move up/down commands.

Sorting entire tables

1. Click in the column you want to sort on. This will normally be the first column in the

table. 

2. Select the Sort tool in the Table tab and then select Ascending or Descending to select

the sort direction.

Sorting a range of rows in a table

You can also sort an individual range of rows in a table.
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1. Select the range of rows in the table you want to sort. 

2. Select the Sort tool in the Table tab and then select Ascending or Descending to select

the sort direction.

Important: When you select a range of rows sorting is always on the first column. You

cannot sort a range on any other columns.

5.12.9 Deleting the contents of cells

Selecting cells and pressing Delete just deletes the contents (i.e. text, graphics etc.) of the

cells, not the cells themselves. The only exception to this is when you select the entire table. If

you do this and press Delete it will delete both the contents and the entire table!  

How to delete the contents of cells

1. Select the cells  whose contents you want to delete. (Don't select the entire table as

this will delete both the contents and the entire table.) 

2. Press the Delete key.

Deleting both cells and their contents

This is only possible with entire rows and columns. 

1. Select the cells, rows or columns you want to delete.  

2. Select the Delete tool in the Table tab and choose Rows or Columns to delete all the

cells and their contents.

See also:
Table Properties  (Reference)

How table sizing works  (Reference)

5.12.10 Converting text to tables

You can convert selected paragraphs to a table. Columns will be created automatically at tab

characters in the text. Note that you cannot convert text to a table inside another table.

Context menu: Direct conversion without a dialog

Right-click on the selected text and select Convert text to a Table in the context menu. This

uses the default table format directly. You can configure the table afterwards with the

Properties tool in the Table tab.
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Table tool: Configure the table with a dialog

Select the paragraphs you want to convert and then select the Table tool in the Write or

Table tab. Before the table is created the table properties dialog is displayed with which

you can configure all table attributes except the number of columns and rows. Those are

based on the selected paragraphs and the tab characters they contain.

See also:
Selecting and formatting cells and tables

Exporting and importing topics

5.12.11 Indenting tables

A table is handled as a single object in a  paragraph that is not allowed to contain any other

objects. The formatting of the table itself is handled by the table properties but the position

and alignment of the table on the page are controlled by the paragraph properties of the

paragraph containing the table.

This means that to indent a table you need to adjust the indent settings of the paragraph

containing the table. This can be done either with a style or by adjusting the paragraph

formatting manually.

How to select the table paragraph for indenting

To indent a table's paragraph you first need to place the cursor between the table and its

paragraph mark. Doing this can be a little tricky until you get the hang of it. To make it

easier it is better to turn on paragraph marks display in the editor with the  tool in Write

> Paragraph. Then just click directly between the paragraph mark and the end of the

table.

Alternatively, you can just place the cursor at the end of the last cell in the table and then

press the right arrow cursor key on your keyboard once, or place the cursor at the begin-

ning of the next paragraph after the table and press the left arrow cursor key once. Both

these operations will also position the cursor between the table and its paragraph mark.
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Adjusting table indent settings

First position the cursor between the table and its paragraph marker (see above), then ad-

just the indent settings with a style or manual formatting:

· To adjust the settings with a style: 

Create a style (see Text Formatting and Styles ) with the necessary indent settings,

then position the cursor and apply the style by selecting it in the style selector (or by

pressing the style's keyboard shortcut if you have defined one). 

· To adjust the settings manually: 

Position the cursor and then use the paragraph formatting tools to adjust the paragraph

settings.

See also:
Selecting and formatting cells and tables  

Text/paragraph styles in tables

5.12.12 Table styles

Just as you can define styles for formatting text and paragraphs you can also define styles for

tables. Like text and paragraph styles, table styles are dynamic. This means that when you

change the style definition all tables in your project formatted with that style change automat-

ically.

Table styles also "inherit" properties from the styles they are based on and this is also dy-

namic. The "child" style inherits all the properties of the "parent" style. If you change the defin-

ition of the parent style all the matching attributes in the child styles will also change. Only at-

tributes that you have explicitly changed in the child styles will remain unchanged. 

How to define a new table style

1. Select Styles > Edit Styles in the Write tab. 

2. Click in the Table Styles section at the top, then select Add Style.
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3. Enter a name for the style in the Style Name: field. 

Multiple style names:

If you enter a table style name with one or more spaces in it, the table will have two or

more style classes in HTML-based output, which is supported in CSS. The first class name

is used by Help+Manual. You can use the additional classes in your own CSS in your

HTML templates to define global style rules for only those tables with this class attribute. 

4. If you want to base the style on another style select the parent style in the Based on

Style: field.

5. Click on Modify Layout to define the attributes of the style. The settings are just the

same as the normal table settings , although there are a couple of table settings

that cannot be included in table styles.

The style name is the CSS class of the table

The style name is exported as the class attribute of the <table> tag, which you can then

reference in your own CSS for your HTML-based output formats.

If you enter a table style name with one or more spaces in it, the table will have two or

more style classes in HTML-based output, which is supported in CSS. The first class name

1391
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is used by Help+Manual. You can use the additional classes in your own CSS in your

HTML templates to define global style rules for only those tables with this class attribute. 

Creating a new table with a style

1. Click on the Table tool in the Write or Table tab and select Insert Table. 

2. Enter the number of rows and columns you want the table to have. 

3. Select the style in the Table Style: field. 

4. Make any manual changes (settings that you want to be different from the style defini-

tions)

5. Click on OK to insert the table.

Note that any properties settings you edit manually in a table formatted with a style will

remain unchanged if you change the definition of the table style later. Only attributes

controlled by the style will change when you change the style definition!

Applying a table style to an existing table

1. Click inside the table that you want to format. 

2. Select Properties in the Table tab and select the style in the Table Style: field.

3. If you want to make any individual changes you can also adjust the settings directly in

the Table Properties dialog before you close it.

Note that any properties settings you edit manually in a table formatted with a style will

remain unchanged if you change the definition of the table style later. Only attributes

controlled by the style will change when you change the style definition!

5.12.13 Table Counters, Captions and CSS

You can add IDs for tables that you can use in your own HTML code. In addition to this, the

name of the table style is exported to HTML as the table's class attribute.

Table counters and captions, table of tables

You can add captions with counter variables to tables with the caption tool in Write > In-

sert Object: 
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This tool inserts captions that are independent from the table, so that they can be inserted

above, below or even in the table. They can be included in the tables of figures generated

for PDF and Word DOCX output and they can also be referenced with both text references

like See Table xxx and hyperlinks. See Figure and table counters  for details. 

Table CSS classes

To give a table a CSS class you just need to define a table style  and apply it to the

table. The style name is exported as the class attribute of the <table> tag. 

If you enter a table style name with one or more spaces in it, the table will have two or

more style classes in HTML-based output, which is supported in CSS. The first class name

is used by Help+Manual. You can use the additional classes in your own CSS in your

HTML templates to define global style rules for only those tables with this class attribute. 

Table IDs

The table properties dialog has an optional ID field. An ID you enter here will be exported

as the <table> tag ID attribute in HTML-based output formats. You will not need this for

normal tables but it is sometimes useful. For example, when you use the sortable tables

option in the Help+Manual  Premium Pack you need to enter a special ID here to

identify your table as sortable.

You may also need to use IDs in tables if you are planning to manipulate your tables with

your own CSS or JavaScript code and need to address an individual table instead of a class

of similar tables, for which you would use a CSS class (see above).

944
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Table ID for table counters and captions

The table ID is not used for referencing the counters used for numbering tables and in-

cluding them in the table of tables. You need to use the ID in the figure caption described

in Figure and table counters  for that.

5.12.14 Text/paragraph styles in tables

Table styles define the formatting of the table itself – the table width and width mode, bor-

ders and border style, background colors and so on. They do not define the formatting of the

text inside the tables – that must be formatted with styles or the manual formatting tools. 

How to align a table with a paragraph style

You can control the alignment of a table by applying a style to the paragraph containing

the table – for example to center a fixed-width table or to indent the left and right sides of

the table from the margins of the page. Only the paragraph attributes will have an effect,

text attributes will be ignored. 

1. Click on  in Write > Paragraph to display paragraph marks (this makes it easier to

see what you are doing). 

2. Click to the right of the table between the table and its paragraph mark so that you

can see the blinking editing cursor between the right margin of the table and the

paragraph mark.

3. Select the style you want to apply in the drop-down style list in the Toolbar.

How to apply styles to the contents of tables

If you select all or part of a table and apply text or paragraph styles the styles will be ap-

plied to the text in the selected cells inside the table. 

· Select text and paragraphs in the table cells and apply styles just as you would in the

normal editor. You can also apply styles to multiple paragraphs in multiple cells by se-

lecting the cells and then applying the style.

Note that if you want to apply a style to all the paragraphs in a table you must select the

entire table by clicking and dragging inside the table. If you click in the left margin to se-
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lect the table you will not be able to apply styles because then the table is selected and

not its contents.

How to apply a table style to a table

1. Click in the table you want to format. 

2. Select Properties in the Table tab and then select the table style you want to use and

click on OK.

See Working with Tables > Table styles  for full details.

How to define a table style

1. Select Styles > Edit Styles in the Write tab. 

2. Click in the Table Styles section at the top, then select Add Style.

3. Enter a name for the style in the Style Name: field. 

4. If you want to base the style on another style select the parent style in the Based on

Style: field.

5. Click on Modify Layout to define the attributes of the style. The settings are just the

same as the normal table settings , although there are a couple of table settings

that cannot be included in table styles.

CSS classes for table styles

When you publish to HTML-based output formats the name of the table style is also the

class attribute of the table. For example, if the table style is called demotable it will contain

a class attribute like this:

<table class="demotable" ...

You can use this knowledge to change the formatting of tables with your own additional

CSS code in your HTML templates, attaching your rules to the class names.

Giving a table multiple class names

Help+Manual will also allow you to create table styles containing spaces. For example,

suppose you create two otherwise identical table styles called "demotable normal" and

"demotable highlight". The result in the HTML code would be:

<table class="demotable normal" ...
<table class="demotable highlight" ...

533
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This effectively gives the tables two classes, which is allowed in CSS. You can then write in-

dividual CSS rules for the "normal" and "highlight" classes to be applied to different

groups of tables in your output that otherwise have identical formattig. 

See also:
Table styles

Table Properties  (Reference)

How table sizing works  (Reference)

Text Formatting and Styles

5.12.15 Nested tables

Help+Manual's table formatting functions are powerful but they do have some limitations.

For example, you can only set a background picture for the entire table. Merging and splitting

cells in a single table can also place limitations on column width adjustments. 

Some of these problems can be solved by using nested tables, i.e. by inserting a second table

inside the first table. Then you can apply different table properties to the second table, which

can be a single cell, row or column in the "parent" table.

Productivity Tip
Temporarily apply thick colored borders to your nes-

ted tables so that you can see where they are while

you are working with them. You can do this most eas-

ily by defining a table style and applying it temporarily

while you are working.

How to insert a nested table

Inserting a nested table is just like inserting any other table. The only difference is where

you insert it:

1. Click inside the cell of the table where you want to insert another table. 

2. Use any of the standard methods for inserting a new table.

The nested table is a fully independent table in its own right. You can use all the normal

table formatting and editing functions on it, including applying a style to its "table para-

graph". You just need to keep track of where your nested tables are, which can be tricky.

Warnings and limitations 

Don't go overboard with nested tables. It's tempting to use them but it can get too com-

plicated very quickly! 
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Page breaks in PDF and DOCX output and printed manuals may not work correctly inside

table rows containing nested tables, particularly if the tables contain merged cells.

See also:
Table Properties  (Reference)

How table sizing works  (Reference)

5.12.16 Using background graphics

In addition to defining background colors you can also add background graphics to your

tables. For example, you can insert a single large graphic behind a table like a "watermark", or

you can tile a small graphic to create a repeating pattern or texture as a background for the

table.

Productivity Tip
You can apply a background graphic to a single cell of

a table by using a single-cell nested table  (insert-

ing one table inside another) and applying the back-

ground graphic to the nested table.

How to apply a background graphic to a table

1. Click in the table and select Properties in the Table tab or right-click and select Table >

Properties to display the Table Properties  dialog. 

2. In the Table Layout tab select the Background Picture option. 

3. Click on  and select the graphics file you want to use. 

4. Select Tile to repeat the graphic in a pattern or Center to display the graphic only

once, centering it on the center of the table.

Matching the size of graphics to your tables can be tricky with centered images. The most

practical solution is to use graphics that have an edge the same color as the page or table

background so that you don't have to line up precisely with the edge of the table.

Graphics are normally applied to the entire table. If you want to apply a graphic to a single

cell or range of cells you can do this by inserting a nested table  and applying the back-

ground graphic to the nested table.

See also:
Table Properties  (Reference)

How table sizing works  (Reference)
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5.12.17 Handling table borders

When you are defining borders around tables it is important to remember that there are two

different "objects" in tables for which you can define borders: The table itself and the cell. Cell

borders and table borders have separate settings.

Productivity Tip
If the thickness of your table borders looks off in your

PDF output try selecting the screen device as the refer-

ence device for PDF output in View > Program Options

> PDF. 

The relationship between table borders and cell borders

The table border is outside the cell borders. If you set both cell and table borders the res-

ulting border around the table will have the width of the cell borders plus the width of the

table border.

· For example, if you set both the cell borders and the table border to a width of 3 pixels

the table border will have a width of 6 pixels, like this:

Table border width: 3 pixels

Cell borders width: 3 pixels

· If you want to create a table with borders that are the same as the cell borders just set a

width for the cell borders and leave the table border set to 0.  

Table border width: 0 pixels

Cell borders width: 3 pixels
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· The following example does the opposite. Here the table border width is set to 3 pixels

and the cell border width is set to 0 pixels. The grid lines are visible to show that it is the

same table:

Table border width: 3 pixels

Cell borders width: 0 pixels

Cells with different border settings

You can define different border settings for individual cells and groups of cells. Just select

the cells whose borders you want to change, then display the table properties dialog and

select the Selected Cells tab.

You cannot define different colors for cell and table borders in a single table. To create

one or more cells with different colored borders insert a second table inside the first table

and define different border color settings for the two tables. See Nested tables  for de-

tails.

See also:
Nested tables

Table Properties  (Reference)

How table sizing works  (Reference)

5.12.18 Conditional text in tables

In tables, conditional text tags can be used to include and exclude both text in cells and com-

plete rows or columns in the table. It is important to understand how this works before you

start using conditional tags in tables, otherwise you can get unexpected results.

Conditional text inside a single cell

Normal text inside a cell:

If the IF and END tags are both inside the same cell, conditional text in a cell works exactly

the same as in normal text. It simply includes or excludes the tagged content according to

the conditions.
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Even if the entire contents of the cell are deleted, nothing happens to the column or row

containing the cell if there are also other cells with content in the column or row. (You

cannot delete a single cell leaving just an empty space in the table.)

When a condition completely deletes the contents of a cell:

The only exception to this behavior is when conditional tags completely delete the con-

tents of a cell and the cell is the only cell in the current row or column. If that happens,

then the row or column will also be deleted. If you want to prevent this and leave an

empty cell, make sure that at least one space character remains in the cell. 

In the first example below, row 2 of the table will be completely removed from the table

unless at least one space (or any other character) is left inside the cell containing the con-

ditional tags.

In the second example, column 1 will be deleted because all the text in the only cell in the

column is deleted. Column 2 will not be deleted, because one character is left over, and so

the cell still has content.

The key is content: If any content is left in a cell then its row or column cannot be deleted,

because the content "protects" the cell, row and column from deletion.

Applying conditions to the content of multiple cells:

If you want to include/exclude the content of multiple cells you must include the IF and
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END conditions inside every cell! If a condition starts in one cell and ends in another cell,

then the entire row or column will be deleted. This happens because rows and columns

can be deleted using only an IF tag, without a closing END tag (see further below for de-

tails).

Applying conditions to entire rows and columns

To include or exclude an entire row or column you put the IF condition right at the begin-

ning of the first cell in the row or column and the END condition at the end of the last cell

in the row or column:

Order of processing and intersecting tags:

When Help+Manual processes your tags, it processes in order from left to right and top to

bottom. You need to consider this sometimes when you are excluding both rows and

columns with tag conditions that intersect with one another:

Removing intersecting first row and second column:
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Removing intersecting first column and second row:

Applying conditions to multiple rows and columns

If you want to apply conditions to multiple rows and columns you must include separate

conditions for every row or column. You cannot start a condition in one row and end it in

another!

Simplified syntax - leaving out the END tag

When you are tagging rows and columns the END tag at the end of the row or column is

actually optional. As long as the tags are positioned right at the beginning of the first cell

in the row or column, and there is no other END tag anywhere else in the row or column,

they will be interpreted as tagging the entire row or column.

For example, these tags will remove row 2 and column 2 in all outputs except PDF:
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Avoid "orphaned" tags within rows and columns!

You should only use these unterminated tags in the first cell of a row or column (or the

cell that becomes the first cell because another row or column has been removed). If you

are tagging content in cells inside a row or column the IF tag should always be followed

by a matching END tag inside the same cell. Failing to do so can have unexpected con-

sequences.

Columns and rows with merged cells

How columns and cells with merged cells are handled depends on which row or column

the merged cell "belongs" to:

· In rows the merged cell belongs to the first column that intersects the cell.

· In columns merged cell belongs to the first row that intersects the cell.
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Entire tables

If you want to include or exclude an entire table, always put the IF condition before the

table and the END condition after the table. Excluding all the rows and/or columns in a

table will not exclude the table, it will only result in an empty table.

Insoluble problems

There is one situation where you cannot exclude a row or a column with conditional text:

This happens when merged cells prevent the first cell of a row or column from being in

the first column or first row of the table. There is no way around this – it is just not pos-

sible to include/exclude these "partial rows/columns" with conditional text.

It is not possible to include/exclude the 2-column row 4 in this table:

For the same reason, it is not possible to include/exclude the 3-row column 2 in this table:
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See also:
Conditional text include options

5.13 Videos and Online Media

Help+Manual takes the manual labor out of adding videos and online media like Prezi™

presentations to your help projects. You just click where you want to insert your movie and

select the video file. Help+Manual handles everything else for you, including choosing and in-

serting the correct code for integrating the media files in the various output formats.

Adding Video Files 

Ø Inserting videos

Ø Support in output formats

Tutorial project for online video and media

We have produced a detailed tutorial project explaining and demonstrating how to insert

various kinds of online video and media. You can find it in the My HelpAndManual

Projects\Examples folder in your Documents director. It is also accessible directly in

the Welcome screen that you can access at the top of the Project Explorer on the left. 

Information on local video file formats

Please see About using video files  for important information on using different video

formats in your projects and support for video in the various publishing formats!

994
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See also:
About using video files

5.13.1 Inserting videos and online media

Inserting a video is basically as easy as inserting a graphic. Just click in the editor where you

want to insert the video, click on the Media tool in Write > Insert, then select the type of

video you want to insert and proceed with the dialog displayed.

Please see About using video files  for important information on using video files in your

projects and support for video in the various publishing formats!

Productivity Tip
If you want to be sure that videos play reliably, use on-

line video services for CHM files, MP4 video or online

services for WebHelp and M4V or online services for

ePUB (Apple iBooks only). 

Tutorial project:

For more detailed examples see the Interactive Media tutorial project that you can find in the

My HelpAndManual Projects\Examples folder in your Documents directory. It is also access-

ible directly in the Welcome screen available at the top of the Project Explorer on the left. 

Adobe Flash discontinued:

Adobe Flash has now been discontinued worldwide and on all platforms, among other things

because of its horrendous security performance. Existing Flash videos in projects will still work

on platforms that have Flash installed but you can no longer add new Flash content. We

strongly recommend that you remove all Flash content. 

Choosing the right video format for maximum reliability

Video is still quite problematic across different platforms. This is a general problem with

digital video that is not specific to Help+Manual. Even though Help+Manual supports a

wide range of different video formats only MP4 and online video services can be con-

sidered reliable. All other video formats should be avoided if you want to avoid trouble. If

you follow the following basic rules your videos will play on the largest possible number

of devices and platforms.

1536
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HelpXplain screencasts and infographics:

Animated HelpXplain screencasts and infographics can be inserted in WebHelp, CHM files

and eWriter books. In other formats the static preview image for the presentation will be

displayed. Note that HelpXplain presentations are only compatible with the CHM format

when it is configured to use the Internet Explorer 9 or Edge HTML rendering mode. See

Animated HelpXplain presentations  for details.

MP4 Video Format:

When you use MP4 videos they should be created with the H.264 video codec and AAC

audio. You can use MP3 audio in your videos, but AAC will be more universally compat-

ible. If possible use a 

CHM Files:

In CHM files use online video services (YouTube, Vimeo or Prezi) at all possible. All other

formats will cause problems for your users, even if they seem to work for you. Also note

that Microsoft's outdated CHM viewer does not handle MP4 correctly. Help+Manual man-

ages online video services in CHM so that no online access is required until the user actu-

ally starts the video by clicking on the preview image.

WebHelp:

In WebHelp you should now only use either MP4 videos or online video services. Flash

video is no longer supported because it has now been disabled worldwide and on all plat-

forms. 

EPUB for Apple iBooks:

Use MP4 in the M4V format with an Apple profile or online video services in ePUB eBooks

targeting the Apple iBooks eBook reader on the iPad and iPhone. Video files are generally

unsupported in ePUB on all other readers.

Inserting animated infographics and screencasts made with HelpX-
plain

HelpXplain is an exciting new web graphics tool from EC Software, the same company that

makes Help+Manual. HelpXplain presentations can run automatically, or they can be in-

teractive tutorials, or even a combination of the two. They are easier to create and more

562
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flexible than with tools like PowerPoint, and they can be embedded in any web page just

as easily as a YouTube video.

Check the path to HelpXplain

Check the General tab of the Program Options  to make sure that the correct path to

the full version of HelpXplain is registered. This makes sure that Help+Manual uses this to

compile your HX projects instead of the integrated compiler used for the simple HX

screencasts you can make with the screen capture utility. It also enables you to open HX

projects directly from within Help+Manual, from the context menu displayed when you

right-click on an Xplain in the HM editor.

HelpXplain can also insert static images

See Inserting Graphics and Screenshots  to learn how to use HelpXplain to insert static

images in Help+Manual. 

Install HelpXplain and create a screencast or animated infographic

You must have HelpXplain installed on your computer to be able to select an .xplain

project in Help+Manual. A free trial version is available. See Animated HelpXplain present-

ations  for more information and a download link.

How to insert a HelpXplain presentation

This is basically just the same as inserting a regular video.

1. Click in the topic in the place where you want to insert the presentation. 

2. Select Media > Insert HelpXplain Presentation in the Insert group in the Write tab.

1261
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3. Select your HelpXplain .xplain project with the  Browse button in the File: field.

The caption, title and preview image defined in the project will be loaded automatic-

ally. 

4. Set the display options and then click on OK to insert.

Variable/Fixed Size: HelpXplain presentations are fully scalable and variable size is gen-

erally the best option. The presentation will then adjust itself auto-

matically to fit the current window size.

Alignment: With text is the default setting and should be used for most

presentations. You can align small presentations to be to the left or

right of the text, so that the text wraps around it. This won't work

well for normal presentations, however, because they will generally

be larger.

Style: Use an image style  for the placeholder image.

Padding: Space on the page around the presentation.

Lightbox: Displays the presentation in a lightbox overlay, instead of as part of

the page. This can be useful in WebHelp if you don't want the

placeholder image to take up too much space. 

Play after: Start the presentation as soon automatically after the specified

number of seconds. 

Endless loop: Continue playing the presentation repeatedly.

Play button: Adds a large Play button in the middle of the preview image so that

the user knows they need to click on it to play.

Print Options

These options control how the Xplain is handled when you publish your project to PDF or

Word. 

492
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First slide and link: Prints the first slide in the Xplain as a static image with a link to

your website with the active Xplain. 

All slides: Prints all the slides in a tabular grid so that they can be viewed stat-

ically in the document. 

Inserting YouTube and Vimeo videos and Prezi animated presenta-
tions

For maximum reliability, online video on video sharing sites like YouTube and Vimeo are

the best choice, because they solve all compatibility problems for you. You just upload

your video to their site and they present it to every device and browser in a format that

works.

Prezi is an online presentation tool, that creates cool presentations with rotation and

zoom effects. Although Prezi has a strong focus on creating impressive "presentations", it

is also a great tool for illustrating and explaining complex structures and procedures in

technical documentation.

Tutorial project:

For more detailed examples see the Interactive Media tutorial project that you can find in

the My HelpAndManual Projects\Examples folder in your Documents directory. It is also

accessible in the Welcome screen at the top of the Project Explorer on the left.

Procedure

The basic procedure for all three online services is the same. However, you must choose

the correct dialog for each service so that Help+Manual knows how to handle the media

correctly. See the websites of the video providers for details on their services:

 YouTube (mainstream online video)

http://www.youtube.com
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 Vimeo (more specialized online video, generally higher quality)

 Prezi  (relatively new service for animated demos and presentations)

1. Click in the editor at the point where you want to insert the video. 

2. Select the Media tool in Write > Insert Object and select the option for the media

type you are inserting. The example below is for YouTube but the dialogs for the other

video formats are essentially identical.

3. Click on the  browse button to browse to the online service so that you can select

the media you want to insert. You can then copy and paste or drag the URL of the me-

dia from your web browser into the URL: field in the dialog.

Alternatively, you can copy and paste the video URL or drag it from the Address: field

of the browser into the URL: field in the Insert Video dialog.

4. After inserting the URL, Use Select Poster Image to play the video and select the place-

holder graphic to be displayed in the topic. The user starts the video by clicking on

this image. See below for issues with the Poster Image function in Vimeo videos.

Tip: Make sure that the preview window for playing the window is large enough be-

fore saving the poster image.

http://www.vimeo.com
https://www.prezi.com
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5. Set the video options .

6. Click on OK to insert the movie in your topic.

Internet Explorer warning with Poster Image in Vimeo

When you use the Poster Image tool in the video dialog with Vimeo videos, you may see a

warning about Internet Explorer. This warning is displayed because of the internal Win-

dows component used to play the video in a Window, which is still based on Internet Ex-

plorer. 

Click away the warning

Vimeo is displaying this because it thinks you are using the Internet Explorer browser to

access your site. This is not the case here and the warning can safely be ignored. You just

need to click on the square in the upper right corner of the warning to be able to take the

snapshot

Or take the snapshot in your browser

Alternatively, you can take the snapshot of the video in your browser. Then save it as a file

and insert the file with the Load Image from File... option in the Poster Image tool. 

Custom web content from other sites

The Custom Web Content option in the Media menu makes it possible to integrate a wide

range of different media content in your topic pages. Help+Manual handles this by em-

bedding the content in an iFrame on your page. 

1365
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Tutorial project:

For more detailed examples see the Interactive Media tutorial project that you can find in

the My HelpAndManual Projects\Examples folder in your Documents directory. It is also

accessible in the Welcome screen at the top of the Project Explorer on the left.

How to insert custom web content in your topic pages:

Click in the topic where you want to insert the content and choose the Custom Web Con-

tent option from the Media tool in the Write tab.

Here too, you basically just need to enter an embed URL to the web page hosting the

content. All the other settings are the same as for YouTube, Vimeo and Prezi:

Getting the embed URL:

This is the only thing that can be a little tricky. In some cases, like the Adobe Express ex-

ample shown above, you will be able to use the direct URL provided by the service. Other
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sites may provide their own embed code with their own iFrame. You can identify this be-

cause it contains an <iframe> tag in the code, that will look something like this:

<iframe width="800" height="600"
src="//www.thinglink.com/card/573536608976896002" type="text/html" framebor-
der="0" webkitallowfullscreen mozallowfullscreen allowfullscreen
scrolling="no"></iframe>

In this case you don't want to insert all the embed code. Instead, you need to get the URL

from the src= attribute of the <iframe> tag, along with the dimensions (highlighted in

yellow and aqua above). 

If the http:// or https:// prefix is missing from the source as in the example, you

need to add it. The URL you would need to use for the ThingLink example would then be:

https://www.thinglink.com/card/573536608976896002

Inserting local video files stored on your computer

These instructions are for inserting a video file stored on your computer. See further be-

low for inserting videos hosted by online video sharing sites like YouTube.

1. Click in the editor at the point where you want to insert the video. 

2. Select the Media tool in Write > Insert Object and select the Local Video option.

3. Click on the  browse button in the Video File: field and select the video file. Altern-

atively you can also drag the video file into the Insert Video dialog.

4. Use Select Poster Image to select the placeholder graphic to be displayed in the topic.

The user starts the video by clicking on this image.

5. Set the video options .

6. Click on OK to insert the movie in your topic.

1363
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Editing the embed code manually:

The Embed Code tab allows you to change the embedding code used for local videos if

you want. 

1. Click on the Embed Code tab and select the I want to enter the embedded HTML code

manually option. 

2. This displays the code that would normally be entered automatically. 

3. Edit  the code or replace it with your own code and click on OK.

Note that you need to be familiar with writing HTML code manually to use this function.

Any changes you make are entirely your own responsibility, Help+Manual will not parse or

check your code in any way!

If you enter additional file or image references in your code the compiler will not know
about the files you are referring to and will not automatically include them in your output.

To solve this problem add these external files to the Baggage Section  – then they will

be included in your HTML output automatically.

How to insert videos stored online using the Local Video option

If your video files are stored on a web server you can insert the URL of the video in the

Local Video dialog instead of the name of the video file. For example, you can use this for

video stored in a folder on your own website.

1. Follow the directions for inserting local video (see above). 

2. Instead of using the  browse button to select the video file, manually enter the URL

of your video file in the Video File: field. 

Important:

You must enter the complete URL and the complete file name. Include the http:// prefix

and the extension of the file and make sure that upper and lower case are correct. Most

web servers are case sensitive. 

1119
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How to embed video from other video sharing sites

You can also embed videos from other video sharing sites but you must do this manually

with an HTML code object, not with the Insert Video tool. This means that the video will

display and play inline. You cannot use the Insert Video tool's lightbox option when you

do this.

1. Visit the video site, select the video you want to embed and get the "embed code".

This is usually available with a button labeled "embed". It will normally be enclosed in

<iframe> or <div> tags. 

2. Click in the editor where you want to insert the embedded video. Then select the Insert

HTML Code Object tool in Write > Insert, paste the embed code into the editing box

and click on OK.

That's it. This may not always work but you should find that it works fine for most com-

mon video sharing sites.

Inserting demo and tutorial videos from Camtasia and Captivate

If you use screen video tools like Techsmith Camtasia or Adobe Captivate to create demos

and tutorials there are some extra points you need to consider when inserting the movies

they generate. Depending on the output format you choose, these tools sometimes out-

put a whole "package" of files that also include a player. If you want to use the entire

package you need to embed the videos manually instead of using the Insert Video tool.

Option 1: Export as a single MP4 file only:

This is the simplest option. Just set your video demo tool to export the movie in the MP4

video format as a single file, with no additional files. Then you can use the Insert Video tool

directly.

1. Choose the single-file MP4 format for export in your video demo tool and make sure

that you turn off any option for embedding the video in an HTML page or including a

player of some kind. 

2. Select the MP4 file with the Insert Video tool in Help+Manual. This should be the only

file you need to use.

Option 2: Link to the video package with the Custom Web Content option:

This method allows you to use the unchanged video package from Camtasia or Captivate, but

you must put it on a separate folder on your web server. You then link to it with the Custom

Web Content option in the Media tool.

This is now the preferred method for inserting full Camtasia or Captivate video packages in

your projects.
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1. In Camtasia or Captivate, export your video package to an empty folder and load the

entire contents of the folder to a suitable empty folder on your web server. You must

do this before the next step, because you need to be able to link to the page online

while you are inserting it. 

2. Click in the Help+Manual editor where you want to insert the video, select the Media

tool and select the Custom Web Content option.

3. Enter the absolute URL to the HTML file in the video package in the URL: field, includ-

ing the http:// or https:// prefix. 

4. Click on the Select Poster Image button to play the online video and create a poster

image. This will only work if the video package is already online on your web server. 

5. Configure the other video options as normal and click on OK to insert the video.

Option 2: Embed the "video package" manually

This old method is now deprecated and is not recommended because it is no longer

necessary. It is more work than including the video package in a separate web folder

and linking to it, and it is less reliable. 

1. Make sure that you export the video package to an empty folder so that it only

contains the files you really need to use. 

2. Add all the files except the HTML file exported by the video demo tool to the

Baggage Files  section in your Help+Manual project. (The HTML file contains

the code you need to insert in your project topic.)

3. Open the HTML file in a text editor, locate the embed code and copy it to the

Windows clipboard. This code is usually clearly identified with comments in the

HTML file. For example, in Camtasia use the block of code labeled "Users look-

ing for simple object embed tags can copy and paste the needed tags below".

4. Click in your Help+Manual topic where you want to insert the video, select the

Insert HTML Code Object tool in Write > Insert Object. Then just paste the

copied code into the editing box and click OK.

Converting videos to M4V for iBooks/ePUB

Videos in ePUB eBooks will only play in the Apple iBooks® player on Apple iOS devices

(iPad, iPhone and iPod Touch). They may play on some other devices but you shouldn't

depend on it.

If you want to insert videos in your iBooks®/ePUB eBooks you must use the M4V format

and it must be encoded correctly with an Apple-compatible profile. If you don't use Apple

QuickTime directly you can use the excellent free Handbrake tool, which delivers very high

quality and comes with all the Apple profiles you need. It has a huge number of settings

but you can ignore them. You just need to select the profile for the target device (iPad or

iPhone/iPod Touch) and convert the video.

1119



561

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

Handbrake website and download: http://handbrake.fr 

See also:
About using video files

5.13.2 Animated HelpXplain presentations

HelpXplain is a new kind of animated infographics pro-

gram. It creates animated screencasts that you can em-

bed in simple HTML pages, and they work without Adobe

Flash (which is now no longer supported anywhere any-

way). Instead, they are based on modern HTML5, CSS3

and JavaScript technologies that work in all browsers on

all platforms – especially including mobile platforms. 

This means you can use HelpXplain presentations both

when you are presenting to an audience yourself, and embedded in your own WebHelp or

CHM documentation. And that is something that you definitely can't do with normal present-

ation tools like PowerPoint or Keynote. 

HelpXplain is faster and more effective than HowTo videos

If you've ever tried to create a HowTo video you know how difficult, stressful and time-

consuming it is. HelpXplain is different. You can create animated HowTo screencasts of

anything on your computer screen that is just as effective as a video. It consists of a series

of screenshots with animated transitions that can be edited or corrected at any time. You

don't have to redo everything if you make a mistake, you just replace a screenshot and

you're done. You don't have the stress of needing to get everything exactly right while

making your screencast, and there is no time pressure. You can wait as long as you like

between screenshots. 

HelpXplain Screencast Example

How does HelpXplain work?

A HelpXplain presentation is basically a single large HTML page, with an optional back-

ground. Your "slides" in the presentation can be positioned anywhere on the page. When

1536
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the presentation is viewed the page is zoomed so that each slide fills the browser window.

The page then moves, zooms and rotates behind the window to bring the next slide into

view. The effect is like a virtual video camera flying over the large presentation and zoom-

ing in over the individual slides, one after another.

Visit http://www.HelpXplain.com for a demo and to download the HelpXplain program. 

See Inserting videos and online media  for instructions on how to insert HelpXplain

presentations in your Help+Manual projects.

Adding a reference to HelpXplain so that Help+Manual can find it

Help+Manual compiles HelpXplain presentations in your project automatically when pub-

lishing the project. If you have the full version of HelpXplain installed it will use that for do-

ing this, otherwise it uses its own HX compiler. Normally HelpXplain will be found auto-

matically if it is installed. However, to make absolutely sure that the full version is used

you can add the reference to it yourself in the Program Options . This also enables you

to open HX projects directly from within Help+Manual, from the context menu displayed

when you right-click on an Xplain in the HM editor.

You can include HelpXplain slides in print-style output

When you include Xplains (HelpXplain presentations) in your projects you will normally

want them to actually run when the user clicks on them. This works fine in CHM, WebHelp

and eWriter. But what about formats like Word and PDF, which are like printed pages

without dynamic content? There you can opt to include either an image of the first slide

that links to the online version, or static images of all the slides displayed in a tabular grid.

See the instructions for HelpXplain in Inserting videos and online media  for full details.

Configuring your CHM topic page templates for HelpXplain

HelpXplain presentations are fully compatible with CHM help files using any of

Help+Manual's current CHM skins or the standard templates in newly-created projects. If

you are using an older skin or template, you need to make a small change in the topic

page template to ensure compatibility with HelpXplain.

1. Open the Help+Manual project (if you are not using a skin) or the .hmskin file (if you

are using a skin). 

2. Go to Configuration > HTML Page Templates > Default and look in the source code.

If X-UA-Compatible meta tags are already there:

If you find the following two lines, or any other version of the X-UA-Compatible meta

tag:

550
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<IF_CHM><meta http-equiv="X-UA-Compatible" con-
tent="IE=8" /></IF_CHM>
<IF_HTML><meta http-equiv="X-UA-Compatible" con-
tent="IE=edge" /></IF_HTML>

Replace them with this single line:

<meta http-equiv="X-UA-Compatible" content="IE=edge" />

If X-UA-Compatible meta tags are not already there:

Simply add this single line, together with the other meta tags:

<meta http-equiv="X-UA-Compatible" content="IE=edge" />

The final result should be that there is only one X-UA-Compatible meta tag, with the

content IE=edge.

5.13.3 Support in output formats

Support for local video files varies according to the output format you are using. This support

is dependent on the output formats themselves, not on the capabilities of Help+Manual.

The bottom line is that if you want to be relatively sure that your movie will play on the user's

computer then use online video services for CHM files, MP4 or online video services for We-

bHelp and M4V for videos in iBooks®/ePUB eBooks (only plays in Apple iBooks®). All other

video formats will cause problems on at least some users' systems, even if they seem to be

working for you.

Adobe Flash discontinued:

Adobe Flash has now been discontinued worldwide and on all platforms, among other

things because of its horrendous security performance. Existing Flash videos in projects

will still work on platforms that have Flash installed but you can no longer add new Flash

content. We strongly recommend that you remove all Flash content. 

Video with subtitles using the VTT MIME format

Video in the MP4 format including reference to text files for subtitles in the VTT MIME

forum is supported in WebHelp and eWriter. If the subtitle files are available such videos

can also be displayed with the subtitles when viewing WebHelp automatically after pub-

lishing. (This is achieved with Help+Manual's own HM2Go mini web server.)



564

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

Support for video files in output formats

HTML Help /

CHM:

Flash video is no longer supported worldwide and should be re-

moved from all projects.

HelpXplain presentations are embedded in the CHM file and will

play reliably. See Animated HelpXplain presentations  for details.

Online video services will play reliably in CHM files. All other video

formats will fail to play in CHM files on at least some users' com-

puters. Online video does require an Internet connection, of course.

However, Help+Manual inserts the videos so that the connection is

only required when the user actually clicks on the video to play it.

The iFrame with  the video content is not loaded at all until then.

When the user clicks, the preview image is replaced with the

iFrame.

MP4 video encoded with an Apple profile is the most reliable video

format, if you must use local video. Note that the video will not and

cannot be embedded in the CHM, as Microsoft now forbids this for

all formats.

WebHelp: Many video formats are theoretically supported, but we strongly re-

commend using only MP4 or online video services. Flash is no

longer supported anywhere and should be removed from all pro-

jects if you have used it in the past. 

HelpXplain presentations are ideal for WebHelp and will play reli-

ably.

eWriter Exe

eBooks:

Same video formats supported in WebHelp, including HelpXplain

presentations.

iBooks®/ePUB

eBooks:

Only Apple iBooks® supports video in ePUB eBooks reliably and

for it to work you must use properly encoded M4V video files cre-

ated with a tool that supports Apple video profiles, like Apple

QuickTime or the excellent free  Handbrake tool. No other video

or presentation formats are supported in ePUB.

Some other ePUB readers may support video but you shouldn't rely

on it yet.

561
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Some ePUB readers will support dynamic HelpXplain presentations

but you shouldn't depend on it. Only use HelpXplain in ePUB if you

are certain that all your users will have readers that support it.

Kindle eBooks: No multimedia support. File links to external media files may work

on Kindle apps in tablets and computers, but will fail on the original

Kindle readers with e-ink displays.

Adobe PDF: No multimedia support except as file links to external media files.

Word DOCX: No multimedia support except as file links to external media files.

See also:
Help Formats  (Reference)

5.14 Keywords and Indexes

Every help file or manual needs a keyword index and Help+Manual makes creating and main-

taining a good index much easier than ever before. You can add index keywords to each topic

in the Topic Options tab on the left of the main editor window. In addition to this you can also

add keywords to anchors for even more granular index references.

If you have the Professional or Floating license version of Help+Manual you can use the Index

Tool  to view and edit the finished index while you work. It enables you to work in the en-

tire index directly as well as entering keywords for individual topics.

Since you can see the results immediately it is very easy to avoid multiple entries that are only

slightly different from one another. In addition to this you can produce a much better index

because you can refer to the finished index while adding new entries, and you can also navig-

ate directly to the topics associated with index entries by clicking on the entries in the Index

Tool.

See also:
IDs, Context Numbers and Keywords  (Reference)

5.14.1 Adding and editing keywords

Each topic in your project can have its own list of "index keywords", each of which will create
an index entry in your output. You can add both simple keywords (master keywords) and
keywords with sub-entries (child keywords). Only one level of child keywords is supported
(this is a restriction imposed by the output formats, not by Help+Manual).

Index generation is automatic. An index will be generated when you publish as soon as you

have added one or more keywords to any topic in your project. However, in WebHelp you

need to activate the index in the output in your Navigation settings  if you want to include

it.

1504
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Productivity Tip
It is best not to use keywords in popup topics and

topics without TOC entries. Clicking on Keyword Index

entries will display these topics in the main help viewer

and this may confuse the user. 

How to add keywords from the topic editor

You can quickly add any word or series of words in the topic editor as a keyword:

· Just select the word or phrase you want to add and press Ctrl+K. 

· This is the standard keyboard shortcut for this function. You can change it if you like in

View > Program Options > Shortcuts.

How to add and edit topic keywords

1. Select the topic you want to add a keyword to and select its  tab below the editor win-

dow. 

2. Type your index entries in the Keywords: field in the Topic Options tab on the left of

the main editor window. Enter one keyword per line and press Enter after each

keyword to create a new line.

Viewing the Topic Options tab and the topic at the same time:

Working with index keywords is easier if you can see the Topic Options tab and the topic

content at the same time. To do this select Show Topic Options side by side in the topic

options menu in the top right corner of the editor. See Tips & Tricks in the Project Ex-

plorer  for more details. 82
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Using the Index tool:

If you have the Professional or Floating license version of Help+Manual you can select the

Index Tool  in Project > Tools so that you can see the finished index while you are writ-

ing.

How to add and edit topic sub-keywords

You can enter index keywords and sub-keywords in the Topic Options tab on the left of

the main editor window. Indenting a keyword with the TAB key automatically makes it the

sub-keyword of the keyword above it. 

1. Proceed as described above for adding keywords. 

2. Enter child keywords in the line directly below their master keyword and indent them

with the TAB key. This will make it the sub-keyword of the keyword directly above it.

You can enter as many child keywords as you like for each master keyword – one per line.

You can only enter one level of child keywords. Child keywords cannot have their own

child keywords.

Adding and editing keywords with the Index tool

If you have the Professional or Floating license version of Help+Manual you can also edit

the real-time index directly with the Index tool. See Editing the index directly  for de-

tails.

568
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Finding topics with no keywords

You can locate topics that have no keywords with the Report Tool. Select the Report Tool

in the Project tab, then choose Missing Keywords Report in the Report Type: field at the

top of the dialog. 

See The Project Report Tool  for more details on using the Report Tool.

See also:
Editing the index directly

IDs, Context Numbers and Keywords  (Reference)

5.14.2 Editing the index directly

If you have the Professional or Floating license version of Help+Manual you can also edit the

real-time index directly with the Index Tool in Project > Tools. Note that this tool is only avail-

able in the Professional and Floating license versions. 

This tool enables you to edit keywords in all the topics where they occur simultaneously. You

can also add keywords to multiple topics and delete keywords from multiple topics at the

same time, in one quick operation.

Productivity Tips
Select Expanded View at the bottom of the Index Tool

window to display links to the topics containing the in-

dex keywords. Double-click on the Index Tool title bar

to undock or redock it.

Editing keywords in the Index window

This method allows you to edit keywords in all the topics where they occur simultan-

eously. Any changes you make to the keyword in this editing dialog updates the keyword

in all the topics where it is used. 

1. Select the Index Tool in Project > Tools, this displays the index window to the right of

the main editor pane. 

1212
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2. Select a keyword in the index and then click on the  Edit Keyword tool in the Index

Tool toolbar. You can select a master keyword or a child keyword.

To add the keyword to more topics select the topics on the right and click on <<

3. Edit the keyword in the Keyword: field, then click on OK to save your changes. This will

save the modified keyword in all the topics whose IDs are listed in the Topic: list on the

left. 
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Viewing Topic Options and the topic at the same time:

Display Topic Options next to the editor window:

Working with index keywords is easier if you can see and the topic content at the same

time. You can't undock the Topic Options tab but you can display it next to the editor. To

do this activate the Show Editor & Topic Options side by side in the options menu at the

top left of the editor window. 

Undock the Index tool:

Since this can make the editor a little narrow on smaller monitors it can be helpful to un-

dock the Index tool, as shown above. To do this just double-click on the Index tool title

bar. You can also get more space when you are working in this mode by pinning the Pro-

ject Explorer to the left margin so that it collapses automatically when it is not needed. 

See Tips & Tricks in the Project Explorer  for instructions and more details on these fea-

tures. 

How to add new keywords in the Index tool

New master keyword:

1. Select the Index Tool in Project > Tools to display the Index window, then select the 

 Add Keyword tool in the Index toolbar. 

82
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2. Select New Master Keyword and type the keyword in the Keyword: field of the dialog

displayed.

3. In the Available Topics: list select the topic IDs of the topics you want to use the

keyword in. Use Ctrl+Click and Shift+Click to select multiple IDs.

4. Select  to add the IDs to the Topics list, then click on OK to insert the new

keyword in all the selected topics. You can also double-click or drag to the left to add

topics to the list.

5. Click on Reload in the Index toolbar to redisplay the index.

New child keyword:

1. Select a master keyword in the Index window. The new child keyword will be added to

this keyword. 

2. Select the  Add Keyword tool in the Index toolbar and then select New Child Key-

word.
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3. Enter the new child keyword in the dialog displayed and press on OK to confirm.

You can use the  button to add the same child keyword to additional topics – just

select the topics in the list on the right and add them to the topics list on the left. If the

master keyword is not stored in those topics it will be added too.

How to add keywords to additional topics

You can add selected keywords to additional topics or remove keywords from selected

topics with the Index window tools.

1. Select the Index Tool in Project > Tools to display the Index window, select a keyword

and open the editing dialog with the  Edit Keyword tool. 
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2. In the Available Topics: list select the topic IDs of the topics you want to use the

keyword in. Use Ctrl+Click and Shift+Click to select multiple IDs.

3. Select  to add the IDs to the Topics list, then click on OK to insert the new

keyword in all the selected topics. You can also double-click or drag to the left to add

topics to the list.

Adding keywords to anchors

If topics contain anchors you can add keywords to the anchors instead of to the main

topic. 

1. Use any of the methods described above to add or edit a keyword in the Index win-

dow. 

2. In the Edit Keyword dialog select the topic in the list on the left, then select the anchor

in the Anchors: drop-down list in the middle. The keyword will then be assigned to the

anchor for this topic instead of to the top of the topic.

Anchors will only be displayed for topics that actually contain anchors. See Anchors - jump

targets  for more details on how to enter and edit anchors. 

Deleting keywords

Warning: Deleting keywords in the Index window deletes the keywords from all the top-

ics in which they occur! If you only want to remove keywords from individual topics use

the  Edit Keyword tool or edit the keywords for the topics directly in the tab.

1. Select the Index Tool in Project > Tools to display the Index window. 

2. Click on the  Delete Keyword tool in the Index toolbar and confirm the prompt dis-

played. 

See also:
IDs, Context Numbers and Keywords  (Reference)

Anchors - jump targets

5.14.3 Find and replace keywords

You can also perform search and replace operations in all the keywords in your project. This is

a very useful Help+Manual function that is easy to overlook! 

How to find and replace keywords

1. Select Editing > Find and Replace Text in the Write tab. 

2. In Find Where select In topic keywords.

415
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Note that Find and Replace does not work on keywords attached to anchors , but it

does work on A-keywords .

See also:
Searching for text, topics and referrers

IDs, Context Numbers and Keywords  (Reference)

Using keywords with anchors

Using A-keywords

5.14.4 Exporting and importing the index

If you are using the Professional or Floating license version of Help+Manual you can export

the entire keyword index of your project as an XML file for external editing or translation.

Then you can re-import the edited file to update the project index. This can either completely

replace the existing index or add the new keywords in the file to the existing index.

Exporting the keyword index to an XML file

Activate the Index Tool and select Export in the toolbar at the top:

A save dialog will be saved in which you can choose the name and location of the expor-

ted index XML file.

577
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Editing or translating the keyword index file

The structure of the exported keyword index file is quite simple, but it's important to know

what you can edit and what you should leave untouched:

   <hmkeyword value=".ipp files" translate="true">
    <hmtopicid value="HM_Working_Graphics_Formats"/>
    <hmtopicid value="HM_Working_Graphics_Hotspots"/>
    <hmsubkeyword value="hotspots in old .ipp files" translate="true">
      <hmtopicid value="HM_Working_Graphics_Formats"/>
      <hmtopicid value="HM_Working_Graphics_Hotspots"/>
    </hmsubkeyword>
  </hmkeyword>

Each keyword is stored in a <hmkeyword> </hmkeyword> tag pair, with the actual

keyword in a value attribute. The topics in which the keyword is used are listed inside the

tag pair, in <hmtopicid /> elements. If the keyword has any sub-keywords, these are

also enclosed inside the main hmkeyword element, in their own pair of <hmsubkeyword>

... </hmsubkeyword> tags that use the same structure, with the topics inside them in

<hmtopicid /> elements . 

Normally, you should ONLY edit the value attributes!

You should only edit the value="keyword" attributes, particularly if you are translating

the index. If you change the topic ID references the keywords will be applied to different

topics when you import the index. 

Adding keywords to new topics

If you want to add the keywords to new topics or remove them from existing topics, you

can achieve this by adding, removing and changing the hmtopicid elements for the cor-

responding keywords. You can also add new keywords in the same way, so long as you

preserve the structure described above. However, make sure that the topic IDs you use ac-

tually exist in the project, otherwise you will get errors!

Importing edited and translated index files

To import an edited index file, just select the Import icon in the toolbar of the Index tool:
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You will see a dialog with which you can choose the XML index file to import. You will

then be asked if you want to add the new keywords in the index to the current project or

to replace the current index with the imported index.

Always select REPLACE for translated indexes!

If you merge a translated index with an existing index you will get index entries in both

languages, which you probably don't want. So always select the option to replace the ex-

isting index when importing a translated index.

Select Merge/Add to update existing indexes

If you select the merge/add option any keywords in the imported index that are not found

in the current index will be added as new keywords. This also includes slightly edited ver-

sions of existing keywords, so please do be aware of this!

Correcting import errors

If you make an error and merge an index you wanted to replace there are two ways to

correct this:
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· Re-import the index with the REPLACE option (this will delete any keywords that are not

in the imported index)

· Close the Help+Manual project without saving (you need to save before importing the

index for this to be possible, of course)

5.14.5 Using keywords with anchors

Normally, clicking on an entry in the index of a help file executes a jump to the top of the

topic containing the keyword. However, you can also associate keywords with anchors, which

are jump targets in your topics. When an anchor keyword is clicked in the index the user is

taken directly to the anchor location in the topic.

How to add keywords to an anchor

1. Select the Insert Anchor  tool in Write > Insert Object to insert a new anchor or

double-click on an anchor icon in your topic text to edit an existing anchor. 

2. Type the keywords into the Keywords: field of the Anchor dialog. You can enter both

main keywords and sub-keywords. Use the TAB key to enter sub-keywords (an inden-

ted keyword automatically becomes the sub-keyword of the keyword above it).

Same keywords in anchors and Topic Options:

It is possible to have the same keywords in both the topic's Topic Options and in one or

more anchors in the same topic. However, if you want your index entries to enable jumps

to the anchor without confusing the user it is better to avoid this.
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Note that you can also add keywords to anchors by editing the keyword with the Index

Tool. See Editing the index directly  for details.

Displaying anchor keywords in the Index Tool

Anchor keywords in the Index Tool:

Normally, anchor keywords look exactly the same as other keywords in the Index Tool in

Project > Tools. To make the anchor keywords visible select Expanded View at the bottom

of the Index Tool window. The anchors of anchor keywords will then be displayed after

their topic IDs, separated from the IDs by a # character, like this:

intro_part1#beginners

In the example above intro_part1 is the topic ID and beginners is the anchor name.

Anchor keywords in the Edit Keyword dialog:

Anchor keywords are always displayed in the topic_id#anchorname format in the Edit

Keyword dialog, which is display by selecting the Edit  tool in the Index Tool toolbar.

Anchor keyword display in HTML Help

When the user clicks on a keyword found in multiple topics, a dialog is displayed showing

the names of the topics in which the keywords are found together with the title of the

help project (this is only really relevant for modular projects containing multiple help

files). 

In HTML Help, however, the keyword text is displayed instead of the name of the topic.

This is a restriction of the HTML Help format and cannot be changed.

568
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Both the entries found here refer to the keyword "Horticulture". The first keyword is an an-

chor keyword, the second is a normal keyword in a topic.

See also:
Editing the Index directly

IDs, Context Numbers and Keywords  (Reference)

5.14.6 Using A-keywords

Key Information
Note that A-keywords are a Microsoft help technology

that is only supported in the Microsoft HTML Help

(CHM) format. A-keywords are irrelevant in all other

output formats, including WebHelp. 

A-keywords, also known as "A-link keywords", are only used in Microsoft's HTML Help (CHM)

format. They are quite similar to normal keywords but they not displayed in the index, they

are always "hidden". What use is a keyword that isn't displayed anywhere? There are two ma-

jor uses for A-keywords: To create "See also" lists of related topics and to create links between

help files in modular help systems. 

See About A-Keywords  for background information.

How to make an automated See Also list with A-keywords

This method creates links that display a list of related topics. It only works in HTML Help

CHM files. It will not work an any other output format.

Step 1: Enter the A-keywords

1. Select a topic and select its Topic Options tab (top left of the main editor window). 
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2. Enter one or more keywords in the A-Keywords: section, one keyword per line. Note

that sub-keywords are not supported with A-keywords!

3. Repeat for all topics you want to "associate" with one another, adding the same A-

keyword to each topic.

Step 2: Create the link

The link that displays the list of See also: topics is created using the Winhelp ALink macro.

The syntax of this macro is much simpler than its HTML Help equivalent and so

Help+Manual automatically translates it when you output to HTML Help. 

1. Select Insert > Link in Write > Insert to create a hyperlink. 

2. Select the Script Link tab in the Insert Hyperlink dialog, then select Winhelp macro as

the type of hyperlink.

3. Enter Alink() in the Script: field and type the keywords you want to link to between the

parentheses. If you enter more than one keyword separate them with semicolon (;)

characters, like this:

This example will create a link that displays a list of all topics that contain the A-keywords

"troubleshooting" or "solutions".

Note that when you are working in HTML Help you can only enter keywords as the argu-

ment for the Winhelp macro. You cannot enter the other parameters for the Winhelp A-

Link macro because they are not translated into HTML Help code!

How to link between help modules with A-keywords

Use this method to create links between the help files of modular help systems if there is a

possibility that the help files containing the target topics may not be present when the

help is viewed. This can happen when you use runtime merging and choose not to include

one or more of the help files in your distribution. It can also happen if you are using con-

ditional output to exclude modules from publish-time merged HTML Help and Winhelp

projects.
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This technique works both in HTML Help and the obsolete Winhelp forma but not in any

other formats. Please study Working with Modular Help Systems  before trying to use

this method!

Step 1: Prepare the alternative topic in the master project

The alternative topic should be in the master project because this is the only help file that

is always present in a runtime-merged modular help system.

1. Open the master help project and choose or create the alternative topic that you want

the user to be able to view when the other help file module containing the target topic

is not available. 

2. Select this alternative topic, select the  tab and enter a unique A-keyword in the A-

Keywords: field. The A-Keyword must be unique. It should not be used anywhere else

in your projects! If it is, all the topics where it is used will be displayed when the A-Link

hyperlink is clicked.

Step 2: Prepare the target topic in the child project

1. Open the child project and select the topic you want to link to. 

2. Select the  tab and enter the same unique A-keyword as above in the A-Keywords:

field. 

Step 3: Create the link

1. Open the project module in which you want to create the link. This can be a master

module or another child module. 

2. Select Insert > Link in Write > Insert to create a hyperlink. 

3. Select the Script Link tab in the Insert Hyperlink dialog, then select Winhelp macro as

the type of hyperlink.

4. Enter Alink() in the Script: field and type the keyword between the parentheses. If your

keyword is "about widgets" the dialog would look like this:

1088
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If the target help file is not present when the user clicks on the link the alternative topic

will be displayed automatically. If the target topic is present a dialog will be displayed in

which the user can select either the target topic or the alternative topic.

This is just a very simple example to show you how this solution works in principle. In

practice you can also make more complex solutions, using more alternative topics and

more keywords. If you use multiple keywords remember to separate them with semi-

colons, like this:

Alink(about widgets;troubleshooting;widget solutions)

Note that when you are working in HTML Help you can only enter keywords as the argu-

ment for the Winhelp macro. You cannot enter the other parameters for the Winhelp A-

Link macro because they are not translated into HTML Help code!

See also:
About A-Keywords  (Reference)

5.14.7 Index section header separators

When Help+Manual generates keyword indexes in WebHelp and PDF, it automatically adds

section headers corresponding to the letter of the alphabet. The keywords are then organized

beneath the section headers by letter, which makes them easier for the user to find quickly: 

Example of index section headers in Webhelp

1606
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You can edit the index section header separators if necessary, for example to add letters for

non-English languages.

How to edit the separators for Webhelp and PDF

1. Locate the separators setting for WebHelp or PDF: 

WebHelp:

In the Project Explorer go to Configuration > Publishing Options > WebHelp > Key-

word Index. 

PDF:

Open the print manual template  for your project in the Print Manual Designer and

select the Keyword Index section. Then select File > Page Options and choose the Key-

word Index Section tab.

2. Then edit the list of separators for your own requirements. For example, for German

you would enter:

A,Ä,B,C,D,E,F,G,H,I,J,K,L,M,N,O,Ö,P,Q,R,S,T,U,Ü,V,W,X,Y,Z

Note that you don't need to enter separators for non-alphabetic characters like "#"

and ".". If there are keywords starting with characters like these the section headers for

them will be generated automatically and placed at the top of the list. 

Adding "letter links" to the separators for Webhelp

It is practical to have "letter links" at top of the index that take you down to the corres-

ponding letter in the index when you click on them:

803
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The "letter links" in the Index

You can create links like these for your own help by adding some code to the HTML tem-

plate for the WebHelp index. You need some experience with editing HTML manually to

do this.

1. In the Project Explorer go to Configuration > Publishing Options > WebHelp > Key-

word Index and select the HTML Source Code tab. 

2. Locate the <%KEYWORD_INDEX%> variable. This variable inserts the content of your

keyword index, so you want to insert your link list directly above it.

3. Insert one or two <br /> line break codes to create some space, then insert one link

for each letter in your link list, using the following syntax:

<a href="#A">A</a>

If you want links to keywords beginning with non-alphabetic characters you must also

enter lines for them yourself. The result will look something like this:

...
<a href="<%HREF_CONTENT_PAGE%>">Contents</a>
<IF_INDEX_PAGE> | <b>Index</b></IF_INDEX_PAGE>
<IF_SEARCH_PAGE> | <a href="<%HREF_SEARCH_PAGE%
>">Search</a></IF_SEARCH_PAGE>
</p><hr size="1" />
<br><a href="#A">A</a>
  <a href="#B">B</a>
  <a href="#C">C</a>
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  <a href="#D">D</a>
  ...
  <a href="#X">X</a>
  <a href="#Y">Y</a>
  <a href="#Z">Z</a>
<!-- Placeholder for the keyword index - this variable is
REQUIRED! -->
<%KEYWORD_INDEX%>
...

See also:
Using HTML templates

About HTML templates  

5.15 Single Sourcing

This chapter provides a brief introduction to the basic principles of single sourcing in

Help+Manual. For full details on how to maintain different versions of your content and gen-

erate different versions of your projects see the following chapters in the help:

· See Conditions and Customized Output  for full details on using conditional output

to create different versions of your project.

· See Working with Modular Help Systems  to learn how to add entire projects to your

project in the same way as topics. You can then include or exclude these projects with

conditions in the same way as normal topics.

· See Command Line Options  to learn how to automate the process of generating dif-

ferent versions of your project. Once you have got it set up, you can generate multiple

versions of your project to multiple destinations in multiple formats with a single click.

· See Publishing  for details on preparing your project for output to various formats.

· See Templates in Help+Manual  and Using HTML Templates  for information on

the various template types available and what you can do with them. 
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What is single sourcing?

You can produce multiple different versions of your

project for any number of different purposes. You

don't have to maintain multiple projects. 

Single sourcing means using a single

project to produce multiple versions of

your documentation for different pur-

poses. 

This can be as simple or as complex as

you need. For example, you might just

want to produce a CHM and a PDF ver-

sion of your documentation – the CHM

for the online help and the PDF to allow

your users to generate a printed version.

Or you might want to generate a wide

variety of very different versions for dif-

ferent purposes. For example, two ver-

sions of the help for a light and full ver-

sion of your product, or different ver-

sions of your documentation with differ-

ent brandings and content for different

clients.

This is all possible from a single project.

Each version can contain different topics

and different chapters. Individual topics

can contain different versions of the the

text, different links and different images.

Each WebHelp, CHM or PDF version can

use a different skins and templates for

different brandings and functionality.

This chapter introduces the basic prin-

ciples of single-sourcing in

Help+Manual and how you can use it to

streamline multiple versions of your

documentation without having to main-

tain multiple copies of the same text.

5.15.1 One Source - Many Formats

The simplest form of single-sourcing in Help+Manual is publishing exactly the same project

to different formats. For example, you might want to publish a CHM version for interactive

online help and a simple PDF version that users can use to generate a printed manual. Here
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too, you will still need to make small variations in your content to adjust for the different con-

texts of the different output formats. 

Publishing to a single output format

You can always publish your Help+Manual project to any of the supported formats, at any

time. There is no "primary format", and no restriction on what format individual projects

can be published to. This is made possible by the XML source format, which can always be

used to generate any output format at any time.

The simplest way to publish is to a single output format.

1. Save your project, then select the Publish tool in the Project tab. 

The Publish page

2. Choose the format you want to publish to, configure your output options and select
Publish Now! to generate your published output. 
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Check out Publishing your Projects  for full details.

Publish to multiple formats in one easy process

You can define publishing "tasks" to publish your project to all the output formats you

want to use in a single efficient process. Once you have set up a task it is saved and you

then just have to select it to re-publish to all the same formats and locations again.

1. Save your project and select Publish in the Project tab. 

2. Select Task Manager to display the Task Manager page. Then:

· Click on Publish Task to publish the current project using one of the predefined tasks.

OR

· Click on New Task to create a new publishing task. 

OR

· Edit an existing task with the Add and Remove Task Action tools.

See Automating Publishing Jobs  for full details.

Adjusting included topics and topic content for different formats

Adjusting included topics:

See Multiple TOCs  for more detailed instructions.

1. In the Project Explorer, select the topic you want to include only in one or more spe-

cific output formats. 

2. Select Change > Include in Builds in Project > Manage Topics. This displays a list of
available build conditions that you can apply to the topic.

3. Activate the check boxes for all the formats where you want to include the selected
topic. The topic will be included in formats you activate in this list. It will be excluded
from all ones that are not activated.

Adjusting content in topics:

You do this with the Conditional Text tool, by tagging versions of text for inclusion and

exclusion depending on the chosen output format.

For example, you might want to include an active hyperlink in the version designed for

CHM but a simple chapter reference in a PDF designed for printing. The tagged text in a

topic would look like this (this is a graphical screenshot, not real text):
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In the example above, the "installation instructions" link will be included in the CHM ver-

sion and the "chapter 1" text in the PDF version. 

1. Select the text or other content (images, multiple paragraphs etc.) you want to include

in a specific output format. 

2. Select the Conditional Text tool with Write > Insert Object >   

3. Select IF and the format you want to include the content in, then click on OK to apply
the tags.

See Variant Content  in this chapter and Conditional text include options  for more
details on using these functions.

See also:
Variant Content

Multiple TOCs

Publishing

Conditions and Customized Output

5.15.2 One Source - Different Versions

Even if you are not publishing versions of your project with different content you will still need

slight variations in your output for different output formats. For example, some topics may

not be appropriate in both CHM and PDF output, and some references in the text might need

to be phrased differently in each format. 

In addition to small variations in content and included topics for different output formats, you

will sometimes want to produce versions of your project with larger differences. For example,

different topics, topics in different order in the TOC and so on. In addition to this you might

also want to generate these versions with a different "look and feel" or corporate branding. If

you want to publish different versions of the project in the same output format, for example

different versions of the same CHM, you need to define your own output conditions.

Defining your own build tags for different versions

You create versions with varying content by tagging content in your topic for inclusion or

exclusion using what we refer to as "build options". You can do this both for output

format (e.g. include in PDF, exclude in CHM) and for options that you define (e.g. include

in DEMO BUILD, exclude for CLIENT JONES).

Tagging content for different output formats is easy, you just need to select the name of

the output format, which is predefined. To create different versions of your project in the

same format you need to define your own "build options". Once you have defined them,

you can use them in exactly the same way as the format tags.

Defining custom build tags:

1. In the Project Explorer go to Configuration > Common Properties > Custom Builds. 
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2. Use Add and Delete to add and delete include options. When you define a new include

option you must enter a "Build ID". This is the actual include option tag and it cannot

be changed later. Use short names for the options, like BUILDA, CLIENT2, DEMO and

so on. 

3. Click in the Display Text column to edit the descriptive texts for your include options.

These are just informative and do not have any effect on the functioning of the condi-

tions. Keep them relatively short because they must be displayed in selection lists in

dialogs, which are generally quite narrow.

All the definitions you enter here are automatically displayed in all locations where include

options are used. 

Tagging content in topics for inclusion or exclusion

You tag variant content in topics for exclusion or inclusion with the Conditional Text tool

in Write > Insert Object.

For example, you might want to include an active hyperlink in the version designed for

CHM but a simple chapter reference in a PDF designed for printing. The tagged text in a

topic would look like this:

In the example above, the "installation instructions" link will be included in the CHM ver-

sion and the "chapter 1" text in the PDF version. You can use your own build tags (see

above) in exactly the same way. Then you can include content by activating the tags when

you publish and exclude it by deactivating them. 

You apply your own user-defined tags like DEM'O and CLIENTA in exactly the same way.

They are also displayed in the Conditional Text tool.

Applying the build conditions:

1. Select the text or other content (images, multiple paragraphs etc.) you want to include

in a specific output format. 

2. Select the Conditional Text tool with Write > Insert Object >   

3. Select If or If Not and the format you want to include the content in, then click on OK
to apply the tags.

Publishing your project:

When you publish your project the build tags you define are automatically displayed in the
Publish dialog, in the Include Options: box. To activate a build tag select its check box,
then the content marked with those tags will be included. The format tags (PDF, CHM
etc.) are selected automatically, depending on the output format you choose.

See Conditions and Customized Output  for full details on using these features.969
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Tagging topics, chapters and modules for inclusion or exclusion

Just as you apply build options to content in topics with the Conditional Text tool, you can

apply the same build options to every item you can include in the TOC. This includes top-

ics, chapters and entire project modules  inserted in modular projects. 

Applying the build conditions:

1. In the Project Explorer, select the topic, chapter or module you want to include only in

one or more output formats or builds. 

2. Select Change > Include in Builds in Project > Manage Topics. This displays a list of
available build conditions that you can apply to the topic. This menu is also available
with a right-click on the item in the TOC. 

3. Activate the check boxes for all the formats where you want to include the selected
topic, chapter or module. It will be included in formats you activate in this list. It will be
excluded from all ones that are not activated.

Adding alternative TOCs to your project

Sometimes just including and excluding individual topics is not enough for an alternative

version. You need a completely different TOC structure. That is possible with includes, but

very difficult to manage. Instead, you can insert an additional TOC with a different selec-

tion of entries organized in a different way. The entries in your additional TOC can point

to the same topic files as those in your main TOC. In addition to this, the alternative TOC

can also have unique topics of its own that are not used in the main TOC at all. 

When you publish your project you can then choose which TOC you want to use. See Mul-

tiple TOCs  for detailed instructions explaining how to use this powerful feature.

Publishing your project with build options and alternative TOCs

When you publish your project both the format-based build options and your user-defined
build options are displayed in the Publish dialog, in the Include Options: box. To activate a
build tag select its check box. Then the content marked with those tags will be included.
The format tags (PDF, CHM etc.) are selected automatically, depending on the output
format you choose:
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If you have defined more than one TOC in your project you can also select the TOC you
want to use in the Select Table of Contents section:

See Conditions and Customized Output  and Multiple TOCs  for more detailed in-

structions on using these features.

See also:
Multiple TOCs

Publishing

Conditions and Customized Output

Working with Modular Help Systems

5.15.3 One Source - Multiple TOCs

Help+Manual's conditional output features can create a wide range of variants of your project

for different purposes. However, it is difficult to create versions with TOCs that have very dif-

ferent structures using only conditional output. The multiple TOC feature solves this problem.

It allows you to create completely different TOCs with a different structure and different

entries for different purposes.

The entries in your additional TOCs can point to the same topic files as in your main TOC. Or

they can have their own topic files that only exist in that TOC. When you publish you choose

which TOC you want to use, and only the topics referenced by that TOC are exported – in

some cases along with topic files linked to in those topics, to prevent dead links.

See Publishing projects with multiple TOCs  for details on selecting specific TOCs when you

are publishing your projects. Also see the Multiple TOCs tutorial project that you can access

directly in the Welcome page at the top of the Project Explorer on the left.

How to create an additional TOC

1. Right-click on the Table of Contents entry at the top of the Project Explorer on the left
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and select Create new Table of Contents in the context menu. 

2. This opens the New TOC dialog:

3. Enter a descriptive title for the new TOC and choose whether you want it to be empty

or a copy of the current TOC. If this is your first additional TOC you probably want it to

be empty rather than a full copy of the entire TOC. Later you may want to make copies

of existing additional TOCs that you then edit.



594

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Basic Working Procedures

4. Then create new entries in the new TOC in any of these ways:

o Drag items from another TOC into the new one (onto the empty node if it doesn't

yet have any entries). This does not create new topics. It only creates new refer-

ences to existing topics.

o Copy and paste from another TOC.

o Create new entries with the Add Topic tool in the Project tab. If you use the TOC

Link option it creates new entries for existing topics. If you use the New Topic op-

tion you will create completely new topics.

IMPORTANT: The "main" TOC always includes all topics!

To maintain compatibility with existing projects, the "original" or "main" TOC in your pro-

ject will always include all topics when you publish with it. If you remove TOC entries from

it without explicitly excluding the topic files that no longer have TOC entries (by using

build options ), those files will still all be included in the background in HTML output

when you publish with the main TOC. They can then be found by search and the keyword

index. 

This only applies to CHM, WebHelp, eWriter and Visual Studio Help output. It doesn't ap-

ply to PDF, DOCX and eBooks, because there only topics that have TOC entries can ever

be included.

Only secondary TOCs automatically exclude the topics for which they do not have

TOC entries!

If you want to create an alternative TOC with a reduced or different set of topics, always

do this with a secondary TOC, not with your "main" or "original" TOC (the top one). Again:

The main TOC is always complete. If there are topic files without TOC entries in the project

they will be included in the background when you choose the main TOC unless they have

explicit build options that exclude them.

Use build options to to include hidden topics with secondary TOCs

By the same token, topic files without TOC entries will not be included automatically in the

background with secondary TOCs. Then, a topic file without an entry in the current TOC

will still be excluded even if it is set to "all builds". It will only be included if you explicitly

989
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set a specific build option on it and activate that in the include options for the publishing

operation. 

Popups in secondary TOCs

When you use popup topics in secondary TOCs the popup topic files your links refer to

will not be included automatically as they are when you use the primary TOC. The All

Builds include option assigned to all topics by default only works automatically in the

primary TOC. 

When you are using multiple TOCs in your project and publishing a secondary TOC, any

popup topics you link to must be included explicitly. You can do this in two different ways:

Option 1: Dead links handling options

Go to View > Program Options > Compilers and set the dead links handling option to Si-

lently include linked topic. This is the simplest solution but it will also automatically include

any excluded topic files that you may have referenced with regular topic links. So you

should always check your compiler report for topics like these that you may have not

wanted to include. You can then handle the links with conditional text  to exclude them

automatically. 

Option 2: Set the build options of your popup topic files

Alternatively you can set the build options of your popup topic files to the output formats

that support popups, which are WebHelp, CHM, eWriter, and Visual Studio Help (if you are

using that). The eWriter format will be included automatically if you set WebHelp, so gen-

erally you will only need to set CHM and WebHelp. 

1. Right-click on the popup topic file in Project Files > Topic Files and select Include in

Builds in the context menu. 

2. Set the include options to WebHelp, CHM and (if necessary) also VSHelp. 

3. Repeat for all your poup topic files.

984
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Managing links to excluded topics in additional TOCs

When you create a TOC that is a subset of the main TOC, your topics will often contain

links to topics that are not in the new TOC. You need to take steps to deal with these links

to ensure that they are not dead and so that they do not accidentally provide access to

content you don't want to include in the version with this TOC.

Failsafe: Global options for links to excluded topics 

You can set a global option for how links to excluded topics are handled in View > Pro-

gram Options > Compilers. There are three choices:

· Silently include linked topic

In HTML-based output formats this exports the topic file without a TOC entry so that

the link displays the topic. In PDF and DOCX this has no effect, because only topics that

are in the TOC can be in the document.

· Remove link

This turns the link into plain text. The referenced topic is not exported.

· Allow links to be dead

This leaves the links unchanged in the topics but does not export the linked topic files.

So either nothing happens or an error message (404) is displayed when the user clicks

on the link. This can be good "protection" if you are managing the links with conditional

output, to make sure that the excluded topics are never seen.
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Use conditional output to replace the links with alternative text

This is basically the same approach you would use for handling the same problem in nor-

mal conditional output scenarios where topics are excluded. See this topic  for full in-

structions. 

Create conditional output build options for your additional TOCs and apply them to the

links to the external topics so with the Conditional Text tool. You can use this method to

either remove the references entirely, or replace them with alternative text or alternative

links in the version with the additional TOC. 

For example, suppose you have a TOC for a specific client. You could create a conditional

build option called CLIENT_B and then tag the link with it like this:

This inserts the first link if you are not exporting the CLIENT_B version and the second

link if you are. 

Setting the default topic with multiple TOCs

If you are using multiple TOCs in your project you can set a separate default topic for each

TOC. Then you will automatically get the correct default topic for that TOC when you use

it.

See Setting the default topic  for full details on setting and managing the default topic

for your project.

Important: The default for secondary TOCs must be set in the TOC

Default topics for secondary TOCs must be set directly in the TOC. The setting in Config-

uration > Common Properties > Language Options is only for the main TOC. 

Each TOC you define can have its own default topic. Just right-click on the topic you want

to use as the default in the TOC and select "Set as Default Topic" in the context menu.

984
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More granular control of output with include options on topic files

In addition to the conditional output tagging inside topics described above, it is also pos-

sible to apply include options to the topic files referenced by the links but not to the TOC

entries in the main TOC pointing to them. This is possible because TOC entries and topic

files are separate items and each can have their own build options.

Consider this example:
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This would allow you to include the Overview topic file with your additional TOC by activ-

ating the build option CLIENT_B in your publishing settings, even if it does not have a

TOC entry. 

You can do this if you activate the global option "Allow links to be dead" to handle the

majority of links, but have a few links for which you do want to include the linked topics,

for example. 

What happens to topics like this in Word and PDF output?

When you then publish the normal TOC that includes the Overview entry to PDF or Word

you have a logical discrepancy: The TOC entry says to include it, but the topic file include

option says to exclude it. That is OK, because in those formats only topics with TOC entries

are included and the TOC entry setting then has priority. The topic will thus be included

normally.

Topics without TOC entries in additional TOCs

When you use topics without TOC entries  in combination with additional TOCs you

may need to take additional action to ensure that the topic file is included in your output.

An additional TOC acts like an include option for every topic it includes, and by default all

other topics can be excluded. Because of this, topic files that are only accessed by hyper-

179
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links and not by TOC entries may get excluded if you are not careful.

Method 1: Use the compiler option to force inclusion

This is the simplest solution. It tells Help+Manual to automatically include any topic file

that is referenced with a link in your project. Just go to View > Program Options > Com-

pilers and set the Handling of dead links option to Silently include linked topic. This will in-

clude all topic files referenced with hyperlinks, even if they don't have TOC entries. The in-

cluded topic files will be listed in the compiler report.

Side-effect: This will also include topics that were excluded from the TOC with build op-

tions, if there are links to those topics that you have overlooked. Check the compiler re-

port!

Method 2: Use a user-defined include option

Alternatively, you can define an include option  with a descriptive name like NONTOC or

something like that and apply it to the topic file  in the Topic Files section. Then you just

need to activate that option  in the Publish screen when you publish. Then all topics

tagged with that option will be included in your output. 

Creating TOC entries for "invisible" topics in PDFs

PDF is a special case because only topics with TOC entries can be included in PDF docu-

ments. If your project contains "invisible" topics that are normally only displayed with hy-

perlinks from other topics you must add TOC entries for them to be able to include them

in the PDF version of your output. This is very simple to do with the knowledge you now

have:

1. Create TOC entries for the "invisible" topics: Either drag the topic file into the TOC or

create a "new" topic and select the topic ID of the invisible topic with the  browse

button in the Topic ID: field of the new topic dialog. You might want to organize these

TOC entries as one or more special chapters in your TOC. 

2. Apply build options to the new TOC entries so that they are only included in the PDF

version of your output. See See Including and excluding TOC entries above for instruc-

tions.

How to "filter" the TOC display by build/include options

You can use include options to "filter" the display of your topics in the TOC and Topic Files

section of the Project Explorer. This makes it possible for you to see only the topics that
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will be included in a specific build, so that you can preview the results of specific build op-

tions without publishing your project.

1. Apply build options to one or more topics. If you don't do this filtering will not have

any effect! See Conditions and Customized Output  for details. 

2. Select Explore > Filter in Project > Manage Topics and set the filter options you want

to apply. The filter settings are also available from the right-click menu in the Project

Explorer (Explore > Filter).

This works both in the TOC and in Topic Files. This only filters entire topics, it does not

filter conditional text tagged within your topics.

Important Notes:

· The current build settings of topics are shown in the Project Explorer, next to the topic

caption in the TOC. Topics and chapters set to All Builds (the default) will always be in-

cluded, of course – you cannot hide them.

· Filtered topics will be either shown in a different color or hidden completely. This de-

pends on your settings for When filtering the table of contents... in View > Program Op-

tions > General. See Program Options - General  for details on these settings.

See also:
Preventing dead links  (Conditional Output)

Publishing projects with multiple TOCs  (Publishing)

5.15.4 Templates and Skins

In addition to varying the content of your output you will often also want to vary the layout

and appearance of different versions of your project when you publish it. How you do this

and what options are available depends on the output format you are using. 

Templates and skins for Webhelp and CHM

The HTML templates  used in WebHelp and CHM are stored in your project and are

fully editable. You can have multiple templates for topics stored in a single project but

only one version of the templates for the navigation panes (TOC, Index and Search) used

in WebHelp. The multiple topic templates are primarily useful for having different layouts

for different topics within the same project. 

If you have the Professional or Floating license version of Help+Manual you can save all

the templates in your project in a "skin" that you can then apply to other projects to

change their layout. 

Alternative topic page templates:
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The HTML topic page templates define the basic layout of your topic pages in HTML-based

output formats. When you publish your project the template provides everything in the page

except the actual topic content, including headers and footers, any JavaScript functionality

and so on. Normally your project only has one topic page template called "Default" and this is

used for all topics. You can define additional templates and then assign them to individual

topics by selecting the template for the topic in the Topic Options tab on the left of the main

editor window. See HTML topic page templates  for full details. 

If you want to use different topic page templates for individual topics in different versions of

your project without using a skin (see below) you need to use snippets:

1. Create the topic itself in the Project Files > Topics section (not in the TOC). This will

create a topic without a TOC entry, which is what we want here because we are only

using this topic for copying. 

2. Set the build options of the topic to "none" so that the actual file is not included in

your output.

3. Create two or more empty topics in the TOC in the positions where you want to have

the different versions of your topics. 

4. In both topics, insert the topic file created in step 1 as a linked snippet. See Re-using

content with snippets  for full instructions.

5. In the Topic Options tab of each topic, select the HTML page template that you want

to use for that topic.

6. Apply the build options in the TOC to include and exclude the topic versions as re-

quired.

Switching template sets with skins:

Normally, you will want to change the entire layout of your project for different pur-

poses. With Help+Manual Professional you can do this with "skins", which save all the

HTML templates in your project in a special file that you can apply to any project when

you publish it to an HTML-based format. When you do this, all the HTML templates in

the project are replaced with those in the skin. The skin can also include variable defini-

tions, Baggage files and text and paragraph styles.

You can also use multiple HTML topic page templates for different topics in skins,

provided the project you apply the skin to uses the same template names. For example,

if your original project uses HTML topic page templates called Default, PageA and

PageB these will be replaced by the versions in the skin if the skin also contains HTML

topic page templates called Default, PageA and PageB. 

1. Edit the HTML templates in a project to get the layout and effects you want. If

you create multiple topic page templates make sure that their names match

those used in the projects you want to format with the skin. See Using HTML

Templates  for details. 
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2. Select Save As... in the File menu and save the project as a skin. The skin can

also contain variable definitions, text and paragraph styles and Baggage files. If

you include styles, their names must also match those used in the projects you

want to format with the skin.

3. When you publish another project to an HTML-based format select the skin cre-

ated in step 2 by clicking on the Select Skin bar in the Publish dialog. This will

replace the templates, variables, Baggage files and styles in the project with

those from the skin.

See Transforming your output with skins  for more details.

Templates for PDF files

The layout of your PDF output is defined in special layout files called print manual tem-

plates, with the extension .mnl. You can edit and create these templates with the Manual

Designer program included with Help+Manual, which has extensive help and tutorials of

its own. 

Like skins for HTML-based formats, PDF print manual templates can be selected in the

Publish dialog with a single click. This makes it possible to apply a completely different

look and feel and/or corporate branding to a document in seconds. In addition to the

general page layout, the PDF template defines the front and back cover pages, the layout

of the table of contents, additional pages like the Foreword and end notes and intro

pages for top level topics, user-defined pages, headers and footers, page and section

numbering styles and so on.

See PDF and Printed Manuals  for full details and instructions.

Templates for eBooks

Help+Manual can generate two different kinds of eBooks: Windows EXE eBooks and ePUB

eBooks. A number of pre-designed layout templates for EXE eBooks are included. Format-

ting options in ePUB eBooks are quite limited and alternative templates are not an option

because the strictness of the ePUB format means that the templates should not be edited.

See the chapters on ePUB eBooks  and Windows Exe eBooks  in the Publishing sec-

tion for details.
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Word DOCX documents

Word DOCX is not generally a primary choice as a documentation format. If you want to

provide a printable version of your documentation use PDF, if you want to provide an in-

teractive help system use CHM or WebHelp, if you want to provide an eBook use ePUB or

Windows EXE eBooks. 

Even so, you can configure the layout of your DOCX output in Help+Manual very extens-

ively with special DOCX template files that you can create and edit directly in MS Word.

See the MS Word DOCX  publishing chapter for details.

See also:
Templates in Help+Manual

Using HTML Templates

Transforming your output with skins

Publishing

PDF and Printed Manuals

5.16 Peer Review with Annotated PDFs

When you are working on documentation you will often want to get feedback, suggestions

and corrections from colleagues and others. If they have Help+Manual themselves they can

simply add their comments to the project with the comments tool . If they don't, however,

you need a different solution, and that is with a PDF version of your project. 
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PDF Review Plugin (2 minutes tutorial)

You generate a PDF  of the project directly with Help+Manual and distribute that to your

colleagues. When you create the PDF you can include any comments that the project already

contains so that these will be visible in the PDF. 

The reviewers then add comments with the PDF commenting feature. When you get the com-

mented PDF back, you can then go through and implement the suggestions in your project. 

The PDF review plugin makes this even easier

In the past the commented PDF and your project were two separate things that you had

to work on without any connection. The PDF review plugin synchronizes and lines up the

topics and comments in the PDF with the corresponding topics in your project. This makes

going through the review much faster and more efficient.

Support for PDF Annotator

In addition to synchronizing normal PDF comments with your project, the PDF review plu-

gin also supports the excellent PDF Annotator tool that provides much more advanced

commenting and highlighting features than the native capabilities of PDF without the ex-

pensive Acrobat program. You can download a free trial from the PDF Annotator site:

https://www.pdfannotator.com/en/ 

Using PDF Peer Review

Step 1: Publish a PDF version of the project with comments

Even if there are no comments in your project, activate the the option to include com-

ments when you publish the PDF version for peer review. This makes sure that comment-

ing is enabled in the PDF so that any PDF editor with commenting capabilities can add

them. This also disables any passwords and other editing restrictions you may have set.

See the Publishing  chapter if you don't know how to publish PDFs yet.

785

613
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Step 2: Distribute the PDF for comments

Send the PDF to your colleagues for commenting/annotation. When you receive it back

you can use the plugin to synchronize it with your project.

Step 3: Load the annotated PDF in the review plugin

Open your project in Help+Manual and select the PDF Review plugin with the Plugins

tool in the Project Tab. Then click on Load and select the annotated PDF file that you re-

ceived from your colleagues.

The list of comments in the PDF include answers from your colleagues. All the list items

are live links that take you directly to the corresponding comment location in the project

topic when you click on them.

Right-click context menu

If you right-click on a comment in the list you get a context menu with which you can

copy the comment to the clipboard or update it in your Help+Manual project.
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How the review tool works

The review tool displays a list of all the comments found in the PDF with a preview of the

pages below. You can zoom the preview with the +/- buttons. The comments are auto-

matically synchronized with the topic display in the editor on the left. When you select a

comment in the plugin the corresponding topic in your project is automatically displayed

in the editor. The comment icon in the PDF is also highlighted in the preview.

5.17 Backups and Emergencies

As with all computer programs, something will occasionally go wrong while you are working.

Your work is the most valuable part of your computer so you really need to be prepared to be

able to recover it in case something goes badly wrong on your machine.

CTRL+S is your friend!

People who grew up in the early days of the computer revolution automatically press

CTRL+S (save current work) on their computers every couple of minutes, no matter what

program they are working. This is still a very good habit than can protect you from losing

valuable work. We strongly recommend that you cultivate this "old-fashioned" habit. If

you do, you will never need to use the rescue copy feature. 

Rescue copy option appears when you can't save your project

If you are unable to save the project for some reason – for example your project is on a

network drive and you lose the connection – Help+Manual will automatically offer you a

special "Rescue Copy" option. 
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How the Rescue Copy works

When this option appears you can then save a special new copy of the project so that you

don't lose your current changes. This copy will not contain all the topics of the project. It

only contains those topics that you changed since the last save. 

Help+Manual can't save the full project in a rescue situation, because then it doesn't have

access to the main project any more. Instead, it saves YOUR unsaved work from local

memory to an additional Help+Manual project.

How to restore from a Rescue Copy

All the text in your Rescue Copy will be the latest version, so to restore to your main pro-

ject you just need to copy the content of all the topics in the Rescue Copy to the main

project:

1. Open both projects (Rescue Copy and original) in Help+Manual. You may find it easier

to open Help+Manual twice, with one project in each instance, so that you have two

separate windows. 

2. Go through the Rescue Copy and in each topic it contains, click in the editor and press

CTRL+A and then CTRL+C to select and copy the entire topic.

3. Then click in the corresponding topic in the original, press CTRL+A to select everything

and then CTRL+V to replace it with the more recent version from the Rescue Copy. 

4. Repeat steps 2 and 3 for each topic in the Rescue Copy.

Automatic background backup protects you against catastrophic
crashes

While you are working Help+Manual automatically stores your unsaved topics in a backup

copy in the background. If the program is ever forced to quit without saving, for example

by a Windows or computer crash, or by something that makes Help+Manual itself crash

(this is extremely rare), the background copy remains available. When you open the pro-

ject the next time you have access to it, Help+Manual will offer to restore your unsaved

work.

You must accept the restore option the first time it is offered!

If the rescue copy prompt appears, you must accept it immediately if you want to restore

your work. If you don't, the old backup copy will be deleted and a new one will be created

for the current session.
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The topic that was open will not be included

The only edited topic that will not be restored will be the one you were working on when

the crash happened. Saving this would interrupt your work while you are editing, so this is

excluded from the backup copy. So you will lose edits on the last topic you were working

on, but only that. 

Backup copies with multiple instances of Help+Manual

If you are working on an uncompressed HMXP project it is quite possible have multiple in-

stances of it open in separate instances of Help+Manual on the same computer at the

same time, and it is also possible to make different edits in the different instances. Each of

these instances will maintain its own backup copy. 

If a crash happens in this constellation, you need to open the project in Help+Manual

multiple times after the crash, once for each instance that was open. The separate rescue

copies will then be restored on after another. 

DON'T use DropBox, OneDrive or Google Drive for ongoing
backups!

Because of the way Help+Manual works, it is a really bad idea to try to edit projects that

are stored in managed cloud folders like DropBox, OneDrive or Google Drive, particularly

if you are collaborating on projects with other users. These systems will then create a

nightmarish mess of "conflicted copies" of your projects, where it will be difficult or im-

possible to reassemble your work from all the different versions.

It is fine to back up your projects to managed cloud folders, just don't do active editing on

projects in them. 

Ongoing backups with third-party solutions

If you are working on your own or in a small group and you are not using a version con-

trol system (see below) there are a number of systems that perform ongoing backups of

your work in different ways. Ideally, these backups should be in a different location to

your computer.

Online backup services

If you have an Internet connection with decent upload speeds it is a good idea to use an

online backup service like Backblaze, Carbonite or SugarSync. They make online backups
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of all your data while you are working and upload your changes as soon as they happen.

Since they are remote, the chances of losing both your local copy and your backup is very

small.

Alternative backup solutions

You can also use systems like AJC Active Backup, which you purchase once and then con-

figure yourself. You decide where you want to store your backups – it can be on another

drive on your computer, an external drive, a network drive or an online location that you

have access to. Here too, these systems monitor your files continuously and make

backups as soon as you save a new version. 

AJC Active Backup is a program created by one of our talented customers. We have no

commercial affiliation with AJC, we just think it's a terrific product and an excellent backup

solution for Help+Manual projects (ideally uncompressed XML projects in the HMXP

format).

Remote backup with version control

One of the most robust backup solutions you can have is a version control system that

stores a central copy of your project on a server. In addition to saving your project re-

motely, it also saves every single change you have ever made, so you have access to all

the versions of your project throughout its history, including everything you ever deleted. 

Version control is free if you use the excellent Subversion system (SVN), and since it also

works via the Internet, it allows multiple authors to collaborate on projects from remote

locations. See the chapter on Using Version Control Systems  for full details.848

http://www.ajcsoft.com/active-backup.htm


Publishing

Publish your help project into your chosen output format! A help website, a PDF
manual, a Microsoft help file, a Word document or an eBook.

Picture courtesy of pixabay or picjumbo

http://pixabay.com/
http://picjumbo.com/
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6 Publishing

6.1 Publishing Your Projects

To distribute or check your project you need to output it to the help or documentation format

you want to use. We refer to this process is as "publishing". When you publish your project

Help+Manual translates the XML source code of your project into the selected output format.

In some formats it also formats your output using templates that you can create and modify. 

This chapter explains how to publish your project to the output formats supported by

Help+Manual. 

6.1.1 General publishing instructions

Once you have made all your preparations and set your configuration options  for the out-

put format you are using publishing is basically just a question of selecting Publish and

choosing the output format.  

The instructions in this topic are for publishing your projects to a single output format manu-

ally. See Publishing Tasks  for instructions on how to automate publishing multiple projects

and multiple versions of projects in one "job" that you can repeat at any time.

How to publish your project to one output format

1. Save your project, then select Publish in the Project tab: 

644

809
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2. Select the output format from the drop-down list at the top. This will display the op-

tions for that format.

· For details on the options see the reference to the Publish Help Project  dialog. 

3. Check the Output File: field. You can change the default output folder and the file

name if you want. Help+Manual will remember this change next time you publish.

However, if you are publishing to WebHelp we strongly recommend that you accept

the "index.html" file name as that is the best choice for WebHelp in almost all cases.

Variables: You can use a variable instead of a file name in the output field. This should

be a variable defined globally for the entire project, not a single-topic variable. Don't

include the file extension in the variable definition, as that is added automatically by

Help+Manual if it is not present in the output field. So you should enter something

like:

<%OUTPUT_FILE%>.pdf or <%OUTPUT_FILE%>.html.

4. Configure your output options, then click on Publish Now to publish. This can take a

couple of minutes with very large projects.

A report on the publish process including any errors and a list of the files and/or folders

you need to include when you distribute your help  to your users is displayed in a win-

dow. This window contains controls with which you can search, copy, print or save the re-

port to an external HTML file.

1310
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Publishing selected topics only

For test purposes you can publish only the topics that are currently selected in the Table

of Contents pane (TOC). If exported topics contain links to topics not included in your out-

put you may want to take steps to handle this. See Preventing dead links  for instruc-

tions on how to deal with this.

1. Select the topics you want to publish in the TOC pane. You can use Ctrl+Click and

Shift+Click to select multiple topics out of order and sequences of topics. Selecting

chapters automatically selects all the chapters' sub-topics. 

2. Select Publish in the File menu or the Project tab.

3. Click on the Table of Contents bar and select Publish selected TOC items only from the

drop-down list:

4. Select your other publish options, then click on Publish Now to publish.

Using skins in CHM and WebHelp and templates in PDF and DOCX

CHM and WebHelp output:

In the Microsoft HTML Help (CHM) and WebHelp (HTML) output formats  you can apply a

completely different layout and appearance to your published output by choosing a "skin"

file in the Publish dialog. Skins include everything from your project that defines the gen-

eral appearance of your output: Your variable definitions, HTML templates, text and table

styles and your Baggage Files. 

Help+Manual comes with some sample skins in the \Skins folder in the Help+Manual pro-

gram directory. If you have the Professional or Floating license version of the program you

can also save your own projects as skins to apply their appearance to other projects

without additional formatting. 

See Transforming your output with skins  for full details.

1. Select Publish in the File menu or the Project tab. 

2. Then select the skin file you want to apply in the Select Skin section and click on Pub-

lish Now to publish.

984
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See HTML Help  and WebHelp  for more details on preparing your project for these

output formats.

PDF and DOCX output:

PDF and DOCX use templates to publish that define the page layout and other features of

the output documents. These are called Word Templates and Print Manual Templates and

can be selected directly in the Publish dialog. Here too, you can select from a selection of

standard templates included with Help+Manual. 

See Adobe PDF and printed manuals  and MS Word DOCX  for details on preparing

your templates for these output formats.

Filtering your output with include options and "Complete" status

Once you have tagged content in your project with include options you can then "filter"

your published output when you publish. You do this by selecting or deselecting the

checkboxes for the corresponding include options in the Publish settings when you pub-

lish. See Conditions and Customized Output  for details.

Filtering with include options:

· In the Include Options: section at the bottom of the Publish screen, select the options

matching the content you want to include in your output. 

The topics and content tagged with matching include options in your project will be in-

cluded ore excluded from your published output depending you your selections. The op-

tion for the current output format is activated automatically and should normally always

be selected. 

Including content tagged for other output formats

You can optionally select the include options for other output formats if you also want to

include content that is actually tagged for those formats. For example, when you publish

to CHM the CHM include option is selected by default. If you also want to include content

that you have actually tagged to be included only in WebHelp you can do that by manu-

ally activating the WebHelp checkbox as well. 

645 655

677 682

969



617

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Publishing

Filtering by "Complete" status:

This is only relevant if you have actually applied topic status  to topics in the TOC. It al-

lows you to exclude all topics that do not have the status "Complete" from your output,

thus automatically excluding any topics that are unfinished or require review. 

Select the option Topic Status: Complete Only below the Include Options box in the Pub-

lish dialog.

Special case: Include options for eWriter Help

eWriter Help is a special case, because internally they are classed as both eBooks and We-

bHelp. Their content is exactly the same as WebHelp and supports nigh on all the format-

ting and scripting that WebHelp supports. However, they are – or can be – distributed in

the same way as eBooks. Because of this, eWriter is the only output format that has two

active include options for including and excluding content: both EBOOK (eBooks) and

HTML (WebHelp).

If you look at the Include Options box in the Publish dialog when you publish to eWriter

you will see that both the WebHelp and the eBook options are selected. This means that

an eWriter Help file will normally include any content tagged for either WebHelp or

eBooks.

Including content in eWriter Help only

If you want content to be include only in eWriter Help you need to nest two conditions

around it, like this:

IF_HTML IF_EBOOK ... END END

Then it will only be included in eWriter Help and nowhere else.

Include options for topics and chapters 

Topics and chapters will be included in eWriter Help if they are tagged with either We-

bHelp or eBook. 

Test-publishing Asian languages on non-Asian Windows

Normally, you cannot publish help projects written Asian languages on non-Asian versions

of Windows because the necessary language settings don't match. However, if you just

want to do a quick test publish and don't have a Windows version in the matching Asian

373
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language there is a configuration setting that will allow you to do this.

· Go to View > Program Options > Compilers and activate the option Tolerant handling

of Asian languages. 

Some features may not work correctly in the resulting help file in HTML Help if the lan-

guages of your Windows version and the help file don't match (Search, Keyword Index)

but you will be able to complete the compilation and view the CHM file, which is sufficient

for testing.

To produce a finished CHM for distribution you must publish it on a copy of Windows

with a matching system locale. 

See also:
Publish Help File  (Reference)

Conditions and Customized Output  

6.1.2 Publishing instructions by format

The basic publishing procedure in Help+Manual is the same for all output formats: You select

Publish, choose the output format and for some formats you choose a layout template or skin

option. The only exception is generating a printed manual directly, which uses a different user

interface. 

The list below lists some individual considerations for each output format.

See Automating Publishing Jobs  and Command Line Publishing  for details on publish-

ing multiple projects and/or output formats in a single operation.

Using variables in the output file field

You can use a variable instead of a file name in the output field. This should be a variable

defined globally for the entire project, not a single-topic variable. Don't include the file ex-

tension in the variable definition, as that is added automatically by Help+Manual if it is

not present in the output field. So you should enter something like:

<%OUTPUT_FILE%>.pdf or <%OUTPUT_FILE%>.html.

Publishing WebHelp (HTML on an intranet or Internet web server)

Use WebHelp to make your documentation accessible on the Internet and local intranets

in your company network. It provides a fully interactive interface with a table of contents,

keyword index and search and supports dynamic features like expanding sections, popup

information windows and videos.

1310
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Check that your HTML Export Options are configured for high-resol-

ution devices

You now need to consider high-resolution 4K monitors and devices like the Microsoft Sur-

face and Lenovo Yoga Pro when you are planning your WebHelp. If you don't do this the

text and other elements will often be too small to read on these devices. If you set the

configuration options described below Help+Manual will automatically adjust everything

else so that it displays correctly on high-resolution displays.

1. Open your project in Help+Manual and in the Project Explorer navigate to Configura-

tion > Publishing Options > WebHelp > HTML Export Options. 

2. Set Font Size Encoding to: em (1em = 100%).

3. The Font size of style "Normal" setting is grayed out for ems/rems because it is only

used when font encoding is set in percent. 

Once the base font encoding is set to ems all elements in your topic files will then auto-

matically be adapted for correct display on both normal and high-resolution devices and

monitors.

Select a skin to define your WebHelp layout

Help+Manual projects include standard HTML templates for WebHelp but these are very

basic and you will normally want a more attractive layout. To get this you just need to se-

lect a skin with the Select Skin option in the Publish dialog (see below). Click on the bar

below the heading and select one of the skins from the previews displayed. It is generally

better to select one of the skins with the word "integrated" in its name. 

If you want even more advanced skins, check out the options available in the 

Help+Manual Premium Pack add-on.

Publish to WebHelp

1. Open and select your project in Help+Manual. Then select Publish in the Project tab,

then click on Publish Format at the top of the page and select WebHelp. 

2. Click on the  browse button in the Index page: field and choose an empty output

folder. Leave the index.html file name unchanged. This should always be used as the

main page for WebHelp.

3. Click on the Select Skin bar and select a WebHelp skin. 

4. Activate the Display file when publishing is complete option so that Help+Manual will

open the WebHelp with its integrated web server after publishing so that you can view

it.

5. Select Publish Now! at the top right to generate and view WebHelp.

https://www.helpandmanual.com/products_hm_pluspack.html
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Important information for publishing WebHelp

Publishing WebHelp is almost the same as publishing any other format. However, since

you are actually creating a website consisting of a large number of individual files there

are a couple of additional points you need to bear in mind:

Always publish to an empty folder:

Always publish WebHelp to its own folder, which should preferably be empty. A large We-

bHelp project can consist of hundreds of files! The program will suggest creating a folder

called \HTML inside your project directory, which is a good choice.

When you publish to WebHelp you can the use the Delete all files in output folder option to

clear the output folder before publishing. You don't need to use this during normal working

but it is a good idea to select it before creating a build that you are going to distribute.

Clearing the output folder makes sure that no old files for topics that you have deleted are in-

cluded in your output unnecessarily. In addition to taking up space these files will also be in-

dexed and will appear in the full-text search (see below).

Clearing the output folder is also essential when you change the name of the project, as this

changes the names of a number of important files that are components of your WebHelp. If

you don't clear the folder the old files will remain in place and may cause problems.

Timestamps and clearing the output folder: 

You don't need to worry about the timestamps of your output HTML files when you clear the

output folder. The HTML file timestamps are always set to the last time the topic was edited,

not the time when the project was published.

Testing WebHelp locally:

Help+Manual activates its own local web server when you publish to WebHelp. This makes it

possible to test your WebHelp output with the same functionality as on a web server without

having to upload your files to the server. However, note that this server is HTTP only. It does

not include support for server-side scripting languages like PHP. If you activate the PHP or

ASP versions of WebHelp search  you must use a full web server with PHP or ASP support

to test the search functionality. 

Testing in other browsers:

If you want to test your WebHelp in other browsers, let it open in your default browser first.

Then copy the URL from the Address: bar of your browser and paste it into the Address: bar

of the other browser. As long as Help+Manual is still open the integrated web server will be

available for the other browser as well. 

Full-text search issues:

1428
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When you are publishing the new WebHelp with full-text search  it's important to

understand that the search index is not generated from your project files or from the

files on your server. It is generated from the HTML files on your local computer, after

the HTML files have been generated. 

· If the output directory contains any other HTML files these will be included in

the index.

To prevent this do not place any other files in the output directory. Since the index is

generated locally you can upload other files to your server separately, then they will

not be included in the index.

· Outdated HTML files will be included in the index if you don't delete them.

To ensure that the HTML files of outdated topics are not included in the index use

the Delete all files in output folderoption in the Publish dialog to delete the contents

of the output directory before publishing. This will not cause problems with the

timestamps of topic files that have not been changed – the HTML file timestamps are

always set to the last time the topic was edited, not the time when the project was

published.

· PHP and ASP search require a full web server for testing.

Help+Manual's local web server activated when you publish does not include server-

side scripting support. If you activate the PHP or ASP versions of WebHelp search

you must use a full web server with PHP or ASP support to test the search functional-

ity. 

Publishing eWriter Help files

The modern alternative to CHM help files

Help+Manual's eWriter format is the modern alternative to CHM help files for Windows

software documentation. It has both a standalone viewer that installs automatically from

the Windows Store and a standard Windows viewer that you can install with your software

for Windows 7 and earlier. EWriter can be fully skinned with WebHelp skins and supports

context-sensitive help.

An eWriter Help file is WebHelp stored in a single file that supports HTML5, CSS3 and

JavaScript without restrictions. You can use WebHelp skins for it to get all the layout and

formatting options available in WebHelp. At the same time, it supports context help calls

from applications in the same way CHM help files. The eWriter format combines the bene-

fits of CHM and WebHelp and eliminates many disadvantages of both. See here  for

more information on this.

1428
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Configuring and using eWriter Help

See the eWriter chapter  in the Configuring section for full information on configuring,

using and distributing eWriter books. See Links & Context Help  and eWriter for Soft-

ware Help  for additional information you will need if you are going to deploy eWriter

for your software documentation. 

Use the .ewriter file extension for files distributed on their own

Use the the standard .ewriter file extension if you are going to distribute eWriter Help

files on their own. This extension is registered in the Windows Store and makes it possible

for Windows 10 and 11 users to get the viewer from the Windows Store when they open

an eWriter file. 

Users on older versions of Windows and MacOS users can get the free installers from our

eWriter page:

https://www.helpandmanual.com/ewriter/ 

Configure your eWriter viewer settings

EWriter books contain settings that configure the viewer's appearance and behavior. Be-

fore publishing to eWriter, check out and set up the configuration options. See here  for

details and instructions. You can configure a main menu and right-click context menu, se-

curity and password options, an expiry date for the help file and some other features.

You need to use a WebHelp skin for your output

Since eWriter is really WebHelp, you need to either configure your WebHelp templates in

your project or choose one of Help+Manual's ready-to-use skins, or one of the dedicated

eWriter skins in the Premium Pack add-on. See here  for details on configuring your

WebHelp templates and here  for more details on skins. 

Publish your eWriter Help

1. Open and select your project in Help+Manual. Then select Publish in the Project tab,

then click on Publish Format at the top of the page and select eWriter Help. 

2. Choose an output folder and file name for your eWriter Help file in the Output File:

field. The extension you give your output file determines the type of eWriter Help file

that will be generated:

a. Data eWriter Help file: Use the standard .ewriter extension or your own cus-

tom extension for your software documentation .
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b. Standalone EXE eWriter Help file: Use the .exe extension to generate a stan-

dalone eWriter Help file with an integrated viewer. This only works on Windows.

3. Click on the Select Skin bar and select a WebHelp skin. If you are selecting an edited

skin for the first time you will need to click on the Open Skin option at the top of the

menu displayed to navigate to the skin file and select it.

4. Look in the Include Options box and make sure that both WebHelp and eBook are se-

lected. Since eWriter combines aspects of both these formats, both these options

need to be active. 

5. Select Publish Now! at the top right to generate the eWriter Help file.

Microsoft HTML Help / CHM

Microsoft CHM files used to be the standard documentation format for user applications

on Windows. However, even though they still work in current Windows they are now ob-

solete. They look as though they belong in the old world of Windows 98, and they do: Mi-

crosoft has not developed the CHM system at all since it was released with Windows 98.

They have not even fixed any of the many bugs. 

The Microsoft CHM viewer doesn't support Unicode or high-resolution displays, and its

appearance cannot be changed in any way. It uses a restricted and quirky version of Inter-

net Explorer to render HTML and has problems with modern HTML5, CSS3 and scripting.

CHM files are blocked on network drives and can only viewed at all when installed on a

local computer drive together with the software that is calling them.

Use the new eWriter format instead of CHM!

If you are not forced to use the obsolete CHM format for some reason, we strongly re-

commend switching to the eWriter format  for local Windows software documentation.

It has a viewer that installs automatically from the Windows Store, supports context-sens-

itive help and is fully skinnable with WebHelp skins.

Make sure you have the Microsoft CHM compiler installed

If you must use CHM, Help+Manual needs this compiler to convert your project output

into a CHM file. It is included in the free Microsoft HTML Help Workshop package. If you

have not installed HTML Help Workshop yet, see here  for instructions and a download

link.
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Publishing projects in non-Latin languages to CHM

If your project is in a non-Latin language like Chinese, Georgian, or Thai, you need to set

language of the System Locale of your Windows system to match that of the project lan-

guage before publishing. Otherwise the characters used in that language won't be dis-

played correctly in the published CHM file.

In current Windows versions this is accessed in Settings > Time & Language > Region >

Additional date, time & regional settings. Then select Region in the new dialog that

opens and you will find the locale setting in the Administrative tab. Alternatively, you can

open the Control Panel directly and select the Region option. Your user account must

have administrator permissions to configure this setting and you must restart Windows

after changing this setting to apply it.

See CHM in Non-Latin Languages  to learn how to publish multiple projects to different

non-Latin languages using CHM without having to restart Windows for each project. 

Check that your HTML Export Options are configured for high-resol-

ution devices

The Microsoft CHM Viewer in Windows uses an old HTML rendering engine that has spe-

cial requirements. Help+Manual can automatically configure your CHM file so that it dis-

plays correctly on high-resolution 4K monitors and devices like the Microsoft Surface and

Lenovo Yoga Pro. If you don't do this the text and other elements will often be too small

to read on these devices. 

1. Open your project in Help+Manual and in the Project Explorer navigate to Configura-

tion > Publishing Options > MS HTML Help > HTML Export Options. 

2. Set Font Size Encoding to: pt Points.

3. Select the checkbox for Make pixel sizes relative to monitor resolution (4K display com-

patibility)

All elements of your CHM file will then automatically be adapted for correct display on

both normal and high-resolution devices and monitors.

Publishing your project as a HTML Help/CHM file

1. Open your project in Help+Manual. Then select Publish in the Project tab, then click

on Publish Format at the top of the page and select HTML Help (.chm) as the output

format. 

2. Choose an output folder and file name for your CHM file in the Output File: field. 

3. Optional: Click on the Select Skin bar and select a skin for the topic page layout in

your PDF. 

629
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Note that skins can only style the topic frame and page in CHM files. The CHM viewer

is a Microsoft component and part of Windows and its appearance cannot be

changed. However, you can configure its behavior and features in Configuration >

Publishing Options > HTML Help. See here for a reference to these options .

4. Click on Publish Now at the top right to generate your CHM file. 

Publishing Microsoft Word DOCX files

Step 1: Publish the project to DOCX

1. Open your project in Help+Manual, select Publish in the Project tab, then select Mi-

crosoft Word as the publish format at the top. 

2. Select an output location for the DOCX file in the Output path + filename: field. Use

the  browse button to select a folder for the output.

3. Click on the Select Word Template bar and select the .docx document layout tem-

plate for your Word DOCX output. See the MS Word DOCX  chapter for details on

how to set up document layout templates for Word. 

Step 2: Activate the TOC, Index and Table of Figures in the DOCX file

These dynamic items are not initialized automatically in Word. When you publish, they are

still just placeholders. You need to open the Word file and initialize them to populate

them with their contents.

1. Open the new DOCX file in Word and locate the table of contents placeholder. 

2. Right-click on the placeholder and select Update Field in the context menu to initialize

the table of contents. Alternatively select the References tab in Word and select the

Update Table option in the Table of Contents section. 

Repeat steps 1 and 2 for the Keyword Index and Table of Figures. The Update Table com-

mands for these items are in the Captions and Index sections of the References tab in

Word. 

Publishing an ePUB eBook for iPad and other eBook readers

Make sure you have an ePUB viewer installed for previewing

See this topic  for information on getting and installing a free ePUB viewer program.
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Configure your ePUB settings

Before publishing an ePUB eBook you need to enter some information that is required to

make the eBook valid. So follow the instructions in this topic  and configure these set-

tings first. Please also note that some content, large tables and complex formatting are

not supported in eBooks. See this topic for details . 

Publish your ePUB eBook

1. Open your project in Help+Manual. Then select Publish in the Project tab, then click

on Publish Format at the top of the page and select ePUB. 

2. Choose an output folder and file name for your ePUB eBook in the Output File: field. 

3. Select Publish Now! at the top right to generate the ePUB eBook.

Publishing a Kindle/Mobi eBook for Amazon Kindle eBook readers and
apps

Make sure you have an Mobi viewer installed for previewing

See this topic  for information on getting and installing a free Mobi viewer program for

viewing the eBook on your computer.

Make sure you have the Amazon Kindle eBook compiler installed

You need the Kindle eBook compiler from Amazon to create Mobi/Kindle eBooks with

Help+Manual, which automatically uses the compiler to create the Kindle eBook with your

project. See this topic  for the download link and instructions.

Configure your Mobi settings

Before publishing an Mobi eBook you need to enter some information that is required to

make the eBook valid. Mobi/Kindle eBooks share the same settings with ePUB eBooks. So

follow the instructions in this topic  and configure these settings first. Please also note

that some content, large tables and complex formatting are not supported in eBooks. See

this topic for details .

Publish your Mobi eBook

1. Open and select your project in Help+Manual. Then select Publish in the Project tab,

then click on Publish Format at the top of the page and select Kindle/Mobi. 
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2. Choose an output folder and file name for your Kindle/Mobi eBook in the Output File:

field. 

3. Select Publish Now! at the top right to generate the Mobi eBook.

Publishing an Adobe PDF document

Help+Manual generates PDF documents both with interactive features (hyperlinks, click-

able table of contents etc.) and in "plain" form, which is more like a simple representation

of a printed page on the screen. Plain PDF documents are ideal for printing. It's a good

idea to create one for those users who prefer to print all or part of their documentation,

because printed PDFs are always much better than printed topics from other help formats.

Choose and configure a PDF template

In addition to the content from your project's topics, you also need page definitions and

additional pages to create a PDF document. In addition to the page margins, headers and

footers and page numbers, you will generally also want things like a cover page, a fore-

word, a print-style table of contents, a keyword index at the end of the document and so

on. All these things are defined in a separate document we refer to as a PDF print manual

template, which you can select and edit with the Manual Designer tool in the Project tab. 

Help+Manual comes with a set of pre-designed PDF templates that you can use right

away without editing them. However, you will need to add your own personal information

to these templates to use them for production output. See Using PDF templates  to

learn how to access, edit and choose a PDF template.

Configure the global PDF options in your project

In the Project Explorer, navigate down to Configuration > Publishing Options > Adobe

PDF and examine and change the settings there as necessary. See here  for reference

information on all the options available there. See the main PDF and Printed Manuals

chapter for more detailed information on PDF.

Publish your project as PDF with the template

1. Open and select your project in Help+Manual. Then select Publish in the Project tab,

then click on Publish Format at the top of the page and select PDF as the output

format. 

2. Choose an output folder and file name for your PDF file in the Output File: field. 
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3. Click on the Select Print Manual Template and select your template. If you are select-

ing an edited template for the first time you will need to click on the Open Skin option

at the top of the menu displayed to navigate to the template and select it.

4. Select Publish Now! at the top right to generate the PDF file.

Generating a printed manual directly

Choose and configure a PDF template

Help+Manual generates printed manuals by creating a temporary PDF and printing it. You

need to choose and prepare a PDF print manual template for printed manuals in the same

way as for producing a PDF. Both printed manuals and PDFs can use the same templates.

See the instructions for publishing PDFs above for details.

Choose your printing options and print

1. Open and select your project in Help+Manual. Then select Print Manual in the File

menu. 

2. Select Print or Preview at the top left depending on whether you want to print directly

or view a preview first. 

3. Select the printer and the print manual template at the top, then select your settings

for printing. See Printing user manuals  for detailed instructions and Print Manual

for a reference to all the available options.

4. Select Print or Preview at the top right to generate the printout or view the preview.

Publishing MS Visual Studio Help for .NET development projects

Please note that Visual Studio Help 2008 and 2010 (MS Help 2.0 and 3.0) is a special case.

Please see the special Visual Studio Help  chapter in the More Advanced Procedures

section for details.

Visual Studio Help is a special help format that is only used for documenting program-

ming components in Visual Studio .NET. It cannot be used for documenting normal ap-

plication programs and if you are not a VS .NET programmer you don't need to know any-

thing about it!

Support for Visual Studio Help is only available in the Professional and Floating license

versions of Help+Manual.

800 1290

1464



629

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Publishing

6.1.3 Publishing projects with multiple TOCs

If you have created a project with more than one TOC you will also want to choose the TOC

you want to use in your output when you publish. You can select this directly in the Publish

dialog:

Topics included when you publish with a specific TOC

When you select an additional TOC to publish with, all the topics in that TOC will be in-

cluded. In addition to this, topic files linked to in the TOC may also be included in HTML-

based output formats, depending on your settings. See Multiple TOCs  for more details

on managing this.

Publishing with a selected TOC in tasks and from the command line

Publishing tasks

You can select your additional TOCs in the Publishing Task Manager  in the same way

as you do when you are publishing manually.

Command line publishing

You can specify additional TOCs in your command line  directly with the /TOC= switch.

See also:
Multiple TOCs

6.1.4 CHM in Asian Languages

The Microsoft HTML Help / CHM help system is very old. It hasn't been updated significantly

since it was originally released with Windows 98. In addition to other restrictions, this means
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that it doesn't support modern Unicode text encoding. It encodes Asian languages like

Chinese, Japanese, Korean and Thai using the old "double-byte" system. 

CHM needs Windows configuration to publish non-Latin languages

Double-byte encoding works fine, but only with additional support from Windows. You

need to have the "system locale" of your Windows system set to the same language as

that of the project you are publishing to CHM. If you don't, the entries in the table of con-

tents will only display random characters for many letters and the search won't work. 

The problem with multiple output languages

This is just about acceptable if you are only publishing a single CHM to a single Asian or

other non-Latin language, even though it is annoying to have to restart Windows to

change the locale setting. It becomes a real problem if you have different versions of your

projects in different languages. The need to restart Windows for each language makes it

impossible to build all your different versions in a single, efficient batch process.

It used to be possible to use Microsoft's "AppLocale" system to solve this problem, be-

cause it could change the locale on the fly during a batch process. However, this no longer

works. It was only designed for Windows XP and Server 2003, and Microsoft terminated

support for it in 2016.

The solution: Windows user accounts for each language

There is a way around the problem: If you set up multiple Windows user accounts, each

account can have a different system locale. Also, in a batch file you can execute applica-

tions as a different user by using the runas directive. So if you set up a Windows account

with the corresponding locale for each language you are publishing to, you can then pub-

lish multiple non-Latin CHMs correctly from any other account by using runas in your

batch file to execute the publishing operations under the user account with the correct

locale.

Step 1: Set up multiple locale accounts for CHM publishing

You need to set up separate Windows user accounts for each non-Latin language you are

going to use for CHM output, and set the system locale for each account to the corres-

ponding non-Latin language. We are going to use Chinese as an example. All these ac-

counts need to be on the computer where the publishing is going to be performed, of

course.

1. Create a new Windows user account with a descriptive user name. Let's say this ac-

count is going to be cn_user. 

https://en.wikipedia.org/wiki/AppLocale
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2. Include a password for the account. 

3. Log into the new account and configure the system locale to the Chinese variant you

will be using for this documentation. In Windows 10 this is accessed in Settings >

Time & Language > Region > Additional date, time & regional settings. Then select

Region in the new dialog that opens and you will find the locale setting in the Admin-

istrative tab. Alternatively, you can open the Control Panel directly and select the Re-

gion option.

4. Log out and log back in to your regular account. Then repeat steps 1-3 for each lan-

guage you want to use.

Step 2: Execute the batch publish operation via runas

Important: If you are not yet familiar with command line and batch publishing please first

study the Command Line Publishing  chapter.

You are going to need to enter the account password manually the first time you do this,

so you start by executing a single command line for each language. After that you can

combine the commands for all operations in a single batch file.

You just need to prefix the normal command line with the runas directive and its two es-

sential parameters, like this:

runas /savecred /user:cn_user "<path>helpman.exe <path>pro-
ject.hmxz /chm=<path>project.chm"

Runas switches:

The /savecred switch is needed to save the password so that it will be available for later

batches. (There is no way to include the password in the command line.) The /user:

switch specifies the user account name. 

Essential quote characters and escaping

The entire Help+Manual command sequence must be enclosed in double quotes (high-

lighted above). If your paths or other components require quotes because they include

spaces you must escape those quotes with a backslash, like this:

runas /savecred /user:cn_user "helpman.exe \"my pro-
ject.hmxz\" /chm=\"my project.chm\""

Run once to save the password

Run each command line once on its own. The console will open and prompt you to enter

the password, which you must do blind, without seeing the password text or placeholder

816
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characters. The /savecred switch will save the credentials so that you don't need to

enter the password manually next time. 

Repeat this for each language, executing the single command line on its own and entering

the password.

Step 3: Combine your command lines to a single batch

Once you have published each CHM once as described above to enter all the passwords

you can build a single batch file for all your CHM versions in all languages. Just enter all

the command lines in a single .cmd or .bat file, with each command line on a separate

line in the file. Then you can execute the batch file from your regular Windows account

and each one will be compiled with the correct locale without you having to change the

locale on your computer or restart Windows.

6.1.5 Microsoft help compilers

The Microsoft HTML Help and Visual Studio 2008 Help (MS Help 2.0) formats are generated

with free compilers available from Microsoft (Visual Studio Help 2010/MS Help 3.0 does not

require a compiler). If you do not have these compilers installed you need to install them be-

fore you can publish your projects to these formats.

After installing the help compiler go to View > Program Options > Compilers and make sure

that the path to the compiler files are correct. See Program Options - Compilers  for de-

tails. 

The HTML Help compiler:

If you are still publishing to the obsolete Microsoft CHM/HTML Help format you need the

Microsoft CHM compiler. You can download Microsoft HTML Help Workshop with the

HTML Help compiler from the EC Software website here:

 https://www.helpandmanual.com/downloads_mscomp.html

Incorrect message displayed during install:

HTML Help Workshop is an ancient program that Microsoft has not updated since it was

released with Windows 98. When you install it you will see a confusing message telling

you that your computer "already has a newer version of HTML Help". This message is an

error in the installer. HTML Help Workshop and the compiler have still been installed cor-

rectly. The message just refers to the old components for displaying HTML Help in Win-

dows, which have not been needed since Windows 98.

1268
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Check the reference to the compiler after installing:

After installing HTML Help workshop, open Help+Manual and go to View > Program Op-

tions > Compilers  and make sure that the reference to the CHM compiler points to the

location where you just installed HTML Help Workshop.

The Visual Studio Help 2008 / MS Help 2.0 compiler

The HXS format is not a help format for normal user applications and it cannot be dis-

played at all on most users' normal Windows systems. It can only be used for document-

ing Visual Studio .NET components, in combination with the Visual Studio 2008 .NET pro-

gramming package. You will only be  able to use this format if you are programming .NET

components with Visual Studio 2008.

The MS Help 2.0 compiler tools can be downloaded from Microsoft with the Visual Studio

Help Integration Kit, which is also known as the VSHIK, but they cannot be used without

the Visual Studio .NET package. You will need to search for the VSHIK on Microsoft's

MSDN site as they frequently change the download location for this kit. 

Visual Studio Help 2010 / MS Help 3.0 (no compiler required)

The MSHC format is the successor to MS Help 2.0/HXS for Visual Studio 2010. It does not

require a compiler, MSHC output is generated directly by Help+Manual. However, it too is

only relevant for Visual Studio 2010 .NET programming components. It cannot be used to

document normal applications and is not relevant outside of the Visual Studio 2010 pro-

gramming package.

See also:
Customize - Compilers

6.1.6 Publication checklist

Before publishing and distributing your files there are a few things you should check because

they are quite easy to forget:

Title and copyright information:

Have you set the project title, author and copyright information? Settings Here

Help window titles:

Have you set the correct titles for your help window title bars? Settings Here
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Language settings:

Have you set the correct language settings for the language of your project? This is partic-

ularly important if you are using languages requiring special Unicode character sets. See

International languages setup  for details.

Special requirements for ePUB and Kindle Mobi eBooks

General information

The ePUB and Kindle/Mobi eBook formats are excellent platforms but they are also more

restrictive than some other formats. They are designed to be more like a book than an

electronic document. Also, eBook readers tend to have small pages and large print and

the print size can be changed by the user, and so the kind of layout you can achieve on

your pages is very limited. This format thus has some special requirements and restric-

tions.

Please also study the information on ePUB and Kindle eBooks in the Configuring Your

Output  and Publishing Formats  and Configuration Settings  chapters before pro-

ceeding.

Free Calibre viewer program

Before publishing to ePUB and Kindle/Mobi, first visit the  Calibre eBook viewer down-

load page and install the free Calibre eBook reader and viewer software. This is essential

because without it you will not be able to preview your eBooks automatically after you

have created them. There are other readers for Windows, but Calibre is excellent and free

and we can recommend it highly. We can no longer recommend Adobe Digital Editions

for this purpose. 

Get the Kindle compiler with 

You need the free Kindle compiler from Amazon to be able to publish Kindle/Mobi

eBooks. This compiler is included in the Amazon Kindle Previewer package, which you can

download here:

Download the Amazon Kindle Previewer

Important: Do NOT try to install the Kindle Previewer in the Program

Files folder!

143
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Don't change the default installation location of the Kindle Previewer

package! If you do, it will not work correctly and you will get all kinds of

errors. Because of the way this Amazon program works, it absolutely

needs to be installed in your standard user account directory in the loca-

tion that Amazon specifies, otherwise it will not have the necessary write

permissions while it is running.

Once installed, H+M should find the Kindle compiler automatically. If you have problems,

you can set the location automatically in View > Program Options > Compilers. The

standard location for the compiler is:

Kindle Previewer version 2:

C:\Users\YourUserAccount\AppData\Local\Amazon\Kindle Pre-
viewer\lib\kindlegen.exe

Kindle Previewer version 3:

C:\Users\YourUserAccount\AppData\Local\Amazon\Kindle Previewer
3\lib\fc\bin\kindlegen.exe

Names of modular projects:

When you are using runtime merging  for CHM files the project filenames and the out-

put filenames of the CHM files must be identical. The references between the child and

the master help files are based on the filenames and if project and output filename don't

match the references will be invalid. 

If you want to change the name of the output file in the Publish dialog you should also

change the name of the entire project to match, using Save As... in the File menu.

Dead links caused by excluded topics

You may have dead links in your project if you have excluded topics from your output

without taking steps to deal with links to the topics that are not present in your output.

You can configure Help+Manual to deal with these dead links automatically in two differ-

ent ways, see Program Options - Compilers  for details. 

These automatic options are useful for a quick fix but it is generally better to use condi-

tional text tags to exclude the links and replace them with alternative text when necessary.

See Preventing dead links  for detailed instructions.
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Linked snippets:

Are you using linked snippets (snippets linked to topic files or external files)? If the source

files are in your current project you need to make sure that they will not be included in

your output, otherwise they will be exported too in electronic help formats and the user

will be able to find them with Search and the Keyword Index (if the snippet files also con-

tain keywords). 

Select the  tab of the each source topic and deselect all the options in Builds which include

this topic. See Re-using content with snippets  for details.

Notes and other information you want to exclude:

Does your project contain any author's notes and other "production information" that

users shouldn't see? It's a good idea to use Comments & Bookmarks  feature for in-

formation like this to ensure that it isn't included in the output. You can also exclude in-

formation from your output with Conditional Text .

See also:
Configuring Your Output

6.1.7 Distribution files

When you publish your output a report is displayed in a window with a reminder of the files

and/or folders that you need to distribute to your users. Below is a summary checklist of the

files you normally need to distribute for each output format supported by Help+Manual. 

External files referenced in your project

In addition to the files actually generated when you publish your project, remember that

you also need to distribute any external files referenced or linked to in your project – for

example PDF files linked to in a CHM help file, which need to be stored in the same folder

as the CHM. This is easy to forget. 

HTML Help (CHM):

HTML Help is published to a single CHM file containing everything needed for the fully-

functional help. You will only need to distribute multiple files if you are creating a modular

project  with multiple help files or if you are accessing additional external files in your

help, for example with file links . If you do access and distribute external files with HTML

Help you must store them in the same directory as the CHM file. Links to external files

with path information will fail on many (but not all) users' computers because of uncorrec-

ted bugs in the Microsoft HTML Help viewer that is an integral part of the Microsoft Win-

dows operating system.
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WebHelp (HTML): 

WebHelp is actually a self-contained website. Like any website it consists of a large num-

ber of separate files, including HTML files, graphics files, JavaScript files and other files all

stored in a single folder. If you have a large help project your WebHelp can easily consist

of hundreds of files. You must upload the entire output folder including all the files it con-

tains to your server for WebHelp to work properly! Also, you must upload all the files to

the same directory! Do not make any changes to these files. For example, do not edit or

change the case of file names.

If you are distributing any additional files with your WebHelp you must add them to the

directory manually, or add them to the Baggage Files  in the Project Explorer (then they

will be exported automatically).

HM2Go tiny web server for local WebHelp:

If you want your WebHelp to be opened locally without a server (for example WebHelp on

CDs and DVDs), Help+Manual has a special mini server that you can distribute with your

help for better performance. See HM2Go - mini server for local WebHelp  for details. 

Adobe PDF:

Adobe PDF output always consists of a single .pdf file. It is also possible to embed refer-

enced files  in the PDF file.

eBooks:

ePUB eBooks consist of a single file with the .epub extension. This file is actually a zip

archive that contains the XHTML and XML files that make up the ePUB eBook.

Kindle/Mobi eBooks consist of a single file with the .mobi extension. This is also an

archive, but has a proprietary Amazon format.

eWriter Help consists of a single data file that can have the extension .ewriter or an

extension defined by the user. It uses a standalone eViewer viewer that can be installed

along with your documentation, or by the user. eWriter Help files with the standard

.ewriter extension can also be installed by the eViewer application available on the

Windows Store, which the user is prompted to install when they double-click on an

.ewriter file. The eViewer is also available for MacOS.

Optionally, eWriter Help can also be generated in an.exe file that contains both the help

content and the viewer program needed to display it. This file is completely self-contained

and it is the only file you need to distribute. However, it is now deprecated because of the
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increasing security problems involved in distributing documentation in executable files.

See eWriter Help  for more details on the benefits of the eWriter format.

MS Word DOCX:

MS Word DOCX is output to a single .docx file. If the file contains images the graphics

files are embedded directly into it, as they are in Word. 

Visual Studio Help 2008 & 2010 (MS Help 2.0/3.0):

Please note that these formats are not designed for general help for user applications!

Visual Studio Help is only used to document programming components in Visual Studio

.NET. This help format is irrelevant for normal help and documentation applications.

Visual Studio Help 2008 (MS Help 2.0/HXS)

Help 2.0 is normally output to a single, self-contained .hxs file. This is the only file you

need to distribute. However, you can also choose an option to create both an .hxs file

and a separate .hxl file in Configuration > Publishing Options > Visual Studio Help >

Namespace & Options . 

Visual Studio Help 2010 (MS Help 3.0/MSHC)

Visual Studio Help 2010/MS Help 3.0 consists of a single file with the extension .mshc.

This is actually a zip archive and it can be unpacked with any zip utility, just like MS Word

.docx files. The compiled MSHC file must then be installed in Visual Studio with the

Visual Studio Help Manager. Please consult the Visual Studio documentation for details. 

See also:
Help Formats  (Reference)

6.1.8 Transforming your output with skins

You may already be familiar with the concept of "skins" from other programs: You select a

skin file and the appearance and layout of the entire program is transformed in seconds.

Help+Manual enables you to do this with your HTML-based output. You can save your entire

design with all its HTML templates and relevant HTML settings in a .hmskin file. You then se-

lect this file when you publish to apply the layout to the current project without changing any

of the project's own settings.

Please note that you can only save your own projects as skins if you have the Professional or

Floating license version of Help+Manual. Basic version users can use skins without limitations

and edit existing skins (for example skins from the Help+Manual Plus Packs) but they cannot

create new skins from their own projects. 

Productivity Tip
Skins can only be used for HTML-based output
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formats. You can style your PDF files and printed

manuals with print manual templates , which work

in the same way as skins. Word files use DOCX tem-

plates .

How to use skins - try it now!

1. Open a project of your own, select Publish in the Project tab, then select WebHelp or

HTML Help as the output format. 

2. On the Publish page  click on the drop-down menu in the Select Skin section and

select one of the standard .hmskin files in the Skins folder in the Help+Manual pro-

gram directory. You can also select the Open Skin... option to select a skin file directly.

When you publish your output it will have the "look and feel" applied by the skin. You

didn't have to do any design work at all! Cool, no?

How to create a skin file

Skin files contain everything you need to style your HTML-based output: Text and table

styles, user-defined variables, your Baggage files (template graphics and logos), HTML

page templates and all the settings and templates for WebHelp. You can turn any project

into a skin file just by saving it as a skin and you can edit skin files in Help+Manual, just

like normal projects.

1. Open a project with a design that you want to use for other projects. 

2. Select Save As... in the File menu and choose the Skin XML File option.

3. Choose a place to save the skin, enter a name and save.

4. You will be asked which configuration components of your project you want to include

in your skin.
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Skin components you can include or exclude when creating a skin

HTML Page Templates: Should generally always be included. This includes

both the templates for topic pages and the various

WebHelp HTML templates. Without them, your skin

will not replace the HTML templates from your pro-

ject. In most cases, that would be pretty pointless. 

Baggage Files: Should generally always be included. The Baggage

Files  section is the place in your skin where you

store your additional JavaScript, CSS and other files

for your skin. Putting them there exports them

automatically when you publish.

Variables: Should generally always be included. Having vari-

ables in the skin allows you to set up configuration

options that you can adjust without having to ad-

just the source code in your templates or baggage

files. Variables can be used in all HTML templates in

your skin and in JavaScript and CSS files in your

baggage files – they are scanned and replaced by

Help+Manual on publishing.

All variables you use in your HTML templates and
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baggage files must be written with the standard <%

VARIABLE_NAME%> syntax, otherwise they won't

be found. You can also use variables from your pro-

ject (both global and user-defined).

Custom Builds: Should generally always be included, but delete any

custom builds from your project in the skin after

creating the skin. Custom builds defined only in the

skin are displayed in the additional Skin Include

Options box displayed in the Publish screen. Hav-

ing custom builds in your skin allows you to create

configuration options that can be activated or de-

activated on publishing. 

You can include or exclude code in your HTML tem-

plates or in your JavaScript and CSS files in your

baggage files with custom builds. For example, sup-

pose you have a custom build called TOPICFOOTER:

Include code when your build option is active with:

<IF_TOPICFOOTER>Code you want to in-
clude when TOPICFOOTER is selected
goes here</IF_TOPICFOOTER>

Include code when your build option is inactive

with:

<IF_TOPICFOOTER>Code you want to in-
clude when TOPICFOOTER is NOT selected
goes here</IF_TOPICFOOTER>

See this topic  for more details.

How to edit skin files

Skin files are actually normal single-file projects with some special limitations. You can

open them and edit them like normal projects but you can only edit those components

that are included in the skin, everything else is unavailable. 

1. Select Open in the File menu and then select Help+Manual skin files (.hmskin) as the

type of file to be opened. (If you don't select this you won't be able to see the skin

files!) 

2. Select an .hmskin file to load and edit. You can find some sample skins in the Skins

folder in the Help+Manual program directory.
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3. Now you can edit the settings of your skin. This is exactly the same as editing the cor-

responding sections of normal projects to configure your output.

Skins have no topics, you can only edit the relevant sections in the Configuration and

Baggage Files sections in the Project Explorer and the text and table styles in Write >

Styles.

Using include conditions to configure features in skins

Key Information
Include options in skins must be defined in the skin!

Include options defined in normal H+M projects will

not be saved in the skin when you save the project as

a skin. You must edit the skin file and add the include

options you want to use.

For advanced users:

You can use include options  to turn features in skins on and off. This makes it possible

for the user to choose features in the skin when they publish their projects because in-

clude options stored in skins are loaded into the Include Options: box in the Publish dialog

when the skin is selected.

For example, suppose you want to give the user the option of having a subtitle under-

neath the title in the table of contents in your WebHelp output. It would work like this:

1. Define an include option in the skin, let's say it's called OPT_SUBTITLE, and let's also

say that we've entered TOC header subtitle as the include option description.  

2. Add code using the include option to the HTML template for the WebHelp table of

contents, for example (you would also have to define the <%SUBTITLE%> variable in

this example, of course):

  <p class="navtitle"><%TITLE%></p>
  <IF_OPT_SUBTITLE><p class="nav-subtitle"><%SUBTITLE%></p></IF_OPT_SUBTITLE>

3. When the user loads the skin in the Publish dialog the option [ ] TOC header subtitle

will automatically be loaded from the skin file and displayed in the Include Options:

box. The header will only be displayed if the user selects this option.

You can take this concept as far as you like: For example, you can use the same include

option to change the CSS definitions in the same HTML template so that the formatting

will be different depending on whether the subtitle is included or not. 
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Including a preview image in a skin

When the user selects a skin in the Publish dialog Help+Manual automatically looks for a

PNG graphic file called $HMSKINPREVIEW.PNG in the skin's Baggage files. If this file is

found a thumbnail version of the preview image is displayed in the Publish dialog. The

user can then click on this image to display a full-size preview.

1. Create your preview image – this will generally be a screenshot of a help file using

your skin – and save it in the PNG format as $HMSKINPREVIEW.PNG. 

2. Add the PNG preview file to the Baggage Files section of your skin.

3. Select the PNG file in the Baggage Files section, right-click on it, select Include in

Builds and deactivate all build options for the file. This will prevent the file from being

exported to your published output, where it is not needed.

Using skins to redefine variables and other settings

You don't have to save all your settings in your skin files. For example, it's possible to cre-

ate a skin that only defines the user variables in your project – you just need to deselect

everything except Variables when you save the skin file. Then you can redefine your vari-

ables in your entire project by selecting the skin file when you publish your project.

You can do the same with your Baggage files, text and table styles, HTML Page Templates

or any combination.

 Applying multiple skins in command lines and batch files

When you publish manually you can only select one skin for the project you are publish-

ing. However, when you use Help+Manual's command line options you can specify as

many skins as you like one after another. 

When you do this the settings in the last skin you specify always have priority for duplic-

ate settings – for example, if you redefine the same variables in two skins the settings in

the second skin are those that will be applied. 

See Command Line Options  and Skins & redefining variables  for more information

on this. 

See also:
The Publish Dialog

Command Line Options
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6.2 Configuring for Publishing

When your project is finished you will want to output it to one of the output formats  sup-

ported by Help+Manual. You can generate all these formats from the same project. 

Configurable publishing options

The layout of the content of your topic pages is controlled by what you enter in the editor

but there are many other aspects of your output that you can configure individually for

different output formats. These options are generally configured with settings in the Con-

figuration  section of your project in the Project Explorer. The layout of your PDF output

is controlled by special template files that you can create and edit with the Manual

Designer program included with Help+Manual.

The topics in this chapter provide an introduction to configuring the options for each

format with references to documentation of the individual settings available for each

format.

See Help Formats  for more information on the individual output formats.

See also:

Project Configuration Settings

Help Formats

6.2.1 Publishing for Hi-Res Displays

WebHelp and HTML Help CHM output need a couple of configuration options to optimize

them for working on modern high-resolution displays. This will not change the performance

on normal displays. 

Configuration for HTML Help/CHM files

The Microsoft CHM Viewer in Windows uses an old HTML rendering engine that has spe-

cial requirements. Help+Manual can automatically configure your CHM file so that it dis-

plays correctly on high-resolution 4K monitors and devices like the Microsoft Surface and

Lenovo Yoga Pro. If you don't do this the text and other elements will often be too small

to read on these devices. 

1. Open your project in Help+Manual and in the Project Explorer navigate to Configura-

tion > Publishing Options > MS HTML Help > HTML Export Options. 

2. Set Font Size Encoding to: pt Points.

3. Select the checkbox for Make pixel sizes relative to monitor resolution (4K display com-

patibility)

All elements of your CHM file will then automatically be adapted for correct display on

both normal and high-resolution devices and monitors.
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Configuration for WebHelp

You now need to consider high-resolution 4K monitors and devices like the Microsoft Sur-

face and Lenovo Yoga Pro when you are planning your WebHelp. If you don't do this the

text and other elements will often be too small to read on these devices. If you set the

configuration options described below Help+Manual will automatically adjust everything

else so that it displays correctly on high-resolution displays.

1. Open your project in Help+Manual and in the Project Explorer navigate to Configura-

tion > Publishing Options > WebHelp > HTML Export Options. 

2. Set Font Size Encoding to: em (1em = 100%).

3. The Font size of style "Normal" setting is grayed out for ems/rems because it is only

used when font encoding is set in percent. 

Once the base font encoding is set to ems all elements in your topic files will then auto-

matically be adapted for correct display on both normal and high-resolution devices and

monitors.

6.2.2 HTML Help

The appearance and functionality of HTML Help output is controlled by the settings in three

Project Configuration sections: 

· Configuration > Publishing Options > HTML Help

· Configuration > Microsoft HTML Help > Help Windows

· Configuration > HTML Page Templates

Additional WebHelp and HTML information for experts

If you are experienced in creating pages with HTML, CSS and JavaScript please refer to the

Using HTML Templates  chapter for information on how you can get the most out of

your HTML-based output in Help+Manual.

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

1026

667



646

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Publishing

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

Settings in the HTML Help section

The settings in Configuration > Publishing Options > HTML Help modify the appearance

and functionality of your HTML Help output. The notes below explain what the sections

are for, which settings you need to check and where you can find more information. 

HTML Export Options:

This section contains some of the most important options for your HTML Help/CHM out-

put. They control how your project is converted to HTML code and you should always

check them before publishing a new project for the first time. Changes made here can

cause radical differences in the behavior and appearance of your HTML Help output.

There are also important settings here that enable your CHM files to display correctly on

modern high-resolution devices.

For full details on all the settings in this section see HTML Export Options  in the HTML

Help section of the Project Configuration chapter. The options in HTML Export Options in

the HTML Help section are also used for the two Microsoft Visual Studio Help formats.

Popup Topics:

The settings for popup topics are included in the HTML Export Options section. For in-

formation on creating and using popup topics in HTML Help see Creating popup topics

and Using JavaScript popups . If you plan on using field-level popups to be displayed

in your application also check Using Context-Sensitive Help  in the More Advanced

Procedures section.

Extended .HHP Settings:

Additional settings for the HHP file:
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This section is for advanced users who have experience with the manual configuration of

HTML Help projects. If you are just getting started with Help+Manual you don't need to worry

about it at all. It enables you to add and modify settings in the HHP project configuration file

that is fed to the Microsoft HTML Help compiler together with all the other project files. 

Context-sensitive application help

This is the internal file name of the popup topics file used for field-level popups that can be

displayed in Windows applications without opening the main help file. If you wish, you can

change the name of this file here. See this topic for details .

Window styles of the table of contents:

These additional options adjust the appearance and behavior of the TOC in the Microsoft

HTML Help viewer:

Display plus/minus icons:

Activates or deactivates the +/- icons displayed to the left of closed/open chapter icons

("books") in the HTML Help viewer's TOC.

Draw lines between items:

When this is activated fine dotted lines are displayed between related items in the TOC, mak-

ing it easier see which topic belongs to which chapter in complex TOCs.

Track selection (mouseover effect):

When this is activated an underline is displayed below topic entries in the TOC when the user

moves the mouse over them. This makes it easier to be sure which topic you are going to click

on.

Only expand a single heading:

When the user selects a new chapter any other chapters on the same level in the TOC that are

open will be closed automatically. This is useful for complex help documents with lots of

chapters, because it is easier to navigate in the TOC if you do not have multiple chapters

open.

If this is a child file merged at run time:

This setting specifies what happens when the user opens the compiled help file directly

if it is part of a modular help system. See Working with Modular Help Systems  for

more information on this subject.

Make CHM files scale correctly on hi-res monitors

The Microsoft CHM Viewer in Windows uses an old HTML rendering engine that has spe-

cial requirements. Help+Manual can automatically configure your CHM file so that it dis-

plays correctly on high-resolution 4K monitors and devices like the Microsoft Surface and

Lenovo Yoga Pro. If you don't do this the text and other elements will often be too small

to read on these devices. 
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1. Open your project in Help+Manual and in the Project Explorer navigate to Configura-

tion > Publishing Options > MS HTML Help > HTML Export Options. 

2. Set Font Size Encoding to: pt Points.

3. Select the checkbox for Make pixel sizes relative to monitor resolution (4K display com-

patibility)

All elements of your CHM file will then automatically be adapted for correct display on

both normal and high-resolution devices and monitors.

See Publishing for Hi-Res Displays  for more details.

Settings in the Help Windows section

In addition to the settings in the HTML Help section, the configuration and appearance of

your HTML Help output is also controlled by the settings in Configuration > Microsoft

HTML Help > Help Windows. In particular, the HTML Help Options  tab configures the

features of the Microsoft help viewer used to display your HTML Help CHM file.

See Help Windows  for some more information on this subject.

Publishing and testing Asian language HTML Help

Match the System Locale to your output language

If you are not using a version of Windows matching your Asian language you must set the

system locale to the correct language, otherwise the HTML Help compiler will not work

properly because it is not a Unicode program; it needs support from Windows to be able

to handle these character sets correctly. To do this open the International settings in the

Windows Control Panel. The setting is in the Advanced tab. In Windows XP it is called

"Language for non-Unicode programs", in later versions of Windows it is called System

Locale.

You need to restart Windows after changing the locale.  

Quick tests with the "Tolerant handling of Asian languages" setting

If you just want to do a quick compile of an Asian project without having to reset the Sys-

tem Locale and restart Windows there is a setting you can use to be able to view the out-

put quickly:

View > Program Options > Compilers > Tolerant Handling of Asian Languages

This option is only for testing. It will create an Asian CHM that can be viewed correctly, but

the keyword index and full-text search will not work correctly. To produce a production
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CHM for distribution you must publish it on a copy of Windows with the system locale set

to the matching language.

Excluding topics from search in CHM

As in WebHelp, you can exclude topics from the search in CHM by adding an underscore

to the beginning of the topic ID. However, for this to work in CHM you must also activate

an additional option for CHM in the HTML Export Options .

Important note for context help: 

When you activate this option for CHM, the extension of the topic file is changed from

.htm to .xhtm. You need to remember this for your context calls made to the internal

topic HTML file in the CHM file. 

To exclude topics from the search: 

1. Add an underscore to the beginning of the topic's topic ID in the Topic Options tab.

For example, to include a topic with the ID Introduction from the search change the ID

to _Introduction. (Note that you will then also have to change the addresses of any ex-

isting calls to your topic from your application!) 

2. Go to the HTML Export Options  and activate the option Exclude topics from CHM

search if ID starts with an underscore.

3. If you have any context help calls to the topic in your CHM file from your application

change the call to the new ID and file extension. For example, if the ID is _Introduc-

tion_Topic the new HTML file name to make the call to will be _introduc-
tion_topic.xhtm

Settings in the HTML Page Templates section

This section provides access to the HTML templates used in all HTML-based output

formats. These templates define the layout of the HTML pages into which the text from

your topics is inserted. 

Publishing with a skin uses the skin template

Normally, you will publish you project to CHM with a skin. When you select a skin the

fully-configured HTML template from the skin is used instead of the template in the pro-

ject and you don't need to concern yourself with it at all. If you want to change the ap-

pearance of the page when using a skin you need to edit the template in the skin, not in

your project. 
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About HTML page templates in CHM output

In HTML Help/CHM files, the HTML page template is the only HTML template used in your

output. It defines the layout of the HTML pages displayed as topics in the MS HTML

Help/CHM Viewer. This viewer is a standard Windows component. It can be configured to

a certain extent in the Help Windows  settings.

Editing HTML templates directly requires experience with editing HTML code. If you are

just getting started with Help+Manual it is recommended that you only use the Simple

Template Layout tab. This allows you to use the default template while you are getting

used to using the program. 

For full details on all the settings in this section see Topic Pages  in the HTML Help sec-

tion of the  Project Configuration chapter.

For information on using and editing HTML templates see the Templates and Secondary

Windows  and Using HTML Templates  chapters in the Reference section.

See also:
Project Configuration - HTML Help

Output Formats - HTML Help

6.2.2.1 Help Windows

In Microsoft HTML Help CHM files only the actual topic pages can be "styled" by

Help+Manual. The CHM Viewer itself is a standard Windows component that is only configur-

able to a very small extent. 

The configurable features of the help viewer are controlled by the help window definitions in

Configuration > Microsoft HTML Help > Help Windows in the Project Explorer.

For details on the individual settings see Help Windows  in the Project Configuration

chapter. For more information on help windows and what they are for see Help Windows

in the Reference section.

What the help window definitions define

· In HTML Help the help window settings define the appearance and functions of the help

viewer, including the controls displayed in the viewer, the text displayed in the viewer

title bar and how secondary and external windows  are handled.

· The help window settings also define the initial size and position of the HTML Help

viewer and secondary windows displayed as external windows (if you are using them).
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Default and user-defined help windows

By default only one default help window type called Main is defined. This is the standard

window type used for all topics. The settings for Main control the appearance and beha-

vior of the main help viewer in HTML Help. 

Windows other than Main are only used to open topics in external windows  when you

link to them. This is done by specifying the secondary window type in the Window: field in

the Insert Hyperlink dialog.

See also:
Using help windows

Templates and Secondary Windows

Help Windows  (Project Configuration)

Help Windows  (Reference)

6.2.2.2 Optimize Publish Speed

When you are publishing this format Help+Manual generates a temporary folder for the in-

termediate source files that are used to create the final output. These are all the files that go

into your final documentation, including the graphics. You can optimize publishing speed for

large projects by changing the location of these temporary files and whether they are deleted

or not between publishing operations. 

Similarly, optimizing the location of your output folder and the project itself can also speed

up publication by reducing the time required to write all the necessary files.

Not deleting the temporary files can speed up subsequent pub-
lishes

If you disable the option for deleting the temporary files after publishing this can some-

times quite significantly speed up subsequent publish operations for the same project.

This is because the graphics that have not changed in the project no longer need to be re-

generated. This effect will be particularly pronounced if you have a lot of graphics in your

project that you have resized in the HM editor. 
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Should you use a RAM drive?

A RAM drive is a virtual, volatile hard disk created in the computer's memory that provides

maximum access speeds. Its contents disappear when you shut down or restart your com-

puter, so it may not provide the benefits of not deleting your temporary files  (see above)

between sessions. Also, this means that RAM drives should never be used as your output

folder, because their contents disappear much too easily.

If you use one it must be large enough to accommodate all the files you write while pub-

lishing and you need to be very careful that it does not fill up completely while you are

publishing, otherwise you will get errors. Instructions for how to do this go beyond the

scope of this documentation. Generally you will need a special software utility to set up a

RAM drive.

Never use RAM drives for your output folder!

This is important, so we're going to repeat it: The contents of RAM drives disappear as

soon as you shut down or restart your computer. So you should only ever use them for

temporary files, never for your output folders!

A RAM drive can improve performance if you only have spinning

hard disks

RAM drives are much faster than spinning hard drives so if you don't have an SSD it can

be worth it to set up a RAM drive for your temporary publishing files, if you have enough

memory. However, an even better solution is to get a modern SSD because that will radic-

ally improve the performance of your entire system.

Don't bother with a RAM drive if you have a fast SSD

RAM drives are much faster than spinning hard drives but only marginally faster than

SSDs for Help+Manual publishing. If you have a fast SSD, setting up a RAM drive will al-

most never provide a noticeable improvement, so it is not worth the effort then.

Optimize the locations of your project, temp files and output
folders

Optimizing the locations of your project, temporary files and output folders can all speed

up publishing. 
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Best solution all round: Everything on a fast local SSD

For the fastest possible publishing speed your project, temporary files folder and output

folder should all be on a fast local SSD on the computer where Help+Manual is running.

Then there are no network transfers during publishing and everything can run at max-

imum speed. 

Best solution for network projects: Temporary files on a fast local

SSD

If you are working on a collaborative project then it must be on a network drive. In this

case you can still improve performance a lot by putting your temporary files on a fast local

SSD on the computer where Help+Manual is running to publish the project. Having the

output folder on the local drive will also improve performance, but not as much as having

the temporary files there. 

How to change the temp files folder location

You can find the setting in the Compilers section of the main program options, in View >

Program Options > Compilers. The setting applies to all output formats that use tempor-

ary files before (CHM, ePUB, Kindle, eWriter, Visual Studio help). The temporary files are

written in sub-folders with names based on the project name and the output format. 
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Exclude your output and temp files folders from your virus checker

On current Windows systems interactive virus checking is performed on every file being

written and can significantly increase the time it takes to generate your published output.

Excluding your output folder and temp files folder from virus checking can speed up pub-

lication of large projects very significantly.

First set up a specific folder where your temporary files will be written (see above). If pos-

sible, also set up a folder where you always write your output files. This can contain mul-

tiple sub-folders for your different output requirements. Then you can configure your

virus checker to exclude these folders from checking.

The instructions below explain how to do this for Windows' own integrated Windows De-
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fender or Security Essentials virus checking. If you are using a commercial solution you will

need to consult your virus checker's documentation to learn how to exclude folders from

checking. Note that commercial virus checkers often slow down your system much more

than Windows' own solution.

Excluding your output and temp folders from Windows Defender or

Windows Security Essentials

1. Open Windows Defender (or Security Essentials on older versions of Windows). 

2. Select the Settings tab and then on the left select Excluded files and locations.

3. Click on the Browse button on the right and select the folder you want to exclude.

4. Click on the Add button to add the selected folder to the exclusions, then select the

option at the bottom of the dialog to save your settings.

6.2.3 WebHelp

The appearance and functionality of WebHelp output is controlled by the options in two
sections in your Project Configuration: 

· Configuration > HTML Page Templates

· Configuration > Publishing Options > WebHelp

Additional WebHelp and HTML information for experts

If you are experienced in creating pages with HTML, CSS and JavaScript please refer to the

Using HTML Templates  chapter for information on how you can get the most out of

your HTML-based output in Help+Manual.

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

1026
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the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

Different appearance in different browsers

It is unavoidable that your WebHelp output will look slightly different depending on the

browser used to view it. HTML Help and Visual Studio Help are proprietary Microsoft

formats that use Microsoft help viewers to display them, and your output in these formats

will always closely resemble your source in the Help+Manual editor. 

This is not possible in WebHelp. The HTML code generated is the best possible comprom-

ise between the many quirks of all the browsers now in use and compliance with the cur-

rent standards for XHTML, HTML and CSS. 

Unfortunately, no browser is really compliant with all the standards. In addition to this, in-

dividual browsers often interpret the same rules and formatting tags differently.

Configuring WebHelp for modern high-resolution devices

You now need to consider high-resolution 4K monitors and devices like the Microsoft Sur-

face and Lenovo Yoga Pro when you are planning your WebHelp. If you don't do this the

text and other elements will often be too small to read on these devices. If you set the

configuration options described below Help+Manual will automatically adjust everything

else so that it displays correctly on high-resolution displays.

1. Open your project in Help+Manual and in the Project Explorer navigate to Configura-

tion > Publishing Options > WebHelp > HTML Export Options.

2. Set Font Size Encoding to: em (1em = 100%).

3. Set Font size of style "Normal" to about 82% for 10pt base font type and about 88%

for 11pt base font type. Adjust as necessary depending on the appearance of your

output. 

You need to set the percentage for Normal because ems are a relative value. The default

font size on all browsers is 16 pixels, which is generally too large for normal body text in

documentation. Compare the Help+Manual editor with the output on your browser to ad-

just the percentage to the correct value for your documentation. 
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Once the base font encoding is set to ems all elements in your topic files will then auto-

matically be adapted for correct display on both normal and high-resolution devices and

monitors.

Settings in the WebHelp section

Edit in the skin if you are using a skin

All these sections must be edited in the .hmskin skin file if you are publishing with a

skin. When you use a skin, the HTML templates and settings in the skin replace those in

your project. Usually, when you are using a skin, you don't need to edit anything because

it has all already been set up by the designer. 

Sections:

The most important sections are Layout, Navigation and HTML Export Options. Always at

least check the settings in these sections before publishing a new project. 

The Layout section:

The options in this section control the layout of your WebHelp.

Integrated:

This uses current HTML5-based templates. The flexible layout uses modern iFrames instead of

the old, deprecated frameset. Recommended for most projects. As in the classic 3-frame lay-

out (see below), you can use the header frame as container for the header of your website or

any other web content.

No Frames:

This option is only for users who want to manage all their help topic files themselves. It does

not create an integrated help system. The TOC file is used as the main index.html file and

topics selected in the TOC display in the same page as the TOC. 

Classic 2 Frames:

This generates the old frameset-based 2-frame layout used in previous versions of

Help+Manual. It is provided mainly for users who want to continue using their own old cus-

tomized templates.

Classic 3 Frames:

This generates the old frameset-based 3-frame layout used in previous versions of

Help+Manual. Here too, it is provided mainly for users who want to continue using their own

old customized templates. The top frame can be used as a container for the header of your

website or any other web page. 
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Single Page Responsive:

This is only displayed when editing a skin. It is a special output format for responsive We-

bHelp that will work across multiple device platforms (desktop, tablets and smartphones).

Currently, it will NOT "just work" if you just select it. It requires extensive JavaScript and CSS

programming on the part of the author because all the special scripting and CSS for this is not

generated automatically. The scripts and CSS must all be included manually in a skin using

this mode. Currently, this format is only used in the V3 Responsive skins in the Premium Pack

3 add-on. 

The Navigation section:

The options in this section control how Help+Manual generates the navigation for your We-

bHelp. Most of the options should be self-explanatory. For full details see Navigation  in

the Project Configuration chapter.

If you want a Keyword Index and Full-text Search tabs in your WebHelp you must activate

these features here!

You can automatically generate an XML site map file  that will be read by search engines to

improve search engine performance when scanning your WebHelp. Note that topics with IDs

beginning with an underscore character (_) are excluded from the site map because they are

also excluded from full-text search. 

The Table of Contents, Keyword Index and Full Text Search sections:

These sections configure the Contents, Index and Search tabs of your WebHelp output. In ad-

dition to this you can also edit the HTML templates that are used for generating these tabs.

Editing HTML templates directly requires experience with editing HTML code. If you are just

getting started with Help+Manual it is recommended that you only use the default settings in

the Simple Template Layout tab.

Note that the Full-text Search feature for WebHelp is only available in the Professional and

Floating license versions of Help+Manual, which include a royalty-free license for the integ-

rated Zoom web search engine from Wrensoft.

For full details on all the settings in these sections see WebHelp  in the Publishing Options

chapter. For full details on using and editing HTML templates see Using HTML Templates

and Templates and Secondary Windows . See Publishing  for an important note on pub-

lishing WebHelp with full-text search.

The HTML Export Options section:

This section contains some of the most important options for your WebHelp output. They

control how your project is converted to HTML code and how popup topics are managed and

you should always check them before publishing a new project for the first time. Changes

made here can cause radical differences in the behavior and appearance of your HTML Help

output.

For full details on all the settings in this section see HTML Export Options  in the HTML

Help section of the Project Configuration chapter.
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This is a shared section! The options in HTML Export Options are used for all HTML-based

output formats (HTML Help, WebHelp, Windows Exe and ePUB eBooks and Visual Studio

Help). The settings of these options are the same for all these formats. You cannot enter dif-

ferent settings for the individual output formats.

The Google Analytics section (Professional Edition only):

This section activates Google Analytics for your WebHelp system.

For full details on Google Analytics see the overview page  and the step by step instructions

page .

Settings in the HTML Page Templates section

Edit in the skin if you are using a skin

HTML page templates must be edited in the .hmskin skin file if you are publishing with

a skin. When you use a skin, the HTML templates and settings in the skin replace those in

your project. Usually, when you are using a skin, you don't need to edit anything because

it has all already been set up by the designer. 

About HTML page templates

This section provides access to the HTML templates used in all HTML-based output

formats except ePUB and Kindle eBooks (which use special templates accessible in the

eBooks configuration sections). These templates define the layout of the HTML pages into

which the text from your topics is inserted. 

Editing HTML templates directly requires experience with editing HTML code. If you are

just getting started with Help+Manual it is recommended that you only use the Simple

Template Layout tab. This allows you to use the default template while you are getting

used to using the program. 

For full details on all the settings in this section see Topic Pages  in the HTML Help sec-

tion of the  Project Configuration chapter.

For information on using and editing HTML templates see the Templates and Secondary

Windows  and Using HTML Templates  chapters in the Reference section.

See also:
Publishing Options - WebHelp

Output Formats - WebHelp
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6.2.3.1 Layout and templates

The options in this section define the layout of your WebHelp. You can use a standard two-

pane layout that directly emulates the HTML Help viewer, a three-pane layout that allows you

to integrate your own website's header page in the top frame or a "no frames, no scripts" op-

tion for manual integration.

Layout settings location:

Configuration > Publishing Options > WebHelp > Layout

Edit in the skin if you are using a skin

Everything in these templates must be edited in the .hmskin skin file if you are publish-

ing with a skin. When you use a skin, the HTML templates and settings in the skin replace

those in your project. Usually, when you are using a skin, you don't need to edit anything

because it has all already been set up by the designer. 

If you want to create your own skin you can turn your project into a skin with Save As... in

the File menu. Then you can edit it as a skin and use the layout you create with other pro-

jects as well. 

Using a skin instead of configuration your layout yourself

Instead of choosing and setting up your layout yourself you can just choose one of the

"skins" provided with Help+Manual. To do this just select one of the available skins with

the Select Skin option in the Publish page and select one of the available skins.

See Transforming your output with skins  for full details.

Choosing your layout mode

There are four different layout modes to choose from: Integrated, which is a modern lay-

out using HTML5 and iFrames; No Frames, which uses the TOC as the main index.html

file; and the two Classic versions with 2-frame and 3-frame layouts using a traditional

HTML4 frameset.

We generally recommend using the Integrated version. The No Frames version is de-

signed for specialists who want to handle the integration of their WebHelp pages them-

selves. The Classic versions are mainly provided for backward compatibility with old pro-

jects and are equivalent to the old standard layouts in Help+Manual 5 and earlier ver-

sions.

Integrated: HTML5 and iFrames for a modern fluid layout

638
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This layout is HTML5-based with modern iFrames instead of the deprec-

ated HTML4 frameset as containers for the navigation and topic pages. It

also has a container at the top for the title of the project and any other

content from your website that you want to put there. 

Settings: 

When you select the Integrated layout option you can define the back-

ground color, borders and frame dimensions in the Simple Options tab. 

Header content:

By default, the Header HTML Content: field only contains the title of the

project. You can add any additional HTML that you want to put here to

integrate the WebHelp with your own website.

Single Page with JS: Responsive WebHelp 3 for the future

This a special output format for responsive WebHelp that will work across multiple device

platforms (desktop, tablets and smartphones). Currently, it will NOT "work" if you just select it.

It requires extensive JavaScript and CSS programming on the part of the author because all

the special scripting and CSS for this is not generated automatically. The scripts and CSS must

all be included manually in a skin using this mode. It will be documented in future updates

when our own responsive WebHelp skins have been released. 

No frames: Choose for fully manual website integration

This option removes completely disables the layout page. Instead , the

Table of Contents  page is used as the main index.html page. Items

clicked in the Table of Contents then display in the same page.

This is designed for authors who want to integrate their WebHelp usage

themselves. It is ideal for small-screen devices like smartphones and small

tablet computers.

Tip: When using this layout, set index.html as the target of the Top

navigation link in theHTML topic page template  and change its cap-

tion to "Contents". Then users will be able to switch back to the contents

easily after viewing pages.

Classic two frames: For legacy projects 

This option uses a traditional HTML4 frameset with two vertical frames,

one for the navigation pages on the left and one for the topic pages on

the right. It is the equivalent of the standard layout in Help+Manual 5

and before.

Settings:

You can turn on a border between the frames and set the width of the

navigation pane on the left in the Simple Options tab. Values below 100

are interpreted as percent, values above 100 as pixels.

1044
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Classic three frames: For legacy projects with website integration in the top
frame

This option uses a traditional HTML4 frameset with the same two

vertical frames as the 2-frame layout, plus a horizontal frame at

the top for your website title, banner etc. It is the equivalent of the

standard 3-frame layout in Help+Manual 5 and before. 

Settings:

In addition to the borders and navigation frame width you can

also define the height and content of the head frame. You can

either insert the HTML code yourself in the editing box, or refer-

ence an HTML file you want to load in the frame. See below for

details.

Content of the header box in Integrated mode

The Integrated layout includes a header box above the navigation and topic panes that

normally just contains the title of the project, which is inserted with the <p>Help+Manual

- User Help</p> code in the Header HTML Content: editing box. You can add any ad-

ditional HTML code of your own that you like here, including references to logo images

etc.

Note: The header box is not a frame

The header box is a normal <div> element on the page, not a frame or an iFrame, so you

cannot load external files into it with normal means. You must actually insert the code you

want to use into the box. 

Content of the head frame in Classic 3-frame mode

When you choose Classic 3-frame mode you have two options for inserting your own top

frame: You can either insert a reference to an existing web page that you want to load into

the top frame or you can enter the HTML code for the top frame directly in the Layout dia-

log. 

Inserting a reference to an existing web page:

Choose the option Head frame loads external file: and enter the name of the

HTML file you want to load into the top frame. 

Ø Help+Manual does not copy this file for you! You must make sure that the file and all the

files it references (graphics etc.) are copied to the correct location on your server.

Ø The HTML file does not have to be stored in the same directory as your help. If it is located

somewhere else you must include the correct relative or absolute path to the HTML file in

the dialog together with the filename.
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Entering your own code in the Layout dialog:

Select the Edit HTML Code tab and edit the code manually in the editor box that activ-

ates when you choose this option. You should have experience with manual HTML

code editing to do this!

Ø When you use this option the head frame HTML file is generated automatically and

copied to your output folder together with the rest of your help.

Ø You can reference graphics files and other external files in your code in the same

way as you would in the other HTML template files. See Using HTML Templates

for details. 

Table of Contents, Index and Search templates

The Layout template defines the basic layout of the user interface for WebHelp. The actual

content is stored in additional pages that are dynamically displayed inside the layout

page, which defines the positions in which the additional pages are displayed. These are

the pages for the table of contents, the keyword index, the full text search option and the

actual topic content. 

All these pages also have templates that you can edit, if you are experienced in HTML and

CSS. You don't need to do this, however. Your project automatically comes with pre-

defined standard templates that provide a very basic but fully functional WebHelp layout

with table of contents, search and keyword index. 

Skins are the easiest way to advanced WebHelp layout

You can create a more advanced layout yourself by editing the templates, but the easiest

way is to use a pre-defined "skin". These skins are special Help+Manual projects that con-

tain all the WebHelp settings and templates to provide an attractive and more functional

layout. You select them in a one-click process when you publish your project. See here

for details.

Texts in the page templates

These templates contain user interface texts that you may want to edit. These include texts

for the navigation buttons (Next / Previous) and the texts for the links in the navigation

pane for switching between the Contents, Index and Search panes. 

Locations of the Topic Page, Table of Contents, Index and Search

templates

Topic pages:

1026
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Configuration > HTML Page Templates > Default

Table of Contents, Index and Search:

Configuration > Publishing Options > WebHelp:

· Table of Contents

· Keyword Index

· Full Text Search

See also:

Layout  (Reference)

HTML template variables  (Reference)

Transforming your output with skins

Using HTML Templates

Templates and Secondary Windows

6.2.3.2 Full text search enhancements

There are a couple of manual settings and switches you can use to change the way that full-

text search works in WebHelp. These aren't absolutely essential but they can be useful for ad-

vanced users to fine-tune search performance.

For full details on all the standard search configuration settings please refer to Full Text

Search  in the Publishing Options chapter.

Get better performance and phrasal searches

By default WebHelp is generated with the client-side JavaScript search platform for full-

text search. This works fine for small projects and has the advantage that it also works loc-

ally. However, for larger projects and additional features like phrasal searching (the ability

to search for an exact phrase in quotes) it is better to use the server-side PHP or ASP

search platform. 

This requires support for PHP or ASP on your web server. Also, it cannot be tested locally

– if you try to open WebHelp configured for ASP or PHP search locally you will only see a

plage of source code when you select search. 

See this topic  for details on how to configure PHP or ASP search.

Excluding topics and files from the search index:

HTML files with names beginning with an underscore (_myfile.htm) are not indexed for

searching. You can use this knowledge to exclude both topics and other files from your

Browser Help search index (i.e. files not generated by Help+Manual). This will also exclude
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topics from CHM search if you activate the corresponding option for CHM in the HTML

Export Options .

· To exclude topics from the search: Add an underscore to the beginning of the topic's

topic ID in the Topic Options tab. For example, to exclude a topic with the ID Introduc-

tion from the search change the ID to _Introduction. (Note that you will then also have

to change the addresses of any existing calls to your topic from your application!)

· To exclude additional files from the search: Just add an underscore to the beginning

of the file name. For example, change myfile.html to _myfile.html.

Make use of index keywords!

In WebHelp, the full-text search includes the index keywords associated with topics in the

search. This means that you can enhance your search by adding keywords to topics that

users might search for, even though they are not included directly in the text of the topic.

This can significantly enhance the usefulness of your searches. 

See the Keywords and Indexes  chapter to learn about how to add index keywords to

your topics.

Excluding page components from the search index:

Out of the box the full-text search feature in WebHelp indexes everything in the page, in-

cluding all the text in the header. When the user executes a search the header text gets

displayed at the beginning of the "excerpt" for each topic displayed in the list of search

results. 

You can change this with two switches that turn indexing on and off in your HTML tem-

plates. These can be used to exclude the both the header itself and the header informa-

tion from the index, which means that the excerpts will begin with the actual text of your

topics. Here's how to do it:

Edit in the skin if you are using a skin

Everything in these templates must be edited in the .hmskin skin file if you are publish-

ing with a skin. When you use a skin, the HTML templates and settings in the skin replace

those in your project. Usually, when you are using a skin, you don't need to edit anything

because it has all already been set up by the designer. 

Procedure:

1. Go to Project Explorer > Configuration > HTML Page Templates > Default. 

1461
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2. Select the "HTML Source Code" tab.

3. Enter <!--ZOOMSTOP--> on a single line of its own directly before the beginning of

the header code, (directly before the <IF_TOPIC_HEADER> switch), like this: 

<!--ZOOMSTOP-->
<IF_TOPIC_HEADER>

4. Enter <!--ZOOMRESTART--> on a single line of its own directly before the <%

TOPIC_TEXT%> variable, like this: 

<!--ZOOMRESTART--> 
<%TOPIC_TEXT%>

5. Repeat steps 1-4 for the other templates in the HTML Page Templates section if you

have created any other custom templates.

That's it. When you recompile everything in the header will be excluded from the index

and the excerpts. You can also exclude parts of individual topics from the search index. To

do this just use the Insert - HTML Code function to insert the stop and start switches be-

fore and after the text you want to exclude.

See also:
The Search template for Browser Help  (Using HTML Templates)

Full Text Search  (Configuration Options)

6.2.3.3 Profiling WebHelp with Google Analytics

A help system is only as good as your users can find the information they are looking for. To

measure the effectiveness of your WebHelp system and improve it where necessary, it makes

sense to track usage so that you can see what your users are searching for and finding. 

Help+Manual Professional and Floating have integrated support for Google Analytics to ac-

complish this goal in a few easy steps. (Please note that this feature is not available in the

Basic version of Help+Manual.)

See this topic  for instructions on setting up your WebHelp for profiling with Google Analyt-

ics.

Important: Use Google Analytics 4 — Universal Analytics is being closed

down

Note that the older Universal Analytics from Google with the UA-xxxxxxx-x tracking IDs

is now deprecated and is going to be completely closed down at the end of June 2023.

Help+Manual 9 and Premium Pack 5 both have full support for the new Google Analytics

4 (GA4) with the new G-xxxxxxxxxx ID format, and you should switch to it immediately.

Among other things, in the default configuration, Google claims that it is now compliant

with the European Union's GDPR legislation. This is disputed by some parties, but it is def-

initely more compliant than Universal Analytics.
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Available information

By integrating Google Analytics, you can track how the content of your WebHelp system is

used and measure its effectiveness. Tracking includes:

General usage

How many visitors are viewing your help? How long are they reading your topics? Which

topics are they reading? Google Analytics delivers detailed statistics on the number of vis-

itors, page views, viewing time, visitor origin and referring pages.

Topics viewed and viewing paths

Learn which help topics are viewed more frequently and which ones are less popular.

Viewing paths tell you, how your users are navigating through your help system and what

they are reading next.

Entry pages and links to external pages

See the most popular entry pages, where users arrive in your WebHelp system. Find out,

where they go when they click on links to other sites.

Full-text search and index terms

What terms are your users searching for? Which results did they follow? Which search

terms are missing? In addition to full-text search terms, Help+Manual's integrated GA

solution also reports use of the keyword index and lists the most popular keywords.

External links

External links are links in your WebHelp system that lead the user away from your site.

Clicks on external links as well as file downloads are tracked separately as events in

Google Analytics.

See also:
Preparing your WebHelp project for Google Analytics

Full Text Search  (Configuration Options)

6.2.3.4 Transforming your output with skins

You may already be familiar with the concept of "skins" from other programs: You select a

skin file and the appearance and layout of the entire program is transformed in seconds.

Help+Manual enables you to do this with your HTML-based output. You can save your entire

design with all its HTML templates and relevant HTML settings in a .hmskin file. You then se-

1433
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lect this file when you publish to apply the layout to the current project without changing any

of the project's own settings.

Please note that you can only save your own projects as skins if you have the Professional or

Floating license version of Help+Manual. Basic version users can use skins without limitations

and edit existing skins (for example skins from the Help+Manual Plus Packs) but they cannot

create new skins from their own projects. 

Productivity Tip
Skins can only be used for HTML-based output

formats. You can style your PDF files and printed

manuals with print manual templates , which work

in the same way as skins. Word files use DOCX tem-

plates .

How to use skins - try it now!

1. Open a project of your own, select Publish in the Project tab, then select WebHelp or

HTML Help as the output format. 

2. On the Publish page  click on the drop-down menu in the Select Skin section and

select one of the standard .hmskin files in the Skins folder in the Help+Manual pro-

gram directory. You can also select the Open Skin... option to select a skin file directly.

When you publish your output it will have the "look and feel" applied by the skin. You

didn't have to do any design work at all! Cool, no?

How to create a skin file

Skin files contain everything you need to style your HTML-based output: Text and table

styles, user-defined variables, your Baggage files (template graphics and logos), HTML

page templates and all the settings and templates for WebHelp. You can turn any project

into a skin file just by saving it as a skin and you can edit skin files in Help+Manual, just

like normal projects.

1. Open a project with a design that you want to use for other projects. 

2. Select Save As... in the File menu and choose the Skin XML File option.

3. Choose a place to save the skin, enter a name and save.

4. You will be asked which configuration components of your project you want to include

in your skin.

803
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Skin components you can include or exclude when creating a skin

HTML Page Templates: Should generally always be included. This includes

both the templates for topic pages and the various

WebHelp HTML templates. Without them, your skin

will not replace the HTML templates from your pro-

ject. In most cases, that would be pretty pointless. 

Baggage Files: Should generally always be included. The Baggage

Files  section is the place in your skin where you

store your additional JavaScript, CSS and other files

for your skin. Putting them there exports them

automatically when you publish.

Variables: Should generally always be included. Having vari-

ables in the skin allows you to set up configuration

options that you can adjust without having to ad-

just the source code in your templates or baggage

files. Variables can be used in all HTML templates in

your skin and in JavaScript and CSS files in your

baggage files – they are scanned and replaced by

Help+Manual on publishing.

All variables you use in your HTML templates and

1119



670

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Publishing

baggage files must be written with the standard <%

VARIABLE_NAME%> syntax, otherwise they won't

be found. You can also use variables from your pro-

ject (both global and user-defined).

Custom Builds: Should generally always be included, but delete any

custom builds from your project in the skin after

creating the skin. Custom builds defined only in the

skin are displayed in the additional Skin Include

Options box displayed in the Publish screen. Hav-

ing custom builds in your skin allows you to create

configuration options that can be activated or de-

activated on publishing. 

You can include or exclude code in your HTML tem-

plates or in your JavaScript and CSS files in your

baggage files with custom builds. For example, sup-

pose you have a custom build called TOPICFOOTER:

Include code when your build option is active with:

<IF_TOPICFOOTER>Code you want to in-
clude when TOPICFOOTER is selected
goes here</IF_TOPICFOOTER>

Include code when your build option is inactive

with:

<IF_TOPICFOOTER>Code you want to in-
clude when TOPICFOOTER is NOT selected
goes here</IF_TOPICFOOTER>

See this topic  for more details.

How to edit skin files

Skin files are actually normal single-file projects with some special limitations. You can

open them and edit them like normal projects but you can only edit those components

that are included in the skin, everything else is unavailable. 

1. Select Open in the File menu and then select Help+Manual skin files (.hmskin) as the

type of file to be opened. (If you don't select this you won't be able to see the skin

files!) 

2. Select an .hmskin file to load and edit. You can find some sample skins in the Skins

folder in the Help+Manual program directory.

1052
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3. Now you can edit the settings of your skin. This is exactly the same as editing the cor-

responding sections of normal projects to configure your output.

Skins have no topics, you can only edit the relevant sections in the Configuration and

Baggage Files sections in the Project Explorer and the text and table styles in Write >

Styles.

Using include conditions to configure features in skins

Key Information
Include options in skins must be defined in the skin!

Include options defined in normal H+M projects will

not be saved in the skin when you save the project as

a skin. You must edit the skin file and add the include

options you want to use.

For advanced users:

You can use include options  to turn features in skins on and off. This makes it possible

for the user to choose features in the skin when they publish their projects because in-

clude options stored in skins are loaded into the Include Options: box in the Publish dialog

when the skin is selected.

For example, suppose you want to give the user the option of having a subtitle under-

neath the title in the table of contents in your WebHelp output. It would work like this:

1. Define an include option in the skin, let's say it's called OPT_SUBTITLE, and let's also

say that we've entered TOC header subtitle as the include option description.  

2. Add code using the include option to the HTML template for the WebHelp table of

contents, for example (you would also have to define the <%SUBTITLE%> variable in

this example, of course):

  <p class="navtitle"><%TITLE%></p>
  <IF_OPT_SUBTITLE><p class="nav-subtitle"><%SUBTITLE%></p></IF_OPT_SUBTITLE>

3. When the user loads the skin in the Publish dialog the option [ ] TOC header subtitle

will automatically be loaded from the skin file and displayed in the Include Options:

box. The header will only be displayed if the user selects this option.

You can take this concept as far as you like: For example, you can use the same include

option to change the CSS definitions in the same HTML template so that the formatting

will be different depending on whether the subtitle is included or not. 

1052
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Including a preview image in a skin

When the user selects a skin in the Publish dialog Help+Manual automatically looks for a

PNG graphic file called $HMSKINPREVIEW.PNG in the skin's Baggage files. If this file is

found a thumbnail version of the preview image is displayed in the Publish dialog. The

user can then click on this image to display a full-size preview.

1. Create your preview image – this will generally be a screenshot of a help file using

your skin – and save it in the PNG format as $HMSKINPREVIEW.PNG. 

2. Add the PNG preview file to the Baggage Files section of your skin.

3. Select the PNG file in the Baggage Files section, right-click on it, select Include in

Builds and deactivate all build options for the file. This will prevent the file from being

exported to your published output, where it is not needed.

Using skins to redefine variables and other settings

You don't have to save all your settings in your skin files. For example, it's possible to cre-

ate a skin that only defines the user variables in your project – you just need to deselect

everything except Variables when you save the skin file. Then you can redefine your vari-

ables in your entire project by selecting the skin file when you publish your project.

You can do the same with your Baggage files, text and table styles, HTML Page Templates

or any combination.

 Applying multiple skins in command lines and batch files

When you publish manually you can only select one skin for the project you are publish-

ing. However, when you use Help+Manual's command line options you can specify as

many skins as you like one after another. 

When you do this the settings in the last skin you specify always have priority for duplic-

ate settings – for example, if you redefine the same variables in two skins the settings in

the second skin are those that will be applied. 

See Command Line Options  and Skins & redefining variables  for more information

on this. 

See also:
The Publish Dialog

Command Line Options

816 834
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6.2.3.5 HM2Go - mini server for local WebHelp

You are probably all too familiar with the annoying yellow warning bar in that appears in In-

ternet Explorer when you open WebHelp files directly on your own computer. Google Chrome

also has problems with local WebHelp files, although they display fine in Chrome online.

Without a web server environment, browsers like Internet Explorer and Chrome are unable to

confirm the security of active features in HTML files and they block them to be on the safe

side.

HM2Go is a tiny server you can distribute with your help

Help+Manual 2 Go (HM2Go) is a tiny server in a single 1.5mb EXE file. When you open

your WebHelp output automatically after publishing it, Help+Manual opens it in HM2Go

so that all browsers display it correctly. 

If you are distributing WebHelp for local viewing you can install HM2Go and be sure that

the help will display properly, even if it opens in  browsers with defective local HTML

handling like IE and Chrome. HM2Go is royalty-free and very easy to deploy and works

both on hard disks and on removable media like CDs and DVDs. There are just two

switches in the command line: 

Using HM2Go for testing your WebHelp after publishing

The HM2Go server is started automatically if you activate the option for displaying your

help output in the Publish page  (Display file when publishing is complete). Once it is

running you will see its icon in the system tray notification area in the Windows Taskbar,

with options for exiting and configuring:

Configuring HM2Go locally:

Just right-click on the HM2Go taskbar icon and select Configure. You can set the port it

uses and the timeout after which it will exit automatically if it is not used for the number

613
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of minutes you specify. The standard port is 80 and you will only need to change this if

you are already running another web server on your computer. A good range of ports that

are guaranteed to be free is from 8805 - 8872. Any number between those values is gen-

erally safe to use. The port and timeout settings will be saved and used the next time

HM2Go is started.

Opening HTML pages with HM2Go when it is running:

Once HM2Go is running you can open any local HTML pages (for example your WebHelp)

with it by entering its IP address in the address field of your web browser. If you have

changed the port you also need to enter the port number. The normal address with the

standard port (80) is http://127.0.0.1 , and you just need to add  the absolute path

to the file you want to open after it like this:

http://127.0.0.1/D:/Documents/My+HelpAndManual+Projects/Demo-
help/HTML/index.html

Use plus (+) characters instead of spaces.

If you have changed the port address to anything except 80 you need to include the port

number in the URL, directly after the IP address and preceded by a colon, like this:

http://127.0.0.1:8810/D:/Documents/My+HelpAndManual+Projects/Demo-
help/HTML/index.html

Relative paths in the browser URL:

In addition to the absolute URL shown in the examples above, you can also use a relative

URL for accessing the help. The path is always relative to the location of the HM2GO.EXE

file when it is started. For example, if the help is in a sub-folder called HELP in the folder

where the HM2GO.EXE program file is stored and started, you can also use this URL:

http://127.0.0.1:8810/HTML/index.html

Distributing HM2Go with your own WebHelp

HM2Go can be distributed with your own WebHelp and used to display it with the user's

default web browser, avoiding all problems normally associated with opening WebHelp

locally without a server. This also works with WebHelp distributed on CDs and DVDs. It will

run fine directly from the CD/DVD.
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How to get the HM2Go program file:

If you are using Help+Manual the HM2Go.exe file is located in the Help+Manual program

directory. Just copy it from there to use it. All you need is this single EXE file. It is easiest to

save it in the same folder as your WebHelp files to use it.

If you are using HM2Go as a stand-along solution you can get it from the EC Software

website here, where you can also always download the latest version:

HM2GO download page

Command line syntax and options for starting HM2Go

The basic syntax for starting HM2GO is:

HM2Go.exe /P:xxxx /T:xx /PRJ:xxxx.html

The /P= switch is the port number, the /T= switch specifies the number of minutes until

HM2Go exits automatically if it is not used and the /PRJ= switch specifies the HTML file

you want to open. Your command line will normally look like this:

HM2GO.EXE /P:8810 /T:0 /PRJ:index.html

It is best not to use the default web server port (80) in case the user already has a local

web server installed. A good range of ports that are guaranteed to be free is from 8805 -

8872. Any number between those values is generally safe to use. Set the timeout to 0 to

prevent the server from exiting automatically unless you have a specific reason for setting

an explicit timeout value.

The /PRJ: switch is not absolutely required. You can also enter: 

HM2GO.EXE "index.html" /P:8810 /T:0 /PRJ:index.html

Absolute and relative paths:

You can also use an absolute or relative path for the location of the WebHelp file to open.

Relative paths are always relative to the location of the HM2GO.EXE file, not to the loca-

tion of the current folder or the batch file! 

Relative path with the help in a folder called "help" below the HM2GO.EXE folder:

HM2GO.EXE /P:8810 /T:0 /PRJ:help/index.html 

Absolute path, only possible when you know the drive letter:

@echo off
start /B HM2GO.EXE /P:8810 /T:0 /PRJ:D:/projects/help/in-
dex.html

https://www.helpandmanual.com/hm2go.html
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Starting HM2Go in a batch file:

If you start HM2Go with a batch file you don't want the command console window to

open visibly. To prevent this, use the start /B command, this example assumes that

HM2GO and the help are in the same folder: 

@echo off
start /B HM2GO.EXE /P:8810 /T:0 /PRJ:index.html 

HM2Go on CDs and DVDs

The best way to use HM2Go on a CD or DVD is to design the disc with a program that

creates an interactive menu for your disc content so that the user can start the help by

clicking a button. You can also create a simple autorun disc (see below), but many users

turn off autorun for optical discs nowadays because of security considerations, so these

may not always work. 

All you need for a produced disc is to store HM2Go.exe in the same folder with all your

WebHelp files and enter the command line options outlined above to start the help. You

can also make context-sensitive calls  to topics in the WebHelp: You just need to prefix

the address with the IP and the port number you have configured for HM2Go, for ex-

ample:

http://127.0.0.1:8810/index.html?introduction.htm#beginners

HM2Go on an auto-starting CD or DVD:

To install HM2Go with your WebHelp on an auto-starting CD or DVD you just need to

burn the WebHelp files and the HM2Go.exe file to the CD or DVD together with an icon

file to be displayed for the disc in Windows Explorer and a text file called autorun.inf.

The minimum contents of autorun.inf are the following lines:

[autorun]
open=HM2GO.EXE /P:8810 /T:0 /PRJ:index.html
icon=youricon.ico

Here too, you can make context-sensitive help calls to topics in the WebHelp as shown

above for produced discs. You can find lots of tutorials for creating more complex autorun

discs online, but it is really better to use a tool for creating "produced" discs with proper

menus where the user starts the help by clicking a menu button.

899
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Relative paths on CDs and DVDs:

You can also use relative paths for accessing the help in commands and links on CDs and

DVDs. Here too, the path is always relative to the location of the HME2GO.EXE program

when it is started. So these commands and links will also work:

[autorun]
open=HM2GO.EXE /P:8810 /T:0 /PRJ:HELP/index.html
icon=youricon.ico

http://127.0.0.1:8810/HELP/index.html?introduction.htm#begin-
ners

The relative http:// URL will only work after HM2GO has been started to establish its relat-

ive location, of course. 

6.2.4 Adobe PDF and printed manuals

The appearance and functionality of Adobe PDF output is controlled by the settings and tools
in the following locations: 

· Project > Tools > Manual Designer (for editing Print Manual Templates)

· Configuration > Publishing Options > Adobe PDF

· View > Program Options > PDF Export

Settings for printed manuals

Manuals printed with Print Manual in the File menu are also generated with Adobe PDF.

However, the configuration options in the Configuration section of the Project Explorer do

not apply here. Printed manuals are configured entirely with Print Manual Templates (see

below) and the settings in the Print Manual dialog.

For more information see PDF and Printed Manuals .

Introduction to PDF and printed manual formatting in Manual
Designer

Here are some brief pointers on some of the most common things you will want to do to

format your template in the Manual Designer program. For full details press F1 in Manual

Designer to view its detailed documentation.

Note that the same templates are used for PDF and printed manuals. Printed manuals are

generated by creating a temporary PDF file, printing it and then deleting it. 

785
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Accessing and editing PDF templates

All the layout information for PDF is stored in the PDF template you use to generate your

PDF output, which is edited with the Help Manual Designer program included with

Help+Manual. You start it by selecting the Templates & Skins > Manual Designer option

the Project tab in the main Help+Manual program.

Once you have a template open in Manual Designer, press F1 to view the separate help

file of Manual Designer. This file includes a tutorial that guides you through the basic

steps. Here are a few pointers for key issues that crop up often (these instructions are for

Manual Designer):

Ready-to-use templates you can start with:

The standard templates you can start with are stored in the /Templates/PDF sub-folder

in the Help+Manual program folder. You cannot edit anything there (that is why we put

the originals there, so they don't get changed). You need to make a copy of the template

you want to edit in your project folder and edit it there. You can do this in Manual

Designer if you want – open the template, then select Save As... in the File menu to make

the copy.

Selecting edited PDF templates:

When you publish, select PDF as your output format in the Publish dialog, then select your

edited template with the Print Manual Template option in the Publish page.

Turning sections on and off in PDF templates:

Open the template in Manual Designer and select the tab corresponding to the section

you want to activate or deactivate. Then select Page Options in the Pages menu and turn

the "Print Section" option on or off to activate or deactivate the section.

Page size:

Select the Master (Background) section, then select Page Options in the Pages menu to

select the paper side and Portrait or Landscape orientation. You can only have one page

orientation for the entire PDF document.

Margins:

Select any section other than "Master" and open the Page Options in the Pages menu. Set

the margins and click on the option "Apply margins to all sections" to set the margins for
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the entire document. You can then change the margins for other individual sections if you

need. Use the "Flip Margins" option to adjust the margin settings to mirror images for left

and right pages in layouts that have different margins for left and right.

Page numbers:

Page numbers are included by default in all the standard PDF templates included with

Help+Manual. You can edit or remove them as you like. To remove them just delete the

elements on the pages that insert them. If you remove page numbering from the pages

you will also want to remove the page number references from the table of contents in

the Table of Contents section. 

See the Manual Designer help for details on how to configure page numbering. 

Headings of topics and in the table of contents:

These are edited and styled in the Topics and Table of Contents sections in the PDF tem-

plate. Each section shows six levels of headings, which represent the six levels of topics

supported in PDF. You can adjust the style of headings on each level by formatting the

placeholder text items containing the heading variables accordingly. 

Page headers and footers:

The easiest way to have them in exactly the same place on the page in your entire project

is to put them in the "Master Page" section and then activate the Master Page as the

background for the page in all the other sections (in Pages > Page Options for each sec-

tion). You put text objects in the top/bottom margins and use the available variables for

inserting things like the title of the project, page number etc. (see the help for details).

For headers or footers containing the title of the current top-level chapter you need to

turn off the Master page in the Topics section and manually insert header or footer ob-

jects there, because the topic title variables will only be valid in that section. You insert the

Publishing variable to insert the name of the current top-level topic title.

ONLY TOP-LEVEL HEADINGS IN HEADERS AND FOOTERS: You can only insert the top-

level topic title in the header or footer. If you insert variables for lower levels you will get

errors, because those levels do not exist on all pages. Only the Publishing variable is

always valid.
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TOC and topic heading numbering:

Numbering for these items is set in the Table of Contents and Topics sections of the tem-

plate. For details see the "Table of Contents" and "Topics Section" chapters in the "Design-

ing a Template" section in the Manual Designer help. 

Adding new elements  on the page and editing elements on the

page:

To add a new element select a tool in the toolbar and click or drag on the page in approx-

imately the position where you want to insert it. Double-click on an element on the page

to edit it. 

Setting page breaks:

You can set whether each section of the PDF starts on a new page in the Page Options for

the section. You can set page breaks for each topic level in the Page Options for the Top-

ics section. These options are in the page breaks table at the bottom of the Page Options

dialog. 

Manual page breaks and switching between portrait and landscape

When you insert a manual page break in Help+Manual with the page break tool you can

decide whether you want the orientation to switch between landscape and portrait mode.

This enables you to use both landscape and portrait pages within a single document. 
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The Print Manual Designer

The appearance and layout of your PDF output is controlled by template files with the ex-

tension .mnl called Print Manual Templates. These templates are edited with an editor

called the Print Manual Designer , which is included with Help+Manual. 

When you open the Print Manual Designer the last template used to publish the current

project you are editing in Help+Manual will be opened automatically, if there is one. 

Print manual templates control much more than the appearance of your PDF page. They

can also be used to add cover pages, introductions, a keyword index and many other fea-

tures.

· To select a print manual template for PDF output just select it in the Publish page with
the Print Manual Template option when you are publishing your project. Help+Manual
will remember this selection the next time you publish the project.

· The print manual template for printed manuals is selected directly in the dialog dis-

played when you select Print Manual in the File menu.

· For details see the PDF and Printed Manuals  chapter, the section on the Print Manual

Designer  in the Tools chapter and the separate help and documentation of the Print

Manual Designer program itself.

Settings in the Adobe PDF section

The three groups of options in Project Explorer > Publishing Options > Adobe PDF

control the basic functionality of your Adobe PDF output.

PDF Layout:

These options are critical for PDF output and should always be checked before generating

PDF from your project for the first time. This is where you select the print manual template

file that defines the entire appearance and content of your PDF document. The Output

Style setting specifies whether you want to create an interactive PDF for on-screen viewing

or a document-style PDF for printing.

 See PDF Layout  and PDF and Printed Manuals  for details.

PDF Options:

These options  are not quite so crucial but they can make a big difference to how your

PDF document functions. They should always be checked before publishing a PDF or dis-

tributing it to your users.
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See PDF Options  for details.

Font Embedding:

The options in this section can significantly effect the size of your PDF output file, and

whether your users see your files with the same fonts that you chose when you produced

the document. How you configure these options is particularly important for languages

requiring full Unicode character sets, like Russian, Greek and many Asian languages.

 See Font Embedding  for details.

Printer driver for generating Adobe PDF

Help+Manual uses a printer driver to generate PDF documents. This will normally be your

screen device or your default printer. If your PDF output is OK you don't need to change

this but if you experience problems you may need to install an additional standard printer

driver for PDF conversion.

See Customize - PDF Export  for details.

See also:
Output Formats - Adobe PDF

Customize - PDF Export

The Print Manual Designer

6.2.5 MS Word DOCX

MS Word DOCX output can be an alternative to PDF output for some needs. Help+Manual

generates DOCX by combining the output content from the topics in your project with flexible

external templates stored in Word DOCX files. 

Publishing your project as Word DOCX 

Publishing your project as DOCX is similar to publishing as PDF: You select Publish, select

Word DOCX as the output format, select the template you want to use for your layout and

click Publish. See Publishing instructions  for more details on this procedure.

Configuring and customizing DOCX templates in Word

Help+Manual comes with a set of standard templates for Word output. These templates

are themselves standard Word DOCX files that you can edit and customize directly in

Word. 

If you select one without editing it you will get a DOCX document using the layout

defined in that template. If any of the variables used in the template are defined in your
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project you will see those items in the output (project title, author etc). Other fields used

in the template will not yet be filled, because they need to be configured directly in the

template – for example, fields for your company name, address and so on.

· See the following topics in this chapter for instructions.

Changing DOCX layout after publishing

You can change the styles and text formatting of Help+Manual's DOCX output in Word

after publishing but it's best not to try to change the layout as this will often result in lay-

out problems.

Why? Like PDF, Word documents represent static documents rather than fluid pages like

HTML pages displayed in a browser. When you publish to DOCX, Help+Manual automat-

ically formats the content from your project topics to fit the layout defined in your DOCX

template. 

If you change the document layout after publishing then you will often find that the con-

tent no longer fits in the layout. Instead, you should modify the DOCX template and re-

publish the document from Help+Manual.

See also:
Project Configuration - Word DOCX

Output Formats - Word DOCX

6.2.5.1 Configuring DOCX templates

Follow this basic procedure to configure a Word DOCX template for your project:

1. Copy the template file you want to use to your project folder, with a new name if you

want. You can find the source templates in the /Templates/Word folder in the

Help+Manual program directory. 

2. Open the copy in Word and edit it as described below.

3. Save it and select it when you publish your project as Word DOCX.

A DOCX template is a normal DOCX file that you can edit directly in Word, just like any other

Word file. However, it has some special components and variables that you must use to en-

able you to create DOCX output from your Help+Manual projects. 

These templates contain one required section that is essential for creating a DOCX file from

your project and a some additional optional sections. You can also add your own pages. 

1472
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Orientation change in PDF and printed manuals only

Note that changing the page orientation with the page breaks tool  is currently only

available for PDF and printed manual output. If you want to change the page orientation

in Word output you must do this in Word after publishing the Word file from

Help+Manual. 

6.2.5.2 The Topics Section (required)

This section required and it is the key to your DOCX template. It defines the layout of your

topic pages, the formatting of the topic headings, using Word styles defined in the template,

and contains the "placeholder" variable that inserts the content from your project's topics

when the DOCX file is generated with the template.

If you open one of the DOCX templates included with Help+Manual in Word you will find the

Topics section page directly after the Table of Contents / Contents page. It will look some-

thing like this:

Example of the Topics section

This section begins with up to nine heading paragraphs, formatted successively with Word's

standard Heading 1 ... Heading 9 styles (Word allows a maximum of 9 heading levels). This is

followed by a single special paragraph with a variable that inserts the content of your

Help+Manual project topics in the template when you publish. 

245
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How it works

When you publish to DOCX with the template, Help+Manual locates the page in the tem-

plate with the heading and topic content definitions. It then generates the topics in the

DOCX document as follows:

1. Get the topic heading text without formatting from the current topic. 

2. Find the matching topic heading level in the Topics section in the template. 

3. Replace the variable in the heading with the topic heading text from the topic and up-

date the heading numbering if necessary.

4. Insert the pre-formatted topic content from the project directly below the heading.

5. Proceed to the next topic.

Heading paragraphs

Format heading paragraphs with Heading 1, Heading 2 etc.

The heading paragraphs are formatted in order with Word's Heading 1, Heading 2, Head-

ing 3 etc. styles. The formatting of each heading is defined in the Word style definition in

the template document. The topic headings are formatted entirely by the template. Only

the plain text of the headings comes from the project. Any heading formatting used in the

project is not used here.

Don't format the heading items manually. Always change the definitions of the standard

Word Heading 1 ... Heading 9 styles to format these items. 

Format the headings as list items if you want numbered topic head-

ings

To provide heading numbering, each heading paragraph must be formatted as a list item.

Each item must be set to the list level corresponding to its topic heading level. So the top

item is Heading 1 and list level 1, the third item is Heading 3 and list level 3, and so on.

The numbering formatting is defined in the Word list definition.

Variables for inserting the topic heading text in the headings

The body of each template heading paragraph contains the Help+Manual <%

CHAPTER_HEADINGx%> variable matching the corresponding level and inserted in a

Word comment field . So you enter <%CHAPTER_HEADING1%> on level 1, <%

CHAPTER_HEADING4%> on level 4 and so on.

694
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Topics without headings

If you do not include the heading formatting placeholders in this page the topics will be

exported without headings. 

Topic text item (inserts the topic content)

The topic text variable inserts the topic content

The content from your project's topics is inserted in the template by the <%TOPIC_TEXT%

> variable, which must be inserted in a Word comment field . This item must be in a

single paragraph following directly after the last heading variable. It only needs to be

entered once. Help+Manual will then use it to insert your topic content under the appro-

priate heading.

Formatting of the topic text paragraph

Any left and right indents applied to the topic text paragraph will define the left and right

margins for all the content inserted from your project. This allows you to indent the entire

topic content on the page. 

All other formatting of this paragraph is ignored – the formatting of your topic content is

defined in your project.

Page layout, page numbering, headers and footers etc.

All these items are normal Word components. Set them up as you would in a normal

Word document. Enter Help+Manual variables anywhere you like, using Word comment

fields  to contain the variables.

Use Word's page number variables, not Help+Manual's! 

6.2.5.3 The Table of Contents

The table of contents is a normal Word table of contents field, just like the ones you insert in

your normal Word documents. You insert it where you want it to appear in relation to the top-

ics from your project. This will usually be directly before them. 

You generate and format the table of contents field in Word with the usual table of contents

tools. The numbering, dot leaders, styles etc. are all defined in Word. The DOCX templates in-

cluded with Help+Manual already have TOC fields defined. You can reformat or replace these

as you like.

694
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Refer to the Word documentation for full details on inserting and formatting the Table of

Contents field.

Items included in the Table of Contents automatically

Heading 1 ... Heading 9 styles are included as topic headings

Your Table of Contents field in the DOCX  template must be configured to include the

standard headings formatted with the standard Word Heading 1 ... Heading 9 styles in the

table of contents. This is the Word default and all the DOCX templates included with

Help+Manual are configured for this. The headings of your topics are included automatic-

ally because they are defined with these styles in the Topics section .

Section headings from the template use styles that are included 

In the DOCX templates included with Help+Manual, the headings of the sections (Con-

tents, Keyword Index, Table of Figures) are formatted with styles that are configured to be

included in the table of contents.

Headings from other template pages

Standard section headings in the DOCX templates

In the DOCX templates included with Help+Manual, the headings of the sections (Con-

tents, Keyword Index, Table of Figures) are formatted with styles that are configured to be

included in the table of contents.

Including your own headings in the TOC with "Heading 1"

The simplest way include headings from other template pages in the table of contents is

to format them with the Heading 1 style. You won't want to use lower-level styles for this

since these pages are all "top-level" pages.

Adding your own styles to the TOC

Alternatively, you can edit the Table of Contents field in Word to include any other styles

used in the template as level 1 items in the TOC. 
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To include sections like the Keyword Index and Table of Figures  in the TOC, just format

their headings with a style defined in your DOCX template and then edit the Table of Con-

tents field options in Word to include that style as a Level 1 item.

Don't try to enter chapter heading variables!

You will see the Help+Manual <%CHAPTER_HEADINGx%> variables displayed in the TOC

field in the DOCX template but you don't need to enter them there. They are imported

automatically from the topic headings defined in the Topics Section , and you only need

to actually enter these variables there.

Page layout, page numbering, headers and footers etc.

All these items are normal Word components. Set them up as you would in a normal

Word document. Enter Help+Manual variables anywhere you like, using Word comment

fields  to contain the variables.
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Use Word's page number variables, not Help+Manual's! 

6.2.5.4 Keyword Index, Table of Figures

Just like the table of contents, the keyword index and table of figures items are standard

Word fields, which are inserted just as you would insert them in any other Word document

where you want to include a keyword index or table of figures. Refer to the Word documenta-

tion for instructions on how to insert and format them. Look for the documentation on "In-

dex" and "Table of Figures".

Adding a Keyword Index section

1. Create a page in the DOCX template for the keyword index. There is no required loca-

tion, but you will want it to be after the Topics Section . 

2. If you want to include the index in the table of contents, create a header using a style

that you have included as a level 1 item in the Table of Contents  field. 

3. Click in the position where you want the index to appear. Then select Quick Parts >

Field in the Text section of the Insert tab in Word.

4. Select the Index item in the Field names: box, click on Index... to adjust the index op-

tions and then on OK to insert the field.

Adding a Table of Figures section

A table of figures is a list of the captions of all the images in your project with references

to their page numbers. 

Note that some of the DOCX templates included with Help+Manual already come with a

table of figures pre-configured. So check it in a template you're using first by editing it in

Word, before you try to create one yourself. 

Step 1: Enter captions for all the images you want to include in the

Table of Figures

Captions are required for the Table of Figures, because the captions are the entries in the

table. You enter them in the topic editor  by double-clicking on the image in the editor.

Step 2: Set the language for the table field to 'English (United

States)' 
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Step 3: Create the table of figures entry in your DOCX template 

1. Create a page in the DOCX template for the Table of Figures. There is no required loc-

ation, you can place it before or after the Topics Section  as you please. 

2. If you want to include an entry for the Table of Figures in the TOC, create a header us-

ing a style that you have included as a level 1 item in the Table of Contents  field. 

3. Click in the position where you want the Table of Figures to appear. 

4. If your document language is set to anything other than English you need to set the

language for the paragraph that will contain the Table of Figures field to English (Un-

ited States). If you don't do this Word will not be able to find the figure number refer-

ences in the captions in the Help+Manual text. 

This will not affect the language of the label text in the generated Table of Figures. For ex-

ample, if the label text for the figures in your project are in German or French, they will still

appear in German or French in the generated table with this setting!

5. Then select the References tab in Word and click on Insert Table of Figures in the 

Captions section.
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Word Table of Figures dialog 

6. Select the Options... item in the Word Table of Figures dialog and then select Style as

the source for the Table of Figures. (This will only be present if you use one of the ex-

isting Help+Manual DOCX templates as your starting point.) Then select H+M Image

Caption as the style to use. You can configure everything else as you please, of course.

Consult the Word documentation for further details. 

Adding a Table of Figures or a Table of Tables after publishing 

Since a table of figures is a normal Word element it  is quite possible to add one after you

have published your DOCX file. You just add it in Word in the same way that you would in

any other Word document. 

Doing this can have an advantage, because it allows you to use a style to select the text

for the table of figures instead of the image captions. When you define the table of fig-

ures in your template you can't use a style because the styles from your project are not

present there. 
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Since all paragraphs formatted with the selected style will become  your "table of figures

"entries you can use this for making tables of other items as well. For example, you can

create a table of tables by creating captions for your tables formatted with a specific style.

You then add a table of figures in Word after generating the final Word DOCX document,

select the style used for your table captions and generate your table of tables. 

The Word table of figures dialog 

Set the language of the insertion paragraph to 'English (United

States)'

If your document language is set to anything other than English you need to set the lan-

guage for the paragraph that will contain the Table of Figures field to English (United

States). If you don't do this Word will not be able to find the figure number references in

the captions in the Help+Manual text. 

This will not affect the language of the label text in the generated Table of Figures. For ex-

ample, if the label text for the figures in your project are in German or French, they will still

appear in German or French in the generated table with this setting!
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Page layout, page numbering, headers and footers etc.

All these items are normal Word components. Set them up as you would in a normal

Word document. Enter Help+Manual variables anywhere you like, using Word comment

fields  to contain the variables.

Use Word's page number variables, not Help+Manual's! 

6.2.5.5 Additional pages, variables, Word fields

You can add any number of additional pages to your DOCX template. They will be in-

cluded in your published DOCX documents together with the content from your project.

You can customize these pages automatically on publishing by including Help+Manual's

global variables and your own user-defined variables anywhere in the template. 

How to create additional pages

You can add additional pages and content anywhere in the template by creating pages in

Word, just as you would for any normal Word document. Just don't add additional con-

tent to the special Topics Source section .

Where your additional pages will be inserted in the output

The pages that come after the Topics Source section will come after all the topics in your

project. The pages that come before the Topics Source section will come before all the

topics in your project.
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Using Help+Manual variables in your template

You can use Help+Manual variables anywhere in DOCX templates. They will be resolved to

their current values when you publish your project to DOCX with the template.

You must enter variables as Word fields

Unlike PDF templates, you cannot just type the variable name directly into the text of your

content in a DOCX template. You must enter Help+Manual variables in Word fields. See

Creating variable fields in Word  for instructions.

Special DOCX template variables:

There are 11 special variables used in DOCX templates. They are all only used in the Topics

Source section . These variables must also all be entered in Word comment fields ,

otherwise they will not work correctly. 

· The <%CHAPTER_HEADING1%> ... <%CHAPTER_HEADING10%> variables 

These are used for the chapter heading items in the Topic Source section. The table of

contents item gets the chapter headings from the chapter heading items automatically.

You don't need to add variables for this to the table of contents item.

· The <%TOPIC_TEXT%> variable

This is used in the Topics Source section as the placeholder that inserts the content from

your project topics into the template to generate the finished DOCX file. It must be

entered in a comment filed.

Page layout, page numbering, headers and footers etc.

All these items are normal Word components. Set them up as you would in a normal

Word document. Enter Help+Manual variables anywhere you like, using Word comment

fields  to contain the variables.

Use Word's page number variables, not Help+Manual's! 

6.2.5.6 Creating variable fields in Word

You can't just type in Help+Manual variables as plain text as you can in a PDF template. To

use Help+Manual variables in your Word DOCX templates you need to enter the variable in a

Word field. 

You can enter Help+Manual variables in any Word fields that get resolved to text.

Help+Manual will find them and replace them with the variable value when you publish with

the DOCX template. However, there are a two field types that you will probably find most use-

ful: Comment fields and document properties.
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Comment fields

These fields are best for inserting variables inside paragraphs or other items. Don't con-

fuse them with the Word comments feature! That is for peer review and is completely dif-

ferent – variables entered in Word comments won't work. 

To enter a comment field with a Help+Manual variable in Word:

1. Open the DOCX template in Word and click in the place where you want to insert the

variable. 

2. Select the Insert tab in Word, then in the Text group select Quick Parts > Field to open

the Field dialog.

3. Select Comments in the Field names: box, then type in the Help+Manual variable in the

New comment: box, using the format <%VARIABLE_NAME%>.

Document properties fields

You can see examples of these fields in some of the standard DOCX templates included

with Help+Manual. They are used for the Title, Author, Year, Abstract and Company In-

formation items displayed on the cover page, for example.

To enter a document properties field with a Help+Manual variable in

Word:

1. Open the DOCX template in Word and click in the place where you want to insert the

variable. 

2. Select the Insert tab in Word, then in the Text group select Quick Parts > Document

Property and then the property you want to insert.

3. This inserts the property item as a box on the page containing a field. Then type in the

Help+Manual variable in the empty field, using the format <%VARIABLE_NAME%>.

6.2.5.7 About the Word Macros

When you publish your project to Word and open the DOCX file for the first time in Word,

you will see a security warning with a button saying "Enable Content". Clicking on this will

automatically generate the Table of Contents and Keyword Index in your project, and any

table of figures and other Word fields if they are present. 
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There are no macros in your DOCX file!

This feature is only a convenience to allow you to quickly generate the TOC and index the

first time you open your Word file. There are no macros stored in the DOCX file itself. They

are stored in a separate file called $helpman-word-helper-macros.dotm, that is gen-

erated together with the Word file. The macro warning you see comes from this helper

document. 

Distributing your DOCX without macros

You can easily distribute your finished DOCX file without macros: Just distribute it on  its

own, without the .dotm helper file. This will not trigger any warnings, because the gener-

ated DOCX is entirely static, without any macros. 

Generating the TOC and index without the macros

Since the macros are only a convenience it is easy to generate the TOC and keyword index

without them. If you don't want to use the macros button or your company security re-

strictions don't permit it, just ignore it. Then in the Word document press Ctrl+A to select

the entire document, followed by F9 to update all the fields and generate your elements.

Then the document is ready to go.

6.2.6 eWriter Help

An eWriter Help file is WebHelp stored in a single file. It is a modern alternative to the obsol-

ete CHM help format for documenting software applications on Windows, and can now also

be used for application help on MacOS. The eWriter format combines the benefits of CHM

and WebHelp, eliminating many disadvantages of both and providing unique security fea-

tures. It uses the operating system's own HTML rendering engine to display the content, with

full support for CSS3, HTML5, JavaScript and media. 

Deploying eWriter Help for software documentation

If you are going to deploy eWriter Help files for your own software documentation you

need to install the eViewer app along with your application and consider some issues re-

garding making your calls to your files and choosing the best file extensions. Please see

EWriter for Software Help  for details on this.731
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The eViewer viewer apps

On Windows 10 and 11, users are automatically prompted to get the eViewer app from

the Windows Store when they try to open an .ewriter file. Downloadable installers for

32-bit and 64-bit versions are also available. See The eWriter Viewer Apps  for details.

How eWriter Help works

An eWriter Help file is essentially a single-file package for WebHelp with added support

for context-sensitive help and security. The content of an eWriter Help file is normal We-

bHelp, with full support for Help+Manual's WebHelp skins. This means that eWriter has

the same formatting, scripting and layout capabilities as WebHelp, and is just as skinnable.

You can choose a WebHelp skin for it, in the same way as you would for WebHelp, or ded-

icated eWriter skins if you are using the Premium Pack add-on.

All the layout is the same as in WebHelp, as defined in the WebHelp skin. This includes the

table of contents, keyword index, search and so on. 

The standalone eWriter Creator application

In addition to the integrated eWriter support in Help+Manual we have also produced a

standalone eWriter Creator application that you can use to package any folder of HTML

files into an eWriter Help file or a CHM file. 

Note that all the navigation within eBooks packaged with the standalone application must

be included in your HTML source! The eWriter viewer does not and cannot add things like

a table of contents or Next/Previous navigation links.

You can get eWriter Creator from the  eWriter web page.

6.2.6.1 Changes in the new version

If you have used eWriter in earlier versions of Help+Manual, please check the following list of

changes for the Windows version of eWriter Help and the eViewer application. The configura-

tion options have been simplified and the syntax for making context help calls to your eWriter

Help files has been modified for consistency across the Windows and MacOS versions.

If you are new to eWriter you can skip this page. All the information you need is in the rest of

the chapter.

What's new in the Windows version

Note that your old syntax for making calls to your eWriter Help files is still supported.

However, we recommend switching to the new syntax for maximum future compatibility.

· New Open Menu

719
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https://www.helpandmanual.com/ewriter/
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· New URL-style command line interface

· Old context help syntax: still supported

· The viewer dimensions and position presets are deprecated (see below)

· The toolbar has updated icons and is visible by default

· The home button on the toolbar has been removed

· The eViewer application now comes with a choice of 6 user interfaceI languages  and

you can edit the text strings for additional languages.

Deprecated features in the Windows version

· Save last position to registry

Previous versions of eViewer had a configurable option in Help+Manual to save the last

window position and size to the Windows registry. The window position was then

stored for each eWriter Help file. The new version automatically saves the last window

position and size  set by the user. The values are stored globally for all .ewriter

files and individually for each eWriter .exe file, if you use that format. 

If you distribute your own copy of eViewer with your software, the stored window posi-

tion affects your copy only, not any other installations of eViewer on the same com-

puter.

You can overwrite the remembered window position with the defpos  command line

parameter. This parameter affects the first call to an .ewriter file only. Subsequent

calls (if the .ewriter file has already been opened) will not change the window posi-

tion at runtime.

· Kiosk mode

Previous versions of eViewer had a configurable project option in Help+Manual to

make the resulting .ewriter file switch to kiosk mode (a borderless full-screen display

mode) when it was opened. The new version of eViewer ignores this option in

.ewriter files. If you wish to use kiosk mode you must now use the command line in-

terface  and the defpos  parameter.

· Window width and height

You can now only specify the initial starting dimensions for eViewer, which will only be

used the very first time a help file is opened. After that, the last dimensions used by the

user are stored and used the next time the help is opened. You can overwrite the re-

membered window position with the defpos  command line parameter. 

739
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· Maximized eViewer window

This is no longer available as a project option in Help+Manual. The eViewer window will

now only open maximized if it was maximized the last time the user closed it.

· Window is centered on screen

This too is no longer available as a project option in Help+Manual. The eViewer window

position now depends on the position it was in the last time the user closed it.

· Window is sizable

The eViewer window is now always sizable, except when kiosk mode is activated via the

command line.al 

6.2.6.2 Compared to CHM and WebHelp

As an alternative to CHM

Help+Manual's eWriter format is a fully viable replacement for the obsolete CHM format

for software help. On Windows 10 and 11 users are automatically prompted to get the

eViewer viewer app from the Microsoft Store when they open an .ewriter file.

Developers just need to include the single-file eViewer application with their application

and documentation. 

As an alternative to WebHelp

EWriter, which is really local WebHelp in a single file, can be a good alternative to We-

bHelp for developers who need to install their documentation together with their applica-

tions. WebHelp can be preferable when it can be installed on your Internet or intranet web

server. Then you can update your documentation at any time without having to redistrib-

ute to all your users.

EWriter vs. CHM vs. WebHelp — Feature for Feature

Feature EWriter CHM WebHelp

Compact compressed

single file format
Yes Yes

No, all HTML, CSS,

JS and graphics files

separate

TOC, Keyword Index,

Full Text Search
Yes Yes Yes

Context-sensitive help

for desktop applica-

tions

Yes Yes
Yes, via regular

browser URLs
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Feature EWriter CHM WebHelp

Local deployment

without a web server
Yes Yes

No, web server re-

quired

Full customization /

scripting of entire user

interface

Yes
No, topic pane only

Fixed, dated design
Yes

Support for high-resol-

ution displays
Yes No, tiny icons Yes

Support for Unicode Yes

No, obsolete

double-byte text en-

coding

Yes

Viewable without addi-

tional software

Yes, as stan-

dalone EXE. Or

with auto-in-

stalling viewer

app.

Yes, viewer included

in Windows
Yes, web browser

Windows API No Yes No

Command line interface

Yes, single-in-

stance help win-

dow

Yes No, only URLs

Cross platform
Windows and

MacOS

No, blocked by Win-

dows
Yes, any platform

All calls open in same

window
Yes Yes

No, each call from

an app opens a new

browser tab or win-

dow

Works on network

drives
Yes No Yes (web server)

Deploy on Internet No No Yes



701

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Publishing

Feature EWriter CHM WebHelp

Update without redis-

tributing
No No Yes

6.2.6.3 Links & Context Help

On Windows, eWriter Help is the modern alternative to the obsolete CHM format for local ap-

plication help. It offers full support for context-sensitive help and file links and combines the

benefits of CHM and WebHelp while eliminating many of the disadvantages of both. On

MacOS eWriter provides an software help format that is not otherwise available in this integ-

rated form.

This topic provides a quick overview of the link options. For full details see the EWriter for

Software Help  chapter.

Viewer installation for eWriter as software documentation

When you are using eWriter as software documentation to replace CHM files you need to

know where the viewer is so that you can make your calls to it reliably. We recommend in-

stalling the standard version of the viewer for this together with your software. See

EWriter for Software Help  for details.

Each book is opened in a separate instance of the eViewer app

Each book you open has one and only one instance. If you make another call to the same

book it will apply to the open instance. You can have multiple books open at the same

time. To address the individual books you include the name of the book in your call along

with the parameters, as shown below.

Choosing the right file extension for your eWriter files

Use the .ewriter file extension for books distributed on their own

You need to use the .ewriter extension for eWriter files that are going to be distributed

on their own. It is registered with the Windows Store, and when a Windows 10 user who

does not have the viewer opens an .ewriter file they will be prompted to install the

viewer from the Windows store. Users on older versions of Windows can download the

Win32 installer from our eWriter page, which will also register the .ewriter extension.

731
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Use your own file extension for eWriter used for software document-

ation

When you are using eWriter for software documentation you want to install the Win32

version of eViewer together with your software and make your calls to it directly. You also

don't want to conflict with any other version of the viewer that your user may have in-

stalled, so in this case you don't want to use the .ewriter extension. Instead, see one of

your own. 

See URL-style command syntax  for full details on this.

EWriter context help links and command line interface

Making calls to eWriter help files from your applications to display topics is very simple.

On Windows, you basically just need to call the viewer app with a shellExecute() or

equivalent function in your programming language, along with the name of the topic file

to be viewed and an optional anchor to scroll to.

File extensions of your topic files

The HTML topic files inside eWriter Help can have either the .htm or .html extension,

based on your settings for the topic file extension in your project in Configuration > Pub-

lishing Options > WebHelp > HTML Export Options. However, only these two extensions

are permitted. If you set a different extension in your project (for example .php or .asp),

the standard .htm extension will be used.

You need to use the correct extension in your context help calls, otherwise the topics will

not be found.

Context calls syntax

The syntax for context calls to eWriter Help has been changed with the introduction of the

new MacOS eViewer and the updated Windows eViewer. If you have used eWriter for ap-

plication help in the past the calls with the old syntax in your existing projects will still

work. However, we strongly recommend switching to the new integrated URL-style syntax

from now on. 

Please refer to the eWriter for Software Help  chapter for full details and instructions.

739
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Basic New Syntax:

"<viewer app>" "ewriter://<ewriter file>?loadpage=<page in the
help>"

Note that when you are using integrated EXE eWriter Help files, the viewer app is the help

file itself, so it calls itself when using the new syntax.

Basic Old Syntax (not supported for MacOS):

"<viewer app>" "<page in the help>"

URL examples eViewer app:
"<path>eViewer.exe" "ewriter://<path>my_help.ewriter?loadpage=in-
dex.html"
"<path>eViewer.exe" "ewriter://<path>my_help.ewriter?loadpage=in-
dex.html?introduction.htm#anchor2"
"<path>eViewer.exe" "ewriter://<path>my_help.ewriter?loadpage=in-
troduction.html?anchor=anchor2 (Premium Pack)"

URL examples Windows EXE eWriter file:
"<path>MyHelp.exe" "ewriter://<path>MyHelp.exe?loadpage=index.html"
"<path>MyHelp.exe" "ewriter://<path>MyHelp.exe?loadpage=index.html?
introduction.htm#anchor2"
"<path>MyHelp.exe" "ewriter://<path>MyHelp.exe?loadpage=introduc-
tion.html?anchor=anchor2" (Premium Pack)

URL parameters and JavaScript

If your HTML pages include scripts that can evaluate URL parameters (supported in some

Premium Pack skins, for example) you can also include parameters to be parsed by your

script, like this:

"<path>eViewer.exe" "ewriter://<path>my_help.ewriter?loadpage=in-
dex.html?mysetting=xyz&setting2=12"

The HTML location object is fully supported for interpreting URLs you pass to your pages

like this. This means you can extract the query portion of the script with document.loc-

ation.search, the hash portion (anchor) with document.location.hash and so on. 
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Linking between eWriter files

If you have multiple eWriter help files installed on your user's computer you may some-

times want to link between them. This will normally only apply when you are using eWriter

for software documentation . 

There are several methods you can use for linking between eWriter files. You must always

use the File Link option for this, not the Internet Link!

Linking between eWriter files when the file association is known

You can use a simple method if you are sure that the .ewriter extension has been asso-

ciated with the eViewer application, or if you are using your own extension that you have

registered as part of your installation on the user's computer. Then you just need to refer-

ence the eWriter file and the topic parameters.

This also works when you have changed the file extension and eViewer name:

Note that this also works if you are using eWriter for software documentation and you

have changed both the file extension and the name of your copy of the eViewer applica-

tion. You just need to link to another eWriter file that has the same extension as the

eWriter file containing the link. 

File name: The name of the eWriter file you want to link to without any path

information. Just the file name. You must use the extension that has

been registered to the eViewer application on the user's computer.

This will be .ewriter if you are sure that has been registered, or

your own custom extension if you are installing eViewer as part of

your software installation and registering the extension yourself. 

731
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Relative path: Only include the path to the file here if the target file is not in the

same folder as the file containing the link. Despite the name, you

can use either a relative or an absolute path.

Important: No quotes around this path, even if it includes spaces!

Execution para-

meters:

The normal WebHelp reference to the topic you want to display in

the target file. The syntax depends on the skin type you are using.

This parameter must be enclosed in double quotes.

Standard Help+Manual skins and older Premium Pack skins:

"index.html?topic.html"

Premium Pack V3 skins:

"topic.html"

Topic file extensions

The topic file extension can be .htm or .html, depending on what

you have set in your project. Other extensions are not allowed for

eWriter topics. 

Anchors and other parameter extensions

Add these in the execution parameters, inside the double quotes,

exactly as you would in WebHelp. 

Using an Internet link instead of a File link (required for MacOS)

You can also use an Internet link to link between eWriter Help files, but then you have to

use the new syntax with the ewriter:// prefix. This is also required if you are using

eWriter Help on MacOS.

ewriter://NewProject.ewriter?loadpage=index.html?topic_name.html
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Linking between files when you are using the integrated viewer in

EXE eWriter books

When you create combined book and viewer files with the EXE extension you always just

enter the EXE file as the file to link to and the topic to open as the parameters. 

File name: The name of the eWriter EXE file you want to link to without any

path information. Just the file name.

Relative path: Only include the path to the file here if the target file is not in the

same folder as the file containing the link. Despite the name, you

can use either a relative or an absolute path.

Important: No quotes around this path, even if it includes spaces!

Execution para-

meters:

The normal WebHelp reference to the topic you want to display in

the target file. The syntax depends on the skin type you are using.

This parameter must be enclosed in double quotes.

Standard Help+Manual skins and older Premium Pack skins:
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"index.html?topic.html"

Premium Pack V3 skins:

"topic.html"

Topic file extensions

The topic file extension can be .htm or .html, depending on what

you have set in your project. Other extensions are not allowed for

eWriter topics. 

Anchors and other parameter extensions

Add these in the execution parameters, inside the double quotes,

exactly as you would in WebHelp. 

Calls to EXE eWriter files with the integrated viewer

You can still create the original EXE eWriter files with an integrated viewer if you wish, al-

though we strongly recommend using the separate viewer. You just need to change the

output file extension to .exe in the Publish screen before publishing. Help+Manual iden-

tifies this automatically and then creates an EXE eWriter Help file with an integrated

viewer.

Not supported on MacOS

Note that EXE eWriter Help is a Windows format and cannot be used on MacOS. On Macs,

you must use the eViewer app and .ewriter data files.

Context calls syntax

The calling syntax is the same as with the external viewer, except you call the EXE eWriter

Help file instead of the viewer, followed by the parameters. You can use both the old and

the new syntax for this.

Old syntax:

<path>my_ebook.exe "index.html?introduction.htm"
<path>my_ebook.exe "index.html?this_page.htm#anchor"
<path>my_ebook.exe "index.html?anotherpage.htm"

New syntax:
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If you use the new syntax, you must also include the name of the EXE eWriter Help file

after the ewriter:// protocol prefix, so that the file is calling itself:

<path>my_ebook.exe "ewriter://my_ebook.exe?loadpage=index.html?
introduction.htm"
<path>my_ebook.exe "ewriter://my_ebook.exe?loadpage=index.html?
this_page.htm#anchor"
<path>my_ebook.exe "ewriter://my_ebook.exe?loadpage=index.html?
anotherpage.htm"

Always include the page parameters in quotes, even if there are no spaces. Otherwise you

will get Windows errors caused by some of the characters that need to be used. 

Links to executable files

If you're used to producing CHM files and WebHelp you don't even think about opening

executable EXE program files from your documentation. But with eWriter Help, you can!

This is possible both from normal links in topics and from TOC entries.

RESTRICTION: Not supported in the Windows Store version of the

viewer!

Windows Store apps are not permitted to invoke executable files from within the program.

Because of this, the functions described below are not available in the Windows Store ver-

sion of the viewer app. However, you can use them if you are installing the standard Win-

dows eViewer app together with your software. See EWriter for Software Help  for de-

tails.

Current directory status when linking to executable files

When executing external files, the eWriter viewer explicitly sets the current directory to

prevent possible failure of file links using a relative path.

File links to executables in topics

Just create a normal file link to the EXE file and add exec: directly before the file name,

like this:

exec:notepad.exe
exec:../demo_program/widget_maker.exe

731
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Links to executables in the TOC

You can also create links to executable files in the TOC of an eWriter Help file. Create a

new topic entry and choose the TOC Link option, and then Link to Web Address. Then

enter the target in the Web Address: field, using same exec:filename.exe format as

above. Here too, you can include a relative path if necessary.

exec:notepad.exe
exec:../demo_program/widget_maker.exe

6.2.6.4 Project and viewer configuration

Configuring your project content

eWriter Help is essentially the same as WebHelp. There are just a couple of considera-

tions  you need to bear in mind when targeting this format.710
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Viewer configuration 

Each eWriter Help file contains the information for custom configuration of the viewer.

These settings are found in Configuration > Publishing Options > eWriter Help. There

are separate sections for General Settings  and the App Menus . 

6.2.6.4.1  Project content

General information

eWriter Help is regular WebHelp packaged in a single file and displayed with special

viewer app. Any layout that works in WebHelp should work in eWriter Help. You can use

the same skins, or dedicated eWriter skins from the Premium Pack add-on.

WebHelp features that are unavailable in eWriter

There are some WebHelp features you can't use in eWriter, mainly because there is no

web server. 

· PHP and ASP search

You can only use the JavaScript search platform in the search options. There is no

web server, and thus there can be no PHP or ASP support.

· External windows

Don't try to open external windows with JavaScript code in eWriter Help.

File extensions of your topic files

The HTML topic files inside eWriter Help can have either the .htm or .html extension,

based on your settings for the topic file extension in your project in Configuration > Pub-

lishing Options > WebHelp > HTML Export Options. However, only these two extensions

are permitted. If you set a different extension in your project (for example .php or .asp),

the standard .htm extension will be used.

Links to other web pages

It is best to configure the eWriter viewer  to open any links to Web pages in the user's

default browser instead of in the viewer. There are no browser tabs in the eWriter viewer.

If you don't set the default browser option, links to other web pages that are set to open

in a new window will replace your WebHelp interface. 

711 714
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6.2.6.4.2  General Settings

The settings for the appearance and features of the viewer app are stored in each eWriter

Help file. You configure them in your project. 

Look in the Project Explorer on the left while your project is open and navigate down to Con-

figuration > Publishing Options > eWriter Help. There are two tabs of settings, Visual Ap-

pearance and Menus and Translation. See the next topic for the settings in the second tab.

The Visual Appearance and Security Settings

The settings in this section control the appearance of the eWriter Help viewer, an icon and

logo and some security options

Zoom +/- Keys
In your finished eWriter Help file, pressing the

CTRL+[Plus] and CTRL+[Minus] keys will zoom the

eViewer display in and out 

Window title

The eViewer window title displays the title of the help file/project. This is a static display

that does not change with the current topic. The previous per-topic display is no longer

supported. The behavior now matches other formats, including CHM, PDF and so on,

which all have static window titles.
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eViewer Window: These settings define the size of the eWriter viewer

window when the user first opens it. Once the user

has adjusted the size this setting is ignored. You can

also set the size and the position of the window on

the first call from your software with the defpos

command  in your call to the viewer. This com-

mand will be ignored if you use it in subsequent calls

once the viewer has been opened.

The dimensions use virtual pixels that adapt auto-

matically to the resolution of the user's monitor.

Custom Icon (Windows only): Choose an .ico format icon file to be displayed for

your help file in Windows Explorer. This setting is ig-

nored on the MacOS version.

Logo: Optional logo image with an optional URL to a web

page. This is displayed in the title bar of the eViewer

on the right, next to the Print icon. 

Copy and print options: Restrict the ability of the user to copy or print con-

tent.

Important – copy/print restriction requires a cus-

tom context menu! 

In order to be able to restrict copying and printing

you must activate a custom context menu  in the

General Settings page. If you don't do this the em-

bedded browser engine provides copying and print-

ing facilities that cannot be disabled by the eWriter

viewer.

Require Admin mode: Windows EXE files only

The user can only view the help file from an Admin-

istrator Windows account. This is only for integrated

EXE eWriter Help files with the viewer and the book

in a single file. 

Open external links in default

browser:

When this is selected, links to external web pages

open in the user's default web browser. 

This is recommended, because otherwise the ex-

ternal pages will open in the viewer, replacing the

current help entirely. Also, the embedded browser

may not provide desirable functionality for normal

web pages that often need to navigate elsewhere.

Password: Password required to open the help file and text

prompt to display when asking for the password.

Including the password in application calls

If your book is protected with a password you can

include it in the call from your software with the p=

switch so that the user does not need to enter it.

However, be aware that doing this is not secure, as it

may be possible to retrieve the password on com-

puters where this has been done.

eViewer.exe "ewriter://<path>\my-
help.ewriter?pw=password"

Expiry date: Create a time-limited eWriter Help file that expires

automatically on a specific date. The file cannot be

opened or accessed after this date.

701
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6.2.6.4.3  App Menus

The settings for the appearance and features of the viewer app are stored in each eWriter

Help file. You configure them in your project. 

Look in the Project Explorer on the left while your project is open and navigate down to Con-

figuration > Publishing Options > eWriter Help. There are two tabs of settings, Visual Ap-

pearance and Menus and Translation. See the previous topic for the settings in the first tab.

Menus and Translation Settings

The functions in this tab allow you to enable and customize the two types of menus that can

be displayed in the eViewer: An application menu to be displayed at the top left corner of the

viewer, and a context menu to be displayed when the user right-clicks in a topic page.

Zoom +/- Keys
In your finished eWriter Help file pressing the

CTRL+[Plus] and CTRL+[Minus] keys will zoom the

eViewer display in and out 

Activating and deactivating menus

Select the check boxes above the menu types to include or exclude the menus from your

Help file. 

Changes since the previous version

Application menu and context (right-click) menu

Application Menu

This is the menu accessed in the top left corner of the eWriter viewer window. The title is

always displayed, so you need to configure it even when you turn the menu itself off.

When the eViewer is opened on its own without an eWriter Help file, it displays "eViewer".

 

No menu entries: Application menu button is displayed without an arrow and with

the short title of the project.
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Menu entries: Menu button includes a drop-down arrow for opening the menu.

Command line: The contents of the menu can be affected by command line

switches if you are calling eWriter Help from your application. See

EWriter for Software Help  for full details.

Context menu (required for disabling copying and printing!)

This is the menu displayed when the user right-clicks in an eWriter book. If you don't ac-

tivate this the right-click menu of the embedded web browser engine is used. 

Disabling copying and printing: 

Note that you can only disable copying and printing (see General Settings ) if the cus-

tom context menu is enabled, because this replaces the browser's context menu. The em-

bedded browser's context menu automatically supports copying and printing and this

cannot be disabled by the eWriter viewer if it has not been replaced by a custom context

menu.

Configuring and customizing menus

· Existing menu items: Click in the demo menu to select an item or position in the

menu. Then click on the entry type on the right and configure it with the options dis-

played.

· New items: Click in the menu where you want to insert the item and select Add or In-

sert. Then define the menu type and configure it.

· Moving items: Select the item and use the four move buttons to move it around. The <

and > buttons are only active for items below submenu items. 

· Deleting and resetting: The Delete button removes the current item. The Reset but-

ton restores all menus to the default settings, deleting any custom menus.

Entry types

Command A number of standard commands supported by the viewer.

They include commands for navigation, selecting and copying

text, printing pages and closing the viewer.

The :home command is no longer available

This command is deprecated in the new version of eViewer

and if you add it, or if it is already configured from an earlier

version, it will not be displayed in your eWriter Help file.

731
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Page link A link to a topic page in your help file. You can select the page

from a drop-down list of all the pages in your source folder.

The field can also be edited manually. This enables you to use

this feature when compiling a modular project made up of

multiple projects to eWriter. Then you just need to manually

enter the topic ID of the topic you want to link to in any of the

projects that are going to be published to the eWriter book. 

Web link A link to an external web page.

· Enter the full URL, including the http:// or https:// pre-

fix.

· Pages will open in the Help file viewer or the user's default

browser, depending on the setting in the General Settings

screen.

Execute external file: Creates an entry that runs a program or opens an external

document. Enter the name and path to the file and any addi-

tional execution parameters you wish to use.

Sub-menus and di-

viders:

These entries create sub-menu headings and dividers to or-

ganize your menus. After creating a sub-menu you can move

other entries into the sub-menu with the four move buttons

(up / down / left / right).

Caption: The captions displayed in the menus. Add a an ampersand (&)

character before the letter that you want to be active for the

keyboard shortcut for the menu option. 

6.2.6.5 Publishing eWriter Help

This topic covers the basic procedure for generating eWriter Help files. See the main Publish-

ing  sections for general publishing instructions.

Formatting eWriter Help

The eWriter Help format is WebHelp packaged in a single file. See the formatting sections

in the WebHelp chapter  for details on how to skin and format your content. Note that

if you are using Premium Pack skins you should choose the dedicated eWriter skins in-

stead of the WebHelp skins.

613
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Choice of two eWriter Help formats

You can generate eWriter Help as a data-only file, or as a standalone EXE file with an in-

tegrated viewer. The EXE version is for Windows only. The data version can be used on

both Windows and MacOS with the separate eViewer viewer application.

Data eWriter help files

This is now the preferred format. The eViewer application is easily available for both Win-

dows and MacOS and the data version can be distributed easily without any security con-

cerns, even by email. Windows 10 and 11 users who don't have the viewer are automatic-

ally prompted to install the Windows Store eWriter Viewer when they try to open an

.ewriter book file.

To generate a data version you just give your output file the standard .ewriter exten-

sion, or a custom extension if you are using eWriter Help for your software documenta-

tion .

EXE eWriter with viewer and help in a single file

This format is practical because all you need is a single file that the user opens on Win-

dows with a regular double-click. You can also use it for software documentation as it in-

cludes full support for context help calls. However, it works on Windows only and is diffi-

cult to distribute because users will be warned about the dangers of downloading EXE

files. You also need to digitally sign the EXE files with your own code signing certificate to

distribute them safely. 

To generate the EXE version, just change the extension of the output file to .exe in the

Publish screen and Help+Manual will generate an EXE eWriter Help file. However, the new

method with the universal standalone viewer is almost always preferable.

Procedure

1. Open and select your project in Help+Manual. Then select Publish in the Project tab,

then click on Publish Format at the top of the page and select eWriter Help. 

2. Choose an output folder and file name for your eWriter Help file in the Output File:

field. The extension you give your output file determines the type of eWriter Help file

that will be generated:

a. Data eWriter Help file: Use the standard .ewriter extension or your own cus-

tom extension for your software documentation .

b. Standalone EXE eWriter Help file: Use the .exe extension to generate a stan-

dalone eWriter Help file with an integrated viewer. This only works on Windows.

731
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3. Click on the Select Skin bar and select a WebHelp skin. If you are selecting an edited

skin for the first time you will need to click on the Open Skin option at the top of the

menu displayed to navigate to the skin file and select it.

4. Look in the Include Options box and make sure that both WebHelp and eBook are se-

lected. Since eWriter combines aspects of both these formats, both these options

need to be active. 

5. Select Publish Now! at the top right to generate the eWriter Help file.

6.2.6.6 Distributing eWriter Help

You have the following options for distributing eWriter Help and making sure that your read-

ers and users have the necessary viewer.

If you are using eWriter Help for application documentation

In this case you need to install the eViewer application along with your own application

and eWriter Help documentation files. Alternatively, you can also use standalone EXE

eWriter files on Windows that combine the viewer and the help in a single file. In both

cases, see EWriter for Software Help  for instructions.

Distributing eWriter Help files for users to read directly

If you are not going to be calling your eWriter documentation from your own software,

you need to make sure that your users will be able to view it. There are several ways to

achieve this:

Use the .ewriter extension for Windows users

This is the best option. You can distribute the files without security issues, even by email,

and Windows 10 and 11 users will be automatically prompted to install eViewer from the

Windows Store if they don't already have it. Once installed, all .ewriter files will auto-

matically open in the viewer.

Provide links to the installers for MacOS and Windows 

MacOS users always need to install the app, and some Windows users may not want to

use the Windows Store. You need to direct these users to the installer downloads on the

eWriter web page:

https://www.helpandmanual.com/ewriter/

Here too, you need to create eWriter Help files with the standard .ewriter extension so

that they open automatically in eViewer.

731
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Standalone EXE eWriter Help files for Windows

The standalone EXE format combining the viewer and the documentation in a single file is

convenient, because it is all the user needs. However, it only works on Windows and there

are serious distribution problems. You cannot send files like this by email, and many users

will mistrust EXE files. Also, you need to sign the file with a code-signing certificate, other-

wise the user will have to click away a scary Windows message saying that it might be

malware. 

Sending eWriter Help files by email 

This is not a problem with data eWriter Help files. You can just mail .ewriter  files as

regular attachments.The books are compact, neutral, compressed data packages that

should not raise any red flags in AV and mail server filters, including those that examine

the contents of zips and other archives. 

Distributing eWriter EXE help files

The EXE books are the original all-in-one option that combine the viewer and the book in

a single file. This is not really very practical nowadays, because downloading EXE files is al-

most always problematic. It also increases the size of every eBook by around 4 megabytes.

Even so, there may still be some situations in which you prefer to distribute your eWriter

books in this format. For example, it is quite possible to use EXE eBooks as integrated help

files for software, as they support the same context references from your application as

the separate viewer application. 

EXE eWriter Help files should be signed

If you do decide to distribute EXE eBooks you must sign them digitally yourself. Our

viewer is signed digitally by us, but as soon as you combine it with your documentation

data, the checksum of the file changes and the signature is no longer valid. You need a

code signing certificate, which you will already have anyway if your are a software de-

veloper.

6.2.6.7 The eViewer Apps

If you are not going to use the standalone EXE format, which is Windows-only and no longer

recommended, you need the eViewer app for displaying eWriter Help. This is available in

three different versions for Windows and one version for MacOS.

Available eViewer versions

You can find the eWriter web page for all downloads here: 

https://www.helpandmanual.com/ewriter/ 

https://www.helpandmanual.com/ewriter/
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Windows Store app: Windows 10 and 11 users are prompted to download this

when they open an eWriter Help file with the .ewriter ex-

tension. This is recommended for eWriter files that you dis-

tribute directly for the users to read on their computers.

Once the Windows Store app is installed, .ewriter files

open with it automatically.

Windows Store location: 

https://www.microsoft.com/de-at/p/ewriter-

viewer/9mzd18c6288w

 

Prompt to download the

Store app

32-bit and 64-bit versions

of eViewer.exe:

This is the regular Windows version of eViewer. It is avail-

able in three locations:

· Installers for end users on the eWriter web page

· Included in the Developer Package on the eWriter

web page

· Included as the regular eViewer.exe in the

Help+Manual program directory

MacOS version: This is available in two locations:

· In the Developer Package on the eWriter web page 

· As an installer for end users on the  eWriter web page

The eViewer developer package

This is recommended if you are creating application help with eWriter. It includes the Win-

dows and MacOS versions of the eViewer application, a package installer for the MacOS

version, documentation, and test applications for both Windows and MacOS, with an in-

staller for the MacOS version.

Download it on the eWriter web page, where you can find it under the eWriter as Applic-

ation Help heading.

https://www.microsoft.com/de-at/p/ewriter-viewer/9mzd18c6288w
https://www.microsoft.com/de-at/p/ewriter-viewer/9mzd18c6288w
https://www.helpandmanual.com/ewriter/
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 Windows and  MacOS installation

The Windows executables are ready to run. You just need to include the eViewer.exe file

and make your calls to it. 

The \MACOS64\eViewer.pkg included in the developer package installs the MacOS ver-

sion of eViewer.

Requirements and capabilities

 Windows version
· Windows 7 or higher

· 32 and 64 bit executables

· Compatible with all eWriter Help data files created

with Help+Manual and HelpXplain, including old

versions

· Customization in Help+Manual (eViewer app

menu, app button color, book icon)

· Command line interface for application help

· Tester application in the developer package to sim-

ulate application help calls

· 6 ready-to-use UI languages, text strings editable

for additional languages

 MacOS version
· MacOS 11.0 Big Sur or later

· Universal binary for Intel and Apple Silicon (M1, M2

and later)

· Compatible with all eWriter Help files created with

Help+Manual and HelpXplain, including old ver-

sions

· Customization in Help+Manual (eViewer app

menu)

· Command line interface for application help

· Tester application in the developer package to sim-

ulate application help calls

· 6 ready-to-use UI languages, text strings editable

for additional languages

6.2.6.7.1  Differences Windows/Mac

The tables below list the differences between eViewer on Windows and MacOS that are im-

portant when you are using eWriter Help for software documentation.

731
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Technical differences

 Windows  MacOS

Window man-

agement

Single instance by app policy, cre-

ates a separate window per

.ewriter file

Single instance by OS policy, cre-

ates a separate window per

.ewriter file

Command line

interface

eviewer.exe
"ewriter://urlstring"
eviewer.exe <file-
name> /param /param

eviewer.app --args
"ewriter://urlstring"

Call by custom

URL scheme

No URL scheme registered Automatically registers
ewriter://

Different URL schemes can be

configured by modifying

Info.plist .

URL string must

use protocol

URL string must start with

ewriter:// 

URL string must start with the pro-

tocol the executable has been re-

gistered for. 

Default: ewriter:// 

Registered file

extensions

No file type registered 

The regular eViewer installer re-

gisters the extension .ewriter.

The EXE itself does not.

Automatically registers .ewriter.

Different file associations can be

configured by modifying

Info.plist .

Open menu

dialog accepts

file types

Dialog accepts .ewriter files

only (this is a hard-coded resource

string inside the EXE).

Dialog accepts the file type(s) the

executable has been registered

for.

Default: .ewriter

Drag & drop of

files into

eViewer win-

dow

Accepts any file and attempts to

open it

Accepts the file type(s) the execut-

able has been registered for. 

Default: .ewriter

725
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 Windows  MacOS

Patch for distri-

bution

No, executables can be distributed

unchanged.

Yes, registered URL scheme must

be changed  by the developer.

Viewer size 4.7 MB (32 bit) and 6.8 MB (64 bit) 35 MB (includes universal binaries)

Visual and Functional differences

 Windows  MacOS

Custom app

menu

Displayed as a drop-down menu

in the application.

Displayed as secondary menu

item next to the app name.

App button

background

and text color

customizable

Yes Not applicable

Custom right-

click menu

Yes, right-click on the internal web

browser displays a custom popup

menu instead of the browser's de-

fault menu.

No, the custom right-click menu is

not used in the MacOS version.

Book icon cus-

tomizable

Displayed as icon for the viewer

window

Not applicable, there is no icon

per window on MacOS

Self-contained

eWriter files

Yes, Windows executable contain-

ing both viewer and the docu-

mentation (.exe file)

No

Context-sensit-

ive help

By command line parameter By command line parameter

725
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 Windows  MacOS

Password pro-

tection

Yes Yes

Expiration date

for eWriter files

Yes Yes

Kiosk mode By command line parameter By command line parameter

Custom UI

translations

Yes Yes

6.2.6.7.2  Installation & configuration

See the The eViewer Apps  for information and the link to get the Developer Package with

all the necessary viewer components. Among other things, this package contains the redis-

tributable executables for both Windows and MacOS.

\MACOS\eViewer.pkg Redistributable eViewer installation package for MacOS.

The viewer is a universal binary for both MacOS 64 Bit (In-

tel) and MacOS 64 Bit (ARM). The viewer requires MacOS

11 Big Sur or later.

\WIN32\eViewer.exe Redistributable 32-bit eViewer for Windows. No installa-

tion required.

Requires Windows 7 or higher, either 32 or 64 bit.

\WIN64\eViewer.exe Redistributable 64-bit eViewer for Windows. No installa-

tion required.

Requires 64-bit Windows 7 or higher.

Windows installation

The Windows executables in this package are ready to be distributed. No special installa-

tion is required.

1. Make a copy of the 32- or 64-bit eViewer.exe and optionally rename the file. 

2. Deploy the renamed file along with your software.

3. For localized distributions, supply a custom language file

4. For application online help use the URL-style command line syntax .

719

729

739



725

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Publishing

Don't register the .ewriter extension

We recommend that you don't register the .ewriter extension as part of your installa-

tion. Instead, always make your calls explicitly to your installed copy of the eViewer app

and your own help files. This guarantees that you are using the same viewer that was up

to date when you generated your help.

Consider using a different extension for your own help files

It is also a good idea to change the extension of your help files to your own version. If you

do this, you can register your extension to your installed version of the eViewer applica-

tion so that your users can open your help files themselves by double-clicking on them.

Then you don't get any conflicts if the user gets .ewriter files from somewhere else. If

they open .ewriter files on Windows 10 and 11 they will get the Windows Store version

of eViewer automatically (and that extension is required for the Store viewer), and that

then doesn't create any conflicts: The .ewriter extension is always used for the Store

version and your application always opens your help files with your installed version of the

viewer.

MacOS installation and configuration

The MacOS installation package is not ready to be distributed. You need to configure it

for installation with your software first.

When you distribute a copy of the MacOS eViewer, you must change the custom URL

scheme that the app registers. Custom URL schemes are global on MacOS and if multiple

apps register the same URL scheme, there is no mechanism for the operating system to

decide which app to call for this scheme.

Procedure:

1. Make a copy of eViewer.app and rename the file. 

2. Change the URL schemes for the renamed viewer app:

a. Open the package content in Finder (CTRL+Click   Show package content)
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b. Inside the package, locate the /Contents folder and the file Info.plist

c. Open Info.plist with XCode

d. Navigate to URL Types   Item 0   URL Schemes   Item 0

e. Change the URL name from "ewriter" to your own unique identifier.

You must use this custom URL scheme in the URL-style command syntax .

For more information please refer to Defining a custom URL scheme on de-

veloper.apple.com.

f. Now this is a good opportunity to change the registered file extension as well,

just in case you are using a different file extension than ".ewriter". Navigate to

Document Types   Item 0   Document Extensions   Item 0 and enter your

custom file extension:

3. Deploy the renamed app package along with your software.

4. For localized distributions, supply a custom language file

5. For application online help use the URL-style command line syntax .

739
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6.2.6.7.3   Open menu entry

By default, eViewer 3 has  Open and Recent Documents entries in the application menu. The

Open item displays a file dialog that lets the user choose an .ewriter file to open. This file ex-

tension is hard-coded and cannot be changed. 

If you distribute a custom version of the viewer for application online help you may also use a

different file extension for your eWriter Help files. The Open item in the menu would then be

redundant. If this is the case, you just need to rename the viewer to hide this menu item auto-

matically.

When eViewer shows an Open item in the application menu

· The Open menu is displayed by the original eViewer – that is, the executable is named

"eViewer.exe" (Windows) or "eViewer.app" (MacOS).

· If you rename the executable for re-distribution, it hides the menu by default. (This is

automatic, based on the internal resource string in the application itself.)

· Standalone Windows eWriter EXE eWriter Help files (executable with HTML data on

board) hide this menu item by default, since they don't "open" other eWriter files.

· This behavior can be overwritten at runtime with the openmenu  command para-

meter.

Original eViewer

Open menu on Windows Open menu on MacOS

747



728

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Publishing

Renamed eViewer executable

Open menu hidden on Windows Open menu hidden on MacOS

6.2.6.7.4  User data storage

The viewer stores its state data in local INI files. The storage folder used for this depends on

the OS. The file name is based on the name of viewer executable. You can have custom

eViewer deployments installed in the same folder. To enable this, the INI files are named as an

MD5 hash of the executable.

Example of an state data file name:

   eViewer107e80d67e78231fdbc518c8ff7d6723.ini

File contents:

· Owner (the application that created the file)

· Window position and maximized state

· Recently opened .ewriter files

 Windows data storage location

C:\Users\<WINDOWSUSERNAME>\AppData\Local\com.ecsoftware.eviewer\

 MacOS data storage location

/Users/<MACUSERNAME>/Library/Application Support/com.ecsoft-
ware.eviewer/
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6.2.6.7.5  Localization

The eWriter Viewer is a multi-language application. It switches the display language automat-

ically based on the global user preferences in Windows or MacOS. In practice, this only affects

a few strings, because the optional menu included with an .ewriter file always displays the

language it was designed in.

Auto-localized items

· Open  menu

· Recent documents  menu

· Captions and mouse hints for user interaction buttons: 
Back
Forward
Print

· Error messages

Integrated Languages

The viewer currently has the following languages integrated in the application:

English, French, German, Italian, Russian and Spanish. 

For all other system languages, the viewer defaults to English. There is no user preference

option to actively switch the display language.

Adding your own languages

You can add a custom translation by supplying a separate language file. This language file

is not used by the standard eViewer installer. However, you can supply it with a custom

distribution . 

To add a custom translation, create a text file called "<eviewerexename>.lang" in the ap-

plication folder. The file must reside next to the executable, have the same name as the

executable and the extension ".lang". 

For the MacOS version, you can also place the language file inside the application pack-

age, in the /Contents/Resource folder.

 Windows

<path>\eViewer.exe
<path>\eViewer.lang
<path>\MyRenamedViewer.exe
<path>\MyRenamedViewer.lang

727
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 MacOS

Outside the package:
<path>/eViewer.app
<path>/eViewer.lang
<path>/MyRenamedViewer.app
<path>/MyRenamedViewer.lang

Inside the package:
<path>/eViewer.app
<path>/eViewer.app/Contents/Resources/eViewer.lang
<path>/MyRenamedViewer.app
<path>/MyRenamedViewer.app/Contents/Resources/MyRenamedViewer.lang

Contents of the .lang File

This language file is a simple text file with UTF-8 encoding. We also recommend using the

byte order mark (BOM). Every translatable string is defined by a constant, an equal sign

and the translation string. Translation strings must not include line breaks. To add line

breaks in longer translation strings, such as error messages, insert a TAB character. 

You don't have to include all items in the language file. The viewer will automatically use

the standard English value for items that are not included.

The %s placeholders: 

Note that some string names include an "%s" placeholder in the name and the text, for ex-

ample the name ERR_OPENINVALID%s. You must always include the "%s" placeholder,

and names that contain one or more of these placeholders must have the same number

of them in the translation string. The "%s" is is used for internal string formatting.

The & Alt key markers:

Similarly, texts used in menus have a & marker before the letter to be used as the ALT key

keyboard shortcut. You should include this marker in your own texts in front of the letter

to be used for your shortcut.

Example of a .lang file:

BACK=&Back
FORWARD=&Forward
ZOOMOUT=Zoom &Out
ZOOMIN=Zoom &In
PRINT=&Print
OPEN=Open...
OPENRECENT=Recent Documents
CLEARRECENT=Clear Menu
CLICKTOOPEN=Click on the logo to open an .ewriter book
CLEARCACHE=Clear browser cache and reload page?
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EWRITERFILEFILTER%s=eWriter Books|%s
ERR_FILENOTFOUND%s=Cannot open "%s"! File not found.
ERR_OPENINVALID%s=Cannot open "%s"!  This file is damaged or has
an invalid format.
ERR_EXPIRED%s=Cannot open "%s"!  This file has expired.
ERR_PASSWORDFAILURE%s=Cannot open "%s".  Wrong password!

As you can see, there are really very few needed strings.

6.2.6.8 EWriter for Software Help

To use eWriter help files for documenting your own software you must do two things:

· Install the eViewer executable  together with your application

· Make your help calls directly to the version you installed

There are also some important file extension and other registration steps you need to take,

particularly for MacOS.  See Installation & Configuration  in The eViewer Apps chapter for

details.

6.2.6.8.1  Links & Context Help

On Windows, eWriter Help is the modern alternative to the obsolete CHM format for local ap-

plication help. It offers full support for context-sensitive help and file links and combines the

benefits of CHM and WebHelp while eliminating many of the disadvantages of both. On

MacOS eWriter provides an software help format that is not otherwise available in this integ-

rated form.

This topic provides a quick overview of the link options. For full details see the EWriter for

Software Help  chapter.

Viewer installation for eWriter as software documentation

When you are using eWriter as software documentation to replace CHM files you need to

know where the viewer is so that you can make your calls to it reliably. We recommend in-

stalling the standard version of the viewer for this together with your software. See

EWriter for Software Help  for details.

Each book is opened in a separate instance of the eViewer app

Each book you open has one and only one instance. If you make another call to the same

book it will apply to the open instance. You can have multiple books open at the same

time. To address the individual books you include the name of the book in your call along

with the parameters, as shown below.
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Choosing the right file extension for your eWriter files

Use the .ewriter file extension for books distributed on their own

You need to use the .ewriter extension for eWriter files that are going to be distributed

on their own. It is registered with the Windows Store, and when a Windows 10 user who

does not have the viewer opens an .ewriter file they will be prompted to install the

viewer from the Windows store. Users on older versions of Windows can download the

Win32 installer from our eWriter page, which will also register the .ewriter extension.

Use your own file extension for eWriter used for software document-

ation

When you are using eWriter for software documentation you want to install the Win32

version of eViewer together with your software and make your calls to it directly. You also

don't want to conflict with any other version of the viewer that your user may have in-

stalled, so in this case you don't want to use the .ewriter extension. Instead, see one of

your own. 

See URL-style command syntax  for full details on this.

EWriter context help links and command line interface

Making calls to eWriter help files from your applications to display topics is very simple.

On Windows, you basically just need to call the viewer app with a shellExecute() or

equivalent function in your programming language, along with the name of the topic file

to be viewed and an optional anchor to scroll to.

File extensions of your topic files

The HTML topic files inside eWriter Help can have either the .htm or .html extension,

based on your settings for the topic file extension in your project in Configuration > Pub-

lishing Options > WebHelp > HTML Export Options. However, only these two extensions

are permitted. If you set a different extension in your project (for example .php or .asp),

the standard .htm extension will be used.

You need to use the correct extension in your context help calls, otherwise the topics will

not be found.

739
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Context calls syntax

The syntax for context calls to eWriter Help has been changed with the introduction of the

new MacOS eViewer and the updated Windows eViewer. If you have used eWriter for ap-

plication help in the past the calls with the old syntax in your existing projects will still

work. However, we strongly recommend switching to the new integrated URL-style syntax

from now on. 

Please refer to the eWriter for Software Help  chapter for full details and instructions.

Basic New Syntax:

"<viewer app>" "ewriter://<ewriter file>?loadpage=<page in the
help>"

Note that when you are using integrated EXE eWriter Help files, the viewer app is the help

file itself, so it calls itself when using the new syntax.

Basic Old Syntax (not supported for MacOS):

"<viewer app>" "<page in the help>"

URL examples eViewer app:
"<path>eViewer.exe" "ewriter://<path>my_help.ewriter?loadpage=in-
dex.html"
"<path>eViewer.exe" "ewriter://<path>my_help.ewriter?loadpage=in-
dex.html?introduction.htm#anchor2"
"<path>eViewer.exe" "ewriter://<path>my_help.ewriter?loadpage=in-
troduction.html?anchor=anchor2 (Premium Pack)"

URL examples Windows EXE eWriter file:
"<path>MyHelp.exe" "ewriter://<path>MyHelp.exe?loadpage=index.html"
"<path>MyHelp.exe" "ewriter://<path>MyHelp.exe?loadpage=index.html?
introduction.htm#anchor2"
"<path>MyHelp.exe" "ewriter://<path>MyHelp.exe?loadpage=introduc-
tion.html?anchor=anchor2" (Premium Pack)

URL parameters and JavaScript

If your HTML pages include scripts that can evaluate URL parameters (supported in some

Premium Pack skins, for example) you can also include parameters to be parsed by your

script, like this:

"<path>eViewer.exe" "ewriter://<path>my_help.ewriter?loadpage=in-

731
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dex.html?mysetting=xyz&setting2=12"

The HTML location object is fully supported for interpreting URLs you pass to your pages

like this. This means you can extract the query portion of the script with document.loc-

ation.search, the hash portion (anchor) with document.location.hash and so on. 

Linking between eWriter files

If you have multiple eWriter help files installed on your user's computer you may some-

times want to link between them. This will normally only apply when you are using eWriter

for software documentation . 

There are several methods you can use for linking between eWriter files. You must always

use the File Link option for this, not the Internet Link!

Linking between eWriter files when the file association is known

You can use a simple method if you are sure that the .ewriter extension has been asso-

ciated with the eViewer application, or if you are using your own extension that you have

registered as part of your installation on the user's computer. Then you just need to refer-

ence the eWriter file and the topic parameters.

This also works when you have changed the file extension and eViewer name:

Note that this also works if you are using eWriter for software documentation and you

have changed both the file extension and the name of your copy of the eViewer applica-

tion. You just need to link to another eWriter file that has the same extension as the

eWriter file containing the link. 

File name: The name of the eWriter file you want to link to without any path

information. Just the file name. You must use the extension that has

731
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been registered to the eViewer application on the user's computer.

This will be .ewriter if you are sure that has been registered, or

your own custom extension if you are installing eViewer as part of

your software installation and registering the extension yourself. 

Relative path: Only include the path to the file here if the target file is not in the

same folder as the file containing the link. Despite the name, you

can use either a relative or an absolute path.

Important: No quotes around this path, even if it includes spaces!

Execution para-

meters:

The normal WebHelp reference to the topic you want to display in

the target file. The syntax depends on the skin type you are using.

This parameter must be enclosed in double quotes.

Standard Help+Manual skins and older Premium Pack skins:

"index.html?topic.html"

Premium Pack V3 skins:

"topic.html"

Topic file extensions

The topic file extension can be .htm or .html, depending on what

you have set in your project. Other extensions are not allowed for

eWriter topics. 

Anchors and other parameter extensions

Add these in the execution parameters, inside the double quotes,

exactly as you would in WebHelp. 

Using an Internet link instead of a File link (required for MacOS)

You can also use an Internet link to link between eWriter Help files, but then you have to

use the new syntax with the ewriter:// prefix. This is also required if you are using

eWriter Help on MacOS.

ewriter://NewProject.ewriter?loadpage=index.html?topic_name.html
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Linking between files when you are using the integrated viewer in

EXE eWriter books

When you create combined book and viewer files with the EXE extension you always just

enter the EXE file as the file to link to and the topic to open as the parameters. 

File name: The name of the eWriter EXE file you want to link to without any

path information. Just the file name.

Relative path: Only include the path to the file here if the target file is not in the

same folder as the file containing the link. Despite the name, you

can use either a relative or an absolute path.

Important: No quotes around this path, even if it includes spaces!

Execution para-

meters:

The normal WebHelp reference to the topic you want to display in

the target file. The syntax depends on the skin type you are using.

This parameter must be enclosed in double quotes.

Standard Help+Manual skins and older Premium Pack skins:
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"index.html?topic.html"

Premium Pack V3 skins:

"topic.html"

Topic file extensions

The topic file extension can be .htm or .html, depending on what

you have set in your project. Other extensions are not allowed for

eWriter topics. 

Anchors and other parameter extensions

Add these in the execution parameters, inside the double quotes,

exactly as you would in WebHelp. 

Calls to EXE eWriter files with the integrated viewer

You can still create the original EXE eWriter files with an integrated viewer if you wish, al-

though we strongly recommend using the separate viewer. You just need to change the

output file extension to .exe in the Publish screen before publishing. Help+Manual iden-

tifies this automatically and then creates an EXE eWriter Help file with an integrated

viewer.

Not supported on MacOS

Note that EXE eWriter Help is a Windows format and cannot be used on MacOS. On Macs,

you must use the eViewer app and .ewriter data files.

Context calls syntax

The calling syntax is the same as with the external viewer, except you call the EXE eWriter

Help file instead of the viewer, followed by the parameters. You can use both the old and

the new syntax for this.

Old syntax:

<path>my_ebook.exe "index.html?introduction.htm"
<path>my_ebook.exe "index.html?this_page.htm#anchor"
<path>my_ebook.exe "index.html?anotherpage.htm"

New syntax:
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If you use the new syntax, you must also include the name of the EXE eWriter Help file

after the ewriter:// protocol prefix, so that the file is calling itself:

<path>my_ebook.exe "ewriter://my_ebook.exe?loadpage=index.html?
introduction.htm"
<path>my_ebook.exe "ewriter://my_ebook.exe?loadpage=index.html?
this_page.htm#anchor"
<path>my_ebook.exe "ewriter://my_ebook.exe?loadpage=index.html?
anotherpage.htm"

Always include the page parameters in quotes, even if there are no spaces. Otherwise you

will get Windows errors caused by some of the characters that need to be used. 

Links to executable files

If you're used to producing CHM files and WebHelp you don't even think about opening

executable EXE program files from your documentation. But with eWriter Help, you can!

This is possible both from normal links in topics and from TOC entries.

RESTRICTION: Not supported in the Windows Store version of the

viewer!

Windows Store apps are not permitted to invoke executable files from within the program.

Because of this, the functions described below are not available in the Windows Store ver-

sion of the viewer app. However, you can use them if you are installing the standard Win-

dows eViewer app together with your software. See EWriter for Software Help  for de-

tails.

Current directory status when linking to executable files

When executing external files, the eWriter viewer explicitly sets the current directory to

prevent possible failure of file links using a relative path.

File links to executables in topics

Just create a normal file link to the EXE file and add exec: directly before the file name,

like this:

exec:notepad.exe
exec:../demo_program/widget_maker.exe
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Links to executables in the TOC

You can also create links to executable files in the TOC of an eWriter Help file. Create a

new topic entry and choose the TOC Link option, and then Link to Web Address. Then

enter the target in the Web Address: field, using same exec:filename.exe format as

above. Here too, you can include a relative path if necessary.

exec:notepad.exe
exec:../demo_program/widget_maker.exe

6.2.6.8.2  URL-style command syntax

To unify the Windows and MacOS platforms, we have implemented the same URL-style com-

mand syntax in both versions of eViewer. The syntax is identical, but the calling conventions

are slightly different because of the different platforms.
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How context help works on Windows and MacOS

How context help calls work on Windows

On Windows, you can call an executable with command line parameters. Multiple calls to

the same executable will normally start multiple instances of the program. However, this is

prevented by the eViewer application. It always displays just one instance of the viewer for

the same help file, even when you make multiple calls to it.

How context help calls work on MacOS

On MacOS, when an application is opened by another program, it is possible to specify

command line parameters as well. But only once. Because of the general single-instance

policy on MacOS, a subsequent call to the same executable does not create a new in-

stance. Instead, it brings the running instance into foreground. At this point, the already

running application does not receive the (different) command line parameters after the --

args command line switch. 

All is not lost, however, because MacOS also makes it pretty simple to register a custom

URL scheme  for an app, which can be used both to open your app and pass commands

to a running instance.

Differences between standard HM skins and frameless Premium
Pack skins

The references for topic files in your call URLs are slightly different for standard

Help+Manual skins and frameless Premium Pack skins. With the standard skins you need

to call both the layout page (index.html) and the topic page (topic.htm or top-

ic_id.html, depending on what you set as your topic extension in your project). 

Standard skins:

ewriter://<path>my_doc.ewriter?loadpage=index.html?topic.htm#an-
chor_id

Premium Pack V3, V4 and V5 skins

ewriter://<path>my_doc.ewriter?loadpage=topic_id.html?anchor=an-
chor_id

725
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Basic URL command syntax

The URL command combines 3 parts: a) the protocol, b) the domain which is our ewriter

file and c) the optional command parameters as the URL query part.

The URL is preceded by the viewer reference

All examples are the argument. They must always be preceded by a reference eViewer app

or the eWriter EXE file name if you are using that format on Windows. When using stan-

dalone Windows EXE files the file is both the viewer and the target and calls itself.

You can use two ? separators in the same URL

Note that you use the ? character after the index.html reference as the first separator,

even though it also comes after the eWriter Help file name. This is because the URL is ac-

tually two combined URLs that are split internally by the viewer.

Protocol Domain (eWriter data file) Query (Command parameters)

ewriter:// <path>my_doc.ewriter loadpage=topic.html
defpos=50,50

Resulting URL (Windows):
ewriter://c:\users\username\documents\my_doc.ewriter?loadpage=in-
dex.html?topic.htm&defpos=50,50
ewriter://c:\users\username\documents\my_doc.ewriter?load-
page=topic.html&defpos=50,50

Resulting URL (MacOS):
ewriter:///Users/username/documents/my_doc.ewriter?loadpage=in-
dex.html?topic.htm&defpos=50,50
ewriter:///Users/username/documents/my_doc.ewriter?load-
page=topic.html&defpos=50,50

Making calls on Windows

 Calls on Windows with eViewer.exe and data help files

The calling convention on Windows is:

Open:     eViewer.exe "urlstring"
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Note:

The protocol for the Windows version is always ewriter://, even if the app has been re-

named. This is possible because the protocol cannot create conflicts on Windows.

Examples:

eViewer.exe "ewriter://c:\users\username\documents\my_e-
book.ewriter?loadpage=index.html?topic.htm&defpos=50,50"

Myviewer.exe "ewriter://c:\users\username\documents\my_e-
book.ewriter?loadpage=topic.html&defpos=50,50"

Escaping (percent encoding) URLs:

The URL can be escaped (percent encoded) on Windows. When served in quotes as a

command line string, the URL is technically a simple string and eViewer.exe will take it at

face value, even if it is not escaped. Escaped URLs will be unescaped internally.  See How

to escape a URL  below.

 Calls on Windows with integrated EXE help files

On Windows you can also create eWriter Help files as a standalone EXE with an integrated

viewer. The calling syntax for these files is exactly the same, with the difference that the

file calls itself. This is because the file is both the viewer and the help file. So it looks like

this:

<path>\widgets_intro.exe "ewriter://<path>\widgets_intro.exe?load-
page=index.html?topic.htm&defpos=50,50"

<path>\advanced_version.exe "ewriter://<path>\advanced_version.exe?
loadpage=topic.html&defpos=50,50"

Making calls on MacOS

 MacOS

The calling convention on MacOS is two-fold. You can use the command line (but only

once) and you can also optionally open the custom URL directly:

Open:    eViewer.app --args "urlstring"

Open:    "urlstring"
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Note:

You must use the same protocol on MacOS that you modified in the installer's

Info.plist. See Installation & Configuration .

If the protocol doesn't work immediately after modification, start the app with a double

click. This should be sufficient to register the custom URL scheme on the Mac.

Examples:

(a) Command line arguments
eViewer.app --args "ewriter:///Users/username/documents/my_e-
book.ewriter?loadpage=index.html?topic.htm&defpos=50,50"
Myviewer.app --args "myprotocol:///Users/username/documents/my_e-
book.ewriter?loadpage=topic.html&defpos=50,50"

(b) Custom URL scheme
"ewriter:///Users/username/documents/my_ebook.ewriter?loadpage=in-
dex.html?topic.htm&defpos=50,50"
"myprotocol:///Users/username/documents/my_ebook.ewriter?load-
page=topic.html&defpos=50,50"

The URL must be escaped with percent encoding on MacOS. It will work unescaped

when served in quotes as a command line string, but the direct call to a custom URL

scheme requires a properly escaped URL.

How to escape your calling URLs with percent encoding

A URL is a single string without spaces. It is made up of a protocol, a domain and trailing

query strings. No spaces are allowed in the domain or the query strings. The domain and

query strings are separated by a question mark (?). Multiple query strings are separated by

an ampersand (&). For detailed information, see the W3C website  HTML URL Encoding

Reference.

To serve the URL string correctly, we must at least escape all spaces in the entire URL and

the question marks within parameters:

Char Escaped string

(space) %20

? %3F

Raw:
"ewriter://c:\users\user name\my documents\my ebook.ewriter?load-
page=index.html?topic.html&defpos=50,50"
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Escaped:
"ewriter://c:\users\user%20name\my%20documents\my%20ebook.ewriter?
loadpage=index.html%3Ftopic.html&defpos=50,50"

6.2.6.8.2.1  loadpage

The loadpage parameter opens and displays a specific HTML page from the eWriter file by

page name. The format of this string depends on the contents of the .ewriter file. 

For .ewriter books created with Help+Manual, the parameter is typically index.html, fol-

lowed by a question mark and the topic page, or it is the topic page directly. Which version is

appropriate, depends on the Webhelp skin used for compilation. Please refer to the

Help+Manual online help for details.

Rule of thumb

Use index.html?topicpage.html for older skins and bare-bone skins (because these skins

implement frames and "index.html" is always the top frame).

Use topicpage.html for frameless Premium Pack skins (V3, V4, V5).

When using standalone EXE eWriter Help files for Windows the file is both the viewer and the

target. The viewer thus calls itself. Otherwise the syntax is exactly the same.

Value Example

Topic page in
the help file

loadpage=index.html
loadpage=index.html?introduction.htm#anchor2
loadpage=introduction.html?anchor=anchor2 (Premium

Pack)

Note:

All examples are the argument. They must always be preceded by the eViewer app or the

eWriter EXE file name if you are using that format on Windows. When using standalone Win-

dows EXE files the file is both the viewer and the target and calls itself.

URL examples eViewer app:
ewriter://<path+filename>?loadpage=index.html
ewriter://<path+filename>?loadpage=index.html?introduction.htm#anchor2
ewriter://<path+filename>?loadpage=introduction.html?anchor=anchor2
(Premium Pack)

URL examples Windows EXE eWriter file:
ewriter://<path+EXEfilename>?loadpage=index.html
ewriter://<path+EXEfilename>?loadpage=index.html?introduction.htm#an-
chor2
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ewriter://<path+EXEfilename>?loadpage=introduction.html?anchor=anchor2
(Premium Pack)

6.2.6.8.2.2  loadcontext

The loadcontext parameter opens and displays a particular HTML page from the eWriter

file by help context number, if the .ewriter book supports it. 

All .ewriter books created by Help+Manual that have the "Enable command line interface" ex-

port option activated (default) include a list of help context numbers and can be called with

this parameter.

When using standalone EXE eWriter Help files for Windows the file is both the viewer and the

target. The viewer thus calls itself. Otherwise the syntax is exactly the same.

Value Example

Help context
number

loadcontext=1000

Note:

All examples are the argument. They must always be preceded by the eViewer app or the

eWriter EXE file name if you are using that format on Windows. When using standalone Win-

dows EXE files the file is both the viewer and the target and calls itself.

URL example eViewer app:
ewriter://<path+filename>?loadcontext=1234

URL example Windows EXE eWriter file:
ewriter://<path+EXEfilename>?loadcontext=1234

6.2.6.8.2.3  defpos

Sets the position and size of the viewer window. This parameter affects the first call to an

.ewriter file only. Subsequent calls (if the .ewriter file has been opened already) will not change

the window position at runtime.

 Windows

Pixel values are absolute physical pixels. On high resolution displays, you must take the sys-

tem DPI into account, because eViewer.exe is DPI-aware. The stayontop option applies to the

Windows version only.
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 MacOS

Pixel values are logical pixels that map to the default size of a non-retina display. The values

may be increased by MacOS depending on the display type and user settings. The stayontop

option is ignored, there is no equivalent for this on MacOS.

Values Example

left,top defpos=50,50

Creates the eViewer window at 50/50 pixels of the screen.

Window size is initialized from the default position specified

in the eWriter file and remembered after the user has viewed

this file once.

left,top,width,height defpos=50,50,800,400

Creates the eViewer window at 50/50 pixels of the screen,

with a width of 800 and a height of 400 pixels.

left,top,width,height,
stayontop

Note:

stayontop is only valid on

Windows

defpos=50,50,800,400,stayontop

Creates a stay-on-top eViewer window at 50/50 pixels of the

screen, with a width of 800 and a height of 400 pixels.

defpos=50,50,stayontop

Creates a stay-on-top eViewer window at 50/50 pixels of the

screen, default width and height.

defpos=stayontop

Creates a stay-on-top eViewer window, default size and posi-

tion.

kioskmode defpos=kioskmode

Switches the eViewer app into full-screen kiosk mode (win-

dow size and position does not apply).

Note: 

In kiosk mode, the user has no visual controls to modify the

window dimensions. Kiosk mode can only be exited by press-

ing ALT+F4 (Windows) or CMD+Q (MacOS).
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Note:

All examples are the argument. They must always be preceded by the eViewer app or the

eWriter EXE file name if you are using that format on Windows. When using standalone Win-

dows EXE files the file is both the viewer and the target and calls itself.

URL examples eViewer app:
ewriter://<path+filename>?defpos=50,50,700,900,stayontop
ewriter://<path+filename>?defpos=50,50
ewriter://<path+filename>?defpos=kioskmode

6.2.6.8.2.4  openmenu

Shows or hides the general menu items Open  and Recent Documents .

Open menu shown on MacOS Open menu on Windows

Value Example

true
false

openmenu=true  (default for the original "eViewer.app" and

"eViewer.exe")

openmenu=false (default for renamed executables)

Note:

All examples are the argument. They must always be preceded by the eViewer app or the

eWriter EXE file name if you are using that format on Windows. When using standalone Win-

dows EXE files the file is both the viewer and the target and calls itself.

727 727
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URL example eViewer app:
ewriter://<path+filename>?openmenu=false

6.2.6.8.2.5  pw

Sets the password preset to open a password-protected eWriter file.

When opening a password-protected eWriter file, the user is normally prompted to enter the

password. This command line switch passes the password directly to the file so that the user is

not prompted to enter it. 

Important security warning:

Submitting the password for a protected ebook as command line parameter is not secure. The

command line password may be hidden for an average user but tech-savvy users can easily

find it.

Value Example

password pw=mypassword

Note:

All examples are the argument. They must always be preceded by the eViewer app or the

eWriter EXE file name if you are using that format on Windows. When using standalone Win-

dows EXE files the file is both the viewer and the target and calls itself.

URL example eViewer app:
ewriter://<path+filename>?pw=mypassword

6.2.6.8.2.6  close

Closes the window of this eWriter file (if called with a file name) or closes the viewer instance

with all windows (if called without a file name)

Note:

Close is the only command that does note require a file name. However, you must still in-

clude the "?" query separator.

Value Example

(none) close
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Note:

All examples are the argument. They must always be preceded by the eViewer app or the

eWriter EXE file name if you are using that format on Windows. When using standalone Win-

dows EXE files the file is both the viewer and the target and calls itself.

URL example eViewer app:
ewriter://<path+filename>?close
ewriter://?close

URL example Windows EXE eWriter file:

ewriter://<path+EXEfilename>?close

6.2.6.8.2.7  JavaScript

URL parameters and JavaScript

If your HTML pages include scripts that can evaluate URL parameters (supported in some

Premium Pack skins, for example) you can also include parameters to be parsed by your

script, like this:

eViewer app:
ewriter://<path+filename>?loadpage=index.html?mysetting=xyz
ewriter://<path+filename>?loadpage=index.html?introduction.ht-
m&mysetting=xyz#anchor2
ewriter://<path+filename>?loadpage=introduction.html?myset-
ting=xyz&anchor=anchor2 (Premium Pack)

Windows EXE eWriter file:
ewriter://<path+EXEfilename>?loadpage=index.html?mysetting=xyz
ewriter://<path+EXEfilename>?loadpage=index.html?introduction.ht-
m&mysetting=xyz#anchor2
ewriter://<path+EXEfilename>?loadpage=introduction.html?myset-
ting=xyz&anchor=anchor2 (Premium Pack)

The HTML location object is fully supported for interpreting URLs you pass to your pages

like this. This means you can extract the query portion of the script with document.loc-

ation.search, the hash portion (anchor) with document.location.hash and so on. 

6.2.7 Kindle/Mobi and ePUB 3.0 eBooks

The standard ePUB and Amazon Kindle/Mobi eBook formats are so similar internally that we

group them together. Almost all their configuration settings are identical, and because of this

they can be configured with the same settings in your project's Configuration sections. 
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Standard ePUB eBooks

ePUB eBooks  are a standard, generic and open eBook format that is supported by

many software readers on all computer platforms and hardware devices, including the 

Apple iBooks® eBook reader on the iPad, iPhone and iPod Touch, Sony Reader and many

others . ePUB eBooks are cross-platform and a huge number of eBooks are already

available in this format.

Amazon Kindle/Mobi eBooks

Kindle/Mobi is the proprietary format used for Amazon Kindle eBooks, which can be read

on the Amazon Kindle hardware eBook readers and a wide variety of Amazon Kindle apps

on different platforms. Internally, this format is really just a minor variant of the universal

ePUB format. However, Kindle eBooks are packaged in a proprietary Amazon binary

format instead of in a normal ZIP file like standard ePUB. There are just a few formatting

and configuration changes that need to be made and these are handled automatically by

Help+Manual.

See also:
Publishing Formats - Kindle and ePUB eBooks

ePUB resources

6.2.7.1 Standard ePUB 3.0 eBooks

Key Information
Keep your eBook projects simple. Avoid complex lay-

outs and formatting, only use simple tables and don't

use invisible topics. Only a..z, A..Z, 0..9 and _ are per-

mitted in topic IDs in eBooks!

About ePUB 3.0

The ePUB 3.0 format introduced in Help+Manual 9 is fully backwards compatible with

ePUB 2.0. Even older ePUB readers can open and display an ePUB 3.0 eBook. There is no

break in versions or any minimum requirement. However, ePUB 3.0 offers more freedom

in page design. 

Help+Manual now has additional formatting settings for ePUB. This includes an editable

Table of Contents template and an editable HTML page template. These are similar to the

corresponding templates in WebHelp, but you should be aware that the formatting op-

tions in eBooks are still quite limited compared to HTML web pages. Avoid complex layout

and formatting. Large and complex tables and tables containing images should be con-

sidered to be toxic, because they will almost always destroy your layout. 
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Install Calibre or Adobe Digital Editions for local testing

Before generating ePUB eBooks you need to install a viewer for previewing the results on

your Windows machine. There are currently only two viewer programs that provide good

results for this on Windows: The free Calibre program and Digital Editions from Adobe. 

We now strongly recommend using Calibre. It is an excellent tool and supports a wide

range of different eBook formats very well, including both ePUB and the Amazon

Kindle/Mobi  format that you can now also generate with Help+Manual. Adobe Digital

Editions only supports ePUB and is rather dated and limited compared to Calibre. Also, Di-

gital Editions was recently found to be  spying on users and collecting their data

without telling them.

 Calibre download page

If you want to use Adobe Digital Editions it is also free and you can get it here:

 Adobe Digital Editions download page

If you plan to target other readers and devices you may also want to get those for testing,

of course. See ePUB Resources  for more information and sources. 

Styles, font faces and variable font size

Styles used in ePUB

Most of the style settings in your project will be used in ePUB eBooks with the exception

of the font face (see below). If you have separate style settings defined for screen and

print view  then the print view settings will be used in ePUB.

You can't choose your font faces for most readers

Apple iBooks® and many other eBook readers use their own font faces and may ignore

the font settings in your project. Your text will be displayed using the font setting in the

reader. Some eBook readers allow the users to change fonts for their viewing pleasure,

but you have no control over that. 

Some readers support font embedding

Adobe Digital Editions and some other eBook readers will display your font faces if you

embed them in the reader. However, this makes your ePUB files much bigger and you

must have permission to distribute the fonts from the font copyright holders! See

Managing Fonts in eBooks  for details.

Variable font size

Users want to be able to change the font size in the reader. To make this possible you

must set your font size encoding to either percent or ems in Project Explorer > Configur-
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ation > Publishing Options > WebHelp > HTML Export Options. Setting the font size

encoding to pixels or points will make the fonts fixed size in some readers, which is not

what you want in ePUB.

HTML page template for ePUB

Usually, you don't need to make any changes to the HTML page template for ePUB out-

put. It is already set up for maximum compatibility with Apple iBooks® and a wide range

of other eBook readers with ePUB support.

Edit the ePUB page template at your own risk:

If you want to make adjustments to the template you can edit it in Project Explorer >

Configuration > Publishing Options >  eBooks > ePUB: Page Template. However, do

edit it unless you are familiar with the ePUB requirements, which are very strict. 

Viewing and editing the source files of ePub eBooks

The ePUB eBook standard is open, free and fully documented in the  International Di-

gital Publishing Forum. Help+Manual produces standard ePUB source files that you can

also edit and process manually and with other programs for editing and producing ePUB. 

Accessing the source files:

When you publish to ePUB the source files are automatically written to a new folder in

your project folder called:

~tmpepub

If you turn off the Delete temporary files after publishing option in the Publish dialog page

you can edit these files directly with any text editor provided you observe the OPF spe-

cifications for ePUB eBooks. However, note that Apple iBooks® is extremely quirky, so get

information on its requirements before trying to create iBooks® ePubs yourself!

Making an ePUB file from the source files:

An ePUB eBook is actually a normal zip archive with the extension .epub instead of the

normal .zip extension. After editing your ePUB source files you can create a valid ePUB

eBook by copying the contents of the ~tmpepub folder to a zip archive and then chan-

ging the extension to .epub.

http://idpf.org/epub
http://idpf.org/epub
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Important: Make sure that the sub-folders are included in the zip archive! Some zip pro-

grams will store all the files in the zip without internal folders if you are not careful. 

6.2.7.2 Amazon Kindle/Mobi eBooks

The Amazon Kindle/Mobi format is the proprietary eBook format used for the Amazon Kindle

platform. Internally it is almost identical to ePUB, but it is packaged in a proprietary binary

container instead of in a standard Zip archive like ePUB. 

Since the actual format of Kindle/Mobi is so similar to ePUB, the two formats share the same

basic settings. You can configure these settings in Project Explorer: Configuration > Publish-

ing Options > eBooks.

Install the Amazon Kindle Previewer to get the Kindle compiler

You need the free Kindle compiler from Amazon to be able to publish Kindle/Mobi

eBooks. This compiler is included in the Amazon Kindle Previewer package, which you can

download here:

Download the Amazon Kindle Previewer

Important: Do NOT try to install the Kindle Previewer in the Program

Files folder!

Don't change the default installation location of the Kindle Previewer

package! If you do, it will not work correctly and you will get all kinds of

errors. Because of the way this Amazon program works, it absolutely

needs to be installed in your Windows user account directory in the loca-

tion Amazon specifies, otherwise it will not have the necessary write per-

missions while it is running.

Once installed, H+M should find the Kindle compiler automatically. If you have problems,

you can set the location automatically in View > Program Options > Compilers. The

standard location for the compiler is:

Kindle Previewer version 2:

C:\Users\YourUserAccount\AppData\Local\Amazon\Kindle Pre-
viewer\lib\kindlegen.exe

http://www.amazon.com/gp/feature.html?docId=1000765261
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Kindle Previewer version 3:

C:\Users\YourUserAccount\AppData\Local\Amazon\Kindle Previewer
3\lib\fc\bin

Install Calibre for local testing

Before generating ePUB eBooks you need to install a viewer for previewing the results on

your Windows machine. The free Calibre program is currently the only solution that can

be recommended for Kindle/Mobi books on Windows. 

Calibre is an excellent tool and supports a wide range of different eBook formats very well,

including both ePUB and Kindle/Mobi. 

 Calibre download page

Formatting restrictions in the Kindle app on iOS

At the time of writing, the iOS Amazon Kindle app for the Apple iPad and iPhone is in-

ferior to other software and hardware Kindle applications in many ways. Since so many

users read Kindle books on these devices you need to be aware of these restrictions and

avoid formatting that will result in ugly or incorrect layout on these devices.

Lists only support plain black round bullets and simple numbering

No other bullets will be displayed in lists on the iOS Kindle app and multi-level lists with

changing numbering and bullet formats will be displayed as an unpredictable mess. It is

best to use only simple bullet lists, and simple numbered lists. Also, numbered lists should

not contain more than 9 items, because the indents will look incorrect as soon as the list

switches from single to double digits.

Indents are ignored entirely

Indented paragraphs are not possible in Kindle eBooks displayed on the iOS version of the

Kindle app. They will simply be ignored by the reader.

Table column widths and vertical alignment are ignored

If you use tables in your Kindle eBook any column widths you set will be ignored. Vertical

alignment settings for tables are also ignored. Instead, all alignment is automatically set to

http://calibre-ebook.com/download
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middle. The result is that the text in table cells with less text is centered vertically instead

of starting at the top or bottom of the cell. There is currently no way to change this. 

Restrictions on the Kindle app for Windows Phone

At the time of writing, the restrictions in the Kindle app for Windows Phone are particu-

larly extreme. Formatting is very limited and unpredictable and it is not possible for Win-

dows Phone users to load Kindle books onto their phones themselves. This is only pos-

sible via the Kindle store.

If you want to target Windows Phone users we strongly recommend that you avoid the

Kindle/Mobi format. Use standard ePUB instead, so that your users can load their eBooks

themselves with a third-party eBook app.

Styles, font faces and variable font size

Styles used in Mobi

Most of the style settings in your project will be used in Mobi eBooks with the exception

of the font face (see below). If you have separate style settings defined for screen and

print view  then the print view settings will be used in Mobi.

Your font face choice is not final

The Kindle readers allow users to select the font they want to display their book in. You

have no control over that. 

Mobi supports font embedding

You can embed your fonts in your Mobi books, but this may not be worth the trouble

since users can change the display font anyway. Embedding fonts makes your eBook files

much bigger and you must have permission to distribute the fonts from the font copy-

right holders as well. 

Variable font size

Users want to be able to change the font size in the reader. To make this possible you

must set your font size encoding to either percent or ems in Project Explorer > Configur-

ation > Publishing Options > WebHelp > HTML Export Options (these options are also

used in eBooks). 

Viewing and editing the source files of Mobi eBooks

Help+Manual produces standard Mobi source files that you can also edit and process

manually and with other programs for editing and producing Mobi eBooks. 

1348
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Accessing the source files:

When you publish to Mobi the source files are automatically written to a new folder in

your project folder called:

~tmpmobi

If you turn off the Delete temporary files after publishing option in the Publish dialog page

you can view and edit these files directly with any text editor or a program that supports

editing the source of Kindle/Mobi eBooks. Note that the specifications for Kindle eBooks

are very strict, so familiarize yourself with them in detail before proceeding.

See also: (ePUB suggestions and settings shared with Mobi)
Formatting recommendations

ePUB settings

Managing Fonts in ePUB

6.2.7.3 Formatting recommendations

Keep your layout and formatting as simple as possible! Kindle and ePUB eBooks are really de-

signed to behave like books, not like electronic documents. They are not designed to support

the dynamic features you may take for granted in other types of electronic documents.

Avoid complex formatting, no scripting or dynamic features

Support for XHTML and CSS is limited and often quirky. Scripting can be considered to be

not available. Keep everything as simple as possible. 

Think book, not website!

Image and video size and use restrictions

Images:

Keep images relatively small and don't insert them in tables. It is a good idea to use the

Zoom is proportional to document width property in the Insert Image dialog to size the im-

age automatically relative to the eBook viewer page. 

Videos:

Videos are only supported on iOS, and will not work in eBooks on any other platform.

Apple recommends a maximum of not more than 11 megabytes of images per chapter for

acceptable performance, particularly on the iPad 1. Images with more than two million

pixels (width x height) are not guaranteed to display in iBooks®, and they would also be

much too big to display normally on any eBook reader, including relatively large readers

like the iPad..
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If you want to show a large video put it on YouTube and embed it with the YouTube op-

tion , then the iPad will switch to the YouTube app automatically and open the video

there. Videos will not work on any other ePUB reader.

Remember that most eBook readers have a very narrow effective page width, so if you

want images to be visible they should be placed directly on the page in paragraphs of their

own. They should also not be too high, because tall images will force page breaks and

leave ugly gaps in your pages.

Caution with images in tables

Generally, it is better to avoid images in  tables entirely. It is much better to put every im-

age directly on the page in a paragraph of its own. It is much easier for an image in a table

to break your layout than an image on the page. This applies particularly to tables with

more than one column. 

Restrictions and requirements for topics

Topics designed for ePUB and Kindle/Mobi have the following requirements and restric-

tions:

· Regular text is OK.

· Formatted text is OK.

· Font management requires special consideration – see Managing Fonts .

· Internal topic links only – no file links or script links.

· External HTTP links are supported but they won't work on hardware readers without

web access!

· All image formats supported in H+M can be used, images are converted according

to your HTML Export options  settings if possible, but conformity with eBooks re-

quirements have priority.

· Simple tables only. If possible, avoid tables entirely. No nested tables, no fixed-width

tables, no complex tables, no tables with background images.

· No JavaScript, no manual page breaks.

· Video is only supported in Apple iBooks®. Consider it to be not available in any

other reader, so only include videos if you in eBooks designed exclusively for

iBooks. 

· Hotspots in images are not supported by any ePUB readers.

Restrictions and requirements for the TOC

The TOC in ePUB and Kindle/Mobi has the following restrictions and requirements:

· Normal topics entries and chapter entries that are topics (chapters with text) are OK.

553
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· Topic entries with anchor references are OK (a TOC entry that links to an anchor in a

topic).

· TOC entries that are chapters without text are not recommended. The TOC entry will

point to the first topic of the chapter.

· No TOC entries that link to external help files or web pages.

No special characters in topic IDs

These eBooks are special compressed formats with internal file systems taht only support

7-bit characters in the internal file names. Make sure that your topic IDs only use a..z, A..Z,

0..9 and _, no other characters. This is also general good practice to avoid possible prob-

lems in all project types.

No topics without TOC entries (invisible topics)!

This requirement is the same as in PDF. Only topics that have TOC entries will be included

in your eBook output. All topics without TOC entries are ignored and will not be included

in your eBook.

6.2.7.4 Cover pictures with title and author

Because of the way that the ePUB and Kindle formats work, your book cover can only contain

a picture. There is no reliable facility for including text on top of the picture and any text ad-

ded would not be displayed in the eBook preview in the library section of the eBook reader. 

ePUB and Kindle covers and TOC tutorial project

You can find a tutorial project with ready-to-use IPP cover image templates and templates

for your eBook TOC in the Examples\ePub Covers folder in your My HelpAndManual Pro-

jects directory. 

Variables in IPP cover images are converted automatically when you

publish

You can solve this problem by using IPP images made with Help+Manual's Impict image

editor, because Help+Manual will automatically convert variables in text objects in the im-

age when you publish the eBook. For example, you can insert variables like <%TITLE%>

and <%AUTHOR%> in text objects in the IPP image. You can also insert user-defined vari-

ables, like the <%SUBTITLE%> entry shown in the example below. 
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How to create an IPP cover with variables

Basically, you just need to select an IPP image created with Impict as the cover of your

book. If the text objects in the image contain variables Help+Manual will automatically

convert them before exporting the cover to the finished eBook as a PNG image.

Optimum dimensions and size for eBook covers

Originally, there were strict limitations on the size of eBook cover images. This has now

changed and you can use quite high resolution images, within reasonable limits. As a

guideline, Amazon now sets 1,000 pixels as the minimum dimension of the short (hori-

zontal) side of the cover image for Kindle eBooks. 

Do a Google image search for "eBook covers" to see some typical examples.

Procedure

1. Choose your cover image, load it in Impict  and save it using Impict's .IPP image

format. This is necessary to make the text objects and variables available to

Help+Manual so that it can exchange them while publishing. 

2. Add Text objects and type in the variables you want Help+Manual to replace when

you publish the book, using the <%VARIABLE_NAME%> syntax. For example,  <%

506
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TITLE%> and <%AUTHOR%> will insert the project title and author name from the Title

and Copyright settings in the Configuration section of your project.

3. You can use the Impict tools to make the cover more attractive. For example, you can

insert filled shapes behind the text objects to make the text stand out against the

background, and you can add shadow effects to the text. 

4. Choose the .IPP file as the cover image in your eBook settings, in Configuration >

Publishing Options > eBooks > ePUB+Kindle: General Settings.

6.2.7.5 eBook settings and templates

The basic configuration settings for ePUB listed below can be found here:

· Project Explorer: Configuration > Publishing Options > eBooks (ePUB, Kindle,

eWriter) > ePUB+Kindle: General Settings

In addition to this, the shared HTML Export Options  settings in the Publishing Options Set-

tings for WebHelp are also used for eBooks.

ePUB and Kindle covers and TOC tutorial project

You can find a tutorial project with ready-to-use IPP cover image templates and templates

for your eBook TOC in the Examples\ePub Covers folder in your My HelpAndManual Pro-

jects directory. 

Relevant settings in HTML Export Options

Most of the settings in HTML Export Options  are used for eBooks but the following

settings require special comments:

Font size encoding: Always set this to percent or ems! If you do not do this the user will

not be able to adjust the font size on many ePUB eBook readers. It

is also advisable to set the font size for Normal to 100% of the

browser's default font. Other values may have unexpected results

on some readers.

Export lists as text: This should generally be on to get the most consistent list format-

ting across different eBook readers and devices. 

Popups: Irrelevant for eBooks, no popups are available. 

1435

1435



761

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Publishing

ePUB+Kindle eBook settings

Cover pictures

Just click and select an image to add front and/or back cover pictures. You must use an

HTML-compatible format (JPG, PNG or GIF).

Configuration options

The only fields that are absolutely required are the book ID (UID), which is the unique

identifier for your eBook, and the title, without which your eBook will not display its title

properly in readers. Most of the other options are recommended, however.

You can use text variables  in all the fields listed below. 

Book ID:

Required! 

Also referred to as the UID. This is the unique identifier of

your eBook, so you should attempt to make it genuinely

unique to avoid confusion with other available publica-

tions. You can use any alphanumeric text string here – for

example your web address plus the name of the book. 

URI:

Optional but recommended

A web link, for example to a page with information about

the book on your website. It's a good idea to include this

as eBook readers often have online access. Always include

the http:// prefix with the URI, plain www. addresses will

probably fail!

ISBN:

Optional, recommended if you

have one

If your book has an ISBN code then enter it here.

Book Title:

Technically optional but re-

quired for proper display of

book title in readers

The title of your eBook.  You can use the <\%TITLE%>

variable to insert the title of your project here.

Subject: 

Optional but recommended

A short description of your eBook's subject matter.

Description:

Optional, generally helpful

A longer description of your eBook.

917
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Author:

Optional but recommended

The author of your eBook. If you have entered the author

of your project in your Common Properties you can insert

the <%AUTHOR%> variable here to use the same text string

automatically.

File Author as:

Optional

An additional attribute for the author that shows explicitly

how the author is to be filed officially. For example, you

might enter Rev. Dr. Martin Luther King Jr. for

Author and King, Martin Luther Jr. for File As.

Publisher:

Optional but recommended

The publisher (i.e. your company) of the eBook. 

Copyright:

Optional but recommended

Your copyright notice. You can use the <\%COPYRIGHT%>

variable to insert the standard copyright notice stored in

your project.

Relation:

Optional

Relation information for your eBook, this can be an URI

(weblink, the new term for URLs) or other information.

This is defined as an "auxiliary resource and its relation-

ship to the publication".

Embed fonts: Embeds the fonts used in your project in the eBook. See

below for more details on this.

Export HelpXplain slide

shows as interactive HTML:

If your project contains a HelpXplain slide show activating

this option will export it with full interactivity instead of as

a static image.Only use this option if you are certain that

the eBook readers you are targeting will support it. Most

readers have very limited HTML5 and CSS3 support. s

Font embedding

You can embed fonts used in your ePUB and Kindle eBooks. This is required for languages

with special character sets on some readers, including Adobe Digital Editions. Apple

iBooks does not require font embedding for special characters, but you may wish to em-

bed fonts to get more control over your book's appearance. 

Kindle does not display embedded fonts by default

Note that Kindle readers and apps do not user your embedded fonts by default. The user

must activate them in the device's or reader's font settings and must know that the setting
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is available. If your layout depends on a specific font you need to be aware that that font

will not be displayed by default on Kindle devices and apps!

Font rights, eBook size

Embedding fonts can make your eBook considerably larger and you must have permission

from the font copyright holder to distribute the fonts you embed.

See Managing Fonts in eBooks  for full details.

Table of Contents template for Kindle and ePUB

You can view and edit the Kindle and ePUB table of contents template in your project con-

figuration settings in this location:

Project Explorer > Configuration > Publishing Options >  eBooks > ePUB+Kindle: Table

of Contents

This works in the same way as the templates in WebHelp: The template provides the basic

page layout and Help+Manual inserts the pre-formatted content into it. 

Usually, you don't need to make any changes to the Table of Contents template for eBook

output. It is already set up for maximum compatibility.

Edit the page template at your own risk:

If you want to make adjustments to the template you can edit it. However, please only do

this if you are familiar with the eBook requirements, which are very strict. If something

goes wrong, just click on the Reset Defaults button to get the original standard template

back. 

HTML page template for Kindle and ePUB

You can view and edit the Kindle and ePUB page template in your project configuration

settings in this location:

Project Explorer > Configuration > Publishing Options >  eBooks > ePUB+Kindle: Page

Template

This works in the same way as the templates in WebHelp: The template provides the basic

page layout and Help+Manual inserts the pre-formatted content into it using the corres-

ponding variables. 

Usually, you don't need to make any changes to the page template for ePUB output. It is

already set up for maximum compatibility with eBooks. Remember that eBook pages are

764
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very simple, and that adding any kind of additional layout is more likely to cause problems

than be helpful. 

Edit the page template at your own risk:

If you want to make adjustments to the template you can edit it. However, please only do

this if you are familiar with the eBook requirements, which are very strict. If something

goes wrong, just click on the Reset Defaults button to get the original standard template

back. 

6.2.7.6 Managing Fonts in eBooks

Be warned that fonts in ePUB and Kindle eBooks are a tricky subject. The majority of eBook

readers and apps actually prefer to allow the user to set the base font, rather than the author.

Many, including Apple iBooks®, will let the user change the base font displayed even if you

set it yourself. The fonts available on eBook readers are also often limited and different from

those available on computers.

Key Information
Always set font size encoding to percent or ems for in

HTML Export Options  for eBooks. Otherwise the

user will not be able to adjust font size on many

devices. 

Font embedding: background and issues

The only way to get any control at all over the fonts in your ePUB and Kindle/Mobi eBooks

is to embed the fonts you use in your eBooks. Help+Manual can do this in a way that is

accepted universally, even by the famously picky Apple iBooks® reader. However, this will

increase the size of your eBooks and there are copyright issues. Also, the Kindle apps and

devices will not display the fonts you set by default! The user must activate "publisher

fonts" in the settings and must know that this is possible. This means that if your layout

depends on specific fonts, it will fail initially on Kindle devices and readers. 

You may decide that it is better to let the reader control your fonts. Given the current situ-

ation, this is probably the only really sane solution.

You must have copyright permission for embedded fonts

Most fonts are copyrighted and you can only embed and distribute them in your eBooks if

you have permission from the copyright holders. This can be time-consuming and expens-

ive. We recommend using free OpenType fonts, that eliminate this problem. See below for

sources. 
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Font embedding is required for non-English languages on some

readers

Adobe Digital Editions and some other ePUB readers require embedded fonts for all non-

English languages requiring special character sets. This does not apply to Apple iBooks®

and Kindle readers and apps, but if you are publishing non-English languages for other

readers you must embed your fonts for correct character display. As a general rule of

thumb, always test your books on all the devices and readers where you expect them to

be read before releasing them.

iOS devices only know their own fonts

Apple iBooks® on iOS devices can handle multiple languages very well. However, they

only have their own special fonts available, and their names are different from those of

most standard fonts. You can target these fonts directly in Help+Manual (see below) but

then you may get unexpected font displays on other readers that do not have the same

Apple fonts installed. However, there are enough fonts in the Apple list with matching

names so that you can get reasonably good cross-platform results without embedding

fonts if you are only use these fonts (see below). 

Unicode fonts are required

Unicode is an absolute requirement for ePUB so you must use Unicode fonts. Do not try

to embed non-Unicode fonts, it will almost certainly not work and can produce disastrous

results. 

There is no universal solution

At the moment, whatever you do will be a compromise. Basically, you just have to accept

that full control over your fonts on all target devices is not possible at the moment, even

with font embedding. And if you embed your fonts you need to deal with the problems

associated with embedding.

Use "Print View" style settings

No matter which fonts you decide to use in your eBooks, we urge you to activate and use

"Print View" style settings in the projects that you publish to eBooks. This will allow you to

set different fonts and other style settings for your eBooks and for your normal electronic

help formats like WebHelp and CHM. 
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These settings are used for eBooks in the same way as for Word and PDF output and they

make it possible to target fonts that do not exist on your Windows computer (for example

the special fonts that are only installed on Apple iOS devices).

See Multiple style sets  for information and instructions. 

Fonts on Apple iOS devices (iPad etc.)

Apple iOS devices have their own fonts and most of their names will not match the fonts

available on your Windows computer. If you want to use your own fonts you must activate

font embedding and make sure that you have copyright permission to distribute them or

use free OpenType fonts (see below). Or you can target the fonts used on iOS directly or

you can just use your own standard Windows fonts and let the iOS device and the user

choose the fonts to be displayed.

Option 1: Use standard Windows fonts

This is the simplest solution and it hands over font control to the iOS devices. Set your

standard fonts to normal Windows fonts like Arial and Times New Roman and don't turn

on font embedding in your ePUB publishing options . Apple iBooks will then use its

own fonts and the user will be able to change the fonts as they please. This is generally a

good idea for your base font (the font used for the majority of your body text) and it has

the added advantage of working on all ePUB readers. You can still target specific iOS fonts

for special styles if you like.

Option 2: Target the iOS fonts directly

If you use this option you must use the "Print View" style settings (see above) because it

means entering the names of fonts not installed on your Windows machine. Manually

enter the names of the iOS fonts (see below for a list) in your style definitions to target

them.

Don't turn on font embedding! Targeting iOS fonts directly is not possible if you turn on

font embedding. If you do, Help+Manual will automatically embed its own free OpenType

Unicode fonts for all fonts that are not found when the ePUB is published.

Option 3: Embed your fonts

Use this option for full control. If you do this all the fonts you use must be available on

your Windows machine. Help+Manual will replace any fonts not found with its own

OpenType Unicode alternatives. 

302
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The fonts you use should either be free fonts or fonts for which you have distribution per-

mission. See below for sources for free OpenType Unicode fonts.

Set your fonts in your "Print View" styles (see above) and activate font embedding in your

ePUB publishing settings. 

Fonts on Adobe Digital Editions and similar readers

Adobe Digital Editions and similar readers only have the absolute minimum of fonts on

board and they do not access the fonts installed on the computer on which they are run-

ning. Also, the included fonts only work for English. If you want to use special fonts or dis-

play languages other than English (or languages that use the English alphabet) you must

embed your fonts when you are targeting these readers. 

The fonts you use should either be free fonts or fonts for which you have distribution per-

mission. See below for sources for free OpenType Unicode fonts.

Set your fonts in your "Print View" styles (see above) and activate font embedding in your

ePUB publishing settings. 

List of iOS fonts and sources for free OpenType fonts

List of iOS fonts

This website lists the fonts currently available on Apple iOS devices and their names. If you

want to target these fonts in your Print View style settings you must enter the font names

exactly as listed here. For example, "AmericanTypewriter" will work but "American Type-

writer" will probably not!

 List of fonts on iOS devices

Sources for free OpenType fonts

The Unifont website is a great resource for locating and downloading free Unicode

OpenType fonts that you can use without fear of copyright infringement problems:

 http://www.unifont.org/fontguide/

http://iosfonts.com/
http://www.unifont.org/fontguide/
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6.2.7.7 Distributing ePUB and Kindle eBooks

Distributing ePUB eBooks directly

Distributing ePUB eBooks is very simple. You can normally distribute them directly to your

customers or users, even if you are targeting Apple iOS/iBooks devices. Unlike iOS apps,

you do not have to distribute eBooks through the Apple store, known as the iBookstore.

Users can install your eBooks directly on their iPad, iPhone or iPod Touch with the free

Apple iTunes program. The same applies to most other ePUB eBook readers, although you

should always check for the specific stores or devices you are targeting.

Easiest distribution method for unprotected ePUB and Kindle books: Via

QR code

Put the eBook file online and post the URL to the file as a QR code, which can be gener-

ated by Help+Manual . Users then scan the QR code with their device camera and the

book is downloaded and loaded automatically by the Kindle app (except on Windows

Phone). This works for ePUB eBooks and unprotected Kindle/Mobi books for viewing with

Kindle apps, except on Windows Phone devices. Kindle hardware readers can only load

eBooks via USB or from the Kindle store.

If you want to add Digital Rights Management (DRM) to ePUB

Just like digital music, digital eBook sales are generally more successful if you don't annoy

your honest customers with DRM (digital rights management / copy protection). 

If you must add DRM to ePUB books you will need to go through a service provider to do

this, as it is a complex and expensive process. 

 Service providers recommended by Adobe

Distributing Kindle books through the Kindle store

You can submit the Kindle/Mobi books generated by Help+Manual directly to the Kindle

Direct Publishing program for distribution via the Kindle store. Get started on this Amazon

page for information and instructions:

 Amazon Kindle Direct Publishing 

If you want to distribute through the Apple iBookstore 

If for some reason you want to or must publish through the Apple iBookstore be warned

that it is a complex process that may be expensive. Some authors have found that they do

not have full control over where and how their books are made available. Here too, it is

262

http://blogs.adobe.com/digitalpublishing/solution-providers
https://kdp.amazon.com
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recommended that you go through an ePUB service provider, which Apple refers to as

"aggregators". 

 Apple iBookstore FAQ for eBook publishing

 iBookstore aggregators approved by Apple

6.2.7.8 ePUB resources

This page contains a selection of hardware, software and information resources relating to the

ePUB format and ePUB eBooks. It is not necessarily complete, but it is a good starting-point. 

Reference reader devices and readers for testing

Apple iBooks

The only reference eBook reader for iBooks is the Apple iPad, with the iBooks app installed

from the Apple App Store. If you want to distribute your eBooks for iOS devices you must

have access to a physical iPad for testing. You will also need access to an iPhone or iPod

Touch if you expect your books to be read on these smaller devices. You can install ePUB

eBooks on these devices with Apple iTunes. Just connect the device to your computer and

drag the ePUB file onto the iPad entry in the iTunes window.

Other hardware readers

It's a good idea to have access to the physical hardware readers you are targeting for testing.

Some have more limited capabilities than others. 

Software readers - get Adobe Digital Editions

The reference software reader is the free  Adobe Digital Editions. Before trying to create

ePUB eBooks you should download this free reader from Adobe and install it. If you don't do

this you won't be able to view your ePUB eBooks on your Windows computer after creating

them with Help+Manual. ADE generally provides a good idea of how your eBook is going to

look on software readers.

Up-to-date resources list on Wikipedia

The most up-to-date list of ePUB resources is available on this page on Wikipedia:

 https://en.wikipedia.org/wiki/EPUB

Hardware devices supporting ePub eBooks

The following hardware readers currently support ePUB eBooks, either directly or with free

additional software. The most notably absent device on this list at the moment is the

Amazon Kindle, which still uses its own closed proprietary format. However, it is rumored

that ePUB support for the Kindle is in the works and due to be released in the near future. 

http://www.apple.com/itunes/content-providers/book-faq.html
https://itunesconnect.apple.com/WebObjects/iTunesConnect.woa/wa/displayAggregators?ccTypeId=13
http://www.adobe.com/products/digitaleditions/
https://en.wikipedia.org/wiki/EPUB
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Dedicated hardware ePUB and eBook readers

There are now a wide range of hardware ePUB and eBook readers on market. See the

Comparison of e-readers on Wikipedia for a good list of the currently available devices

and their capabilities.

Apple iPad, iPhone and iPod Touch

All these devices support ePUB directly with the iBooks® eBook reader integrated in their

iOS operating system. Help+Manual ePUB eBooks are fully compatible with Apple

iBooks®. There are also other eBook readers for iOS available in the Apple iTunes App

Store.

Android smartphones and tablets

A wide variety of ePUB readers are available for Android. 

Other mobile phones and smartphones

Many other mobile devices also support ePUB eBooks.

Software readers for ePub eBooks

Software readers for ePUB eBooks are already available on many platforms. The following

list only includes the known software-based readers that support the ePUB format at the

time of writing – others may already be available. 

The reference software reader is Adobe Digital Editions used to be a good choice but it

is now no longer supported so well and it has been involved in controversies regarding

Adobe's use of user data. For general testing on Windows, Mac OS and Linux we now re-

commend the Calibre eBook Reader.

Calibre eBook Reader (Windows, Apple Mac OS, Linux) 

This free program is now the software ePUB reader with the best support for ePUB and we

strongly recommend that you install it for testing your ePUB books. 

Other software eBook readers

There is now such a large number of software-based eBook readers for all current systems

that it would be impossible to make any recommendations here. You will need to check

current reviews for the best readers for the system you want to use. For testing your own

eBooks, however, we can warmly recommend Calibre.

Online resources for ePub eBooks

Melody Simmons eBook Indie Covers 

Excellent site for everything related to eBook covers and cover images.

https://en.wikipedia.org/wiki/Kobo_eReader
http://www.adobe.com/products/digitaleditions/
https://calibre-ebook.com/
https://calibre-ebook.com/
https://ebookindiecovers.com
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International Digital Publishing Forum 

This is main home page for ePUB and everything relating to the ePUB format. This is also

where you can find full specifications of the open ePUB format.

Project Gutenberg 

A huge number of free eBooks in all categories, including both classics and new books.

Feedbooks 

Free classics in ePUB format.

Snee 

Free children's picture books in ePUB format

See also:
Output Formats - eBooks

Publishing Options - eBooks

6.2.7.9 Optimize Publish Speed

When you are publishing this format Help+Manual generates a temporary folder for the in-

termediate source files that are used to create the final output. These are all the files that go

into your final documentation, including the graphics. You can optimize publishing speed for

large projects by changing the location of these temporary files and whether they are deleted

or not between publishing operations. 

Similarly, optimizing the location of your output folder and the project itself can also speed

up publication by reducing the time required to write all the necessary files.

Not deleting the temporary files can speed up subsequent pub-
lishes

If you disable the option for deleting the temporary files after publishing this can some-

times quite significantly speed up subsequent publish operations for the same project.

This is because the graphics that have not changed in the project no longer need to be re-

generated. This effect will be particularly pronounced if you have a lot of graphics in your

project that you have resized in the HM editor. 

1519

1472

http://www.idpf.org/
http://www.feedbooks.com/
http://www.snee.com/epubkidsbooks/
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Should you use a RAM drive?

A RAM drive is a virtual, volatile hard disk created in the computer's memory that provides

maximum access speeds. Its contents disappear when you shut down or restart your com-

puter, so it may not provide the benefits of not deleting your temporary files  (see above)

between sessions. Also, this means that RAM drives should never be used as your output

folder, because their contents disappear much too easily.

If you use one it must be large enough to accommodate all the files you write while pub-

lishing and you need to be very careful that it does not fill up completely while you are

publishing, otherwise you will get errors. Instructions for how to do this go beyond the

scope of this documentation. Generally you will need a special software utility to set up a

RAM drive.

Never use RAM drives for your output folder!

This is important, so we're going to repeat it: The contents of RAM drives disappear as

soon as you shut down or restart your computer. So you should only ever use them for

temporary files, never for your output folders!

A RAM drive can improve performance if you only have spinning

hard disks

RAM drives are much faster than spinning hard drives so if you don't have an SSD it can

be worth it to set up a RAM drive for your temporary publishing files, if you have enough

memory. However, an even better solution is to get a modern SSD because that will radic-

ally improve the performance of your entire system.

Don't bother with a RAM drive if you have a fast SSD

RAM drives are much faster than spinning hard drives but only marginally faster than

SSDs for Help+Manual publishing. If you have a fast SSD, setting up a RAM drive will al-

most never provide a noticeable improvement, so it is not worth the effort then.

Optimize the locations of your project, temp files and output
folders

Optimizing the locations of your project, temporary files and output folders can all speed

up publishing. 
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Best solution all round: Everything on a fast local SSD

For the fastest possible publishing speed your project, temporary files folder and output

folder should all be on a fast local SSD on the computer where Help+Manual is running.

Then there are no network transfers during publishing and everything can run at max-

imum speed. 

Best solution for network projects: Temporary files on a fast local

SSD

If you are working on a collaborative project then it must be on a network drive. In this

case you can still improve performance a lot by putting your temporary files on a fast local

SSD on the computer where Help+Manual is running to publish the project. Having the

output folder on the local drive will also improve performance, but not as much as having

the temporary files there. 

How to change the temp files folder location

You can find the setting in the Compilers section of the main program options, in View >

Program Options > Compilers. The setting applies to all output formats that use tempor-

ary files before (CHM, ePUB, Kindle, eWriter, Visual Studio help). The temporary files are

written in sub-folders with names based on the project name and the output format. 
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Exclude your output and temp files folders from your virus checker

On current Windows systems interactive virus checking is performed on every file being

written and can significantly increase the time it takes to generate your published output.

Excluding your output folder and temp files folder from virus checking can speed up pub-

lication of large projects very significantly.

First set up a specific folder where your temporary files will be written (see above). If pos-

sible, also set up a folder where you always write your output files. This can contain mul-

tiple sub-folders for your different output requirements. Then you can configure your

virus checker to exclude these folders from checking.

The instructions below explain how to do this for Windows' own integrated Windows De-
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fender or Security Essentials virus checking. If you are using a commercial solution you will

need to consult your virus checker's documentation to learn how to exclude folders from

checking. Note that commercial virus checkers often slow down your system much more

than Windows' own solution.

Excluding your output and temp folders from Windows Defender or

Windows Security Essentials

1. Open Windows Defender (or Security Essentials on older versions of Windows). 

2. Select the Settings tab and then on the left select Excluded files and locations.

3. Click on the Browse button on the right and select the folder you want to exclude.

4. Click on the Add button to add the selected folder to the exclusions, then select the

option at the bottom of the dialog to save your settings.

6.2.8 Visual Studio Help

Visual Studio Help is available in two versions, Visual Studio Help 2008 and 2010, which are

also known as MS Help 2.0 and MS Help 3.0, respectively. Originally, each of these help

formats was announced as the upcoming the successor to HTML Help. However, in both cases

Microsoft then backpedaled and it now seems clear that they are not going to be released as

help formats for normal user applications. 

About configuring Visual Studio Help output:

The two Visual Studio Help formats are only relevant for documenting programming com-

ponents within the Visual Studio .NET environment. If this does not apply to you please

don't worry about this help format. It cannot be used for any other purpose.

Please refer to the special Visual Studio Help  chapter in the More Advanced Proced-

ures section for details on working with Visual Studio Help in Help+Manual.

See also:
Visual Studio Help  (Advanced Procedures)

Visual Studio Help  (Configuration Options)

Visual Studio Help  (Reference)

6.2.8.1 Optimize Publish Speed

When you are publishing this format Help+Manual generates a temporary folder for the in-

termediate source files that are used to create the final output. These are all the files that go

into your final documentation, including the graphics. You can optimize publishing speed for

large projects by changing the location of these temporary files and whether they are deleted

or not between publishing operations. 

Similarly, optimizing the location of your output folder and the project itself can also speed

1132
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up publication by reducing the time required to write all the necessary files.

Not deleting the temporary files can speed up subsequent pub-
lishes

If you disable the option for deleting the temporary files after publishing this can some-

times quite significantly speed up subsequent publish operations for the same project.

This is because the graphics that have not changed in the project no longer need to be re-

generated. This effect will be particularly pronounced if you have a lot of graphics in your

project that you have resized in the HM editor. 

Should you use a RAM drive?

A RAM drive is a virtual, volatile hard disk created in the computer's memory that provides

maximum access speeds. Its contents disappear when you shut down or restart your com-

puter, so it may not provide the benefits of not deleting your temporary files  (see above)

between sessions. Also, this means that RAM drives should never be used as your output

folder, because their contents disappear much too easily.

If you use one it must be large enough to accommodate all the files you write while pub-

lishing and you need to be very careful that it does not fill up completely while you are

publishing, otherwise you will get errors. Instructions for how to do this go beyond the

scope of this documentation. Generally you will need a special software utility to set up a

RAM drive.

Never use RAM drives for your output folder!

This is important, so we're going to repeat it: The contents of RAM drives disappear as

soon as you shut down or restart your computer. So you should only ever use them for

temporary files, never for your output folders!

A RAM drive can improve performance if you only have spinning

hard disks

RAM drives are much faster than spinning hard drives so if you don't have an SSD it can
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be worth it to set up a RAM drive for your temporary publishing files, if you have enough

memory. However, an even better solution is to get a modern SSD because that will radic-

ally improve the performance of your entire system.

Don't bother with a RAM drive if you have a fast SSD

RAM drives are much faster than spinning hard drives but only marginally faster than

SSDs for Help+Manual publishing. If you have a fast SSD, setting up a RAM drive will al-

most never provide a noticeable improvement, so it is not worth the effort then.

Optimize the locations of your project, temp files and output
folders

Optimizing the locations of your project, temporary files and output folders can all speed

up publishing. 

Best solution all round: Everything on a fast local SSD

For the fastest possible publishing speed your project, temporary files folder and output

folder should all be on a fast local SSD on the computer where Help+Manual is running.

Then there are no network transfers during publishing and everything can run at max-

imum speed. 

Best solution for network projects: Temporary files on a fast local

SSD

If you are working on a collaborative project then it must be on a network drive. In this

case you can still improve performance a lot by putting your temporary files on a fast local

SSD on the computer where Help+Manual is running to publish the project. Having the

output folder on the local drive will also improve performance, but not as much as having

the temporary files there. 

How to change the temp files folder location

You can find the setting in the Compilers section of the main program options, in View >

Program Options > Compilers. The setting applies to all output formats that use tempor-

ary files before (CHM, ePUB, Kindle, eWriter, Visual Studio help). The temporary files are

written in sub-folders with names based on the project name and the output format. 
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Exclude your output and temp files folders from your virus checker

On current Windows systems interactive virus checking is performed on every file being

written and can significantly increase the time it takes to generate your published output.

Excluding your output folder and temp files folder from virus checking can speed up pub-

lication of large projects very significantly.

First set up a specific folder where your temporary files will be written (see above). If pos-

sible, also set up a folder where you always write your output files. This can contain mul-

tiple sub-folders for your different output requirements. Then you can configure your

virus checker to exclude these folders from checking.

The instructions below explain how to do this for Windows' own integrated Windows De-
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fender or Security Essentials virus checking. If you are using a commercial solution you will

need to consult your virus checker's documentation to learn how to exclude folders from

checking. Note that commercial virus checkers often slow down your system much more

than Windows' own solution.

Excluding your output and temp folders from Windows Defender or

Windows Security Essentials

1. Open Windows Defender (or Security Essentials on older versions of Windows). 

2. Select the Settings tab and then on the left select Excluded files and locations.

3. Click on the Browse button on the right and select the folder you want to exclude.

4. Click on the Add button to add the selected folder to the exclusions, then select the

option at the bottom of the dialog to save your settings.

6.3 Testing and Statistics

Testing your help project is just as important as testing your application. You should publish

your project  regularly, view the output, test its interaction with your application  and

also use Help+Manual's tools and features for checking your project for help bugs. 

In addition to invalid macros and scripts  (which you are responsible for checking yourself)

help bugs can include dead and inappropriate links, missing graphics and inappropriate index

keywords. 

6.3.1 Tools for finding help bugs

Help+Manual includes a number of tools and features that help you to find "help bugs" in

your project:

Project reports

The Report Tool  gives you a comprehensive overview of the current state of your pro-

ject, allowing you to check topics, links, graphics and other elements.

Testing links and missing graphics

You can test links  directly in the Help+Manual editor. Dead and invalid links are high-

lighted automatically in the editor. Missing graphics are immediately visible, highlighted

as a big red X.

613 892
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Searching for topics and referrers

There are a number of different ways to search for topics and referrers  by text, topic

IDs and help context numbers. Referrers are other topics that refer to the current topic,

and checking them can sometimes be useful. 

Checking keywords

The Index Tool  is very useful for checking and managing the keywords in your project.

Among other things, it enables you to immediately see and eliminate duplicate keywords

with variant spellings and formats.

6.3.2 Using the Report Tool

The Project Reports tool can generate reports with varying degrees of detail on your entire

project, chapters or even individual topics. You can also generate reports on topics modified

between specific dates, topics associated with specific help window types  and topics with a

specified status . For details see The Report Tool .

Information you can get with the Report Tool

· Word and character count for both individual topics and the entire project (Full Re-

port mode only)

· Topic details of all topics, including titles, topic IDs, help context numbers, inclusion

options and date edited

· Keywords in all topics, listed by topic

· All hyperlinks, both to and from topics, listed by topic

· All topic anchors, listed by topic, including anchor keywords and context numbers

· All images used, listed by topic

· Topics without index keywords

· Topics without TOC entries

· Unused images found in the project's image folders

· Detailed project statistics, including the number of topics with topic type, number of

keywords with keyword type, number of links and hotspots with types (including scripts

and macros) and the number of images with names and list of where they are refer-

enced.

See also:
The Report Tool
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6.3.3 Word and Character Count

Word count for a single topic:

Select the topic, then select the Word Count tool in Write > Font.

Word count for the entire project:

Select the Report tool  in the Project tab and choose the Full Report option. This will in-

clude a word and character count at the end of the report, and individual word counts for

each topic.

You can include/exclude topics in/from the entire report and the word count by selecting

or deselecting Include Options  and the other filtering options in the report dialog

(topic classes, topic status, modification date range).

6.3.4 Testing links and missing graphics

All links and graphics inserted in your projects incorporate dynamic validity checking features.

Dead links to other topics in your project are automatically highlighted in red and a popup

explanation is displayed when you position the mouse over them if the mouseover hints fea-

ture is enabled in File > Program Options > General. Missing images are clearly indicated by

a square graphic with a red X in the middle.

How to test links in the editor

· Hold down Ctrl and click on the link to visit the topic to which the link points. 

· In addition to topic links you can also use this feature to test Internet links and file links

and to display the source topics of linked snippets .

· Use the  Back button in the Quick Access Toolbar and the History button between the

 Back and  Next buttons to return to the topic you were editing before testing the

link. 

1212
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Dead links and graphics in the editor

Dead links to other topics in your project and missing graphics are clearly identified in the

editor, you can't miss them. Dead links are highlighted in red, missing graphics files are

shown as a square with a big red X in the middle. Note that the mouseover popup inform-

ation for dead links is only displayed if this feature is activated in View > Program Op-

tions > General.

Links to external targets:

Links to external targets (outside your project) and other help projects cannot be checked

by Help+Manual. You are responsible for checking these yourself.

Locating dead links and graphics with the Report Tool

You can generate a full list of dead links and missing graphics in all or part of your project

with the Report Tool , which is accessed in Project > Tools . 

See also:
The Report Tool

6.3.5 Searching for topics and referrers

When you are testing your project you will often want to find topics and check links to and

from your topics. Help+Manual includes several tools that make this a quick and easy process.

In addition to the search functions described here you can also use the Report Tool  to

generate detailed reports on your project with full lists of topics, links, graphics and other de-

tails.

The functions for finding and replacing text in Help+Manual are very similar to the compar-

able functions in word processors, with some additional options for the special requirements

of help projects. 

In addition to this the program also has powerful functions for locating individual topics by

their topic IDs and their context numbers, and for locating "referrers", i.e. topics containing

links to the current topic or topics.  

Productivity Tip
The Search function is also available in the XML Source

editor tab (Professional and Floating license versions

only) and all HTML editor windows for HTML tem-

plates and other editing windows. Just right-click in

these editor windows to access.

1212
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How to find and replace text

1. Select Write > Editing > Find & Replace… or press Ctrl+F. 

2. Enter your search text and choose your options. These are self-explanatory and are

very similar to all search and replace functions in all modern word processors.

Find where:

Topic Keywords searches for index keywords you have associated with your topics.

Image File Names changes the filenames of graphics file references in your projects so

that they refer to files with different names. See below for details. 

Captions searches in TOC captions (the Topic Title field in the Topic options tab below the

main editor window). Note that replacing  this text does not change the name of the topic

in the TOC or the header in the header box above the editor. Instead, it "uncouples" the

topic title attribute from the other two texts, giving it a different value. 

Table of Contents searches in the TOC in the Project Explorer (search only, no replace).

Conditional Texts searches and replaces the tag names in conditional text build tags. See

Conditional text include options  for details on how these tags work and how they are

used.

How to find and replace variables and conditional tags

Variables:

Note: This only works for variables that have been typed in manually. You can't use the

search function to locate variables inserted with the Variable tool in Write > Insert Object.

1. Select Find & Replace in the Edit menu and set the scope of your search (current topic,

all topics etc). 

2. To search for a variable or replace text with a variable enter:

<% + VARIABLENAME + %>

For example if your variable is called DEMOBUILD you would type:

<%DEMOBUILD%>

When you insert or replace variables with Find and Replace the variables are not high-

lighted in the topic text. This is exactly the same as typing in variables manually  – the

variables are still fully functional, they are just not highlighted in the text. (The highlight is

994
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just an editing convenience to make the variables easier to see.)

Conditional tags:

1. Select Find & Replace in the Edit menu and set the scope of your search (current topic,

all topics etc). 

2. Select Conditional Texts as the type of search to perform.

3. Enter the conditional tags you want to search for, including the commas if you are

searching for tags with multiple conditions.

Examples:

Find what: CHM,HTML

Find what: USER1

Find what: PDF,NEWBUILD,HTML

How to find and replace images

Images are referenced with their file names only so you can "replace" them with other im-

ages by replacing their file names in your topics. Help+Manual finds the image files by

searching through all the folders in your Project Search Path  so if the file name you use

is in one of those folders Help+Manual will be able to find it.

1. Select Write > Editing > Find & Replace… or press Ctrl+F. 

2. Select Image File Names in the Find Where section.

3. Enter the exact name of the image file as the search and replacement texts, including

the file extension, for example: main_screen.bmp.

4. Choose your other options. These are self-explanatory and are very similar to all

search and replace functions in all modern word processors.

Tip: Changing image type

You can change the type of image used by searching and replacing the file name exten-

sion. For example, if you have replaced all your PNG files with BMP files of the same name,

you would just need to replace all instances of .png in image file names with the .bmp

extension.

How to find topics by ID or context number

1. Select Project > Manage Topics > Find >  Find Topic 

2. Select Topic ID or Help Context Number.

514
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Find topics that link to the current topic

You can find links to the current topic with the Find Referrers function, which also shows

which topics the current topics links to. 

Links to and from the current topic:

· Select Topics > Manage Topics > Find > Find Referrers 

OR

· Right-click on a topic in the TOC and select Find Referrers in the context menu.

Selecting Find Referrers for a chapter in the TOC will display the referrers for all the topics

in the chapter. You can also use this function for multiple topics. Just select two or more

topics in the TOC before selecting the function. Note that this function will only find links

to the current topic or topics in the current project! You cannot use this function to locate

links to the topic in other projects or help files. 

Finding links in all topics:

· Select Project > Tools > Report Tool and select either Long Report or Full Report mode.

The report will include lists of all outgoing and ingoing links in all topics in your project. 

See also:
Find & Replace  (Reference)

Find Referrers  (Reference)

The Project Reports Tool

6.3.6 Testing keywords

The Index Tool provides a preview of your finished index and it is also fully editable, allowing

you to edit and correct keywords in all the topics where they occur at the same time. 

The Find and Replace Text function in Write > Editing also works on keywords. You can locate

and replace keywords in your entire project in a just a few seconds. 

See also:
Keywords and Indexes

Editing the index directly

Searching for text, topics and referrers

6.4 PDF and Printed Manuals

In addition to publishing electronic help formats, Help+Manual can also generate fully-

formatted user manuals, which can be printed directly or output as Adobe PDF files for distri-

bution so that users can print their own manuals. Printed manuals are generated by creating a
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temporary PDF file and then printing it, providing all the formatting options that are also

available for PDF.

See also:
The Adobe PDF format   

Using PDF templates

6.4.1 About PDF output

Print manual templates

The layout of PDF files and printed manuals is defined in template files with the extension

.mnl that are referred to as "print manual templates". These templates are edited with a

program called the Print Manual Designer, which is included with Help+Manual. 

You can create multiple print manual templates and use them to change the formatting

and layout of your PDF files in seconds. this is similar to the skins  available for HTML-

based output formats.

See Using PDF templates  for more details.

Additional pages and components in PDF files

In addition to the layout (margins etc), your print manual templates can also add a num-

ber of additional optional pages to your PDF documents that normal help files do not

contain. These can include front and back cover pages, a print-style table of contents, a

foreword, "intro" pages for your top-level chapters, pages of notes at the beginning or

end of the document and so on.

You can also create your own addition pages in your templates, insert "snippet" objects

that load text from external files or from topics in your Help+Manual project and create

multi-column layouts.

In addition to this, PDF documents have layout components that you do not need in elec-

tronic help: Headers and footers with page and section numbers, margin settings, format-

ted headings in the TOC and above topics and so on. 

All these features are created and edited in your print manual templates which you can

edit with the Print Manual Designer. 

6.4.2 Peer review with annotated PDFs

When you are working on documentation you will often want to get feedback, suggestions

and corrections from colleagues and others. If they have Help+Manual themselves they can

simply add their comments to the project with the comments tool . If they don't, however,

you need a different solution, and that is with a PDF version of your project. 
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PDF Review Plugin (2 minutes tutorial)

You generate a PDF  of the project directly with Help+Manual and distribute that to your

colleagues. When you create the PDF you can include any comments that the project already

contains so that these will be visible in the PDF. 

The reviewers then add comments with the PDF commenting feature. When you get the com-

mented PDF back, you can then go through and implement the suggestions in your project. 

The PDF review plugin makes this even easier

In the past the commented PDF and your project were two separate things that you had

to work on without any connection. The PDF review plugin synchronizes and lines up the

topics and comments in the PDF with the corresponding topics in your project. This makes

going through the review much faster and more efficient.

Support for PDF Annotator

In addition to synchronizing normal PDF comments with your project, the PDF review plu-

785
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gin also supports the excellent PDF Annotator tool that provides much more advanced

commenting and highlighting features than the native capabilities of PDF without the ex-

pensive Acrobat program. You can download a free trial from the PDF Annotator site:

https://www.pdfannotator.com/en/ 

Using PDF Peer Review

Step 1: Publish a PDF version of the project with comments

Even if there are no comments in your project, activate the the option to include com-

ments when you publish the PDF version for peer review. This makes sure that comment-

ing is enabled in the PDF so that any PDF editor with commenting capabilities can add

them. This also disables any passwords and other editing restrictions you may have set.

See the Publishing  chapter if you don't know how to publish PDFs yet.

Step 2: Distribute the PDF for comments

Send the PDF to your colleagues for commenting/annotation. When you receive it back

you can use the plugin to synchronize it with your project.

Step 3: Load the annotated PDF in the review plugin

Open your project in Help+Manual and select the PDF Review plugin with the Plugins

tool in the Project Tab. Then click on Load and select the annotated PDF file that you re-

ceived from your colleagues.

The list of comments in the PDF include answers from your colleagues. All the list items

are live links that take you directly to the corresponding comment location in the project

topic when you click on them.

613
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Right-click context menu

If you right-click on a comment in the list you get a context menu with which you can

copy the comment to the clipboard or update it in your Help+Manual project.

How the review tool works

The review tool displays a list of all the comments found in the PDF with a preview of the

pages below. You can zoom the preview with the +/- buttons. The comments are auto-

matically synchronized with the topic display in the editor on the left. When you select a

comment in the plugin the corresponding topic in your project is automatically displayed

in the editor. The comment icon in the PDF is also highlighted in the preview.

6.4.3 Topic headings

The formatting of your topic headings in your Help+Manual project is ignored in PDF. This is

one of the key things to understand when generating PDFs in Help+Manual. Only the plain

text of your topic headings is exported to the PDF document (the full formatting and layout of

the body of the topics are included, of course). The formatting of the headings is defined in

your print manual template , where you also define the layout of your PDF file. 803
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How topics and headings are exported to PDF

· Topic content:

When you publish to PDF the entire content of your topic files is exported to PDF with

all its formatting and layout as you define it in the Help+Manual editor. Only the mar-

gins are set in the print manual template because there are no margins in the H+M ed-

itor, which is designed primarily for electronic documentation formats.

· Topic headings:

The text of your topic headings are exported from your project as plain, unformatted

text. No other content from the header box is imported (i.e. no graphics, hyperlinks etc).

The formatting, positioning, spacing and layout of the topic headings are defined in the

print manual template. You can use either the topic caption from the Table of Contents

(TOC) or the topic header from the header box above the H+M editor for your topic

headings. This is useful because it allows you to use longer (heading) or shorter (cap-

tion) versions of the heading texts as necessary.

How topic heading texts are inserted in your PDF documents

Your topic heading texts are inserted in the Table of Contents and Topics sections of your

print manual templates using variables. The Publishing ...   variables insert the head-

ings from the TOC captions for topics in the TOC levels 1-6, the Publishing ... Pub-

lishing variables (Topics section only) insert the headings from the heading box above

the H+M editor. 

For more details see the help of the Print Manual Designer program. 

Creating TOC entries for "invisible" topics in PDFs

PDF is a special case because only topics with TOC entries can be included in PDF docu-

ments. If your project contains "invisible" topics that are normally only displayed with hy-

perlinks from other topics you must add TOC entries for them to be able to include them

in the PDF version of your output. This is very simple to do with the knowledge you now

have:

1. Create TOC entries for the "invisible" topics: Either drag the topic file into the TOC or

create a "new" topic and select the topic ID of the invisible topic with the  browse

button in the Topic ID: field of the new topic dialog. You might want to organize these

TOC entries as one or more special chapters in your TOC. 

2. Apply build options to the new TOC entries so that they are only included in the PDF

version of your output. See See Including and excluding TOC entries above for instruc-
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tions.

6.4.4 Title page images

You implement this feature by editing your PDF template with the Manual Designer  pro-

gram. Once you have become familiar with the Designer, see Designing a Template > Top

Level Intro Pages in the Manual Designer help (F1) to learn how to make the kind of title

pages shown further below.

You can associate both a graphic image and a description with any topic in your project in the

Topic Options tab that you can select to the left of the main editor window.

You can add these for any topic but for PDF output they are only relevant for top-level topics.

You can configure your PDF template to use them for title pages for the main sections of your

project with an image and a description, like this:

805



793

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Publishing

6.4.5 Named destinations

When Help+Manual generates PDF documents it automatically exports a number PDF an-

chors known as "named destinations" for targets in the document. These destinations are sim-

ilar to topic anchors  in HTML documents. You can use these destinations as targets in hy-

perlinks to the PDF files.

Key Information
Named destinations are only generated if you gener-

ate an interactive PDF  document.

415
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Items exported as named destinations

Topic IDs

Topic IDs are exported as named destinations in all lower case. Links to named destina-

tions are case-sensitive, so you must also use the lower case format in all your links to

named destinations in PDFs created by Help+Manual. 

For example, if your topic ID is Index_Topic then the named destination in the PDF will

be index_topic. 

Topic anchors

Anchors inserted in your topics are exported together with the topic IDs, also in all lower

case letters, using the syntax topicid#anchorid. The topic ID is always part of the

named destination for an anchor, with a pound character (#) between the two.

Links to anchors in PDF only work in PDF links:

Links to named destinations including anchors are a special case. They will only work in

links in PDF files, not in links in WebHelp files. If you use a link with an anchor in WebHelp

output the link will only open the PDF file at the first page.

Standard PDF template sections

The following named destinations are exported for the standard PDF template sections

defined in your print manual template . These destinations are exported in all  lower

case as shown below, and that is also how you must link to them. (The commas are not

part of the destinations.)

cover, title1, title2, title3, foreword, toc, topics, endnote1,
index, endnote2, backcover

Note that there are no destinations for repeating sections like Top Level Entry and Blank

Pages. 

User-defined template sections

User-defined PDF sections created in Manual Designer with the Insert Page option in the

Pages menu are also exported as named destinations. The destinations generated for

these sections are called custom1, custom2, custom3 and so on – i.e. the word "cus-

tom" in all lower case plus the sequential number of the custom page in the order in

which the pages were created in the template.

Important note:

The named destinations for user-defined sections are fixed and are assigned in the order

in which the user-defined sections are created. The first section you create gets the destin-

ation custom1, the second section gets custom2 and so on. The actual order of the cus-

803
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tom sections in your template is irrelevant.

Linking to named destinations in PDF documents

You can create links to both page numbers and "named destinations" in PDF documents. The

procedure is the same for links that will be used in PDF files and in WebHelp output.

 Named destinations are jump targets that work like anchors. These links will work in PDFs

created by Help+Manual and in WebHelp created by Help+Manual, but not in CHM files. The

Microsoft CHM viewer does not support the link format needed to jump to destinations in

PDF files. A link to a PDF in a CHM file will simply open the PDF at the first page. See Named

destinations in PDF  for details on the named destinations created in PDFs by Help+Manual

and more background information.

Use normal topic links for targets in the current document

Note that named destinations are only needed for links between two different PDF files or

from other applications or documents. Use normal topic links to jump to targets within

your Help+Manual projects (i.e. from one topic to another). You don't need to use named

destinations for this.

Requirements:

· File Links are required for linking to PDFs:

You must use the File Link option for creating links to targets inside PDF files. The Inter-

net Link option will not always work correctly, even in WebHelp. 

· Set the PDF to "interactive" to use named destinations:

If the PDF you are linking to is created with Help+Manual it must be generated using

the "interactive PDF" option in your PDF settings . Named destinations are only gen-

erated for interactive PDF documents.

Linking to named destinations in PDF documents:

You need to create a file link with the destination added to it to link to a destination in a

PDF document. Internet links will not work correctly, not even in WebHelp.The syntax is

the same for links that are going to be in PDF files and WebHelp files. The links to the PDF

files will also work in CHM files, but they will only open the PDF document; they will not

jump to the destination in the PDF from a link in a CHM.

465
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Procedure:

1. Follow the instructions for inserting a file link  and enter the name of the PDF file

you want to link to. 

2. Add #nameddest= after the file name, followed by the name of the named destina-

tion in all lower case characters. See this topic  for details of the named destinations

you can jump to.

Examples:

myfile.pdf#nameddest=toc (jumps to the Table of Contents in the PDF)

myfile.pdf#nameddest=welcome_topic (jumps to the topic with the ID Wel-

come_Topic)

myfile.pdf#nameddest=custom1 (jumps to user-defined template section 1)

Special case: anchors:

Links to named destinations including anchors are a special case. They will only work in

links in PDF files, not in links in WebHelp files. If you use a link with an anchor in WebHelp

output the link will only open the PDF file at the first page.

Example:

In a PDF file, the following file link will jump to the anchor testanchor in the topic with

the ID Welcome_Topic. In a WebHelp file it will only open the PDF at the first page.

myfile.pdf#nameddest=welcome_topic#testanchor 

Linking to a page number in a PDF document:

You need to create a file link with the page number added to it do link to a page number

in a PDF document. Internet links will not work correctly, not even in WebHelp.The syntax

is the same for links that are going to be in PDF files and WebHelp files. The links to the

PDF files will also work in CHM files, but they will only open the PDF document; they will

not jump to the page number in the PDF from a link in a CHM.

Important: The page number destinations in PDFs created by Help+Manual start count-

ing at 0, so you must jump to the actual page number minus one. If you are jumping to

pages in PDFs created by other tools you can usually jump to the actual page numbers.

1. Follow the instructions for inserting a file link  and enter the name of the PDF file

you want to link to. 

425
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2. Add #page= after the file name, followed by the page number:

myfile.pdf#page=123 (jumps to page 124)

myfile.pdf#page=0 (jumps to page 1, same as just opening the PDF file without a

target)

myfile.pdf#page=11 (jumps to page 12)

Links to PDFs from WebHelp and HTML files

Links to named destinations in PDF from Help+Manual WebHelp

When creating links to named destinations in PDF files from WebHelp you can use exactly

the same procedure and syntax as for links from PDF files. Create a file link and follow the

instructions above. 

Links to named destinations in PDF from other HTML files

The syntax is also the same for links to named destinations in other HTML files not gener-

ated by Help+Manual. Just create a hyperlink using the same pdf_file.pdf#named-

dest=xxxx and pdf_file.pdf#page=yy syntax for the href target of the link as you

use in Help+Manual, where xxxx is the named destination and yy is the page number.

Links to PDF from CHM files

You cannot link to named destinations in PDFs from a page in a CHM file. The Microsoft

CHM viewer will block all attempts to do this. You can only use a normal file link to open

the PDF file at the first page. That is the only option available. This is a limitation of the

CHM format and the Microsoft CHM viewer. Help+Manual cannot do anything to change

this (and the PDF must be in the same folder as the CHM to open at all).

6.4.6 Graphics in PDF

There are a couple of areas where PDF handles graphics a little differently than other output

formats.

Fitting images on the page

Help+Manual will always try to fit everything you put in your topics within the margins of

the PDF page if possible. Images in tables will be scaled to fit in the table cell containing

them and images on the page will be scaled to fit on the page.
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If you want to avoid this scaling effect you need to plan your images so that they are small

enough to fit in their containers without scaling (table or page).

Higher-quality images for better zooming and scaling

When you scale an image in the Help+Manual editor it is normally physically resized when

you publish it to an output format in Help+Manual. This is handled differently in PDF.

Scaled images are not resized. Instead, Help+Manual exports the full original image file

with a scaling command. The image is thus displayed at the correct size relative to the

page in the PDF viewer, but you get better quality when the user zooms the viewer and

images will also have better quality in printouts of the PDF page.

Doing this also increases the size of the PDF file, of course, because the larger images are

stored in larger files. You can reduce the impact of this by using SVG vector images where

possible, because these scale to large sizes at full quality without needing more data in

the file. 

PNG with transparency and SVG vector images

Normal bitmap graphics are converted to compressed BMP images in PDF output. PNG im-

ages and SVG vector graphics are supported natively and will be included in the PDF as ori-

ginal PNG and SVG files if possible. 

PNG with alpha transparency

PNG images with transparency will now show what is beneath them in the transparent

areas instead of a simulated white background.  

SVG vector images support depends on image complexity

SVG images are tested for their complexity. If they contain gradients, which cannot be re-

produced in PDF, the SVG image is exported as a bitmap. If there are no complex gradi-

ents, H+M renders the SVG natively. 

6.4.7 Publishing PDF files

Before you generate a PDF file you will probably want to modify one of the standard print

manual templates  supplied with Help+Manual for your own needs. These standard tem-

plates provide a basic framework for your user manuals and PDF documents but they contain

a number of elements which you will want to change, like the contents of the cover page and

introduction and so on.

Key Information

803
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A maximum of 6 TOC levels are supported in PDF files.

If you have more levels than this, they will be displayed

on the same level of the print-style TOC. Levels below

level 6 will not have headings in the body of your text.

Step 1: Prepare your print manual template

Follow the instructions in Using PDF templates  to create or edit a PDF print manual

template. 

Once you have created a personalized print manual template you can use it as often as

you like, both for your current project and for other projects. 

It's a good idea to store your edited template in your project directory. This keeps all the

files associated with your project together and makes your project more portable.

Step 2: Configure your PDF settings

Open your project and go to Configuration > Publishing Options > Adobe PDF  in the

Project Explorer to configure the export settings for Adobe PDF. 

See Adobe PDF settings  in the Reference section for details on the other available set-

tings.

A printer driver is needed for PDF output:

Go to View > Program Options > PDF Export  and check your reference device for

PDF output. 

If you are not using EMF or WMF graphics you can get good results by setting the

screen device. Otherwise you need to use a printer driver, which does not have to be

the driver for a printer physically connected to your computer.

If you experience any problems with your PDF output they may be caused by propriet-

ary printer drivers. If this happens try installing a standard driver for a common printer

like a LaserJet or a DeskJet from the Windows CD. Then select this driver as your refer-

ence device in the PDF Export tab. You can also achieve excellent results with the Mi-

crosoft XPS Document Writer driver included with Windows 7 and Vista.

Embedding fonts in your PDF output file:

If you use rare fonts in your project you should make sure that those fonts are embed-

ded in your PDF file, otherwise they will not be displayed on computers where they are

not installed. However, note that this can significantly increase the size of your PDF file

(particularly on Windows 7 and Vista!).
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By default, Help+Manual automatically embeds all fonts except a list of standard fonts.

To check this exclusion list go to Configuration > Publishing Options > Adobe PDF

Output > Font Embedding .

Step 3: Publish your PDF 

1. Select  Project  > Publish , and select Adobe PDF as your publishing format. 

2. Choose whether you wish to publish comments  as annotations in the PDF. This is

useful if you are sending a PDF for a review of your project and you want your com-

ments to be available.

3. Select your PDF template  in the Publish settings, then just click Publish Now to

generate your PDF. 

See Publishing Your Projects  for more details on publishing.

See also:
Publishing Your Projects

Using PDF templates

Conditions and Customized Output

PDF Questions  (FAQ)

6.4.8 Printing user manuals

The Print Manual feature in Help+Manual generates the printout by creating a temporary PDF

file and printing it. This means that preparing a printed manual is essentially the same process

as preparing for generating a PDF file. You use the same configuration options and the same

print manual templates for defining the layout of your printout.

Before you print  a user manual you will probably want to modify one of the standard print

manual templates  supplied with Help+Manual for your own needs. These standard tem-

plates provide a basic framework for your user manuals and PDF documents but they contain

a number of elements which you will want to change, like the content of the cover page and

introduction and so on.
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Key Information
A maximum of 6 TOC levels are supported in printed

manuals. If you have more levels than this (which is

not recommended) they will all be displayed on the

same level of the published TOC. Levels below level 6

will not have headings in the body of your text.

Step 1: Prepare your print manual template

Follow the instructions in Using PDF templates  to create or edit a PDF print manual

template. 

Once you have created a personalized print manual template you can use it as often as

you like, both for your current project and for other projects. 

It's a good idea to store your  edited template in your project directory. This keeps all the

files associated with your project together and makes your project more portable.

Step 2: Use Print Preview to check your user manual

1. Select Print Manual in the File menu and then select Preview. 

Print Preview

2. Select the printer you want to use at the top of the page (the printer driver is needed

to generate the preview).

3. Select the print manual template you prepared in Step 1 in the field below the printer

selection. Use Open Template... to select the template file, which has the extension

.mnl. A set of standard templates can be found in the \Templates\pdf folder in the

Help+Manual program directory.

4. Select any Include Options appropriate for your manual. The default selection here is

Print Manual and you will not need to change this unless you have made use of in-

803
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clude options in your project. (See Conditions and Customized Output  for more de-

tails on include options and how to use them.)

5. Set the other options in the dialog as you would like to have them, then click on Pre-

view on the right to display the print preview.

You can jump to individual pages in the preview by entering page numbers in the box at

the top of the preview widow.

Step 3: Print your user manual

1. Open your project and select Print Manual in the File menu, and make sure that Print

is selected in the page displayed. 

Print

2. Select the printer you want to use at the top of the page.

3. Select the print manual template you prepared in Step 1 in the field below the printer

selection. Use Open Template... to select the template file, which has the extension

.mnl. A set of standard templates can be found in the \Templates\pdf folder in the

Help+Manual program directory.

4. Select any Include Options appropriate for your manual. The default selection here is

Print Manual and you will not need to change this unless you have made use of in-

clude options in your project. (See Conditions and Customized Output  for more de-

tails on include options and how to use them.)

969
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5. Set the other options in the dialog as you would like to have them, then click on OK to

print.

Printing or previewing selected topics only

1. If you only want to print or preview individual chapters or topics select them first in

the TOC with the mouse. Use Ctrl+Click and Shift+Click to select multiple topics. 

2. Then follow the instructions above, click on the Table of Contents bar above the In-

clude Options box in the Print Manual page and select the Publish selected TOC items

only option in the drop-down menu.

When you use this method the cover page, TOC and other additional pages defined in

your print manual template will also be generated. To prevent this just make a copy of the

template and edit it to disable all sections except the Topics section. Then use this "topics-

only" template for generating your "quick output".

See also:
Printing topics

Print Manual  (dialog reference)

6.4.9 Using PDF templates

The layout of Help+Manual's PDF and print manual output is controlled by template files

called "print manual templates" with the extension .mnl that do much more than just define

the appearance of your pages. These templates can also add front and back covers, multiple

title pages at the beginning, an introduction, a formatted table of contents, title pages for in-

dividual chapters, graphics, headers and footers, a formatted index and multiple endnotes

pages. You can also define your own additional pages and insert topics from your project or

external files with a "snippets" function.

All the global variables and user-defined variables from your project file can be used in your

print manual templates. Since the templates are external files you can use them in multiple

projects, applying them to your output just as you apply skins  to HTML-based output

formats. 
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How to select a print manual template

You can select separate templates for PDF output and printed manuals. 

Selecting a print manual template for PDF output:

1. Select Publish in the Project menu, then select PDF as your publishing format. 

2. Click on the dropdown area shown above to select the template you want to use.

Selecting a print manual template for printing a user manual:

1. Select the File menu and click on Print User Manual . 

2. Click on the dropdown area shown above to select the template you want to use.

How to edit a print manual template

· Select Project  > Tools > Manual Designer  to open the Print Manual Designer. Then

select File > Open in the Designer to open the template for editing. You can find a se-

lection of standard templates that you can edit in the \Templates\pdf folder in the

Help+Manual program directory.

· When you open the Manual Designer it will automatically load the last PDF template

used for the current Help+Manual project, if there is one.

The Print Manual Designer is a separate program with its own documentation. See the

help in the Designer for details on how to use it.

1290
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Location of the standard print manual templates

Help+Manual comes with a selection of standard print manual templates that are stored

in the \Templates\pdf subdirectory in the Help+Manual program directory. These

templates have the file extension .mnl.

See also:
Templates and Secondary Windows

6.4.10 The Print Manual Designer

The Print Manual Designer is a separate program used for editing the .mnl print manual

template files that define the layout and appearance of your published PDF files and printed

manuals. 

In addition to defining the layout of your PDF pages, you can also add additional pages and

content not included in your project, including cover and back cover pages, an introduction, a

formatted table of contents, title pages for individual chapters, headers and footers, a format-

ted index and multiple endnotes pages. You can also add your own custom pages and insert

topics from your project and external Help+Manual XML files. 

The Print Manual Designer has its own help so this topic only describes the basic procedures

for opening templates for editing and selecting them in your projects. Print manual template

files have the extension .mnl.

How to start the Print Manual Designer

· Select Templates & Skins > Launch PDF Manual Designer in Project > Tools.

If a PDF template has already been used with the current project you can select it directly

in the menu and load it into Manual Designer.

If you have not yet used a PDF template you should start with one of the standard tem-

plates included with Help+Manual. It is generally easier to edit an existing template, be-

cause all the necessary objects have already been added and you just need to modify

1007
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them. The standard templates can be found in the \Templates\pdf folder in the

Help+Manual program directory, which is normally C:\Program Files\EC Soft-
ware\HelpAndManual8.

You will need to make a copy of any standard template you load from the Help+Manual

program directory storage to be able to edit it. To do this, select Save As... in the File

menu and save it in your project folder. 

How to edit a print manual template associated with your project

If PDF templates have already been used with the current project they are listed in the

Templates & Skins menu. You can select one of the templates directly in the menu and it

will be opened with Manual Designer.

Note that you can use different templates for PDF and print manual output.

How to assign a print manual template to your project

You select the template to be used with your project in the Publish settings when you are

publishing your project. Once you have made a selection there Help+Manual will remem-

ber the setting the next time you publish your project to PDF.

Selecting a template for Adobe PDF output:

1. Select Publish in the File menu and then select PDF as your publishing format. 
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2. Select the PDF template you want to use by clicking on the drop-down area shown

above.

Selecting a template for printed manuals:

1. Open your project, click on the File menu and select Print Manual. 

2. Select the PDF template you want to use by clicking on the drop-down area shown

above.

See also:
PDF and Printed Manuals

PDF and print manual templates

Adobe PDF

Printed manuals

6.4.11 Embedding files in PDFs

You can automatically embed files referenced with file links into the PDF file when you ex-

port your project to PDF. This makes it possible to distribute additional files with your PDF

document without having to use multiple files. 

When the user clicks on the link the file will be displayed with the application with which it

is associated in Windows. This works for most file types, including other PDF files, docu-

ments and images of all kinds and even executable EXE files.

1. In the Project Explorer go to Configuration > Publishing Options > Adobe PDF >

PDF Layout and activate the option File links - embed linked files with the following ex-

tensions:. 

2. Make sure that the files you want to link to are stored in one of the folders referenced

in your Image Folders  list in your project configuration settings. If you have many

785
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folder references place the files in one of the first few folders in the list.

3. Create your file links using the normal procedure. 

When you publish your project the files referenced with file links will be physically embed-

ded in the PDF file. You no longer need to distribute these files separately as they are now

part of the PDF. This will increase the size of the PDF accordingly, of course.

See also:
Inserting file links

6.4.12 Fonts & font embedding

If you are using Western languages with the Latin character set you will generally not have

any problems with font rendering in your PDF files, unless the fonts you use in your project

are not installed on the user's computer. If that is likely, you should embed the fonts in the

PDF document with the settings in Configuration > Publishing Options > Adobe PDF > Font

Embedding. See Font Embedding  for details.

Text looks strange with incorrect spacing 

If the text in your PDF looks strange, with some characters displayed incorrectly and odd

spacing between the characters the culprit is most probably the printer driver used to

generate the PDF document. To fix this, go to View > Program Options > PDF and select

a different driver for your PDF output. 

On current versions of Windows you will generally get good results with the Microsoft XPS

Document Writer driver, which is always present. Customized drivers from printer manu-

facturers often cause problems, however. If you experience this, try installing one of the

standard printer drivers included with Windows. To do this, just add a new printer in the

Windows Control Panel, then choose that printer as your PDF reference driver in

Help+Manual. You don't have to have the physical printer to be able to do this. Any re-

cent DeskJet or LaserJet driver from the standard list will generally produce good results,

and the Brother HL series laser printer drivers are also generally good.

Problems with symbol and bullet characters

PDF often has problems with the handling of bullet and symbol characters from some

fonts and character sets. Help+Manual avoids this problem by inserting these characters

as glyphs, which are small graphics. This option is on by default but in some rare cases it

may cause different problems – for example when you are later trying to convert your PDF

to something else with a different program. If you need to, you can switch this option off

in Configuration > Publishing Options > Adobe PDF > Font Embedding.

424
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Settings for Asian languages and other special character sets

If you are publishing a project that requires fonts with special character sets, for example

for Asian languages, Russian or Greek, you may need to configure some special settings in

the font embedding section of your project. See Font Embedding  for details.

Use fonts that contain all the characters you are using

If you are using any kind of special characters it is very important that the font you choose

to display them includes those characters. This is usually the case with modern Unicode

fonts, but custom fonts often have limited character sets. Your PDF may look OK when

such a font is used, but you may find that the file then becomes very large and the text

cannot be selected or searched. This is because of the missing characters — when this

happens, all the characters (not just the missing ones) have to be replaced with little

graphics to make up for the missing support in the font. This takes up a lot of space and

cannot be searched like normal text.

Use separate fonts for different languages in the same project

If you are mixing languages with the Latin character set and other languages in a single

project, particularly Asian languages, it is generally advisable to use separate fonts for

each language. Here too, it is essential to make sure that the fonts you use actually con-

tain all the characters you are using in your text. A single missing character in the font can

cause the text to all be rendered as glyphs (graphics), resulting in the problems described

above.

See Font Embedding  for detailed recommendations on this subject.

6.5 Automating Publishing Jobs

In addition to publishing your project to a single output format, you can also define "publish-

ing tasks" with a list of multiple output formats and versions of your project. Once you have

got a task set up, you just need to select it to perform all the predefined publishing opera-

tions in one automated process. You can also generate batch files from tasks that you can

then integrate in your own automated software build processes. You can do this manually

with the command line options , but it is much easier to generate the batch files automatic-

ally with the Publishing Task Manager. 

1447
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Publish multiple versions and formats with the Task Manager

Professional and Floating license versions only

Please note that support for publishing tasks is only included in the Professional and

Floating license versions of Help+Manual. The task-based publishing interface is not avail-

able in the Basic version. 

6.5.1 Using publishing tasks

To open the Publishing Task Manager select Publish in the File Menu, then click on Task Man-

ager at the upper right to show the Task Manager page. Help+Manual includes a ready-made

publishing task called "Common" for the three most common output formats.
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A publishing task consists of a list of "actions". Each action is one publishing operation for

your project. The action definition includes the output format (CHM, WebHelp, PDF etc.)

and the output file name and path, whether you want to delete the temporary files and

display the finished help automatically and the include options for conditional output .

In addition to this, the actions can also include a list of variables you want to redefine for

this specific task.

For full instructions, see Creating and editing tasks .

How to publish all the actions in a task

1. Double-click on each action in the task and check at least the output file name and

path. If you want, you can also set include options and redefine some variables in your

project as well. 

2. Close the action editing dialog and click on Publish Task to finish. Help+Manual will

then perform all the publishing task actions one after another.

3. There is no step 3, you're finished!

How to publish individual actions in a task

If you want, you can also publish just individual actions in a task instead of all of them.

1. Select the actions you want to publish in the task. If you want to select more than one

action use Ctrl+Click and Shift+Click. 

2. Right click on the selected items or click on More... to display the context menu:

616
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3. Select Publish Selected Items to publish.

Repeat recent manual publishes with "Recent Publishes"

If you are in a hurry you can repeat recent manual publish operations with the "Recent

Publishes" task, which is generated automatically by Help+Manual. You will only see this

task if you have published the current project manually at least once.

You can repeat all the publish operations stored in Recent Publishes unchanged, publish

individual actions (see above) or edit the actions to change them before publishing. 

Don't try to permanently save actions in Recent Publishes. They will be overwritten

by your next manual publish operations!

6.5.2 Creating and editing tasks

Creating and editing publishing tasks is quite similar to publishing a project. Almost all the

settings and procedures are really identical. The only difference is that instead of publishing

directly, you are saving the publishing instructions to be used again later.

Productivity Tip
Before you start trying to create publishing tasks you

should be familiar with manual publishing. Learn to

use conditional output  and variables  on their

own before trying to use them in publishing tasks.

How to create publishing tasks and actions

A publishing task is a group of publishing operations that are all performed together. A

publishing action is a single publishing operation within a publishing task. You can have

more than one action for the same output format in a single task if you want. For ex-

ample, a task might include three different PDF versions of your project, using different

templates and with different content.

969 917
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Using variables in the output file field

You can use a variable instead of a file name in the output field. This should be a variable

defined globally for the entire project, not a single-topic variable. Don't include the file ex-

tension in the variable definition, as that is added automatically by Help+Manual if it is

not present in the output field. So you should enter something like:

<%OUTPUT_FILE%>.pdf or <%OUTPUT_FILE%>.html.

Creating a task:

1. Open the Publishing Task Manager and click on the New Task button at the bottom of
the task list. This opens the task editing dialog: 

2. Type the name of the task in the left box of the top and the name of the first action in
the right box. 

3. A new task must always have at least one action. Select the action type on the left,
then set up your publishing output path/file and options just as you would for normal
manual publishing. You can also use Include Options  for publishing different ver-
sions of your project. See further below for information on setting up custom vari-
ables.

4. Click on OK to create the task. 

Adding more actions:

To add a new action just click on the "Add New Task Action" item directly below the task.
This displays the same dialog as above, in which you can select the task type and define
its output options and settings. 

616
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How to edit and rename actions

Opening the action for editing:

To edit an action in a task just double-click on the action or right-click on it and select Edit

Action in the context menu. All the editing operations are the same as for creating a task.

Renaming actions:

To rename an action open it for editing and click in the action name box at the top of the

edit action dialog. Note that you can only rename actions, you cannot rename tasks after

creating them!

How to use custom variables in publishing actions

Until the Publishing Task Manager became available you could only redefine variables

with command line publishing. You needed to define an external variable definition file

and refer to it in a command line. Now you can redefine the values of any variables in

your project for individual publishing actions to individualize each publishing output as

you want. For example, if the product name referred to is different in two versions of your

documentation, you can redefine your PRODUCTNAME variable (or whatever you have

called it).

Redefining just a few variables manually:

1. Make a note of the variable names you want to redefine. 

2. Open the action for editing and select the Custom Variables tab.

3. Click on Add and enter the name of the variable you want to redefine.

4. Select the variable type (HTML or Text) and enter its value, just as you would when
defining a user variable . 919
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Redefining a large number of variables from a list:

You can also import an edited list of variable definitions. The easiest way to do this is to

first export the variables stored in your project to a text file and edit their definitions there.

Then you can import the edited file in one easy operation.

1. In the Project Explorer, go to Configuration > Common Properties > Text Variables

and use the Export button to export your variables to a text file. See User-defined vari-

ables  for more information on working with variables. 

2. Edit the list of variables in a text editor. You can remove variables from the list by de-

leting their definition lines and change the variable definitions, but don't try to change

the variable names.

3. Open the publishing action for editing, select Custom Variables and use the Import

button to import the edited variables list.

Tip: You can also use the Export button to export an edited list of variables from the ac-

tion for use in other actions!

Build events: Programs to execute before and after publishing

The Build Events tab allows you to define programs to be executed before and after pub-

lishing. For example, you might define a pre-processor that you have programmed your-

self to change the content of your project before it is published, or a digital signing tool to

sign your output after it has been published. 

Adding build events:

Use the Add button in the Build Events tab to add events. 

Name: The name of the event shown in the Publishing Task Manager. This

can be anything you like.

Command: The command to be executed. If the path is not in your Windows

path variable you need to include the path relative to file to be ex-

ecuted.

Parameters: Any optional parameters for the command. 

Exit codes:

If you set an event before publishing Help+Manual waits for exit code 0 from the last

build event before starting. Any program, script or batch file you execute before publish-

919
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ing must deliver a valid exit code when it closes, otherwise Help+Manual will not proceed

with the publishing process. 

Programs and utilities need to deliver a valid exit code on closing. If you are using a batch

file you should always terminate it with the following line to make certain that you have a

valid exit code:

EXIT /B %ERRORLEVEL%

Help+Manual will only proceed if it registers and exit code of 0 from the build event.

Anything else is interpreted as an error and publishing will not proceed.

6.6 Command Line Publishing

Help+Manual has a full command line publishing interface that supports conditional include

options, batch and INI files, skins and variable definitions. This make it possible to fully auto-

mate your publication process. The command line interface runs as a console-only process

that does not open the main Help+Manual program. It returns standard exit codes that can

be captured and processed by your batch files.

Generally, you will only need to use the command line interface for particularly complex pub-

lishing tasks and for integration into your regular software build process. If you just want to

generate multiple versions and output formats in a single process it is easier to use the Pub-

lishing Task Manager . You can also use the Publishing Task Manager to auto-generate

batch files that you can use in your own automated build processes. Publishing tasks created

with the Task Manager can also be called via the command line interface as well, using

the /TSK= switch. 

License management for batch/build server operation 

If you are going to run command line/batch publishing operations with Help+Manual

from other users on your network you need to register your license for build server opera-

tion. This can be done with any Professional or Floating license version. 

Command line batch activation for headless servers

Before using your machine as a build server you need to activate your license for batch

use with the following command line call:

<path>HELPMAN.EXE /lic:XXXXXXXXXXXXX

Where XXXXXXXXXXXXX is your license key. The server must have an Internet connection

when you do this. Upon successful activation, the digital license key for build server use is

saved in the Help+Manual program directory on the headless server. You only need to do

809
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this once. After this you can run normal batch operations on the licensed computer from

anywhere in your local network.

6.6.1 H+M command line syntax

This syntax guide for the main Help+Manual program is a quick reference for users familiar

with using the Windows command line. For detailed instructions see the other topics in this

chapter. 

Paths in the command line

The syntax examples all assume that you are entering the command lines in the

Help+Manual program directory, which is normally C:\Program Files\EC Soft-

ware\HelpAndManual8. To get the same effect you can also add the Help+Manual pro-

gram directory to your Windows PATH  environment variable so that you can use the

HELPMAN.EXE file without adding a path to it. 

When you do this you must only enter a path for the project file argument (pro-

ject.hmxz in the syntax guide). All the other file name arguments automatically use this

path so you don't need to enter a path for them if they are stored in the project directory.

You must enter path information for all files stored in any other location. You can use rel-

ative paths if you want – they are then relative to the project directory.

Help+Manual (helpman.exe) command line syntax:

HELPMAN.EXE "<Path>\project.hmxz" /<format> /<other
switches> ...

Always enclose all paths and filenames containing spaces in quotes.

HELPMAN.EXE Single option, use
once only

The Help+Manual program file.

<Path> Single option, use
once once only

The path to the project file, e.g.
"F:\Projects\Help Pro-
ject\project.hmx". Always

enclose this and the project file
name in quotes if they contain
spaces. This path is used
automatically for all other file
arguments for which you do not
enter paths.

project.hmxz / 

project.hmxp

Single option, use
once only

The project file you want to
open. This must always come

http://support.microsoft.com/kb/310519
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Help+Manual (helpman.exe) command line syntax:

HELPMAN.EXE "<Path>\project.hmxz" /<format> /<other
switches> ...

Always enclose all paths and filenames containing spaces in quotes.

directly after the Help+Manual
program file name.

/<format> Multiple option,
use once per
output format,
followed by the
local options for
that output

The output format switch. This
must always be the first switch
entered after the project file
name. The other switches listed
below can be used in any order
but they must come after the
output format switch.

Switches: 

/CHM (HTML Help)

/HTML (WebHelp)

/HXS (VS Help 2008 / MS

Help 2.0 and VS Help 2010 /
MS Help 3.0)

/PDF (Adobe PDF)

/DOCX (Word DOCX)

/EPUB (iBooks/ePUB eBook)

/MOBI (Amazon Kindle Mobi
eBook)

/EBOOK (eWriter Help) OR

/EXE (eWriter Help)

eWriter Help:

eWriter Help files are created
with an integrated viewer if you
use the .exe extension and as

a book only if you use any other
extension. For clarity, you
should always specify the
output file name and extension
for this format in your batch
jobs. See here .

Examples:

   /EXE=testproject.exe
   /EBOOK="newbook.ewriter"
   /EXE="F:\Final
Build\testproject.ewriter"

Visual Studio Help:

719
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Help+Manual (helpman.exe) command line syntax:

HELPMAN.EXE "<Path>\project.hmxz" /<format> /<other
switches> ...

Always enclose all paths and filenames containing spaces in quotes.

There is just one switch for both
formats (.HXS and .MSHC).
Which format is generated
depends on the file extension
you specify for the output file
(.hxs or .mxhc). 

Output file name and path: 

You can also specify the output
file name and path. If you don't
specify it, the values used when
you last published to the
specified format will be used.

Examples:

   /CHM=testproject.chm
   /HTML="F:\Final
Build\index.html"

/I=<include options> Local option, use
once per output
format option,
after the format
option.

Always use this if
your project uses
format-based build
options!

Corresponds to the include
options set in the Make Help
File & Run  dialog. User-
defined options  are also
supported. Use upper case only,
separate options with commas
and don't type any spaces
between individual options.

If you don't specify the /I switch

the program will use the last
include options used when you
last published to the specified
format.

Important: These options do
not select the output format!

Format include options: 

ALL All builds and user-

defined options "true".

CHM (HTML Help)

HTML (WebHelp)

HXS (VS Help 2008 / MS Help

2.0 and
         VS Help 2010 / MS
Help 3.0)

1310

988
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Help+Manual (helpman.exe) command line syntax:

HELPMAN.EXE "<Path>\project.hmxz" /<format> /<other
switches> ...

Always enclose all paths and filenames containing spaces in quotes.

PDF (Adobe PDF)

PRINT (Word DOCX and RTF)

EBOOK (Windows Exe or

ePUB eBook)

Examples: 

/I=CHM,MYBUILD
/I=HTML,HXS,DEMOVERSION

You should always use this
switch to specify the valid
output format if your project
uses format based build options
(conditional text or TOC include
options). Otherwise the build
options may not work correctly!

For the same reason, when you

use the /I switch you should

also always include the format
you are exporting to.

You can use your user-defined
include options in exactly the
same way as the format include
options.

/E=<exclude options> Local option, use
once per output
format option,
after the format
option. 

Can be used on its
own or in
combination with
and after the /I=
include switch, to
negate individual
options.

This is the reversed version of
the /I= include switch. It
excludes content tagged with
the specified build options
instead of including it. 

Purpose:

The /E= switch negates any
existing includes set with
the /I= switch, overriding all
other switches for the affected
content. This is useful if you
want to exclude some individual
items that have multiple build
options applied. 

For example, suppose you have
multiple topics tagged with
CLIENTA and some of those
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Help+Manual (helpman.exe) command line syntax:

HELPMAN.EXE "<Path>\project.hmxz" /<format> /<other
switches> ...

Always enclose all paths and filenames containing spaces in quotes.

topics are also tagged with
BETA. To include all the

CLIENTA content that are not

also tagged with BETA you

would use this switch
combination:

Example:

/I=HTML,CLIENTA /E=BETA

This will exclude all content
tagged with the BETA build, no

matter what other build options
are included. 

/TOC=<TOC Name> Selects the TOC to
be used for
publishing in
projects in which
multiple TOCs
have been
defined. 

IMPORTANT: Can
only be used once
in a single
command line,
because your
output can only
use one TOC.

Syntax example:

/TOC="Demo Version TOC"

Note the quotes around TOC
names containing spaces!

/TSK=<task:action> Special option to
execute a
publishing task.
Can be used
multiple times in a
single command
line to execute
multiple tasks.

For better clarity
use on its own
command line
within a batch file

Call a publishing task  defined
in your project. Syntax:

/TSK="Task Name:Action
Name"

If you only enter the task name
on its own (no : character!) all
the actions in the task will be
executed. If you include an
action name separated by the :
character only that action will
be executed.

To execute multiple tasks or
actions use /TSK= multiple

343

809



822

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Publishing

Help+Manual (helpman.exe) command line syntax:

HELPMAN.EXE "<Path>\project.hmxz" /<format> /<other
switches> ...

Always enclose all paths and filenames containing spaces in quotes.

not combined with
other switches. 

HELPMAN.EXE +
Project + /TSK
+ /TSK..

times in the command line with
one task or task+action per
instance.

Copy and paste the task and
action names from  File >
Publish > Task Manager. 

Use the "Generate Publish Batch
File" in the Task Manager to
generate examples.

/V=<filename> Local option, can
only be used once
per output format
option, after the
format option. 

Use skins with
the /O= switch if
you want to apply
multiple files for
redefining
variables to the
same output. To
redefine variables
only with skins the
skins should be
saved with
variables only.

Redefines some or all of the
variables in your project with a
list of variables in an external
text file. You do not need to
enter a path if the file is stored
in the project directory. Use
quotes if the path or filename
contain spaces.

Data file format:

TITLE=Widget Editor V2.8
EDITORS=John and Jane Doe
COPYRIGHT=Widgets Inc.,
all rights reserved

One line per definition, no
quotes, no spaces on either side
of the = sign.

Command line usage
examples: 

/V=variables.txt
/V="F:\Data
Sources\variables.txt"

/O=<filename> Local option, can
be used multiple
times per output
format option,
after the format
option. The last file
used has priority.

Apply a project skin  to the
project when publishing. Enter
the name of the .hmskin file

for the filename argument. 

Overwrites all variables,
settings and HTML templates in
the project with those defined in
the skin file. You can use this
switch multiple times,
specifying multiple skins. If the

638



823

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Publishing

Help+Manual (helpman.exe) command line syntax:

HELPMAN.EXE "<Path>\project.hmxz" /<format> /<other
switches> ...

Always enclose all paths and filenames containing spaces in quotes.

same attributes are defined in
more than one skin the last skin
in the command line always has
priority.

Note that the use of .hmskin
skins is intended for HTML
output only. If you use them for
other output formats you will
only get the settings that can
actually be edited in them in
Help+Manual.

/S=complete Local option, use
once per output
format option,
after the format
option

Only includes topics and chapters

with the status "complete" in

your published output. All topics

with any other status are ex-

cluded. Only the status "com-

plete" is supported for this

switch.

/Template=<filename> Local option, use
once per output
format option,
after the format
option

Specifies the name of the PDF
or DOCX template file. Include
the path and use quotes if the
path or file name contain
spaces. Only supported for PDF
and DOCX output.  You do not
need to enter a path if the file is
stored in the project directory.

If you don't specify this switch
the program uses the template
selected for PDF or DOCX in
your publishing options .

/noclose Deprecated as of
version 5.3, no
longer has any
effect.

In earlier versions this switch
left Help+Manual open after
publishing was completed. As of
version 5.3 only a console is
opened in command line mode,
the main program is never
opened and so this switch is
deprecated. Using it will not

1442
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Help+Manual (helpman.exe) command line syntax:

HELPMAN.EXE "<Path>\project.hmxz" /<format> /<other
switches> ...

Always enclose all paths and filenames containing spaces in quotes.

cause an error, but it also won't
do anything. 

/keeptemp Global option,
insert after the
first format option
for which you wish
it to apply

Don't delete the temporary
source directories and files
generated when publishing
HTML Help, Apple
iBooks®/ePUB, Kindle/Mobi,
EWRiter and Visual Studio Help.

/L=<compiler log file> Global option,
insert after the
first format option
for which you wish
it to apply

Outputs the compiler log to the
specified text file. If you don't
enter a path the file is stored in
the project directory. Use
quotes if the path or filename
contain spaces. 

If you use multiple output
format  options or .INI files
you can enter this switch after
the last output format switch to
log the error messages for all
output formats.

If you do not use this switch no
log will be written, even if
errors occur. If you want to see
the errors you must either
include a pause command in
your batch to keep the console
open or specify a log file
with /L. 

/stdout Global option. Must
be the SECOND
command line
parameter, directly
after the project
file reference.

Directs command output to
STDOUT instead of creating a
new console.

Should only be used in batch
files.

/debug Global option, use
once per command
line after all the
format options

Display a message window
before outputting showing the
batch commands and whether
they have been recognized
properly. Use for

830 837
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Help+Manual (helpman.exe) command line syntax:

HELPMAN.EXE "<Path>\project.hmxz" /<format> /<other
switches> ...

Always enclose all paths and filenames containing spaces in quotes.

troubleshooting if your
command line doesn't work as
expected.

Warning: Don't use /debug in
normal batch build processes. It
opens a modal window and will
interrupt the automated
process.

6.6.2 Exit codes

When the command line console closes it issues a standard exit code that you can use to con-

trol further batch processing if you are integrating Help+Manual output in your automated

build process.

Note that a log file is not generated automatically, even if errors occur and the console will

normally close automatically after the process finishes.

· If you want to create a log you must explicitly specify this with the /L=<logfile>

switch in your command line. Log files are not generated automatically.

· If you want to be able to read the console messages you must include a pause in-

struction at the end of your batch file to keep the console window open. (This is only

possible with a batch file, not with direct entry in the command line console.)

Exit code Meaning

0 No errors, compilation com-

pleted correctly

1 General critical error, compila-

tion could not be finished,

aborted 

2 One or more warnings, see log

file or console output for de-

tails

3 One or more non-critical er-

rors, see log file or console

output for details
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6.6.3 Basic command line options

This topic describes the basic command line options available and how to use them by
entering the commands manually from a command line prompt. See INI and batch files  for
details on how to automate the process and for information on using more complex
sequences of commands. 

See Syntax reference  for details of all the command line switches and arguments
available.

Paths in the command line

The examples all assume that you are entering the command lines in the Help+Manual

program directory. When you do this you must only enter a path for the project file. All

the other file name arguments automatically use this path so you don't need to enter a

path for them if they are stored in the project directory. 

However, you must enter path information for all files stored in any other location. You

can use relative paths if you want – they are then relative to the project directory.

If you store your batch files in the project directory then you only need to enter the path

to the HELPMAN.EXE program (or you can add HELPMAN.EXE to your system PATH vari-

able and then you don't need to enter a path for that either).

Basic syntax – opening a project from the command line

This is the simplest possible command. It just starts Help+Manual and loads the specified

project file. This is rather pointless on its own but it illustrates how the command line is

used.

· Switch to the Help+Manual program directory and enter the following command, repla-

cing F:\My Projects\ with the path to your project file and projectfile.hmxz

with your project file name, which can be an .hmxp or an .hmxz file:

HELPMAN.EXE "F:\My Projects\projectfile.hmxz"

· Note the use of quotes! Since the project path contains a space it must be enclosed in

quotes. The same applies for any file names in the command line that contain spaces. 

Compiling a project from the command line

To publish a project from the command you just need to add an additional command

known as a "switch" to specify the output format you want to use. The following example

compiles the project to an HTML Help CHM file, using the last output location and file

name you used when you published manually. 

837
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See the Syntax reference  for details of the available output format switches.

HELPMAN.EXE "F:\My Projects\projectfile.hmxz" /CHM

The output format switch must always be the first switch after the project file name. All the

other switches can come in any order but they must be after the output format switch.

The only exception here is the /TSK switch for publishing predefined publishing tasks,

which can be used on its own without any other switches. See Output to multiple

formats  for details.

Note the use of quotes! All paths and file names that contain spaces must be enclosed in

quotes.

Compiling a project to a different location and file name

To publish a project to a different location and file name just add them to the output

format switch with an equals sign:

HELPMAN.EXE "F:\My Projects\projectfile.hmxz" /CHM="F:\My Pro-
jects\Help\WidgetHelp.chm"

If you don't enter the output filename and path the last values used when publishing

manually from Help+Manual will be used.

Note the use of quotes! All paths and file names that contain spaces must be enclosed in

quotes.

Compiling to PDF with a specific PDF print manual template

The following examples generate PDF files with an explicitly-specified print manual tem-

plate.  The first example assumes that the print manual template is stored in the project

directory. The second example gets the template from the \Templates\Pdf folder in

the Help+Manual program directory.

Example 1:

HELPMAN.EXE "D:\Help Project\MyHelp.hmxz" /PDF=widget.pdf /Tem-
plate=a4_template.mnl

Example 2:

HELPMAN.EXE "D:\Help Project\MyHelp.hmxz" /PDF=widget.pdf /Tem-
plate="C:\Program Files\EC Software\HelpAndManual8Tem-
plates\Pdf\widget.mnl"

817
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6.6.4 Using include options

You can use conditional output include options in the command line. These options control

what is included in your published output on the basis of the selected output format or user-

defined include option conditions. Setting them is equivalent to setting the include options in

the Publish  dialog when you publish manually.

Specifying include options is optional. If you don't specify this switch Help+Manual will use

the default include options, which are the options you used the last time you published to the

current output format manually.

See the Syntax reference  for details on all the available switches and parameters.

Key Information
Note that include options do not select the output

format! Include options only control what is included

in or excluded from your project, not the output

format of your project.

How to use include options

When you use this switch you should always also specify an include option for the current

output format as the first option. If you leave out the /I= switch the include options set

the last time you published the project manually will be used.

Add the /I= include options switch after the output format switch. Follow it with all the in-

clude options you want to use, separated by commas. Don't use quotes or spaces (a space

would identify a new switch).

Examples:

HELPMAN.EXE D:\Projects\widgeth-
elp.hmxz /CHM /I=CHM,FINALBUILD,USVERSION

HELPMAN.EXE D:\Projects\widgethelp.hmxp /CHM /I=CHM,PDF,DEMO

Both these examples output to HTML Help files (CHM). Note that the CHM include option is

included in both cases. The output format itself should always be included as the first in-

clude option. 

The second example also includes items specifically tagged for PDF in the HTML Help out-

put, which would normally only be included when you publish to PDF. 

1310
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Negating includes with exclude options

Normally, include options operate with OR logic. This means that if content is tagged with

multiple include options only ONE of those options needs to evaluate as true to include

the content. Sometimes, however, you may also want to exclude content on the basis of a

single option, no matter what other options the content is tagged with. This is not pos-

sible when publishing directly from Help+Manual, but you can do it with command line

publishing with the /E= exclude switch.

For example, suppose you have a project with a large number of topics intended only for

Client A, which you tag with a build option you have called CLIENTA. In addition to this,

you have also defined a build option called BETA, which you use for some content that is

not yet final. Your project includes the following three topics, with these build option tags:

Topic A: CLIENTA
Topic B: CLIENTA
Topic C: CLIENTA,BETA

If you only use /I= include options there is no way to include all the normal CLIENTA top-

ics but exclude Topic C, which is also tagged with BETA. Due to the OR logic, activating

CLIENTA as an include option would also include Topic C, because only one option needs

to be true to include the content.

You solve this problem by adding the /E= exclude switch with the BETA build, as follows:

/I=HTML,CLIENTA /E=BETA

The above switches in your command line will include Topic A and Topic B, but will ex-

clude topic C.

Output format and user-defined include options

Output format include options (i.e. for the output formats supported by Help+Manual)

and user-defined include options are both used in exactly the same way. Just type the op-

tions after the /I= switch, separated by commas. The examples below show the user-

defined options in red.

Examples:

HELPMAN.EXE D:\Projects\widgeth-
elp.hmxz /CHM /I=CHM,FINALBUILD,USVERSION

HELPMAN.EXE D:\Projects\widgethelp.hmxp /CHM /I=CHM,PDF,DEMO

See also:
Conditions and Customized Output 969
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6.6.5 Output to multiple formats

You can generate output to multiple formats with the command line, either by calling publish-

ing tasks defined in the Task Manager or by defining the output formats directly.  You can

also achieve this with multiple command lines stored and executed with INI and batch files

. 

Syntax for executing publishing tasks in the command line:

HELPMAN.EXE <path>\projectfile.hmxz /TSK="taskname:action-
name" /TSK="taskname:actionname"...

Syntax for selecting multiple formats directly in the command line:

HELPMAN.EXE <path>\project-
file.hmxz /<format1> /<switches> /<format2> /<switches> ...

Each format switch must be directly followed by all the switches you want to apply to that

format. Each format must have its own set of switches, they are not applied to multiple

formats.

Using publishing tasks in the command line

The easiest way to publish to multiple output formats from the command line is to call

predefined publishing tasks created with the Publishing Task Manager using the /TSK=

switch. See Automating Publishing Jobs  for full instructions on using the Task Manager.

Calling tasks in batch and INI files

Technically, it is possible to include the /TSK= switch as just one switch among many in a

single command line. However, there is no real benefit to this and it makes your batch files

more difficult to read and debug. 

Unlike other switches, the /TSK= switch can be used on its own. All you need is HM Program

+ Project File + /TSK. For clarity, it is really better to call this switch on its own on a

single command line.

The switch can be used in INI files in the same way as other switches. Just use the syntax:

TSK=taskname:actionname

As always with INI files, don't use any quotes around the components of the line.

Create task command lines with the Task Manager:

You can generate command lines for single and multiple actions from the Task Manager. Just

select the actions in a task, the select the Generate Publish Batch File option to create a batch

file. You can the copy the command line from that file to use it in your own manually-created

batch files.
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Although it is possible to mix the /TSK= switch with other switches it is easier to manage

if you call publishing tasks on individual lines of their own. Unlike other switches, all you

need for this switch is the HELPMAN.EXE filename, the project filename and the /TSK=

switch with the task and action names.

Publishing all the actions in a task:

To publish all the actions in a task just include the task name on its own, like this:

HELPMAN.EXE D:\Projects\widgets.hmxp /TSK="Daily Build"

Publishing single actions in a task:

To publish a single actions in a task add the name of the action after the name of the task,

separated by a colon (:) character:

HELPMAN.EXE D:\Projects\widgets.hmxp /TSK="Daily Build:Full CHM
Output"

Publishing multiple selected actions in a task:

To publish a multiple (but not all) actions in a task use the /TSK= switch multiple times,

once for each action. Alternatively, you can also write separate command lines for each ac-

tion if you like. The result will be the same. 

HELPMAN.EXE D:\Projects\widgets.hmxp /TSK="Daily Build:Full CHM
Output" /TSK="Daily Build:Full HTML Output"
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Local and Global Switches for Multiple Output

Local switches

The following switches are "local". They must be applied to each output

format individually by inserting them after the format switch for which they

should apply and before the next format switch.

/I=<include options> The include options you want to use

for the output format.

/Template=<template> The PDF template to be used for PDF

output (only for PDF output).

/V=<filename> This switch specifies an external file

to redefine the values of variables in
your project file. It can only be used
once per output format. See
Redefining Variables  for more
information.

/O=<filename> This switch specifies an external .hm-

skin HTML skin file to apply to your

output. Can be used multiple times

per output format. The last skin use

has priority for properties that also

exist in the previous skins.

/S=complete Only output topics with the status

"complete". 

Global switches

These switches can only be used once per command line and they apply from

the point in the command line at which they are inserted. 

/keeptemp Doesn't delete the temporary

directories and source files
generated for HTML Help, Visual
Studio Help and Apple
iBooks®/ePUB output.

/E=<compiler log file> Outputs the compiler log to the

specified file. 

/debug Displays debug information for each

output format before publishing.

If you have multiple output formats in a single command line you must insert

these switches directly after the first output format to apply them to all out-

put formats. To apply them only to  some output formats insert the switches

after the first output format for which you wish them to apply.

Examples:

1) helpman.exe project.hmxz /CHM /keeptemp /EPUB
2) helpman.exe project.hmxp /CHM /EPUB /keeptemp

Example 1) above keeps the temporary files for both the CHM and EPUB out-

put. Example 2) only keeps the temporary files for the CHM output. The same

applies for log files and debug information. 

See Syntax reference  for more information on the individual switches and

parameters.

834

817



834

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Publishing

Multiple output format command line examples

Example 1:

The following example compiles a project file to HTML Help and PDF, using conditional

output include options for the HTML Help file and selecting a specific PDF print manual

template for the PDF output file. The template is assumed to be in the project directory; if

it is stored somewhere else you must include its path.

HELPMAN.EXE D:\Projects\widget.hmxz /CHM=widgeth-
elp.chm /I=CHM,DEMO /PDF=manual.pdf /Template=manual.mnl

Example 2:

The following example compiles to CHM and WebHelp using include options. 

HELPMAN.EXE D:\Projects\widget.hmxp /CHM=D:\CHM\wid-
get.chm /I=CHM,FINAL /HTML=D:\HTML\index.html /I=HTML,FINAL 

See also:
.INI and batch files

6.6.6 Skins & redefining variables

You can also apply project skins and redefine some or all of your variables from the command

line. Note that creating user-defined skins is only possible with the Professional and Floating

license versions of Help+Manual. You can use existing skins with the Basic version but you

cannot save or edit your own skins. 

Skins are applied with the /O= switch and can completely restyle your entire project, includ-

ing the user-defined variables. What the skin does depends what you store in the skin file – it

is also possible to store only variables in a skin. The variables file method is applied with

the /V= switch and only redefines variables. 

When you are outputting to multiple formats you must enter separate /O= and /V= switches

for each output format for which you wish to redefine the variables. See Output to multiple

formats  and .INI and batch files  for details.

Applying project skins with the /O= switch

The easiest way to redefine user-defined variables in your entire project is with skins,

which can also apply an entirely new design to your project. In addition to user-defined

variables skins can also include your HTML page templates, your Baggage files and your

text and table styles. What is included depends on what you save with the skin file. 

837
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1. Save a project skin file (preferably in your project folder) and edit it with the values

you want to use. See Transforming your output with skins  for full details. 

IMPORTANT: To create a skin for redefining variables only, you can save a skin that

only contains variables. To do this select ONLY the variables option in the dialog dis-

played when saving the project as a skin. Leave all the other options unselected:

2. Reference the skin file in your command line with the /O= switch.

If the file is stored in your project directory you don't need to enter a path for the vari-

ables file because the path to the project file is used automatically. If it is stored anywhere

else you must enter a path. (You can enter either absolute paths or relative paths relative

to the project directory.)

Examples:

HELPMAN.EXE "D:\Project Files\Widget Help\Myproject.hmxp" /O=de-
moversion.hmskin

HELPMAN.EXE "D:\Project Files\Widget Help\Myproject.hmxz" /O="D:
\Data Files\lightversion.hmskin"

Remember, if any paths or file names contain spaces you must enclose them in quotes!

Multiple skins:

You can specify multiple skins for the same output format in a single command line. If the

same attributes are defined in more than one skin the attributes from the last skin in the

command line will overwrite those used in the previous skins.
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If you want to specify skins for separate output formats you must do so separately for

each output format. 

Redefining variables with the /V= switch

This method only redefines variables. You can also combine the two methods in any order

– if the skin file and the variables file both redefine the same variables the last file in the

command line has priority. You can redefine both TEXT and HTML variables. The variable

type will be maintained when you redefine it.

Important: Unlike the /O= switch for skins, the /V= switch for a variables text file can only

be used once per output format. If you use it more than once only the last reference will

be used. The others will be ignored.

Step one: Create a file with the new definitions

1. Create a new plain-text file and enter each variable you want to redefine with its new

value on a separate line using the following syntax. You don't have to redefine all the

variables. Only those included in the file will be affected. 

VARIABLENAME1=The new value of variable 1
VARIABLENAME2=<a href="https://www.helpandmanual.com/">EC Software Website</a>
VARIABLENAME3=The new value of variable 3

Don't enter the <% and %> tags for the variable names in this file and don't insert

quotes around the variable value strings. Don't enter tabs or spaces to the left or right

of the = signs.

Be careful to enter HTML code for HTML variables and text for text variables. If you

enter HTML code for text variables the code will be interpreted as plain text. 

2. Save the file with the .txt extension in your project directory.

Step 2: Publish your project with the /V= switch

Add the /V= switch with the name of  the variables file created in Step 1 to the command

line. If the file is stored in your project directory you don't need to enter a path for the

variables file because the path to the project file is used automatically. If it is stored any-

where else you must enter a path. (You can enter either absolute paths or relative paths

relative to the project directory.)

Examples:

HELPMAN.EXE "D:\Project Files\Widget Help\Myproject.hmxz" /V="D:
\Data Files\variables.txt"
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HELPMAN.EXE "D:\Project Files\Widget Help\Mypro-
ject.hmxp" /CHM=Myproject.chm /V=variables.txt /PDF=Mypro-
ject.pdf /V=variablespdf.txt

In the second example, different variables files are used for two different output formats

created in the same command line.

Remember, if any paths or file names contain spaces you must enclose them in quotes!

See also:
Using Variables

Using Skins

6.6.7 INI and batch files

As you have probably already realized, command lines can get quite long and complex, par-

ticularly if you use them to generate multiple output formats to different locations simultan-

eously. You can solve this problem with configuration files called INI files that contain all the

parameters you want to process, including output to as many different formats as you want. 

If you combine this with a batch file in the Help+Manual program directory and create a

shortcut to this file on your desktop you can automate the entire process and publish to mul-

tiple output formats with complex options for each format with a single mouse click.

Using batch files

Creating batch files for multiple command lines is very simple: 

1. Just use a text editor (not a word processor!!) to create a plain text file with the exten-

sion .cmd or .bat (CMD is the more modern format). 

2. Enter each command line exactly as you would in the command console, one com-

mand on each line.

3. Save the batch file and double-click it to execute it.

If you are not familiar with Windows batch files you can find plenty of information about

how to use them online. 

Using publishing tasks in the command line

The easiest way to publish to multiple output formats from the command line is to call

predefined publishing tasks created with the Publishing Task Manager using the /TSK=

switch. See Automating Publishing Jobs  for full instructions on using the Task Manager.

Calling tasks in batch and INI files

Technically, it is possible to include the /TSK= switch as just one switch among many in a

single command line. However, there is no real benefit to this and it makes your batch files

more difficult to read and debug. 
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Unlike other switches, the /TSK= switch can be used on its own. All you need is HM Program

+ Project File + /TSK. For clarity, it is really better to call this switch on its own on a

single command line.

The switch can be used in INI files in the same way as other switches. Just use the syntax:

TSK=taskname:actionname

As always with INI files, don't use any quotes around the components of the line.

Create task command lines with the Task Manager:

You can generate command lines for single and multiple actions from the Task Manager. Just

select the actions in a task, the select the Generate Publish Batch File option to create a batch

file. You can the copy the command line from that file to use it in your own manually-created

batch files.

Although it is possible to mix the /TSK= switch with other switches it is easier to manage

if you call publishing tasks on individual lines of their own. Unlike other switches, all you

need for this switch is the HELPMAN.EXE filename, the project filename and the /TSK=

switch with the task and action names.

Publishing all the actions in a task:

To publish all the actions in a task just include the task name on its own, like this:

HELPMAN.EXE D:\Projects\widgets.hmxp /TSK="Daily Build"

Publishing single actions in a task:

To publish a single actions in a task add the name of the action after the name of the task,

separated by a colon (:) character:

HELPMAN.EXE D:\Projects\widgets.hmxp /TSK="Daily Build:Full CHM
Output"

Publishing multiple selected actions in a task:

To publish a multiple (but not all) actions in a task use the /TSK= switch multiple times,

once for each action. Alternatively, you can also write separate command lines for each ac-

tion if you like. The result will be the same. 

HELPMAN.EXE D:\Projects\widgets.hmxp /TSK="Daily Build:Full CHM
Output" /TSK="Daily Build:Full HTML Output"
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How to create an .INI file

Use a text editor to create a plain text file with the extension .ini (for example

batchoutput.ini) in the project directory of the project you want to publish.

· The INI file contains all the switches and parameters that come after the project file

name, with one switch or parameter per line. They must be entered in exactly the same

order as you would enter them on the command line. That means the output format

switch always comes first, followed by all the other switches.

· The rules for multiple output The rules for multiple output  are also the same as on

the command line. First the first output format switch followed by its switches, then the

next output format switch followed by its switches, and so on.

· The switches you can use in the INI file are exactly the same as the command line

switches. However, they must all be entered on a single line and they are not preceded

by a slash. 

· Unlike command lines, you must not use quotes in INI files, even if your arguments con-

tain spaces! This is very important!

· You can enter comments if you want. Comments must be entered on a single line and

preceded by a semicolon character (;). 

Example:

CHM=F:\Project Files\Help Project\Help\WidgetHelp.chm
I=CHM,FINALBUILD
KEEPTEMP
; This line is a comment
PDF=F:\Project Files\Help Project\PDF\WidgetHelp.pdf
I=PDF,FINALBUILD
Template=usletter.mnl
TSK=Special
L=F:\Project Files\Help Project\Logs\publishlog.txt

What this example INI file does:

Note that the INI file only includes all the options that would normally come after the

Help+Manual program file name and the project file name in the command line. The pro-

gram file and project file must still be included in the command line, or in a batch file. 

· The first line publishes to HTML Help with a specific output directory and file name.

Specifying the output explicitly allows you to publish to other destinations manually in

Help+Manual without worrying about changing the destination of the .INI The first line

publishes to HTML Help with a specific output directory and file name. Specifying the

output explicitly allows you to publish to other destinations manually in Help+Manual
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without worrying about changing the destination of the .INI file output. (Every time

you publish manually you automatically reset the default output destination.)

· The I=CHM,FINALBUILD include options switch includes everything tagged with the

user-defined option FINALBUILD.  Since you have specified a user-defined option you

must also specify CHM to ensure that any items specifically tagged for HTML Help are

also included. KEEPTEMP tells Help+Manual not to delete the temporary source files

used to generate the HTML Help output.

· Then the same project is output to PDF, also with a specific output directory and file-

name. The include options are the same, but with PDF instead of CHM to include the

appropriate topics in addition to everything tagged with FINALBUILD. 

· The Template=usletter.mnl line specifies the PDF print manual template  to be used

for the output. Since no path is specified this is assumed to be in the project directory. If

it is stored in any other location you must include a path.

· The TSK=Special line additionally executes a publishing task defined in the Publishing

Task Manager . This can include a large number of publishing operations and is ef-

fectively like calling an additional batch file with all that it contains.

· Finally, the L= parameter stores all the messages associated with the publish operation

in a log file in a specified location. If no path had been included this file would have

been stored in the project directory.
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Local and Global Switches for Multiple Format Output

Local switches:

The following switches are "local". In .INI files They must be applied to each

output format individually by inserting them after the format switch for which

they should apply and before the next format switch.

I=<include options> The include options you want to use for

the output format.

TEMPLATE=<PDF template> The PDF template to be used for PDF

output (only for PDF output).

V=<filename> This switch specifies an external file to

redefine the values of variables in your
project file. This can only be used once
per output format.

O=<filename> This switch specifies a .hmskin skin file

to be applied to the output. This can be
used multiple times per output format. 
If you specify more than one skin the
definitions and elements in the last skin
referenced will be used for any elements
defined in all skins.

S=complete This switch specifies that only topics

with the status "complete" are to be
included in the output.

Global switches:

These switches can only be used once per .INI file and they apply from the

point in the .INI file at which they are inserted:

KEEPTEMP Doesn't delete the temporary

directories and source files
generated for HTML Help, Apple
iBooks®/ePUB and Visual Studio
Help output. 

L=<log file> Outputs the publication log to the

specified file. 

DEBUG Displays debug information for each

output format before publishing.

NOCLOSE No longer required or supported.

This switch is deprecated because

command line execution now runs in

console mode only and

Help+Manual is not opened at all.

If you have multiple output formats in a single .INI file you must insert these

switches directly after the first output format to apply them to all output

formats. To apply them only to only some output formats insert the switches

after the first output format for which you wish them to apply.

Examples:

1)
CHM=project.chm
KEEPTEMP
EPUB=project.epub

2)
CHM=project.chm
EPUB=project.epub
KEEPTEMP

Example 1) above keeps the temporary files for both the CHM and EPUB out-

put. Example 2) only keeps the temporary files for the EPUB output. The same

applies for log files and debug information. 

See Syntax reference  for more information on the individual switches and

parameters.

817
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How to use the INI file from the command line

To use an INI file just specify it as the first and only parameter after the project file name

in the command line. If it is stored in the project directory you don't need to specify a

path for it. If it is stored anywhere else you must specify a path.

As usual, the example assumes that you are working from the Help+Manual program dir-

ectory.

Example:

HELPMAN.EXE "D:\Help Project\Widget\WidgetHelp.hmxp" batchout-
put.ini

This starts Help+Manual, opens WidgetHelp.hmxp and then executes all the commands

specified by the switches and parameters contained in batchoutput.ini.

How to use the INI file from a batch file

You can take this one step further and automate the process completely by putting the

command line (or lines!) with the reference to the .INI file in a batch file. Then you can

create a shortcut to the batch file and perform the entire complex output process by

double-clicking on the shortcut. Here's how:

· Create a plain text file with the extension .bat or .cmd (for example batchout-

put.bat) and store it in the Help+Manual program directory. Then you only need to

enter the path to the project file, since all other parameters automatically use the path

of the project directory.

· Enter each command line you want to execute on a separate line in the file, as shown in

the example below.

· Finally, create a shortcut to the batch file. The most convenient location for this is nor-

mally on your desktop, but it can be anywhere you like. Then double-clicking on the

shortcut will execute the batch file, which will use the settings in the specified INI file (or

files) to perform all the operations you have specified.

Batch file example:

@ECHO OFF
HELPMAN.EXE "D:\Help Project\Widget\WidgetHelp.hmxp" batchoutput.ini
HELPMAN.EXE "D:\Help Project\Widget Two\WidgetTwoHelp.hmxz" batchtwo.ini

The @ECHO OFF command suppresses the output to the command console. It is not really

required, it is just customary to use it.
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You will normally only want to use one command line with an .INI file per batch file, but

there is nothing to prevent you from including as many as you like. They will all be pro-

cessed one after another when you call the batch file.

Remember to store each .INI file in its own project directory – i.e. in the directory in

which its associated .hmxz or .hmxp project file is stored.

See also:
Output to multiple formats

6.6.8 Temp files location

In a number of output formats temporary files are generated as source for the final output

format (CHM, ePUB, Kindle, eWriter, Visual Studio Help). By default, these files are written to a

folder inside the project folder, but you can change this location if you like. Doing this can

speed up the publishing process, particularly if your project is accessed on a network drive by

the instance of Help+Manual performing the publishing operation. Publishing will be much

faster if the temporary files are created on a fast SSD drive on the same computer where

Help+Manual is running.

The temporary files folder is a global program setting that will also be used in command line

operations once it has been set in the Program Options.

See Optimize Publish Speed  for more details on folder locations and publishing speed. The

referred topic is for CHM output but the same principles apply for all output formats where

temporary files are generated. 

How to change the temp files folder location

You can find the setting in the Compilers section of the main program options, in View >

Program Options > Compilers. The setting applies to all output formats that use tempor-

ary files before (CHM, ePUB, Kindle, eWriter, Visual Studio help). The temporary files are

written in sub-folders with names based on the project name and the output format. 

830
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6.6.9 Publishing from your application

If you follow the rules and syntax of the Help+Manual XML Language you can generate

Help+Manual projects directly from your application and publish them to any supported out-

put format without ever opening Help+Manual. 

This can be useful for producing things like automated program code documentation for

which you do not need to edit the project in Help+Manual. Of course, you can also edit the

projects you generate from your application manually with Help+Manual later if you want.

Note that Help+Manual Professional is required for this because the Basic version create un-

compressed XML project files and its publishing capabilities for some of the features suppor-

ted are also limited. 
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Generating projects programmatically

To write topics and projects directly, either from your application or manually, you need to

follow the rules and syntax of the Help+Manual XML Language, which are documented in

detail in the file Helpman_XML_ref.chm. This file can be found in the Help+Manual

program directory. 

The best way to get started is to work through this tutorial on the Help+Manual User

forum:

 Creating Content from Scratch with XML

You need to be a forum member to access this section. Registration is free and without

any obligations, just click on Register in the forum header and follow the instructions dis-

played. 

Auto-publishing after you generate

After generating your project from your application you can then publish it automatically

with batch commands, following the instructions in the other topics in this chapter. You

don't need to open Help+Manual to do this –  provided you don't want to edit the con-

tent before publishing the entire process can be fully automated.

Note that this is only possible if you create an entire XML project, including a full, valid

.hmxp project file. You cannot publish individual XML topic files programmatically with

this method. 

http://helpman.it-authoring.com/viewtopic.php?t=5145
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Unleash the power of Help+Manual! This chapter really goes into details and explains
the nuts and bolts that every documentation professional should know about.

Picture courtesy of pixabay or picjumbo

http://pixabay.com/
http://picjumbo.com/
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7 More Advanced Procedures

7.1 Using Version Control Systems

Key Information
Active support for VCS is only available in the Profes-

sional and Floating license versions of Help+Manual

and is only possible with projects saved in uncom-

pressed XML/HMXP. Single-file HMXZ projects are

binary and cannot be linked to VCS repositories.

Version control systems enable multiple authors to collaborate on the same project from any

location. They do this by linking a local copy of the project on your computer with a central

master copy that everyone synchronizes with. This copy can be local or online. In addition to

collaboration, version control provides a full backup of every change in your project, allowing

you to revert to or recover earlier versions if necessary.

If you save your projects in uncompressed XML  (recommended anyway and also required

for multi-user editing) you can integrate them directly in your Git, Subversion, or other version

control repository.

Advantages

· Offline editing – you don't need a network connection to work on your project

· Collaboration on projects from any location

· Ongoing backups and revert to earlier versions

Collaborating on projects without version control

If all your users are on the same local network you can collaborate on the same project

directly, without version control.  See Multi-User Editing  for details.

7.1.1 Introduction

Before using Help+Manual with a version control system (VCS) it's important to understand

how your project is linked to the VCS database and how the two interact. The following intro-

duction will make it easier to use the VCS support functions because it will enable you to un-

derstand what is actually happening when you use them.

126

1171
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Local working copy – central master copy

When you use version control there are two copies of your project: A local copy on your

own computer, which is the project you are actually working on, and the master copy that

you and all your colleagues synchronize with. The master copy is referred to as the repos-

itory. Your local copy is linked to the master copy and your changes are synchronized with

the master copy so that other users also have access to them. 

Your local copy is completely local. You don't need a network connection to work on it.

But you do need a network connection to synchronize with the master copy.

Synchronize before and after work

Once your local working copy is set up and linked to the master copy, you synchronize

with the master copy before and after each working session:

1. Open the project and synchronize with the Version Control tool in the Project tab. This

updates your working copy with all the latest changes added by your colleagues. 

2. Make your changes to the project.

3. When you are finished, synchronize again to add your changes to the master copy.

Avoid conflicts: Coordinate with your colleagues

If two authors work on the same text at the same time, you may get a conflict that you

need to resolve with the tools provided by the version control system. You will generally

be presented with a side-by-side view where you must choose which version of each

change you want to keep, "yours" or "theirs". 

These conflicts can be eliminated or kept to a minimum if you coordinate with your col-

leagues. Just let each other know in advance which texts each of you is going to be work-

ing on. 

Warning: Extreme caution with deleting topics and changing topic

IDs

Always coordinate with your colleagues before deleting topics or changing topic IDs

when working under version control!

The most critical thing you can do when collaborating via version control is to delete a

topic, or change a topic ID. (For the version control system, changing a topic ID is also a

deletion, combined with the creation of a new topic.) The worst scenario is if one user de-

letes a topic and synchronizes, and another user then edits that topic and tries to syn-
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chronize. That creates a deep conflict that the system administrator would have to resolve

directly with the version control system tools.

See also:
Multi-User Editing

7.1.2 Syncing Your Project

Once you have configured version control and set up your local working copy, using version

control couldn't be simpler. You just work on the local working copy of your project and se-

lect the Version Control tool when you want to synchronize with the central repository on the

server. You only need a network connection for synchronization. All your work on the project

can be carried out offline.

See the separate instructions for SVN and Git to learn how to get everything up and running.

Synchronize both before and after working!

You should always synchronize before you start working, to make sure that you have all

the latest changes added to the repository by your colleagues.

Then synchronize again at the end of your working session to add your changes to the

central repository. 

Synchronize often, coordinate with your colleagues

It is best to synchronize after every working session, even if your work is not 100% com-

plete. Frequent synchronization makes conflicts with your colleagues' work less likely.

Also, it is advisable to coordinate with your colleagues on who is working on what part of

the project. This is particularly important if you are going to make major structural

changes, like deleting or moving topics and chapters and creating new topics. Good com-

munication can eliminate time-wasting conflicts. 

1171
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7.1.3 Supported Version Control Systems

Supported systems

Git and Subversion

Help+Manual's version control interface comes with pre-configured scripts for synchroniz-

ing with both Git and Subversion. In addition to this, there is also an option for syncing

with any other version control system that supports scripted access. 

Integrated Team Foundation Server and Visual Source Safe support

has been removed

As of Help+Manual 9, we have removed the integrated support for the sunsetted Team

Foundation Server. Even Microsoft is now switching to Git for their own version control

needs, and this is reflected in their purchase of the GitHub platform. If you absolutely

must continue using TFS, you will need to use the Custom Version Control  option and

set up scripted synchronization with your TFS repository. 

Support for Visual Source Safe has also been removed. This legacy system is now com-

pletely obsolete and should no longer be used.

Custom version control interface

Help+Manual's interface to version control is fully scripted and open, which means you

can configure it yourself to synchronize with any VCS that supports scripted access. You

can also reconfigure the scripts for Git and Subversion yourself, for example to include

user names and passwords in the parameters passed to the system.

About Git

Originally called "git" (all lower case), Git was developed by Linus Torvalds, the creator of

Linux, and is now the premier version control system worldwide. It is extremely reliable

and amazingly fast. It is a peer-to-peer system that does not require server software. Every

user has the entire repository, and thus every user could be the central repository that

everyone else synchronizes with. 

In practice, you will put a central copy of the repository on a server. Then all your users

will synchronize with that. You can host it yourself, or use excellent free services like

GitHub and Bitbucket. 

889
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About Subversion

The older Subversion is still an excellent system, but it has some disadvantages compared

to Git. The main one is that it is a centralized system requiring installation of both client

software on the user's computer and a full server installation with the repository on the

central server. Users don't have a copy of the repository, just references to it. This means

that the central repository is a potential single point of failure, unlike Git where every user

has a full copy of the entire repository.

Because of this, there are fewer public hosting options for Subversion than for Git, and

they tend to be more expensive. Quite a few web hosting providers support Subversion,

but in many cases you will have to manage and configure the server installation yourself.

7.1.4 Configuration in Help+Manual

Before using version control, you also need to activate it for the system you are using in

Help+Manual. 

Activating and configuring version control in Help+Manual 

Select Program Options in the View tab and then the Version Control tab. Then activate

support for the system you are using and make sure that the link to the main VCS pro-

gram is correct. (See Scripts and Customization  for details on the Custom VCS option.)889



853

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

More Advanced Procedures

Subversion:

(1) Link to the Tortoise svn.exe program in the \bin\ sub-folder of the Tortoise SVN

program folder.

(2) Add the path to your merge tool for SVN here. See Configuring a Merge Tool  for

details.

Git:

(1) Link to the git.exe program in the \bin\ sub-folder of the Git program folder.

Scripts: 

Use the standard scripts without any changes to get started.

The "Custom Version Control" option

This option enables you to add another version control system not natively supported in

Help+Manual. You will need to understand the scripting interface to this system and con-

figure the script template  for it with the necessary commands before you start to use it.

7.1.5 Using Git

Git is now the leading version control system worldwide. It was developed by Linus Torvalds,

who also created Linux. It is extremely reliable, fast, and secure, and much more flexible than

previous systems. Microsoft has now switched to Git for version control for their own software

development, moving away from their own Team Foundation Server (TFS) system. 

Choose Git if you don't yet have version control

If you are not yet using a version control system, we strongly recommend using Git be-

cause it offers the best handling of Help+Manual projects. Microsoft's TFS is now sunset-

ted and it has always been difficult to manage. SVN is still excellent, but more and more

users are switching to Git and its days are numbered. The number of available SVN distri-

butions is dwindling fast, and organizations like Collabnet that used to provide SVN distri-

butions and services have exited the market.

Simple Git management

Despite its great popularity, Git also has a reputation for being complicated and nerdy,

and only accessible to Unix developers who spend 48 hours a day at their keyboards. It

can be like that, because it has a literally huge range of capabilities and functions.

884
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However, there are now excellent tools for managing projects under Git, which we will in-

troduce to you here, and the functions you need for managing and synchronizing

Help+Manual projects are simple and straightforward. 

All possibilities available for experts

At the same time as offering simple Git management, Help+Manual makes it possible for

Git experts to configure the Git integration in any way they want. The scripts for interact-

ing with Git are open and fully editable. See Scripts and Customization  for details.

7.1.5.1 Git Components

Unlike SVN, Git is a so-called "peer-to-peer" system. There is no server. Instead, every single

Git user has a full copy of the entire repository. Theoretically, any Git user could also be your

central repository. However, that is generally impractical and can be complicated. Instead,

most people will find it easiest to use an online hosting service like the excellent free GitHub.

Install Git on your computer

Every user needs to install Git

You need to get the official Git for Windows from the  central Git site. There are a num-

ber of choices you need to make while installing. See  this guide on phoenixNAP for

good recommendations.

Important settings while installing

For working with Help+Manual, there are some important settings you should make while

installing Git:

· Set "main" as your default initial branch

By default, Git will want to set "master" as the initial branch. However, most people now

use "main", and this is also how Help+Manual is set up. So select the option to override

the default branch name and change it to "main".

· Git from the command line and also from 3rd-party software

This option is essential for integration with Help+Manual and must be selected.

· Checkout Windows-style line endings

This should be selected for work with Git in Windows and Help+Manual.

All the other settings can be left as their defaults.

889

https://git-scm.com/downloads
https://phoenixnap.com/kb/how-to-install-git-windows
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After installing: set your user name in Git

You need to set a user name that will be associated with you when you synchronize your

projects with the Git repository. Follow the instructions on this GitHub page:

 How to set your Git user name

Tip: If you are going to be using a service like GitHub, this name can be the same as your

GitHub user name, but does not have to be.

After installing: Set your Git email address if you won't be using

GitHub

If you're going to be using GitHub, your email address will be set there. Otherwise, follow

these instructions for setting the address for Git:

 How to set your Git email address

Important: If you do set your email address here, it must match your GitHub email ad-

dress.

Get a Git GUI (graphical user interface)

You also need to install a "GUI", or graphical user interface, for managing your projects in

Git outside of Help+Manual. Administrators will need this for turning Help+Manual pro-

jects into repositories and uploading them to the central repository. Regular users will

need the GUI for downloading their working copies with the URL provided by the adminis-

trator.

Recommendation: GitHub Desktop

Even if you are not using GitHub for hosting your projects, we recommend using the free

 GitHub Desktop program as your management tool, unless you already have another

solution. It works fine with other repositories, and even with your own repositories hosted

on your own server and accessed via SSH or https. 

If you don't already have a Git solution, we also recommend using the free GitHub for

hosting your repositories. See GitHub & GitHub Desktop  for instructions.

DON'T use the "Git GUI" included with the Git software

The very basic "Git GUI" included with the Git installation is problematic for regular users

and should not be used unless you are already familiar with it. Among other things, it will

856

https://docs.github.com/en/github/getting-started-with-github/setting-your-username-in-git
https://docs.github.com/en/articles/setting-your-commit-email-address
https://desktop.github.com/
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not create functional working copies from the central repository without additional

manual configuration of the working copy after creating it.

List of available Git GUIs

See  this page for a list of available Git GUI programs with descriptions.

7.1.5.2 GitHub & GitHub Desktop

Since Git is peer-to-peer, you can actually host your central repository anywhere that all your

users can access it. However, if you don't already have a Git solution, we strongly recommend

using the free GitHub, which is now owned and managed by Microsoft. It is reliable and easy

to use, and provides the excellent GitHub Desktop program for creating your local working

copies and external management. 

GitHub benefits

GitHub is managed by Microsoft, which now also uses Git for its own code management.

However, it was originally an open source development and even before being taken over

by Microsoft it was firmly established as the leading site for hosting projects managed un-

der Git, both privately and publicly. 

GitHub is the result of the same development philosophy as Git itself, and it is just as reli-

able as the entire Git system. It is completely free for most needs, and highly accessible in-

ternationally, with excellent transfer speeds. It can be used both publicly and privately, and

it is very easy to give users access to the projects hosted there when needed.

GitHub Desktop: An excellent Git GUI, not just for GitHub

The free  GitHub Desktop program is an excellent, multi-purpose Git GUI that can be

used for managing Git repositories hosted anywhere, not just on GitHub. If you don't

already have another solution we recommend it. 

In this documentation, all Git GUI operations are described for GitHub Desktop. However,

the basic principles are the same for all Git GUIs, so if you are using a different system the

instructions should be easily transferable. 

All users: Set up a GitHub account and install GitHub Desktop

Set up GIT first

If you have not already done so, download and install Git on your computer. See Git Com-

ponents  for instructions.854

https://git-scm.com/downloads/guis
https://desktop.github.com/
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Set up a GitHub account

Setting up a GitHub account couldn't be easier. Just visit https://github.com/ and click the

Sign Up button. 

· Choose your user name carefully, because that will also be used in the addresses of

your projects on GitHub. 

· The list of interests is only to direct you to various paid plans, so it doesn't really matter

what you select there at first.

· Choose the free plan to get started. You can consider other plans later.

When you're done you'll be taken to your new home page on GitHub:

Download and install the GitHub Desktop Git GUI

You are going to need GitHub Desktop for most of the operations described here, so

download and install that now:

https://desktop.github.com/

https://github.com/
https://desktop.github.com/
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Sign in to your account with GitHub Desktop

After installing, you need to sign in to your GitHub account with GitHub desktop. You will

then be asked to continue to your browser, where you will authorize GitHub Desktop to

access your account. 

Administrators: Create a HM project repository and upload it to
GitHub

To work with Help+Manual in GitHub, you first need to turn the project your team wants

to collaborate on into a Git repository and upload it to GitHub.

Warning: Don't use the New Repository... option

If you use the New Repository... option for this in GitHub Desktop, it will create an empty

repository folder inside your Help+Manual project folder, which is not what you want.

Initialize a HM project as a Git repository

1. Open GitHub Desktop and select Add Local Repository in the File menu. This dialog

opens: 

2. Click Choose... and select the Help+Manual project folder you want to initialize as a

repository. GitHub Desktop will tell you it's not a repository:
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3. Click on the link in the text shown above to get this dialog:

4. The path cannot be changed now. Just enter a name and description and click on

Create to initialize the project as a Git repository.
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GitHub Desktop will apply the settings and create the .git sub-folder containing all the

repository data. Never touch or edit anything in this folder.

Upload the repository to GitHub

Once you have created the repository, this screen will be displayed in GitHub Desktop:

Procedure

1. Check that the branch shown at the top is "main", which is required for Help+Manual.

If it isn't, this means you missed an important step in your Git installation. To change

this, open an administrator command console and enter the following command to

correct this: 

git config --global init.defaultBranch main

2. Enter a summary and description at the lower left. 

3. Click on Publish Repository to upload to GitHub.

Adminstrators: Invite users to collaborate on the repository

To be able to access the repository, your users need to have their own GitHub accounts

and you need to add them as collaborators by sending them an invitation. You will need

the GitHub user names of the users you want to invite.
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1. Log into your GitHub account in your web browser and select the project repository

from the list on the left. Then click on the Settings link in the bar above the project de-

tails: 

2. Then select Collaborators on the left and the green Add People button on the right:

3. Enter the user name in the dialog displayed and confirm the invitation. The user will

then have 7 days to confirm.

Users: Download a local working copy with GitHub Desktop

Once you have confirmed your administrator's invitation to collaborate on the project via

the repository you can download your local working copy with GitHub desktop. The repos-

itory you have been invited to will show up in the GitHub Desktop window:
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Click on the Clone button at the bottom right and choose a location for your local copy. It

must be in a directory where you have full read and write permissions. 

Then just click on Clone to create the working copy. You can then work in the project in

Help+Manual. 
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7.1.5.3 Other Hosting Options

There are many other Git hosting solutions available, but none of them are as user-friendly as

GitHub, mainly because most of them are focused on programmers. In addition to this, you

can also easily host your Git repositories on your own Internet server, because no server-side

software is required. Even so, this does require a fair amount of command line configuration. 

This topic provides details on setting up your own Git server for administrators who want to

do this. It also includes details on BitBucket as an alternative to GitHub as an example of what

less user-friendly hosting solutions can be like. 

Important: Always create "main" as your default repository branch

No matter what method you use for setting up and managing your Git repositories, it is

important that you always configure them to use "main" as their default branch. All the

Help+Manual Git scripts use this branch and they will fail if you use the older "master"

branch instead.

Admins: Git hosting with BitBucket

BitBucket is also an excellent and reliable free Git hosting service. Unfortunately, it is also

less user-friendly than GitHub for non-programmers. The most critical problem for

Help+Manual users is that you can't use GitHub Desktop for uploading your local projects

to BitBucket, and the SourceTree Git GUI that is linked to BitBucket is not something that

we can recommend for technical writers who are not software developers

However, if you are an administrator and need to use BitBucket for some reason, here is a

brief summary of what you need to know for using it to host Help+Manual projects.

Important: Git user name and email address

Your Git user name and email address  must match your BitBucket credentials.

Getting your local Help+Manual repository onto BitBucket

The only reliable way to do this is manually via the command line. There are instructions for

"migrating repositories to BitBucket" with the SourceTree tool, but they are for the Mac ver-

sion only and assume the repository is already linked to a remote host like GitHub. 

1. First, create an application password for your BitBucket repository, following the instruc-

tions here. You MUST copy and store the generated password when it is shown to you. It

will never be accessible again. 

https://support.atlassian.com/bitbucket-cloud/docs/create-an-app-password/
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2. Initialize your local Help+Manual project as a Git repository. You can do this with GitHub

Desktop, as described in GitHub & GitHub Desktop , or via the command line in the pro-

ject folder:

git init -b main
git add -A
git commit -m "First Commit"

3. Then create an empty repository on BitBucket and get its URL. You can then link and up-

load the local Help+Manual repository to the BitBucket repository with the following com-

mands. The first time you do this you will be asked for your BitBucket app password:

git remote add source https://username@bitbucket.org/username/reponame.git
git push -u -f https://username@bitbucket.org/username/reponame.git main

Then you're done.

Getting users to download their local working copies

This can be done with GitHub Desktop, but the users will also need a BitBucket account and

the BitBucket application password (see above). 

1. First,  give the user access to the repository on BitBucket. 

2. Get the URL of the repository on BitBucket and provide it to the user. 

3. User: Open GitHub Desktop and select Clone Repository in the File menu.

4. Select the URL tab, then paste the BitBucket URL in the central field and choose the local

path to an empty folder in the lower field.
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5. Click Clone to create the working copy. You will have to enter your BitBucket user name

and the application password.

Once this is done, the user can work on the project normally in Help+Manual . It can also

be administered with GitHub Desktop, of course. 

Admins: Git hosting on your own server

Git requires no server-side software. All you need to do to have a central repository on

your server is initialize a Help+Manual project as a Git repository, save it on your server

and provide secure access for your users. If you are familiar with operations like this, this is

really the easiest way to get Git set up for your users.

Absolute prerequisite: Key pair SSH access or other transparent ac-

cess

Help+Manual cannot stop for password entry during synchronization and it would also be

infuriating for users. This means that if you are going to host on your own server, the ac-

cess must be via SSH and you must install public/private SSH key pairs for each user, or

another transparent access mechanism. Whatever method you use, users must be able to

access the repository folders without stopping for login entry, and SSH key pairs are gen-

erally the best and safest method. This is required so that Help+Manual can synchronize

to the server folder transparently and silently. 

This is not something we can describe here. See this Microsoft article if you need informa-

tion to get started.

Step 1: Create a directory for your git repositories on your server

Log into your server with SSH (or edit directly on the server) and create a folder in the loc-

ation where you want to store all your Git repositories. This should also be a location

where you are giving your users access with SSH key pairs.

Let's assume that the directory is going to be called git and that it's going to be on the

root level. You will need to modify the paths in the examples below if yours is different, of

course.

The path to the folder will then be:

~/git

871
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if the folder is in the root of the home directory of the account you are logging into (as-

sumed in the examples below) or just

/git

if it is in the actual root of the server.

Step 2: Create a "bare" repository from the Help+Manual project

and install it on the server

The server copy does not actually need the Help+Manual project files. It only needs the

.git folder from the project folder containing the repository. Then you can store multiple

repositories in the same folder on your server. (Remember, every Git user has the entire

repository). This is referred to as a "bare" repository.

First you need to initialize the Help+Manual project as a Git repository. Enter the following

commands in the Help+Manual project folder in PowerShell or a Command Console:

git init -b main
git add -A
git commit -m "First Commit"

Next you need to create the bare repository with a name in another folder. Let's assume

it's going to be called temp, on the same level as the project folder, and that the project

repository is going to be called widget_help. You do this with the following command:

git clone --bare .git '../temp/widget_help.git'

This copies the .git folder from your Help+Manual project folder to the temp folder as a

bare repository called widget_help.git. 

The bare repository must have a name – i.e not just .git – as well as being bare, so that

you can put multiple repositories in the same folder on your server.

Next you need to copy the bare repository to your Git repository folder on your server

with SCP. Windows 10 and above now come with SCP built in, so you should be able to do

this from the command console. If it doesn't work there, use PowerShell. 

Switch to the folder containing the bare copy you made in the last step and enter this

command, replacing the file and folder names and your SSH user name and domain with

your own values:

scp -r widget_help.git sshuser@domain:~/git

Explanation:

· sshuser is your SSH user name

· domain is your server's domain
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· ~/git is the path to the repository folder on the server from the login location

Finally, log in to the server with SSH and enter the following commands to switch to the

repository folder and initialize the repository on the server for shared access. You will

need to adjust the path to the one of your own repository folder on the server, of course.

cd ./git/widget_help.git
git init --bare --shared

Your server repository is now ready.

Step 2: Enable users to download their local working copies

Once you have given your users SSH access to the repository folder with key pairs they

are already authorized for the repository, so you don't need the additional invite step that

is necessary for GitHub or BitBucket. You just need to give the user the SSH user name

URL they need to clone the repository themselves or do it in GitHub Desktop if they are

afraid of the command line.

SSH user name URL for the users

You give each user their SSH user name URL for the repository, which will be:

sshuser@domain:~/git/widget_help.git .

· sshuser is the user's SSH user name

· domain is your server's domain

· ~/git is the path to the repository folder on the server from the user's login location

· The dot ( . )  at the end is important. It prevents an additional sub-folder from being

created in the user's folder

Method 1: Command Line

User: Open a command console, switch to the empty folder where you want to install your

local working copy of the project and enter the command (remember to include the dot at

the end):

git clone sshuser@domain:~/git/widget_help.git .

Replace sshuser@domain:~/git/widget_help.git with the user name URL

provided by your administrator for the repository.

Method 2: GitHub Desktop
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1. Open GitHub Desktop and select Clone Repository in the File menu. 

2. Select the URL tab, enter your SSH user name URL in the central field and choose your

empty folder for your local working copy with the Choose button.

3. Then just click on Clone to clone your local working copy.

Once this is done, you can work on the project normally in Help+Manual .

7.1.5.4 Configuring a Merge Tool

Occasionally, you and a colleague will both make changes to the same text in the same topic

at the same time. This will only happen if you really both edit the same sentence in different

ways. Changes in different locations in the same project or even the same topic will be

merged silently by Git, but may still create contradictions in the meaning of your text, so you

really always need to coordinate with colleagues before working on the same topics.

You need a "merge tool" to handle conflicts

When conflicts occur, you need to be able to see your version of the text and the conflict-

ing version and choose which one you want to save to the repository. This is done in a

"merge tool", which shows you the versions side by side.

871
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Use WinMerge or Beyond Compare

There are two solutions we can recommend for this: The free WinMerge tool or the paid

Beyond Compare tool in the Pro version. Both are excellent, and it is really up to you

which one you use. 

Configuring WinMerge as a merge tool

The free WinMerge tool is a well-maintained and outstanding solution for comparing and

merging the contents of files and folders. It is fully aware of both SVN and Git and can be

used as a merge tool for both systems.

Step 1: Download and install WinMerge

Download WinMerge and install it. 

Step 2: Configure Git for WinMerge

Although WinMerge understands Git conflict files, it does not come with an integrated

configuration for optimal performance. You need to add some lines to the Git configura-

tion file for optimum performance, and to tell Git that you want to use WinMerge.

In a text editor like Notepad or Notepad++, open the file .gitconfig ,which you can

find in the following location:

C:\Users\<username>\.gitconfig

If there are any [mergetool.., [merge.., [difftool.. or [diff.. entries similar to those shown be-

low, you need to delete them. However, check with your administrator first before doing

this. Otherwise just copy and paste the following lines to the end of the .gitconfig file

and save it. 

[mergetool]
    prompt = false
    keepBackup = true
    keepTemporaries = false
[merge]
    tool = winmerge
[mergetool "winmerge"]
    name = OneMerge
    trustExitCode = true
    cmd = "'C:/Program Files/WinMerge/WinMergeU.exe'" -u -e -fm -wl -dl
\"Local\" -wr -dr \"Remote\" \"./$LOCAL\" \"./$BASE\" \"./$REMOTE\" -o
\"./$MERGED\"
[diff]
    tool = winmerge
[difftool "winmerge"]

https://winmerge.org
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    name = WinMerge
    trustExitCode = true
    cmd = "'C:/Program Files/WinMerge/WinMergeU.exe'" -u -e \"./$LOCAL\"
\"./$REMOTE\"

Configuring Beyond Compare Pro as a merge tool

Beyond Compare is the leading paid diffing and merging program for Windows. Like

WinMerge, it is also fully aware of both SVN and Git and can be used as a merge tool for

both systems.

Important: Pro version required 

You must have the Pro version of Beyond Compare for this, as other versions do not sup-

port the required 3-way compare for conflict resolution. 

Warning: Only recommended if you are familiar with version control

or Beyond Compare

Beyond Compare is a great tool, but its 3-pane merge tool interface may be less easy to

understand for normal users. We only recommend using it if you are already use Beyond

Compare regularly and/or are intimately familiar with diffing and merging in version con-

trol systems. Otherwise, please use the free WinMerge, which is generally easier to man-

age.

Configuring Beyond Compare Pro as your Git merge tool

In a text editor like Notepad or Notepad++, open the file .gitconfig ,which you can

find in the following location:

C:\Users\<username>\.gitconfig

If there are any [mergetool.., [merge.., [difftool.. or [diff.. entries similar to those shown be-

low, you need to delete them. However, check with your administrator first before doing

this. Otherwise just copy and paste the following lines to the end of the .gitconfig file

and save it. 

[mergetool]
    prompt = false
    keepBackup = false
    keepTemporaries = false
[merge]

tool = bc
[mergetool "bc"]

path = c:/Program Files/Beyond Compare 4/bcomp.exe
[diff]

tool = bc
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[difftool "bc"]
path = c:/Program Files/Beyond Compare 4/bcomp.exe

Note: This will configure Beyond Compare Pro as both your merge tool and your diffing

tool.

Older Git versions:

For older versions of Git before 2.2, replace "bc" in the references above with "bc3".

7.1.5.5 Using Git in Help+Manual

Once you have configured Help+Manual  for Git and set up the Git components  and got

your local working copy, you can basically just edit normally. The only difference is that you

need to synchronize with the repository copy before and after work.

Communicate with your colleagues

The most important part of work with version control is to make sure that you and your

colleagues don't edit the same things at the same time. If you do, you will have to waste

time resolving conflicts. It is particularly important to make sure that everyone knows

when one of you deletes a topic or changes its ID. Editing a topic that another user has

already deleted or renamed can cause serious conflicts that can only be resolved centrally

by the administrator.

· Always be clear about who is going to be working on what today.

· Always inform everyone before you delete a topic, change its ID or make any other

structural changes in the project.

Synchronize before and after work

Always synchronize with the repository before you start work to get the latest changes,

and after finishing work to add your changes to the repository. Those are the only times

you need a connection to the repository. All your other work can be performed offline.

Once your project is set up for Git, Help+Manual will display the Git tool in the Project

toolbar. To synchronize your project with the SVN repository you just need to click this

tool.

852 854
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The submenu offers a number of individual options, but you won't normally need these.

Clicking on the main tool will both download new changes from the repository and up-

load your changes to the repository. So you just need to do this before starting work to

get the latest changes from your colleagues and after you finish work to add your own

changes.

Dealing with conflicts

If conflicts are found while synchronizing, the conflicted file will be opened in your merge

tool  so that you can choose which version of the conflict to keep. The merge tool

provides a 3-way comparison of the XML source of the conflicted topic, showing the ori-

ginal server version, your version and your colleague's conflicting version.

Resolving conflicts in WinMerge

When a conflict is registered, the WinMerge window will pop up automatically showing

the conflicts. 

Procedure

Tip: To make conflict editing easier in WinMerge, open the View menu and activate Wrap

Lines, and optionally also Toolbar > Big Icons. 

1. Choose which versions of the conflicts to keep. 

2. Save with the blue Save tool.

3. Press Escape to close WinMerge. If there are more conflicts it will pop up again with

the next conflict.

4. Repeat 1-3 until all conflicts are resolved.

868
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Resolving conflicts in WinMerge

In the WinMerge conflict resolution screen, your version is on the left (Local), your col-

league's version is on the right (Remote) and the earlier version on server is in the middle

column. You can copy your version or your colleague's version onto the central server

pane with the buttons in the toolbar.

Procedure:

· You need to choose which version you want to keep before you can save. You can do

this for individual conflicts or for all conflicts.

· If you want to use REMOTE (your colleague) for all conflicts, click in any of the conflicts

in the Remote column, then click the Copy All button (see above), and then the blue

Save button. 

· If you want to use LOCAL (you) for all conflicts, click in any of the conflicts in the Local

column, then click the Copy All button (see above), and then the blue Save button. 

· To resolve individual conflicts, click in the highlighted conflict in the column you want to

use (LOCAL or REMOTE)and select one of the two Copy Right/Left buttons (see

above). The buttons with the green arrows move to the next conflict after copying. 

When you have checked all conflicts and selected Save, press Escape to close WinMerge.

If there are more conflicts it will open again automatically until all conflicts have been re-

solved.
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Resolving conflicts in Beyond Compare Pro

Beyond Compare Pro  can also be used as your Git merge tool, and is actually already

prec-onfigured to do so. It is an excellent tool, its 3-pane merge interface is designed with

programmers in mind and can be confusing and difficult to understand for normal users.

If you are not already familiar with Beyond Compare Pro and/or with merging and diffing

in version control systems we recommend that you use the free WinMerge instead. 

Resolving conflicts

When a conflict is registered, the WinMerge window will pop up automatically showing

the conflicts. 

Basic Procedure

1. Choose which versions of the conflicts to keep. 

2. Click the small blue Save tool.

3. Press Escape to close Beyond Compare. If there are more conflicts it will pop up

again with the next conflict.

4. Repeat 1-3 until all conflicts are resolved.

Resolving conflicts in Beyond Compare

The BeyondCompare conflict resolution screen has three basic sections:

· The top row shows your version of the conflict file in the left column (LOCAL), your col-

league's version in the right column (REMOTE) and the original version before both ed-

its in the non-editable center column (BASE).

· The middle row shows the differences between the current selected conflict lines above

one another (first three lines) and the selected output version (bottom line).

· The bottom row shows the resolution/output file that will be merged with the reposit-

ory.

868
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How it works – don't change the output file!!!

The result that is going to be committed to the Git repository is shown in the large bot-

tom pane. DO NOT CHANGE THIS FILE!!!! For example, don't click on the Left or Right

buttons or select a different file from the drop-down list. This is very important!!! If you

make any changes to the automatic setting of the output file the synchronization process

in Help+Manual will hang and you will need to clean up the results manually. 

For each conflict shown in the file (pink highlights) you must choose whether you want to

use your version (left) or your colleague's version (right). 

Conflict resolution steps

1. Click in the highlighted conflict in either the left or the right pane. 

2. Click on Left or Right in the toolbar at the top to transfer either your version (Left) or

your colleague's version (Right) to the final version (large bottom pane). You can also

click on the little arrows to the left of each conflict instead.

3. Proceed to the next conflict and repeat.

4. When you are finished, click on the blue Save icon at the right-hand end of the output

file field to save and confirm the output file. 

5. Press ESCAPE to close Beyond Compare. If there are any more conflicts it will re-open

with the next conflict file. Repeat 1-5 until all conflicts have been processed.
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7.1.6 Using Subversion (SVN)

Subversion (SVN) used to be the preeminent open source version control system, but it is rap-

idly being replaced by Git. If you are already using SVN, by all means stay with it. It's still an

excellent and reliable system, provided you have an SVN server. 

However, you should also know that Subversion is on the way out. There are now fewer main-

tained SVN distributions and hosting solutions, because the world is switching to Git. If you

are just getting started, we strongly recommend choosing Git. It is now firmly established as

the leading system, with excellent free hosting solutions for your central repository like

GitHub and Bitbucket. 

About Subversion

Unlike Git, which is peer-to-peer, SVN uses a client-server architecture. There are always

two software components: The server software that manages the central master copy of

your project, and the client software on the user's computers, which manages the syn-

chronization with the central master copy.

Because of this, working with SVN requires a server configured to run the SVN server soft-

ware. There are a number of different weays to get this set up, depending on your facilit-

ies and requirements. See SVN Components  for details.

Changes for SVN users in Help+Manual 9

Use the latest versions of SVN and Tortoise SVN

Help+Manual 9 now integrates with SVN via the standard command line interface, via

fully editable scripts . This eliminates the need to have the runtime components

provided by client packages like Tortoise SVN and Collabnet. Because of this, you can now

always uses the latest SVN server system and install the latest version of Tortoise SVN.

You also no longer need to install the additional runtime components from Collabnet,

which has closed down its SVN operations.

You now need to get your working copy outside of Help+Manual 

It is not currently possible to create local working copies via the command line interface

from within Help+Manual. You need to do this outside of Help+Manual. See the guides in

this chapter for details.

877
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External conflict editing

Similarly, you now need to set up an external tool for editing conflicts. We recommend the

excellent free WinMerge program, which comes with full support for SVN. Here too, see

this guide for details.

Status icons are no longer displayed in the TOC

Finally, command line integration with SVN cannot support the status icons that used to

be displayed in the Table of Contents within Help+Manual. 

7.1.6.1 SVN Components

The SVN system always has two components: a server and a client. The server manages the

central master copy of your projects in a database that is referred to as the "repository". The

client software installed on each user's computer manages the local copy of the project that

the user works on, and synchronizes it with the master copy on the server. 

This synchronization is not continuous: Users would generally synchronize once before work-

ing, to get the latest changes from the central repository, and once after working, to add their

changes to the repository.

Server component: The main Subversion distribution

The Subversion server manages your central project storage repository and is normally in-

stalled on a central server computer, which can be accessed via your local network or the

Internet. It can be installed on the same computer where you do your work, but that is not

recommended. 

Your SVN server does not have to be a Windows computer. There are versions available

for Linux, Unix and Mac OS X servers as well as for Windows, and you should use those if

your central server is already on one of those platforms.  See here for a central list of

SVN server distributions, but note that support for SVN is becoming less widespread and

some of the sources listed may no longer be in service. In particular, all the Collabnet of-

ferings are no longer available and their links point to a different company with no SVN

support.

If you are running a Windows server we currently recommend the  Visual SVN distribu-

tion, which is free for commercial use for up to 15 users and provides easily configurable

and secure local and remote access via https://.

https://subversion.apache.org/packages.html
http://www.visualsvn.com/visualsvn/
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Client component: the SVN client software

This is the software that each user installs on their computer to communicate with the

SVN server. It provides the interface that Help+Manual interacts with and some clients

also include integration in Windows Explorer so that you can perform operations there

directly. The best clients are also free and open source.

Please use Tortoise SVN as your Subversion client

There are a number of SVN clients for Windows, but we strongly recommend using 

 Tortoise SVN. This will ensure maximum compatibility and minimum problems.

 See this guide for a more detailed introduction to Tortoise SVN.

7.1.6.2 Setting up SVN

This topic outlines the steps you need to perform to get started with SVN. This is just a basic

guide to show you the components you need to install and where you need to install them. It

does not replace the installation instructions for the individual components. If you do not feel

comfortable with installing components like this yourself please get help from an experienced

friend or colleague or your system administrator. Also, please take the time to study and fol-

low the instructions for the versions you are installing.

SVN hosting solutions

Although the number of SVN distributions is now very much reduced because of the fad-

ing popularity of the system, there are still a lot of paid and free hosting solutions for

SVN. In addition to this, some Internet service providers also include SVN as an either op-

tional or standard part of some of their packages. 

We can't recommend any specific services for this, but ask around and you will find

plenty. 

SVN on an inexpensive NAS unit

One of the best and easiest ways to get an SVN server in a small office is to purchase an

inexpensive NAS (Network Attached Storage) unit from a company like Synology. These

units have SVN server packages that can be installed with a few simple clicks, making

them very easy to set up and maintain. In addition to this, you get the added benefits of a

central backup solution with protection against hard drive failure, because they are de-

signed to protect your data even if individual drives fail.

https://tortoisesvn.net/downloads.html
https://www.developer.com/microsoft/tortoisesvn-beginners-guide/
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Check that the individual unit supports SVN

Some models don't support the SVN package. Check that it is supported before purchas-

ing.

Use an Uninterruptible Power Supply (UPS)!

Always use an uninterruptible power supply unit with battery backup on the unit where

the SVN server is installed. The one thing that servers and NAS units generally cannot

handle is power failures! For example, the UPS units from APC are inexpensive, very reli-

able and have plug-and-play support for leading NAS vendors like Synology.

Server installations: Installing SVN and the SVN client

This is the standard installation for authors working in teams. You install the main SVN

component on a server computer and the client software on each author's own local com-

puter. The repository (database) containing the master copy of your project is stored and

managed on the server. The local copies that the authors work on are stored on each au-

thor's own computer and synchronized with the master copy in the repository on the

server.

1. Install and configure an SVN distribution (this is the server component) on a server

computer on your network. 

2. Install an SVN client on all the computers using Help+Manual. We strongly recom-

mend using Tortoise SVN because it provides the best support for Help+Manual and

excellent integration in the Windows Explorer interface.

3. Add your project(s) to the SVN repository and have each author working on the pro-

ject create a local working copy from the master copy in the repository. See Setting up

Your HM Projects  for details.

One-person installations: Install Tortoise SVN only

If you are one author working on your own you can also get all the benefits of SVN on

your local computer. If you want, you can go the full Monty and install the full version of

SVN server on your local computer and link to that with the client. However, there is a

simpler method, because the Tortoise SVN client package actually includes full SVN func-

tionality for local use. 

7.1.6.3 Setting up your Projects

To manage a project in Subversion you need to perform the following tasks:

879
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· Set up a repository for the project on your Subversion server. This is the only task you

must perform with the server software. If you are working in a company this will gener-

ally be done for you by your system administrator.

· Add your Help+Manual project to the new server repository. This task can be per-

formed in the Tortoise SVN client.

· Check out working copies: You and each user must then "check out" (download) a

working copy of the project from the server repository to a folder on their local com-

puter. This too can be performed with the Tortoise SVN client.

Admin: Set up a repository for the project on your SVN server

Theoretically, you can have manage multiple projects in sub-folders of a single repository,

and then just provide the URLs to the specific folder for each project to your users.

However, we generally recommend creating a separate repository for each project. This is

more secure, and if anything ever happens to the repository then it only affects one pro-

ject, not all of them.

Setting up the repository on your SVN server

This is generally a task for the system administrator, who should take the time to familiar-

ize themselves with the management of their SVN server software. If you have an SVN

hosting provider, they will provide tools for doing this task. We currently recommend the

Visual SVN distribution, which is free for commercial use for up to 15 users and provides

easily configurable and secure local and remote access via https://.

Choosing your repository structure – branching considerations

If you are only going to host a single HM project in each repository and not do any

branching, you can just create an empty repository folder and load your HM project into it

directly. If you don't know what branching is, this is what you should do.

If you do plan on doing branching, then you will already know how you want to set this

up. Note that branching is not supported from within Help+Manual. You will need to set

up the branching yourself and then have your users check out and synchronize working

copies of the branch they should be working on.

Get the URL for your users — local and remote access

Once you have set up the repository you will need the URL for you and your users to be

able to access the repository and synchronize with it. This URL will generally be provided

by your SVN server software, for example Visual SVN.

http://www.visualsvn.com/visualsvn/
http://www.visualsvn.com/visualsvn/
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Admin: Add your Help+Manual project to the repository

Once your repository is set up and you have its URL, you can add the Help+Manual pro-

ject to be hosted on it using the Tortoise SVN client. Your project should be in the uncom-

pressed HMXP format . All the image files and other external files it uses should be

stored in sub-folders of the project folder. Otherwise they won't be accessible to all users.

Preparation

These instructions are for the Tortoise SVN client, which we recommend. So install the

latest version of Tortoise SVN on your computer, and on the computers of all users who

are going to be working on the project via SVN. 

Tortoise SVN works through integration in Windows Explorer, so all the following steps

are performed from within Windows Explorer.

Procedure

1. Right-click on the project folder in Windows Explorer and Select Tortoise SVN > Im-

port in the context menu. 

2. Enter the URL of your repository in the dialog displayed. The prefix may be svn:// or

https://, depending on the configuration of your SVN server.

126

https://tortoisesvn.net/
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3. Click on OK. You may be asked to enter the user name and password for the reposit-

ory. Then all the project files and folders will be uploaded to the repository. This can

take a while, depending on the speed if your connection. 

That is it. Your repository is now ready to be used.

User: Check out local working copies from the repository

Once the repository is set up, the final step is for each user to check out a local working

copy from the repository. This is automatically linked to the copy in the repository, so that

each user's work can be synchronized with the central copy. This operation is also per-

formed with the Tortoise SVN client in Windows Explorer.

Each user must install the current version of Tortoise SVN on their computers, both to be

able to check out the working copy and to synchronize it with the repository in their daily

work.
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Procedure

1. Create an empty folder for the working copy. This must be in a location where the user

has full read and write permissions. 

2. Right-click on the folder in Windows Explorer and select SVN Checkout in the context

menu:

3. This dialog is displayed:
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4. Enter the URL of the repository in (1). The prefix may be svn:// or https://, depending

on your server. Check that the correct target folder is displayed in (2). Leave the

Checkout Depth to Fully recursive (3) and make sure that HEAD revision (4) is

checked. Then click on OK.

This will download the project and a sub-folder called .svn to the working copy directory.

This folder should never be touched or opened, as it is managed entirely by SVN. 

Then you are done and can start editing and synchronizing  the local working copy in

Help+Manual.

7.1.6.4 Configuring a Merge Tool

Occasionally, you and a colleague will both make changes to the same text in the same topic

at the same time. This will only happen if you really both edit the same sentence in different

ways. Changes in different locations in the same project or even the same topic will be

merged silently by SVN, but may still create contradictions in the meaning of your text, so you

really always need to coordinate with colleagues before working on the same topics.

886
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You need a "merge tool" to handle conflicts

When conflicts occur, you need to be able to see your version of the text and the conflict-

ing version and choose which one you want to save to the repository. This is done in a

"merge tool", which shows you the versions side by side. Unfortunately, even though Tor-

toise SVN is an outstanding SVN client, its merge tool is not intuitive enough for normal

users working in a program like Help+Manual.

Use WinMerge or Beyond Compare

There are two solutions we can recommend: The free WinMerge tool or the paid Beyond

Compare tool in the Pro version. Both are excellent, and it is really up to you which one

you use. 

Configuring WinMerge as a merge tool

The free WinMerge tool is a well-maintained and outstanding solution for comparing and

merging the contents of files and folders. It is fully aware of both SVN and Git and can be

used as a merge tool for both systems.

Step 1: Download and install WinMerge

Download WinMerge and run it to install it. Select "Custom installation" and make sure

that you install all the listed components. Select these options when they are offered:

· Integrate with Tortoise SVN

· Register WinMerge as a 3-way merge tool 

If this option is shown select it and:

Select Merge at right pane

Disable Auto-merge at startup time

Note: The WinMerge setup may also offer the more practical Merge at center pane option.

However, at the time of writing this doesn't work for its SVN integration and the merging

is always set to the right pane. This documentation thus only covers the right-pane mer-

ging method. 

Step 2: Add the path to WinMerge in Help+Manual 

Open View > Program Options Version > Control and configure the path to the

WinMergeU.exe program in the Merge Tool to Resolve Conflicts field. WinMerge will then

be opened automatically to resolve conflicts encountered when synchronizing with the

SVN repository. See Using SVN in Help+Manual  for details.886

https://winmerge.org
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Beyond Compare cannot be used as a merge tool for SVN

Unfortunately, Beyond Compare cannot currently be used as a merge tool for SVN. This is

because calling BC as a 3-pane merge tool requires additional information about each in-

dividual conflict file and all the additional temporary files that cannot be accessed auto-

matically when processing all the files in a batch.

We recommend using the free WinMerge as your merge tool for SVN. See above for de-

tails.

7.1.6.5 Using SVN in Help+Manual

Once you have configured Help+Manual  for SVN and set up the SVN components  and

saved your local working copy , you can basically just edit normally. The only difference is

that you need to synchronize with the repository copy before and after work.

Communicate with your colleagues

The most important part of work with version control is to make sure that you and your

colleagues don't edit the same things at the same time. If you do, you will have to waste

time resolving conflicts. It is particularly important to make sure that everyone knows

when one of you deletes a topic or changes its ID. Editing a topic that another user has

already deleted or renamed can cause serious conflicts that can only be resolved centrally

by the administrator.

· Always be clear about who is going to be working on what today.

· Always inform everyone before you delete a topic, change its ID or make any other

structural changes in the project.

Synchronize before and after work

Always synchronize with the repository before you start work to get the latest changes,

and after finishing work to add your changes to the repository. Those are the only times

you need a connection to the repository. All your other work can be performed offline.

Once your project is set up for SVN, Help+Manual will display the SVN tool in the Project

toolbar. To synchronize your project with the SVN repository you just need to click this

tool.

852 877

879
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The submenu offers a number of individual options, but you won't normally need these.

Clicking on the main tool will both download new changes from the repository and up-

load your changes to the repository. So you just need to do this before starting work to

get the latest changes from your colleagues and after you finish work to add your own

changes.

Dealing with conflicts

If conflicts are found while synchronizing, the conflicted file will be opened in your merge

tool  so that you can choose which version of the conflict to keep. The merge tool

provides a 3-way comparison of the XML source of the conflicted topic, showing the ori-

ginal server version, your version and your colleague's conflicting version.

Resolving conflicts in WinMerge

When a conflict is registered, the WinMerge window will pop up automatically showing

the conflicts. 

Procedure

1. Choose which versions of the conflicts to keep. 

2. Save with the blue Save tool.

3. Close WinMerge. If there are more conflicts it will pop up again with the next conflict.

4. Repeat 1-3 until all conflicts are resolved.

After resolving

If you choose YOUR version for any conflict resolutions you must select the SVN tool in

the Help+Manual toolbar again to synchronize your confirmed version with the main re-

pository.

884
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Resolving conflicts in WinMerge

The WinMerge conflict resolution screen looks like this:

Procedure:

· By default, YOUR version is the accepted solution ("Mine" in the column heading). If

you just do nothing and save with the blue Save tool, YOUR version will overwrite all

the conflicts in the file.

· If you want to use THEIRS for all conflicts, just click the Copy All button (see above) and

then the blue Save button. 

· To use THEIRS for individual conflicts, click in the highlighted conflict and select one of

the two Copy Right buttons (see above). The rightmost button moves to the next con-

flict after copying. 

When you have checked all conflicts and selected Save, close WinMerge. If there are more

conflicts it will open again automatically until all conflicts have been resolved.
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Synchronize again after resolving!

If you have kept any of YOUR versions of the conflicts you must synchronize again after

resolving to finalize sending your changes to the repository. 

Beyond Compare cannot be used as a merge tool for SVN

Unfortunately, Beyond Compare cannot currently be used as a merge tool for SVN. This is

because calling BC as a 3-pane merge tool requires additional information about each in-

dividual conflict file and all the additional temporary files that cannot be accessed auto-

matically when processing all the files in a batch.

We recommend using the free WinMerge as your merge tool for SVN. See above for de-

tails.

7.1.7 Scripts and Customization

This section is for users familiar with the scripting interface of their version control system. If

you are unsure of how this works, please don't try to edit the scripts as this could cause seri-

ous problems. 

Note that you cannot create repositories or download local working copies of your project

from your repository from within Help+Manual. Those are tasks that must be performed with

your version control software. See the sections on Git and SVN for details.

If you are familiar with scripting and the API of your VCS, reading the scripts should be pretty

self-explanatory.
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Location of the scripts
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are stored in the \Tools\ sub-folder in the Help+Manual program folder. They are edit-

able, but we strongly recommend making a copy and using the Custom Command File

option to refer to your version instead of changing the original.
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Basic operation of the Git and SVN scripts

The Git and SVN scripts are called by Help+Manual with the following syntax:

script_name [GET|SYNC|CHECKOUT|CHECKIN|STATUS] "vcs_exe_path"
"projectfolder"

On opening, control jumps to the section specified by the command, executes all the op-

erations there on the project folder with the VCS executable, and then exits. 

You  should have sections for all the possible commands in your script (get|sync|

checkout|checkin|status), since those commands can always be issued by

Help+Manual. 

The Git script uses "main" as the default branch

Note that the Git script uses "main" as the default branch for your repository. If this is dif-

ferent in your case, you need to change the branch reference in the script.

Custom command script

This script is an empty template. You need to add all your own operations under the re-

spective command labels. The way it is called also differs from the scripts for Git and SVN

in that Help+Manual itself does not call the VCS executable. This means that you need to

include that in your own commands under the individual labels. 

script_name [GET|SYNC|CHECKOUT|CHECKIN|STATUS] "projectfolder"

For example, if you are using tf.exe for Team Foundation Server, and you have added

its path to your Windows environment variables, your sync section could look liked this

(the %3 variable inserts your project folder path):

:sync
%3tf get
%3tf add /recursive
GOTO eof

7.1.8 Backups

Backups

If your VCS system is managed correctly, you don't need to make backups of your local

copy of your VCS project because the version control system is your backup. The entire

backup strategy is handled by the VCS system, with incremental backups that allow you to

return to earlier versions of your topics and projects if necessary. You just need to make
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sure that your VCS repository is backed up as well, so that you do not lose everything it

contains if disaster strikes in the location where the repository is stored. 

The history function

The history function  is disabled automatically for projects under version control. If you

wish, you can delete the history folder inside the project folder of your working copy so

that old history files don't end up in your repository.

Making manual local backups

You can make manual local backups of your project with the Save As.. option in the File

menu. This will create an unlinked copy of your project that is not connected to the VCS.

DON'T continue editing on this project when you do this, however! If you do, your edits

will no longer be part of the version linked to the VCS repository.

7.2 Using Context-Sensitive Help

Context-sensitive help is used in software applications, both standalone applications and web

applications. It is defined as help relevant to what the user is currently doing in your applica-

tion. For example, if the user presses F1 or clicks on a Help button in a dialog, they would see

a help topic describing that dialog – that is context-sensitive help.

Implementing context-sensitive help takes a little work up front but it will bring considerable

benefits for you in the long run because it will make your product easier to understand for

your users. 

The options you have for implementing context-sensitive help depend on your output format,

because different formats support different ways of making calls to your help files. 

See also:
Context-Sensitive Help & Popups  (Reference)

IDs, Context Numbers and Keywords  (Reference)

Creating popup topics

Creating topics without TOC entries

Organizing invisible topics

7.2.1 Context help support by output format

Basically "context help" means access to specific help information from within your applica-

tion or web page. You can create context help links and calls to Help+Manual output in a

wide variety of ways.

The options you have for implementing context-sensitive help depend on your output format,

because different formats support different ways of making calls to your help files. This topic
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lists the different types of context help possible in the output formats supported by

Help+Manual.

For more details on context-sensitive help, the available context-sensitive help technologies

and implementation information for programmers see the Context-Sensitive Help &

Popups  chapter in the Reference section.

Context help links to eWriter Help: Integrated viewer

For instructions on context links to eWriter help, see both Links & Context Help  and

eWriter for Software Help  in the main eWriter Help chapter.

Important: Updates to the eWriter context help interface

Please refer to the above chapters even if you are already familiar with eWriter help from

earlier versions. A new calling syntax has been introduced along with the new eViewer 3

and the version for MacOS. the old syntax is still supported, but we still recommend

switching to the new syntax for all new help files.

HTML Help (CHM)

This is the standard Microsoft help format for Windows applications.  It is used for help in-

stalled locally on the user's computer. 

Calls to HTML Help CHM files are made using the Microsoft HTML Help API (application

programming interface), which is documented in the help file delivered with the free Mi-

crosoft HTML Help Workshop compiler and CHM authoring package. For details see Ap-

plication calls to context-sensitive topics .

Making the calls is up to your programmers; each programming language has different

methods for doing this. You can download programming tutorials from our website.

Supported context-sensitive help types

· Calls to specific help topics

Display a specific topic in your help, inside the main help window.

· Calls to anchors in specific help topics

Display a specific topic in your help file in the main help window and scroll down to an

anchor  (jump target) within the topic.

· Field-level popups

Field-level popups  are small popup windows displayed in your application. They are

1586
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https://www.helpandmanual.com/support_tutorials.html


894

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

More Advanced Procedures

read from the help file but the main help window is not opened. Useful for document-

ing individual fields and controls in your application (thus the name).

· Training card help

Training card help uses the HTML ActiveX control (CHM) to create special interactive

links between your help topics and your application. In theory you can use training card

help to create interactive tutorials that guide users through steps of doing things in

your program. In practice it is so difficult to implement that most developers try it out

once and then decide that it is not worth their time. You can insert ActiveX objects for

training card help with Help+Manual's Write > Insert Object > Plain HTML Code com-

mand (HTML Help).

Internal structure of H+M CHM files

One important thing to know about the CHM files generated by Help+Manual when mak-

ing calls to them from your applications is that there are no internal folders. 

Help+Manual uses a "flat file" directory model inside the CHM, with everything on the

root level. This means that all topics and other files inside the CHM can be accessed dir-

ectly, without any path information. Some programming tips assume the use of folders –

for example a folder called "html" for the HTML topic files – and if they also include this

path without alternatives in their call examples this will lead to failures. But that is really

the only element of H+M CHM files that you need to be aware of.

WebHelp

WebHelp is displayed in a normal web browser like Firefox, Safari, Opera or even Internet

Explorer. It is used for help accessed on networks and the Internet. Calls to WebHelp are

made with normal URLs. The basic syntax is:

index.html?topicname.htm#anchorname

where index.html is the main start page, topicname.htm is the topic ID in all lower case +

the extension ".htm" and anchorname is the optional anchor you want to scroll to on the

page. See Linking to WebHelp topics  for details.

Supported context-sensitive help types

· Calls to specific help topics

Display a specific topic in your help, inside the main help window.

· Calls to anchors in specific help topics

Display a specific topic in your help file in the main help window and scroll down to an

anchor  (jump target) within the topic.

899
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· Calls using CHM help context numbers

We have also implemented support for help context numbers in WebHelp so that you

can use the same numbers you use in your CHM help if necessary. See Linking to We-

bHelp topics  for details.

Field-level popups and topics in V3 Premium Pack skins

When you use the V3 Responsive skins in the Premium Pack add-on you can also display

both popups and topics within your own web pages without taking the the user away

from the page. The popups and topics are draggable and resizable. The field-level topics

include a bar at the top with which the user can redisplay the topic within the entire help if

they want to browse further.

Adobe PDF, ePUB and Kindle/Mobi eBooks, Word DOCX

These print-style formats do not support any real context-sensitive help features. In PDF

files you can link to anchors called "named destinations ", but without proper browse

buttons in the PDF viewer they are not as flexible as hyperlinks HTML-based formats. 

See also:
Context-Sensitive Help & Popups

Linking to and controlling eWriter help

Configuring for publishing - all formats

7.2.2 Creating context-sensitive topics

Context-sensitive help displays topics relevant to what the user is currently doing in an applic-

ation. Normally, this will open the main help viewer and show the relevant topic. The Mi-

crosoft HTML Help CHM format supports a technology called "field-level popups", which are

displayed directly in your application, not in the main help window. Field-level popups are

only supported in Microsoft HTML Help CHM files. JavaScript popups cannot be used as field-

level popups.

As the help author you don't need to do anything special to create normal context-sensitive

topics. They are simply normal TOC topics and normal popup topics. They become "context-

sensitive" when they are called directly from the application. What makes field-level popup

topics a little different is the fact that they are called on their own, without the help viewer,

but when the same popup topics are called within the help they behave the same as other

popup topics. The difference is in the way the topics are called, not in the way they are cre-

ated.

For more background information see the Context-Sensitive Help & Popups  chapter in the

Reference section.
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How to create a normal context-sensitive topic

Normal context-sensitive topics are simply normal topics in the TOC. Just follow the in-

structions in Creating new topics  to create a new topic in the TOC. 

These topics become context-sensitive topics when they are called directly from the
application. How this is done depends on the programming language and your output

format. For details see Application calls to context-sensitive topics .

How to create and use field-level popup topics

Field-level popup topics are simply normal popup topics. Just follow the instructions in

Creating popup topics  to create and edit popup topics. 

Requirements for field-level popups:

CHM only: Field-level popup topics are only supported in Microsoft HTML Help CHM

files. All the popup topics you create with help context numbers are always exported to

the CHM file in plain text form, even if JavaScript popups  are activated. If you activate

JavaScript popups, all popup links in your topics will display as JavaScript popups in the

CHM viewer, but you can still activate the plain text version as field-level popups.

Add context numbers: Plain text popup topics used in HTML Help must have help con-

text numbers ! This is required by the Microsoft HTML Help API for popups and if your

popup topics do not have help context numbers they will not be exported to the internal

popup text file in the CHM.

No formatting or graphics: Plain text popups are really plain text only. Any formatting,

graphics, tables etc. will be stripped when they are displayed as field-level popups. Take

care to make your popup content comprehensible as plain text.

Changing the name of the internal field-level popups file in the

CHM:

By default, the internal field-level popup file is called CSHelp.txt. You can change this in

Project Explorer > Configuration > Publishing Options > HTML Help > Extended .HHP

Settings. See Extended .HHP Settings  for details.

Using field-level popups:

To use field-level popups your programmers must call the popup topic inside the help file

from your application, using the appropriate API calls for HTML Help. The syntax of these
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calls depends on your programming language. You can  download tutorials for most

current languages from our website. SeeApplication calls to context-sensitive topics  for
more details.

Auto-generating your popup topics from a map file:

If your programmers provide you with a "map file" of the topic IDs and context numbers

for the elements in the program that need to be documented you can also generate your

field-level popup topics automatically! See Auto-generating context-sensitive topics  for

details.

See also:
Creating popup topics

Auto-generating field-level popups

Context-Sensitive Help & Popups

Organizing invisible topics

7.2.3 Links to help from your application

Making the calls to your context-sensitive topics is basically a job for the programmer, not the

help author (you may be both, of course). In the help itself there is no difference between

context-sensitive topics and popups and normal topics and popups – the difference is how

they are called from the application.

The HTML Help CHM files and Visual Studio Help files generated by Help+Manual are fully

standard-compliant so you can use all the standard procedures for linking to and calling con-

text-sensitive topics. 

Context calls to WebHelp are made with regular URLs. For details see Application calls to We-

bHelp . 

Internal structure of H+M CHM files

One important thing to know about the CHM files generated by Help+Manual when mak-

ing calls to them from your applications is that there are no internal folders. 

We use a "flat file" directory model inside the CHM, with everything on the root level. This

means that all topics and other files inside the CHM can be accessed directly, without any

path information. Some programming tips assume the use of folders -- for example a

folder called "html" for the HTML topic files, and if they also include this path without al-

ternatives in their call examples this will lead to failures. But that is really the only element

of H+M CHM files that you need to be aware of.
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Calls to normal topics in the TOC

These are normal topic calls that open the main help viewer at the topic you are making

the call to. See your programming language's documentation for making calls to the help

format you are using. 

See Application calls to WebHelp  for details of the URL syntax for making calls to We-

bHelp topics. 

Calls to HTML Help popups

Application calls to HTML Help field-level popups are made using the popup interface of

the Microsoft HTML Help API. The syntax for these calls depends on the programming

language you are using. See the section on tutorials and resources for programmers be-

low. 

Application calls to HTML Help popups can only be made if you use HTML Help's own

plain-text popup format, in which the popup texts are stored in a special plain-text file in-

side the CHM file.This option is activated in Configuration > Publishing Options > HTML

Help > Popup Topics in the Project Explorer, where you can also specify the name of the

text file to be generated.

Plain text popup topics used in HTML Help must have context numbers! This is required

by the Microsoft HTML Help API for popups and if your popup topics do not have help

context numbers they will not be exported to the internal popup text file in the CHM.

Tutorials and resources for programmers

· The HTML Help API is fully documented in the help of the free Microsoft HTML Help

compiler (HTML Help Workshop). 

· Tutorials for interfacing between your help and your application in the most major pro-

gramming languages are available on the tutorials page at the EC Software website. 

· A free set of tools for interfacing to help and context-sensitive help in older versions of

Borland Delphi and Borland C++ is also available at the website, on the Delphi re-

sources page. This is not needed in Delphi 2005 and later, which include integrated sup-

port for interfacing with HTML Help.

· The following websites are also highly recommended as good sources of up-to-date in-

formation on interfacing with help files from your application:

The MS Help Wiki

Helpware Group Help Knowledge Base

MSDN HTML Help Reference

899
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The HTML Help Center

See also:
Context-Sensitive Help & Popups  (Reference)

7.2.4 Linking to WebHelp topics

You can create context-sensitive calls to WebHelp  (web HTML) from your application or

web pages with normal URLs using the syntax explained below. These calls can be made loc-

ally, across networks or across the Internet.

Field-level popups are not supported in WebHelp, they can only be implemented with HTML

Help (CHM). The JavaScript popups  supported in WebHelp can only be used within your

help, you cannot make calls to them from your application or web pages. 

HM2Go mini server for local WebHelp

If you want your WebHelp to be opened locally without a server (for example WebHelp on

CDs and DVDs), Help+Manual has a special mini server that you can distribute with your

help for better performance. See HM2Go - mini server for local WebHelp  for details. 

How to make calls to Webhelp topics

Calls to WebHelp must be normal URLs, made in the same way as any other URL link that

opens a browser with a specific web location or local HTML file, using exactly the same

syntax: 

Calling syntax:

index.html?topicname.htm#anchorname

Different syntax in Premium Pack V3, V4 and V5 skins

Please note that the new V3 skins in the Premium Pack add-on use a simpler, easier URL

syntax that only requires you to use topic.html. The index.html?topic.htm syntax

is no longer required for these skins, although it is supported for backward compatibility.

They also use a different syntax for references to anchors. See the Premium Pack docu-

mentation for full details.

Examples of the standard WebHelp URL syntax:

This example uses the standard file names and extensions and accesses an anchor in the

referenced topic:

1586

1510

212

673

http://mvps.org/htmlhelpcenter/
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index.html?introduction.htm#gettingstarted

The following example shows a call to a project that was published with both a non-

standard index file name and a non-standard extension for the topic files (see below).

There is no reference to an anchor in this example.

help.html?new_features.html

Elements of the calls: 

index.html This is the name of the index file of your WebHelp (this is the de-

fault, it can be changed in the Publish  dialog when you publish).

If you use this on its own it will simply display the help system with

the standard home topic.

?topicname.htm This is the name of the topic you want to display. This is created by

combining the topic ID  with the extension .htm..

This is the default topic extension, you can change it in Project

Configuration >  Publishing Options > WebHelp > HTML Export

Options . (These settings are shared with the other HTML-based

output formats and can also be accessed in the HTML Help and

Visual Studio Help sections.)

#anchorname Optional. This is the name of an anchor  in the topic that you

want to jump to. 

Using context IDs to link to WebHelp

Normally, context IDs or context numbers  are only used in Microsoft CHM/HTML Help

files. However, Help+Manual also exports a scripted map file of all the context IDs in your

project in your WebHelp output and allows you to link to them with a URL switch, in the

same way as you link to normal topic IDs. This makes it easier for programmers who are

using context IDs for making their CHM files to remap their calls to WebHelp.

Calling syntax:

index.html?contextid=xxxxx

Where xxxxxx is the context number/context ID. This works both for normal topic con-

text IDs and context IDs attached to anchors. If you are using standard templates or skins

the anchor must not be inside hidden text (i.e. not inside a toggle that is not open when

the topic is opened). If you are use a  Premium Pack skin the ToggleJump feature im-

plemented there allows you to link to anchors inside toggles as well.

1310

368

1435

415

369

https://www.helpandmanual.com/products_hm_pluspack.html
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Examples:

http://www.mydocumentation.com/index.html?contextid=60672

That is really all there is to it.

Where this is implemented:

Standard Templates:

The context ID URL switch was added in Help+Manual 6.3. It will work directly if you are

using the standard HTML templates in your project, although you may need to reset the

Layout template before publishing to get it to work, in Configuration > Publishing Op-

tions > WebHelp > Layout. 

Standard Skins:

Similarly, it has also been implemented in the standard HTML skins provided with

Help+Manual. If you are using an earlier edited copy of these skins you will need to get

the new version from the /Templates/HTML Skins to be able to use URL switches with con-

text IDs.

Premium Pack Skins:

The Premium Pack skins for Help+Manual 6 and later all support URL switches with con-

text IDs. You just need to make sure you are using version 1.56 or later if you are using

the version 1 Premium Pack or 2.20 or later if you are using version 2.

Adding support in your own skins:

Please contact support@ec-software.com if you want to add support for context IDs in

URL switches to your own custom skins or templates.

Links to WebHelp topics without the 'index.html' reference

By default, only the topic will be opened if you link to it with the topic name only, i.e. like

this:

topicname.htm

In all the standard skins, a link will then be displayed automatically above the topic header

with which the user can display the full user interface with the TOC. 

Automatic reload will stop Google from indexing your WebHelp!

There is a reload feature that will do this automatically when only the topic file is ad-

dressed without the index.html part of the URL. This is off by default, because Google

interprets the automatic reload as an attempt to increase your click count artificially and

mailto:support@ec-software.com
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stops indexing your WebHelp. 

Turning on automatic TOC reload for topic.htm links

If you don't care about Google indexing your WebHelp, or if you are using the WebHelp

on a local intranet server where there is no Google indexing, you can turn the automatic

reload feature on:

1. Open the .hmskin file for the skin you are using in Help+Manual. 

2. In the Project Explorer on the left, navigate down to Configuration > Publishing Op-

tions > WebHelp > Navigation.

3. Activate the option "When a topic is opened outside the navigation frame..."

Calling only a topic when automatic reload is on:

When the automatic reload option is active you can still call just the topic without the TOC

if you want. You do this by leaving out the index.html part and adding a simple switch

to your URL.

topicname.htm?toc=0#anchorname (with an anchor)

topicname.htm?toc=0 (without an anchor)

Avoid direct calls to the topic file

Direct calls to the topic.htm file without the index.html? portion of the URL will only

display the topic file by default. There is an reload feature that automatically displays the

full user interface for such links but this is off by default because Google doesn't index

your site when it is on  (see above). 

However, even when the automatic reload feature is on, you should try to make sure that

all your links to your WebHelp use the full index.html?topic.htm syntax. The reload

feature is convenient, but in addition to creating problems with Google it will also confuse

the browser history, so that the user will get unexpected results when they try to navigate

with the Back and Next buttons. 

It is thus always advisable to use the full call including the index file, using the standard

syntax:

index.html?introduction.htm#gettingstarted

See also:
Creating popup topics

Context-Sensitive Help & Popups

Topic files without TOC entries

207

1586

375
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7.2.5 Linking to and controlling eWriter help

On Windows, eWriter Help is the modern alternative to the obsolete CHM format for local ap-

plication help. It offers full support for context-sensitive help and file links and combines the

benefits of CHM and WebHelp while eliminating many of the disadvantages of both. On

MacOS eWriter provides an software help format that is not otherwise available in this integ-

rated form.

This topic provides a quick overview of the link options. For full details see the EWriter for

Software Help  chapter.

Viewer installation for eWriter as software documentation

When you are using eWriter as software documentation to replace CHM files you need to

know where the viewer is so that you can make your calls to it reliably. We recommend in-

stalling the standard version of the viewer for this together with your software. See

EWriter for Software Help  for details.

Each book is opened in a separate instance of the eViewer app

Each book you open has one and only one instance. If you make another call to the same

book it will apply to the open instance. You can have multiple books open at the same

time. To address the individual books you include the name of the book in your call along

with the parameters, as shown below.

Choosing the right file extension for your eWriter files

Use the .ewriter file extension for books distributed on their own

You need to use the .ewriter extension for eWriter files that are going to be distributed

on their own. It is registered with the Windows Store, and when a Windows 10 user who

does not have the viewer opens an .ewriter file they will be prompted to install the

viewer from the Windows store. Users on older versions of Windows can download the

Win32 installer from our eWriter page, which will also register the .ewriter extension.

Use your own file extension for eWriter used for software document-

ation

When you are using eWriter for software documentation you want to install the Win32

version of eViewer together with your software and make your calls to it directly. You also

don't want to conflict with any other version of the viewer that your user may have in-

stalled, so in this case you don't want to use the .ewriter extension. Instead, see one of

731

731

https://www.helpandmanual.com/ewriter/
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your own. 

See URL-style command syntax  for full details on this.

EWriter context help links and command line interface

Making calls to eWriter help files from your applications to display topics is very simple.

On Windows, you basically just need to call the viewer app with a shellExecute() or

equivalent function in your programming language, along with the name of the topic file

to be viewed and an optional anchor to scroll to.

File extensions of your topic files

The HTML topic files inside eWriter Help can have either the .htm or .html extension,

based on your settings for the topic file extension in your project in Configuration > Pub-

lishing Options > WebHelp > HTML Export Options. However, only these two extensions

are permitted. If you set a different extension in your project (for example .php or .asp),

the standard .htm extension will be used.

You need to use the correct extension in your context help calls, otherwise the topics will

not be found.

Context calls syntax

The syntax for context calls to eWriter Help has been changed with the introduction of the

new MacOS eViewer and the updated Windows eViewer. If you have used eWriter for ap-

plication help in the past the calls with the old syntax in your existing projects will still

work. However, we strongly recommend switching to the new integrated URL-style syntax

from now on. 

Please refer to the eWriter for Software Help  chapter for full details and instructions.

Basic New Syntax:

"<viewer app>" "ewriter://<ewriter file>?loadpage=<page in the
help>"

Note that when you are using integrated EXE eWriter Help files, the viewer app is the help

file itself, so it calls itself when using the new syntax.

Basic Old Syntax (not supported for MacOS):

"<viewer app>" "<page in the help>"

739

731
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URL examples eViewer app:
"<path>eViewer.exe" "ewriter://<path>my_help.ewriter?loadpage=in-
dex.html"
"<path>eViewer.exe" "ewriter://<path>my_help.ewriter?loadpage=in-
dex.html?introduction.htm#anchor2"
"<path>eViewer.exe" "ewriter://<path>my_help.ewriter?loadpage=in-
troduction.html?anchor=anchor2 (Premium Pack)"

URL examples Windows EXE eWriter file:
"<path>MyHelp.exe" "ewriter://<path>MyHelp.exe?loadpage=index.html"
"<path>MyHelp.exe" "ewriter://<path>MyHelp.exe?loadpage=index.html?
introduction.htm#anchor2"
"<path>MyHelp.exe" "ewriter://<path>MyHelp.exe?loadpage=introduc-
tion.html?anchor=anchor2" (Premium Pack)

URL parameters and JavaScript

If your HTML pages include scripts that can evaluate URL parameters (supported in some

Premium Pack skins, for example) you can also include parameters to be parsed by your

script, like this:

"<path>eViewer.exe" "ewriter://<path>my_help.ewriter?loadpage=in-
dex.html?mysetting=xyz&setting2=12"

The HTML location object is fully supported for interpreting URLs you pass to your pages

like this. This means you can extract the query portion of the script with document.loc-

ation.search, the hash portion (anchor) with document.location.hash and so on. 

Linking between eWriter files

If you have multiple eWriter help files installed on your user's computer you may some-

times want to link between them. This will normally only apply when you are using eWriter

for software documentation . 

There are several methods you can use for linking between eWriter files. You must always

use the File Link option for this, not the Internet Link!

Linking between eWriter files when the file association is known

You can use a simple method if you are sure that the .ewriter extension has been asso-

ciated with the eViewer application, or if you are using your own extension that you have

registered as part of your installation on the user's computer. Then you just need to refer-

ence the eWriter file and the topic parameters.

731
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This also works when you have changed the file extension and eViewer name:

Note that this also works if you are using eWriter for software documentation and you

have changed both the file extension and the name of your copy of the eViewer applica-

tion. You just need to link to another eWriter file that has the same extension as the

eWriter file containing the link. 

File name: The name of the eWriter file you want to link to without any path

information. Just the file name. You must use the extension that has

been registered to the eViewer application on the user's computer.

This will be .ewriter if you are sure that has been registered, or

your own custom extension if you are installing eViewer as part of

your software installation and registering the extension yourself. 

Relative path: Only include the path to the file here if the target file is not in the

same folder as the file containing the link. Despite the name, you

can use either a relative or an absolute path.

Important: No quotes around this path, even if it includes spaces!

Execution para-

meters:

The normal WebHelp reference to the topic you want to display in

the target file. The syntax depends on the skin type you are using.

This parameter must be enclosed in double quotes.

Standard Help+Manual skins and older Premium Pack skins:

"index.html?topic.html"

Premium Pack V3 skins:

"topic.html"
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Topic file extensions

The topic file extension can be .htm or .html, depending on what

you have set in your project. Other extensions are not allowed for

eWriter topics. 

Anchors and other parameter extensions

Add these in the execution parameters, inside the double quotes,

exactly as you would in WebHelp. 

Using an Internet link instead of a File link (required for MacOS)

You can also use an Internet link to link between eWriter Help files, but then you have to

use the new syntax with the ewriter:// prefix. This is also required if you are using

eWriter Help on MacOS.

ewriter://NewProject.ewriter?loadpage=index.html?topic_name.html

Linking between files when you are using the integrated viewer in

EXE eWriter books

When you create combined book and viewer files with the EXE extension you always just

enter the EXE file as the file to link to and the topic to open as the parameters. 
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File name: The name of the eWriter EXE file you want to link to without any

path information. Just the file name.

Relative path: Only include the path to the file here if the target file is not in the

same folder as the file containing the link. Despite the name, you

can use either a relative or an absolute path.

Important: No quotes around this path, even if it includes spaces!

Execution para-

meters:

The normal WebHelp reference to the topic you want to display in

the target file. The syntax depends on the skin type you are using.

This parameter must be enclosed in double quotes.

Standard Help+Manual skins and older Premium Pack skins:

"index.html?topic.html"

Premium Pack V3 skins:

"topic.html"

Topic file extensions

The topic file extension can be .htm or .html, depending on what

you have set in your project. Other extensions are not allowed for

eWriter topics. 

Anchors and other parameter extensions

Add these in the execution parameters, inside the double quotes,

exactly as you would in WebHelp. 
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Calls to EXE eWriter files with the integrated viewer

You can still create the original EXE eWriter files with an integrated viewer if you wish, al-

though we strongly recommend using the separate viewer. You just need to change the

output file extension to .exe in the Publish screen before publishing. Help+Manual iden-

tifies this automatically and then creates an EXE eWriter Help file with an integrated

viewer.

Not supported on MacOS

Note that EXE eWriter Help is a Windows format and cannot be used on MacOS. On Macs,

you must use the eViewer app and .ewriter data files.

Context calls syntax

The calling syntax is the same as with the external viewer, except you call the EXE eWriter

Help file instead of the viewer, followed by the parameters. You can use both the old and

the new syntax for this.

Old syntax:

<path>my_ebook.exe "index.html?introduction.htm"
<path>my_ebook.exe "index.html?this_page.htm#anchor"
<path>my_ebook.exe "index.html?anotherpage.htm"

New syntax:

If you use the new syntax, you must also include the name of the EXE eWriter Help file

after the ewriter:// protocol prefix, so that the file is calling itself:

<path>my_ebook.exe "ewriter://my_ebook.exe?loadpage=index.html?
introduction.htm"
<path>my_ebook.exe "ewriter://my_ebook.exe?loadpage=index.html?
this_page.htm#anchor"
<path>my_ebook.exe "ewriter://my_ebook.exe?loadpage=index.html?
anotherpage.htm"

Always include the page parameters in quotes, even if there are no spaces. Otherwise you

will get Windows errors caused by some of the characters that need to be used. 

Links to executable files

If you're used to producing CHM files and WebHelp you don't even think about opening

executable EXE program files from your documentation. But with eWriter Help, you can!
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This is possible both from normal links in topics and from TOC entries.

RESTRICTION: Not supported in the Windows Store version of the

viewer!

Windows Store apps are not permitted to invoke executable files from within the program.

Because of this, the functions described below are not available in the Windows Store ver-

sion of the viewer app. However, you can use them if you are installing the standard Win-

dows eViewer app together with your software. See EWriter for Software Help  for de-

tails.

Current directory status when linking to executable files

When executing external files, the eWriter viewer explicitly sets the current directory to

prevent possible failure of file links using a relative path.

File links to executables in topics

Just create a normal file link to the EXE file and add exec: directly before the file name,

like this:

exec:notepad.exe
exec:../demo_program/widget_maker.exe

Links to executables in the TOC

You can also create links to executable files in the TOC of an eWriter Help file. Create a

new topic entry and choose the TOC Link option, and then Link to Web Address. Then

enter the target in the Web Address: field, using same exec:filename.exe format as

above. Here too, you can include a relative path if necessary.

731
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exec:notepad.exe
exec:../demo_program/widget_maker.exe

See also:
eWriter Help

7.2.6 Auto-generating topics for context help

Complex applications have a lot of components and controls and if you document them all

with context-sensitive topics this means you need to create a lot of topics. This can be a very

tedious task and it's also easy to make mistakes, because it means entering hundreds of con-

text numbers and topic IDs that may not have very descriptive names.

Help+Manual can do all this work for you with the help of map files , which are simple text

files containing lists of the topic IDs and help context numbers to be used for documenting

the controls in the program. These files can be provided by the programmers (they can be

generated by most modern programming languages). They have a standard format and syn-

tax and Help+Manual can use them both to apply missing help context numbers to existing

topics and to generate missing topics with the necessary IDs and help context numbers.

How to auto-generate your topic files with the map file

1. Obtain the map file from the programmers and make sure that it only contains the

topics you want to use. 

Plain text popup topics used in HTML Help must have context numbers so make sure

you include context numbers in your map file! This is required by the Microsoft HTML

Help API for popups and if your popup topics do not have help context numbers they

will not be exported to the internal popup text file in the CHM.

2. Open your project (you might want to make a backup first) and select Project > Tools

> Context Tool:

696

1598
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3. Click on Import map file... and select the map file. A dialog will be displayed asking you

whether you want to merge or replace the existing numbers

Replace:

This deletes ALL context numbers in the current project and replaces them with the

numbers from the map file.

Merge:

This only replaces the context numbers for topics with matching IDs. All other topics

are left unchanged.

Auto-generating topics:

When you import a map file any topic IDs in the file that don't exist in your project will be

listed in red in the Context Tool editing box. When you click on OK the tool will ask you if

you want to create topic files for these IDs. 

If you say yes the files will be created in the Topic Files section, without TOC entries. If you

want to create TOC entries for the new topics you must do this manually.

See also:
About map files

The Help Context Tool

179

1598

1241
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7.2.7 Named destinations in PDF

When Help+Manual generates PDF documents it automatically exports a number PDF an-

chors known as "named destinations" for targets in the document. These destinations are sim-

ilar to topic anchors  in HTML documents. You can use these destinations as targets in hy-

perlinks to the PDF files.

Key Information
Named destinations are only generated if you gener-

ate an interactive PDF  document.

Items exported as named destinations

Topic IDs

Topic IDs are exported as named destinations in all lower case. Links to named destina-

tions are case-sensitive, so you must also use the lower case format in all your links to

named destinations in PDFs created by Help+Manual. 

For example, if your topic ID is Index_Topic then the named destination in the PDF will

be index_topic. 

Topic anchors

Anchors inserted in your topics are exported together with the topic IDs, also in all lower

case letters, using the syntax topicid#anchorid. The topic ID is always part of the

named destination for an anchor, with a pound character (#) between the two.

Links to anchors in PDF only work in PDF links:

Links to named destinations including anchors are a special case. They will only work in

links in PDF files, not in links in WebHelp files. If you use a link with an anchor in WebHelp

output the link will only open the PDF file at the first page.

Standard PDF template sections

The following named destinations are exported for the standard PDF template sections

defined in your print manual template . These destinations are exported in all  lower

case as shown below, and that is also how you must link to them. (The commas are not

part of the destinations.)

cover, title1, title2, title3, foreword, toc, topics, endnote1,
index, endnote2, backcover

Note that there are no destinations for repeating sections like Top Level Entry and Blank

Pages. 

415

1442

803
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User-defined template sections

User-defined PDF sections created in Manual Designer with the Insert Page option in the

Pages menu are also exported as named destinations. The destinations generated for

these sections are called custom1, custom2, custom3 and so on – i.e. the word "cus-

tom" in all lower case plus the sequential number of the custom page in the order in

which the pages were created in the template.

Important note:

The named destinations for user-defined sections are fixed and are assigned in the order

in which the user-defined sections are created. The first section you create gets the destin-

ation custom1, the second section gets custom2 and so on. The actual order of the cus-

tom sections in your template is irrelevant.

Linking to named destinations in PDF documents

You can create links to both page numbers and "named destinations" in PDF documents. The

procedure is the same for links that will be used in PDF files and in WebHelp output.

 Named destinations are jump targets that work like anchors. These links will work in PDFs

created by Help+Manual and in WebHelp created by Help+Manual, but not in CHM files. The

Microsoft CHM viewer does not support the link format needed to jump to destinations in

PDF files. A link to a PDF in a CHM file will simply open the PDF at the first page. See Named

destinations in PDF  for details on the named destinations created in PDFs by Help+Manual

and more background information.

Use normal topic links for targets in the current document

Note that named destinations are only needed for links between two different PDF files or

from other applications or documents. Use normal topic links to jump to targets within

your Help+Manual projects (i.e. from one topic to another). You don't need to use named

destinations for this.

Requirements:

· File Links are required for linking to PDFs:

You must use the File Link option for creating links to targets inside PDF files. The Inter-

net Link option will not always work correctly, even in WebHelp. 

· Set the PDF to "interactive" to use named destinations:

If the PDF you are linking to is created with Help+Manual it must be generated using

the "interactive PDF" option in your PDF settings . Named destinations are only gen-

erated for interactive PDF documents.

465

1442
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Linking to named destinations in PDF documents:

You need to create a file link with the destination added to it to link to a destination in a

PDF document. Internet links will not work correctly, not even in WebHelp.The syntax is

the same for links that are going to be in PDF files and WebHelp files. The links to the PDF

files will also work in CHM files, but they will only open the PDF document; they will not

jump to the destination in the PDF from a link in a CHM.

Procedure:

1. Follow the instructions for inserting a file link  and enter the name of the PDF file

you want to link to. 

2. Add #nameddest= after the file name, followed by the name of the named destina-

tion in all lower case characters. See this topic  for details of the named destinations

you can jump to.

Examples:

myfile.pdf#nameddest=toc (jumps to the Table of Contents in the PDF)

myfile.pdf#nameddest=welcome_topic (jumps to the topic with the ID Wel-

come_Topic)

myfile.pdf#nameddest=custom1 (jumps to user-defined template section 1)

Special case: anchors:

Links to named destinations including anchors are a special case. They will only work in

links in PDF files, not in links in WebHelp files. If you use a link with an anchor in WebHelp

output the link will only open the PDF file at the first page.

Example:

In a PDF file, the following file link will jump to the anchor testanchor in the topic with

the ID Welcome_Topic. In a WebHelp file it will only open the PDF at the first page.

myfile.pdf#nameddest=welcome_topic#testanchor 

Linking to a page number in a PDF document:

You need to create a file link with the page number added to it do link to a page number

in a PDF document. Internet links will not work correctly, not even in WebHelp.The syntax

425

465
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is the same for links that are going to be in PDF files and WebHelp files. The links to the

PDF files will also work in CHM files, but they will only open the PDF document; they will

not jump to the page number in the PDF from a link in a CHM.

Important: The page number destinations in PDFs created by Help+Manual start count-

ing at 0, so you must jump to the actual page number minus one. If you are jumping to

pages in PDFs created by other tools you can usually jump to the actual page numbers.

1. Follow the instructions for inserting a file link  and enter the name of the PDF file

you want to link to. 

2. Add #page= after the file name, followed by the page number:

myfile.pdf#page=123 (jumps to page 124)

myfile.pdf#page=0 (jumps to page 1, same as just opening the PDF file without a

target)

myfile.pdf#page=11 (jumps to page 12)

Links to PDFs from WebHelp and HTML files

Links to named destinations in PDF from Help+Manual WebHelp

When creating links to named destinations in PDF files from WebHelp you can use exactly

the same procedure and syntax as for links from PDF files. Create a file link and follow the

instructions above. 

Links to named destinations in PDF from other HTML files

The syntax is also the same for links to named destinations in other HTML files not gener-

ated by Help+Manual. Just create a hyperlink using the same pdf_file.pdf#named-

dest=xxxx and pdf_file.pdf#page=yy syntax for the href target of the link as you

use in Help+Manual, where xxxx is the named destination and yy is the page number.

Links to PDF from CHM files

You cannot link to named destinations in PDFs from a page in a CHM file. The Microsoft

CHM viewer will block all attempts to do this. You can only use a normal file link to open

the PDF file at the first page. That is the only option available. This is a limitation of the

CHM format and the Microsoft CHM viewer. Help+Manual cannot do anything to change

this (and the PDF must be in the same folder as the CHM to open at all).

425
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7.3 Using Variables

Variables are used to insert text that may change in your output when you publish your pro-

ject. They are ideal for things like program names and version numbers. To update, you just

need to edit the variable definition and recompile. Predefined variables make it easy to insert

things like the current date, the title of your help project and so on.

Variables have no effective length limit. You are unlikely to be able to enter more than 2 giga-

bytes of text in the variable definition fields. User-defined variables can contain either plain

text or HTML code. This allows you to use variables to insert HTML code in your HTML tem-

plates. Help+Manual supports both a wide selection of predefined variables and user-defined

variables. 

You can set different values for variables in individual topics and redefine some or all of your

variables with a list of values stored in an external text file when you publish your project. 

See also:
Variables in HTML templates

Variables and Conditional Output  (Reference)

7.3.1 Where you can use variables

The following table provides a quick reference showing where you can use which kinds of

variables. 

You can use both HTML variables and plain text variables in all locations. However, whether or

not it makes sense to use HTML variables in all locations depends on the code you use, of

course! In output formats not based on HTML (PDF, DOCX, printed manuals) the text portion

of the variables will be extracted automatically. 

Location: Supported variables:

Topic text and headers

Plain-text variables:

Global predefined variables and user-defined variables in-

serted with the  Text Variable tool in Write > Insert

Object: 

<%VARIABLE_NAME%>

Note that variables typed in manually are not highlighted

in the editor and double-clicking on them will not open

the variable selection list.

1049

1558
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HTML variables:

HTML variables inserted in these locations will only insert

the text portion of the HTML code. For example, if the

variable contains:

<a href="https://www.helpandmanual.com>EC

Software Website</a> 

only "EC Software Website" will be inserted. All the HTML

code (blue) will be stripped out.  If there is no plain-text

portion nothing will be inserted.

TOC, keywords, image cap-

tions, link captions, macros in

macro links

Plain-text variables:

Global predefined variables and user-defined variables in-

serted manually by typing the variable names using the

syntax <%VARIABLE_NAME%>.

HTML variables:

In these locations only the plain-text portion of HTML

variable values will be inserted (see example above).  If

there is no plain-text portion nothing will be inserted.

HTML code objects and scripts

in script links Plain-text variables:

Global predefined variables and user-defined variables

can be used in code objects and script link scripts directly.

The variables must inserted manually by typing the vari-

able names using the standard syntax <%VARIABLE_NAME

%>.

HTML variables:

HTML variables will generally work as expected in these

locations, inserting the full HTML code stored in the vari-

able. You can also use most of the exclusive HTML tem-

plate variables  here, with a couple of logical excep-

tions:

1569
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HTML template variable exceptions: 

The following HTML template variables can't be used in

code objects because they can only be evaluated when

they are used directly in the HTML template:

DOCTYPE, GAACCOUNT

HTML templates

Plain-text variables:

Global predefined variables, user-defined variables and

special HTML template variables inserted manually by

typing the variable names.

HTML variables:

You can use HTML variables without restriction in HTML

templates. The HTML code stored in the variable will be

inserted in the in the template. You can also use HTML

template variables  as part of the value of the HTML

variable. 

PDF templates edited with

Manual Designer Plain-text variables:

Global predefined variables, user-defined variables and

special PDF template variables inserted manually by typ-

ing the variable names.

HTML variables:

HTML variables will only insert the plain-text portion of

the variable value in PDF templates. If there is no plain-

text portion nothing will be inserted.

See also:
Variables and Conditional Output  (Reference)

7.3.2 User-defined variables

You can define any number of your own variables to use in your project. These user-defined

variables are stored with your project, which means that they are only available to the project

1569
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in which they are defined. However, you can transfer variables between projects with the Ex-

port and Import functions (see below). 

User-defined variables can be used almost everywhere in your projects: In topics and headers,

the Table of Contents, keywords, image captions, link captions, macros, scripts, HTML code

objects, HTML templates and PDF templates. See the other topics in this section for details on

using variables in these locations.

See Inserting variables in topics  and Inserting variables in other locations  for details on

how to use variables in your projects.

Plain-text variables and HTML variables

You can define two different types of variables: Text variables and HTML variables. Both

types have no effective length limit (theoretically you could enter up to 2 gigabytes of

text).  See The power of editable variables  for more details on using HTML variables.

Plain-text variables:

Plain-text variables contain text only. The text is inserted as plain text wherever you use

the variable. You can use them anywhere where variables are supported.

HTML variables:

HTML variables contain HTML code. They are designed primarily for use in HTML tem-

plates and HTML code objects. If you use an HTML variable anywhere else (for example in

a topic in the Help+Manual editor) only any plain text portion of the variable value will be

inserted (i.e. text outside of any HTML tags. If there is no plain text portion nothing will be

inserted.

Important: Unlike plain text variables, you cannot nest HTML variables (variable as part of

the variable value). It is also not possible to nest a plain text variable inside an HTML vari-

able 

How to define a variable

1. In the Project Manager go to Configuration > Common Properties > Text Variables. 

2. Select Add, enter the name for your variable and click on OK. 

932 934
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You don't need to worry about case, the variable name will be converted to all upper

case automatically.

3. Select HTML or Text in the Type column. HTML Variables can contain HTML, JavaScript

and CSS code in addition to normal text.

4. If you want to protect the variable against accidental editing select Yes in the Protected

column. The values of protected variables are shown grayed out. 

5. Click in the Value column next to your new variable and enter the text or HTML code. 

There is effectively no limit to the amount of text you can enter – you are unlikely to be

able to enter more than 2 gigabytes of text in the Value column!

Variable name syntax

Exactly the same variable name syntax is used for variables in all parts of your projects:

<%VARIABLENAME%>

· Since you can also type variables manually in topic text and topic headers it is important

to observe this syntax! The variable name VARIABLENAME must be in all upper case and

it must be enclosed between opening and closing <% and %> tags. 

· Spaces are allowed in variable names because the beginning and end of the variable are

clearly defined by the <% and %> tags. For example:

<%VARIABLE NAME WITH SPACES%>

How to edit user-defined variables

· In the Project Manager go to Configuration > Common Properties > Text Variables.

OR:
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· Double-click on a variable in the editor and select More... to go the Text Variables con-

figuration screen.

The second option only works with variables entered with Insert > Text Variable. Vari-

ables typed in manually are not highlighted and you cannot display the variables list by

double-clicking on them.

Importing and exporting your user-defined variables

You can use these features to copy variables between projects and to define variables in a

text editor and then load them into your project. (This can be easier than defining a lot of

long variables directly in Help+Manual.)

Exporting user-defined variables:

1. In the Project Manager go to Configuration > Common Properties > Text Variables. 

2. Select to Export your project variables to a text file.

Importing user-defined variables from a file:

1. Use an editor like Windows Notepad to create a list of variables in a plain text file, us-

ing the following syntax: 

VARIABLENAME1=Variable value
MYVARIABLE=another variable value

One variable per line, variable name all in capital letters, no spaces on either side of

the = character, no quotes. You can also enter HTML code for HTML variables, of

course.

2. Import the variables with the Import button in the Text Variables section in your Pro-

ject Configuration. 
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3. If your list includes HTML variables you must manually change the type of the vari-

ables to HTML after importing, otherwise the code will be interpreted as plain text.

Use the Export function (see above) to see an example of the necessary format and the

syntax of the file.

Importing user-defined variables from another project:

You can also import all the user-defined variables from another Help+Manual project. To

do this just click on Copy properties from... at the bottom of the Text Variables editing win-

dow and select the project you want to import the variables from. This will overwrite the

variables in the current project.

If you want to merge the variables from another project you must export them to a text

file and then import them from the text file  (see above). 

See also:
Variables and Conditional Output  (Reference)

7.3.3 Global predefined variables

There are a large number of global predefined variables that you can use to insert items that

you may want to change, for example the title of the project, the copyright note, the date and

time in various formats and the date and time at which the current topic was last edited.

Some of the predefined variables have automatic values, others take their values from the

Configuration section of your project. See Global predefined variables  for a list of the avail-

able variables, what they do and where they get their values.

See Inserting variables in topics  and Inserting variables in other locations  for details on

how to use variables in your projects.

Where you can use global predefined variables

Help+Manual's global predefined variables can be used almost everywhere in your pro-

jects: In topics and headers, the Table of Contents, keywords, image captions, link cap-

tions, macros, scripts, HTML code objects, HTML templates and PDF templates. 

You cannot use HTML code in global variables:

Note that all global variables are plain-text variables so you cannot use them to insert

HTML code. Even if you create an HTML variable and use it as the value of a global vari-

able only the plain-text portion of the variable will be inserted.

See Inserting variables in topics  and Inserting variables in other locations  for details

on how to use variables of all kinds in all these locations.

1558
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Variable name syntax

Exactly the same variable name syntax is used for variables in all parts of your projects:

<%VARIABLENAME%>

Since you can also type variables manually in topic text and topic headers it is important

to observe this syntax! The variable name VARIABLENAME must be in all upper case and it

must be enclosed between opening and closing <% and %> tags. 

See also:
Variables and Conditional Output  (Reference)

Global predefined variables  (Reference with list of variables)

Date and time variables

7.3.4 Editing, formatting and disabling variables

This topic describes how to edit variables in the Help+Manual editor, how to format the con-

tent of variables in your output (i.e. with bold text or text styles) and how to disable variables

so that the variable name is displayed in your output instead of the content of the variable.

HTML variables and plain text variables

You can create user-defined variables in two modes: As plain text or as HTML code. If you

set the variable to HTML mode you can include any HTML code, JavaScript and CSS you

like as long as the syntax is correct. You are responsible for this – no syntax checking is

performed!

HTML variables will only insert the full HTML code in HTML templates and HTML code ob-

jects. In other locations only the plain-text portion of the variable value will be inserted. If

there is no plain-text portion nothing will be inserted.

Nested text variables - variable as value of another variable

You can "nest" text variables, i.e. you can use one variable as part or all of the value of an-

other variable. To do this just type in the variable name in the value field of the other vari-

able, using the standard variable name syntax <%VARIABLENAME%> (spaces are allowed).

Nesting is not allowed in HTML variables:

Unlike plain text variables, you cannot nest HTML variables. Nesting is not supported at all

in HTML variables: It is also not possible to nest a plain text variable inside an HTML vari-

able, or an HTML variable inside a plain text variable.

1558
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How to edit the values of variables

In the Project Explorer go to Configuration > Common Properties > Text Variables and

edit the values of the variables in the list. If the variable value is grayed out it is protected

and you must first unprotect it by setting the protected switch to No in the Protected

column.

You can also double-click on a highlighted button variable in the editor and then select

More... to display the variable editing window. (This is not possible with manually-typed

variables without a button highlight.)
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Importing, exporting, sorting and managing your variables

Importing and exporting:

The Import and Export buttons next to the variables list allow you to save your variables

to a file and load variable definitions saved in a file.



927

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

More Advanced Procedures

Export exports the current variable list to a text file, using the standard INI format. (You

can use this to get a full example of the format if you like.) This only includes your user-

defined variables. Help+Manual's own predefined variables are not exported. It also does

not include the Type (HTML or Text) or Protected attributes.

Import imports a list of variables and corresponding values from a plain text file using the

standard INI format, adding them to the project's variable list. You must set the variable

type (HTML or Text) manually after importing the list. The file must be be a plain text file,

and it must be encoded in the UTF8 format if it includes any accented or special charac-

ters. The type cannot be stored with the list. When you import you can choose to merge

the imported list with your existing variables or replace all the existing variables com-

pletely. 

Syntax: VARIABLENAME=Variable value

You can get an example of a variable list by using Export. Enter one variable per line

without spaces on either side of the = sign and with a hard carriage return at the end of

each line. 

Example:

PRODNAME=Widget Confabulator 3
PRODUCT PATH=\Application\Widget\Program
WEBSITE=<a href="http://www.acmecoyote.com/">Acme Coyote Products</a>
CURRENT LOCATION=Bombay, India

Deleting, Moving and Sorting:

The Delete, Move and Sort buttons are for managing and organizing your variables list:
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You can select multiple variables for moving and deleting with SHIFT+Click and

CTRL+Click. This also works for multiple individual variables with unselected variables

between them. 

The Sort button sorts the variables list alphabetically. 

How to edit the names of variables in topics

You cannot edit the names of variables in your variable definitions – they are fixed there

and to "edit" the name you need to create a new variable with the desired new name. This

section is about editing the names of variables that you have inserted in the topics in your

project. 

Variables in your project are actually always just plain text variable names identified by the

tag delimiters <% and %>. When you use the Insert > Text Variable function the vari-

ables are displayed as highlighted buttons for easy identification and you can double-click

on them to display the variables list, but this is just for convenience. 

You can also type in variables manually. The clickable highlight is just an editing conveni-

ence to make the variables easier to see and use. 

Editing the names of variables inserted with the Variable tool:

· To edit a variable name just click once inside the highlighted variable name and type. (If

you change the variable to one that does not exist it will not work, of course...) 

· To display the variables list double-click on the highlighted variable in the editor. If

you then select a different variable from the list it will replace the original variable in the

editor.
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Editing the names of variables typed manually:

Variables typed manually are normal text and their names can be edited normally. They

cannot be highlighted and you cannot double-click on them to display the variables list.

Highlighted variables at the beginning of a paragraph:

If a highlighted variable is at the beginning of a paragraph you can't insert any text before

it; all the text you type to the left of the variable will also be highlighted. Here is how to

solve this problem:

1. Click to the left of the variable and press Enter to create a new paragraph. 

2. Press the space bar followed by Backspace and type your text. 

3. Click to the right of the new text and press Delete to bring the variable up into the

same paragraph. 

If you type text instead of pressing the space bar it will be highlighted as a variable. To

correct this just right-click on the highlight and select Convert to plain text.

How to use formatting and styles with variables

The values of variables are stored as plain text, without any formatting information.

However, you can easily turn the content of variables into formatted text with bold, under-
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line or styles in your output by formatting the variable name in the Help+Manual editor.

Formatting variables manually:

1. Select the variable in the editor so that the entire variable is highlighted. This is the

same for both variables typed manually and variables inserted with the  Text Vari-

able tool in Write > Insert Object. 

  Formatting the variable formats the variable 

  contents in your published output.

Be careful to select the entire variable – if you only format part of the variable it can no

longer be identified correctly by the compiler!

2. Use the formatting options in Write > Font to format the variable. For example, if you

format the variable with bold and italic the variable's value will be bold and italic in

your output.

Formatting variables with styles:

If you include variables in paragraphs that use paragraph and font styles you don't need

to do anything – the variables' values will automatically be formatted like the rest of the

text in the paragraph.

If you have defined text-only styles (see Defining styles ) you can apply them to vari-

ables:

1. Select the variable in the editor so that the entire variable is highlighted (this is the

same for both variables typed manually and variables inserted with Insert > Text Vari-

able). 

Here too, be extremely careful to select the entire variable – if you only format part of

the variable it can no longer be identified correctly by the compiler!

2. Apply your text-only style by selecting it in the style selector in the Toolbar, pressing

the hotkey combination you have defined for the style or by selecting Format >

Format with Style.

281
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How to disable variables

Sometimes you may want to include the variables themselves rather than their values in

your output. For example, this was necessary in this help in all the places where examples

of the variables are displayed – if we had not disabled the variables here the values of the

variables would have been displayed and the examples wouldn't have made much sense! 

· To disable variables just type a \ backslash character between the opening <% tag de-

limiter and the variable name. This works in exactly the same way for all variables any-

where in your project. It also works both for the green highlighted variables inserted

with Insert > Text Variable and variables typed in manually.

· Note that you only need to disable variables that are actually defined in the place where

you are using them. You don't need to use the backslash character to disable undefined

variables or for variables that are not supported where you are using them. For ex-

ample, if you type the special HTML template variables  in a topic the variable names

will always be displayed in the output because they are not defined there.

· To also include the backslash character as shown in the examples below just type two

backslash characters!

Examples:

To enter the backslash in highlighted variables just click

inside the variable and start typing.

<%\TIMELONG%>

<%\NOW%>

<%\AUTHOR%>

All the examples on the left were typed with two back-

slashes inside the variable to show how they are entered

in the editor. With a single backslash you would simply see

the variable name in the output.

<%TOPIC_TEXT%>
<%FANTASY_VARIABLE%>

These two examples were entered without backslashes.

They do not need to be disabled because they are not

supported in normal topics – the first is a HTML template

variable, the second is simply undefined.

How to disable the variable highlight

The highlight displayed for variables inserted with Insert > Text Variable uses the same

system as the highlighting used for hyperlinks. You can turn the highlight off by right-

clicking on the variable and selecting Convert to plain text in the context menu displayed.

The variable will still work when you do this, but it is then just like a manually-typed vari-

able. You can no longer-double click on it to display the variables list.

1569
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This is not reversible! You can undo it with Ctrl+Z or  Undo in Write > Editing directly

after making the change but later you cannot convert an non-highlighted variable to a

highlighted one. The only alternative is to re-enter the variable with Insert > Text Vari-

able.

See also:
Variables and Conditional Output  (Reference)

7.3.5 Inserting variables in topics and headers

You can use both Help+Manual's predefined variables and your own user-defined variables in

your topics and topic headers. These are all displayed automatically in the Insert Text Vari-

able  dialog so you don't need to refer to a list to use them. 

If you use HTML variables in your topics and headers only the plain-text portion of the vari-

able value will be inserted. If the variable does not contain a plain-text portion (text outside of

any HTML tags) nothing will be inserted. 

How to insert and edit variables with the Variables Tool

The procedure is identical for predefined variables and user-defined variables. They are all

displayed together in the same dialog:

1. Click in the editor where you want to insert the variable, either in the text or the topic

header above the text. 

2. Select Write > Insert Object >  or press Ctrl+T.

1558
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3. Select the variable you want to use from the list and click on OK (or just double-click

on the variable in the list).

Variables inserted with this method are displayed with a button-style highlight like this:

 This is only to make the variable easier to see in the editor. Variables

typed in manually (see below) are also fully functional.See Variables and Conditional Out-

put  for lists of the available predefined variables and what they do.

Editing highlighted variables:

Double-clicking on a variable opens the Insert Variable  dialog with which you can

change the variable to a different variable or access the Edit Variables dialog by clicking

on More...

How to type in variables manually

Variables can also be typed in manually in topics and headers. They are evaluated auto-

matically when you publish your output and work in exactly the same way as variables

entered with the Insert Variable dialog. 

· Just type in the variable exactly as it appears in the variable list. Use all upper-case char-

acters, and enclose the variable name in <% and %> tag delimiters. Spaces are permitted

in variable names.

· Example: This sentence contains a <%USER_DEFINED_VARIABLE%> typed in manually.

Variables inserted with this method are not highlighted in the topic text and you cannot

double-click on them to open the Edit Variables dialog. Also, if you make a mistake when

you type the name of a variable it won't work!

Date and time formatting in variables

A number of the predefined variables in Help+Manual enter the current date or time or

the date or time associated with an item in your project. Normally these variables will

automatically use the date and time format set in your Windows configuration. In addition

to this they also automatically use the current language set in your project for words in

the time and date, if applicable. 

However, the <%NOW%>, <%TOPICLASTEDITED%> and <%DATE%> variables also support

the use of a "format string" with which you can define the entire date and time format to

be displayed. You define the format by adding the format string to the variable in paren-

theses like this:

<%NOW(dddd, mmmm d, yyyy)%>

1558
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See Date and time variables  for details of the syntax.

Note that this only works with these three variables. If you add format strings to any other

variables the variable will no longer work. Also, you can only use this option by editing

variables in the Help+Manual editor. You cannot use the date and time formatting syntax

in variable definitions. 

See also:
Variables and Conditional Output  (Reference)

Where you can use variables

Editing, formatting and disabling variables

Date and time variables

7.3.6 Inserting variables in other project locations

You can also use all the global predefined variables and your own user-defined variables in

the captions in the Table of Contents, keywords, image captions, link captions, macros and

scripts, HTML code objects, HTML templates, PDF print manual templates and text entry fields

in your project's Configuration section.

There is one difference, however: In all these locations you cannot use the Write > Insert Ob-

ject >   tool, you must type the variables in manually.

If you use HTML variables anywhere except in HTML templates and HTML code objects only

the plain-text portion of the variable value will be inserted. If the variable does not contain a

plain-text portion nothing will be inserted. 

How to display available variables

· Go to Configuration > Common Properties > Text Variables in the Project Explorer to

view and edit your user-defined variables.

1565
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· See global predefined variables  for a list of the available predefined variables.

How to use variables in the TOC

1. In the Project Explorer, click on the TOC entry you want to edit and press F2 to activate

caption editing. 

2. The variable insertion dialog used in topics is not available here! Type in the variable

exactly as it appears in the variable list. 

Examples:

<%DATELONG%
>

A predefined variable (the date in long format)

<%MYPROJECT
%>

A user-defined variable

How to use variables in keywords

Text variables are supported both in normal index keywords and in A-keywords.

1561
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· The procedure here is exactly the same: Just type in the variable, entering it exactly as it

is listed, complete with the opening <% tag and the closing %> tag. 

See Keywords and Indexes  for details on editing and using keywords.

How to use variables in image captions

1. Double-click on the graphic in the editor to open its properties dialog. 

2. Type in the variable in the Image Caption field, entering it exactly as it is listed, com-

plete with the opening <% tag and the closing %> tag.

How to use variables in link captions

You can also use text variables in link captions, i.e. the texts of hyperlinks shown in your

topics. You can edit these directly, just by clicking once in the caption and typing, but it is

still a little easier to double-click on the link to edit it in its properties dialog.

1. Double-click on the link to display the Hyperlink dialog . 

2. Type in the variable in the Caption: field, entering it exactly as it is listed, complete with

the opening <% tag and the closing %> tag.

How to use variables in macros and scripts

You can also use text variables in macros and scripts inserted in macro and script links and

graphics hotspots. 

HTML variables are supported in scripts. 

· Just follow the instructions for inserting macros and scripts in macro and script links

and graphics hotspots  and type the variable in the Script: editing field in the place

where you want to use it, entering it exactly as it is listed, complete with the opening <%

tag and the closing %> tag.

How to use text variables in HTML code objects

Both text variables and HTML variables are also supported in HTML code objects  inser-

ted with  tool in Write > Insert Object. 

· Here too, just type in the variable in the code object using the standard syntax and the

opening and closing <% and %> tags around the variable name (spaces are permitted in
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variable names). The variables will be parsed and replaced automatically when you pub-

lish your project.

Remember that no syntax checking is performed on the contents of HTML code objects;

you are entirely responsible for the proper syntax and structure of your HTML code! 

Important: You cannot use HTML template variables  in HTML code objects because

the code objects are parsed together with the topic content, before it is inserted in the

template. 

See The power of editable variables  for some powerful additional features available

with HTML variables!

Date and time formatting in variables

A number of the predefined variables in Help+Manual enter the current date or time or

the date or time associated with an item in your project. Normally these variables will

automatically use the date and time format set in your Windows configuration. In addition

to this they also automatically use the current language set in your project for words in

the time and date, if applicable. 

However, the <%NOW%>, <%TOPICLASTEDITED%> and <%DATE%> variables also support

the use of a "format string" with which you can define the entire date and time format to

be displayed. You define the format by adding the format string to the variable in paren-

theses like this:

<%NOW(dddd, mmmm d, yyyy)%>

See Date and time variables  for details of the syntax.

Note that this only works with these three variables. If you add format strings to any other

variables the variable will no longer work. Also, you can only use this option by editing

variables in the Help+Manual editor. You cannot use the date and time formatting syntax

in variable definitions. 

See also:
Variables and Conditional Output  (Reference)

Date and time variables

7.3.7 Date and time variables

Key Information
You can only format the date and time with these four

variables that support formatting strings.. 
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Help+Manual supports a number of variables for inserting the date and/or time. Some of

these support special formatting strings with which you have full control over how the date

and time elements are displayed.

Language of the date and time entries

The date and time entries created by these variables will use the language setting of your

Help+Manual project. 

Languages with nominative or genitive date forms

Variables that include time can only write the month names in the nominative form for

these languages, because that is all that Windows allows in combination with the time. If

you need the genitive form use <%DATELONG%> or <%DATE%>, which both write the genit-

ive form, and combine them with a separate time variable. The variables <%NOW%> and <%

TOPICLASTEDITED%> both write the nominative form, because they also include the

time.

All date and time variables

The variables shown in red also support formatting strings (see further below for details).

<%NOW%>: Inserts the current date and time. Returns the

month in nominative form in applicable languages.

Supports a formatting string (see further below for

details).

<%DATE%>: The current date in short format, without the time.

Returns the month in genitive form in applicable

languages. Supports a formatting string (see further

below for details).

<%\DATELONG%>: The current date in long format, without the time.

This also includes long month names, in the genit-

ive form in applicable languages.

<%TIME%>: The current time in short format. 

<%TIMELONG%>: The current time in long format. 

<%MONTHNAME%>: The current month in long format (i.e. February, not

Feb or 2). 
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<%YEAR%>: The current year in 4-digit format. 

<%TOPICLASTEDITED%>: The date and time when the topic containing the

variable was last edited in short format. Supports a

formatting string (see further below for details).

Uses the nominative form for applicable languages.

<%TOPICLASTEDITEDTIME%>: The time when the topic containing the variable

was last edited. 

How to use formatting strings in the supported variables

To use this feature you insert the <%NOW%> , <%DATE%> or <%TOPICLASTEDITED%> vari-

able in your project, either manually or with the Insert Variable tool, and then manually

type a format string in parentheses inside the variable name in the Help+Manual editor: 

<%NOW(format string)%> 
<%DATE(format string)%>

<%TOPICLASTEDITED(format string)%> 

Position and syntax of the format string:

The format string must be inserted in parentheses between last letter of the variable name

and the closing %> characters of the variable tag. The string can contain both "specifiers"

that define the date and time format and normal text. Normal text must be enclosed in

double quotes.

Specifiers may be written in upper or lower case, the result will be the same. 

Examples:

<%NOW("This topic was published on " dddd, mmmm d, yyyy, " at "
hh:mm AM/PM)%>
<%TOPICLASTEDITED("This topic was last modified on " dddd, mmmm d,
yyyy, " at " hh:mm AM/PM)%>

Example result: This topic was last modified on Tuesday, January 3, 2013, at 12:22 PM

The text within the quotes will be inserted exactly as it is written. Any spaces required

must be included within the quotes and the quotes must be separated from the specifiers

by spaces.
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Date and time format specifiers

Specifier Function

" text "

' text '

Anything enclosed in single or double quotes is inserted unchanged as

plain text and does not affect formatting.

. and , You can include periods and commas in the formatting string with the

specifiers, these characters to not need to be quoted.

c Displays the date using the standard Windows short date format, followed

by the time using the standard Windows long time format. The time is not

displayed if the fractional part of the DateTime value is zero.

d Displays the day of the month as a number without a leading zero (1-31).

dd Displays the day of the month as a number with a leading zero (01-31).

ddd Displays the day as an abbreviation (Sun-Sat) using the standard Windows

strings for short day names.

dddd Displays the day as a full name (Sunday-Saturday) using the standard

Windows strings for full day names.

ddddd Displays the date using the standard Windows short date format.

dddddd Displays the date using the standard Windows long date format.

m Displays the month as a number without a leading zero (1-12). If the m

specifier immediately follows an h or hh specifier, the minute rather than

the month is displayed.

mm Displays the month as a number with a leading zero (01-12). If the mm

specifier immediately follows an h or hh specifier, the minute rather than

the month is displayed.

mmm Displays the month as an abbreviation (Jan-Dec) using the standard Win-

dows values for short month names.

mmmm  Displays the month as a full name (January-December) using the stand-

ard Windows values for long month names.

yy Displays the year as a two-digit number (00-99).

yyyy Displays the year as a four-digit number (0000-9999).

h Displays the hour without a leading zero (0-23).

hh Displays the hour with a leading zero (00-23).
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n Displays the minute without a leading zero (0-59).

nn Displays the minute with a leading zero (00-59).

s Displays the second without a leading zero (0-59).

ss Displays the second with a leading zero (00-59).

z Displays the millisecond without a leading zero (0-999).

zzz Displays the millisecond with a leading zero (000-999).

t Displays the time using the standard Windows short time format.

tt Displays the time using the standard Windows long time format.

am/pm Uses the 12-hour clock for the preceding h or hh specifier, and displays

'am' for any hour before noon, and 'pm' for any hour after noon. The

am/pm specifier can use lower, upper, or mixed case, and the result is dis-

played accordingly.

ampm Uses the 12-hour clock for the preceding h or hh specifier, and displays

the contents of the Windows TimeAMString global variable for any hour

before noon, and the contents of the TimePMString global variable for any

hour after noon.

/ Displays the date separator set in your Windows configuration.

: Displays the time separator set in your Windows configuration.

See also:
Using Variables

7.3.8 Counter variables for numbering

You can use counter variables to number anything in your project that needs consecutive

numbering, such as illustrations and so on. There are two kinds of counter variables: User-

defined counter variables, which cannot be referenced, and two special predefined counter

variables for numbered figures and tables, which can be referenced. With these two variables

you can use references like "See Fig. X" or "See Table Y", both in plain text and in hyperlinks. 

Important resriction: Counter variables are not supported in the TOC

Because of the way that counter variables are processed, you can only use them in the

body of your topic texts. If you use them in the table of contents (TOC) the counters will

be incorrect. This is because the TOC is processed separately from the topic files. Since the

counter variables can only be incremented when they are processed, this means that all

counter variables in the TOC will be processed, and then the counter variables in the top-

917
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ics. This means that it is impossible for the count to proceed logically from a variable in

the TOC to the same variable in one of the topics.

You might then assume that you can use counter variables in the TOC if they are only

used there, but that also won't work. The reason for this is that in some circumstances it is

quite possible for the TOC to be processed multiple times when you publish your project.

If this happens, the values of the variables will be incremented every time the TOC is pro-

cessed.

7.3.8.1 User-defined counters

You can define as many user counter variables as you like and you can define the starting

number to be used for each variable, which makes it possible to use the variables across mul-

tiple projects. User-defined counter variables cannot be referenced. They simply provide con-

secutive automatic numbering, with no additional functionality. 

Key Information
If you use a counter variable inside topic or image

captions you must only use it in topic or image cap-

tions. If you also use it in normal topic text the num-

bering will be wrong. (Variables in captions are evalu-

ated in a separate pass when you publish.)

Restrictions of user-defined counter variables

Counter variables are simple counters that cannot be referenced

User-defined variables are quite simple. They will provide you with continuous numbering

but that is all. You cannot "refer" to them with variables in references like "See Figure XX".

See Figure and table counters  for instructions on how to create referencing counters

for figures and tables. 

Counter variables are not supported in the TOC

Because of the way that counter variables are processed, you can only use them in the

body of your topic texts. If you use them in the table of contents (TOC) the counters will

be incorrect. This is because the TOC is processed separately from the topic files. Since the

counter variables can only be incremented when they are processed, this means that all

counter variables in the TOC will be processed, and then the counter variables in the top-

ics. This means that it is impossible for the count to proceed logically from a variable in

the TOC to the same variable in one of the topics.

944
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You might then assume that you can use counter variables in the TOC if they are only

used there, but that also won't work. The reason for this is that in some circumstances it is

quite possible for the TOC to be processed multiple times when you publish your project.

If this happens, the values of the variables will be incremented every time the TOC is pro-

cessed.

How to define user counter variables

User counter variables are identified by two ++ characters at the end of the variable

name. Otherwise counter variables can have any name you like, just like normal user-

defined variables. 

Every time Help+Manual encounters the variable in a project it increases its value by 1.

This means if you want to start with 1 you  must enter "0" as the variable's initial value

when you define it. If you want to start with 10 you must enter "9" and so on (without the

quotes).

1. Define a text variable with two + characters at the end of its name, for example ITEM+

+, VIEW++ and so on. 

2. Set the value of the variable to 0 if you want to start counting at 1, to 89 if you want

to start counting with 90 and so on. (Always one less than the number you want to

use, the value is always incremented whenever the variable is used.)

How to use counter variables

Just insert the variable in the place where you want the count to be displayed. Each time

you use the same variable the variable's last value will be increased by 1. For example, to

number your images just type the counter variable in the image caption field of the Insert

Image dialog with appropriate text, for example 

  The Insert Image dialog (select Write > Insert > Image, or double-click an existing image

to display)
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User variables in image captions:

User-defined variables cannot be referenced. Use the special figure and table counter vari-

ables  for creating numbered figures and tables that you can reference in other places

in your text. 

If you do use user counter variables in image captions it's important to know that they are

evaluated in a separate pass when you publish. This means that if you use a counter vari-

able in an image caption you must never use the same variable anywhere else in the cur-

rent project. You can only use that variable in image captions. If you also use the variable

in other locations the count will be incorrect.

Using counter variables in modular projects

You can use these variables in modular projects. You just need to reset the starting value

of the variables in your child projects if you are using runtime merging in HTML Help.

Publish time merging:

If you are using publish time merging you just need to define the variable in the master

project and then use it throughout all your projects. Publish time merging is the only

available option for all formats except HTML Help. In HTML Help you can choose either

publish time merging or runtime merging,

Runtime merging in HTML Help:

If you are using runtime merging for your HTML Help output you must define the correct

starting values for each variable in the child projects. To do this you need to check the fi-

nal value in the preceding project and set the starting value to that value. 

For example, if the final value of your IMAGENO++ variable in Project A is 63 you need to

define the value of IMAGENO++ in Project B as 63. Then the value will be incremented

correctly to 64 the first time you use the variable in Project B.

See also:
Working with Modular Help Systems

7.3.8.2 Figure and table counters

In addition to simple user-defined counters, Help+Manual also supports specialized figure

and table counters and an additional related user counter. These allow you to create

numbered tables of figures and tables in your projects and to include cross-references to the

individual figures and tables. 

944
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Introduction to figure and table counters

Figure and table counters can be referenced

You can link to and reference figure and table counters with the Figure Link  option in

the Hyperlink Tool. This is also explained further below on this page.

Figure counters in image dialogs

Figure counters can be integrated in image references (both static images and image

toggles). The options for this are included in the normal image and toggle insertion dia-

logs.

\

The Figure <%HMFIGCOUNTER%>: entry is created automatically when you activate the

Add to Table of Figures option. If you edit the Figure text your edit will be used the next

time you use the dialog. See further below in this topic to learn how to use these captions.

Figure and table counters in "figure caption" objects

In addition to the integrated image references you can also create special "figure caption"

objects with the Caption tool. In addition to images, these captions can also be used for

tables (which don't have their own captions) and for your own custom captions for any-

thing else you like. The Caption tool is located in Write > Insert Object.

420
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Here too, the Figure <%HMFIGCOUNTER%>: entry is created automatically when you ac-

tivate the Add to Table of Figures option. If you edit the Figure text your edit will be used

the next time you use the dialog.

These captions are very flexible. They allow you to create numbered references to any

class of items in your project, not just tables and images. For example, you could create a

numbered list of equations or quotations or anything else you like. See further below in

this topic to learn how to use them.

The variables used:

There are three variables used for figure and table counters.  

Counter Variable Where incremented

<%HMFIGCOUNTER%>
· In an image with the option "Add to Table of Figures" 

· In a toggle image with the option "Add to Table of Fig-

ures" 

· In a figure caption of type "Figure" with the option

"Add to Table of Figures" 

<%HMTBLCOUNTER%>
· In a figure caption of type "Table" with the option "Add

to Table of Figures" 

<%HMUSRCOUNTER%>
· In a figure caption of type "User" with the option "Add

to Table of Figures" 
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Smart incrementation

The incrementation of these counter variables is "smart". Their values are only increased in

the locations listed above. If you insert them in the body text of your project or anywhere

else except these "incrementing locations" their values will not be incremented. This

makes it much easier to insert references to your figures, tables and other listed items

than in the past.

Important: The old figure and table counter variables are deprec-
ated!

The <%HMFIGURECOUNTER%> and <%HMTABLECOUNTER%> variables introduced in

Help+Manual 7 will still work, but they are deprecated and no longer documented. If you

have used them in your projects you don't need to replace them immediately. However,

support for them will be removed in the future, so in the long run you should replace

them with the new counter variables described below. Also, any new counters you add

should use the new variables.

The old variables don't support tables of figures and tables

Note that the old variables won't be used in the new tables of figures and tables (see fur-

ther below in this topic for details). You need to update to the new variables for that.

No automatic conversion

Unfortunately, it was not possible to include automatic conversion for the old figure and

table counters. The differences are simply too great. To update existing counters you need

to delete the old ones and create the new ones as described below.

Limitations of the figure and table counter variables

Before Help+Manual 9, referencing these counter variables had to be done manually and

this was subject to a number of limitations. These restrictions have now been removed

with the new figure link tool. See further below for basic instructions and on the Figure

Link  page for full details.420
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Counter variables are not supported in the TOC

Because of the way that counter variables are processed, you can only use them in the

body of your topic texts. If you use them in the table of contents (TOC) the counters will

be incorrect. This is because the TOC is processed separately from the topic files. 

You might then assume that you can use counter variables in the TOC if they are only

used there, but that also won't work. The reason for this is that in some circumstances it is

quite possible for the TOC to be processed multiple times when you publish your project.

If this happens, the values of the variables will be incremented every time the TOC is pro-

cessed.

Using figure counters in image and image toggle dialogs

Images that you insert with the image tool  and image toggles inserted with the toggle

tool  are both classed as figures in your project. You can number them sequentially with

the figure counter, which you can activate in the normal dialog for inserting the image or

toggle. The option for doing this looks the same in both dialogs – this example shows the

image dialog:

Activating the figure counter for an image or image toggle

You do this while inserting an image or toggle, or by double-clicking on an existing image

or image toggle to display its dialog. Just activate the Add to Table of Figures checkbox.

This automatically inserts the text Figure </%HMFIGCOUNTER%> in the caption field. 

The Picture ID

The Picture ID: field is important for links and references to the caption (see further be-

low). A unique ID is generated automatically when you insert an image. You can edit this if

you want to make it more "human readable", and this is generally recommended – it's a

481
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lot easier to know what you are linking to when the ID is widgetexample instead of

FIG58500E9A. Unaccented letters and numbers only, no spaces. 

Important: IDs must be unique in the current topic. If you use the same ID more than

once in a topic your references will not work correctly.

Editing the caption

If you want a different word instead of Figure just edit it. Help+Manual will then remem-

ber this and use your edit in the next caption. You can then add the normal caption for

the image after the : character. That is all there is to it.

Links and references to figures and tables

You can link to figures, tables and caption objects that contain IDs using the Figure

Link  option in the regular hyperlink tool. This works the same way as linking to an an-

chor in a topic. In addition to this, it can insert a reference to the target with its caption

and number.

Limitation: The only limitation of this function is that it must be an active link. You can't

currently create a reference that is just plain text.

Procedure

1. Click where you want to insert the link and open the hyperlink tool. 

2. Choose Figure Link on the left, then select the ID of the topic containing the figure

from the list.

3. Select the ID of the figure from the list next to the Target: field. You will only see IDs

here if the topic contains figures with IDs.

Tip: The preview on the right scrolls to the item with the selected ID.

4. The <\%HMFIGURECAPTION%> variable inserts the caption and counter number of

the target item in the link text.

420
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Resetting counters and adding chapter references

Resetting the counter

If you don't change anything the figure counter will number your figures consecutively

throughout your entire project. If you want to reset the counter, for example to count

from 1 in every chapter, you can do this by adding an = sign and the starting value for the

counter, like this:

<%HMFIGCOUNTER=12%> (resets the figure counter to 12)

<%HMFIGCOUNTER=1%> (resets the figure counter to 1)

Adding chapter references

In addition to resetting the counter you can also include a manual chapter reference in the

counter. There just needs to be a non-numeric character before the actual number you are

resetting the counter to:

<%HMFIGCOUNTER=3-12%> (resets the figure counter to 3-12)

<%HMFIGCOUNTER=II.1%> (resets the figure counter to II.1)

You only need to make this entry in the first instance of the variable where it is used. After

that it will be used automatically until you reset it again. If you are numbering like this you

need to include a reset like this in the first figure reference at the beginning of each

chapter.

Chapter references in the counters are NOT automatic!

Important: Note that you can't use automatic chapter references! In the examples above

the "3" and "II" references will not increment automatically. You need to change them at

the beginning of each chapter when you reset the figure counter.

Using figure captions for images, tables and other elements

Figure captions are the most flexible kind of captions. They are not physically linked to

anything; they are just a special caption with a counter reference in the body of your topic

text. This means you can insert them anywhere in your topics to create captions for im-

ages, tables and any other numbered elements you want to use, list and reference in your

projects. They are created with the Caption tool in Write > Insert Object: 
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Figure captions are independent elements

The figure caption is an independent element. When you create a reference to it you are

referring to the caption, not to the element it is captioning. This means you can position

your caption anywhere you want: above or below an image or table or other element, or

even inside the table you want it to caption. 

Three figure caption types

You can select between three different figure caption types in the caption tool, corres-

ponding to the three counter variables used for the tables of figures: Figure, Table and

User Defined. You 
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Automatic variable selection

When you select the caption type, the corresponding variable is inserted in the Label: field

automatically, along with the default label:

Editing the label

If you want a different word instead of Figure or Table or the standard user text, just

edit it. Help+Manual will then remember this and use your edit in the next caption for that

caption type. You can then add the normal caption for the image in the Text: field. That is

all there is to it.

The ID

The ID: field is important for links and references to the caption (see further below). If you

want to link to your figure captions you need to include an ID. The ID must be unique in

the current topic, otherwise links to the captions won't work. Unaccented letters and num-

bers only, no spaces. 

Important: IDs must be unique in the current topic. If you use the same ID more than

once in a topic your references will not work correctly.

The caption text:

The text in the Text: field is the rest of the caption, which is displayed after the : character.

An inserted caption then looks like this:
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The user counter in figure captions

The User Defined option is only available in figure captions and works in exactly the same

way as the other two counter variables. It makes it possible for you to include both a

counter and a table of figures for a third class of items. For example, if your project in-

cludes formulas you could use it for numbering the formulas and labeling them with cap-

tions that you can refer to:

Everything else works in exactly the same way as the figure and table counters in the fig-

ure captions. See further above for details.

References to figure and table counters

References to these three special figure, table and user counters all work in the same way.

The most important things to know  are where and how these "smart" counters are auto-

matically incremented, and that the counters are not incremented when you use them in

your body text. 

Where the variables are incremented automatically:

Counter Variable Where incremented

<%HMFIGCOUNTER%>
· In an image with the option "Add to Table of Figures" 
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Counter Variable Where incremented

· In a toggle image with the option "Add to Table of Fig-

ures" 

· In a figure caption of type "Figure" with the option

"Add to Table of Figures" 

<%HMTBLCOUNTER%>
· In a figure caption of type "Table" with the option "Add

to Table of Figures" 

<%HMUSRCOUNTER%>
· In a figure caption of type "User" with the option "Add

to Table of Figures" 

Smart incrementation

The values are only incremented automatically in the locations listed above. If you insert

the same variables in the body text of your project or anywhere else except these "incre-

menting locations" their values will not be incremented. This makes possible to insert ref-

erences to them in your body text without having to adjust their values manually.

When references need to be adjusted

If you insert a reference to a figure or table counter directly after the figure or table, you

can just insert the counter variable directly. In that position it will have the same value as

the counter in the figure or table. In some cases, however, you need to adjust the values

because of the position of the reference. This is done with the + (plus) and - (minus) ver-

sions of the variables — see further below for instructions on using these.

Referencing a figure counter AFTER the counter:

Direct reference to a single figure or table

This is the simplest case. If the reference comes after the counter in one of the incrementing

positions, before it is used again for another figure or table, it will always have the same value

as the counter.
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The copy of the variable in the text will have the same value as the variable in the figure cap-

tion, whatever that is. 

Reference to multiple figures or tables

In the following example you need to adjust the value of the reference to the RED figure with

a -1 version of the variable (see further below in this topic for instructions). This is necessary

because the counter has already been incremented again in the caption of the BLUE figure.

The reference to the BLUE figure comes directly after the figure, so its reference does not

need to be changed. 

Referencing a figure counter BEFORE the counter

If you want to insert a reference to a figure or table counter BEFORE the figure or table, you

need to increase the value of the reference to match the incremented counter, like this:
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The reference to the RED figure needs to be increased by 1, because the value of the counter

variable will be 1 higher than in the text. The reference to the BLUE variable needs to be in-

creased by 2, because the counter variable is 2 higher than in the body text position.

Using + and - variables to adjust references

When you need to adjust the value of references to figure and table counters, you do this

with the "plus" and "minus" versions of the counter variables:

Regular Version Plus Version Minus Version

<%HMFIGCOUNTER%> <%HMFIGCOUNTER+%> <%HMFIGCOUNTER-%>

<%HMTBLCOUNTER%> <%HMTBLCOUNTER+%> <%HMTBLCOUNTER-%>

<%HMUSRCOUNTER%> <%HMUSRCOUNTER+%> <%HMUSRCOUNTER-%>

You can either type these variables in manually or insert them with the Variable tool in

Write > Insert Object:
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You then insert the values by clicking in the variable and adding the appropriate number

between the plus or minus sign and the % character:

Generating the tables of figures

In addition to automatic numbering of your images, tables and other elements, these

counters can also be used to generate three tables with lists of all your numbered figures

and their locations in your project:

· Table of figures (the <%HMFIGCOUNTER%> variable)

· Table of tables (the <%HMTBLCOUNTER%> variable)

· Table of user elements (the <%HMUSRCOUNTER%> variable)

Where the tables of figures are available

These tables can currently be generated in PDF and Word DOCX output. The tables will in-

clude all entries for which you have activated the Add to table of figures option. 
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Support in PDF

The tables of figures are configured in the Tables section in the print manual template,

which you edit in Manual Designer : All entries in your project with the Add to Table of

Figures option will be listed in these tables if you have this section configured and activ-

ated in Manual Designer:

There are a number of bands and variables that you can use there. For full details see

Designing a Template > Tables Section in the Manual Designer help (F1 in Manual

Designer).

Support in Word DOCX

In Word you just need to configure the standard Table of Figures and Table of Tables sec-

tions in your Word template, edited in Word. Here too, all the entries in your project with

the Add to Table of Figures option activated will be listed in these tables in your Word out-

put. See Keyword Index, Table of Figures  in the Word chapter for details on setting this

up.

7.3.9 Find and replace variables

You find and replace text variables in exactly the same way as you would  find and replace

normal text. You can replace variables with variables, normal text with variables and variables

with normal text. 

How to find and replace variables

1. Select Find & Replace  in the Edit menu. 

2. To search for a variable or replace text with a variable enter:

<% + VARIABLENAME + %>

For example if your variable is called DEMOBUILD you would type:

805

689

235
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<%DEMOBUILD%>

When you insert or replace variables with Find and Replace the variables are not high-

lighted in the topic text. This is exactly the same as typing in variables manually  – the

variables are still fully functional, they are just not highlighted in the text. (The highlight is

just an editing convenience to make the variables easier to see.)

See also:
Variables and Conditional Output  (Reference)

7.3.10 Variables in HTML templates

The HTML templates that generate the pages in Help+Manual's HTML-based output formats

(HTML Help, WebHelp, Windows Exe and ePUB eBooks and Visual Studio Help) make extens-

ive use of variables. You can use all global predefined variables and all your user-defined vari-

ables in your HTML templates

There are also a number of special predefined variables for use in these templates only. For

details on these variables and how to use them see Variables in HTML templates . 

User-defined variables in HTML templates and skins

In WebHelp, all your user-defined variables are exported as JavaScript variables in a .js

file called hmvariables.js. This file combines both the user variables defined in your

project and those defined in your WebHelp skin, if you are using one. If the same variable

is defined both in your project and your skin the definition in the skin takes precedence

and gets exported to the .js file. 

You can make these variables available for use in your scripts in your templates by loading

this file prior to referencing the variables, like this:

<script src="hmvariables.js"></script>

The variables are stored in an object called hmConfigVariables  and the variables

themselves are stored in all upper case. So if you have a variable called PROJECTVERSION

you would reference it as:

hmConfigVariables.PROJECTVERSION

The values are always strings. If you want to use the values as numbers, Boolean values

etc. you need to convert them before using them. 

HTML variables in HTML templates and skins

HTML variables are primarily designed for use in HTML templates and HTML code objects

– you can use them in other locations but then only the text portion of the variable value

will be inserted. 
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The code stored in the HTML variable must make sense in the template, of course, you are

entirely responsible for that!

Don't edit HTML templates if you don't understand HTML!

Any changes you make to the HTML templates are not checked for plausibility or syntax

errors. You are entirely responsible for all the code you enter and all the changes you

make. Making changes to the template code without knowing what you are doing can

cause serious errors and malfunctions.

See also:
Using HTML Templates

Variables in HTML templates  

Conditional output in HTML templates   

The power of editable variables

Variables and Conditional Output  (Reference, lists of available variables and conditions)

7.3.11 Redefining variables

You can always change the definitions of your variables individually in Configuration > Com-

mon Properties > Text Variables in the Project Explorer. In addition to this you can set differ-

ent values for specific variables in  individual topics. When you publish your project you can

also redefine some or all of the variables in your entire project with a project skin or a variable

definitions file. 

How to redefine variables in individual topics

If you want a variable to have a different value in individual topics you can redefine it in

the Topic Options tab on the left of the main editor window when the topic is selected.

Note that this is only possible with user-defined variables. You cannot define

Help+Manual's standard variables with this feature. 

1. Select the topic in the Project Explorer, then select the Topic Options tab on the left of

the main editor window. 
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2. Click on the + button next to the Topic Variables box at the bottom of the window.

3. Select the variable you want to redefine and click OK, this adds the variable to the

Topic Variables list.

4. Click in the Value field and enter a new value. The values you enter here will only be

used in the current topic. 

See The power of editable variables  for more information on the kind of things you can

do with this feature.

How to redefine some or all variables when you publish

When you publish your project you can redefine some or all of the variables in the entire

project in two different ways: With "skins" and with the command line compilation feature.

Redefining variables with publishing tasks

The Publishing Task Manager makes it possible to define "tasks" to publish your project to

multiple output formats and destinations in a single integrated operation. In addition to

this you can also redefine the variables in your project when you publish the task with a

list of alternative variable definitions. See Publishing to multiple formats  for instruc-

tions.

Redefining your variables with skins:

Note that you can also assign skins to publishing tasks . 

1. Create a project skin (only possible with Help+Manual Professional) containing the al-

ternative definitions of your variables (and anything else you want to change in your

963
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project). If you only want to redefine your variables you can create a skin that only

contains your variable definitions. See Transforming Your Output with Skins  for

more details. 

2. When you publish your project  to an HTML-based output format select the skin file

in the Publish  dialog. 

Note that skins can't be selected in the Publish dialog in non-HTML formats – you need to

use command line publishing (see below) for those formats where skins are not directly

available. 

Redefining your variables from the command line:

You can also create a simple text file containing a list of definitions of the variables you

want to change. You can then specify this file in the command line to redefine all the vari-

ables in your project with the values in the file. 

In addition to this you can also specify a project skin file in the command line, to apply a

completely different appearance to the entire project as well as redefining the variables. 

For more details on the procedure for redefining variables see Skins & redefining vari-

ables  in the Command Line chapter and Transforming Your Output with Skins .

See also:
Variables and Conditional Output  (Reference)

Transforming Your Output with Skins

Command Line Options

Skins & redefining variables

7.3.12 Variables in style repositories

If you define variables in a style repository  they will also appear and be available in the

projects to which the repository is linked. When you link the repository, all the variables in the

repository that do not exist in the project are copied to the project. Variables that already ex-

ist in the projects are left unchanged; their values do not update with different values from

the repository.

At present, this is really just a convenience for sharing variables to multiple projects. The val-

ues of the variables are not dynamically linked, even if the styles are. The values of the vari-

ables in your projects will NOT update when their values are changed in the repository. This is

the same as existing variables in the project, which are not updated with the values of reposit-

ory variables when you link a repository.

The only way to force the values of a variable in a project to update with a changed value in

the repository is to delete the variable in the project. Then the variable will appear again with

the new value from the linked repository the next time the project is loaded. However, this is

not really very practical, because you would need to do this for all the variables in all your

projects every time you change the values of the variables in the repository.
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7.3.13 The power of editable variables

Help+Manual's variables have several features that make them extremely powerful and flex-

ible:

· You can define variables as HTML variables or as plain-text variables

· You can redefine user variables on a per-topic basis

· You can redefine user variables for your entire project with publishing tasks

These features are particularly powerful when you are generating HTML-based output. For ex-

ample, you can perform search engine optimization on a per-topic basis and you can add in-

dividual JavaScript code to the HTML templates of every topic. We are sure that you will come

up with additional uses for this powerful feature – experiment! 

Key Information
HTML variables only insert HTML code in HTML tem-

plates and HTML code objects. If you insert an HTML

variable in the body of your topic only the text portion

of the variable value will be used.

How to redefine variable in individual topics

Only redefine user-defined variables with this method. Although redefining global vari-

ables can sometimes work, this is not guaranteed and it should generally be avoided. In-

stead of redefining a global variable, define a user variable for your chosen purpose and

insert the global variable as the original definition of the user variable. Then you can re-

define the user variable when necessary.

1. Define an HTML or plain-text variable. 

2. Insert the variable in a topic, an HTML template or an HTML code object. 

3. Select a topic in the Project Explorer, select the Topic Options tab on the left of the

main editor window and redefine the variable in the Topic Variables table – just click

on the + button, select the variable you want to redefine and then enter a new value

for it.
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Tip: You can insert multiple variables at the same time by selecting them with SHIFT+Click

and CTRL+Click in the list displayed when you click on the + button.

The value you enter for the variable in the Topic Options tab will only be used in the cur-

rent topic.

Redefining variables in publishing tasks

When you publish your project with publishing tasks you can also redefine any user-

defined variables in your project for individual tasks. See Automating Publishing Jobs

for full details on working with tasks. See Redefining variables  for full details on the

various methods available for redefining variables.

1. Define a publish task with one or more publishing actions for the output format(s) and
destination(s) you want to create. 

2. Double-click on the publishing action in the task list to edit it and select the Custom
Variables tab.

3. Edit the values of the variables you want to change.

Per-topic redefinitions have priority over publishing redefinitions!
Variables redefined in publishing tasks will not change variables that you have already re-
defined in individual topics. Since the per-topic redefinition is always evaluated last, it al-
ways has priority.

How to do per-topic search engine optimization

All your topic keywords are automatically included in your topic page head section in a

<meta> keywords tag. However you may want to add additional meta information your-

809
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self to fine-tune your site's search engine performance. You can do this with editable

HTML variables. This simple example shows you how to do this.

1. Define an HTML variable and enter the HTML code for your meta tag as the variable's

value, for example: 

<meta name="description" content="<%TOPIC_HEADER_TEXT%>" />

Using the <%TOPIC_HEADER_TEXT%> variable as the default value for the content at-

tribute means that you won't have to edit the description for every single topic, just

for the topics where you want to include additional information in the description. 

2. Insert the variable in the <head> section of your HTML topic page template in the po-

sition where you want to insert the meta tag (see Using HTML Templates  for de-

tails). Let's assume you have called the variable <%METADSCR%>:

<head>
<title><%TOPIC_TITLE%></title>
<meta name="generator" content="Help &amp; Manual" />
<%METADSCR%>
...

If you do nothing else every topic will now contain the text from the topic header as

the meta description text. Next you want to redefine this text for individual topics.

3. In the Project Explorer select the topic for which you want to redefine the meta tag.

Select the Topic Options tab on the left of the main editor window, click on +, select

the <%METADSCR%> variable from the list and then enter the new code that you want

to insert. That's it. (Using words defined as keywords in the description is often help-

ful.)

1026
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This is a very simple example that just demonstrates the basic principle. Variables are so

flexible that you can find a number of different ways of doing this: For example, instead of

using an HTML variable for the entire line of code you could define <%METADSCR%> as a

plain-text variable, enter <%TOPIC_HEADER_TEXT%> as its value and use it like this:

<meta name="description" content="<%METADSCR%>" />

If you do nothing the topic header text is still inserted as the description. To redefine the

content for individual topics you then just need to enter the new description text, not the

entire line of code.

How to insert individual script code in topics

When you add your own JavaScript functions to your topics it is generally good practice

to add the functions to the <head> section of your HTML page template and call the

functions from within the topic with HTML code objects  inserted in the topic. If you

need different code functions in individual topics you can achieve this with editable vari-

ables.

Variables containing the actual code:

This assumes that you are going to insert the entire body of your JavaScript code in the

<head> section of your HTML topic page template.

1. Define an HTML variable and paste your entire JavaScript code block in as the variable

value, including the opening and closing <script> tags if appropriate. 

469
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You can insert as much code as you like but it cannot include line breaks so you must

use semicolons to terminate all statements and then remove all line breaks in your ed-

itor with search and replace before copying and pasting.

2. Insert the variable in the appropriate position in your HTML topic page template (see

Using HTML Templates  for details). For example, suppose you want to add a block

of code with a variable called <%JS_USERPOLL%>:

<meta http-equiv="Content-Style-Type" content="text/css" />
<link type="text/css" href="<%STYLESHEET%>" rel="stylesheet" />
<%JS_USERPOLL%>
</head>

3. To redefine the code for an individual topic select the topic in the Project Explorer and

select the Topic Options tab on the left of the main editor window. Then click on +, se-

lect the <%JS_USERPOLL%> variable from the list and paste in the new code that you

want to insert as the new variable value. That's it.

Of course, you could also use variables within your JavaScript code to replace just part of

the code on a per-topic basis.

Variables containing a reference to a .js file:

This assumes your code is contained in an external .js file that you are referencing in

your HTML topic page template.

1. Save the different versions of your JavaScript code in text files with the extension .js

and add all the files to your Baggage Files  to ensure that they will be exported cor-

rectly when you publish your project. 

2. Define a plain-text variable and enter the name of the main JavaScript file (the one

that will be used in most topics) as the variable value.

3. Add the include reference to your HTML topic page template (see Using HTML Tem-

plates  for details) and use the variable instead of the name of the JavaScript file .

For example, suppose the variable is called <%JS_FUNCS%>:

<meta http-equiv="Content-Style-Type" content="text/css" />
<link type="text/css" href="<%STYLESHEET%>" rel="stylesheet" />
<script type="text/javascript" src="<%JS_FUNCS%>"></script>
</head>

4. To select a different JavaScript file for an individual topic select the topic in the Project

Explorer and select the Topic Options tab on the left of the main editor window. Then

click on +, select the <%JS_FUNCS%> variable from the list and enter the name of the

alternative JavaScript file as the new variable value. That's it.
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Redefining the <title> tag and template variables

The <title> tag:

You can redefine the current topic's <title> tag directly in the Topic Options tab on the

left of the main editor window, in the <TITLE> Tag: field. The contents of this field are nor-

mally the same as the topic caption from the Table of Contents but if you edit it here the

edited version will be inserted in the <title> tag in your HTML-based output, and this

too can be useful for search engine optimization. 

Other redefinable template variables:

Note that you can also redefine a number of HTML template variables on a per-topic basis

with the Topic Variables section in . For example you can also redefine <%TOPIC_TITLE%

> (normally returns the TOC caption of the topic), <%TOPIC_TITLE_PATH%> (the path to

the current topic in the TOC of the project) and <%TOPIC_HEADER_TEXT%> (the text from

the header box above the editor). 

See HTML template variables  in the Reference section for more details of the special-

ized HTML template variables available. 

How to redefine all your variables

You can also take redefining variables a step further: You can redefine all the variables in

your entire project when you publish with a project skin or variable definition file. 

For full details on this see Transforming your output with skins  and Skins & redefining

variables . The skins method can be used from the Publish dialog and it can also apply a

completely different layout and style to your entire project. The variable definition file

method can only be used from the command line but it can also be used to redefine

global variables, which is not possible with the skin method.

See also:
Redefining variables

Transforming your output with skins

Skins & redefining variables

HTML template variables  (reference)

7.3.14 Variables in PDF templates

You can use all predefined global variables and your user-defined variables in text objects in

your PDF templates. 
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In addition to this there are large number of special predefined variables for use in PDF tem-

plates only. These are described in the help of the Print Manual Designer program used to

edit the PDF templates that control the formatting of your PDF output and printed manuals. 

To start this program look in the Project > Tools tab and then select the Manual Designer

option under the Templates & Skins heading. If you have already used a print manual tem-

plate with the current project you will be able to open it directly in Manual Designer from this

menu.

How to use text variables in PDF print manual templates

Just type the variable into the text of the text object. Always type the variables exactly as

listed, complete with the opening <% tag and the closing %> tag – for example <%TITLE%

> or <%VERSION%>.

· For more details see the help included with the Print Manual Designer program.

· HTML variables will work without modification in PDF documents but they will only in-

sert the plain-text portion of the variable value – if there is no plain-text portion nothing

will be inserted.

See also:
PDF and print manual templates

PDF and Printed Manuals

7.4 Conditions and Customized Output

There are many situations where you may want to generate different output versions of your

projects with different content. You might need different versions of your documentation for

light and professional versions of a program, or specific products might have different names

in different versions. 

It is also often necessary to change your content to adapt it to the output format. For ex-

ample, some texts that are suitable in the electronic HTML Help version of the help might not

make sense or might need to be expressed or formatted differently in the PDF print version.

See also:
Using Variables

Variables and Conditional Output

Conditional output in HTML templates

7.4.1 How conditional output works

Help+Manual projects are made up of chapters, topics and the content of topics. You can use

conditional output to include or exclude content on all these levels: Entire chapters, topics or

specific content within topics. You do this by "tagging" chapters, topics and content with con-

ditions known as "include conditions" or "build conditions". Then when you publish your pro-
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ject you select or deselect the matching tags in the Publish dialog  to include or exclude the

tagged content.

This is a two-step process, which is outlined below. For full details please study the rest of this

chapter.

Step 1: Tag your content with include conditions

This step identifies the content you want to include or exclude when you publish. You can

tag the content with format conditions (PDF, CHM, HTML etc.) or user-defined conditions

(for example DEMOBUILD, BILLS_VERSION, FUTURE_FUNCTIONS). 

Tagging content in topics

This is done with the  Conditional Text Tool in Write > Insert Object. This tool places

"conditional text" tags at the beginning and end of the content you want to include or ex-

clude, using an IF ... END syntax. For example IF_PDF ..... END, or

IF_PDF,HTML,CHM ... END and so on

Tagging topics and chapters

This is done with the Change > Include in Builds settings in Project > Manage Topics.

These settings can also be accessed by right-clicking on topics in the Table of Contents or

Topic Files sections of the Project Explorer. 

Note that if you tag a chapter with build conditions the tags will not be set for all the

chapter's sub-topics. You need to multi-select all the topics for which you want to apply

conditions. 

Step 2: Select the include options when you publish

When you publish your project you then select or deselect the available include options in

the Publish dialog. Format conditions are selected automatically, so if you are publishing

to PDF all content tagged with IF_PDF will be included in your output. 

User-defined conditions must be selected manually: For example, to include all content

identified with DEMOBUILD you need to select the DEMOBUILD option in the Publish dia-

log, and to exclude it from your output you deselect it.

7.4.2 Multiple TOCs

Help+Manual's conditional output features can create a wide range of variants of your project

for different purposes. However, it is difficult to create versions with TOCs that have very dif-

ferent structures using only conditional output. The multiple TOC feature solves this problem.

It allows you to create completely different TOCs with a different structure and different
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entries for different purposes.

The entries in your additional TOCs can point to the same topic files as in your main TOC. Or

they can have their own topic files that only exist in that TOC. When you publish you choose

which TOC you want to use, and only the topics referenced by that TOC are exported – in

some cases along with topic files linked to in those topics, to prevent dead links.

See Publishing projects with multiple TOCs  for details on selecting specific TOCs when you

are publishing your projects. Also see the Multiple TOCs tutorial project that you can access

directly in the Welcome page at the top of the Project Explorer on the left.

How to create an additional TOC

1. Right-click on the Table of Contents entry at the top of the Project Explorer on the left

and select Create new Table of Contents in the context menu. 

2. This opens the New TOC dialog:

629
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3. Enter a descriptive title for the new TOC and choose whether you want it to be empty

or a copy of the current TOC. If this is your first additional TOC you probably want it to

be empty rather than a full copy of the entire TOC. Later you may want to make copies

of existing additional TOCs that you then edit.

4. Then create new entries in the new TOC in any of these ways:

o Drag items from another TOC into the new one (onto the empty node if it doesn't

yet have any entries). This does not create new topics. It only creates new refer-

ences to existing topics.

o Copy and paste from another TOC.

o Create new entries with the Add Topic tool in the Project tab. If you use the TOC

Link option it creates new entries for existing topics. If you use the New Topic op-

tion you will create completely new topics.

IMPORTANT: The "main" TOC always includes all topics!

To maintain compatibility with existing projects, the "original" or "main" TOC in your pro-

ject will always include all topics when you publish with it. If you remove TOC entries from

it without explicitly excluding the topic files that no longer have TOC entries (by using

build options ), those files will still all be included in the background in HTML output989
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when you publish with the main TOC. They can then be found by search and the keyword

index. 

This only applies to CHM, WebHelp, eWriter and Visual Studio Help output. It doesn't ap-

ply to PDF, DOCX and eBooks, because there only topics that have TOC entries can ever

be included.

Only secondary TOCs automatically exclude the topics for which they do not have

TOC entries!

If you want to create an alternative TOC with a reduced or different set of topics, always

do this with a secondary TOC, not with your "main" or "original" TOC (the top one). Again:

The main TOC is always complete. If there are topic files without TOC entries in the project

they will be included in the background when you choose the main TOC unless they have

explicit build options that exclude them.

Use build options to to include hidden topics with secondary TOCs

By the same token, topic files without TOC entries will not be included automatically in the

background with secondary TOCs. Then, a topic file without an entry in the current TOC

will still be excluded even if it is set to "all builds". It will only be included if you explicitly

set a specific build option on it and activate that in the include options for the publishing

operation. 

Popups in secondary TOCs

When you use popup topics in secondary TOCs the popup topic files your links refer to

will not be included automatically as they are when you use the primary TOC. The All

Builds include option assigned to all topics by default only works automatically in the

primary TOC. 

When you are using multiple TOCs in your project and publishing a secondary TOC, any

popup topics you link to must be included explicitly. You can do this in two different ways:

Option 1: Dead links handling options

Go to View > Program Options > Compilers and set the dead links handling option to Si-

lently include linked topic. This is the simplest solution but it will also automatically include

any excluded topic files that you may have referenced with regular topic links. So you

should always check your compiler report for topics like these that you may have not

wanted to include. You can then handle the links with conditional text  to exclude them

automatically. 

984
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Option 2: Set the build options of your popup topic files

Alternatively you can set the build options of your popup topic files to the output formats

that support popups, which are WebHelp, CHM, eWriter, and Visual Studio Help (if you are

using that). The eWriter format will be included automatically if you set WebHelp, so gen-

erally you will only need to set CHM and WebHelp. 

1. Right-click on the popup topic file in Project Files > Topic Files and select Include in

Builds in the context menu. 

2. Set the include options to WebHelp, CHM and (if necessary) also VSHelp. 

3. Repeat for all your poup topic files.

Managing links to excluded topics in additional TOCs

When you create a TOC that is a subset of the main TOC, your topics will often contain
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links to topics that are not in the new TOC. You need to take steps to deal with these links

to ensure that they are not dead and so that they do not accidentally provide access to

content you don't want to include in the version with this TOC.

Failsafe: Global options for links to excluded topics 

You can set a global option for how links to excluded topics are handled in View > Pro-

gram Options > Compilers. There are three choices:

· Silently include linked topic

In HTML-based output formats this exports the topic file without a TOC entry so that

the link displays the topic. In PDF and DOCX this has no effect, because only topics that

are in the TOC can be in the document.

· Remove link

This turns the link into plain text. The referenced topic is not exported.

· Allow links to be dead

This leaves the links unchanged in the topics but does not export the linked topic files.

So either nothing happens or an error message (404) is displayed when the user clicks

on the link. This can be good "protection" if you are managing the links with conditional

output, to make sure that the excluded topics are never seen.

Use conditional output to replace the links with alternative text

This is basically the same approach you would use for handling the same problem in nor-

mal conditional output scenarios where topics are excluded. See this topic  for full in-

structions. 

Create conditional output build options for your additional TOCs and apply them to the

links to the external topics so with the Conditional Text tool. You can use this method to

either remove the references entirely, or replace them with alternative text or alternative

links in the version with the additional TOC. 

For example, suppose you have a TOC for a specific client. You could create a conditional

build option called CLIENT_B and then tag the link with it like this:

This inserts the first link if you are not exporting the CLIENT_B version and the second

link if you are. 

Setting the default topic with multiple TOCs

If you are using multiple TOCs in your project you can set a separate default topic for each

984
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TOC. Then you will automatically get the correct default topic for that TOC when you use

it.

See Setting the default topic  for full details on setting and managing the default topic

for your project.

Important: The default for secondary TOCs must be set in the TOC

Default topics for secondary TOCs must be set directly in the TOC. The setting in Config-

uration > Common Properties > Language Options is only for the main TOC. 

Each TOC you define can have its own default topic. Just right-click on the topic you want

to use as the default in the TOC and select "Set as Default Topic" in the context menu.

More granular control of output with include options on topic files

In addition to the conditional output tagging inside topics described above, it is also pos-

sible to apply include options to the topic files referenced by the links but not to the TOC

entries in the main TOC pointing to them. This is possible because TOC entries and topic

files are separate items and each can have their own build options.

Consider this example:

128
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This would allow you to include the Overview topic file with your additional TOC by activ-

ating the build option CLIENT_B in your publishing settings, even if it does not have a

TOC entry. 

You can do this if you activate the global option "Allow links to be dead" to handle the

majority of links, but have a few links for which you do want to include the linked topics,

for example. 

What happens to topics like this in Word and PDF output?

When you then publish the normal TOC that includes the Overview entry to PDF or Word

you have a logical discrepancy: The TOC entry says to include it, but the topic file include

option says to exclude it. That is OK, because in those formats only topics with TOC entries

are included and the TOC entry setting then has priority. The topic will thus be included

normally.

Topics without TOC entries in additional TOCs

When you use topics without TOC entries  in combination with additional TOCs you

may need to take additional action to ensure that the topic file is included in your output.

An additional TOC acts like an include option for every topic it includes, and by default all

other topics can be excluded. Because of this, topic files that are only accessed by hyper-

179
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links and not by TOC entries may get excluded if you are not careful.

Method 1: Use the compiler option to force inclusion

This is the simplest solution. It tells Help+Manual to automatically include any topic file

that is referenced with a link in your project. Just go to View > Program Options > Com-

pilers and set the Handling of dead links option to Silently include linked topic. This will in-

clude all topic files referenced with hyperlinks, even if they don't have TOC entries. The in-

cluded topic files will be listed in the compiler report.

Side-effect: This will also include topics that were excluded from the TOC with build op-

tions, if there are links to those topics that you have overlooked. Check the compiler re-

port!

Method 2: Use a user-defined include option

Alternatively, you can define an include option  with a descriptive name like NONTOC or

something like that and apply it to the topic file  in the Topic Files section. Then you just

need to activate that option  in the Publish screen when you publish. Then all topics

tagged with that option will be included in your output. 

Creating TOC entries for "invisible" topics in PDFs

PDF is a special case because only topics with TOC entries can be included in PDF docu-

ments. If your project contains "invisible" topics that are normally only displayed with hy-

perlinks from other topics you must add TOC entries for them to be able to include them

in the PDF version of your output. This is very simple to do with the knowledge you now

have:

1. Create TOC entries for the "invisible" topics: Either drag the topic file into the TOC or

create a "new" topic and select the topic ID of the invisible topic with the  browse

button in the Topic ID: field of the new topic dialog. You might want to organize these

TOC entries as one or more special chapters in your TOC. 

2. Apply build options to the new TOC entries so that they are only included in the PDF

version of your output. See See Including and excluding TOC entries above for instruc-

tions.

How to "filter" the TOC display by build/include options

You can use include options to "filter" the display of your topics in the TOC and Topic Files

section of the Project Explorer. This makes it possible for you to see only the topics that

988

991

983



979

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

More Advanced Procedures

will be included in a specific build, so that you can preview the results of specific build op-

tions without publishing your project.

1. Apply build options to one or more topics. If you don't do this filtering will not have

any effect! See Conditions and Customized Output  for details. 

2. Select Explore > Filter in Project > Manage Topics and set the filter options you want

to apply. The filter settings are also available from the right-click menu in the Project

Explorer (Explore > Filter).

This works both in the TOC and in Topic Files. This only filters entire topics, it does not

filter conditional text tagged within your topics.

Important Notes:

· The current build settings of topics are shown in the Project Explorer, next to the topic

caption in the TOC. Topics and chapters set to All Builds (the default) will always be in-

cluded, of course – you cannot hide them.

· Filtered topics will be either shown in a different color or hidden completely. This de-

pends on your settings for When filtering the table of contents... in View > Program Op-

tions > General. See Program Options - General  for details on these settings.

See also:
Preventing dead links  (Conditional Output)

Publishing projects with multiple TOCs  (Publishing)

7.4.3 About include options

Using include options gives you very fine control over what you include and exclude in your

published output. You can "tag" chapters, topics and content within your topics with include

options. 

When you generate your output you then select the corresponding include options in the

Publish  options to include or exclude the items tagged with those options from your pub-

lished output.  

Including/excluding topics and content – "Include in Builds" and the
Conditional Text tool

You can tag both topics and content within topics with include options. Different methods

are used in each case.

· Topics are tagged with Change > Include in Builds in Project > Manage Topics. 

· Content is tagged with the  Conditional Text tool in Write > Insert Object.
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Format include options and user-defined include options

There are two different kinds of include options, those based on your publishing format

and those defined by the user. The format-based options are used to create different ver-

sions on the basis of your output format – for example alternative text for the PDF ver-

sion. The user-defined options are used to create fundamentally different versions of your

project – for example for different versions of your product or for different customer

groups.

Format-based include options:

These include options are predefined. They correspond to the output formats supported

by Help+Manual. For example, if you tag an item or topic content with the HTML Help op-

tion it will only be included when you  publish to HTML Help. However, they are not abso-

lutely fixed to the output format: It is quite possible to include content tagged for CHM in

another format if you want at publish time. You just have to activate the CHM include op-

tion in the Publish page. 

You can optionally select the include options for other output formats if you also want to

include content that is actually tagged for those formats. For example, when you publish

to CHM the CHM include option is selected by default. If you also want to include content

that you have actually tagged to be included only in WebHelp you can do that by manu-

ally activating the WebHelp checkbox as well. 

User-defined include options:

These include options are conditions that you define yourself. you can define as many of

them as you want. you can tag text and topics with them in exactly the same way as with

the format-based options. they are defined in Configuration > Common Properties >

Custom Builds. 

When you tag content with a user-defined include option it will only be included in your

output if you activate the corresponding option in the Publish  options. Otherwise it will

be excluded.

Special case: Include options for eWriter Help

eWriter Help is a special case, because internally they are classed as both eBooks and We-

bHelp. Their content is exactly the same as WebHelp and supports nigh on all the format-

ting and scripting that WebHelp supports. However, they are – or can be – distributed in

the same way as eBooks. Because of this, eWriter is the only output format that has two

1310



981

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

More Advanced Procedures

active include options for including and excluding content: both EBOOK (eBooks) and

HTML (WebHelp).

If you look at the Include Options box in the Publish dialog when you publish to eWriter

you will see that both the WebHelp and the eBook options are selected. This means that

an eWriter Help file will normally include any content tagged for either WebHelp or

eBooks.

Including content in eWriter Help only

If you want content to be include only in eWriter Help you need to nest two conditions

around it, like this:

IF_HTML IF_EBOOK ... END END

Then it will only be included in eWriter Help and nowhere else.

Include options for topics and chapters 

Topics and chapters will be included in eWriter Help if they are tagged with either We-

bHelp or eBook. 

Other conditional output features

In addition to include options you can also control and vary your output with alternative

TOCs , variables , HTML template conditions , and modular projects . 

For more background information see the Variables & Conditional Output  chapter in

the reference section and the Working with Modular Help Systems  chapter.

Important: Include options use OR logic

It is crucial to understand is that conditions use OR logic. This means that only one condi-

tion needs to evaluate true to include or exclude the content it refers to. If multiple condi-

tions are true the corresponding content will also be included but only one condition is

needed to enable inclusion.

This means you need to be careful with tagging using multiple conditions. For example, if

you tag a topic for both CHM (HTML Help) and TEST_BUILD you will never be able to ex-

clude that topic from your HTML Help output, because the CHM tag will always include it.
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Topics and chapters:

· By default, all new topics are tagged with the option ALL Builds. This means that they

will always be included. 

· If you tag a topic with a format condition (e.g. CHM) that topic will only be included in

that output format.

· If you tag a topic with a format condition (e.g. CHM) and a user-defined condition (e.g.

TEST_BUILD) that topic will always be included in the matching output format. In addi-

tion to that, it will also be included in any other output formats when you activate the

corresponding include option in the Publish  options.

· IFNOT simply reverses the logic – IFNOT CHM includes content in all formats except

HTML Help.

Content in topics

· By default all topic content is included in all output unless it is explicitly excluded with

conditional text tags.

· Tagging content with a format condition only includes that content in that output

format.

· Tagging content with a user-defined condition only includes that content when the

matching condition is activated in the Publish  options. 

· Here too, IFNOT reverses the logic – IFNOT HTML includes the tagged content in all

formats except WebHelp.

7.4.4 Using conditional output

Conditional output works in the same way on all the levels where it is supported: You mark a

part of your project (text, graphic, topic, chapter etc.) with a condition, referred to as an "in-

clude option" or "build option", and then choose whether you want to apply the condition

when you publish your project.

Productivity Tip
You can search and replace conditional text tags. Just

select "Conditional Texts" in the "Find where:" field

when you search. See Searching  for details.
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Step 1: Tag topics or content with conditions

Tag a topic or chapter

1. Select the topic or chapter in the TOC in the Project Explorer. 

2. Select Change > Include in Builds in Project > Manage Topics and select the condi-

tions you want to apply. (You can also access these options by right-clicking on a topic

in the Project Explorer.)

3. If you are excluding a topic right-click on the topic entry in the TOC and select Check

Referrers to see whether any other topics link to the topic you want to exclude. If so,

you need to use the Conditional Text tool (see below) to exclude any links to the topic

and replace them with alternative text when the topic they link to is excluded.

When you tag chapters their sub-topics will not be tagged with the same conditions auto-

matically – you need to use multi-select to tag multiple topics at the same time. See Topic

include options  for full details.

Tag content in a topic

1. Select the text you want to tag in the editor. 

2. Select the Conditional Text tool with Write > Insert Object >  and choose the op-

tions you want to apply. 

See Conditional text include options for full details . Also, there are additional features

for conditional text in tables. See Conditional text in tables  for details. 

Step 2: Activate the condition when you publish

Remember that include options use OR logic! The content will be included if one or more

of the selected include options applies when you publish.

Publishing to single formats and destinations:

When you publish your project select the include options that you want to apply in the

Publish  options. You can choose to apply individual options, combinations of options,

all options or no options for every publish run. See Publishing to one format  for details.

Include options based on output format are activated automatically when you select that

format. For example, when you publish to HTML Help the HTML Help include option is

activated.
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Publishing to multiple formats and destinations:

You can also apply include options to publishing tasks when you are publishing to mul-

tiple destinations and output formats. You can define individual include options for each

publishing action in your publishing tasks. See Automating Publishing Jobs  for details.

How to "filter" the TOC display by build/include options

You can use include options to "filter" the display of your topics in the TOC and Topic Files

section of the Project Explorer. This makes it possible for you to see only the topics that

will be included in a specific build, so that you can preview the results of specific build op-

tions without publishing your project.

1. Apply build options to one or more topics. If you don't do this filtering will not have

any effect! See Conditions and Customized Output  for details. 

2. Select Explore > Filter in Project > Manage Topics and set the filter options you want

to apply. The filter settings are also available from the right-click menu in the Project

Explorer (Explore > Filter).

This works both in the TOC and in Topic Files. This only filters entire topics, it does not

filter conditional text tagged within your topics.

Important Notes:

· The current build settings of topics are shown in the Project Explorer, next to the topic

caption in the TOC. Topics and chapters set to All Builds (the default) will always be in-

cluded, of course – you cannot hide them.

· Filtered topics will be either shown in a different color or hidden completely. This de-

pends on your settings for When filtering the table of contents... in View > Program Op-

tions > General. See Program Options - General  for details on these settings.

See also:
Variables and Conditional Output  (Reference)

Publishing Your Projects

Managing topics in the Explorer

7.4.5 Preventing dead links

Excluding topics from your output can create dead hyperlinks. If there are links to the ex-

cluded topics in other topics, those links will not have any targets and will produce errors or

do nothing when the user clicks on them. You need to plan your project to prevent this from

happening.
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Help+Manual has several functions that can help you to prevent and eliminate dead hyper-

links caused by excluding topics. If you use them correctly you can easily locate all potential

dead links and automatically replace them with alternative text or links.

How to use Find Referrers to locate potential dead links

Whenever you set an include option to exclude a topic you should always use the Find Re-

ferrers function to check for any links to the excluded topic in other topics. 

1. Select the topic you plan to exclude in the Project Explorer. You can select either a

TOC item or a topic file. 

2. Right-click on the topic name in the Project Explorer and select Find Referrers in the

context menu. Alternatively you can also select Find > Find Referrers in Project > Man-

age Topics.

3. This displays the topic referrer report. Double-click on its title bar to display it in an ex-

ternal window, this makes it easier to use (double-clicking on the title bar again re-

docks it to the Help+Manual window):

Links to the topic in other topics are listed in the Is referred by column. The Links to

column only shows topics that the current topic links to, which you don't need to

worry about here.

4. Click on the links in the Is referred by column to display the topics so that you can use

conditional text to eliminate dead links (see below). When you are finished you can re-

turn to the current topic by clicking on its link in the Topic column.
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How to use Conditional Text to replace dead links

When you exclude topics from your published output you do this with include options.

You can prevent dead links to the topic by using the exactly the same include options to

also exclude the hyperlinks that would be dead. This is then automatic. The hyperlinks will

always be excluded whenever the topic they link to is excluded, because they are both

controlled by the same include options. 

You can also use additional include options to include alternative text or even alternative

links whenever the topic is excluded.

1. Use Find Referrers (see above) to locate all topics containing links to the topic you

want to exclude. 

2. Open the topic containing the link that you want to exclude in the editor and locate

the link. 

You now need to decide what needs to be excluded and replaced. We will assume that

you want to exclude the entire sentence containing the link and replace it with an al-

ternative sentence.

Excluding the link:

3. Select the entire sentence containing the link and select the  Conditional Text Tool

in Write > Insert Object.
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4. Now select exactly the same include options that you are using to exclude the topic

the link points to and click on OK. 

In the example above we have selected WebHelp and Adobe PDF. This means that the

link will only be included when you publish to WebHelp or PDF, it will be excluded

from all other formats. Since the options match those set for the topic the link points

to it will be excluded whenever the topic is excluded and included when it is included.

Including alternative text and/or links:

5. If you want, you can now write an alternative sentence with or without a link to a dif-

ferent topic and use conditional text to include the alternative text whenever the ori-

ginal text is excluded. 

The easiest way to do this is with IFNOT. In the above example we would also select

WebHelp and Adobe PDF, but in combination with IFNOT instead of IF. This will ensure

that the alternative is always included when the original is excluded, and vice versa.

How to set publishing options to manage dead links

These options can be configured in View > Program Options > Compilers. They not a "fi-

nal" solution. They should only be used as a failsafe to handle any dead links you may

have accidentally missed when planning your project. 

Option 1: Silently include linked topic

This option prevents dead links by exporting your excluded topics when you publish if

there are any other topics that contain links to them. When this is done no TOC entry is

exported for the topic, so it can only be displayed by clicking on the links to it. Don't use

this option if the topics you are excluding contain information you don't want a specific

user group to see!

All nominally excluded topics that get included by this option will be listed as "implicitly

exported" in the compiler report when you publish your project.

Option 2: Remove links

This option simply deactivates dead links to topics excluded from your output. The link

caption text is still there but it is normal text, no longer a hyperlink. This is definitely safer

than Option 1, because it always ensures that excluded content remains excluded.

However, depending on the context the plain text in place of the links may be confusing

for your users.

All links turned into plain text in this way are listed in the compiler report.



988

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

More Advanced Procedures

Option 3: Allow links to be dead

This option does nothing at all. The links are left in your output and they point to invalid

targets. When the user clicks on them either nothing will happen or an error message will

be displayed.

7.4.6 Defining include options

There are two kinds of include options (also known as build conditions): Output format in-

clude options and user-defined include options. Output format options are used to include or

exclude content in specific output formats (HTML Help, PDF etc). User-defined options are

used to create different versions of your project in any output format. In both cases you select

or deselect the include options you want to apply when you publish your project. 

Both types of include options are displayed in the same lists and are accessed in the same

way. For details see the other topics in this chapter.

How to define your own include options

An include option or "custom build" condition is basically just a named tag with which you

can identify topics or content in your topics. Once you have tagged your content you can

then include or exclude it with the corresponding include options that you can activate

and deactivate in the Publish  settings. 

1. In the Project Explorer go to Configuration > Common Properties > Custom Builds. 

2. Use Add and Delete to add and delete include options. When you define a new include

option you must enter a "Build ID". This is the actual include option tag and it cannot

be changed later. (Changing it would break existing conditions in your project.)

3. Click in the Display Text column to edit the descriptive texts for your include options.

These are just informative and do not have any effect on the functioning of the condi-

tions. Keep them short because they must be displayed in selection lists in dialogs,

which are generally quite narrow.

4. All the definitions you enter here are automatically displayed in all locations where in-

clude options are used. 

See also:
Conditions and Customized Output

Conditional text include options

Topic include options

1310

969

994

989



989

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

More Advanced Procedures

7.4.7 Topic include options

Topic include options are used to include or exclude entire topics or chapters from your out-

put on the basis of one or more conditions. When you apply topic includes to a chapter you

can include or exclude all the chapter's sub-topics with a single setting. 

Separate TOC entry and topic file include options

Your TOC entries and topic files are actually two separate items: The TOC entries are con-

nected to the topic files by a kind of hyperlink. The TOC entry and the topic files also have

separate include options. If you work in the TOC you will normally not need to think about

this because the matching include options for the associated topic files will be set auto-

matically. 

However, the situation is different if you have multiple TOC entries  for the same topic

in the TOC. Then you need to think about what happens when you set different include

options for TOC entries linked to the same topic file. 

Please see Topic entry and topic file include options  for more information, also on set-

ting include options for topic files directly.

How to set topic include options in the TOC

1. Select the topic or chapter you want to include or exclude by clicking on its entry in

the Table of Contents (TOC). You can select multiple topics and chapters with

Ctrl+Click and Shift+Click. 

2. Select the topic in the TOC, then select Change > Include in Builds in Project > Man-

age Topics and select the conditions you want to apply. You can select multiple op-

tions.

You can also access these options by right-clicking on a topic in the Project Explorer.

3. Select Find > Referrers in Project > Manage Topics to make sure that there are no

links to the topic that will be dead in the output if the topic is excluded. 

If you wish, you can include such topics  in your output automatically to prevent

dead links. 

· ALL BUILDS is the default. Selecting it deselects all other options.

· Assigning include options to a chapter does not automatically assign the selected op-

tions to the sub-topics and other chapters it contains. You must use multi select

(Shift+Click and Ctrl+Click) to apply include options to multiple topics and chapters. If

you exclude a chapter without excluding its subtopics the TOC entries for the sub-topics
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will not be included (they have nowhere to go) but the topic files will, and it will be pos-

sible for users to find them with Search and in the Index. 

· You can't include a topic that has a parent without including its parent as well. If you

have inconsistent build options like this an option is displayed in the right-click menu

with which you can correct it, by applying the missing options to the parent chapter. 

· If you exclude all the sub-topics of a chapter and include the chapter topic the chapter

will be converted to a normal topic when you publish.

How include options are applied to sub-topics

Including/excluding a chapter does not include/exclude its sub-

topics

Include options you apply to a chapter are not automatically applied to sub-topics. You

must use multi select (Shift+Click and Ctrl+Click) to apply include options to multiple top-

ics and chapters. If you exclude a chapter without excluding its subtopics the TOC entries

for the sub-topics will not be included (they have nowhere to go) but the topic files will,

and it will be possible for users to find them with Search and in the Index. 

Excluding all a chapter's sub-topics

If you exclude all of a chapter's sub-topics this will not exclude the chapter. If a chapter no

longer has any sub-topics it is no longer a chapter – it will be automatically converted to a

normal topic when you publish your project.

Excluding parent chapters and including their children:

This creates a conflict situation – since the parent is excluded the children cannot be in-

cluded. To correct it right-click on the one of the child topics and select the option for

adding the missing build options to the parent. This tool is also available in Project >

Change > Include in Builds and is only displayed when there is such a conflict. 
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How to set topic include options in the Topic Files section

You should generally set and change include options for topics in the TOC, then the op-

tions for the associated topic files will be set automatically. However, for topics without

TOC entries you must set the include options directly in Topic Files, in the Project Files sec-

tion of the Project Explorer. Just select the topic file and then set the include options in ex-

actly the same way as for a TOC entry

Important: Setting topic file include options does not automatically set the correspond-

ing include options for any linked TOC entries. You should always work directly in the TOC

for topics that have TOC entries unless you have a specific reason for wanting to set the

options for the topic files only.

See Topic entry and topic file include options  for more background information.

Checking for and correcting links from other topics

When you exclude topics from your output it is important to make sure that there are no

links to the excluded topic from other topics in your project. If there are, the links will be

dead in your output – when the user clicks on them either nothing will happen or an error

will be displayed (this depends on the output format).

1584



992

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

More Advanced Procedures

See Preventing dead links  for a more detailed discussion of this subject and strategies

for dealing with the problem efficiently. 

Checking for dead links

1. Right-click on the TOC entry of the topic you want to exclude and select Find Referrers

in the context menu. 

2. If any links to the current topic are listed click on the links to jump to the topics con-

taining the links so that you can correct them.

Correcting dead links with conditional text

You can use the same condition that you are using to exclude the topic to simultaneously

exclude the links to the topic. You just need to enclose the links in conditional text  tags

using the same condition that you used to exclude the topic. 

For example, if you want the topic to only be included in HTML Help output you would

tag all the links to the topic with an IF CHM conditional text condition to match the HTML

Help setting in Builds which include this topic. The procedure is similar for user-defined

conditions.

Inserting alternative text to replace the excluded links

In addition to excluding the links you can also use conditional text  tags to include al-

ternative text to replace the links that are being excluded. For example, if the topic is only

to be included in HTML Help you might use an ELSE or an IFNOT CHM condition to in-

clude the alternative text in all other formats, or an IF PDF condition to show the altern-

ative text in the PDF version. Here too, the procedure is similar for user-defined condi-

tions.

Topics without TOC entries in additional TOCs

When you use topics without TOC entries  in combination with additional TOCs you

may need to take additional action to ensure that the topic file is included in your output.

An additional TOC acts like an include option for every topic it includes, and by default all

other topics can be excluded. Because of this, topic files that are only accessed by hyper-

links and not by TOC entries may get excluded if you are not careful.

Method 1: Use the compiler option to force inclusion

This is the simplest solution. It tells Help+Manual to automatically include any topic file
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that is referenced with a link in your project. Just go to View > Program Options > Com-

pilers and set the Handling of dead links option to Silently include linked topic. This will in-

clude all topic files referenced with hyperlinks, even if they don't have TOC entries. The in-

cluded topic files will be listed in the compiler report.

Side-effect: This will also include topics that were excluded from the TOC with build op-

tions, if there are links to those topics that you have overlooked. Check the compiler re-

port!

Method 2: Use a user-defined include option

Alternatively, you can define an include option  with a descriptive name like NONTOC or

something like that and apply it to the topic file  in the Topic Files section. Then you just

need to activate that option  in the Publish screen when you publish. Then all topics

tagged with that option will be included in your output. 

How to apply include options when you publish

1. Select Publish in the Project tab or the File menu. 

2. Select your output format, then check the options in the Include Options: setting in the

Publish  settings. 

3. Select the options you want to apply from the list by checking the boxes next to the

names in the Include Options section on the right. 

All topics whose include options match the options selected here will be included in

your output. Topics whose options don't match will be excluded.

4. Check the other settings in the dialog and click OK to publish. 

The include option for the current output format is always selected automatically but it is

only relevant for topics not tagged with ALL BUILDS. Any other include options must be

selected manually. 

See also:
Conditions and Customized Output

Topic entry and topic file include options
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Preventing dead links

Defining include options

Topic include options

Command Line Options

7.4.8 Conditional text include options

Conditional text include options are used to include or exclude specific passages of text and

other items within a topic on the basis of one or more conditions. 

See Conditional text in tables  to learn how to use conditional text in tables, where they

have additional capabilities for tagging rows and columns. See Command Line Options  for

details on how to use these options from the command line and in batch files.

Method 1: Select text first

This is the fastest and easiest way because it automatically inserts the condition tags at

the beginning and end of the text and other content you want to tag. If you want to use

an ELSE tag as well you must still insert it manually, however (see further below).

1. Select the text or items you want to include or exclude in the editor. 

2. Select Write > Insert Object >   

3. In the dialog displayed select:

IF to include the selection if the condition is True when you publish (e.g. include text

in CHM output)

IFNOT to include the selection if the condition is False when you publish (e.g. include

text in all outputs except CHM)

4. Select all the conditions you want to apply by checking the boxes next to their names.

You can apply multiple conditions in a single conditional text tag.

5. Click on OK. The beginning and end of the conditional text block are marked by or-

ange tags in your text.

Method 2: Setting the IF and ENDIF tags manually

When you use this method you must insert the IF, ENDIF and ELSE (if used) tags separ-

ately, selecting the Conditional Text tool once for each individual tag. 

1. Click in the position where you want the text condition to begin. 

2. Select Write > Insert Object >   

3. In the dialog displayed select:
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IF to include the selection if the condition is True when you publish (e.g. include text

in CHM output)

IFNOT to include the selection if the condition is False when you publish (e.g. include

text in all outputs except CHM)

4. Select all the conditions you want to apply by checking the boxes next to their names.

You can apply multiple conditions in a single conditional text tag. 

5. Click on OK  to insert the tag.

6. Click in the position  where you want the text condition to end.

7. Select the Conditional Text tool again and insert the ENDIF condition.

Nesting include tags

You can nest conditional text blocks but do this with caution, it is easy to get confused

with complex conditions and to produce unexpected results.

Nested tags are evaluated starting with the outer tags. Evaluation stops as soon as a con-

dition evaluates as false, effectively creating AND logic. For example:

IF_CHM IF_DEMOBUILD content content content content ENDIF ENDIF

In the above example the content will only be included if the output format is CHM and

DEMOBUILD is selected in the Publish settings.

Using the ELSE condition

The ELSE condition can be used to provide an alternative text to be displayed if your

main condition is not fulfilled. It is inserted as a single tag between a pair of IF/ENDIF or

IFNOT/ENDIF tags. The ELSE condition is not associated with any include options. It

simply provides an alternative block of  content to be included if the previous conditions

do are not evaluate as true when you publish.

· Just click in the position in the text where you want to insert the ELSE condition, select

Write > Insert Object > , and then select ELSE. 

If the main condition evaluates True when you publish then everything between the IF

tag and the ELSE tag is output. If the main condition evaluates False when you publish

then everything between the ELSE tag and the ENDIF tag is exported.
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Example:

The following condition will output TEXT 1 if the output format is HTML Help (CHM), other-

wise it will output TEXT 2:

IF_CHM Text 1 ELSE Text 2 ENDIF

How to edit text conditions

Double-click on the orange text condition tag in your text to display the Text Condition

dialog, or right-click on the tag and select Edit.

How to apply include options when you publish

1. Select Publish in the Project tab or the File menu. 

2. Select your output format, then activate the include options as required in the Pub-

lish  settings. 

All content tagged with conditional text include options matching the Include Options

selected here will be included or excluded in your output, depending on whether you

used IF or IFNOT.

3. Check the other settings and then click on Publish Now to publish. 

See also:
Conditions and Customized Output

Defining include options

Topic include options

Command Line Options

7.4.9 Conditional text in tables

In tables, conditional text tags can be used to include and exclude both text in cells and com-

plete rows or columns in the table. It is important to understand how this works before you

start using conditional tags in tables, otherwise you can get unexpected results.
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Conditional text inside a single cell

Normal text inside a cell:

If the IF and END tags are both inside the same cell, conditional text in a cell works exactly

the same as in normal text. It simply includes or excludes the tagged content according to

the conditions.

Even if the entire contents of the cell are deleted, nothing happens to the column or row

containing the cell if there are also other cells with content in the column or row. (You

cannot delete a single cell leaving just an empty space in the table.)

When a condition completely deletes the contents of a cell:

The only exception to this behavior is when conditional tags completely delete the con-

tents of a cell and the cell is the only cell in the current row or column. If that happens,

then the row or column will also be deleted. If you want to prevent this and leave an

empty cell, make sure that at least one space character remains in the cell. 

In the first example below, row 2 of the table will be completely removed from the table

unless at least one space (or any other character) is left inside the cell containing the con-

ditional tags.

In the second example, column 1 will be deleted because all the text in the only cell in the

column is deleted. Column 2 will not be deleted, because one character is left over, and so

the cell still has content.
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The key is content: If any content is left in a cell then its row or column cannot be deleted,

because the content "protects" the cell, row and column from deletion.

Applying conditions to the content of multiple cells:

If you want to include/exclude the content of multiple cells you must include the IF and

END conditions inside every cell! If a condition starts in one cell and ends in another cell,

then the entire row or column will be deleted. This happens because rows and columns

can be deleted using only an IF tag, without a closing END tag (see further below for de-

tails).

Applying conditions to entire rows and columns

To include or exclude an entire row or column you put the IF condition right at the begin-

ning of the first cell in the row or column and the END condition at the end of the last cell

in the row or column:
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Order of processing and intersecting tags:

When Help+Manual processes your tags, it processes in order from left to right and top to

bottom. You need to consider this sometimes when you are excluding both rows and

columns with tag conditions that intersect with one another:

Removing intersecting first row and second column:

Removing intersecting first column and second row:

Applying conditions to multiple rows and columns

If you want to apply conditions to multiple rows and columns you must include separate

conditions for every row or column. You cannot start a condition in one row and end it in

another!
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Simplified syntax - leaving out the END tag

When you are tagging rows and columns the END tag at the end of the row or column is

actually optional. As long as the tags are positioned right at the beginning of the first cell

in the row or column, and there is no other END tag anywhere else in the row or column,

they will be interpreted as tagging the entire row or column.

For example, these tags will remove row 2 and column 2 in all outputs except PDF:

Avoid "orphaned" tags within rows and columns!

You should only use these unterminated tags in the first cell of a row or column (or the

cell that becomes the first cell because another row or column has been removed). If you

are tagging content in cells inside a row or column the IF tag should always be followed

by a matching END tag inside the same cell. Failing to do so can have unexpected con-

sequences.
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Columns and rows with merged cells

How columns and cells with merged cells are handled depends on which row or column

the merged cell "belongs" to:

· In rows the merged cell belongs to the first column that intersects the cell.

· In columns merged cell belongs to the first row that intersects the cell.

Entire tables

If you want to include or exclude an entire table, always put the IF condition before the

table and the END condition after the table. Excluding all the rows and/or columns in a

table will not exclude the table, it will only result in an empty table.
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Insoluble problems

There is one situation where you cannot exclude a row or a column with conditional text:

This happens when merged cells prevent the first cell of a row or column from being in

the first column or first row of the table. There is no way around this – it is just not pos-

sible to include/exclude these "partial rows/columns" with conditional text.

It is not possible to include/exclude the 2-column row 4 in this table:

For the same reason, it is not possible to include/exclude the 3-row column 2 in this table:

See also:
Conditional text include options

7.4.10 Modular projects include options

You can "merge" additional Help+Manual projects ("modules") into your current project by

inserting them in your Table of Contents, in the same way as inserting a new topic. This also

makes it possible to use conditional output include options on entire modules in the same

way as on individual topics.

Modules are inserted in the TOC in the same way as topics, so you can apply include options

to entire modules in the same way as to topics. A module include option can include or ex-

clude an entire project with its entire directory tree, all its chapters, sub-chapters and topics
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and all its invisible topics as well. If the module also has child modules a single module in-

clude option will include or exclude the module with all its children.

Modules can also have their own include options in all the chapters and topics in the module.

These will also be evaluated and applied when you publish the entire modular project.

See Working with Modular Help Systems  for details on creating and using modular pro-

jects.

How to set include options for modules

In a project containing child modules select the child module you want to include or ex-

clude by clicking on its Table of Contents entry in the TOC of the master project. 

Including or excluding entire modules:

1. Select Change > Include in Builds the Project > Manage Topics. 

2. Select all the options you want to apply by clicking in the boxes next to the options'

names. You can select multiple options.

Including or excluding module topics and chapters:

Just select the chapters inside the module and apply include options as you would for

normal topics and chapters. You can also use conditional text  include options for con-

tent inside the chapters in the normal way. (Editing for child projects  needs to be activ-

ated for this to be possible.)

Before excluding, a module generate a project report  to make sure that excluding the

module will not create any dead links. (Links with targets in other help files and projects

are listed in the reports.) You can get around this problem by creating links between mod-

ules with A-keywords . 
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How to apply include options when you compile

The include option for the current output format is always selected automatically. Any

other include options must be selected manually. However, if you select user-defined in-

clude options you must always also select at least the option for the current output

format.

1. Select Publish in the File menu or in the Project tab. 

All modules whose Include Options match the Include Options selected here will be in-

cluded in your output.

2. Select your publishing options , then click on Publish Now to publish.

See also:
Working with Modular Help Systems

Defining include options

7.4.11 Redefining variables

You can always change the definitions of your variables individually in Configuration > Com-

mon Properties > Text Variables in the Project Explorer. In addition to this you can set differ-

ent values for specific variables in  individual topics. When you publish your project you can

also redefine some or all of the variables in your entire project with a project skin or a variable

definitions file. 

How to redefine variables in individual topics

If you want a variable to have a different value in individual topics you can redefine it in

the Topic Options tab on the left of the main editor window when the topic is selected.

Note that this is only possible with user-defined variables. You cannot define

Help+Manual's standard variables with this feature. 

1. Select the topic in the Project Explorer, then select the Topic Options tab on the left of

the main editor window. 
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2. Click on the + button next to the Topic Variables box at the bottom of the window.

3. Select the variable you want to redefine and click OK, this adds the variable to the

Topic Variables list.

4. Click in the Value field and enter a new value. The values you enter here will only be

used in the current topic. 

See The power of editable variables  for more information on the kind of things you can

do with this feature.

How to redefine some or all variables when you publish

When you publish your project you can redefine some or all of the variables in the entire

project in two different ways: With "skins" and with the command line compilation feature.

Redefining variables with publishing tasks

The Publishing Task Manager makes it possible to define "tasks" to publish your project to

multiple output formats and destinations in a single integrated operation. In addition to

this you can also redefine the variables in your project when you publish the task with a

list of alternative variable definitions. See Publishing to multiple formats  for instruc-

tions.

Redefining your variables with skins:

Note that you can also assign skins to publishing tasks . 

1. Create a project skin (only possible with Help+Manual Professional) containing the al-

ternative definitions of your variables (and anything else you want to change in your
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project). If you only want to redefine your variables you can create a skin that only

contains your variable definitions. See Transforming Your Output with Skins  for

more details. 

2. When you publish your project  to an HTML-based output format select the skin file

in the Publish  dialog. 

Note that skins can't be selected in the Publish dialog in non-HTML formats – you need to

use command line publishing (see below) for those formats where skins are not directly

available. 

Redefining your variables from the command line:

You can also create a simple text file containing a list of definitions of the variables you

want to change. You can then specify this file in the command line to redefine all the vari-

ables in your project with the values in the file. 

In addition to this you can also specify a project skin file in the command line, to apply a

completely different appearance to the entire project as well as redefining the variables. 

For more details on the procedure for redefining variables see Skins & redefining vari-

ables  in the Command Line chapter and Transforming Your Output with Skins .

See also:
Variables and Conditional Output  (Reference)

Transforming Your Output with Skins

Command Line Options

Skins & redefining variables

7.4.12 HTML template conditions

Key Information
The ELSE condition is not available in HTML tem-

plates. 

Conditional output and variables are also supported in your project's HTML templates. You

can use all the same include conditions in HTML templates that you can use in your topics

with the Conditional Text tool. In addition to this there are also a number of special pre-

defined conditional switches that are available in HTML templates only.

For details see Conditional output  in the chapter on using HTML templates.

See also:
Using HTML Templates

Conditional output in HTML templates

HTML template output conditions  (reference list)
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7.5 Templates in Help+Manual

Templates are like an empty framework for topics, projects, PDF files and printed manuals.

They are used to define the layout and appearance of these objects and to include text and

other elements that the objects always or usually contain so that you don't have to enter

them manually every time.  

See also:
Help Windows

7.5.1 Template types

The following template types are used in Help+Manual:

Project templates: A project template is an empty project that stores all the

settings you want to use in a project, including all your Pro-

ject Configuration settings, text styles, HTML templates and

so on. Project templates can also include topic content that

you want to use in every new project.

HTML skins: Skins are applied when you publish to HTML-based output.

They apply a complete pre-designed layout to your project

with a single click. You can save and edit your own skins or

used predefined ones. Skins can only be created with the

Professional and Floating license versions of Help+Manual.

You can use existing skins with the Basic version but you

cannot save or edit your own skins. 

Topic content templates: Topic content templates are entire topics and can include

everything that a topic can include. They can be loaded

manually, or automatically when you create a new topic.

Print manual templates: (PDF

and printed manuals)
These templates define the layout and appearance of your

PDF output and printed manuals. They are created and ed-

ited with the Print Manual Designer, a separate program in-

cluded with Help+Manual.

DOCX templates These work in a similar way to PDF templates, but for Word

DOCX output. They are special Word DOCX files with pre-

defined content that Help+Manual combines with the out-

put from your project to create a DOCX file with a pre-

defined layout.

HTML templates: These templates define the layout, general appearance and

features of your topic pages in Help+Manual's HTML-based

output formats. They are included in every project but they

1609
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are generally not used there because HTML output formats

are almost always published with HTML skins . Skins

contain exactly the same templates. They replace the pro-

ject templates when you publish with them.

The topic page templates for your topics can be viewed and

edited with the Project Explorer in the Configuration >

HTML Page Templates section. 

The additional HTML templates for the various components

of WebHelp (TOC, Index, Search, frameset) can be viewed

and edited in Configuration > Publishing Options > We-

bHelp.

7.5.2 Templates for projects

A help project template is simply an entire Help+Manual project with all its settings, including

all your styles and all the settings and items in the Project Explorer. A project template can in-

clude topics with content but it does not have to. If you have topics that you always use (for

example terms and conditions, introductions and so on) you may want to include them.

The difference between HTML skins and project templates

Unlike HTML skins , project templates are used as a model for new projects. You can

also apply project templates to existing projects but this is a little more complicated (see

below).

Skins are applied when you publish and do not affect the settings in your current project,

the settings in project templates become an integral part of your project.

How to create a project template from an existing project

This is generally the easiest way to create a project template because then you don't have

to go through all the project settings.

1. Create a backup copy of the project you want to use as a template and open the

backup. 

2. Delete all the topics you don't want to include in the template and edit any topics that

you do want to include so that they do not contain any unnecessary text or other

items.

3. Select Save As in the File menu and save the edited project in a safe place. You don't

have to use a special format, a project template is exactly the same as a normal

Help+Manual project.
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How to use a template to create a new project

Make a copy of the template project and edit:

Just make a copy of the template project file or project folder (if you are using uncom-

pressed XML format), rename the .hmxz (compressed) or .hmxp (uncompressed) file and

start editing. That is all there is to it.

How to apply a template to an existing project

You can also apply project templates to existing projects. However, this cannot be done in

one process, you need to choose the parts of the template you want to apply. 

Step 1: Apply the template stylesheet

1. Open the project you want to apply the template to and select Styles > Edit Styles in

the Write tab. 

2. Click on the Copy Styles From...  and then select the project file you want to copy the

stylesheet from. 

Note that this will overwrite all the styles in your existing project!

Step 2: Apply the Project Configuration settings

All the other settings in your projects are stored in the Configuration  section in the Pro-

ject Explorer. You must import the properties here section by section:

1. Select the Configuration section of your project in the Project Explorer. 

2. Select a section that you want to copy and click on the Copy Properties From... button
at the bottom of the screen. Then select the project you want to copy the properties
from.

You will be asked whether you want to copy the properties from just the current sub-

section or from the entire section (for example: just the Image Folders section of Com-

mon Properties or the entire Common Properties section).

Note that this will overwrite all the settings in your existing project!

3. Repeat for all the template sections you want to copy.

If you want to copy the complete template import all the Common Properties and HTML

Page Templates sections, plus all the Publishing Options sections for any output formats

you are using.

1400
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Step 3: Import the Baggage Files

If your original project also contains Baggage Files  you should import those to the new

project as well. 

1. Select the Baggage Files section in the Project Explorer. 

2. Select Add File > Add New File in Project > Manage Topics and select the

Help+Manual project you want to import the Baggage files from.

3. You will be asked if you want to import the Baggage Files from the selected project.

Confirm to import the files. 

Using our examples to create your own project

Do you like the appearance of the Help+Manual help? In case you do we've included the

complete source project used to create this help you are reading now. It is stored in the

Examples\HelpAndManual6 folder in your Documents directory.

We have also included the custom skin we used to create the CHM and WebHelp versions

of this help, and you are welcome to use that too. The skin is called HM6-OnlineHelp-

Webhelp+CHM.hmskin and you can select it directly with the Select Skin option in the

Publish dialog. It is stored the \Templates\HTML Skins folder in the Help+Manual

program directory, along with all the other skins we provide for your use.

Creating a project based on the Help+Manual help:

Open our help project in Help+Manual and make a copy of it in a new folder with Save

As... in the File menu. Then just delete all the topics and go through the Configuration sec-

tions in the Project Explorer to change the details necessary for your own help, like the

title and so on. 

Using our styles etc. in your own projects:

Follow the instructions for applying project templates to existing projects (see above) and

copy the styles, Configuration sections and Baggage files from our help project – or any

other project you want to use as a model.

See also:
Creating Projects

Creating and Editing Topics

7.5.3 HTML Skins

You may already be familiar with the concept of "skins" from other programs: You select a

skin file and the appearance and layout of the entire program is transformed in seconds.
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Help+Manual enables you to do this with your HTML-based output. You can save your entire

design with all its HTML templates and relevant HTML settings in a .hmskin file. You then se-

lect this file when you publish to apply the layout to the current project without changing any

of the project's own settings.

Please note that you can only save your own projects as skins if you have the Professional or

Floating license version of Help+Manual. Basic version users can use skins without limitations

and edit existing skins (for example skins from the Help+Manual Plus Packs) but they cannot

create new skins from their own projects. 

Productivity Tip
Skins can only be used for HTML-based output

formats. You can style your PDF files and printed

manuals with print manual templates , which work

in the same way as skins. Word files use DOCX tem-

plates .

How to use skins - try it now!

1. Open a project of your own, select Publish in the Project tab, then select WebHelp or

HTML Help as the output format. 

2. On the Publish page  click on the drop-down menu in the Select Skin section and

select one of the standard .hmskin files in the Skins folder in the Help+Manual pro-

gram directory. You can also select the Open Skin... option to select a skin file directly.

When you publish your output it will have the "look and feel" applied by the skin. You

didn't have to do any design work at all! Cool, no?

How to create a skin file

Skin files contain everything you need to style your HTML-based output: Text and table

styles, user-defined variables, your Baggage files (template graphics and logos), HTML

page templates and all the settings and templates for WebHelp. You can turn any project

into a skin file just by saving it as a skin and you can edit skin files in Help+Manual, just

like normal projects.

1. Open a project with a design that you want to use for other projects. 

2. Select Save As... in the File menu and choose the Skin XML File option.

3. Choose a place to save the skin, enter a name and save.

4. You will be asked which configuration components of your project you want to include

in your skin.
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Skin components you can include or exclude when creating a skin

HTML Page Templates: Should generally always be included. This includes

both the templates for topic pages and the various

WebHelp HTML templates. Without them, your skin

will not replace the HTML templates from your pro-

ject. In most cases, that would be pretty pointless. 

Baggage Files: Should generally always be included. The Baggage

Files  section is the place in your skin where you

store your additional JavaScript, CSS and other files

for your skin. Putting them there exports them

automatically when you publish.

Variables: Should generally always be included. Having vari-

ables in the skin allows you to set up configuration

options that you can adjust without having to ad-

just the source code in your templates or baggage

files. Variables can be used in all HTML templates in

your skin and in JavaScript and CSS files in your

baggage files – they are scanned and replaced by

Help+Manual on publishing.

All variables you use in your HTML templates and

1119
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baggage files must be written with the standard <%

VARIABLE_NAME%> syntax, otherwise they won't

be found. You can also use variables from your pro-

ject (both global and user-defined).

Custom Builds: Should generally always be included, but delete any

custom builds from your project in the skin after

creating the skin. Custom builds defined only in the

skin are displayed in the additional Skin Include

Options box displayed in the Publish screen. Hav-

ing custom builds in your skin allows you to create

configuration options that can be activated or de-

activated on publishing. 

You can include or exclude code in your HTML tem-

plates or in your JavaScript and CSS files in your

baggage files with custom builds. For example, sup-

pose you have a custom build called TOPICFOOTER:

Include code when your build option is active with:

<IF_TOPICFOOTER>Code you want to in-
clude when TOPICFOOTER is selected
goes here</IF_TOPICFOOTER>

Include code when your build option is inactive

with:

<IF_TOPICFOOTER>Code you want to in-
clude when TOPICFOOTER is NOT selected
goes here</IF_TOPICFOOTER>

See this topic  for more details.

How to edit skin files

Skin files are actually normal single-file projects with some special limitations. You can

open them and edit them like normal projects but you can only edit those components

that are included in the skin, everything else is unavailable. 

1. Select Open in the File menu and then select Help+Manual skin files (.hmskin) as the

type of file to be opened. (If you don't select this you won't be able to see the skin

files!) 

2. Select an .hmskin file to load and edit. You can find some sample skins in the Skins

folder in the Help+Manual program directory.

1052
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3. Now you can edit the settings of your skin. This is exactly the same as editing the cor-

responding sections of normal projects to configure your output.

Skins have no topics, you can only edit the relevant sections in the Configuration and

Baggage Files sections in the Project Explorer and the text and table styles in Write >

Styles.

Using include conditions to configure features in skins

Key Information
Include options in skins must be defined in the skin!

Include options defined in normal H+M projects will

not be saved in the skin when you save the project as

a skin. You must edit the skin file and add the include

options you want to use.

For advanced users:

You can use include options  to turn features in skins on and off. This makes it possible

for the user to choose features in the skin when they publish their projects because in-

clude options stored in skins are loaded into the Include Options: box in the Publish dialog

when the skin is selected.

For example, suppose you want to give the user the option of having a subtitle under-

neath the title in the table of contents in your WebHelp output. It would work like this:

1. Define an include option in the skin, let's say it's called OPT_SUBTITLE, and let's also

say that we've entered TOC header subtitle as the include option description.  

2. Add code using the include option to the HTML template for the WebHelp table of

contents, for example (you would also have to define the <%SUBTITLE%> variable in

this example, of course):

  <p class="navtitle"><%TITLE%></p>
  <IF_OPT_SUBTITLE><p class="nav-subtitle"><%SUBTITLE%></p></IF_OPT_SUBTITLE>

3. When the user loads the skin in the Publish dialog the option [ ] TOC header subtitle

will automatically be loaded from the skin file and displayed in the Include Options:

box. The header will only be displayed if the user selects this option.

You can take this concept as far as you like: For example, you can use the same include

option to change the CSS definitions in the same HTML template so that the formatting

will be different depending on whether the subtitle is included or not. 

1052
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Including a preview image in a skin

When the user selects a skin in the Publish dialog Help+Manual automatically looks for a

PNG graphic file called $HMSKINPREVIEW.PNG in the skin's Baggage files. If this file is

found a thumbnail version of the preview image is displayed in the Publish dialog. The

user can then click on this image to display a full-size preview.

1. Create your preview image – this will generally be a screenshot of a help file using

your skin – and save it in the PNG format as $HMSKINPREVIEW.PNG. 

2. Add the PNG preview file to the Baggage Files section of your skin.

3. Select the PNG file in the Baggage Files section, right-click on it, select Include in

Builds and deactivate all build options for the file. This will prevent the file from being

exported to your published output, where it is not needed.

Using skins to redefine variables and other settings

You don't have to save all your settings in your skin files. For example, it's possible to cre-

ate a skin that only defines the user variables in your project – you just need to deselect

everything except Variables when you save the skin file. Then you can redefine your vari-

ables in your entire project by selecting the skin file when you publish your project.

You can do the same with your Baggage files, text and table styles, HTML Page Templates

or any combination.

 Applying multiple skins in command lines and batch files

When you publish manually you can only select one skin for the project you are publish-

ing. However, when you use Help+Manual's command line options you can specify as

many skins as you like one after another. 

When you do this the settings in the last skin you specify always have priority for duplic-

ate settings – for example, if you redefine the same variables in two skins the settings in

the second skin are those that will be applied. 

See Command Line Options  and Skins & redefining variables  for more information

on this. 

See also:
The Publish Dialog

Command Line Options
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7.5.4 Content templates for topics

A topic content template is an XML file containing the "framework" of a topic – it is used to

create topics with repetitive content, for example identical tables and headings and so on.

Topic content templates can contain everything that a topic can contain, including tables,

formatted text, graphics, links and so on. You can create as many content templates as you

like and load them with you create topics with standard layout that you use repeatedly. You

can also create content templates that are loaded automatically when you create new topics.

How to create a topic content template

1. Create a new topic. The topic ID is irrelevant because you are going to delete the topic

as soon as you have saved the template. 

2. Edit the topic and add everything that you want to have in the template. You can use

all the features that you can use in a normal topic, including tables, graphics, format-

ted text, hyperlinks and so on. 

3. Enter the topic header (in the area above the editor, not in the TOC) exactly as you

want it to appear in the topic. See the instructions below for automatically inserting

the TOC caption in the header.

4. Select File > Save Topic to File in Project > Manage Topics and save the topic as an

XML file in the project folder, using the following naming syntax:

filename.template.xml

The .template. part of the name is essential, it identifies the XML file as a template.

Templates must be stored in the current project directory and must use this naming

syntax. If you call the template default.template.xml it will be selected automat-

ically for new topics (see further below for details).

Examples:

intro.template.xml
functiondocs.template.xml
standarddocs.template.xml

default.template.xml (will be autoselected for new topics)

5. Delete the topic you have just created if you don't want to use it in your project now.

How to use topic content templates

To create a new topic with a template:

1. Choose one of the Add Topic options in the Project tab to create a new topic. 
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2. Select the template in the Topic Template: field of the Insert New Topic or Chapter dia-

log.

Note that the template will only appear in the Topic Template: field for selection if it is

stored in your project directory using the filename.template.xml naming syntax (see

above for details).

To load a template into an empty topic:

1. Create an empty topic. 

2. Select File > Load Topic from File in Project > Manage Topics and select the template

file you want to load. 

Don't try to load a template into an existing topic, this will overwrite the entire contents of

the topic! 

Insert the TOC caption in the topic header

When you create topic templates to use for creating new topics you can include a special

variable in the header that will automatically insert the topic caption (the title of the topic

you enter in the Add Topic dialog) in the header of the topic. If you don't use this variable

the template will be loaded with the header saved with the topic. 
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You also need to insert this variable in the Title Tag: field in the Topic Options tab on the

left of the editor window so that the header text of your topic is used there as well – oth-

erwise the header text stored with the content template file will be used. 

1. Delete the header of the template topic (in the area above the editor, not in the TOC)

and replace it with the following variable: 

 %TEXT%

2. Type in the variable manually exactly as shown, using all upper case. Only enter %

and % before and after the variable name. This is the only variable that does not use <

% and %> tags. 

You can also include other text and elements in the header, including graphics. Only

the variable is replaced when a new topic is created.

3. Select the Topic Options tab on the left of the editor window and type the same %

TEXT% variable in the <TITLE> Tag: field:

This variable only works when you create a new topic with a content template file. The %

TEXT% variable is not translated when you load the template into a empty topic with File

> Load Topic from File in Project > Manage Topics.

Setting up an automatic template for new topics

In addition to templates that you can select manually for new topics you can also create a

topic content template with a special name that will get selected automatically for every
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new topic. Just follow the instructions above for creating topic templates and save the

template in your project folder (the same folder where your .hmxp or .hmxz project file is

stored) with the following name:

default.template.xml

If this template exists in your project folder it will be preselected automatically when you

create a new topic. If you want to change it you can still select a different template from

the list in the new topic dialog. Otherwise clicking on OK will create the new topic with the

standard template. 

Topic content templates for topic styles

If you frequently use topics with different standard styles you could create a separate tem-

plate for topics with each set of styles already preset in the topic header and body. Then

you just need to select the appropriate template when you create a new topic (see above).

See also:
Creating new topics

Exporting and importing topics

7.5.5 PDF and printed manual templates

The layout of Help+Manual's PDF and print manual output is controlled by template files

called "print manual templates" with the extension .mnl that do much more than just define

the appearance of your pages. These templates can also add front and back covers, multiple

title pages at the beginning, an introduction, a formatted table of contents, title pages for in-

dividual chapters, graphics, headers and footers, a formatted index and multiple endnotes

pages. You can also define your own additional pages and insert topics from your project or

external files with a "snippets" function.

All the global variables and user-defined variables from your project file can be used in your

print manual templates. Since the templates are external files you can use them in multiple

projects, applying them to your output just as you apply skins  to HTML-based output

formats. 

How to select a print manual template

You can select separate templates for PDF output and printed manuals. 

Selecting a print manual template for PDF output:

1. Select Publish in the Project menu, then select PDF as your publishing format. 
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2. Click on the dropdown area shown above to select the template you want to use.

Selecting a print manual template for printing a user manual:

1. Select the File menu and click on Print User Manual . 

2. Click on the dropdown area shown above to select the template you want to use.

How to edit a print manual template

· Select Project  > Tools > Manual Designer  to open the Print Manual Designer. Then

select File > Open in the Designer to open the template for editing. You can find a se-

lection of standard templates that you can edit in the \Templates\pdf folder in the

Help+Manual program directory.

· When you open the Manual Designer it will automatically load the last PDF template

used for the current Help+Manual project, if there is one.

The Print Manual Designer is a separate program with its own documentation. See the

help in the Designer for details on how to use it.

Location of the standard print manual templates

Help+Manual comes with a selection of standard print manual templates that are stored

in the \Templates\pdf subdirectory in the Help+Manual program directory. These

templates have the file extension .mnl.

See also:

1290
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PDF and Printed Manuals

7.5.6 Word DOCX templates

Help+Manual comes with a set of standard templates for Word output. These templates are

themselves standard Word DOCX files that you can edit and customize directly in Word. They

are stored in the Help+Manual program folder, in /Templates/Word.

If you select one without editing it when publishing your project to Word DOCX you will get a

DOCX document using the layout defined in that template. If any of the variables used in the

template are defined in your project you will see those items in the output (project title, au-

thor etc). Other fields used in the template will not yet be filled, because they need to be con-

figured directly in the template – for example, fields for your company name, address and so

on.

See this chapter  for full details on using and configuring DOCX templates.

7.5.7 HTML templates

HTML templates are used to define the layout of all Help+Manual's HTML-based output

formats (HTML Help, WebHelp, eBooks and Visual Studio Help). In topic pages, what you

enter in the editor defines the content, the templates define the framework in which your

content is presented. The HTML templates are stored together with your project.

The same HTML topic page templates are used for the topic pages in all three formats. In ad-

dition to this there are also separate templates for the frameset file and the Table of Contents

and Keyword Index frames used in WebHelp, where they emulate the HTML Help viewer user

interface.

You don't normally need to think about HTML templates

For normal work with Help+Manual you don't have to think about what HTML templates

contain and how to edit them. That is all handled in the background by the program. A

simple style editor is provided that allows you to modify the basic layout of your pages in

the associated output formats without having to edit the HTML code directly. 

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you
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do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

Accessing and editing the HTML templates

For everyday work you can adjust the settings of your HTML templates just as you would

adjust any of the other output settings in your Project Configuration  settings. The

simple style editor hides the HTML code with a point-and-click interface.

The HTML topic page template:

In most projects and skins there is just one HTML topic page template called Default,

which is assigned to all new topics automatically. It can be viewed and edited in the Con-

figuration section of your project or skin in the Project Explorer, in Configuration > HTML

Page Templates, where you can also create new templates. 

Among other things, the HTML topic page template defines the background colors of

your topic and topic header in HTML-based output formats and the Top, Previous and

Next navigation links displayed in the topic header in these formats.

1400
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The Simple Template Layout tab provides most of the functions you will normally need,

see this topic  for some basic instructions. This tab is disabled when code in the Source

Code tab has been edited.

The HTML Source Code tab allows you to edit all the source code of the template and even

completely replace it with your own code. 

Disabled Simple Layout tab:

The Simple Layout tab will be disabled as soon as you edit source code to prevent acci-

dental deletion of your custom code. It can only be re-enabled by clicking on the Reset

Template button. This will delete the edited code and replace it with the standard tem-

plate

The HTML templates for WebHelp components:

There are also additional HTML templates for WebHelp, which define the layout frameset,

TOC, Search, and Index components of the WebHelp user interface. These are accessed in

Configuration > Publishing Options > WebHelp. See HTML Output and HTML Tem-

plates  for full details.
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Setting the background colors of topics and headers

The background colors of topics and headers are set in the HTML page template for all

HTML-based formats. Background colors are not used in DOCX, PDF and printed manuals.

Here too, the backgrounds are defined in your project if you are not using a skin and in

the .hmskin skin file if you are.

See Background colors and help viewers  for details on how to set the background col-

ors in the HTML page template. 

Doing more with HTML templates

If you are familiar with writing HTML, Help+Manual's HTML templates are a very powerful

tool that gives you a great deal of control over the appearance of your output pages in all

HTML-based formats. 

If you feel like getting under the hood and finding out what you can do with HTML tem-

plates, have a look at the HTML Output and HTML Templates  chapter in the More Ad-

vanced Procedures section.

See also:
WebHelp settings

Using HTML Templates

7.5.8 eWriter Help Templates

eWriter Help files really WebHelp packaged in a single file together with an integrated viewer.

The topic page layout is defined by the same HTML page templates that are used for the

topic pages of  HTML Help and WebHelp. The Layout, TOC, Keyword Index and Search pages

are defined by the same templates used for WebHelp. Normally, you will use a WebHelp skin

to publish eWriter Help.

See eWriter Help  in the Publishing chapter for full details.

See also:
eWriter Help settings  

7.5.9 Page templates for ePUB and Kindle eBooks

The topic pages in ePUB and Kindle/Mobi eBooks use a special HTML page template that is

pre-generated by Help+Manual. This is necessary because these eBook formats have special

requirements and strict specifications that need to be observed to produce valid books. 

You can edit the source code of the combined ePUB/Kindle template in Configuration > Pub-

lishing Options > eBooks > ePUB + Kindle: Page Template. However, please only do this if

you are familiar with the eBooks specification. It is quite easy to create output that looks OK
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when you view it locally but creates problems later. It may be rejected by the eBook distribu-

tion platform because it doesn't "validate", or it may display incorrectly on some devices.

7.5.10 Using secondary windows in CHM help

Secondary windows are only relevant in Microsoft HTML Help CHM files. They are used to dis-

play  individual topics in external windows.

Productivity Tip
Avoid using hyperlinks in secondary windows. Al-

though an external window is a full instance of the

help viewer hyperlinks between it and the main help

can quickly get very confusing for the user.

How to display topics in external windows in HTML Help

In HTML Help you can use additional help window definitions to display topics in external

windows when they are opened with hyperlinks. Topics can only be displayed in external

windows in HTML Help CHM files and the help window settings have no effect in other

help formats. 

Important Restrictions

Important: Help window types can only be used in hyperlinks. 

You cannot directly associate a help window type with an individual topic and you cannot

set a topic in the TOC to open in an external window when you click on its TOC entry.

You cannot link open topics from other CHM files in external windows.

Due to restrictions in the Microsoft HTML Help CHM viewer, you can only display topics

from the current CHM file in an external window. It does not work when linking to topics

in another CHM file. 

Procedure:

1. In the Project Explorer go to Configuration > Microsoft HTML Help > Help Windows

and create at least one secondary help window type definition with Add. 

Adjust the settings of the window definition as you want the external window to ap-

pear – in addition to the size and position you may want to switch off navigation con-

trols etc. in the help window definition's HTML Help Options tab.  

2. In the HTML Help Options tab activate the option Links to secondary help windows

open a new help window.

3. When you create a hyperlink to a topic specify the secondary help window type with
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the Window: setting in the link definition. 

When the user clicks on the hyperlink the target topic it will now be displayed in an ex-

ternal window in HTML Help, with all the settings defined for the window type in step 1. 

See also:
Help Windows

Using help windows

Links and secondary windows

HTML templates

Using HTML Templates

7.6 HTML Output and HTML Templates

HTML templates are used to define the topic layout of all Help+Manual's HTML-based output

formats (HTML Help, WebHelp, Windows Exe and ePUB eBooks and Visual Studio Help). What

you enter in the editor defines the content of your topics, the templates define the framework

in which your content is presented. The HTML templates are stored together with your pro-

ject.

In addition to this there is an additional set of HTML templates for the special components of

WebHelp output (TOC, Index, Search, frameset).

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.
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See also:
HTML templates  (Reference)

Help Windows  (Reference)

Templates and Secondary Windows

Using help windows

7.6.1 Font Size Units & Dimensions in HTML

In HTML, the units used for font sizes and dimensions now more important than ever before.

With the introduction of high-resolution 4K monitors and portable devices with super high

resolution screens like the Microsoft Surface and Lenovo Yoga Pro series, content on the

screen must scale correctly to be attractive and legible. 

Help+Manual now handles this automatically. You basically just need to select the correct

font size units for your output formats and Help+Manual will automatically adjust all the

other dimensions on your pages accordingly so that they scale correctly on high-resolution

devices and also look correct on older, "normal" devices.

These settings are made in the HTML Export Options section of your project (they are not

available in skins, only in your project). There are separate sections for WebHelp and HTML

Help/CHM. The WebHelp settings are also used for eBooks (eWriter, ePUB and Kindle/Mobi)

and the CHM settings are shared with the Visual Studio Help output formats. 

Setting the correct units for hi-res devices for WebHelp output

You now need to consider high-resolution 4K monitors and devices like the Microsoft Sur-

face and Lenovo Yoga Pro when you are planning your WebHelp. If you don't do this the

text and other elements will often be too small to read on these devices. If you set the

configuration options described below Help+Manual will automatically adjust everything

else so that it displays correctly on high-resolution displays.

1. Open your project in Help+Manual and in the Project Explorer navigate to Configura-

tion > Publishing Options > WebHelp > HTML Export Options. 

2. Set Font Size Encoding to: em (1em = 100%).

3. The Font size of style "Normal" setting is grayed out for ems/rems because it is only

used when font encoding is set in percent. 

Once the base font encoding is set to ems all elements in your topic files will then auto-

matically be adapted for correct display on both normal and high-resolution devices and

monitors.

Setting the correct units for hi-res devices for CHM output

The Microsoft CHM Viewer in Windows uses an old HTML rendering engine that has spe-

1611
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cial requirements. Help+Manual can automatically configure your CHM file so that it dis-

plays correctly on high-resolution 4K monitors and devices like the Microsoft Surface and

Lenovo Yoga Pro. If you don't do this the text and other elements will often be too small

to read on these devices. 

1. Open your project in Help+Manual and in the Project Explorer navigate to Configura-

tion > Publishing Options > MS HTML Help > HTML Export Options. 

2. Set Font Size Encoding to: pt Points.

3. Select the checkbox for Make pixel sizes relative to monitor resolution (4K display com-

patibility)

All elements of your CHM file will then automatically be adapted for correct display on

both normal and high-resolution devices and monitors.

7.6.2 Types of HTML templates

There are two categories of HTML templates: The HTML topic page templates that define your

topic pages in all HTML-based output formats and an additional group of HTML templates

used to define the additional components of WebHelp output, which are also used for eWriter

Help.

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

667
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HTML topic page templates:

These are the templates for your topics and they are used for all HTML-based output

formats. They define everything in your topic pages except the topic content. They are

stored in Configuration > HTML Page Templates.

Additional templates for WebHelp:

In addition to this there are also separate templates for the main index.html page  and

the Table of Contents , Keyword Index  and Full-text Search  pages used in We-

bHelp to emulate the HTML Help viewer user interface. These templates are stored in

Configuration > Publishing Options > WebHelp.

Special script and CSS components information for experts:

If you are experienced in HTML, CSS and JavaScript coding please refer to Script and CSS

components for experts . This topic contains important information on how the refer-

ences to important script and other components in the templates are managed and how

you can manipulate them.

 

Which HTML templates are used where and when...

The WebHelp Layout template contents depend on the layout op-

tion chosen

The contents of the layout template change depending on whether you choose "Integ-

rated", "Classic 2 Frames" or "Classic 3 Frames" in Configuration > Publishing Options >

WebHelp > Layout. In the Integrated version, HTML5 is used and the topic and navigation

pages are loaded in modern iFrames. The Classic versions use a traditional frameset (now

deprecated) and load the topic and navigation pages into conventional frames. The same

JavaScript files are used in all three versions, however. 

The "No Frames" option disables the Layout template

The layout template is not used at all if you choose the "No Frames" option. Then the

Table of Contents template is set as the main index.html file and the contents of the

layout template are irrelevant for your output because the template is not present.
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HTML Topic Page templates are (almost) always used.

The topic page templates in Configuration > HTML Page Templates are used by almost

all HTML-based output formats (CHM, WebHelp, eWriter Help and Visual Studio Help

2008 and 2010). 

Exception: ePUB and Kindle/Mobi

The ePUB and Kindle/Mobi eBook formats us a special template stored in  Configuration

> Publishing Options > eBooks > ePUB + Kindle: Page Template. This template can also

be edited there, but please only change it if you are familiar with the eBook specifications.

The WebHelp Table of Contents, Index and Search templates

The contents of the WebHelp Table of Contents, Index and Search templates define three

separate pages for these functions. They are loaded into the navigation frame in WebHelp

and eWriter Help when they are displayed. Some skins load them in the background so

that they are always present and can be switched to without reloading.

Templates in the "No Frames" Layout Option

If you choose the "No Frames" option,  the Layout template is disabled and is not used. In-

stead, the TOC template is used as the main index.html file. 

7.6.3 Editing HTML templates

All the various HTML templates used in your projects can be edited directly in the Configura-

tion section of your project where they are stored. Help+Manual has an integrated HTML

code editor with syntax highlighting, search and replace and spell checking. 

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

667
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To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

Editing HTML templates requires familiarity with HTML:

You must be familiar with manual HTML coding to edit the HTML templates yourself. Your

code is also entirely your own responsibility – it is not syntax-checked in any way by

Help+Manual. Only delete or change code in the standard templates if you really under-

stand what you are doing, otherwise you may experience unexpected errors and malfunc-

tions in your output!

When making code changes it is good practice to publish regularly to test the results of

your changes, otherwise it can be difficult to localize and identify the changes that are

causing a specific problem.

Template locations

HTML template storage location:

All your HTML templates are stored in the main project XML file, inside CDATA sections. If

you are working in uncompressed XML (HMXP mode) this is the file with the name of the

project and the extension .hmxp. This is an XML file that can be edited directly with a

text or XML editor, but it is actually much easier to access the templates directly in

Help+Manual, where you have a code editor with syntax highlighting. 

If you are using the compressed HMXZ format the project file containing the templates is

called project.hmxp and it is stored inside the HMXZ file, which is really just a zip

archive that you can unpack with any zip utility. Again, however, it is much easier to edit

the templates directly in Help+Manual.

Topic page templates location:

In the Project Explorer go to Configuration > HTML Page Templates to edit the tem-

plates for your topics. By default there is just one template called Default that is used for

all topics. However, you can define additional templates and assign them to individual
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topics in Topic Options tab on the left of the main editor window, in the HTML Page Tem-

plate: field. 

These templates are used for all HTML-based output formats. The same templates are

used for all formats, you cannot define different templates for specific output formats.

WebHelp templates location:

In the Project Explorer go to Configuration > Publishing Options > WebHelp to edit the

additional templates for the help frameset (Layout), Table of Contents, Keyword Index and

Search panes in your WebHelp output. 

How to create new HTML templates

Topic page templates:

You can create as many topic page templates for your HTML output as you like and assign

them to individual topics so that selected topics can use different layouts or include differ-

ent features. Just go to Project Explorer > Configuration > HTML Page Templates > De-

fault and click on Add to create a new template. See HTML topic page templates  for

full details and instructions.

Using multiple topic page templates in skins:

You can create multiple topic page templates in skins. However, to be able to use them

you must also create additional page templates with exactly the same names in all the

projects you use with the skins. This is necessary so that you can select the template name

in the Topic Options tab to associate it with individual topics. The contents of the addi-

tional templates in the project are irrelevant because they are not used. You only need the

names so that you can make the association with the topics.

WebHelp templates:

Unlike topic page templates, each project only has one copy each of the templates used

for the main index page (the page containing the frames or iFrames into which navigation

and topic pages are loaded) and the table of contents, keyword index and full-text search

pages. You can edit these HTML pages in Configuration > Publishing Options > We-

bHelp, but if you want to create alternative versions you need to save your project as a

skin . You can then edit the templates in the skin separately from the project and apply

the template versions in the skin to any project when you publish it.

1036
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How to edit HTML templates

All the templates have two editing modes, in two tabs. In the simple mode tab you can

make a number of changes without actually having to edit the HTML code directly. This is

recommended for most users. The HTML source code tab gives you direct access to all the

code of the template – you should only use this option if you have experience with editing

HTML and CSS code.

Simple editing mode:

Note that the Simple Template Layout tab is only available for the standard Default tem-

plate. All additional topic page templates you create can only be edited in HTML Source

Code mode. 

1. Select the template you want to edit then select the Simple Template Layout tab in the

editor window. 

2. Make your changes and additions, then save your project to save your changes. 
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See HTML Page Templates  and WebHelp  in the Reference section for details on the

settings for each template type.

Editing the HTML code:

Note that user-created HTML page templates can only be edited in HTML Source Code

mode.

Disabled Simple Layout tab:

The Simple Layout tab will be disabled as soon as you edit source code to prevent acci-

dental deletion of your custom code. It can only be re-enabled by clicking on the Reset

Template button. This will delete the edited code and replace it with the standard tem-

plate

1. Select the template you want to edit then select the Edit HTML Code tab in the editor

window. 

2. Edit the template in the editor window displayed. The editor supports syntax high-

lighting to make editing easier. See the other sections in this chapter for details on the

contents of the different template types.

1413 1415
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3. When you are finished save your project to store your changes. 

The changes will be applied immediately but most of them may only be visible in your

published output. However, any background colors you set for your topic body and

header will be displayed in the editor directly.

The source code editor for templates

The HTML template source code window is a basic HTML code editor with syntax high-

lighting that makes it easy to see the different components of your template code.

In addition to all the normal editing functions it also has a number of additional features

available in the right-click context menu:

In addition to standard editing features there are two useful tools:

Insert Color Code:

Displays a color picker and inserts the color value as a standard HTML hex triplet (e.g.

#ffffff for white). 

Pixel < > Em Calculator:

Converts values between pixels and ems. This is very useful when you are converting tradi-

tional pixel-based layouts to responsive ems-based layouts. 

Important: Ems are relative!
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Ems is actually a relative value. When converting between pixels and ems you need to

enter the base font percentage value first. This percentage represents the size of your

base font relative to the base font of most browsers, which is 16 pixels. 

For example, if your main body text font is 11 points, that is equivalent to 15 pixels. To get

the same base font size in your output in the majority of browsers you need to set the

base font percentage to 95%, and that will then be equal to 1 em within the context of

your project. 

See also:
Templates and Secondary Windows

Help Windows  (Reference)

7.6.4 HTML topic page templates

The HTML topic page templates are used to define the layout and behavior of topic pages in

all HTML-based output formats (HTML Help, WebHelp, eWriter Help and Visual Studio Help).

Only ePUB eBooks use a special internal template that cannot be edited. 

By default there is just one template called Default which is assigned to new topics automatic-

ally. However, you can define as many different templates as you like. 

You can assign a different template to any topic in the Topic Options tab on the left of the

main editor window. Just select the template you want to use in the drop-down list in the

HTML Page Template: field. 

See Editing HTML templates  for details on how to edit templates.

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 
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Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

Template location

Configuration > HTML Page Templates

Creating and using new HTML page templates

By default there is only one HTML page template called "Default", which is used for all

topics by default (duh...). However, you can create as many new templates as you like and

apply them to individual topics.

Creating a new HTML page template:

1. Go to Project Explorer > Configuration > HTML Page Templates and select the De-

fault template entry. 

2. Click on the Add button at the top left and enter a descriptive name for your new tem-

plate. 

3. The new template is created with the standard default template code, which you can

then edit. Note that the following variables are all required:

<%DOCTYPE%> Enters the HTML page doctype declaration. If you prefer to

use your own specific doctype declaration you can use it in-

stead but you must use either the doctype variable or a valid

doctype declaration. 

<%TOPIC_KEYWORDS
%>

The meta tag with this variable is required if you want your

index keywords to be included in the topic for search en-

gines.

<%DOCCHARSET%> The language/charset of the document. The meta tag with

this variable is required, an error will be displayed if it is not

present.

<%STYLESHEET%> Inserts the reference to the CSS style sheet generated by

Help+Manual. No access to the Help+Manual styles is pos-

sible without this reference.

<%TOPIC_HEADER%> Inserts the topic header. Required if you want your topic to

have a header.
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<%TOPIC_TEXT%> Inserts the topic content in the template. Required, your

topic will not have any content without this variable.

Using your custom HTML page templates:

1. Select the topic where you want to use your own template. 

2. Select the Topic Options tab on the left of the Help+Manual editor window.

3. Select your own template in the HTML Page Template: field. 

Simple Template Layout tab

This tab is only available for the standard Default topic page template. All user-defined

templates can only be edited in the HTML Source Code tab.
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Disabled Simple Layout tab:

The Simple Layout tab will be disabled as soon as you edit source code to prevent acci-

dental deletion of your custom code. It can only be re-enabled by clicking on the Reset

Template button. This will delete the edited code and replace it with the standard tem-

plate.

Background colors:

These settings set the background colors for your topic header and body. The colors will

be shown in the Help+Manual editor.

Text above topic:

Everything you enter in this box is inserted at the top of every topic, before your topic

text. Effectively, this adds a header to your topics (beneath the actual topic header con-

taining the topic title). This text is only shown in your output, not in the Help+Manual ed-

itor.

You can enter HTML tags here to format the text, including references to images.

Topics with headers have <Top>, <Previous> and <Next> links:

This allows you to activate navigation links in your topic headers, either as simple text links

or is a graphical icons. To insert an icon click in the Image File column, click on the 

Browse button and select the file. 

Image files must be located in one of the folders listed in your Project Search Path settings

in Configuration > Common Properties > Project Search Path.

Text below topic:

Everything you enter in this box is inserted at the bottom of every topic, after your topic

text. Effectively, this adds a footer to your topics. This text is only shown in your output,

not in the Help+Manual editor.

Here too, you can enter HTML tags here to format the text, including references to im-

ages.
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HTML Source Code tab

This tab gives you full access to the HTML code of the template file. Editing HTML tem-

plates directly requires experience with editing HTML code. If you are just getting started

with Help+Manual it is advisable to only use the Simple Template Layout tab. This allows

you to use the default template while you are getting used to the program. 

For full details on all the settings in this section see HTML Page Templates  in the Refer-

ence section.

Structure of topic page templates

Topic content:

The most important thing to know about topic page templates is that your final HTML

pages are made by combining code of the template with the contents of the topics edited

in Help+Manual. In HTML terms, the content from the editor is everything between the

<body> and </body> tags, the HTML template provides everything else.

1413
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The content of your topic is inserted in the template at publish time by the variable <%

TOPIC_TEXT%> in the template. When you publish, the HTML page is created by repla-

cing this variable in the template with the content of the current topic.

The topic header:

The topic header is also generated by the template. It is created by the code between the

<IF_TOPIC_HEADER> and </IF_TOPIC_HEADER> conditions. (These condition tags are

always stripped out before your project is published. The output code contains no propri-

etary tags.)

You can add material to the header on every topic page by adding text, links images etc.

between these condition tags. The contents of the header box from the editor is inserted

with the variable <%TOPIC_HEADER%>.

Creating "headers" and "footers":

You can create "headers" and "footers" in the body of your topic by editing the HTML

template and adding material above and below the <%TOPIC_TEXT%> variable.

Everything above this variable will be a header, everything below it will be a footer. This

can also be done in the Simple Template Layout tab, which provides text entry boxes for

this purpose.

Breadcrumb trail navigation links

The <%TOPIC_BREADCRUMBS%> variable can be used to create a "breadcrumb trail" of

navigation links to the topics above the current topic in the TOC tree. This can be useful

for showing the user where they are.

For example, if the current topic is The Editor in the sequence Introduction > About the

Program > User Interface > The Editor, inserting the <%TOPIC_BREADCRUMBS%> variable

would create this series of links in your output (note that the current topic is not included):

Introduction > About the Program > User Interface

The links are active, i.e. clicking on them will take the user to the referenced topics. For ex-

ample, this feature is used to create the breadcrumb trail of links above the headers in the

HTML Help and WebHelp versions of this help.

How to insert a breadcrumb trail:

These instructions show you how to insert a breadcrumb trail at the top of the topic text,

directly below the header. 
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1. Select the Default template in Configuration > HTML Page Templates and locate the

following code: 

<!-- Placeholder for topic body. -->
<table width="100%" border="0" cellspacing="0" cellpadding="5">
<tr valign="top"><td align="left">
<%TOPIC_TEXT%>
</td></tr></table>

2. Add the following code (highlighted in blue):

<!-- Placeholder for topic body. -->
<table width="100%" border="0" cellspacing="0" cellpadding="5">
<tr valign="top"><td align="left">
<IF_TOPIC_BREADCRUMBS><p style="font-size: 8pt; margin-bottom: 15px">
<%TOPIC_BREADCRUMBS%> &gt; <%TOPIC_TITLE%></p></IF_TOPIC_BREADCRUMBS>
<%TOPIC_TEXT%>
</td></tr></table>

The <IF_TOPIC_BREADCRUMBS> condition ensures that the trail is only inserted where it

is relevant. (The breadcrumbs variable is empty in top-level topics and in all topics in the

Invisible Topics section.) 

If you want you can also use <IFNOT_TOPIC_BREADCRUMBS> to insert alternative con-

tent to be displayed in top-level topics.

Note that the title of the current topic is not included in the <%TOPIC_BREADCRUMBS%>

variable because it may not be needed if the topic title is visible directly above the bread-

crumb trail. In our example we have included the current topic title with the <%

TOPIC_TITLE%> variable to show how it is done. (The &gt; code inserts the > character,

which could otherwise be misinterpreted by some browsers.)

For more details on variables and output conditions in HTML templates see HTML tem-

plate variables  and HTML template output conditions .

Breadcrumb trail without active links:

If you need to create a breadcrumb trail without active links you can do this with the <%

TOPIC_TITLE_PATH%> variable. This is almost the same as the breadcrumbs variable but

it creates no links and also includes the title of the current topic. See HTML Template Vari-

ables  for details.

Navigation links to parent chapter

Have you tried clicking the green "home" button in the header of this help? Instead of tak-

ing the user rigidly to the default page of the help it automatically links to the parent

chapter of the current topic, if there is one. If the current topic doesn't have a parent

chapter (for example if its top chapter is a chapter without text) the link will automatically

take the user to the project's default topic.

1569 1577
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You can do this with the variable <%HREF_PARENT_CHAPTER%> . Just use this variable

instead of the <%HREF_DEFAULT_PAGE%> variable in your topic page template.

Everything is automatic – when you publish the correct links are generated automatically

to the parent chapter or the default topic, depending on whether a parent chapter is avail-

able or not.

See also:
Editing HTML templates

Script and CSS components for experts

HTML template variables

HTML template output conditions

Variables

Conditional output

Help Windows

7.6.5 The Layout template for WebHelp

The layout template is usually the source code of the main index.html file for your We-

bHelp. It defines the traditional frameset (Classic layout options for legacy WebHelp) or mod-

ern iFrames (Integrated option) into which the topic and navigation pages are loaded. Basic-

ally it only provides the external framework and tells the browser which files to load into

which frames. This means that you should not normally have any reason to edit it. 

If you choose the No Frames option this template is not used at all. Then, the table of con-

tents  page is used as the main index.html file.

This template is highly specialized and should only be edited if you have advanced HTML

editing skills. It is essential for the proper functioning of the entire navigation system in We-

bHelp and editing errors you make here can easily make your help unusable. 

See Editing HTML templates  for details on how to edit templates and Script and CSS com-

ponents for experts  for more details on the content of the template.

Template location

Configuration > Publishing Options > WebHelp > Layout

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.
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Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

See also:
Editing HTML templates

HTML template variables

HTML template output conditions

Variables

Conditional output

Script and CSS components for experts

7.6.6 The TOC template for WebHelp

This HTML template is only used in WebHelp. It generates the Table of Contents (TOC) pane

in the frame layout that emulates the appearance and functionality of the HTML Help viewer

in a normal browser. 

Be particularly careful when editing this template! The TOC template is an integral part of the

dynamic TOC of your WebHelp output. Its code is essential for the proper functioning of the

help. 

When you publish the actual table of contents for your project is inserted in the TOC page by

the <%TABLE_OF_CONTENTS%> variable. 

See Editing HTML templates  for details on how to edit templates and Script and CSS com-

ponents for experts  for more details on its contents.

Template location

Configuration > Publishing Options > WebHelp > Table of Contents

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-
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bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

Script links for expanding and collapsing the TOC

You can use the following code to create links that will allow the user to expand and col-

lapse the entire TOC with a single click:

In the TOC or topic page template pages:

<a href="javascript:parent.fullexpand()">Expand the TOC</a>
<a href="javascript:parent.fullcollapse()">Collapse the TOC</a>

In the main layout template page, or in the TOC page if "No Frames" is selected:

<a href="javascript:fullexpand()">Expand the TOC</a>
<a href="javascript:fullcollapse()">Collapse the TOC</a>

See also:
Editing HTML templates

Variables

Conditional output

Help Windows

Script and CSS components for experts

7.6.7 The Keyword Index template for WebHelp

This HTML template is only used for WebHelp. It generates the keyword index pane within the

frame layout that emulates the appearance and functionality of the HTML Help viewer in a

normal browser. 

The keyword index template is an integral part of the help viewer generated by Help+Manual

for WebHelp. Its code is essential for the proper functioning of the index. Please be extremely
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careful when you are editing this template. If you don't understand what a piece of code is for

it's better to leave it alone!

When you publish the actual keyword index is inserted in the Index page by the <%

KEYWORD_INDEX%> variable. 

See Editing HTML templates  for details on how to edit templates and Script and CSS com-

ponents for experts  for more information on the contents of the template. 

Template location

Configuration > Publishing Options > WebHelp > Full Text Search

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

See also:
Editing HTML templates

Variables in HTML templates

Conditional output in HTML templates

Script and CSS components for experts

7.6.8 The Search template for WebHelp

This HTML template is only used in WebHelp and is only active if you have the Professional or

Floating license version of Help+Manual, which include a bundled, royalty-free license for the
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Wrensoft Zoom web search engine necessary for full-text search in WebHelp. It generates the

Search pane in the frame layout that emulates the appearance and functionality of the HTML

Help viewer in a normal browser. 

The Search template is an integral part of the full-text search function in the WebHelp output.

Its code is essential for the proper functioning of the search function. Please be extremely

careful when you are editing this template – if you don't understand what a piece of code is

for it's better to leave it alone!

The standard search script is inserted in the Search page by the <%SEARCH_SCRIPT%> vari-

able. You can't edit this script but you can configure all the text used in the script and other

features. See Full Text Search  in the reference section for details on the configuration op-

tions for Search.

See Editing HTML templates  for details on how to edit templates and Script and CSS com-

ponents for experts  for more information on the template contents. 

Template location

Configuration > Publishing Options > WebHelp > Full Text Search

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

See also:
Editing HTML templates
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Script and CSS components for experts

Variables

Conditional output

Help Windows

7.6.9 HTML font families and headings

Defining font families for HTML output formats

The fonts you define may not always be present on the user's system or may be restricted

by some browsers. To avoid just getting the browser's default font you can define font

"families" for the fonts you use. This is a list of alternative fonts that the browser will use

instead of your chosen font if it is not available. 

The font families settings

The settings for this are in Configuration > Publishing Options > WebHelp > HTML

Fonts. The same settings are available in the section for Microsoft HTML Help. The fonts

you define are global and are used in all HTML output formats (WebHelp, CHM, eWriter,

Kindle, ePub and Visual Studio Help). 

How to define font families

Help+Manual already has families defined for most common fonts. You can edit the exist-

ing families by clicking in the entry. To add a new family just scroll down to the bottom of

the list and click in the first empty row.

Rules for font families

· The first entry is the name of the font you are defining the family for.
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· Insert a comma after each font name that is followed by another font name.

· All font names that contain spaces must be enclosed in single quotes.

· The browser will choose the first alternative font in the list that is available, so define

the family in order of preference.

· Always insert a standard, web-safe font as the last option if you are using fonts that

may not be available.

Generating H1 .. H6 styles for WebHelp

When you are targeting WebHelp you want the main headings in your topics to use the

standard HTML H1 through H6 heading styles so that search engines like Google will

automatically identify the important subjects in your topics. You can achieve this by using

Help+Manual's Heading1...Heading6 style naming convention.

Styles called Heading1 ... Heading6 are exported as H1 .. H6 in HTML

· Getting this to work is simple. Just use styles called Heading1 through Heading6 for

the headings in your topics that you want to export as H1 through H6 in your HTML

output.

· The Heading1 style is a predefined standard style that is automatically used for the text

in your topic headers by Help+Manual, so the titles of your topics are always automatic-

ally exported as H1 styles in HTML.

· To use H2 through H6 headings just define additional styles called Heading2 through

Heading6 and use them for your sub-headings in your topics. They will then be expor-

ted as H2 through H6.

See also:
Text Formatting and Styles

7.6.10 Variables in HTML templates

You can use all global predefined variables and user-defined variables in all HTML templates.

In addition to this there are a number of special HTML template variables, which are only rel-

evant in HTML templates.

User-defined variables from your projects and skins are exported to a JavaScript object for

reference in your scripts. See below for details.

In addition to these variables you can also use predefined and user-defined conditional

switches to include or exclude content on the basis of conditions. This is particularly useful for

variables, which are often only relevant in certain contexts. For details see Conditional output

in HTML templates .
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Key Information
When you are using a skin  remember that variables can be stored

either in your project or in the skin. However, if you create variables with

the same name in both the project and the skin, the value defined in the

skin will be used. 

Variables reference

More information on the variables and conditions that you can use in HTML templates can

be found in the following locations:

· List of global predefined variables

· List of HTML template variables

· Creating user-defined variables

· List of HTML template output conditions

How to use user-defined variables in HTML templates

You can use all your user-defined variables in HTML templates, including HTML variables

for inserting HTML code. Just type in the variable in the position where you want to use it

in the standard format, complete with the opening <% tag and the closing %> tag.

Example:

...
<br /><br />
</IF_TOPIC_HEADER>
<br /><hr />
By: <%HELPAUTHOR%>
<br /><hr />
<%TOPIC_TEXT%>
</body>
</html>

The above example inserts the contents of the user-defined variable between horizontal

rules above the topic text on every page.

User-defined variables in your own scripts

In WebHelp, all your user-defined variables are exported as JavaScript variables in a .js

file called hmvariables.js. This file combines both the user variables defined in your

project and those defined in your WebHelp skin, if you are using one. If the same variable

is defined both in your project and your skin the definition in the skin takes precedence

and gets exported to the .js file. 
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You can make these variables available for use in your scripts in your templates by loading

this file prior to referencing the variables, like this:

<script src="hmvariables.js"></script>

The variables are stored in an object called hmConfigVariables  and the variables

themselves are stored in all upper case. So if you have a variable called PROJECTVERSION

you would reference it as:

hmConfigVariables.PROJECTVERSION

The values are always strings. If you want to use the values as numbers, Boolean values

etc. you need to convert them before using them. 

How to use predefined variables in HTML templates

You can use both the global variables and the special HTML template variables. They are

used just in the same way as user-defined variables. Just type them into the template in

the position where you want to use them. Always type the variables exactly as shown in

the variable lists, complete with the opening <% tag and the closing %> tag.

Example:

...
<%TOPIC_TEXT%>
<IF_HTML>
<br><br><hr><center>Page URL: 
<a href="http://www.domain.com/help/index.html?
<%HREF_CURRENT_PAGE%>" target="top">http://www.domain.com/help/index.html?
<%HREF_CURRENT_PAGE%></a></center>
</IF_HTML>
...

The above example inserts the web URL of the current page at the bottom of every topic

page in WebHelp. (This makes it easy for support staff to give users the address of specific

help topics in the online version of your help.) 

Using editable variables in HTML templates

You can redefine both global and user variables in individual topics, by assigning a new

value to the variable for the topic in Topic Options tab on the left of the main editor win-

dow. This is particularly useful for HTML templates because it enables you to insert indi-

vidual code and text in your templates for on a per-topic basis. For example, you can ref-

erence different versions of JavaScript files in individual topics or insert individual texts in

the head section of the page for search engine optimization. 
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1. Use your user-defined or global variables normally in your HTML template. (This is

particularly useful for HTML variables!). 

2. Select the topic where you want the variable to have a different value. Select the Topic

Options tab on the left of the main editor window and add the variable and its new

value in the Topic Variables section. 

See The power of editable variables  for more detailed instructions.

See also:
Editing HTML templates

Global predefined variables  (reference list)

HTML template variables  (reference list)

Conditional output in HTML templates

The power of editable variables

7.6.11 Conditional output in HTML templates

You can use all of Help+Manual's standard conditional output options in HTML templates,

both your user-defined include options  and options based on the current output format. In

addition to this there are a few special conditional switches which are only for use in WebHelp

output, because they are only relevant there. See the lists below for details.

These conditions are used to enclose blocks of HTML code in your template that you want to

include in the output only if the condition is fulfilled. The condition tags themselves are never

included in your output code, they are always stripped from the code before publishing. 

Conditions based on the output format are only relevant in the HTML topic page tem-

plates  which are used in HTML Help, WebHelp, Windows Exe and ePUB eBooks and Visual

Studio Help. The TOC, search and keyword index templates are only used in WebHelp so it

does not make sense to use format-based conditions there since the output format is always

WebHelp.
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If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

Conditional output reference

For more information on the available output conditions, variables and how to use them

see the following topics:

· List of HTML template output conditions

· Defining your own include options  

· List of global predefined variables

· List of HTML template variables

· Creating user-defined variables

Template conditional tags are hard-wired to the output format

Conditional tags in HTML templates look very similar to the conditions you use for con-

tent in your project. However, there is one very important difference: In templates, the

true/false status of the conditions is hard-wired to the output format and cannot be

changed. 
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In the Publish screen you can include content tagged for other output formats than the

one you are currently publishing to by activating the checkboxes for those formats manu-

ally. This has no effect on the conditional tags in your templates, however. This is very im-

portant, because in templates you will often want to exclude code that would cause errors

in some output formats. If this wasn't the case, including content tagged for WebHelp in a

CHM file the Publish screen could cause serious errors if that also included template code

tagged exclusively for WebHelp in a CHM file. 

How to use include options in HTML templates

Like most HTML tags each condition has an opening tag and a corresponding closing tag,

using the same </ syntax to identify the closing tag as all regular tags. Simply enclose the

code you want to include conditionally between the two tags. 

Note that the ELSE condition is not available in HTML templates.

Examples:

<IF_TOPIC_HEADER>
<font size="3">This text only appears in the topic if the topic has a
<b>header</b>.<br><br>
It will not be included in popup topics, which never have a header, or in topics
assigned 
help window types defined without a header.</font>
</IF_TOPIC_HEADER>

<IFNOT_PREVIOUS_PAGE>This text will only be displayed in 
the very first topic in your help.</IFNOT_PREVIOUS_PAGE>

<IF_NEXT_PAGE>
<a href="<%HREF_NEXT_PAGE%>">Click here to jump to the next topic</a>
</IF_NEXT_PAGE>

The last example only displays the link if there is a next topic to jump to. 

How to use user-defined conditions

Basically this is exactly the same as using the predefined include options, you just have to

use the following syntax rules to create your conditional switches from the names of your

include options in Configuration > Common Properties > Custom Builds :

Syntax:

Opening tag: < + IF_ + OPTION + >

Closing tag: </ + IF_ + OPTION + >

NOT version: < + IFNOT_ + OPTION + >

1410
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NOT closing tag: </ + IFNOT_ + OPTION + >

Examples:

This example shows how to use the user-defined include options ALPHABUILD and

BETABUILD:

<IF_ALPHABUILD>
This text will be included if ALPHABUILD is selected in the Include Options in
the 
Make Help File & Run dialog.
</IF_ALPHABUILD>
<IFNOT_BETABUILD>
This text will be excluded if BETABUILD is selected in the Include Options in
the 
Make Help File & Run dialog.
</IFNOT_BETABUILD>

Using multiple conditions with OR or AND logic in HTML templates

If you want to allow for multiple conditions with OR or AND logic in your HTML templates

you can do this as well.

Multiple conditions with AND logic

If you want to include content in a template only if multiple conditions are all true, you

just need to nest the condition tags. Then the content inside the conditions will only be in-

cluded if all the tags in the nesting chain are true. For example, suppose you want to in-

clude some code only if the output is a CHM file and the user-defined option CLIENT1 are

both true:

<IF_CHM><IF_CLIENT1>
This text will only be included if both CHM and CLIENT1 are true.
</IF_CLIENT1></IF_CHM>

The order is irrelevant, but you must be careful not to "cross" the end tags. In the example

above, both CLIENT1 tags must be inside the CHM tags.

Multiple conditions with OR logic

If you want to include content in a template if any one of multiple conditions is true you

can include multiple conditions inside a single tag, separated by the | character. 

Important:

Note that this does not work with IFNOT conditions, only with IF conditions!
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<IF_CHM|HTML|CLIENT1>
This text will be included if any one or more of the 3 conditions is true.
</IF_CHM|HTML|CLIENT1>

Here too, the order is irrelevant, but you should use the same order in the start and end

tags.

See also:
HTML template output conditions  (reference list)

Editing HTML templates

Variables in HTML templates

7.6.12 Graphics references in HTML templates

You can reference external graphics in HTML templates. Help+Manual parses the template

code for image references and automatically includes the graphics in your output. 

In addition to this you can also embed graphics in your project by adding them to the Bag-

gage Files.  Baggage graphics are always exported automatically when you publish and

they can be referenced without any path information in all HTML-based output formats. See

below for details.

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.
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Supported graphics types and how to reference them

Graphics types:

You can use any image types supported in HTML pages. This will generally be JPG, GIF,

PNG and SVG images. Note that SVG images have restrictions in the CHM format. See

here for details .

Referencing graphics stored in your project folder and search

path:

Graphics files stored in your project folder and in folders listed in your project search

path  can be referenced in the supported tags (see below) without any path informa-

tion, like this:

<img src="logo23.jpg" width="200" height="42" />

The files will be located and exported with your published output automatically. 

Referencing graphics with other tags:

If you use other tags to reference your graphics you must add the graphics to your Bag-

gage Files or copy them to your output folder manually to ensure that they are exported

(see below).

Referencing graphics stored in other locations:

If your graphics files are stored elsewhere you must include an absolute or relative path to

the current location of the graphics files in your template code. Here too, this feature is

only supported for certain tags (see further below on this page for details). For example:

<img src="../source files/graphics/logo23.jpg" width="200"
height="42" />

If you use absolute paths it is advisable to use UNC path syntax, for example:

<img src="\\?\C:\Users\Robert\Desktop\Source Images\image7.jpg" />
<img src="\\MainServer\HelpStuff\Graphics\image10.jpg" />

When you publish Help+Manual will locate the files using the path you enter and then

strip the path in the published files and export the files with your output. The resulting

code in the three examples above would look like this:

498
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<img src="logo23.jpg" width="200" height="42" />
<img src="image7.jpg" />
<img src="\image10.jpg" />

Where to store your source graphics files:

If you store the referenced external graphic files in the project directory (i.e. in the same

directory as the .hmxz or .hmxp project file) or reference the files with paths to their loc-

ation at publish time in your code they will be exported automatically. Alternatively you

can add the files to your project's Baggage Files – see below for instructions.

Supported HTML image reference tags

Images referenced in your templates and stored in your project folder will only be found

and exported automatically when they are referenced in the HTML tags listed below. 

All other image tags and attributes are ignored. If you reference graphics in your tem-

plates in any other way you should add the images to the Baggage Files (see below) or

copy them to your output folder manually to ensure that they will be exported. This also

includes the variant images for mouseover buttons as they are not referenced with the

tags listed above!

Automatically

Parsed Tags

Supported Attributes

<body> Images referenced with the background="" attribute.

OR

Images referenced within the style="" attribute using the

syntax 

style="background: #FFFFFF url(image.jpg)" 

(this can be combined with other style elements, of course)

<img> Images referenced with the src="" attribute

<table> Images referenced with the background="" attribute

OR

Images referenced within the style="" attribute using the

syntax 

style="background: #FFFFFF url(image.jpg)" 
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(this can be combined with other style elements, of course)

Adding graphics to your project's Baggage Files

The easiest way to ensure that graphics files and other files referenced in your HTML tem-

plates are located and exported correctly is to add them to your project's "Baggage" in

Project Files > Baggage Files in the Project Explorer. Then you can use any tag references

you like and you don't need to worry about whether the files will be exported and integ-

rated in your output. 

All files in the Baggage Files section are integrated in your project automatically and can

be referenced in your template code without any path information. 

See Using Baggage Files  for more information and instructions.

See also:
Graphics in HTML templates  (Reference)

Editing HTML templates

Variables in HTML templates

Conditional output in HTML templates

Using Baggage Files

7.6.13 Featured images for chapter titles

The Featured Image and Description  settings in the Topic Options tab associate individual

graphic images and descriptions with any topic. You can reference the description text and

the image with variables in your HTML page templates to display the description text and the

image together with the topic content. For example, you can display a title image with an

overlaid description  as used in Help+Manual's own online help, as shown below:

1119
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The featured image and description are used to replace 

the topic heading in the main top-level chapters

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

667
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Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

Variables and include conditions for description and featured image

You insert and control the description and images with two variables and one pair of in-

clude conditions:

<%TOPIC_PICTURE%> This inserts the file name of the topic image for the current

topic so that you can display it in your template. You use it

in an image tag, like this:

<img src="<%TOPIC_PICTURE%>"/>

Image file names must be HTML-compatible! No spaces, ac-

cented characters, non-ASCII characters or non-alphanu-

meric characters allowed!

The associated image is exported automatically. You don't

need to add any path information, because the image is al-

ways accessible directly with its name.

<%TOPIC_DESCRIPTION
%>:

Inserts the topic description text as plain text. When you are

inserting it in a template you will need to include it in an ap-

propriate HTML tag, for example a paragraph tag:

<p><%TOPIC_DESCRIPTION%></p>

<IF_TOPIC_PICTURE>
...
</IF_TOPIC_PICTURE>

<IFNOT_TOPIC_PICTUR
E> ...
</IFNOT_TOPIC_PICTU
RE>

These conditions make it possible to include or exclude

HTML template content based on whether the current topic

has an associated featured image. For example, you will

usually only want to use title images for top-level chapters,

and the normal topic header in normal topics with no asso-

ciated images.

<IF_TOPIC_PICTURE>
    
    Code for the title image version goes
here...

</IF_TOPIC_PICTURE><IFNOT_TOPIC_PICTURE>

    Code for the normal header version goes
here....
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</IFNOT_TOPIC_PICTURE>

7.6.14 Referencing external files

With the exception of a limited number of graphics references , external files you reference

in your template code are not automatically exported with your project because Help+Manual

does not know about them. There are two ways to solve this problem:

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

Add the files to your project's Baggage

The easiest way to ensure that graphics files and other files referenced in your HTML tem-

plates are located and exported correctly is to add them to your project's "Baggage" in

Project Files > Baggage Files in the Project Explorer. Then you can use any tag references

you like and you don't need to worry about whether the files will be exported and integ-

rated in your output. 

All files in the Baggage Files section are integrated in your project automatically and can

be referenced in your template code without any path information. 

1056
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See Using Baggage Files  for more information and instructions.

Manually integrate the files in your output

In WebHelp you must manually copy the files to your output directory if you have not

added them to the Baggage (see above). The only exception to this are image files refer-

enced in supported tags,  which are exported automatically. 

In HTML Help you need to tell the compiler to include the files in the CHM file. Proceed

as follows:

1. Copy the external file(s) to your project directory (the directory containing your .hmxz

or .hmxp project file). 

2. In the Project Explorer go to Configuration > Publishing Options > HTML Help > Ex-

tended .HHP Settings .

3. In the Additional Settings editing box add the following entries:

[FILES]
..\functions.js
..\updatelist.txt

Don't add a second [FILES] header if one already exists. Enter each external filename on

its own line below the [FILES] header and precede it with the ..\ relative path reference.

This relative path reference is necessary because the project is published from a tempor-

ary subdirectory in the project directory, so files in the project directory are one level up. If

your files are stored elsewhere you need to adjust the path accordingly.

See also:
Using Baggage Files

7.6.15 Script and CSS components for experts

This topic is only relevant for users with extensive HTML, CSS and JavaScript coding experi-

ence. It explains how the standard script and other references are managed in the various

templates and how you can manipulate them for your own needs.

Key Information
Note that all these instructions also apply for tem-

plates in skin files . Skins contain the same tem-

plates as normal projects, in the same locations.

Script components used in the templates

Help+Manual uses the  jQuery JavaScript framework in CHM and WebHelp output for

more efficient JavaScript coding and effects. The compressed version of the latest jQuery
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script file is exported and referenced automatically in the templates. There are also addi-

tional CSS script files included by Help+Manual for layout and dynamic functions. If you

are familiar with HTML, CSS and JavaScript coding, you can change the positions of the

references to these files, leave them out entirely or write your own modified versions of

the style definitions and functions they contain.

Which HTML templates are used where and when...

The WebHelp Layout template contents depend on the layout op-

tion chosen

The contents of the layout template change depending on whether you choose "Integ-

rated", "Classic 2 Frames" or "Classic 3 Frames" in Configuration > Publishing Options >

WebHelp > Layout. In the Integrated version, HTML5 is used and the topic and navigation

pages are loaded in modern iFrames. The Classic versions use a traditional frameset (now

deprecated) and load the topic and navigation pages into conventional frames. The same

JavaScript files are used in all three versions, however. 

The "No Frames" option disables the Layout template

The layout template is not used at all if you choose the "No Frames" option. Then the

Table of Contents template is set as the main index.html file and the contents of the

layout template are irrelevant for your output because the template is not present.

HTML Topic Page templates are (almost) always used.

The topic page templates in Configuration > HTML Page Templates are used by almost

all HTML-based output formats (CHM, WebHelp, eWriter Help and Visual Studio Help

2008 and 2010). 

Exception: ePUB and Kindle/Mobi

The ePUB and Kindle/Mobi eBook formats us a special template stored in  Configuration

> Publishing Options > eBooks > ePUB + Kindle: Page Template. This template can also

be edited there, but please only change it if you are familiar with the eBook specifications.

The WebHelp Table of Contents, Index and Search templates

The contents of the WebHelp Table of Contents, Index and Search templates define three

separate pages for these functions. They are loaded into the navigation frame in WebHelp

and eWriter Help when they are displayed. Some skins load them in the background so

that they are always present and can be switched to without reloading.
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Templates in the "No Frames" Layout Option

If you choose the "No Frames" option,  the Layout template is disabled and is not used. In-

stead, the TOC template is used as the main index.html file. 

Switches: Turn off inline CSS in the TOC, disable UI redirect script,
export keyword index as list box  

There are some additional special switches and options you can use to get more control

over your HTML output in WebHelp.

Turn off inline CSS in the TOC

Normally, Help+Manual writes a certain amount of inline CSS style code in the TOC elements

so that our own scripts can manage the functionality of the TOC better. However, you can

turn this off completely if you want full control over the TOC formatting for your own pur-

poses. 

To do this you just need to insert the following special comment anywhere in the <head>

section of the TOC template  page:

<!--HM_NO_INLINE_CSS-->

Insert it exactly as shown above, with no spaces and on a single line of its own. This will export

the entire TOC tree without any inline CSS styling. 

Redirect topics to full WebHelp UI

Redirecting topics to the full WebHelp user interface

Search engines will usually only link to WebHelp topics by the topic name, instead of using

the full index.html?topic.htm syntax.  You can activate an automatic redirect to show

the full WebHelp user interface when this happens. Open your project (if you are not using a

skin) or the .hmskin skin file (if you are using a skin) in Help+Manual. Then in the Project Ex-

plorer on the left go to Configuration > Publishing Options > WebHelp > Navigation. 

Locate the option "When a topic is loaded outside the navigation frame, force it to reload the

navigation frame" and turn it ON.

Google will not index WebHelp using automatic redirects from the

topic to the full WebHelp UI

In the past, Help+Manual automatically activated this option. Unfortunately, Google now in-

terprets redirects like this as "duplicate content" and does not index any of the WebHelp topic

pages on a site that does this. This option is now turned off by default and you should not ac-

tivate it if you want to be indexed by Google. 

1044
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Alternative option in standard and Premium Pack skins

The standard WebHelp skins included with Help+Manual and the Premium Pack skins now

have a solution for this problem. When a page is opened on its own an automatic link above

the topic header is shown that the user can click on to open the full user interface. This does

not trigger the problem with Google.

Export the keyword index as a list box

Normally the keyword index is exported as a combination of <div> and <table> ele-

ments and the formatting is handled automatically by Help+Manual. If you want to

control it entirely yourself you can insert a switch that will tell Help+Manual to export

the keyword index as a list box (<select> element with <option> elements). Note

that when you do this you must also provide your own JavaScript and CSS code for

managing the index! On its own, the list box is as dead as a doornail!

To do this you just need to insert the following special comment anywhere in the

<head> section of the Keyword Index  template page:

 <!--HM_KEYWORD_INDEX_AS_LIST-->

Insert it exactly as shown above, with no spaces and on a single line of its own. This will

export the keyword index and its contents as a list box that you can style and manage

as you like. 

Script and CSS components in the WebHelp Layout template (for in-
dex.html)

The template in Configuration > Publishing Options > WebHelp > Layout defines the

main index.html file in your WebHelp output if you are using one of the integrated lay-

out options. If you choose the No Frames option the Table of Contents template is used

for the main index.html file and the contents of the Layout template are not used at all.

This template is then not relevant.

CSS components:

The CSS stylesheet generated from the styles defined in your project is referenced in the

Layout template with this line of code:

<link type="text/css" href="<%STYLESHEET%>" rel="stylesheet" />

This reference is not strictly required in the layout template and you may be able to re-

move it if none of your project styles are referenced in the template. If you want to re-

define or extend any styles referenced there simply place an include for your own

stylesheet or your own inline style code directly after this reference. Store your .css

1045
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stylesheet file in the Baggage Files  section of your project, then it will be exported

automatically. 

In addition to this there is inline CSS code for the components of the layout file itself. You

can edit this if you want, but the results are entirely your responsibility. 

Referenced script files:

The following three files are referenced in index.html file. 

jquery.js The jQuery script file containing all the jQuery functions.

helpman_set-

tings.js:

Settings and configuration variables used by Help+Manual's

scripts.

helpman_naviga-

tion.js

Functions used in the main layout page for the table of con-

tents and dynamic layout features.

Changing the positions of the main script files

The three script files (jquery.js, helpman_settings.js and helpman_naviga-

tion.js) can be inserted as a block using the following special script include with the <%

NAVIGATION_SCRIPT%> variable for the source . 

<script type="text/javascript" src="<%NAVIGATION_SCRIPT%>"></script>

To control the position of all three files together just place the above line in the place

where you want them to appear. If you want to control them individually do not use the

above line or the <%NAVIGATION_SCRIPT%> variable. Instead, add the lines individually

in the places where you want them to appear.

<script type="text/javascript" src="jquery.js"></script>
<script type="text/javascript" src="helpman_settings.js"></script>
<script type="text/javascript" src="helpman_navigation.js"></script>

If you don't use the <%NAVIGATION_SCRIPT%> variable Help+Manual will not insert any

of these lines automatically. So you can exclude any of the files in this template by not us-

ing the variable and leaving out the include of the file you don't want to use. 

Don't try to use both the <%NAVIGATION_SCRIPT%> variable and the explicit includes! If

you do, you will get double entries!

Using your own version of jQuery

If you want to use a different version of jQuery for any reason, you can. Just save it in the

Baggage Files section of your project and make sure that the file is called jquery.js,

1119
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then it will overwrite the version exported by Help+Manual. If you want you can also in-

clude your own version with a different name and reference it in your own include line.

Redefining functions in the scripts

If you want to redefine any of the functions in the existing scripts just define your own

versions in scripts added inline or with includes after Help+Manual's own versions, refer-

encing Help+Manual's scripts explicitly as shown above so that they come first. If you use

a script file rather than inline code put it in your Baggage Files section, then it will be ex-

ported automatically. 

Use the variable syntax without the "var" identifier (you're redefining functions that

already exist!) to redefine any functions, like this:

functionName = function(arg1, arg2, ...) {
your code here...
}

Script and CSS components in the HTML topic page template

The template(s) (you can define multiple page templates ) in Configuration > HTML

Page Templates define(s) the HTML pages into which the rendered contents of your top-

ics are inserted when you publish your project to an HTML-based output format. This is

CHM, WebHelp, EXE eBooks and Visual Studio Help 2008 and 2010 but not Apple

iBooks/ePUB. The ePUB output uses a special hard-wired template that cannot be edited.

CSS components:

The CSS stylesheet generated from the styles defined in your project is referenced in the

HTML topic page template with this line of code:

<link type="text/css" href="<%STYLESHEET%>" rel="stylesheet" />

This reference is essential for the proper formatting of your topic content as designed in

the Help+Manual editor! If you want to redefine or extend any styles referenced there

simply place an include for your own stylesheet or your own inline style code directly after

this reference. Store your .css stylesheet file in the Baggage Files  section of your pro-

ject, then it will be exported automatically. 

Referenced script files:

The following four files are referenced in topic page templates. 

jquery.js The jQuery script file containing all the jQuery functions.

1037
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helpman_set-

tings.js:

Settings and configuration variables used by Help+Manual's

scripts.

helpman_topi-

cinit.js

Functions used to initialize the topic pages and provide addi-

tional functionality there.

highlight.js This file is used by the Wrensoft Zoom full-text search engine

for WebHelp to provide highlighting for the search results if

you have activated highlighting. It is inserted and referenced

automatically and you can't change its position. It should be

considered to be hard-wired and off limits.

Changing the positions of the main script files

If the template does not already contain includes for the main script files (jquery.js,

helpman_settings.js and helpman_topicinit.js) the include lines are inserted

automatically. If you want to change the positions of the main script files you just need to

insert the include lines in the template yourself in the position where you want them to

appear. For example, you may want to make sure that the jQuery reference comes before

some functions of your own that include jQuery:

<script type="text/javascript" src="jquery.js"></script>
<script type="text/javascript" src="helpman_settings.js"></script>
<script type="text/javascript" src="helpman_topicinit.js"></script>

If these includes appear anywhere in the <head> section Help+Manual will not insert its

own versions.

Using your own version of jQuery

If you want to use a different version of jQuery for any reason, you can. Just save it in the

Baggage Files section of your project and make sure that the file is called jquery.js,

then it will overwrite the version exported by Help+Manual. Also, any include whose src=

attribute starts with the characters "jquery" will also prevent Help+Manual from writing its

own include line for jQuery, so if you want you can also include a version with a different

name.

Redefining functions in the scripts

If you want to redefine any of the functions in the existing scripts just define your own

versions in scripts added inline or with includes after Help+Manual's own versions, refer-

encing Help+Manual's scripts explicitly as shown above so that they come first. If you use

a script file rather than inline code put it in your Baggage Files section, then it will be ex-

ported automatically. 
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Use the variable syntax without the "var" identifier (you're redefining functions that

already exist!) to redefine any functions, like this:

functionName = function(arg1, arg2, ...) {
your code here...
}

Script and CSS components in the WebHelp TOC template

The template in Configuration > Publishing Options > WebHelp > Table of Contents

defines the contents of the table of contents page in WebHelp. 

Without frames, the TOC is the main page

This page is used in two different ways, depending on which layout option you choose in

the Layout template. If you choose "Integrated" or "Classic 2-Frame" or "Classic 3-Frame"

the TOC page is loaded into an iFrame or conventional frame in the main index.html

page defined by the layout template. If you choose "No Frames" the layout template is

not used and the TOC page is used as the main index.html page. The page contains

script that checks whether it is in a frame or being opened on its own.

CSS components:

The CSS stylesheet generated from the styles defined in your project is referenced in the

HTML topic page template with this line of code:

<link type="text/css" href="<%STYLESHEET%>" rel="stylesheet" />

This reference is not strictly required in the TOC template and you may be able to remove

it if none of your project styles are referenced in the template. If you want to redefine or

extend any styles referenced there simply place an include for your own stylesheet or your

own inline style code directly after this reference. Store your .css stylesheet file in the Bag-

gage Files  section of your project, then it will be exported automatically. 

Special CSS components for the TOC list:

The actual CSS that controls the layout of the TOC itself is only used in this page and it is

thus inserted as inline code. The first lines simply define the text formatting of the text

levels (six levels are defined – you should not normally need more than 4 levels in your

TOC if you want your users to actually read your documentation). This is then followed by

this extremely important block of code:

/* TOC LIST CSS */
#toc    { padding: 0; margin: 0; }
#toc li { margin-top: 2px; }
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#toc ul { padding-left:0; }
/* TOC LIST CSS */

You can adjust the spacing and positioning of the individual entries in the TOC with pad-

ding and margin values in these CSS lines. 

Referenced script files:

The TOC is a special case when it comes to script file references. In the frame-based layout

options (Integrated and the Classic frame layouts) all the TOC manipulation is performed

from the main layout page. There are calls to functions in the TOC, but they reference

scripts in the parent layout page. There are thus no direct includes for the jQuery and

other script files in this page. 

If the TOC is opened on its own without the layout page (No Frames option, or the user

opens the TOC directly) the initialization script in the TOC page identifies this and loads

the following three scripts dynamically:

jquery.js The jQuery script file containing all the jQuery functions.

helpman_set-

tings.js:

Settings and configuration variables used by Help+Manual's

scripts.

helpman_naviga-

tion.js

Functions used to initialize the topic pages and provide addi-

tional functionality there.

Loading the main script files yourself

If for any reason you want to reference any of the main script files yourself you can do this

with standard includes entered in the template code:

<script type="text/javascript" src="jquery.js"></script>
<script type="text/javascript" src="helpman_settings.js"></script>
<script type="text/javascript" src="helpman_navigation.js"></script>

If you do this, Help+Manual will automatically remove the dynamic load options for the

script files you reference from the code it generates. You are most likely to need to do this

with jQuery, if you want to use your own jQuery functions within the TOC page, for which

you will need an instance of jQuery inside the page's own namespace. But you may also

want to have access to the variables in the settings file or force a specific position for the

navigation file in the template code for cases where the TOC is loaded on its own.

Doing this will not interfere with the functioning of Help+Manual's own TOC code. If the

parent layout page is present, the navigation functions in the layout page's instance of the

script will still be used automatically. 
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Using your own version of jQuery

If you want to use a different version of jQuery for any reason, you can. Just save it in the

Baggage Files section of your project and make sure that the file is called jquery.js,

then it will overwrite the version exported by Help+Manual. Also, any include whose src=

attribute starts with the characters "jquery" will also prevent Help+Manual from writing its

own dynamic load line for jQuery, so if you want you can also include a version with a dif-

ferent name.

Redefining functions in the scripts

If you want to redefine any of the functions in the existing scripts just define your own

versions in scripts added inline or with includes after Help+Manual's own versions, refer-

encing Help+Manual's scripts explicitly as shown above so that they come first. If you use

a script file rather than inline code put it in your Baggage Files section, then it will be ex-

ported automatically. 

Use the variable syntax without the "var" identifier (you're redefining functions that

already exist!) to redefine any functions, like this:

functionName = function(arg1, arg2, ...) {
your code here...
}

Script components in the WebHelp Keyword Index template

The template in Configuration > Publishing Options > WebHelp > Keyword Index

defines the contents of the Keyword Index pane file in your WebHelp output. If you are

using the integrated layout option the page is loaded into the navigation pane iFrame

when the user views the Index (or into the navigation pane frame if you are using one of

the classic layouts).

CSS components:

The CSS stylesheet generated from the styles defined in your project is referenced in the

HTML topic page template with this line of code:

<link type="text/css" href="<%STYLESHEET%>" rel="stylesheet" />

This reference is not strictly required in the index template and you may be able to re-

move it if none of your project styles are referenced in the template.  If you want to re-

define or extend any styles referenced there simply place an include for your own

stylesheet or your own inline style code directly after this reference. Store your .css
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stylesheet file in the Baggage Files  section of your project, then it will be exported

automatically. 

In addition to this there is inline style code that defines how the components of the

keyword index are displayed. You can edit these styles if you wish to achieve your own

results. 

Referenced script files:

The following two files are referenced in keyword index template. 

jquery.js The jQuery script file containing all the jQuery functions.

helpman_set-

tings.js:

Settings and configuration variables used by Help+Manual's

scripts.

Changing the positions of the script files

The script files (jquery.js, and helpman_settings.js) are inserted automatically at

the end of the <head> section if they are not referenced explicitly in the template code. If

you want to change the positions of the includes just add the following explicitly in the

places where you want them to appear. Help+Manual will then not add them automatic-

ally.

<script type="text/javascript" src="jquery.js"></script>
<script type="text/javascript" src="helpman_settings.js"></script>

Using your own version of jQuery

If you want to use a different version of jQuery for any reason, you can. Just save it in the

Baggage Files section of your project and make sure that the file is called jquery.js,

then it will overwrite the version exported by Help+Manual. If you want you can also in-

clude your own version with a different name and reference it in your own include line. As

long as the src= attribute begins with the characters "jquery" Help+Manual will identify it

as a jQuery include.

Redefining functions in the scripts

If you want to redefine any of the functions in the existing scripts just define your own

versions in scripts added inline or with includes after Help+Manual's own versions, refer-

encing Help+Manual's scripts explicitly as shown above so that they come first. If you use

a script file rather than inline code put it in your Baggage Files section, then it will be ex-

ported automatically. 

1119
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Use the variable syntax without the "var" identifier (the functions already exist!) to redefine

existing functions, like this:

functionName = function(arg1, arg2, ...) {
your code here...
}

Script components in the WebHelp Full Text Search template

The template in Configuration > Publishing Options > WebHelp > Full Text Search

defines  the contents of the Full Text Search pane file in your WebHelp output. If you are

using the integrated layout option the page is loaded into the navigation pane iFrame

when the user views the Search (or into the navigation pane frame if you are using one of

the classic layouts).

CSS Components:

The CSS stylesheet generated from the styles defined in your project is referenced in the

HTML topic page template with this line of code:

<link type="text/css" href="<%STYLESHEET%>" rel="stylesheet" />

This reference is not strictly required in the search template and you may be able to re-

move it if none of your project styles are referenced in the template.  If you want to re-

define or extend any styles referenced there simply place an include for your own

stylesheet or your own inline style code directly after this reference. Store your .css

stylesheet file in the Baggage Files  section of your project, then it will be exported

automatically. 

In addition to this there is inline style code that defines how the components of the search

components are displayed. You can edit these styles if you wish to achieve your own res-

ults. Do so with care, because the search components are quite finicky.

Tip: If you find that you are unable to get line spacing to do what you want in the search

components this is because the Wrensoft Zoom search engine is doing quite a bit of line

spacing with hard <br /> tags. The only way to deal with this is to analyze the generated

code with a tool like Firebug and use JavaScript to remove these hard breaks on the fly. 

Referenced script files:

jQuery is not used by default in the Search page. Also, the entire "script" package is inser-

ted by the <%SEARCH_SCRIPT%> variable and all its components should normally be in

the same place. If you leave this variable out you must do everything manually. The fol-

lowing two files are referenced in keyword index template. 
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zoom_search.js The Wrensoft Zoom search engine script.

helpman_set-

tings.js:

Settings and configuration variables used by Help+Manual's

scripts (may also contain search settings).

Changing the position of the script files

Normally you would only change the position of the entire search script block by adjust-

ing the position of the <%SEARCH_SCRIPT%> variable. If you want to leave it out for any

reason you should study the normal output carefully and insert everything manually. 

7.6.16 Troubleshooting

When you edit HTML templates manually Help+Manual does not verify the code in any way.

You are entirely responsible for checking and testing the code you write. It is a always good

idea to back up your template in an external text file before editing.

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

667
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Back up your template before editing

You can always revert to the standard default template with the Reset Defaults button

(see below), but you should make backups of working versions of your own edited tem-

plates before you make more changes. Reverting to the default template overwrites the

entire template with the standard version – it does not return you to your own previous

version.

Copy the entire contents of the template, paste it to an editor and save it in an external

file. Then if anything goes wrong you can always paste the original version from the saved

file back into the template editing window.

Test your output regularly

Sooner or later, editing your HTML templates will cause errors in your output. This cannot

be avoided and it happens to the best of us. 

If you make a lot of different changes before testing your output it can be very difficult to

localize which change is causing the problem. To avoid this kind of frustration you should

always make changes gradually, one step at a time. After each change, publish and test

your output before proceeding to the next change. Then you will always know which

change is causing the problem and it will be much easier to correct.

In WebHelp you can also edit your output files directly to avoid the publishing step.

However, doing this can be a little tricky because you always need to remember to copy

every change back into your project before proceeding.

If something goes wrong revert to the default template

You can always restore the default template. Just select Reset in the template editing

screen. 

However, this will completely replace your version of the template with the standard ver-

sion, so you will also lose any earlier changes you may have made to it. If you have not

already done so, make a backup of your own version before reverting to the default 

See also:
Editing HTML templates

7.7 Working with Style Repositories

Terminology Warning!

1030
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Don't confuse "style repositories" with the repositories

used in version control systems !

A style repository is a special uncompressed Help+Manual project that you use to share

stylesm snippets and to a certain extent also variables between multiple projects. This is an

excellent way to ensure that your styles are standardized across multiple projects. It is also a

good way to make sure that everyone uses the same standard formatting when you are work-

ing on a project in a team . 

Ideally, you should edit the styles for all the projects in the style repository, not in the indi-

vidual projects. So if you only have individual projects with their own styles it is really more

practical to work without a repository. 

Professional and Floating license versions only

Please note that support for style repositories is only included in the Professional and

Floating license versions of Help+Manual. Style repositories are not available in the Basic

version.

Differences between a style repository project and a normal project

A style repository is quite similar to a normal uncompressed HMXP project. The main dif-

ference is that it does not have a table of contents, because you never publish a repository

project directly. It is a storage place for the text and paragraph styles used in other pro-

jects, allowing you to share the same set of styles between multiple projects. 

Topic files in style repositories can be shared as snippets

A style repository can also contain topic files, which are available as snippets to all the

projects that are linked to the repository. Since the snippets use the styles in the style re-

pository, and the repository styles are available in all the projects using the repository, the

formatting of the snippets is always correct. You don't need to worry about having match-

ing styles in your own project, because the styles are already there.

Variables in style repositories are shared ONCE

If you define variables in your style repository they will also appear in the projects to

which the repository is linked. However, the values of the variables are not dynamically

linked, even if the styles are. The values of the variables in your projects will NOT update

when their values are changed in the repository.

848
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7.7.1 Creating and using style repositories

You can create a style repository from any Help+Manual project. You just need to select Save

As... in the File menu and then select Save as Repository as the project type to save. You need

to save to an empty folder, just as you do for a normal uncompressed HMXP project. After

saving you need to "register" the style repository with the Repository Manager, which makes

it available for use in your projects.

Productivity Tip
The objective should be to edit your repository styles

in the style repository, not in the projects linked to the

style repository. This ensures consistency across all

projects using the style repository.

The purpose of creating a style repository is primarily to have a standard set of paragraph and

text styles that you can share between multiple projects. The style repository links and imports

these styles to the projects where it is used, and you can update the styles for all the projects

by editing the styles in the style repository. 

Step 1: Create a style repository directly or from a project

You can create a style repository directly, or from a project. If you already have a project

containing the styles and/or topics you want to use in the repository then it's easiest to

create the repository from the project. Otherwise you can just create a new, empty repos-

itory.

Repository save location must be accessible to all authors

It's important to save the style repository directly to the location where you are going to

use it, because the it is registered automatically when you save it. If you need to change

the registration later you can do this with the Repository Manager (see further below).

The folder where you save the style repository should be accessible for all authors who are

going to work on projects that will use the style repository, so you may want to save it on

a network drive. The connection to the style repository is a "live" link. It is accessed act-

ively while you are working on your projects because the project is using the styles from

the style repository.

Creating a new repository directly

1. Select the New Project option and then choose Repository as the project type to cre-

ate. 
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Note that saving the project as a style repository removes the Table of Contents from the

project. The topic files in the style repository are only accessible in the Project Files >

Topic Files section. 

Creating a repository from an existing project

You can use the Save as... option in the File menu to save an existing project as a reposit-

ory. This can also be used to create copies of existing repositories.

1. Choose the project containing the topics and/or styles you want to use in your repos-

itory. 

2. Select Save As... in the File menu and choose Save as Repository as the save option.

Choose an empty folder to save the style repository in. If the style repository is going

to be used in team projects it should be saved on a network drive where all team

members have access. 

Note that saving the project as a style repository removes the Table of Contents from the

project. The topic files in the style repository are only accessible in the Project Files >

Topic Files section. 

Step 2: Register the style repository with the Repository Manager

This step is not necessary on the computer that created the style repository, because sav-

ing a repository automatically registers that repository with that copy of Help+Manual. 

Every other author who is going to use the style repository needs to perform this step in

their copy of Help+Manual to make the repository available for their projects. The style

repository must be registered with the Help+Manual program, not with the project.

1. In the Project Explorer, select the Repository Manager in the File menu to open the Re-

pository Manager: 
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2. Click on the Add button and select the style repository that you want to register.

See Repository Manager  for more details.

Step 3: Attach the style repository to your project

1. Open your project in Help+Manual and select Repository Manager in the File menu. 

2. Select the style repository you want to use in the Use this Repository drop-down list.

1293
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3. Select Link or Copy mode for your styles: 

Link repository

styles:

This is the standard option. The style repository's styles are used

in your project but they are not editable in your project. You

can only edit the styles in the style repository, not in the pro-

ject. 

Use this option for standardizing your styles with the style

repository as the only styles source.

Copy repository

styles:

This option links the style repository styles to your project but

also allows you edit them in the project, creating local variants

of the central repository styles. 

Use this option if you just want to use the style repository

as a starting-point for a project.

Important Notes: 

Using a style repository overwrites existing styles!

Attaching a style repository to a project automatically overwrites all styles in the project

with the style repository styles that have the same names, in both Link and Copy mode!

Unique styles will remain unchanged, but all styles with matching names will be replaced

with the style repository styles. This is not reversible – only styles unique to the style re-

pository can be removed when you unlink the repository – so make backups before exper-

imenting! 
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You can only link one style repository to a project!

Since a style repository is a designed as a control center for styles you can only link one

style repository to a project. Multiple repositories would not make sense, because then

you would have conflicts between the styles.

Unlinking a style repository from your project and switching reposit-
ories

You can also "unlink" a style repository from a project if you want to remove its associ-

ation and its unique styles. You can also switch from one style repository to another. 

Important note: When you unlink a style repository any standard or existing styles that

were changed by importing the repository styles will not be switched back to their original

settings. 

Unlinking a style repository:

1. Open your project in Help+Manual and select Repository Manager in the File menu. 

2. Select Project does not use a repository in the Use this repository: drop-down list, then

click on OK. 

3. The resolve styles dialog  will be displayed in which you can choose which reposit-
ory styles you want to keep or remove. By default, all the unique repository styles will
be removed from the project.

1295
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Switching style repositories:

1. Open your project in Help+Manual and select Repository Manager in the File menu. 

2. Select the style repository you want to switch to and click on OK. 

3. Here too, a dialog will be displayed in which you can choose which repository styles
you want to keep or remove.

See also:
Repository Manager

7.7.2 Styles in style repositories

The primary purpose of a style repository is to have a common source of styles for multiple

projects. It makes it possible for you to edit the styles of multiple projects in a single location.

You can also share snippets  with a style repository, but the styles are the "glue" that the

repository uses to keep your projects synchronized. 

In a nutshell: You can use style repositories to import styles to your projects and to share

styles with multiple projects so that you are sure that you are using the same styles in all your

related projects. You can also lock repository styles so that all team members working on a

project can only use the predefined styles, because the styles can only be edited in the style

repository project.

Additional settings in style repositories

In addition to styles and snippets, you can also share some other settings with style repos-

itories:

Topic ID Prefix

This is the prefix that is automatically added to new topic IDs. If this is defined in Config-

uration > Common Properties > Miscellaneous Options in the style repository project it

will be used in all projects linked to the repository.

Editing styles centrally in the style repository

When you link a style repository to your project its styles are imported to the project and

they are also linked to the project. When the styles are updated in the style repository the

changes are reflected in all the projects that use the repository. To get maximum benefits

from this, you should always only edit the styles in the repository. You can prevent acci-

dental editing by selecting Link mode  for your styles when you associate the style re-

pository with the proejct. 

1293
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1. Select Open in the File menu and select .hmxr as the file type to open. 

2. Open the style repository project and edit your styles just as you would in a normal

Help+Manual project. The changes will be reflected in the projects using the style re-

pository the next time you open the projects. 

3. If the project is open when you edit the style repository please close and re-open the

project to refresh the styles from the repository.

Editing styles in your local project

Link mode: Styles not editable locally

When the repository styles are connected to your project in Link mode  you cannot edit

them in your local project. When you open Edit Styles  this is indicated by red shield

icons on the styles:

Copy mode: Styles editable locally

When the repository styles are connected to your project in Copy mode  you can edit

them in your local project. When you open Edit Styles  this is indicated by little "key"

icons on the styles:

1080
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When you have edited a style locally this is shown by a "User" icon, as shown above. The

edited local settings are then used instead of the style settings in the style repository.

However, your styles are still linked to the style repository! Any settings you haven't

changed in the local project will be taken from the style repository and will be updated if

you edit the styles in the repository.

Resetting locally edited styles:

To reset a locally-edited style just select it in the style editing dialog and click on Remove

Style. Then it will revert back to the version in the style repository and the User icon will be

removed. 

Switching between Copy and Link mode for styles:

You can switch between Copy and Link mode  by changing the setting in the Repository

Manager.

Editing a project when the style repository is not available

Sometimes you may need to edit a project when the style repository it is linked to is not

available. That is fine, because full copies of all the styles from the repository are stored in

your project when you link it to the repository. This only works for style repositories asso-

ciated with your project in Link mode . 

You will not see changes someone else makes to the repository styles while you are work-

ing in this way, of course, but they will update as soon as the style repository is available

again – for example when you are back in the office and your laptop is connected to the

office network where the style repository is stored.

See also:

1080
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Repository Manager

7.7.3 Snippets in style repositories

In addition to styles, a style repository can also contain topic files. These files are automatic-

ally available to all projects linked to the style repository as snippets. They can be inserted dir-

ectly with the Insert Snippet tool , with the special From Repository section.

Since the repository styles are also available in all linked projects, all the snippets contained in

the style repository will be formatted the same in all the linked projects where they are used.

In addition to this, the style repository provides an easy, centralized place to edit the snippets.

Just as with the repository styles, editing the topic files in the style repository automatically

updates the content of the snippets in all projects where they are used.

This only applies when you link the snippets, of course! If you insert the snippets in paste

mode they become part of the target topic and later changes to the source will not have any

effect. 

Using and editing style repository snippets

Using style repository snippets:

· Topics stored in a style repository are available automatically as snippets as soon as the

repository is linked to a project. To insert a snippet from the linked style repository just

select the snippet tool and use the From Repository option to access the repository

snippets. See Re-using content with snippets  for details.

Editing style repository snippets:

To edit the snippets in the style repository you need to open the repository and edit the

topic files there. 

1. Select Open in the File menu and select .hmxr as the file type to open. 

2. Open the style repository project and edit the topic files just as you would in a normal

Help+Manual project. Note that style repositories don't have a table of contents. You

need to edit the files in the Project Files > Topic Files section.

Editing a project when the style repository is not available

Sometimes you may need to edit a project when the style repository it is linked to is not

available. When you do this your linked snippets will not be visible because the link is

"live". You will just see entries in your topics showing that the snippets cannot be found.

They will become visible again as soon as the style repository is available again – for ex-
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ample when you are back in the office and your laptop is connected to the office network

where the style repository is stored.

What you can't do is insert new snippets from the style repository when the repository is

not available. After all, it's not available... 

See also:
Repository Manager

7.7.4 Variables and build options

If you define variables and custom build options  in a style repository they will also appear

and be available in the projects to which the repository is linked. 

When you link the repository, all the variables and custom build options in the repository that

do not exist in the project are copied to the project. Variables with the same names as those

in the repository that already exist in the project are skipped and left unchanged; their values

do not update with different values from the repository.

Similarly, any custom build options defined in the repository will be copied to the project

when it is linked. 

Variables and build options are not linked like styles

At present, this is really just a convenience for sharing variables to multiple projects. It is a

simple copy operation performed when the repository is linked to the project. The values

of the variables are not dynamically linked in the same way as the styles. The values of the

variables in your projects will NOT update when their values are changed in the repository,

and the variables will not be removed from the project if you delete them in the reposit-

ory. Similarly, the values in the repository will not change if you edit the variables in the

project.

In the same way, build options imported from a repository are not linked to the repository

in any way. Deleting them or changing their descriptions in the repository does not have

any effect on the versions in the project. Similarly, deleting them or editing their descrip-

tions in the project will not have any effect on the versions in the repository.

Updating variable values from a repository

The only way to force the values of a variable in a project to update with a changed value

in the repository is to delete the variable in the project. Then the variable will appear again

with the new value from the linked repository the next time the project is loaded. 

So to update your repository variables you need to delete them in your project and reload

the project. You can select and delete multiple variables with CTRL+Click (individual vari-

ables) and SHIFT+Click (blocks of variables).

1293
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This is admittedly not all that practical, because you need to do this for all the variables in

all your projects every time you change the values of the variables in the repository. In a

future major release of Help+Manual we plan to make repository variables dynamically

linked as well. 

7.8 Working with Modular Help Systems

A modular help system is a help system that consists of multiple Help+Manual projects that

can be published as a single project. This can make it easier to manage large projects.

In addition to this, it may sometimes be practical to break up projects into modules when you

are working in a team, even though it is also possible for all team members to work in the

same project together in Help+Manual Professional. For example, individual team members

may want to work on their parts of the project on their laptops.

See Modular Projects  in the Reference section for some more background information on

modular help systems.

See also:
Modular Projects  (Reference)

7.8.1 Support in output formats

Modular projects in HTML Help (CHM)

In and HTML Help (CHM) you can create genuinely modular help systems, in which your

output consists of multiple help files that are all displayed in a single Table of Contents

(TOC). This makes it possible to create different versions of your help simply by including

or excluding help file modules from your distribution package: Modules that are not there

are excluded from the TOC automatically.

Master projects in runtime HTML Help (CHM) projects

In modular HTML Help (CHM) projects in which the child projects are merged in runtime

mode , the master project must contain at least one topic and the default topic must be

set in the master project. If you don't do this you will get an error opening the main CHM

and the indexes of the child CHMs won't be available. 

Modular projects in other output formats

You can also use Help+Manual's modular project features in other output formats.

However, here the advantages of using modular projects is only available during the edit-

ing stage. The output is always a single integrated help system. It is effectively the same as

publishing your help from one large project. 

1547
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7.8.2 Creating and editing modular projects

Creating a modular project is just as easy as adding a topic to a project. Once you have added

the child project its TOC is displayed as part of the current project's TOC and you can edit it

directly if you turn off read-only mode (see below).

When you publish the master project the entire TOC of the child project is inserted in the

master TOC at the point where you insert the child project in the master TOC tree.

See Modular Projects  in the Reference section for some more background information on

modular help systems.

Productivity Tip
By default child modules are inserted in read-only

mode. This is recommended for multi-user editing,

otherwise all topics in child projects will be locked for

all users. You can turn off read-only mode in Configur-

ation > Common Properties > Miscellaneous.

How to create a master project

A master project is a normal Help+Manual project. The only thing that makes it a "master"

is the fact that it contains child projects. You can create either an "empty" master project

or a master project with content:

· An empty master project is a project without any topics of its own. It is simply a
framework for handling your child projects, and all the items in its TOC are child pro-
jects. 

· A master project with content also has its own topics. Your child projects are inserted
in the TOC along with the master project's own topics.

This distinction is actually a little arbitrary. You can always add topics to the master project

at any time, even if it is empty when you start. The only thing you need to remember is

that the master project's own topics will always be included in the output.

How to add child projects

1. Click at the point in the master project's TOC where you want to insert the child pro-

ject (module). 

2. Select Add Topic in Project > Managing Topics and then select the Include Help Pro-

ject option.

1547
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3. In the Project File: field click on the  Browse button and select the .hmxz or .hmxp

project file you want to include.

Merge content on publishing: If you select this mode the external project's contents

will be displayed in the TOC of the current project and can be edited directly if you

turn off read-only mode (see below). Merged projects are still stored externally and

their topics are identified by small green icon in the TOC. 

Merge content at runtime: This is for HTML Help only and just inserts a placeholder

in the TOC. The projects must be edited and published separately and are only

merged when the user views them if the help files are all present in the same folder. 

4. Click on OK to insert the child project in the TOC. 
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Display for a project inserted 

with publish time merging    

Display for a project inserted 

with runtime merging

The "Merged Projects" section and modular projects not included in
the TOC

When you are merging your modules on publishing it is possible to include an entire pro-

ject module in your publishing output without including it in the TOC. In supported output

formats all the topics of the module will then be present, but only accessible via hyperlinks

in your other topics,  and the full-text search and keyword index (CHM, WebHelp, eWriter,

VS Help). 

How this works

This is the same as including a single topic without a TOC entry by creating it directly in

the Project Files > Topic Files section in the Project Explorer, or by deleting its TOC entry

without deleting the associated topic file. The only difference is that this then applies for

all the topics in the project module.
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The Merged Projects section in Configuration

When you add a child module in the TOC using the publish-time merge method,

Help+Manual automatically creates an entry for it down in Configuration > Merged Pro-

jects:

These entries are similar to the entries for topic files in the Project Files > Topic Files sec-

tion. Just as the TOC entries for normal topics point to the topic files in the Topic Files sec-

tion, the entries for project modules in the TOC point to topic files of the projects in the

Merged Projects section. 

The entries in Merged Projects are automatically given the build option None so that their

contents are not included in your output when you exclude them from the TOC:

How to include a "hidden" child project in your output

Here too, the method is similar to including a topic without a TOC entry. Instead of adding

the module to the TOC, you just right-click on the Merged Projects and select Add

Merged Help Project in the context menu displayed.
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Change the include options to include the project's topics

When you insert a project module like this its include options will initially be set to None.

To include its topics in your output you need to right-click on its entry in Merged Projects

and set its include options in the Include in Builds context menu so as to include its topics

in the output formats where you want this to happen.

Using multiple TOCs with modular projects

You can also use additional TOCs in your master project in order to create alternative out-

puts using different combinations of modules and native topics from the master project.

You just need to create an additional TOC and insert references to the child modules

there.

See Multiple TOCs  for details on how to create and manage additional TOCs.

How to edit the child project

Saving child projects separately

When you select Save As.. in a modular project Help+Manual always saves the master pro-

ject. You must edit child projects separately if you want to save copies of them.

Publish time merging:

If you choose publish merging the project will immediately be displayed as part of your

project's TOC and you can edit its topics directly, as though they were part of the current

project. The topics of merged projects are identified with green icons on the TOC entries.

343
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Read-only mode:

By default the project will be inserted in read-only mode to prevent accidental changes.

You can activate editing in Configuration > Common Properties > Miscellaneous. If you

are using multi-user editing you should leave read-only mode ON, otherwise all the topics

of child projects will be locked for all other users as long as you have the master project

open. 

Runtime merging:

If you choose runtime merging a placeholder is inserted in the TOC in the position in

which the child project will be inserted. You can edit the child project by right-clicking on

the placeholder and selecting Edit Child Project.

How to access a child project's files and configuration settings

Even when the TOC of the your child project is visible in the master TOC you cannot see

all the child's Topic Files and Configuration settings directly. Only the topics with TOC

entries are actually displayed in the master TOC. You can access topic files without TOC

entries and the child's configuration settings in the Merged Projects section in the Project

Explorer:

This section is located right at the bottom of the Configuration section. Note that like the

TOC, the files and settings of merged projects are only shown for projects inserted in pub-

lish-time merging mode. Runtime-merged projects are just placeholders and are not really
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part of your project, they must be opened and edited separately. 

How to change the merge method

The merge method for HTML Help (CHM) is selected when you insert the child project. To

change it you must remove the child project from the TOC and re-insert it with the other

merge method.

1. Select the main module item in the Project Explorer and press DELETE or select Add

Topic > Delete in Project > Manage Topics. 

2. Insert the same module again, selecting the other merge method.

Note that merge options are only relevant for HTML Help (CHM). In all other output

formats the master and child projects are always published together as one large help

project, which is the equivalent of publish time merging.

Setting a global help window for runtime merging

When using runtime merging it is advisable to define a global "window name" for all the

projects in the modular help system. This improves the performance of links to your help

from your applications. When you define a global help window, all calls to the help system

will open in the same CHM help viewer. Without a global window, you will get additional

help viewers opening when calls are made first to one module and then to another.

The global help window option is set in Configuration > Publishing Options > Microsoft

HTML Help > Help Windows . You need to set the same global window name in all

projects in the modular help system, including the master project. 

If you use this option the global help window name must begin with $global_, followed

by an identifier consisting only of alphabetic characters. You must use the same global

name in all the projects.

Examples of valid global window names:

$global_main_mycompany
$global_widgethelp

Important – make sure your window name is unique!

Don't use the standard $global_main name! If you do it is quite possible that some other

software on the user's computer will also be using that name and then your help could

open in their help window!

1453
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Exporting runtime modules to other formats

When you insert a module in runtime mode it will only be published to HTML Help (CHM).

 If you want to publish the same module to other formats you must insert it in your TOC a

second time in publish-time mode. When you do this you should also set the include op-

tions for each version so that the correct version gets published automatically depending

on the output format you choose:

 

Setting the include options:

Just right-click on the main module "node" (spiky green icon) in the TOC, select Include in

Builds in the context menu and then set the include options appropriately. Make sure that

you set the options so that it is not possible to export both versions together!

You can also access the include options in Manage Topics > Change in the Project tab. See

Conditions and Customized Output  for more details on using include options.

See also:
Modular Projects  (Reference)

7.8.3 Merge methods for CHM

In Microsoft HTML Help CHM files you can create genuine modular projects with separate

help files that are displayed in a single TOC. This is called "runtime merging". Alternatively,

you can also combine all your modules to one large help file, just like the output from a single

project. This is called "publish-time merging".

969
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Choosing the merge method is only relevant for HTML Help. All other output formats use

publish-time merging only, merging all the modules in your project to create output that is

exactly the same as output generated from a single project.

See Runtime and publish time merging  in the Reference section for full details of the cap-

abilities of these two different output methods for modular projects in HTML Help. 

Master projects in runtime HTML Help (CHM) projects

In modular HTML Help (CHM) projects in which the child projects are merged in runtime

mode , the master project must contain at least one topic and the default topic must be

set in the master project. If you don't do this you will get an error opening the main CHM

and the indexes of the child CHMs won't be available. (This is caused by uncorrected bugs

in the Microsoft HTML Help system.)

How to choose and change the merge method

You can set the merge method separately for every child project you insert. You choose

the merge method when you insert the child project. 

Important: The project filenames and the output filenames CHM files must be identical.

The references between the child and the master help files are based on the

filenames and if project and output filename don't match the references will

be invalid. 

Choosing the merge method while inserting a child project:

· Select Merge content on publishing or Merge content at runtime when you are inserting

the child project  in your master project.

1551
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Changing the merge method after inserting the child project:

To change the merge method just remove the module from the TOC and re-insert it with

the other merge method. You cannot change the merge method of a module without re-

moving it from the TOC first.

1. Select the main module item in the Project Explorer and press DELETE or select Add

Topic > Delete in Project > Manage Topics. This does not delete the project on the

disk, it only removes it from the TOC of the master. 

2. Insert the same module again, selecting the other merge method.

Setting a global help window for runtime merging

When using runtime merging it is advisable to define a global "window name" for all the

projects in the modular help system. This improves the performance of links to your help

from your applications. When you define a global help window, all calls to the help system

will open in the same CHM help viewer. Without a global window, you will get additional

help viewers opening when calls are made first to one module and then to another.

The global help window option is set in Configuration > Publishing Options > Microsoft

HTML Help > Help Windows . You need to set the same global window name in all

projects in the modular help system, including the master project. 

1453
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If you use this option the global help window name must begin with $global_, followed

by an identifier consisting only of alphabetic characters. You must use the same global

name in all the projects.

Examples of valid global window names:

$global_main_mycompany
$global_widgethelp

Important – make sure your window name is unique!

Don't use the standard $global_main name! If you do it is quite possible that some other

software on the user's computer will also be using that name and then your help could

open in their help window!

Publishing runtime modules to other formats

When you insert a module in runtime mode it will only be published to HTML Help (CHM).

 If you want to publish the same module to other formats you must insert it in your TOC a

second time in publish-time mode. When you do this you should also set the include op-

tions for each version so that the correct version gets published automatically depending

on the output format you choose:

 

Setting the include options:

Just right-click on the main module "node" (spiky green icon) in the TOC, select Include in

Builds in the context menu and then set the include options appropriately. Make sure that

you set the options so that it is not possible to export both versions together!
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You can also access the include options in Manage Topics > Change in the Project tab. See

Conditions and Customized Output  for more details on using include options.

Additional merge options for HTML Help

In HTML Help you can specify what happens when the user tries to open the child CHM

module directly instead of the master module.

1. Open the Configuration section of the child module in the Project Explorer and select

Publishing Options > HTML Help > Extended .HHP Settings. 

2. In the section If this is a child file, merged at run time select the Table of Contents you

want to open when the user opens the file directly.

If you select the master file TOC option opening the child file will be exactly the same as

opening the master file – the entire integrated TOC of the master file will be displayed.

Otherwise the child file will open on its own, just like any other HTML Help file.

See also:
Modular Projects  (Reference)

7.8.4 Links and search in runtime CHM

When you create runtime-merged modular CHM help systems there are two key issues that

you need to consider for the proper integration of the modules:

· How to manage calls to topics in the child CHM modules

· How to ensure that search works in all the CHM modules

Managing calls to topics in the child CHM modules

The Microsoft CHM system cannot automatically route your help calls through the master

module to the child modules. When you call a topic in a child module you have to make

the call to that CHM file, in exactly the same way as if it were a normal, independent CHM.

There is no problem there. You just need to know that you make the calls to the child

CHM module directly and it will work.

However, if you don't configure the CHM correctly, a call to the child CHM will only open

that CHM. The user won't see the TOC of the merged CHM system, and that isn't what you

want. You need to tell the CHM viewer that you want the full TOC from the master.

1. Open the child module project in Help+Manual and in the Project Explorer navigate

down to Configuration > Publishing Options > Microsoft HTML Help > Extended

.HHP Options. 

2. On the lower right, check the settings under the heading If this is a child file merged at

runt time...

969
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3. Select Table of contents of the master file: and enter the name of the master CHM that

is going to be used in your runtime modular help system. This file name should not

contain any spaces.

4. Repeat this for all the projects for your CHM child modules.

Ensuring that search works for all the runtime modules

When the user opens the help from the master module, either directly or with a call from

your software, search will always include all the modules in the runtime help system. This

is because Help+Manual automatically includes references to all the available child mod-

ules in the master, and if they are there then they will be searched.

This cannot be done automatically in the child modules. They are just independent help

files, and normally they don't and can't know anything about the other modules. If you

make a call to a child file the search will then only be performed in that file's topics unless

you tell the CHM system that you also want to search in the other modules. 

Like displaying the TOC of the master, this is also something that you configure in the Ex-

tended .HHP Options:

1. Open the child module project in Help+Manual and in the Project Explorer navigate

down to Configuration > Publishing Options > Microsoft HTML Help > Extended

.HHP Options. 

2. In the Additional settings for the HHP file: box enter this heading on the first line (see

screenshot below):

[MERGE FILES]

3. Then enter the names of all the other CHM files in the modular runtime system, in-

cluding the master file. Enter one file on each line, like this:

[MERGE FILES]
master_file.chm
module1.chm
module2.chm

4. Repeat steps 1-3 for all the projects for your CHM child modules.

Note: Always include all the modules that might ever be used in the runtime help system.

It is fine for modules that are not present to be listed. If they are not found they will just

be skipped without an error.
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Setting a global help window for runtime merging

When using runtime merging it is advisable to define a global "window name" for all the

projects in the modular help system. This improves the performance of links to your help

from your applications. When you define a global help window, all calls to the help system

will open in the same CHM help viewer. Without a global window, you will get additional

help viewers opening when calls are made first to one module and then to another.

The global help window option is set in Configuration > Publishing Options > Microsoft

HTML Help > Help Windows . You need to set the same global window name in all

projects in the modular help system, including the master project. 

If you use this option the global help window name must begin with $global_, followed

by an identifier consisting only of alphabetic characters. You must use the same global

name in all the projects.

Examples of valid global window names:

$global_main_mycompany
$global_widgethelp

Important – make sure your window name is unique!

Don't use the standard $global_main name! If you do it is quite possible that some other

software on the user's computer will also be using that name and then your help could

open in their help window!

1453
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7.8.5 Managing modules in the TOC

You can manage module entries in the Table of Contents (TOC) in exactly the same way as

regular TOC items. 

Moving module entries

You can move module entries and change their level in exactly the same way as any other

TOC entries. 

To move a module entry: 

Modules can be moved around in the TOC in the same way as ordinary topics. You just

need to select the main module node in order to be able to manipulate it like a topic

entry:

Select the main module entry in the TOC with the mouse and drag it, or use the normal

copy and paste methods to move by copying and pasting. 

· Select the entry and use cut and paste. 

· Use the  and  buttons in Write > Manage Topics.

To change the level a module entry:

Select the entry and click on the Promote  and Demote  buttons in Write > Manage

Topics.
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To delete a module entry:

Select the entry and press DELETE, or select Add Topic > Delete in Write > Manage Top-

ics. (This does not delete the module project, it just removes the module entry from the

current TOC.)

Using multiple TOCs with modular projects

You can also use additional TOCs in your master project in order to create alternative out-

puts using different combinations of modules and native topics from the master project.

You just need to create an additional TOC and insert references to the child modules

there.

See Multiple TOCs  for details on how to create and manage additional TOCs.

Replacing modules

You can easily replace one module with another one if you need to, without deleting it

first.

1. Select the module in the TOC. 

2. On the right under the module reference, select the Bind to another project button.

This displays a simple dialog:

3. Select the new project you want to insert in the Project File: field. If it contains multiple

TOCs you can select the TOC to insert.

343
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4. Select the merge method (Publishing / Runtime) and click on OK to replace the existing

module reference.

Forbidden: copying modules, second copies of modules, circular mod-
ule references

Copying modules:

"Copying" modules is not possible because they are really only references to entire help

projects. Also, you cannot copy modules within the same project because duplicate mod-

ule references are forbidden. If you want to insert the same module in a second project

you must do this directly.

Duplicate modules:

Similarly, you cannot insert a second copy of a module entry within the same project. This

is not allowed because it would cause irreconcilable conflicts because of the duplicate

topic IDs and context numbers it would create. 

Circular module references:

This is something you need to be aware of yourself because Help+Manual cannot prevent

it automatically and it can cause serious errors. A circular reference is a module that con-

tains another module that then contains the first module. For example, suppose Project A

contains Project B as a module. If you then open Project B on its own and try to insert Pro-

ject A as a module the results in your output can be both unpredictable and unpleasant.

Don't do it. 

Using include options on your modules

You can use conditional output include options on entire modules in the same way as you

can on individual topics. To do this select the main module entry in the TOC and then se-

lect Project > Change > Include in Builds to select the include options for the module.

You can also access the include options by right-clicking on the main module entry in the

TOC. See Modular projects include options  for full details. 1002
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How to access a child project's files and configuration settings

Even when the TOC of the your child project is visible in the master TOC you cannot see

all the child's Topic Files and Configuration settings directly. Only the topics with TOC

entries are actually displayed in the master TOC. You can access topic files without TOC

entries and the child's configuration settings in the Merged Projects section in the Project

Explorer:

This section is located right at the bottom of the Configuration section. Note that like the

TOC, the files and settings of merged projects are only shown for projects inserted in pub-

lish-time merging mode. Runtime-merged projects are just placeholders and are not really

part of your project, they must be opened and edited separately. 

See also:
Modular Projects  (Reference, more background information)1547
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7.8.6 Managing graphics in modules

It's always important to avoid duplicate filenames for your graphics because of the way

Help+Manual manages graphics and locates your graphics files . This applies in particular

for modular projects, because you will often have separate graphics folders for each project. 

Duplicate names are OK if you use runtime merging  because then each module is pub-

lished individually and the correct graphics will be used. However, if you use publish time

merging  Help+Manual will only find the first instance of any duplicates as it searches

through the graphics folders to locate the correct files.

Use filename prefixes for graphics files in modules

· The simplest solution for this problem is to add a unique prefix to the filenames of

graphics files used in modules, in the same way that you use prefixes for the topic

IDs  in modules. 

· The prefix should be short – two letters and an underline character are usually plenty –

and should identify the module.

See also:

Managing your graphics

7.8.7 Managing IDs and context numbers

In modular projects you also have to devote some thought and planning to topic IDs and

context numbers . Modules are separate projects and Help+Manual can only prevent con-

flicts caused by duplicate IDs and context numbers within a single project. This means you are

responsible for making sure that you do not have duplicates in the modules you are going to

include in your help system.

When you need to avoid duplicates

Duplicates are forbidden in publish time merging , which is the only available merge

mode for all output formats except HTML Help (CHM). Duplicate topic IDs and help con-

text numbers in modules merged at publish time will cause link failures and other errors

because they are all in the same output help file. 

Duplicate topic IDs and help context numbers are actually not a problem in CHM projects

merged at runtime. Since the output consists of separate help files there are no conflicts

and all links will work normally. However, it is still a good idea to avoid duplicates within

projects because then you can always switch to publish time merging without any prob-

lems if you need to.
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How to avoid duplicate topic IDs

Help+Manual has a feature that makes preventing duplicate topic IDs very easy. In each

project you can automatically add a unique prefix to your topic IDs when you create a new

topic. Then even topics with the same basic ID will actually be different. For example, with

an auto-prefix the ID Introduction could be Master_Introduction in one project and

Mod1_Introduction in another project.

1. Go to Configuration > Common Properties > Miscellaneous . 

2. Enter a prefix for your topic IDs in the Topic ID Prefix: field. It's helpful to add an un-

derline character after the prefix, this makes the IDs easier to read in the various ID

lists displayed in Help+Manual. For example, the topics in this help file all use the pre-

fix HM_.

3. Repeat for each project you want to include in your modular help system.

If you assign a unique prefix to each project used in your help system and make sure that

it is used for all modules you won't have any problems with ID conflicts.

How to avoid duplicate help context numbers

Since you can't add prefixes to help context numbers you have to avoid conflicts here by

assigning a predefined range of numbers to each project in your help system. This is ef-

fectively the same as a prefix, you just have to make sure the ranges are far enough apart

so that they can never overlap.

1. Choose a range of numbers for each of your modules. Make sure that the range is

large enough to avoid overlaps even if you add a lot more topics to your project than

you initially expect to use! Help context numbers can have a value of 1 –

4294967295 (unsigned 4-byte integer) so there are plenty of ranges to choose from. 

2. Go to Project Explorer > Configuration > Common Properties > Miscellaneous .

3. Enter the starting number for the range assigned for the current project in the Start

with: field.

4. Enter a reasonable number for the Increment by: value. This should be large enough to

allow you to add topics between existing topics but small enough so that you won't

go out of your assigned context number range even if you add a lot of topics to your

project.

5. Repeat for every project you want to include in your modular help system.

1411
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How to set up existing projects to avoid conflicts

The above methods are fine for new projects. However, when you want to include existing

projects in a modular help system you may already have duplicates conflicts that you need

to deal with.

1. Check your projects to see whether the context number ranges and IDs used have po-

tential conflicts. The Project Reports  tool can be a helpful aid here. 

2. Use the Help Context Tool  to assign new context numbers to your individual mod-

ules. 

Remember that when you change help context numbers your programmers must also

change the corresponding calls to your topics made from your application!

3. Edit your topic IDs to eliminate the conflicts. Introduce a prefix naming scheme for IDs

with a different prefix for each module. This must be done manually. You cannot

search and replace topic IDs in the Help+Manual editor.

4. After doing this use the Help Context Tool  and the Project Reports  tool to ex-

port lists of the new context numbers and topic IDs for your programmers.

5. Check whether any scripts  or plain HTML code objects  inserted in your project

contain references to the old topic IDs. These are not updated automatically and need

to be checked. The same applies to any links to the old IDs from other projects and

help files.

Changing IDs and context numbers globally

The operations described below are only possible with the Professional and Floating li-

cense versions of Help+Manual and are for advanced users only. If you don't feel comfort-

able with editing source code directly you should not try this. Even if you do, please make

a backup copy of your entire project folder before starting!

Note that the risk of damaging your project when you do this is relatively high because it

is easy to make mistakes, particularly if you are performing multiple replaces without a

manual check for every instance. You have been warned! 

Adding prefixes to topic IDs globally:

You need a tool that can rename multiple files and a text editor that can perform search

and replace on multiple files for this operation. Without these tools it would be just as fast

to edit your topic IDs manually.

1. If your project is not already saved in uncompressed XML format select Save As... in

the File menu and save it in an empty folder with the Help Project (uncompressed XML)
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option. This will create a directory of plain-text XML files that contain all the compon-

ents of your project. 

2. Using your multiple file renaming tool rename the topic files in the Topics folder to

add the prefix you want to have to the filenames – the topic IDs are the topic file-

names.

3. Open the table of contents file in the Maps folder and add the prefix to all the topic

IDs in the href= attributes so that the match the new filenames created in step 2 –

make sure that upper and lower case match. This is necessary to make the TOC entries

point to the new topic filenames.

4. Open the .hmxp project file in a text editor and locate the section between the

<helpcontext-numbers> tags. Add the prefix to all the topic IDs in the href= attrib-

utes that assign the help context numbers to specific topics so that the entries match

the filenames created in step 2. (This will only be necessary if help context numbers

are defined in your project.)

5. With your multi-file search and replace tool search all the topic files in the Topics

folder for type="topiclink" href=" and add your prefix after the href=" – you must

search for this entire string, otherwise you will add prefixes to file links, Internet links

and script links as well, and that would break them.

Warning: 

Doing this will break links to topics that are not in the current project and you will

need to repair them afterwards. Broken links are highlighted in red. If you have a lot of

cross-project topic links you may not want to do this. 

Changing context numbers globally:

You can also use the same method to change your context numbers globally. Here you

just need to add new number to the beginning of all existing context numbers to "shift"

them into a different range. You can do this by editing the .hmxp project file, which is

where the context numbers are stored:

1. Save in uncompressed XML mode and open the .hmxp project file in a text editor. 

2. Locate the section between the <helpcontext-numbers> tags and add the "shift"

number to the beginning of all the context numbers. That's it. 

See also:
Modular Projects  (Reference)

IDs, Context Numbers and Keywords  (Reference)

7.8.8 Creating links between modules

How you create links between modules depends to a great extent on whether you use

runtime or publish time merging. If you use publish time merging all the modules are always

present so you can use normal topic links. If you use runtime merging for CHM files (it is only

1547
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supported in CHM) you should use the A-link method (see below) for all links to modules

which might not be present at runtime.

Basic principles

· Remember that runtime merging is only possible in HTML Help (CHM) help files. All

other formats use only publish time merging.

· Even with runtime merging, links from child modules to the master module are always

OK because the master module is always present. 

· It is better to use A-links for all links from the master to child modules and between

child modules for runtime merging projects. Then you can always be sure that you will

not have problems if you ever need to leave a module out.

· External windows cannot be used across module boundaries in modular help with

HTML Help. You cannot make a link that opens a topic from another help file in an ex-

ternal window. This is a restriction of HTML Help.

How to create normal links between topics in different modules

In modular projects you can create normal links between topics in different modules in al-

most exactly the same way as between topics within a normal project. You just have to

bear in mind that the help file containing the target of the link must be present at runtime

(when the help is viewed), otherwise the link will be dead and the user will get an error

message. 

1. Select the topic in which you want to insert the link – topics in child modules are iden-

tified in the Project Explorer with spiky green icons on their TOC entries: 

  Display for a module configured 

  for publish time merging

If your child module is configured for runtime merging you cannot edit its topics in

the TOC – then you must right-click on the module entry and select Edit Child in the

context menu to edit its topics.

2. Proceed as you normally would for inserting a topic hyperlink.
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3. In the Hyperlink dialog  click on the  browse button in the Help File: field and

choose the project or published help file containing the topic you want to link to. (It is

always preferable to choose a project rather than a compiled help file if possible.)

Never try to create links between different output formats. This will not work! 

4. If you choose a project (.hmxz, .hmxp) or HTML Help (.chm) file the topic IDs of the

external project or help file will now be displayed in the Topic ID list. Choose the topic

(and anchor  if applicable) you want to link to and click on OK.

5. Remember that this link depends on the presence of the target help file. If there is any

chance that the target file may not be there at runtime don't link to it, or use the A-

link method described below.

Setting a global help window for runtime merging

When using runtime merging it is advisable to define a global "window name" for all the

projects in the modular help system. This improves the performance of links to your help

from your applications. When you define a global help window, all calls to the help system

will open in the same CHM help viewer. Without a global window, you will get additional

help viewers opening when calls are made first to one module and then to another.

The global help window option is set in Configuration > Publishing Options > Microsoft

HTML Help > Help Windows . You need to set the same global window name in all

projects in the modular help system, including the master project. 

If you use this option the global help window name must begin with $global_, followed

by an identifier consisting only of alphabetic characters. You must use the same global

name in all the projects.

Examples of valid global window names:

$global_main_mycompany
$global_widgethelp

Important – make sure your window name is unique!

Don't use the standard $global_main name! If you do it is quite possible that some other

software on the user's computer will also be using that name and then your help could

open in their help window!

How to use A-links to create links between modules

Use this method to create links between modules when you are not sure whether the

module containing the link target will be present at runtime or not. It creates a link that

points to both the main target topic and to an alternative topic in the master help module.

1352
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If the main target is present the user can select it from the dialog. If it is not present the al-

ternative topic is displayed automatically.

This method only works in HTML Help (the A-link macro is translated automatically when

you publish to HTML Help). Use it for creating links between the help files of modular help

systems if there is a possibility that the help files containing the target topics may not be

present at runtime. This can happen when you use runtime merging and choose not to in-

clude one or more of the help files in your distribution. 

Step 1: Prepare the alternative topic in the master project

The alternative topic should be in the master project because this is the only help file that

is always present in a runtime-merged modular help system.

1. Open the master help project and choose or create the alternative topic that you want

the user to be able to view when the other help file module containing the target topic

is not available. This can be any topic including a topic in the Topic Files section that

does not have a TOC entry. 

2. Select this alternative topic in the Project Explorer, display its  tab and enter a unique

A-keyword in its A-Keywords: field. 

Step 2: Prepare the target topic in the child project

1. Select the topic you want to link to in the child project. 

2. Display the topic's  tab and enter the same A-keyword as above in its A-Keywords:

field. 

This A-keyword should only be used in these two topics. If you use it in any other topics

in any module these topics will also be displayed in the link list.

Step 3: Create the link

1. Open the module in which you want to create the link. This can be a master module or

another child module. 

2. Select the topic where you want to create the link and open the Insert Hyperlink dia-

log.

3. Select the Script Link option on the left, then select Winhelp macro.

4. Enter Alink() in the Script: field and type the keyword between the parentheses. If your

keyword is "about widgets" the dialog would look like this:
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If the target help file is not present when the user clicks on the link the alternative topic

will be displayed automatically. If the target topic is present a dialog will be displayed in

which the user can select either the target topic or the alternative topic.

This is just a very simple example to show you how this solution works in principle. In

practice you can also make more complex solutions, using more alternative topics and

more keywords. If you use multiple keywords remember to separate them with semi-

colons, like this:

Alink(about widgets;troubleshooting;widget solutions)

See also:
Using A-keywords

About A-keywords

Creating a modular project

Modular Projects  (Reference)

7.8.9 Publishing modular projects

When you are publishing modular projects to HTML Help the procedure you use depends on

the merging method  you are using for your child modules. If you are using runtime mer-

ging you must publish all the child projects separately, they are not published automatically

when you publish the master project.

All other output formats only use publish time merging.

Generating output with publish time merging

When you use publish time merging all the child modules of the master module are com-

bined automatically. You only need to publish the master file, all child modules are in-

cluded in a single publish run. 

In HTML Help publish time merging is an option  that you can select for each module

in your master project. 

In all other formats publish time merging is always used for all modules. All modules will

always be published together with the main project as one large project. 
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Generating CHM help systems with runtime merging

Runtime merging is only possible in HTML Help. It is irrelevant for all other output

formats. Runtime merging is an option  that you can select for each module in your

master project. 

Important: The project filenames and the output filenames of the CHM files must be

identical. The references between the child and the master help files are

based on the filenames and if project and output filename don't match the

references will be invalid. 

Child modules configured for runtime merging must be published individu-

ally, they are not published automatically when you publish the master mod-

ule!

1. Check your master project for child projects configured for runtime merging. They are

easy to identify because their contents are not displayed as part of the master pro-

ject's TOC. 

  Display for a project inserted 

  with runtime merging

2. Right-click on the runtime modules, select Edit Child in the context menu to open the

child projects, then select the child projects in the Project Explorer and publish them. 

1096
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If any of your child modules contain their own child modules configured for runtime

merging these must also be published separately. 

3. Publish the master module.

4. Copy all the published help files to the same directory if you have not published them

to the same directory.

Settings controlled by the master project in publish time merging

When you use publish time merging almost everything is controlled by the master project.

The settings of the child projects are ignored and replaced by the settings of the master

project. However, if settings in the child projects are unique and not duplicated in the

master then they will be used: 

Project search

paths:

Project search paths defined in the child projects that are not

defined in the master project are added to the end of the master

project's list of paths. When inserting a graphic or a  snippet file

Help+Manual then searches through all the paths in order and in-

serts the first file it finds with a matching name. This means you

must be careful not to use files with duplicate names in your child

projects.

User-defined vari-

ables:

If child projects contain user-defined variables with names that are

not used in the master project the definitions in the child projects

will be used. However, if the master project contains variables with

identical names then the definitions from the master project will be

used.

Custom include

options:

If a child project contains user-defined include options  not

defined in the master project they are available in publish time

merging.

HTML topic page

templates:

The HTML topic page templates  of the master project replace all

child project templates that have the same names. For example, this

means that the Default template from the master project template

is always used in all child modules, replacing any template changes

that may have been made in the child projects.

If child projects contain HTML page template definitions with

names not used for templates in the master project then these

HTML page templates will be used in the child projects. 

988
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For example, if you have defined an HTML page template called Se-

condary in your child module it will be used in the child module if

there is no HTML page template called Secondary in the master

module. 

However, if the master module contains a template called Second-

ary then the master's version will be used in the child module as

well and the version defined in the child module will be ignored. 

Baggage files: Baggage files in the master project have priority over Baggage files

with the same name in child projects. See Baggage handling  for

further details.

See also:
Publishing Your Projects

Modular Projects  (Reference)

Baggage file handling

7.8.10 Multiple WebHelp projects

Like all other output formats except CHM, WebHelp only supports publish-time merging.

When you publish a project containing child modules to WebHelp all the child projects are al-

ways published to a single HTML directory with a single index file and Table of Contents

(TOC). 

However, sometimes you may still want to set up a larger WebHelp project with a modular

structure, using a separate directory and index file for each module. When you do this the

WebHelp help systems in the separate output directories are referred to as "collections".

How to set up a "modular" Webhelp project

To do this you must create and edit completely separate projects. Do not use a master-

child structure. Your project modules must be independent of each other.

Publishing and uploading to your server:

When you publish your "modular" WebHelp projects each project must be published to a

separate folder. In the same way, when you upload the projects to your server you must

store them in separate folders. If you upload them all to the same folder you will probably

overwrite some files, resulting in errors.

1124
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Restrictions with "modular" Webhelp projects

There are some important restrictions and also some important points you need to ob-

serve when working with collections and the links between them.

· These are not real modular projects. You cannot insert the child modules in a master

Help+Manual project. If you did this all the modules would automatically be integrated

in a single output folder, which is not what you want here. Separate "modules" must be

opened and published as separate projects.

· You can link between collections but you cannot merge their TOCs.

· You cannot create links to the target topics in the project files of the other projects be-

cause Help+Manual cannot manage links between collections across directory bound-

aries. You must use Internet links , inserting the correct URLs and/or paths between

your planned directory locations yourself.

Compiling projects to separate HTML directories

· Open each project and publish it separately, to a separate directory. A WebHelp project

like this in its own directory is called a "collection".

· Make sure that you manually enter a different output directory for each project in the

Index Page: field of the  Publish  dialog. It is good to check this to make absolutely

sure that you are not publishing everything to the same directory.

Creating links between Webhelp projects

Do not try to use normal topic links for hyperlinks between WebHelp projects output to

separate directories. This will not work! Use Internet links  (see below for syntax).

In the Target window: field of the Hyperlink dialog  select:

Same as referring

topic:

Opens the target topic in the current window. The TOC of the cur-

rent collection will continue to be displayed. You will not see the

TOC of the collection containing the target topic.

Top frame: Opens the target topic in the current window with the TOC of the

target collection. The TOC of the current collection will no longer be

displayed.

New window: Opens the target topic in a new window together with its own TOC.

The current window remains open.

422
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Syntax for links between collections

The standard syntax for links between collections is as follows:

index.html?topic_id.htm#anchor

Use lower case: The names and extensions of all the files generated for WebHelp

are all lower case, even if the topic IDs used to generate the file

names contain upper case characters (all file names are automatic-

ally "down-cased" when you publish). This is very important – if you

use upper-case characters your links will fail on all Unix and Linux

servers and many other systems!

index.html This is the index file of the target project and it should always be

included in the links. Even though linking directly to the topic file

may seem to work the browser history may not be stored properly,

making it impossible for the user to return to the original topic by

using the browser's Back button. 

By default the index file of WebHelp has the extension .html un-

less you enter a different extension in the Index Page: field of the

Publish  dialog.

?topic_id.htm The ? character is necessary between the index file and the topic fi-

lename. Each topic is stored in a separate file and the file name is

generated by converting all characters to lower case and adding

.htm to the topic's topic ID.  For example, if the topic ID is

HM_Intro then the topic file name would be hm_intro.htm. 

#anchor This is optional and links to an anchor  in the target topic. 

See also:
WebHelp

7.9 Using Baggage Files

The Project Files > Baggage Files section in the Project Explorer enables you to add a collec-

tion of small, frequently-used files to your project. The entries in the Baggage Files section are

not links or references, they become a physical part of your project. 

These files are stored together with your project files and they are always accessible, even if

you delete the original source files. If you use the single-file .hmxz format your baggage files

are stored inside your project file. In the uncompressed .hmxp XML format (Professional and

Floating license versions only) they are stored in the Baggage folder inside your project folder.
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7.9.1 Uses for Baggage Files

There are two main uses for the Baggage Files section: For files of your own referenced in

your HTML code and scripts and as a storage area for small, frequently-used graphics you

want to keep with your project, particularly those used in your HTML templates (for example

logos, buttons etc).

Integrating files referenced in HTML code and scripts:

There are a number of functions in Help+Manual that allow you to insert your own inline

HTML code in your output or to modify the HTML code generated by the program. These

include HTML Code Object Tool , the HTML code editing function of the Insert Video

Tool , all the HTML editing functions for HTML templates  and the code you enter in

scripts and macros .

If you want to reference graphics files and other files in this code Help+Manual normally

has no way of knowing that these files exist or that you want them to be exported with

your project when you publish. The Baggage Files section provides a quick and elegant

way of solving this problem. 

All files that you add to your project as Baggage are automatically exported when you

publish your output and can be referenced in your HTML code by name only, without any

additional path information.

Frequently-used graphics

You can also use the Baggage Files section for storing small, frequently-used graphics files

– for example custom icons used for your Table of Contents in WebHelp output or logo

images that you use frequently. Once you have added them to the Baggage you can de-

lete any graphics files used in your project from other locations. Help+Manual always

looks for files in the Baggage first, so if they are there they will be found, for all output

formats.

This is a useful way of keeping the files associated with your project together but it should

generally only be used for relatively small files. This applies particularly if you are using the

single-file .hmxz format, because all your Baggage files are stored inside the .hmxz file

together with all the other project components. (The Basic version of Help+Manual only

supports the .hmxz format .)

Graphics storage location in HMXP projects

When you are working in single-file HMXZ mode we don't recommend storing large num-

bers of large files like graphics in your Baggage. If you do, you will bloat the project files

and this may slow down editing because the entire contents of the HMXZ must be loaded
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into memory when it is opened. However, you don't have this problem in HMXP projects

because the contents of the Baggage are just files on disks.

Storing your graphics in your Baggage in HMXP projects can be practical if you are saving

your projects in a Version Control System  (VCS).  If you do this, then your graphics are

automatically saved to the VCS repository because they are an integrated part of your

project. Since graphics can take up a lot of space in the repository you may or may not

want to do this, but it is available as an option if you want it.

7.9.2 Adding and referencing files

All files you add to the Baggage Files section are automatically included/exported in your

HTML-based output. This is the best way to include files referenced in manually-edited code

in your projects. You can reference all files in the Baggage section directly in your code. You

don't have to add any path information because the files are always available on the same

directory level as the other help files. All necessary copying and references are handled auto-

matically by Help+Manual. (This is why Help+Manual uses a flat-file model without sub-

folders in its CHM and WebHelp output, by the way: easier referencing in your code.)

You can use Baggage files for files referenced in the code entered with Insert > HTML

Code , the HTML code editing function of the Insert Video Tool , all the HTML editing

functions for HTML templates  and the code you enter in scripts and macros .

Adding files to the Baggage section

Files you place in the Baggage section become part of your project and are always avail-

able. They do not have to be loaded from any external directory – you can even delete the

original files after adding them to your Baggage. 

1. In the Project Explorer, select Project Files > Baggage Files. 

2. In the Ribbon select Add File > Add New File in Project > Manage Topics.

3. Select the file you want to add and click on OK. The file will be added to the Baggage

list and will become part of your project. 

Note that you can use include options  for Baggage files!

Referencing Baggage files in your HTML code

Baggage files are always directly accessible for your code and they are always in the same

directory as the other files in your output. This also applies in HTML Help: Here, the Bag-

gage files are in the same internal "virtual directory" inside the CHM file as all the other

files in your HTML Help system.
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Baggage files can be referenced directly without any path information because they are

always stored on the same directory level as the other help files. Just enter the name of

the file as it is shown in the list in the Baggage section.

See also:
Inserting plain HTML code

Videos and Online Media

Using HTML Templates

Inserting script and macro links

7.9.3 Removing, exporting and importing

Removing and exporting files stored in the Baggage section are generally quite straightfor-

ward operations but there are a couple of points you need to bear in mind. You can also im-

port the baggage files from other projects. 

Removing and exporting Baggage files

Removing Baggage files:

1. Go to Project Files > Baggage Files in the Project Explorer and select the Baggage file

you want to remove. 

2. Press DELETE or select Add File > Delete Entry in Project > Manage Topics.

Note that this physically deletes the selected file from your project. If you want to keep a

copy of it export it first before deleting it (see below).

Exporting Baggage files:

This saves a copy of the selected Baggage file in a new location (for example to back up

the file before removing it from your project). 

1. Go to Project Files > Baggage Files in the Project Explorer and select the Baggage file

you want to export. 

2. Select Save Baggage File As... button in the lower right corner of the Help+Manual

window.

Importing Baggage files from other projects

You can import all the Baggage files from another Help+Manual project to the current

project. 

Files with duplicate names will be overwritten when you do this.
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1. Select the Baggage Files section in the Project Explorer. 

2. Select Add File > Add New File in Project > Manage Topics and select the

Help+Manual you want to import the Baggage files from.

3. You will be asked if you want to import the Baggage files from the selected project.

Confirm to import the files. 

Renaming Baggage files

You cannot rename Baggage files directly in Help+Manual. To rename a Baggage file re-

move it from the Baggage list (see above), rename the original file and then add it to the

Baggage list again.

Warning: Do not attempt to rename Baggage files on the disk in Windows Explorer, do-

ing this will cause errors in your project!

7.9.4 Editing Baggage Files

You can edit text files in the Baggage directly. Help+Manual includes an integrated source

code editor with basic syntax highlighting for most of the common languages that you are

likely to use in your Baggage Files. This makes it possible to perform quick edits on the files

without having to export and re-import them.

To edit, select the file in Project Files > Baggage Files > Baggage and it will be automatically

opened in the editor on the right. You can open a Search and Replace dialog with CTRL+F.

Editing Baggage files
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7.9.5 Baggage handling

This topic summarizes how Baggage files are handled by Help+Manual. This information will

help you to understand how Baggage works.

Where and how Baggage files are used

Graphics in the Baggage section can be used for all output formats. If you use graphics

formats not directly supported by the output format they will be converted automatically

when you publish, just like the other graphics in your project. 

For example, BMP files will be converted to a  format compatible with HTML in HTML-

based output formats. References to the BMP files in your topics will be adjusted automat-

ically but references to BMP files in your own HTML code will fail – they would have failed

anyway because BMP is not supported in HTML.

Non-graphics files in the Baggage section are only relevant for HTML-based formats. They

are ignored in all other formats.

Using include options with Baggage files

You can use conditional output include options on Baggage files just as you can on topics.

This makes it possible to explicitly include or exclude individual Baggage files in or from

specific output formats or builds.

1. Select the Baggage file in the Project Explorer. 

2. Right-click on the Baggage file and select Include in Builds in the context menu.

OR: Select Change > Include in Builds in Project > Manage Topics.

3. Select the build options you want to apply to the file. 

Baggage graphics files have priority

Baggage graphics files have priority over graphics files stored in the folders in your project

search path . If a graphics file in the Baggage section has the same name as a file on

the project search path the Baggage version will always be used in the output.

This means you must take care to avoid duplicate file names in your graphics folders and

the Baggage section, otherwise the versions in your graphics folders will be "invisible" to

the program when you generate your output. (In any case it is better to use the Image

Shortcuts  function for graphics than Baggage.)
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Size of the Baggage section

Since Baggage files are physically stored as part of your project they should only be used

for a small collection small files. Use the Image Shortcuts  function for frequently-used

graphics files.

This is particularly important when you are saving in the single-file .hmxz format, which is

the only format supported by the Basic version of Help+Manual. Adding a large number

of large files to your Baggage will significantly inflate the size of the .hmxz project file,

which may cause problems on slower computers with less memory.

Baggage files in modular projects

The Baggage files from project modules are also merged in your output when you are us-

ing publish-time merging. If individual modules contain Baggage files with the same

names Help+Manual always uses the first Baggage file encountered and ignores all other

Baggage files. This means that Baggage files in the master module always have priority,

followed by the child modules in the order in which they are processed. 

For example, if both the master module and the child modules contain Baggage files

called redarrow.gif  and functions.js the versions of the files in the master will

project be used in the entire project, both in the master module's topics and in the child

module's topics. The versions in the child modules will be ignored. 

If two child modules contain different versions of a file with the same name the first ver-

sion encountered will be used in the topics of both modules and the other version will be

ignored.

To make sure that Baggage files in child modules are used in the child module you must

make sure that their names are unique and not used in any other modules, including the

master module.

See also:
Working with Modular Help Systems

7.10 Source Code Documentation

Help+Manual includes and integrates the latest version of Microsoft Sandcastle, making it

possible for you to generate source code documentation for your .NET development projects

directly. You just need to follow some simple rules for commenting and make a single config-

uration change in your Visual Studio project. Then you can convert the assembly structures

and your comments directly into a pre-formatted Help+Manual documentation project.
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Unlike the standalone version of Sandcastle, which generates non-editable CHM files directly,

this allows you to edit the project in any way you like and publish to all the formats supported

by Help+Manual—not just CHM but PDF, WebHelp, Visual Studio Help and so on. 

The Sandcastle import option automatically creates a pre-formatted,

 
pre-structured Help+Manual project from your source code

7.10.1 About MS Sandcastle

Sandcastle is a free Microsoft tool that automatically generates documentation from program

source assemblies and XML comment files for Microsoft Visual Studio .NET development pro-

jects. If you are already using Sandcastle and have it installed on your computer Help+Manual

supports it from version 2.4 and above. However, we strongly recommend installing the

runtime version bundled with Help+Manual. It is the latest official version from Microsoft and

will be used automatically once it is installed. 

Use the Sandcastle version included with Help+Manual

Help+Manual comes with the latest official version of Sandcastle from Microsoft. You just

need to select the Sandcastle option when you install Help+Manual to get it. We strongly

recommend using the bundled version. It is the latest available and Help+Manual is op-

timized for interaction with this version. It will not interfere with your own Sandcastle in-

stallation if you have one, but once it is installed Help+Manual will only use this version

and will ignore your version. 
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If you didn't install Sandcastle with Help+Manual just run  the latest installer again and

select the option shown above. For more background information about Sandcastle see

 Microsoft's Sandcastle page.

You don't need (and can't use) Sandcastle Help File Builder with

Help+Manual!

Microsoft is no longer releasing new versions of Sandcastle (but that doesn't prevent it

from working just fine). There is now an independent project called Sandcastle Help File

Builder, developed and maintained on Codeplex by Eric Woodruff. You don't need to use

Sandcastle Help File Builder with Help+Manual, and it is also not possible to do so. It is

not needed because Help+Manual performs the tasks that HFB performs, interfacing with

Sandcastle and generating the output. 

You are free to use Help File Builder with your Sandcastle installation independently of

Help+Manual, of course. You just don't need it and can't use it for generating Sandcastle

source code documentation from your .NET projects with Help+Manual. 

7.10.2 Configuring Your .NET Project

You need to do two things to set up your .NET project for source code documentation with

Help+Manual and Sandcastle: 

1. Comment your code 

2. Set one configuration option in the project. 

https://www.helpandmanual.com/downloads.html?upd
http://msdn.microsoft.com/en-us/vstudio/bb608422.aspx
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Commenting your code

Basic procedure:

To create documentation for your code you need to insert XML elements in special com-

ment fields, which you identify by using triple slashes instead of the usual double slashes.

Insert these comment fields in the source code directly before the code block to which the

comments refer, like this:

/// <summary> 
/// The summary generally comes first. This summary would be 
/// for the class level documentation. </summary> 
/// <remarks> 
/// You can use the remarks tag for longer comments</remarks> 
public class WidgetConfabulator : TestInterface
{
    /// <summary> 
    /// Store for the realname property.</summary> 
    private string _realname = null;

    /// <summary> 
    /// The class constructor. </summary> 
    public WidgetConfabulator()
    {
        // This is a normal comment with two slashes and no XML tags 
        // and will NOT be included in the documentation
    }
}

When you compile with comments file option activated (see below) the XML documenta-

tion file used by Sandcastle will generated from the XML tags in your triple-slash com-

ments. 

Sandcastle XML Comments Guide

For full details on the XML comments supported by Sandcastle see the comprehensive

Sandcastle XML Comments guide maintained by Eric Woodruff, the originator and man-

ager of the Sandcastle Help File Builder project:

 Sandcastle XML Comments Guide

Important warning: There are a some tags and elements described in the guide that are

only supported by Sandcastle Help File Builder. These are identified in the guide and they

should not be used with projects that you are going to document with Help+Manual

without Help File Builder (which you can't use with Help+Manual, because HM then per-

forms the function of Help File Builder). 

http://ewsoftware.github.io/XMLCommentsGuide/html/4268757F-CE8D-4E6D-8502-4F7F2E22DDA3.htm
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Activating XML documentation file generation in your Visual Studio
project

The other requirement is to configure your project in Visual Studio so that it will generate

the XML documentation file from your Sandcastle comments and XML tags. To do this

open your development project in Visual Studio and go to the Project Properties > Build

section. Scroll down to the Output heading, enable the the XML documentation file option

and enter a suitable name for it. 

Alternatively you can also compile your assemblies with the documentation switch and the

comments file name: /doc:comments.xml 

7.10.3 Importing from Visual Studio

To get your documentation from your .NET project into Help+Manual you just need to import

it with the Sandcastle option. You can do this either by creating a completely new

Help+Manual project, or you can add it to an existing project. Once you have created a pro-

ject for your .NET documentation you can also update it by re-importing into the same pro-

ject again. 

Importing from your .NET project to a new Help+Manual project

1. Select New Project in the File menu. 
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2. Select Sandcastle documentation file in the Import existing documentation section in

the lower half of the page. 

3. Enter the name and path for your new Help+Manual project and configure the other

settings as you would for an empty new project .

4. Click on Continue with Options and select your assemblies, comment files and any de-

pendent assemblies. The comments file is the XML documentation file  you config-

ure in your .NET project. You can choose multiple files in each category. You can also

set a topic status to be set for your imported topics.

5. Click on Import. Help+Manual will then run Sandcastle in the background, generate

the project and import it to a Help+Manual project. Depending on the size of your

programming project this may take a while. The time this takes depends on Sandcastle

and the speed of your computer, not on Help+Manual. 

124

1127
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6. When the process is finished your Sandcastle project will appear in Help+Manual for

editing. You can then edit and publish it just like any normal Help+Manual project:
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Updating existing HM projects from your source code

You can also update your source code documentation to the Help+Manual project you

created from an earlier version.

Open the Help+Manual project and select Import in the File menu instead of New Project.

All the other steps are the same as described above. New topics chapters will be added to

the end of the existing TOC. Updates to existing topics and chapters will be handled de-

pending on the conflict management settings you configure for "changed topics". If you

opt to overwrite the existing topics the earlier versions will be replaced.

7.11 Visual Studio Help

Visual Studio Help is available in two versions, Visual Studio Help 2008 and 2010, which are

also known as MS Help 2.0 and MS Help 3.0, respectively. Originally, each of these help

formats was announced as the upcoming the successor to HTML Help. However, in both cases

Microsoft then backpedaled and it now seems clear that they are not going to be released as

help formats for normal user applications. 

These formats are only relevant for documenting Visual Studio .NET programming compon-

ents within the Microsoft Visual Studio programming environment. They cannot be used for

documenting normal application programs.

This section just provides a brief introduction to publishing Visual Studio Help with

Help+Manual. If you want to use Visual Studio Help you need to be experienced in VS.NET

programming. It will not be of any use to you otherwise. In addition to this you should also

study the relevant documentation in the Visual Studio package and the Visual Studio Help In-

tegration Kit/VSHIK (for version 2.0, check the MSDN site for details).

You can find an excellent introduction to both versions of Visual Studio Help on the  Help-

ware.net website.

Support for Visual Studio Help (both formats) is only included in the Professional and Floating

license versions of Help+Manual. 

See also:
Visual Studio Help  (Help Formats)

Visual Studio Help  (Project Configuration)

7.11.1 Requirements and limitations

Both Visual Studio Help formats – Help 2.0/HXS and Help 3.0/MSHC – are irrelevant for nor-

mal help and documentation purposes. You cannot view or use them unless you have the

Visual Studio .NET programming package installed and you cannot even create Visual Studio

1525

1464

http://www.helpware.net/
http://www.helpware.net/
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2008 without Visual Studio. You cannot use Visual Studio Help to document normal applica-

tion programs. 

Limitations of Visual Studio Help

Surprisingly for a help format that was touted as the best thing since sliced bread, the fea-

tures and capabilities of both the Visual Studio Help formats are actually considerably

more limited than those of either the obsolete Winhelp format or HTML Help, the formats

both versions of VS Help were originally supposed to replace. 

Many common features of Microsoft's earlier help formats are not available in Visual Stu-

dio Help. For example, window types  are not supported at all, nor are links to external

files. Links to external videos are also taboo in Visual Studio Help. The only external links

that are permitted are web URLs with absolute addresses.

What you need to publish and view Visual Studio Help 2008

To publish Help 2.0 you need Visual Studio 2002 or later and the Visual Studio Help Integ-

ration Kit (VSHIK), which can be downloaded from the Microsoft website (check the MSDN

site for details). Both these packages must be installed to publish Help 2.0 with

Help+Manual. 

After installing the Help 2.0 compiler go to View > Program Options > Compilers  in

Help+Manual and make sure that the correct path is entered to the compiler executable.

To view Help 2.0 documentation you only need Microsoft Visual Studio 2002 or later, the

VSHIK does not have to be installed. Unlike HTML Help there is no standalone version of

the Help 2.0 viewer. If you don't have MS Visual Studio installed you can't view Help 2.0. 

The MS Help 2.0 compiler:

The MS Help 2.0 compiler is part of the Visual Studio Help Integration Kit (VSHIK), which

you must download from the Microsoft website in the correct version for your version of

Visual Studio .NET. Unlike the HTML Help and Winhelp compilers it is not a standalone

compiler system. It can only be used in combination with Visual Studio .NET, which you

will have if you are programming Visual Studio .NET components. If you are not program-

ming Visual Studio .NET components you don't need it. Got it?

The Visual Studio Help Integration Kit:

This package is available directly from the Microsoft website. Unfortunately, the download

location has been changing quite frequently recently so you will need to search for it on

194

1268
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the MSDN site yourself – any download link we could provide here would probably be ob-

solete again by the time you read this.

What you need to publish and view Visual Studio Help 2010

Unlike Visual Studio Help 2008, the new MS Help 3.0/MSHC format does not require a

special compiler. It is really just a zip archive with the extension .mshc, containing XHTML

topic files and configuration files. Help+Manual can generate MSHC files directly without

any assistance from other software.

There is also no special viewer for Help 3.0, although  Rob Chandler has produced a

very nice one. The default viewer for MSHC help files is your default browser, but this only

works if Visual Studio 2010 is installed, because it provides the necessary software for

making the help contents available to the browser.

See also:
Visual Studio Help  (Reference)1525

http://mshcmigrate.helpmvp.com/viewer
http://mshcmigrate.helpmvp.com/viewer
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7.11.2 About publishing VS Help

Required settings

In Help+Manual you can enter these settings in Configuration > Publishing Options >

Visual Studio Help > Namespace & Options .

Visual Studio Help 2008 (HXS)

The Help 2.0 compiler requires a "namespace" and a "unique identifier" (also referred to

as a "Unique Title ID" in the documentation). Both must be entered otherwise the com-

piler will quit with an error message. (The namespace is used to call the help viewer, the

unique identifier is like a Topic ID for the entire help file.)

Visual Studio Help 2010 (MSHC)

The Help 3.0 format only has three required settings: The vendor name (the company that

owns the book and packages), the product name (the name of your product) and the

book name (the name of your book). The fourth required setting is the locale, but that is

inserted automatically by Help+Manual on the basis of the language setting in your pro-

ject.

Note that in MS Help 3.0 a "package" is a single MSHC help file. A "book" is a group of

packages that you install together. A package can belong to more than one book.

Registration is required for VS help files

Unlike HTML Help CHM files you cannot just copy a Visual Studio Help HSX or MSHC file

to your disk and then click on it to start it. It must be installed and registered first. 

Visual Studio Help 2008 (HXS)

When you publish HXS files with Help+Manual they are installed and registered automat-

ically on your development machine so that you can view them there. However, when you

distribute your files you must configure the MS Installer to do this. See the documentation

of the installer and your Microsoft Visual Studio package for details.

Visual Studio Help 2010 (MSHC)

Visual Studio Help 2010 MSHC files must be installed with the Visual Studio Help Man-

ager. Please see the VS documentation for details.

1464
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Referencing files in your HTML topic templates

If you reference any additional files in your HTML topic templates  you must add them

to the Baggage Section  in the Project Files section of the Project Explorer. MS Help 2

does not have anything like an .HHP file with which you can tell the compiler to include

additional files. (Yet another surprising limitation compared to Microsoft's other earlier

help formats.) 

If you add files to the Baggage Section they will be included in your published output

automatically.

"Do not compile" option for debugging Visual Studio Help 2008 files

Note this option only applies to Visual Studio Help 2008/MS Help 2.0.

Help+Manual supports two different compile options for Visual Studio Help. Normally you

will compile a finished HXS file, which will then be automatically registered on your local

development computer and opened. If this does not work properly there is also a debug-

ging option called Do not compile, open with VStudio in the Publish  dialog.

· If you select the Do not compile option Help+Manual generates a Visual Studio Help

Project file with the extension .HWProj in the temporary output directory. This is a

small XML file that acts as a wrapper for Visual Studio. 

· When you select this option the temporary output directory (in your project directory) is

not deleted after you compile the project. After publishing you can then use the

.HWProj file to open and compile the project file directly in VS.Net, using the debug-

ging options available there.

Calls to register and view .HXS files

The following two calls are just brief examples. For full details please refer to the docu-

mentation of VS.NET and the VSHIK!

Manual registration of an .HXS file:

"C:\Program Files\Microsoft Help 2.0 SDK\hxreg" -n Namespace -i
UniqueID -c MyHelpfile.HXS

Call to view an .HXS file:

"C:\Program Files\Common Files\Microsoft Shared\Help\dex-
plore.exe" /helpcol ms-help://ECSoftware

1036

1119

613
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As you can see there is no file name in the call. In the above example ECSoftware is the

Namespace. The viewer will only find the file if it has been registered correctly.

See also:
Visual Studio Help  (Reference)

Publishing Your Projects

7.12 XML and XML editing

XML is only relevant at all if you are using the Professional or Floating license version of

Help+Manual. The Basic version does not have an XML editing tab in the Editor window and

can only save in the compressed, single-file .hmxz format in which you do not have access to

the XML source files of your project. (The Basic version can edit uncompressed XML projects

however, so that it can be used as a translation editor.)

Working directly with the XML source code is something for advanced users only. You do not

have to know anything at all about XML to work with Help+Manual. 

7.12.1 XML Editing

There are basically two ways to edit the Help+Manual's XML source code: In the source code

editor for topics, which you can find in the XML tab on the left the main editor window, and

by editing the actual source of your project files directly with an external XML editor.

Editing the XML source files

To access the XML source files you need to save in the uncompressed .hmxp format. You

can then edit all the source files with any normal text editor or a dedicated XML editor.

If you want to make any changes to the code you must observe the rules and syntax of

the Help+Manual XML Language, which is open and fully documented in the

Help+Manual XML Language Reference help file you can find in the Help+Manual pro-

gram directory. 

The helpproject.xsd XML schema file is automatically saved with every Help+Manual

project, in the project folder. It is used to check the well-formedness and syntax of all the

XML in the project files. Do not make any changes to this schema. Help+Manual depends

on it being the way it is, and any changes must be supported and integrated in the pro-

gram itself.

Editing in the XML Source tab

You can edit the source code of the current topic directly in the XML Source tab behind

the main editor window. This tab contains a simple code editor with syntax highlighting,

1525

613
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word wrap and search and replace features. The code you enter is automatically parsed

and checked for syntax and well-formedness. It will only be accepted if it does not contain

any errors.

Note that you can only edit one topic at a time in the XML Source tab. If you want to edit

multiple topics you must use an external editor with multi-topic capabilities and edit the

source files directly. 

Search and spell checking are both available in the XML editor – just right-click in the ed-

itor to access these features.

Complex search and replace with XML

Once you have gained an understanding of the basic principles of the XML syntax you can

perform complex search and replace operations on the XML source code that would not

be possible in the Help+Manual editor. 

To do this you will need an editor that can perform search and replace operations on mul-

tiple files in multiple folders. If you are not using a dedicated XML editor a very good and

inexpensive tool for this is  FAR HTML from Helpware, which also has an excellent com-

plex search and replace tool that is easier to use than regular expressions. 

Alternatively, if you feel comfortable with regular expressions for complex text processing

 you can use "grep" utilities like  PowerGREP from JG Software, which is one of the best

tools available for this. JG also has a great tool for generating and testing regular expres-

sions called RegEx Buddy. PowerGREP can also work on compressed .hmxz projects, be-

cause you can set it up to read and edit the contents of zip archives. You just need to tell

it that files with the .hmxz extension are zip archives. 

WYSIWYG previews in browsers and XML editors

Help+Manual projects are saved with an XSL stylesheet for WYSIWYG previews in web

browsers and XML editors. Because of the way XML works this doesn't provide WYSIWYG

editing in XML editors, but it does give you an idea of how the page will eventually look. 

7.12.2 Generating H+M XML

If you follow the rules of the Help+Manual XML Language you can also create topics, chapters

and entire projects directly yourself, either manually or programmatically from your applica-

tion. For example you can set up your application to generate documentation projects and

topics, which you can than either edit in Help+Manual or publish directly  from the com-

mand line without ever having to open Help+Manual yourself. Then you would be using

Help+Manual as a compiler for your documentation.

845

http://www.helpwaregroup.com/products/far
http://www.powergrep.com/
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Help+Manual XML schema documentation

The XML schema and language used in Help+Manual is fully documented in the

Help+Manual XML Language Reference help file that you can find in the Help+Manual

program folder. In addition to the schema and XML tag documentation, this help file also

contains a tutorial explaining how to create Help+Manual projects and topic files yourself. 

This tutorial provides a basic skeleton for a fully-functional Help+Manual project. You can

use this as a template to create the XML with your own application. The chapter explains

the most important settings that you will want to change in the XML (such as project title,

language, search path) and the basic structure of project and topic files. 

Creating projects and topics

The tutorial contains basic skeletons for project and topic files, which are really very

simple. In this form you should be up and running within 5 minutes or so. For example,

the source of a topic file is really just a few lines of code:

<topic>
 <title>Welcome topic</title>
 <body>
   <header><para styleclass="Heading1">Welcome topic</para></header>
   <para styleclass="Normal">Enter topic text here.</para>
   <para styleclass="Normal">Enter more topic text here.</para>
 </body>
</topic>

More complex topic content

Creating topics with images, links and formatted text is a bit more challenging, but it's still

pretty simple. The easiest way to get the code you need is to write some sample text in a

topic in Help+Manual, then switch to the XML code editor and examine the source.

When you are creating topics from scratch you will find you can omit many of the optional

parameters that the XML schema defines. Try remove everything from the XML code that

is extraneous to the content you want, then switch back to the WYSIWYG editor. You will

notice that even a very basic XML structure will work fine. 

7.13 Using OLE Objects

OLE (Object Linking and Embedding) objects are active links in your project to documents cre-

ated and edited in other applications. This enables you to insert formatted objects that you

cannot create directly in the Help+Manual editor, such as formulas created in the MS Equa-

tion Editor. 
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OLE objects can be inserted as links to external files (recommended) or as links to objects that

are actually embedded in your project file. Embedded objects are stored with your project

and will increase its size. 

When your help file is published, OLE objects are converted into static bitmap graphics. The

advantage of OLE over screenshots is that the objects remain editable. Double-clicking on an

OLE object in the Help+Manual editor opens it for editing in its associated program.

Please see About using OLE objects  in the Reference section for some important addi-

tional information.

See also:
Insert OLE Object

About using OLE objects

7.13.1 Inserting OLE objects

OLE stands for "Object Linking and Embedding". It is a Windows technology that allows you

to link or embed documents and files from other programs into your current document. In-

stead of importing the external document you just link to it, enabling you to update the ex-

ternal document if necessary without making a new copy.

Note that OLE objects are actually controlled by the OLE server of the associated application,

not by Help+Manual. Whether and how the object is editable depends on the server and if

the function fails it is due to the server, not to Help+Manual. 

When you publish your content all OLE objects are converted to bitmap graphics. This means

that you can only use document types that can be converted to static graphics.

Key Information
OLE objects are only "live" while you are working in

the Help+Manual editor! When you publish your out-

put they are always converted to bitmap graphics. This

is necessary because the output formats do not sup-

port live OLE objects.

How to insert an external file as an OLE object

Linking is always preferable to embedding. Embedded OLE objects inflate your project

files and cannot be edited outside Help+Manual. Linked objects are normal documents

and can be edited directly with the associated application.

Inserting a OLE link to an external file:

1. Select the OLE Object Tool   in Write > Insert Object. 

1538

1385

1538
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2. Select the Create from File option in the dialog displayed.

3. Use the Browse button to select the file you want to insert. The file does not have to

be in your project directory. Remember that only objects that can be displayed as

static graphics are supported.

4. Select the Link check box. This inserts a link to the external file instead of embedding

the file in your project. If you deselect this check box the object will be embedded in-

stead of being linked.

5. Select Display as Icon if you only want to display a placeholder icon for the object in

the Help+Manual editor. If you deselect this option you can preview and size the ob-

ject in the editor.

6. Click on OK to insert the OLE object.

Embedding an OLE copy of an external file in your project:

· Proceed exactly as described above but deselect the Link check box in Step 4. This will

make a copy of the external file and physically embed it in your Help+Manual project. 

Note that when an OLE object is embedded editing the external file will not change the

copy in your project! To edit the embedded OLE object you must double-click on the ob-

ject in the Help+Manual editor.

Vertical alignment for small inline OLE objects

When you are inserting small OLE objects like math formulas inline in text you will want to

control their vertical alignment so that they flow better with the text. You can do this with

a setting in the Font dialog that will appear when an OLE object is selected.

1. Create and insert your OLE object, for example a math formula. 
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2. Click once on the object to select it and then open the Font dialog by clicking on the

little "open" icon on the lower right corner of Font in the Write tab.

3. You can now adjust the vertical alignment of the OLE object with the setting in the

character spacing tab:

How to embed a new OLE object in your project

The Create New option always embeds the resulting object in your project. It is preferable

to use Create from File to ensure that the OLE object is stored as an external file. 

1. Select the OLE Object Tool   in Write > Insert Object. 
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2. Select Create New in the dialog displayed, then select the application in the Object

Type list. 

Remember that only OLE objects that can be displayed as static graphics are suppor-

ted. 

3. Select Display as Icon to display the OLE object as a small icon link. Otherwise a graph-

ical image of the object will be inserted in your topic.

4. Click on OK to open the external application to create the object. 

Important: 

When you create an OLE object in this way the file you create with your external applica-

tion is physically embedded in your Help+Manual project, it is not stored as an external

file. This type of OLE object can only be edited from within your Help+Manual project. 

How to edit OLE objects

All OLE objects:

To edit an OLE object with the application that created it just double-click on the object in

the Help+Manual editor. Or right-click on the object and select Edit or Open.This method

works both for OLE objects that are embedded in your project file and OLE objects inser-

ted as links to external files.

OLE objects inserted as links:

When you insert an OLE object as a link (see above for details) you can also edit it by edit-

ing the external file with the application associated with it directly.

Deleting OLE objects:

Place the cursor before or after the OLE object and press Backspace or Delete. 

See also:
Insert OLE Object

About using OLE objects

7.14 Replacing Formatting and Styles

The Styles > Replace Styles function in the Write tab is a global search and replace function

for replacing either font attributes or paragraph attributes. This can be quite a useful aid when

you are importing formatted text from some external sources. 

1385
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Converting imported HTML formatting to styles globally with

Premium Pack Toolbox

Help+Manual automatically imports and integrates the styles from Word RTF files, but

formatted text from HTML must be imported as "manual formatting". This is necessary be-

cause HTML formatting cannot be automatically converted cleanly into "text" and "para-

graph" styles. Normally, if you want to use styles on imported formatted text you must

first create Help+Manual styles on the basis of the imported formatting and then apply

the styles to your text – either manually or with Replace Styles.

Provided style classes were used in the original HTML you can globally strip out inline

formatting imported from HTML and convert it to style references with the powerful Tool-

box utility included in the Premium Pack style pack. If you have or are considering buying

the Premium Pack, see Integrating imported formatting globally  for details on this. 

Otherwise see the instructions in this chapter, starting with Introduction to style replace-

ment .

See also:
Importing Data

Text Formatting and Styles

Dynamic Styles

7.14.1 Introduction to style replacement

Before you start using this function, please read through the following explanations carefully.

They will make it much easier to use this function effectively. 

If you are an experienced computer user you will probably find that you will be able to use

the function after reading this section only. If you require more information continue to the

next chapters and follow the instructions provided there.

Font and paragraph attributes are separate

The first important thing to understand when you are using this function is that font at-

tributes and paragraph attributes are internally separate. In Help+Manual the two sets of

attributes are combined in paragraph styles. However, every paragraph style actually has

two sets of attributes with the same name: one set of font attributes and one set of para-

graph attributes.

For this reason the Replace Styles dialog has two modes, which must be used separately:

One mode for the font attributes and one mode for the paragraph attributes. 

Since paragraph styles consist of both font and paragraph attributes this means that you

must always perform two passes with Replace Styles to apply paragraph styles: One to re-

1165
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place the font attributes and one to replace the paragraph attributes. Since paragraph at-

tributes are sometimes not "unique" – many different paragraph styles may share the

same paragraph settings – you may find it easier to apply paragraph styles manually in

some cases.

ALL the search attributes must match

The search is performed for all the attributes in the left column (Search for Format/Style:).

All the replacement or removal operations are only performed on text that returns a per-

fect match for all the options in the left column. 

This also applies for the operations defined by the Inline Formatting replacement settings

in the right column (Remove inline formatting etc). The operations will only be performed

on text that matches the search arguments in the left column perfectly!

Current formatting is preselected automatically

When you open the Replace Styles dialog the search settings in the left column are set to

the attributes of the text at the current cursor position. If you perform your search without

changing anything in the left column, any operations you choose in the right column will

only be performed on text that precisely matches the text attributes at the current cursor

position. This includes both the style name (which is just one attribute among many) and

all the other attributes.

For example, if the cursor is in the normal text of a paragraph styled with StyleA, any oper-

ations will only be performed on text styled with StyleA. Text within StyleA  text with differ-

ent formatting will be ignored and will remain unchanged, unless you use a "fuzzy" search

(see below). 

The style name is just one attribute among many

Remember that the name of a style is just one attribute among many – setting the style

name in the search column on the left just searches for text associated with that style

name. It too can be switched to (Any) to create a fuzzy search, and doing this does not

change any of the other attributes.

Changing the style name at the top of the column does not change any of the other attrib-

utes, it only changes the style name. 

So you can search for the same attributes in combination with the style name (to find a

style that has already been applied) or without the style name (to find text that you want

to restyle or integrate in an existing style).
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Explicit searches and fuzzy searches

The search is precise for attributes in the left column that are specified explicitly. The

search is "fuzzy" for attributes that are specified as (Any). 

For example, if you want to include inline-formatted text that has a different font in your

search you must set the Font Face setting in the left column to (Any). Then the search will

find both text matching the main style and text with a different font. 

The same applies in the same way to all other attributes.

Inline formatting is only changed if it matches

The Remove inline formatting options in the right column are only performed on inline

formatted text that precisely matches the settings in the left column. 

Example:

For example, suppose you want to remove all manually-applied italics from your body

text, which is Arial 11 points. You use several different body text styles and you want to re-

move manually-applied italics from all of them. You need the following settings:

Left Column Right Column

Font Style Name: (any text) (keep style name)

Remove inline formatting

Font Face: Arial (Use style attributes)

Font Size: 11 (Use style attributes)

Font Style Italic

All other settings (any) (Use style attributes)

This will remove all manually-applied Italic formatting on any Arial 11 text with any style,

but it will not remove any other inline formatting because only Arial 11 Italic matches the

search. 

If you change (any text) to Normal for the Font Style Name in the left column then only

formatting in paragraphs formatted with Normal will be changed.

See also:
Importing Data

Text Formatting and Styles

Dynamic Styles
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7.14.2 Font attributes - styled text

The methods described below only work for text already formatted with Help+Manual styles.

See the topic on unstyled text  for instructions on how to deal with texts that do not yet

have styles applied.

Before you try to follow these instructions, please study the Introduction to style replace-

ment  for an explanation of how the Replace Styles function works. This will make it much

easier for you to use this feature.

Replacing one existing font style with another – exact search

This is the most straightforward operation. It simply takes texts formatted with one style

and applies a different style to them. The exact search replaces only text formatted with

the named style. Any inline-formatted text within text formatted with the target style will

be protected, as will any text formatted with other styles.

1. Select multiple topics if you want to replace only in some topics

If you only want to replace styles in specific topics select those topics in the Project Ex-

plorer first, using Shift+Click or Ctrl+Click. Select the topic containing the example of

the style you want to replace last, so that you can select the style example in the next

step.

2. Click in styled text in the editor, then select Replace Styles and Font Styles

Click inside some text formatted with the style you want to replace, then select Styles

> Replace Styles in the Write tab. Then select the Font Styles mode at the top of the

dialog that appears.  

3. Leave all left column attributes unchanged

All the formatting attributes of the current style are displayed in the left column and

the style name is displayed at the top of the left column. Don't change any of the left-

column font attribute settings – the attributes must all match exactly for an exact

search.

4. Select the new style in the right column

Select the new style you want to apply from the drop-down list directly below the

Change to Format/Style: heading on the right. If you need to create the style first, se-

lect Edit Styles.

5. Leave inline formatting settings unchanged

Leave the option Remove inline formatting activated. This will only replace inline

formatting matching the settings in the left column, so any manually-formatted text

1147
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with different attributes will be protected. When you are performing an exact search

this option is effectively inactive.

6. Click on Replace Styles to execute

A dialog will be displayed allowing you to choose where you want to replace: In the

entire project, the main topics, the invisible topics or selected topics only. You can also

perform a test run to check how many styles would be found and replaced before ac-

tually applying the changes. 

Note that any changes in the current topic will only be visible in the editor after you

close the Replace Styles dialog.

Replacing one existing font style with another - fuzzy search

This method allows you to extend the scope of your search, so that in addition to finding

text that exactly matches your style you can also apply the target style to other texts. For

example, it allows you to also reset inline-formatted texts within your search text.

Fuzzy searches only seem complicated at first, they are actually quite simple. If you have

trouble try out the examples at the bottom of the instructions, they will help demonstrate

how it works.

1. Select multiple topics if you want to replace only in some topics

If you only want to replace styles in specific topics select those topics in the Project Ex-

plorer first, using Shift+Click or Ctrl+Click. Select the topic containing the example of

the style you want to replace last, so that you can select the style example in the next

step. 

2. Select a style in the editor, then select Replace Styles and Font mode

Click inside some text formatted with the style you want to replace, then select Format

> Replace Styles. Then select the Font Styles mode at the top of the dialog that ap-

pears. 

3. Set selected left-column attributes to (Any)

All the formatting attributes of the current style are displayed in the left column and

the style name is displayed at the top of the left column. 

Examples:

Suppose you know that the text whose styles you want to replace contains sub-texts

formatted with a different font that you want to reset. To do this you need to set the

Font Face attribute to (Any). 
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If you also want to reset text formatted with a different size you must also set the Font

Size attribute to (Any).

If you also want to reset text formatted with bold or italics you must set the Font

Styles attribute to (Any).

The same principle applies to all the attributes in the list. To match any differences

from the standard style settings you need to set the attributes for those differences to

(Any). You can even do this for the style name, but be careful – this may reset more

texts than you expect!

4. Select the new style in the right column

Select the new style you want to apply from the drop-down list directly below the

Change to Format/Style: heading on the right. If you need to create the style first, se-

lect Edit Styles.

5. Adjust the inline formatting settings for the desired result

As soon as you have activated fuzzy options in the search with (Any) settings you can

also start to find manually-applied formatting within your texts, i.e. formatting that

does not match the standard style settings. This makes the Inline Formatting: options

relevant.

"Remove inline formatting" resets all matching texts:

This option will reset all inline-formatted texts that match the search settings in the

left-hand column to the settings of the target style selected.

Any texts that don't match the search settings will not be reset. This means that you

can "protect" texts formatted in certain ways by choosing your search settings care-

fully. The best way to learn how to do this is to experiment with some test texts.

"Remove except B/I/U/Color" protects these attributes:

The second option "protects" bold, italic, underlined and colored text. This allows you

to be a little less careful with your left column settings and still protect these format-

ting styles, which are very frequently applied manually.

"Custom Settings" lets you choose for yourself

This option gives you full control over the target formatting, in the same way that the

individual settings in the left hand column let you control the search settings. 

By default all the attributes are set to Use style attributes. To change the output

formatting just change any of the settings.
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Important: Note that using this option will create new inline formatting within the

styled text!

6. Click on Replace Styles to execute

A dialog will be displayed allowing you to choose where you want to replace: In the

entire project, the main topics, the invisible topics or selected topics only. You can also

perform a test run to check how many styles would be found and replaced before ac-

tually applying the changes.

Note that any changes in the current topic will only be visible in the editor after you

close the Replace Styles dialog.

Examples of fuzzy searches

Objective: Search for settings: Change to settings:

Replace one style with an-

other. Leave manually-applied

bold, italics, and underlining

within the text intact.

· Font Style Name set to

the name of the source

style

· Font Styles and Under-

line set to (Any)

· All other attributes un-

changed

· Font Style Name set to

target style

· Inline Formatting set to
Remove except
B/I/U/Color

Replace one style with an-

other. Change manually-

formatted text with a different

font to the target font, leaving

all manually-applied bold, it-

alics, underlining and text

color within the target text in-

tact.

· Font Style Name set to

the name of the source

style

· Font Face, Font Styles,

Underline and Text Co-

lor set to (Any)

· All other attributes un-

changed

· Font Style Name set to

target style.

· Inline Formatting set to
Remove except
B/I/U/Color

Replace one style with an-

other and reset all manually-

applied formatting, including

bold, italics, underlining and

color.

· Font Style Name set to

the name of the source

style

· All other attributes set to
(Any)

· Font Style Name set to

target style

· Inline Formatting set to
Remove inline
formatting

See also:
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Importing Data

Text Formatting and Styles

Dynamic Styles

7.14.3 Font attributes - unstyled text

The instructions below explain how to use Replace Styles to apply formatting to text that does

not have any Help+Manual styles applied to it. See the topic on styled text  for information

on how to reformat text that already has Help+Manual styles applied to it.

Before you try to follow these instructions, please study the Introduction to style replace-

ment  for an explanation of how the Replace Styles function works. This will make it much

easier for you to use this feature.

Applying font attribute styles to unstyled text

Unstyled text is text that does not have any Help+Manual style applied to it. This is visible

in the style selector in the Write > Font section of the Ribbon – when it is blank instead of

displaying a style the text at the current cursor position is unstyled.

  The style selector looks like this when 

  the cursor is on unstyled text

Basically you proceed exactly as you would for performing an exact or fuzzy search for

styled text.  When you click in unstyled text before selecting the Replace Styles function

the Font Style Name field in the left column of the Replace Styles dialog automatically dis-

plays (Unstyled text only).

All the other settings and procedures are exactly the same. This is because the only differ-

ence between styled and unstyled text is that styled text has a style name assigned to it.

Remember: the style name is just one attribute among many.

For more details see the example in Styling imported text .

Reformatting manually-formatted text with styles

Frequently you will format certain texts in a different way to highlight them or make them

easier to identify. For example, you might format the names of menu items using a differ-

ent font and italics. The objective here is to apply named styles to these texts, so that you

can later change the formatting of all of them just by changing the style definition.
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You will most frequently need to do this with imported formatted text – for example from

RTF, CHM or HTML files – where all the formatting is always imported as manual format-

ting. 

This is a two-step process: First you need to create a style on the basis of the manual

formatting, then you need to use Replace Styles to apply this style to all the examples of

that formatting in your project. After you do this you can then change the formatting of

all these texts just by editing the style definition.

Step 1: Create a new style on the basis of the formatting

1. Select an example of the text you want to use as the model for the style (click in the

text or select it). 

2. Select Styles > Create Style from Selection in the Write tab and create a new text

style  on the basis of the formatting. 

This example creates a text style because it is assumed you are applying style to text

within paragraphs. You can also use the same approach for creating paragraph styles, but

then you must also apply the paragraph format  to the text as well in a second opera-

tion.

Step 2: Apply the style to all the texts with matching formatting

1. Select multiple topics if you want to replace only in some topics

If you only want to replace styles in specific topics select those topics in the Project Ex-

plorer first, using Shift+Click or Ctrl+Click. Select the topic containing the example of

the style you want to replace last, so that you can select the style example in the next

step. 

2. Click in the formatted text in the editor, then select Replace Styles and Font
mode

Click inside the example of the text you want to style, then select Styles > Replace

Styles in the Write tab. Then select the Font Styles mode at the top of the dialog that

appears.

3. Select (Any text) for the Font Style Name

If a style name is displayed in the Font Style Name: field in the left column change it to

(Any text). This is particularly important if you have selected the text with which you

just created the new style: Since the text you want to style does not yet have the style

name it will not be found unless you make this change.

Leave all other settings in the left column unchanged!

4. Select the name of the style you created in the right column

281
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Select the name of the new style you just created in the Change to Format/Style

column. Leave all other settings in this column unchanged. The inline formatting set-

tings are irrelevant because you are performing an exact search.

5. Click on Replace Styles to execute

A dialog will be displayed allowing you to choose where you want to replace: In the

entire project, the main topics, the invisible topics or selected topics only. You can also

perform a test run to check how many styles would be found and replaced before ac-

tually applying the changes.

Note that any changes in the current topic will only be visible in the editor after you

close the Replace Styles dialog.

Reformatting manually-formatted text without using styles

Sometimes you may just want to quickly replace one kind of formatting in your document

with another kind of formatting, without using styles at all. You do this by switching off

the style names in the search and target fields and then replacing the formatting.

1. Select multiple topics if you want to replace only in some topics

If you only want to reformat text in specific topics select those topics in the Project Ex-

plorer first, using Shift+Click or Ctrl+Click. Select the topic containing the example of

the formatting you want to replace last, so that you can select the style example in the

next step. 

2. Click in the formatted text in the editor, then select Replace Styles and Font
mode

Click inside some text with the formatting you want to change, then select Styles > Re-

place Styles in the Write tab. Then select the Font Styles mode at the top of the dialog

that appears. 

Leave the settings in the left column as they are or change them, depending on the

formatting you want to change.

3. Change the Font Style Name: setting in the left column to (Any text)

This will find all instances of the text formatted in exactly this way, no matter whether

it has a style or not. You can also use the option (Unstyled text only) if you only want

to find text that has no style applied to it. You may need to perform the search twice,

once with each option, to get all the matching text.)

4. Select the target style name setting

In the Font Style Name: field in the right column select either (Keep style name) or (Re-

move style name). The first option will keep any style name explicitly assigned to the
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reformatted text, applying the new formatting as manual (inline) formatting. The

second option will remove any explicit style name, so that the text is manually format-

ted only – it will then have the style name of the paragraph surrounding it.

5. Select Custom Settings: in the right column

Then manually select all the attributes that you want to apply to the text. All the set-

tings you leave set to (Use style attributes) in the right column will remain unchanged.

6. Click on Replace Styles to execute

A dialog will be displayed allowing you to choose where you want to replace: In the

entire project, the main topics, the invisible topics or selected topics only. You can also

perform a test run to check how many styles would be found and replaced before ac-

tually applying the changes.

Note that any changes in the current topic will only be visible in the editor after you

close the Replace Styles dialog.

Turning styles into manually-formatted text

This is just a variation on reformatting manually-formatted text without using styles. Basic-

ally all you need to do is follow the instructions for reformatting manually formatted text

(see above) with the following two changes:

1. Select the name of the style you want to remove in the left column. 

2. Select (Remove style name) in the right column.

7.14.4 Paragraph attributes - styled text

The methods described below only work for paragraphs already formatted with Help+Manual

styles. See the topic on unstyled paragraphs  for instructions on how to deal with para-

graphs that do not yet have styles applied.

Before you try to follow these instructions, please study the Introduction to style replace-

ment  for an explanation of how the Replace Styles function works. This will make it much

easier for you to use this feature.

Replacing one paragraph style with another – exact search

This is the most straightforward operation. It simply takes paragraphs formatted with one

style and applies a different style to them. Exact search replaces only the styles of para-

graphs formatted with the named style. Any inline-formatted text within text formatted

with the target style will be protected, as will any text formatted with other styles.

1. Select multiple topics if you want to replace only in some topics

1158
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If you only want to replace styles in specific topics select those topics in the Project Ex-

plorer first, using Shift+Click or Ctrl+Click. Select the topic containing the example of

the style you want to replace last, so that you can select the style example in the next

step.

2. Click in a styled paragraph in the editor, then select Replace Styles and
Paragraph mode

Click inside a paragraph formatted with the style you want to replace, then select

Styles > Replace Styles in the Write tab. Then select the Paragraph Styles mode at the

top of the dialog that appears.

3. Leave all left column attributes unchanged

All the formatting attributes of the current style are displayed in the left column

(Search for Format/Style)and the style name is displayed at the top of the left column.

Don't change any of the left-column paragraph attribute settings – the attributes must

all match exactly for an exact search.

4. Select the new style in the right column

Select the new style you want to apply from the drop-down list directly below the

Change to Format/Style: heading on the right. If you need to create the style first, se-

lect Edit Styles.

5. Leave the inline formatting settings unchanged

Leave the option Remove inline formatting activated. This will only replace inline para-

graph formatting matching the settings in the left column, so any manually-applied

paragraph attributes will be protected. When you are performing an exact search this

option is effectively inactive.

Important: The target style will not be applied at all to paragraphs that do not have

precisely matching attributes. If you also want the style to be applied to "modified"

versions of the paragraphs you must use a "fuzzy" search (see below).

6. Click on Replace Styles to execute

A dialog will be displayed allowing you to choose where you want to replace: In the

entire project, the main topics, the invisible topics or selected topics only. You can also

perform a test run to check how many styles would be found and replaced before ac-

tually applying the changes. 

Note that any changes in the current topic will only be visible in the editor after you

close the Replace Styles dialog.
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Replacing one paragraph style with another - fuzzy search

This method allows you to extend the scope of your search, so that in addition to finding

paragraphs that exactly match your style you can also apply the target style to other para-

graphs. You will probably want to do this, because most texts will contain paragraphs with

additional manual indents and so on.

Fuzzy searches only seem complicated at first, they are actually quite simple. If you have

trouble try the examples at the bottom of the instructions, they will help demonstrate how

it works.

1. Select multiple topics if you want to replace only in some topics

If you only want to replace styles in specific topics select those topics in the Project Ex-

plorer first, using Shift+Click or Ctrl+Click. Select the topic containing the example of

the style you want to replace last, so that you can select the style example in the next

step.

2. Click in a styled paragraph the editor, then select Replace Styles and Paragraph

mode

Click inside some text formatted with the style you want to replace, then select Styles

> Replace Styles in the Write tab. Then select the Paragraph Styles mode at the top of

the dialog that appears.

3. Set selected left-column attributes to (Any)

All the formatting attributes of the current style are displayed in the left column and

the style name is displayed at the top of the left column. 

For example, suppose you know that you have manually changed the indent of some

of the paragraphs formatted with the current style. To include these paragraphs in the

search set the Left Indent and/or Right Indent attributes to (Any). 

The same applies for all the other settings. It is the same principle: If you know that

you have manually changed any settings in paragraphs formatted with the current

style you must set those settings to (Any) to include the manually-altered paragraphs

in the search.

4. Select the new style in the right column

Select the new paragraph style you want to apply from the drop-down list directly be-

low the Change to Format/Style: heading on the right. If you need to create the style

first, select Edit Styles.

5. Adjust the inline formatting settings for the desired result
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As soon as you have activated fuzzy options in the search by including (Any) for search

options can also start to find manually-applied paragraph formatting that does not

match the standard style settings. This makes the Inline Formatting: options relevant.

"Remove inline formatting" resets all matching paragraph set-

tings

This option will reset all manually-applied paragraph settings that match the search

settings in the left-hand column to the settings of the target style selected.

Any texts that don't match the search settings will not be reset. This means that the

target style will not be applied to paragraphs with settings that don't match your com-

bination of exact and fuzzy search options.

"Remove except Alignment+Indent" protects these attributes

The second option "protects" alignment and indenting from being reset by the target

style. This allows you to be a little less careful with your left column settings and still

protect these formatting styles.

"Custom Settings" lets you choose for yourself

This option gives you full control over the target formatting, in the same way that the

individual settings in the left hand column let you control the search settings. 

By default all the attributes are set to Use style attributes. To change the output

formatting just change any of the settings.

Note that using this option will result in paragraphs with additional manually-applied

formatting

6. Click on Replace Styles to execute

A dialog will be displayed allowing you to choose where you want to replace: In the

entire project, the main topics, the invisible topics or selected topics only. You can also

perform a test run to check how many styles would be found and replaced before ac-

tually applying the changes.

Note that any changes in the current topic will only be visible in the editor after you

close the Replace Styles dialog.

Examples of fuzzy searches

Objective: Search for settings: Change to settings:
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Replace one paragraph style

with another. Include para-

graphs with manually-modi-

fied indents in the search.

· Left Indent and/or Right

Indent set to (Any) or
(Any value <> 0)

· All other attributes un-

changed, including Para

Style Name

· Para Style Name set to

target paragraph style

name

· Inline Formatting set to
Remove except Align-
ment+Indent

Replace one paragraph style

with another. Include para-

graphs with manually-modi-

fied indents and manually-

modified alignment in the

search.

· Left Indent and/or Right

Indent  set to (Any) or
(Any value <> 0),

Alignment set to (Any).

· All other attributes un-

changed, including Para

Style Name

· Para Style Name set to

target paragraph style

name

· Inline Formatting set to
Remove except Align-
ment+Indent

Replace one paragraph style

with another and reset all

manually-applied paragraph

formatting, including align-

ments and indents.

· All attributes unchanged,

including the style name.

· Para Style Name set to

target style.

· Inline Formatting set to
Remove inline
formatting

See also:
Importing Data

Text Formatting and Styles

Dynamic Styles

7.14.5 Paragraph attributes - unstyled text

The instructions below explain how to use Replace Styles to apply formatting to paragraphs

that do not have any Help+Manual styles applied to them. See the topic on styled para-

graphs  for information on how to reformat paragraphs that already have Help+Manual

styles applied to them.

Before you try to follow these instructions, please study the Introduction to style replace-

ment  for an explanation of how the Replace Styles function works. This will make it much

easier for you to use this feature.

Applying paragraph styles to imported and other unstyled text

Unstyled paragraphs are paragraphs that do not have any Help+Manual styles applied to

them. This is visible in the style selector in the Ribbon – when it is blank instead of display-

ing a style the text at the current cursor position is unstyled.
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  The style selector looks like this when 

  the cursor is on unstyled text

Basically you proceed exactly as you would for performing an exact or fuzzy search for

styled paragraphs. When you click in an unstyled paragraph before selecting the Replace

Styles function the Para Style Name field in the left column of the Replace Styles dialog

displays (Unstyled text only).

If the Para Style Name field is not set to (Unstyled text only) already you must change it to

this setting to make sure that the search finds paragraphs with no styles applied. All the

other settings and procedures are exactly the same. This is because the only difference

between styled and unstyled text is that styled text has a style name assigned to it. Re-

member: the style name is just one attribute among many.

For more details see the example in Styling imported text .

Reformatting manually-formatted paragraphs with styles

Frequently you will manually format some paragraphs in a different way from other para-

graphs in your project. After a while you may decide that there are enough of these para-

graphs to define a style for them. The following instructions explain how to use Replace

Styles to achieve this.

This is a two-step process: First you need to create a style on the basis of the manual

formatting, then you need to use Replace Styles to apply this style to all the matching

paragraphs in your project. After you do this you can then change the formatting of all

these paragraphs just by editing the style definition.

Step 1: Create a new style on the basis of the formatting

1. Click in the paragraph that you want to use as the model for the style. 

2. Select Styles > Create Style from Selection in the Write tab and create a new

paragraph style  on the basis of the formatting. 

The font attributes of the new paragraph style will be set automatically. You can then

use Font Styles mode in a second pass to apply the font styles to your target text.

1162
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Step 2: Apply the style to all the texts with matching formatting

1. Select multiple topics if you want to replace only in some topics.

If you only want to replace styles in specific topics select those topics in the Project Ex-

plorer first, using Shift+Click or Ctrl+Click. Select the topic containing the example of

the style you want to replace last, so that you can select the style example in the next

step.

2. Select a paragraph in the editor, then select Replace Styles and Paragraph
mode.

Click inside the example of the paragraph you want to style, then select Styles > Re-

place Styles in the Write tab. Then select the Paragraph Styles mode at the top of the

dialog that appears.

3. Select (Any text) for the Para Style Name.

If a style name is displayed in the Para Style Name: field in the left column change it to

(Any text). This will ensure that all paragraphs with matching attributes will be found.

Leave all other settings in the left column unchanged!

4. Select the name of the paragraph style you just created in the right column.

Select the name of the new style you just created in the Change to Format/Style

column. Leave all other settings in this column unchanged. The inline formatting set-

tings are irrelevant because you are performing an exact search.

5. Click on Replace Styles to execute.

A dialog will be displayed allowing you to choose where you want to replace: In the

entire project, the main topics, the invisible topics or selected topics only. You can also

perform a test run to check how many styles would be found and replaced before ac-

tually applying the changes.

Note that any changes in the current topic will only be visible in the editor after you

close the Replace Styles dialog.

Reformatting manually-formatted paragraphs without styles

Sometimes you may just want to quickly replace one kind of paragraph formatting in your

document with another kind of formatting, without using styles at all. You do this by

switching off the style names in the search and target fields and then replacing the

formatting.

1. Select multiple topics if you want to replace only in some topics.
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If you only want to reformat paragraphs in specific topics select those topics in the

Project Explorer first, using Shift+Click or Ctrl+Click. Select the topic containing the ex-

ample of the formatting you want to replace last, so that you can select the style ex-

ample in the next step.

2. Select a paragraph in the editor, then select Replace Styles and Paragraph
mode.

Click inside a paragraph with the formatting you want to change, then select Styles >

Replace Styles in the Write tab. Then select the Paragraph Styles mode at the top of

the dialog that appears. 

Leave the settings in the left column as they are or change them, depending on the

formatting you want to change.

3. Change the Para Style Name: setting in the left column to (Any text).

This will find all instances of the paragraph formatted in exactly this way. You can also

use the option (Unstyled text only) if you only want to find paragraphs that has no

style applied to it. (You may need to perform the search twice, once with each option,

to get all the matching paragraphs.)

4. Select the target style name setting.

In the Para Style Name: field in the right column select either (Keep style name) or (Re-

move style name). The first option will keep any style name explicitly assigned to the

reformatted paragraph. The second option will remove any explicit style name, so that

the resulting paragraph is manually formatted only.

5. Select Custom Settings: in the right column.

Then manually select all the attributes that you want to apply to the text. All the attrib-

utes you leave set to (Use style attributes) will remain unchanged.

6. Click on Replace Styles to execute.

A dialog will be displayed allowing you to choose where you want to replace: In the

entire project, the main topics, the invisible topics or selected topics only. You can also

perform a test run to check how many styles would be found and replaced before ac-

tually applying the changes.

Note that any changes in the current topic will only be visible in the editor after you

close the Replace Styles dialog.

Turning styled paragraphs into manually-formatted paragraphs

This is just a variation on reformatting manually-formatted paragraphs without using

styles. Basically all you need to do is follow the instructions for reformatting manually
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formatted paragraphs  with the following two changes:

1. Select the name of the style you want to remove in the left column. 

2. Select (Remove style name) in the right column.

7.14.6 Styling imported formatted text

When you import Word RTF files the styles used in the file are retained and automatically ad-

ded to your project styles, which you can access and edit in Write > Edit Styles. 

The situation is different when you import formatted text from other sources like CHM or

HTML files. Then the formatting is retained but the text does not have any styles. Effectively, it

is all manually formatted. You can use the Replace Styles function to integrate this formatting

into the stylesheet of your project, either by applying existing styles or by creating new styles

and applying them.

This topic illustrates this by walking you through the steps of a typical example. For details on

how to perform the individual operations see the topics in this chapter on replacing font and

paragraph styles and formatting. 

Tip: Converting imported HTML formatting with Premium Pack Tool-

box

Provided style classes were used in the original HTML you can globally strip out inline

formatting imported from HTML and convert it to style references with the powerful Tool-

box utility included in the Premium Pack style pack. See Integrating imported formatting

with Toolbox  for details. 

Example: Applying the Normal style to imported body text

Let's assume that you want to apply the Normal style to all your imported unstyled body

text. At the same time you also want to apply named styles to inline-formatted text within

your body text, some of which has different font settings to that of the body text (for ex-

ample menu names and other items formatted with different fonts etc). 

Step 1: Setting up the styles

If you want to use the style of the imported text in your project you first need to use
formatting from your imported text as a model to update your project's style definitions.

1. Update the Normal style on the basis of the imported text. 

Click in a plain area of the imported body text and select Styles> Create Style from

Selection in the Write tab. Then select Change existing style, select Normal in the style

list and activate Assign paragraph attributes.

1154
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2. Update or create text styles for additional formatting.

If special formatting is used for text within other paragraphs click in examples of this

formatting in your imported text. Then use Styles> Create Style from Selection in the

Write tab to update or create a new text styles for this formatting. Repeat for all differ-

ent formatting types used within paragraphs.

See Defining styles  for more details on using the Create Style from Selection func-

tion.

Step 2: Apply the Normal font attributes to the main body text

Next you want to apply the modified Normal font style attributes to the text of the body
paragraphs in your imported text.

1. Select multiple topics if you want to replace only in some topics

If you only want to replace styles in specific topics select those topics in the Project Ex-

plorer first, using Shift+Click or Ctrl+Click. Select the topic containing the example of

the style you want to replace last, so that you can select the style example in the next

step.

2. Select an example of the body text in the editor, then select Replace Styles and
Font mode

Click inside some text formatted with the style you want to replace, then select Styles

> Replace Styles in the Write tab. Then select the Font Styles mode at the top of the
dialog that appears. 

3. In the left column, set the Font Style Name to (Unstyled text only)

Set Font Style Name in the left column to (Unstyled text only) and leave all other
attributes unchanged. This will find all text with the attributes of the current paragraph
and will make sure that any paragraphs in your project that already have named
styles remain unaffected. 

4. Select Normal in the right column

Select Normal in the drop-down list directly below the Change to Format/Style: head-

ing on the right. This will apply the Normal style to all matching text. 

5. Leave the inline formatting settings unchanged

The exact settings in the left column will only match the unchanged body text, so any

text within paragraphs with different formatting will be ignored. This makes the Inline

Formatting: options irrelevant – you can leave the default setting of Remove inline

formatting as it is.

6. Click on Replace Styles to execute

281
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A dialog will be displayed allowing you to choose where you want to replace: In the
entire project, the main topics, the invisible topics or selected topics only. You can
also perform a test run to check how many styles would be found and replaced before
actually applying the changes.

Note that any changes in the current topic will only be visible in the editor after you

close the Replace Styles dialog.

Step 3: Apply text styles to sub-texts within the body text

Now you want to apply the text styles created in step 1 to the differently formatted sub-
texts within the body text. This must be repeated for each sub-text type.

1. Select multiple topics if you want to replace only in some topics

If you only want to replace styles in specific topics select those topics in the Project Ex-

plorer first, using Shift+Click or Ctrl+Click. Select the topic containing the example of

the style you want to replace last, so that you can select the style example in the next

step.

2. Click in an example of the sub-text in the editor, then select Replace Styles and
Font mode

Click inside one of the formatted texts that you want to style, then select Styles >

Replace Styles in the Write tab. Then select the Font Styles mode at the top of the
dialog that appears. 

3. Select (Unstyled text only) or (Any text) in the left column

If you know that none of the sub-texts have styles applied to them select (Unstyled

text only), otherwise select (Any text) to make sure that you find all of them.

4. Select the target style in the right column and execute

In the right column select the appropriate text style in the Change to Format/Style list

and then click on Replace Styles to replace all the styles. 

Repeat the above procedure for every text style in your project.

Step 4: Apply the Normal paragraph attributes to your body text

Finally, you also want to apply the paragraph attributes of the Normal style to your impor-

ted body text so that it is fully integrated in your stylesheet.

1. Select multiple topics if you want to replace only in some topics

If you only want to replace styles in specific topics select those topics in the Project Ex-

plorer first, using Shift+Click or Ctrl+Click. Select the topic containing the example of
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the style you want to replace last, so that you can select the style example in the next

step.

2. Click in a body paragraph editor, then select Replace Styles and Paragraph
mode

Click in one of your body text paragraphs, then select Styles > Replace Styles in the

Write tab. Then select the Paragraph Styles mode at the top of the dialog that ap-

pears.

3. Select (Unstyled text only) for the Para Style Name

If a style name is displayed in the Para Style Name: field in the left column change it to

(Unstyled text only). This will ensure that only paragraphs that do not yet have styles

applied to them will be found. This will reduce the possibility of errors and will protect

any styled paragraphs in your project with the same settings. Leave all other settings

in the left column unchanged!

4. Select Normal in the right column

Select the Normal style in the Change to Format/Style column. Leave all other settings

in this column unchanged. The inline formatting settings are irrelevant because you

are performing an exact search.

5. Click on Replace Styles to execute

A dialog will be displayed allowing you to choose where you want to replace: In the

entire project, the main topics, the invisible topics or selected topics only. You can also

perform a test run to check how many styles would be found and replaced before ac-

tually applying the changes.

Note that any changes in the current topic will only be visible in the editor after you

close the Replace Styles dialog.

See also:
Importing Data

Text Formatting and Styles

Dynamic Styles

7.14.7 Integrating imported formatting globally

If you have the Premium Pack style pack add-on for Help+Manual 9 you can use its powerful

Toolbox utility to convert formatting imported from HTML to styles. Provided the imported

text used HTML classes, Toolbox can strip out the manual formatting and apply the style at-

tributes to bring your imported text fully under the control of your project stylesheet.

148

273

1482

https://www.helpandmanual.com/products_hm_pluspack.html


1166

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

More Advanced Procedures

About formatting in text imported from HTML

When you import HTML files or a CHM help file to a Help+Manual project your formatting

comes in as inline formatting. Normally, you need to create styles based on the formatting

and then manually apply them to all the paragraphs in your project where you want to use

the style. This new tool eliminates many hours of tedious work by doing this automatic-

ally.

If your imported text includes style names you can use Normalize Project Styles in the

Tools menu of Toolbox to remove the inline formatting and apply the style to all para-

graphs in the project using the style. All you need is for a paragraph or any text within the

paragraph to be tagged with a style name. It will then apply your selected paragraph style

to the entire paragraph, eliminating manual formatting at the same time.

Why is this better than just re-applying styles or using the Replace Styles tool
in Help+Manual?

· Much, much faster than any other method

To re-apply styles you would need to go through your project manually, select each

paragraph and then select the style. Normalize processes your entire project in seconds.

· Protects meaningful formatting

Re-applying styles is a blunt tool that re-formats everything in the entire paragraph.

Normalize allows you to protect text formatted with other styles, while still removing re-

dundant manual formatting attributes from those text tags. You can also protect manual

bold, italics and underlining, and choose different styles for different hyperlink and

toggle types.

· Replace Styles doesn't handle paragraph and text attributes at the same time

The Replace Styles tool in Help+Manual is powerful, but it only allows you to process

either paragraph attributes or text attributes. Because of this, it is impossible to use it

globally to format entire paragraphs accurately: You can't tell it to use a style in a text

element for the paragraph, or a paragraph style for the text, because these elements are

always accessed in separate operations.

This is fully compatible with Tidy XML

The Normalize Project Styles function is fully compatible with the new Tidy XML func-

tion  introduced in Help+Manual 9.3. It automatically identifies whether topics are

formatted with the Tidy XML option active or not and adjusts its own XML formatting ac-

cordingly. 

For the most compact code it is best to use both Tidy XML and normalizing. 
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The imported text does need to include style names 

After importing HTML files or a CHM file, first check whether the text is tagged with style

names – it will be if style names (classes or IDs) were used in the original HTML. All you

need to identify a paragraph for normalization is for some text anywhere within the para-

graph to be tagged with a style name.

This is necessary, because otherwise it's not possible to identify the paragraphs you want

to re-style. Style names that are not present in the stylesheet are shown in red in the style

selector. If you are using Help+Manual 9.2 or earlier you may need to activate the XML

editor briefly to make the red style names appear in the current topic (this cosmetic bug is

fixed in Version 8.3 and later).

Step 1: Create the paragraph style you want to use for all the text containing

the imported style 

The easiest way to do this is to use a paragraph already containing the style name as a

model. Make any adjustments to the formatting you want in the Help+Manual editor,

then click in the text that is formatted the way way want it and select Styles > Create Style

from Selection in the Write tab. 
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Repeat this for all the styles you want to use. Then save the project when you have fin-

ished and close it.

Step 2: Normalize the styles with Toolbox

Open the project with PP Toolbox and select the Normalize Project Styles option in the Tools

menu. Then select the Individual Styles tab.



1169

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

More Advanced Procedures

If you have used the name of the imported style for the style added to your project

stylesheet you just need to select its name in the Style to normalize: field and it will be

used both for identifying the paragraphs to style and for normalizing. Otherwise you need

to select the style to be applied to the identified paragraphs with the Replace with para-

graph style option.

Set the other options as explained in the screenshot above, then click on Normalize Style

to proceed. The first time you do this you should then check the results in your project be-

fore proceeding with additional styles.
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8 Multi-User Editing & Translation

8.1 Multi-User Editing

Help+Manual allows multiple users to edit the same project at the same time when both are

on the same local network with its integrated multi-user editing capabilities. Users in different

locations should use version control for collaboration (see further below). 

The only restriction in local multi-user editing is that it is not possible for two authors to edit

the same topic simultaneously. When one author is editing a topic, a second author accessing

the topic can view it but not edit it. A message will be displayed saying that the topic is read-

only because it is in use.

Multi-user editing works directly "out of the box". You do not need to do any server configur-

ation. There are no special settings and you don't need a database or additional external soft-

ware, either locally or on the server. You just need to store your project in uncompressed XML

(.hmxp) format on a drive that all your authors can access and start editing. 

  

Productivity Tip
Refresh your project regularly! While collaborating on

the same project  always click on Refresh Project in the

Project menu whenever you switch to a new topic to

make sure that you see the current version of the

Table of Contents and Project Files.

Requirements for multi-user editing

· Professional and Floating licenses only: 

Multi-user editing is only supported with the Professional and Floating licenses for

Help+Manual. All users accessing the project must be working with Professional or

Floating licenses.

· Uncompressed XML save format only:

Projects must be saved in the uncompressed XML (.hmxp) format for multi-user editing

to be possible. The compressed .hmxz format cannot be used because it is stored in a

single file and it is necessary to access individual topic files for multi-user editing.

· All projects and sub-projects must also be saved as uncompressed XML:

If the project has any merged sub-projects they must all also be saved as uncompressed

.hmxp projects. You cannot have any .hmxz sub-projects if you are going to use multi-

user editing.
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Use a version control system for remote multi-user editing

Help+Manual's integrated multi-user editing is only for users working on the same local

network (LAN). If you wish to do multi-user editing remotely and offline (users in different

geographical locations, also needing to edit without a network connection) you need to

store a master copy of your project in a version control system. Then each user works on a

linked copy of the project on their own computers, which they synchronize via the version

control system's server. This provides all the advantages of direct remote editing, but each

author is still working on their own local (but linked) copy rather than directly via an Inter-

net connection.  

See Using Version Control Systems  for instructions on getting Help+Manual set up to

work with version control for remote editing.

Each remote user needs their own local copy of Help+Manual

Note that the remote authors will need their own copies of Help+Manual on their own

computers to do this. This is possible with both the Professional and Floating license ver-

sions. 

Supported version control systems

Out of the box, Help+Manual is already configured to support Subversion and Git. Both

these systems are free and open source, and extremely mature and reliable. In addition to

this, you can also configure additional scripts yourself to support any other version control

system with a command line interface.

Basic procedure

With version control, authors can work on shared projects offline from any location. Each

author downloads a local working copy of the project from the repository. This working

copy is what you edit, but it remains linked to the "master" copy in the repository. Only

changes need to be transferred in either direction. This makes the solution extremely effi-

cient and also very robust -- you have none of the data integrity and speed nightmares in-

volved in live editing via an open connection. 

Almost all your work is done offline. You just need to synchronize with the server once be-

fore starting work, to get the latest changes from your colleagues, and once afterwards to

add your new work to the server version.

848
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Conflicts with other users' work

This process generally works even if two people have worked on the same topics. If they

have edited different parts of the topics the changes are just merged silently, because

there are no conflicts. If they have both edited the same text you get a dialog from the

version control system asking you which versions of each change you want to keep

("mine" or "theirs"). Agreements between team members on which topics to work on can

keep these conflicts to a minimum. 

Full instructions

See Using Version Control Systems  for instructions on getting Help+Manual set up to

work with version control for remote editing.

Use a style repository to standardize your styles!

Style standardization is a common problem in team projects: you generally don't want in-

dividual authors making arbitrary changes to the styles of your standard layout. 

If you want to make sure that the same styles are used by everyone working on the pro-

ject it's advisable to store the styles in a style repository project and link the repository to

your documentation project. Then only give the team member responsible for layout ac-

cess to the style repository so that only she or he can edit the project styles. 

See Working with Style Repositories  for instructions on how to set this up for your pro-

ject.

The Refresh Project and Synchronize SVN/TFS tools in the Project tab

The Refresh Project tool is for local multi-user editing without a ver-

sion control system

This is a very important tool when you are working in Help+Manual's direct multi-user

editing mode on your local network. It updates the display of the project and the TOC on

848
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your screen so that you can be sure that you are seeing the current version, including any

changes made to the TOC by other users who may have moved, deleted or renamed TOC

items.  

Refresh also updates the contents and lock state (read-only or read-write) of the current

topic displayed in the editor. 

Always use Refresh Project before making any changes that affect the TOC (renaming,

moving, deleting and creating topics). 

Always save your project directly after making changes that affect the TOC to make sure

that there are no conflicts with other users' edits that you need to resolve.

See Creating, renaming, moving and deleting topics below for more details.

The Version Control tool is for projects managed in version control

systems

The Synchronize tool is only relevant for users working

directly on the same project in a local network

When you are working on a local working copy of a project managed in a version control

system you don't need to use the Refresh Project tool, because you are always the only

person working on your local working copy. 

Instead, you use the Version Control tool to merge your work with the master copy on the

version control server. See Using Version Control Systems  for full details.

Editing topics

For local multi-user editing, just store the project on a network or server drive where all

authors have read/write access. (Save using the uncompressed HMXP format, otherwise

this will not work!) Then all users open the same project and start editing as normal. 

You will only notice a difference if you try to edit a topic that someone else has open –

then you will get a message telling you that the topic is open and is not currently avail-

able. Help+Manual will never allow two different versions of the same topic to be created

and it will never allow two users to edit the same topic at the same time. This applies even

if you have not saved your project. 

848
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When you select a topic that another user is already working on you will see a red bar

with a READ ONLY warning at the top of the editor screen and the topic will be grayed out

in the TOC. 

If another user starts editing the topic while you are viewing it you will not see the READ

ONLY bar immediately. However, if you then try to edit the topic you will get a message

telling you that the topic is now being worked on and then the READ ONLY bar will be

displayed.

Custom display color for read-only topics:

You can set a custom color for displaying read-only topics in the TOC to make them easier

to identify for you. Go to View > Program Options > Editor and change the setting for

Display color for read-only TOC items.

Creating, renaming, moving and deleting topics

Help+Manual never allows you to edit the content of topics being worked on by other

users under any circumstances, even if you have not saved or refreshed your project. 

However, when you make changes in the TOC in multi-user mode you are working on a

local copy of the TOC. The changes are only written to the actual project file when you

save the project. If another user has made changes to the same TOC entries you will have

a conflict and a dialog will be displayed asking you to resolve the conflict – you must then

decide which version of the changes to keep and which to discard.

User Refresh Project to avoid TOC conflicts:

To avoid conflicts you should always select Refresh Project in the Project tab before mak-

ing any changes to the TOC. This will update your local copy of the TOC with the current

main version. 

Refresh also updates the contents and lock state (read-only or read-write) of the current

topic displayed in the editor.
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Creating new topics:

You can create new topics just as you would when you are working on a project on your

own. New topics cannot conflict with changes made by other users so you can always cre-

ate them. Of course, if you choose a topic ID/topic file name that conflicts with an existing

topic you will not be allowed to create the topic.

Renaming, moving and deleting topics:

Always select Refresh Project before moving or deleting topics or renaming them in the

TOC. This ensures that you are viewing the current version of the TOC in the main project

file and prevents you having to resolve conflicts with your co-workers.

Once you have done this you can move and delete topics just as you would when you are

working in single-user mode. 

Even so, it is generally advisable to check with your colleagues before moving or deleting

topics that others have also worked on! If in doubt make a copy of the topic with File >

Save Topic to File in Project > Manage Topics before deleting it.

Global search and replace

You can perform global search and replace operations normally when other users are

working on the same project as you. You will be able to find terms in topics that other

users are working on but you will not be able to replace them there until the other users

save their work and stop editing the topics.

Editing your project configuration

Your settings in the Configuration section of your project are not managed in the same

way as your project content. Any changes you make here are made without warnings or

locking. Anyone who makes changes here and saves the project will overwrite the current

settings with the new settings.

When you are working in a team the Configuration section should be the responsibility of

the project manager. Always check with your project manager or co-workers before chan-

ging anything in your project configuration!  
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8.2 Translating Your Projects

Integrated support for translation and localization is only included in the Professional and

Floating license versions of Help+Manual. Although all versions support Unicode and can thus

produce projects in all supported languages, the Basic version does not include the Project

Synchronization Tool  and does not support saving in the uncompressed XML format re-

quired for translation with tools like SDL Trados . 

However, you can use the Basic version to edit projects created with the Professional or Float-

ing license version without restrictions. It can edit all the features of both compressed HMXZ

projects and uncompressed HMXP projects. It just can't create some of the features that are

exclusive to the Professional and Floating license versions, but the translator doesn't need to

do that anyway.

The topics in this chapter provide an introduction to Help+Manual's translation and localiza-

tion features and show you where to find the information you need to use them.

See also:
Translating in Help+Manual
Translating with external editors
The Project Synchronization Tool

8.2.1 About translation support

DeepL AI machine translation is built in to Help+Manual!

If you want to get a head start on translating your projects you can use the built-in DeepL

translation system. This advanced artificial intelligence based machine translation is radic-

ally better than any automatic translation in the past and you may find it good enough for

basic needs or a foundation for proofreading with surprisingly little need for correction.

The XML project format can be processed directly by translation tools

Your uncompressed XML project files (.hmxp save mode) can be edited and translated dir-

ectly with an XML-aware professional translation tool like  SDL Trados. See the topic on

translation memory  for instructions.

Using Help+Manual as your translation edtior

You can also translate your projects in Help+Manual itself. This can be done either in-

house using your own copy of the program or by an outside translator working with

Help+Manual as a translation editor. Only the Basic version of Help+Manual is required

for this. The Basic version can edit all features of projects created with the Professional or

Floating license versions, including uncompressed projects in the HMXP format (it cannot

create them but it can edit them). You cannot create some features with the Basic version,

1245
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but this is not something the translator should be doing anyway, and all features created

with the other versions can be translated with the Basic version.

Integrated support for updating translations made with

Help+Manual 

The Project Synchronization Tool  makes it easy to identify topics containing changes in

the next version of your documentation so that you can provide the translator with a new

version of the project file to update. 

Using XML editors

While it is possible to edit Help+Manual projects with a normal XML editor it is not some-

thing we can recommend. This also exposes all the XML source code and tags to editing

and the danger of damage to the code and errors is very high. For good, reliable results it

is best to use either Help+Manual itself as the translation editor or a translation memory

tool.

Using Help+Manual as the translation editor

This is the simplest solution. If your translator also has Help+Manual (the Basic version can

be used to translate all projects, including Professional projects) they just open a copy of

the project and translate it, and you then get a translated version back. The Project Syn-

chronization Tool included in the program identifies new text that needs to be translated

when you update your projects.

Using a translation memory tool

"Translation memory" tools like SD Trados (this is the market leader)  automatically "re-

member" all text that has been translated so nothing ever needs to be translated twice.

They can process Help+Manual's XML projects directly, so there is no conversion neces-

sary. When you update your projects all known text is translated automatically and the hu-

man translator only needs to handle new and changed material.

8.2.2 Machine translation with DeepL

The DeepL plugin included with Help+Manual uses DeepL's amazingly accurate artificial intel-

ligence translation system to translate in both directions between the 25 currently supported

languages:

Bulgarian, British English, American English, Chinese (simplified), Czech, Danish, Dutch,

Estonian, Finnish, French, German, Greek, Hungarian, Italian, Japanese, Latvian, Lithuanian,

Polish, Portuguese, Romanian, Russian, Slovak, Slovenian, Spanish, Swedish, Turkish

1245
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It is very fast and works in a way that allows you to check the translations as you go and make

any necessary corrections.

How to use the translation plugin

You need a free or paid DeepL Developer API subscription

You can test the quality of DeepL translations directly on the DeepL website. Just visit the

site and enter the text you want to translate. You'll be amazed at the quality of the results.

https://www.deepl.com/translator
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Free subscription

You can use DeepL free of charge in Help+Manual with a free API subscription that allows

you to translate up to 500,000 characters of text per month. This is a great way to test it

out, and it will also be easily enough for many smaller projects. Note however that the

character count does include all the XML code, so it may be less than you expect. 

Paid subscription

If you need more text you can opt for the paid subscription, which is just €4.99 a month

plus very reasonable volume fees. Either way, it is a tiny fraction of what translation nor-

mally costs.

Getting your Developer API key

You can get the free or paid Developer API key subscription directly on this page at the

DeepL website:

 https://www.deepl.com/en/pro.html#developer 

Important: You must have a Developer API key, not any other type

You must use either a Developer API key (free or paid) to use DeepL with Help+Manual .

Please do make sure that is the one you get, because other key types available on other

pages on the DeepL site won't work. 

Setting up DeepL in Help+Manual

This couldn't be easier. Just select the DeepL Translator plugin with the Plugins tool in the

Project tab. Then select the About tab to access the configuration options.

Entering your API key

Select the About tab and paste your key in the Your DeepL Auth-Key Field. This automat-

ically selects the correct Base URL, which is displayed below your key.

https://www.deepl.com/en/pro.html#developer
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Translating with DeepL

The DeepL plugin doesn't translate entire topics automatically. It works on the text you se-

lect in the topic. It is possible to select the entire topic, but we recommend doing one

paragraph at a time so that you can check and make any minor corrections to the results

as you go along. We strongly recommend that this work should be performed by

someone who knows the target language well so that you get good corrections.

Keyboard Shortcuts:

You can assign keyboard shortcuts to the Translate and Apply operations in the About tab

of the DeepL plugin:
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1: Select your source and target languages

Select the topic you want to translate in your project, then select the Translate tab in the

plugin. Select the source language from the drop-down list above the Original box and

the target language from the list above the Translation box. You can also choose the

Detect Language option for the source language if you like, but that may cause a slight

delay on some systems.
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2. Select the paragraph you want to translate

As soon as you select the text you want to translate in the topic it is automatically trans-

ferred to the Original box in the plugin.
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3: Click on Translate to perform the translation

The Translate button contacts the DeepL server and performs the translation, which then

appears in the Translation box. The display in the box is read-only. You can edit the trans-

lation after it is transferred into the topic editor. 

4: Click on Apply Translation to insert the translation

Finally, the Apply Translation button inserts the translation in the editor, replacing the ori-

ginal selected text. You can make any edits there if necessary. Then you just repeat the

above steps for the next paragraph or group of paragraphs you want to translate.

Protecting text against translation

If you want to prevent individual words and passages of text from being translated you

just need to select it and apply the protected text formatting option in the Font section of

the Write tab. DeepL will then ignore the protected text.
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Protecting frequently-used words and phrases

You can prevent frequently-used words and phrases from being translated by entering

them into a glossary. Glossaries can also be used to change words and phrases automatic-

ally. See further below for details.

Using the API Glossary feature to protect words and phrases

The API Glossary tab in the DeepL plugin allows you to define and use lists of words and

phrases that you don't want to translate. For example, you will generally want product

names to remain unchanged whenever you use them. Using a glossary to protect these

words and phrases is much easier than locating all instances of the text in your project

and applying the protected text feature to each one.
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About glossary files

API Glossaries are simple plain-text files containing a list of words and phrases. They are

integrated with DeepL's machine learning system so that it takes them into account when

analyzing the context of the translation. This results in better translation results than the

older local Glossary system.

· You can use multiple glossaries in a single project.

· Glossaries are external files and can be used in multiple projects.

· If you unload the glossary it will no longer be used in the current project.

How to create a glossary

1. Select the API Glossary tab in the DeepL plugin and click on New to open the glossary

editor window. 

2. Select the language pair and direction in the language field. This is important as it tells

DeepL how to interpret the content inserted by the glossary. Not all possible language

combinations are supported yet, but more are being added.

3. Enter the phrase and the desired translation on a single line, separated by tabs
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Entries are case-sensitive

Note that the entries are case-sensitive. If you wish to protect versions of the same words

with different cases you need to enter each one separately. 

Clicking on OK prompts you to save the file with the extension .txt. If you are only going

to use it in the current project you can save it in the project folder. If you want to use it in

multiple projects you can save it in a location that will be accessible for all the projects. It

is added to the active translation glossary list automatically after saving.

Editing a glossary

To edit an existing glossary just select it in the list and click on the Edit button.

Adding and removing existing glossaries

To add an existing glossary for use with the current project just click on Add and then se-

lect the glossary file. If you no longer wish to use a glossary in the current project select it

in the active list and click on the Remove button. This does not delete the glossary file. It

just removes it from the list of glossaries used in the current project. 

8.2.3 Using translation memory tools

Many professional translators and translation agencies use "translation memory" tools like SD

Trados (this is the market leader) to translate Help+Manual projects. 

Translation memory tools are generally too complex and expensive to purchase and learn

yourself unless your company has its own translation department. However, the benefits of

using them are so great that you should really consider working with translators who use

them, particularly if you have extensive documentation that gets updated regularly.

If you can, using translation memory is definitely the most efficient way to manage the trans-

lation and localization of your Help+Manual projects.

Protecting text against changes and translation

You can explicitly protect text against translation and editing changes. To do this select

the text in the editor and then select the "padlock" tool in Write > Font. The text will then

be displayed shaded in the Help+Manual editor and it will be tagged with the attribute

translate="false" in the XML topic file.
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How translation memory works

Translation memory tools have an integrated dynamic database for your projects that

automatically "remembers" all text that has been translated. When you deliver updated

version of your project the software first reads it through and automatically translates all

the sentences that have already been translated. Then the human translator only needs to

process the new and changed material.

In addition to this they generally also feature additional tools to make translation more ef-

ficient, like a terminology database that gives the translator direct access to the correct

translated terms for all your special terminology. 

Benefits of translation memory

· Never translate anything twice – all unchanged material gets translated automatically

· Terminology consistency – your customers don't get confused by varying terms for the

same things

· Easy updating – no need to track changes, you just send the new version for translation

· Compatibility with Help+Manual projects – the tools work on them directly

Translation memory tool compatibility

Generally, any tool capable of handling XML files should be able to process

Help+Manual's topic and TOC files, although some will do it better than others. XML-

aware tools like  SDL Trados and  Across can process Help+Manual projects directly.

Generating configuration files for Help+Manual in Trados

Trados configuration files are no longer included directly

Help+Manual no longer includes standard configuration files for SDL Trados because ex-

perience has shown that most translators need to generate their own version, and this is

better done directly in the specific version of Trados that they are using.

Creating an .sdlfiletype for Help+Manual 

Translators using SDL Trados need to generate an .sdlfiletype configuration file from

the XSD file included in every HM project folder. XSD stands for "XML Schema Data' and it

http://www.trados.com/
https://www.across.net/
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defines the entire Help+Manual' XML format, or "schema". It describes which tags are al-

lowed by the XML schema, how they relate to each other and what they can contain. Most

XML editors, including Trados, can validate an XML file against the schema. If the XML that

the program writes validates against the XSD file, this guarantees that H&M will be able

read it after translation. 

Trados has a list of all the file types that Trados knows how to process, including HTML,

XHTML, Word, DITA, and several other XML schemas. Trados can add XML schemas it

does not yet know by analyzing the XSD file for that schema. To (re-)create an

.sdlfiletype configuration file for the current version of Trados, the translator needs

to get Trados to analyze the file helpproject.xsd that is included in the project folder

of every Help+Manual HMXP project. Trados will then rebuild the .sdlfiletype to up-

date it to the current version, or create a new one. This configuration file will then be used

for processing Help & Manual projects.

Using the XSL file for WYSIWYG display

In addition to using XSD to process XML and be able to write valid XML for the schema,

programs like Trados also have configurable display filters to display the data in the XML

tags in a way that the human translators can more easily work with. These filters can be

configured with XSLT (Extensible Stylesheet Language Transformations) defined in an XSL

file, which defines how the tags in the schema should be displayed on the screen.

An XSL file is also included in the project folder for browser display of the topics and Tra-

dos can use this for displaying the data the translator is working on. Web browsers can

also read this file: If you open a topic XML file with a web browser and the browser sup-

ports XSLT (the XSL file is referenced in the topic), then the browser can display an ap-

proximate representation of the topic, both the original and the translation.

How to deliver your projects for translation with translation
memory

If you are working with a translator who is using one of these tools you need to send

them the entire folder containing your project in the uncompressed XML/HMXP format.

You can only save projects in this format with the Professional or Floating license version. 

The translators need to have the entire project folder, which should also contain all your

graphics files folders. You will receive back a translated version that you can open directly

in Help+Manual to do any final layout work and publish the project to the formats you

want to use (CHM, HTML etc).

1. Make sure your graphics are included in your project folder
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Graphics files:

The translator will be able to understand the project better if you include the graphics

files. The easiest way to enable this is to make sure that all the graphics are included in

the project folder as well. You can move them there easily, and generally they should

always be kept there. See Managing your graphics  for instructions.

Graphics containing text:

If you create your graphics using the Impict editor  included with Help+Manual you

can have it store the text they contain in linked XML files that can be translated by

translation memory programs. See Translating texts in images  for more details.

2. Set up the language settings for the target language in the translation version

For details on the settings you need to make and the issues you need to consider

study International languages setup .

3. Check whether you need to include any snippet files for the translator

If your files contain linked snippets  from external sources you may need to include

copies of these embedded files for the translator. 

If you include the files with the translation package you should put them in a separate

folder inside the project folder you are going to send to the translator and add an

entry to Configuration > Common Properties > Project Search Path  pointing to

the folder containing the snippet files so that Help+Manual will find them. 

4. Pack everything in a zip file for the translator

Finally, pack up the entire prepared folder and all its contents in a zip or other appro-

priate archive format and send it to the translators for processing.

Translating individual topics

Since all your topics are stored as individual XML files you can also send copies of indi-

vidual files out for translation as well. However, this is not generally recommended. It is

usually better to provide the entire project so that the translator has the entire context.

Also, when you split out individual topics it is much too easy to lose track of what has

been edited and what hasn't.

In addition to copying individual topic files from your project folder you can also export

topic files with the File > Save Topic to File function in Project > Manage Topics.
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How to update projects using translation memory

When you use translation memory tools the procedure for translating an updated project

is exactly the same as for the original project. You just send the translators the entire up-

dated project folder, using the procedure described above. The translation memory data-

base will automatically translate all the known sentences, leaving only the new and

changed material for the human translators to process.

8.2.4 Translating in Help+Manual

Help+Manual itself is really the best XML editor for editing and translating your projects. The

inexpensive Basic version costs less than most professional XML editors and can do much

more. It can edit both compressed and uncompressed projects created with the Professional

or Floating license version without restriction. It is just lacking some features, but they are not

features the translator needs – for example ePUB and Visual Studio output. Unlike a normal

XML editor, you can work in WYSIWYG mode and you also have access to all of

Help+Manual's advanced tools and features.

Translating projects in Help+Manual is basically exactly the same as working on a project in

your own language. You just make a sibling copy of the project with the Project Synchroniza-

tion Tool , set up the language settings appropriately for the target language and work you

way through the project, translating as you go. When a new version of your project becomes

available you can then use the Project Synchronization tool to create an updated version of

the translated project containing all the topics with new material to be translated.

Protecting text against changes and translation

You can explicitly protect text against translation and editing changes. To do this select

the text in the editor and then select the "padlock" tool in Write > Font. The text will then

be displayed shaded in the Help+Manual editor and it will be tagged with the attribute

translate="false" in the XML topic file.

Procedure for translating projects in Help+Manual 

When you are using Help+Manual as the translation editor you can use either the com-

pressed .hmxz format or the uncompressed XML .hmxp format – which you use is up to

you. However, both the original project and the translated version must be saved in the

same format, otherwise you will not be able to use the Project Synchronization tool later

to update your translations.

1. Make sure your graphics are included in the project folder

1245
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Graphics files:

The translator will be able to understand the project better if you include the graphics

files. The easiest way to enable this is to make sure that all the graphics are included in

the project folder as well. You can move them there easily, and generally they should

always be kept there. See Managing your graphics  for instructions.

Graphics containing text:

If you create your graphics using the Impict editor  included with Help+Manual you

can have it store the text they contain in linked XML files that can be translated by

translation memory programs. See Translating texts in images  for more details.

2. Check whether you need to include any snippet files for the translator

If your files contain linked snippets  from external sources you may need to include

copies of these embedded files for the translator. 

If you include the files with the translation package you should put them in a separate

folder inside the project folder you are going to send to the translator and add an

entry to Configuration > Common Properties > Project Search Path  pointing to

the folder containing the snippet files so that Help+Manual will find them. 

3. Make a sibling copy for the translator to work on

If you have the Basic version of Help+Manual you must just make a copy with Save

As... in the File menu. The Project Synchronization tool is not included with the Basic

version.

In the Professional or Floating license version select Synchronize in Project > Tools

and make a sibling copy of the original project. This copy will have exactly the same

internal IDs as the original, which will make it possible to identify changes and update

the translated version with the Synchronize tool later. 

See The Project Synchronization Tool  for more details.

4. Set up the language settings for the target language in the translation version

This is very important and can lead to unexpected errors in your output if you forget it.

For details on the settings you need to make and the issues you need to consider

study International languages setup .

5. Translate the project in Help+Manual

Obviously, the first thing you will translate will be the texts of your topics. But there are

also a number of other things that you should not forget, and a few things that you

should not translate:
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· Remember to translate all the normal index keywords in the Topic Options tab and

the Index Tool. See Keywords and Indexes  for details on working with index

entries. 

· Don't translate any A-keywords  in the  tab. These keywords are never seen by the

user and they will work best if you leave them unchanged.

· Check through all the sections of Project Configuration  and translate any texts

that will be visible to the user, including the values of text variables . 

· Don't translate the names of variables or include options  (build conditions). You

can translate the display texts for include options if you want but you don't have to,

they are never seen by the user.

See Instructions for translators and editors  for a full list of guidelines.

6. Publish your output, check and distribute

Publish your output as normal. Before distributing it check it to make sure that

everything is OK for the target language. For example, if your language settings are

not correct special characters in the target language may not be displayed correctly. 

Procedure for updating translated projects

Translating the first version of your project is straightforward, you just make a copy and

translate it. The next challenge is to produce an updated version of the translation when a

new version of your original documentation is released.

If you are using the Basic version of Help+Manual you must make notes of all your

changes and tell the translator where they are. 

If you have Help+Manual Professional you can use the Project Synchronization Tool  to

make an updated version of the translated project. Project Synch will delete removed top-

ics, add new topics and mark changed topics as changed. Full copies of the original text of

all new and changed topics, topic titles in the TOC and topic headings can be inserted for

the translator if you want. (Otherwise you must provide a copy of the original version for

the translator to refer to.)

1. Create an updated version of the project for the translator

Basic version:

If you have the Basic version of Help+Manual you must send the translator a copy of

the new version of the original project with annotations showing where the changes

are located. The translator must then use Help+Manual to update the old version of

the translation.
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Professional/Floating license version:

Follow the instructions in The Project Synchronization Tool  for synchronizing the

new version of your documentation with the translated version. This will create a new

version of the old translated project for the translator, with deleted topics removed,

new topics inserted and changed topics marked as changed. You can also choose to

insert full copies of the new content of all new and changed topics for the translator to

work with.

2. Make copies of all new and changed graphics and other external files

Before sending the updated project to the translator, make sure that you also include

all new and modified graphics in the translation package, along with any new and

changed external files. Here too, keeping everything in one project folder makes

things a lot easier.

Also check whether there are any changes in linked snippets  – if there are you will

probably need to include copies of the new versions of the source files for the trans-

lator. 

3. Translate the changes and generate your output

Once the translator has produced the new version you can generate your output as

normal. Don't forget to check through the Configuration settings in the Project Ex-

plorer to make sure that all relevant texts visible to the user have been translated.

After generating your output check the finished product carefully to make sure that

everything is OK in the target language. For example, make sure that special charac-

ters are rendered correctly – if they are not you may need to adjust the language set-

tings for your project.

See also:
The Project Synchronization Tool  

International languages setup

8.2.5 Translating with external editors

It is also possible to edit and translate the XML files in your project with any XML editor, along

with WYSIWYG previews if the editor supports that feature. However, we really don't recom-

mend this because the disadvantages greatly outweigh the benefits. XML editors are designed

for XML programmers, not for translators or authors. They expose all the XML source code

and tags to the translator, who has to be extremely careful not to damage anything accident-

ally. In addition to this, it is much harder and slower to work on the text in this way, and more

errors are almost guaranteed.
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Protecting text against changes and translation

You can explicitly protect text against translation and editing changes. To do this select

the text in the editor and then select the "padlock" tool in Write > Font. The text will then

be displayed shaded in the Help+Manual editor and it will be tagged with the attribute

translate="false" in the XML topic file.

Procedure for translating in an external editor

Translating in external editors is only possible with the Professional and Floating license

versions of Help+Manual. The Basic version cannot write the uncompressed XML format

required for access by other editors and translation tools. 

The following procedure assumes that you have saved the project in this format. If you

haven't, use Save As... in the File menu and choose Help Project/Uncompressed XML as the

save format and an empty folder to save to. You can then add folders for graphics, snip-

pets etc. to this new folder.

1. Make sure your graphics are included in the project folder

Graphics files:

The translator will be able to understand the project better if you include the graphics

files. The easiest way to enable this is to make sure that all the graphics are included in

the project folder as well. You can move them there easily, and generally they should

always be kept there. See Managing your graphics  for instructions.

Graphics containing text:

If you create your graphics using the Impict editor  included with Help+Manual you

can have it store the text they contain in linked XML files that can be translated by

translation memory programs. See Translating texts in images  for more details.

2. Check whether you need to include any snippet files for the translator

If your files contain linked snippets  from external sources you may need to include

copies of these embedded files for the translator. 

If you include the files with the translation package you should put them in a separate

folder inside the project folder you are going to send to the translator and add an

entry to Configuration > Common Properties > Project Search Path  pointing to

the folder containing the snippet files so that Help+Manual will find them. 

3. Make a "sibling copy" for the translator to work on

Select Synchronize in Project > Tools and make a sibling copy of the original project.

This copy will have exactly the same internal IDs as the original, which will make it pos-
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sible to identify changes and update the translated version with the Synchronize tool

later. See The Project Synchronization Tool  for more details.

It is best to perform this step after consolidating all your graphics and external files in

the project folder.

4. Set up the language settings in the sibling copy for the new language

This is very important and can lead to unexpected errors in your output if you forget it.

For details on the settings you need to make and the issues you need to consider

study International languages setup . 

5. Translate the project with your external tool

The physical procedure for translating will depend on the tool you use to edit the XML

files. However, there are some important instructions for translators that should always

be observed. See Instructions for translators and editors  for full details.

6. Check through the Configuration to make sure that everything is OK

When the translation is complete load it in Help+Manual and check through it care-

fully make sure that all the relevant texts  in the project's Configuration section in

the Project Explorer have been translated to the new language. Also check things like

the index keywords etc. 

7. Publish your project in the new language

You will be able to generate the new version of your output in the target language dir-

ectly. What you get back from the translator is already a fully-functional Help+Manual

project since they have been working directly on the project source files. 

Here too, of course, you should check things like special characters in your output be-

fore distributing the finished product. 

Procedure for updating translations

When your original project is updated you can use the Project Synchronization Tool to

make an updated version of the old translated project for the translator.

These instructions assume that you used the Project Synchronization tool to create a sib-

ling copy for the translator to work on when you sent the project for translation. If you did

not do this you may need to use a special feature of the Synch tool to link the two pro-

jects. See Synching existing projects  for details. 

1. Create an updated version of translated project for the translator

1245
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Follow the instructions in The Project Synchronization Tool  for synchronizing the

new version of your documentation with the old translated version. This will create a

new version of the translated project for the translator. Deleted topics will be removed,

new topics will be inserted and changed topics will be marked as changed. You can

also choose to insert full copies of the new content of all new and changed topics for

the translator to work with.

2. Translate the new material

This is the same procedure as above. The translator just translates the new material in

the updated XML package.

3. Generate your output from the updated project

You don't need to check your language settings because you are already using a pro-

ject set up for the target language. After checking that everything has been translated

correctly you can generate your output with Help+Manual normally.

Translating individual topics

Since all your topics are stored as individual XML files you can also send copies of indi-

vidual files out for translation as well. However, this is not generally recommended. It is

usually better to provide the entire project so that the translator has the entire context.

Also, when you split out individual topics it is much too easy to lose track of what has

been edited and what hasn't.

In addition to copying individual topic files from your project folder you can also export

topic files with the File > Save Topic to File function in Project > Manage Topics.

8.2.6 Translating texts in images

If you create images with Impict  that contain text objects you will also need to translate the

texts in the images. If the translator is working in Help+Manual they can edit the texts directly

in Impict – you just need to remember to give them copies of all the images in Impict's own

IPP format so that the texts remain editable.

Translating image texts in Impict

If possible it is probably better for the translator to work directly in Impict to translate the

image texts. Text lengths often change when they are translated and this will generally

make it necessary to move and modify the text objects in the images. Some languages will

also require a different layout because of the different structure and logic of the language.

If the translator works in Impict they can do this work directly, eliminating the need for

you to have to do it later.

1245
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Exporting image texts to XML for translation

Translators using XML editors or translation tools will not have access to Impict. You can

export the texts in your Impict IPP images to external XML files that these translators can

edit. Later, you can import the translated texts from the XML files to the IPP images with

Impict and make any necessary modifications.

For details see the chapter on Translating Texts in Images in the Impict help.

8.2.7 Translation-friendly Tidy XML

Starting in Version 8.3 Help+Manual supports "Tidy XML" that is more translation-friendly for

XML-based translation tools. It significantly simplifies the amount of XML tag information in

the source code of your topics, making them much easier to edit with other XML-based edit-

ors.

Tidy XML source code has a minimum of <text> tags breaking up your paragraphs and sig-

nificantly reduced redundant attributes inside the tags that do need to be used.

Benefits, discipline and compatibility warning

The new XML syntax writes <text> tags only where necessary. If the text style is identical

with the paragraph style, the text is simply placed between the <para>…</para> tags,

making it much easier to read for an external translator. Explicit <text> tags are only in-

serted for text with a different format from its paragraph. In addition to this, redundant

“styleclass” attributes for <text> tags and links are eliminated – text that has the same

style as its paragraph no longer needs a styleclass attribute at all.

Tidy XML only works if you use styles!

You can only get the full benefits of Tidy XML if you use styles instead of manual format-

ting. When you format with styles, each paragraph just contains a reference to the style-

class. When you apply manual formatting all the formatting information must be written

literally into the XML tags. Your XML gets bloated again and much harder to translate.

You can clean up manual formatting in existing projects by "normalizing" your styles with

the Toolbox utility included with the Premium Pack add-on (see below for details).

Not compatible with earlier versions of Help+Manual

Tidy XML is not activated by default because it is not compatible with older versions of

Help+Manual. You won't lose data when opening  a Tidy XML project with an older ver-

sion, but the formatting and layout will probably look distorted. Don't open projects con-
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verted to Tidy XML with older versions of Help+Manual, and make a full backup before

converting so that you will have access to the older version if necessary!

How to activate Tidy XML

You can activate Tidy XML and apply it to all the topics in existing projects with the op-

tions in Configuration > Common Properties > Miscellaneous Options (in the Project Ex-

plorer on the left in Help+Manual).

Procedure:

1. Make a backup of your  project and store it in a safe place! 

2. Open your original project in Help+Manual and in the Project Explorer navigate to

Configuration > Common Properties > Miscellaneous Options.

3. Enable “Write translation-friendly XML“, then click on “Apply to all topics“ to apply it to

all existing topics. (Otherwise it will only be used for new topics created after activating

the setting.)

Cleaning up manual formatting with Premium Pack Toolbox

Starting in version 3.25, the powerful Toolbox utility included in the Premium Pack skins

add-on has a new function with which you can globally clean up manual formatting from

your projects. This can very significantly reduce the amount of "cruft" in your XML code

caused by manual formatting. 

The Entire Project option in this tool strips all the manual formatting from an entire pro-

ject, but it enables you to retain text formatted with different styles within paragraphs

(which are efficient) and optionally also manually-applied bold, italics and underlining

(which are so common that they can hardly be avoided). In addition to this it can also

https://www.helpandmanual.com/products_hm_pluspack.html
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standardize the styles used for hyperlinks and toggles, allowing you to choose specific

styles for all hyperlink and toggle types. 

The Individual Styles option is used for integrating inline formatting imported from HTML,

converting it globally into references to styles. 

8.2.8 Instructions for translators and editors

When you are working on the XML files it is important that you should only translate or edit

those parts of the file that are "editable". This topic provides basic instructions for translators

and editors of Help+Manual project, particularly those working on the XML files rather than in

Help+Manual itself. How important these instructions are will depend on the XML editing tool

you are using. Some XML editors will protect attributes and tags, making it difficult or im-

possible to accidentally damage them, others don't provide this protection and must be used

with more care.

Recommendation: Don't use tools that force you to work directly on XML

code

We provide tips for what to avoid when working on the XML code directly below.

However, the most important recommendation here is to not work on the XML code dir-

ectly at all, ever. It doesn't matter how experienced you are. If you try to translate text in
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the XML code directly you will damage it and you will then waste many unproductive

hours trying to locate and fix the damage.

Any savings you may think you are getting by using a cheap or free tool to edit the source

code directly will be eaten up many times over by all the valuable time you waste fixing

the problems created when you accidentally damage the source code and make it incom-

patible with Help+Manual.

Use Tidy XML and eliminate manual formatting as far as possible

If you must use an XML code editor for any reason, use the Tidy XML feature to make the

XML code as friendly and accessible as possible. In addition to this, we strongly recom-

mend using the Normalize Project Styles feature in the Premium Pack Toolbox to com-

pletely eliminate manual formatting tags from your code to make it easier to work on. See

Translation-friendly Tidy XML  for details.

What you are NOT allowed to translate or edit

Do not translate:

· Anything inside tags (XML elements)

· Text identified as translate="false"

· Tag/element attributes

Anything inside tags (XML elements)

The first and most important principle is that you are never allowed to edit anything inside

tags. All text in tags and tag attributes – i.e. anything between the < and > characters

marking the beginning and end of a tag – is strictly off limits for translators and editors.

Don't even think about editing anything inside tags, this information doesn't even exist for

you. Just ignore it.

Nothing inside tags is ever seen by the user so nothing inside tags ever needs to be trans-

lated or edited. For example, even though many of the words inside the following tag (in

blue) are in English you are not allowed to translate them because they are inside the tag:

<config-value name="title" translate="true">Help &amp; Manual
XML Language Reference</config-value>

You are only allowed to translate the text shown in red, because it is plain text between

tags (and because the tag has a translate="true" attribute, see below).

1198
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Text tagged as translate="false"

This should be fairly obvious: In Help+Manual text can be protected against changing and

this applies the attribute translate="false" to the text tag. Any text tagged with this attrib-

ute should be left unchanged unless the author specifically provides other instructions.

Element attributes

Element attributes are also inside tags so that is already a very good reason not to trans-

late them. However, this point is so important we would like to repeat it. Don't even think

about translating or editing the attributes of any XML elements. Again, none of these at-

tributes are ever seen by the user so they don't need to be translated. If you do translate

them you will create syntax errors and make it impossible for Help+Manual to open the

project correctly.

In the following example too, you can only translate or edit the text shown in red.

Everything else is strictly off limits. All the texts shown in green are element attributes.

Editing or translating them will make it impossible to re-import the XML files because of

the strictness of XML syntax.

<para styleclass="Heading2"><text styleclass="Heading2">What
you are </text><text styleclass="Heading2" style="text-
decoration:underline;">not</text><text
styleclass="Heading2"> allowed to translate or
edit:</text></para>

Of course, sometimes you will have to use your own judgment a little. In the example

above you will have to move around the underline tags around the word "not" because

the structure of the sentence will probably be quite different in another language. This is

generally OK provided you do it carefully and don't move these tags outside any other

tags enclosing them. Just be careful and if you are not entirely sure what you are doing

leave it alone or get help from someone with more experience.

Ultimately, you will save a lot of time and frustration if you use a proper translation tool

that hides the tags from you so you don't need to worry about them at all. 

What you are allowed to translate or edit

Text data between tags with the translate="true" attribute

What you may translate is very clearly defined. Every element containing translatable data

is identified with the translate="true" attribute in the opening tag. This means that you
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don't even need to look at any elements that don't have this tag. If a tag has the attribute

translate="false" just ignore its content.

Here too, of course, you are only allowed to translate or edit the text data between the

tags. You are still not permitted to touch anything inside the tags themselves, even in the

tags with translate="true". 

Translatable elements

Element Translatable

text Text is always translatable if its translate attribute is set to "true". Do not

translate if translate="false" is set.

link The captions of hyperlinks (topic links, web links, file links, script/macro

links) are translatable if their translate attribute is set to true.

caption Image captions are translatable if their translate attribute is set to true.

keyword Keywords are always translatable. They always have a translate at-

tribute and the setting is always "true".

Note that this does not apply to a-keywords! A-keywords are never

seen by the user and should never be translated because this can break

help functionality!

html-code The translate attribute of html-code elements is always set to "true".

However, whether a translation is really required will depend on the

nature of the code. If in doubt, ask!

config-value Only some config-value elements are translatable. If they have a trans-

late attribute and it is set to true they can be translated. If not they

should be left alone. 

See also:
Project Synchronization

Editing XML source code

1245
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9 Help+Manual Premium Pack

The Help+Manual Premium Pack is an add-on that includes a wide range of advanced We-

bHelp and eWriter skins and a configuration utility called Toolbox that also features a number

of useful power tools features for Help+Manual projects as well as skins. 

View the Premium Pack documentation



Tools included with Help+Manual

Help+Manual has every tool you need, at your fingertips!
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10 Tools included with Help+Manual

10.1 The Screen Capture Tool

Help+Manual has an integrated screen capture tool that includes all the functions you need

to make attractive screenshots quickly and efficiently. In a unique feature available only on

Help+Manual, it can also capture sequences of screenshots and display them as animated tu-

torials with a moving mouse cursor. 

Screen Capture is in the Project tab

Special features

Composite captures:

After selecting the first area for capture you can use SHIFT+Click to add additional

areas and create a composite capture.

Multi-monitor and hi-res support:

The capture tool fully supports multi-monitor configurations and high-resolution displays.

You can capture on any monitor, even if one has a higher resolution than the other, and

captures will be correct on both high and low resolution displays.

Capture animated screencasts

The unique Screencast feature captures a series of screenshots and turns them into an an-

imated presentation with a moving cursor. This is ideal for showing how something is

done and is very much quicker than trying to make a screencast tutorial with a video-

based tool. 

The Screencasts are compiled to your HTML-based output with the engine from EC Soft-

ware's HelpXplain tool. Referred to as "Xplains", they are saved in the standard .xplain

format and can be inserted in your topics and published without HelpXplain. If you do
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have HelpXplain you can edit them to create much more complex animations and

presentations. See the HelpXplain website for details. 

Editing with Impict or HelpXplain

You can add shapes, shadows and background colors and automatically resize your

screenshots with a choice of high-quality scaling filters using the Impict graphics editor

included with Help+Manual . Impict edits are non-destructive, which means you can al-

ways go back and change something if you need to.

Alternatively, you can also use the new HelpXplain tool to edit your screenshots and

screencasts. It can then be configured to replace Impict as your standard graphics editor

in  Program Options . 

How to capture a window, control or menu

1. Click in the editor in the position where you want to insert the screenshot. 

2. Select Screen Capture and then Take Screenshot in Project > Tools.

You can change the default hotkey (Print Screen) for screen capture here if you wish,

for example if it conflicts with another program on your system. You can also choose

whether you want to include the mouse cursor or not. The Delay option gives you 5

seconds to make changes on the screen before the capture starts.

3. Choose whether you want to include the cursor or not, then select Start. 

506
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4. Click on a window or window control to select it with the green border. Or drag with

the mouse to select a free region. 

5. Hold down CTRL and click in the selection to insert the screenshot in your topic and

save the screenshot file. 

How to make a composite capture

The capture tool supports making multiple rectangular captures at the same time, which

are combined to a single image. 

1. Start your capture normally and make your first capture. 

2. Instead of using CTRL+Click, hold down the SHIFT key and click or drag to select

an additional area. Repeat to select more areas.

3. When you are finished, hold down CTRL and click in the selection to insert the screen-

shot in your topic and save the screenshot file. 

Capturing the entire screen

1. Start your capture normally. 

2. Instead of selecting a capture area, click on the full screen icon shown at the top of the

screen.

Capturing an animated screencast

This unique tool, which use the graphics and animation engine from our HelpXplain tool,

enables you to make little HowTo tutorials with just a few clicks. It combines a series of

screenshots showing the steps you want to demonstrate and includes the animated

http://www.helpxplain.com
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mouse cursor. When played in your output, the screencast steps through the screenshots,

demonstrating exactly what you did when you made it.

This simple example demonstrates how to use the word wrap feature in the Notepad ed-

itor included with Windows. It took 30 seconds to create.

Simple screencast demo

Here's a screencast of how to make a screencast

Creating screencasts with Help+Manual

Procedure

1. Make sure the program you want to document is set up and ready before you start.

Click in the topic editor in the position where you want to insert the screencast. Then

Create Screencast in in the Screen Capture tool in Project > Tools. 
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You can change the default hotkey (Print Screen) for screen capture here if you wish,

for example if it conflicts with another program on your system. You should usually in-

clude the mouse cursor in screencasts as a way to show the user what to do. 

2. Click on the red Start button. This doesn't start recording. It hides Help+Manual and

displays the capture tools at the top of your screen and the green capture frame. Posi-

tion the capture frame roughly around the window or area you want to capture. 

Controls at the top of the screen

The controls for adjusting the capture frame to the program window are disabled dur-

ing recording. 

· Fit capture frame to window snaps the frame to the window beneath it

· Fit window to capture frame snaps the window to the capture frame 

3. Click the Record button in the center to start. Screenshots are not made until you

click. Then Operate the program normally. A screenshot will be made every time you

click the mouse. Left-clicks, right-clicks, double-clicks and drag operations will all be

recorded and represented.

· Press the Record button to pause/restart automatic screenshots. Press the hotkey

(default: Print Screen) to make a manual screenshot. This also works when re-

cording is paused.

4. Click on the Done tool in the icon bar to make the last screenshot and terminate re-

cording. You will then be asked to save the .xplain file (give it a descriptive name)

and the following dialog will be displayed. 

· Show/Display switches instantly between the screencast slides. This is best for creat-

ing a "movie" of something happening on the screen.
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· Move In / Pan animates the screenshots, moving them out of and into view like an

image slider.

See also:
Screen Capture  (dialog reference)

About Graphics in Help+Manual

The Impict Screenshot Editor

10.2 The Project Report Tool

This tool generates detailed reports on your project that can be used for a wide range of pur-

poses, including documentation, providing your programmers with lists of topic IDs for their

help calls, checking project status, locating dead links, finding missing images and unused im-

ages and so on. Reports are displayed immediately in a special viewer but you can also save

them in HTML files for documentation and other purposes. 

See the report dialog reference  for details on the dialog options and the available report

types . 

How to generate a project report

1. Select Report Tool in Project > Tools. 

1316
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2. Select the report type in the tabs on the left. 

3. Select the other options to change the sort order of your report and which topics you

wish to include or exclude (see the dialog reference  for details).

4. Click on OK to display the report in your default browser.

Word and character counts

The Full Report option includes word and character counts for each topic listed and also a

cumulative count for all the topics in the report. 

Word counts for individual topic classes, builds etc.

You can use the selection options in the Report tool to get word counts for any custom-

ized group of topics. For example, you can use the date range option to get a count for all

the topics modified between specified dates. Similarly, you can get counts for topics with

specific build options, classes or status, or any combination of these filters.

1318
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Word counts for selected topics

You can also get a cumulative word count for selected topics in the TOC. Just select the

topics before opening the Report tool, with Ctrl+Click and Shift+Click. Then start

the Report tool, select the Selected Topics option in the Include Options box on the right

and generate a Full Report.

Important note: Selected chapters always include all the sub-topics of the chapters!

Locate and remove unused images

Help+Manual can help you to locate unused graphics files in your project and remove

them so that they no longer take up space. 

1. Select the Project Report tool and choose the Full Report option. 

2. Set the Sort Order option to Topic ID. This is important to ensure that all topics will

be covered by the report, including those that do not have TOC entries.

3. Run the report and scroll down to the bottom of the page. Each folder where unused

images are found has a button with which you can move the images to a backup

folder for storage or deletion.

Report types

Short report: Simple list of all topics in your project with status, caption (i.e. the

TOC title), topic IDs, help context numbers, builds in which the topics

are included and date last edited. The report also includes a summary

of the number of topics and keywords in your project.

This is a practical format for providing your programmers with a list

of topic IDs and context numbers for their calls.

Use Topic ID sort order to include all topics!

Use the Topic ID sort order with this report if you want to ensure that

all topics are covered by the report, including those that do not have

TOC entries.

Extended report: Also includes each topic's keywords and help window and a more de-

tailed project summary with a list of the images used in the project. 
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Missing images are shown in red.

Use Topic ID sort order to include all topics!

Use the Topic ID sort order with this report if you want to ensure that

all topics are covered by the report, including those that do not have

TOC entries.

Long report: Also includes lists of the images used in each topic, lists of the links in

each topic with their targets (including topic links, Internet links, file

links and script links) and the first lines of the text with which the

topic begins.

Missing images and dead links are shown in red.

Use Topic ID sort order to include all topics!

Use the Topic ID sort order with this report if you want to ensure that

all topics are covered by the report, including those that do not have

TOC entries.

Full report: Same as the Long Report but also includes an additional full list of

images used in the project with a lists of the topics in which each im-

age is used. In addition to this there is also a list of images in the pro-

ject's graphics folders that are not used in the project (useful for tidy-

ing up your project folders).

This report also includes word and character counts of each indi-

vidual topic and all the topics in the report. See further above on this

page for more details on word counts.

Locating and removing unused images

Unused images are listed at the end of the report with controls for

moving them to a backup folder for saving or deletion. 

Use Topic ID sort order!

Always use the Topic ID sort order with this report to ensure that all

topics are covered by the report, including those that do not have

TOC entries.

Missing keywords: Displays all topics which do not contain any index keywords. This can

be useful when you are building an index, as it shows you where you

may have forgotten to enter keywords. 

Use Topic ID sort order!

Always use the Topic ID sort order with this report to ensure that all
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topics are covered by the report, including those that do not have

TOC entries. 

Files not in TOC: Displays all topic files that do not have TOC entries. 

Caution: If you use TOC sort order with this option you will get an

empty report!

See also:
Reports  (dialog reference)

10.3 The Impict Screenshot Editor

Help+Manual comes with a fully-featured graphics editing program called Impict. This pro-

gram is designed specifically for editing and enhancing screenshots and other graphics used

in help and documentation projects. Since Impict comes with its own comprehensive help this

topic only explains how to start the program and how to open graphics files for editing in

Impict from the Help+Manual editor. 

For full details on editing images with Impict see the program's own help.

Setting Impict as your default image editor

Several of the functions described below only open Impict if it is set as your default image

editor. This is the default setting when Help+Manual is installed. 

1. Select Program Options in the View tab and then select the General tab in the dialog

displayed. 

2. Check that impict.exe is selected in the Default Image Editor: field. If it isn't use the

 browse button to select this file in the Help+Manual program directory, which is

normally C:\Program Files\EC Software\HelpAndManual8.

Alternatively you can also select any other graphics editing program. Then most of the

functions described below will open this program instead of Impict.

How to start Impict 

There are several different ways to start Impict:

· Select the Image Editor tool in Project > Tools.

· Select Impict in the Help+Manual program group in the Windows Start menu.

· Right-click on an image in the Help+Manual editor and select the option for editing the

image in  Impict.

1318
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How to open an image in Impict from the editor

1. Click once on the image you want to edit in the Help+Manual editor to select it. 

2. Select Image Editor in Project > Tools or right-click on the image and select the option

for editing the image in  Impict.

Note that these options will open the image in a different image editor if Impict is not

defined as your default image editor (see above).

See also:
Using Graphics

Screen Capture

10.4 The Print Manual Designer

The Print Manual Designer is a separate program used for editing the .mnl print manual

template files that define the layout and appearance of your published PDF files and printed

manuals. 

In addition to defining the layout of your PDF pages, you can also add additional pages and

content not included in your project, including cover and back cover pages, an introduction, a

formatted table of contents, title pages for individual chapters, headers and footers, a format-

ted index and multiple endnotes pages. You can also add your own custom pages and insert

topics from your project and external Help+Manual XML files. 

The Print Manual Designer has its own help so this topic only describes the basic procedures

for opening templates for editing and selecting them in your projects. Print manual template

files have the extension .mnl.

How to start the Print Manual Designer

· Select Templates & Skins > Launch PDF Manual Designer in Project > Tools.

479
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If a PDF template has already been used with the current project you can select it directly

in the menu and load it into Manual Designer.

If you have not yet used a PDF template you should start with one of the standard tem-

plates included with Help+Manual. It is generally easier to edit an existing template, be-

cause all the necessary objects have already been added and you just need to modify

them. The standard templates can be found in the \Templates\pdf folder in the

Help+Manual program directory, which is normally C:\Program Files\EC Soft-
ware\HelpAndManual8.

You will need to make a copy of any standard template you load from the Help+Manual

program directory storage to be able to edit it. To do this, select Save As... in the File

menu and save it in your project folder. 

How to edit a print manual template associated with your project

If PDF templates have already been used with the current project they are listed in the

Templates & Skins menu. You can select one of the templates directly in the menu and it

will be opened with Manual Designer.

Note that you can use different templates for PDF and print manual output.
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How to assign a print manual template to your project

You select the template to be used with your project in the Publish settings when you are

publishing your project. Once you have made a selection there Help+Manual will remem-

ber the setting the next time you publish your project to PDF.

Selecting a template for Adobe PDF output:

1. Select Publish in the File menu and then select PDF as your publishing format. 

2. Select the PDF template you want to use by clicking on the drop-down area shown

above.

Selecting a template for printed manuals:

1. Open your project, click on the File menu and select Print Manual. 

2. Select the PDF template you want to use by clicking on the drop-down area shown

above.

See also:
PDF and Printed Manuals

PDF and print manual templates

Adobe PDF

Printed manuals

785
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10.5 The Spell Checker

The spell checker included with Help+Manual supports both manual spell checking (check

topics or the entire project in a single session) and "live" spell checking, which highlights in-

correctly spelled words as you type.

See Spell checking  in the Creating and Editing Topics chapter for instructions on using

both manual and live spell checking functions.

Open Office dictionaries

The spell checker uses Open Office dictionaries for spell checking and hyphenation. These

dictionaries are free and are available for a very large number of languages. 

Productivity Tip
Spell checking is supported almost everywhere in

Help+Manual where you can enter text. Just right-click

to display the context menu or click on the upper half

of the Spelling tool in the Project tab to access. 

The Spelling tool

The Spelling tool in the Project tab is available almost everywhere in Help+Manual where

you can enter text, including the HTML editors for HTML templates and code objects, the

XML editor, the TOC captions in text entry mode and all of the text entry fields in the Con-

figuration section of your project. 

· Clicking on the top half of the Spelling tool checks selected text (if any is selected) OR

the current topic or text entry field or window (if no text is selected).

· Clicking the bottom half of the Spelling tool displays the spell-check menu.

238
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Spell Checker Options

Select Tools > Spelling > Configure Spell Checker, then configure your options in the

User Preferences tab. 

Most of the settings here are self-explanatory. Here are a couple of notes on special func-

tions:

Live spelling:

Identifies incorrect words with squiggly red underlines while you are working. Right-click

on words with these underlines to display a spell-check menu. Does not support repeated

words and dual capitals (see below)

Main dictionary only:

When this is active suggested corrections will be taken from the main dictionary for the

current language only. No suggestions will be taken from your own user dictionaries.

Prompt on repeated word, correct Dual capitals:

These functions are not active for live spell checking. They are only supported in the inter-

active spell check started from with the Spelling tool in the Ribbon.
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Selecting the language and adding main dictionaries

Select Tools > Spelling > Configure Spell

Checker, then select the dictionary for the

language of your project in the Dictionaries

tab. 

To add dictionaries for more languages click

on Download dictionaries... These dictionary

files must be unpacked (if they are in a zip or

other archive file) and saved in the \dic-

tionaries folder in the Help+Manual pro-

gram directory.

Note that the download page for the

OpenOffice dictionaries is often unavailable.

If you can't access it you may have to wait a

while and try again. 

Select the user dictionaries:

All user dictionaries listed in the Custom Dic-

tionaries section will also be used for spell

checks. You can store these dictionaries any-

where you want, also on network drives, and multiple users can access the same dictionary

at the same time.

Select When adding words, use this dictionary: to choose the user dictionary you want to

use to store new words.

Hyphenation dictionary is a separate selection:

Note that you need to select the dictionary to be used for automatic hyphenation in PDF

and DOCX separately. Note also that there are no configuration options for hyphenation

beyond the custom word list with which you can specify how specific words are to be hy-

phenated, and words that are not to be hyphenated. Beyond that all aspects of hyphena-

tion are controlled by the Open Office hyphenation dictionaries used by Help+Manual. 
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Styles excluded from spell checking are also excluded from hyphen-

ation

No hyphenation is performed on text formatted with styles that are excluded from spell

checking. You can thus disable hyphenation for any text by formatting it with one of the

styles you have excluded from spell checking. See Disabling spell checking for specific

styles further below for details on this.

Hyphenation dictionaries and word lists

The OpenOffice spelling dictionaries also

support automatic hyphenation, which is

used in printed manuals, DOCX and PDF

output. You need to select the dictionary

you want to use in the Dictionaries tab (see

screenshot on right).

Hyphenation word lists

You can create a list of words that you want

to exclude from hyphenation or hyphenate

in a special way. Click on the Edit button in

the Custom Word List section at the bottom

of the spell checker configuration dialog to

display the editor. Beyond this, all aspects of

hyphenation are controlled automatically by

the Open Office hyphenation dictionaries.

Creating word lists in a text editor

You can also create your own word list with

a text editor and load it with the  browse button in the Custom Word List section:

· Just create a plain text file with one word on each line. 

· Insert equals signs (=)  in the positions where you want hyphens to be possible. For ex-

ample re=dun=dant allows two possible hyphenations.

· Words without equal signs on the list will be excluded from hyphenation, i.e. they will

never be hyphenated.
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· The list is case-sensitive. You must include both capitalized and uncapitalized versions of

your words if this is relevant for you.

Links are excluded from hyphenation

Internet and email links are automatically excluded from hyphenation. 

Styles excluded from spell checking are also excluded from hy-

phenation

No hyphenation is performed on text formatted with styles that are excluded from spell

checking. You can thus disable hyphenation for any text by formatting it with one of the

styles you have excluded from spell checking. See Disabling spell checking for specific

styles further below in this topic for instructions.

Selecting and adding custom (user) dictionaries

The main dictionaries are not editable.

However, you can create custom user dic-

tionaries to store your own additional terms.

These dictionaries can also store auto-cor-

rect word pairs and "excluded" words that

you want to always identify as incorrect even

if they are in the main dictionary. 

See Using custom dictionaries  and Creat-

ing and editing custom dictionaries  for

full details on this subject.

· The standard user dictionary is stored in

your My Documents folder (called Docu-

ments in Windows Vista). To use this just

select it in the When adding words, use this

dictionary list at the bottom of the dialog.

· Click on Add/New to create a new user

dictionary or to select an existing diction-

ary. You can store your dictionary any-

where you like. 

· If you only want to use the selected dictionaries for the current project activate Selected

dictionaries are used for this help project only. Otherwise your selections will be stored

for all projects. 

1228
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Disabling spell checking for specific styles

The settings in the Ignore List tab exclude text formatted with specific styles from both

spell checking and hyphenation. This makes it possible to prevent spell checking for text

where it would not make sense, for example in quoted text in other languages. You can

also use this feature to prevent hyphenation for any text.

1. Select Tools > Spelling > Configure Spell Checker and click on the Ignore List tab. 

2. Select the check boxes of all the styles you want to exclude from checking. 

All text formatted with the selected styles will be ignored by the spell checker. 

Styles excluded from spell checking are also excluded from hy-

phenation

Again, note that no hyphenation is performed on text formatted with styles that are ex-

cluded from spell checking. You can thus disable hyphenation for any text by formatting it

with one of the styles you have excluded from spell checking. 

See also:
Using custom user dictionaries

Creating and editing custom user dictionaries

Spell checking

1228
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10.5.1 Creating and editing custom dictionaries

You can store your custom user dictionaries in any location, including network drives. Multiple

users working on the same or different projects can use them simultaneously. In addition to

storing your own terms, user dictionaries can also store auto-correct pairs for terms you al-

ways want to correct automatically during manual spell checking and "excluded" words that

you always want to mark as incorrect, even if they may be in one of the main dictionaries. 

Creating a custom user dictionary

1. Select Tools > Spelling > Configure Spell Checker, then select the Dictionaries tab. 
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2. Click Add/New and choose a name and storage location for the dictionary. Dictionaries

can be stored anywhere you like, also on network drives. They can also be used simul-

taneously by other users working on the same project or different projects.

You can also use the Add button to select existing user dictionaries. This adds them to

the Custom Dictionaries list so that they are used by the spell checker. 

Using dictionaries for the current project only

Normally, your dictionary setup will be stored with your Help+Manual program settings

and will be activated for all your projects. If you only want to use your dictionary settings

for the current project select the option Selected options are used for this help project only

in the Dictionaries tab.

How to edit custom user dictionaries

In addition to adding incorrect words to your user dictionaries while spell checking, you

can also edit the dictionaries to remove words added accidentally or to add new words.

1. Select Tools > Spelling > Configure Spell Checker, then select the Dictionaries tab

and click the dictionary you want to edit in the Custom Dictionaries box. 

2. Enter a word and click on Add to add, select a word and click on Delete to remove.
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Auto-Corrections and Excluded Words

The Auto-Corrections and Excluded Words tabs in the edit user dictionary dialog (see

above) have the following functions:

Auto-Corrections:

The first word in each pair in this list will be automatically replaced by the second word

during manual spell checks. (This function is not supported in live spell checking.) You

cannot enter words that are already included in the Excluded Words list.

Excluded Words:

All the words in this list are identified as incorrect by the spell checker, even if they are

contained in the main dictionary. You cannot enter words that are already included in the

Auto-Correct Pairs list.

See Spell checking  for instructions on using these functions while spell checking.

See also:
Using custom dictionaries

Spell checking

10.5.2 Using custom dictionaries

You can define and use as many custom user dictionaries as you want. In addition to the

standard function of storing words not contained in your main dictionaries these dictionaries

also have two more very useful functions:  

Auto-Correct for frequent errors and abbreviations:

The Auto-Correct function automatically replaces common typing errors and abbrevi-

ations with the correct words or entire phrases during manual spell checking (not during

live spell-checking or typing). See Spell checking  in the Creating and Editing Topics

chapter for details on using this function. This function is not available in live spell check

mode!

Excluded Words for exception handling:

The Excluded Words function allows you to enter words that will always be marked as in-

correct, even if they would normally be considered correct. This allows you to enter excep-

tions for words contained in the standard main dictionaries that you want to handle differ-

ently. 

238
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Selecting the user dictionary for the Add Word function

The spell checker uses the words from all user dictionaries listed in the Custom Dictionar-

ies section in the Dictionaries tab. However, new words can only be added to one selected

user dictionary. This dictionary is used for the Add function in both live and manual spell

checking. 

This dictionary is also used when you select AutoCorrect in the manual spell checker. For

more details see Spell checking  in the Creating and Editing Topics chapter.

1. Select Tools > Spelling > Configure Spell Checker, then select the Dictionaries tab. 

2. Select the custom dictionary you want to use in the Custom Dictionaries: box. Click

Add/New if you want to add a new dictionary or select a dictionary stored in a differ-

238
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ent location. (Custom dictionaries can be stored anywhere and can be shared by mul-

tiple users working simultaneously.)

3. Select the dictionary you want to use from the list in the Custom Dictionary: field. 

Activating and deactivating custom user dictionaries

Although words are always added to the same custom user dictionary (see above) you can

define and use as many custom dictionaries as you like. New words will be added to the

standard custom dictionary, but the spell checker will use all the activated dictionaries for

checking spelling and for the Auto-Correct  and Excluded Words functions.

Activating user dictionaries:

1. Select Tools > Spelling > Configure Spell Checker and click on the Dictionaries tab. 

1220
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2. Click on the Add/New button to add dictionaries to the Custom Dictionaries list. You

can then create a new dictionary or select an existing dictionary.

All the listed dictionaries will be used for spell checking. These dictionaries can be

stored in any location, also on network drives, and they can be used simultaneously by

multiple users.

Deactivating user dictionaries:

To deactivate a user dictionary just select it in the list and click on Remove. This will not

delete the dictionary, it will just remove it from the dictionaries list. 
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Using dictionaries for the current project only

Normally your dictionary setup will be stored with your Help+Manual program settings

and will be activated for all your projects. If you only want to use your dictionary settings

for the current project select the option Selected options are used for this help project only

in the Dictionaries tab.

See also:
Creating and editing custom user dictionaries

Spell checking

10.6 The Formula Editor

The Help+Manual formual editor tool is available in Write > Insert Object. It inserts simple or

complex formulas directly into your topic pages. 

How formulas are inserted and exported

Formulas are inserted in your topics in encapsulated code in the XML source of the topic.

However, when your project is exported this is rendered by the compiler and converted to

a bitmap graphic.

1226
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Using the tool

Entering expressions

Select the expression you want to enter using the buttons in the middle of the tool. This

inserts the LaTeX code in the Expression box and immediately displays the result in the

Preview box. You can then edit the code manually, or add additional expressions. If you

enter an invalid or unknown expression the preview display will switch to an envelope

graphic. 

Formatting

Font: Choose the math font for the expression. The default is Cambria

Math and this will usually work well.

Font size: This adjusts the size of the formula. It is not really the size of the

characters, as all the characters are scaled vectors. 

Spacing: Adds padding around the formula

LaTeX-based formulas

The editor uses code based on the standard LaTeX formula syntax, which is displayed and

edited in the Expression box. This means that you can use any standard guide to LaTeX

math formatting to learn how to manipulate the code displayed. 

Restrictions on custom LaTeX code

Note that not all LaTeX math codes are supported, although you will find that almost all

basic symbols and expression types are available. If you insert invalid or unsupported

code this will be indicated by a standard envelope image for the entire formula:
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10.7 The Project Converter

This tool converts the now-obsolete project files created with Help+Manual 3 (.hm3) and 4

(.hmx) to the current Help+Manual XML format. It also has a command line interface so that

you can convert multiple files with batch files. See Project converter syntax  in the Com-

mand Line Options chapter for details.

You can convert old projects directly by opening them. Just click on the File menu, select

Open, choose the project type you want to open and follow the instructions displayed. This

will also give you the option of opening the external converter program.

You can also open the Project Converter manually by selecting it in the Help+Manual pro-

gram group in the windows Start menu. This gives you more control over the conversion op-

tions.

How to convert projects

1. Select the File menu and click on Open. 

2. Select the project or help file type you want to convert, then navigate to the file and

select it.

3. The following dialog is displayed:

137
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Convert and open:

Automatically converts the project to the compressed, single-file .hmxz format, storing it

in the same directory as the original file. The converted project is then loaded for editing

automatically. If you choose this option no additional options are displayed.

Start external converter:

Opens the external Project Converter program providing additional options, particularly

for Help+Manual 3 (see below). 

You can also start the Project Converter directly by selecting it in the Help+Manual pro-

gram group in the Windows Start menu. See also Project converter syntax  for informa-

tion on running the Converter from batch files to convert multiple projects.

Using the external Project Converter

When you use the external converter you can choose the project file format (compressed

single-file format or uncompressed XML) and configure the Help+Manual 3 conversion

settings. See also Project converter syntax  for information on running the Converter

from batch files to convert multiple projects.

Project file format:

First you must choose whether you want to export to the compressed .hmxz single-file

format (default) or uncompressed XML (a directory of individual XML project files). 

137
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· Uncompressed XML is only available in the Professional and Floating license versions of

Help+Manual. This format is required for multi-user editing. 

· If you choose uncompressed XML you must choose an empty directory for the output

files. This is necessary because this format consists of several folders with individual files

for all topics and other project components. 

Help+Manual 3 conversion settings

If you are converting a Help+Manual 3 project the following additional options will be dis-

played in the next screen of the conversion wizard:
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Convert tables to auto-

size:

This converts the fixed-size Version 3 tables to dynamic

tables that will automatically resize to fit the help viewer win-

dow. 

Note that this option makes the widths of all columns in

your tables variable – they will adjust automatically on the

basis of their content.

Don't activate this option if your project contains tables with

explicitly defined column widths as it may cause formatting

problems! (For example if you use tables as a formatting

tool.)

Convert only last column

to auto-size:

This has the same effect as the previous option but it only

makes the last (rightmost) column in the table variable. This

is the most flexible table conversion option.

Concatenate similar

tables:

In Help+Manual 3 it was often necessary to split tables to

control formatting properly. In PDF and printed manuals

Help+Manual now splits tables automatically at page

boundaries and can also automatically generate headers on

each page so manual table splitting is no longer necessary.

This option can identify similar tables in your topics and

automatically join them together to create a single table that

is more easy to handle.

Tolerance for column

width differences:

Defines how closely matched the columns of tables have to

be to be combined with the Concatenate function. Two

tables will only be combined if all the widths of all their

columns are within this tolerance. 

Increase this value  if your tables contain manually-adjusted

column widths with slight variances.

Try to recognize styles

and format converted

text with styles:

If this is selected the Converter will attempt to identify styles

applied to the text in your .hm3 project. It will create new

style definitions for these styles and apply them to para-

graphs formatted with these styles in the old project.

Please note that this process cannot be perfect because style

names in Help+Manual 3 projects did not have a very close

association with text and paragraphs. All the formatting of

your text will be converted correctly but you may find that

some paragraphs are associated with the Normal style in-

stead of a newly-defined style matching the old formatting.
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Invisible topics from obsolete Help+Manual project formats (HM3 and
HM4)

If your old HMX or HM3 project contains "invisible topics" (topics without TOC entries)

they will be moved to a sub-folder called Topics\Invisible in the Topic Files section in the

Project Explorer. 

Automatic Converter:

When you use the automatic converter a chapter

called (Former Invisible Topics) will also be created

at the bottom of the converted project's Table of

Contents (TOC) section. 

These TOC entries are linked to the topic files of

the former invisible topics but they will still not be

included in your published output because their in-

clude options are automatically set to "None". 

You can delete the (Former Invisible

Topics) chapter by selecting it and

pressing DELETE. Before confirming,

deselect the option Also delete re-

ferred topic files to keep the actual

topic files. 
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External Converter:

When you use the external converter program you can decide what you want to do with

your old invisible topics:

Add invisible topics to TOC creates the (Former Invisible Topics) chapter described

above. We recommend deselecting this option.

Keep organization structure creates sub-folders in the Topic Files section to match your

folder structure in your old project. You can create a maximum of 10 levels but the con-

verter will not create more levels than the original project contained.

Help+Manual 5 and 6 projects do not require conversion

The Help+Manual 5 and 6 project formats have the same file extensions as the current

version and are directly compatible with Help+Manual 9. They do not require conversion

and can be opened directly. 

Avoid editing current projects with earlier versions

You can edit Help+Manual 9 projects with versions 5 and 6 but it is not recommended.

Any features not supported in the earlier versions will be stripped out when you save

there.

Editing teams should all use the same version

Similarly, if you are working on projects in a team, it is essential that all team members

should use the same version of Help+Manual. All members should also have the same up-

date installed, so that their builds are really all identical. 
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About converting Help+Manual 4 projects

Help+Manual 4 .hmx projects are converted 1:1 without any restrictions or limitations. All

version 4 features are supported in the current version of Help+Manual – you will not see

any formatting or functional changes.

About converting Help+Manual 3 projects

Help+Manual 3 did not have dynamic styles and its table formatting options were quite

limited. In addition to this the code of the HTML templates used for HTML-based output

formats has changed considerably and if you have made any additions of your own you

will have to add them again manually after converting. 

Styles:

If you select Convert Styles in the options (see below ) the Project Converter will try to

identify the styles used in your HM3 project and replace them with dynamic styles. This is

only possible with text explicitly formatted with styles in the HM3 project – the formatting

of manually-formatted text will be converted but it will not be associated with a defined

style. 

If the style of a paragraph cannot be identified uniquely it will be assigned the Normal

style. Its text formatting will converted correctly but it will be applied manually. The result

will be a paragraph with the Normal style containing manually-formatted text.

Tables:

Tables in Help+Manual 3 were fixed-width only and they were often split into multiple

tables to handle page break problems in PDF and printed manuals. The Project Converter

has options for dealing with both of these issues (see below ) but because of the differ-

ences between the two table formats you may need to make some manual corrections to

your tables after importing.

Customized HTML templates:

The HTML templates  have changed considerably since version 3, so it is not possible to

transfer custom code from your .hm3 projects when they are imported – the risk of

mangling the resulting code would be too great. 

If you have entered custom code in your templates you will need to re-enter it manually in

the templates of your project after conversion. 

See also:
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Creating Projects

Importing Data

Text Formatting and Styles

Dynamic Styles

Working with Tables

10.8 The Help Context Tool

The Help Context Tool helps to manage the help context numbers  in your project and it

can also be used to generate topic files automatically from map files containing a list of topic

IDs and context numbers (this will normally be supplied by your programmers). 

You can assign, delete, import and export help context numbers in batch mode for your entire

project. 

Key Information
Note that you cannot import help context numbers to

anchors, even though you can export help context

map files with anchor information. Also, you can only

import one help context number per topic with the

context tool. Multiple numbers must be added manu-

ally.

Supported context number range

Help+Manual stores context numbers as an unsigned 4-byte integer, which means you

can enter values between 1 and 4294967295. This is nearly 4.3 billion, so it should provide

you with just about enough numbers for most help files if they are not too large.

Assigning context numbers to all topics without them

This function only assigns context numbers to topics that do not yet have them, existing

context numbers are protected. If you want to renumber all the topics in your project first

use the Delete function (see below) to clear all the numbers in your entire project.

1. Select your project in the Project Explorer, then select Context Tool in Project > Tools. 

2. Click on Create Numbers. A dialog will be displayed informing you of the starting

number an the increments that will be used between numbers. 

3. Click on Create Numbers to assign the numbers. Numbers will be added to all topics in

your project that do not yet have context numbers.
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Changing the increment:

This function uses the increment set in your project configuration for assigning context

numbers to new topics. You can change the setting in the Project Explorer in Configura-

tion > Common Properties > Miscellaneous.

Editing and adding context numbers for single topics

1. Select your project and open the Context Tool (see above). 

2. Select List all Topics to make sure that all topics are listed, including those that do not

have context numbers yet.

3. Select a topic from the list, click on the topic you want to edit and select Edit Number.

4. You can then add a new context number or edit the existing number. 

You can't add multiple context numbers with this method. To add multiple numbers to a

topic you must access the Topic Options tab on the left of the main editor window.

Adding new numbers and topics:

The Add New Number function is for creating new topics with new numbers. Enter a new

topic ID followed by a new number. The new topic ID and context number will be added

to the list and a new topic file will be created when you click on OK. 

An error will be displayed if you enter the ID of an existing topic.

Deleting help context numbers

1. Open your project and select Tools > Help Context Tool. 

2. Select the context numbers you want to delete in the list displayed. Use Ctrl+Click and

Shift+Click to select multiple numbers.

3. Click on Delete Selected to delete the context numbers from the selected topics.

Note that if selected topics have multiple context numbers all the numbers will be de-

leted, even though only  the first number is shown for the topic in the list.

Importing context numbers and auto-generating topics from a map
file

Software development tools can generate "map" files with lists of context IDs and match-

ing help context numbers. Programmers often provide these lists to inform the help au-
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thors of the topic IDs and context numbers needed for context-sensitive help calls.

In addition to importing missing context numbers to existing topics this function can also

auto-generate missing topics from a map file. Since context-sensitive help often consists

of hundreds of very short topics this capability can save you many hours of boring and

frustrating work. It creates the basic framework for your context help in seconds.

Importing context numbers:

1. Obtain the map file from the programmers and make sure that it only contains the

topics you want to use. These files have a standard syntax – you can create an example

by using the Help Context Tool's export function (see below). 

2. Open your project (you might want to make a backup first) and select Tools > Help

Context Tool.

3. Select Import Map File and select the map file you want to import. A dialog will be dis-

played asking you whether you want to merge or replace the existing numbers

Replace:

This deletes ALL context numbers in the current project and replaces them with the

numbers from the map file.

Merge:

This only replaces the context numbers for topics with matching IDs. All other topics

are left unchanged.

Auto-generating topics:

When you import a map file any topic IDs in the file that don't exist in your project will be

listed in red in the Context Tool editing box. When you click on OK the tool will ask you if

you want to create topic files for these IDs. 

If you say yes the files will be created in the Topic Files section, without TOC entries. If you

want to create TOC entries for the new topics you must do this manually.

Exporting IDs and context numbers to a map file

You can also use the Help Context Tool to export the topic IDs and help context numbers

from your project to a map file that the application programmers can use for writing their

context help calls (and also to obtain an example of the map file syntax). 

1. Open your project (you might want to make a backup first) and select the Context

Tool in the Tools > Help Context Tool section. 
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2. If you only want to export some of the help context numbers select them in the list

with Ctrl+Click and Shift+Click. Then select Export Map File:

 

3. Select Export selected numbers only if you don't want to export the entire list, then

choose the Map File Syntax: 

· #Define is the default and selects the standard #define syntax used in most map

files.

· INI Style selects the standard INI file format.

· Custom allows you to define your syntax yourself. To do this you can combine the

three map file variables displayed (see below) with any text or additional characters

of your own.

4. Enter a filename and click on Save to export the map file.

Variable syntax for custom map file output

You can use the following three variables in your map files:

<%TOPICID%> Inserts the Topic ID of the current topic. Unlike <

%HREF_CURRENT_PAGE%> this variable inserts

the Topic ID exactly as it is displayed in the Topic

Options tab on the left of the main editor win-

dow, including upper and lower case characters.

<%ANCHORID%> Inserts the anchor ID of an anchor that has a help

context number. 

<%TOPIC_HELPCONTEXT%> Inserts the help context number of the current

topic or anchor. 

Just inserting the variable on its own generates a

decimal number. You can also export the context

numbers in hexadecimal by adding a hex prefix:
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&<%TOPIC_HELPCONTEXT%> Exports to hex in the format &000000FF

0x<%TOPIC_HELPCONTEXT%> Exports to hex in the format 0x000000FF

See also:
Topic IDs and context numbers

IDs, Context Numbers and Keywords

10.9 The Project Synchronization Tool

The Project Synchronization Tool is used mainly to update translated versions of your pro-

jects. This tool compares the latest original version of your project with the last translated ver-

sion and updates the translated version so that the translator can translate the new and

changed material. It inserts new topics, moves moved topics, deletes deleted topics and iden-

tifies topics with changes. All new and changed topics are highlighted and the complete new

version of the topic content is inserted above the old translated version.

The Project Synchronization Tool is only available in the Professional and Floating license ver-

sions of Help+Manual.

Project Synchronization is not needed if you are using translation

memory!

The Project Synchronization Tool is only needed if you are not using a translation memory

tool like  SDL Trados. See the translation memory  topic for more detailed instruc-

tions.

If you are using translation memory, updating your translations is automatic and there is

no need to synchronize your projects. Instead, you just give the translator the latest ver-

sion of your project in the uncompressed HMXP format. The translation memory tool

automatically identifies all the text that has not changed and replaces it with the original

translations from its database for your projects. The translator then only needs to work on

the new and changed texts. In many cases, much of this will also be translated semi-auto-

matically, because it will contain identical or similar phrases and now familiar terminology.

10.9.1 About Project Synchronization

Project synchronization helps you produce and maintain translated versions of your projects.

Producing the initial translation is easy – you just make a "sibling copy" of your original pro-

ject with Project Synch and give it to the translator, who translates all the text in the project
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into a different language, using either Help+Manual or an external tool like SDL Trados that

can edit the XML project files directly (Professional and Floating license versions of H+M

only).

The real job of Project Synch begins when you need to update your documentation. When

the new version of the original project is ready you use Project Synch to compare the new

version of the original with the last translated version of the project delivered by the trans-

lator.

The old translated version is then updated: New versions of modified topics are inserted for

translation, completely new topics are inserted, deleted topics are removed, stylesheets and

project properties are updated and so on.

You then send the updated version to the translator, who translates the changes and new

content and returns it to you.

What project synchronization does and does not do:

Project synchronization compares differences in project structure, not in topic content.

This makes it possible to compare two projects written in completely different languages –

the original version and the translated version – and to update the structural changes in

the translated version.

Project Synch is not a "track changes" or "compare by content" function. 

It does not show you where changed text is in individual topics or what specific changes

each topic contains. It only tracks which topics have changed and updates the project

structure to the latest version. 

It just shows you that topics contain changes. These changes can be topic content,

keywords, settings in the topic's tab or changes in the topic caption in the TOC.

Project Synch is not suitable for monitoring ongoing changes in two projects.

Project Synch assumes that nothing in the translated version is ever changed independ-

ently. It only checks for changes in the original version and updates the structure of the

translation version to reflect those changes.

If independent structural changes (new topics, moved topics etc.) are made in

the translated version Project Synch will eliminate them!

It is extremely important to understand this. The translator is not permitted to make any

structural changes to the project! They must just produce a 1:1 translation of the project

structure as you deliver it to them.

Because of this you shouldn't try to use Project Synch to compare and synchronize ongo-

ing changes made in two different versions of the same project in the same language. If
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you do, all the changes in the target version (equivalent to the translation version) will be

eliminated when you synchronize!

How changes are synchronized:

The original project and the translated project are linked as a "translation pair" which we

refer to as "siblings". When you compare the two Project Synch can then identify all items

in the original project that have changed since a specified date. This is achieved with in-

ternal ID codes and timestamps that are assigned to the entire project, topics and other

elements of your project.

· New topics: These are inserted in the translated version in the correct positions so that

they can be translated. They are highlighted in the TOC. 

· Changed topics: These are highlighted in the translated version. The complete new

version of the content of the changed topic is inserted in the translated version. This

can either replace the old translated text or be inserted above the old translated text.

· Deleted topics: These are removed from the TOC of the translated version.

· Moved topics: If their content has not changed they are simply moved to their new po-

sitions in the translated project. They are not highlighted in the TOC unless their con-

tent is also changed.

· Topics with changed titles or keywords: Project Synch treats these as changed topics

and also highlights them in the TOC.

See also:
Identifying changes

Interim updates

Problems and troubleshooting

10.9.2 Synchronization Steps

The topics in this chapter describe the steps required to synchronize an updated version of

the original project with the old translation. This process creates a new version for the trans-

lator in which the following changes have been made:

· Changed topics are marked as changed and the new text from the original topic is in-

serted above the old translated version so that the translator can compare and make

the changes.

· Moved topics are moved

· Deleted topics are removed

· New topics are inserted and marked as new so that the translator can translate them

10.9.2.1 Step 1: Create a translation sibling

The first step of using Project Synch is creating a copy of your original project for the trans-

lator to work on. If you want, you can do this in Windows Explorer or any other file manager.

1255
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However, if you do this you must then link the two projects as a "language pair" manually

later. It is easier to use Project Synch to create a "sibling", then the two projects are "paired"

automatically.

Project format:

If the project is going to be translated using an XML-based tool like SDL Trados , you

must save the project and generate the sibling in uncompressed XML format. This format

is only supported by the Professional and Floating license versions of Help+Manual. 

The compressed single-file .hmxz format can only be translated using Help+Manual as

the translation editor. Project Synch is also not available in the Basic version of

Help+Manual. The tool is only included with the Professional and Floating license ver-

sions.

Synchronizing existing translations:

You can also synchronize projects that have already been translated without using the

Project Synch function. However, there are a few points you need to bear in mind when

doing this. Please see the Problems and Troubleshooting  topic for details.

1: Save the project and create the new sibling

Before you perform this step you should be as certain as possible that your original pro-

ject is finished and will not be changed again while the translator is working. You can syn-

chronize more changes  later if necessary but it will make the process more complic-

ated.

1. Save your original project. It doesn't hurt to use this as an opportunity create a backup

in a safe place as well! From now on this project will be referred to as the Master. 

2. Select Tools > Synchronize... and select the New tab in the dialog displayed.

1187
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3. Select the language and character set of your target project (see International lan-

guages setup  for details) and choose a file name and the location where you want

to save it. By default Help+Manual will suggest a project name with the language code

of the new language added to the old project name – you can change this to some-

thing more descriptive if you like. The select OK to save the new sibling.

The sibling will automatically be saved in the format of the current project: .hmxz for

single-file projects, .hmxp for uncompressed XML projects (H+M Pro only).

2: Send the sibling to the translator

Now all you need to do is pack the new project folder and all its contents in a ZIP file and

send it to the translator for translation. Before doing so you should check that you have

included everything the translator will need. 

Graphics files:

Make sure that all the graphics files used in your project are included. It is best to put all

the graphics files in one or more folders inside the project folder.

Snippets files:

If you are using linked snippets  from other locations you may need to include copies of

the snippet files for the translator. It is best to put all the snippet files in one or more

folders inside the project folder.

Project Search Path:

Update the Project Search Path  if necessary, adding entries at the top of the list for any

folders you have added to the project folder for the snippets and graphics files. Then

everything will display correctly when the translator opens the project from the folder – re-
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lative paths are used in the Project Search Path, so if the additional folders are inside the

folder containing the project file the paths will be "portable".

It's also a good idea to publish the translation copy once before sending it off to make

sure that it's working correctly – then you won't have to waste time answering questions

from the translator.

Make sure that the translator reads and understands the translation guidelines
before starting work!

10.9.2.2 Step 2: Translate the original project copy

In this step the translator just works through his or her copy of the project in Help+Manual or

their translation tool and translates it into the target language. There is nothing special about

this, but the translator must observe the guidelines listed below.

Once the translation is finished it can be published and distributed with the translated version

of your application. This is the end of this step of the process. The real work comes when you

need to synchronize and the next version of the help and translate the changes.

Guidelines for the translator

The translator's job is only to translate. Making any structural changes to the project is

strictly forbidden for the translator! For example, if the translator adds, moves or deletes

topics these changes will be deleted the next time the language pair is synchronized!

Configuration: Check and translate all the texts used in Title & Copyright, Text

Variables (see below), HTML Page Templates (the translator may

need information from you here), Help Windows (window titles but

not window names) and any text fields used in the relevant publish-

ing options sections (HTML Help, PDF etc).

Topic Options: Never under any circumstances make any changes to anything in

the Topic Options tab except the Keywords. Everything else in this

tab is off limits for the translator!

The TOC: Only translate the captions. No other changes here are permitted. In

particular, never make any changes to the structure of the TOC. Do

not move or delete topics. 

When working in Help+Manual always translate the TOC captions

before translating the topic header above the topic text. The header

is normally linked to the caption and will only need to be translated

if it is different. Translating the header first would break this link.

Topic Headers: Only translate topic headers if they do not get translated automat-

ically when you translate the TOC captions. (This is only the case if

1250
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the header and the caption are different.)

Topic Text: Translate everything here that is not protected (shaded text, cannot

be edited without unprotecting). Be careful not to delete any hyper-

links and only translate the captions of hyperlinks, not their targets,

which are the untranslatable topic IDs and anchor IDs.

Text Variables: If the text contains variables go to Configuration > Common Prop-

erties > Text Variables and translate their definitions. Do not trans-

late the variable names!

Hyperlinks: Only translate the captions of hyperlinks. Do not make any changes

to the links themselves or their targets.

Keywords / Index: Only translate the keywords in the Keywords: editing box in the

Topic Options tab on the left of the main editor window. Use the In-

dex Tool in the Project tab to help you find the other topics where

the same keywords are used.

Do not translate the A-Keywords. These are never visible to the

user and should remain in the original language because they are

used in special links that must reference the original keyword

names!

10.9.2.3 Step 3: Update the original project

This step must be performed on the original project file used to create the translation sibling

in Step 1. Only this file will have the correct Project GUID  that can be used for synchroniza-

tion in the next step.

That is all you need to know about this step. Simply work on your project normally, making

any necessary changes, deletions and additions. There are no restrictions on the changes you

can make.

Mark the changes with comments while you are working!

To make the translator's work easier use the comments and bookmarks  features to

identify the text that has been changed. You can write comments to explain where the

changes are, particularly if they are only in the – otherwise the translator may waste a lot

of time trying to find changes in the text that are not there!

10.9.2.4 Step 4: Synchronize the new version

This step is where the real work of the Project Synch function comes in. Now you want to syn-

chronize the new version of the original help with the translation of the original version. The

result will be an updated translation version in which all the topics containing changes are

marked, with the new versions of the updated topic contents inserted for translation.
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For this step you need the updated version of the original project edited in Step 3 and the ori-

ginal translation delivered by the translator in Step 2.

Key Information
The Synch procedure has reversed since Help+Manual

4! Now you open the Master (original) project and

synchronize with the old translation. 

Synchronize the old translation with the updated original

The synchronization is performed by opening the latest version of the original project

then selecting the old translated version to be updated. 

1. Open the updated original project in Help+Manual. 

2. Select Tools > Synchronize and select the Compare tab. Then select the old translated

project in the Select OLD sibling... field:

3. Select your synchronization options. Recommended settings:

· Keep old and new text in TOC and topics

· Highlight changed topics

DON'T select Compare TOC by Topic ID when you are comparing a sibling! This is a

special setting for comparing existing translations  that are not siblings.

4. Click on OK to update the translated version.

This will update the old translated project with the changes in the new version of the ori-

ginal. After the conversion you can check the updated translation to make sure that
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everything has gone OK and then send it to the translator so that they can translate the

changes and the new material. 

Before the translator starts work make sure that he or she has studied the instructions for

identifying changes  and the original translation guidelines .

Synchronizing modular projects

When you are synchronizing modular projects consisting of multiple separate

Help+Manual projects in a master module, you need to perform the actual synchroniza-

tion on each project separately. So you would Synchronize the master project with its

master sibling in the second language, and the child projects with their corresponding sib-

lings in the second language.

Child projects / modules with different names

In Help+Manual prior to version 8 your child modules needed to have the same names in

all languages. Otherwise their names would be changed to the names of the same mod-

ules in the master language when you synchronized. Starting in version 8 you can now

have child modules with different names in the individual languages. For example, a child

module called CHILDA_ENG.hmxp in the English master copy can now have an equivalent

CHILDA_DE.hmxp module in the German sibling and the reference to this will not be re-

set in the master when you synchronize.

Project synchronization settings

Keep old and new

text in TOC and top-

ics:

Selecting this will insert the complete new version of topics con-

taining changes above the old translated version. The old and

new versions will be separated by a header saying -----OLD

TEXT-----.

The same procedure is used for the TOC captions, the headers

and the keywords in the tab.

This is the best mode for normal synchronization.

Simply overwrite

with new content:

The content of changed topics, headers, topic captions etc. will

be completely overwritten with the new versions in the original

language. 

The translator must then use a copy of the original version of the

translation for comparison.
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Do not overwrite, just

flag changes:

This option only highlights changed topics in the TOC and does

overwrite the translated version or insert a new version.

The translator must then use a copy of the new version of the

original to obtain the new versions of the topics and their

keywords etc.

Note that even when this option is selected the following

changes will still be updated:

· Context numbers

· Topic IDs

· Help window settings

· TOC structure (new, moved and deleted topics)

Highlight changed

topics:

Selecting this identifies changed topics with colored highlights

("Needs Review") in the TOC. 

This should always be on. If you turn it off it will be very difficult

to identify where changes are located.

Compare TOC by

Topic ID:

WARNING: Do not use this option for synchronizing sib-

lings!

This is a special setting for synchronizing two versions of a pro-

ject that were not created by making a sibling copy of the ori-

ginal. In normal synch mode the Project Synch tool compares

topics on the basis of their hidden internal ID, which never

changes – this makes it possible to compare topics even when

their visible IDs have been edited. 

If you independently create two projects that have the same

structure and Topic IDs they will look identical but their invisible

internal IDs will not match. The first time you synch such projects

you need to use this option to compare by topic ID. After this

the internal IDs will by synchronized and the projects will then

be siblings.

10.9.2.5 Step 5: Translate the changes

Synchronizing the new version of the original with the old translated version updates the

translated version with the changes that need to be made. You can then give the updated

translated version to the translator for review and translation of the changes.
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The translator then needs to go through the project, locate the changes and translate them.

The actual translation work here is pretty much the same as the original translation, and the

same guidelines should be followed. The main problem is identifying where the changes are. 

See also:
Guidelines for translators

Identifying changes in the synch project

10.9.3 Identifying changes

Remember that Project Synch doesn't compare content, it only identifies changed, new and

deleted topics and updates the structure of the translation project to match the new version

of the original project.

If possible, you should thus always document and explain your changes with comments

while you are working on the new version of the original project. 

This is particularly important if you only make changes in the Topic Options tab on the left of

the main editor window, because then the translator may waste a lot of time looking for

changes in the text that are not there. It is also very helpful for the translator if you systemat-

ically tag text changes with comments as well, however.

How to identify changes in the synched project

New topics: New topics are inserted in the translation project in

the correct position in the TOC. If you have selected

highlighting in the synchronization options, every new

topic in the TOC will be highlighted with the Needs

Review status, which will be light green unless you

have changed it.

In addition to this, the new topic will not be in the

same language as the translated version, of course. 

Deleted topics: Deleted topics are simply removed from the project.

They are no longer there.

Changed topics: Changed topics are highlighted with the Needs Review

status in the TOC. The new version of the topic in the

original language is inserted above the old translated

version unless you have turned this off in the synch

settings.

Remember that changes can be in the topic header

and the Topic Options as well as in the topic content!

Moved topics: Moved topics are simply moved to their new position

in the TOC. They are not highlighted as changed un-
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less they contain other changes in their text, header or

Topic Options settings.

Topic captions in the TOC: If topic captions have changed the new version of the

caption will be inserted and the old version will be en-

closed between <OLD> and </OLD> tags, like this:

Getting Started with Widget Confabulator

<OLD>Introduction</OLD>

In this example the author has edited the topic caption

to make it longer. You can see the old translated ver-

sion between the OLD tags – the original caption was

just Introduction.

When only the topic caption is changed no new text is

inserted in the topic body or header.

Keywords: When a topic is flagged as changed you should always

also check the Keywords in the Topic Options tab on

the left of the main editor window, as this can also be

the cause for the change flag.

If you have selected Keep old and new text in the syn-

chronization options the old and new keywords are

separated by an --OLD KEYWORDS-- divider, with the

new keywords above. 

Topic IDs and other : It is important to understand that changes in the Topic

Options can also cause the topic to be flagged as

changed, even if nothing has actually changed in the

topic text. So if you can't find any changes in the text

the change is probably in the Topic Options some-

where, or possibly also in the topic header. 

See also:
Guidelines for translators

10.9.4 Interim updates

It happens: You thought your project was finished but after the translator has started work on

the new translation you discover that you need to make some more changes and/or additions

to the original project. Can the translator synchronize these changes into his/her project, even

though the actual translation is not yet finished?

This is possible, provided your new changes are saved after the last changes made by the

translator. So if you need to make changes after the project has been sent out for translation

you need to coordinate with the translator(s) before making the changes.
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Synchronizing interim updates

1. Inform the translator that further changes need to be made. Ask them to finish all

their work on the current version before proceeding. Then they should send you the

finished project. 

2. Once you have the finished project from the translator that is the new "old" version.

You can now make your changes in the original version. 

3. Once you have made your changes, perform the project synchronization  step on

the translated version of the project again. This will create a new working version for

the translator that you can then send them so that they can complete the work.

Always select the "Keep old and new text" option in the synchronization options!

This ensures that the translator can also reference any work they may have done on the

affected topics before you made the new changes. 

See also:
Project synchronization settings

Identifying changes

10.9.5 Synching existing projects

You may already have versions of your project in different languages. The question is, can you

synchronize these projects? The answer is yes as long as the structure and topic IDs are

identical – if they are then Project Synch has a special function that will turn the two projects

into siblings. 

About matching project siblings:

Projects are synchronized using the hidden internal numerical IDs of your topics and the

topic captions in the Table of Contents (TOC). Each topic and each topic caption has a

unique internal numerical ID that is assigned when the topic is created and it is normally

never changed – not even if you change the Topic ID . It is part of the topic forever, un-

til it is deleted. These IDs are not editable and not visible to the user. 

Matching project siblings are projects with identical internal numerical IDs for all topics

and all TOC entries. Only matching project pairs can be synchronized directly with the nor-

mal Project Synch settings. 

In the case of a translated version this is only the case if you created the translated version

by making a copy of the original project and then translated its text. If you built the trans-

lated version from scratch the internal numerical IDs may not match and you will have a

problem. You can correct this with the Compare by Topic ID option.

1251
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Synchronizing existing projects that are not matching siblings

If the internal IDs of your projects do not match you need to use the Compare by Topic ID

option the first time you compare. Project Synch will then synchronize the internal numer-

ical IDs of the two projects. After this you can synchronize the projects normally.

1. Make absolutely sure that the structure and topic IDs of the two versions of your pro-

ject match. Then save both projects in the same format (single-file compressed or un-

compressed XML) and open the original version. 

2. Select Synchronize in Project > Tools and click on the Compare tab. 

3. Choose the translated project in the Select OLD sibling... field, then activate the Com-

pare TOC by Topic ID option. You will be warned that this is only for special purposes.

4. Set your other options and synchronize the two projects. 

You only need to do this once. After this the internal numerical IDs are synchronized and

the two projects are real siblings that can be synchronized normally. 

See also:

Problems and troubleshooting

10.9.6 Problems and troubleshooting

If you work within its capabilities, remembering that it cannot be used to highlight changes in

topic text, Project Synch will work very reliably. However, you may still encounter some prob-

lems in certain situations, particularly if you don't follow the instructions. 

Always create backups before synchronizing

Since project synch automatically modifies your translated version of the project you

should always create backups before synchronizing. This is simply good security policy,

and it is particularly important if you are synchronizing existing translations that were not

created with the help of project synch (see below). Then you can always resort to the

backup if anything goes wrong. 

Comparisons with changes in both projects

Structural changes made in the translated version will be deleted!

Please always remember that this function is only for updating translated versions to re-

flect changes made in the original project. It is assumed that the translator does not make

any structural changes to the project. If the translator makes structural changes like

adding new topics, moving or deleting topics etc. these changes will be deleted when you

synchronize the translated project with the master!

Again: The translator is not allowed to make any structural changes to the project or to

alter anything in the project configuration settings or (except translation of the keywords).
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Translating the content is fine, but structural changes made by the translator will probably

be deleted during synchronization and may also cause problems!

Comparisons with existing translations

Can you compare an existing translation with the original master project?

You can do this even if the language pair was not created with the Project Synch tool,

provided that the structure and Topic IDs of the two project versions match precisely. If

this is the case you can use the Compare by Topic ID option to turn the two projects into

real siblings that can be synchronized normally. 

For full details see Synching existing projects .

See also:
Synching existing projects

Translation guidelines
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Extensive cross-references and links to the Procedures sections. Quickly find what you
are looking for!

Picture courtesy of pixabay or picjumbo

http://pixabay.com/
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11 Reference

11.1 Program Options

This dialog is available in both the File menu and the View tab. It contains the settings for

configuring how Help+Manual itself works. These settings are all saved with the program, as

opposed to the settings in Project Explorer > Project Configuration  which are all saved

with individual projects.

It is a good idea to check through these settings before you start working with Help+Manual.

You may be surprised at all the things you can adjust and configure!

See also:
Project Configuration Settings

Options & Keyboard Shortcuts

11.1.1 Program Options - General

These options control how Help+Manual starts up, automatic backups, automatic update

checking and some other general features.

User interface

language:

Currently either German or English are available. Automatic sets the

language to your Windows language (if it is German or English), oth-

erwise you can set the language manually. 

Automatically

check for up-

dates:

Checks for the availability of a more recent version of Help+Manual.

New versions are published regularly, both to provide new and im-

proved functions and to correct issues reported by users.

1400
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Note that this only works if you are connected to the Internet. Also, if

you are behind a firewall you may need to configure your firewall set-

tings give the Help+Manual program helpman.exe permission to

access the Internet.

What does checking "now and then" mean in this option? Here's what

the programmer has to say about it:

It means that it checks for updates not every time you start it, but

more frequently than once a month. It will check more often in the

beginning and less often if it gets frustrated because it hasn't suc-

cessfully detected an update for a while. That could be once a week

or so. But it never checks for updates on Sundays and occasionally

does on weekdays, except if the day is a holiday in Austria. It only

checks for updates when it is idle and there are no other urgent

tasks to process and it stops checking when it finds that you are on

lunch break (it figures you will not read the message while you are

away). 

Note: The above is not entirely serious...

Show mouseover

hints for buttons

and objects in

text:

Recommended! 

When this is activated little tooltip popups are displayed when you

position the mouse cursor over toolbar buttons and objects in the

editor. These popups contain a lot of useful information for your pro-

ject. They are like an extra status bar for links, graphics etc. 

New feature in Help+Manual 9: 

Topic links now show a preview of the target topic when you hover

over a topic link for more than a second or so.

Open last help

projects on start:

Automatically loads the last project(s) you had open when you start

Help+Manual. If you activate this Help+Manual will also return to the

last topic you were editing and re-open any topics that were open in

tabs when you closed the program. 

See Workspaces and Preferences  if you want to save sets of pro-

jects that you want to be able to load with a single command.

45
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Empty Clipboard

when

Help+Manual

closes:

Automatically clears the Windows Clipboard when you exit the pro-

gram.

When filtering

table of contents

do not hide

nodes, display

them with:

Setting for the TOC filter option in Project > Manage Topics > Ex-

plore > Filter. This allows you to filter the TOC display in the Project

Explorer to hide or highlight topics on the basis of their "Include in

Builds" settings.

When you activate this option topics filtered out by build are dis-

played in a different color instead of being hidden.

Default image

editor:

By default Help+Manual starts the integrated Impict graphics editing

program when you click on graphic in the Help+Manual editor and

then select the Image Editor tool in the Project tab. This setting allows

you to change this to a different graphics editing program.

HelpXplain ed-

itor:

Location of the full version of EC Software HelpXplain, if it is installed.

Help+Manual will use this to compile HelpXplain presentations  in-

serted in your project, if it is installed. Otherwise the simple HelpX-

plain screencasts you can create directly in Help+Manual will be com-

piled with the integrated HX compiler.

See also:
Options & Keyboard Shortcuts

The View Tab

Devices with Hi-Res Displays

11.1.2 Program Options - Ribbon

You can configure the Ribbon toolba. If you wish, you can completely rearrange all the tools

in all the Ribbon tabs. However, be warned that if you do this referring to the help will be-

come difficult, because the documentation always refers to the standard layout.

View and Insert tabs for your own use

You can use the View tab as your own personal tab. We have intentionally left this tab al-

most empty and all the standard functions can be removed because they are also avail-

able elsewhere. The Quick Access Toolbar can be customized directly and the Program

Options are also available in the File menu. 

In addition to this, you can also activate an additional Insert tab, that is normally empty

and thus disabled by default. To do this select Insert in the Ribbon Tab: field and then

561

59

1398

44

https://www.helpandmanual.com/hx/


1264

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Reference

move groups to it from the list on the right. For example, you could move the Insert and

Insert Object groups that are normally in the Write tab there.

Ribbon tab: Selects the Ribbon tab you want to customize.

Groups in this tab: The function groups included in the selected tab. Select and use

Remove>>, Move Up and Move Down to edit. 

Available groups: Shows all the available function groups. To add a group to the

current tab select it and then click on <<Add.

Reset defaults: Returns all the Ribbon settings to the default configuration. 

See also:
Project Configuration Settings

Options & Keyboard Shortcuts

11.1.3 Program Options - Shortcuts

You can use these options to assign keyboard shortcuts to most program functions. You can

also change the standard keyboard shortcuts that are already assigned if you want, although

this is generally not recommended.

Just click on the option you want to assign a new or different shortcut to, then select the

shortcut in the Current Shortcut: fields.

1400
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Current shortcut: These two fields select the letter (right) and the control key (left).

Select the letter key first for options that do not yet have a shortcut

assigned.

Reset Defaults: Resets all the shortcuts to the default settings that Help+Manual

has when it is freshly installed.

See also:
Project Configuration Settings

Options & Keyboard Shortcuts

11.1.4 Program Options - Editor

Productivity Tip
You can access the Editor settings quickly by right-

clicking in the ruler above the editor window. This also

provides quick access to the paragraph settings dialog.

These options adjust the appearance and behavior of the Help+Manual editor.

1400
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Ruler units: You can select pixels, inches, centimeters or points. Pixels are

recommended for maximum accuracy – Help+Manual

handles all sizes internally in pixels and all other units must be

converted. 

Display a vertical ruler: Display a vertical ruler to the left of the editor as well as a ho-

rizontal ruler.

Show paragraph and

text marks in editor:

Show spaces:

Makes tabs, paragraph end marks and spaces visible in the

editor. This can be useful for identifying formatting problems.

Can also be switched on and off with  in Write > Paragraph

.

Disable zoom and scale

text only:

Turns off the global zoom feature in the Help+Manual editor

so that only text is scaled. All other elements (graphics, tables

etc) are then no longer scaled. 

Font settings for XML

and HTML editors:

Allows you to select a different font for the XML source code

editor and the HTML code editors used for HTML templates,

HTML code objects etc.

Only fixed-space console fonts like Courier New or Lucida

Console will look good in these editors.

Smart selection: When you select text Help+Manual tries to automatically se-

lect at whole word boundaries to make selectin easier and

more accurate. In some languages like Japanese this can

cause problems, because they do not have the same kind of

white space word boundaries as Western European lan-

guages.

This option lets you turn this off when working in languages

like this.

Live preview for styles: When this is activated you will get a live preview of what the

currently selected text will look like when formatted with

styles when you scroll through styles in the style selector tool

in the ribbon toolbar. You can turn this feature off if you find

that it makes style selection slower.

Show strong table grid

lines in edit mode:

Uses darker and slightly thicker grid lines to show the borders

of tables. Can be useful to make tables more visible on some

monitors.

Automatically detect

URLs while typing text:

When this setting is active Internet URLs and email addresses

will automatically be turned into Internet links  as you type.

Auto-replace blanks in

topic IDs with character:

Topic IDs containing blanks and some special characters

would be invalid. By default, Help+Manual replaces the blanks

and other illegal characters with hyphens. You can use this

setting to change the character used. 

We recommend using either hyphens (-) or underscores (_).

You can use other characters, but if you select an illegal char-

acter it won't be used. Instead, the blank or illegal character in

the ID will simply be deleted and not replaced.

Automatically manage

topic bookmarks for

every comment:

When this is selected creating a new comment  automatic-

ally also creates a new bookmark for the current topic, using

the beginning of the comment text as the bookmark label. 

All the bookmarks will be listed in the Bookmarks tool but

they will all link to the top of the topic. Deleting comments

will also delete the linked bookmarks. 

Apply status to new top-

ics:

Choose a status (highlight color and name) to be applied to

new topics automatically. Note that only the standard status

settings (Needs Review, Out of Date, Under Construction) can

be used for this. User-defined status settings are stored with

your project, not with your program settings, and are thus not

available here. 

After changes set status

to:

Automatically change the topic status to the value you specify

after editing changes have been made. 

Display color for read-

only TOC items:

Sets a custom color for highlighting read-only topics and

other items in the TOC. This is mainly relevant for multi-user

editing and can make locked topics easier to identify in the

TOC. 

Use old (wrong) table

style assignment

Version 8 fixes a table style problem that can break existing

tables.

In version 7, a table displayed at least 1 colored heading row

if (a) the table defined a dedicated heading row color or (b)

the table style defined a dedicated heading row color. Even

then, when a particular table defined its number of heading

rows as zero (this is a table-specific property, not a style

property).

In other words, setting a table style with a heading row color

automatically made tables without heading rows display at

least one colored heading row. This was in fact wrong and has

been corrected in version 8.

However, this change may break existing tables which previ-

ously displayed a colored heading row, despite their heading

row count was zero. You need to modify those tables and as-

sign a dedicated heading row count > 0.

To restore the previous behavior of table styles, enable this

option.

Translate Asian Font

Names

This option is important when editing Asian help projects

on a non-Asian Windows version.

Most Asian fonts have two names, their original name and an

English name. For example, the font "    " is a Chinese

font, which will show as "    " on a Chinese Windows,

but as "Microsoft YaHei" on a non-Chinese Windows. Both

names, the original name and the English name, can be used

to assign this font to a text, but only one variant is selectable

in the font dialog box. On an English Windows, you will al-

ways see "Microsoft YaHei" in the font dialog box, on a

Chinese Window there's instead a font named "    ".

In order to be able to edit (and not just export) Asian pro-

jects on a non-Asian Windows, Help+Manual can translate

Asian font names when the project is loaded. On an English

Windows, all occurrences of native font names will be trans-

lated their English equivalent and vice versa.

Treat Impict images

(*.ipp) as transparent

When this is set the background color of Impict IPP images

(i.e. the color of the canvas) will be treated as transparent. The

IPP images will then be exported as a PNG with a transparent

background.

Auto-adjust legacy WMF

images

The old Windows WMF vector format was created long be-

fore modern, high-resolution monitors and laptop screens ex-

isted. It prevents your old WMF images from being scaled in-

correctly by Windows and displayed too large on high-resolu-

tion screens. It should also be on if you are working in a team

with some users on traditional monitors and others on high-

resolution monitors. 

See Supported graphics formats  for more details on this

setting and when you might want to turn it off.

We strongly recommend that the old WMF and EMF vector

formats should no longer be used. Use modern SVG vector

graphics instead. 

422
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See also:
Project Configuration Settings

Options & Keyboard Shortcuts

11.1.5 Program Options - Compilers

These options configure the paths to the Microsoft compilers used to generate HTML Help

and Visual Studio Help 2008 (MS Help 2.0/HXS). Visual Studio Help 2010 does not require a

compiler. You can also configure which compiler messages you wish to see in the report gen-

erated when you publish your projects. The paths to these compilers will usually be found

automatically during installation.

Compiler messages: It is a good idea to leave all these messages activated as they

make it much easier to identify problems when you are publish-

ing.

Handling of dead

links:

These settings define how Help+Manual deals with dead hyper-

links created when you exclude topics from your build without

also excluding links to them in other topics. 

Silently include linked topics:

Excluded topics will be exported anyway if they are referenced in

links in other topics in your project.Topics exported in this way do

not have TOC entries – they are exported "invisibly" and will only

be displayed when the user clicks on the links referencing them.

Remove link:

Removes the hyperlink from the text, leaving only plain text. This

1400
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is really only recommended for testing purposes because the

dead links may not make sense in your text if they are inactive. 

Allow links to be dead:

This option does nothing. The links are not changed and the user

will either get an error message or nothing at all will happen when

they click on the links.

Tolerant handling of

Asian languages:

Allows you to publish projects in Asian languages on Windows

systems whose language does not match the language of the help

project. Some features in the help generated may not work cor-

rectly, however (Search, Index). To test these features properly you

need a version of Windows whose language or at least the system

locale matches that of the project you are compiling. This is ne-

cessary because the Microsoft CHM format does not use Unicode

and it needs support from the operating system to display lan-

guages with special character sets correctly. 

If you are not using a version of Windows matching your Asian

language you must set the system locale to the correct language,

otherwise the HTML Help compiler will not work properly because

it is not a Unicode program; it needs support from Windows to be

able to handle these character sets correctly. To do this open the

International settings in the Windows Control Panel. The setting is

in the Advanced tab. In Windows XP it is called "Language for

non-Unicode programs", in later versions of Windows it is called

System Locale.

You need to restart Windows after changing the locale.  

Location for tem-

porary files:

Enables you to specify a different drive and folder for storing the

temporary files generated while publishing a number of output

formats (CHM, ePUB, Kindle, eWriter, Visual Studio Help). In some

cases this can speed up the publishing process, particularly if your

project is on a network drive.

See Optimize Publish Speed  for details. 

HTML Help com-

piler:

The paths to the Microsoft compiler for HTML Help/CHM files. To

get this you need to download the free Microsoft HTML Help

Workshop package.  Visit this page for the download link for the

correct version:

Microsoft HTML Help Workshop download

651
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Warning:

When you install HTML Help Workshop you will get a confusing

message saying that your computer "already has a newer version

of HTML Help". This is an error in the Microsoft installer and is not

relevant to the HTML Help Workshop program or the compiler.

Both have installed correctly when you see this message. 

Microsoft Help 2.0

compiler:

Location of Visual Studio Help 2008 compiler for the Microsoft

Help 2.0/HXS help format (VS Help 2010 does not require a com-

piler). You can only get this compiler as part of Visual Studio. 

Note that Visual Studio Help is only relevant for programmers

documenting Visual Studio .NET components. It is irrelevant for all

other purposes and cannot be used as a general help or docu-

mentation format for application programs.

Amazon Kindle

compiler:

Location of the Amazon compiler that you need for publishing

Kindle/Mobi eBooks. This compiler is included in the Amazon

Kindle Previewer package, which you can download here:

Download the Amazon Kindle Previewer

Important: Do NOT try to install the Kindle Previewer in the

Program Files folder!

Don't change the default installation location of the Kindle Pre-

viewer package! If you do, it will not work correctly and you will

get all kinds of errors. Because of the way this Amazon program

works, it absolutely needs to be installed in your Windows user

account directory and the location Amazon chooses, otherwise

it will not have the necessary write permissions while it is run-

ning.

Help+Manual will normally find the Kindle compiler automatically,

but if it doesn't you can set its location here. It will normally be

saved in:

Kindle Previewer version 2:

C:\Users\YourUserAccount\Ap-
pData\Local\Amazon\Kindle Previewer\lib\kindle-
gen.exe

http://www.amazon.com/gp/feature.html?docId=1000765261
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Kindle Previewer version 3:

C:\Users\YourUserAccount\Ap-
pData\Local\Amazon\Kindle Previewer 3\lib\fc\bin

Resets all the settings and paths to the default values.

Search for  com-

pilers:

Attempts to locate the necessary compiler executable files in your

Program Files directory.

See also:
Project Configuration Settings

Options & Keyboard Shortcuts

11.1.6 Program Options - PDF Export

This tab can be used to set a different "reference printer driver" for generating PDF output.

The PDF engine must have a printer driver to generate PDF files – if you don't have any

printer installed on your computer the screen driver will be used to generate PDFs.

PDF output anomalies are often caused by bugs in proprietary drivers from printer manufac-

turers. If you experience problems try installing a standard driver for a common printer from

the Windows CD and selecting it here. This doesn't have to be a driver for a printer that is

physically connected to your computer.

Problems with the reference driver used for generating PDF output can also result in incorrect

displays for special characters and international languages. However, if you experience prob-

lems like this first check the language settings  of your project to make sure that everything

is set up correctly. If you still have problems in  your PDF output after making sure that your

language settings are correct you can try using a different reference printer driver.

If you are not using WMF or EMF graphics it is generally best to use the screen device to gen-

erate PDFs. A proper printer driver is needed to mange EMF and WMF graphics, however –

otherwise these graphics may be clipped in your PDF output.

1400
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Use screen as refer-

ence device:

Uses the computer's screen driver as the reference device for

PDF output. Help+Manual defaults to this setting if you have

no printer installed. This option is generally preferable unless

your projects contain EMF or WMF graphics. If you use EMF or

WMF graphics you should choose a printer driver, otherwise the

graphics may not display or may be clipped.

Use default reference

device:

Uses the default printer driver for PDF output. Leave this setting

selected if your PDF output is OK.

Use this printer driver

as a reference device:

Use this to select an alternative printer driver to use for PDF

output. Click on the  browse button to select the printer.

See also:
Project Configuration Settings

Options & Keyboard Shortcuts

11.1.7 Program Options - Version Control

These settings enable and configure support for version control systems. 

1400
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Custom scripting

See Scripts and Customization  for details on customizing the scripting interface with

your version control system.

889
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Subversion, Git: Enable or disable support for Subversion and Git. 

Path to VCS EXE: Reference to the program that has to be called to perform syn-

chronization with your version control system. With SVN this

will be the Tortoise client's svn.exe in the \bin\ sub-folder

of the Tortoise program directory. With Git it is git.exe in the

\bin\ sub-folder of the Git program directory. 

Command file: The command scripting file called by Help+Manual to perform

the synchronization operations.  The standard files are stored in

the \Tools\ sub-folder in the Help+Manual program direct-

ory. 

Don't edit those files directly. If you want to customize syncing

operation, please create your own separate file and use the al-

ternate Custom Command File option.

Custom Version Con-

trol:

This provides the option to interface with a different version

control system. 

Sub-folder:

The sub-folder in your project folder that contains your version

control system's syncing data.

Command file:

This file contains all the commands for interfacing with your

VCS, including the paths and references to any programs it

uses. A standard command file you can use as a template is

provided in the \Tools\ sub-folder in the Help+Manual pro-

gram directory. 

11.2 Workspace, Toolbars and Dialogs

This section provides a reference to the individual controls in the Ribbon Toolbar and their as-

sociated dialogs. 

Only dialogs that need explaining are documented

Please note that although this reference is quite complete, only dialogs that really need

explaining are documented. We try not to waste your time with things that are really obvi-

ous and self-explanatory.
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You can create keyboard shortcuts for most Ribbon tools

Most of the tools in the Ribbon can also be accessed with keyboard shortcuts. To view, as-

sign and change your keyboard shortcuts select Program Options in the View tab.

11.2.1 The Workspace

The Help+Manual workspace has three main components that are immediately visible: The

Ribbon Toolbar where you access all program functions, the Project Explorer for navigating

and managing your projects and the Editor where you edit the content of your projects. 

In addition to this, the File menu in the blue tab on the left reveals a fourth component called

"backstage view". This completely hides both the Project Explorer and the Editor, providing

plenty of the space for the dialogs and interactive assistants needed by the functions in the

File menu.

The Ribbon Toolbar

The Ribbon Toolbar is the control center where you access virtually all of Help+Manual's

functions. If you  use Microsoft Office you will already be familiar with the Ribbon inter-

face. It is context-sensitive, automatically displaying functions relevant to what you are

currently doing.

Tip: The Ribbon can also be operated almost entirely via the keyboard. To display the ac-

celerator keys just press and release the ALT key once – the keys will be displayed in icons

superimposed on the Ribbon.
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The Project Explorer and Editor

The Project Explorer is like Windows Explorer for Help+Manual projects. When you load

or create a project all its contents are displayed here, including both the topic files it con-

tains and all the settings and configuration options. You can load multiple projects in the

Project Explorer and copy and paste between them.

The Editor is where you edit your topic content, and project settings dialogs. To edit a

topic you just select the topic in the Project Explorer and start editing in the Editor, which

works very much like a normal word processor. To edit project settings you just select the

settings in the Configuration section of the Project Explorer. 

The File Menu

The File menu  in the highlighted tab at the left end of the Ribbon is the fourth main

workspace element. When you click on it, it replaces the entire program window with the

"backstage view". It provides access to major functions requiring large, interactive dialogs

with lots of information and configuration options. This is where you open existing pro-

jects, create new projects, publish and print your projects, save your projects with other

names and in other formats and so on. The functions include:

· Open, Close, Save and Exit (normal file menu functions)

· Save As (save projects with different names and in a number of different formats, in-

cluding extended formats like skins and style repositories)

· Program Options (global Help+Manual configuration options)

1281
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· New Project (create new Help+Manual projects, either empty or by importing existing

data)

· Publish (output your projects to any of the supported formats)

· Import (import data into the current project)

· Version Control (options for integrating your project in a supported version control

system)

· Print Manual (generated a printed manual from your project)

· Repository Manager (register style repositories created with Save As.. so that you can

link them to your projects)

The Quick Access Toolbar

The Quick Access Toolbar at the left end of the main program title bar provides access

to your most frequently-used tools. It is fully configurable. Just click on the drop-down

icon to the right of it to add or remove functions. 

By default the QAT includes the New, Open and Save tools and also the Back and Forward

tools that navigate through the topic files and other Project Explorer items you have vis-

ited in your current editing session. 

See also:
The User Interface

Using the Project Explorer

Editing Topics

11.2.2 The Topic Options Tab

The Topic Options tab is accessible on the left of the main editor window and contains a num-

ber of key settings for the topic currently displayed. It enables you to view and edit a number

of settings that are assigned automatically when you create topics, and some additional op-

tional settings.
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<TITLE> tag: This is the text inserted in the <TITLE> tag in topic pages in HTML-

based output. By default this is the text displayed as the table of

contents entry displayed in the Project Explorer on the left. If you

edit the TOC entry this text changes automatically, unless you edit

this field in Topic Options manually.

If the topic header text in the box above the editor is different from

the TOC entry, the TOC entry is shown here and not the topic

header text. (Again, only if you didn't edit the title tag text manu-

ally.)

Topic ID: The address of the topic. This is used for referencing topics for links

etc. and it is also used for generating the file names of HTML files

generated for topics in HTML-based output formats.

You can change the topic ID by editing this entry. When you do

this, all the references to the topic within your project are updated

automatically. 

External references to the topic from other projects and other web

pages linking to your WebHelp cannot be updated from within

Help+Manual. They will become invalid if you change the topic ID

and must then be updated. 
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Anchor: Target of the TOC entry for the topic. Normally this is the top of the

topic, but if there are anchors defined in the topic you can select

one here. Then the TOC entry will scroll down to the anchor when it

is selected.

This option is normally only used for topics with multiple TOC

entries . Then each entry can link to the appropriate part of the

topic. Don't let this possibility tempt you to make excessively long

topics – that is generally a bad idea. Normally, it is much better to

have a separate document for each topic.

Topic class: There are two possible classes: Default and Popup. Most topics will

be default topics. The popup class can only be selected for topics

that don't have TOC entries, because popup topics are not allowed

to have TOC entries. See Creating popup topics  for details. 

Help context: Optional numeric context IDs for use in Microsoft HTML Help/CHM

files. You only need these if your programmers are using context

IDs for references from your application to the CHM help file. See

the chapters on context sensitive help  and the Help Context

Tool  for more details.

HTML Page Tem-

plate:

This selects the HTML layout template to be used for this topic in

HTML-based output formats. Normally this will be the standard De-

fault template. You can only select additional templates here if you

have defined them yourself . 

Topic Status: This just provides another way to select and set the status for the

current topic  displayed in the table of contents in the Project Ex-

plorer on  the left. This is design-time only – the status is not expor-

ted to your output. 

Keywords: The index keywords associated with the topic. You can enter them

directly here or centrally with the Index tool  (Professional and

Floating license versions only).

A-Keywords: These are special "associative" keywords that are only supported in

the Microsoft HTML Help/CHM help format. See this topic  for

more details on this.

Description: An optional description of the topic. This has two uses:

1. Source for the description meta tag  for search engine

optimization in WebHelp. 
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2. Future use for alternative table of contents layouts with de-
scriptions and images as well as titles.

Featured image: This allows you to associate an image with the topic that can then
be used in topic templates and PDF title pages for chapters. 

In HTML templates you can use the TOPIC_PICTURE  variable
to insert the images in your templates. 

See the help of the Print Manual Designer program for details on
how to use the featured images to create title pages for chapters in
PDF output.

Topic variables: This table can be used to change the definition of user-defined or

global variables for the current topic only. See this topic for de-

tails .

11.2.3 The XML Source Tab

This tab allows you to view and edit the XML source code of the current topic (Professional

and Floating license versions only). You will almost never need to use this when working on

projects. 

Only edit the XML if you are familiar with the H+M XML schema

Although XML looks similar to HTML at first glance it is actually totally different. It is also

100% strict and does not tolerate even the smallest syntax error. If you make any edit that

does not conform to the Help+Manual XML schema, the editor will silently delete your ed-

its when you return to the main topic editor or move to another topic.

See XML and XML Editing  for more information on this subject.

1573
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11.2.4 The File Menu

The File menu  provides access to major functions requiring large, interactive dialogs with

lots of information and configuration options. This is where you open existing projects, create

new projects, publish and print your projects, save your projects with other names and in

other formats and so on.

The following entries are only described briefly here. See the links in the descriptions for full

details.

Open, Save, Save

As, Close, Exit:

Open an existing project, save or close the current project, exit

Help+Manual.

Recent Projects: Select a project you have worked on recently.

New Project: Create a new Help+Manual project; either a completely new project

or with data imported from another source. See Creating Pro-

jects  for full instructions.

Import: Import data from other documentation formats to the current pro-

ject. See Importing data into existing projects  for details.

Version Control: Connect the current project to a version control system or down-

load a working copy of a Help+Manual project from a version con-

trol repository. See Using Version Control Systems .

1281
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Print Manual: Print the current project as a formatted paper manual. See PDF and

Printed Manuals .

Repository Man-

ager:

Manage Style Repositories for sharing Help+Manual stylesheets

and snippets between multiple projects. See Working with Style Re-

positories .

11.2.4.1 Recent Projects & Workspaces

Recent Projects

Click/select: Open the selected project in the current instance of

Help+Manual.

Pin icons (on right) "Pinning" a project entry moves it to the top of the list for

easy access.

RIGHT-CLICK MENU: Open in new instance:

Open the project in a new copy of Help+Manual.

Add to / Remove from pinned projects:

Moves the entry to the top of the list for easy access or re-

moves the entry from the pinned list (same as pin icon).

Remove from list:

Prune the list by removing the current entry completely.

Move Up/Down:

Arrange the list to suit your preferences

Quickly access recent

documents:

Shows the select number of recent documents from the top

of the list in the File Menu. 

1. Use the pin icons to move the projects you want to man-

age to the top of the list. 

2. Activate quick access to enter these projects in the File

Menu.

Workspaces

Lists the workspaces  you have created so that you can select them.

11.2.4.2 Publish

This option outputs or "publishes" the current project to any of the help and documentation

785
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formats supported by Help+Manual. The Publish options page changes depending on the

output format you select.

The Publish Help Project page:

This page is displayed when you select the Publish tool in the Project tab or Publish in the

File menu. 

The options displayed depend on the publishing format selected.

The Task Manager

The Task Manager (button at upper right) is used to generate multiple output formats and

project versions in a single operation. You can save "tasks" and reuse them to publish

multiple versions and formats in one quick process. See Automating Publishing Jobs

for full details.

809
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Publish multiple versions and formats with the Task Manager

Common features:

Publish Format: Select the format for your published documentation. You can

choose any format supported by Help+Manual at any time. Any

project can always be published to any format.

The options displayed in the Publish page depend on the publish-

ing format selected.

Output file and

path:

Where you want to generate your output and the name of the out-

put file. By default Help+Manual uses your project directory and

the project name. You can change this here whenever you like,

however. When you do this the program makes all necessary in-

ternal changes automatically. Your setting is stored for your project

and displayed the next time you publish.

You can use the  browse button to navigate to a different output

directory.

Include Options: These options are used in combination with Help+Manual's condi-

tional output features.  Topics and content that are "tagged" with

the options you select here will be included in your output, those

that don't match will be excluded from your output. Please study
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Conditions and Customized Output  before using!

Current format:

By default the include option for the selected output format is

preselected. If you also select other options you must leave the cur-

rent format option selected, otherwise only the content matching

the other options will be included.

Skin include options:

If you select a skin for publishing to WebHelp or HTML Help/CHM

any include options stored in the skin will be displayed in a separ-

ate box. Skin authors often use these options for activating features

available in the skin.

Table of Contents: Active if you have defined at least one additional Table of Contents

(TOC) in your project. You can then select which TOC you want to

publish your project with.

Publish selected TOC items only:

Displayed in the Table of Contents menu if one or more topics in

the TOC are selected. Activating this option only outputs the topics

currently selected in the TOC. 

Publish topics with

status "Complete"

only:

Only exports topics with the status  "complete" to your published

output. This enables you to prevent topics that are not yet finished

from being included in your output. 

Important: This will only work if you are actually using topic

status  to mark your topics while working in the TOC.

Display file when

complete:

Automatically displays the output file as soon as it has been gener-

ated, using the appropriate viewer.

HTML Help settings:

Select Skin: Allows you to select a .hmskin skin file  to replace the entire

design of a project while publishing. This allows you to apply a

completely different layout and "branding" to your project with a

single click. You can save the current project as a skin with Save As

in the File menu.

Delete temporary

files:

Selected by default. Normally all the source files generated to pub-

lish HTML Help are deleted. If you deselect this you can view the
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source files in the \~tmphtml directory, which you can find in your

project directory.

Webhelp settings:

Index page: The default index page for WebHelp is index.html. You can

change this here, along with the output path. This is not recom-

mended, however. If you use the standard index.html name

browsers will automatically display the help if the user just access

the path, without an index file name. Help+Manual remembers

your setting for the current project.

Select Skin: Allows you to select a .hmskin HTML skin file  to replace the

entire design of a project while publishing. This allows you to apply

a completely different layout and "branding" to your project with a

single click. You can save the current project as a skin with Save As

in the File menu.

Delete all files in

output folder:

Clears all the files in the output folder before publishing. Use this

when you are producing a distribution build to ensure that the

folder only contains the files related to the current version of your

project. Otherwise the directory may contain HTML files for topics

that you have already deleted in your project, left over from previ-

ous compiles. These files take up unnecessary space and are also

indexed by the indexer and included in the full-text search function,

which is something you want to avoid.

Always use this function if you change the title of your project as

this also changes the names of all the output files associated with

the full-text search  function. If the old files are present the in-

dexer may attempt to index them, which can cause errors.

Sub-folders: This option only deletes files in the output folder, it

will not delete sub-folders.

Adobe PDF settings:

Print manual tem-

plate: 

Selects the .mnl print manual template  file to be used to gener-

ate the PDF file. This template file defines the PDF layout, generates

the print-style table of contents and the index and adds a number

638
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of additional pages and other features like headers, footers, page

numbers etc. You can edit your templates with the Print Manual

Designer  included with Help+Manual. 

Highlight hotspots: For testing only. Displays outlines around the hotspots and links in

your PDF output. Dead links and hotspots to missing targets are

also highlighted. 

Publish PDF with

design comments:

Publish the comments from your project (normally never exported)

as annotations in the PDF. This can be useful for distributing PDFs

for proofreading and commenting in a team. 

eWriter Help for Windows and MacOS

Since eWriter Help files are WebHelp packaged with an integrated viewer, you will gener-

ally select a WebHelp skin for publishing this format. 

See eWriter Help  in the Publishing chapter for details on preparing your projects for

publishing this type of help file. 

Kindle/Mobi and ePUB eBook settings

There are no special Publish screen settings for Kindle/Mobi and ePUB eBooks. 

See Kindle/Mobi and ePUB 3.0 eBooks  for details on configuring your projects for

these output formats.

MS Word DOCX Settings

The only setting here is the selection of the layout template for your DOCX output, which

is a special DOCX file. 

See MS Word DOCX  for instructions on how to prepare and use these templates.

Visual Studio Help settings:

Visual Studio Ver-

sion:

Only relevant for documenting programming components in the

Visual Studio .NET programming environment. Cannot be used for

documenting normal user applications.
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You can choose both Visual Studio 2008/HXS and Visual Studio

2010/MSHC formats. The HXS format requires installation of a spe-

cial compiler from the Visual Studio 2008 .NET package. See Visual

Studio Help  for details. 

Do not compile: Visual Studio 2008/HXS only.

This is a special debugging option for Visual Studio Help 2008 (MS

Help 2.0/HXS) only. Instead of publishing a finished .HXS file it

generates a .HWProj  project file that you can open and compile

manually in Visual Studio .NET. For details see About publishing VS

Help .

Delete temporary

files:

Selected by default. Normally all the source files generated to com-

pile Visual Studio Help are deleted. If you deselect this you can view

the source files in the \~tmphxs directory, which you can find in

your project directory.

See also:
Conditions and Customized Output

11.2.4.3 Save As

Save the current project in another name and/or location and in a different format. You can

use this option to switch between the single-file compressed format (HMXZ) and the uncom-

pressed XML format (HMXP, only available in the Professional and Floating license versions).

Both these formats have exactly the same contents, the HMXZ format just packs the compon-

ent files into a single compressed archive file (zip format).

Modular Projects
When you select Save As.. in a modular project

Help+Manual always saves the master project. You

must edit child projects separately if you want to save

copies of them.

In addition to this you can also save your project as a skin or a style repository.

Help Project

(single file):

Save the current project in compressed, single-file format (HMXZ).

This is the only format available in the Basic version of

Help+Manual. Same contents as the uncompressed HMXP format,

1464
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with all files saved in a compressed zip archive with the extension

.hmxz.

Help Project (un-

compressed XML):

Professional and Floating license versions only. Save the current

project in uncompressed XML format (HMXP). Required for multi-

user editing and linking to version control systems. You must save

in an empty folder, although you can add other sub-folders your-

self later. All the files are plain-text XML, including the main HMXP

project file.

Skin XML file: Professional and Floating license versions only. Save the current

project as a skin. You can then apply the templates, styles, variables

and layout it contains to other projects on publishing by selecting

the skin file in the Publish dialog. See Transforming your output

with skins  for details.

Save as a Reposit-

ory:

Professional and Floating license versions only. A style repository is

a special uncompressed HMXP project without a table of contents.

Linking it to a project makes the styles and topics in the style repos-

itory available in the project. This enables you to share a common

set of styles between multiple projects and use the topics in the

project as snippets, together with the styles they are defined with.

See Working with Style Repositories  for details.

Rescue Copy: The earlier Rescue Copy option has now been replaced by an auto-

matic rescue copy for drive system failures and an ongoing back-

ground backup of unsaved edits for recovering from system

crashes. 

Automatic rescue copy

If you are unable to save your project because the drive it is stored

on becomes unavailable or unresponsive Help+Manual will display

an automatic rescue copy option that will allow you to save those

topics with unsaved edits to a special copy of the project containing

only those topics. You can then copy your changes back to the

main project when it becomes available again.

Ongoing background backup

All your unsaved edits are stored in a background backup until you

successfully save your project. If your computer or Windows
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crashes or you experience some other catastrophic event that pre-

vents you from saving, Help+Manual will offer to restore your un-

saved edits from the Rescue Copy the next time you open the pro-

ject. 

See Backups and Emergencies  for more details on both these

features.

11.2.4.4 Print Manual

These options are for generating a printed manual directly on a connected printer. You can

preview before printing with the Preview options. In addition to normal printing it also sup-

ports booklet printing with multiple pages per sheet and fold/cut options. 

If you need to have a manual printed professionally by a service provider you should create a

PDF file with Help+Manual's PDF output options .

Print options

Printer: The printer you want to use.

608
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Print Manual Tem-

plate:

The Print Manual function uses the same templates  as the PDF

output function. Click on the drop-down menu below the printer

selection and then select your .mnl print manual template file with

Open Template.. or select Start Manual Designer to open the cur-

rent template in Manual Designer. (This program has its own separ-

ate help.)

Table of Contents: Active if you have defined at least one additional Table of Contents

(TOC) in your project. You can then select which TOC you want to

print your project with.

Publish selected TOC items only:

Displayed in the Table of Contents menu if one or more topics in

the TOC are selected. Activating this option only outputs the topics

currently selected in the TOC. 

Include Options: These options can be used in combination with Help+Manual's

conditional output features. Topics and content that don't match

the selections you make here will be excluded from your output.

Please study Conditions and Customized Output  before using!

If no options are selected the Include Options list is highlighted in

red to indicate that no output will be generated. 

Current format:

By default the include option for the selected output format (Print

Manual) is preselected. If you also select other options you must

leave the current format option selected, otherwise content tagged

for the current format will be excluded!

Text and Links: Options for controlling how colored text and hyperlinks are to be

displayed in your output. Set accordingly for monochrome or color

printers.

Print links with

page referrers:

Prints hyperlinks with "page referrer" cross references. These little

icons showing the page number of the referenced topic.

Settings - scaling

and booklets:

Page scaling or booklet printing. Select Normal (1:1) for best quality

in normal printouts. 

Print cut marks:

Prints professional printer-style cut marks for trimming your output

1019
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Settings - pages

output:

All pages, current page, odd pages, even pages, defined page

range.

Page Range:

Enter the numbers of the pages you want to print separated by

commas (example: 12,42,49). Note that all page range numbers

refer to the sequential numbers of the sheets of paper in your out-

put, not to the numbers shown on the pages, which may be differ-

ent. Use Print Preview  to check the numbers of the pages to out-

put.

Preview options and settings

The Print Preview function previews your printout on the computer screen. The options

are exactly the same as in the first screen of the normal Print Dialog.  Print Preview is

extremely fast, you can use it for a quick preview of your project layout.

Unsupported functions in preview mode:

· Selection by page number and booklet printing options are not supported in Print Pre-

view mode. Selected Topics in the Include Options section works, however.

· Page numbers are not displayed in the page referrers  (cross references to page

numbers for links) in Print Preview mode. The page referrer icons are shown, but they

are empty. This is not an error. The referrer numbers can only be generated when you

actually output to a printer.

See also:
Print Preview

Conditions and Customized Output

11.2.4.5 Import

The Import option allows you to import data from external sources into the current project in-

stead of into a new project. It opens the regular Import page. See Importing data into existing

projects  for details.
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11.2.4.6 Style Repository Manager

The Repository Manager is used for registering style repository projects in your Help+Manual

configuration and removing them. Style repositories must be registered with your copy of

Help+Manual to be used. After registering, you can then use them in your projects. See Work-

ing with Style Repositories  for full details.

Add: Select a .hmxr style repository project and add it to the re-

gistered lists of repositories for your copy of Help+Manual. You

must add a style repository to the list before you can link it to a

project. 

Remove: Remove (de-register) a style repository from your Help+Manual

configuration. This does not delete the style repository project.

1076



1294

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Reference

It just removes its registration from your copy of Help+Manual.

Use this repository: Link a repository:

Use this list to link a style repository to the current project selec-

ted in Help+Manual. 

Unlink a repository:

Select Project does not use a style repository at the top of the

list to unlink the repository from the project selected in

Help+Manual. 

Link styles: When you select this option the styles in the style repository are

actively linked to the Help+Manual project. When the styles are

updated in the style repository they are automatically updated

in the linked project. 

The styles are locked in the project and cannot be edited there.

They can only be edited in the style repository project. 

Use this option to manage styles centrally for multiple projects

and projects edited by multiple authors. 

Copy styles: This option simply copies the styles from the style repository to

the project. The styles can then also be edited in the project. 

Use this option for more "relaxed" style management: Create a

project basing its styles on the repository styles, then make any

additional style changes in the project rather than in the style

repository. 

See also:
Working with Style Repositories 1076
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11.2.4.6.1  Resolve Styles Dialog

This dialog appears when you unlink a repository from a project or switch your project's re-

pository association from one repository to another one. In both cases Help+Manual needs to

know what you want to do with the styles that the original repository was sharing with your

project.

By default all styles will be removed when you unlink a repository. If you want to keep styles

click on the "Yes, remove style" text in the Remove column to switch it to "Keep".

Remove style: This is the default option. The style will be deleted from your pro-

ject stylesheet and any text formatted with the style will be reset to

"Normal" formatting, without a style association.

Keep style: A copy of the style will be kept in the project stylesheet. Any text

formatted with the style will retain its association with this style. 

Keep All / Remove

All

This button switches the entire list between "keep" and "remove".

See also:
Working with Repositories 1076
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11.2.5 The Project Tab

This tab contains all the tools used for managing topic files and managing and publishing

projects. In addition to this it includes a copy of the clipboard tools available in the Write tab

and links to the external tools included with Help+Manual.

Note that the standard file functions (Open, Close, New etc.) are accessed in the File menu .

See also:
Publishing Your Projects

11.2.5.1 Clipboard

The Clipboard group contains a standard set of tools for using the Windows clipboard (Copy,

Cut, Paste, Paste as Text). You can use the clipboard tools for copying both content in topics

and for topics and chapters in the Project Explorer. 

Remember that Drag & Drop also work both in the editor and in the Project Explorer, also

between different projects.

Special Paste Commands:

Paste as Text:

Ctrl+Shift+V

· Pastes copied text as plain text, without any formatting (bold, un-

derline, graphics etc). 

· Use if you want to copy text without any formatting from other

topics, projects or other programs such as MS Word or a web

browser. 

· This feature is also useful for pasting text into paragraphs format-

ted with styles without transferring the style of the copied text

into the target paragraph.

Paste HTML: · Paste material copied from HTML pages into Help+Manual.

· Use for copying formatted text, images etc. from web pages into

the Help+Manual editor.

· When copying from some graphics programs this can be used to

paste transparent PNG and GIF images from the clipboard

without losing transparency. See Inserting Graphics and Screen-

shots  for details.

See also:
Copying, cutting and pasting text  

Moving cutting and pasting topics
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11.2.5.2 Manage Topics

The Manage Topics group contains all the main functions for creating topics and manipulat-

ing them in the Table of Contents (TOC) and Project Files sections of the Project Explorer. 

Several of the options in this menu already have keyboard shortcuts. You can assign shortcuts

to the other options yourself in View > Program Options > Shortcuts.

Topic group options:

Add Topic / Add

File:

Name changes depending on whether you are in the TOC or

Project Files.

· Create new topics, chapters and topic files.

· Delete topics, chapters and topic files

Explore · Expand and collapse branches in the Project Explorer

· Filter Explorer display by build options

· Disable Drag & Drop in Explorer to prevent accidental edit-

ing

· Open selected topics in a new tab

Change: · Set build options for topics and chapters

· Change the item status (colored highlight in the TOC)

· Change the icon displayed for the item (not supported in all

output formats)

· Convert a topic to a chapter without text and vice-versa

Find: · Locate topics by ID and help context numbers

· Locate topics containing links to the current topic

File: · Load topics from external XML file, and from RTF, RVF, HTML

and TXT files

· Save topics as XML files or reusable snippets  (text blocks

in external files).

· Reload (refresh) the current topic, for example to display up-

dated images.

· Move selected topics around in the TOC (up/down)

· Promote and demote topics in the TOC (left/right)

· Edit topic caption

· Print topic

See also:
Creating and Editing Topics

Managing the TOC and Topic Files
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Options & Keyboard Shortcuts

11.2.5.2.1  Add Topic/File

Creates a new topic file in the Table of Contents (TOC) or the Project Files section. See Creat-

ing new topics .for more details.

Insert New Topic or Chapter dialog:

This dialog is displayed when you select one of Add Topic options. It creates a new topic, a

new chapter or a TOC item linked to web page or another help file.

 

Topic /Chapter:

Creates a new topic with a TOC entry (in the TOC) or a new topic file without a TOC  entry

(in Project Files). The topic automatically becomes a "chapter" as soon as it has sub-top-

ics. 

When you select the function in the Project Files section you can only add topic files, no

other options are available.

Position: Position of the new topic in the TOC relative to the current topic.

59
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Topic heading: The title of the topic in the TOC. This text is also entered as the

topic header (in the box above the editor). 

Topic ID: This is the "address" of the topic. It is never seen by the user and

must be unique. It is the XML file name of the topic file and used to

generate the HTML file name for the topic in HTML-based output

formats.

Use only English ASCII characters and numbers. Foreign characters,

spaces and special characters will cause problems in some output

formats.

HTML template: The HTML page template  to be linked to the topic. This will usu-

ally be Default unless you have created additional templates. 

Topic Class: Whether the topic is a normal topic or a popup topic. You can only

select the Popup class in the Topic Files section of the Project Ex-

plorer. You cannot create popup topics in the Table of Contents

section.

Create in : The folder in the Project Files section where you want to store the

new topic file. 

Topic template: Normally new topics are empty. If you wish, you can specify a tem-

plate file  here containing standard text, tables, images and any

other content. You must create template files first, otherwise noth-

ing will be displayed here.

TOC Icon: Select the icon for the topic in the TOC. In WebHelp the custom

Help+Manual icons will be used. Microsoft HTML Help CHM files

can only use the standard Microsoft CHM icon set, which

Help+Manual matches to the most similar custom icons.

Multiple topics:

Allows you to enter multiple topics at the same time, for example by pasting a list of topic

titles that you want to use as captions. Each line of text entered in the Item Captions: field

will create a new topic with that text as the caption in the TOC. The topic IDs  are gener-

ated automatically from the caption texts.
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Position: Position of the first new topic in the TOC relative to the current

topic.

Headings: Each line of text you enter here creates a new topic. 

Press Enter to create a new topic line.

Press Tab or use the indent buttons on the right to create sub-top-

ics.

Create In: The folder in the Project Files section where you want to store the

new topic file. 

Topic Template: Normally new topics are empty. If you wish, you can specify a tem-

plate file  here containing standard text, tables, images and any

other content.

TOC Link: Link to web address or an existing topic

This option can create two types of links:

1016
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Link to a topic in this project:

Creates an additional link to an existing topic in the current project. See Multiple TOC

entries for one topic  for more details on this subject.

Link to a web address:

Instead of displaying a topic this displays a web page with the URL you enter here. You

must include the http:// prefix if the address, otherwise it won't work.

After creating the TOC entry you can specify the target of the link on the right:

TOC link targets in different output formats:

WebHelp: Web links in the TOC are no longer recommended for WebHelp. In

the future, they will not work in responsive, single-page layouts be-

cause there is no topic frame where a web page can be loaded.

They will just open in a new window instead.

· Topic frame displays in the topic frame, if there is one. Otherwise

it will open in a new browser page or tab.

· Top frame replaces the WebHelp entirely with the linked web

page.

· New window opens the link in a new browser window or tab.

HTML Help/CHM: Web links in the TOC always open in the topic frame in CHM files.

The target window setting is ignored.

eWriter Help: Web links in the TOC are not recommended in eWriter Help. They

can be opened in the topic frame but the embedded browser will

often not provide good results with external websites. It is much

371
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better to put web links in the body of your topics and configure

them to open in an external browser window in the eWriter set-

tings . 

PDF and Word

DOCX:

Web links in the TOC are not supported and are ignored in these

formats. The TOC entries are not included in the TOC.

Kindle/Mobi ePUB

eBooks

Web links in the TOC are not supported and are ignored in these

formats. The TOC entries are not included in the TOC.

Visual Studio Help: Web links and external links in the TOC are not permitted in these

formats. The TOC entries are not included in the TOC.

Link to External Help (CHM only!)

Instead of creating a new topic file this creates a TOC item that is a link to a topic in an-

other CHM help file. When the user clicks on the TOC entry the topic from the other help

file is displayed. 

This only works in HTML Help! 

The target topic must be the same format as the main help file – you can't link between

help files of different formats.

Position: Position of the chapter node in the TOC relative to the current

topic.

Heading in Table

of Contents:

The title of the item in the TOC. 

Help file: The Help+Manual project file (.hmxp, .hmxz) or the help file

(.chm) containing the topic you want to link to.

Target topic: The topic you want to link to.

Web Link:

Creates a topic that references a web page on the Internet:

· In eBooks selecting the topic in the TOC opens the referenced web page in an external

browser window. 

1477
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· In HTML Help and WebHelp selecting the topic the page can be opened inside the

help viewer, as part of the help, or in an external window. 

· In PDF and Word DOCX the topic is ignored and is not included in the output.

Position: Position of the item in the TOC relative to the current topic.

Heading: The title of the item in the TOC. 

Target address: The URL of the HTML page you want to link to. If this is not a local

file you must enter the fully-qualified URL, including the http:// pre-

fix. 

Include Help Project:

Inserts a placeholder for another Help+Manual project, turning the current project into a

master/parent project. When you publish the master project the TOC of the child project

will be added to that of the master project. 

Position: Position of the first topic of the external project in the TOC relative

to the current topic.

Project file: The the .hmxp or .hmxz project file that you want to include 

Merge content on

publishing /

runtime:

These settings are only relevant for HTML Help (CHM). All other

formats are always merged when they are published.

For more details see Working with Modular Help Systems .

Merge content on publishing: 

This merges the selected project with the project you are inserting

it. The result is integrated help that is the same as help produced

from a single project. You do not have to publish your child pro-

jects separately when you use this method. However, you must

take steps  to ensure that you do not have duplicate topic IDs

and help context numbers in your projects, otherwise you will ex-

perience unexpected errors in your help.

Merge content at runtime:

Supported in HTML Help (CHM) only. This merges the child help

file modules into the TOC of the master when the help is opened

on the user's computer. The child help files must be published sep-

arately. If these help file modules (CHM) are present in the same

1088
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folder as the master help file their TOCs will be merged with the

master TOC and the effect is the same as one help file containing

all modules. If the modules are not present on the user's computer

they will not be included in the TOC. 

See also:
Creating new topics

Content templates for topics

11.2.5.2.2  Explore

This sub-menu contains options that control the behavior of the Project Explorer.

Expand / Collapse

These options expand and collapse the Table of Contents and Topic Files display in the

Project Explorer.

Filter 

This allows you to filter the Table of Contents display on the basis of your build op-

tions/include options. It will only have any effect if you have actually assigned build op-

tions to your topics. See Conditions and Customized Output  for more details. 

Note that this function only filters topics in the TOC, it does not filter content in your top-

ics tagged with build options using the Conditional Text tool.

Disable Drag & Drop in Explorer

This protects your TOC against accidental changes with the mouse. This can be useful

when you are just editing your project and are no longer making any changes to the TOC.

Open Topic in a New Tab

Open the current topic in a new tab in the Help+Manual editor.

11.2.5.2.3  Change

The options in this sub-menu are for changing the properties and functions of selected TOC

items and topic files (some functions are only available for TOC items).
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Include in Builds

Sets or clears conditional build/include options for the selected TOC items or topic files.

This feature is used to include or exclude topics from your published output. You can do

the same for content inside your topics with the Conditional Text  tool. See Conditions

and Customized Output  for details. 

Topic Status

This is an editing aid. It allows you to "flag" topics in the TOC with colors associated with

"status" name as a reminder of the current editing status of the topic -- for example

"Needs Review" or "Out of Date". You can define your own status options with Define Cus-

tom Status and you can edit your status definitions in Configuration > Common Proper-

ties > Topic Status. 

Topic status is not exported when you publish, it is an editing aid only.

You can also use topic status to exclude unfinished topics from your output. Just select

the option "Complete Only" in the Publish  dialog and all topics with a status other than

Complete will not be exported when you publish.

You can also sort and group the display of your files by topic status in the Topic Files file

viewer – see Managing topic files in the Explorer  for details.

Change Icon

Allows you to change the TOC icon of the selected topics in the TOC. Only the displayed

icons are available in HTML Help (CHM) and eWriter Help. Topic icons are not supported

at all in ePUB eBooks.

If you want chapter icons to switch automatically between the "open" and "closed" ver-

sions you must use one of the first eight icons and make sure that "Automatic" is activated

in the Change Icon menu.

In WebHelp you can also use your own custom icons, which you can set in Configuration

> Publishing Options > WebHelp > Navigation.

Convert to Chapter without/with Text

Converts the selected chapter topic to a chapter with or without text. A chapter topic

without text is just an empty node in the Table of Contents and does not have any content

of its own or any properties. If you convert a chapter topic with text to a chapter topic

without text the text in the deleted topic will be moved to a new sub-topic. 
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Note: Chapters without text are deprecated in modern documentation and we do not re-

commend using them.

11.2.5.2.4  Find

This sub-menu contains options for locating topics in your project and links to and from se-

lected topics.

The Find Topic dialog:

· Typing text in the Select Topic: field automatically takes you to the first topic in the list

matching the text you type. (This does not work for help context numbers.)

· The topic IDs and help context numbers of modular child projects in your TOC are not

shown in the list.

Find Referrers:

This option displays a list of all links to and from one or more selected topics. It is nor-

mally displayed in the main program window but you can undock it by double-clicking on

its title bar. To redock just double-click again.

The Find Referrers report includes both normal links and links in graphics hotspots .

However, please note that the report does not include any references to topics that may

be contained in scripts, macros or plain HTML code  that you have entered yourself. 

Dialog options

Topic: The link address of the current topic. 

509
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Tip: All the links are active! You can navigate to all the topics and back

to the current topic by clicking on the links in the dialog. 

Is referred by: All the topics in the current project that refer to the selected topic.

Links to the topic from other projects are not included, even if the pro-

jects are included in the TOC of the current project as child modules.

Links to: All the topics in the current project linked to by the current topic. Links

to topics in other projects are not listed, even if the projects are in-

cluded in the TOC of the current project as child modules.

This list also includes references to any topics in which the current

topic is used as a snippet .

You can click on the topic ID links in the list to visit the topics and edit

them without closing the Find Referrers report.

Dialog toolbar

Returns you to the original topic after visiting other topics in the reports list. In-

active for reports including results for more than one topic.

Simple search function for finding text in the report window.

Copies text from the report window to the clipboard. (This does not select all the

text in the report - you must select text with the mouse first.)

Prints the report.

Saves the report to a file. The file is saved in HTML format.

See also:
Searching for text, topics and referrers

Find Topic

Find & Replace Text

11.2.5.2.5  File

This sub-menu contains options for saving and loading selected text and topics to and from

external files. You can save topics and selected text to Help+Manual XML files. You can load

topics from Help+Manual XML files and also from RTF, RVF, HTML and TXT files. 
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The Reload Topic command refreshes the current topic. This can be useful when you have

changed a graphics file on the hard disk and also when multiple users are working on the

same project (use together with Refresh Project in the Project tab).

Dialog options:

Load Topic from

file:

Create an empty topic before using! Overwrites the current topic

with the contents of an RTF, RVF, TXT, HTML or Help+Manual XML

file. 

Save Topic to File: Saves the entire topic to a Help+Manual XML file that you can use

as a snippet or load with Load Topic from File. Saves and loads the

topic's keywords with the topic file. 

Save Snippet: Text in topic selected:

Saves only the selected text to a simple Help+Manual XML file

without any keywords.

No text selected:

Saves the entire topic to a Help+Manual XML file along with

keywords (same as Save Topic to File).

Print topic: Sends the current topic to a printer.

Reload Topic: Reloads the current topic file in the editor. Refreshes graphics if the

graphic file has been changed and can also be used to refresh topic

lock status for multi-user editing. 

See also:
Reusing content with snippets

11.2.5.2.6  Mini Toolbar

The "mini toolbar" in the Manage Topics group is mainly for editing

the structure of your Table of Contents. You can move topics up and

down and also change the "level" of topics in the TOC – this is done

by "demoting" or "promoting" topics. In addition to this the mini

toolbar contains a function for editing the topic caption.

Mini toolbar functions

Move the selected topic up or down in the TOC. This doesn't change the cur-

rent level of the topic, it just moves it.

265
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Promote or demote the selected topic in the TOC hierarchy. "Promoting" (left

arrow) a topic moves it up to a higher level – for example it moves a topic out

of a chapter onto the same level as the main chapter topic. "Demoting" (right

arrow) moves the topic down to a lower level – for example making it the

sub-topic of a chapter.

Edit the TOC caption (title) of the topic. You can also edit the caption by click-

ing in the TOC and pressing F2 and by clicking twice slowly in the TOC.

11.2.5.3 Project

The Project group contains functions for publishing your project, jumping to bookmarks and

accessing your Project Configuration settings. 

Project group options:

Publish: · Displays the same Publish  dialog available in the File menu

· Clicking on the lower part of the icon executes a "Quick Publish" to

the selected output format, applying the last settings used. 

Print Manual: Displays the same Print Manual  page available in the File menu.

Bookmark: Displays a list of the bookmarks  defined in your project. Selecting a

bookmark in the list jumps to the topic containing the bookmark.

You can also add a bookmark to the current topic and delete book-

marks.

Options: Links to the different sections of the Configuration  section of your

project that is also available directly in the Project Explorer.

Refresh Pro-

ject:

Reloads the project and updates the TOC and editor display. This is

only active for multi-user editing  and projects linked to a version

control system  repository.

Version Con-

trol:

Only displayed in projects under recognized version control. Options

for synchronizing the project with the VCS repository and other related

functions. See Using Version Control Systems .

See also:
Project Configuration

Comments and Bookmarks
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11.2.5.3.1  Publish

This option outputs or "publishes" the current project to any of the help and documentation

formats supported by Help+Manual. The Publish options page changes depending on the

output format you select.

The Publish Help Project page:

This page is displayed when you select the Publish tool in the Project tab or Publish in the

File menu. 

The options displayed depend on the publishing format selected.

The Task Manager

The Task Manager (button at upper right) is used to generate multiple output formats and

project versions in a single operation. You can save "tasks" and reuse them to publish

multiple versions and formats in one quick process. See Automating Publishing Jobs

for full details.

809
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Publish multiple versions and formats with the Task Manager

Common features:

Publish Format: Select the format for your published documentation. You can

choose any format supported by Help+Manual at any time. Any

project can always be published to any format.

The options displayed in the Publish page depend on the publish-

ing format selected.

Output file and

path:

Where you want to generate your output and the name of the out-

put file. By default Help+Manual uses your project directory and

the project name. You can change this here whenever you like,

however. When you do this the program makes all necessary in-

ternal changes automatically. Your setting is stored for your project

and displayed the next time you publish.

You can use the  browse button to navigate to a different output

directory.

Include Options: These options are used in combination with Help+Manual's condi-

tional output features.  Topics and content that are "tagged" with

the options you select here will be included in your output, those
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that don't match will be excluded from your output. Please study

Conditions and Customized Output  before using!

Current format:

By default the include option for the selected output format is

preselected. If you also select other options you must leave the cur-

rent format option selected, otherwise only the content matching

the other options will be included.

Skin include options:

If you select a skin for publishing to WebHelp or HTML Help/CHM

any include options stored in the skin will be displayed in a separ-

ate box. Skin authors often use these options for activating features

available in the skin.

Table of Contents: Active if you have defined at least one additional Table of Contents

(TOC) in your project. You can then select which TOC you want to

publish your project with.

Publish selected TOC items only:

Displayed in the Table of Contents menu if one or more topics in

the TOC are selected. Activating this option only outputs the topics

currently selected in the TOC. 

Publish topics with

status "Complete"

only:

Only exports topics with the status  "complete" to your published

output. This enables you to prevent topics that are not yet finished

from being included in your output. 

Important: This will only work if you are actually using topic

status  to mark your topics while working in the TOC.

Display file when

complete:

Automatically displays the output file as soon as it has been gener-

ated, using the appropriate viewer.

HTML Help settings:

Select Skin: Allows you to select a .hmskin skin file  to replace the entire

design of a project while publishing. This allows you to apply a

completely different layout and "branding" to your project with a

single click. You can save the current project as a skin with Save As

in the File menu.
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Delete temporary

files:

Selected by default. Normally all the source files generated to pub-

lish HTML Help are deleted. If you deselect this you can view the

source files in the \~tmphtml directory, which you can find in your

project directory.

Webhelp settings:

Index page: The default index page for WebHelp is index.html. You can

change this here, along with the output path. This is not recom-

mended, however. If you use the standard index.html name

browsers will automatically display the help if the user just access

the path, without an index file name. Help+Manual remembers

your setting for the current project.

Select Skin: Allows you to select a .hmskin HTML skin file  to replace the

entire design of a project while publishing. This allows you to apply

a completely different layout and "branding" to your project with a

single click. You can save the current project as a skin with Save As

in the File menu.

Delete all files in

output folder:

Clears all the files in the output folder before publishing. Use this

when you are producing a distribution build to ensure that the

folder only contains the files related to the current version of your

project. Otherwise the directory may contain HTML files for topics

that you have already deleted in your project, left over from previ-

ous compiles. These files take up unnecessary space and are also

indexed by the indexer and included in the full-text search function,

which is something you want to avoid.

Always use this function if you change the title of your project as

this also changes the names of all the output files associated with

the full-text search  function. If the old files are present the in-

dexer may attempt to index them, which can cause errors.

Sub-folders: This option only deletes files in the output folder, it

will not delete sub-folders.

638
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Adobe PDF settings:

Print manual tem-

plate: 

Selects the .mnl print manual template  file to be used to gener-

ate the PDF file. This template file defines the PDF layout, generates

the print-style table of contents and the index and adds a number

of additional pages and other features like headers, footers, page

numbers etc. You can edit your templates with the Print Manual

Designer  included with Help+Manual. 

Highlight hotspots: For testing only. Displays outlines around the hotspots and links in

your PDF output. Dead links and hotspots to missing targets are

also highlighted. 

Publish PDF with

design comments:

Publish the comments from your project (normally never exported)

as annotations in the PDF. This can be useful for distributing PDFs

for proofreading and commenting in a team. 

eWriter Help for Windows and MacOS

Since eWriter Help files are WebHelp packaged with an integrated viewer, you will gener-

ally select a WebHelp skin for publishing this format. 

See eWriter Help  in the Publishing chapter for details on preparing your projects for

publishing this type of help file. 

Kindle/Mobi and ePUB eBook settings

There are no special Publish screen settings for Kindle/Mobi and ePUB eBooks. 

See Kindle/Mobi and ePUB 3.0 eBooks  for details on configuring your projects for

these output formats.

MS Word DOCX Settings

The only setting here is the selection of the layout template for your DOCX output, which

is a special DOCX file. 

See MS Word DOCX  for instructions on how to prepare and use these templates.
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Visual Studio Help settings:

Visual Studio Ver-

sion:

Only relevant for documenting programming components in the

Visual Studio .NET programming environment. Cannot be used for

documenting normal user applications.

You can choose both Visual Studio 2008/HXS and Visual Studio

2010/MSHC formats. The HXS format requires installation of a spe-

cial compiler from the Visual Studio 2008 .NET package. See Visual

Studio Help  for details. 

Do not compile: Visual Studio 2008/HXS only.

This is a special debugging option for Visual Studio Help 2008 (MS

Help 2.0/HXS) only. Instead of publishing a finished .HXS file it

generates a .HWProj  project file that you can open and compile

manually in Visual Studio .NET. For details see About publishing VS

Help .

Delete temporary

files:

Selected by default. Normally all the source files generated to com-

pile Visual Studio Help are deleted. If you deselect this you can view

the source files in the \~tmphxs directory, which you can find in

your project directory.

See also:
Conditions and Customized Output

11.2.5.3.2  Bookmark

This option displays a list of the bookmarks in your current project and allows you to add new

bookmarks. Bookmarks mark topics, not positions within topics. You can only add one book-

mark to any one topic.

You can jump to the bookmarks by selecting them in the list. 

To create a new bookmark just select Bookmark Current Topic. By default the topic title is

used as the bookmark title but you can change this if you want.

Automatically creating bookmarks for comments:

You can configure Help+Manual to automatically create a topic bookmark for every com-

ment you insert. Open Program Options in the File menu and activate the option Automat-

ically manage topic bookmarks for every comment. Then a bookmark with a pin in the

Table of Contents will be added for every comment you create. These bookmarks can be

viewed and accessed with the Bookmarks tool in the Project tab.

1464

1135

969
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See also:
Comments and bookmarks

11.2.5.3.3  Options

This provides links to the main configuration sections for your project in the Project Explorer.

These links are just a convenience, all the sections can be accessed directly in the Configura-

tion section of the Project Explorer. 

See Project Configuration .

11.2.5.4 Tools

The Tools group provides direct access to a variety of tools included with Help+Manual, in-

cluding a full-featured graphics editing program, a powerful screenshot capture program and

a separate editor for designing the layout templates for your PDF files and printed manuals.

These tools are covered in more detail in the Tools Included with Help+Manual  chapter,

and some of them also have their own help files.

See also:
Tools included with Help+Manual

11.2.5.4.1  Spelling

The Spell Check option in the Tools menu provides access to Help+Manual's spell checker

and its configuration options. Full details of these options and the configuration settings are

can be found in The Spell Checker  in the chapter on the tools included with the program.

Note that Help+Manual supports live spell checking that marks incorrectly-spelled words as

you type. Just select Spelling > Configure Spell Checker and activate the Check spelling as

you type option.

Productivity Tip
Spell checking is supported almost everywhere in

Help+Manual where you can enter text. Just right-click

to display the context menu or click on the upper half

of the Spelling tool in the Project tab to access. 

See also:
The Spell Checker

11.2.5.4.2  Screen Capture

This option starts Help+Manual 's integrated screenshot program, with which you can:

· Take snapshots of your screen and program components for using in your documenta-

tion. This tool captures windows, controls, menus, the entire screen and free areas.

· Create animated screencasts. This unique tool uses the capture and animation engine

from our HelpXplain application to capture a series of screenshots and turn them into

253
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an animated HowTo video. This is massively easier and faster than using a video-based

tool.

For details on using this tool see Screen Capture  in Tools Included with Help+Manual.

The Screen Capture dialog:

Click on More Options to display all the options shown in the screenshot above.

Dialog options

Start: Starts the screenshot or screencast process.

Include cursor: Includes the mouse pointer in the captured image.

Start with delay:

(screencasts only)

Gives you a 5-second delay to open dialogs etc. before the capture

process begins. This only relevant for screenshots, not for screen-

casts.

Hotkey:

(screencasts only)

Lets you choose the hotkey you want to use for capturing slides

manually in screencasts. This only relevant for screenshots, not for

screencasts.

Cancel hotkey: The key to use for canceling/exiting from the screenshot or screen-

cast and returning to Help+Manual without doing anything. 

Show hints: Guides you through the capture process with popups and mouse-

over information.

1207
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Lock frame:

(screencasts only)

Locks the capture frame during the screencast capture process to

prevent accidental adjustment of its size with the mouse.

Remember set-

tings:

Stores your settings for the next capture

See also:
The Screen Capture Tool  (Instructions)

11.2.5.4.3  Image Editor

By default the Image Editor tool in Project > Tools starts the Impict graphics editing program

included with Help+Manual. You can change this to a different graphics editing program in

View > Program Options > General. 

The Impict program has its own separate help and documentation.

If you select an image in the Help+Manual editor before selecting Image Editor the corres-

ponding graphics file will be loaded into the graphics editing program automatically.

See also:
The Impict Screenshot Editor

11.2.5.4.4  Report Tool

This tool generates detailed reports on your project that can be used for a wide range of pur-

poses, including documentation, providing your programmers with lists of topic IDs for their

help calls, checking project status, locating dead links, finding missing images and unused im-

ages and so on.

See the Report Tool  for full details on how to generate reports.

1207
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The Project Report dialog:

Note that all options that exclude topics will reduce the accuracy of link reporting (links to

topics that are not included in the report will not be checked).

Dialog options

Sort order: How you want your topics to be sorted in the report. Note that only

the Table of Contents sort option also includes chapters

without text. All the other options (Topic ID, Context Number,

Modification Date) only include topics that actually have con-

tents.

If you sort by context number only those topics that actually
have context numbers will be included in the report!

TOC: If you have defined more than one TOC in your project you can se-

lect the TOC here to report on only the topics included in that TOC.

See Multiple TOCs  for details.343
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Modified between: Only include topics edited between two specified dates. 

Report topic

classes:

Include only topics with specific topic classes in the report. Cur-

rently there are only two classes: Default for all normal topics and

Popup for popup topics . 

Topics with status: Include only topics with a specific editing status  in the report.

Include options: Include topics on the basis of predefined and user-defined include

options. This works in the same way as include options in condi-

tional output .

Selected Topics:

If you have selected topics in the TOC before opening the Report

Tool you can select this to report on only the selected topics. Note

that selecting chapters always includes all the topics in the chapter.

Use Ctrl+Click and Shift+Click to select multiple topics in

the TOC.

Report types

Short project re-

port:

Simple list of all topics in your project with status, caption (i.e. the

TOC title), topic IDs, help context numbers, builds in which the top-

ics are included and date last edited. The report also includes a

summary of the number of topics and keywords in your project.

This is a practical format for providing your programmers with a list

of topic IDs and context numbers for their calls.

Extended report: Also includes each topic's keywords and help window and a more

detailed project summary at the end with a list of all the images

used in the project. 

Missing images are shown in red.

Long report: Also includes lists of the images used in each topic, lists of the links

in each topic with their targets (including topic links, Internet links,

file links and script links) and the first lines of the text with which

the topic begins. As in the extended report the summary includes a

list of all the images used in the project

Missing images and dead links are shown in red.

207

373

982



1321

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Reference

Full report: Same as the Long Report but also includes an additional full list of

images used in the project with references to the topics in which

each image is used, and word and character counts  for indi-

vidual topics and all the topics in the report. 

In addition to this there is also a list of images found in the pro-

ject's image folders that are not used in the project (useful for tidy-

ing up your project folders).

Missing images and dead links are shown in red.

Missing keywords

report:

Special report that only locates topics that do not have any index

keywords.

Files not in TOC re-

port:

Special report that lists the topic files in your project that do not

have TOC entries.

Caution: If you use TOC sort order with this option you will get an

empty report!

Custom styles re-

port:

Special report that locates topics containing text with manual

formatting instead of styles . Styles are strongly recommended

for efficiency and compatibility with translation tools.

See also:
Report Tool  (Instructions)

11.2.5.4.5  Index Tool

This tool displays an editable and fully-functional version of the finished index of your project.

This enables you to polish and tidy your index very easily. For example you can quickly correct

multiple index entries that are similar, and you can test your index links to make sure that they

point to the right places. You can also use the integrated editing tools to assign existing and

new keywords to multiple topics in a single operation.

The Index Tool can be used most effectively in combination with the index keyword entry

functions for individual topics in the Topic Options tab on the left the main editor window.

See Keywords and Indexes

781

273

1212

565



1322

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Reference

The Index Tool window:

Editing tools

Edit keyword Edit the selected keyword simultaneously in all the topics where the

keyword occurs. You can also add the keyword to additional topics

by including them in the list on the left side of the dialog displayed.

New keyword: Add a new keyword to one or more topics simultaneously. 

Delete keyword: Delete the selected keyword from all the topics where it is used. Ac-

cess the Topic Options tab on the left of the main editor window to

delete keywords from individual topics. 

Display: Display the topic(s) the current keyword links to.

Reload: Reload the finished index to refresh editing changes.
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Import/Export: Import index from an XML file, export the index to an XML file. 

Expanded view: Includes direct links to the topics containing the keywords.

See also:
Editing the index directly

11.2.5.4.6  Templates & Skins

PDF Templates and Manual Designer

This menu provides access to the Manual Designer , with which you can edit your PDF

Templates. If PDF templates have already been used with the project you can select them

here to edit them in Manual Designer.

The Print Manual Designer is a separate program included with Help+Manual. It is used

for editing the  template files that define the layout and appearance of the PDF files and

printed manuals generated from your projects. The Print Manual Designer program has its

own separate help and documentation.

HTML Skins and Word DOCX templates

You can also select available HTML skins and Word DOCX templates in this menu. 

HTML Skins are actually a special kind of Help+Manual project and they are opened in

Help+Manual. See Transforming your output with skins  and HTML Output and HTML

Templates  for more information.

DOCX templates are Word DOCX files and they are opened in MS Word. See Word DOCX

Templates  for more information.

See also:
Print Manual Designer

Using PDF templates

11.2.5.4.7  Context Tool

The Help Context Tool is used to manage the help context numbers  in your project. You

can use it to assign, delete, import and export help context numbers in batch mode for your

entire project. In addition to this you can also use the tool to automatically generate context

help topics from a map file containing a list of topic IDs and context numbers.

568

785

667

1026

1021

1217

803

368



1324

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Reference

Help context numbers are a HTML Help CHM technology

Help context numbers are generally only relevant in the Microsoft HTML Help (CHM)

format. They are not used natively in any other help format and programmers nowadays

generally prefer to use topic IDs instead because they are more "human-readable". 

However, if you are already using context numbers for your calls to your help

Help+Manual also supports them in URLs for WebHelp. This allows you to use the same

context IDs for accessing your web-based documentation as well. See Linking to WebHelp

topics  for details.

See also:
The Help Context Tool

11.2.5.4.8  Synchronize

The Project Synchronization tool is used for updating translated versions of your project.

When your original project has been updated you use Project Synch to compare the updated

original project with the old translated project. The Project Synchronizer then creates a new

version for the translator containing the changed and new material that needs to be trans-

lated. 

The Project Synchronizer adds new topics, deletes deleted topics, moves moved topics and

marks topics with new content as changed. It also updates the table of contents, index, etc.,

providing a complete updated project for the translator to work on. You can also configure it

to insert the new version of changed topics above the old translated version so that the trans-

lator can compare them and update the changes. 

See also:
The Project Synchronization Tool

11.2.6 The Write Tab

This is the tab where you will probably be spending most of your time while actually writing

the content of your projects. It contains all your text formatting and editing tools and also all

the tools for inserting special help features like toggles (expanding sections and images),

snippets (reusable text blocks), HTML code objects and so on.

11.2.6.1 Clipboard

The Clipboard group contains a standard set of tools for using the Windows clipboard (Copy,

Cut, Paste, Paste as Text). You can use the clipboard tools for copying both content in topics

and for topics and chapters in the Project Explorer. 

Remember that Drag & Drop also work both in the editor and in the Project Explorer, also

between different projects.

899
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Special Paste Commands:

Paste as Text:

Ctrl+Shift+V

· Pastes copied text as plain text, without any formatting (bold, un-

derline, graphics etc). 

· Use if you want to copy text without any formatting from other

topics, projects or other programs such as MS Word or a web

browser. 

· This feature is also useful for pasting text into paragraphs format-

ted with styles without transferring the style of the copied text

into the target paragraph.

Paste HTML: · Paste material copied from HTML pages into Help+Manual.

· Use for copying formatted text, images etc. from web pages into

the Help+Manual editor.

· When copying from some graphics programs this can be used to

paste transparent PNG and GIF images from the clipboard

without losing transparency. See Inserting Graphics and Screen-

shots  for details.

See also:
Copying, cutting and pasting text  

Moving cutting and pasting topics

11.2.6.2 Editing

The Editing group contains basic editing commands for finding, replacing and selecting text

and for undoing your editing operations. All these commands are also available via keyboard

shortcuts. You can view and edit the shortcuts in View > Program Options > Shortcuts.

481

233

357



1326

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Reference

Editing group functions:

Find and

Replace:

Search for and replace text. You can search in topics and headers, topic

keywords (index keywords), captions, the table of contents, graphics file

names and conditional text tags inserted with the Conditional Text tool .

Undo: Undo the last editing action. Note that this must be selected repeatedly for

some more complex actions.

Undo is not available for operations in the TOC!

Redo: Reverse the last Undo operation.

Redo is not available for operations in the TOC!

Select All: Selects the entire contents of the current topic or the current table cell. 

See also:
Creating and Editing Topics

The Project Explorer

Options & Keyboard Shortcuts

11.2.6.2.1  Find & Replace Text

This is a standard find and replace function but with a couple of extra features for finding and

replacing in Help+Manual projects. The dialog can be used both for simple searches and for

replacing text. The dialog serves dual purpose, both for searching without replacing and for

searching and replacing in the same operation.

Note that you cannot search for or replace text in the topic captions in the Table of Contents

(TOC).

The Find & Replace dialog:

994
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Note that some of the buttons on the right will be disabled depending on where and how

you are searching. For example, you cannot replace in the Table of Contents, but you can

in Captions (TOC captions, topic titles). Wildcard characters are not supported.

Dialog options:

Find in: Search in the current topic (default), all topics from here or all Top-

ics.

Find Where: · Topic text and header searches the content of your topics.

· Topic keywords searches the keywords stored in the Topic Op-

tions tab on the left of the main editor window.

· Table of Contents locates topics in the TOC by their title. Re-

place is not supported in this mode.

· Captions searches the TOC captions (topic title) stored in the

Topic Options tab on the left of the main editor window. Replace

is supported in this mode.

· Image filenames searches for references to graphics files. You

can use this mode to "replace" images in your project by making

image references point to different graphics files.

· Conditional texts searches for conditional text tags inserted with

the Conditional Text tool .

Find what: Enter the text you want to find here.

Replace with: Enter the replacement text here.

Find Next: Starts or continues the search.

Find All: Finds all occurrences of the search term and displays them in a re-

port screen with links to the topics.

Replace: Replaces the current instance.

Replace All: Replaces all instances of the search text. A prompt is displayed to

make sure that you want to do this before proceeding. 

Note that the scope of Replace All is also defined by the selections

you make in Search Options!

See also:

994
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Searching for text, topics and referrers

Find Topic

Find Referrers

11.2.6.3 Font

Most of the formatting tools in the Font group should be self-explanatory. They are very sim-

ilar to the options available in normal word processors. There are just a couple that deserve

extra mention and explanation.

Font formatting tools

Font Dialog:

Clicking on the Font Dialog icon at

the bottom right corner of the

Font group opens the full font

formatting dialog. See Format

Font  for more details.

Protect Text: Protects text from change and

translation. Select text and click to

apply. Protected text is displayed

with a shaded background and is

tagged with the attribute trans-

late="false" in the XML source

code of your topic file. 

Style selector: Shows the style applied to the cur-

rent text at the cursor and can be

used to select a new style. Used

for both text and paragraph styles.

If text is manually formatted or im-

ported you must select it first to

apply a style, otherwise the style

will be applied to the entire cur-

rent paragraph. 

Syntax highlighting: Tool for applying standardized

syntax highlighting to program

code in a number of different lan-

guages. 

235
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Count words: Count the words in selected text

or the current topic. See Word and

Character Count  for more op-

tions.

Subscript, Superscript, Upper/Lower Case, Text Co-

lor, Highlight Color

Functions for applying these func-

tions to selected text.

See also:
Text Formatting & Styles

Formatting Program Source Code

11.2.6.3.1  Format Font

Click the dialog icon in the Font

group to display the Font dialog

This is a standard font formatting dialog.

Everything should be familiar from word pro-

cessing programs and pretty self-explanatory. Ex-

actly the same dialogs are displayed for format-

ting text manually  and for defining styles .

The only difference when you define a style is

that your formatting is stored in the style for re-

use. All font attributes can either be used directly

or for defining styles.

The Format Font dialog:

This dialog is displayed by clicking on the little Dialog icon in the toolbar (see above).

781
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Font formatting principles:

· When formatting text manually select text before selecting the Font dialog to apply

formatting to text.
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· If you apply font attributes without selecting text they will only be applied to new text

typed at the current cursor position.

· Remember that only standard fonts will be present on most user's computers for most

output formats!

Font tab options:

The only option here that is not self-explanatory is Script:, which is important for texts in

non-English languages. If you are having problems with displaying special characters in

these languages always check the Script setting, particularly if you have imported your

text from RTF, HTML or CHM files. 

Character Spacing tab options:

Character spa-

cing:

These options increase or decrease the spaces ("leading") between in-

dividual characters. The effects are shown directly in the preview box. 

Horizontal scal-

ing:

This "stretches" or "compresses" the text horizontally. The effects are

shown directly in the preview box.

See also:
Text Formatting and Styles

11.2.6.3.2  Syntax Highlighting

This menu option applies highlights program code text to make it easier to read. A number of

programming languages are supported, and you can customize the highlighting styles for

each program language. 

For more details see Formatting program source code .

Options for predefined languages

This dialog is displayed when you select Format > Syntax Highlighting > Customize. The

following options are available when you select one of the predefined languages:

273
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Format with style: The basic appearance of all text formatted with the Syntax High-

lighting function is controlled by the standard Code Example

style. This is the currently only style you can use for syntax high-

lighting.

Opens the Edit Styles dialog to edit the Code Example style.

Elements: Settings for defining the color and font styles of the various ele-

ments highlighted by the function.

Format with soft

breaks:

Use soft line breaks instead of paragraphs for code examples. This

can be necessary to get the desired results in some cases.

Reset defaults: Resets all settings for the current language to the default values.

This also replaces any reserved words you have loaded.

Additional options for custom highlighters

If you select one of the three custom highlighters at the bottom of the list you have the

following additional options for defining your own language highlighting rules:
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Quotes: Specify whether single or double quotes are to be identified as

quotes.

Identifiers: The relevant characters that are allowed in identifiers for the lan-

guage you are using. This should normally be set to A-Za-z0-9,

and/or an explicit list. Identifiers are all special words used in the

language. 

Sequential character classes are identified with the beginning and

end characters linked with a dash (0-9), otherwise you just enter ex-

plicit characters. For example, if you want to include the $ and _

characters as well as alphanumeric characters, you would enter:

0-9a-zA-Z$_

Don't use commas or spaces! 

That would include the comma and space characters as identifiers.

Then "ERROR,LIST" and "ERROR LIST" would both be identified as a

single keyword. 

Include all the characters you use in your list!

You should include all the characters that can appear in variables

and keywords in your identifiers character list. For example, if you

include the underscore character in your variable names, you must

also include it in your identifiers list. If you don't, the characters

between underscores will be identified as a separate word. 

How the identifier characters are used

Only words that contain only the characters listed in the Identifiers

list will be checked. If the word is in the list of reserved words it will

get the reserved words formatting. If it is not, it will get the identifi-

ers formatting. 

A different category will be applied if a word does not consist of

the identifier characters, or if it is covered by another rule (Number,

Comment, String etc). 

Comments: The commenting style used. You can currently only choose

between a list of preset commenting styles, but this should cover

most needs. 

Edit reserved

words:

Create and edit a list of reserved words for your custom language.

You can paste lists of words into the editing dialog. Only the char-

acters you define in the Identifiers setting can be included in your
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reserved words. If the words include other characters they will be

ignored by the highlighter. 

See also:
Formatting program source code

11.2.6.4 Paragraph

The Paragraph group contains the tools for formatting paragraphs manually. In addition to

justification, line spacing and indents this also includes tools for creating bulleted and

numbered lists and applying borders and background colors to paragraphs.

The following reference only shows the Paragraph group tools that are not entirely self-ex-

planatory.

310
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Paragraph group tools:

Paragraph dialog:

Clicking on the small dialog icon in the bottom right corner opens

the normal paragraph formatting dialog in which you can apply all

available paragraph formatting settings.

Lists: Tools for bulleted and numbered lists. List definitions are separate

from styles. Click on the arrows next to the list tools to display a list

style gallery and the options for opening the list dialogs.

Indents: Increase and decrease paragraph indents. These tools can also be

used in lists, where they change the level of the list items.

Borders and

Shading:
Displays a menu in which you can apply individual simple borders or

open the full Borders and Backgrounds dialog to set more complex

options for the current paragraph.

Alignment and

Line Spacing:

Adjusts the paragraph alignment and line spacing. 

Clicking on the main line spacing button successively increases the

line spacing of the text at the cursor. The menu displayed with the

arrow on the right of the button allows you to select a range of indi-

vidual line spacing options.

Keep with Next,

Keep Together,

Word Wrap:

Keep current paragraph with next paragraph, keep selected para-

graphs together, turn word wrap on and off.

Be careful with the keep together options. If you over-use them you

can create oversized unbreakable blocks that run off the bottom of

the page. 

Keep with next and keep together are only active in PDF and Word

output.

Text marks: Clicking this tool displays paragraph end markers and tab characters

in your text so that you can see them more easily. You can turn this

on permanently with the settings in View > Program Options > Ed-

itor.

See also:
Text Formatting and Styles 273
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Numbered and bulleted lists

11.2.6.4.1  Format Paragraph

The dialog icons opens the

Paragraph dialog

This is the manual paragraph formatting dialog displayed

when you select the Dialog icon  in the Paragraph

group. Most of its features should be familiar from word

processing programs and pretty self-explanatory. Exactly

the same dialogs are displayed for formatting text manu-

ally  and for defining styles . 

When formatting text manually paragraph attributes are

applied to all paragraphs that are at least partially selec-

ted, or to the paragraph in which the cursor is currently

located.

Internally, Help+Manual handles all measurements in pixels. For maximum precision working

in pixels rather than inches or centimeters is recommended. You can change your measure-

ment units setting globally in View > Program Options > Editor > Ruler Units .

The Indents and Spacing and Tab Stops tabs:

All the settings in these tabs are exactly the same as in a normal word processor and

should be self-explanatory. Note that tab stops are not supported in HTML-based formats

and should generally only be used in hanging indents, where they are automatically con-

verted in HTML output. Please see Using indents  for details on using indents in help

files.
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The Line and Page breaks tab:

The first two settings in this tab are only used for printing manuals and generating PDF

and Word output. They are ignored in all other output formats.

Keep lines to-

gether:

Applying this attribute to a paragraph or a style will keep all of the

lines of a paragraph together at a page break. Don't use for body

text – if your paragraphs are large this setting will bump the entire

paragraph onto the next page, leaving an ugly gap!

Keep paragraph

with next:

Keeps the paragraph with the next paragraph at a page break. Gen-

erally only used for headings. If you use empty paragraphs after

headings remember that you must apply this setting to both the

heading and the empty paragraph, otherwise it won't work.

Word wrap: If you disable this setting the lines of paragraphs will no longer

automatically wrap to the next line. It is normally only used for

formatting program code and other text where the ends of each

line is defined with a paragraph end mark. If you disable this in nor-

mal text everything except the first line will disappear off the right

margin of the page.
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In HTML-based output formats turning off word wrap is achieved

by converting all spaces to non-breaking spaces. You can then also

use leading spaces for indenting text. 

See also:
Text Formatting and Styles

Using indents

Tabs, indents and HTML

11.2.6.4.2  Format Borders and Shading

This dialog is displayed by clicking on the Borders tool in the Write > Paragraph group and

then selecting Borders and Shading.

These settings allow you to apply borders and colored backgrounds to paragraphs. Most of

its features should be familiar from word processing programs and pretty self-explanatory.

Exactly the same dialogs are displayed for formatting text manually  and for defining

styles . 

The Format Borders & Shading tab:

When you format text manually border and background attributes are applied to all para-

graphs that are at least partially selected, or to the paragraph in which the cursor is cur-

rently located.

Multiple paragraphs with a background color may have white space between them. Mul-

tiple paragraphs with borders will have individual borders around each paragraph instead

of one border around all paragraphs. To avoid these problems press SHIFT-ENTER instead

of ENTER between paragraphs with borders and backgrounds.
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Dialog options:

Settings: These settings define the color and dimensions of the border and

the background. The Offset is the distance between the border and

the paragraph.

Preview: The buttons around the Preview window activate or deactivate the

border display for top / bottom / left / right.

Border style: You must select one of these styles to display borders. If None (the

default) is selected no borders will be displayed!

See also:
Text Formatting and Styles

11.2.6.4.3  Format Bullets and Numbering

This dialog is displayed when you click on the Bulleted or Numbered List tool in Write > Para-

graph and then select the Bullets and Numbering option displayed below the list styles dis-

played. 

To apply a bulleted or numbered list select paragraphs in the editor, display this dialog and

then select one of the list styles.

Although selecting numbered and bulleted lists is very simple using them properly in

Help+Manual requires a little more information. Please see Numbered and bulleted lists

for details.

273
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The Format Bullets & Numbering dialogs:

Restart numbering / Select to restart the numbering of the current item or list with a
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Start at: different number. You can also use this to reset the numbering

of a list to begin at 1.

Customize: Select to modify the currently selected bullet or numbering

style.

Reset: Select to reset the current bullet or numbering style to its de-

fault settings.

The Customize dialog (Bullets):

Displayed by selecting Customize in the Bulleted tab. Edits the properties for the bullets

style selected in the main tab.

 

Levels: Number of levels in the list. This is not active for bulleted lists, which al-

ways only have one level. 

Level Format: Formatting and style for the current level. Bulleted lists always only have

one level.

Number

style:

Selecting anything except Bullet here switches to a numbered list.

Select Bullet: Select a different character to use for the bullet in the bulleted list. The se-

lected character will be displayed in the preview box on the right.
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The Customize dialog (Numbered List):

Displayed by selecting Customize in the Numbered tab. Edits the properties for the

numbered list style selected in the main tab.

 

Levels: Number of levels in the list. This is not active for ordinary lists,

which always only have one level. 

Level Format: Formatting and style for the current level. Ordinary numbered

lists always only have one level.

Number style: You can choose a variety of styles for your numbered list. Experi-

ment!

Number format: The format of the number displayed in the list. The variable <L1>

displays the list number and should not be deleted. Any other

characters you enter will be added to the number. The result is

displayed in the preview box on the right. 

Start numbering at: Only active for lower levels of outline numbered lists (see below).

Legal numbering

style:

Activates legal numbering style for outline numbered lists, with

all the list numbers at the left margin (see below).

Level reset: When this is selected the numbering of sub-levels in outline

numbered lists always re-starts with 1 or the equivalent (see be-
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low).

The Customize dialog (Outline Numbered List):

Displayed by selecting Customize in the Outline Numbered tab. Edits the properties for the

outline numbered list style selected in the main tab.

  

Levels / Count: Number of levels in the outline numbered list style. You can

change the number of levels by adjusting the Count: value.

Level Format: Formatting and style for the current level. Select the level to

modify by clicking in the Levels box.

Number style: You can choose a variety of styles for your numbered list. Experi-

ment!

Number format: The format of the number displayed in the list. The variables

<L1>, <L2> etc. (for  the levels) display the list numbers and

should not be deleted. Any other characters you enter will be ad-

ded to the number. The result is displayed in the preview box on

the right. 

Start numbering at: Resets the starting number of the current level. Only active for

lower levels of outline numbered lists.
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Legal numbering

style:

Activates legal numbering style for outline numbered lists, with

all the list numbers at the left margin. This setting must be set

separately for each level of an outline numbered list!

Level reset: When this is selected the numbering of sub-levels in outline

numbered lists always re-starts with 1 or the equivalent. Other-

wise the numbering continues from one sub-level to the next.

Must be selected separately for each level of the outline

numbered list.

See also:
Text Formatting and Styles

Numbered and bulleted lists

11.2.6.5 Styles

The Styles group contains the main functions for editing and manipulating text, paragraph

and table styles. Using styles effectively can radically speed up your work and will also make

your projects look more uniform and professional. They will also save you a lot of time – once

you have got styles set up you can change the fonts and formatting in your entire project in a

couple of minutes just by changing your style definitions. 

273
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Styles group functions:

Edit Styles: Display the dialog for creating and editing text, paragraph and table

styles. 

Create Style from

Selection: 

Uses the text and paragraph settings at the cursor position to create

a new style or redefine an existing style.

Replace Styles: Global search and replace operation to replace formatting and

styles in your entire project. Searches for text attributes and para-

graph attributes separately. 

11.2.6.5.1  Create Style from Selection

This option turns the current selection into a dynamic style that you can reuse. Formatting

text manually and then turning it into a style is often easier than designing a style "from

scratch" in the styles definition dialogs.

If no text is selected the function uses the attributes of the paragraph in which the cursor is

currently located, including the paragraph attributes and the text attributes at the current

cursor position. 

Dialog options

Create a new style: Define a completely new style using the current selection as a

model.
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Change existing

style:

Redefine an existing style. The style assigned to the current selec-

tion or cursor position is the default but you can select another

style to redefine.

New style name: Enter a new name or accept the name of the style you want to re-

define.

Based on style: Select a "parent" child to make the new or redefined style the child

of another style. If you select a paragraph style as the parent the

new style will also be a paragraph style.

Assign paragraph

attributes:

Assigns both the text and paragraph attributes of the current selec-

tion to the new or redefined style.

Edit Styles: Opens the Edit Styles dialog for more detailed styles editing.

See also:
Text Formatting and Styles

Defining styles

11.2.6.5.2  Edit Styles

This dialog contains all the settings for creating and editing text, paragraph and table styles.

For full details on creating, editing and using styles please see Text Formatting and Styles .

Table styles and text/paragraph styles

To display the options for table styles just click on one of the entries in the Table Styles

section on the left. In the same way, display the options for text and paragraph styles by

clicking on one of the entries in the Text & Paragraph Styles section. 

Image styles

The image styles  are a separate group in the styles list, in the same way as the Table

and Text & Paragraph styles. 

Dual Styles for electronic help and print-style help (PDF etc.)

Screen View and Print View tabs:

273

281

273
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You can define two sets of settings for each style: Screen View is for electronic help

formats (HTML Help, WebHelp and eWriter Help), Print View is for page-style formats

(PDF, Print User Manual, Word DOCX and ePUB eBooks).

You can switch between the Screen and Print View style settings in the Help+Manual ed-

itor by clicking on the Screen/Print button in the status bar at the bottom of the main pro-

gram window.

Dialog options

Style name: Name of the current style.

Based on style: The "parent" style of the current style. Styles inherit all attrib-

utes that you do not explicitly change from their parent style.

You can change the parent style by selecting a different style in

this field.

Shortcut: The keyboard shortcut for selecting the style. To add a shortcut

just click in this field and press the key combination for the

shortcut.

Add Style Creates a new style definition.

Remove Style Deletes the current style. If the style has any sub-styles (child

styles) they will also be deleted (a warning is displayed). Not

active for Help+Manual's standard styles, which cannot be de-

leted.

Copy Styles From... Copies the styles definition set from another Help+Manual pro-

ject. 

This completely overwrites the current style definition set, re-

placing it with the definitions of the other project.

Font, Paragraph,

Borders (Text & Para-

These buttons display the dialogs for formatting the Font, Para-

graph and Borders & Backgrounds attributes of the current style.
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graph Styles) The dialogs are exactly the same as the standard Format

Font , Format Paragraph  and  Format Borders & Back-

grounds  dialogs.

Modify Layout (Table

and Image Styles)

Displays the layout settings for table styles. These settings are a

subset of the normal Table Properties dialog. 

Reset Style Resets the current styles to the default settings. Always use this

before defining a text-only style  to make sure that you do

not accidentally include paragraph or border attributes.

See also:
Text Formatting and Styles

Dynamic Styles

11.2.6.5.3  Replace Styles

This is quite a complex and powerful tool for replacing formatting and styles globally

throughout your entire project. It replaces font and paragraph styles and settings separately,

in two separate operations, and requires a little planning to use. See Replacing Formatting

and Styles  for details.

See also:
Replacing Formatting and Styles

11.2.6.6 Insert / Insert Object

The Insert and Insert Object groups in the Write tab are particularly important. They contains

options for inserting different kinds of hyperlinks and all the objects that you can use in

Help+Manual topics in addition to text. You can also insert tables here so that you don't have

to switch to the Table tab while you are working.

Insert group:

1329 1336
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Link: Displays the dialog for inserting hyperlinks in your topic. You can in-

sert topic links, file links, internet/email links and links that run scripts

or macros. Select text first to create

Image: Displays the dialog for inserting a graphic in your topic.

Media: Displays the dialog for inserting a video or other media in your topic.

Table: A graphical tool for inserting tables quickly and a link to the standard

Insert Table dialog.

Insert Object group
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Text Variable: Displays the dialog for inserting a text variable  in your

topic. Includes both the program's predefined variables and

any variables you have defined for your project.

Snippet: Inserts a topic or an external Help+Manual XML file as a snip-

pet  which can be either  linked or pasted. Linked snippets

are dynamic and update automatically when the linked file is

changed. Pasted snippets are like ordinary cut and paste.

Toggle: Insert toggles : expanding sections, expanding inline text

and expanding images. These items "grow" when the user

clicks on them in the help. Only supported in HTML-based

output formats with JavaScript.

Conditional Text: Displays the dialog for inserting conditional text tags  to in-

clude or exclude text and other content from your output on

the basis of conditions.

Topic Anchor: Displays the dialog for inserting an anchor  in your topic as

a target for topic links and other references. (Anchors can also

be used as targets for HTML links in WebHelp.)

HTML Code Ob-

ject:

Displays the dialog for inserting inline HTML code  in your

topics for adding features and functionality in HTML-based

output formats. This code is ignored in all non-HTML based

output formats.

Manual Page

Break:

Inserts a hard page break  at the cursor position. Page

breaks are only used in PDF, Printed Manuals and Word out-

put. They are ignored in all other formats. 

Print orientation: Landscape / Portrait

When you insert a manual page break you can decide

whether you want the orientation to switch between land-

scape and portrait mode. This enables you to use both land-

scape and portrait pages within a single document. 

Comment/Book-

mark:

Opens the dialog for entering a comment  for yourself or

others working on the project. Comments can also be used as

bookmarks, with which you can find and jump to places in

your project quickly with Bookmark in Project > Project.

Comments and bookmarks are not included in your output.

QR Code: Insert a QR code . These codes can be directly interpreted

by smartphone cameras. If the QR code contains a web hyper-

link scanning the code will automatically open the referenced

page in the smartphone's browser. 

OLE Object: Displays the standard Windows dialog for inserting OLE ob-

jects  (Object Linking and Embedding) in your topics. OLE

objects are converted to graphics in your output. 

Horizontal line: Inserts a horizontal line  in the topic at the cursor position.

Formula: Inserts a mathematical formula .

Link list: Inserts a link list  with references to selected groups of top-

ics.

Caption object: Inserts a caption  that can include numbering variables that

you can refer to. 

Special Charac-

ter:

Displays the character map dialog for inserting special charac-

ters  that are not available on the keyboard in your topic.

917

265

382

994

415

469

245

253

262

1139

245

1232

256

944

245



1352

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Reference

See also:
Using Graphics

Adding video files

Re-using content with snippets

Using OLE Objects

Using Context-Sensitive Help

Using Variables

Conditions and Customized Output

11.2.6.6.1  Link

This dialog contains all the options for inserting hyperlinks in your topics. For detailed instruc-

tions see the Links, Anchors, Macros Scripts and HTML  chapter. The appearance of the dia-

log changes depending on the kind of link you are inserting.

The Insert Hyperlink dialog:

Common options for all link types:

Caption / Picture: The caption displayed in the text for the link if you are creating a

text link. If you select text in the editor before invoking the Insert

Link function the selected text is displayed here.

If you select Picture in the Style section (see below) Picture: is

displayed above this field instead of Caption:. The  browse but-

ton to the right of the entry field is then activated so that you can

select a picture to use.

Using the Automating Publishing Jobs variable:

If you type this variable in the Caption: field it will automatically in-

sert the title of the target topic as the caption of the link when you

publish your project. See Inserting topic links  for details. 
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Tooltip: Adds text for a tooltip that is displayed on mouseover in HTML-

based output formats.

Style:

Link: The standard link format: text link, displayed in blue with an under-

line.

Text: Displays the link as plain text that you must format yourself in the

editor. If you don't format the link it will be active but it will not

look any different from the text around it, i.e. it will not be identifi-

able as a link.

Button: Displays the link as a standard Windows button. The caption in the

Caption: field is used as the label text on the button.

Picture: Uses a graphic as the link instead of a text caption. The supported

graphics types are indicated by file extensions are displayed in the

dialog displayed when you click on the  Browse button to select

a file.

Topic link dialog options:

Help file: The file containing the topic you want to link to. By default this is

the current project file but you can also create links to other project

files and compiled HTML Help CHM files. 

Click on the  browse button to select a different help file. Its top-

ics will then be displayed in the Topic ID list.
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The target help file must be present in the same directory as the file

containing the link at runtime (i.e. on the user's computer). Also, the

target help file must have the same format as the help file contain-

ing the link. You cannot create links between help files of different

types, only between two CHM files.

Window: Only relevant in HTML Help. If you have defined secondary window

types for your project you can select a different help window type

for opening the target topic. 

In HTML Help selecting a secondary help window here only opens

an external window if secondary HTML Help windows are activated

in the Help Windows  configuration. If they are not activated this

setting has no effect in HTML Help.

Topics in HTML Help do not change their background colors when

you specify a secondary help window in a hyperlink. Their colors are

defined by the HTML template of their own window type definition

and this cannot be changed by a link. Even when they are displayed

in an external window the secondary window type only controls the

appearance of the window, not of the topic itself. 

Target: The topic ID of the topic you want to link to. Select the ID from the

list or type its name in the entry field. Each letter you type will auto-

matically display the first topic matching that letter.

Anchor:

(drop-down list

next to Target:)

Use to link to an anchor inside the selected topic, so that clicking

on the link takes the user directly to the position of the anchor. An-

chors are only displayed here if the target topic already contains

anchors. If you have just inserted an anchor in the target topic it is

not displayed until you save your project.

Topic preview: Preview of the target topic

1454
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Internet link dialog options:

Address: The website URL or email address you want to link to. Always enter

a complete URL for websites, including the http:// protocol pre-

fix. Links without this prefix sometimes don't work in HTML Help.

Test Test the URL. Opens your browser or email program.

Links to an Internet

address:

Select to enter a website URL.

Sends an email: Select to enter an email address.

Target window: Same as referring topic

Opens the web page in the current browser window or the help

viewer if possible. (The Windows Exe eBook viewers cannot display

web pages, ePUB readers will only open a browser if possible and

available.)

Use this option instead of Top frame when loading web

pages into WebHelp topics if you want the Table of Contents to
remain visible when the web page is loaded.

New window:

Opens the web page in a new browser window. 

Top frame:

This option is designed for WebHelp output. It  loads the web page

into the topmost frame in the current frame structure, completely

overwriting the Table of Contents so that the web page fills the en-

tire browser window.
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Figure link dialog options:

Figure links are special topic links that use the ID of a figure, table or caption variable as

their target. You choose the topic containing the figure, then choose the figure ID from a

drop-down list. This functions in exactly the same way as a link to an anchor in a topic.

See Figure and Table Counters  for details on how to use these variables and create fig-

ure IDs.

Target: The topic containing the figure you want to link to. This is exactly

the same as a regular topic link. It must be in the current project.

Figure ID: Select this from the drop-down list next to the target field. There

will only be entries in the list if there are figure IDs in the target

topic. This works in exactly the same way as a link to an anchor in a

topic.

File link dialog options:

File links link to external files located in the same directory as the help file containing the

link. When the user selects the link it is like double-clicking on a file in the Windows Ex-

plorer. 

See Inserting file links  for details and compatibility with various output formats.

944
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File name: The name of the file you want to link to. You can use the  browse

button to select a file but this will not enter any path information

because it is assumed that the file will be in the same directory as

the help file containing the link.

If you enter the file name manually always type the complete name

of the file, including the extension.

Relative path: A relative path to the file. This path will be inserted before the file

name in the actual link. It should be the path that is valid when the

help is viewed by the user, NOT a path on your computer!

Execution para-

meters:

Any parameters you want to add to the file link, for example

switches or a file name to follow an executable program. 

Test Tests the file link with the execution parameters. If you use the 

button in the File name: field to select the file this will access the

file wherever it is located.

Note that this doesn't test whether the file link is compatible with

your output format! It only tests how executing the external file be-

haves with the execution parameters entered.

Script link dialog options:

This option enters a link that executes a Winhelp macro or some JavaScript code. Please

see Inserting script and macro links  for information on how to use this function.452
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HTML JavaScript: Select this to enter JavaScript code. Only supported in HTML Help

and WebHelp output. 

Winhelp macro: Select to enter a Winhelp macro. Although the obsolete Winhelp

output is no longer supported, four special Winhelp macros are

automatically converted to their ActiveX equivalents in HTML Help.

See Inserting script and macro links  for details.

Script: Enter your script or Winhelp macro here. 

Note on script links:

Script links are generated as follows:

<a href=" contents of Script window ">

If you are familiar with web scripting you can use this information

to enter complex scripts. (See the links under See also: below for full

details on this.)

Load from File:

Save to File:

These buttons allow you to save and load blocks of script and

macro code that you want to reuse. 

Load from file.. loads a text file to the current cursor position in the

script window. 

Save to file.. saves the entire contents of the script window to a text

file. 

See also:
Inserting script and macro links

Scripts, HTML and Macros  (Reference)

452
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11.2.6.6.2  Image

This dialog contains all the options for inserting graphics in your topics. For detailed instruc-

tions see the Working with Graphics  chapter. In addition to this also see the The Impict

Screenshot Editor  information on the screenshot enhancement and graphics editing pro-

gram included with Help+Manual.

The Insert / Open Image dialog:

Dialog options:

Open file options: The upper part of the window is a standard Windows file open dia-

log. 

File name: The image file you want to insert. You can select a file from the dir-

ectory above with the mouse or type the filename here. You can

also use wildcard characters (? and *) to filter the directory. For ex-

ample typing *.jpg will only display the JPG files in the current

folder and ???.gif will only display GIF files with 3-character

names.

Files of type: This drop-down list filters all the graphics file formats supported by

Help+Manual. You can display all the supported files or only files of

specific types.

Picture: This box displays a thumbnail preview of the currently selected

graphics file and the dimensions of the file. Click on the thumbnail

to display a full-size preview of the selected graphics file.

Picture ID: Text you add here is inserted in the <img> tag as an ID attribute in

HTML-based output formats. This is only relevant if you want to

479

1216



1360

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Reference

manipulate your HTML code manually and need to reference your

images with ID attributes.

Image Style: Apply an image style  that you have defined to set the width and

a border for a class of images.

HTML Class: Allows you to enter one or more HTML class names (separated by

spaces) to be added to the class="" attribute of the <img> tag

in HTML-based output. This is only needed if you plan to provide

additional formatting for images with your own CSS code. Use with

care – this can easily interfere with things like responsive images!

Tooltip: Text you enter here is added to the <img> tag as the ALT attribute

in HTML-based output formats so that it will be displayed as a tool-

tip when the user positions the mouse over the image. 

Note: If you leave this field blank the image filename will be ex-

ported as the tooltip unless you turn this off in Configuration >

Publishing Options > WebHelp / HTML Help > HTML Export Op-

tions.

Alignment: These options define how the graphic will be aligned in your out-

put. This works in all output formats (including PDF) and 

With text 

The default setting. Treats the graphic as though it is a character in

the text. It flows with the text without any wrapping. 

Left of text

Positions the graphic to the left of the text and wraps the text

around it to the right.

Right of text

Positions the graphic to the right of the text and wraps the text

around it to the left. 

Note that the left/right of text formatting is not displayed in the ed-

itor. It is only shown in the output. 

Left/right of text is an electronic help format feature. It is not sup-

ported in PDF or Word DOCX. Use tables to position graphics in

these formats.

Padding: This defines an invisible margin around the edge of the graphic,

between the graphic and text and any other objects on the page.

492
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Enter a value in pixels or click on  to set individual values for the

sides of the image.

 You can also enter individual values for each side of the image

manually:

Padding setting Effect

10 Sets the same padding value for all four

sides of the image,.

10 15 Sets padding to 10 pixels for top and bot-

tom and 15 pixels for left and right

10 25 15 5 Top: 10 pixels, Right: 25 pixels, Bottom: 5

pixels, Left: 15 pixels

Display size: This setting allows you to resize graphics  precisely by percent.

Images are not physically resized. The original files are exported

with scaling information that controls their display size in the out-

put format.

Use % of page width settings for responsive images:

The % of page width settings ensure that images adjust for the cur-

rent window size in HTML and when exporting to PDF and Word.

This prevents breaking your layout on mobile devices. 

Caption: Text displayed as a caption beneath the graphic. This text is always

centered and automatically uses the standard style Image Caption.

You can format it manually by selecting the graphic in the editor

window and then selecting text formatting options.

Opens the Hotspot Editor , with which you can add clickable

areas with hyperlinks to your graphics.

11.2.6.6.3  Hotspot editor

The hotspot editor enables you to define "clickable areas" in your graphics and associate all

the different types of hyperlinks with them that are supported by H+M. When the user clicks

on the hotspot area in the graphic it is exactly the same as clicking on a hyperlink of the same

type in the topic text.

The parameters of the different kinds of hotspot hyperlinks are exactly the same as those for

normal hyperlinks. For details see Links, Anchors, Macros, Scripts and HTML  and Graphics

with hotspots, macros and scripts .
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The Picture Hotspot Editor:

Dialog options:

Toolbar options:

Inserts a topic link hotspot.

Inserts an Internet link hotspot.

Inserts a file link hotspot.

Inserts a script link hotspot.

Aligns the hotspots in a vertical row, aligning with the first hotspot selec-

ted. 

Aligns the hotspots in a horizontal row, aligning with the first hotspot se-

lected.

Deletes the hotspot (same as pressing the Delete key).
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Selected

hotspot:

Shows the properties of the selected hotspot. You can adjust the size and

position of the hotspot by dragging with the mouse or by entering values

here.

Rectangle /

Ellipse:

Choose a rectangular or an elliptical hotspot.

Title: Adds a title attribute text to the hotspot link.

Hyperlink settings:

The settings of the various hyperlink types are exactly the same as those for normal hyper-

links in the topic text. For details see Links, Anchors, Macros, Scripts and HTML  and

Graphics with hotspots, macros and scripts .

See also:
Graphics with hotspots, macros and scripts

Links, Anchors, Macros, Scripts and HTML

11.2.6.6.4  Media: Local Videos

This option is used to insert movies in your topics for the output formats that support them.

See Videos and Animated Media  for details. There are a number of different dialogs for the

different video and animated media types. The options in each dialog are quite similar, how-

ever. 

Insert Video / Video tab:

File: The local video file you want to insert. 

Drag & Drop:

· You can drag local video files into the the Local Video dialog

Caption/Title: The caption is displayed below the placeholder image for the video

just like the caption of an image. The Title is the ALT tag text of the

409
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preview image that is also displayed as mouseover tip. 

Aspect ratio: This will generally be set automatically from the video you select. If

you select the aspect ratio (4:3, 16:9 or 16:10) you only need to

enter the width of the video. The height is then calculated auto-

matically. Alternatively you can select Custom Aspect Ratio and

enter both values manually.

Width/Height: The dimensions of the video. If you select the aspect ratio the

height is grayed out and is calculated automatically from the

width.

Alignment/

Padding:

This is the same as the alignment and padding values for inserting

images. It inserts space around the video in the topic page. 

Play Inline/

Use Lightbox:

If you select Lightbox the video will be played in an overlay on the

page when the user clicks on the placeholder image. Inline plays

the video in the page in the position where the placeholder image

is displayed, in the same way as embedded videos on most web

pages.

Preview zoom: Zoom size of the preview image. This is also the display size of the

video when you select Zoom proportional to page width (inline op-

tion only).

Zoom proportional

to page:

Makes the preview image responsive, and also the video if it is

played inline. Its percentage width will then be relative to the cur-

rent page width and will adjust automatically when the user

changes the browser or viewer window size. 

This is only available if you select Play Inline. When you choose

Lightbox mode the lightbox overlay containing the video always

scales to the page automatically.

Show controls: Displays the video player's controls if possible.

Add play button: Adds an overlay Play button to the placeholder image so that it is

more obvious to the user that they can play the video by clicking

on it. 

Insert Video / Embed Code tab:

This tab displays the HTML code used to embed the movie in HTML-based output formats

(HTML Help and WebHelp) and allows you to edit it if you want to. 
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Selecting I want to enter the embedded HTML code manually displays the code and allows

you to edit it or replace it with your own code. Select this after selecting your video in the

main tab, otherwise you won't get very meaningful code! 

See also:
Videos and Animated Media

11.2.6.6.5  Media: Online Video Services

This option is used to insert videos hosted by online video services in your topics for the out-

put formats that support them. See Videos and Animated Media  for details. In addition to

online videos, Help+Manual also supports Prezi, an online tool that creates cool presentations

with rotation and zoom effects. Each online video service has its own dialog. The options in

each dialog are identical, however. The example below uses the Vimeo dialog. 

548
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Insert Video / Video tab:

URL: The URL of the online video or animated presentation. You can

use either the URL from the Address: field of your browser or

the shortened "Share" URL provided by the video service you

are using. Help+Manual will automatically convert it so that it

works properly. 

Drag & Drop:

· You can drag URLs from the browser into the YouTube,

Vimeo and Prezi dialogs.

Caption/Title: The caption is displayed below the placeholder image for the

video just like the caption of an image. The Title is the ALT tag

text of the preview image that is also displayed as mouseover

tip. 

Aspect ratio: If you select the aspect ratio (4:3, 16:9 or 16:10) you only need
to enter the width of the video. The height is then calculated
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automatically. Alternatively you can select Custom Aspect Ra-
tio and enter both values manually.

Width/Height: The dimensions of the video. If you select the aspect ratio the

height is grayed out and is calculated automatically from the

width.

Alignment/

Padding:

This is the same as the alignment and padding values for insert-

ing images. It inserts space around the video in the topic page. 

Play Inline/

Use Lightbox:

If you select Lightbox the video will be played in an overlay on

the page when the user clicks on the placeholder image. Inline

plays the video in the page in the position where the place-

holder image is displayed, in the same way as embedded

videos on most web pages.

Preview zoom: Zoom size of the preview image. This is also the display size of

the video when you select Zoom proportional to page width (in-

line option only).

Zoom proportional

to page width:

Makes the video and the preview image responsive. Its per-

centage width will then be relative to the current page width

and will adjust automatically when the user changes the

browser or viewer window size. 

This is only available if you select Play Inline. When you choose

Lightbox mode the lightbox overlay containing the video al-

ways scales to the page automatically.

Show controls: Displays the video player's controls if possible.

Add play button: Adds an overlay Play button to the placeholder image so that it

is more obvious to the user that they can play the video by

clicking on it. 

See also:
Videos and Animated Media

11.2.6.6.6  Media: HelpXplain

This option is used to insert animated presentations and infographics created with our own

HelpXplain tool. This links directly to the .xplain source file, which is compiled fresh when

you publish your Help+Manual project so that the latest version is always integrated in your

output.

The dialog is very similar to the video dialog, with just a couple of small differences.

548
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Insert HelpXplain / HelpXplain tab:

File: The HelpXplain source file, which has the extension .xplain.

Drag & Drop:

· You can drag .xplain files into the the HelpXplain dialog

Caption/Title: The caption is displayed below the placeholder image for the

video just like the caption of an image. The Title is the ALT tag

text of the preview image that is also displayed as mouseover

tip. 

Display Options: Fixed or variable. Variable is recommended for inline presenta-

tions. Then the presentation will expand and contract with the

browser page. 

Alignment: This is the same as the alignment and padding values for in-

serting images. Padding inserts space around the video in the

topic page. 

Lightbox: If you select Lightbox the video will be played in an overlay on

the page when the user clicks on the placeholder image. Other-

wise the presentation plays inline in the page in the position

where the placeholder image is displayed, in the same way as

embedded videos on most web pages.

Play after: Delay before the presentation plays automatically. Uncheck the

checkbox to disable autoplay.

Endless loop: Repeat the presentation indefinitely unless the user stops it.
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Add play button: Adds an overlay Play button to the placeholder image  so that

it is more obvious to the user that they can play the video by

clicking on it. Only available for Lightbox mode.

Print options: Options for outputting the Xplain as static slides when publish-

ing to PDF or Word.

Print Options tab

Options for outputting the Xplain as static slides when publishing to PDF or Word. You

can export just the first slide, or all slides in a tabular grid.

See also:
Videos and Animated Media

Animated HelpXplain presentations

11.2.6.6.7  Anchor

Inserts an anchor in your topic. An anchor is a "jump target" within a topic that enables you to

define hyperlinks that jump to specific positions in topics.

The Insert Anchor dialog:

 

Dialog options:

Anchor ID: An alphanumeric ID that is used as the address of the anchor. Use a

descriptive ID that is easy to identify. These IDs are displayed in the

548
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Topic Options tab on the left of the main editor window and in the

Insert Hyperlink dialog.

You cannot use spaces or special characters. A warning will be dis-

played if you try to use illegal characters.

Help Context: You can assign help context numbers to anchors so that you can

make context-sensitive calls to specific positions inside topics. If

you have activated the automatic generation  of context num-

bers for anchors a number will be displayed here automatically.

Keywords: You can also assign index keywords to anchors (normal K-keywords

only, A-keywords  are not supported here). If you do this, select-

ing the keyword in the index will jump to the anchor instead of the

top of the topic. In this case the keyword should only be defined in

the anchor, not also in the topic's Topic Options.

See also:
Anchors - jump targets

11.2.6.6.8  Text Variable

This simple dialog displays the list of available text variables for insertion in your topic. The list

includes both Help+Manual's predefined variables and any variables you have defined for

your project. When you insert variables with this dialog they are highlighted as objects in the

editor, like this:

This makes them easier to identify. This is only a convenience, however. You can also enter

variables by typing them directly in the editor. When you publish your output Help+Manual

will still identify them.
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The Insert Text Variable dialog:

Selecting More... displays the Text Variables section in your Project Configuration so that

you can edit existing variables or add new ones.

See also:
Using Variables

11.2.6.6.9  Conditional Text

This dialog is used to insert include option tags in your topics to control what is included and

excluded from your output on the text level. See Conditions and Customized Output  for

more details.

Note that conditions set in the text work in combination with the options you select in the

Publish  settings when you publish your project.

917
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The Insert Text Condition dialog:

Dialog options:

IF Marks the beginning of a positive include option condition for all the

options selected in the list on the right (tagged content is included if

the condition evaluates TRUE). You can select multiple conditions.

The text and other content enclosed by the condition will be included

in your output if one or more of the selected conditions are fulfilled

(OR logic).

IFNOT Sets the beginning of a negative include option condition for all the

options selected in the list (tagged content is included if the condition

evaluates FALSE). Here too, you can select multiple conditions.

The text and other content enclosed by the condition will only be in-

cluded in your output if none of the selected conditions are fulfilled

(OR logic).

ELSE Marks the beginning of text to be included if the previous condition is

not fulfilled. This tag must be inserted between a pair of IF/ENDIF or

IFNOT/ENDIF condition tags. 

For example, if the output format is HTML Help (CHM) the following

condition will output TEXT 1, otherwise it will output TEXT 2:
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ENDIF Marks the end of an IF or IFNOT condition. If you select text in the ed-

itor before invoking this function the ENDIF tag is added automatically

at the end of the selected text.

Opens the dialog for defining and editing user-defined include op-

tions. 

See also:
Conditions and Customized Output

Compile Help File

Publishing Your Projects

11.2.6.6.10  Toggle

This dialog is used to insert expanding sections, text and images, known as Toggles , in

your topics. There are two versions of the dialog, depending on whether you choose the Ex-

panding Text or Screenshot Toggle option a the top of the dialog.

The Insert Toggle dialog – Expanding Text mode:

Insert Toggle dialog options for expanding text:

Export Options: These options control whether the toggle is expanded or collapsed

in your output. Normally, toggles are expanded in print formats

(PDF, printed manuals and Word DOCX) and collapsed by default in

supported electronic formats.

Note that toggle switching is not supported in Windows Exe or

ePUB eBooks and so toggles are always displayed expanded in

these formats.
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Optional ID: This is optional and we recommend that you leave it blank. You

only need to enter an ID here if you plan to access the toggle IDs in

the HTML code of your output for any reason. 

If you leave this field blank Help+Manual will give each toggle a

unique internal ID. If you enter your own ID you must make sure

that each ID in the current topic is unique and you must also edit

your IDs manually if you copy your toggles, otherwise you will have

ID conflicts.

Caption: This is the "header" of your expanding section. It is also the active

link that the user clicks on to expand or collapse the section. (If you

select text before inserting the toggle the text will automatically be

displayed here).

Link style: Selecting this displays the toggle header formatted as a normal hy-

perlink, deselecting it displays the header as plain text (it is still an

active link).

For more details on formatting toggle links see below and in the

Formatting toggle links  topic.

Tooltip: Text you enter here is displayed as a mouseover tooltip when the

user positions the mouse pointer over the toggle header. 

Icon: This option allows you to choose the image to be displayed to the

left of the toggle header/link for both expanding section toggles

and inline text toggles. You can choose no icon, one of the three

standard icons or use your own icons. 

If you choose a standard icon the icon files (one for each state) will

be copied to your project or graphics directory the first time you se-

lect the function. 

If you choose to use your own icons you can then select the graph-

ics for the two icon states in the Collapsed: and Expanded: fields. We

recommend storing the icons in your standard graphics folder  or

your project folder. See below  for more details on using your

own icons for expanding sections.

Print icons:

The icons used for expanding toggle links are often not appropriate

for printed manuals and other print-style documents (PDF, DOCX,

iBooks®/ePUB). When you select custom icons you can set a differ-

ent icon to be used in these formats. Or select Remove icon when

printing to publish without an icon.
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Toggle a Table: This option creates an expanding section toggle. 

Create a new table:

This is the standard option. It automatically creates a new, single-

cell table for the text that you want to expand. This table is inserted

directly after the toggle header (caption). The table and the header

are both automatically indented by the same amount from the icon.

Toggle the table below this link:

This option is displayed if there is a table directly below the current

position and it allows you to toggle an existing table. There can be a

maximum of one paragraph of empty space between the toggle

header and the table.

Toggle Inline Text: This option creates an expanding inline text toggle. 

Enter your text in the editing box. You cannot enter any formatting

in this box. You can enter hard returns with enter for easier editing

but they will be ignored in the generated toggle.

Note that you can also include icons with inline text toggle links.

They work the same way as for the icons in expanding text toggle

headings. 

Format text with

Style:

Applies a style to the expanding inline text, for example to make it

stand out against the rest of the text in the paragraph. 
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The Insert Toggle dialog – Screenshot Toggle mode:

Insert Toggle dialog options for expanding images

Export Options: These options control whether the toggle is expanded or collapsed

in your output. Normally, toggles are expanded in print formats

(PDF, printed manuals and Word DOCX) and collapsed by default in

supported electronic formats.

Note that toggle switching is not supported Windows Exe or ePUB

eBooks and so toggles are always displayed expanded in these

formats.
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Optional ID: This is optional and we recommend that you leave this field

blank. You only need to enter an ID here if you plan to access the

toggle IDs in the HTML code of your output for any reason.

If you leave this field blank Help+Manual will give each toggle a

unique internal ID. If you enter your own ID you must make sure

that each ID in the current topic is unique and you must also edit

your IDs manually if you copy your toggles, otherwise you will have

ID conflicts.

Picture file name: This is the full-size image to be used in your toggle. Click on the 

Browse button to select an image file directly.

Thumbnail: Size of the preview image relative to the full size of the image.

Zoom is proportional

to document width:

Makes the image responsive in HTML-based output formats. The

defined zoom size of the image will then be relative to the current

page width. For example, 50% zoom will make the image 50% of

the page width, with the height proportional to the width.

Alignment: Selecting Left or Right positions the preview image to the left or

right of the text and flows the text around it. Works the same as the

alignment option for normal images.

Padding: Inserts padding around the image. The values are in pixels. 

Tooltip:

Caption:

The tooltip and caption you enter here are normally displayed in

both the expanded and the collapsed states. The texts are automat-

ically copied to the When Collapsed: fields, which are grayed out un-

less you select them to enter different texts there.

The tooltip is displayed when the user positions the mouse pointer

over the image. The caption is displayed beneath the image using

the standard image caption style .

When collapsed use

different settings:

Normally, the toggle will use the same image, tooltip and caption

for both the expanded and the collapsed states. You can select the

options here to use a different image and enter a different tooltip or

caption.

Picture: Select this option to use a different image  in the collapsed state.

You only need to use this if you are really using a completely differ-

ent image for the collapsed state, for example an icon. Normally,

the smaller version of the image is generated automatically.

Alternatively you can use your own image for the thumbnail version.

If you do this you must create this version yourself with Impict  or
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your favorite graphics program. You must create the image with the

correct size you want to display – Help+Manual will not zoom the

image for you. 

Tooltip:

Caption:

Select these options to enter a different tooltip and/or caption for

the collapsed state.

See also:
Toggles: Expanding Text and Images

11.2.6.6.11  Caption

The caption tool in Write > Insert Object inserts an independent caption object that can be

referenced in a table of figures or tables and used as a target for topic links, in the same way

as a link to an anchor. These captions can be used just as static independent captions for im-

ages, tables or anything else, or integrated with the figure and table counters  functions. 

Topic links to caption objects

Provided you include an ID, you can link to caption objects in topic links  in the same

way as to regular anchors. The ID can be selected from the drop-down list of anchors next

to the Target: field in the Link tool. 

The caption object dialog

Type: You can create a figure, table or custom caption. These are gener-

ally used in tables of figures and tables , for which a reference

382
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variable and an ID are generated automatically. However, you can

also delete the variable and just use the object as a static caption.

ID: Generated automatically, but you can also edit it. It should be

unique in the current topic. The ID is required when you are using

figure and table counters, and for using the caption object as an

anchor target.

Label and Text: Title and content of the caption. You need to include the counter

variable in the label if you are integrating with the figure and table

counters feature.

Add to Table of

Figures

Required for the figure and table counters features.

11.2.6.6.12  HTML Code Object

This function is designed for advanced users with a good knowledge of HTML. It is used to in-

sert your own inline HTML code to be included in HTML Help and WebHelp output. Code you

insert with this function is ignored in all other output formats. 

The code you enter here is inserted directly in the output page at the point in the text where

you insert it. Your code will not be checked or parsed in any way by Help+Manual – you are

entirely responsible for making sure that it works yourself. If you include references to files

you must also make sure that they are accessible.
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The Insert HTML Code dialog:

You don't need to insert any normal page tags like <HEAD> or <BODY> and so on. these

tags already exist in the output pages.

Dialog options:

Just type the code you want to insert in the editing window. You can increase the window

size by dragging the lower right corner.

Load from File: Saves the contents of the editing window to a text file so that you

can reuse it.

Save to File: Loads the contents of a text file to the current cursor position in the

editing window.

See also:
Inserting plain HTML code 469
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11.2.6.6.13  Comment

This function inserts a comment in the current topic with information, reminders or questions

for the authors or reviewers of the project. Note that comments are an editing aid only. They

are not included in your published output! 

The Insert Comment/Bookmark dialog:

· Just type your comment in the editing box and click on OK to insert it at the cursor posi-

tion. 

· Show comment as icon only displays the comment as a red "pin" icon in the editor. 

See also:
Comments and bookmarks

Image caption and comment styles

11.2.6.6.14  QR Code

Inserts a QR code in your topic. QR codes can be scanned by smartphone cameras with little

QR apps. If the code contains a valid web link the smartphone's browser will automatically

open the referenced page when the code is scanned. QR codes can also contain text.

253
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Code Data: The data you want to encode in the QR code. This will normally be

a web link that you want users to be able to visit when they scan

the code with their smartphone. Web links must be complete, in-

cluding the http:// prefix!

In addition to web links QR codes can also contain plain text, which

will also be scanned.

Dot size: The size of the dots to be used to make up the QR code matrix, in

pixels. Larger dots can be scanned more easily and reliably but will

create larger QR codes. At least 4 pixels per dot are recommended.

Margins: A margin around the QR code graphic, in pixels.

Color: The color of the code. Only use black unless you have a very special

reason for using a different color.

Alignment: Position of the QR code in relation to the text in your topic. This is

the same as the Alignment option for graphics. It works in all out-

put formats and is shown in the editor.

11.2.6.6.15  Snippets

This option inserts a topic from the current project, a style repository project  or an external

Help+Manual XML topic or snippet file in the current topic at the cursor position. You can in-

sert snippets in two modes: Paste and Linked. Pasted snippets are just like normal pasted text

1076
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from any other source. Linked snippets are dynamically linked to the source topics or files and

will updated automatically when the sources are edited.

When you publish your project a copy of the linked snippets is inserted in the output. 

See Re-using content with snippets  for details on working with snippets.

The Insert Snippet Dialog – From Topic

This dialog inserts topics from the current project as snippets. Just select the topic ID of

the topic you want to embed from the list and click on OK to insert it. 

Dialog options:

Select topic: Select the topic ID of the topic you want to insert as a snippet.

Common options in all snippet dialog modes:

Preview Click on the preview on the right to see a full-size preview of the

snippet contents.

Copy & Paste Pastes the contents of the snippet file at the cursor position. After

this you can edit it normally, just like any other text. Pasted snip-

265
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pets are not linked to the source file.

Snippet is linked Creates a link to the original topic. The contents of the snippet can-

not be edited in the editor but they will update automatically when

the original topic is changed.

Snippet begins a

new paragraph

If this is selected the snippet begins and ends with a new para-

graph (block mode). If you deselect it the snippet will be inserted in

inline mode, which allows you to use snippets within paragraphs.

The Insert Snippet dialog – From File and From Repository:

From file:

This option is for inserting snippets from external XML topic files. You can create these

files from topics and from selected text in topics with File > Save Snippet in Project >

Manage Topics.

From repository:

This option is only available in Help+Manual Professional and only in projects linked to a

style repository. It displays the snippets stored in a style repository project linked to your

current project. It works the same as inserting a snippet from a topic in the current project.

See Working with Style Repositories  for details on style repositories.

Dialog options:

Snippet file: The snippet file you want to insert. This must be a valid

Help+Manual XML topic file or snippet file. You can create snippet

files from topics and selected text with File > Save Snippet in Pro-

ject > Manage Topics.

Help+Manual Professional only:

If you are using Help+Manual Professional you can save your pro-

jects in the uncompressed XML format (.hmxp option). When you

do this you can load any topic file from another project directly as

a snippet.

Select Topic: Select the topic ID of the topic file stored in the style repository. 

1076
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Use project search

path

Only relevant for external XML snippet files. Select this to add the

path to the snippet file to your Project Search Path  in Configur-

ation > Common Properties in the Project Explorer. If you do not

select this option the path to the snippet will be stored in the topic

with the snippet and the link to the snippet will be dead if the snip-

pet is ever moved.

It is a good idea to use this option and to keep your snippet files

organized in easily-accessible directories. You can then move your

snippets and Help+Manual will still be able to find them if you up-

date the Project Search Path. This will make it easier to transport

your entire project and to send out all the components of your

project for translation if this ever becomes necessary.

See also:
Using embedded topics

Working with style repositories

11.2.6.6.16  OLE Object

This function inserts an OLE (Object Linking & Embedding) object in the editor screen. An OLE

object is a document created by another program. If you double-click on the object in the

Help+Manual editor the document will be opened with its associated program so that you

can edit it.

Depending on how you create them, OLE objects are either embedded in your topic file or in-

serted as links. We recommend using the link method, this generates fewer overheads and al-

lows you to edit the files without opening Help+Manual.

Important: OLE objects are only linked in the Help+Manual editor. In your published output

they are just bitmap graphics. This is necessary because the documentation formats do not

support live OLE objects.

The Insert OLE Object dialog:

When you publish your output OLE objects are converted to bitmap graphics. They are not

exported to your published files as active links – this is impossible in the Help+Manual's out-

1405
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put formats. This means that you cannot use all types of OLE objects supported by your Win-

dows installation. For example, you can't insert movies as OLE objects because they would be

converted to static bitmap images.

Create from File mode dialog options:

Create from File: Insert an existing file as an OLE object.

Create New: Open an OLE-enabled program to create a new OLE object. See be-

low.

File: Click on Browse to select the file to insert. This file does not have to

be in your project folder.

Link: Inserts a link to the file instead of embedding it in your project. Re-

commended – this reduces system overheads and makes it possible

to edit the linked file without opening Help+Manual.

If you deselect this option a copy of the file will be embedded in

your project and you can only edit it by double-clicking on it in the

Help+Manual editor.

Display as icon: Displays an icon to represent the object in the editor instead of the

contents of the OLE object file. 

Create New mode dialog options:

Create New: Opens the associated program to create an OLE object and embed

it in your project file. This method is not recommended. It creates

considerable system overheads and you cannot edit the object as

an external file. Create from File (see above) in Link mode is

always preferable. 

Create from File: Switches to Create from File mode. See above.

Object Type: Select the program with which you wish to create the document for

the OLE link. Only use programs that generate documents that can

be converted to a single bitmap graphic, such as Word or Excel.

Display as icon: Displays an icon to represent the object in the editor instead of the

contents of the OLE object file. 

See also:
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Using OLE Objects

About using OLE objects

11.2.6.6.17  Special Characters

This function allows you to insert special characters not available directly via the keyboard. A

number of common special characters are available directly from the menu:

Advanced functions of the Special Characters dialog

This dialog also allows you to access and store a wide range of special characters from

special symbol fonts and use them reliably in all output formats by configuring

Help+Manual to convert them to scalable vector graphics on output. Please also see the

Special characters, lines and breaks  topic for full details on the capabilities of this dia-

log.

The Insert Special Character dialog:

Clicking on More Symbols... at the bottom of the menu displays the following dialog:

1139
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· Just select the font you want to use, then select the character and click on Insert to in-

sert it in the editor at the current cursor position. 

· You can increase the size of the character map for easier viewing by dragging the bot-

tom right corner of the dialog window.

Select font: Choose the font you want to use. Note that in specialized symbol

fonts like FontAwesome and Fontello the characters included in the

font are usually right down at the bottom of the list, after all the

normal standard characters. See the Special characters, lines and

breaks  topic for full details on using these fonts with maximum

compatibility in your output.

Range: Select the standard range of characters you want to access in the

font. These selections will work for standard fonts but may not for

specialized symbol fonts. 

Character Code: The standard hexadecimal code for the selected character. 

Add to Custom: Copy the selected character to the Custom Symbols tab (see be-

low). 

Insert: Inserts the selected character in the topic editor.

245
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The Custom Symbols tab

You can store selected symbols from the Character Map in this tab for quick access with

the Add to Custom button (see above). This works for both single symbols and sequences

of symbols. See the Special characters, lines and breaks  topic for instructions. 

Symbol Text: The symbol or symbols in the entry. A new entry is created auto-

matically when you use the Add to Custom button in the Character

Map tab. You can also create entries with the New button. 

Font: Displays and changes the font of the current entry. Changing the

font may display unexpected or garbage characters as not all fonts

will have the same symbol characters in the same locations.

Size and color: Font size and color. ;-)

New: Creates a new entry. This allows you to create entries with multiple

characters, which you can then copy from other entries.

Up/Down: Organize the entries in the list

Remove: Delete the selected entry

245
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Insert: Insert the current entry in the topic editor

See also:
Special characters, lines and breaks

11.2.7 The Table Tab

This menu contains the options for inserting and manipulating tables in your topics. Most of

these options will only be active when the cursor is actually in a table or when you have selec-

ted all or part of the table. 

Table styles:

Note that you must select Properties to select a style for the current table. To define table

styles go to Write > Styles > Edit Styles.

245
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Table tab options:

Select: Selection options for selecting all or part of the current table. 

Properties: Opens the Table Properties dialog to edit the properties of an ex-

isting table. You must select this if you want to set or change the

style for the current table. 

New Table: Opens the dialog for defining and inserting a new table at the cur-

rent cursor position. Same options as in the Write tab.

Delete: Delete rows or columns.

Rows and

Columns:

Insert additional rows and columns.

Move and Sort: Move selected rows and sort the entire table.

Merge Options for merging, splitting and unmerging table cells and rows. 

Lock Column: Locks or unlocks the width of the selected column or columns.

When column width is locked the column will not become wider or

narrower when the user resizes the viewer window on the screen.

Tables with a percentage width must have at least one unlocked

column. 

Alignment: Sets the alignment of text within cells.

Text Direction: Switch between vertical and horizontal text.

See also:
Working with Tables

11.2.7.1 Table Properties

This dialog is displayed by clicking in a table and selecting Properties in the Table tab. It

defines or changes the formatting, layout and appearance of entire tables and selected parts

of tables. It is also displayed automatically when you create a new table. See Working with

Tables  for details on creating and using tables.

518
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The Table Properties Tab:

The properties in this tab are applied to the entire table.

Table Size

Rows:

Columns:

If you are creating a new table these values define the total number

of rows and columns in the table. 

In an existing table increasing the values adds rows and columns in

the last row and column and decreasing the values deletes rows



1393

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Reference

and columns from the last row and column (i.e. rightmost column

and bottom row). 

For more precise control over adding and deleting rows and

columns use the Insert and Delete functions  in the Table menu.

Table ID: This setting is optional. It assigns an ID attribute to the <table>

tag that you can reference in your own HTML code. 

Most users should leave this blank. Only use it if you really plan to

reference your tables by ID with your own HTML and CSS code. 

If you assign your own IDs to the tables used in toggles  you

must be very careful not to use the same ID more than once in any

topic If you do your toggles will not work properly.

Layout

Table Style: Selecting this applies the selected table style  to the table. Any

attributes you change after applying a style will not be under the

control of the style – they are like manual formatting in a para-

graph formatted with a style. 

Table can split to

next page:

Tables can now split automatically at page boundaries for PDFs and

printed manuals generated with File menu > Print User Manual

. 

Page breaks are possible inside table rows but not in rows contain-

ing nested tables .

Number of head-

ing rows:

The heading rows option repeats the first x rows of the table at the

top of the table when it is continued on the following page.

If you enter 0 for the heading rows the table will not have a head-

ing.

Head row color: The background color for the heading row

Alternating row

color:

Background color for alternating table rows. The main background

color is set by the Table has solid color: setting (see below). This

setting defines the color for every other row. 

Autosize table: Creates a table that calculates its size on the basis of the contents

of its cells. The absolute width of the table in your output will de-

528
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pend on how you adjust the width of the cells and the table itself

and the content you put in them.

In the editor an autosized table initially occupies the full available

width of the current paragraph (if the paragraph has indents the

table will be narrower than the page). You can adjust column

widths with the mouse after adding content (note that this locks

the width  of the columns). 

In PDF, printed manuals and DOCX autosized tables appear ex-

actly as the are displayed in the editor, filling the entire width of the

paragraph/page.

In HTML-based output formats autosized tables are only as wide

as their content. If all columns contain full paragraphs the table will

be as wide as the page but if the columns only contain small

amounts of text the table will be narrower than the page.

Size table to fit on

page:

Creates a table that is permanently maximized to the width of the

current paragraph (if the paragraph has indents the table will be

narrower than the page). This is exactly the same as setting a width

of 100% with the Size manually option.

Tables sized with this option always occupy the entire available

width of the current paragraph or page. They can only be made

narrower by increasing the left and/or right indents of the para-

graph.

The same applies for tables inside other tables: If paragraph con-

taining the table is indented the 100% value is the width of the in-

dented paragraph, otherwise it is the width of the cell containing

the table.

Size table manu-

ally:

Creates a table with a fixed width in percent or pixels, relative to the

width of the current paragraph. Setting a value of 100% is exactly

the same as Size table to fit on page.

Here too, percentage values are always relative to the paragraph

containing the table. If the paragraph is indented the value is a per-

centage of the width of the indented paragraph; otherwise the

value is a percentage of the page width or the table cell width, if

the table is inserted inside another table. 

Note that as in HTML tables, pixel values are "preferred values"

rather than being  absolute. If you insert graphics or other objects

522
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that are larger than these values the cell widths will be adjusted

automatically so that the objects fit, and the other cells will be

made narrower accordingly.

· Note that all automatic width adjustment features can only work if the width of at least

one of the table's columns is dynamic (i.e. has no set width). 

· To set/reset click in a table column or select one or more columns. Then select Table >

Lock Column Width or right-click and select Table > Lock Column Width.

Background and Borders

These settings define the background for the entire table. You can define the background

color for individual cells in the Selected Cells  tab.

Table is transpar-

ent:

This makes the background of the page visible through the table. 

Table has solid

color:

This selects an opaque background color. If you also set a color for

alternating rows (see above) this color is only used for the alternat-

ing rows of the table. 

Background pic-

ture:

This allows you to use a graphics file as the background for your

table. See Using background graphics  in the Working with

Tables chapter for details.

Select Tile to repeat the background picture, Center to center it

in the table. 

Cell Borders

These settings work just like the formatting parameters for borders and cell spacing in

HTML tables. In all settings a value of zero turns the property off (i.e. no borders).

Cell borders: This defines the width of borders around the cells inside the table.

Border around

table:

This defines the border around the edges of the table.

Border color: This defines the color of all borders

Border style: This defines the appearance of the border. This is easier to see than

to describe – just try it out!

1391
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You can’t define different colors for individual cell borders. However, you can achieve this

by inserting a second table inside your main table. See Nested tables  for details.

Cell Padding and Spacing

Cell padding: This is the space between the edge of the cell contents and the

border of the cell.

Cell spacing: This is the space between the border of one cell and the border of

the next cell. This is effectively like making a broader border

between the cells but it doesn't affect the width of any border lines

you define between the cells.

You can only define padding and spacing for the entire table. If you need different set-

tings for individual rows, columns or cells you can achieve this by using nested tables .

The Selected Cells tab: 

The properties in this tab are applied to selected cells only. If no cells are selected the

Selected Cells properties are applied to the cell in which the cursor is located.

539
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To apply these options to a single cell just click in the cell you want to format before se-

lecting Table Properties. You don’t need to drag to select a single cell.

Cell Options

Note that adjusting the size of cells manually with the mouse automatically resets the set-

tings configured in this section.

Preferred width: This sets the target width of the selected cells/columns in pixels or

percent. Percent values are relative to the width of the table. If this

is set to 0 the automatic width is calculated as the table width di-

vided by the number of columns, unless graphics or other objects

force different widths for individual columns.

If you set the preferred width to a non-zero percent or pixel value

the editor will attempt to achieve the specified value but the widths

will be adjusted if it is not possible. The width of content such as

graphics or other objects always has priority. If you insert an image

wider than the preferred width the cell will be made wider so that

the image fits, for example.

Height at least: This is the minimum height of the cell/row. If it is 0 the height is cal-

culated automatically on the basis of the cell contents. If it has any

non-zero value the cell/row will be at least that high, and higher if

necessary to accommodate the content.

Background color: Sets a different background color for individual cells.

Vertical alignment 

Top / Center:

Bottom / Default:

These options control the vertical positioning of text and other con-

tent within the selected cells. They are pretty self-explanatory.

Cell borders 

Cell borders: Set individual border options for the selected cell(s). 

See also:
Working with Tables 518
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11.2.8 The View Tab

The View menu contains options for changing Help+Manual's appearance and behavior. In

addition to changing the color and style of the program window you can also access the Pro-

gram Options  dialog with extensive configuration options for all aspects of the program. 

Most of the settings in these dialogs are self-explanatory. For more details see Options &

Keyboard Shortcuts .

View menu options:

Program Op-

tions

Customize the way Help+Manual works, see Program Options  for

full details.

Also available in the File menu .

Color Scheme Select from a variety of themes for the Help+Manual user interface.

Text size Adjust the size of the text displayed in the Help+Manual user interface

Toolbar op-

tions

Position and visibility of the ribbon toolbar

Save/Load

Preferences

Saves all your preferences and program settings, including your license,

to a text .ini file. You can then load these preferences from the file to

completely restore your entire Help+Manual configuration. This can be

very helpful when setting up a new computer, or for making sure you

have the same settings on your desktop and laptop machines.

What is included:

All user preferences, license key, keyboard shortcuts, recent pro-

jects, Quick Access Toolbar  settings, pinned projects, syntax

highlighter configuration and everything else that you can config-

ure.

What is not included

Window positions, since these are usually not relevant on a second

computer.

Reset Windows

Settings / User

Preferences

These two options reset everything to the factory defaults. The Window

Settings option resets all the appearance settings. The User Prefer-

ences option resets all your settings for the entire program.

1261
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This option can be a first alternative to reinstalling if you think there is

some problem with your installation.

Change File As-

sociations

Opens the utility program fileasoc.exe, which requires administrator

permissions. 

This program sets or changes the default application for

Help+Manual's file extensions (.HMXZ, .HMXP, .HMXR, .MNL and .IPP).

In other words: which program starts if you double-click on such a file

in Windows Explorer. This tool is helpful if you unintentionally changed

those file associations in Windows, or if you have installed an additional

older version of Help+Manual after installing version 8.

Edit Proxy Set-

tings

Opens the utility program proxyedt.exe, which requires administrator

permissions.  

This specifies a proxy address, user name and password for Internet ac-

cess, in particular to automatically check-out floating licenses . If your

organization uses a mandatory internal proxy server for Internet access,

these settings might be required to get an Internet connection.

proxyedt.exe creates an INI file named proxy.ini in the application

folder. Once created, you can deploy this INI file to other workstations

by copy & paste, if they are using the same credentials.

See also:
Customize

Customizing Help+Manual

11.2.9 The Help Tab

The Help tab provides access to this help file (Online Help), which can also be accessed at any

time by pressing the F1 key. In addition, this menu also contains a number of links to specific

important information and how-to topics in the help and some useful links to the EC Software

website. 

You can also check whether you are using the latest version of Help+Manual with the Check

for Update function and send a mail to support with the Customer Support link.

License and Maintenance

Check the current status of your license and maintenance, change the license key, enter

and purchase maintenance extensions. 

37
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11.3 Project Configuration Settings

The Configuration section in the Project Explorer menu is the control center for your project.

Unlike the settings in View > Program Options (which are program settings), all the settings

you enter here are stored in your current project and are only available to the project in which

they are stored. They define all the basic parameters for your help project and how it is output

to the formats supported by the program.

Productivity Tip
You can use both user-defined variables and global

variables in the text fields in your configuration set-

tings. For example you could use © <%\YEAR%> by

<%AUTHOR%> for your copyright message.

There are three groups of settings in the program configuration settings: Common Properties,

HTML Page Templates and Publishing Options.

Common Properties:

These settings define things like the name of your project displayed in help window title

bars, copyright messages, language settings, where images and snippet files used in the

project are stored, text variables used in the project and so on. This is also where you will

find the help window definitions used to configure the help viewer for Microsoft HTML

Help (CHM). 

It is always a good idea to check all the settings in this section when you create a new pro-

ject.

HTML Page Templates:

The HTML page templates are combined with the contents of your topic pages when you

publish to most HTML-based output formats (ePUB and Kindle eBooks have their own

page template). The template provides everything above and below <body> </body>

tags, the content from the editor provides everything that goes between the body tags.

Advanced users can edit the source code of the HTML page templates directly to custom-

ize their output in any way they like. 

HTML page templates in skins:

If you are using a skin the HTML page template in your project is not used. It is replaced

by the template in the skin. If you want to make changes, you need to edit the HTML page

template in the skin, not in your project.
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Publishing Options:

These settings are organized in sections by output format. They allow you to control how

each output format is handled, providing a high degree of customization. For example, in

the WebHelp section you can directly edit all the additional HTML templates that define

the frameset and the Contents, Index and Search pages of your WebHelp output. In HTML

Help you can configure different modes for popup topics, in PDF you can choose between

interactive and static PDF files and so on.

11.3.1 Common Properties

Most of these settings are "housekeeping" for your project. They include things like the title

of your project, language settings, customized topic status settings and the locations of im-

ages and snippet files used in the project.

In addition to this section also includes settings for some of Help+Manual's special features:

Text Variables:

This section allows you to define and store any number of variables for use in your pro-

ject. You can use both plain text variables for inserting text anywhere in your project (also

in the TOC, keywords and Configuration) and HTML variables for inserting HTML code in

your HTML templates and HTML code objects.

This is very useful for texts that may change after you create your project, such as pro-

gram names and so on. You can then change the texts in your entire project just by edit-

ing the variables, and you are always sure that all instances have been changed.

Custom Builds:

This section allows you to define your own include options . Include options are like

tags that you use to include or exclude text, topics, chapters or entire modules from your

help output. You simply tag content with your include options in your project and then se-

lect or deselect the corresponding options in the Compile Help File  dialog when you

publish.

Miscellaneous Options:

This may sound unimportant but it isn't! Some key settings that don't fit anywhere else

are stored here, so do check it out. 

988
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11.3.1.1 Title & Copyright

Help title: The title of your help project. The text you enter here can be inserted

anywhere in your project with the  <%TITLE%> variable. 

For example, in HTML Help you can display it in the title bar of the

help viewers by inserting the <%TITLE%> variable in the Title bar

text: field for the Main help window definition in the Help Win-

dows  section (this is the default setting). 

In WebHelp this text is inserted in the title bar of the web browser by

using the <%TITLE%> variable in the <title> tag of the frameset

file in the Layout  section (this is the default setting).

Author: The author of your help project. This text is not used automatically

by Help+Manual. You can insert it yourself anywhere in your project

with the <%AUTHOR%> variable.

Summary: A short text describing your project. This text is not used automatic-

ally by Help+Manual. You can insert it yourself anywhere in your

project with the <%SUMMARY%> variable.

Copyright: The copyright notice for your project. This text is not used automat-

ically by Help+Manual. You can insert it yourself anywhere in your

project with the <%COPYRIGHT%> variable.

Comment: Space for a comment about your project. This text is for internal in-

formation and documentation only. There is no corresponding vari-

able so you cannot insert it in topics in your project.

Major Version:

Minor Version:

Build Version:

These fields have four corresponding variables that can be used to

generate three-part version numbers. 

The variables corresponding to the individual components are <%

VERSION_MAJOR%>, <%VERSION_MINOR%> and <%VERSION_BUILD

%>.

The fourth variable, <\%VERSION%>, combines the contents of the

three fields with dots between them, like this:

6.5.456

Default ("Home")

topic:

This setting specifies the topic that is automatically displayed when

an electronic help file is opened (HTML Help, WebHelp, eWriter

1452
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Help). This setting is not supported in ePUB eBooks.

See Setting the default topic  for full details on setting and using

the default topic in different contexts.

You can also use a user-defined variable in this setting to insert the

topic ID of the default topic. Just type the variable name into the De-

fault Topic field using the standard <%VARIABLE_NAME%> syntax.

This makes it possible to define the default topic dynamically by

changing the definition  of the variable when you publish. 

Note on Home topic and CHM publishing:

When you are working in Help+Manual and publish a CHM it will try

to display with the topic you are currently working on, not with the

Home topic. This won't affect the CHM when it is opened directly or

by your application, it is just a convenience for use when you are

testing while working with Help+Manual.

See also:
Creating Projects

Using Variables

11.3.1.2 Language Settings

These settings are very important for correct handling of languages and character sets in your

output. Before making any changes here please study the International Languages and

Unicode  chapter in the Reference section carefully. For more detailed instructions for indi-

vidual languages please also refer to International languages setup  in the Creating Pro-

jects chapter.

Language of help

file:

Defines the language of the help file. This option controls sorting

in the keyword index and full-text search in the published help file.

In addition to this it also identifies the language to the system for

proper handling of languages with special character sets and lan-

guages requiring Unicode  for proper processing.

· The default setting (English United States) works correctly

for all Western European languages and should not be changed

unless really necessary.

· The language setting should be changed for Eastern European

languages (including Greek and Turkish) and the Font character

set setting (see below) should then be set to match.

· This setting must be changed for all Asian languages and other

languages requiring Unicode  support (all languages with

128
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917

1627

143

1627

1627
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more than 255 characters that store characters as two bytes).

Here too, the Font character set must also be set to match. Cor-

rect Unicode support for these languages is not possible without

a correct language setting and a matching font character set set-

ting.

Bi-directional Lan-

guage Mode:

This setting is for activating support for right-to-left languages like

Arabic, Hebrew and Farsi. The default is Left to Right and it should

only be changed if you are working with a right-to-left language

like Hebrew, Farsi or Arabic.

Right-to-left support is only available in HTML Help (CHM). It is not

supported in any other output format.

The setting makes radical changes in the way Help+Manual oper-

ates, switching the direction of all the texts in the editor, TOC and

everywhere else, both in Help+Manual itself and in the published

output.

Font character set: Defines the character set to be used both in your published help

file and in the Help+Manual editor. 

· The default setting (ANSI_CHARSET) should be used for English

and all other Western European languages.

· This option must be set to the correct, specific character set for

all Eastern European languages (including Greek and Turkish).

Furthermore, this setting must match the Language of the help

file setting.

· This option must also be set to the correct, specific character set

for all languages requiring Unicode  support (most Asian lan-

guages and other languages with more than 255 characters). In

these languages too it is essential to set both this option and the

help file language option to the correct, matching settings for

the language you are using.

Default font: This is not the default font for your help file! This option only sets

the font used by Microsoft HTML Help for dialog boxes and table

of contents entries. The default is MS Sans Serif,8,0 and HTML Help

is optimized for this font and font size. If you change this font al-

ways test thoroughly before publishing your help.

The value 8 defines the font size and should generally not be

changed. The value 0 defines the character set. You do not need to

1627
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change the character set value – if it is necessary Help+Manual will

do this for you automatically when you publish your project.

See also:
International Languages Setup  (Procedures)

International Languages and Unicode  (Reference)

Test-publishing Asian languages on non-Asian Windows

11.3.1.3 Project Search Path

This section contains the relative paths to folders where you store the graphics and external

snippet files  used in your project. 

Key Information
The project search paths are all relative to the project

directory – the full path is only shown for information.

This makes it easier to move your project and your

graphics and snippets folders.

How Help+Manual locates graphics and snippet files:

When you insert an image or snippet file in your project Help+Manual only stores the file

name, it does not store the path to the file. It finds the file by searching all the folders lis-

ted in the Project Search Path, in the order in which they are listed. 

This makes it easy to move project and graphics folders to other locations. However, it

also means you must be careful to avoid duplicate graphics file names in different folders.

See Managing your graphics  for more information.

143

1627

613

265

514
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Controls:

To insert a new entry click on Add Entry and navigate to the folder

you want to add.

To delete an entry click on the entry to select it, then click on Re-

move Entry. 

The Move Up and Move Down buttons move entries up and down in

the list. This controls the order in which Help+Manual searches

folders to locate graphics files.

Remember that Help+Manual always inserts the first file with a

matching name that it finds with a matching name. If two folders in

the search list contain files with the same name the first file will al-

ways be inserted. The second file will never be found.

See also:
Using Graphics

Reusing content with snippets

Managing your graphics

11.3.1.4 Text Variables

This section allows you to define and store any number of variables for use in your project.

This is very useful for texts that may change after you create your project, such as program

names and so on. You can then change the texts in your entire project just by editing the vari-

ables, and you are always sure that all instances have been changed.

Key Information
Plain text variables can include other variables as part

of their definition. HTML variables cannot include vari-

ables in their definitions.

Plain text variables and HTML variables

You can define variables as either plain text variables or HTML variables. 

Plain text variables can be used anywhere and everything they contain will be rendered

as plain text, including HTML code. 

HTML variables can contain HTML code. If they are used in topics only the plain text part

of the code will be inserted, for example the text portion of a hyperlink. The HTML code is

only used when the variables are used in HTML templates and HTML code objects. If you

479

265

514
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insert an HTML variable in locations where HTML code is not supported (for example the

main editor) only the plain-text portion of the variable value will be used. If there is no

plain-text portion nothing will be inserted.
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Controls:
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Add Add a new variable to the list. Variable names can contain spaces. Vari-

able names are converted to all upper case characters automatically. 

After creating a variable select the Type (HTML or Text), then enter the

value in the Value column. There is no effective limit on the amount of

text you can enter. The theoretical limit is 2 gigabytes, which should be

enough for most purposes.

Delete Select to delete variables from the list. Does not check whether the

variable is in use in your project. You can select multiple variables for

deletion with SHIFT+Click and CTRL+Click. This also works with mul-

tiple variables with unselected variables between them.

Undefined variables will be output to your project as the variable

name. You can search for them and remove them as normal text with

Find & Replace in the Write tab.

Import Imports a list of variables and corresponding values from a plain text

file using the standard INI format, adding them to the project's vari-

able list. You must set the variable type (HTML or Text) manually after

importing the list – the type cannot be stored with the list. INI sections

are not supported, so please don't use them.

Syntax: VARIABLENAME=Variable value

Enter one variable per line without spaces on either side of the = sign

and with a hard carriage return at the end of each line. 

Example:

PRODNAME=Widget Confabulator 3
PRODUCT PATH=\Application\Widget\Program
WEBSITE=<a href="http://www.acmecoyote.com/">Acme Coyote
Products</a>
CURRENT LOCATION=Bombay, India

Export This function exports the current variable list to a text file, using the

same format as shown above. (You can use this to get a full example

of the format if you like.)

This only includes user-defined variables. Help+Manual's own pre-

defined variables are not exported.

Move Up

Move Down

Sort

These functions help you to arrange the variables list. The Sort button

sorts the entire list alphabetically. The Move Up and Move Down but-

tons move individual variables up and down in the list. You can select

multiple variables for moving with SHIFT+Click and CTRL+Click. This

also works with multiple variables with unselected variables between

them.
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See also:
Using Variables

11.3.1.5 Custom Builds

This section allows you to define your own include options, which are also referred to as build

options. These options s are like tags that you use to include or exclude text, topics, chapters

or entire modules from your help output. You simply tag content with your include options in

your project and then select or deselect the corresponding options in the Publish  dialog

when you publish.

See Conditions and Customized Output  for details on using this function in your projects.

Controls:

 Select to add a new user-defined build option. 

Spaces and a number of special characters are not allowed in build op-

tion names. They will simply be removed if you enter them. It is best just

to use A..Z and 0..9. All the characters you enter will also be converted to

upper case.

The Display Text is displayed in the lists of build options used in the pro-

gram to help you identify the individual options. By default it is the same

as the build option name but you can change it if you want. Just click in

the text in the Display Text column and edit.

Deletes the current build option from the list.

Note that Help+Manual does not check whether you have used the in-

clude option in your project when you do this! 

Undefined include option tags used in your topics will still be functional

and since you cannot select them in the Compile Help File  dialog they

will always exclude the text they enclose.

See also:
Conditions and Customized Output

11.3.1.6 Topic Status

This section allows you to modify the standard "topic status" colors and names that you can

use to identify topics in the Table of Contents while you are working. You can also define as

many custom status types as you like. When you publish your project you can select Export

"complete" only to exclude unfinished topics from your published output.

917
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969
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Controls:

 
Define a new custom status. You will first be able to define the new

status name then the color picker will be displayed so that you can define

the highlight color. Choose a light color that will not obscure the black

text in the Table of Contents!

Deletes the current status definition from the list. You can only delete

user-defined status definitions. The three standard definitions cannot be

deleted.

Edit the name and color of the current status definition.

See also:
Topic icon, status and timestamps

11.3.1.7 Miscellaneous Options

The settings in this section set the read-only attribute for merged child projects and allow you

to automatically generate help context numbers and prefixes for topic IDs for new topics.

Help context numbers are sometimes used to make direct calls to help topics from application

programs. Topic ID prefixes are useful for preventing duplicate IDs in modular help systems.

Topic ID Prefix: Any text you enter here is automatically added as a prefix to the

suggested topic ID when you create a new topic. Note that this

function can only be used for new topics; you cannot automatically

change existing topic IDs.

Help Context

Numbers:

If you activate this function help context numbers will be assigned

to new topics automatically, starting with the Start with number.

Each new number will be generated by incrementing the last num-

ber assigned by the Increment by setting.

This function will only be used for new topics and anchors created

after it is activated. You can add, delete and change the context

numbers of existing topics with the Help Context Tool .

Apply help context numbers to topic anchors:

This setting will also automatically generate help context numbers

for new topic anchors  so that anchors can also be used for calls

to help topics from applications.

373

1241

415
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Write translation-

friendly XML

This "Tidy XML" feature significantly simplifies the XML source

code of your topics, reducing the amount of tag information that

needs to be written. This can make translation with XML-based

tools easier but it is not compatible with earlier versions of

Help+Manual. 

Make sure you have a backup of your project before applying this

option. Otherwise you will have trouble accessing it with earlier

versions if you ever need to. 

History Files: Configure whether history files are automatically created for

changed topics so that you can revert to previous versions if ne-

cessary. History files are then saved every time you save your pro-

ject.

See Topic History  for details.

Calculate figure

tables:

This option does a preliminary generation pass of your project to

calculate the numbers and captions of figures, tables and captions

using the figure table references. It is needed to enable forward

references to these elements to work – i.e. references to figures

coming later in the project than the reference. 

It is semi-automatic: If it is off and Help+Manual finds a figure

table reference that needs advance calculation during export, it will

stop with an error and ask you to restart. After this, it will be left on

for the project until you turn it off.

Note that leaving this on will roughly double the time it takes to

publish a project, so turn it off unless you really need it.

See Inserting figure links  and Figure and table counters  for

details.

Open child projects

read-only:

This protects child projects merged into the TOC of the current

project against accidental editing. This is the default setting. 

See Working with Modular Help Systems  for more information

on editing merged child projects.

See also:
Topic IDs and context numbers

IDs and context numbers in modular help

Working with Modular Help Systems

Anchors - jump targets
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11.3.2 HTML Page Templates

This section allows you to edit the HTML templates that define the layout and general appear-

ance of your topic pages in all HTML-based output formats. See Using HTML Templates

for full details.

HTML page templates are shared:

Note that the same HTML templates are used for most HTML-based output formats

(HTML Help, WebHelp, eWriter Help and both versions of Visual Studio Help). The only ex-

ception are ePUB and Kindle eBooks. The layout for these eBooks is extremely strict and

they uses special template generated by Help+Manual. You can edit this template in Con-

figuration > Publishing Options > eBooks, but please only do so if you are familiar with

the eBook specifications.

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

Simple Template Layout tab:

The Simple Template Layout tab hides the HTML code of the page template and allows

you to make some simple changes and additions. This mode is recommended if you do

not have experience with editing HTML code.

1026

667
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Disabled Simple Layout tab:

The Simple Layout tab will be disabled as soon as you edit source code to prevent acci-

dental deletion of your custom code. It can only be re-enabled by clicking on the Reset

Template button. This will delete the edited code and replace it with the standard tem-

plate

Add / Delete Create new HTML templates and delete existing ones. You

can assign page templates to individual topics when you

create them and in the Topic Options tab on the left of the

main editor window.

Reset Defaults Resets the current page template to the default settings.

Header /Text background

color:

Defines the background colors of the topic header and

text. 

Text above topic:

Text below topic:

Any text you enter in these two editing boxes will be inser-

ted on every page above and below the main text of your

topic. 

HTML code is permitted but you are responsible for the

correct syntax.

Topics with headers have

<Top>, <Previous> and

<Next> links:

Activating this option adds additional navigation links to

the headers of your topic. These links always point to the

Top topic (the home topic defined in Configuration >

Common Properties > Language Settings) and the Next

and Previous topics in your help.

You can edit the captions of the links in the Caption

column but you cannot change their functionality. 

By default the links are text-only. You can create button

links by selecting graphics files for your buttons in the

Image File column. Use the  browse button to locate the

graphics files. 

HTML Source Code tab:

In this mode you can edit all the code of the HTML templates for your help window defini-

tions manually with a basic HTML code editor with syntax highlighting. Experience with

editing HTML code is needed – please don't change or delete anything here unless you
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really understand what you are doing!

Disabled Simple Layout tab:

The Simple Layout tab will be disabled as soon as you edit source code to prevent acci-

dental deletion of your custom code. It can only be re-enabled by clicking on the Reset

Template button. This will delete the edited code and replace it with the standard tem-

plate

See also:
Templates and Secondary Windows

Using HTML Templates

11.3.3 Publishing Options

The options in this section configure how your project is published to the supported output

formats. You should always check through all the settings in the relevant section before you

output to a new format.

See also:
Publishing

Configuring Your Output

11.3.3.1 WebHelp

The settings in this section control how your project is exported to WebHelp, which can be

displayed with any modern web browser. Help+Manual's WebHelp provides a layout similar

to that of the HTML Help viewer so that it can be used intuitively by all Windows users. In ad-

dition to a Table of Contents with expanding and collapsing chapter entries it also includes a

keyword index and full-text search and supports JavaScript popups  that will also work

transparently on all modern browsers.

Shared settings:

The options in the HTML Export Options section for WebHelp are also used for eBooks

(ePUB, Kindle/Mobi) and eWriter Help. These settings are accessible in the WebHelp

section of your project configuration. Settings that are not relevant for individual formats

are ignored in those formats.

See also:
WebHelp  (Help Formats)

WebHelp  (Configuring Your Output)

11.3.3.1.1  Layout

This section defines the HTML template  file containing the source code of the main page

of your WebHelp output, which is normally called index.html. The default setting is Integ-

rated and you should leave this unchanged for most projects. 
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· For more background information see WebHelp  in the Configuring Your Output

chapter and WebHelp  and Browser compatibility  in the Reference > Help

Formats chapter.

· There are also some special variables you can use in the layout page's HTML template.

For details see HTML template variables  in the Reference section.

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

Simple Options

Simple Options provides basic configuration options without source code editing. Please

only use the options available here if you are not familiar with editing HTML code manu-

ally.

HTML Source Code tab:

This tab allows you to see and edit all the code of the TOC template manually. Experience

in editing HTML code is necessary for using this mode! Note that the code in this template

is essential for the proper functioning of the TOC. Please don't change or delete anything

that you don't fully understand!
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Disabled Simple Layout tab:

The Simple Layout tab will be disabled as soon as you edit source code to prevent acci-

dental deletion of your custom code. It can only be re-enabled by clicking on the Reset

Template button. This will delete the edited code and replace it with the standard tem-

plate

Editing window: The editor provides full HTML syntax highlighting to make

editing easier. To enlarge the window for easier editing just

resize the window.

This button automatically clears the HTML template and re-

loads the default template. Use with caution. This function

completely overwrites all your editing changes in the source

code!

Applying this change re-enables the Simple Layout Tab.

Integrated

This is the modern version of WebHelp and should be preferred for most purposes. It uses

an HTML5-based layout with iFrames instead of the deprecated frameset used in the clas-

sic two-frame and three-frame layouts. When you choose this option the Layout template

is your main index.html file. 

Background color: The color of the background page visible around the navigation,

topic and header panes.

Width of left

frame:

Width of the navigation pane in pixels. The TOC, Keyword Index

and Search are displayed in this pane.

Frame margins: Free space around the WebHelp panes on the page.

Frame border: Width of the border line around the three frames on the page.

Header height: Height of the header pane across the top of the page.

Header HTML con-

tent:

By default the header only contains the title of your project.

However, you can include anything you like here to provide a

header that will integrate the help in the rest of your website.
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No frames

Choose for manual website integration. This uses the TOC page as your main index.html

file instead of the layout page. There is then no integration in a user interface and the

TOC, Index, Search and Topic pages are all separate. 

If you choose this option you should also turn off the navigation option  that forces

loading of the user interface when topic pages are opened on their own. 

Classic two-frames and three frames

These two layouts use a classic HTML4 frameset layout with a frameset page containing

normal frames. These components are now deprecated and you should only use them if

you have a specific reason for doing so. When you choose one of these options the Lay-

out template is your main index.html file. 

The three-pane layout gives you an additional frame above for integration in your web-

site. You can use the top frame to insert your standard website header components.

1422
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Show borders between

frames:

Displays border lines between the two or three frames of

your layout. Turn off for a "seamless" look.

Width of the left frame: Defines the width of the navigation frame containing your

project's TOC. Only displayed if a frame mode is activated.

You can enter the values as either pixels or percent:

· Values under 100 are interpreted as percent.

· Values above 100 are interpreted as pixels.

Height of head frame: Only displayed if the Three Frame option is selected. Defines

the height of the head frame in pixels. The height of this

frame is always fixed so you must choose the right height to

match the layout of the file you are loading into the head

frame.

Head frame has scroll-

bars:

Only displayed if the Three Frame option is selected. If you

deselect this no scrollbars will be displayed, even if the con-

tent does not fit in the head frame. Deactivate for a seamless

appearance (you must plan the height of your head frame

content precisely for this to work properly).

Head frame loads ex-

ternal file:

Select to load an existing HTML file into the top frame. Only

displayed if the Three Frame option is selected. 

Enter the name of the HTML file you want to load into your

top frame here. Filenames are case sensitive in most web

servers so be careful to enter the entire name correctly.

Enter the absolute or relative path to the file if is not going

to be in the same directory as your help (for example if you

are going to use the standard header file for your website). 

Important: Help+Manual will not copy this file or any files

that it references to your output folder for you! You are re-

sponsible for ensuring that the file and any files it references

(graphics etc.) are stored in the correct location.

Examples:

File will be in help directory:

headframe.html

File will be in another directory two levels up from your help

on the server:

././headframe.htm

File will be on a different server:

http://www.servername.com/general/head-
frame.htm

Edit head frame HTML

code:

Choose this option to create and edit the HTML code to be

loaded into the head frame directly. Only displayed if the

Three Frame option is selected. 

When you choose this option the head frame file is gener-

ated automatically using the code you enter here when you

publish your help. You can reference graphics and other files

in it in the same way that you would in all other HTML tem-

plate files. 

Please study Using HTML Templates  first.1026
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See also:
Using HTML Templates

WebHelp  (Configuring your Output)

WebHelp  (Help Formats)

HTML template variables  (Reference)

Browser compatibility

11.3.3.1.2  Navigation

These settings control how the navigation is handled in your WebHelp output. Like the set-

tings in the Layout template, they are important for the functionality and appearance of your

help in web browsers. You should always check them before publishing your WebHelp to

make absolutely sure that the help will behave as you want.

For more information see WebHelp  in the Configuring Your Output chapter and We-

bHelp  and Browser compatibility  in the Reference > Help Formats chapter.

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

Include Keyword Index

Include Full-text Search

These features should be self-explanatory. They simply

switch individual features in your WebHelp on and off. 
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Note that Full Text Search is only available in the Profes-

sional and Floating license versions of Help+Manual and will

only work if the user has JavaScript enabled.

If you activate search you should also configure the search

options in the Full Text Search  section.

Add chapter numbers to

Table of Contents:

Adds topic/chapter numbering to the TOC in your WebHelp

output.

Numbering format string:

This string defines the format of your chapter numbers. The

standard format is standard legal numbering (1.1, 1.2 etc.),

defined by the string 1.1.1.1.1.1

The characters in the string are processed in pairs for each

level: A format character followed by a spacing character.

Enter as many pairs as you need for the levels in your pro-

ject. There are five format characters you can use. Do not in-

clude a spacing character after the last format character.

Format characters: (only these characters allowed)

1 = Numeric/Arabic

I = Roman, upper case

i = Roman, lower case

A = Alphabetic, upper case

a = Alphabetic, lower case

Examples:

Format String Result

1.1.1.1.1.1  "1.4.5" or "2.1.16.7.9"

I 1.a.1.a.1 "I 4.e" or "II 1.p.7.i"

I-1.1  "I-4.5" or "II.1.16"

A.i.1.1.1.1  "A.iv.5" or "B.i.16.7.9"

Single click on caption in

Table of Contents ex-

pands chapter:

By default, the user must double-click on chapters to expand

them in the TOC. This option allows you to change this to

expand on a single click.

Note: 

We recommend leaving this option off. The default mode al-
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lows you to select chapters without expanding them auto-

matically and you can still expand chapters with a single click

on the chapter icon. 

Automatically collapse

unfocused entries:

When you set this option all chapters except the chapter in

which the user is currently browsing collapse (close) auto-

matically. This can make navigation easier in large help pro-

jects because you do not have a large number of chapters

open at the same time.

Note:

Selecting this option will disable On load, expand... All Entries

(see below)

On load, expand: Allows you to expand the TOC automatically when the user

opens the help. You can expand either all entries or just top-

level entries (main chapters).

Note:

Expand All Entries is disabled when Automatically collapse

unfocused entries is selected (see above).

When a topic is loaded

outside the navigation

frame, force it to reload

the navigation frame

Leave this OFF if you want your WebHelp to be indexed by

Google!

Turning this on automatically reloads the entire WebHelp in-

terface automatically when a topic is opened directly with a

link to the topic file only (topicname.htm) instead of the

full WebHelp syntax (index.html?topicname.htm).

In the past, Help+Manual automatically activated this option.

Unfortunately, Google now interprets redirects like this as

"duplicate content" and does not index any of the WebHelp

topic pages on a site that does this. This option is now

turned off by default and you should not activate it if you

want to be indexed by Google. 

The standard WebHelp skins included with Help+Manual

and the Premium Pack skins now have a solution for this

problem. When a page is opened on its own an automatic

link above the topic header is shown that the user can click

on to open the full user interface. This does not trigger the

problem with Google.
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Create a site map for im-

proved search engine

visibility:

Generates an XML site map file that will be automatically

read by search engines like Google, Yahoo!, Ask and Bing.

The site map tells the search engine where all your topics are

and when they were last updated. This can improve search

engine efficiency when scanning your site.

Topics excluded from site map: Note that topics with IDs

beginning with an underscore character (_) are excluded

from the site map because they are also excluded from full-

text search. 

Full website URL: You must enter the fully-qualified URL to

your WebHelp folder on your website here, including the

http:// protocol prefix and the last slash. For example:

http://www.yourdomain.com/info/help/

Icons in the TOC: If you want you can select your own icons to be used in the

Table of Contents here. If you select custom icons stored in

folders listed in your Image Folders  they will be copied to

your output directory automatically.

If you use custom icons you can only use a set of three icons:

One pair for the open/closed state of chapters and one icon

for individual topics.

See also:
WebHelp  (Configuring your Output)

WebHelp  (Help Formats)

Browser compatibility

11.3.3.1.3  Table of Contents

This section provides access to the HTML template  file that contains the source code of the

Table of Contents pane in your WebHelp output. the See Using HTML Templates  for full

details.

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.
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Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

Simple Template Layout tab:

This mode is recommended if you do not have experience with editing HTML code!

Text above TOC head-

ings:

Text below TOC head-

ings:

Any text you enter in these two editing boxes will be inserted

above and below the TOC tree with the topic entries. For ex-

ample, you might want to enter the title of your project

above the tree and a copyright notice below the tree. HTML

tags are allowed.

The default code inserts the title of your project and links to

the Keyword Index and Full-text Search panes (if activated in

your settings). Please do not change this code unless you

really understand how it works.

Format of TOC headings: These settings define the formatting styles to be used for the

headings in your TOC. You can use up to six levels. However,

note that users will normally find anything more than a max-

imum of three levels generally and four in exceptional cases

confusing and difficult to navigate.

This button automatically clears the HTML template and re-

loads the default template. Use with caution. This function

completely overwrites all your editing changes! 
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Disabled Simple Layout tab:

The Simple Layout tab will be disabled as soon as you edit source code to prevent acci-

dental deletion of your custom code. It can only be re-enabled by clicking on the Reset

Template button. This will delete the edited code and replace it with the standard tem-

plate

HTML Source Code tab:

This tab allows you to see and edit all the code of the TOC template manually. Experience

in editing HTML code is necessary for using this mode! Note that the code in this template

is essential for the proper functioning of the TOC. Please don't change or delete anything

that you don't fully understand!

Disabled Simple Layout tab:

The Simple Layout tab will be disabled as soon as you edit source code to prevent acci-

dental deletion of your custom code. It can only be re-enabled by clicking on the Reset

Template button. This will delete the edited code and replace it with the standard tem-

plate

Editing window: The editor provides full HTML syntax highlighting to make

editing easier. To enlarge the window for easier editing just

resize the window.

This button automatically clears the HTML template and re-

loads the default template. Use with caution. This function

completely overwrites all your editing changes in the source

code!

Applying this change re-enables the Simple Layout Tab.

See also:
WebHelp  (Help Formats)

Using HTML Templates

HTML Templates  (Reference)

11.3.3.1.4  Keyword Index

This section allows you to edit the HTML template  that defines the layout and appearance

of the Keyword Index pane in your WebHelp output. See Using HTML Templates  for full

details.
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If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

Simple Template Layout tab:

This mode is recommended if you do not have experience with editing HTML code!

667
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Text above Keyword Index: Any text you enter in this editing box will be inserted

above the Keyword Index. HTML tags are allowed.

The default code inserts the title of the Keyword Index

and links to the TOC and Full-text Search (if activated in

your settings) panes. Please do not change this code un-

less you really understand how it works.

Keyword Index Font: These settings define the font styles to be used for the

components of your Keyword Index. 

Index Separators: These entries generate the headings for each letter group

in the Keyword Index. If your help is not in English you

can add appropriate letters for your language.

This button automatically clears the HTML template and

reloads the default template. Use with caution – this

function completely overwrites all your editing changes! 

Disabled Simple Layout tab:

The Simple Layout tab will be disabled as soon as you edit source code to prevent acci-

dental deletion of your custom code. It can only be re-enabled by clicking on the Reset

Template button. This will delete the edited code and replace it with the standard tem-

plate

HTML Source Code tab:

This tab allows you to see and edit all the code of the TOC template manually. Experience

in editing HTML code is necessary for using this mode! Note that the code in this template

is essential for the proper functioning of the TOC. Please don't change or delete anything

that you don't fully understand!
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Disabled Simple Layout tab:

The Simple Layout tab will be disabled as soon as you edit source code to prevent acci-

dental deletion of your custom code. It can only be re-enabled by clicking on the Reset

Template button. This will delete the edited code and replace it with the standard tem-

plate

Editing window: The editor provides full HTML syntax highlighting to make

editing easier. To enlarge the window for easier editing just

resize the window.

This button automatically clears the HTML template and re-

loads the default template. Use with caution. This function

completely overwrites all your editing changes in the source

code!

Applying this change re-enables the Simple Layout Tab.

See also:
Using HTML Templates

HTML Templates  (Reference)

WebHelp  (Help Formats)

11.3.3.1.5  Full Text Search

This section configures the Full-text Search function for WebHelp output. It includes both the

options for configuring the behavior of the search function and the HTML template  that

defines the layout and appearance of the Search pane in your WebHelp output. See Using

HTML Templates  for full details. 

· Professional and Floating license version feature only:

Please note that the support for full-text search in WebHelp is only included in the Pro-

fessional and Floating license versions of Help+Manual.

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-
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ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

A full web server required for testing PHP and ASP search

The PHP and ASP search modes use server-side scripting languages that make search per-

formance much faster in large projects and also support phrasal searching, which is not

possible with client-side JavaScript searching. However, because of this you need a full

web server with support for PHP or ASP for these search modes, also for testing. 

The mini server included with Help+Manual for WebHelp does not include PHP or ASP

support and you cannot use it to test PHP or ASP search on your local computer. 

How full-text search works in WebHelp

There are three different search modes you can choose: JavaScript, PHP or ASP. JavaScript

works entirely in the user's browser, PHP and ASP work on the web server and require web

server support. 

JavaScript mode:

This mode works on any computer, even without a web server, so you can also test it

directly on your local machine. It uses an index of words found in the project, together

with the locations where the words are found. This means that it is not possible to

search for phrases because the index only knows about the locations of the individual

words.

PHP and ASP modes:

These modes work on the server and support searching for exact phrases as well as

single words. They require a web server with PHP or ASP support, also for testing.

Which you choose will depend on what your web server supports – ask your system

administrator or web provider for advice if you are not sure. You cannot test PHP or

ASP search on your local computer, you must use a web server with the appropriate

PHP or ASP support (this can also be installed locally, check with your system adminis-

trator for details). 
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Simple Template Layout tab:

This mode is recommended if you do not have experience with editing HTML code!

This button automatically clears all your settings and the

HTML template and reloads the default template. Use

with caution – this function completely overwrites all your

editing changes! 

Text on top of Search page: The text here defines what appears at the top of the

Search pane in the WebHelp shown in the user's browser.

HTML tags are allowed.

The default code inserts the title of the Full-text Search

and links to TOC and Index. Please do not change this

code unless you really understand how it works.

Disabled Simple Layout tab:

The Simple Layout tab will be disabled as soon as you edit source code to prevent acci-

dental deletion of your custom code. It can only be re-enabled by clicking on the Reset

Template button. This will delete the edited code and replace it with the standard tem-

plate

HTML Source Code tab:

This tab allows you to see and edit all the code of the TOC template manually. Experience

in editing HTML code is necessary for using this mode! Note that the code in this template

is essential for the proper functioning of the TOC. Please don't change or delete anything

that you don't fully understand!
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Disabled Simple Layout tab:

The Simple Layout tab will be disabled as soon as you edit source code to prevent acci-

dental deletion of your custom code. It can only be re-enabled by clicking on the Reset

Template button. This will delete the edited code and replace it with the standard tem-

plate

Editing window: The editor provides full HTML syntax highlighting to make

editing easier. To enlarge the window for easier editing just

resize the window.

This button automatically clears the HTML template and re-

loads the default template. Use with caution. This function

completely overwrites all your editing changes in the source

code!

Applying this change re-enables the Simple Layout Tab.

Configuration options:

The configuration options for Full-text Search are quite simple but they are important be-

cause they make a major difference to how search functions. The Accent and Single-case

options are particularly important for some languages.
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Search platform: JavaScript, PHP or ASP. 

JavaScript works everywhere, also on local machines,

and does not require web server support but does not

support phrasal searches and may be slower with larger

projects. 

PHP and ASP require a web server with PHP or ASP sup-

port. They support phrasal searches and are consider-

ably faster than JavaScript but they do not work without

a properly-configured web server. Local testing is not

possible without a local web server.

String Constants / Transla-

tion:

The String Constants table is a list of the texts that are

used in the user interface of the Search function. You

can edit the default texts in the Text column directly.

HTML tags are not permitted here, you can only enter

plain text.

  

(Load / Save Constants):

In addition to editing the string constants yourself you

can also load sets of constants for a variety of different

languages, and save your own constants to external

files. 

The constants are stored in Unicode text files, so you

can store your texts in any language. The files have the

extension *.zlang and are stored in the \Tem-

plates\html folder in the Help+Manual program dir-

ectory, which is normally C:\Program Files\EC

Software\HelpAndManual8. You will find files for

most common languages in this directory. 

Exclude these words from

search:

This list defines common words you don't want to in-

clude in the full-text search index to save space. This is

an important point because the JavaScript full-text index

has to be completely downloaded from your server by

the user's browser before a search can be executed. 

You can add your own words and delete existing words.

Just click in the list and edit, and only enter one word

per line. Copy and paste is supported.

Note that this list must contain at least one word. If you

delete all the entries it will default to the standard

entries when you save your project.

Skip words with less than ...

characters:

This is another function that decreases the size of the in-

dex. Words with less then 3 characters are usually not

very meaningful and excluding them from the search is

generally recommended.

Word-joining characters: The indexing function automatically treats words linked

with the characters you specify here as single words. For

example, if the "-" character is included here ready-

mix and readymix would both be treated as the same

single word.

You can edit the list to add your own characters or de-

lete existing characters.

Enable "Sort results by date": When this is activated users can sort the search results

by score (relevance of the topic found) or date.

Search is accent-insensitive: This converts accents and umlauts to their base charac-

ters so that the search doesn't make a difference

between base characters and their accented versions. 

This is strongly recommended for highly-accented lan-

guages like French and German, as it will make the

searches much more effective for the user.

Support for single-case lan-

guages:

This creates a search index for the special needs of Asian

languages that do not have cases. It is only optimized

for these Asian character sets and should not be activ-

ated for Romance languages with Latin character sets.

Enable exact phrase search: Only available in PHP and ASP modes. When this is se-

lected users can search for exact phrases by enclosing

the search phrase in quotes. 
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See also:
WebHelp  (Help Formats)

Using HTML Templates

HTML Templates  (Reference)

11.3.3.1.6  Zoom Indexer

The full-text search in your WebHelp output is implemented with a bundled version of the

Zoom search indexer tool from Wrensoft. The standard version will serve the great majority of

users' needs, but if you want you can also integrate the full version of Zoom in your projects.

This gives you access to much more extensive search configuration options through Zoom's

own configuration interface.

The full version of Zoom also gives you the option to use CGI server-side searching. This is

only really needed for huge sites with thousands of topics. For almost all other purposes, the

PHP and ASP server-side options included in the bundled version will be more than sufficient.

Important: This section is not included in skins

This section is not stored in HTML skins, it is project-only. Even if you are using a skin, you

must still configure this in your project.

Using the full version of Zoom

Just activate the check box in Configuration > Publishing Options > WebHelp > Zoom

Indexer to tell Help+Manual that you want to use the full version of Zoom. Then enter the

locations of your Zoom installation and the Zoom configuration file that you plan to use.

See the Zoom documentation for full details on using and configuring the standalone ver-

sion of Zoom.

Tip: You can use a user-defined variable  to specify the Zoom configuration file. In ad-

dition to this, you can also use variables inside the custom Zoom configuration file.

This makes it possible to select different configuration files in publishing tasks and

batch files for automated build operations.

11.3.3.1.7  Google Analytics

Use Google Analytics 4 — Universal Analytics is being closed down

Note that the older Universal Analytics from Google with the UA-xxxxxxx-x tracking IDs

is now deprecated and is going to be completely closed down at the end of June 2023.

Help+Manual 9 and Premium Pack 5 both have full support for the new Google Analytics

4 (GA4) with the new G-xxxxxxxxxx ID format, and you should switch to it immediately.

Among other things, in the default configuration, Google claims that it is now compliant
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with the European Union's GDPR legislation. This is disputed by some parties, but it is def-

initely more compliant than Universal Analytics.

Help+Manual Professional and Floating have built-in support for Google

Analytics

Please note that Google Analytics support is available in Help+Manual Professional and

Floating only. This feature is not available in the Basic version of Help+Manual.

Sign up for Google Analytics and get a tracking ID

To use Google Analytics you must sign up for the service, configure it for the URL of your

WebHelp and get a tracking ID. Then you just need to enter the ID in your Help+Manual

project.

Activating Google Analytics in your project

You must activate Google Analytics in your project by entering either your Universal Ana-

lytics or your GA4 ID in Configuration > Publishing Options > WebHelp > Google Ana-

lytics. Everything else is automatic and is handled by the code in the skins used to publish

your WebHelp output.

Important: This section is not included in skins

This section is not stored in HTML skins, it is project-only. Even if you are using a skin, you

must still configure this in your project.

Use the correct Google Analytics ID

It is important that you really enter the tracking ID. This is a little confusing in the Google

Analytics site – your account can also have another numeric identifier –and the ID is some-
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times difficult to find. We can't post navigation examples here because Google also

changes their site layout quite often. Here is how to know that you have the right ID. 

If you find an ID that is only numbers without the prefixes shown below, it is not your

tracking ID.

Old Universal Analytics

The tracking ID for the older Universal Analytics always starts with UA- and has the format

UA-xxxxxxx-x, where the x characters are your specific ID.

New Google Analytics 4

The tracking ID for the new GA4 always starts with G- and has the format G-

xxxxxxxxxx. 

See also:
Profiling WebHelp with Google Analytics  (Overview)

Full Text Search  (Configuration Options)

11.3.3.1.8  HTML Export Options

These options configure many key aspects of how your project content is converted to HTML

code for WebHelp and eBooks (ePUB, Kindle and eWriter Help). There is a separate set of set-

tings for Microsoft HTML Help CHM files and the Microsoft Visual Studio Help formats, which

have different requirements .

Important: This section is not included in skins

This section is not stored in HTML skins, it is project-only. Even if you are using a skin, you

must still configure this in your project.

HTML export settings for WebHelp and eBooks (ePUB, Kindle and

eWriter):

Extension for HTML

topic files:

By default all HTML topic files are exported with the extension

.html. You can change this to.htm, .asp, .php or a

manually-entered extension but extensions other than .htm or

.html are only supported in WebHelp. The .html extension is

always used for topic files in HTML Help (CHM files) and

Visual Studio Help. 

This setting is also irrelevant for eBooks.

666
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CSS stylesheet file

name:

This setting allows you to change the name of the stylesheet

file exported with the CSS style information. The default file

name is default.css.

Note that in Premium Pack V3, V4 and V5 skins the CSS

stylesheet name is automatically set to hmproject-

styles.css on export and cannot be changed. The name is

not displayed here.

Font size encoding: This setting allows you to choose how font sizes are defined in

your output. You can choose pt (points), px (pixels), % (per-

cent) or ems (where 1 em = 100%). Which setting you choose

controls how fonts are displayed on the user's screen and

whether or not the user can change the font size.

Choose pt or px to lock your font size and layout, % or
ems to allow the user to change the font size.

Always choose % or ems for ePUB eBooks, otherwise
many readers will not allow font size changing.

Points:

When you export the font size in points the user cannot adjust

the font size. However, the size of the fonts displayed on the

user's computer screen will vary depending on the Windows

screen DPI setting and/or font size settings. For example, if

you develop your help on a machine with Windows set to

96dpi (the standard) your text layout may be incorrect on

computers set to 120dpi (fonts look much too big, text in

hanging indents may be wider than the indent etc). This is be-

cause the size of the fonts changes but the size of the other

layout elements (indents, locked table cells etc.) doesn't.

Pixels:

This is the only setting that ensures that the fonts and your

layout will always be displayed exactly as you see them on

your development machine. The font size is always uses the

same number of pixels, so it is always the same size relative to

other elements of your layout like indents, graphics and so on.

Percent or Ems:

If you select percent or Ems the user will be able to adjust the

font size in the help, for example by holding down Ctrl and

turning the mouse scroll wheel. This may or may not be a

good thing, because the size of other layout elements (graph-

ics, indents, locked table cells etc.) will not change, so the user
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adjustments may "break" your layout.

Important note on the % and ems settings:
If you choose these units all the other dimensions in the HTML

output for WebHelp and eBooks will use relative ems dimen-

sions instead of absolute values. This is necessary for respons-

ive designs in which the entire layout can be scaled by chan-

ging the base font size. 

Font size of Normal

style:

If you choose percent or ems for font size encoding (see

above) you can also use this setting to define the size of the

Normal style in relation to the default font of the user's

browser. The value is expressed in percent and the default is

100%. 

The 100% default is generally not the best choice, however!

What you need really depends on the entire layout. For ex-

ample, if your base font size is equivalent to 10-11 points the

correct font size for Normal would be around 82%.

Export WebHelp with

UTF-8 BOM:

Only switch this off if you are using PHP code in your project

and your server's PHP system is having trouble with the BOM

at the beginning of your webhelp files. If you don't know what

PHP is you don't need to turn this off!

All Help+Manual webhelp files are stored in UTF-8 Unicode.

The UTF-8 BOM (Byte Order Mark) is a special character code

at the beginning of the file that identifies it as a UTF-8

Unicode file. It is generally better to leave this in because it

will prevent old and badly-configured servers from misinter-

preting the UTF-8 Unicode formatting. However, the PHP in-

stallations on some servers still have trouble with the BOM

and so you may need to switch the BOM off if you are using

PHP.

Replace blanks and un-

derscores in HTML file

names with hyphens:

If you leave this off, illegal characters, spaces and underscores

in HTML file names will be replaced by underscores (old

Help+Manual standard). Turning it on uses hyphens instead.

This is off by default to prevent breaking links in existing pro-

jects. 

Apply date and time When this is on (default setting) the timestamps of your HTML
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stamp of topic to HTML

topic files:

topic files will be set to the date and time of the topic in your

project, which is equivalent to the time of the last change. This

makes it easier to synchronize your output folder with an old

version on your web server, for example. This is only really rel-

evant for WebHelp output – in CHM help the topic files are all

hidden inside the CHM.

If you turn this off the timestamps of all HTML files will always

be the date and time at which your entire project was pub-

lished. 

Do not turn this setting off unless you have a specific reason

to do so.

Modify archive bit of

topic files depending

on changes:

Turning this on will automatically clear the archive bits of all

modified files in your WebHelp output folder. Use this if you

have an FTP program like  Second Copy that can synchron-

ize your output folder with your web server folder using

archive bits.

The advantage of this is that it automatically flags all modified

files, even if their timestamps have not changed. This is im-

portant because the timestamps of your topic files are only

changed if the topics have actually been edited. For example,

if you change your HTML templates this will change all your

topic files but it will not change the timestamps of topic files

that have not been edited, even though their contents change

because of the template changes. Using archive bits guaran-

tees that all modified files are identified.

Using this option only makes sense if you have an FTP pro-

gram that supports folder synchronization on the basis of

archive bits, however...

Export style names: When this is selected Help+Manual uses the full names of

your styles in the stylesheet. This makes the sheet much easier

to read if you ever want to view or edit it manually.

If you deselect this option the style names are converted to

brief, alphanumeric codes that are not so "human-friendly".

This can make your project a little bit smaller but not much.

Export lists as text: This setting is recommended. When it is selected numbered

and bulleted lists are managed using text formatting in HTML-

http://www.secondcopy.com/index.html
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based output. This will generally provide better list formatting

across browsers than the standard lists generated when you

turn it off. Even in HTML Help, which uses MS Internet Ex-

plorer for HTML rendering, you will find that lists display bet-

ter with this setting.

If you deselect this option lists will be exported as standard

<OL> and <UL> lists with <LI> list elements. This option also

supports formatted lists but has some limitations compared to

the text option. See Formatting Lists  for more information

on this. 

If an image has no cap-

tion, export file name

as hint:

Images in HTML pages can have an ALT attribute that displays

a small text in a "tooltip" when the user positions the mouse

pointer over the image. 

Selecting this option exports the image file name as the ALT

attribute if the image doesn't have a caption. Unless your

graphics files have very descriptive names it is normally advis-

able to switch this off.

Highlight hotspots in

pictures

When this is on hotspot links in images and graphics are high-

lighted for easier visibility and respond on mouseover. Turn-

ing this off creates invisible hotspots that only change the

mouse cursor form on mouseover.

Conversion options for

non-HTML image

formats:

This option controls how images in your project not compat-

ible with HTML are converted and exported when you publish

to HTML-based formats. It does not affect JPEG, GIF and PNG

images, which are exported without conversion.

Which option provides the best results depends on the type

of images in your project. GIF and PNG generally provide the

smallest files with the best quality for screenshots with 256

colors or less. PNG files are usually too large for images with

more than 256 colors; JPEG is the better choice for those.

Screenshots often do not look so good when converted to

JPEG so you should always choose your settings to make sure

that this doesn't happen. It is better to use GIF or PNG and no

more than 256 colors for screenshots.

JPEG and true-color PNG are really only needed for photo-

graphs and continuous-tone graphics, and JPEG is generally

335
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preferable for this because it produces much smaller files for

true color images. 

Output quality for JPEG

images:

You can reduce graphic file size by decreasing the quality but

this will also make the images look less good. A value of

between 80 and 90 is normally acceptable.

Note that this quality setting is only applied to JPEG images

actually generated by the program on the basis of the conver-

sion settings (see above). JPEG images that you insert in your

project directly are not affected. They are used as they are,

without any changes.

Export topics of class

"Popup" as JavaScript

popup windows:

Activate this to use JavaScript popups in WebHelp, CHM and

Visual Studio Help. See Creating popup topics  and Using

JavaScript popups  for full details.

See also:
Configuring Your Output

WebHelp  (Help Formats)

11.3.3.1.8.1  Popup Topics

In WebHelp, popup topics are activated with the option Export topics of class "Popup" as

JavaScript popup windows in HTML Export Options. This is the only option for popups in We-

bHelp. If it is not activated the popup topics will be displayed as normal topics.

For full details see Creating popup topics  and Using JavaScript popups . 

Important: This section is not included in skins

This section is not stored in HTML skins, it is project-only. Even if you are using a skin, you

must still configure this in your project.

Customizing JavaScript popups:

Click on Customize popup appearance in HTML Export Options to display the configura-

tion dialog:

207

212

644

1510

207 212
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Click/mouseover: Displays the popup on user click or mouseover (i.e. as soon as the

user moves the mouse pointer over the link). Be careful with using

the mouseover option as many users find this intrusive and it may

also trigger popup blockers in some browsers.

Border width: Enter 0 for no border, any value above 0 (in pixels) to draw a border

around the popup box.

Border padding: The distance between the popup content and the border or edge

of the popup (if there is no border) in pixels.

Background: The background color of the popup box.

Border color: The color of the border, if there is one.

Rounded borders

and drop shadow:

These effects are only supported by modern browsers: Internet Ex-

plorer 9, Firefox 3.6, Opera 10.6, Google Chrome 10 or later.

See also:
Creating popup topics

Using JavaScript popups

11.3.3.1.9  HTML Fonts

These options configure how fonts and symbol characters are exported to HTML output

formats. The same settings can be configured in both the WebHelp and Microsoft HTML Help

(CHM) sections, but they are used globally for all HTML output formats (WebHelp, CHM,

eWriter, ePub, Kindle, Visual Studio Help). 

207

212
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Important: This section is not included in skins

This section is not stored in HTML skins, it is project-only. Even if you are using a skin, you

must still configure this in your project.

Export Symbol fonts as SVG

Converts characters of the Symbol fonts specified here to SVG glyphs on output. SVG

graphics scale just as well as fonts, but unlike Symbol fonts, SVG graphics work in all

browsers and cannot be blocked by ad blockers or security settings as web fonts can. They

also make it possible to use Windows-only Symbol fonts like Windings on the web. 

See Special characters, lines and breaks  for full details.

Define HTML font families

This section allows you change the predefined HTML font families in Help+Manual and

define your own for additional fonts. Font families are a list of alternative fonts to be used

if the user's browser does not have access to the main font you have defined. 

See HTML fonts and headings  for instructions.

See also:
Configuring Your Output

11.3.3.2 Adobe PDF

The settings in this section control how your project is exported to Adobe PDF, which can be

displayed with Adobe Acrobat or Acrobat Reader, or any number of other PDF viewers. The

most important setting is the link to the print manual template which defines the appearance

and layout of your PDF output. 

In addition to selecting the template you can choose whether you want to generate an inter-

active PDF with active hyperlinks for on-screen viewing or a print manual style PDF designed

to enable the user to print out a hard copy of the user manual. You can also adjust a number

of security-related settings.

See also:
Customize - PDF Export

PDF and Printed Manuals

Adobe PDF  (Help Formats)

11.3.3.2.1  PDF Layout

The settings in this section have an effect on the appearance and style of your PDF output.

The most important setting is the link to the print manual template  which defines the page

245
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layout of your PDF output and adds additional pages and features (cover, index, contents etc).

See PDF and Printed Manuals  for details.785
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Interactive PDF docu-

ment:

Generates a PDF designed for interactive on-screen viewing.

When you select this option hyperlinks in the PDF are active

and the entries in the print-style Table of Contents at the be-

ginning of the document are actively linked to the topics

they refer to.

When you select this you should also activate Underline

Topic Links and paint in color (see below) to make your hy-

perlinks visible. 

Similar to a printed

manual:

Generates a static PDF designed for printing rather than on-

screen viewing. Automatically disables all the other interact-

ive options in this section.

Create Table of Contents: Generates an interactive Table of Contents which is dis-

played in the "Bookmarks" section of Adobe Reader. Only

available for interactive PDF documents. 

Note that this is not the same as the Table of Contents sec-

tion configured in the print manual template , which is de-

signed for use in printed PDFs.

Outlines are numbered

(1.2.3.4...):

If you activate this option the entries "Bookmarks" Table of

Contents displayed in Adobe Reader will also be numbered

automatically.This option uses the standard legal numbering

format for chapters/sections and sub-chapters/sub-sections.

Important:  You cannot change change the numbering style

for this auto-generated TOC. It is generated by the PDF

viewer, not by Help+Manual. Even if your PDF template uses

another numbering style, the Bookmarks TOC will still use

the standard legal style if this option is activated.

Apply numbers to links: If outlines are numbered, links that point to these Table of

Contents entries do not automatically pick up the numbering

of the outline. You can enable that with this option.

  

 

PDF has active hyper-

links:

Make the hyperlinks (topic links, file links, web links) in your

topics active and clickable in the PDF document.

Only available if you select the Interactive PDF Document

option as well. 

Underline topic links and

paint in color:

This allows you to choose whether the links in your PDF are

visible and defines the color. 

If you turn this off in a PDF document with active hyperlinks

the links will still be active but they will be formatted as nor-

mal text and will not be visible!

You can also choose whether you want links to be under-

lined or not with the option Single Underline / No Underline.

Insert page referrers: Inserts a small icon containing the link target page number

after every hyperlink. Recommended for PDFs designed for

printing. You can choose from a number of different referrer

icon styles. Try them out and see which one you like best!

File links - embed linked

files:

Activating this option physically embeds external files in the

PDF file so that you can distribute additional files with your

PDF document. Only files linked to in your document with

file links  will be embedded. 

Ignore blank pages in

PDF file:

If you configure your print manual template  to start

chapters on odd pages you will have blank pages in your

PDF file. This is fine for printing but not so good for on-

screen viewing.

This option enables you to suppress the blank pages without

editing the print manual template. Don't forget to turn it off

after using it, however – otherwise it's easy to think that

"Start on odd page" isn't working!

803
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See also:
Customize - PDF Export

PDF and Printed Manuals

Embedding files in PDFs

11.3.3.2.2  PDF Options

These options set the standard options for saving the PDF output file. These are identical to

the options that you can set in Acrobat and they should all be self-explanatory. Note that

some PDF viewer programs may not support some of the options you activate here.

PDF/A Mode: Activate PDF-A mode for compatibility with the official long-term

archiving options. See this Wikipedia page for details.

Text compression: PDF text compression. Should usually be set to Deflate for max-

imum compression.

Image quality: Activating JPEG compression reduces file size but also reduces the

quality of the images in your PDF file.

Open mode: How and what the PDF displays when the user first opens it.

Zoom mode: Default zoom mode to be activated when the user first opens the

PDF.

Viewer layout: Default PDF viewer layout to be activated when the user first opens

the PDF.

Owner and user

password:

Passwords you can set to protect the PDF against changes or unau-

thorized opening. Use in combination with the user permissions

check boxes on the right.

Document inform-

ation:

The information displayed when the user selects the document in-

formation option in the PDF viewer program.

Using variables:

Note that you can use variables  in all the Document Information fields.

See also:
Customize - PDF Export

PDF and Printed Manuals
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11.3.3.2.3  Font Embedding

If the fonts you use in your PDF document are not installed on the user's computer your doc-

ument may not be displayed correctly, because substitute fonts will be used. You can solve

this problem by embedding the fonts in your PDF document, but this can increase the size of

your document considerably, particularly if you are using Unicode-based languages like Asian

languages. 

If you need to keep your PDF files as small as possible it is advisable to only use standard

fonts like Arial and Times Roman that will be installed on all users' computers. You can then

reduce the PDF file size by adding these fonts to the exclusion list and by embedding only

font subsets of the characters used in your project (see below). This is often not possible for

languages with special character sets, particularly Asian languages. 

Problems in font rendering: check the PDF printer driver!

If your fonts are rendered with strange spacing and seemingly incorrect characters the

problem is generally the reference printer driver used for generating PDFs. See here  for

information. 

Recommendation for Asian languages and other languages with special

character sets

In general you should always embed fonts for languages with special character sets, like

Russian, Greek and Asian languages in particular. If you experience problems with the nor-

mal embedding modes, try the option for Type 3 fonts, even if you are not using Type 3

fonts in your project. Help+Manual will then embed the fonts in Type 3 mode, and this of-

ten solves problems, particularly in documents where Asian languages are mixed with text

using the English alphabet.

It is generally best not to use CID font embedding for these languages. See CID font em-

bedding  in the PDF chapter for more details.

1271
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Embedding fonts: If you must embed fonts you can reduce the size of your PDF files

by selecting the right embedding option.

Embed TrueType fonts embeds all TrueType fonts except the

fonts you add to the exclusion list (see below).

Embed symbol fonts only embeds fonts like Symbol and Wing-

dings. This ensures that special characters that depend on these

fonts will be displayed correctly. Other fonts not found on the

user's computers will be substituted with available similar fonts.

Use Base 14 Type1 fonts tells Acrobat to substitute its own built-

in fonts. This switches off font embedding and will work ad-

equately if your fonts are similar enough to the Base 14 fonts

(Times/Mac or Times New Roman PS MT /Win; Helvetica/Mac or

Arial MT/Win; Courier, Symbol, and Zapf Dingbats, each with regu-

lar, bold, italic or oblique, and bold italic styles).

Embed TrueType subset only embeds the code pages of the

TrueType fonts that are actually used in your project. 

Embed TrueType subset (used characters only) saves even more

space by only embedding the characters that are actually used in

your project. Note that this can slow down publishing considerably

with larger projects.

Embed Type 3 Fonts is fur using Adobe Type 3 fonts instead of

TrueType. 

Embed CID Fonts generates virtual fonts in the PDF that are en-

coded with CIDs (Character IDs). In some documents this can

provide better rendering. However, this option may not be optimal

for special character sets like Russian, Greek and Asian languages.

With these fonts, you will often find that CID fonts look good but

the PDF file is very large and the text cannot be selected or

searched. See CID font embedding  in the PDF chapter for more

details.

Do not embed

these fonts:

If you choose Embed TrueType fonts you can reduce the size of

your output file by excluding all the common fonts that all users

are likely to have installed on their computers. 

All the fonts you add to this list will not be embedded in your out-

put file.

If a TrueType font

cannot be embed-

ded, use Type3

Some Windows TrueType fonts like MSGothic are implemented as

"collections" of font variants with the extension .ttc instead of as

the standard TrueType .ttf font package. Font collections can't

be embedded directly in PDF, but if you leave this option on

Help+Manual will automatically convert them to Type3 and embed

them. Then they will work fine.

We recommend leaving this option on. It won't cause any prob-

lems with normal fonts and it will eliminate "cannot embed font"

errors with TrueType font collections and other problem fonts.

Optimize embed-

ded fonts for

cross-platform:

This option can improve the rendering of fonts in different PDF

readers on multiple platforms. 

Export as glyphs PDF frequently has problems with symbol characters and bullet

characters used in lists. To deal with this, Help+Manual can export

these characters as glyphs (small vector graphics). These are then

always "correct" because the display of a glyph is never affected by

the way a font is rendered. If you ever have problems with this, for

example when trying to convert your PDF in an external program,

you can turn this option off here. Then the symbol characters will

be exported as normal text characters, which may be rendered in-

correctly in some configurations.

See Special characters, lines and breaks .

Special symbol fonts

Not all symbol fonts are recognized automatically. You can add

symbol fonts here so that they will be referenced directly.

Help+Manual automatically recognizes FontAwesome, Fontello

and Webdings, for example, but you can add additional symbol

fonts as well.

About CID font

embedding:

The Embed CID Fonts option in Configuration > Publishing Op-

tions > Adobe PDF > Font Embedding is a rather esoteric techno-

logy that can reduce the size of your PDF and improve font render-

ing.

When you activate Embed CID Fonts the characters actually used in

the project are embedded in the PDF file as "virtual" fonts, using a

special internal format and CID (Character ID) encoding of the

characters. 

This only works with fonts that actually contain all the characters

you need to display. If you select a normal western font like Treb-

uchet that does not contain the characters for the language you

are using you will have problems. The text will automatically be

rendered as graphical glyphs because the characters are not avail-

able, which will make your PDF files huge. Also, it will not be pos-

sible to select or copy text from the PDF, because it does not con-

tain text, only graphics.

Effectively, this means that Embed CID Fonts only works with

Unicode fonts that contain the full Unicode character set!

See CID font embedding  in the PDF chapter for more details.

1450
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See also:
Customize - PDF Export

CID Font embedding

PDF and Printed Manuals

11.3.3.2.4  CID font embedding

The Embed CID Fonts option in Configuration > Publishing Options > Adobe PDF > Font

Embedding is a rather esoteric technology that can reduce the size of your PDF and improve

font rendering.

When you activate Embed CID Fonts the characters actually used in the project are embedded

in the PDF file as "virtual" fonts, using a special internal format and CID (Character ID) encod-

ing of the characters. 

This only works with fonts that actually contain all the characters you need to display. If you

select a normal western font like Trebuchet that does not contain the characters for the lan-

guage you are using you will have problems. The text will automatically be rendered as graph-

ical glyphs because the characters are not available, which will make your PDF files huge. Also,

it will not be possible to select or copy text from the PDF, because it does not contain text,

only graphics.

Effectively, this means that Embed CID Fonts only works with Unicode fonts that contain the

full Unicode character set!

CID font embedding and Asian fonts

When you select CID font embedding for Asian fonts the PDF will generally look very

good but you will usually not be able to select or search the text and the PDF file will be

very large. This is because the characters are then rendered as glyphs (small graphics). In

most cases, it is better to choose either TrueType or Type 3 embedding for Asian docu-

ments, particularly Asian documents that also contain text using the English alphabet.

Type 3 embedding will usually produce the best results for such documents, even if you

are not using Type 3 fonts in your project (Help+Manual embeds the fonts in Type 3

mode.)

Recommendations for CID font embedding

It is not really possible to provide more than a general rule of thumb for CID font embed-

ding: It should usually be off for Asian languages, Russian and Greek, but it can provide

better rendering and smaller PDF sizes for other languages. We can only suggest that you

test your PDFs with CID on and off to see which is better for your specific needs. 

PDF files much too large:

If your PDF files get massively larger with CID embedding switched on, that is a sure sign

that the fonts you are using do not contain all the characters you need. This also means

1271

1450

785



1451

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Reference

that these fonts will not actually be used even if CID is off: Then, Windows will perform

font substitution and will replace your font with one that does contain the necessary char-

acters.

Special Unicode characters:

If special characters are not rendering correctly this is also a sign that the font you are us-

ing does not contain all the necessary characters, and Windows font substitution is also

failing to find them. The only way to really get all characters to render correctly is to use

fonts that really contain all the characters you are using. Otherwise you will get oversized

PDFs or incorrect rendering or both.

Why CID font embedding exists

Although Help+Manual can generate PDFs from projects written in Unicode-based lan-

guages, the Adobe PDF format does not actually support Unicode directly. This is because

PDF is a universal format designed to be displayed on any computer running any operat-

ing system. If PDF files were encoded with Unicode they would not display on older oper-

ating systems like Windows 98 and Windows NT that have no Unicode support. 

PDF files gets around this problem by using a different encoding internally that can map

and represent all the Unicode characters. PDF currently supports two internal encoding

formats for Unicode: double-byte characters (which are often mistakenly confused with

Unicode) and "character ID" or CID. 

When you use CID font embedding, PDF engine does not embed the entire font. Instead,

it only embeds the characters that are actually used, storing them as a special PDF "vir-

tual" font with character ID encoding. A single copy of each character in each size used is

stored as a graphical glyph and it is then referenced in the text with the CID code that

makes it possible to copy text and search in the PDF. 

You might think that this would make it unnecessary to embed fonts not available on the

user's computer in the PDF, but unfortunately this is not always the case. 

See also:
International languages setup

Adobe PDF - Font Embedding  (Configuration Options)

11.3.3.3 Microsoft HTML Help

The settings in this section control how your project is exported to HTML Help. The settings

here are also used for the MS Visual Studio Help output formats.

Shared settings:

The options in the HTML Export Options section for MS HTML Help/CHM  files are

also used for the MS Visual Studio Help  output formats. These settings are accessible
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in the HTML Help  section of your project configuration. Settings that are not relevant

for an individual format are ignored in that format.

The HTML export settings for WebHelp and eBooks can be configured in the WebHelp

and configuration section.

See also:
HTML Help  (Help Formats)

HTML Help Options  (Help Windows)

HTML Page Templates

11.3.3.3.1  Help Windows

These settings define the appearance and behavior of the help viewer used to display Mi-

crosoft HTML Help CHM files. They are completely irrelevant for all other formats. They used

to be relevant for the Microsoft Winhelp format but that format is now completely obsolete

and no longer used or supported. HTML Help CHM has been the standard Windows help

format since Windows 98.

This help viewer is a component of Microsoft Windows. The settings in the help window defin-

itions can only control the features provided by the viewer. For more information see Help

Windows  in the Reference section.

See also:
Using help windows

Configuring Your Output

Templates and Secondary Windows

Help Windows  (Reference)

11.3.3.3.1.1  General Options

These common properties are displayed at the top of the editing screen and are always avail-

able no matter which tab is selected. 

Select window: Select a help window definition for editing. By default only the

standard Main window is defined. Click on Add to create addi-

tional secondary help windows. Remove deletes the current sec-

ondary help window (Main cannot be deleted).

Window name: This is the identifying name of your help window type, which is

displayed in the Help Window: field in each topic's tab. It is re-

stricted to a maximum length of 8 characters. No spaces or non-

alphanumeric characters are allowed.

You cannot rename a secondary help window once you have cre-

ated it.
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Global window

name:

Only use this option for HTML Help files using runtime merging in

a collection of master/child CHM files. You can then use the same

global help window name for all the CHM files for better access to

the CHM collections via the help calls from your applications. 

The benefit of using a global help window is that the help always

opens in the same window on new help calls, even when you are

making calls to child modules. If you don't use a global window,

calls to different modules in the help system will open new in-

stances of the help viewer.

If you use this option the global help window name must use the

following format, and you must use the same global name in all

the projects:

$global_<windowname>

Examples:

$global_main_mycompany
$global_widgethelp

Important – make sure your window name is unique!

Don't use the standard $global_main name! If you do it is quite

possible that some other software on the user's computer will

also be using that name and then your help could open in their

help window!

Title bar text: This is the text displayed in the title bar of the help viewer in

HTML Help. You can enter different texts for secondary window

definitions to display different titles in the title bars of external

windows.

By default this field contains the <%TITLE%> variable, which auto-

matically displays the text entered in Help Title: field in the Title &

Copyright  section, so you only need to change this if you want

to display a different text.

Size and position: Defines the size and position of the main help viewer for Main

and for external windows for secondary help window definitions. 

Note that in HTML Help these settings are only used the first time

the help is opened for the main help viewer. After that Windows

stores the user's own settings and re-uses them the next time the

1402
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help is opened. The settings will always be used for external win-

dows, however.

Position Wizard The Position Wizard displays a dummy window that you can posi-

tion and resize on the screen to set the size and position values. 

If you have a dual monitor system use the position wizard in the

primary monitor and make sure that the primary monitor is on

the left: On dual-monitor systems the 0,0 position is defined as

the top left corner of the primary monitor, so doing this will make

sure that the resulting values also work on single-monitor com-

puters.

See also:
Using help windows

11.3.3.3.1.2  HTML Help Viewer UI

These options control the appearance and behavior of the main HTML Help viewer (Main help

window) and the viewer windows for external windows  (user-defined secondary windows).

Specifying a secondary help window in a hyperlink to a topic will only have any effect in HTML

Help if the option Links to secondary help windows open a new help window is activated here.

If not, all the secondary window settings will be ignored and the settings for Main will be

used. 

Productivity Tip
Note that there is no Keep window on top setting for

HTML Help. This can only be activated by the pro-

grammer in the call to the HTML Help – see the HTML

Help API documentation for details. 
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Links to secondary

help windows

open a new help

window:

Activates external windows. When you specify a secondary help

window in the Insert Hyperlink dialog (with the Window: option)

the target window will be opened in an external window with the

settings for the specified secondary window.

If this option is not activated links to secondary windows will open

in the main help viewer.

Visible buttons: These options are used to choose which control buttons are dis-

played in the help viewer. You may want to switch them all off for

external windows .

Window has a nav-

igation panel:

This option activates or deactivates display of the help viewer's

navigation panel containing the Table of Contents, keyword index

and other tabs. You may want to disable this for external win-

dows . Note that if you also disable the Hide/Show button in

the Visible Buttons section the user will not be able to activate the

navigation panel at all!

Search tab:

Favorites tab:

These options activate or deactivate the display of the Search and

Favorites tabs in the navigation panel. Note that if they are dis-

abled it will not be possible for the user to enable them.

Save size and posi-

tion in Registry:

When this is selected the current help window size and position are

saved in the Windows Registry when the user closes the help.

Otherwise the size and position you define will always be used.

Don't turn this option off; it really annoys most users if their posi-

tions are not saved!

User-defined but-

tons:

Allows you to define two HTML URLs as targets for the Home but-

ton and two user-defined buttons. (These buttons must also be ac-

tivated in Visible buttons: to be displayed.)

You cannot enter links to topics in the help here. Note that you

must enter fully-qualified URLs including the protocol (i.e.

http://, ftp:// etc). Simple URLs without the protocol (e.g.

www.domainname.com) will  not work.

You can edit the names of the Jump 1 and Jump 2 buttons but you

cannot change the name of the Home button.

The icons displayed for these buttons are hard-wired into the Mi-

crosoft HTML Help viewer and cannot be changed.

1025
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See also:
Secondary windows

11.3.3.3.2  Extended .HHP Settings

This section enables you to add or overwrite sections of the HHP project file used to generate

your HTML Help output. (See HTML Help project files  for details). Normally you will never

need to use this feature but there may be situations where you want or need to make

changes to your HTML Help output by making changes or additions to the HHP file.

Please only use these feature if you understand HHP files and how to edit them. You can find

information on the settings in the documentation distributed with Microsoft HTML Help

Workshop.

Adding entries to the HHP file

To add entries to the HHP file enter the section heading name in upper case and enclosed

in square brackets, followed by the settings you want to add or change, entering one set-

ting per line with a hard line break (ENTER) at the end of each line. Don't enter any section

heading more than once.

Note that merging files into your CHM file is much easier with the Baggage Files section in

the Project Explorer. See Using Baggage Files  for details. 

Example:

About paths to referenced files:

When Help+Manual compiles your project all the HTML Help project files , including

the HHP file, are generated in a temporary directory called \~tmpchm and then fed to

the Microsoft HTML Help compiler. This directory is created in your project directory,

which is the directory containing your .hmxp or .hmxz project file.

This means that all file paths entered in the Extended HHP Settings must be relative to

this directory, because that is where the .hhp file is located. In the example above, for

instance, the files referenced are located in the project directory, which is one directory

up from \~tmpchm. This is why ..\ must be prefixed to each file reference so that the

compiler can find the files.
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If your files are stored in other locations you must adjust the relative paths accordingly.

Storing them in the project directory is usually the simplest solution, however.

Context-sensitive application help file

You can set the file name for the plain-text popups file stored inside the CHM file here. By

default it is called CSHelp.txt.

This file name is only relevant if you are accessing these popups from your application to

use them as field-level popups that are displayed in your application without the main

help interface. See Creating context-sensitive topics  and About field-level popups

for details.

Window styles of the Table of Contents

Below the Extended HHP Settings editing window are some additional options with which

you can adjust the appearance and behavior of the TOC in the Microsoft HTML Help

viewer:

Display plus/minus icons:

Activates or deactivates the +/- icons displayed to the left of closed/open chapter icons

("books") in the HTML Help viewer's TOC.

Draw lines between items:

When this is activated fine dotted lines are displayed between related items in the TOC,

making it easier see which topic belongs to which chapter in complex TOCs.

Track selection (mouseover effect):

When this is activated an underline is displayed below topic entries in the TOC when the

user moves the mouse over them. This makes it easier to be sure which topic you are go-

ing to click on.

Only expand a single heading:

When the user selects a new chapter any other chapters on the same level in the TOC that

are open will be closed automatically. This is useful for complex help documents with lots

of chapters, because it is easier to navigate in the TOC if you do not have multiple

chapters open.

Child module TOC settings

This setting is only relevant if the current project is a child project in your modular help

system. It controls what happens when the user tries to open the child .chm module dir-

895 1592
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ectly. 

Its own table of contents 

This makes the child file open with its own table of contents as a separate help file in its

own right.

Table of contents of the master file 

This automatically opens the master .chm and loads the child .chm into its TOC when the

child file is opened. This is effectively the same as opening the master .chm directly. Use

the  browse button to select the master .chm file (this must be present in the same dir-

ectory on the user's computer at runtime).

See also:

Working with Modular Help Systems

Using Baggage Files

Using HTML Templates

Inserting HTML Code

HTML Help  (Help Formats)

HTML Help Options  (Help Windows)

11.3.3.3.3  HTML Export Options

These options configure many key aspects of how your project content is converted to HTML

code for the Microsoft HTML Help/CHM help file format and the two Microsoft Visual Studio

Help file formats. There is a separate set of settings for the WebHelp and ePUB eBook

formats, which have different requirements .

Important: This section is not included in skins

This section is not stored in HTML skins, it is project-only. Even if you are using a skin, you

must still configure this in your project.

HTML export settings for Microsoft CHM and Microsoft Visual Studio

Help:

Setting up CHM files for high-resolution devices:

The Microsoft CHM Viewer in Windows uses an old HTML rendering engine that has spe-

cial requirements. Help+Manual can automatically configure your CHM file so that it dis-

plays correctly on high-resolution 4K monitors and devices like the Microsoft Surface and

Lenovo Yoga Pro. If you don't do this the text and other elements will often be too small

to read on these devices. 

1. Open your project in Help+Manual and in the Project Explorer navigate to Configura-

tion > Publishing Options > MS HTML Help > HTML Export Options. 
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2. Set Font Size Encoding to: pt Points.

3. Select the checkbox for Make pixel sizes relative to monitor resolution (4K display com-

patibility)

All elements of your CHM file will then automatically be adapted for correct display on

both normal and high-resolution devices and monitors.
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Extension for HTML

topic files:

By default all HTML topic files are exported with the extension

.html. You can change this to .htm, here if you want.

However, CHM and Visual Studio Help only support either

.htm or .html. Other extensions are only allowed in We-

bHelp.

CSS stylesheet file

name:

This setting allows you to change the name of the stylesheet

file exported with the CSS style information. The default file

name is default.css.

Font size encoding: This setting allows you to choose how font sizes are defined

in your output. You can choose pt (points), px (pixels), %

(percent) or ems (where 1 em = 100%). Which setting you

choose controls how fonts are displayed on the user's screen

and whether or not the user can change the font size.

Special note on font size for CHM files and

high-resolution devices:

Always choose points for CHM for the best results on mod-

ern devices. See above .

Points:

Normally, font sizes set in points cannot be adjusted by the

user. However, because of the special way the MS CHM

Viewer works, this is still the optimum setting for CHM files.

You should always choose points for CHM unless you have a

specific reason for choosing something else.

Pixels:

This is a 1:1 setting. The font sizes are set in screen pixels, so

they should correspond directly to the number of pixels on

the screen. This does not work on modern high-resolution

monitors, where the physical pixels on the screen are no

longer equivalent to the defined pixel dimensions of fonts

and other elements.

Percent or Ems:

These are relative dimensions. Percent is relative to the base

font size. Ems are more complicated, but they are also indir-

ectly relative to the base font size. However, these font size

encodings are not recommended for HTML Help/CHM files!

Font size of Normal

style:

If you choose percent or ems for font size encoding (see

above) you can also use this setting to define the size of the

Normal style in relation to the default font of the user's

browser, which is a 16-pixel font on all current browser. The

value is expressed in percent and the default is 100%. 

The 100% default is generally not the best choice, however!

What you need really depends on the entire layout. For ex-

ample, if your base font size is equivalent to 10-11 points the

correct font size for Normal would be around 82%.

The ems and percent font size encodings used with this are

not recommended for HTML Help/CHM files!

Make CHM compatible

with high resolution

monitors

This option encodes all dimensions that are normally spe-

cified in pixels, for example in a tag like

<img src="xxxxx.png" width="500"
height="300"/>

as inches in CHM files to make the content automatically scal-

able on ultra-high resolution monitors. 

For hi-res compatible CHM files you need to specify this op-

tion in combination with font encoding in points. This is set

automatically when you choose this option and should not be

changed.

Exclude topics from

CHM search if topic

starts with an under-

score

Topics whose IDs start with an underscore are automatically

excluded from search in WebHelp . If you check this option,

topics whose IDs start with an underscore will also be ex-

cluded from search in CHM files:

Important note for context help: 

When you activate this option, the extension of the topic file

is changed from .htm to .xhtm. You need to remember this

for your context calls made to the internal topic HTML file in

the CHM file. 

For example, if the ID is _Introduction_Topic the new

HTML file name to make the call to will be _introduc-
tion_topic.xhtm.

Replace blanks and un-

derscores in HTML file

names with hyphens:

If you leave this off, illegal characters, spaces and underscores

in HTML file names will be replaced by underscores (old

Help+Manual standard). Turning it on uses hyphens instead.

This is off by default to prevent breaking links in existing pro-

jects from earlier Help+Manual versions. 

Export style names: When this is selected Help+Manual uses the full names of

your styles in the stylesheet. This makes the sheet much

easier to read if you ever want to view or edit it manually.

If you deselect this option the style names are converted to

brief, alphanumeric codes that are not so "human-friendly".

This can make your project a little bit smaller but not much.

Export lists as text: This setting is recommended. When it is selected numbered

and bulleted lists are managed using text formatting in

HTML-based output. This will generally provide better list

formatting across browsers than the standard lists generated

when you turn it off. Even in HTML Help, which uses MS Inter-

net Explorer for HTML rendering, you will find that lists dis-

play better with this setting.

If you deselect this option lists will be exported as standard

<OL> and <UL> lists with <LI> list elements. This option also

supports formatted lists but has some limitations compared

to the text option. See Formatting Lists  for more informa-

tion on this. 

If an image has no cap-

tion export file name as

hint:

Images in HTML pages can have an ALT attribute that displays

a small text in a "tooltip" when the user positions the mouse

pointer over the image. 

Selecting this option exports the image file name as the ALT

attribute if the image doesn't have a caption. Unless your

graphics files have very descriptive names it is normally advis-

able to switch this off.

Highlight hotspots in

pictures

When this is on hotspot links in images and graphics are high-

lighted for easier visibility and respond on mouseover. Turn-

ing this off creates invisible hotspots that only change the

mouse cursor form on mouseover.

Export SVG images as

PNG

If you turn this off, SVG vector images will be exported nat-

ively to CHM. However, you need to ensure that your SVGs

are compatible with CHM for this to work correctly. See SVG

Graphics  for details.

File links - embed

linked files

Activating this option physically embeds external files in the

PDF file so that you can distribute additional files with your

PDF document. Only files linked to in your document with file

links  will be embedded. 

Conversion options for

non-HTML image

formats:

This option controls how images in your project not compat-

ible with HTML are converted and exported when you publish

to HTML-based formats. It does not affect JPEG, GIF and PNG

images, which are exported without conversion.

Which option provides the best results depends on the type

of images in your project. GIF and PNG generally provide the

smallest files with the best quality for screenshots with 256

colors or less. PNG files are usually too large for images with

more than 256 colors; JPEG is the better choice for those.

Screenshots often do not look so good when converted to

JPEG so you should always choose your settings to make sure

that this doesn't happen. It is better to use GIF or PNG and no

more than 256 colors for screenshots.

JPEG and true-color PNG are really only needed for photo-

graphs and continuous-tone graphics, and JPEG is generally

preferable for this because it produces much smaller files for

true color images. 

Output quality for JPEG

images:

You can reduce graphic file size by decreasing the quality but

this will also make the images look less good. A value of

between 80 and 90 is normally acceptable.

Note that this quality setting is only applied to JPEG images

actually generated by the program on the basis of the con-

version settings (see above). JPEG images that you insert in

your project directly are not affected. They are used as they

are, without any changes.

Export topics of class

"Popup" as JavaScript

popup windows:

Activate this to use JavaScript popups in WebHelp, CHM and

Visual Studio Help. See Creating popup topics  and Using

JavaScript popups  for full details.
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See also:
Configuring Your Output

HTML Help  (Help Formats)

HTML Help Options  (Help Windows)

11.3.3.3.3.1  Popup Topics

In HTML Help CHM you can use either the CHM format's native plain-text popups and the

JavaScript popups generated by Help+Manual. If you activate JavaScript popups then they

will be used for all popup links in your project. If you turn JavaScript popups off then the nat-

ive plain-text popups will be used for topic popup links. However, even when JavaScript

popups are activated the plain-text version of the popup file is still exported to the CHM and

can be used for field-level popups displayed in your application. 

Selecting popup mode in HTML Help

To activate JavaScript popups select Export topics of class "Popup" as JavaScript popup win-

dows in HTML Export Options. If this option is not activated, links to popup topics in your

help will display as normal CHM plain-text popups.

For full details see Creating popup topics  and Using JavaScript popups . 

Customizing JavaScript popups:

Click on Customize popup appearance in HTML Export Options to display the configura-

tion dialog:

Click/mouseover: Displays the popup on user click or mouseover (i.e. as soon as the

user moves the mouse pointer over the link). Be careful with using

the mouseover option as many users find this intrusive and it may

also trigger popup blockers in some browsers.
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Border width: Enter 0 for no border, any value above 0 (in pixels) to draw a border

around the popup box.

Border padding: The distance between the popup content and the border or edge

of the popup (if there is no border) in pixels.

Background: The background color of the popup box.

Border color: The color of the border, if there is one.

Rounded borders

and drop shadow:

These effects are only supported by modern browsers: Internet Ex-

plorer 9, Firefox 3.6, Opera 10.6, Google Chrome 10 or later.

See also:
Creating popup topics

Using JavaScript popups

Using Context-Sensitive Help

HTML Help  (Help Formats)

HTML Help Options  (Help Windows)

11.3.3.3.4  HTML Fonts

These options configure how fonts and symbol characters are exported to HTML output

formats. The same settings can be configured in both the WebHelp and Microsoft HTML Help

(CHM) sections, but they are used globally for all HTML output formats (WebHelp, CHM,

eWriter, ePub, Kindle, Visual Studio Help). 

Important: This section is not included in skins

This section is not stored in HTML skins, it is project-only. Even if you are using a skin, you

must still configure this in your project.

Export Symbol fonts as SVG

Converts characters of the Symbol fonts specified here to SVG glyphs on output. SVG

graphics scale just as well as fonts, but unlike Symbol fonts, SVG graphics work in all

browsers and cannot be blocked by ad blockers or security settings as web fonts can. They

also make it possible to use Windows-only Symbol fonts like Windings on the web. 

See Special characters, lines and breaks  for full details.

Define HTML font families

This section allows you change the predefined HTML font families in Help+Manual and
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define your own for additional fonts. Font families are a list of alternative fonts to be used

if the user's browser does not have access to the main font you have defined. 

See HTML fonts and headings  for instructions.

See also:
Configuring Your Output

11.3.3.4 Visual Studio Help

Visual Studio Help is available in two versions, Visual Studio Help 2008 and 2010, which are

also known as MS Help 2.0 and MS Help 3.0, respectively. Originally, each of these help

formats was announced as the upcoming the successor to HTML Help. However, in both cases

Microsoft then backpedaled and it now seems clear that they are not going to be released as

help formats for normal user applications. 

You cannot use Visual Studio Help for normal applications

Please note that these are special help formats that are only used for documenting pro-

gramming components integrated in the Visual Studio .NET programming environment.

They are not suitable for any other purpose and cannot be used for normal help projects

for application programs!

Shared settings:

The options in the HTML Export Options section for MS HTML Help/CHM  files are

also used for the MS Visual Studio Help  output formats. These settings are accessible

in the HTML Help  section of your project configuration. Settings that are not relevant

for an individual format are ignored in that format.

The HTML export settings for WebHelp and eBooks can be configured in the WebHelp

and configuration section.

See also:
Visual Studio Help  (Advanced Procedures)

Visual Studio Help  (Reference)

11.3.3.4.1  Namespace & Options

This section is where you enter the special settings required for publishing Visual Studio Help.

Please refer to the documentation of Visual Studio .NET and the Visual Studio Help Integra-

tion Kit (version for VS 2008 and earlier) for full details.

Visual Studio 2010 (MSHC)

There are only three required settings for MSHC output:
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Vendor

Name:

The company that owns the book and packages. This name is also used

for certificate validation. A "package" is a single MSHC help file. A "book"

is a group of packages installed together. A package can belong to more

than one book.

Product

Name:

The name of your product.

Book Name: The name of the book to which the package belongs. A "package" is a

single MSHC help file. A "book" is a group of packages installed to-

gether. A package can belong to more than one book.

Visual Studio 2008 (HXS):

Unlike HTML Help CHM files, Visual Studio Help HXS files cannot be opened unless they

are registered in the Windows Registry (see About publishing VS Help ). Also, they are

not called by their file name but by their "Namespace".

Namespace: The Namespace identifier used for calling MS Help 2.0 files. No special

characters or spaces are permitted. See the VS.NET documentation for

details.

Unique Iden-

tifier:

The unique identifier (rather like a topic ID for an entire help file) re-

quired for Visual Studio Help files. See the VS.NET documentation for de-

tails.

Output file

type:

You can output either a single .HXS file or an .HXS file with a separate

.HXL file. See the VS.NET documentation for details.

Indexes: Help+Manual can generate both full-text search and associative keyword

indexes using the A-keywords entered in the tabs of your topics.

F-Index Forces the generation of the F-Index file for use in Visual Studio Help.

See also:
Visual Studio Help  (Advanced Procedures)

Visual Studio Help  (Reference)
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11.3.3.4.2  Popup Topics

Microsoft has abandoned popup technology in Visual Studio Help. These formats have no

native format for popups and do not support field-level popups. However, you can add

Help+Manual's own JavaScript popups for display within the main help file.

Activating popups:

The option for activating popups is in the HTML Export Options .

For full details see Creating popup topics  and Using JavaScript popups .

Customizing JavaScript popups:

JavaScript popups are user-customizable. Select Customize popup appearance option in

HTML Export Options to display the configuration dialog:

Click/mouseover: Displays the popup on user click or mouseover (i.e. as soon as the

user moves the mouse pointer over the link). Be careful with using

the mouseover option as many users find this intrusive and it may

also trigger popup blockers in some browsers.

Border width: Enter 0 for no border, any value above 0 (in pixels) to draw a border

around the popup box.

Border padding: The distance between the popup content and the border or edge

of the popup (if there is no border) in pixels.

Background: The background color of the popup box.

Border color: The color of the border, if there is one.
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Rounded borders

and drop shadow:

These effects are only supported by modern browsers: Internet Ex-

plorer 9, Firefox 3.6, Opera 10.6, Google Chrome 10 or later.

See also:
Creating popup topics

Using JavaScript popups

11.3.3.4.3  HTML Export Options

These options configure many key aspects of how your project content is converted to HTML

code for the Microsoft HTML Help/CHM help file format and the two Microsoft Visual Studio

Help file formats. There is a separate set of settings for the WebHelp and ePUB eBook

formats, which have different requirements .

Important: This section is not included in skins

This section is not stored in HTML skins, it is project-only. Even if you are using a skin, you

must still configure this in your project.

HTML export settings for Microsoft CHM and Microsoft Visual Studio

Help:

Setting up CHM files for high-resolution devices:

The Microsoft CHM Viewer in Windows uses an old HTML rendering engine that has spe-

cial requirements. Help+Manual can automatically configure your CHM file so that it dis-

plays correctly on high-resolution 4K monitors and devices like the Microsoft Surface and

Lenovo Yoga Pro. If you don't do this the text and other elements will often be too small

to read on these devices. 

1. Open your project in Help+Manual and in the Project Explorer navigate to Configura-

tion > Publishing Options > MS HTML Help > HTML Export Options. 

2. Set Font Size Encoding to: pt Points.

3. Select the checkbox for Make pixel sizes relative to monitor resolution (4K display com-

patibility)

All elements of your CHM file will then automatically be adapted for correct display on

both normal and high-resolution devices and monitors.

Extension for HTML

topic files:

By default all HTML topic files are exported with the extension

.html. You can change this to .htm, here if you want.

However, CHM and Visual Studio Help only support either

.htm or .html. Other extensions are only allowed in We-
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bHelp.

CSS stylesheet file

name:

This setting allows you to change the name of the stylesheet

file exported with the CSS style information. The default file

name is default.css.

Font size encoding: This setting allows you to choose how font sizes are defined

in your output. You can choose pt (points), px (pixels), %

(percent) or ems (where 1 em = 100%). Which setting you

choose controls how fonts are displayed on the user's screen

and whether or not the user can change the font size.

Special note on font size for CHM files and

high-resolution devices:

Always choose points for CHM for the best results on mod-

ern devices. See above .

Points:

Normally, font sizes set in points cannot be adjusted by the

user. However, because of the special way the MS CHM

Viewer works, this is still the optimum setting for CHM files.

You should always choose points for CHM unless you have a

specific reason for choosing something else.

Pixels:

This is a 1:1 setting. The font sizes are set in screen pixels, so

they should correspond directly to the number of pixels on

the screen. This does not work on modern high-resolution

monitors, where the physical pixels on the screen are no

longer equivalent to the defined pixel dimensions of fonts

and other elements.

Percent or Ems:

These are relative dimensions. Percent is relative to the base

font size. Ems are more complicated, but they are also indir-

ectly relative to the base font size. However, these font size

encodings are not recommended for HTML Help/CHM files!

Font size of Normal

style:

If you choose percent or ems for font size encoding (see

above) you can also use this setting to define the size of the

1467
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Normal style in relation to the default font of the user's

browser, which is a 16-pixel font on all current browser. The

value is expressed in percent and the default is 100%. 

The 100% default is generally not the best choice, however!

What you need really depends on the entire layout. For ex-

ample, if your base font size is equivalent to 10-11 points the

correct font size for Normal would be around 82%.

The ems and percent font size encodings used with this are

not recommended for HTML Help/CHM files!

Make CHM compatible

with high resolution

monitors

This option encodes all dimensions that are normally spe-

cified in pixels, for example in a tag like

<img src="xxxxx.png" width="500"
height="300"/>

as inches in CHM files to make the content automatically scal-

able on ultra-high resolution monitors. 

For hi-res compatible CHM files you need to specify this op-

tion in combination with font encoding in points. This is set

automatically when you choose this option and should not be

changed.

Exclude topics from

CHM search if topic

starts with an under-

score

Topics whose IDs start with an underscore are automatically

excluded from search in WebHelp . If you check this option,

topics whose IDs start with an underscore will also be ex-

cluded from search in CHM files:

Important note for context help: 

When you activate this option, the extension of the topic file

is changed from .htm to .xhtm. You need to remember this

for your context calls made to the internal topic HTML file in

the CHM file. 

For example, if the ID is _Introduction_Topic the new

HTML file name to make the call to will be _introduc-
tion_topic.xhtm.

Replace blanks and un-

derscores in HTML file

names with hyphens:

If you leave this off, illegal characters, spaces and underscores

in HTML file names will be replaced by underscores (old

Help+Manual standard). Turning it on uses hyphens instead.

664
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This is off by default to prevent breaking links in existing pro-

jects from earlier Help+Manual versions. 

Export style names: When this is selected Help+Manual uses the full names of

your styles in the stylesheet. This makes the sheet much

easier to read if you ever want to view or edit it manually.

If you deselect this option the style names are converted to

brief, alphanumeric codes that are not so "human-friendly".

This can make your project a little bit smaller but not much.

Export lists as text: This setting is recommended. When it is selected numbered

and bulleted lists are managed using text formatting in

HTML-based output. This will generally provide better list

formatting across browsers than the standard lists generated

when you turn it off. Even in HTML Help, which uses MS Inter-

net Explorer for HTML rendering, you will find that lists dis-

play better with this setting.

If you deselect this option lists will be exported as standard

<OL> and <UL> lists with <LI> list elements. This option also

supports formatted lists but has some limitations compared

to the text option. See Formatting Lists  for more informa-

tion on this. 

If an image has no cap-

tion export file name as

hint:

Images in HTML pages can have an ALT attribute that displays

a small text in a "tooltip" when the user positions the mouse

pointer over the image. 

Selecting this option exports the image file name as the ALT

attribute if the image doesn't have a caption. Unless your

graphics files have very descriptive names it is normally advis-

able to switch this off.

Highlight hotspots in

pictures

When this is on hotspot links in images and graphics are high-

lighted for easier visibility and respond on mouseover. Turn-

ing this off creates invisible hotspots that only change the

mouse cursor form on mouseover.

Export SVG images as

PNG

If you turn this off, SVG vector images will be exported nat-

ively to CHM. However, you need to ensure that your SVGs

are compatible with CHM for this to work correctly. See SVG

Graphics  for details.

335
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File links - embed

linked files

Activating this option physically embeds external files in the

PDF file so that you can distribute additional files with your

PDF document. Only files linked to in your document with file

links  will be embedded. 

Conversion options for

non-HTML image

formats:

This option controls how images in your project not compat-

ible with HTML are converted and exported when you publish

to HTML-based formats. It does not affect JPEG, GIF and PNG

images, which are exported without conversion.

Which option provides the best results depends on the type

of images in your project. GIF and PNG generally provide the

smallest files with the best quality for screenshots with 256

colors or less. PNG files are usually too large for images with

more than 256 colors; JPEG is the better choice for those.

Screenshots often do not look so good when converted to

JPEG so you should always choose your settings to make sure

that this doesn't happen. It is better to use GIF or PNG and no

more than 256 colors for screenshots.

JPEG and true-color PNG are really only needed for photo-

graphs and continuous-tone graphics, and JPEG is generally

preferable for this because it produces much smaller files for

true color images. 

Output quality for JPEG

images:

You can reduce graphic file size by decreasing the quality but

this will also make the images look less good. A value of

between 80 and 90 is normally acceptable.

Note that this quality setting is only applied to JPEG images

actually generated by the program on the basis of the con-

version settings (see above). JPEG images that you insert in

your project directly are not affected. They are used as they

are, without any changes.

Export topics of class

"Popup" as JavaScript

popup windows:

Activate this to use JavaScript popups in WebHelp, CHM and

Visual Studio Help. See Creating popup topics  and Using

JavaScript popups  for full details.

See also:
Configuring Your Output

Visual Studio Help  (Advanced Procedures)

Visual Studio Help  (Reference)

424
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11.3.3.5 Microsoft Word

The settings in this section control how your project is exported to MS Word DOCX, which

generates 100% compatible Word DOCX documents. 

In addition to the options you can configure here you can also define the entire Word DOCX

layout with templates that you can edit directly in Word. See this chapter  for details.

11.3.3.5.1  Word Options

The options in this section provide some additional options for your MS Word DOCX output. 

In addition to the options you can configure here you can also define the entire Word DOCX

layout with templates that you can edit directly in Word. See this chapter  for details.

Options:

Link colors and underline

styles

Colors and styles for hyperlinks in your Word documents

Enable links to external

files:

Enter the extensions of external file types you want to permit

links to here. 

Note that the files will generally have to be in the same

folder as the Word file for these links to work!

Figure numbering: Add automatic figure numbering to images in your topics

that have captions.

Note that figure numbering will only be added to images

with captions configured in the Insert Image dialog. It will

not be applied to images without captions!

See also:
MS Word DOCX  (Help Formats)

MS Word DOCX  (Publishing)

11.3.3.6 eBooks: ePUB+Kindle

The settings in this section control how your project is exported to the ePUB and Kindle/Mobi

eBooks formats. Kindle/Mobi is the standard format for Amazon Kindle eBooks and allows

you to distribute your eBooks directly through Amazon. The ePUB eBook format is now the

leading universal open format for eBooks. The ePUB 3.0 eBooks generated by Help+Manual

are compatible with all ePUB hardware and software readers. However, they also contain the

additional special configuration and formatting information for display on Apple iOS devices

(iPad, iPhone and iPod Touch).

682
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See the sections on eBooks in the Publishing Formats  and Configuring Your Output

chapters for more information on preparing and publishing eBooks.

See also:
Publishing Formats - eBooks  

Configuring Your Output - ePUB

11.3.3.6.1  ePUB+Kindle: General Settings

The ePUB 3.0 eBook and Kindle/Mobi eBook formats are ideal for distributing your docu-

mentation as eBooks on the great majority of platforms available today. 

However, you also need to understand that eBooks are more restrictive than some other

formats. They are designed to be more like a book than an electronic document. As a result,

there are both limitations on the formatting you can use and some special requirements. See

the sections on eBooks in the Publishing Formats  and Configuring Your Output

chapters for more information on preparing and publishing eBooks.

Important: This section is not included in skins

This section is not stored in HTML skins, it is project-only. Even if you are using a skin, you

must still configure this in your project.

Cover pictures

Just click and select an image to add front and/or back cover pictures. You must use an

HTML-compatible format (JPG, PNG or GIF).

Configuration options

The only fields that are absolutely required are the book ID (UID), which is the unique

identifier for your eBook, and the title, without which your eBook will not display its title

properly in readers. Most of the other options are recommended, however.

You can use text variables  in all the fields listed below. 

Book ID:

Required! 

Also referred to as the UID. This is the unique identifier of

your eBook, so you should attempt to make it genuinely

unique to avoid confusion with other available publica-

tions. You can use any alphanumeric text string here – for

example your web address plus the name of the book. 

URI:

Optional but recommended

A web link, for example to a page with information about

the book on your website. It's a good idea to include this

as eBook readers often have online access. Always include

1513 749

1513

749

1513 749
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the http:// prefix with the URI, plain www. addresses will

probably fail!

ISBN:

Optional, recommended if you

have one

If your book has an ISBN code then enter it here.

Book Title:

Technically optional but re-

quired for proper display of

book title in readers

The title of your eBook.  You can use the <\%TITLE%>

variable to insert the title of your project here.

Subject: 

Optional but recommended

A short description of your eBook's subject matter.

Description:

Optional, generally helpful

A longer description of your eBook.

Author:

Optional but recommended

The author of your eBook. If you have entered the author

of your project in your Common Properties you can insert

the <%AUTHOR%> variable here to use the same text string

automatically.

File Author as:

Optional

An additional attribute for the author that shows explicitly

how the author is to be filed officially. For example, you

might enter Rev. Dr. Martin Luther King Jr. for

Author and King, Martin Luther Jr. for File As.

Publisher:

Optional but recommended

The publisher (i.e. your company) of the eBook. 

Copyright:

Optional but recommended

Your copyright notice. You can use the <\%COPYRIGHT%>

variable to insert the standard copyright notice stored in

your project.

Relation:

Optional

Relation information for your eBook, this can be an URI

(weblink, the new term for URLs) or other information.

This is defined as an "auxiliary resource and its relation-

ship to the publication".

Embed fonts: Embeds the fonts used in your project in the eBook. See

below for more details on this.
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Export HelpXplain slide

shows as interactive HTML:

If your project contains a HelpXplain slide show activating

this option will export it with full interactivity instead of as

a static image.Only use this option if you are certain that

the eBook readers you are targeting will support it. Most

readers have very limited HTML5 and CSS3 support. s

Font embedding

You can embed fonts used in your ePUB and Kindle eBooks. This is required for languages

with special character sets on some readers, including Adobe Digital Editions. Apple

iBooks does not require font embedding for special characters, but you may wish to em-

bed fonts to get more control over your book's appearance. 

Kindle does not display embedded fonts by default

Note that Kindle readers and apps do not user your embedded fonts by default. The user

must activate them in the device's or reader's font settings and must know that the setting

is available. If your layout depends on a specific font you need to be aware that that font

will not be displayed by default on Kindle devices and apps!

Font rights, eBook size

Embedding fonts can make your eBook considerably larger and you must have permission

from the font copyright holder to distribute the fonts you embed.

See Managing Fonts in eBooks  for full details.

11.3.3.6.2  ePUB+Kindle: Table of Contents

The ePUB 3.0 and Kindle/Mobi formats support a customizable Table of Contents (TOC).

These formats are HTML, and you can change the format of the TOC for your eBooks by edit-

ing the TOC template in this section.

TOC HTML Code:

The actual table of contents HTML code is generated automatically by Help+Manual as an

unordered list (<ol>) and inserted in the template by the <%TABLE_OF_CONTENTS%>

variable.

Don't replace the <nav> element:

For compatibility with the ePUB format you should not try to replace the <nav> tags in

the TOC template with different elements.

CSS styles and stylesheets:

764
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By default Help+Manual references the CSS stylesheet generated from the styles defined

in your project in this page, using the <%STYLESHEET%> variable in the head section of

the template. You can replace this with your own inline CSS styles in the template or a ref-

erence to your own CSS stylesheet file if you like. If you use your own stylesheet file, just

add it to the baggage files  section of your project and it will be exported automatic-

ally. 

11.3.3.6.3  ePUB+Kindle: Page Template

The ePUB 3.0 and Kindle/Mobi formats supports a customizable page template. The format is

HTML, and you can change the layout of the pages for your eBooks by editing the page tem-

plate in this section. 

Don't try to lay out eBooks like normal HTML pages!

The Kindle and ePUB formats are designed to be like a real printed book and they only

support very limited HTML layout capabilities. Don't try to include JavaScript and naviga-

tion commands – that would just make your book invalid and it will never work. 

Remember also that the pages on eBook readers are effectively very small. Basically, you

should aim for simple, free-flowing paragraphs with images between the paragraphs. 

Page content HTML code:

The HTML code for your pages is generated automatically by Help+Manual from the top-

ics in your project and inserted in the template by the <%TOPIC_TEXT%> variable. 

Keywords element:

Don't delete or replace the element containing the <%TOPIC_KEYWORDS%> variable. This

is required to enable Help+Manual to insert valid index keywords in your pages.

CSS styles and stylesheets:

By default Help+Manual references the CSS stylesheet generated from the styles defined

in your project in this page, using the <%STYLESHEET%> variable in the head section of

the template. Don't delete this! If you do, none of the styles defined in your project will

be used!

In almost all cases, the formatting of your page content should be controlled entirely by

the styles defined in your project. You can add your own inline CSS styles in the template

or a reference to your own CSS stylesheet file if you like, but these should only be used for

page layout. 

If you use your own stylesheet file, just add it to the baggage files  section of your pro-

ject and it will be exported automatically. 

11.3.3.6.4  HTML Export Options

The ePUB and Kindle/Mobi formats share their HTML export settings with WebHelp. These

settings can be configured in the Publishing Options > WebHelp > HTML Export Options

1121
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section. Settings there that are not relevant for eBooks will just be ignored in eBook output.

See here for details .

11.3.3.7 eWriter Help

eWriter Help is available with viewers for both Windows and MacOS. The standalone Windows

eViewer is also available in a Windows Store version, that the user is prompted to install when

they open a file with the .ewriter extension. In addition to this there are download in-

stallers for the various viewer versions for end users, and versions of the viewers for de-

velopers to install with their software for application help. 

See eWriter Help  in the Publishing chapter for full details.

Shared settings:

The options in the HTML Export Options section for WebHelp are also used for eBooks

(ePUB, Kindle/Mobi) and eWriter Help. These settings are accessible in the WebHelp

section of your project configuration. Settings that are not relevant for individual formats

are ignored in those formats.

11.3.3.7.1  General Settings

The settings in this section control the appearance of the eWriter Help viewer, an icon and

logo and some security options

Zoom +/- Keys
In your finished eWriter Help file, pressing the

CTRL+[Plus] and CTRL+[Minus] keys will zoom the

eViewer display in and out 

Window title

The eViewer window title displays the title of the help file/project. This is a static display

that does not change with the current topic. The previous per-topic display is no longer

supported. The behavior now matches other formats, including CHM, PDF and so on,

which all have static window titles.

1435
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Options

eViewer Window: These settings define the size of the eWriter viewer

window when the user first opens it. Once the user

has adjusted the size this setting is ignored. You can

also set the size and the position of the window on

the first call from your software with the defpos

command  in your call to the viewer. This com-

mand will be ignored if you use it in subsequent calls

once the viewer has been opened.

The dimensions use virtual pixels that adapt auto-

matically to the resolution of the user's monitor.

Custom Icon (Windows only): Choose an .ico format icon file to be displayed for

your help file in Windows Explorer. This setting is ig-

nored on the MacOS version.

Logo: Optional logo image with an optional URL to a web

page. This is displayed in the title bar of the eViewer

on the right, next to the Print icon. 

Copy and print options: Restrict the ability of the user to copy or print con-

tent.

Important – copy/print restriction requires a cus-

tom context menu! 

In order to be able to restrict copying and printing

you must activate a custom context menu  in the

General Settings page. If you don't do this the em-

bedded browser engine provides copying and print-

ing facilities that cannot be disabled by the eWriter

viewer.

Require Admin mode: Windows EXE files only

The user can only view the help file from an Admin-

istrator Windows account. This is only for integrated

EXE eWriter Help files with the viewer and the book

in a single file. 

701
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Open external links in default

browser:

When this is selected, links to external web pages

open in the user's default web browser. 

This is recommended, because otherwise the ex-

ternal pages will open in the viewer, replacing the

current help entirely. Also, the embedded browser

may not provide desirable functionality for normal

web pages that often need to navigate elsewhere.

Password: Password required to open the help file and text

prompt to display when asking for the password.

Including the password in application calls

If your book is protected with a password you can

include it in the call from your software with the p=

switch so that the user does not need to enter it.

However, be aware that doing this is not secure, as it

may be possible to retrieve the password on com-

puters where this has been done.

eViewer.exe "ewriter://<path>\my-
help.ewriter?pw=password"

Expiry date: Create a time-limited eWriter Help file that expires

automatically on a specific date. The file cannot be

opened or accessed after this date.

11.3.3.7.2  App Menus

The functions in this tab allow you to enable and customize the two types of menus that can

be displayed in the eViewer: An application menu to be displayed at the top left corner of the

viewer, and a context menu to be displayed when the user right-clicks in a topic page.

Zoom +/- Keys
In your finished eWriter Help file pressing the

CTRL+[Plus] and CTRL+[Minus] keys will zoom the

eViewer display in and out 
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Activating and deactivating menus

Select the check boxes above the menu types to include or exclude the menus from your

Help file. 

Changes since the previous version

Application menu and context (right-click) menu

Application Menu

This is the menu accessed in the top left corner of the eWriter viewer window. The title is

always displayed, so you need to configure it even when you turn the menu itself off.

When the eViewer is opened on its own without an eWriter Help file, it displays "eViewer".

 

No menu entries: Application menu button is displayed without an arrow and with

the short title of the project.

Menu entries: Menu button includes a drop-down arrow for opening the menu.

Command line: The contents of the menu can be affected by command line

switches if you are calling eWriter Help from your application. See

EWriter for Software Help  for full details.

Context menu (required for disabling copying and printing!)

This is the menu displayed when the user right-clicks in an eWriter book. If you don't ac-

tivate this the right-click menu of the embedded web browser engine is used. 

Disabling copying and printing: 

Note that you can only disable copying and printing (see General Settings ) if the cus-

tom context menu is enabled, because this replaces the browser's context menu. The em-

bedded browser's context menu automatically supports copying and printing and this

cannot be disabled by the eWriter viewer if it has not been replaced by a custom context

menu.

731
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Configuring and customizing menus

· Existing menu items: Click in the demo menu to select an item or position in the

menu. Then click on the entry type on the right and configure it with the options dis-

played.

· New items: Click in the menu where you want to insert the item and select Add or In-

sert. Then define the menu type and configure it.

· Moving items: Select the item and use the four move buttons to move it around. The <

and > buttons are only active for items below submenu items. 

· Deleting and resetting: The Delete button removes the current item. The Reset but-

ton restores all menus to the default settings, deleting any custom menus.

Entry types

Command A number of standard commands supported by the viewer.

They include commands for navigation, selecting and copying

text, printing pages and closing the viewer.

The :home command is no longer available

This command is deprecated in the new version of eViewer

and if you add it, or if it is already configured from an earlier

version, it will not be displayed in your eWriter Help file.

Page link A link to a topic page in your help file. You can select the page

from a drop-down list of all the pages in your source folder.

The field can also be edited manually. This enables you to use

this feature when compiling a modular project made up of

multiple projects to eWriter. Then you just need to manually

enter the topic ID of the topic you want to link to in any of the

projects that are going to be published to the eWriter book. 

Web link A link to an external web page.

· Enter the full URL, including the http:// or https:// pre-

fix.

· Pages will open in the Help file viewer or the user's default

browser, depending on the setting in the General Settings

screen.

Execute external file: Creates an entry that runs a program or opens an external

document. Enter the name and path to the file and any addi-
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tional execution parameters you wish to use.

Sub-menus and di-

viders:

These entries create sub-menu headings and dividers to or-

ganize your menus. After creating a sub-menu you can move

other entries into the sub-menu with the four move buttons

(up / down / left / right).

Caption: The captions displayed in the menus. Add a an ampersand (&)

character before the letter that you want to be active for the

keyboard shortcut for the menu option. 

11.4 Styles, Formatting and Tables

This section provides some general background information on the styles used in

Help+Manual and how they work. If you are familiar with using styles in word processors like

Microsoft Word most of this will already be familiar to you but there are also some differ-

ences that you should be aware of.

See also:
Text Formatting and Styles  (how-to instructions)

11.4.1 Why use dynamic styles?

The advantages of dynamic styles are so great that you will never want to go back to manual

formatting once you have learned how to use them. They will speed up your work, make it

more efficient and make your finished product look more attractive and professional. If you

wish, it is quite possible to use only manual formatting in your Help+Manual projects.

However, if you do this you will create a lot of unnecessary extra work for yourself and your

documentation will not look so good. 

Instant changes throughout your project

When you format text manually you have to go back and change everything manually

whenever you change your mind about how you want a headline or a paragraph to look.

This can take hours in a big project, and since it's boring and repetitive work you are also

likely to make mistakes. Also, when you format manually you will often apply slightly dif-

ferent formatting to text passages that are supposed to look the same, and your work will

look messy as a result.

Suppose your client or your boss says that they want to use Verdana 16 point instead of

Times Roman 14 point in the topic headers. With styles all you need to do is change the

definition of  the heading style, which takes a couple of seconds, and all the headers in

your entire project are updated instantly.

273
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You can think of a style as a named formatting definition for either text or an entire para-

graph. When you use styles you have a separate style for every different type of para-

graph and text in your project. For example, by default normal body text paragraphs are

normally formatted with a style called Normal, and the topic headers are normally format-

ted with a style called Heading1. You can define as many other styles as you like for other

purposes.

Instant formatting

Once you get the hang of it, working with styles is much faster than using manual format-

ting. To format an entire paragraph you just select the style in the menu, or press the

hotkey combination for the style, and all the formatting is applied immediately. You don't

even have to select the paragraph. And all new text and paragraphs you type from that

point will also have the selected style until you change it.

Uniform appearance and layout

Since your styles are predefined all your formatting, indents and so on will be identical,

giving your projects a uniform and much more professional appearance. 

"Branding" your output with skins

If you have the Professional or Floating license version of Help+Manual you can save all

your styles and your other project layout settings in a special format file called a "skin".

When you publish another project you can apply all the styles from the skin to it by select-

ing the skin file in the Publish  dialog – all the styles in the project with matching names

will then be replaced by the styles from the skin.

See Transforming Your Output with Skins  for full details on this.

Dynamic inheritance

Help+Manual's styles aren't just dynamic, they also have dynamic inheritance. This means

that styles based on other styles automatically "inherit" the properties of their parent

styles. All properties that you do not change in the child styles are dynamically linked to

the parent style. 

This means you can create families of styles in which you can change properties through-

out the entire family just by modifying a single parent style. See About inheritance in

styles  for full details on dynamic inheritance and how it works.
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Smaller output files

Note that using styles efficiently can also make your output files quite a bit smaller, partic-

ularly in HTML-based output (HTML Help, WebHelp, Visual Studio Help, Windows Exe and

ePUB eBooks). Manual formatting must include a large number of detailed tags every time

it is applied – in extreme cases these tags can use up more bytes than the text itself. Styles

are only defined once and are applied with a simple and very brief reference to the in-

ternal stylesheet. 

See also:
Text Formatting and Styles  (how-to instructions)

About inheritance in styles

11.4.2 How do styles work?

To understand how dynamic styles work you need to understand three concepts: Style defini-

tions, dynamic linking and dynamic inheritance. Style definitions are how you create styles,

dynamic linking is how your styles are associated with your text and dynamic inheritance en-

ables you to create related "families" of styles.

Style definitions:

A style is a set of formatting definitions with a name that makes it possible for you to

identify and select it. It can include all the formatting attributes that you can apply to text

and paragraphs with the Font, Paragraph and Borders and Backgrounds formatting tools.

For convenience, you can create two kinds of styles: Text styles, which only define font

formatting attributes, and paragraph styles, which define all available attributes, including

font attributes. Similarly, styles can also be linked to either entire paragraphs or individual

passages of text. These are the two "units" that are used in connection with styles. (See

Paragraph and text styles  for details.)

Dynamic linking:

A set of formatting definitions is no good on its own, of course. Styles are useful because

you can link them to paragraphs and text in your project. As soon as you apply a style

to a paragraph or a passage of text the style definition is dynamically linked to that para-

graph or that text. All the style attributes are applied to the paragraph or the text auto-

matically, and when the cursor is in the paragraph or the text the name of the style is dis-

played in the style selector in the Toolbar:
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   Here the cursor is in a paragraph

   formatted with the Normal style.

We say that the style is dynamically linked because all changes in the style definition are

automatically and immediately reflected in all paragraphs and/or text linked to the style. If

you change the font face, font size, paragraph indents and so on in the style definition

these changes are all immediately reflected in all the paragraphs and text linked to the

style.

Dynamic inheritance:

Most styles are based on other styles. This makes defining styles easier, because you often

have groups of quite similar styles. In addition to this it also makes styles much more

powerful.  Here's why:

We refer to "parent" and "child" styles. Just as a human child inherits some genes from its

parents and has some unique characteristics of its own, styles also inherit some properties

from their parents and have some properties of their own.

In styles, however, inheritance is dynamic, in exactly the same way that linking to the text

formatted by styles is dynamic. All attributes that you don't change in the child styles are

shared with the parent style. If you change an attribute in the parent style the change is

immediately reflected in both the child style and all paragraphs and/or text formatted

with the child style. 

This means that you can make changes to entire "families" of styles, and to all the text

formatted with those styles, just by editing one parent style. For example, you can usually

change the font in your entire project by changing the font setting in the Normal style,

because most of styles in your project are  usually based on that style. 

See About inheritance in styles  for full details on this subject.

See also:
Text Formatting and Styles  (how-to instructions)

About inheritance in styles

11.4.3 About inheritance in styles

Alongside dynamic linking , dynamic inheritance is the second feature that gives dynamic

styles their great flexibility and power. If you understand dynamic inheritance you will be able

to use and organize your styles much more efficiently, so please do study this topic carefully!
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What is dynamic inheritance?

Put briefly, dynamic inheritance means that styles based on other styles inherit the attrib-

utes of their parent styles, and the inherited attributes are dynamically linked to the same

attributes in the parent styles. If an attribute is changed in the parent the change is auto-

matically (and immediately) inherited by all child styles. Equally, these changes are also

automatically and immediately reflected in all texts to which the child styles are linked. 

For example, if you change the font of the Normal style, which is usually the "Grand-

daddy" style on which almost all styles in any project are based, this automatically and im-

mediately changes the font in (almost) all styles in your project. The only exceptions are

styles that are not based on Normal, and styles which already have different fonts set.

And this is the next important aspect of dynamic inheritance: It only applies to attributes

that have not been changed in the child styles. As soon as an attribute is changed in a

style it is "fixed", and no longer affected by changes in the parent style. Styles based on

the changed child style will then inherit this new attribute, not the original attribute from

the original parent.

The inheritance tree

Styles do not have to be based on other styles but they usually are. When you create a

new style on the basis of another style (see Defining styles ) it is initially an exact copy

of its parent style, so that it shares all its attributes of the parent. We say that the child

style "inherits" all the attributes of its parent style. 

Two identical styles wouldn't be much use, so you then edit some of the attributes of your

new style and leave others unchanged. The key to understanding dynamic inheritance is

understanding its relationship to the changed and unchanged attributes in the child styles.

Let's have a look at a simple example of a style inheritance tree. The standard style on

which almost all other styles are based is called Normal. You can edit this style, but like

the other standard styles  you cannot rename it or delete it. The example below shows

some styles based on Normal. Please note that this tree is simplified to make the explana-

tions easier; in reality there are many more attributes, and each style could also have mul-

tiple children on each level instead of just one.
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                     Fig. 1: Simplified example of a style tree

Changed and unchanged attributes:

In this example changed attributes are shown in blue, unchanged attributes in black. 

The unchanged attributes are dynamically linked to the corresponding attributes in their

parent styles – changes made to these attributes in the parent are automatically inherited

by the children. By the same token, inheritance from the parent stops at the changed at-

tributes. 

How this works in the example:

In the example above all the child styles except Callout inherit the Arial font from Normal,

because this font face has not been changed in any of these styles. If you edit Normal and

change Arial to Times Roman then the font of all the child styles except Callout will auto-

matically change from Arial to Times Roman.

The styles Normal Indent and Normal Indent 2 also inherit the font size from Normal. If

you edit Normal and change the its font size from 11 points to 12 points this change will

be inherited by these two styles, but not by the two Heading styles.

Another good example is the Space After attribute. In Normal this attribute is set to 0.1",

and this value is inherited by all of the child styles except Heading2. If you edit Normal

and set its Space After attribute to 0.0" this change will be inherited by all the child styles

except Heading2.
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Changed attributes start a new inheritance sequence:

A changed attribute in a child style starts a new inheritance sequence:

In Callout the original font has been changed to Verdana 10. Callout 2 inherits the font

face, but the size has been changed to 12. This means that if you edit Callout and change

its font to Tahoma, this change will be inherited by Callout 2. However, changing the font

size in Callout will not be reflected in Callout 2, because the font size has been changed

there, thus stopping inheritance for that attribute.

The same applies to the font weight in the two Heading styles. In Heading1 the font

weight has been changed to bold, so changes to the font weight in Normal will not have

any effect on Heading1 or any of its children. Heading2 inherits the font weight attribute

from Heading1, so if you edit Heading1 and change its weight to non-bold this change

will be inherited by Heading2.

This illustrates the most important characteristic of inheritance for changed attributes:

Changing an attribute turns off inheritance from the parent for that attribute. At the same

time, however, it starts a new inheritance tree for the same attribute: when you create new

styles based on the modified style the new setting is inherited by the new styles.

Parallel inheritance and serial inheritance:

You can also organize the inheritance of your style families in two different ways, with par-

allel inheritance and serial inheritance. It works like this:

               Fig. 2: Parallel and serial inheritance

In parallel inheritance trees all the sub-styles are direct children of the parent style. This

option is used when you are creating direct variants of a parent style. For example, you

might use this to create three different variants of your body text style that have different

indents but are otherwise identical.

In serial trees you have a grandparent - parent - child relationship structure. Each new

style is based on the preceding variant. This option is used for families of styles that

change progressively. A typical example of this is a family of headline styles with font sizes

that get progressively smaller. 
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As Fig. 1  further above in this topic shows, most style trees use a combination of paral-

lel and serial inheritance.

Why dynamic inheritance is useful:

Just as dynamic styles make it possible to reformat your entire project by editing a couple

of style definitions, dynamic inheritance makes it possible to make basic changes to entire

families of styles by editing a single style definition. For example, you can usually change

the base font for your entire project by changing the font setting of Normal. For more de-

tails on using these features to plan your styles see Style organization strategies .

Stopping inheritance:

Precisely because dynamic inheritance is so powerful there may be times when you want

to stop it. There are situations when you want to make absolutely certain that a style will

never be changed when you make changes to another style. 

Doing this is very simple: Just don't base your new style on another style: When you cre-

ate a new style  select (None) in the Based on Style: field for the style definition. You can

also change this later if you want. See Editing styles  for details.

The standard Code Example style used for formatting program code with the syntax high-

lighter  is an example of this. This style does not have a parent because its format must

always be the same – you don't want any other styles to be able to change its font, size or

paragraph formatting.

A style without a parent starts a new inheritance tree

A style without a parent does not inherit any attributes from any other styles. This means

that it is "protected" against unexpected changes caused by changes in parent styles. 

At the same time, a style without a parent is also the "first parent" in a new inheritance

tree: If you base new styles on this style they will inherit the properties of the style. You

can use these capabilities to create new and separate families of styles. See Style

organization strategies  for some more ideas on this.

Switch off inheritance with caution!

When you are learning how to use styles it is tempting to switch off inheritance for many

styles because you may think this will give you greater control over your formatting. In the

short term this is true but in the long term it is better to learn to use inheritance efficiently.

Defining many styles without parents will actually create much more work for you later if

you decide to make far-reaching changes in your formatting. Again, see Style organization

strategies  for some more ideas on this.
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See also:
Style organization strategies

Text Formatting and Styles  (how-to instructions)

11.4.4 The standard styles

If you look at the styles list in the styles editing dialog you will notice that some styles are dis-

played with the addition (Standard Style) after the style name. These styles are special styles

that  Help+Manual always expects to find because it uses them for specific purposes. You can

edit them but you cannot change their names and you cannot delete them.

The standard styles and what they are for:

Normal: This is the basic parent style that almost all other styles, including

header styles, are normally based on. By default Normal is also used

for the standard starting paragraph in all new topics. (You can change

this by defining a new standard topic content template .)

Having almost all other styles based on Normal makes it possible to

make changes to the appearance of your entire project by editing

Normal. For example, changing the font of Normal automatically

changes the font of all other styles in which you have not explicitly

defined a different font from the one set for Normal.

For more details on this see About inheritance in styles  and Style

organization strategies .

Code Example: This style is automatically applied to all program code formatted with

the Syntax Highlighter . Unlike most other styles it is not based on

Normal, because you don't want its appearance to change when you

change the formatting of the rest of your project.

Comment: This style defines the appearance of the comments  you can enter in

your project. This style is quite limited compared to most other styles.

See Image caption and comment styles  for details.

Heading1: This is the style used for the topic header displayed in the box above

the editing area. It's a good idea to use it as the parent for a family of

heading styles for use in the rest of your project. 

Image Caption: This style is applied to the captions of graphics  inserted in your top-

ics. Like the Comment style it is quite limited: See Image caption and

comment styles  for details.
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Notes: This style is reserved for functions that may be added to Help+Manual

in a future release. 

See also:
Text Formatting and Styles  (how-to instructions)

11.4.5 Paragraph, text and table styles

There are three different kinds of styles: paragraph styles, text styles and table styles. Para-

graph and text styles are closely related, table styles are actually completely separate.

As their names suggest, paragraph styles are for formatting entire paragraphs, text styles are

for formatting text only. See Defining styles  and Formatting text with styles  and for de-

tails on how to define and use paragraph and text styles.

About table styles

Table styles are used for tables only and do not have anything to do with the styles used for

formatting text and paragraphs. However, the rules of dynamic styles and dynamic inheritance

also apply for table styles. See Table styles  in the Working with Tables chapter for details

on using table styles.

The difference between paragraph and text styles:

Paragraph styles: 

These are the most commonly-used styles. They include all style attributes (font and para-

graph, including borders and background colors) and they are used for controlling the

general layout of your entire project. A paragraph style is generally applied to one or

more paragraphs. Note that border and background attributes are set separately but they

are actually a subset of the paragraph attributes.

Text styles:

These styles only include font attributes. They are used for applying standard formatting

to individual passages of text. 

Using paragraph styles as text styles:

If you select text within a paragraph and apply a paragraph style only its text attributes will

be applied. Effectively, the paragraph style is used as a text style when you do this. 

Display in the Ribbon:

In the style selector in the Ribbon paragraph styles are identified by a paragraph symbol,

text styles by an underlined a symbol. 
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Can you convert between the two style types?

Yes. The division between paragraph and text styles is actually made for convenience. In

reality all styles can always store all possible style attributes.

Converting a text style to a paragraph style:

You can always convert a text style to a paragraph style simply by adding paragraph

attributes to it. This is possible even if the style is based on another text style because

you are adding attributes, not taking them away, and this does not cause any prob-

lems in the style's dynamic inheritance tree (see below).

Converting a paragraph style to a text style:

You can also convert a paragraph style to text styles, but this is a little more difficult. If

the paragraph style is based on another paragraph style you must change its parent

setting  to (None) or to a text style. This is necessary because of dynamic inherit-

ance: If a style is based on a paragraph style it must inherit its parent's paragraph at-

tributes, and this makes it impossible for it to be a text style. 

See About inheritance in styles  for more information on dynamic inheritance.

See also:
Text Formatting and Styles  (how-to instructions)

Defining styles

Editing styles

About inheritance in styles

11.4.6 Image Styles

You can now define styles for images in the same way as for paragraphs and tables. And just

as with paragraphs and tables, changing the image style definition changes the formatting for
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all images tagged with the style. 

Image styles can also be used for image toggles and video placeholders

Note that image styles can be applied to image toggles  and the placeholders for

videos and online media .

Image style settings

Image styles can include these settings. The width and height settings allow you to create

a class of images that match exactly in your output. 

Responsive or

fixed width:

We recommend always using the responsive width setting (% of

page width). This makes your images adjust to the browser or

viewer window in HTML formats, or to the page width on publish-

ing in PDF and Word files. In both cases this prevents your images

from breaking your layout.

Responsive images in tables:

Note that when an image is in a table the % width is relative to the

table cell, not to the page.

Fixed height: This sets all the images to the same absolute height in pixels. You

cannot combine this with a width setting. You must set either the

width, or the height. 

Borders: Apply a border around all images formatted with the style.

Caption alignment: Align the image caption left, centered or right.
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Note on image styles in Word export

Image styles in Word DOCX export can have borders, but they cannot include rounded

corners or an offset between the image and the border. This is a restriction of the style

settings available in Word.

Defining an image style

Notes

· You can't add style settings to the Default image style. This is the standard setting for

images and is without additional style attributes. 

·  Image styles can be based on other image styles or independent. This is the same as

with other style types.

Procedure

1. Open Styles > Edit Styles in the Write tab. 

2. Locate the Image Styles heading and click on Add Style. 

3. Enter a name and choose whether it is to be based on another style or not. Styles

based on other styles inherit any settings you don't change in the parent.

4. Select Modify Layout to define the style settings.
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Width or height:

You can define either the width or the height. The other setting is always automatic. 

Percentage width or fixed width:

Percentage is recommended, because it makes the images responsive, adjusting in rela-

tion to the width of the current window or page. This is essential for responsive web

design for both desktop and mobile devices, and it also ensures that your images won't

break PDF and Word layouts.

Borders:

You can define the border style (solid, dashed etc.), width and color. Plus the radius, which

creates rounded corners, and an offset, for a border offset from the image.

Rounded borders with an offset:

If you use a style with rounded borders and an offset for the border, you will want the

rounded corners of the image to match those of the border as closely as possible. For this

to work, you need to use a fairly high value for the border radius. In the example below,

the 5px radius doesn't match the image, but the 20px radius does.
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Caption alignment:

Centered, left or right. The text style for the caption is defined globally with the Image

Caption style in the Text & Paragraph Styles section. 

Applying styles to images

The style setting is in the Insert/Open Image dialog displayed when you insert an image.

For existing images, just double-click on the image in the topic editor to display it.

Procedure

1. Insert a new image, or double-click on an existing image to display the dialog. 

2. Select the style from the Image Style: dropdown list and click on Open to save. 

Dual Styles for electronic help and print-style help (PDF etc.)

Screen View and Print View tabs:

You can define two sets of settings for each style: Screen View is for electronic help

formats (HTML Help, WebHelp and eWriter Help), Print View is for page-style formats

(PDF, Print User Manual, Word DOCX and ePUB eBooks).
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You can switch between the Screen and Print View style settings in the Help+Manual ed-

itor by clicking on the Screen/Print button in the status bar at the bottom of the main pro-

gram window.

11.4.7 Style organization strategies

This section describes some basic principles that will help you to use styles more efficiently.

Once you understand styles the way you use them is also a question of your personal working

preferences. For example, some people prefer to have a small, more manageable set of styles

and pay for this convenience with a little more manual formatting work. Others prefer to have

a large and almost complete set of styles that allows them to control virtually all their format-

ting by editing styles.

Separating formatting and content:

One of the basic purposes of dynamic styles is to allow you to separate formatting and

content. Theoretically, if you do this completely all the formatting in your entire project

would be controlled by styles and you would be able to change the appearance of

everything just by modifying the styles. In the real world all projects will normally contain

a certain amount of manually-formatted text. For example bold and underlining to em-

phasize individual words and passages, and individual manually-formatted paragraphs

and sections for which it would not be worthwhile to create one or more special styles. 
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The "many styles" and "few styles" strategies:

The number of styles you really need depends mainly on the amount of manual format-

ting you are willing to do. There are two basic approaches to this, the "many styles"

strategy and the "few styles" strategy:

Many styles:

If you want to control all your formatting with styles you will need quite a large number of

styles for each project. Most of these styles will not be unique, they will be variants of

other styles. For example you will probably want to have several variants of the Normal

style used for standard paragraphs with indents and other modifications. 

Few styles:

The "few styles" approach uses exactly the opposite strategy. Here you would use a single

style for each basic paragraph type, heading type and so on. With this strategy you don't

create any variants of these styles: If you want to use a variant, for example with an indent,

you must then apply the indent manually while you are writing and editing your topics.

This approach results in a much smaller list of styles that is easier to manage. It works if

you are quite clear about what formatting you are going to apply manually. However, you

must really be absolutely sure that all the manual formatting you apply are things you are

not going to change. In the case of indents, for example, this is generally a relatively safe

assumption.

You can still make global changes to your styles when you use this method, but any

manual formatting you have applied will not be changed when you change the style defin-

itions. (Manual formatting always has priority over style formatting.)

Style families

No matter whether you use many or few styles it is always advisable to organize your

styles in "families", both by name and by inheritance . 

Style name families:

This is simply logical and makes your styles easier to identify and find. It makes sense to

create families of headline styles called Heading1, Heading2, Heading3 and so on. Then

they all appear together in the list and you know what they are for. If you want you can

also include some key information in the names. You can organize your other style groups

like body text and so on in the same way.

1485
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Remember that you can rename your styles at any time! 

Don't hesitate to rename your styles if you need to! Help+Manual automatically updates

all style references so you can rename them to improve your styles organization whenever

you want.

Style inheritance families:

Styles inherit properties from the styles they are based on. If you base groups of styles on

a common parent style you can make changes to the common properties of the entire

style group by editing the parent style.

For example, you could base all your headline styles on the standard style  Heading1, if

you want them to be similar to Heading1. If you don't want them to be similar to Head-

ing1 you could create a new parent style for the headlines you want to use in your topics,

and base your other headline styles on that.

The same applies to other groups of styles for text or paragraphs with similar attributes.

See About inheritance in styles  for more background information on this.

Naming paragraph and text styles

It's advisable to apply a prefix to text styles that automatically distinguishes them from

paragraph styles and keeps them together in all the style selection lists, which are sorted

alphabetically – for example P_ for paragraph styles and T_ for text styles. 

Actually, you only need to use a prefix for one of the two because anything that doesn't

have the prefix is automatically identifiable as the other type. 

One inheritance tree or multiple trees?

By default all the styles in Help+Manual except the standard Code Example style (see The

standard styles ) are based on Normal, which is also the style used for standard para-

graphs in topics. This means that you have a single style inheritance tree. The advantage

of this is that it makes it possible to change attributes throughout your entire project by

editing Normal. You can change the standard font in all your styles simply by changing

the font of Normal, provided you haven't explicitly changed the base font in any styles.

The same applies for all other inherited attributes of Normal.

Creating new style inheritance trees:

When you create a new style that is not based on any other styles you effectively create a

new style inheritance tree. The question is, is this an advantage or a disadvantage?
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The main advantage of a completely new tree is that it is guaranteed that you can't acci-

dentally change the attributes of styles in the tree by editing Normal or another higher-

level style. Many authors use one tree for body text styles and another tree for header

styles, for example. 

The disadvantage is the same as the advantage: You have to edit the styles in the second

tree separately, which means maintaining your styles can be a little more work. But it can

be worth it if you find making this division makes it easier for you to manage your project.

It's a question of personal preference:

Ultimately it's a question of personal preference whether you use the one-tree or the

multi-tree method. However, it's probably a bad idea to create too many trees, as that can

get really troublesome to manage. 

If you do use multiple trees it's best to stick to one tree for each main group, for example

one tree for body text styles, one tree for header styles (particularly if you use different

fonts for headers and body text) and so on. 

Using hotkeys

Last but not least, don't forget to assign hotkeys (keyboard shortcuts) to your frequently-

used styles! If you spend any amount of time working with Help+Manual (and if you're

writing help you will) this can radically speed up your work. 

See also:
Text Formatting and Styles  (how-to instructions)

11.4.8 Tabs, indents and HTML

Tab stops and indents as used in word processors are unknown in HTML. You should thus al-

ways avoid using tab stops in any topics intended for output to HTML-based formats, i.e.

HTML Help, WebHelp and Windows Exe and ePUB eBooks. 

Attempts to use spaces to create indented effects in HTML-based output will also not be very

successful. This is because all HTML browsers ignore multiple spaces: It doesn't matter

whether you enter a single space or 100 spaces, the browser will always render them as a

single space – unless you enter hard (non-breaking) spaces with Alt+0160 on the numeric

keypad. 

Help+Manual actually converts multiple spaces you enter in the editor to space/hard space

pairs in HTML output to get around this problem, but this still doesn't make spaces a good

tool for indents – spaces render with different widths in different fonts and hard and soft

spaces can also have different widths.

273
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Tabs and indents are not the same thing:

In the Tab Stops settings of the Paragraph formatting dialog you will see the following

warning:

This might make you think that you can't use indents at all for HTML-based output but

this is not the case. You can use indented paragraphs, you just shouldn't try to use tabs or

spaces to make indents. You should always use Help+Manual's paragraph indenting

functions.

How Help+Manual handles indents in HTML:

How Help+Manual handles indented paragraphs depends on how they are formatted.

Paragraphs with simple indents are formatted with margin settings. 

Hanging indents are converted to tables, because this is the only way to make this con-

struction stable in HTML.

Special case – hanging indents with a tab stop:

Hanging indents are the only place you should use a tab stop. Here the tab character is

used to insert the space between the text in the left part of the indent (the hanging part)

from the main body of the paragraph, as shown in the example below. Paragraphs like this

are converted to tables in HTML, which is the only really stable structure for displaying

paragraphs with hanging indents in all browsers and the Microsoft HTML Help viewer.

299
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This also works if the beginning of the first line is indented from the left margin. This will

also be converted to a table structure that will be stable in HTML-based output.

See also:
Using indents

11.4.9 About table and column widths

The dynamic behavior of tables in the Help+Manual editor and published output may be a

little unfamiliar and even frustrating at first if you come from a word processing background.

This is because they work much more like HTML tables than like tables in word processors like

Word or Open Office Writer. However, if you have experience  with HTML you will feel right at

home with Help+Manual's table sizing functions.

Table and column width values

Tables have two sets of width values that interact with one another: The width of the table

and the widths of the individual columns. These values can be defined or undefined. 

Undefined width:

When the width value of a table or a column is undefined its width is determined by its

content – then the cells and columns will expand just enough for the content to fit, and no

more. This also applies to the height of table cells.

Defined width:

When the width value of a table or column is defined it will be at least as wide as the

defined value. If the content is wider the defined value will be ignored and the table or

column will expand to fit the content. 

Content expands table cells

Table cells are always at least as large as the content they contain. Your width and height

settings will always be ignored if your content is wider or higher. Table cells always expand

to accommodate all the text and  graphics they contain. Additional wrapping text will only

make a cell higher but graphics and non-wrapping text can also make cells wider, overrid-

ing the width settings.
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Table width settings

Tables have three different "width modes":

Autosize:

This is the default setting. Initially, the width of the table and all columns is undefined. All

widths are dynamic and everything expands to fit the content – the content defines the

width of both the columns and the table. 

Fit on page:

Equivalent to a width of 100%. The table will always expand to fit the current margins of

the paragraph or the entire page. Any column width settings that prevent this will be ig-

nored. The table should have at least one dynamic column to allow it to expand to fit the

page, otherwise all columns will automatically switch to dynamic width.

Manual:

The table will always have the preset width in percent or absolute pixels. It should have at

least one dynamic column that can expand or contract to make the defined width pos-

sible. If the defined table width is not possible with the preset column widths all columns

will automatically switch to dynamic width.

Column width settings

By default, columns are "dynamic" – this means that they do not have a width setting,

they expand automatically to fit the content in their cells and the table width settings. 

"Lock Column":

The Lock Column tool in the Table tab locks the current width of the selected column as a

fixed value in pixels. This width will be maintained if possible. This tool also shows whether

the current column is locked or unlocked – it is highlighted when the column is locked.

Column width in the Table Properties dialog:

You can lock the column width to a pixel or percentage value with Table > Properties >

Selected Cells. This width will be maintained if possible. 
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Resizing column widths with the mouse:

Resizing column widths with the mouse always locks both columns affected by the resize

operation. Be aware of this when planning your tables! You will often need to unlock one

column after resizing with the mouse to allow your table to resize correctly.

Impossible column widths

If any column width setting is not possible all column widths in the table will be reset to

dynamic. This will happen if the column contains content (graphics, non-breaking text)

that is wider than the set width or if the set width is made impossible by the other table

settings. 

For example, this will happen if:

· The table has a fixed width in pixels and the sum of the individual column widths is

greater than the width of the table.

· The sum of the column widths in percent is greater than 100%.

· Any table column contains content that is wider than the defined width of the column.

Height settings

Tables do not have height settings. Their height is always defined by the height of their

content.

Row/cell height is dynamic by default – it expands automatically to fit the content. You

can set a minimum fixed height value in pixels in Table > Properties > Selected Cells. If

the content of the cell or row is smaller than this value white space will be added. If the

content is higher the setting is ignored.

See also:
Working with Tables
Table Properties

11.5 Publishing Formats

This section provides an overview of the features, characteristics, advantages and disadvant-

ages of the output formats currently supported by Help+Manual. There is no such thing as

the "best" format. Each format serves its purpose, and each can be a good choice for some

tasks and a less good choice for others. 
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The supported formats:

HTML Help: This is currently the most popular electronic help format for Win-

dows applications. It packs your entire help project into a single

CHM file. Fast, compact, excellent navigation and usability, univer-

sally compatible and full interaction with applications. Displayed by

the HTML Help Viewer, that has been included with Windows since

Windows 98.

WebHelp: Displays in normal web browsers on all platforms (Windows, Linux,

Mac OS X, Unix). An emulation of the HTML Help interface, de-

signed for use on the Web and intranets. Complete with a dynamic

Table of Contents pane, keyword index and full-text search. Con-

sists of a directory containing a large number of HTML files, graph-

ics files and the files needed to display the Table of Contents etc. 

eWriter Help: eWriter combines the benefits of CHM and WebHelp and elimin-

ates many of the disadvantages of both. This exclusive

Help+Manual format has viewer applications for both Windows and

MacOS. You can distribute your eWriter Help in two ways:

· A single EXE file with combined integrated viewer and docu-

mentation (Windows only)

· Separate viewer and help files (eViewer viewer and help files

with an extension of your choice)

Using a separate viewer program and help files makes it easier to

give your customers updates for your help files because you just

need to distribute plain data files that do not need to be signed.

This format also provides an emulation of the familiar HTML Help

Viewer layout so that all users will be able to use it intuitively

without additional explanation.

Apple

iBooks®/ePUB

eBooks :

ePUB eBooks are an open format that is rapidly becoming a univer-

sal standard. In addition to displaying on Apple iOS devices (iPad,

iPhone, iPod Touch), they are supported by many other hardware

and software readers on many platforms. 

Adobe PDF: Your project can also be output as a fully-formatted and full-fea-

tured PDF file that can be displayed on any computer with a PDF
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reader. Ideal for providing manuals that users can print themselves,

either on CDs or for download.

Printed manu-

als:

The Print Manual feature (in the File menu) generates a temporary

PDF file in the background and outputs it to your printer. Also sup-

ports booklet format (multiple pages per sheet) and duplex print-

ing.

MS Word

DOCX:

Generates the current MS Word DOCX format, compatible with all

versions of Word that support DOCX. Includes templates that are

themselves DOCX files that can be edited in Word. For details see

MS Word DOCX  in the Configuring for Publishing chapter.

Visual Studio Help

2008 and 2010:

These specialized formats are also known as MS Help 2.0 and MS

Help 3.0. They are provided for programmers who need them to

document programming components in Visual Studio .NET. They

are not documented extensively in the help because Microsoft has

not released them for general use under Windows. Both formats

are irrelevant for normal application documentation.

For details see Visual Studio Help  in the More Advanced Proced-

ures section and the documentation of the MS Visual Studio .NET

package. (If you don't have this package you don't need and can-

not use Visual Studio Help.)

11.5.1 HTML Help

HTML Help is now fully established as the standard Windows help format and unless you have

a very good reason to use something else it is the best choice for online help distributed with

modern Windows applications. Users are familiar with it, navigation is intuitive and it supports

all the interactive and context-sensitive help technologies that make good help effective. And

since it is HTML-based you have considerable flexibility for both formatting and introducing

special features and functions.

HTML Help does have a couple of disadvantages: It is not ideal for web-based help or for help

on networks, but it is the top choice for help installed with applications on the user's com-

puter.

Restrictions on HTML Help on network drives:

Security restrictions in Windows now prevent access to HTML Help files network drives

and the Internet. File links  in HTML Help files will now generally not work at all across

networks, you can only link to files stored in the same folder as the HTML Help CHM file. It
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is possible to enable display of HTML Help on network drives with some special Windows

Registry entries, for which EC Software provides a free tool.

Features and pros and cons of HTML Help:

File extension: .chm

Format: One CHM file contains the entire help.

Platforms: All Windows versions since Windows 98 

Typical use: Local online help for applications installed on the user's com-

puter

Table of contents: Yes. Integrated in the CHM file and always visible in the viewer.

Excellent, immediately intuitive navigation for the user.

Keyword index: Yes

Full text search: Yes

Context sensitive

help:

Yes, full context-sensitive help support. Can include text-only

field-level popups  which can be displayed directly within

your application without the main help window.  

Popups: Yes, both in the help viewer and for context-sensitive help. Nat-

ively, HTML Help only supports text-only popups without

formatting or graphics. Only these plain-text popups can be

used for field-level popups displayed in your application. 

You can also use Help+Manual's JavaScript popups  in HTML

Help. In addition to formatted text and graphics JavaScript

popups also support hyperlinks and even videos and anima-

tions. 

You cannot mix JavaScript popups and plain-text popups in a

single project but you can create a separate project containing

only your plain-text popups if you want to include JavaScript

popups in your main project.

Multimedia: All Windows-compatible video formats are supported, along

with online video services. However, support for playing the

formats used must also be installed on the user's computer. For

897
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example, if you use a DiVX video don't expect it to be playable

on all user machines! 

Generally speaking, MP4 video is the most reliable video

format. However, if you want guaranteed compatibility it is best

to put your video on an online service like YouTube or Vimeo.

Then they will automatically handle the compatibility issues by

generating multiple versions of your video and serving up the

correct one for the current user.

Printable by user: The Print function of HTML Help is very limited. The help viewer

can print topics and chapters but each topic is printed on a sep-

arate page.

Pros: Single file containing all topics, graphics and the table of con-

tents. Intuitive, directory tree style table of contents that is al-

ways visible to the user. Flexible formatting with HTML (in

Help+Manual you have full control over your topic pages with

HTML templates ), including the ability to add functions with

JavaScript etc. by adding your own code to topics  and tem-

plates .The HTML base makes it easy to produce a browser-

based version for the web that looks almost identical to the

HTML Help version.

Cons: Popup topics are limited to plain text in native mode. Severe re-

strictions on deployment in networks and the Internet, primarily

suitable for help installed locally on the user's computer to-

gether with the application.

See also:
HTML Help  (Configuring Your Output)

HTML Help  (Configuration Options)

11.5.1.1 HTML Help project files

When you publish your project to HTML Help Help+Manual creates a temporary directory

called \~tmpchm in your project directory (this is the directory containing your .hmxp or

.hmxz project file). It then outputs all the files needed by the Microsoft HTML Help compiler

to this directory. These files include all the standard HTML Help project files that you would

create if you were producing HTML Help manually with HTML Help Workshop.
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Viewing the HTML Help source files:

Normally the \~tmpchm directory and all its contents are deleted after your project has

been published. If you want to view the files after publishing to check them just deselect

the Delete temporary files option in the Publish  dialog.

HTML Help project files:

projectname.hhp: This is the "control" file that brings together all the elements of the

project, telling the compiler what is going to be used and what

goes where.

projectname.hhc: This file contains the table of contents.

projectname.hhk: This file contains the keyword index.

projectname.hm: This is the map file containing the help context number assign-

ments.

projectname.h: This file contains the alias assignments, if applicable.

projectname.log: This file is generated by the Microsoft HTML Help compiler. It con-

tains the log of the last publishing session and any error messages

or warnings.

default.css: This file is generated by Help+Manual and contains the styles in-

formation for your project. It may have a different name if you

have changed it in Configuration > Publishing Options > HTML

Help > HTML Export Options  (Note that these settings are

shared with all HTML-based output formats. They are also access-

ible in the WebHelp and Visual Studio Help sections of the Con-

figuration section.)

CSHelp.txt: This file is generated by Help+Manual if you have activated plain-

text popups for HTML Help. It is a plain-text file containing the

texts of your popup topics. It may have a different name if you

have changed it in the the popup options  for HTML Help.

hm_popuptopics.js: This file is generated by Help+Manual if you have activated

JavaScript popups  in your project. It contains the code for your

JavaScript popups. It is added to the compiled CHM help file.

1310
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HTML files: These files with the extension .htm or .html contain your topics.

They are generated from your project by Help+Manual so that the

Microsoft compiler can use them to create the compiled CHM help

file.

Graphics files: These files are generated from your project in the correct formats

by Help+Manual so that the compiler can use them to create the

compiled CHM help file.

11.5.2 WebHelp

WebHelp outputs your project to normal HTML pages that can be displayed with a standard

web browser, either locally or on the Internet. The WebHelp generated by Help+Manual is de-

signed to emulate the appearance and functionality of HTML Help, with a TOC tree pane, a

keyword index and full-text search (Pro version only).

The HTML code generated for WebHelp is CSS and DHTML based and is compatible with all

modern browsers on all platforms (Windows, Linux, Mac OS X, Unix). It is intelligent code that

automatically "downgrades gracefully" when it encounters old browses and browsers with re-

strictive security functions. On these browsers some of the "eye candy" functions will be

turned off but the help will still be fully functional.

WebHelp is the best choice for help on the Internet and on local intranet systems, where

HTML Help is restricted by Windows security barriers.

Features and pros and cons of WebHelp:

File extensions: .htm and .html, graphics in JPG, PNG or GIF format. You can

also set the extensions of your topic files to anything else re-

quired by your project in HTML Export Options  (e.g. .php

etc.).

Format: A collection of HTML, graphics and other files in a directory, just

like a website (it is a website)

Platforms: All major computer platforms and browsers, including Mac and

Linux

Browser compatibil-

ity:

The WebHelp output generated by Help+Manual is fully com-

patible with all major browsers. In addition to this the output

will also work transparently on older and security-restricted

browsers. It achieves this by automatically identifying browser

capabilities and "downgrading gracefully", providing less dy-

1459
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namic and formatting features but still presenting a fully-func-

tional help system.

Typical use: Online help and documentation on the web or on local in-

tranets where the use of HTML Help is not practical. 

Table of contents: Yes

Keyword index: Yes

Full text search: Yes (available in the Professional and Floating license versions

of Help+Manual only)

Context-sensitive

help:

Context calls from applications  to topics and anchors in top-

ics are supported. Field-level context popups displayed  within

your applications are not supported.

Popups: Yes, with JavaScript popups  that are compatible with all cur-

rent browsers and do not trigger popup blockers.

Multimedia: Theoretically a wide range of video formats are supported, but

whether they work or not depend on support for playing the

formats used being installed on the user's computer. Also, the

degree and quality of the support also depends on the support

provided by the browser the user is using. So please test your

output on all relevant browsers before distributing! 

However, if you want guaranteed compatibility it is best to put

your video on an online service like YouTube or Vimeo. Then

they will automatically handle the compatibility issues by gen-

erating multiple versions of your video and serving up the cor-

rect one for the current user.

Printable by user: Limited to browser print functions, which can generally only

print individual topics. 

Pros: Platform and cross-browser compatible, ideal for help on the

web and intranet systems. All the flexibility and formatting

power of HTML, including the ability to add functions with

JavaScript etc. by adding your own code to topics  and tem-

plates .
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Cons: WebHelp consists of many individual HTML files, graphics and

other files. 

See also:
WebHelp  (Configuring Your Output)

WebHelp  (Configuration Options)

Browser compatibility

11.5.2.1 Browser compatibility

The WebHelp generated by Help+Manual is compatible with all modern browsers. It requires

a web server and JavaScript to work correctly (see below for details). For documentation in-

stalled locally, use eWriter, CHM, or possibly PDF. 

Different appearance in different browsers:

It is unavoidable that your WebHelp output will look slightly different depending on the

browser used to view it. HTML Help and Visual Studio Help are proprietary Microsoft

formats that are displayed with Microsoft viewers using the integrated Windows WebView

component. Your output in these formats will generally resemble your source in the

Help+Manual editor more closely. 

This is not possible in WebHelp. The HTML code generated is the best possible comprom-

ise between compliance with web standards for HTML and CSS and the quirks and weak-

nesses of individual browsers. Discrepancies between browsers have become less in recent

years, but to a certain extent individual browsers often interpret the same rules differently.

Skins for legacy browsers

If you are targeting legacy browsers or WebViews, usually based on very old versions of

Internet Explorer, we recommend using the "Two Frames Classic" skins. These are original

skins from the IE 6 era that still use the deprecated frameset structure, and they should

still work fine on very old browsers.

Browser and web server requirements for all features:

The current WebHelp skins require current browsers supporting HTML5, CSS3 and the

current iteration of JavaScript. WebHelp has a complex, multi-page structure and requires

both JavaScript and a web server to work correctly. It will not work if you just try to open

its HTML files by double-clicking them — it is designed for the web and must be deployed

on a web server (either Internet or intranet) and accessed via a web browser with a URL. If

you need WebHelp style documentation stored locally, use eWriter instead . 

See also:
WebHelp  (Configuring Your Output)
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WebHelp  (Configuration Options)

11.5.3 Kindle and ePUB eBooks

The Amazon Kindle/Mobi eBook format

Kindle/Mobi is the proprietary format used for Amazon Kindle eBooks, which can be read

on the Amazon Kindle hardware eBook readers and a wide variety of Kindle apps on dif-

ferent platofrms. Internally, this format is really just a minor variant of the universal ePUB

format. However, Kindle eBooks are packaged in a proprietary Amazon binary format in-

stead of in a normal ZIP file like standard ePUB. There are just a few formatting and con-

figuration changes that need to be made and these are handled automatically by

Help+Manual.

The standard ePUB eBook format

The ePUB format (file extension .epub) is a standard for eBooks created by the Interna-

tional Digital Publishing Forum. It is the standard eBook format on Apple iOS devices,

which currently include the iPad, the iPhone and the iPod Touch. Help+Manual's ePUB

output is designed to be fully compatible with the Apple iBooks® eBook reader on these

devices so that you can distribute your ePUB output through the Apple iTunes store. 

In addition to Apple iBooks®, ePUB is also supported by most other hardware eBook

readers, including the Sony Reader series, other smartphones and many other devices,

and by many software readers like the Adobe Digital Editions reader. 

See ePUB Resources  for more details, including sources for reader software and

devices. 

Professional and Floating license versions only

Please note that the support for ePUB and Kindle eBooks only included in the Professional

and Floating license versions of Help+Manual. You cannot generate these eBooks with the

Basic version. 

11.5.3.1 Apple iBooks® - ePUB

Key Information
Keep your eBook projects simple. Avoid complex lay-

outs and formatting, only use simple tables and don't

use invisible topics. Only a..z, A..Z, 0..9 and _ are per-

mitted in topic IDs in eBooks!
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The ePUB format

The ePUB format is completely open. An ePUB eBook consists of basic XHTML for the

book content, XML for descriptions, and a zip archive file with the extension .epub con-

taining all the files. 

Apple iBooks® ePUB eBooks:

The ePUB eBooks generated by Help+Manual are fully compatible with the Apple

iBooks® reader on the Apple iPad, iPhone and iPod Touch. iBooks® is different from

other readers in many ways and has a number of special requirements. 

Features and pros and cons of ePUB eBooks:

File extension: .epub

Format: A single zip archive file containing the XHTML and XML files

and other components. Additional configuration files and spe-

cial settings are required for compatibility with Apple iBooks®

on Apple's iOS devices (iPad, iPhone and iPod Touch). 

Platforms: Viewable on any platform or device for which an ePUB reader is

available. Apple iBooks® on the iPad, iPhone and iPod Touch,

Sony Reader, Windows, Apple OS X, Linux, Unix, Sony Reader,

mobile phones and many more.

Typical use: Reading books on hardware eBook readers. Although a large

number of software readers are available, only a very small

number of users actually read books on computers. The huge

majority use mobile devices like the iPad to read eBooks.

Distribution: ePUB eBooks can be distributed directly. Even if you are target-

ing Apple iBooks® devices, you can distribute your ePUB

eBooks directly to your customers and they can install them on

the device themselves.

Easiest distribution method: 

Put the eBook file online and post the URL to the file as a QR

code, which can be generated by Help+Manual . Users then

scan the QR code with their device camera and the book is

downloaded and loaded automatically by their ePUB eBook

reader app. 

262



1515

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Reference

Table of contents: Yes, not supported by all readers

Keyword index: No

Full text search: Yes, but search functionality depends on reader

Context-sensitive

help:

No support for context-sensitive help, you cannot make direct

calls to specific topics in the help

Popups: No

Multimedia: Video is supported in iBooks® on Apple iOS devices (iPad,

iPhone, iPod Touch). Some other devices may support video

but don't depend on it. Most don't. 

Printable by user: Yes, but print functionality depends on reader

Pros: Single-file, universal cross-platform format already supported

by many software and hardware readers. Large number of ePUB

eBooks already published, already a universal standard. Gener-

ally intuitive handling (depends on reader). 

Cons: This is really a dedicated format for books in electronic form.

Best for books that users read in the same way as a printed

book. Search but no index, simple formatting only, video only in

iBooks®.

See also:
Kindle/Mobi and ePUB 3.0  (Configuring for Publishing)

11.5.3.2 Amazon Kindle/Mobi

Key Information
Keep your eBook projects simple. Avoid complex lay-

outs and formatting, only use simple tables and don't

use invisible topics. Only a..z, A..Z, 0..9 and _ are per-

mitted in topic IDs in eBooks!

The Amazon Kindle/Mobi format

The Kindle/Mobi format is closed and proprietary and used only for Amazon Kindle

eBooks. You can view the source files generated before the creation of a Kindle eBook, but

once the book has been created it can generally be regarded as closed and only viewable

on an Amazon Kindle device or with an Amazon Kindle app.
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Features and pros and cons of Kindle eBooks:

File extension: .mobi

Format: A proprietary compressed binary file containing the XHTML and

XML files and other Kindle eBook components. 

Platforms: Kindle eBooks distributed via the Amazon Kindle store are only

viewable on Amazon Kindle devices and apps. Unprotected

Kindle eBook files can also be viewed with other compatible

reader apps like Calibre.

Typical use: Can only be used for Kindle eBooks.

Distribution: Unprotected Kindle eBooks can be distributed directly. Users

can install them on their devices themselves. The only exception

is the Windows Phone platform, which can only accept Kindle

eBooks directly from the Amazon Kindle store for the Kindle

app. 

Easiest distribution method: 

Put the eBook file online and post the URL to the file as a QR

code, which can be generated by Help+Manual . Users then

scan the QR code with their device camera and the book is

downloaded and loaded automatically by the Kindle app (ex-

cept on Windows Phone). 

Table of contents: Yes

Keyword index: No

Full text search: Yes

Context-sensitive
help:

No support for context-sensitive help, you cannot make direct

calls to specific topics in the help

Popups: No

Multimedia: No

Printable by user: No
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Pros: Only way to distribute eBooks for the Amazon Kindle. You can

distribute them directly to the user or submit them to Amazon

for distribution via the official Kindle store.

Cons:

See also:
Kindle/Mobi and ePUB 3.0  (Configuring for Publishing)

11.5.3.3 ePUB resources

This page contains a selection of hardware, software and information resources relating to the

ePUB format and ePUB eBooks. It is not necessarily complete, but it is a good starting-point. 

Reference reader devices and readers for testing

Apple iBooks

The only reference eBook reader for iBooks is the Apple iPad, with the iBooks app installed

from the Apple App Store. If you want to distribute your eBooks for iOS devices you must

have access to a physical iPad for testing. You will also need access to an iPhone or iPod

Touch if you expect your books to be read on these smaller devices. You can install ePUB

eBooks on these devices with Apple iTunes. Just connect the device to your computer and

drag the ePUB file onto the iPad entry in the iTunes window.

Other hardware readers

It's a good idea to have access to the physical hardware readers you are targeting for testing.

Some have more limited capabilities than others. 

Software readers - get Adobe Digital Editions

The reference software reader is the free  Adobe Digital Editions. Before trying to create

ePUB eBooks you should download this free reader from Adobe and install it. If you don't do

this you won't be able to view your ePUB eBooks on your Windows computer after creating

them with Help+Manual. ADE generally provides a good idea of how your eBook is going to

look on software readers.

Up-to-date resources list on Wikipedia

The most up-to-date list of ePUB resources is available on this page on Wikipedia:

 https://en.wikipedia.org/wiki/EPUB

Hardware devices supporting ePub eBooks

The following hardware readers currently support ePUB eBooks, either directly or with free

additional software. The most notably absent device on this list at the moment is the

749
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Amazon Kindle, which still uses its own closed proprietary format. However, it is rumored

that ePUB support for the Kindle is in the works and due to be released in the near future. 

Dedicated hardware ePUB and eBook readers

There are now a wide range of hardware ePUB and eBook readers on market. See the

Comparison of e-readers on Wikipedia for a good list of the currently available devices

and their capabilities.

Apple iPad, iPhone and iPod Touch

All these devices support ePUB directly with the iBooks® eBook reader integrated in their

iOS operating system. Help+Manual ePUB eBooks are fully compatible with Apple

iBooks®. There are also other eBook readers for iOS available in the Apple iTunes App

Store.

Android smartphones and tablets

A wide variety of ePUB readers are available for Android. 

Other mobile phones and smartphones

Many other mobile devices also support ePUB eBooks.

Software readers for ePub eBooks

Software readers for ePUB eBooks are already available on many platforms. The following

list only includes the known software-based readers that support the ePUB format at the

time of writing – others may already be available. 

The reference software reader is Adobe Digital Editions used to be a good choice but it

is now no longer supported so well and it has been involved in controversies regarding

Adobe's use of user data. For general testing on Windows, Mac OS and Linux we now re-

commend the Calibre eBook Reader.

Calibre eBook Reader (Windows, Apple Mac OS, Linux) 

This free program is now the software ePUB reader with the best support for ePUB and we

strongly recommend that you install it for testing your ePUB books. 

Other software eBook readers

There is now such a large number of software-based eBook readers for all current systems

that it would be impossible to make any recommendations here. You will need to check

current reviews for the best readers for the system you want to use. For testing your own

eBooks, however, we can warmly recommend Calibre.

Online resources for ePub eBooks

Melody Simmons eBook Indie Covers 

https://en.wikipedia.org/wiki/Kobo_eReader
http://www.adobe.com/products/digitaleditions/
https://calibre-ebook.com/
https://calibre-ebook.com/
https://ebookindiecovers.com
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Excellent site for everything related to eBook covers and cover images.

International Digital Publishing Forum 

This is main home page for ePUB and everything relating to the ePUB format. This is also

where you can find full specifications of the open ePUB format.

Project Gutenberg 

A huge number of free eBooks in all categories, including both classics and new books.

Feedbooks 

Free classics in ePUB format.

Snee 

Free children's picture books in ePUB format

11.5.4 eWriter Help

Key Information
Help+Manual eWriter Help is available for Windows

and MacOS. Use ePUB, PDF or Word RTF to target

other platforms.  

This exclusive Help+Manual format packages WebHelp  with its full table of contents and

user interface into a single file. On Windows 10 users will be prompted to install the Windows

Store eViewer app for eWriter when they open a file with the .ewriter extension, if they

don't already have the viewer. A free installer for the standard Windows eViewer app is avail-

able from our eWriter page for users on earlier versions of Windows. 

EWriter uses Windows' own HTML rendering engine to display the content, with full support

for CSS3, HTML5 and JavaScript. The eWriter files are neutral, digitally compressed files that

can be distributed without signatures by download or as email attachments. 

The better alternative to CHM on Windows

eWriter Help files are an attractive alternative to the obsolete CHM format for document-

ing software applications on Windows machines. The eWriter format combines the bene-

fits of CHM and WebHelp and eliminates many disadvantages of both. It also allows you

to execute operations  in your application with hyperlinks for the creation of interactive

help tutorials.

1510
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A modern integrated help format for MacOS

With the exception of the very old Apple Help/Help Viewer format that most Mac apps no

longer use, there is not really an integrated help format like CHM for the Apple platform.

eViewer provides one.

Layout and functionality with WebHelp skins

You can use WebHelp skins for eWriter to get all the layout and formatting options avail-

able in WebHelp, including integrated search and a keyword index. At the same time, it is

a compact single file like a CHM and supports context help calls from applications. Unlike

CHM files, it can be accessed on networks, and unlike WebHelp, repeated application calls

to the same eWriter Help file all open in the same window. It is stored in a single, compact

binary file.

Unique benefits of eWriter Help

Viewer and distribution options

· Windows Store viewer that installs automatically when the user opens an eWriter file

with the .ewriter extension (Windows 10)

· Free installer for users on earlier versions of Windows

· Viewer can also be installed as part of your software installation

· Neutral binary files that can be freely distributed by download, as email attachments or

as part of a software installation

General Features:

· Publish Help+Manual created documentation directly to eWriter with full TOC and user

interface, using WebHelp skins.

· You can also package any HTML files or websites as an eWriter Help file, complete with

all the layout and dynamic features supported by HTML.  

· Consistent presentation, always using the same HTML rendering engine. No nasty sur-

prises because of different displays in different browsers. 

· Perform operations in your application with links in the help for interactive documenta-

tion and tutorials

· Advanced security: provides levels of protection impossible in CHM files or WebHelp. 

· Supports HelpXplain animations, video, JavaScript, CSS etc. 

· Context help support – use eBooks instead of CHM files or WebHelp for software docu-

mentation.  

· Make advanced eBooks with rich features not possible in conventional, plain-text

eBooks. 

731
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· Kiosk mode for interactive demonstrations and presentations. 

Security features

· Password protection. 

· Prevent copying and printing. 

· EBooks with expiry date that can automatically open a specific web page when opened

after expiry. 

· Support for digital signing for added validation and protection. 

· Prevent access to the source code of your HTML pages. 

· Allow eBooks to be opened only by Administrator Windows accounts.  

Benefits for software documentation

· Full support for context help calls to topics and anchors

· Security and access control features not available in CHM and WebHelp

· Can be accessed on a local network, unlike CHM.

· Compact, single-file format (WebHelp must be stored in a folder containing many files

and requires a web server to work properly) 

· Unlike WebHelp, every call from your application to the eBook is opened in the same

window. Every call from an application to WebHelp opens a new browser window. 

· Full support for context help with simple URL syntax. You can interpret all the compon-

ents of the URL command line just as you would in a normal web browser.

· The user never sees the command line.  

Features and pros and cons of eWriter Help:

File extension: .ewriter

.exe (older integrated format with book and viewer in a single

EXE file)

You can also choose any extension you like when deploying

eWriter for your own software documentation .

Formats: Single, neutral compressed binary file. Separate standalone

viewer. 

Alternative: Integrated format combining viewer and book in a

single EXE file with a name of your choice.

Platforms: Full MS Windows only, Windows RT and Windows CS not sup-

ported. Viewer for MacOS planned.

731
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Typical use: Windows software documentation, computer and Windows

tablet based eBooks, standalone documentation, time-limited

subscription and demonstration books, kiosk applications (in-

cludes a kiosk mode)

Table of contents: Yes

Keyword index: Yes

Full text search: Yes

Context-sensitive

help:

Full support for context-sensitive help. It is possible to make

direct calls to specific topics and anchors in the help. Combines

the functionality of CHM and WebHelp in a single compact file. 

Limitation: No equivalent for CHM's A-Links and K-Links

Popups: Yes, same formatted popup functionality supported as in regu-

lar WebHelp.

Multimedia: Same as WebHelp 

Printable by user: Printing by topic, as in WebHelp. Even so, we recommend

providing a PDF version for printing.

Pros: Combines benefits of CHM and WebHelp, eliminating the dis-

advantages of both formats. Reliable HTML rendering because

the same Windows HTML engine is always used. Same layout

and skinning flexibility as WebHelp. Supports performing oper-

ations in your application  from links in the help for interact-

ive documentation and tutorials. Full context sensitive help sup-

port. Single compact file. Accessible on local networks. Excellent

security and access control features. 

Windows Store viewer app installs automatically for users of

Windows 8 and 10. Free viewer installers available for Windows

XP, Vista and 7.

Cons: Windows only, not yet available on Linux, MacOS, iOS or

Android. Not compatible with hardware eBook readers (but can

be used on Windows tablets). No equivalent for CHM A-Link

and K-Link functionality.

See also:

708
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Configuring eWriter Help  

eWriter project configuration settings reference

11.5.5 Adobe PDF

Adobe's Portable Document Format (PDF) is now the industry standard format for electronic

distribution of printable manuals. PDF provides a high level of formatting fidelity. Layout and

appearance are "fixed", and unlike HTML it is not dependent on the quirks of browsers. 

It is also a compact, single-file format that is now supported by all major computer platforms

as well as Windows. Navigation can be quite good but it is less flexible for on-screen viewing

and navigation than HTML Help. The domain of PDF is printable manuals with clearly-defined

layout and formatting that do not change on different systems. It is suitable for downloading

but not for online viewing on the Web as users must always download the entire document,

even if they only want to view a single page.

 Features and pros and cons of Adobe PDF:

File extension: .pdf

PDF version: The PDF output conforms to version 1.2 of the PDF specifica-

tion and can be viewed with version 3 and above of Adobe

Acrobat and Adobe Reader.

Format: One .pdf file containing all text and graphics

Platforms: All major computer platforms and operating systems

Typical use: Print manuals distributed in electronic form, electronic books

Table of contents: Yes, integrated in the PDF file. Hyperlinks are supported for on-

screen viewing.

Keyword index: Yes but limited, just page number references at the end of the

document.

Full text search: Yes, in Adobe Reader

Context-sensitive

help:

Support for links to topics, page numbers and PDF template

sections with named destinations

Popups: No support for popups. Popup links are displayed as normal

text.

696
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Multimedia: No multimedia support.

Printable by user: Yes. The PDF format is ideal for printing and providing a print-

able version of your manual. 

Pros: Printer orientated format supporting precise layout with spe-

cifically defined page sizes, margins, headers, footers, etc.

Highly customizable with Help+Manual using print manual

templates .

Cons: Requires the Adobe Reader viewer but this is free and installed

on almost all computers. Many other excellent viewers are

available. Not appropriate for application help because of the

lack of context-sensitive features. Not suitable for Internet ac-

cess because the entire document must be downloaded to view

anything in the document.

Other information: All the topics not included in your project's Table of Contents

are excluded from PDF output and printed manuals. This is by

design because PDF is treated as a print format. By definition,

there is no place in print-style documents for topics that are not

included in the TOC, which are only designed to be accessed

with hyperlinks. 

If you want to include information from topics not included in

your TOC you need to use Help+Manual's conditional output

features  to make alternative content for the PDF version.

See also:
Adobe PDF  (Configuring Your Output)

Adobe PDF  (Configuration Options)

PDF and Printed Manuals

11.5.6 Printed manuals

When you output a manual to your printer with the Print Manual in the File menu

Help+Manual generates a temporary PDF file and deletes it after the printout has been com-

pleted.

Just like Adobe PDF output, the layout of printed manuals is controlled with print manual

templates . For details on printing manuals and using print manual templates see PDF and

Printed Manuals .

See also:
Adobe PDF  (Configuring Your Output)

PDF and Printed Manuals
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11.5.7 Visual Studio Help

Visual Studio Help is available in two versions, Visual Studio Help 2008 and 2010, which are

also known as MS Help 2.0 and MS Help 3.0, respectively. Originally, each of these help

formats was announced as the upcoming the successor to HTML Help. However, in both cases

Microsoft then backpedaled and it now seems clear that they are not going to be released as

help formats for normal user applications. 

Professional and Floating license versions Only

Please note that the support for Visual Studio Help (both formats) is only included in the

Professional and Floating license versions of Help+Manual. You cannot generate Visual

Studio Help with the Basic version.

Visual Studio Help is not for consumer applications!

Visual Studio Help is only used for documenting components designed to be integrated

into the Visual Studio .NET programming environment. The advantage of this is that the

documentation becomes part of VS.NET's own documentation, making it possible to

provide context-sensitive help for third-party VS.NET components.

For all other help applications you should always use one of the the other more appropri-

ate formats, for example an HTML Help CHM file for help installed locally with your applic-

ation and WebHelp for help accessed on a network or the Internet. For more information

see Visual Studio Help  in the More Advanced Procedures section.

See also:
Visual Studio Help  (Advanced Procedures)

Visual Studio Help  (Publishing Options)

11.5.8 MS Word DOCX

This is the native MS Word DOCX format supported by all current versions of Word. It in-

cludes full support for configurable layout templates  that are themselves DOCX files that

you can edit in Word. 

 Features and pros and cons of the Word DOCX format:

File extension: .docx

Format: One DOCX  file, graphics embedded in the file

Platforms: MS Word

1132
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Typical use: Print manuals distributed in electronic form, has now been gen-

erally replaced by PDF

Table of contents: Yes, auto-generated in Word

Keyword index: Yes, auto-generated in Word

Full text search: Yes (with MS Word)

Context sensitive

help:

No

Popups: No support for popups

Multimedia: No multimedia support

Printable by user: Yes (with MS Word)

Pros: Can be viewed, edited, searched and printed with MS Word. 

Cons: Relatively static, similar to PDF. Not suitable for interactive help.

Other information: As in PDF, all the topics not included in your TOC are excluded

from DOCX output. This is by design because DOCX is treated

as a print format. By definition, there is no place in print-style

documents for topics that are not included in the TOC. 

If you want to include information from topics not included in

your TOC you need to use Help+Manual's conditional output

features  or alternative TOCs  to make alternative content

for the DOCX version.

Hyperlinks  are supported in MS Word DOCX files.

See also:
MS Word DOCX  (Configuring Your Output)

MS Word DOCX  (Configuration Options)

11.6 Project Content

This section covers some subjects relating to the content of your projects, including Section

1194.21 accessibility information, background information on using snippets and multiple

TOC references, information on using graphics and videos in your projects and information on

scripts, inline HTML code objects and macros. 
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11.6.1 Snippets and multiple references

Help+Manual gives you two different ways to "reuse" topics in your project: The Snippets

Tool , which inserts a copy of the contents of one topic or an external H+M XML file in an-

other topic, and multiple references  to a single topic in the Table of Contents (TOC). Both

these methods have their advantages and disadvantages.

About multiple TOC references to a single topic:

Creating multiple TOC references to a single topic is a little like having several doors to

the same room. You may be able to enter through different doors, but the room is always

the same. A topic with multiple TOC references is still just one topic, but the user can dis-

play it by clicking on different entries in the TOC. 

For the user it looks as though there is a separate copy of the topic in several different

locations. Actually, however, there isn't. There is still just one topic, and this means that it

is 100% identical in every location. It cannot have even the smallest difference because it

is the same topic. The only difference that is possible is that you can have different cap-

tions (titles) for the TOC entries for each instance – the doors are different but the room is

the same.

See Multiple TOC entries for one topic  for instructions on using this feature.

Advantages:

· The "multiple topics" do not increase the size of your output files because there is really

only one topic. 

Disadvantages:

· All the "instances" have the same topic ID so it is only possible to create hyperlinks to

the original instance.

· For the same reason all keywords associated with the topic will always link to the ori-

ginal instance of the topic.

· All the instances are 100% identical because they are the same topic. You cannot have

different text before or after the "copies" in the individual locations.

About the Snippets Tool:

The Snippets Tool  allows you to insert the contents of one topic in another topic. This

can be done either in Copy mode or in Link mode. 

Using Copy mode is like copying and pasting text. The contents of the other topic or XML

file are pasted into the current topic and can be edited. Only the text is copied and once

265
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the copy has been made the text is part of the current topic. If the topic you inserted from

is edited nothing changes in the current topic. 

This mode is used for text blocks that you want to edit after inserting them, for example

tables that need to be filled out.

When you use Link mode you create a link to the other topic or XML file. You can't edit

the text inside the current topic but when the source topic or file is changed the changes

are reflected in the linked copy as well. When you publish your project a static copy is

made of the linked topic, but until then the link is dynamic and all changes in the linked

topic are updated.

Linked snippets can be used in multiple places and all the "copies" will be updated simul-

taneously when the linked topic or file is edited. This mode is used for text that you want

to use in many places in exactly the same way.

The current contents of the source topic are displayed in the editor at the insertion point

with a shaded background.

In addition to this, the source topic or XML file also exports any index keywords  it con-

tains to the target topic. (With XML file snippets this only applies if the snippet is a full

topic.) This means that any keywords associated with the source topic also only need to

be entered once; they are automatically exported to all target topics and combined with

any keywords the target topic already contains. This only works with index keywords,

however. A-keywords , topic IDs  and help context numbers  are not exported, be-

cause this would cause logical problems.

Advantages:

This method has several important advantages over multiple TOC references :

· You can include different text before and after the embedded topic. This makes embed-

ded topics ideal for documentation where you need to repeat the same instructions in

different contexts.

· You can insert snippets inline, as formatted text that is part of an existing paragraph. 

· In the published output all the topics containing embedded topics are real, unique top-

ics containing copies of the source information. Each topic has its own unique topic ID

that can be linked to directly.

· All normal index keywords are embedded together with the topic – you only need to

enter the keywords for the embedded text once. (A-keywords are not embedded be-

cause this would cause logical contradictions.)
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Disadvantages:

· The only real disadvantage of embedded topics is that they make your project larger,

but not really all that much larger. Text does not take up much room and multiple in-

stances of  graphics don't inflate your file size because there is never more than one

copy of identical graphics in your output file.

See Re-using content with snippets  for instructions on using this feature.

See also:
Multiple TOC entries for one topic

Re-using content with snippets

11.6.2 Graphics, Videos and OLE Objects

This section contains some useful background information on using graphics, multimedia files

and OLE objects in your help projects.

11.6.2.1 Graphic formats and file size

The main factor that increases the size of your help files is the use of big graphics with too

many colors. Compared to images text hardly takes up any space at all.  

In many cases you may find it most practical to use standard uncompressed BMP bitmap files

for your graphics in your projects. This may seem odd at first: BMP files are generally larger

than all other graphic files, as they are without any compression at all. However, they can be

converted most easily and since they are  uncompressed they suffer no quality degradation.

Help+Manual converts BMP files to the appropriate format and compress them automatically

when you publish your output. Like the XML format used for the source of your topics, BMP is

a flexible choice for exporting to multiple formats.

Use Impict .IPP images directly for edited screenshots

If you edit your images in Help+Manual's Impict graphics editor you will often add shapes,

text callouts etc. If you save these images in Impict's own .IPP format you will be able to

re-edit all the objects you add later. You can insert Impict .IPP images directly in your top-

ics. They have lossless compression and can be converted to all other formats required,

just like BMP. 

How to keep your graphics and help files small:

Here are some basic rules of thumb for minimizing the size of your graphics and output

files if you need to keep output sizes to an absolute minimum. However, file sizes are

really not as important nowadays as they used to be. You may find it more practical to re-

lax these rules and use full-color BMP and IPP images across the board. 
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Use images with 256 colors for screenshots.

This will generally reduce your output file size more than anything else. You will almost

never need more than 256 colors for screenshots unless your program contains graphical

components with complex color gradients. 

Don't use JPEGs for screenshots.

Help+Manual allows you to insert compressed JPG images directly into your projects,

along with many other graphics formats. However, JPG images are always TrueColor, so

it's not possible to reduce the number of colors to 256 or less. Also, the compression used

in JPEG images often makes screenshots look bad because it creates ugly "artefacts" at

the sharp transitions that are typical in elements of items on computer screens.

It's better to use uncompressed BMP images with 256 colors or less and allow

Help+Manual's Image Conversion function to handle the compression at publish time. If

you want to do the compression yourself use GIF or PNG for 256-color images, the quality

will be much better than with JPG.

The Image Conversion settings are in the HTML Export Options , which can be accessed

in both the HTML Help and the WebHelp sections of Configuration > Publishing Options

in the Project Explorer. 

Don't use PNG for images with more than 256 colors

The PNG format is an excellent choice for images with up to 256 colors. It is even more

compact than GIF and has excellent quality. However, PNG files with more than 256 colors

are actually a different format. These files are significantly larger than the equivalent JPG

files. Sometimes they are only a little smaller than BMP files.

This also means that you should make sure that your image conversion settings  will

not convert images with more than 256 colors to PNG. If your project contains images

with more than 256 colors it is better to choose JPG as the conversion format.

Avoid conversion of photos reduced to 256 colors:

Modern graphics programs can do an excellent job of reducing photos to 256 colors with

little or no reduction in visible quality, which also saves space. However, doing this can

cause a problem in Help+Manual if you save the images as BMP.

If your image conversion settings  are set to convert images with 256 colors or less to

GIF any photos with this number of colors will also be converted to GIF. This can make

them look bad, with nasty posterizing effects, and it can also increase the size of your files

because continuous-tone images compress poorly in the GIF format.

1459

1459

1459



1531

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Reference

If you get bad results with 256-color photos saved as BMP try saving them in the PNG 

format with your graphics program and then insert them directly into your Help+Manual

project. This will ensure that they will not be converted in HTML-based output formats.

Keep the dimensions of your graphics small.

Smaller graphics take up much less space. Do you really need to include a full-size screen-

shot of the main program window? If the user is reading your help the program you are

describing is already on the screen, and full-size screenshots also make the help difficult

to navigate. A 75% or even 50% size version is normally plenty as a visual reference.

You can shrink the screenshot and add attractive callouts and other features with

Impict , the full-featured screenshot editing program bundled with Help+Manual. You

can also make screenshots at reduced sizes directly with Help+Manual's integrated screen

capture utility  or with the standalone  TNT screen capture program.

Reduce the use of photographs.

Lots of full-color photos will also bloat your output files. If you do use them keep them

small and if you are producing HTML Help or WebHelp make sure that your image con-

version settings  are set to Convert 256 colors to GIF and True Color to JPEG. While you

are at it, experiment with the JPG compression setting in the same place; your pictures

may be smaller and look just as good with a lower quality setting. A value between 70 and

80 is generally fine for most purposes and you can often get away with even higher com-

pression settings. 

Don't show the entire image if you don't have to.

Areas of an image that are a single color take up almost no space when the image is com-

pressed and parts of an image that are not there take up no space. Quite often you can

save space by cropping your images to remove unnecessary information, and this also fo-

cuses user attention on what is important.

You can also crop your screenshots with special effects like Ripped Paper Edge in the

Screen Capture  tool and the Impict  screenshot editing program. This both saves

space and makes your screenshots look better!

Tips and tricks for graphics formats:

 Adding JPGs, PNGs, SVGs and GIFs to your projects directly:

Help+Manual inserts JPG, PNG, SVG and GIF images directly, without converting or re-

compressing them. They are exported to HTML-based output formats just as they are.
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However, they do have to be converted for some other formats. See SVG Graphics  for

some more information on this vector-based format.

Windows metafiles:

You also can add vector-format Windows metafiles (WMF and EMF files) to your projects

directly. When you publish your projects these files are converted to bitmaps and then the

normal conversion and compression options set in your Image Conversion settings are

applied.

See also:
Using Graphics  

SVG Graphics

Image conversion settings  

11.6.2.2 SVG Graphics

Vector-based SVG graphics files are very useful for responsive designs and any other formats

where the content may be zoomed because they are compact and can be scaled without any

loss of quality. You can insert them directly in your topics just like any other graphics files.

How they are supported and handled in individual output formats varies slightly, however.

WebHelp: Both uncompressed SVG and compressed SVGz graphics are ex-

ported directly as the original files in WebHelp. In addition to this,

each image has a PNG fallback image that is displayed in older

browsers that do not support SVG.

MS HTML

Help/CHM:
(Also applies for

older versions of In-

ternet Explorer)

The Microsoft CHM viewer uses an older mode of Internet Explorer

to display help pages which is not seamlessly compatible with SVG

files. They can only be rendered correctly if certain conditions are

fulfilled. Because of this, SVGs are converted to PNG by default

when you publish to CHM. If you are sure that your SVG files will

work correctly in CHM you can turn this conversion off.

Characteristics of the PNG conversion:

When SVGs are converted to PNG the resulting PNG will have the

current display dimensions of the SVG or the original SVG dimen-

sions, whichever are larger.
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Enable export of native SVG files to CHM:

By default, Help+Manual converts SVG to PNG for CHM export for

maximum compatibility. If you want vector SVGs to be exported

natively to CHM you need to turn off PNG conversion in Configur-

ation > Publishing Options > Microsoft HTML Help > HTML

Export Options.

Compiler warnings for incompatible SVGs

Help+Manual checks for these attributes when you publish to CHM

with native SVG support switched on. If it encounters files without

the necessary attributes warnings will be displayed in the compiler

report. 

Conditions for correct rendering of SVG graphics

in the CHM viewer

SVG graphics are will be rendered and scaled correctly in the Mi-

crosoft CHM viewer if the following conditions are fulfilled:

1) The skin or template includes the following line in the HTML

Page Template:

<meta http-equiv="X-UA-Compatible" con-
tent="IE=9" />

This line is included by default in all of Help+Manual's standard

CHM skins and in the CHM skins in the Premium Pack add-on. If

this line is missing or if the IE level is set to 8 or lower, the CHM

viewer will not support SVG and the SVG graphics will be converted

to PNG on export.

2) The SVG file you use contains correctly configured width,

height and viewBox attribute

The version of MS Internet Explorer used in the CHM viewer can

only scale SVG graphics if the <svg> tag in the SVG file contains

correctly configured width and height attributes followed by the

correctly configured viewBox attribute. These attributes should look

like this when you view the SVG file in a code or text editor (see

further below for instructions):
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<svg width="212.16249" height="211.27501"
viewBox="0 0 212.16249 211.27501" ...

Configuring the width, height and viewBox at-

tributes in your SVG images

If your graphic program can configure the width, height and

viewBox attributes in the <svg> tag in your images you just need

to enable those options there. Otherwise you need to edit the

.svg file in a text/code editor and add the attributes to the <svg>

tag yourself. (SVG files are actually text files containing vector

graphics code.)

Editing the <svg> tag manually

1. Open the .svg file in a text or code editor (NOT in a word pro-

cessor!). 

2. Locate the <svg ... tag, which begins in the first line of the

file. 

3. Add the viewBox attribute after the width and height attributes,

as follows:

<svg width="212.16249" height="211.27501"
viewBox="0 0 212.16249 211.27501" ...

4. The first two values in the viewBox attribute are two zeroes sep-

arated by a space. This is followed by the width and height val-

ues, which should be exactly the same as the values from the

width and height attributes, as shown in the example.

5. Save the SVG file. After this, it should behave responsively in

CHM and Internet Explorer.

Word DOCX: Only the latest version of Word 2016 in the Office 365 edition sup-

ports SVG graphics. To ensure maximum compatibility with the

very large number of users on other versions, SVG graphics are

converted to PNG files for export to Word DOCX.

When SVGs are converted to PNG the resulting PNG will have the

current display dimensions of the SVG or the original SVG dimen-

sions, whichever are larger.
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Adobe PDF: SVG graphics are exported to PDF if possible (if they are not too

complex). More complex SVGs will be exported to PNG with alpha

transparency, which is supported natively in PDF. 

When SVGs are converted to PNG the resulting PNG will have a 32-

bit color depth and will have the current display dimensions of the

SVG or the original SVG dimensions, whichever are larger.

eWriter Help: Same support as in WebHelp (eWriter is WebHelp in a single file

with an embedded viewer).

ePUB and Kindle

eBooks:

SVG graphics are supported natively in these formats. 

11.6.2.3 Embedded graphics

Normally when you insert graphics in Help+Manual you only insert references to external

graphics files. This is also the recommended way for handling graphics because it is much

more efficient and prevents your project file from getting too large.

There are two kinds of images that actually get embedded in your project files as encapsu-

lated binary data: Embedded OLE objects  and images pasted together with text from word

processing programs like Microsoft Word. 

Avoid using embedded images whenever you can.

For technical reasons embedded images use up many times their own size in memory and

also place quite a heavy load on system resources. If you use a lot of them they will also

significantly increase the size of your project files, which may slow down the functioning

of the Help+Manual editor on older computers with limited memory.

Embedded OLE objects:

See Embedded OLE objects  and Inserting OLE objects  for information on how to

use OLE objects in your projects without embedding them. Embedded OLE objects are

also embedded in your topic files, which bloats the files unnecessarily.

Pasting graphics from MS Word:

When you paste graphics together with text from MS Word you will be prompted to con-

vert them to external files. You should always do this to avoid bloating your topics with

1139
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embedded images. You can also convert embedded images later: by right-clicking on the

graphic and selecting Convert Embedded Image in the popup menu.

Identifying embedded images:

When you click on an embedded image it does not appear as a "negative" image.

Normally-inserted images appear as negatives with all their colors reversed when you click

on them. You can also locate embedded images in your project with the Report Tool :

Perform a full report with image references and then search for the word "embedded" in

the report. 

See also:
Using Graphics

11.6.2.4 About using video files

Video files used in Help+Manual and the output formats it generates are always handled by

the associated players and codecs, not by Help+Manual itself. These players and the neces-

sary codecs for the specific formats must be properly installed, both on your computer for

editing and on the user's computer or mobile device for viewing. Because of this a number of

restrictions apply that you should be aware of before using video files in your projects.

Basically, only MP4 and online video sharing sites are reliable

For reliable video, use only MP4 video or online video sharing sites for video in your

Help+Manual projects. All other video formats will cause problems. 

MP4 will be generally compatible provided you encode it with a standard profile using

H.264 for video and MP3 or AAC for the audio. Online video sharing sites like YouTube

handle all the compatibility problems for you and reduce the bandwidth load on your own

website, which can otherwise be considerable if many people view your videos.

Adobe Flash discontinued:

Adobe Flash has now been discontinued worldwide and on all platforms, among other

things because of its horrendous security performance. Existing Flash videos in projects

will still work on platforms that have Flash installed but you can no longer add new Flash

content. We strongly recommend that you remove all Flash content. 

Support for media files in output formats:

HTML Help

(CHM)

Use online video services in CHM. Help+Manual handles this so

that the online site is only accessed when the user actually clicks on

the preview image to start the video.

1212
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Local video formats will always cause problems in CHM files for at

least some of your users and should be avoided.

WebHelp (HTML): Supports all media formats supported by the user's browser, but

only MP4 and online video services can now be considered to be

really reliable. 

Flash has been discontinued worldwide on all platforms and Flash

content should now be removed from all projects.

eWriter Help: Same video support as in WebHelp.

ePUB eBooks: M4V video files encoded with an Apple profile for the iPad or

iPhone are supported in ePUB in Apple iBooks on Apple iOS

devices. They will not play on the great majority of other devices

and software readers. 

M4V videos must be created in the correct format for iOS devices

with Apple QuickTime or a third-party program like the free 

 Handbrake (highly recommended) that comes with correct profiles

for these devices. 

Dynamic HelpXplain presentations are supported in some ePUB

readers but you shouldn't depend on it. Only use HelpXplain

presentations in ePUB if you are certain that your users will have an

appropriate reader.

Kindle eBooks: No support for video.

Adobe PDF: No support for video files except external links.

MS Word DOCX: No support for video files except external links.

See Conditions and Customized Output  for details on creating alternative content for

different output formats.

Embedding video files:

Since the termination of Flash support, Microsoft CHM files no longer support embedding

for any video formats. MP4 video files can be embedded in eWriter Help. All other video

files must be distributed with your help as separate files.

When you publish your project a list of any files you need to distribute together with your

help is displayed in the compiler report if necessary, so always remember to check this!

969
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The video preview function in Help+Manual

Functionality in Help+Manual also depends on the players

How and whether the preview function works in Help+Manual also depends on the player

installation on your computer. If the necessary players or codecs are not available or not

installed properly the preview function will not work.

You may need administrator rights to run the preview function

On some systems you need to be working in a Windows account with full administrator

rights to use the movie preview function. If the function doesn't work and you know that

the correct player is installed try switching to a full administrator account. 

See also:
Videos and Animated Media

11.6.2.5 About using OLE objects

OLE support has some restrictions, because active OLE objects cannot be supported directly in

the published output formats generated by Help+Manual. OLE objects in the editor remain

clickable and editable so that you can edit them in their associated applications. However,

when you publish your project the objects are converted into static bitmap graphics. 

It is best to think of OLE objects as static graphics that remain editable until you publish your

output.

Linking is always preferable to embedding:

You can either embed OLE objects in your project or insert them as a link to an external

file. The Create New option in the Insert OLE Object  dialog always embeds the object in

your project. The Create from File option embeds the object if you deselect the Link op-

tion.

Embedding OLE objects in your projects has several disadvantages:

· It increases the size of your project files.

· Handling embedded objects generates considerable system overheads. This can slow

down Help+Manual, particularly on older computers and systems with less memory.

· Embedded objects can only be edited by opening Help+Manual and double-clicking on

the object in the editor. Linked objects can be edited normally as external files

It is thus always preferable to use links to external files instead of embedded OLE objects.
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Restrictions on OLE objects in Help+Manual

Because of the restrictions listed below it is advisable to only use OLE objects when there

is no alternative. For example, you can copy text with tables and complex formatting

directly from MS Word and Excel, so you no longer need to use OLE objects for this. You

can also use linked snippets  for reusing content once you have converted it to a

Help+Manual XML file.

You can only use OLE ob-

jects that can be displayed

as graphics.

You cannot use dynamic objects like videos and other

media files. The OLE selection dialog is a Windows ele-

ment that automatically displays all the OLE-capable ap-

plications installed on your system. This does not mean

that you can use all the object types listed!

Only the visible part of large

OLE objects is included in

the output.

For example, if you insert a Word document consisting

of several pages only the page (or part of the page) that

is visible in the Help+Manual editor will be included in

your published output. This is a restriction imposed by

conversion of the objects into static graphic images.

Print quality and the quality

of OLE objects in PDFs may

be slightly inferior.

This is caused by the conversion to static graphics de-

signed for on-screen viewing and cannot be prevented.

See also:
Using OLE Objects

Insert OLE Object

11.6.3 Scripts and HTML

In addition to creating word-processor style content, experienced help authors often want or

need to "get under the hood" of their help output and add their own code in the form of

JavaScript, HTML code or Winhelp macros. Help+Manual has extensive facilities that allow

you to do this: 

· You can create links in your text that execute Winhelp macros or JavaScript code  in

the appropriate output formats. These links can be inserted both in the text  of your

topics and in hotspots  in your graphics.

· You can enter inline HTML code  in your topics that will be inserted in your output

exactly as you wrote it, without any changes. (HTML-based output formats only, of

course.) This code can include anything supported by HTML, including scripts.

· You can manually edit the HTML templates  that are used to generate the topic

pages in HTML-based output formats.
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You need to be familiar with HTML, scripting and Winhelp macros to use these features. It is

assumed that you know what you are doing and the code you enter is entirely your responsib-

ility. It is not corrected, parsed or syntax-checked by Help+Manual. The only exceptions are

some graphic file references in your HTML topic page templates, which are parsed and expor-

ted  with your output.

The topics in this section provide some extra background information that will help you to use

these features more effectively. 

11.6.3.1 About JavaScript links

You can enter links that execute JavaScript code both in the text  of your topics and in hot-

spots  in your graphics. Since JavaScript is an HTML-based technology requiring a browser

this feature is only supported in HTML-based output formats (HTML Help, WebHelp and

Visual Studio Help). Note that although Windows Exe and ePUB eBooks are also HTML-based,

JavaScript is not supported in eBooks: The embedded viewer in Exe eBooks does not support

JavaScript. Even though scripting is officially included in the ePUB specification, neither Apple

iBooks® nor the majority of other readers for ePUB eBooks support it, so it is effectively irrel-

evant in ePUB.  

You can also include JavaScript and other script code in plain HTML code inserted in your top-

ics using the Insert > HTML Code  feature. This option is normally preferable to script links

for more complex code. See About inline HTML code  for some more information on this.

JavaScript restrictions in users' browsers:

In HTML Help you can generally assume that MSIE-compatible JavaScript will work be-

cause the HTML Help viewer is actually Microsoft Internet Explorer with a different user in-

terface. However, when you use JavaScript in WebHelp remember that some users may

have JavaScript turned off, so your help should also be comprehensible and functional

without the additional JavaScript functions. 

JavaScript links that refer to script functions:

You can also refer to JavaScript functions stored in your own external JavaScript code (i.e.

code that you have written) in JavaScript links. There are several different ways to make

these functions available to the JavaScript links:

· Add your separate .js script file to the Baggage Files  to include it in your output.

Then edit the HTML page template  for your topics and add an include for the .js

script file in the appropriate location in the template file.

· Use HTML variables  – you can then insert your script in the correct position in your

template with the variable and redefine it on a per-topic basis in the Topic Options tab

on the left of the main editor window, allowing you to use different versions of your

code in every topic if you want.
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· Edit the HTML template for your topics and manually add the script with the functions

to the <head> section of the template. Note that this will include the script code in

every topic page, even those pages where the functions are not needed. (See About in-

line HTML code  for details on how to avoid this problem.)

· Insert the script code containing the functions at the beginning of the topic containing

the link with the Insert > HTML Code  function. If you use this method the code will

only be available in the topic where you insert it. Note also that this will insert the code

between the <BODY> tags of the topic page – this will work in most cases but since ref-

erenced scripts should generally be in the <HEAD> section you may want to use one of

the other methods.

How Help+Manual handles JavaScript code in links:

To use this feature effectively it is important to understand how Help+Manual handles the

JavaScript code you enter in your links. When you select the JavaScript option in the Insert

Hyperlink  dialog the script you enter in the dialog box is only part of the final code

generated in your output:
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This dialog is effectively identical for script links

in your text and script links in hotspots in graphics.

In the HTML output the code is put together as follows:

<a href="  +  your code  +  ">  +  link caption  +  </a>

For example, if you enter javascript:alert('Hello World!'); in the Script: entry

box and Hello World! in the Caption: field Help+Manual will generate the following

link:

<a href="javascript:alert('Hello World!');">Hello World!</a>

That is just a simple example. Here is a more complex piece of JavaScript as entered in the

Script: entry box (this example opens a popup window):

javascript:window.open('https://www.helpandmanual.com/helphtml/in-
dex.html?whatsnew.htm','PopupWindow','toolbar=0,location=0,direct-
ories=0,status=0,menubar=0,resizable=yes,scroll-
bars=1,width=600,height=600,left=0,top=0');

The output generated from this script would look like this:
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<a href="javascript:window.open('https://www.helpand-
manual.com/helphtml/index.html?whatsnew.htm','PopupWindow','tool-
bar=0,location=0,directories=0,status=0,menubar=0,resiz-
able=yes,scrollbars=1,width=600,height=600,left=0,top=0');">Your
Link Caption</a>

Entering complex JavaScript Code:

Effectively, Help+Manual enters your JavaScript code between the " and " characters for

the href= attribute of the <a> tag. However, this is not nearly as restrictive as it sounds at

first. When you understand how Help+Manual actually generates the output code you can

also enter quite complex scripts. You just have to remember the syntax and work within it:

<a href="  +  your code  +  ">  +  link caption  +  </a>

For example, you can also create a complex link tags like this, using multiple quotes within

the tag:

<a href="javascript:void(0);" 
onmouseover="return overlib('Popup text.', STICKY, MOUSEOFF);" 
onmouseout="return nd();">Display Overlib Popup</a>

All you need to do to achieve this is copy the entire link shown above into the Script: field,

leaving out the <a href=" at the beginning and the ">Display Overlib Popup</a>

at the end. For the above example you would first enter Display Overlib Popup in

the Caption: field and the following code in the Script: field: 

javascript:void(0);" 
onmouseover="return overlib('Popup text.', STICKY, MOUSEOFF);" 
onmouseout="return nd();

JavaScript stumbling blocks:

Remember that JavaScript is very picky about syntax and case! For example, if you enter

javascript:Alert("Hello World!") instead of javascript:alert("Hello

World!") you will just get an error message. 

You must also remember to be very careful about nesting single and double quotes.

Help+Manual generates script links with double quotes on the outside so any quotes nes-

ted within those quotes must be single quotes.

See also:
Inserting script and macro links

Inserting plain HTML code

About inline HTML code

Using HTML Templates
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11.6.3.2 About Winhelp macro links

Although the obsolete Winhelp format is no longer supported, the Winhelp macro option in

the Insert > Hyperlink  function has been kept because it makes it possible to use four Win-

help macros as "shorthand" methods for implementing features in HTML Help CHM files that

would be much more complicated if you programmed them manually. Help+Manual auto-

matically converts these four macros into the necessary CHM ActiveX code. 

No other Winhelp macros can be used. You can only use these four, and only for HTML Help

CHM output.

Winhelp macros translated in HTML Help:

The following four Winhelp macros are supported for HTML Help because their syntax is

much easier to use than the equivalent source code for HTML Help. When you use these

macros, Help+Manual translates them into the necessary ActiveX commands and scripting

in HTML Help.

You can only use these four macros, and only for HTML Help CHM output:

ALink()  KLink()

TCard() Close()

This is particularly useful when you are using A-Keywords to build automated See Also..

lists and links between help files in modular help systems.

For details see Inserting script and macro links  and Using A-keywords . 

Note that only keywords are supported as arguments in the ALink and KLink macros when

they are used in HTML Help. All other arguments are ignored.

You don't need the ExecFile() macro

If you have upgraded from Help+Manual 3 you may be wondering what has happened to

the ExecFile() Winhelp macro, which used to be translated in HTML Help. This is no

longer necessary because you can now use file links  instead, which produce the same

result much more efficiently.

See also:
Inserting file links

Inserting script and macro links

Using A-keywords
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11.6.3.3 About inline HTML code

The Insert HTML Code Object  tool in Write > Insert Object allows you to include plain

HTML code at any point in your topics and export it unchanged to all HTML-based output

formats (HTML Help, Browser-based HTML, Windows Exe and ePUB eBooks and Visual Studio

Help). 

This topic assumes that you are already familiar with writing code in HTML and JavaScript.

Plain HTML code in eBooks:

Note that although regular HTML is exported to eBooks, only plain formatting code and

basic CSS will actually work in this format. You cannot use scripts or DHTML. Technically,

the ePUB specifications do include scripting but almost all ePUB readers ignore it, and

those that don't are unlikely to do what you want.

Apple iBooks®:

Be extremely careful when entering inline HTML code for Apple iBooks. It is more quirky

than any other ePUB reader and the results can be unexpected. 

When to use plain HTML code:

There are basically two situations where you may want to use plain HTML code:

· When you want to add features to your HTML-based output with dynamic HTML and

scripting.

· When you want to write your own HTML code to achieve formatting results that you

can't create directly with Help+Manual.

HTML code objects are preferable to using JavaScript links  for inserting more complex

JavaScript code in your pages. Since the code is inserted in the page you can also include

links, and you have more freedom to format your code because you are not restricted by

the link insertion syntax.

How plain HTML code is inserted:

Plain HTML code objects are inserted directly at the current insertion point in your topic

text. The code is inserted exactly as you write it without any changes, and it is not parsed

or syntax-checked in any way. The only exceptions are some graphic file references in your

HTML topic templates, which are parsed and exported  with your output.

This means that you are 100% responsible for making sure that you write valid

code!

Since the entire topic contents are always inserted between the <body> and </body>

tags of the HTML topic page template  the plain HTML code you enter is also always in-
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serted after the opening <body> tag, even if you enter it right at the top of the topic

page. It is important to remember this if you are inserting scripts that need to be in the

<head> section. 

Adding HTML code to HTML topic page templates:

You cannot use the Insert HTML Code Object tool to add code outside the <body> and

</body> tags of  your topic pages. If you need to do this you must add the code to the

HTML template  that is used  to generate all the topic code outside the <body> and

</body> tags.

You can do this either directly or with HTML variables. In addition to this you can also edit

the content of your variables on a by-topic basis by redefining variables for individual top-

ics in the Topic Options tab on the left of the main editor window. See The power of edit-

able variables  for more details on this.

Adding template code to selected topics only

 If you need different versions of the code in individual topics you can use HTML variables

 to achieve this. Basically you define an HTML variable to hold the code and insert it in the

appropriate location in your HTML page template. Then you redefine the content of the

variable for individual topics in the Topic Options tab on the left of the main editor win-

dow (in the Topic Variables table at the bottom of the screen). 

You can also use these redefinable variables to link to different versions of external script

files in individual topics. See The power of editable variables  for more details on this.

Referencing script functions in plain HTML code:

If the code you insert in your topics with the HTML Code Object tool contains calls to

JavaScript functions you have written you may want or need to include these functions in

external .js files or in the <HEAD> section of your topic pages. There are two ways to do

this:

· Add your separate .js script file to the Baggage Files  to include it in your output.

Then edit the HTML template  for your topics and add an include directive for the

.js script file in the appropriate location in the template file.

· Edit the HTML template for your topics and manually add the script with the functions

to the <head> section of the template.  

See also:
Inserting script and macro links

About JavaScript Links

Inserting plain HTML code

The power of editable variables
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Using HTML Templates

11.7 Modules, Conditional Output & Variables

This section provides background information on the features of Help+Manual that allow you

to create variants of your projects. 

Modular projects make it possible to combine multiple projects in a single master project, in

which you can edit and publish them as though they were a single project. 

Conditional output is used to generate different versions of your project for different output

formats or different purposes. 

Variables are used to quickly insert standard texts and they can be redefined quickly for pro-

ject variants.

11.7.1 Modular Projects

A modular help system is a help system that consists of multiple help projects that can be ed-

ited separately but published as though they were a single project. There are also two levels

of "modularity": Modular help projects (your project consists of multiple Help+Manual mod-

ules) and modular help systems (your output help files also consist of modules).

Modular help projects:

A modular project consists of multiple projects, referred to as "modules", that you edit

separately but publish together with the help of a main project referred to as a "master

project" or "master module".

You can output a modular project as a single help file, then you are only using authoring

modularity, or as multiple help files, then you are also using output modularity.

Authoring modularity gives you practical advantages for managing your projects, output

modularity gives you additional flexibility for the configuration of different versions of

your help.

Modular help systems:

A modular help system is one that is made of separate modules at "runtime", i.e. when the

user is viewing it. Runtime modular help systems are only supported in the Microsoft

HTML Help (CHM) format.

A modular CHM help system consist of a "master" CHM module containing the main TOC,

which must always be present, and one or more "child" CHM modules, any of which may

or may not be present.

1026
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If a child CHM module is present at runtime its TOC is merged into the TOC of the master

CHM module when the help is viewed. For the user everything looks like a single help file.

If the child module is not present its TOC is not included. This process is automatic and

depends only on the presence of the child CHM module in the same folder as the master

CHM module.

With a little planning you can easily distribute different versions of your CHM-based help

for different product versions just by including or excluding individual modules in your

distribution package.

See Runtime and publish time merging  for more details on truly modular projects.

Multiple TOCs

You can combine alternative TOCs  with modular projects. For example, you could cre-

ate a TOC that contains references to a completely different set modules in a different or-

der and combined with different topics and chapters. 

Linked snippets are not modules

In addition to modular help systems Help+Manual also allows you to include individual

topic files and chapters from other projects in your current project as linked snippets.

This blurs the distinction between modular and non-modular projects slightly. 

It is important to understand that true modular help systems are only possible when en-

tire projects are used as modules. When you insert a topic or chapter from another project

it becomes part of the current module when you publish. Such topics and chapters cannot

be handled as separate modules in published modular help systems, even in HTML Help. 

Why use modular help systems?

There are a number of very good reasons for using modular help systems:

Create different versions without editing:

In HTML Help you can create genuinely modular help systems (see above) in which you

can include and exclude entire sections of the help simply by including and excluding help

files from your distribution package. You must always include the master file but if a child

file is not found its contents are simply excluded from the TOC automatically. This is ideal

for applications with different versions.
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Reusing content efficiently:

You can create "boilerplate" projects for reusable project sections, for example introduc-

tions that are always very similar or your product lists or terms and conditions. (Note that

in many cases snippets  are also an efficient way of doing this.)

More efficient group work:

When you are working on a project in a team you can assign separate modules to each

team member. Each author can then work on his or her own modules separately if they do

not have access to the central version on the server.

Managing very large projects:

Modularizing your help projects makes large projects easier to manage. Among other

things, publishing the smaller child modules on their own is faster and you can check your

output more quickly.

Master projects and child projects

A modular project consists of one master project and one or more child projects (which

can in turn be master projects containing their own child projects). 

Both master projects and child projects are ordinary Help+Manual projects. The only thing

that makes them "modular" is the way they are structured: References to the child projects

are inserted in the TOC of the master project as single items, in exactly the same way that

you insert topics. 

It is important to understand that inserting a child project in a master project does not

merge the projects physically. They still remain separate projects. They are just managed

together.

Editing modules inserted in publish-time merging mode:

· In the Master TOC:

Publish-time merging modules are displayed as part of the master TOC and can be ed-

ited directly in the TOC, in the same way as the master project's own topics. (To enable

in-place editing you may need to activate this in Configuration > Common Properties

> Miscellaneous and then reload your project.)

· In the Merged Projects section:

If you open the Configuration section in the Project Explorer you will find a section

called "Merged Projects" right down at the bottom. This gives you direct editing access
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to the entire contents of the module, including its Configuration settings, project files

and so on.

Editing modules inserted in runtime merging mode:

Modules inserted for runtime merging are just placeholders, however. To edit them you

need to right-click on the placeholder in the master TOC and select Open Child Project...

The project will then be opened as a normal additional project in the Project Explorer. 

Publishing modular projects

When you publish the master project it behaves as though it is a single project. The entire

TOC of each child project and all the topics it contains is merged into the output. This

works in all output formats supported by Help+Manual, but there are differences in how

it is handled and the options you have depending on the format you choose:

HTML Help: You can choose whether you want to merge the projects com-

pletely and create a single output file, or create individual projects

whose TOCs are all displayed and accessed through the TOC of the

master help file. See Runtime merging and publish time merging

.

Important: 

The project filenames and the output filenames of the CHM files

must be identical. The references between the child and the master

help files are based on the filenames (before the extension) and if

project and output filename don't match the references will be in-

valid. 

WebHelp: In WebHelp the output of a modular project is always merged com-

pletely. The files of all the modules are output to a single directory

and accessed with a single index.html file that integrates the

master and all child TOCs in a single master TOC.

eWriter, Kindle

and ePUB eBooks:

The entire modular project is always published to a single eBook.

The TOCs of the master module and all child modules are integ-

rated in the single TOC of the eBook.

PDF and DOCX: Modular projects are always merged to a single document when

you output to PDF or DOCX or print a user manual with the Print

Manual function in the File menu.

See also:
Working with Modular Help Systems
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11.7.1.1 CHM: Runtime and publish time merging

In HTML Help (CHM) you can create genuine modular help systems with separate help files

that are displayed in a single TOC at runtime (when the user views them). Alternatively, you

can also combine all your modules to one large help file. 

See Choosing the merge method  for instructions on how to set the different merge meth-

ods for HTML Help.

Publish time merging – one integrated help file

Publish time merging generates one single help file from all your module projects. From

the point of view of your output this is no different from working with one single project

without modules. With this method the project is only modular while you are working on

it, your output is exactly the same as that produced from a single help file without mod-

ules. 

One of the more practical advantages of publish time merging is that all the modules, in-

cluding all the child modules, are published in a single quick process when you publish the

master project. You don't have to open and publish every module separately as you do for

projects configured for runtime merging.

In publish time merging Help+Manual combines all the modules and

creates one big help file when you publish the master module. If you

want to exclude a module you must republish without the module.

1096
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Runtime merging – separate help files

When you generate separate help files for each module in your project this is called

runtime merging: When the user "runs" the help the separate help files are "merged" and

displayed in a single help viewer with a single Table of Contents (TOC) containing all the

topics of all the available modules.

Runtime merging produces genuinely modular help systems in HTML Help. The master

module containing the main TOC must always be present, but you can include or exclude

the other modules from the help simply by including and excluding the help files of the

child modules from the directory in which the help is stored. If a module's help file is not

present its topics are simply not included in the TOC. 

The great advantage of this is the enormous flexibility it gives you. With a little planning

you can reduce the work involved in distributing different versions of your help for differ-

ent versions of your product to almost zero. All you need to do is include or exclude help

files from your distribution package.

Important: The project filenames and the output filenames of your CHM files must be

identical. The references between the child and the master help files are

based on the filenames and if project and output filename don't match the

references will be invalid. 

With runtime merging you create separate help files for the master and child

modules (each module must be compiled separately). Help files that are not

present on the user's computer are automatically excluded from the TOC.
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Mixing runtime and publish time merging

You specify whether child projects are to be merged at publish time or runtime when you

insert the project in the master project. Since this is specified separately for each project it

is possible to mix runtime and publish time merging. However, you need to be careful

when you do this as it is quite easy to lose track of what you are doing in complex pro-

jects with a lot of modules. 

Global help window names for runtime merging

When using runtime merging it is advisable to define a global "window name" for all the

projects in the modular help system. This improves the performance of links to your help

from your applications. When you define a global help window, all calls to the help system

will open in the same CHM help viewer. Without a global window, you will get additional

help viewers opening when calls are made first to one module and then to another.

The global help window option is set in Configuration > Publishing Options > Microsoft

HTML Help > Help Windows . You need to set the same global window name in all

projects in the modular help system, including the master project. 

Exporting runtime modules to other formats

When you insert a module in runtime mode it will only be published to HTML Help (CHM).

 If you want to publish the same module to other formats you must insert it in your TOC a

second time in publish-time mode. When you do this you should also set the include op-

tions for each version so that the correct version gets published automatically depending

on the output format you choose:
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Setting the include options:

Just right-click on the main module "node" (spiky green icon) in the TOC, select Include in

Builds in the context menu and then set the include options appropriately. Make sure that

you set the options so that it is not possible to export both versions together!

You can also access the include options in Manage Topics > Change in the Project tab. See

Conditions and Customized Output  for more details on using include options.

Advantages and Disadvantages of the Two Merging Methods

The following table summarizes the pros and cons of the two merging methods. Remem-

ber that runtime merging is only possible in HTML Help (CHM).

969
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Runtime Merging Publish Time Merging

Advantages Disadvantages Advantages Disadvantages

Truly modular,
dynamic help
systems. Different
versions can be
created simply by
including and
excluding help files
in your distribution
without re-
publishing.

All the component
modules must be
published
separately .

Single help file,
exactly like those
produced from
single
Help+Manual
projects. All the
component
modules are
published
automatically in a
single quick
process.

You must
republish  to
produce different
versions of the
help for different
product versions.

Duplicate topic IDs
and context
numbers in
modules are not a
problem because
the output files are
truly separate.

When creating
links to the help
from your
application you
must always be
careful to link to
the correct help
file .

Links to the help
from your
application are
always to the same
help file.

You must be
careful to avoid
duplicate topic
IDs  and context
numbers in
different modules
because the
modules are
merged to a single
help file.

Invisible topics of
all modules are
included
automatically
because the child
modules are
published
separately.

Multiple files that
must be
distributed instead
of a single help
file. 

A little easier to
manage because
you can handle all
the projects as if
they were a single
project.

See also:
Working with Modular Help Systems

Planning modular projects

11.7.1.2 Planning modular projects

If you want to get the full benefits from modular projects you need to do some planning.

Module divisions should be logical rather than arbitrary. You must break your project up into

modules in a way that increases your flexibility, and you need to plan ahead to make sure that

you take any possible future changes into account. You also need to think very carefully about

links between modules and make sure that any links you create will not create problems for

you later.
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Planning for future modular help systems

Even if you are not using modular projects now it is a good idea to plan ahead just in case

you decide to modularize your projects in the future. In particular, you should always use

topic ID naming schemes that will enable you to combine projects at a later date without

creating ID conflicts. Then you always have the freedom to switch to runtime merging if

you want, and your projects will also have a better and more logical structure that is easier

to manage in the long run. See Managing IDs and context numbers  for instructions on

how to avoid duplicates.

Be clear about which module is your master module:

Even though every Help+Manual project can contain as many modules as you like, you

should always manage each modular help system with one master project. Otherwise you

will go crazy trying to keep track of everything and mistakes are almost guaranteed

sooner or later. You can reuse modules in different modular help systems, but then they

should be completely separate systems with their own master modules.

Don't nest your modules too deeply

Sub-modules can also contain their own sub-modules and there are no physical limits on

how far you can nest sub-modules. However, it is best to make cautious use of this capab-

ility because it is easy to lose track of what you are doing. This applies in particular when

you are mixing runtime and publish time merging.

It's a good idea to store your child module projects in a clearly-organized directory system

without many levels of sub-directories. Even if your project itself has many levels, you will

find your project files much easier to access if you store them all on the same level in

folders with descriptive names, possibly including level numbers.

Don't create modules unless you really need to

Don't create modules just for the sake of making modules. A single project is always

easier to manage, it can be edited by multiple users at the same time (Professional and

Floating license versions only) and Help+Manual can manage large projects with ease. 

Master modules with and without content

The master module can have content of its own or you can use it as an empty framework

for the sub-modules. If the master has content then the common components of your

documentation that are always included should be in the master module. 
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If you put as much as possible in separate modules the master module only needs to be

edited by the person responsible for doing the final publish, and this can be an advant-

age.

Exception: Runtime-merged CHM modules

In modular HTML Help (CHM) projects in which the child projects are merged in runtime

mode , the master project must contain at least one topic and the default topic must be

set in the master project. If you don't do this you will get an error opening the main CHM

and the indexes of the child CHMs won't be available. (This is caused by uncorrected bugs

in the Microsoft HTML Help system.)

Minimize links between modules:

Each module should be as independent and complete in itself as possible. It should con-

tain all the information needed to describe the module of your application that it is built

for. 

If you are using runtime merging it is particularly important to make sure that the context-

sensitive help topics  needed by your application are going to be there when the user

needs them. It may be necessary to move topics to one of the main modules that is al-

ways present. If you don't want to include the topic in the TOC you don't have to, you can

create a topic without a TOC entry and link to that.

It is generally advisable to avoid context links across module boundaries, even if you are

currently using publish time merging. This will save you a lot of unnecessary work if you

ever decide you want to switch to runtime merging.

Links to the master module are never a problem because that is always present, but links

between modules and from the master to the child modules should be kept to an abso-

lute minimum. If you must create inter-module links you should make absolutely sure that

the target module will always be present when the user runs the help. Alternatively, use A-

links  to make sure that links to non-existent modules will display a suitable alternative

topic.

Always call popup topics directly

Calls to CHM popup topics are not routed from the master module to the child modules.

If you call popup topics in HTML Help CHM files from your application you must always

make the popup calls directly to the help file containing the popup topic, not to the mas-

ter file. (This only applies for runtime merging, of course – in publish time merging there is

always only one help file you can make calls to.)
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Take steps to avoid duplicate topic IDs and context numbers:

In publish time merging duplicate topic IDs and help context numbers  in modules will

cause link failures and other errors in your help files. Help+Manual can only prevent du-

plicates within a single project so you have to take steps to prevent duplicates in your

modules yourself. For details see Managing IDs and context numbers  in Working with

Modular Help Systems .

Always place all your output files in the same directory

This is essential for runtime-merged CHM projects. The Microsoft HTML Help viewer in

particular has some annoying bugs that make it almost impossible to call files from the

help that are not in the same directory as the help file. Even if links to other directories

seem to work on your test computer they will fail on very many users' computers, so

don't use them.

Don't worry about the whys and wherefores, just always put all your help files and any ex-

ternal files you need to call in the same directory. That is the only way to avoid problems

and have a help system that always works.

See also:
Working with Modular Help Systems

11.7.2 Variables and Conditional Output

This section contains background information on the various kinds of variables and condi-

tional switches available in Help+Manual and reference lists of all the variables and switches. 

See also:
Using Variables

11.7.2.1 Where you can use variables

The following table provides a quick reference showing where you can use which kinds of

variables in your projects:

Location: Supported variables:

Topic text and headers

Plain-text variables:

Global predefined variables and user-defined variables in-

serted with the  Text Variable tool in Write > Insert

Object: 
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<%VARIABLE_NAME%>

Note that variables typed in manually are not highlighted

in the editor and double-clicking on them will not open

the variable selection list.

HTML variables:

HTML variables inserted in these locations will only insert

the text portion of the HTML code. For example, if the

variable contains:

<a href="https://www.helpandmanual.com>EC

Software Website</a> 

only "EC Software Website" will be inserted. All the HTML

code (blue) will be stripped out.  If there is no plain-text

portion nothing will be inserted.

TOC, keywords, image cap-

tions, link captions, macros in

macro links

Plain-text variables:

Global predefined variables and user-defined variables in-

serted manually by typing the variable names using the

syntax <%VARIABLE_NAME%>.

HTML variables:

In these locations only the plain-text portion of HTML

variable values will be inserted (see example above).  If

there is no plain-text portion nothing will be inserted.

HTML code objects and scripts

in script links Plain-text variables:

Global predefined variables and user-defined variables

can be used in code objects and script link scripts directly.

The variables must inserted manually by typing the vari-

able names using the standard syntax <%VARIABLE_NAME

%>.

HTML variables:

HTML variables will generally work as expected in these
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locations, inserting the full HTML code stored in the vari-

able. You can also use most of the exclusive HTML tem-

plate variables  here, with a couple of logical excep-

tions:

HTML template variable exceptions: 

The following HTML template variables can't be used in

code objects because they can only be evaluated when

they are used directly in the HTML template:

DOCTYPE, GAACCOUNT

HTML templates

Plain-text variables:

Global predefined variables, user-defined variables and

special HTML template variables inserted manually by

typing the variable names.

HTML variables:

You can use HTML variables without restriction in HTML

templates. The HTML code stored in the variable will be

inserted in the in the template. You can also use HTML

template variables  as part of the value of the HTML

variable. 

PDF templates edited with

Manual Designer Plain-text variables:

Global predefined variables, user-defined variables and

special PDF template variables inserted manually by typ-

ing the variable names.

HTML variables:

HTML variables will only insert the plain-text portion of

the variable value in PDF templates. If there is no plain-

text portion nothing will be inserted.

See also:
Using Variables
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11.7.2.2 Global predefined variables

With the exception of Automating Publishing Jobs, these variables can be used every-

where in your project where variables are supported, including topics, headers, links, the TOC,

scripts, macros and all HTML templates. See Using Variables  for details, and Date and Time

Variables  for information on date and time formatting options.

All the date and time variables use the corresponding date and time formats set in the Win-

dows configuration on the computer on which you are running Help+Manual.

Variable Content and/or function of the variable

<%AUTHOR%> The name of the author of the help defined in Pro-
ject Explorer > Configuration > Common

Properties > Title & Copyright. 

<%COPYRIGHT%> The copyright statement defined in Project Ex-
plorer > Configuration > Common Proper-

ties > Title & Copyright. 

<%DATE%> The current date in short format, without the time. The

format matches the language set for your project. Sup-

ports manual formatting options  that allow you to

configure how the date is displayed.

Returns the month in genitive form in applicable lan-

guages.

<%DATELONG%> The current date in long format. The language and

format are generated automatically to match the lan-

guage set for your project. This automatically includes

long month names, in the genitive form in applicable

languages. No manual formatting options.

<%HMFIGURECOUNTER%>
<%HMTABLECOUNTER%>

Counter variables  for figures and variables. Unlike

user-defined counter variables, these variables can be

referenced to create references like "See Fig. X". 

Important: Counter variables cannot be used in the

table of contents.

<%MONTHNAME%> The current month in long format (i.e. February, not

Feb or 2). The format matches the language set for

your project. 
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Variable Content and/or function of the variable

<%NOW%> The current date and time. The language and format

are generated automatically to match the language set

for your project. Supports manual formatting op-

tions  that allow you to configure how the date and

time are displayed.

Returns the month in nominative form in applicable

languages.

<%OUTPUTFILEDIR%> The absolute Windows-style output path of the current

build, without a trailing backslash.

<%OUTPUTFILENAME%> Name of the output file for the current build, without

path or other information. For example, if you are pub-

lishing to CHM it will be the name of the CHM file, if

you are publishing to HTML it will be the name of the

main HTML file (normally index.html unless you

change it), and so on. 

<%OUTPUTFILEPATH%> The absolute Windows-style output path of the current

build, including a trailing backslash. 

<%SELF%> The name of the current project file without path or ex-

tension. 

<%SELFFULLNAME%> The name of the current project file including the file

extension and the full path to the project directory, as

displayed in the Help+Manual title bar. This can be

useful for documenting which project version you have

used to generate your documentation.

<%SUMMARY%> The Summary text for the project defined in Project
Explorer > Configuration > Common Prop-

erties > Title & Copyright. 

<%TARGETTITLE%> This is a special variable that can only be used in the

captions of topic hyperlinks. When used there it will

automatically insert the current title of the target topic

of the link as the caption when you publish your pro-

ject. See Inserting topic links  for details. 
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Variable Content and/or function of the variable

<%TIME%> The current time in short format. The format matches

the language set for your project. No manual format-

ting options.

<%TIMELONG%> The current time in long format. The format matches

the language set for your project. No manual format-

ting options.

<%TITLE%> The title of the help project defined in Project Ex-
plorer > Configuration > Common Proper-

ties > Title & Copyright. 

<%TOPICHELPCONTEXT%> Help context number(s) assigned to the current topic

<%TOPICLASTEDITED%> The date when the topic containing the variable was

last edited in short format.  Supports manual format-

ting options  that allow you to configure how the

date and time are displayed.

Returns the month in nominative form in applicable

languages.

<%TOPICLASTEDITEDTIME%> The time when the topic containing the variable was

last edited. The format matches the language set for

your project.

<%TOPICLASTEDITEDUSER%> Name of the user who last edited the current topic. 

<%TOPICMETA:NAME%> Special variable for use in topics only. Inserts the values

of meta tags added to the XML source of topic files.

Currently only relevant for Sandcastle import, where

Help+Manual inserts a meta tag with hash value to

check whether existing sandcastle topics have been

changed or not. (Have a look at the XML source of im-

ported Sandcastle topics to see this.) However, it will

also work on your own meta tags if you add them to

the XML yourself.

Usage: Replace "NAME" with the name of the XML

meta tag you want to reference. 

<%TOPICSTATUS%> Status  of the current topic. 
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Variable Content and/or function of the variable

<%TOPICTITLE%> Title text of the current topic. This is taken from the

Title Tag: field in the Topic Options tab (on the left

of the editor window) and is normally the same as the

TOC caption for the topic and will change automatic-

ally when you edit the TOC caption in the TOC. So this

variable gives you the TOC caption, unless you edit the

Title Tag field 

Editing the Title Tag text in Topic Options:

Editing the Title Tag: field manually "uncouples"

this field from the TOC caption. The variable then still

returns the contents of the field in Topic Options, so if

you want to use it for the TOC caption we recommend

not editing the field in Topic Options.

To "recouple" the Topic Options field with the TOC

caption, just edit either so that the texts are both

identical. This works the same as the coupling between

the TOC caption and the topic header text.

Deprecated older version:

The older <\%TOPIC_TITLE%> version of this variable is

still supported and does not need to be changed in

your projects. However, please always use the current

<%TOPICTITLE%> version now.

<%VERSION%> An automatically-generated combination of the Major,

Minor and Build version variables, with dots between

the versions. For example, if Major=3, Minor=25 and

Build=329 then <%VERSION%> will be 3.25.329.

<%VERSION_BUILD%> The Build Version text for the project defined in Pro-
ject Explorer > Configuration > Common

Properties > Title & Copyright. 

<%VERSION_MAJOR%> The Major Version text for the project defined in Pro-
ject Explorer > Configuration > Common

Properties > Title & Copyright. 

<%VERSION_MINOR%> The Minor Version text for the project defined in Pro-
ject Explorer > Configuration > Common

Properties > Title & Copyright. 
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Variable Content and/or function of the variable

<%YEAR%> The current year in 4-digit format. No manual format-

ting options.

See also:
Date and Time Variables

Using Variables

Using HTML Templates

11.7.2.3 Variables in Style Repositories

If you define variables in a style repository  they will also appear and be available in the

projects to which the repository is linked. When you link the repository, all the variables in the

repository that do not exist in the project are copied to the project. Variables that already ex-

ist in the projects are left unchanged; their values do not update with different values from

the repository.

At present, this is really just a convenience for sharing variables to multiple projects. The val-

ues of the variables are not dynamically linked, even if the styles are. The values of the vari-

ables in your projects will NOT update when their values are changed in the repository. This is

the same as existing variables in the project, which are not updated with the values of reposit-

ory variables when you link a repository.

Updating variable values from a repository

The only way to force the values of a variable in a project to update with a changed value

in the repository is to delete the variable in the project. Then the variable will appear again

with the new value from the linked repository the next time the project is loaded. 

So to update your repository variables you need to delete them in your project and reload

the project. You can select and delete multiple variables with CTRL+Click (individual vari-

ables) and SHIFT+Click (blocks of variables).

This is admittedly not all that practical, because you need to do this for all the variables in

all your projects every time you change the values of the variables in the repository. In a

future major release of Help+Manual we plan to make repository variables dynamically

linked as well. 

11.7.2.4 Date and time variables

Key Information
You can only format the date and time with these four

variables that support formatting strings.. 
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Help+Manual supports a number of variables for inserting the date and/or time. Some of

these support special formatting strings with which you have full control over how the date

and time elements are displayed.

Language of the date and time entries

The date and time entries created by these variables will use the language setting of your

Help+Manual project. 

Languages with nominative or genitive date forms

Variables that include time can only write the month names in the nominative form for

these languages, because that is all that Windows allows in combination with the time. If

you need the genitive form use <%DATELONG%> or <%DATE%>, which both write the genit-

ive form, and combine them with a separate time variable. The variables <%NOW%> and <%

TOPICLASTEDITED%> both write the nominative form, because they also include the

time.

All date and time variables

The variables shown in red also support formatting strings (see further below for details).

<%NOW%>: Inserts the current date and time. Returns the

month in nominative form in applicable languages.

Supports a formatting string (see further below for

details).

<%DATE%>: The current date in short format, without the time.

Returns the month in genitive form in applicable

languages. Supports a formatting string (see further

below for details).

<%\DATELONG%>: The current date in long format, without the time.

This also includes long month names, in the genit-

ive form in applicable languages.

<%TIME%>: The current time in short format. 

<%TIMELONG%>: The current time in long format. 
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<%MONTHNAME%>: The current month in long format (i.e. February, not

Feb or 2). 

<%YEAR%>: The current year in 4-digit format. 

<%TOPICLASTEDITED%>: The date and time when the topic containing the

variable was last edited in short format. Supports a

formatting string (see further below for details).

Uses the nominative form for applicable languages.

<%TOPICLASTEDITEDTIME%>: The time when the topic containing the variable

was last edited. 

How to use formatting strings in the supported variables

To use this feature you insert the <%NOW%> , <%DATE%> or <%TOPICLASTEDITED%> vari-

able in your project, either manually or with the Insert Variable tool, and then manually

type a format string in parentheses inside the variable name in the Help+Manual editor: 

<%NOW(format string)%> 
<%DATE(format string)%>

<%TOPICLASTEDITED(format string)%> 

Position and syntax of the format string:

The format string must be inserted in parentheses between last letter of the variable name

and the closing %> characters of the variable tag. The string can contain both "specifiers"

that define the date and time format and normal text. Normal text must be enclosed in

double quotes.

Specifiers may be written in upper or lower case, the result will be the same. 

Examples:

<%NOW("This topic was published on " dddd, mmmm d, yyyy, " at "
hh:mm AM/PM)%>
<%TOPICLASTEDITED("This topic was last modified on " dddd, mmmm d,
yyyy, " at " hh:mm AM/PM)%>

Example result: This topic was last modified on Tuesday, January 3, 2013, at 12:22 PM

The text within the quotes will be inserted exactly as it is written. Any spaces required

must be included within the quotes and the quotes must be separated from the specifiers

by spaces.
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Date and time format specifiers

Specifier Function

" text "

' text '

Anything enclosed in single or double quotes is inserted unchanged as

plain text and does not affect formatting.

. and , You can include periods and commas in the formatting string with the

specifiers, these characters to not need to be quoted.

c Displays the date using the standard Windows short date format, followed

by the time using the standard Windows long time format. The time is not

displayed if the fractional part of the DateTime value is zero.

d Displays the day of the month as a number without a leading zero (1-31).

dd Displays the day of the month as a number with a leading zero (01-31).

ddd Displays the day as an abbreviation (Sun-Sat) using the standard Windows

strings for short day names.

dddd Displays the day as a full name (Sunday-Saturday) using the standard

Windows strings for full day names.

ddddd Displays the date using the standard Windows short date format.

dddddd Displays the date using the standard Windows long date format.

m Displays the month as a number without a leading zero (1-12). If the m

specifier immediately follows an h or hh specifier, the minute rather than

the month is displayed.

mm Displays the month as a number with a leading zero (01-12). If the mm

specifier immediately follows an h or hh specifier, the minute rather than

the month is displayed.

mmm Displays the month as an abbreviation (Jan-Dec) using the standard Win-

dows values for short month names.

mmmm  Displays the month as a full name (January-December) using the stand-

ard Windows values for long month names.

yy Displays the year as a two-digit number (00-99).

yyyy Displays the year as a four-digit number (0000-9999).

h Displays the hour without a leading zero (0-23).

hh Displays the hour with a leading zero (00-23).
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n Displays the minute without a leading zero (0-59).

nn Displays the minute with a leading zero (00-59).

s Displays the second without a leading zero (0-59).

ss Displays the second with a leading zero (00-59).

z Displays the millisecond without a leading zero (0-999).

zzz Displays the millisecond with a leading zero (000-999).

t Displays the time using the standard Windows short time format.

tt Displays the time using the standard Windows long time format.

am/pm Uses the 12-hour clock for the preceding h or hh specifier, and displays

'am' for any hour before noon, and 'pm' for any hour after noon. The

am/pm specifier can use lower, upper, or mixed case, and the result is dis-

played accordingly.

ampm Uses the 12-hour clock for the preceding h or hh specifier, and displays

the contents of the Windows TimeAMString global variable for any hour

before noon, and the contents of the TimePMString global variable for any

hour after noon.

/ Displays the date separator set in your Windows configuration.

: Displays the time separator set in your Windows configuration.

See also:
Using Variables

11.7.2.5 HTML template variables

You can use all global predefined variables  and user-defined variables  in HTML
templates . In addition to this you can also use the following special predefined variables,
which are only relevant in HTML templates.

Variables for use in topic page templates only:

These variables can only be used in topic page templates. They are valid in all HTML-

based output formats (HTML Help, WebHelp, Windows Exe and ePUB eBooks and Visual

Studio Help).

917
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Variable Content and/or function of the variable

Note on HREF-Variables: All the HREF variables insert the local names of

the corresponding pages within the current dir-

ectory without any path information, e.g. top-

ic1name.htm, topic2name.htm and so on.

<%DOCCHARSET%> Inserts the correct character set information in

the meta tags at the beginning of the HTML out-

put pages. This variable is essential in all tem-

plates and should not be removed. If you do re-

move it you will get an error message from the

compiler.

<%DOCTYPE%> Inserts the correct DOCTYPE tag at the beginning

of the HTML output pages. This variable is essen-

tial in all templates and should normally not be

removed. If you do remove it you will get an er-

ror message from the compiler.

You can insert your own <DOCTYPE> declaration

in the template explicitly and if you do this no

error message will be displayed. However, it may

produce unexpected results. 

<%GA4ACCOUNT%> Filled with the value specified for the for your

new Google Analytics 4 (GA4) Google Analytics

account  (your tracking ID).

<%GAACCOUNT%> Filled with the value specified for the for your old

Universal Analytics Google Analytics account

(your tracking ID).

<%HM_LINKLIST_SIBLINGS%>
<%HM_LINKLIST_CHILDREN%>
<%HM_LINKLIST_ANCHORS%>

These variables can be used in the topic HTML

page template. They insert UL link lists:

SIBLINGS: All the siblings of the current topic.

CHILDREN: All the children of the current topic.

ANCHORS: Anchors in the current topic.

Not for use in V3 and V4 skins:

Note that you can't use these variables in the

page templates for Premium Pack V3 and V4

666
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Variable Content and/or function of the variable

Note on HREF-Variables: All the HREF variables insert the local names of

the corresponding pages within the current dir-

ectory without any path information, e.g. top-

ic1name.htm, topic2name.htm and so on.

skins. Since topic content is loaded dynamically

in these skins, variables set in the template don't

change. 

<%HREF_CURRENT_PAGE%> Link address of the current page.

<%HREF_DEFAULT_PAGE%> Link address of the "Default" topic. This is used

for the standard Top navigation link in the topic

headers so that users can return to the default

topic in your project.

<%HREF_NEXT_PAGE%> Link address of the next topic.

<%HREF_PARENT_CHAPTER%> Link address of the parent topic (chapter). This

can be used as an alternative to <%

HREF_DEFAULT_PAGE%>.

If the parent is a chapter without text, this is the

link address of the parent's parent. If no valid

parent is available, the variable is the link address

of the default page.

<%HREF_PREVIOUS_PAGE%> Link address of the previous topic (used for Pre-

vious/Next buttons). 

<%STYLESHEET%> Inserts the reference to the CSS stylesheet con-

taining all the styles information for your project.

This variable is essential in all templates and

should not be removed. If you do remove it you

will get an error message from the compiler.

<%TOPIC_AKEYWORDS%> Inserts all the A-keywords  of the current topic,

comma-separated.

<%TOPIC_BREADCRUMBS%> Generates a series of "breadcrumb trail" naviga-

tion links to topics above the current topic in the

579



1572

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Reference

Variable Content and/or function of the variable

Note on HREF-Variables: All the HREF variables insert the local names of

the corresponding pages within the current dir-

ectory without any path information, e.g. top-

ic1name.htm, topic2name.htm and so on.

TOC tree. This variable is empty in top-level top-

ics. In second-level topics and below the variable

generates a series of links in the format Link1 >

Link2 > Link3 ...

The current topic is not included in the series. If

you want to place the current topic title at the

end of the breadcrumb trail you can do so with

the HTML template variables variable (see

below).

The breadcrumb trail variable is empty in topics

in the Invisible Topics section.

This variable has a matching condition pair:

<IF_TOPIC_BREADCRUMBS> and

<IFNOT_TOPIC_BREADCRUMBS>. These condi-

tions can be used to only insert the trail where it

is relevant and to insert alternative content when

it is not relevant.

See here  for details on how to use this vari-

able.

<%TOPIC_HEADER%> Inserts the header of the current topic if it exists.

If the current topic has no header the value of

this variable is null. This can be different from the

topic caption inserted with <%TOPIC_TITLE%>.

<%TOPIC_HEADER_TEXT%> Inserts the header of the current topic as plain

text. This is particularly useful if your project

headers are different from and longer than the

TOC captions, which is inserted with <%

TOPIC_TITLE%>.

This is used primarily for search engine optimiza-

tion, for which you would insert it in the de-

1036
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Variable Content and/or function of the variable

Note on HREF-Variables: All the HREF variables insert the local names of

the corresponding pages within the current dir-

ectory without any path information, e.g. top-

ic1name.htm, topic2name.htm and so on.

scription meta tag, like this:

<meta name="description" content="<%
TOPIC_HEADER_TEXT%>">

<%TOPIC_DESCRIPTION%>
<%TOPICMETA:DESCRIPTION%>

Inserts the text from the Description field in the

topic's Topic Options tab if you have entered a

description there. Otherwise it inserts the first

177 characters of the topic text, followed by an

ellipsis (...).

This can be used in combination with the "fea-

tured image" (see next row) to insert a "title" im-

age and a description for your topic in your tem-

plate.

In addition to this it can also be used to populate

the description meta tag for search engines like

this:

<meta name="description" content="<%
TOPIC_DESCRIPTION%>">

<%TOPICMETA:PICTURE%>
<%TOPIC_PICTURE%>

Returns the file name of the "featured image" for

the current topic, if one has been set in the

topic's Topic Options. Returns blank if no fea-

tured image has been set.

<%TOPIC_KEYWORDS%> Inserts all the keywords  of the current topic,

comma-separated. Needless to say, this variable

is essential for the keyword index and shouldn't

be removed...

<%TOPIC_TEXT%> Inserts the body text of a topic, i.e. the entire

topic as edited and formatted in your project in

the Help+Manual editor. This is the most import-

ant variable. If you leave it out your topics will be

empty! 

565
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Variable Content and/or function of the variable

Note on HREF-Variables: All the HREF variables insert the local names of

the corresponding pages within the current dir-

ectory without any path information, e.g. top-

ic1name.htm, topic2name.htm and so on.

<%TOPICTITLE%> Title text of the current topic. This is taken from

the Title Tag: field in the Topic Options tab

(on the left of the editor window) and is normally

the same as the TOC caption for the topic and

will change automatically when you edit the TOC

caption in the TOC. So this variable gives you the

TOC caption, unless you edit the Title Tag field 

Editing the Title Tag text in Topic Options:

Editing the Title Tag: field manually "un-

couples" this field from the TOC caption. The

variable then still returns the contents of the field

in Topic Options, so if you want to use it for the

TOC caption we recommend not editing the field

in Topic Options.

To "recouple" the Topic Options field with the

TOC caption, just edit either so that the texts are

both identical. This works the same as the coup-

ling between the TOC caption and the topic

header text.

Deprecated older version:

The older <\%TOPIC_TITLE%> version of this

variable is still supported and does not need to

be changed in your projects. However, please al-

ways use the current <%TOPICTITLE%> version

now.

<%TOPIC_TITLE_PATH%> This variable is similar to the breadcrumbs vari-

able above but it delivers the breadcrumb trail as

a plain text string without any links. Unlike the

breadcrumbs variable it also includes the name

of the current topic, so it always delivers a full

trail.

The primary use of this variable is for search en-
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Variable Content and/or function of the variable

Note on HREF-Variables: All the HREF variables insert the local names of

the corresponding pages within the current dir-

ectory without any path information, e.g. top-

ic1name.htm, topic2name.htm and so on.

gine optimization, for which you would insert it

in the <title> tag of your topic page template

instead of the normal <%TOPIC_TITLE%> vari-

able, like this:

<title><%TOPIC_TITLE_PATH%></title>

Modification for HTML Help:

If you also output to HTML Help you should use

conditional text to ensure that this variable is

only used in Browser Help, otherwise you will get

the full path as the topic name in your search

results in the HTML Help viewer. Do it like this:

<title><IF_HTML><%TOPIC_TITLE_PATH%
></IF_HTML><IF_CHM><%TOPIC_TITLE%
></IF_CHM></title>

<%TOPICID%> Returns the plain topic ID as written in the Topic

ID: field of , without any filename  extension and

without changing the ID text to lower case. This

can be used to add an ID reference in your meta

attributes in your web pages, for example:

<meta name="id" content="<%TOPICID%
>" />

(This variable can also be used in normal topic

pages.)

<%XMLLANG%> Returns the project language code, e.g. en-us

for US English. 

Variables for use in WebHelp only:

All the remaining variables are only relevant in WebHelp  (HTML):1510
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Variables for WebHelp 3 mode only:

In WebHelp 3 mode, the JavaScript files, graphics and video files and CSS files are all

saved in sub-folders of the main WebHelp folder. You can use these variables in your

HTML templates to automatically insert the relative paths to these folders. 

Variable Content and/or function of the variable

<%HM_RELPATH_JAVASCRIPT%> Returns the relative path to the JavaScript files

folder: 

./js/

<%HM_RELPATH_IMAGES%> Returns the relative path to the images and me-

dia files folder (video files are also stored here):

./images/

<%HM_RELPATH_CSS%> Returns the relative path to the CSS files folder:

./css/

Global variables for all WebHelp templates:

Variable Content and/or function of the variable

<%HREF_CONTENT_PAGE%> Link address of the TOC page

<%HREF_INDEX_PAGE%> Link address of the keyword index-page

<%HREF_SEARCH_PAGE%> Link address of the full-text search page

<%HREF_TOP_PAGE%> Link address of the top frame (e.g. "index.html")
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Variables for the Layout frameset template only:

Variable Content and/or function of the variable

<%HREF_CONTENT_PAGE_DYN%> Link address of the dynamic TOC page.

<%HREF_CONTENT_PAGE_STATIC%
> 

Link address of the static TOC page.

<%NAVIGATION_SCRIPT%> Inserts the navigation script required by the top

frame.

Variables for the Table of Contents template only:

Variable Content and/or function of the variable

<%TABLE_OF_CONTENTS%> Inserts the entire TOC in the page.

Variables for the Keyword Index template only:

Variable Content and/or function of the variable

<%KEYWORD_INDEX%> Inserts the entire keyword index in the page.

Variables for the Search template only:

Variable Content and/or function of the variable

<%SEARCH_SCRIPT%> Inserts the full-text search script in the page.

See also:
Using Variables

Using HTML Templates

Editing HTML templates

Help Windows

11.7.2.6 HTML template output conditions

You can use all of Help+Manual's standard conditional output options in HTML templates,
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both your user-defined include options  and options based on the current output format. In

addition to this there are a few special conditional switches which are only for use in

Help+Manual's WebHelp output, because they are only relevant there. See the lists below for

details.

These conditions are like special HTML tags. They are used to enclose blocks of HTML code in

your template that you want to include in the output only if the condition is fulfilled. 

In HTML templates you can only use output format conditions for HTML-based output

formats (CHM, HTML, EBOOK and HXS). This is because these templates are only used for

HTML-based output – so <IF_PDF> would not have any meaning, for example. Note that the

EBOOK condition applies both for Windows Exe and ePUB eBooks. 

Conditions are stripped before publishing

All the condition tags are stripped from your code before actually generating the HTML

output. No proprietary tags are included in your output!

Conditional tags in templates are hard-wired to the output format

Conditional tags in HTML templates look very similar to the conditions you use for con-

tent in your project. However, there is one very important difference: In templates, the

true/false status of the conditions is hard-wired to the output format and cannot be

changed. 

In the Publish screen you can include content tagged for other output formats than the

one you are currently publishing to by activating the checkboxes for those formats manu-

ally. This has no effect on the conditional tags in your templates, however. This is very im-

portant, because in templates you will often want to exclude code that would cause errors

in some output formats. If this wasn't the case, including content tagged for WebHelp in a

CHM file the Publish screen could cause serious errors if that also included template code

tagged exclusively for WebHelp in a CHM file. 

Combining conditions with AND and OR logic

You can combine conditions to achieve AND and OR logic if necessary. For AND you need

to nest two sets of conditons, for OR you combine the conditions in a single tag.

Nesting conditions for AND logic

If you only want to include content when multiple conditions are all true you need to nest

them like this:

<IF_HTML><IF_TOGGLES> ... </IF_TOGGLES></IF_HTML>

988
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The above conditions will only include the content between the tags if the output format

is WebHelp and there are toggles on the current page.

Combining conditions for OR logic

If you want to include content if any one of multiple conditions is true you combine them

in a single tag separated by the | pipe character. 

Important: Note that this does not work with IFNOT conditions, only with IF conditions!

You can use this feature like this:

<IF_CHM|TOGGLES> ... </IF_CHM|TOGGLES>

The above condition will include the content between the tags if the current format is

CHM or if there are toggles on the page, or if both are the case. 

Predefined HTML template conditions:

In addition to the predefined conditions listed here you can also use your own user-

defined include options  as conditions in HTML templates. See Conditional output in

HTML templates  for details on how to use the conditions.

Conditions Function of the condition

<IF_CHM> True when you generate HTML Help/CHM. 

<IF_EBOOK> True for eWriter/Windows EXE eBooks (false for other

eBook types).

<IF_EPUB> True for ePUB and Kindle/Mobi eBooks (false for

eWriter Help).

<IF_FRAMES> True if WebHelp is exported with frames (a frame-

based format is selected in the Navigation  op-

tions). This could be used for entering a link from

topic pages to your TOC page when you select the No

Frames, No Scripts layout option, for example.

Only relevant for WebHelp.

<IF_GA4ACCOUNT> True if the setting for your new Google Analytics 4

(GA4) Google Analytics account  is not empty.

<IF_GAACCOUNT> True if the setting for your old Universal Analytics

Google Analytics account  is not empty.
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Conditions Function of the condition

<IF_HTML> True when you generate WebHelp (HTML)

<IF_HXS> True when you generate Visual Studio Help (2008 or

2010)

<IF_INDEX_PAGE> True if a keyword index is included in the output. For

example, you could use this to exclude a link to the

index page from the TOC page if the keyword index is

not included. Only relevant for WebHelp. 

<IF_NEXT_PAGE> True if a next page exists. Used to suppress or display

a grayed-out version of the Next button in the very

last topic. Can only be used in topic page templates.

<IF_PREVIOUS_PAGE> True if a previous page exists (the variable <%

HREF_PREVIOUS_PAGE%> is not empty). Used to

suppress or display a grayed-out version of the Pre-

vious navigation button in the very first topic. Can

only be used in topic page templates.

<IF_SEARCH_PAGE> True if full-text search is included in the output. For

example, you could use this to exclude a link to the

search page from the TOC or keyword index page if

the search function is turned off. Only relevant for

WebHelp.

<IF_TOGGLES> True if the current topic contains one or more

toggles  (expanding text and images). Can only be

used in topic page templates.

<IF_TOPIC_BREADCRUMBS> True if the <%TOPIC_BREADCRUMBS%> variable is not

empty (see HTML template variables ). For ex-

ample, this variable is always empty in topics in the

Invisible Topics section and in top-level topics. Can

only be used in topic page templates.

<IF_TOPIC_HEADER> True if the current topic has a header and the header

is not empty (the variable <%TOPIC_HEADER%> is not

equal to ""). Can only be used in topic page tem-

plates. 

382
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Conditions Function of the condition

<IF_TOPIC_PICTURE> True if the current topic has a featured image associ-

ated with it. You can then use this to insert the image.

Can only be used in topic page templates.

<IF_XHTML> True if XHTML 1.1 output is activated in your HTML

Export Options.  You will generally only need this in

reusable skins, when the skin may be used for pro-

jects published with either normal HTML or XHTML. 

"IFNOT" versions negate the meaning of the conditions:

Exclude Conditions Function of the exclude condition

<IFNOT_CONDITIONNAME> Negates the positive version of the condition. Con-

tent between the condition tags is only inserted if the

condition is not true. Available for all conditions. 

See also:
User-defined include options

Using HTML Templates

Conditional output in HTML templates

Help Windows

11.7.2.7 PDF template variables

You can use all Help+Manual's global predefined variables  and your own user-defined

variables  in the text objects in PDF print manual templates . In addition to this there are

also a number of special predefined variables that can only be used in print manual tem-

plates. These variables are described and listed in the separate help and documentation of the

Print Manual Designer program included with Help+Manual.

Key Information
Conditions are not supported in PDF print manual

templates. You cannot use conditional text or any

other conditions in these templates.
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Using variables in PDF templates

Global and user-defined variables from your project:

Just type the variable in any text object in your PDF template, using the standard <%

VARIABLENAME%> syntax. 

Special PDF template variables:

These variables can be typed in manually but they can also be inserted from a list by se-

lecting the Variable button in the text object dialog. This option is preferable because it

automatically shows you which PDF template variables are valid in the current location. 

See also:
Using Variables

PDF and Printed Manuals

The Print Manual Designer

11.7.2.8 Conditional output

Help+Manual supports multiple levels of conditional output that give you very precise control

over what is included in your published projects on the basis of output format and user-

defined output conditions . These features make it possible to generate different versions

of your project for different purposes and formats. You can control the inclusion or exclusion

of everything from individual words (or even single letters) to entire topics and branches of

the Table of Contents (TOC).

For example, if you output your project to both HTML Help and PDF you will generally need

to make some small changes to the text for the PDF version because some things that are rel-

evant in electronic help don't make sense in PDF or a printed manual. With conditional output

you can include both versions in the same project and only the relevant components will be

included when you publish.

How conditional output works:

Instead of creating and maintaining multiple versions of your project for different versions

you only have one project, or one set of modular projects, containing all the content and

topics for the alternate versions you need to generate. The chapters, topics and topic con-

tent (text, graphics, tables etc.) for the alternate versions are "tagged" with conditions

called "include options" (also known as build conditions) that control whether they are in-

cluded in the output or not. 

Note that in HTML Help you can also create different versions of your documentation with

runtime modular projects. See Runtime and publish time merging  for details on this.
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Format-based include options:

These options allow you to include or exclude topics and content on the basis of the se-

lected output format.

For example, suppose you have two different versions of a sentence, one for the HTML

Help version and one for the PDF version. You would enclose the first version in an

IF_CHM conditional text tag  and the second in an IF_PDF tag. And that is all you have to

do, everything else is automatic. When you publish to HTML Help only the IF_CHM version

is included, and when you publish to PDF only the IF_PDF version is included. 

User-defined include options:

These options allow you to include or exclude topics and content on the basis of condi-

tions that you define. This makes it possible to create different versions of your published

output irrespective of the output format. For example you may have different documenta-

tion for different versions of a product. 

For example, suppose you defined an include option called BETABUILD and tag specific

text passages and topics in your project with an IF_BETABUILD condition. To include those

passages in your output you just select the BETABUILD include option in the Publish

dialog when you publish, along with any other relevant options.

Multiple TOCs

You can combine alternative TOCs  with conditional output when you need to create

versions of your project with a completely different TOC structure. 

Conditional output and links

It is important to plan your links when you are working with conditional output. When you

exclude a topic from your output any hyperlinks to that topic in other topic will be dead

unless you also exclude the links. 

Before excluding a topic always right-click on its TOC entry and select Check Referrers to

locate any links to the topic. You can then use the same conditions to exclude the links

from your output. In addition to this you may want to add additional conditional text op-

tions to include alternative text to replace the links. 

You can configure Help+Manual to include the topic anyway  to prevent dead links, but

it is better to exclude the links using the same output conditions.
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Levels of conditional output supported by Help+Manual:

Conditional text: On the text level you can use conditional text tags  to mark sec-

tions in your topics –  paragraphs, graphics, sentences and even indi-

vidual words and letters – that should only be included when a spe-

cific condition is fulfilled (output format or user defined). 

Text variables: Text variables (see Using Variables ) allow you to use variables for

text items. Then if the item changes you only need to redefine the

variable once to implement the change throughout your entire pro-

ject. 

Variables are not really conditional output in the strictest sense of

the term, but you can use them for conditional output by redefining

them globally  with a project skin or a variables file that replaces

the variable definitions in your project at publish time.

Topic conditions: These conditions allow you to include or exclude entire topics and

chapters  on the basis of output format or user-defined conditions.

Multiple TOCs: You can combine alternative TOCs  with conditional output when

you need to create versions of your project with a completely differ-

ent TOC structure. 

Modular pro-

jects:

Help+Manual's modular projects features  enable you to include

or exclude entire projects in your help at publish time. This makes it

possible to quickly add or remove entire blocks with multiple

chapters 

HTML condi-

tions:

You can also use some special conditional switches in HTML tem-

plates  to control when code in the template should be included or

excluded.

See also:
Conditions and Customized Output

Using Variables

Working with Modular Help Systems

Conditional output in HTML templates

11.7.2.9 TOC entry and topic file include options

Your TOC entries and topic files are actually two separate items: The TOC entries are only links

pointing to the topic files. The TOC entry and the topic files also have separate include op-
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tions. If you work in the TOC you will normally not need to think about this because the

matching include options for the associated topic files will be set automatically. 

However, the situation is different if you have multiple TOC entries  for the same topic in

the TOC. Then you need to think about what happens when you set different include options

for TOC entries linked to the same topic file. 

How build options are applied to TOC entries and topic files

Working in the TOC:

When you work in the Table of Contents section of the Project Explorer setting or chan-

ging an include option for the TOC item automatically sets the same option for the topic

file to which the TOC entry is linked. Normally this is a 1:1 association and you don' t need

to think about it at all. It is set and cleared for both items automatically. However, the situ-

ation is different for topic files with multiple TOC entries. See below for details.

Working in the Topic Files section:

Setting or changing an include option for a topic in the Topic Files section of the Project

Explorer does not automatically change the include options for any associated TOC

entries. For technical reasons, the topic files cannot be permitted to control the TOC

entries. Among other things, this would create a mess when the TOC contains multiple

references to the topic file, each with different build options.

Topic files with no TOC entry 

If a topic file has no TOC entry (for example for popup topics or topics displayed in ex-

ternal windows) you must set include options directly for the topic file, in Topic Files in the

Project Files section of the Project Explorer.

This is generally the only time when you should set include options for topic files directly.

In all other cases you should set the options in the TOC unless you have a specific reason

for wanting different options for the TOC entry and the associated topic file.

Topic files with multiple TOC entries

If you have multiple TOC entries  for the same topic in the TOC setting include options

for the individual TOC entries is a little more complicated. Basically, the following prin-

ciples are applied:

· The include options are saved separately for each TOC entry.

· The include options of the linked topic file are set as the sum of all the options set for

the linked TOC entries. 
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Note that these settings are handled automatically if you set the options in the TOC.

However, if you set the include options for the topic files directly you are responsible for

getting the associations right yourself. 

Examples:

In the following example the include options of the topic file are set to ALL because only

this setting will cover all the settings required for both the associated TOC entries.

Item Type Name Include Options

TOC entry 1 Introduction CHM

TOC entry 2 Introduction(2) ALL

Topic file Introduction.xml ALL

In the following example the include options of the topic file are set to the combination of

the options for both associated TOC entries.

Item Type Name Include Options

TOC entry 1 Introduction CHM, HTML

TOC entry 2 Introduction(2) PDF

Topic file Introduction.xml CHM, HTML, PDF

11.7.3 Context-Sensitive Help & Popups

Context-sensitive help  enables users to obtain help that is directly relevant to a specific

program feature or the task they are currently performing. It can make it much easier for

users to learn how to use your application because they get information about what they are

trying to do while they are trying to do it. This makes your users happier and saves you time

and money by reducing the amount of support you have to provide.

What is context-sensitive help?

There are basically three kinds of context-sensitive help that you need to think about as a

help author:

· The user presses F1 and the help is displayed with a topic relevant to the "context" in

which the user pressed the key. For example, pressing F1 in an editor could display a

topic on editing, pressing F1 in a configuration dialog could display a topic on the fea-

tures of that dialog, and so on.

· Clicking on a "Help" button in a dialog displays a help topic describing that dialog.

· Right-clicking on a control in an application and selecting What's This? displays a

popup window with a text describing the control and what it is for. 
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· Clicking on any other kind of control in an application (an icon etc.) to display a small

popup directly in the application.

The first two kinds of context-sensitive help are implemented with normal calls to specific

topics in your help. These are almost always ordinary topics that are included in the Table

of Contents (TOC). As the help author you only have to make sure that relevant topics are

available, and you must also coordinate with the programmers on the topic IDs and/or

help context numbers  that are to be used to access the topics from the application. See

About implementing context help  for some more background information on this.

Context-sensitive help using popup topics displayed directly in your application is a spe-

cial case. These popups are referred to as "field-level" popups and they are only suppor-

ted in the Microsoft HTML Help (CHM) format. See About field-level popups  in this

chapter for details.

See also:
Context-Sensitive Help  (HowTo)

About field-level popups

11.7.3.1 Context-sensitive help technologies

A full tutorial on implementing context-sensitive help in applications would go well beyond

the scope of this help. This topic is just provided to inform you of the various context-sensit-

ive help technologies that are available in Windows so that you can consider using them in

your application.

Context-sensitive help technologies available in Windows:

Tooltips: Little "tips" that appear automatically when the user moves the

mouse over a control. These are usually implemented in the applic-

ation itself rather than being stored in an external help file. Most

modern programming environments support tooltips.

Even if you don't implement any other kind of context help for the

controls in your application it is always a good idea to include tool-

tips with brief explanations of what the controls do. This alone can

significantly reduce the number of support requests you have to

deal with!

What's This? help: In many modern applications you can right-click on a control and

select a What's This? option that displays a popup window with a

help text. If you can make your users aware of this (and that is not

easy) this can significantly reduce support requests. 

This can be implemented with the help of popup topics created in

Help+Manual. The advantage of this is that the topics are displayed
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on their own in a little independent window, without opening the

entire help. 

Microsoft includes support for What's This? help in its program-

ming languages. The free EC Software Help Suite tools package

available on our website makes implementing What's This? help

easier in older versions of Borland Delphi and Borland C++. Delphi

2005 and later have integrated support for CHM and do not need

the Help Suite.

Help buttons in

dialogs:

These buttons link directly to the relevant topic in your main help

file. These are implemented with a direct call to the help file and the

topic.

All dialogs requiring any explanation should have a HELP button. In

addition to making your application much easier to use these but-

tons also help to ensure that your users actually read your help in-

stead of just reaching for the phone or writing you an email!

F1 context help: Relevant help is displayed automatically when the user presses the

F1 key. What help topics or features are called depends on where

and when the user presses F1 (the "context"). How this is imple-

mented depends on the individual programming language and it is

entirely up to the programmer. As the help author you only have to

provide the programmers with the necessary topic IDs and/or help

context numbers  so that they can call the appropriate topics.

Training card

help:

This is a powerful but rather cumbersome help technology de-

veloped by Microsoft and supported in HTML Help . It allows you

to create interactive tutorials in your help that automatically per-

form actions in your application when the user clicks on hotspots

and links in your help. For example, you can invoke functions, dis-

play menus, select options and fill out data fields to show the user

how to do things. 

For programming information on implementing training card help

see the MSDN Library on Microsoft's website – we can't provide

direct links here because the MSDN web programmers change the

addresses so frequently.

Although training card help is a very powerful tool there are good

reasons why it is very rarely used. It can be quite tricky to imple-

ment and every programming language handles it differently. 
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Interactive wiz-

ards:

There are basically two kinds of interactive wizards: "Programmed

wizards" created as part of your program and "help wizards" cre-

ated with help technologies like HTML Help. 

We don't want to go into programmed wizards here, but they can

be very useful for guiding your users through complex configura-

tion tasks. For example, a help wizard could guide a user through

the process of configuring a complex program, only continuing to

the next dialog screen when all the settings have been completed

correctly. 

Non-programmed help wizards are simply ordinary help files, or

sections of help files, that teach users how to perform a specific

task in a systematic way. They can be integrated in your main help

but it is generally a good idea to create them as separate help files.

Then they can be called when needed and they don't get in the way

when they are no longer needed.

Simple help wizards guide the user through a task or procedure

without direct interactivity. For example, you could create a little

help project that shows the user how to configure your program.

Each topic would be a single step in the procedure, with screen-

shots showing exactly what needs to be done and Next and Previ-

ous buttons for navigation. 

More advanced help wizards make use of training card help (see

above) to open dialogs and perform operations in your application.

If you use this you should always also prompt your users to try the

procedure out for themselves as well, otherwise they will only learn

how to use the wizard rather than the program itself!

HelpXplain

screencasts and

tutorials: 

You can insert animated screencasts and tutorials made with our

HelpXplain tool  in any topic with a couple of clicks. These tutori-

als are easy to make and can make your documentation much

more informative and easy to understand.

Simple HelpXplain screencasts can be made directly with the Screen

Capture tool  in Help+Manual itself, but you need the full HelpX-

plain program if you want to edit them or make more advanced

presentations. 

Flash demos: Flash has now been discontinued worldwide on all platforms and is

no longer supported. All Flash content should now be removed

from Help+Manual projects. 
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See also:
Using Context-Sensitive Help

Creating popup topics

11.7.3.2 About popup topics

Popup topics  must be created without TOC entries  because they are never included in

the TOC (Table of Contents). If a topic has a TOC entry you will not be able to use it as a

popup. 

Instead of being displayed in the help viewer popups are displayed in small "popup windows"

that are closed again when the user clicks after reading their contents. 

All popup topics can be displayed with links from within your help file. HTML Help (CHM) nat-

ive plain-text popups can also be displayed within your application, without displaying the

main help viewer. Then they are referred to as "field-level popups".

The two uses for popup topics: 

Within the help

file:

Inside the help file popups are used to display small items of in-

formation that you want to make available but you don’t want to

include again and again in the help text. 

A good example of this would be a definition of a technical term

that is used frequently in your text. Instead of repeating the defini-

tion again and again you would turn the term into a link that links

to a popup topic. However, you may also want to consider using in-

line text toggles  for this.

When the user clicks on the link the contents of the topic are dis-

played in a small popup box, without leaving the current topic.

Context-sensitive

help:

HTML Help popup topics (but not JavaScript popups ) can also

be called directly from applications. When they are called in this

way they are displayed on their own, without displaying the help

file, and closed again immediately when the user clicks on them.

This makes them a useful context-sensitive help tool for describing

controls and functions in programs. See About field-level

popups  for more details.

The pros and cons of using popups:

Popups are definitely useful and it is tempting to make extensive use of them. However,

there are a couple of issues you need to think about before doing so:
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· Using popups makes it more difficult to produce a printed version of your help. The

user can’t display popups in a PDF or a printed manual so to produce the printed ver-

sion you need to provide different ways of accessing the same information, for example

by creating different versions of the text and using conditional output . This can be

quite a lot of work and can get quite complicated to maintain.

· Popups reduce the multi-output compatibility of your source. Plain text popups are ex-

clusive to HTML Help, and in WebHelp (HTML) you can only use JavaScript popups .

Popups do not work at all in Word DOCX, PDF and printed manuals. 

· If you want to produce multiple format versions of your help project from the same

source it’s best not to use popups too much because they can significantly increase the

work involved in maintaining the multiple versions.

· If you need context-sensitive field-level HTML Help for display within your application it

may be advisable to make a separate Help+Manual project just for these popups.

Where popup topics are supported:

Popups are not supported in all the output formats generated by Help+Manual, and the way

popups are handled and the options available also vary from format to format. The following

table provides a summary of where and how you can use popups:
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Where popups are supported

Output Format Supported Popup Types Where Supported

HTML Help (.CHM): Plain-text popups integrated
in the main help file.
Context numbers are
required for these popup
topics!

Formatted JavaScript
popups  stored in the
main help file.

Plain-text popups are only
supported as field-level
popups in applications. If
you want popups in the help
text you must activate
JavaScript popups.

Formatted JavaScript
popups can only be used in
the help text. They are not
supported for context-
sensitive help.

Browser-based HTML 
(.HTM):

Fully-formatted JavaScript
popups  integrated in the
individual HTML files.

JavaScript popups can only
be used in help topics. You
cannot link to them from
your application.

eWriter Help: Same popup options as
WebHelp

Same as WebHelp

ePUB and Kindle Mobi
eBooks:

Popups are not supported.
Popup links are
automatically converted to
plain text.

N/A

Adobe PDF and
printed user manuals:

Popups are not supported.
Popup links are
automatically converted to
plain text.

N/A

Word DOCX: Popups are not supported.
Popup links are
automatically converted to
plain text.

N/A

See also:
Context-Sensitive Help  (HowTo)

Conditions and Customized Output

Using JavaScript popups

11.7.3.3 Using field-level popups

Key Information
Field-level popups must have help context  num-

bers. Field-level popups are only exported if you as-

sign help context numbers to them! 
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A field-level popup is a popup displayed directly from within your application. They are nor-

mally only available for Microsoft HTML Help CHM files.

Field-level popups for WebHelp

In their native form field-level popups are only supported by the Microsoft HTML Help

(CHM) format. This is the version described in this topic. However, the responsive skins

available in the Premium Pack 3 add-on for Help+Manual also add field-level popups for

WebHelp. Their use is explained in the additional help chapter titled Help+Manual

Premium Pack added to the main Help+Manual help when you install the Premium Pack.

(If you don't  have the Premium Pack installed this chapter will just display some intro-

ductory material.)

Introduction

In your Help+Manual project, the same popup topics are used for both purposes. When

you publish your project the content of the topics are automatically exported to a special

text file in the CHM for field-level popups, and to the JavaScript popups file for JavaScript

popups. 

The plain-text CHM popups are not available within the main CHM file, however. They are

only for field-level popups. You can only use JavaScript popups for popups displayed

within the CHM file.

· Normal popup topics are displayed within the help when the user clicks on a link in a

topic, for example to display a definition or an explanation. JavaScript popups must be

activated for this to be possible in HTML Help CHM files and WebHelp.

· Field-level popup topics are called directly by the application and displayed in little

windows of their own. This is done without displaying the rest of the help at all. Only

the little popup is displayed, and it is closed again as soon as the user clicks on it.

About creating field-level popups:

Field-level popups are only supported in HTML Help CHM files. They are a proprietary Mi-

crosoft technology and they are not supported in any other output format.

To create field-level popups the help author needs to perform the following steps:

1. Create popup topics  so that you have popups to display. 

2. Assign help context numbers  to all your popup topics. This is essential because

field-level CHM popups must be called by their context numbers. If you don't assign

numbers the topics won't be exported to the plain-text field-level popups file!
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3. Inform your programmer of the help context numbers and topic IDs and the name of

the internal plain text popups file so that they can make the calls. You can use the con-

text tool  to export a list of IDs and context numbers. 

The internal popups file is normally called CSHelp.txt but you can change its name in

the Extended .HHP Settings .

See Implementing context help  for more general information.

If you are writing field-level popups for an application you may have to produce a lot of

popups. You can save yourself a lot of work by generating your field-level popups auto-

matically .

Using both field-level popups and JavaScript popups

Only the CHM format's native plain-text popups can be used as field-level popups. If you

also want to display popups inside your CHM help file you must activate JavaScript

popups , otherwise links to popup topics will be displayed as normal topics. 

The native plain-text popups used in CHM cannot be used for displaying topics inside the

main CHM file, only for field-level popups. (This plain-text file is always exported, even if

JavaScript popups are turned off.) 

If JavaScript popups are activated, popup links in your project topics will display as JS

popups in the HTML Help viewer. However, since the plain-text popups file is also stored

in the CHM, calls to this file from your application will also work. 

See also:
Creating popup topics

Using Context-Sensitive Help

IDs, Context Numbers and Keywords

11.7.3.4 Implementing context help

Generally, implementing context-sensitive help called from the application is the job of the

programmers. They must write the calls that access specific topics in your help, and the syntax

of these calls depends both on the help format and the programming language they are us-

ing. 

HTML Help (CHM) supports both context-sensitive calls to specific help topics and field-level

popups displayed within your application. WebHelp only supports calls to specific topics (see

Context calls to WebHelp for details ).

Free tutorials and context-sensitive help tools for programmers:

How the context-sensitive help calls to your help are made varies depending on the pro-

gramming language you are using. A collection of free tutorials for programmers is avail-

able on the tutorials page at the EC Software website. These tutorials cover implement-
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ing context-sensitive help and interfacing with the help files generated by Help+Manual in

most common programming languages.

You may also be interested in EC Software Help Suite (EHS), a free package of tools for

interfacing with help for Borland Delphi and Borland C++ programmers. EHS is particu-

larly useful for implementing all kinds of context-sensitive help and ships with the full

source code. It is available on the Delphi resources page at the EC Software website,

where you can also download a comprehensive free tutorial on integrating help in Delphi

applications.

Resources for .NET programmers:

You can find an excellent guide to interfacing with help files in .NET programming lan-

guages on Rob Chandler's Helpware site:

 Working with HH 1.x CHM Files in .NET Applications

Rob's site also offers a wealth of information on working with help files in other applica-

tions and languages, including plenty of information on Visual Studio Help for program-

mers.

Your job as the help author

There are a number of things that you need to do as the help author to help make con-

text-sensitive help work:

Topic IDs and context numbers for the programmers

Your programmers need a way to access the topics in the help. This applies equally to
topics in the main help that bring up the entire help and popup topics that are accessed
individually. 

Programs access the topics in HTML Help with the topic IDs and/or the help context

numbers , both of which are stored in the Topic Options tab of each topic. When you
are planning your help project you need to talk to the programmers and find out which
they want to use, and if they need to use special formats. (Some programming languages
require special formats for topic IDs or specific number ranges for help context numbers.)

Topic ID prefixes: If your programmers require special topic ID prefixes you

can apply these to the IDs of new topics automatically. Just

go to Configuration > Common Properties > Miscel-

laneous  and insert the prefix you want to use in the

Topic ID Prefix field.

If you have the Professional or Floating license version of

Help+Manual you can also use an external editor  to add
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ID prefixes to existing topics globally throughout your entire

project (advanced users only).

Auto-generating help

context numbers:

Help+Manual can generate and apply help context numbers

to new topics automatically. Go to Project Explorer > Con-

figuration > Common Properties > Miscellaneous  to set

up this feature.

Applying help context

numbers to existing top-

ics:

You can apply help context numbers to existing topics and

import "help context map files" with lists of context num-

bers provided by your programmers. See The Help Context

Tool  for details.

Changing topic IDs: Don't despair if you discover that you've been using the

wrong topic ID format! You can edit your topic IDs at any

time, Help+Manual updates all internal links automatically. 

See Topic IDs and context numbers  for details.

Planning your structure for context-sensitive help

Before you start writing you also need to plan the kind of context-sensitive help you are

going to use. For example, if the dialogs in the application are going to have a Help but-

ton you need to have appropriate topics for those buttons to link to from all the relevant

dialogs. This may sound trivial but it's quite easy to forget!

Planning the use of field-level popup topics

Field-level popup topics are exactly the same as popup topics used within your help. The
only difference is that they are accessed directly by the application instead of with a link
from a help topic. 

When they are used in this way they are displayed in their own little window that is closed

after the user has read the contents, without displaying the entire help. They are most

commonly used for What's This? help , but they can also be accessed by buttons etc. 

If you are going to use field-level popup topics these require some careful planning.

Among other things, you need a full list of all the controls and other program elements

for which you need field-level popups, along with all the topic IDs and/or help context

numbers that are going to be used to access them. 
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Auto-generating your field-level popup topics

Since there are generally a lot of these topics creating them manually can be time-con-

suming, and you will probably start to wish that you could generate them automatically.

Well, you can! 

All you need to do is get a "help context map file" from the programmer with a list of the

topic IDs and help context numbers (if applicable). Once you have this you can automatic-

ally generate all the popup topics in Help+Manual together with the matching IDs and

help context numbers. See Auto-generating field-level popups  for details.

See also:
Using Context-Sensitive Help

The Help Context Tool

Creating popup topics

Topic IDs and context numbers

Auto-generating field-level popups

11.7.3.5 Popups in CHM and eBooks

There are a couple of things you need to bear in mind when editing popup topics because of

the different ways they are handled in different formats. 

Popup topics in eBooks:

Amazon Kindle and ePUB/Apple iBooks have no support for popups or any other dynamic

features. Technically, the ePUB specification does include support for JavaScript, but you

cannot expect it to actually work anywhere.

Popup topics in HTML Help:

Native CHM plain-text popups:

If you do not activate JavaScript popups  your CHM files will only use HTML Help's nat-

ive popup plain-text topics. These can only contain text, without any formatting or other

elements. This means that even if you enter formatted text in the popup topics in the

Help+Manual editor (which is possible because it is needed for other output formats) all

formatting, links, graphics, tables, table contents etc. will be stripped when you publish to

HTML Help.

Formatted JavaScript popups:

Help+Manual also supports a custom JavaScript popup mode that can be used in both
HTML Help and WebHelp. However, you cannot make application calls to JavaScript
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popups. If you activate JavaScript popups in CHM, you must still access the plain-text
popups (which are also included in the CHM file) for field-level popups  displayed in
your application. See Using JavaScript popups  for details on JavaScript popups.

Information for application programmers:

The plain-text popups used in HTML Help are stored in an internal text file in the HTML

Help CHM file. This is the file you need to reference in your application calls to field-level

popups. By default this file is called CSHelp.txt, but you can change this file name in

Configuration > Publishing Options > HTML Help > Popup Topics . 

Controlling the width of popup topics:

In HTML Help the width of popup windows is controlled by the help viewer on the basis of

the amount of text and the user's screen width. Since this system was designed a long

time ago it does not allow for modern computers with wide-format screens and multiple

monitors. When normal popups are displayed on these computers the popups can be

much too wide, which looks terrible. 

There are a couple of simple tricks for solving this problem, which are described in Creat-

ing popup topics  in the Basic Procedures section. 

See also:
Creating popup topics

Using Context-Sensitive Help

Using JavaScript popups

11.7.3.6 About map files

The compilers for many modern programming languages have facilities for automatically

generating text files called "map files" containing the topic IDs and/or help context numbers

for the components and controls used in the program. These files can save you a lot of work

in Help+Manual.

Generating missing topics and context numbers:

Help+Manual can use these files both to assign missing help context numbers to existing

topics and to automatically generate missing topics with the topic IDs and help context

numbers. This second capability is particularly useful for generating the field-level popup

topics used to document program components controls and controls with the right-click

What's This? function and other similar functions. See Auto-generating field-level

popups  and The Help Context Tool  for details.
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Map file syntax:

By default, these files have a very simple syntax, which can be either #define syntax or INI

syntax. When anchor IDs are used they must follow directly on the associated topic ID,

separated by a # character:

Example of #define syntax:

#define IDH_DEFAULT 100001
#define IDH_OK_BTN 100002
#define IDH_CANCEL_BTN 100003
#define IDH_CLOSE#example 100004
#define IDH_HELP_BTN 100005
#define IDH_APPLY_BTN 100006
#define IDH_APP_HMB 100010
#define IDH_WHAT_IS_THIS_CMD 100011
#define IDH_WHAT_IS_THIS_POPUP 100012

Example of INI syntax:

AboutImage = 10172
AboutIMPICT = 10000
AddingCallout#example = 10236
AddingCursorsandDazzle = 10230
AddingDropShadow = 10167
AddingLensObject#example = 10234
AddingLinesandArrow = 10229
AddingMoreBitmap = 10225

Alternative map file syntax:

When you are exporting map files  with the context tool you can also generate your

own alternative syntax using the following variables:

<%TOPICID%> The topic ID of the topic being exported

<%ANCHORID%> The anchor ID of the anchor being exported

<%TOPIC_HELPCONTEXT%
>

The help context number

Just select the Custom option in the export dialog to configure your own map file with

these variables. You can place any text characters you need between the variables, they

will be exported as-is. 

1241
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Restrictions of map files:

Using map files to apply help context numbers to existing topics is very straightforward.

However, there are two basic restrictions when you are using map files to generate topics

that do not yet exist in your help project:

You cannot generate topic captions

Since the map file syntax only includes the topic ID and the help context number you can-

not include captions (i.e. the names of the topics in the TOC) for the topics in the map file

and you cannot use the map file to generate captions. All topics generated from map files

use the topic ID as the caption.

You can only generate topics without TOC entries

This second restriction follows from the first. Since auto-generated topics cannot have

captions they are always generated without TOC entries, as topic files in the Topic Files

section of the Project Explorer. 

This is generally not a problem since the primary purpose of this function is to auto-gen-

erate field-level popup topics for documenting program components. If you need to use

the function to generate topics in the TOC you must create TOC items  for them manu-

ally after importing them. 

You cannot assign context numbers to anchors

Help+Manual's context tool can export the information about anchor links to map files

but you cannot import context numbers to existing or new anchors from a map file. 

See also:
Auto-generating context-sensitive topics

The Help Context Tool

Using Context-Sensitive Help

11.8 Project Structure & Templates

This section includes some background information about the structure of your projects and

some of the features that are important in help files and WebHelp output. Studying this sec-

tion will give you a better understanding of these formats. 

11.8.1 Topic IDs, Context Numbers and Keywords

Topic IDs, context numbers and keywords are grouped together in this chapter because they

are all used for locating things in your help files. 
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Topic IDs and context numbers are used as the "addresses" of topics, both for links within

your help files and for context-sensitive calls to your help file from applications. 

Keywords are used for generating index entries, which are also hyperlinks to topics in elec-

tronic help files. In addition to this there are also special keywords called "A-keywords" can

also be used to create other kinds of links, including See Also... links to related topics and

links between different help files.

11.8.1.1 About topic IDs and anchors

Topic IDs:

Every topic in your help project has a unique alphanumeric topic ID, which you can view

by clicking on the topic's  tab above the editor pane. The topic ID is required because it is

the unique identifier of each topic. Without the topic ID neither Help+Manual nor any

electronic help system can find the topic.

Internally, Help+Manual uses the Topic IDs as the "addresses" for accessing topics within

your help while you are working. In addition to this they are also used as the addresses for

calls to topics in your help from applications, both on their own and in combination with

help context numbers . 

For information on making these calls to different help formats see the documentation of

your programming language and the tutorials for programmers available on the EC

Software website. 

Topic ID properties:

Maximum topic ID

length:

Topic IDs can be up to 255 characters long.

Permitted charac-

ters:

Topic IDs are computer-readable addresses and are used as the file

names of HTML topic files in HTML-based formats. Because of this,

it is advisable to only use a..z, A..Z, 0..9, the underline character _

and the $ character in topic IDs. 

This is actually stricter than necessary, but following this rule will

ensure that you do not experience problems later, particularly in

HTML-based publishing formats.

Forbidden charac-

ters:

Spaces and a number of special characters like (\  / : * ? # = + % !

@ [ ] > " | , < > &') are explicitly forbidden in topic IDs and

Help+Manual will display a warning message if you try to enter

them.
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Changing topic IDs:

Help+Manual allows you to edit topic IDs at any time. All internal links within your project
are updated automatically when you do this. However, remember that changing topic IDs
may break links from other projects and calls to the topics from applications. 

· For more information see Topic IDs and context numbers .

Topic IDs and HTML output files:

Topic IDs are used as the names of the HTML files generated for your topics by

Help+Manual. In HTML-based output formats, links and calls to topics simply access the

HTML files containing the topics.

This applies both for the visible files generated in WebHelp and the "internal" files used in
HTML Help (here the HTML topic files are hidden inside the CHM help file, as though they
were inside a directory).

In both cases the file name is created by converting the topic ID to all lower case
characters and adding the file extension. In HTML Help this extension is always .htm. In

WebHelp the default is also .htm but you can change this in Project Explorer > Config-

uration > Publishing Options > WebHelp > HTML Export Options .

Anchors:

Anchors are named "jump targets" that you can insert in your topics so that you can cre-

ate links to specific locations within topics. They can be used both for hyperlinks within

your help project and for calls to your help topics made from application programs. 

Anchors are entered with the  Anchor Tool in Write > Insert Object. The anchors

stored in each topic are listed in the topic's tab in the Anchor: list. This list always contains

at least one anchor called (Top of Page), which is the standard jump target for links

without anchors.

· For details see Anchors - jump targets .

Maximum anchor

ID length:

Anchor IDs can be up to 256 characters long.

Permitted charac-

ters:

Spaces and a number of special characters like (\  / : * ? # = + % !

@ [ ] > " | , < > &') are not permitted in anchor IDs and

Help+Manual will display a warning message if you try to enter

them. In addition to this, however, it is actually advisable only use
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a..z, A..Z, 0..9, the underline character _ and the $ character in an-

chor IDs.

This will ensure that you do not experience problems later, particu-

larly in HTML-based publishing formats. Most browsers only sup-

port plain ASCII filenames and anchor names. 

Where not suppor-

ted:

Links to anchors are not supported in external windows  in HTML

Help.

Anchors with context numbers and keywords

Help+Manual allows you to assign both help context numbers and keywords to anchors.
This makes it possible to make help calls to anchors from application programs and to
create index entries that take the user to a specific location in a topic instead of to the top
of the topic containing the keyword.

· For details see Topic IDs and context numbers  and Using keywords with anchors
. 

Syntax for browser links to anchors in topics

You can create ordinary links from web pages to anchors in your WebHelp topic pages.
However, the syntax for these links is slightly different from the standard HTML syntax for
linking to anchors:

index.html?topicname.htm#anchorname

· See Anchors - jump targets  for details.

See also:

Topic IDs and context numbers

Anchors - jump targets

11.8.1.2 About help context numbers

Help context numbers are a second unique numeric identifier for each topic (the first and

main identifier is the topic ID ). Unlike topic IDs context numbers are optional. You can use

them if you want, but you don't have to. 

Introduction:

Like topic IDs, context numbers can be viewed and edited in the Topic Options tab on the

left of the main editor window. They are displayed in the Help Context Number: field. You

can enter and edit them there, but they can also be assigned automatically. See Topic IDs

and context numbers  for details.
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Help context numbers were originally introduced with the now obsolete Winhelp format

as the main way of making application calls to help topics, and they are still supported in

HTML Help CHM files. Many programmers and programming languages still use them but

they have actually become less popular in recent years. Since they are numeric only they

are not very "human-friendly" and it is quite easy for a programmer to make a call to the

wrong help context number and not notice it. 

Most modern programming languages can make calls directly to topic IDs  in HTML

Help without using context numbers at all, and this is now the preferred method. Topic

IDs are alphanumeric and can be up to 255 characters long, which means that they can be

descriptive and human-readable, which significantly reduces errors. 

Help context number range:

Help context numbers are stored as unsigned 4-byte integers. This means you can enter

values between 1 and 4294967295. This gives you nearly 4.3 billion unique numbers. If

you have a project that requires more context numbers than this we would love to meet

you and buy you a beer.

Context number are generally for HTML Help only:

Help context numbers are a Microsoft help technology and since the demise of Winhelp

they are only used for application calls to HTML Help. They are not used for internal hy-

perlinks within your help project and are generally irrelevant in other output formats. 

Support for context numbers in WebHelp URLs

However, Help+Manual does support the use of context numbers in URLs used as context

references to WebHelp topics. You wouldn't want to use this as your primary reference

method for WebHelp – normal topic IDs are human-readable easier to implement without

errors – but this support may be useful if you are already using context numbers in CHM

and want to use the same references for your WebHelp documentation. See here  for

details.

Context numbers in anchors:

In addition to context numbers in topics Help+Manual also allows you to assign help con-

text numbers to anchors . This makes it possible to make direct context number applic-

ation help calls to defined points within topics instead of just opening the topic at the

top. 
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Compatibility and call syntax:

Help+Manual's HTML Help output is generated directly by the Microsoft HTML Help com-

piler and is 100% compatible with HTML Help standards. This also includes the format and

syntax of the help context numbers. If your project contains help context numbers you can

make calls to them with the standard syntax of the HTML Help API. 

For details on making calls to help context numbers see the documentation included with

the Microsoft HTML Help Workshop compiler package. In addition to this you can also

find some useful tutorials for programmerson the EC Software website that explain how

to interface to HTML Help with range of common programming languages. If you use

.NET languages see the  Guide to CHM Help in .NET on the excellent Helpware site. 

See also:
Topic IDs and context numbers

11.8.1.3 About index keywords

Index keywords are a list of words associated with a topic that are used to generate the

keyword indexes in  the output formats that support them. Keywords are entered and viewed

in the Keywords: field of each topic's tab. In addition to this you can also view and manage

the resulting index interactively by right-clicking in the Index tab in the Table of Contents / In-

dex pane. 

· See Keywords and Indexes  for details on using these features.

Keywords and sub-keywords:

Keywords can have sub-keywords, which are also described as child keywords. This is a

standard feature of all indexes in both printed and electronic form. For example, an entry

called Indexes might have the following kind of child keywords:

Indexes
about
editing
editing, in teams
organizing
problems

One level of sub-keywords only:

Indexes cannot have more than one level of sub-keywords. This is a restriction of the out-

put formats, not of Help+Manual. All the supported output formats only have one level of

sub-keywords and Help+Manual is thus also limited to one level.
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Choosing relevant keywords:

Producing a good index is not a process that can be automated. It is an art, not a science,

and needs to be done manually. There is simply no alternative to the selection of indi-

vidual relevant keywords in each topic by the author. For example, an index including all

occurrences of all the words in your help would be worse than useless, because it would

make it impossible to find anything relevant. You need to examine each topic individually

and make individual decisions whether a word merits being added to the index or not. 

It may be relevant to list every single reference to an author's name, for the sake of com-

pleteness. However, in a help file you will not want to list every single reference to most

subjects. For example, index entries that refer to passing mentions in introductory

chapters will simply waste the user's time. When users click on an index entry they want to

find information that they can use, and that should be the criterion for including a term in

the index.

See also:

Keywords and Indexes

11.8.1.4 About A-Keywords

A-keywords, which are also referred to as "associative keywords" (that's what the A stands for)

or "A-link keywords", are quite a mystery to many help authors. They are actually not as com-

plicated as many people believe, but they tend to get neglected because most people believe

they are too difficult to understand or use.

A-keywords are available in HTML Help CHM files only

A-keywords are a proprietary Microsoft technology that is only supported in the Microsoft

HTML Help CHM format. They used to be supported in the Winhelp HLP format as well,

but that is now obsolete and no longer used. You cannot use A-keywords in any other

format. 

Introduction to A-keywords

The following brief list describes the main features and capabilities of A-keywords.  First

and foremost it is important to understand that A-keywords are a Microsoft help techno-

logy that is only available in HTML Help. Their functionality is not available in any other

output format. 
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A-keywords are invisible

A-keywords are similar to ordinary index keywords ("K-keywords" or "K-link keywords")

but they are never seen by the user. This might seem strange at first – what good is a

keyword that nobody can see? That brings us to the purpose of A-keywords:

A-keywords are used for "associative" linking

A-keywords are not used for indexes, they are used for creating "associative" links. When

an A-keyword is accessed it returns a list of links to all the topics in the help that contain

that keyword. We say that the topics are "associated" with the keyword.

These links are not pre-defined by the help author, they are generated actively when the

user views the help. When the user clicks on a special hyperlink that access an A-keyword

the help viewer searches all the topics in the help to see whether they contain the

keyword, including all topics in external help files in modular help systems .

This makes it possible to use them to generate lists of links to "relevant" topics. To add a

topic to the list you just need to include the relevant A-keyword in its Topic Options, in

the A-Keywords section.

A-keywords are "soft" and "conditional"

This means that you don't have to "hard code" links to specific topic addresses. Only links

to topics containing the A-keyword (or keywords) at runtime are displayed. This means

you can create links to topics that may or may not be present when the user views the

help, which usually only happens in modular help systems.

A-keywords have their limitations

All this being said, A-keywords do have their drawbacks. They are extremely useful for cre-

ating links to external help files in modular projects. However, as you will discover yourself

when you try, it is a lot of work to use them to create genuinely meaningful "See also"

lists. 

The problem is that the inclusion of a simple keyword is too mechanical to be able to

provide a real basis for relevance in all but the most simple and technical texts. Also, man-

aging your A-keywords and their relevance is actually much more difficult than simply de-

ciding yourself which topics are really relevant to the current topic. You will either end up

overwhelming the user with too many links that are not really relevant, or you will miss the

relevant links.
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More information about A-keywords

If you are interested in more background information about the technology and uses of

A-keywords the best place to start is the website  http://www.helpware.net. Be warned,

however, that the information provided there will be easiest to understand if you have ex-

perience with developing HTML Help and Winhelp Note that Windows Vista does not support Win-

help. If you want to be compatible with Vista you must transition to a different help format. files manually

with Microsoft's Help Workshop and HTML Help Workshop!

The main uses of A-keywords

There quite a few technical uses for A-keywords but the main purposes in normal help

files are for automated generation of "See also" lists and for links between separate help

files in modular help systems .

"See also" lists:

You can use A-keywords to create "See Also" links that automatically display link lists of

related topics when the user clicks on them. The list includes all topics found containing

the A-keywords specified in the A-link macro definition. These links work in both indi-

vidual help files and modular help systems  consisting of multiple help files.

One of the most interesting features of this function is that you don't have to specify

which help files you want to look in. The help viewer will automatically search all available

help files that are part of the modular help system for the A-keyword. This means that it

will automatically include topics from modules that are available from the list and exclude

topics from modules that are not available.

See Using A-Keywords  for details on how to make your own "See also" lists.

Links between help modules:

You can also A-keywords to create links between modular help files . The advantage of

this method is that if the target file is not available at runtime the link is not dead. Instead,

the user sees an alternative topic from the current help file. If the target file is available the

user sees a dialog in which he or she can choose the topic from the target file or the al-

ternative topic.

See Using A-keywords  for details on how to make associative links between help mod-

ules.

See also:
Keywords and Indexes

Using A-keywords
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11.8.2 Help Windows in HTML Help

The Microsoft HTML Help format uses sets of definitions referred to as "help windows" to

configure the help viewers used to display CHM files. Help window definitions can also be

used to display individual topics in external windows when you link to them.

Help window definitions are only relevant for HTML Help output. Their settings are ignored in

all other output formats. 

Help windows in Help+Manual

In Help+Manual help window definitions are stored with your projects. Each project has its

own set of help window definitions, which you can view, edit and add to in the Project Ex-

plorer in Configuration > Microsoft HTML Help > Help Windows.

Secondary windows

By default there is only one help window called Main, which defines the configuration of

the main help viewer for HTML Help.

You can define additional "secondary" help windows are used to display topics in external

help viewer windows when you link to them. You do this by selecting the name of the sec-

ondary window in the Insert Hyperlink dialog, in the Window: field.

This is the only use for secondary windows, they have no other purpose and they are only

relevant in HTML Help.

See also:
Help Windows settings

Using help windows

External windows and invisible topics

11.8.2.1 External windows in HTML Help

In HTML Help you can use additional or "secondary" help window definitions to display topics

in external windows. An external window is a full-featured help viewer window that is dis-

played separately from the main help window. In a way, external windows are like popups, but

they have all the features of the main help viewer.

External windows are only supported in HTML Help and can only be activated by specifying a

secondary help window in the definition of a hyperlink to the topic you want to open in an ex-

ternal window.

External windows in HTML Help

In HTML Help you must activate secondary windows to be able to display external win-

dows. This is a global setting – when you activate it all links to topics specifying a second-
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ary window will be displayed in external windows. The appearance and features of the ex-

ternal window are defined by the HTML Help Options settings in Configuration > Mi-

crosoft HTML Help > Help Windows. 

Note that in HTML Help using a secondary window in a hyperlink does not change the

background colors or the topic template, which are controlled by the topic's HTML page

template,  not by the help window. The buttons, controls, window position and size

from the secondary help window definition are all used, however. 

· To display an external window with different background colors in HTML Help you must

define the topic file itself with an HTML page template that has different background

colors.

Secondary windows cannot be used in the TOC

It is not possible to create topics in the TOC that automatically open in external windows

when you click on them. You can only activate secondary windows by specifying the win-

dow type in a hyperlink definition.

See also:
Help Windows settings

Using secondary windows

11.8.2.2 Help windows in HTML Help

In HTML Help the Main help window definition defines the buttons and other features of the

main help viewer window. The size and position settings are only used the first time the user

opens the help – after that Windows stores the user' settings and uses those the next time the

help is opened.

Secondary help windows can be used in HTML Help to display topics in external windows with

hyperlinks. This is a global setting (see below) – if you turn it on all topics associated with sec-

ondary windows will be displayed in external windows.

About help windows in HTML help:

Level of control: The definition of the Main help window controls the entire appear-

ance of the HTML Help viewer and the controls it contains. 

The size and position settings are only used the first time the user

opens the help – after that Windows stores the user' settings and

uses those the next time the help is opened.

Secondary win-

dows:

Hyperlinks to topics specifying secondary windows can display the

topic in an external window if this feature is activated in the HTML
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Help Options in Configuration > Microsoft HTML Help > Help

Windows. 

If this feature is not activated the Window: option in the Insert

Hyperlink dialog will simply be ignored.

Popups: Help window settings are irrelevant for popup topics. Popup topic

files are defined by selecting "Popup" as the Topic Class, either

when defining the topic or in the tab.

See also:
Help Windows settings

Using help windows

Creating popup topics

11.8.3 HTML Templates

Help+Manual uses editable HTML files referred to as "templates" to define the basic layout of

your topic pages in your published output. There are templates for your topic pages that are

used for all HTML-based output formats and additional templates that are only used for We-

bHelp output, which are used to define the overall layout (frameset) and the Table of Con-

tents, Search and Index panes in the WebHelp help system generated by Help+Manual.

If you are using an HTML skin you must edit your templates and settings

in the skin!

Nowadays you will almost always choose an HTML skin  to publish your project to We-

bHelp or HTML Help/CHM. A skin is a special kind of Help+Manual project without topics

that only stores your HTML templates and all the settings relevant for HTML output to

these two formats. When you choose a skin, the templates and settings in the skin com-

pletely replace those in your project.

Normally, a skin is pre-designed and you don't need to change anything. However, if you

do want to change something, you must do all your editing in the .hmskin skin file. Edit-

ing in your Help+Manual project won't have any effect because those templates and set-

tings are not used.

To edit a skin, make a copy of the .hmskin skin file in your project folder and then open

it in Help+Manual by selecting .hmskin as the file type to open in the Open dialog. All

the templates and settings are in the same places as in a normal Help+Manual project. 

Exception: HTML Export Options

The HTML Export Options section is not stored in skins and needs to be edited in your pro-

ject.

1452
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HTML templates are not help windows!

HTML topic page templates and help windows  are completely separate. Help windows

are only relevant in HTML Help (CHM), where they are used to configure the help viewer

and for opening linked topics in external windows. 

HTML topic page templates can be assigned to individual topics in the Topic Options tab

on the left of the main editor window. Help windows cannot be assigned to individual

topics, you can only use them in hyperlinks. 

HTML topic page templates

These templates define the layout and appearance of your topic pages in all HTML-based

output formats, including the background colors of the topic and the topic header. 

By default there is one HTML topic page template called Default that is assigned to all

topics. You can edit this template and you can also define as many additional templates as

you like and assign them to individual topics, by selecting them in the HTML Page Tem-

plate: field in the Topic Options tab on the left of the main editor window.

The HTML topic page templates can be accessed in Configuration > HTML Page Tem-

plates in the Project Explorer. See Using HTML Templates  for more details.

How topic page templates work

If you are familiar with HTML, you will know that HTML pages consist of a number of

standard sections. The visible content of the page is stored between the <body> and

</body> tags. The general page definition and any additional functions (for  example the

page title, keywords, scripts, search engine information etc.) are stored in the other sec-

tions above and sometimes also below this main body section. 

When you publish your project to HTML-based output formats the HTML pages for your

topics are "assembled" from two components: The HTML page template is taken as the

framework and the content from the Help+Manual editor is inserted in this template

between the <body> and </body> tags. Individual content outside the body section is in-

serted with variables. The content of your topics is also inserted by a variable called <%
TOPIC_TEXT%>. 

Additional WebHelp templates

In addition to the HTML topic page templates there are also four additional HTML tem-

plates that are used to configure your WebHelp output. These templates define the layout

of the entire help (frameset) and the pages for the Table of Contents, Search and Index

panes in your WebHelp output.

1609
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These templates can be accessed in Configuration > Publishing Options > WebHelp in

the Project Explorer. Unlike the topic page templates, there is only one copy of each of

these WebHelp templates per project, you cannot define additional versions as you can

for HTML topic page templates. However, you can apply different versions to your output

with "skins". See Transforming your Output with Skins  for details and instructions.

See also:
Using HTML Templates

Templates in Help+Manual

Using help windows

11.8.3.1 Graphics in HTML templates

You can reference external graphics in HTML templates, using any graphics types supported

in HTML. This is generally JPG, GIF and PNG. 

Automatic identification and export of graphics files 

Graphics referenced in your templates with <img> tags and with background attributes in

<body> and <table> tags (see below) will be located and exported automatically if pos-

sible:

· Graphics listed in the project search path  will be found and exported automatically.

You do not need to enter path information in your templates for graphics files stored in

these locations. You do need to add your project directory to the project search path

explicitly if you have anything stored there directly, however.

· Graphics stored in other locations will be found and exported if you include the paths to

the files in your template code. These paths will be stripped from the code automatic-

ally when the project is published, where appropriate.

If you use other tags and/or store the files in one of the above locations you need to add

the files to your Baggage Files.  They will then be exported to your published output

automatically, irrespective of where and how they are referenced. 

See Graphics references in HTML templates  for instructions and more information.

How graphics references in your templates are processed:

When you publish your project to an HTML-based format Help+Manual parses the tem-

plate, resolves the file paths to graphics files if specified, copies the file to the destination

output directory and removes any path information from the file references. In the case of

HTML Help and Visual Studio Help the graphic is automatically integrated in the output

file. 

However, the parser only parses the three HTML tags and attributes listed below. No other

image references are processed automatically. 
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Supported HTML tags:

Graphics referenced using the tags and attributes shown below are identified automatic-

ally by Help+Manual and exported with your project when you publish to HTML-based

output formats. You do not need to do anything yourself to include them in your project.

If you reference graphics in your templates using other tags you should add them to the

Baggage Files  to make sure they are exported with your project. In particular, this also

includes the variant images for mouseover buttons as they are not referenced with the

tags listed below!

You should also add your graphics to the Baggage Files if they are not stored in the pro-

ject folder and you do not want to add the paths to the graphics in your template code.

Automatically

Parsed Tags

Supported Attributes

<body> Images referenced with the background="" attribute.

OR

Images referenced within the style="" attribute using the

syntax 

style="background: #FFFFFF url(image.jpg)" 

(this can be combined with other style elements, of course)

<img> Images referenced with the src="" attribute

<table> Images referenced with the background="" attribute

OR

Images referenced within the style="" attribute using the

syntax 

style="background: #FFFFFF url(image.jpg)" 

(this can be combined with other style elements, of course)

See also:
Using Baggage Files

Using HTML Templates

Editing HTML templates

Help Windows
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11.8.3.2 HTML Template Variables

You can use all global predefined variables  and user-defined variables  in HTML
templates . In addition to this you can also use the following special predefined variables,
which are only relevant in HTML templates.

Variables for use in topic page templates only:

These variables can only be used in topic page templates. They are valid in all HTML-

based output formats (HTML Help, WebHelp, Windows Exe and ePUB eBooks and Visual

Studio Help).

Variable Content and/or function of the variable

Note on HREF-Variables: All the HREF variables insert the local names of

the corresponding pages within the current dir-

ectory without any path information, e.g. top-

ic1name.htm, topic2name.htm and so on.

<%DOCCHARSET%> Inserts the correct character set information in

the meta tags at the beginning of the HTML out-

put pages. This variable is essential in all tem-

plates and should not be removed. If you do re-

move it you will get an error message from the

compiler.

<%DOCTYPE%> Inserts the correct DOCTYPE tag at the beginning

of the HTML output pages. This variable is essen-

tial in all templates and should normally not be

removed. If you do remove it you will get an er-

ror message from the compiler.

You can insert your own <DOCTYPE> declaration

in the template explicitly and if you do this no

error message will be displayed. However, it may

produce unexpected results. 

<%GA4ACCOUNT%> Filled with the value specified for the for your

new Google Analytics 4 (GA4) Google Analytics

account  (your tracking ID).

<%GAACCOUNT%> Filled with the value specified for the for your old

Universal Analytics Google Analytics account

(your tracking ID).

1561 919
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Variable Content and/or function of the variable

Note on HREF-Variables: All the HREF variables insert the local names of

the corresponding pages within the current dir-

ectory without any path information, e.g. top-

ic1name.htm, topic2name.htm and so on.

<%HM_LINKLIST_SIBLINGS%>
<%HM_LINKLIST_CHILDREN%>
<%HM_LINKLIST_ANCHORS%>

These variables can be used in the topic HTML

page template. They insert UL link lists:

SIBLINGS: All the siblings of the current topic.

CHILDREN: All the children of the current topic.

ANCHORS: Anchors in the current topic.

Not for use in V3 and V4 skins:

Note that you can't use these variables in the

page templates for Premium Pack V3 and V4

skins. Since topic content is loaded dynamically

in these skins, variables set in the template don't

change. 

<%HREF_CURRENT_PAGE%> Link address of the current page.

<%HREF_DEFAULT_PAGE%> Link address of the "Default" topic. This is used

for the standard Top navigation link in the topic

headers so that users can return to the default

topic in your project.

<%HREF_NEXT_PAGE%> Link address of the next topic.

<%HREF_PARENT_CHAPTER%> Link address of the parent topic (chapter). This

can be used as an alternative to <%

HREF_DEFAULT_PAGE%>.

If the parent is a chapter without text, this is the

link address of the parent's parent. If no valid

parent is available, the variable is the link address

of the default page.

<%HREF_PREVIOUS_PAGE%> Link address of the previous topic (used for Pre-

vious/Next buttons). 

<%STYLESHEET%> Inserts the reference to the CSS stylesheet con-
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Variable Content and/or function of the variable

Note on HREF-Variables: All the HREF variables insert the local names of

the corresponding pages within the current dir-

ectory without any path information, e.g. top-

ic1name.htm, topic2name.htm and so on.

taining all the styles information for your project.

This variable is essential in all templates and

should not be removed. If you do remove it you

will get an error message from the compiler.

<%TOPIC_AKEYWORDS%> Inserts all the A-keywords  of the current topic,

comma-separated.

<%TOPIC_BREADCRUMBS%> Generates a series of "breadcrumb trail" naviga-

tion links to topics above the current topic in the

TOC tree. This variable is empty in top-level top-

ics. In second-level topics and below the variable

generates a series of links in the format Link1 >

Link2 > Link3 ...

The current topic is not included in the series. If

you want to place the current topic title at the

end of the breadcrumb trail you can do so with

the HTML Template Variables variable (see

below).

The breadcrumb trail variable is empty in topics

in the Invisible Topics section.

This variable has a matching condition pair:

<IF_TOPIC_BREADCRUMBS> and

<IFNOT_TOPIC_BREADCRUMBS>. These condi-

tions can be used to only insert the trail where it

is relevant and to insert alternative content when

it is not relevant.

See here  for details on how to use this vari-

able.

<%TOPIC_HEADER%> Inserts the header of the current topic if it exists.

If the current topic has no header the value of

this variable is null. This can be different from the

579
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Variable Content and/or function of the variable

Note on HREF-Variables: All the HREF variables insert the local names of

the corresponding pages within the current dir-

ectory without any path information, e.g. top-

ic1name.htm, topic2name.htm and so on.

topic caption inserted with <%TOPIC_TITLE%>.

<%TOPIC_HEADER_TEXT%> Inserts the header of the current topic as plain

text. This is particularly useful if your project

headers are different from and longer than the

TOC captions, which is inserted with <%

TOPIC_TITLE%>.

This is used primarily for search engine optimiza-

tion, for which you would insert it in the de-

scription meta tag, like this:

<meta name="description" content="<%
TOPIC_HEADER_TEXT%>">

<%TOPIC_DESCRIPTION%>
<%TOPICMETA:DESCRIPTION%>

Inserts the text from the Description field in the

topic's Topic Options tab if you have entered a

description there. Otherwise it inserts the first

177 characters of the topic text, followed by an

ellipsis (...).

This can be used in combination with the "fea-

tured image" (see next row) to insert a "title" im-

age and a description for your topic in your tem-

plate.

In addition to this it can also be used to populate

the description meta tag for search engines like

this:

<meta name="description" content="<%
TOPIC_DESCRIPTION%>">

<%TOPICMETA:PICTURE%>
<%TOPIC_PICTURE%>

Returns the file name of the "featured image" for

the current topic, if one has been set in the

topic's Topic Options. Returns blank if no fea-

tured image has been set.
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Variable Content and/or function of the variable

Note on HREF-Variables: All the HREF variables insert the local names of

the corresponding pages within the current dir-

ectory without any path information, e.g. top-

ic1name.htm, topic2name.htm and so on.

<%TOPIC_KEYWORDS%> Inserts all the keywords  of the current topic,

comma-separated. Needless to say, this variable

is essential for the keyword index and shouldn't

be removed...

<%TOPIC_TEXT%> Inserts the body text of a topic, i.e. the entire

topic as edited and formatted in your project in

the Help+Manual editor. This is the most import-

ant variable. If you leave it out your topics will be

empty! 

<%TOPICTITLE%> Title text of the current topic. This is taken from

the Title Tag: field in the Topic Options tab

(on the left of the editor window) and is normally

the same as the TOC caption for the topic and

will change automatically when you edit the TOC

caption in the TOC. So this variable gives you the

TOC caption, unless you edit the Title Tag field 

Editing the Title Tag text in Topic Options:

Editing the Title Tag: field manually "un-

couples" this field from the TOC caption. The

variable then still returns the contents of the field

in Topic Options, so if you want to use it for the

TOC caption we recommend not editing the field

in Topic Options.

To "recouple" the Topic Options field with the

TOC caption, just edit either so that the texts are

both identical. This works the same as the coup-

ling between the TOC caption and the topic

header text.

Deprecated older version:

The older <\%TOPIC_TITLE%> version of this

variable is still supported and does not need to

565
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Variable Content and/or function of the variable

Note on HREF-Variables: All the HREF variables insert the local names of

the corresponding pages within the current dir-

ectory without any path information, e.g. top-

ic1name.htm, topic2name.htm and so on.

be changed in your projects. However, please al-

ways use the current <%TOPICTITLE%> version

now.

<%TOPIC_TITLE_PATH%> This variable is similar to the breadcrumbs vari-

able above but it delivers the breadcrumb trail as

a plain text string without any links. Unlike the

breadcrumbs variable it also includes the name

of the current topic, so it always delivers a full

trail.

The primary use of this variable is for search en-

gine optimization, for which you would insert it

in the <title> tag of your topic page template

instead of the normal <%TOPIC_TITLE%> vari-

able, like this:

<title><%TOPIC_TITLE_PATH%></title>

Modification for HTML Help:

If you also output to HTML Help you should use

conditional text to ensure that this variable is

only used in Browser Help, otherwise you will get

the full path as the topic name in your search

results in the HTML Help viewer. Do it like this:

<title><IF_HTML><%TOPIC_TITLE_PATH%
></IF_HTML><IF_CHM><%TOPIC_TITLE%
></IF_CHM></title>

<%TOPICID%> Returns the plain topic ID as written in the Topic

ID: field of , without any filename  extension and

without changing the ID text to lower case. This

can be used to add an ID reference in your meta

attributes in your web pages, for example:

<meta name="id" content="<%TOPICID%
>" />
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Variable Content and/or function of the variable

Note on HREF-Variables: All the HREF variables insert the local names of

the corresponding pages within the current dir-

ectory without any path information, e.g. top-

ic1name.htm, topic2name.htm and so on.

(This variable can also be used in normal topic

pages.)

<%XMLLANG%> Returns the project language code, e.g. en-us

for US English. 

Variables for use in WebHelp only:

All the remaining variables are only relevant in WebHelp  (HTML):

Variables for WebHelp 3 mode only:

In WebHelp 3 mode, the JavaScript files, graphics and video files and CSS files are all

saved in sub-folders of the main WebHelp folder. You can use these variables in your

HTML templates to automatically insert the relative paths to these folders. 

Variable Content and/or function of the variable

<%HM_RELPATH_JAVASCRIPT%> Returns the relative path to the JavaScript files

folder: 

./js/

<%HM_RELPATH_IMAGES%> Returns the relative path to the images and me-

dia files folder (video files are also stored here):

./images/

<%HM_RELPATH_CSS%> Returns the relative path to the CSS files folder:

./css/

1510



1622

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Reference

Global variables for all WebHelp templates:

Variable Content and/or function of the variable

<%HREF_CONTENT_PAGE%> Link address of the TOC page

<%HREF_INDEX_PAGE%> Link address of the keyword index-page

<%HREF_SEARCH_PAGE%> Link address of the full-text search page

<%HREF_TOP_PAGE%> Link address of the top frame (e.g. "index.html")

Variables for the Layout frameset template only:

Variable Content and/or function of the variable

<%HREF_CONTENT_PAGE_DYN%> Link address of the dynamic TOC page.

<%HREF_CONTENT_PAGE_STATIC%
> 

Link address of the static TOC page.

<%NAVIGATION_SCRIPT%> Inserts the navigation script required by the top

frame.

Variables for the Table of Contents template only:

Variable Content and/or function of the variable

<%TABLE_OF_CONTENTS%> Inserts the entire TOC in the page.

Variables for the Keyword Index template only:

Variable Content and/or function of the variable

<%KEYWORD_INDEX%> Inserts the entire keyword index in the page.
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Variables for the Search template only:

Variable Content and/or function of the variable

<%SEARCH_SCRIPT%> Inserts the full-text search script in the page.

See also:
Using Variables

Using HTML Templates

Editing HTML templates

Help Windows

11.8.3.3 HTML Template Output Conditions

You can use all of Help+Manual's standard conditional output options in HTML templates,

both your user-defined include options  and options based on the current output format. In

addition to this there are a few special conditional switches which are only for use in

Help+Manual's WebHelp output, because they are only relevant there. See the lists below for

details.

These conditions are like special HTML tags. They are used to enclose blocks of HTML code in

your template that you want to include in the output only if the condition is fulfilled. 

In HTML templates you can only use output format conditions for HTML-based output

formats (CHM, HTML, EBOOK and HXS). This is because these templates are only used for

HTML-based output – so <IF_PDF> would not have any meaning, for example. Note that the

EBOOK condition applies both for Windows Exe and ePUB eBooks. 

Conditions are stripped before publishing

All the condition tags are stripped from your code before actually generating the HTML

output. No proprietary tags are included in your output!

Conditional tags in templates are hard-wired to the output format

Conditional tags in HTML templates look very similar to the conditions you use for con-

tent in your project. However, there is one very important difference: In templates, the

true/false status of the conditions is hard-wired to the output format and cannot be

changed. 

In the Publish screen you can include content tagged for other output formats than the

one you are currently publishing to by activating the checkboxes for those formats manu-

ally. This has no effect on the conditional tags in your templates, however. This is very im-

portant, because in templates you will often want to exclude code that would cause errors
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in some output formats. If this wasn't the case, including content tagged for WebHelp in a

CHM file the Publish screen could cause serious errors if that also included template code

tagged exclusively for WebHelp in a CHM file. 

Combining conditions with AND and OR logic

You can combine conditions to achieve AND and OR logic if necessary. For AND you need

to nest two sets of conditons, for OR you combine the conditions in a single tag.

Nesting conditions for AND logic

If you only want to include content when multiple conditions are all true you need to nest

them like this:

<IF_HTML><IF_TOGGLES> ... </IF_TOGGLES></IF_HTML>

The above conditions will only include the content between the tags if the output format

is WebHelp and there are toggles on the current page.

Combining conditions for OR logic

If you want to include content if any one of multiple conditions is true you combine them

in a single tag separated by the | pipe character. 

Important: Note that this does not work with IFNOT conditions, only with IF conditions!

You can use this feature like this:

<IF_CHM|TOGGLES> ... </IF_CHM|TOGGLES>

The above condition will include the content between the tags if the current format is

CHM or if there are toggles on the page, or if both are the case. 

Predefined HTML template conditions:

In addition to the predefined conditions listed here you can also use your own user-

defined include options  as conditions in HTML templates. See Conditional output in

HTML templates  for details on how to use the conditions.

Conditions Function of the condition

<IF_CHM> True when you generate HTML Help/CHM. 

<IF_EBOOK> True for eWriter/Windows EXE eBooks (false for other

eBook types).

988
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Conditions Function of the condition

<IF_EPUB> True for ePUB and Kindle/Mobi eBooks (false for

eWriter Help).

<IF_FRAMES> True if WebHelp is exported with frames (a frame-

based format is selected in the Navigation  op-

tions). This could be used for entering a link from

topic pages to your TOC page when you select the No

Frames, No Scripts layout option, for example.

Only relevant for WebHelp.

<IF_GA4ACCOUNT> True if the setting for your new Google Analytics 4

(GA4) Google Analytics account  is not empty.

<IF_GAACCOUNT> True if the setting for your old Universal Analytics

Google Analytics account  is not empty.

<IF_HTML> True when you generate WebHelp (HTML)

<IF_HXS> True when you generate Visual Studio Help (2008 or

2010)

<IF_INDEX_PAGE> True if a keyword index is included in the output. For

example, you could use this to exclude a link to the

index page from the TOC page if the keyword index is

not included. Only relevant for WebHelp. 

<IF_NEXT_PAGE> True if a next page exists. Used to suppress or display

a grayed-out version of the Next button in the very

last topic. Can only be used in topic page templates.

<IF_PREVIOUS_PAGE> True if a previous page exists (the variable <%

HREF_PREVIOUS_PAGE%> is not empty). Used to

suppress or display a grayed-out version of the Pre-

vious navigation button in the very first topic. Can

only be used in topic page templates.

<IF_SEARCH_PAGE> True if full-text search is included in the output. For

example, you could use this to exclude a link to the

search page from the TOC or keyword index page if

the search function is turned off. Only relevant for

1420
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Conditions Function of the condition

WebHelp.

<IF_TOGGLES> True if the current topic contains one or more

toggles  (expanding text and images). Can only be

used in topic page templates.

<IF_TOPIC_BREADCRUMBS> True if the <%TOPIC_BREADCRUMBS%> variable is not

empty (see HTML template variables ). For ex-

ample, this variable is always empty in topics in the

Invisible Topics section and in top-level topics. Can

only be used in topic page templates.

<IF_TOPIC_HEADER> True if the current topic has a header and the header

is not empty (the variable <%TOPIC_HEADER%> is not

equal to ""). Can only be used in topic page tem-

plates. 

<IF_TOPIC_PICTURE> True if the current topic has a featured image associ-

ated with it. You can then use this to insert the image.

Can only be used in topic page templates.

<IF_XHTML> True if XHTML 1.1 output is activated in your HTML

Export Options.  You will generally only need this in

reusable skins, when the skin may be used for pro-

jects published with either normal HTML or XHTML. 

"IFNOT" versions negate the meaning of the conditions:

Exclude Conditions Function of the exclude condition

<IFNOT_CONDITIONNAME> Negates the positive version of the condition. Con-

tent between the condition tags is only inserted if the

condition is not true. Available for all conditions. 

See also:
User-defined include options

Using HTML Templates

Conditional output in HTML templates

Help Windows
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11.9 International Languages and Unicode

Help+Manual's project files are always encoded in Unicode, which means that you can de-

velop help projects in all languages, including Asian languages and other languages with

more than 255 characters that are supported under Windows. The only restriction is on right-

to-left languages like Arabic, Farsi and Hebrew. You can edit projects in RTL languages, but

you can only publish to HTML Help CHM and WebHelp. Other output formats are not suppor-

ted for RTL languages.

When you are working with languages requiring Unicode and some other languages requiring

special characters, including Eastern European languages, Greek and Turkish, it is important to

configure your project correctly to avoid problems in your published help files.

In addition to this there are also some important requirements for your Windows configura-

tion for Unicode-based languages, and you need to be aware of these before you start work

on a project in a language requiring Unicode.

The topics in this chapter provide some useful background information on handling interna-

tional languages that should make these issues easier to understand.

See also:
Language Settings  (Configuration Options)

International Language Setup

11.9.1 About H+M's Unicode support

This topic provides some important background information that will help you to understand

how to use Help+Manual with languages that cannot be edited or displayed properly without

Unicode. 

In addition to reading this section please also see International languages setup  and Lan-

guage Settings  for details on configuring your project output in the language you are us-

ing, both with Unicode-based languages and other languages.

Unicode support in Help+Manual's output formats:

Provided the other requirements listed below are met Help+Manual can output projects

written in Unicode-based languages to all its output formats.

Windows versions supporting Unicode:

Help+Manual requires XP, Vista, Windows 7 or later. You cannot run the program on Win-

dows 95, 98, ME and NT4 because these versions of Windows do not support Unicode.

Windows 2000 may work but it is not officially supported.

1403
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Windows language version requirements:

Although you can edit and publish projects on any language version of Windows that is

properly configured you can only test the published Unicode HTML Help properly on a

version of Windows with a matching language. 

For example, Chinese HTML Help can only be tested properly on a Chinese version of

Windows. You may be able to display the help, but things like full-text search and the in-

dex will not work correctly.

This means that ideally, a matching language version of Windows XP or later is required

for development of help in Unicode-based languages. You need a Chinese Windows to

develop Chinese help, Thai Windows to develop Thai help and so on.

Requirements for publishing projects:

The Microsoft help compiler for HTML Help (CHM files) is quite old and it does not sup-

port Unicode directly. This means that some special configuration settings in Windows are

required when you are publishing projects using Unicode-based languages like Chinese or

Thai to HTML Help. 

WebHelp, Windows Exe and ePUB eBooks, DOCX, Visual Studio

Help:

You can publish Unicode projects to these formats with any version of Windows XP or

later provided you have the necessary language support installed to display and edit the

language you are using. Help+Manual itself handles the Unicode output to WebHelp,

eBooks and MS Word DOCX, and the MS Help 2.0 compiler is fully Unicode-compliant.

HTML Help:

The HTML Help compiler does not support Unicode directly. (This is a restriction of the

compiler, not of Help+Manual). To be able to publish a project written in a Unicode-based

language to HTML Help the "system locale" of your version of Windows Windows XP or

later must be set to match the language you are using. This is necessary to enable the

HTML Help compiler to process the language correctly for Unicode output.

Changing the system locale

Note that the system locale and the user locale are different! Simply setting the display and/or

data entry language does not change the system locale!

1. Log in to a user account with administrator privileges. 

2. Open the Regional and Languages section in the Windows Control Panel.
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· Windows XP: Select your language as the default language for non-Unicode programs

in the Advanced tab (this tab is only displayed if you have administrator privileges!).

· Windows Vista and Windows 7: Select the Change System Locale button in the Admin-

istrative tab (this tab is only displayed if you have administrator privileges!).

3. Click on OK to apply the setting and then restart Windows.

Requirements for viewing Unicode-based help:

WebHelp, eBooks, MS Word DOCX:

You can view Unicode help in these formats with any version of Windows 95 or later

provided you have the necessary language support installed to display the language in

question. The browser and word processor used to display WebHelp and DOCX must be

Unicode-enabled, of course. The operating system must also be able to run the reader

software for ePUB – some readers may not run on very early versions of Windows. 

HTML Help:

You can display Unicode-based languages with any version of Windows XP or later

provided you have the necessary support installed to display the language you are using.

However, some features of the help, such as the full-text search and index, will only work

properly on Windows versions with a matching language.

Visual Studio Help:

Visual Studio Help is only supported on Windows Windows XP or later. However, it is fully

Unicode-compliant and will display properly with all features on any language version of

these versions of Windows provided they have support installed for the language of your

help file. Note that Visual Studio Help is only relevant for documenting programming

components in the Visual Studio .NET environment. It cannot be used for documenting

normal application programs.

See also:
International languages setup

Language Settings

11.9.2 About project language settings

The language settings for your project in Configuration > Common Properties > Language

Settings control how texts with international languages and character sets are handled in

your output. If you work in English or any other Western European language you should not

need to change the default settings, but in other languages you will need to adjust the set-

tings to avoid font display problems in your published output.

143
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Language of the Help File:

This sets the language code of your project. On its own this setting does not actually af-

fect how characters are displayed, it only identifies the language to the system and con-

trols how sorting is handled in the Keyword Index and everywhere else where sorting is

used. 

Setting for English and other Western European Languages:

The default setting is English (United States) and if you are using English or any

other Western European language you don't need to change this. In fact, it's better if you

don't because if you do you may experience a known problem in your HTML Help output:

On some users' computers the title bar of your help will sometimes display "HTML Help"

instead of the title of your help project. Setting this option to English (United

States) will prevent this problem.

Setting for other languages:

If you are using languages with special character sets or Unicode character sets like

Eastern European languages, Greek, Turkish, Chinese, Japanese or Thai you must change

this setting to the language you are using. In these languages this setting makes sure that

sorting works correctly. In addition to this it also identifies the language to the system so

that special characters and Unicode processing (if necessary) are handled correctly for the

language.

In addition to this you must also change the Font Character Set setting (see below)

to the correct character set for your language. In these languages both these settings

must set to the correct values for the language you are using for the language to be

handled properly in your output.

Bi-directional Language Mode:

This is used to switch Help+Manual's writing mode to right-to-left for languages like

Hebrew, Arabic and Farsi. The setting makes radical changes to the way Help+Manual op-

erates, switching the writing direction of the TOC and all text in both the program itself

and all output formats.

Don't change the default setting unless you are using one of these languages! Please also

note that right-to-left languages are only supported in HTML Help, you cannot publish

help in other formats in these languages.



1631

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Reference

Font character set:

This is the setting that really controls how international characters are displayed on the

user's computer, because it defines the character set containing the characters to be dis-

played.

Setting for English and other Western European Languages:

The default setting is ANSI_CHARSET and this character set contains all the characters re-

quired for English and all other Western European languages. If you are using any of these

languages you do not need to change this, and you shouldn't! For example, if you change

it to DEFAULT_CHARSET or any other value you may experience display problems with

special characters in your output.

Setting for other languages:

If you are using languages with special character sets or Unicode character sets like

Eastern European languages, Greek, Turkish, Chinese, Japanese or Thai you must set the

correct character set for the language you are using to ensure that all characters are

handled correctly in your output. 

In addition to this you must also change the Language of the Help File setting

(see above) to ensure correct sorting and to identify the language you are using to the

system. In all these languages both these settings must set to the correct values for the

language you are using to be handled properly in your output.

The Default Font setting:

This setting is only relevant for HTML Help (CHM). Despite its rather misleading name,

which was chosen by Microsoft, it does not set the default font for your entire project. It

only sets the font for the Table of Contents (TOC) and dialog boxes displayed in CHM files.

Setting for English and Western European languages

The default setting for this is MS Sans Serif,8,0 and the HTML Help viewer is de-

signed for the size of letters generated by this font at this setting. It is thus generally ad-

visable to leave the setting as it is for English and Western European languages. If you do

change it you should test your published help thoroughly on as many versions of Win-

dows as you can and with Windows set to both regular and large fonts to make sure that

everything fits.
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Languages with special character sets

It may be necessary to choose other fonts for languages with special character sets, in-

cluding Eastern European languages, Greek, Turkish and Asian languages. In these cases

you may need to experiment a little until you find a font that produces satisfactory res-

ults. 

You should always use a standard font included with Windows in these languages, how-

ever, otherwise the font may not be available on your users' systems when the help is dis-

played.

 See also:
Language Settings

International Languages Setup

11.9.3 Language settings and PDF

There are some additional settings that are relevant for PDF output when you are publishing

Unicode-based languages like Asian languages.

The Reference Printer Driver for PDF

In addition to the language settings in the Project Explorer in Configuration > Common

Properties > Language Settings, which apply to all output formats, font handling in PDF

and printed user manuals is also controlled by the reference printer driver that is used to

generate the PDF output. (Printed manuals are also generated using PDF.)

Problems with the reference driver used for generating PDF output can also result in in-

correct displays for special characters and international languages. However, if you experi-

ence issues like this first check the language settings of your project to make sure that

everything is set up correctly. If you still have problems in your PDF output after making

sure that your language settings are correct you can try using a different reference printer

driver. 

To set the reference printer driver for PDF output go to View > Program Options > PDF

Export. See  Program Options - PDF Export  for more details.

CID font embedding

The CID font embedding option enables more efficient embedding of Unicode fonts in

PDF files, particularly for Asian languages with very large character sets. You can set it  in

Configuration > Publishing Options > Adobe PDF > Font Embedding. See CID font em-

bedding for Unicode fonts  for more details on this.

See also:
Language Settings
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Program Options - PDF Export

PDF Font Embedding
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relevant sections of the help.
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12 Frequently Asked Questions

12.1 General questions

Which help format is the best?

There is no simple answer to this question. Each of the formats currently supported by

Help+Manual (eight including printed manuals) has its advantages and disadvantages. For

detailed information see Help Formats  in the Reference section.

How can I integrate my help files with my application?

Help+Manual creates 100% standards-conform help files. How published help files are integ-

rated with Windows applications depends on the development tool used for creating the ap-

plication.  You can download a collection of free tutorials for programmers from our website

describing how to integrate HTML Help with number of leading programming tools:

https://www.helpandmanual.com/support_tutorials.html

WebHelp can be integrated with your application with normal URLs. The syntax is explained in

Application links to WebHelp , along with examples.

Where can I get the Microsoft help compilers?

A free Microsoft help compiler is needed to generate HTML help CHM files. The HTML Help

Workshop compiler package can be freely downloaded from the Microsoft website.

However, since the compiler is quite hard to find on the Microsoft site and the location some-

times changes we provide a link to the correct version on our website:

https://www.helpandmanual.com/downloads_mscomp.html

Visual Studio Help 2008 compiler: 

The Visual Studio Help 2008 compiler for the HXS format is part of the Visual Studio Help In-

tegration Kit (VSIK) which can be downloaded from the Microsoft MSDN website. (Visual Stu-

dio Help 2010 does not require a compiler.) However, it is not  a standalone compiler, it can

only be used in combination with the Visual Studio .NET programming package. You don't

need it if you don't have this package. This format is only used for documenting Visual Studio

.NET components. It is not used for creating normal help for applications and you will not

need it unless you are a Visual Studio .NET programmer.

12.2 Publishing questions

I get a message saying topics have been "implicitly included"!

This is the result of a configuration option that prevents dead hyperlinks in your output. When

this option is used Help+Manual will automatically include topics referenced by active hyper-

links even if you exclude them from your output with conditional output controls.

1504
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There are a number of other options and methods for dealing with hyperlinks to excluded

topics. See Preventing dead links  for more information on all these options.

I get a message saying hyperlinks in my output have been deleted!

This is the result of a configuration option that prevents dead hyperlinks in your output. When

this option is used Help+Manual will automatically convert active hyperlinks to excluded top-

ics to plain text.

There are a number of other options and methods for dealing with hyperlinks to excluded

topics. See Preventing dead links  for more information on all these options.

I get a message saying the "help compiler" cannot be found!

HTML Help (CHM) compiler:

You need to install the free Microsoft HTML Help Workshop help compiler package to be able

to publish your project to the HTML Help (CHM) format. You can download this compiler

from this page on our website:

 https://www.helpandmanual.com/downloads_mscomp.html

After installing the compilers to View > Program Options > Compilers and check that the

paths to the compiler program is correct.

Kindle eBook compiler:

This is required for publishing Kindle/Mobi eBooks. See Amazon Kindle/Mobi eBooks  for

details on how to get and install the compiler for Help+Manual. 

Visual Studio Help compiler: 

The Visual Studio Help 2008 compiler for the HXS format is part of the Visual Studio Help In-

tegration Kit (VSIK) which can be downloaded from the Microsoft MSDN website. (Visual Stu-

dio Help 2010 does not require a compiler.) However, it is not  a standalone compiler, it can

only be used in combination with the Visual Studio .NET programming package. You don't

need it if you don't have this package. This format is only used for documenting Visual Studio

.NET components. It is not used for creating normal help for applications and you will not

need it unless you are a Visual Studio .NET programmer.

See also:
Publishing your Output

Conditions and Customized Output

12.3 Dynamic styles questions

My paragraph style is "stuck", applying a style doesn't seem to change it!

You have probably applied manual formatting to the paragraph. To apply a new style or re-

apply the original settings of the current style first select the entire paragraph, then apply the

style. If only part of the text in the paragraph is selected only font attributes are applied.
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Imported formatted text is always initially "manually formatted". You must apply styles to it to

bring it under the control of the Help+Manual styles system. For example, you can use Create

style from selection  to define and use new styles on the basis of your imported formatted

text.

I can't reformat a new empty paragraph. Applying a new style doesn't seem to
change anything.

A new paragraph must contain some text before you can apply a style correctly. Enter some

text first, then you will be able to apply the style.

Nothing happens when I apply a style to a list paragraph!

The indentation of bulleted and numbered lists is controlled by the first item in the list. You

can apply styles to the other items but the paragraph attributes will be ignored in all items ex-

cept the first list item. See Formatting lists  for more details.

See also:
Text Formatting and Styles

12.4 Editing questions

I'm trying to activate paragraph borders but no borders are being displayed!

You have to select a Border Style option in the Paragraph Border & Background  dialog.

The default setting is None and this does not display any borders.

Editing has become very slow and my .hmxz project file is much larger than I ex-
pected!

You probably have a large number of image objects embedded in the text. This can happen

when you copy and paste images and text together MS Word. This automatically inserts the

images as embedded OLE objects, which uses up a very large amount of memory and com-

puter resources. Inserting a large number of large OLE objects can also have the same effect,

particularly on older and slower computers with limited memory.

To solve this problem you can convert these embedded images into external graphics files.

Just right-click on the embedded images and select Convert Embedded Image in the popup

menu.

Identifying embedded images:

When you click on an embedded image it does not appear as a "negative" image. Normally-

inserted images appear as negatives with all their colors reversed when you click on them.

I'm having trouble copying paragraphs with the mouse – my copied paragraph
gets "combined" with the next paragraph!

You're probably used to working with a word processor like Word or Open Office.

Help+Manual's editor is a little different from these programs and it stores its paragraph

formatting in a different way. Because of this it's not possible to select the "paragraph mark"

at the end of each paragraph. 
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The best way to copy paragraphs "cleanly" is to press Enter once in the target location to cre-

ate an empty paragraph, then copy to the empty paragraph. After completing the copy you

can then delete any extra paragraphs without losing style information.

I sometimes experience unexpected small changes in indents and spacing when I
change paragraph and other formatting attributes!

Help+Manual calculates all dimensions in pixels internally. If you display your dimensions in

inches or another unit the values are converted from pixels and the results must often be

rounded. 

If you want to work with maximum precision choose pixels for all dimensions. You will get

used to it quite quickly and then you won't experience any rounding "surprises".

When I format lists in a single indented paragraph the indent disappears!

Technically lists need to contain at least two items (paragraphs) because the formatting of the

list is "controlled" by the first paragraph. You can solve this problem by selecting more than

one paragraph or the entire text of a single paragraph before selecting the bullet or number-

ing tool in the Toolbar. 

Alternatively you can also place the cursor at the very beginning of the paragraph (before the

first paragraph) before selecting the list tool, this will also work.

See also:
Writing and formatting text

12.5 HTML and HTML Help questions

My HTML Help CHM file doesn't work on a network drive – I just see error
messages instead of the topic pages!

Windows now imposes severe restrictions on accessing HTML Help CHM files on networks

and the Internet. File links will now generally not work at all and HTML Help itself is also

severely restricted. 

Without registry changes on the user's computer HTML Help now cannot be used at all on

networks. EC Software has produced a small free tool called HHReg to help with this problem,

which can be downloaded here:

HHReg CHM Utility

However, it is really better to use WebHelp for help on networks and on the Internet. These

registry changes must be made on every computer that needs to access the help, and al-

though HHReg can be integrated in your install process opening up these registry keys on

your users' computers does represent a security risk.

I entered tab stops or spaces to create indents but they don't work in any HTML-
based output formats!

Tab stops are unknown in HTML, it simply doesn't support them at all. Spaces also don't work

for indents in HTML because all groups of spaces are ignored and displayed as a single space.

223
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Help+Manual converts multiple spaces to alternating hard and soft spaces to solve this prob-

lem but this will still not be accurate for tabular data.

If you need to create accurate spacing to format code examples use indented paragraphs

(these are converted automatically in HTML-based output formats) or tables. You can use

multiple spaces for indenting in code examples if you turn word wrap off in the paragraph

settings – then all spaces will be non-breaking spaces, which will render correctly.

Also use tables to create tabulated lists in HTML-based output formats.

Search isn't working in my HTML Help CHM output, even though I enabled it in my
project configuration!

This is probably a Microsoft HTML Help Workshop installation problem. To correct this pro-

ceed as follows:

1. Uninstall MS HTML Help Workshop.

2. Download the latest version from our website at 

https://www.helpandmanual.com/downloads_mscomp.html

3. Log on to a Windows account with administrator rights (this is essential!) and install the

new version.

I can't activate search in my WebHelp output!

Full-text search for WebHelp is only supported in the Professional and Floating license ver-

sions of Help+Manual because a royalty-free license for the search indexing tool is required.

When publishing to WebHelp you should also make sure that your user account has full read-

write access permissions to the Help+Manual program directory. Not having write access here

can sometimes cause generation of the search index to fail.

I want to change the Top / Previous / Next navigation texts in the topic headers
of my output!

You can change these texts and also select graphics files to use as buttons instead of the

texts. In the Project Explorer select the Default template in Configuration > HTML Page Tem-

plates to change these texts.

If you want to get more fancy and do things like adding buttons with mouseover effects you

will need to edit the HTML code of the template yourself. See Using HTML Templates  for

more information on editing HTML templates.

How can I change the title of the help viewer window?

By default the title bar of the help viewer displays the Project Title entered in Configuration >

Common Properties > Title & Copyright . 

This text is inserted in the help window title by inserting the <%TITLE%> variable in the help

window definition. This makes it possible to define different titles to be displayed when topics

are displayed in external windows using different help window definitions:

1026
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Go to Configuration > Common Properties > Help Windows . Select the Main help win-

dow type and check the Title bar text: field. If you insert <%TITLE%> here it will insert the

topic title, but you can enter any text you like.

Note that if a different title is assigned to the current help window this has priority over the Help

Title entered in the Title & Copyright section. The help window title will then be displayed

in the help viewer title bar when a topic using the corresponding window type is displayed.

I entered the title correctly but the help viewer of my CHM file always has the title
"HTML Help"!

This is a bug in the Microsoft HTML Help viewer. Non-English HTML Help files always display

"HTML Help" in the title bar when they are displayed by Windows versions with a different

language from the language of the help file. Only the titles of English help files are displayed

correctly on all language versions of Windows.

The only known solution is to set the Language of the help file in Configuration > Common

Properties > Language Settings to English (United States) if this is possible for your help pro-

ject. (This is generally possible for all western European languages without special character

sets.)

See About project language settings  for more details.

The names of my image files are displayed as tooltips in my HTML-based output
formats!

In the Project Explorer go to Configuration > Publishing Options > HTML Help > HTML Ex-

port Options  and deselect the option If an image has no caption export file name as hint

(ALT tag).

Note that these are shared options. They can also be accessed in the WebHelp and Visual

Studio Help sections.

The popups in my HTML Help output are only plain text, although I included bold
and other formatting in my popup topics!

By default, HTML Help only supports plain-text popups without any formatting. Help+Manual

provides another solution for formatted popups in HTML Help. See Creating popup topics

for details

Can I view and edit the HTML Help source files?

Help+Manual generates all the files needed for viewing and editing HTML Help projects with

the MS HTML Help Workshop application. However, these files are normally deleted automat-

ically after publishing. 

To prevent this deselect the option Delete temporary files after compilation in the Publish

dialog when you publish your project to HTML Help. You will then find all the project files in

the \~tmpchm folder in your project directory (the directory containing your project file).

I want to use my own custom icons in the HTML Help TOC!

Help+Manual includes 42 predefined icons that can be used in the HTML Help TOC by select-

ing Project > Manage Topics > Change > Icon. These icons are predefined by HTML Help

and they are the only ones that are available. Although the Microsoft HTML Help Workshop
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documentation suggests that these default icons can be replaced by a custom icon strip this

feature has never actually worked in HTML Help. Please complain to Microsoft. Loudly.

My help file fails or crashes if it is installed in a path containing a # character!

This is a restriction of HTML Help that cannot be changed. The # character is reserved for

bookmark (anchor) references from URLs and cannot be used in the paths. The only solution

is to make sure that there are no # characters in the paths to your help files.

I would like to call a HTML Help CHM file from the command line!

Just execute the hh.exe HTML Help viewer with the name of the help file as the first para-

meter:

HH "myhelp.chm"

HH.exe is the HTML Help executable. It is located in the Windows directory does not require

a path.

Examples:

Note that topic names are referenced as Topic ID + .htm in all lower case characters. (The

standard extension is .htm but this can be changed in Configuration > Publishing Options >

HTML Help > HTML Export Options .)

HH "myhelp.chm::/requestedtopic.htm"

Opens the file myhelp.chm and displays the topic requestedtopic.htm. The "::/" in the para-

meter separates the requested topic (the html file name in the internal structure of the .chm

file).

HH "myhelp.chm::/requestedtopic.htm#paragraph2"

Opens the file myhelp.chm and displays the topic requestedtopic.htm and jumps to the topic

anchor paragraph2.

HH -mapid 123456 myhelp.chm

Opens the file myhelp.chm and displays a topic referring to its help context number.

Our programmers need a list of help context numbers!

Select Context Tool in the Tools tab and then select the option Export Map File. This exports

the Topic IDs and corresponding context numbers to a standard map file. See The Help Con-

text Tool  for full instructions.

See also:
HTML Help  (Help Formats)

12.6 PDF questions

The formatting of topic headings in my PDFs doesn't match what I see in the
H+M editor!
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This is normal. Although all the formatting of your topic content is preserved in PDF only the

text of your topic headers is used in your PDF documents. In PDF the formatting of your topic

headers and the layout of your pages are controlled by the "print manual template" for your

PDF output. See Topic headings in PDF  for details.

My PDF files seem to be too big. What could be causing this?

There are a number of possible causes for this:

· Graphics scaling: The first thing to check is the images used in your files. Help+Manual

supports image scaling  of high-resolution images for PDF files. If you are using large im-

ages to improve printout quality your files will be bigger and there is not a lot you can do

about it, other than turning off scaling and using smaller images.

· Graphics compression: Check your image compression settings for PDF in Configuration >

Publishing  Options > Adobe PDF > PDF Options . You can significantly reduce the size

of your files with JPEG compression but this also reduces image quality.

· Font embedding: Embedded fonts significantly increase the size of PDF files. Unless it's ab-

solutely  essential only use standard fonts like Arial and Times Roman so that you don't

have to embed fonts. Check your embedding settings in Configuration > Publishing Op-

tions > Adobe PDF > Font Embedding .

· Graphics in your PDF template: If you insert very large graphics in your PDF templates

this will also increase the size of your PDF. Check all the template sections for forgotten

graphics, including graphics objects whose size has accidentally been made very small –

they will still be exported to the PDF!

Note that the nominal image format doesn't affect the size of your PDF files. All supported

formats are converted to bitmaps.

Where are the settings for activating/deactivating PDF pages?

If you are upgrading from Help+Manual 3 you may be looking for the project configuration

settings that activate and deactivate PDF components (TOC, Introduction etc.) in your output.

This functionality is now only available in the print manual template , which you must edit

with the Print Manual Designer . In Help+Manual 3 it was possible to make these settings in

two places (project configuration and the template), and this caused conflicts and mistakes for

some users.

I configured my template to start chapters on odd pages but all my chapters are
starting on the next available page, no matter whether the page is odd or even!

Go to Configuration > Publishing Options > Adobe PDF > PDF Layout  and deselect the

option Ignore blank pages in PDF file. Setting this option disables the "Start on odd pages"

setting because it makes it impossible to insert blank pages in the output to force topics to

start on odd pages.

Graphics in tables extend beyond the edge of the page in PDF output!

When you place graphics on the page without tables they are automatically resized to fit on

the page in PDF. This is not possible for graphics in tables, however, because here the table
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cell and not the page is the container for the graphic. When you insert graphics in tables you

need to make sure that your layout will fit on the page. In addition to graphics clipping over-

sized graphics in tables will also switch all column widths to variable in PDF, which will prob-

ably mess up your layout. 

The text in my PDF output looks strange or garbled!

Help+Manual uses a printer driver to generate PDF documents and "optimized" drivers from

printer manufacturers sometimes cause output problems. 

You can solve this problem by installing a different printer driver and selecting it as the refer-

ence driver for PDF generation. This driver does not have to be for a printer that is physically

connected to your computer. In fact, you will probably achieve the best results with a stand-

ard printer driver from the Windows CD rather than with an "optimized" driver from a printer

manufacturer.

If you are not using WMF or EMF graphics it is generally best to use the screen device to gen-

erate PDFs. A proper printer driver is needed to mange EMF and WMF graphics, however.

See Customize - PDF Export  for details on how to set this up.

I created a PDF with active hyperlinks but the links are invisible!

Go to Configuration > Publishing Options > Adobe PDF > PDF Layout and activate the Un-

derline topic links and paint in color: option to define the visibility and color of the hyperlinks

in your PDF document.

For more details see PDF Layout . 

My hyperlinks to topics in other projects don't work in PDF!

PDF is really a print-style documentation format that was not originally designed for use as in-

teractive help. Hyperlinks within PDF files will now work but you cannot link between PDF

files. 

You can link to external PDF files with file links,  provided the external PDF is in the same

folder as the PDF containing the link, but this will only open the PDF file. You cannot link to a

specific topic inside an external PDF file.

See also:
Adobe PDF  (Help Formats)

12.7 Printing questions

The page referrer numbers aren't shown in my print preview!

This is not an error. Page referrers (cross references with page numbers for hyperlinks) can

only be displayed in the actual printout.

The text in my printed manuals looks strange or garbled!

When you print a user manual Help+Manual first generates a PDF file and then prints it. The

PDF is generated using a printer driver and "optimized" drivers from printer manufacturers

can sometimes cause output problems. The printer driver used to generate the PDF is nor-

1271
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mally your default printer driver but it is possible to select a different driver for PDF genera-

tion if necessary.

You can generally solve this problem by installing a different printer driver and selecting it as

the reference driver for PDF generation. This driver does not have to be for a printer that is

physically connected to your computer. In fact, you will probably achieve the best results with

a standard printer driver from the Windows CD rather than with an "optimized" driver from a

printer manufacturer.

See Customize - PDF Export  for details on how to set this up.

See also:
PDF and Printed Manuals

Customize - PDF Export

12.8 Searching in WebHelp

How does searching work in WebHelp?

After you publish your WebHelp project the indexer scans all the files found in the HTML out-

put directory and creates an index file. This index contains a list of all the words found and

their locations in the files in your project.

When the user accesses the search function for the first time the index file is downloaded by

the user's browser. All subsequent searches during the current session then access this local

copy on the user's computer. 

My index includes references to additional files that I added to my output direct-
ory manually! Huh??

It's important to understand that the indexer scans all the files in your output directory! This

means if you add your own files to the directory before you publish they will be scanned too. 

If you don't want your own files to be included in the index you must add them to the output

directory after you publish your project – or upload them to your server separately so that

they cannot be indexed when you publish.

My index includes references to deleted topics! What's happening?

Normally Help+Manual doesn't delete anything in your HTML output directory. Since every

topic is a separate HTML file in WebHelp the files for deleted topics are still in the output dir-

ectory when you publish a new version of the project that no longer contains these topics.

To prevent this it's a good idea to use the Delete all files in output folder function in the Pub-

lish dialog when you publish a build for distribution. See Publishing  for more details on

this.

Why can't I search for phrases in WebHelp?

Actually, you can. However, to do this you need to set up your search platform to use server-

side searching based on either the PHP or ASP platform. This requires support for PHP or ASP

on your server and can't be tested locally, because it is a server-only technology. 

1271
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By default, WebHelp is generated using the client-side JavaScript platform, which is fine for

smaller projects. However, for larger projects and features like phrasal searching it is better to

use the PHP or ASP platforms.

See this topic  for instructions.

How can I search for exact words and phrases in WebHelp?

JavaScript platform:

Enclosing one or more words in quotes searches for exact words if you are using the

JavaScript search platform. For example, entering cat will find cat, catalog and advocate,

but entering "cat" with quotes will only find cat. This also works for groups of words – enter-

ing "cat dog fish" will only find the exact occurrences of all three words.

This can be combined with wildcard characters. For example,  "cat*" will find catalog but

not advocate.

ASP and PHP platforms:

These platforms support searches for exact phrases that are enclosed in quotes. 

See this topic  for instructions.

See also:
Full-text Search configuration options

12.9 Spell check questions

Can I create custom dictionaries for specific projects or subjects?

Yes, as many as you like! You can store your custom dictionaries wherever you like, including

network drives, and multiple users can use them at the same time.  See The Spell Checker

for full details on how to create and use custom dictionaries.

I selected "Auto-Correct" for a correction during spell checking but the auto-cor-
rect word pair was not added to the custom dictionary!

Check which custom dictionary you have activated for adding terms in the current project in

Spelling > Configure Spell Checker in the Project tab. You can use multiple dictionaries for

spell checking but you can only add new terms to one dictionary at a time.

Where can I get additional dictionaries for the spell checker?

You can download additional dictionaries directly from the spell checker configuration dialog.

Select Spelling > Configure Spell Checker in the Project tab, then click on Download dictionar-

ies... in the Dictionaries tab. 

Note that main dictionaries must be saved in the Dictionaries folder in the Help+Manual pro-

gram directory, otherwise Help+Manual will not be able to find them.

See also:
Spell checking

Spell Checker
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12.10 Table questions

The widths of the columns in my tables are different from what I expect them to
be!

You have probably entered contradictory settings for the table and cell/column widths. When

this happens Help+Manual automatically sets the widths of all columns to dynamic and they

then adjust themselves on the basis of their content. You can usually correct this by setting at

least one column with a dynamic width so that you can "lock" the width of the other columns. 

You can turn column width locking on and off with the Lock Column tool in the Table tab. The

tool is highlighted when the cursor is in a column that is locked.

Graphics in tables extend beyond the edge of the page in PDF output!

When you place graphics on the page without tables they are automatically resized to fit on

the page in PDF. This is not possible for graphics in tables, however, because here the table

cell and not the page is the container for the graphic. When you insert graphics in tables you

need to make sure that your layout will fit on the page. In addition to graphics clipping over-

sized graphics in tables will also switch all column widths to variable in PDF, which will prob-

ably mess up your layout. 

See also:
Working with Tables

12.11 User interface questions

There are two copies of my topics – once in the TOC and once in Topic Files!

Actually, there is only one copy of each topic. The Table of Contents is really just a list of links,

like hyperlinks on a web page. The actual topic files are stored in Topic Files in the Project

Files section of the Project Explorer. For convenience the topic files that TOC entries link to are

displayed for editing automatically when you click on the entries.

I undocked a Help+Manual window and now I can't dock it again!

You can always redock a window by double-clicking on its title bar (double-clicking also

works for undocking, by the way). In addition to this you can dock or undock any dockable

window by dragging it to the border of the main Editor window. Most windows can be

docked to any side of the editor window. 

I'd also like to be able to undock the Topic Options tab!

This is not possible. The Editor window components and tabs are fixed and cannot be un-

docked. 

See also:
Options & Keyboard Shortcuts
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12.12 Video questions

My movie is not playing properly in my published output. What can I do?

See About using video  for recommendations on video formats. Basically, you should only

use either MP4 video files or online video sharing services (YouTube, Vimeo and Prezi). All

other video formats will cause problems sooner or later.

Check that the correct codec and/or player are installed. Videos can only be played if the cor-

rect player and codec support for them is installed on the computer where your help is being

viewed. Generally speaking, only MP4 video is reliable. 

With some formats and/or browsers you may need to activate the Start Automatically and

Show Controls options in the Insert Video  dialog for the animation or video to play cor-

rectly. Flash videos do not support these external controls – if you want player controls for

Flash you must embed them in the video with the program that you use to create it. 

The movie preview function in Insert Video dialog doesn't seem to be working!

On some systems you may find that need to be working in a Windows account with full ad-

ministrator rights to use the movie preview function. If the function doesn't work and you

know that the correct player is installed try switching to a full administrator account. 

See also:
Videos and Online Media
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eBooks, eWriter for Windows    

configuring output     696

EC Software contact information     66

Edit menu    

Find and Replace     1326

editable variables     963

in HTML templates     1049

editing topics     94

editor    

change font for     1265

customizing     1265

double click, triple click     223

editing is slow, oversized .HMX projects     1637

format painter     223

navigating in     223

paragraph copying problems     1637

protect text against changes     223

sections     55

selecting text in     232

tabs     55

using     223

ELSE condition    

and text include options     994

and topic include options     989

not supported in HTML templates     1052

embedded graphics    

identifying     1535

locating with Report Tool     1535

embedding files in PDFs     424, 807

EMF images     479, 1529

English interface     1261

ePUB    

general settings     1473

HTML export options     1476

page template     1024, 1476

settings in Project Configuration     1472

TOC template     1475

eWriter    

application calls     903

close viewer from application     903

context calls and     903

linking to context IDs in WebHelp     903

linking to WebHelp topics     903

links to     457

syntax for calls/links to     903

eWriter Help files    

about     1519

application menu     714, 1479

CD ROM catalogs     1519

context help     444, 701, 731, 903

context menu     714, 1479

distributing     718

field-level popups     1519

file links     444, 701, 731, 903

for software documentation     731

kiosk applications     1519

layout settings in Project Configuration     711, 1477

links to EXE files     444, 701, 731, 903

menu configuration and translation     714, 1479

pros and cons     1519

Short Title in eWriter menu     714, 1479

special include options     979

viewer installers     716

viewers     718, 719

Windows Store and Win32 viewers     719

eWriter Help files, configuring     696

eWriter website     731

Excel    

copying from and to     233

exclude and include options (conditional output)     828

exclude topics from search in CHM     645

exclude topics from search in WebHelp    

special settings for in WebHelp     664

excluded topics    

export if referenced (option)     1268

remove dead links (option)     1268

excluding topics and content     120

EXE files    

linking to in EWrieter eBooks     444, 701, 731, 903

ExecFile() macro    

equivalent for HTML Help     1544

exit codes (command line builds)     825

Expand All    

code for expanding WebHelp TOC     1044

expanding image toggles    

converting existing images     392

creating     392

formatting with CSS     392

expanding inline text toggles    

creating     389

formatting text and links     389

expanding section toggles    

creating     384

editing     384

embedded topics in     384

existing tables with IDs     384
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expanding section toggles    

formatting headers     384

icons, suppressing in PDF etc.     384

icons, swapping     384

icons, using in     384

indents in     384

nesting     384

supported content     384

expanding sections    

nesting     382

expanding text and images    

copying     395

copying and editing     396

CSS styles for links     399

duplicate ID conflicts     396

examples     382

Expand All / Collapse All functions     402

IDs, auto-incrementing     395

Print button with Expand All     402

support in output formats     382

troubleshooting     404

updating old expanding sections     406

expanding text and images, troubleshooting    

large output files     404

output file size     404

page breaks in PDFs and printed manuals     404

problems with expanding section toggles     404

problems with formatting in toggle links     404

problems with IDs     404

Explorer    

folders     77, 377

managing Topic Files     77, 377

exporting    

topics as XML files     365

Extended .HHP Settings     1457

file references in     469

external data    

importing into projects and topics     155

importing Sandcastle projects     151

external files    

integrating in projects     1120, 1121

referencing in HTML code     469, 1121

external windows    

and hyperlinks     469

and invisible topics     1609

displaying topics in     194

how to display topics in     1025

in HTML Help     1610

in modular projects     1609

opening topics in     469

restrictions in modular projects     1110

- F -
F1 context help     1587

featured images     792

tutorial     118

field-level popups     207, 212, 215, 435, 440, 645, 892,
899, 1462, 1506, 1586, 1590, 1592, 1594, 1597

about     215, 1592

and map files     1598

in HTML Help     215, 1592

internal file name     895, 1457

figure and table numbering     944

figure links     420

figures    

links to     420

file links    

compatibility in output formats     424

creating     424

eWriter Help files     444, 701, 731, 903

linking to targets and pages in PDFs     424, 438

using in hotspots in graphics     509

File Menu     53

Print Manual (dialog reference)     1290

save as     1288

file size    

smaller with styles     1482

files    

excluding from full-text search in WebHelp     664

filter TOC by build options    

filter TOC     1304

Find and Replace    

conditional tags     235

Edit menu     1326

font styles     1144, 1147, 1151

formatting     1144

graphics     513

images     235, 782

in TOC and Invisible Topics     235, 782

multi-user editing     1171

paragraph styles     1144, 1154, 1158

referrers     235, 782

styles     1637

text     235, 782

topics     235, 782
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Find and Replace    

variables     235, 958

Find Referrers     461, 982, 984

Topics menu     1306

F-Index     1464

Firefox    

underlined TOC entries, suppressing     122

firewalls    

and update checking function     1261

font character set (language settings)     143

font size preview     223

changing     94, 223

font styles    

searching and replacing     1144, 1147, 1151

fonts    

change font for XML and HTML editors     1265

CID font embedding     1447

different in print and help file     302

embedding in PDF files     1447

fonts and font embedding in PDF     808

Format Font (dialog reference)     1329

formatting tools     274

Type 14 fonts     1447

Type 3 fonts     1447

footers and headers    

creating in topics (HTML only)     1036

in HTML pages     203

Format Font (dialog reference)     1329

Format menu     1347

Syntax Highlighting     1331

format painter tool     223, 274

formatting    

replacing, about     1143

searching and replacing, about     1144

formatting text     94

formulas    

inserting as OLE objects     1140

vertical alignment     1140

FrameMaker projects    

how to import     157

frames in WebHelp     1415

frequently-used graphics    

creating shortcuts to     517

FTP    

archive bit mode for folder synching     1435

Second Copy folder synching program     1435

full text search template     1611

full-text search    

ASP search     1428

enhance with index keywords     664

excluding files from search index in WebHelp     664

excluding page sections from search index in
WebHelp     664

HTML template for WebHelp     1046

in WebHelp     1512

issues in WebHelp     613

language files for other languages     116

not working in HTML Help     1638

PHP search     1428

phrasal searches     664

phrasal searching     1428

settings for WebHelp     1428

special settings for in WebHelp     664

template for in WebHelp     664

full-text search in WebHelp     655

deleting output folder before publishing     1644

phrasal searches     1644

searching for exact words     1644

- G -
German interface     1261

Get Latest VCS Version     1307

getting help for Help+Manual     65

ghost links     455

GIF images     479, 1529

global predefined variables     1561

global variables    

name syntax     923

plain text only     923

where supported     923

Google Analytics     666, 1433

Google Chrome    

WebHelp doesn't run locally     673

graphics     481

about     1529

aligning     489

as table background     540

caption style     1490

captions, adding and formatting     481

converting to expanding image toggles     392

creating shortcuts to     517

duplicate filenames     514, 1107

editing     503

editing and resizing     503

embedded     1535
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graphics     481

exporting text in as XML     1197

finding and replacing     513

folders for     514

formats and file size     1529

frequently-used     517

HelpXplain slides as graphics     481

hi-res for PDF and printing     503

hotspots, macros and scripts in     509

IDs for, incrementing     514

Image Shortcuts for frequently-used graphics     517

in HTML templates     1613

in modular projects     514, 1107

in PDF     797

Insert dialog     1359

inserting     104

inserting from files     481

inserting in topics     481

inserting unsupported graphics formats     481

inserting with cut and paste     104, 481

listing     1212

managing     514

missing     779

missing and unused, finding     1212

moving and renaming     514

opening in Impict graphics editor     506

pasting from Word     104, 1535

positioning     489

project search path     514

recently-used images, reinserting     517

referencing in HTML templates     1056

replacing manually     513

resizing increases output size     503

responsive     481

responsive with captions     481

selecting     232

setting default editor     1261, 1318

storing in Baggage     1120

supported formats     479

testing for missing graphics     781

translating text in     1191, 1197

unused, removing     1212

updating for translations     1191

updating quickly with new versions     481

using     479

using as hyperlinks     508

zoom factor     481, 503

graphics editor    

Impict     1216

setting default editor     1216, 1261, 1318

using     1216

graphics folders    

project search path     1405

setting locations for     1405

group work    

with modular projects     1547

- H -
H1 - H6 headings for HTML     286

hanging indents    

and tab stops     1500

restrictions     299

using     299

hard page breaks    

inserting     245

hard spaces     1500

HEAD section of HTML template    

adding HTML code and scripts to     1545

header    

adding material to on every page     1036

additional content in     191, 229

changing background color     191, 229

formatting     191, 229

in electronic help formats     191, 229

in PDF, RTF and printed manuals     191, 229

turning on and off     191, 229

header formatting for PDF and DOCX     302

headers and footers    

creating in topics (HTML only)     1036

in HTML pages     203

Heading1 style     1490

Help 2.0     1525

setting compiler location     1268

Help buttons     1587

help compilers     632

compiler messages settings     1268

not found     1635

options     1268

setting locations     1268

where to get     1635

help context numbers    

about     1603

auto-generating     1411

auto-generating topics with     1241

cannot import to anchors     1241
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help context numbers    

context numbers     1241

exporting and importing     1241

generating list     1638

help formats     1603

output format compatibility     1603

reassigning and deleting multiple     1241

settings in Project Configuration     1411

supported range     1241, 1603

help context numbers, context IDs    

and anchors     368

assigning automatically     368

assigning manually     368

auto-generating     368

changing globally     1107

linking to in eWriter     444, 903

linking to in WebHelp     440, 899

multiple context numbers per topic     368

preventing duplicates in modular projects     1107

value range     368

Help Context Tool     1323

using     1241

help files    

integrating with applications     1635

TOC link to     183

help for Help+Manual     65

help formats    

about     1504

Adobe PDF     1523

eBooks, ePUB     1513

eWriter Help files     1519

HTML Help     1506

MS Word DOCX     1525

printed manuals     1524

Visual Studio Help/Help 2.0     1525

WebHelp     1510

Help menu    

reference     1399

help project    

language and character set     143

help title     139

help viewers    

background colors     142

changing appearance of     194

defining appearance of     142

for different output formats     194

help window title in HTML Help     1638

help windows    

about     1609

and output formats     650

changing for topic     194

choosing (basic setup)     194

creating, deleting and editing     194

external     469

in HTML Help     1610

not linked to HTML templates     1611

secondary windows     469

secondary windows, using     1025

setting title     139

settings in Project Configuration     1452, 1454

types     650

Help+Manual    

about     35

buying     66

customizing     1261

getting help     65

Quick Start Tutorials     69

support address     65

tutorials     65

user interface     43

why Help+Manual?     35

Help+Manual 2 Go mini server     673

Help+Manual 3 projects    

converting     132, 1234

custom HTML code in     132, 1234

invisible topic conversion     1234

style conversion     132, 1234

table conversion     132, 1234

Help+Manual 4 projects    

converting     132

Help+Manual 5 projects    

backward compatibility with     132

Help+Manual 9 new features     23

Help+Manual help    

using as a template for your projects     1008

Help+Manual help source code     121

HelpXplain    

animated presentations and screencasts     561

insert slide as static image     481

high-resolution displays     44

settings for CHM files     645

HLP files    

settings for importing     157

HM2Go mini server     673

HM3 IPP graphics with hotspots     479

HM3 projects    
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HM3 projects    

converting     132, 1234

custom HTML code in     132, 1234

invisible topic conversion     1234

style conversion     132, 1234

table conversion     132, 1234

HMXP     126

HMXZ     126

horizontal lines    

inserting     245

hotkeys    

for styles     281, 295

Hotspot editor (dialog reference)     1361

hotspots    

aligning     509

compatibility in output formats     509

in old .ipp and .SHG files     479, 509

inserting in graphics     509

linking to popup topics     509

visible or invisible     509

HTML    

appearance in different browsers     655

configuring WebHelp output     655

expand WebHelp automatically on open     655

H1 - H6 headings     286

output format for lists     341, 1435, 1459, 1467

single-click option for WebHelp navigation     655

timestamp of HTML topic files     1435, 1459

HTML (WebHelp)     1510

HTML code    

about using     1539

inserting in topics     469

pasting into Help+Manual editor     1296, 1324

saving to and loading from files     469

HTML code object    

Insert dialog (dialog reference)     1379

HTML code objects    

about     1545

and HTML variables     1545

inserting in topics     469

inserting outside <body> tags     1545

limitations in eBooks     1545

referencing script functions in     1545

saving to and loading from files     469

variables in     934

where supported     1545

HTML Export Options     1435, 1459, 1467

HTML files    

importing into individual topics     155

importing to topics     365

merging into existing topics     169, 469

settings for importing     157

HTML Help     1457, 1508

about     1506

anchor keyword display in     577

calling from command line     1638

compiler     632

configuring output     645

context-sensitive help     892

correct display on hi-res monitors     645

crashes     1638

custom TOC icons     1638

editing source files     1638

exclude topics from search     645

Extended .HHP settings     1457

external windows     1609

field-level popups     1597

field-level popups in     215, 1592

help window title issues     1638

help windows     1609

help windows in     1610

HTML page templates     1413

JavaScript popups     1597

keep on top     1454

links to CHM modules     1100

links to external windows across modules     1110

merge options for modules     1096, 1100

modular help settings     1457

navigation links in header     1638

popup topics in     207, 1597

popup topics settings     1462

project files     1508

pros and cons     1506

referencing external files in     1457

restrictions on network drives     1506, 1638

search in CHM modules     1100

search not working     1638

secondary windows     1609

setting compiler location     1268

settings in Project Configuration     1451

support for modular projects     1088

support for videos and animations     563

temporary files     1508

TOC behavior, configuring     645

users get error message     1638

video files support     1536
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HTML Help options     1454

HTML page templates    

background colors     203

headers and footers     203

HTML editing mode     1413

navigation links     203

setting for individual topics     203

simple editing mode     1413

HTML templates    

about     1021, 1028, 1611

and Baggage graphics     1056

color code entry tool     1030

conditional output in     1052

creating new     1030, 1036

defined     1007

editable variables in     1049

editing     1030

editing changes don't work!     1030

ELSE condition     1052

for topic pages     1036

graphics in     1613

HTML page templates     1413

in HTML Help     1610

include options in     1006

Index template for WebHelp     1045

Layout template     1043

multiple conditions     1052

output conditions (reference)     1577

pixel ems calculator     1030

referencing external files in     1062

referencing graphics in     1056

Search template for WebHelp     1046

TOC template for WebHelp     1044

troubleshooting     1075

variables and     1611

variables in     934, 959, 1049

variables in (reference)     1569

HTML topic page templates    

defined     1007

HTML variables     963

defining     919

how they work     919

managing     1406

search engine optimization     963

settings in Project Configuration     1406

using with HTML code objects     1545

where supported     917

HTML5    

video tag     563

HXS    

publishing     613

HXS files    

namespace     1135

registration requirement     1135

unique identifier     1135

hyperlinks    

[****] links     455

and external windows     469

and secondary windows     469

automatic title of target as caption     410

captions     455

converting to normal text     455

creating     110

editing and formatting     455

file links     424, 438

ghost links     455

graphics as hyperlinks     508

Insert dialog (dialog reference)     1352

Internet links     422

Internet links to PDF pages     422

linking to targets and pages in PDF     424, 438

macro links     452

preventing dead links     461, 984

script links     452

selecting     232

testing for dead hyperlinks     781

to anchors     110, 415

to anchors in snippets     415

to eWriter     457

to figures and captions     420

to other projects and help files     457

to popup topics     207

to WebHelp     457

topic links     410

types supported     409

hyphenation    

creating hyphenation word lists     1220

selecting hyphenation dictionary     1220

- I -
iBooks, ePUB    

configuring output     750

distributing     768

font management     764

formatting recommendations     756
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iBooks, ePUB    

inline images bug in iBooks     750

resources     769

restrictions and requirements     750

settings     760

source files for manual editing     750

icon    

change icon     1304

IDs    

assigning and choosing     368

internal numerical IDs (Project Synch)     1257

prefixes for topic IDs     368

IDs, auto-incrementing for graphics     514

IDs, auto-incrementing for tables     535

IDs, auto-incrementing for toggles     395

image captions    

entering     481

formatting     305, 481

standard style for     292, 305, 1490

variables in     934

image editor    

selecting default     1318

image folders    

managing     514

moving and renaming     514

project search path     1405

setting locations for     1405

Image Shortcuts    

for frequently-used graphics     517

image styles     492, 1492

images    

converting to expanding image toggles     392

creating shortcuts to     517

exporting text in as XML     1197

frequently-used     517

Image Shortcuts for frequently-used graphics     517

image styles     492, 1492

recently-used images, reinserting     517

translating text in     1197

unused, locating and removing     1212

images (see graphics)    

supported formats     479

using     479

Impict    

no red capture border     507

screen capture tool in     507

Impict graphics editor    

editable objects     506

exporting text for translation     506

output file larger after resizing     503

resizing images with     503

transparent background     506

using     506

Impict screenshot editor    

using     1216

implicitly included topics     1635

imported text    

globally applying styles to     1144

globally applying styles to, example     1162

globally integrating styles with Toolbox     1165

importing external data     148

external HTML files (#MERGE)     169, 469

globally applying styles to imported text     1144

into existing projects     90

into new projects     90

Sandcastle projects     151

settings for importing     157

styles from other projects     281, 295

topics from external files     365

importing styles with style repositories     1083

include and exclude options (conditional output)     828

include conditions    

defined     969

include options    

about     979

and modular projects     1002

and publishing     613, 989, 994, 1002

conditional text     994

defining user options     988

editing     989, 994, 1002

eWriter Help files     979

exclude all a topic's subtopics     989

filter TOC with     1304

filtering in the TOC     982

for Baggage files     1124

for topic entries     1584

for topic files     1584

for topics without TOC entries     179

format-based     979, 1582

in command lines     828

in HTML templates     1052

insert dialog (dialog reference)     1371

logic     982

negating with exclude options     828

nesting     994

OR logic     979
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include options    

searching     235, 982

settings in Project Configuration (custom builds)    
1410

topic include options     989

user-defined     979, 1582

using     982

indent tool    

error message in lists     334

indenting tables     532

indents    

and tab stops     1500

cannot indent lists     299

hanging indents     1500

how exported     1500

leading spaces     299, 310

negative indents     299

problems when adjusting     1637

problems with lists     334, 1637

restrictions     299

unexpected changes     1637

using     299

index    

anchors and     565

editing     565

editing directly     568

exporting and importing the index     574

HTML template for WebHelp     1045

letter links in WebHelp     582

section header separators in     582

translating and editing the index     574

index keywords     664

about     1605

adding     565

duplicates and variants     565

editing     565

enhance WebHelp search with     664

entry format     565

in popups     565

in topics without TOC entries     565

red underline     565

sub-entry levels     565

sub-keywords     1605

index separators for WebHelp     1425

Index template     1611

Index Tool     568

exporting and importing the index     574

translating and editing the index     574

Index Tool (dialog reference)     1321

inheritance    

in styles     1484, 1485

inheritance trees     1485

stopping     1485

style families     1497

INI files    

for command line options     837

inline HTML code (HTML code objects)     1545

inserting in topics     469

saving to and loading from files     469

Insert / Insert Object (reference)     1349

Insert Video (dialog reference)     1363

inserting graphics     104

inserting tables     107

Interactive wizards     1587

international languages    

about     1627

and PDF     1632

CID font embedding for PDF     143

configuration settings for     143

project settings     1629

requiring Unicode     1627

Unicode mode in Windows     1629

Internet Explorer    

SVG graphics in     496, 500, 1532

turning off yellow warning bar in WebHelp     613

yellow warning bar     673

Internet links    

compatibility in output formats     422

creating     422

creating automatically     422

linking to PDF pages     422

using in hotspots in graphics     509

invisible files     48

invisible topics    

importing from old projects     1234

invisible topics, converting from old projects     85

IPP images    

transparent background     506

- J -
JavaScript    

about JS links     1540

about using     1539

complex code in links     1540

complex scripts     452
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JavaScript    

nesting quotes     1540

script links     452

syntax in Help+Manual     1540

troubleshooting     1540

using in hotspots in graphics     509

where supported     1540

JavaScript popups     215, 1592, 1597

in HTML Help and WebHelp     212

in WebHelp     1512

options     212, 1440, 1462

using     212

JPG images     479, 1529

jump targets     415

- K -
keyboard shortcuts     59, 1274

customizing     1264

for styles     281, 295

using with styles     292

keyword index template     1611

keywords     565, 1212

about     1600

adding     565

adding child keywords     568

adding master keywords     568

adding to anchors     568

A-keywords     476, 579

checking     779

deleting     568

duplicates and variants     565

editing     565, 568

entry format     565

exporting and importing the index     574

find and replace     573, 785

find topics with no keywords     1212

finding topics with no keywords     565, 1212

in embedded topics     196, 265

in popups     565

in topics without TOC entries     565

listing for project     1212

red underline     565

sorting problems     143

sub-entry levels     565

testing     785

translating and editing the index     574

using with anchors     415, 577

variables in     934

viewing in Index Tool     577

Kindle/Mobi    

compiler for     633, 1268

page template     1024

K-keywords    

in embedded topics     196, 265

KLink() macro    

translation in HTML Help     452, 1544

- L -
language    

user interface language     1261

language and character set     143

language of help file (language settings)     143

language settings     139

and PDF     1632

CID font embedding for PDF     143

configuration settings for     143

default font     143

font character set     143

for project     69, 1629

help file language     143

in Project Configuration     1403

language of help file     143

project language and character set     143

right-to-left languages, activating support for     1403

Unicode     143

languages     1627, 1629

right-to-left languages     1403

last topic edited, returning to     217

Layout section in WebHelp     655, 660

Layout template     1043

leading spaces     299

legal numbering style     324

Lenovo Yoga Pro - hi-res displays     44

level reset (outline numbering)     324

levels (outline numbering)     324

lines    

inserting     245

link styling tutorial     122

link texts    

editing     455

linking    

to popup topics     207

linking to context IDs in eWriter     903

linking to context IDs in WebHelp     440, 899
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linking to eWriter topics     903

linking to WebHelp topics     440, 899

links    

dead     779

Insert dialog (dialog reference)     1352

named destinations in PDF     409, 465, 793, 913

preventing dead links     461, 984

styling with CSS, tutorial     122

to anchors     110, 415

to anchors in snippets     415

tutorial     110

types supported     409

links to CHM modules     1100

lists    

applying deletes indent     1637

cannot indent     299

output format in HTML     341, 1435, 1459, 1467

lists (dialog reference)     1340

live spell checking     94

Load Topic from File     1307

loading multiple projects     73

loading projects     73

localization     1177

localization and translation    

DeepL     1178

features and support     1177

machine translation     1178

translation memory     1187

tutorials     1177

logic of include options     979

- M -
machine translation     1178

macro links    

creating     452

macros    

distribute DOCX without macros     695

update Word fields without macros     695

Word macros     695

macros (Winhelp)    

about     1544

translation in HTML Help     452, 1544

macros and scripts    

variables in     934

map files    

about     1598

auto-generating topics with     911

cannot import context nos. to anchors     1241

exporting (with custom syntax)     1241

field-level popups     1598

generating context numbers and topics with     1598

importing     1241

restrictions     1598

map styles from RTF     157

master and child projects     1547

master projects     1547

menu icons     53

menus reference    

Help tab     1399

MERGE command for importing HTML files     169, 469

merge method in modular projects    

choosing and changing     1089, 1096

Merged Projects section     1089

metafiles     1529

Microsoft help compilers    

setting locations     1268

where to get     1635

Microsoft Sandcastle     1125, 1126, 1127

getting Sandcastle     1126

importing Sandcastle projects     151

Sandcastle Help File Builder     1126

supported Sandcastle versions     151

Microsoft Surface Pro - hi-res displays     44

missing graphics     779

modular help    

about     1088

A-keywords and     476, 579, 1606

linking between modules     476, 579

modular help systems    

about     1547

modular projects     1547

about     1547

and WebHelp     1117

changing merge method     1089

child modules     1555

child projects     1089, 1555

context numbers, preventing duplicates     1107

copying     1103

creating     1089

editing child projects in master     1089

editing in master     1089

graphics in     514, 1107

hyperlinks between     457

IDs, preventing duplicates     1107

include options     1002
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modular projects     1547

including without TOC entries     1089

inserting a project in the TOC (quick guide)     183

linking between modules     1110, 1555

links to CHM modules     1100

managing modules in the TOC     1103

master modules     1555

master projects     1089, 1555

merge methods     1096

merge options for HTML Help     1096

Merged Projects section     1089

nesting modules     1555

planning     1555

project and output names must match     633

publishing     1114

read-only mode     1089

read-only mode for child projects     1089

runtime and publish-time merging     1551

search in CHM modules     1100

second copies     1103

structuring     1555

support in output formats     1088

modules    

changing merge method     1089

master and child     1089

monitors, high resolution     44

monitors, multiple    

save window positions for     1261

mouse wheel    

changing font size preview setting     1265

movies    

Insert dialog (dialog reference)     1363

moving topics     100

MS Excel    

copying from and to     233

MS Help 2.0 (Visual Studio Help)    

about     1132, 1525

compiler     632, 1132

configuring Visual Studio Help output     775

example calls     1135

export options     1464

limitations     1132

namespace     1135, 1464

popups     1466

publishing     113, 1135

registering HXS files     1135

requirements     1132

unique identifier     1135, 1464

MS Help 2.0/3.0 (Visual Studio Help)    

publishing     613

MS Word    

copying and pasting from/to     94

copying from and to     233

differences from Word     228

mangles XML source code     264

pasting graphics from     1535

MS Word DOCX    

about     1525

pros and cons     1525

MS Word DOCX output    

settings in Project Configuration     1472

MSHC    

publishing     613

multi-monitor displays    

save window positions for     1261

multiple TOCs     589, 592

tutorial project     119

multi-user editing    

and version control systems     848, 1171

read-only mode for child projects     1089

standardizing styles     1171

- N -
named destinations in PDF files     409, 424, 438, 465, 793,
913

limitations     465, 793, 913

navigation links in topic headers     203

Navigation section in WebHelp     655

nested tables    

don't split across pages     539

nesting include options     994

network drives    

HTML Help doesn't work     1638

restrictions on HTML Help     1506

new projects     124

creating with imported data     149

non-breaking spaces     1500

non-scrolling header template     121

Normal style     96, 1490

Notes style     1490

number format (outline numbering)     324

number style (outline numbering)     324

numbered lists    

adjusting indents     334

creating     318
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numbered lists    

customizing     318

format     318

formatting numbers in     334

inserting un-numbered paragraphs     318

outline numbered lists     324

styles in     334

numbering    

restarting in numbered lists     318

style in numbered lists     318

numbering and bullets (dialog reference)     1340

numbering, automatic with variables     941

- O -
old projects, converting     85

OLE objects    

about     1139, 1529

creating new     1140

editing     1140

embedded     1535

embedding     1140

embedding vs. linking     1538

implementation in Help+Manual     1538

Insert dialog (dialog reference)     1385

inserting from files     1140

restrictions     1538

vertical alignment     1140

online media     548

OpenOffice spelling dictionaries    

selecting and downloading     1220

optimizing publishing speed     651, 771, 775

organizing styles     1497

outline numbered lists    

customizing     324

formatting     324

level reset     324

levels     324

number format     324

number style     324

styles in     334

Outline TOC in PDF     1442

Outline TOC in PDF, numbering     1442

output formats     132

about     1504

Adobe PDF     1523

configuring (introduction)     644

configuring Adobe PDF output     677

configuring ePUB eBooks output     750

configuring eWriter Help files     696

configuring HTML Help output     645

configuring printed manuals     677

configuring Visual Studio Help output     775

configuring WebHelp output     655

configuring Word DOCX output     682

distribution files     636

eBooks, ePUB     1513

ePUB formatting recommendations     756

ePUB resources     769

ePUB restrictions and requirements     750

ePUB settings     760

ePUB, distributing     768

eWriter Help files     1519

font management     764

HTML Help     1506

MS Word DOCX     1525

printed manuals     1524

Visual Studio Help/Help 2.0     1525

WebHelp     1510

which is best?     1635

output size    

larger after resizing graphics     503

- P -
page breaks    

errors caused by tables     539

inserting     245

page referrers for PDF     1290, 1442

paragraph end marks    

cannot select     228

paragraph marks    

displaying in editor     1265

paragraph styles     292, 1491

defining     281

defining from selection     281, 295

naming for easy finding     1497

searching and replacing     1144, 1154, 1158

paragraphs    

borders and backgrounds (dialog reference)     1339

borders not displayed     1637

copying problems     1637

Format menu (dialog reference)     1336

formatting tools     274

indenting     299

selecting with triple click     223
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parent style    

changing     288

paste as text    

copying text without formatting     1296, 1324

paste HTML     1296, 1324

PCD images     479

PDF    

about     785

additional pages in     786

Bookmarks TOC, numbering     1442

bullet and symbol characters     808

CID font embedding     143, 1447, 1450, 1632

clipped graphics     1271

comments, include as annotations     253, 798

configuring PDF output     677

cross references     1290, 1442

embedding files in     424, 807

file embedding setting     1442

font embedding     677

font embedding settings in Project Configuration    
143, 1447

fonts and font embedding recommendations     808

generating     798

graphics in     797

header formatting     302

including/excluding pages     677, 798, 803, 1019

individual styles for     302

layout settings in Project Configuration     1442

linking to specific pages in     422

linking to specific targets and pages in     424

linking to targets and pages in     438

max. TOC levels     798

named destinations in     409, 424, 438, 465, 793, 913

negative indents     299

no graphics     1271

Outline TOC, numbering     1442

page break errors     539

page referrers     1290, 1442

page referrers for topic links     410

PDF-A activation     1446

Print Manual Designer     805, 1217

printer driver required for     677

pros and cons     1523

reference driver for     1271

settings     798

settings in Project Configuration     1442, 1446

sidebar with negative indents     299

suppressing toggle icons     384

table widths     522

template variables     1581

templates for     805, 1019, 1217

templates for, standard files     116

templates, location     803

templates, using     803

title pages tutorial     118

title pages with images     792

topic headings in     790

Type 14 fonts     1447

Type 3 fonts     1447

Unicode now supported     1632

using hi-res graphics in     503

video files support     1536

PDF manual     65

PDF problems    

can't output     1641

files too big     1641

garbled output     1641

heading formatting doesn't match project     1641

including/excluding pages     1641

odd/even page problems     1641

PDF templates    

defined     1007

variables in     968

PDF-A     1446

per-topic variable redefinition     963

PHP search in WebHelp     1428

PHP, switch off the BOM for compatibility     1435

phrasal searches in WebHelp     664, 1644

phrasal searching    

PHP or ASP required     1428

plain HTML code    

about     1545

adding to <head> section     1545

and Baggage     1120

and HTML variables     1545

files referenced in     1120

Insert dialog (dialog reference)     1379

inserting outside <body> tags     1545

limitations in eBooks     1545

referencing script functions in     1545

where supported     1545

plain-text variables    

defining     919

PNG    

in PDF     797

PNG images     479, 1529
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popup topics    

about     1586, 1590

and context help     1590

application calls to     897

auto-generating for context help     1594

context numbers for CHM popups     207

creating     207

field-level popups     207, 215, 895, 1586, 1590, 1592,
1594, 1597

for context-sensitive help     895

in eBooks     1597

in HTML Help     207, 1597, 1610

in Visual Studio Help/Help 2.0     1466

JavaScript popups     212, 1440

linking to     207, 410

linking to from hotspots     509

plain text only in HTML Help     1638

pros and cons     1590

settings for HTML Help     1462

settings for WebHelp     1440

where supported     207, 1590

width of, controlling     207, 1597

Premium Pack 3     655

preview mode for screen and print styles     302

Print Manual     1290

Print Manual Designer     1323

configuring PDF output with     677

configuring printed manuals with     677

using     805, 1217

print manual templates     786, 800

defined     1007

editing     803, 1019

opening current template for editing     1442

selecting     803, 1019

standard files     116

standard templates     803, 1019

using     1019

variables in     968

Print Preview     1290

Print Preview function    

selected topics only     800

print styles and screen styles     302

printed manuals    

about     785, 1524

configuring     677

templates for     800, 1019

printing    

excluding TOC etc.     800

garbled printouts     1643

no page referrers (cross references) in print preview  

 
 1643

previewing before printing     800

selected topics only     800

single and multiple topics     263

toggles     407

program code    

Syntax Highlighting     1331

Program Options - Compilers     1268

Program Options - Editor     1265

Program Options - General     1261

Program Options - PDF Export     1271

Program Options - Ribbon     1263

Program Options - Shortcuts     1264

program workspace     1275

project    

save as     1288

title & copyright notice     1402

Project Configuration     1457

about     1400

Adobe PDF font embedding options     1447

Adobe PDF Layout     1442

Adobe PDF Options     1442, 1446

and multi-user editing     1171

CID font embedding     1447

Common Properties     1401

copying settings between projects     233

custom builds     1410

eBooks settings     1472

editing     139

eWriter Help files layout settings     711, 1477

eWriter Help files menu configuration     714, 1479

Google Analytics     1433

help windows     1452

help windows general options     1452

help windows HTML Help options     1454

HTML Export Options     1435, 1459, 1467

HTML Help     1451

HTML Help Extended .HHP settings     1457

HTML Help modular help     1457

HTML Help popup topics     1462

HTML page templates     1413

Language Settings     1403

MS Word DOCX settings     1472

project search path     1405

publishing options     1415

right-to-left languages, activating support for     1403
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Project Configuration     1457

sections     1400

Text Variables     1406

Title & Copyright     1402

Topic IDs and Help Context numbers     1411

variables in     1401

Visual Studio Help (Help 2.0) settings     1464

WebHelp     1415, 1420, 1423, 1425, 1428, 1440

Project Converter    

command line syntax     137

converting H+M 3 projects     1234

converting old projects     132

custom code in HTML templates     132, 1234

invisible topic conversion     1234

restrictions and limitations     132, 1234

Project Explorer     1304

defined     48

docking and undocking Explorer panes     59

folders     77, 377

managing Topic Files     77, 377

navigating in     73

pinning Explorer panes     59

sections, about     70

Table of Contents     173

tutorial     70

Project Explorer panes    

moving     82

pinning     82

split view     82, 94

undocking and redocking     82

Project Files section     48

defined     48

Project menu    

Project Configuration     1316

project reports     779

saving as HTML files     1212

using the Reports Tool     1212

Project Reports tool     1212

Project Reports tool (dialog reference)     1318

project search path     1405

and graphics     514

and snippets     196, 265

Project Synchronization    

about     1245

creating translation sibling pairs     1247

how changes are synchronized     1245

identifying changes in synchronized projects     1255

interim updates     1256

internal numerical IDs     1257

material disappears after synchronization!     1258

no text-level comparison     1245

Professional version only     1245

project folder and     1247

synchronizing existing translations     1257, 1258

synchronizing new versions     1251

translating changes     1254

translating the original project     1250

updating the original project     1251

Project Synchronization Tool    

Ribbon reference     1324

project templates    

applying to existing projects     1008

creating     1008

defined     1007

Help+Manual help project template     1008

using to create new projects     1008

projects    

checking status     1212

converting old projects     85, 132, 1234

copying and moving topics between     165, 357

copying settings between     233

copying styles between     306

copying text and content between     233

creating     124

creating (tutorial)     69

creating new projects     124

creating with imported data     149

inserting in another project (quick guide)     183

invisible topics from old projects     1234

language settings     1629

large projects     1547

multi-user edting     1171

PDF and language settings     1632

Project Configuration     1316

publishing     113, 613

saving as skins     638, 667

templates for     1008

testing     779

title, copyright and language settings     139

translating in Help+Manual     1191

translating with XML in external editors     1194

promote/demote topics in the TOC     1308

protect text against changes     223

protected variables     919

PSD images     479

PSP images     479
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Publish     1309

Publish Help File (dialog reference)     1282, 1310

publishing    

about     613

Asian languages on non-Asian windows     613

checklist     633

epub eBooks     613

file locations     651, 771, 775

implicitly included topics message     1635

include options and     613

Microsoft help compilers     632

modular projects     1547

projects     613

publish only complete to     613

selected topics     613

speeding up     651, 771, 775

tasks - batch publishing jobs     586, 809, 810, 812

temporary files     651, 771, 775

with skins     613

publishing directly from your application     845

publishing formats     132

Publishing Options     1415

Publishing Task Manager     809

creating and editing publishing tasks     812

using publishing tasks     810

publishing, about     1547

publish-time merging     1096, 1114, 1551

- Q -
QR codes     262, 1381

Quick Access Toolbar     53

Quick Search tool     43, 58

- R -
read-only topics    

setting display color in TOC     1171, 1265

recently changed topics, link list     217

recently-used images, reinserting     517

Reference section     1261

references    

to topics, finding     1306

referrers     779, 982

finding     235, 782

Refresh Project     1309

Refresh Project command    

for multi-user editing     1171

Reload Topic     1307

remote editing     848, 1171

replace    

multi-user editing     1171

replace styles     1637

replacing formatting    

about     1144

replacing formatting and styles    

about     1143

replacing styles    

about     1144

Report Tool (dialog reference)     1318

Reporting Tool    

locating missing graphics with     781

using to test projects     780

reports    

saving as HTML files     1212

using the Reports Tool     1212

repositories: style repositories for shared styles and
snippets     196, 265, 1293, 1411

about     1076

creating and using     1078

snippets in     1086

styles in     1083

variables in     1087

repository (style repository)    

save as     1288

rescue copy     1288

automatically restore lost work     608

if you can't save     139

when you can't save your project     608

resizing graphics     481, 503

responsive design    

ems and percent dimensions for     1435

responsive graphics    

relative to page width     481

relative to table width     481

responsive images    

SVG in CHM and Internet Explorer     496, 500, 1532

with styles     492, 496, 1492

reusing content     1547

Ribbon - Project     1296

Add File (dialog reference)     1298

Add Topic (dialog reference)     1298

Bookmark     1315

Change     1304

File     1307
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Ribbon - Project     1296

Find Referrers (dialog reference)     1306

Manage Topics group (dialog reference)     1297

Project group (dialog reference)     1309

Publish     1282, 1310

Ribbon - Table     1390

Table Properties (dialog reference)     1391

Ribbon - Tools     1207, 1316

Customize     1261

editor customizing options     1265

general customize options     1261

Help Context Tool     1323

Image Editor     1318

Index Tool (dialog reference)     1321

Print Manual Designer     1323

Report Tool (dialog reference)     1318

Screen Capture (dialog reference)     1316

Spell Checker     1316

Synchronize     1324

Ribbon - View     1398

Ribbon - Write     1324

Anchor (dialog reference)     1369

Borders and Background (dialog reference)     1339

Bullets and Numbering (dialog reference)     1340

Comment (dialog reference)     1381

Conditional Text (dialog reference)     1371

Create Style from Selection (dialog reference)     1346

Edit Styles (dialog reference)     1347

Editing group (dialog reference)     1325

Font (dialog reference)     1329

Font group (dialog reference)     1328

Hotspot editor (dialog reference)     1361

HTML Code Object (dialog reference)     1379

Image (dialog reference)     1359

Insert / Insert Object     1349

Link     1352

OLE Object (dialog reference)     1385

Paragraph (dialog reference)     1336

Paragraph group (dialog reference)     1334

Replace Styles     1349

snippets (dialog reference)     1382

Special Characters (dialog reference)     1387

Styles group (dialog reference)     1345

Text Variable (dialog reference)     1370

Toggles (dialog reference)     1373

Video (dialog reference)     1363

Ribbon - Write tab    

mini toolbar     1308

Ribbon reference    

Project tab     1296

Ribbon Toolbar     53

accelerator keys     59

customizing     1263

Ribbon Toolbar (Reference)     1274

right-to-left languages     1403, 1629

RoboHelp projects (X5, X6, 7 and 8)    

settings for importing     157

rotated text in tables     525

row height     1502

rows (tables)    

adding, deleting, moving     528

RTF    

table widths     522

RTF files    

importing into individual topics     155

importing styles     157

importing to topics     365

map styles from RTF     157

settings for importing     157

styles in     157

ruler    

indent tool     299

rulers    

display vertical ruler     1265

ruler units     1265

runtime merging     1096, 1100, 1114, 1551

RVF files    

exporting topics to RVF     365

importing into individual topics     155

importing to topics     365

- S -
sample projects     65

Sandcastle     1125, 1126, 1127

commenting your code     1127

configuring your .NET project     1127

getting Sandcastle     1126

importing Sandcastle projects     151

Sandcastle Help File Builder     1126

supported Sandcastle versions     151

Sandcastle Help File Builder     1126

save mode    

uncompressed XML mode     126

Save Topic to File     1307

Screen Capture tool     1207
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Screen Capture tool     1207

no red capture border     507

using     507

Screen Capture tool (dialog reference)     1316

screen resolution     44

screen styles and print styles     302

screencasts    

HelpXplain presentations     561

screenshots    

Screen Capture Tool     1207

with Screen Capture tool     507

script links    

creating     452

using in hotspots in graphics     509

scripts    

about using     1539

files referenced in     1120

inserting JavaScript in topics     1540

script components in HTML templates     1063

user-defined variables in     1049

SDL Trados     1177

configuration file for     1187

INI file for     1177

search    

exclude parts of topics from search in WebHelp    
664

exclude topics from search in CHM     645

exclude topics from search in WebHelp     664

full-text search for WebHelp     664, 1046

not working in HTML Help     1638

search and replace    

complex with XML     264

conditional text     235

font styles     1144, 1147, 1151

formatting     1144

graphics     513

images     235, 782

in TOC and Invisible Topics     235, 782

multi-user editing     1171

paragraph styles     1144, 1154, 1158

referrers     235, 782

text     235, 782

topics     235, 782

variables     235, 958

search engine optimization     1569

per-topic variable redefinition     963

search in CHM modules     1100

search interface language files for WebHelp     116

Search template     1611

Second Copy FTP folder synching program     1435

secondary windows    

and hyperlinks     469

in HTML Help     1610

opening topics in     469

using     1025

section header separators (in keyword index)     582

See Also lists    

creating with A-keywords     476, 579

selecting    

keyboard shortcuts for     232

paragraphs     232

text and content     232

SEO     963, 1569

settings    

copying project settings between projects     233

shared HTML settings     1415, 1451, 1472

shared snippets in style repositories     1086

shared styles in style repositories     1083

SHG graphics with hotspots     479

SHG images    

hotspots converted automatically     479

supported formats     479

Short Title in eWriter menu     714, 1479

shortcuts    

customizing     1264

Show Differences     1307

Show History     1307

sidebar for PDF     299

single sourcing     585

content variation for multiple formats     586

eBook templates     601

eBooks     601

HTML page templates     601

multiple formats from one project     586

multiple TOCs     589

PDF templates     601

templates and skins     601

variant content     589

site map     655, 1420

sitemap    

generate automatically     655, 1420

skins     116

and styles     1482

command line option     834

creating skin files     638, 667

defined     1007



1673

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Index

skins     116

editing skin files     638, 667

multiple skins with command line options     638, 667

publishing with     613

redefining variables with     834, 960

save as     1288

using     1010

using for HTML output formats     638, 667

slow publishing    

optimizing     651, 771, 775

snippet project     1083

managing snippets     196, 265

style repositories     1086

snippets     365

and project search path     196, 265

editing snippet files     196, 265

finding where used     196, 265

hyperlinks and     196, 265

in style repositories     1086

Insert dialog (dialog reference)     1382

keywords in     196, 265

linking to anchors in     415

locating source files with Find Referrers     1306

managing in a snippet project     196, 265

moving     1382

project search path     1382

repositories and     196, 265

save selected text as snippet     1307

save topic as snippet     1307

using     196, 265

vs. multiple references     1527

snippets folders    

project search path     1405

setting locations for     1405

sorting tables     530

sorting TOC entries     363

source code    

color code entry tool     1030

editor     1030

leading spaces for indents     299, 310

pixel ems calculator     1030

syntax highlighting     310

source code documentation    

.NET source documentation with Sandcastle     1125,
1126

commenting your code     1127

configuring your .NET project     1127

source code for the Help+Manual help     121

spaces    

hard spaces     1500

multiple spaces in HTML     1500

spaces for indents     299, 310

spacing    

unexpected changes     1637

special characters    

curly quotes     245

Insert dialog (dialog reference)     1387

inserting     245

typographic quotes     245

Spell Checker    

configuring     1220

custom user dictionaries     1226, 1228, 1645

dictionaries     1220

disabling for selected styles     1220

hyphenation     1220

OpenOffice dictionaries     1220

using     1220

spell checking    

auto-correct     238

configuring     238

custom dictionaries     238

custom user dictionaries     1645

live spell checking     94, 238

manual     238

multiple languages     238

TOC captions     238

status    

edit     1304

status (dialog reference)     1410

style inheritance    

in table styles     533

style repositories for shared styles and snippets    

about     1076

creating and using     1078

snippets in     1086

styles in     1083

variables in     1087

styles    

about     1482

aligning tables with     537

applying to table contents     308, 537

applying to tables     308

can't reformat empty paragraphs     1636

changing on the basis of selection     288

changing parent     288

converting styles     1491
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styles    

copying from other projects     306

copying text without styles     233

creating from selection     1346

defining     281

defining from selection     281, 295

defining new     96

different styles for PDF, DOCX and eBooks     302

display in Toolbar     279

dynamic linking and inheritance     1484, 1485

editing     288, 1347

explained     1484, 1485

families     1497

formatting text with     292

H1 - H6 headings for HTML     286

image captions and comments     305

image styles     492, 1492

imported     281, 295

importing from another project     281, 295

importing from RTF     157

importing with style repositories     1083

in skin files     638, 667

in style reposities     1083

in tables     308

inheritance trees     1485, 1497

moving and renaming     288

organization strategies     1497

paragraph and text styles     292, 1491

paragraph style "stuck"     1636

preview mode     302

quick guide to using     277

renaming     1497

replacing, about     1143

searching and replacing, about     1144

selecting and applying     292

smaller files with styles     1482

source code     310

standard styles     1490

standardizing for team projects     1171

syntax highlighting     310

table styles     107, 533, 1491

toolbar display     1491

using (tutorial)     96

using in numbered and bulleted lists     334

why use?     1482

styles preview mode (screen/print)     94, 223

stylesheets    

applying from project template     1008

copying between projects     306

subtitles in video     563

subtopics    

exclude all a topic's subtopics     989

Subversion     1272

activate/deactivate     1272

client library location, manual setting     1272

support address     65

support email link     1399

Surface Pro - hi-res displays     44

SVG graphics     797

in CHM and Internet Explorer     496, 500, 1532

responsive images     496, 500, 1532

SVG images     479

SVN     1272

activate/deactivate     1272

client library location, manual setting     1272

symbols    

inserting     1387

syntax highlighting    

customizing     310

exporting and importing settings     310

Format menu     1331

leading spaces for indents     310

sharing settings with other users     310

system locale    

changing for Unicode     1627

system locale, changing for language compatibility     143

- T -
tab stops    

and indents     1500

not supported in HTML     1500, 1638

table and figure numbering     944

table grid lines    

displaying darker     1265

Table of Contents     48

changing topic icons in     373

defined     48

docking and undocking     1646

multiple entries for one topic     371

multi-user editing     1171

organizing     100

overview     100

promoting and demoting topics in     364

spell checking     238

timestamps     373
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Table of Contents section    

about, in Project Explorer     173

table of figures     689

table of tables     689

table styles     107, 1347, 1491

applying     96, 533

creating tables with     533

CSS classes for     308

defining     96, 533

multiple classes for one table     533

table styles (dialog reference)     1347

Table tab (dialog reference)     1390

table width and height     1502

tables    

about     519

about table sizing     1502

adding, deleting, moving rows/columns     528

auto-incrementing table IDs     535

background images     540

borders     541

captions     535

column width problems     1646

column widths     520, 522

conditional text in tables     542, 996

converting tables to text     531

converting text to tables     531

copying and pasting in     519

copying multiple cells     519

counters     535

creating     520

CSS classes for     308

deleting cell contents     531

displaying grid lines darker     1265

formatting     525

including and excluding rows and columns     542, 996

indenting and centering     532

Insert dialog (dialog reference)     1391

inserting     107

manipulating     107

merging/unmerging cells     529

nested     539

paragraph settings for     532

printing settings     520

resizing     525

rotated text     525

selecting     525

size options     520

sorting     530

splitting cells     529

splitting tables     529

styles and     308

table captions     535

table IDs     535

table styles     519

tabs    

and indents     1500

not supported in HTML     1500

Task Manager     809

creating and editing publishing tasks     812

using publishing tasks     810

tasks - batch publishing jobs     809, 810

creating and editing     812

redefining variables     812

TCard() macro    

translation in HTML Help     452, 1544

templates    

automatic for new topics     1016

color code entry tool     1030

content templates for new topics     174

external templates included with Help+Manual     116

for eBooks     1024

for PDF     786

for PDF and printed manuals     800, 1019

for PDF and printed manuals, using     803

for projects     1008

for topics (with content)     1016

HTML templates     1021, 1028

HTML templates, conditional output     1052

HTML templates, creating new     1030

HTML templates, editing     1030

HTML templates, external file references in     1062

HTML templates, graphics references in     1056

HTML templates, troubleshooting     1075

HTML templates, variables in     1049

HTML topic templates     1036

HTML topic templates, creating     1036

Index template for WebHelp     1045

PDF templates with Print Manual Designer     805,
1217

pixel ems calculator     1030

Search template for WebHelp     1046

template types defined     1007

TOC template for WebHelp     1044

templates for new topics     1016

templates for new topics, automatic     1016

templates, HTML page    
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templates, HTML page    

background colors     203

headers and footers     203

navigation links     203

setting for individual topics     203

temporary files    

change folder location     651, 771, 775

HTML Help files     1508

testing projects     779

testing WebHelp with HM2Go mini server     673

text    

copying unformatted     233

copying without formatting     1296, 1324

copying, cutting and pasting     233

format painter tool     274

formatting manually     274

formatting with styles     292

in images, translating     1197

selecting     232

wrapping around graphics     489

text style     253

text styles     253, 292, 1491

creating from selection     1346

defining     281

defining from selection     281, 295

display in Toolbar     279

editing     1347

naming for easy finding     1497

Text Variable    

Insert dialog (dialog reference)     1370

text variables    

managing     1406

settings in Project Configuration     1406

three-frame layout     655, 660

Tidy XML    

about     1198

activate and apply to project     1411

strip manual formatting globally     1198

TIF images     479

timestamp    

of HTML topic files     1435, 1459

timestamps    

topic and TOC timestamps     373

title & copyright notice     1402

title bar text     1402

title pages in PDF    

tutorial     118

TOC     48

about, in Project Explorer     173

alternative TOCs     589

changing topic icons in     373

check out to edit with VCS systems     1171

custom icons in WebHelp     373

defined     48

disable Drag & Drop     1304

docking and undocking     1646

expand/collapse     1304

filter by build options     1261, 1304

filter display with build options     982

filtering by build options     77, 377

multiple entries for one topic     371

multiple TOCs     592

multi-user editing     1171

promoting and demoting topics in     364

setting color for read-only topics     1171, 1265

spell checking     238

timestamps     373

variables in     934

TOC entries    

adding to topic files     179

deleting with and without topic files     361

deleting without deleting topic     179

sorting     363

TOC link to web page     183

TOC template     1611

toggles     384, 389, 392

about     383

animation     383

copying     395

copying and editing     396

CSS styles for links     399

duplicate ID conflicts     396

examples     382

Expand All / Collapse All functions     402

IDs     404

IDs, auto-incrementing     395

Insert dialog (dialog reference)     1373

nesting     382

output file size     404

pre-expanding toggles for printing     407

Print button with Expand All     402

printing     407

Pro version only     382

support in output formats     382

troubleshooting     404

types     383
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toggles     384, 389, 392

updating old expanding sections     406

toggles, expanding images    

converting existing images     392

creating     392

formatting with CSS     392

toggles, expanding inline text    

creating     389

formatting text and links     389

toggles, expanding sections    

creating     384

editing     384

embedded topics in     384

formatting headers     384

icons, suppressing in PDF etc.     384

icons, swapping     384

icons, using in     384

indents in     384

nesting     384

supported content     384

toggles, troubleshooting    

large output files     404

page breaks in PDFs and printed manuals     404

problems with expanding section toggles     404

problems with formatting in toggle links     404

problems with IDs     404

Tooltips     1587

topic    

convert to chapter with/without text     1304

load from file     1307

reload function     1307

save snippet (selected text)     1307

save to file     1307

status     1304

topic caption (in TOC)    

editing     189, 360

link with topic header (off/on)     189, 360

topic class     1298

topic content templates     1016

defined     1007

topic files    

about - general introduction     173

auto-generating from map files     179

creating without TOC entries     179

deleting     77, 377

deleting with and without TOC entries     361

find topic files with no TOC entry     77, 377, 1212

importing into individual topics     155

include options with     179

managing     77, 377

moving     77, 377

organizing in folders     375

sorting and grouping     77, 377

Topic Files section     48

creating new folders in     179

defined     48

topic header (editing box above topic)    

additional content in     191, 229

changing background color     191, 229

editing     189, 360, 1036

formatting     191, 229

in electronic help formats     191, 229

in PDF, RTF and printed manuals     191, 229

link with topic caption (off/on)     189, 360

turning off for individual topics     189, 360

turning on and off     191, 229

topic headings    

in PDF     790

topic icons    

changing in TOC     373

topic IDs    

about     1600, 1601

assigning and choosing     368

auto-correcting blanks in     1265

changing globally     1107

descriptive     368

editing     368

editing/changing     1601

finding     235, 782

hierarchical     368

in modular projects     1107

listing     1212

maximum length     1601

permitted characters     1601

prefixes, generating automatically     368

settings in Project Configuration     1411

topic include options    

checking and correcting dead links     989

exclude all a topic's subtopics     989

setting and editing     989

topics without TOC entries     989

topic links    

compatibility in output formats     410

creating multiple     410

inserting     410

page referrers for links in PDF     410
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topic links    

quick captions     410

to figures and captions     420

Topic Options    

cannot undock     1646

topic page template     1611

topic status    

edit     1304

topic status (dialog reference)     1410

topic templates     1016

topic templates, HTML    

breadcrumb trail navigation     1036

creating new     1036

using and editing     1036

topics    

about - general introduction     173

and project search path     165

auto-generating with map files     1598

background colors     194

copying and pasting between projects     165

creating and editing     172

creating multiple in TOC     174

creating new     91

creating new in TOC     174

creating popups     207

creating with templates     174

creating without TOC entries     179

cutting and pasting     100

display in external windows     1025

displaying in external windows     194

edit caption (title)     1308

edit in multiple tabs     55

editing caption and header     189, 360

exclude topics from search in CHM     645

exclude topics from search in WebHelp     664

exporting     165

exporting and importing     365

field-level popups     1598

finding     235, 782

finding references to     1306

formatting     165

implicitly included compiler message     1635

importing     165

include options with     179

inserting JavaScript in     1540

last topic edited, returning to     217

listing editing dates     1212

move up/down     1308

moving     100

moving, cutting and pasting     357

multiple TOC entries for one topic     371

multi-user editing     1171

opening in external windows     469

print     1308

printing single and multiple topics     263

promote/demote     1308

promoting and demoting in the TOC     364

publish only complete topics     613

recently changed, editing     217

recently changed, get a link list     217

saving as snippets     365

sharing     165

snippets     165

snippets vs. multiple references     1527

styles     165

testing     780, 782

text is unformatted!     165

timestamps     373

TOC link to external help file     183

translating     1194

topics without TOC entries    

creating     179, 375

include options with     179

organizing in folders     375

Trados     1177

configuration file for     1187

INI file for     1177

training card help     1587

translatable elements in XML     1200

translate="false"     1200

translating individual topics     1194

translating individual topics with XML    

tutorials     1194

translating projects    

and localization     1177

project synchronization and     1245

text in images     1197

translating projects in Help+Manual     1191

translating with external editors     1194

translation     1177, 1194, 1197

procedure     1191

protecting text against changes and translation    
1191

translation and localization    

DeepL     1178

features and support     1177



1679

Help+Manual - User Help 
 
                                                                                                                                                                  © 2023 by EC Software, all rights reserved

Index

translation and localization    

machine translation     1178

translation memory     1187

tutorials     1177

translation memory     1187

transparent background    

activate for IPP images     506

triple click to select paragraph     223

troubleshooting     1271

TrueType fonts    

cannot embed font message in PDF     1447

embedding in PDF files     1447

tutorials    

adding topics     91

background images for topics and headers     122

conditional output     120

creating hyperlinks     110

creating projects     69

customized icons for WebHelp TOC     122

DHTML Examples     122

entering and editing text     94

expanding and collapsing sections     122

external tutorials included with Help+Manual     116

featured images     118

inserting graphics     104

inserting tables     107

modular help systems     120

multiple TOCs     119

navigation buttons     122

non-scrolling headers     122

organizing the TOC     100

Print link     122

publishing projects     113

Quick Start     69

styling hyperlinks with CSS     122

suppress underlined TOC entries in Firefox     122

title pages in PDF     118

using Help+Manual     65

Using Styles     96

videos and online media     119

TXT files    

importing into individual topics     155

Type 14 fonts     1447

Type 3 fonts     1447

typographic quotes     245

- U -
Unicode    

about support in H+M     1627

editing requirements     1627

international language setup     143

now supported in PDF     1632

publishing requirements     1627

which languages require     1627

Windows requirements for     1627

Unicode mode in Windows     1629

unused images, locating and removing     1212

update checker     1399

update checking function    

and firewalls     1261

configuring     1261

updating graphics quickly     481

URLs    

detecting automatically     1265

user dictionaries    

for spell checker     238

multi-user     238

storage locations     238

user interface     43

Application Button     53

customizing     59

dialog icons     53

editor     55

menu icons     53

Project Explorer     48

Quick Access Toolbar     53

Ribbon Toolbar     53

user manuals    

using hi-res graphics in     503

user-defined variables    

where supported     919

UTF-8    

not supported in HTML Help     143

UTF-8 BOM, switch off for PHP     1435

- V -
variable name syntax     919

variable names    

editing in the editor     924

variables    
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variables    

about     917, 1558

breadrcrumb trail variable     1569

counter variables for numbering     941

date and time formatting     932

date and time formatting in     937, 1565

disable variable highlight     924

disabling     924

editing and formatting     924

find and replace     958

formatting and styles with     924

global predefined variables     923, 1561

HTML variables     917

in HTML templates     959, 1049, 1611

in PDF templates     968, 1581

in style repositories     1087

Insert dialog (dialog reference)     1370

inserting in topics and headers     932

managing     1406

maximum characters     917

nesting - variable as value of another variable     924

plain-text variables     917

protected variables     919

redefining for conditional output     960, 1004

redefining in command line options     834

redefining in individual topics     960

redefining per topic     963

redefining with publishing tasks     963

redefining with skins     638, 667, 834

search and replace     958

search engine optimization     963

settings in Project Configuration     1406

typing manually     932

user-defined, creating and editing     919

user-defined, importing and exporting     919

using outside topics     934

variable name syntax     919, 923

where supported     917, 1558

with and without highlight     932, 958

VCS    

advantages     848

and multi-user editing     848

and remote editing     848

backups     891

control visibility     848

graphics and additional files     1120

manual check-out and check-in     1411

Project tab functions     1307

supported systems     848

unbinding projects     891

Version Control Systems    

advantages     848

and multi-user editing     848

and remote editing     848

backups     891

control visibility     848

graphics and additional files     1120

introduction     848

manual check-out and check-in     1411

Project tab functions     1307

supported systems     848

unbinding projects     891

vertical alignment of OLE objects     1140

vertical ruler    

display     1265

video     563

HTML5 video tag     563

subtitles     563

video files     548

about     1529

converting to M4V and MP4     549

HelpXplain presentations and screencasts     561

inserting in topics     549

support in output formats     563, 1536

video preview function not working     1647

videos not playing properly     1647

videos and online media    

tutorial project     119

Visual Source Safe    

support in HM     848

Visual SourceSafe    

Project tab functions     1307

Visual Studio Help (MS Help 2.0)    

about     1132

compiler     1132

configuring Visual Studio Help output     775

example calls     1135

export options     1464

F-Index     1464

limitations     1132

namespace     1135, 1464

popups     1466

publishing     113, 1135

registering HXS files     1135

requirements     1132

settings in Project Configuration     1464
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Visual Studio Help (MS Help 2.0)    

unique identifier     1135, 1464

Visual Studio Help (MS Help 2.0/3.0)    

publishing     613

Visual Studio Help Integration Kit     1132

Visual Studio Help/Help 2.0    

about     1525

pros and cons     1525

VSIK     1132

- W -
web pages    

inserting in topics     183

WebHelp    

3-frame layout     655

about     1510

and modular projects     1117

appearance in different browsers     655

application calls     899

ASP search     1428

browser compatibility     1512

configuring output     655

context calls and     440, 899

custom icons     373

deleting output folder before publishing     613, 1282,
1310, 1644

displaying topics without TOC     440, 899

expand automatically on open     655

frames settings     1415

FTP folder synching with archive bits     1435

full-text search     655, 1046

full-text search issues     613, 1644

full-text search settings     1428

Google Analytics     655

HM2Go mini server     673

HTML page templates     1413

index separators     1425

integrated web server for testing     613

JavaScript popups     1512

Keyword Index settings     1425

language files for Search interface     116

Layout section in Project Configuration     655

layout settings     1415

link syntax     1117

linking to     440

linking to anchors in     415

linking to context IDs in WebHelp     899

linking to WebHelp topics     899

links between projects     1117

links to     457

navigation behavior (single or double click)     655

Navigation section in Project Configuration     655

navigation settings     1420

PHP search     1428

phrasal searching     1428

popup topics settings     1440

pros and cons     1510

publishing     113

search engine optimization     1420

settings in Project Configuration     1415

sitemap file, generating     655

support for videos and animations     563

syntax for calls/links to     440, 899

testing with HM2Go mini server     673

three-frame layout     655

TOC settings     1423

video files support     1536

WebHelp links to context IDs     440

WebHelp statistics with Google Analytics     666

welcome page     21

Welcome section     48

defined     48

What's This? help     1587

windows    

docking and undocking     1646

external windows     469

secondary windows     469

Windows metafiles     1529

Winhelp files    

settings for importing     157

Winhelp macros    

about     1544

translation in HTML Help     452, 1544

wizards     1587

WMF images     479, 1529

Word    

copying and pasting from/to     94

copying from and to     233

pasting graphics from     104, 1535

word count and character count     223, 781, 1212

Word DOCX    

about     1525

configuring Word DOCX output     682

pros and cons     1525

table of figures     689
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Word DOCX    

table of tables     689

Word files (RTF)    

importing graphics from (troubleshooting)     157

settings for importing     157

word formatting    

automatic for word left of cursor     1637

Word macros    

distribute DOCX without macros     695

update Word fields without macros     695

Word macros     695

Word RTF    

videos and animations     563

workspace (about)     1275

Wrensoft Zoom WebHelp search indexer     1433

writing and formatting text in the editor     223

- X -
X5 and X6 projects    

settings for importing     157

XML    

activate and apply Tidy XML     1411

and translating projects     1194

exporting text in Impict images     506

strip manual formatting globally     1198

translation-friendly Tidy XML     1198

XML editing     1137

XML elements    

translatable elements     1200

XML Export/Import    

text in images     1197

XML files    

check list for translators and editors     1200

editable elements     1200

exporting/importing topics     365

importing     165

reusing as snippets     165

XML schema     1194

documentation     264

XML schema and stylesheet files     116

XML source code    

complex search and replace     1137

editing     264, 1137

XSL stylesheets for previews     1137

XML Source tab     264, 1137

editing XML source code     223

XML topic files    

importing into individual topics     155

XSL stylesheets for previews     1137

- Y -
Yoga Pro - hi-res displays     44

YouTube videos    

embedding in topics     549

- Z -
zoom factor for graphics     481, 503

Zoom Indexer for WebHelp search    

using full version     1433
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