Please enable JavaScript to view this site.

You can add images in standard bitmap formats to your HelpXplain projects: JPEG, PNG, GIF or BMP, and also SVG vector images. SVG images cannot be cropped and shadows will only be applied around the main borders of an SVG image.

Inserting images

There are several ways to insert images in HelpXplain, which also depend on the context in which you are working.

Edit an individual image on its own

If you just want to edit a single image you can open it from a file or paste it from the clipboard:

image_open

Select Open in the File menu and open the image file

Select New in the File menu and then Screenshot or Clipboard Picture

Add images to slides

To add an image to a slide, select the slide in the Slides list, click in the slide and then select the Picture tool:

workspace_tools4

You can insert images from files, from the clipboard and by taking a screenshot

Image export – format and size

Images retain their original format when you publish them if possible. They are only converted to different formats if necessary for HTML pages. For example, a transparent PNG will be exported as a transparent PNG, but a BMP will be converted, since HTML does not support BMP.

Images are resized on publishing to make them as small as possible, based on the display and zoom settings defined in your project. The only exception is the background image, which is always exported at full resolution.

Image operations

Standard resizing and cropping

There are two crop tools, a simple tool in the normal editing window and more advanced cropping options in the Picture Tools tab.

When you select an image directly and drag its corners it will be resized. Hold down SHIFT while dragging to resize in increments defined by the snapping grid you can configure in the View tab.

To crop an image click on the Crop (pencil) tool in the top right corner first, then drag its corner handles. You can also drag the image to position it inside the crop frame. Image cropping is non-destructive and can be adjusted at any time. You can't crop SVG images.

slider_resize_image

Advanced cropping in the Picture Tools tab

Select an image, then select the Picture Tools/Image tab. When you choose Crop in the Picture Tools it initially activates HelpXplain's normal crop mode for the image. See Cropping Screenshots above. However, when you select the Crop mode you will also see a menu of shapes in the Image Tools toolbar that are used for HelpXplain's powerful Crop-to-Shape feature. See the section on Picture Tools in General Editing for more details.

picturetools_cropshape

Apply an outline

Select the image, then open the Outline section in the Properties pane on the right and configure an outline. This works for images in the same way as for shapes.

properties_outline

Replacing an image with another image

You can replace an image on the canvas with another image directly. Copy the image you want to replace to the Windows clipboard, for example in your graphics program, or by copying or cutting it in HelpXplain with CTRL+C or CTRL+X. Then click on the image you want to replace on the HelpXplain canvas and press CTRL+V to replace it. This overwrites the internal image file in your HelpXplain project without changing the file name.

Converting an image to a shape

Select the image, then open the Outline section in the Properties pane on the right and select a shape with the Change Shape option.

image_changeshape

This fills the selected shape with the image. It can then be manipulated like a regular shape. Alternatively, you can also use the powerful Crop-to-Shape option in the Picture Tools tab.

Drop shadow

Select the image, then open the Opacity & Shadow section in the Properties pane on the right and configure the shadow. This also works on images that have been converted to shapes. Shadows applied to SVG images will only be applied around the outer border.